别发十大愿：利益愿：遍入尘刹利益愿

    庚二：遍入尘刹利益愿

    一尘中有尘数刹，一一刹有难思佛，
    一一佛处众会中，我见恒演菩提行。

    别发十大愿也是一地菩萨所发之愿，一地菩萨又叫欢喜地，因为断除遍计的障碍执著，超出世间，证得真如法性，入于法性流中，生在如来家里，成佛真子。所以能见到佛的不思议境界：即在一个微尘中有所有微尘数的佛刹；在不可说不可说的刹土之中，有难以思议，不可计数的诸佛如来；一一如来都有浩瀚无边的菩萨声闻缘觉天龙八部人非人等大众周匝围绕；诸佛常为大会海众敷演菩提妙行。如来利益众生任运自在，广大无边，所以菩萨发愿在三界九有之中广修一切妙行，成就功德海藏，如佛无异遍于尘刹利益众生。《十地经》云：“愿乘不退轮，修菩萨行，令见诸佛演菩提行。”

    华严宗的法界缘起观点认为：尘沙诸法，无非都是法界缘起。因为缘起之法，都具有寂照两重特性。正如所见的一粒微尘，因为全体是法界，所以完全具足寂照特性。犹如镜子又明又净，所以能照摄许多镜子入于本镜中。本镜又可被多镜照在其中，这样互相映照。一个镜子是这样，所有镜子也都是如此。一尘既然同于法界，寂照具足，所以能含一切法入在自己之中，此一尘又入一切法之中，互相映入。一尘如此，一切法也都如此，所以重重交映，无穷无尽，这都是由于一真法界的本性所以能如此。清凉国师云：“大哉真界，万法资始。包空有而绝相，入言象而无迹，妙有得之而不有，真空得之而不空。生灭得之而真常，缘起得之而交映。”

    如上境界凡夫难思难测，这是因为法界本性寂照不二，或明空双运，但凡夫被无明障蔽，落于戏论之中。诸佛遍于一切，三世不离，放大光明，现大威神，出大音声，说法不休，而我等如聋如盲不闻不见。《净土忏》云：“十方诸佛常在世间，法音不绝，妙香充塞，法味盈空。放净光明，照触一切，常住妙理，遍满虚空。”所以我们应勇猛奋起，执持真空无我妙有的利剑，斩断一切分别戏论的根本，荡除一切业障烦恼，显发本来真境界。

    开示诸法空性的是般若法门，开示诸法光明的是如来藏法门。抉择般若的是胜义谛理论，抉择如来藏光明的是名言净见理论。名言净见理论是随顺诸佛菩萨的见解而作抉择的。凡夫犹如患有眼病的人，在他的境界里把洁白的海螺硬是看成黄色，而诸佛菩萨如眼睛明净之人，见到海螺白色的本来面目。同样凡夫面前的一切法就是佛的智慧境界，但因无明眼翳的作用，凡夫却见成不清净的器情界。佛菩萨见众生前的一微尘无非是佛的清净依报或究竟大光明的法界。一尘是清净刹土诸佛众会或光明法界，那么每一尘也都不例外。如此则一尘等同一切尘，一切尘同于一尘，大小互融，一多不二，交相辉映，重重无尽，都是无碍解脱境界。全知麦彭仁波切在《定解宝灯论》的第六品中说如果对净见量所抉择的明空大法界，生起真实信解，获得甚深安忍，则会“见一尘中尘数刹，刹那亦能现数劫，诸法实空幻定解，入于如来之境界。”这样的抉择在《宝性论》及密宗《大幻化网》中有深入透彻的宣说。如果没有可靠的教理，殊胜的窍诀，则对于华严及如来藏光明，只能看看读读而已，想深入其堂奥则极为艰难。因此欲探佛法玄妙之士，不应心胸狭隘，目光短浅，甘作井底之蛙，应上求玄中玄、密中密的殊胜妙法，如此会步入一个广阔的天地。


别发十大愿：不离师友愿：庚二、不离善知识愿

    庚二、不离善知识愿

    所有益我善知识，为我显示普贤行，
    常愿与我同集会，于我常生欢喜心。

    经中阿难尊者说：「善知识是得道成就的一半因缘，佛纠正他的观点说：并非如你所说，善知识具足成道的全部因缘。」《法华经》中云：“善知识者，是大因缘。所谓令得见佛，发阿耨多罗三藐三菩提心。”《弥勒请问经》云：“弥勒当知声闻缘觉及无上佛陀之解脱，彻见诸法之智慧，皆来自依止善知识。弥勒，当知众生之一切利乐皆源于自之善根，彼亦来自善知识。”善知识是如此的重要，所以作为欲求安乐的，想得到声闻缘觉以及无上佛果的人都应平等地发起如是愿：诚心祈愿所有能利益我的善知识，给我显明开示普贤行愿，照明解脱大道，引导入于涅槃大城，能在一切时处与我聚会在一起，对我恒时欢喜愉悦，无有疲厌弃舍之心，犹如蜜蜂喜欢芬芳的妙花一样。

    世间人为了学习一些雕虫小技，如文艺、武功、工巧、诗画等，也会在数年乃至用尽毕生精力依师求学，亦步亦趋地潜心用功学习，对师父毕恭毕敬，对待师命象圣旨一样丝毫不敢违犯，如此才能成办。那么要求得无上菩提果位，寻访上师，观察依止，这是首要的工作。否则如憨山大师云：“修心容易遇师难，不遇明师总是闲，自作聪明空费力，盲修瞎炼也徒然。”

    现在有些人有点世间知识学问，自我感觉良好，不寻师访友，独自闭门造车，埋头研究佛经论典。记了几句经文偈语，背了些法相名词，消释得几本经书。自己分别念理解了些道理，不知对错正邪，就自信自肯，认为通达佛菩萨祖师大德的密意，甚至认为理解文句就是证悟，所以著书立说，收摄门徒，沽名钓誉，赚钱捞财，甚至呵祖骂佛，斥经谤教。如此贩卖如来，瞎人天眼目，灭正法圣教者，在如今世间可谓如麻似粟。正如宣化上人云：“蒙懵传蒙懵，一传两不懂，师父下地狱，徒弟往里拱。”诚可悲叹。

    《华严经》中云：“犹如暗中宝，无灯不可见，佛法无人说，虽智不能了。”善知识就如黑暗中的灯炬一样，照亮修行人的道路。或依善知识引导开示的灯光，能见到自心无明黑暗中隐藏的佛性宝藏。若无善知识指引教授，纵使绝顶聪明，竭尽其智力，也无法了知佛法的少分。何以如此？因佛法深奥广大，远非世人以世间智识所能窥测，所以必须依止善知识。宁玛巴大法王文殊师利菩萨化身的全知龙钦绕降尊者云：“如是无谬因果道，来源依止善知识。三世一切佛菩萨，以及声闻缘觉众，获三菩提由师生，获得世间增上乐，亦源依止诸上师，故当谨依善知识。”

    要依止善知识就要知道什么是善知识。《大般涅槃经》云：“何故名为善知识耶？善知识者，能教众生远离十恶，修行十善，以是义故，名善知识。又复如法而说，如说而行，自远十恶，亦令他离，自行菩提，亦令他行，名善知识。又自行施戒闻慧，亦令他行，名善知识。又不能自乐，常为众生，不讼他短，常说善事，名善知识。如大船师，善渡人故，诸佛菩萨亦复如是，度尽众生出生死海，名善知识。”《华严经·离世间品》中说善知识有十种：「所谓令发菩提心的善知识；令生长善根的善知识；令修行六波罗蜜的善知识；令解脱一切法的善知识；令成熟一切众生的善知识；令得决定辩才的善知识；令不著一切世间的善知识；令在一切劫中不厌倦修行的善知识；令修行普贤妙行的善知识；令入于一切佛智所入境界的善知识。」

    所以依止善知识的人，应当了解依止善知识的功德、必要、作用。《华严经》中说：「善男子，菩萨由善知识的摄持不会堕入恶趣；由善知识的教导得以出离世间；由善知识才能得到恒时不离菩萨的无忘失妙行；由善知识得以成就菩萨的一切稀有妙行；由善知识才能依靠正觉之道断除业惑障碍，出离生死大城到达清净解脱之地。」《华严经·不动优婆夷章》云：“其有修行善知识教，诸佛世尊悉皆欢喜。其有随顺善知识语，则得近一切智地。其有能于善知识语无疑惑者，则常值遇一切善友。其有发心愿常不离善知识者，则得具足一切义利也。”《德生童子有德童女章》云：“善知识者，长诸善根，譬如雪山，长诸药草。善知识者，是佛法器，譬如大海，吞纳众流。善知识者，是功德净法生处，譬如大海，出生众宝。善知识者，能净菩提心，譬如猛火，能炼真金。善知识者，出过世法，如须弥山，出于大海。善知识者，不染世法，譬如莲花，不著于水。善知识者，不受诸恶，譬如大海，不宿死尸。善知识者，增长白法，譬如白月，色光圆明。善知识者，照明法界，譬如盛日，照四天下。善知识者，长菩萨身，譬如父母，养育儿子。以要言之，菩萨摩诃萨若能随顺善知识教，得十不可说百千亿那由他功德等。”博朵瓦格西说：“总摄一切教授首，是不舍离善知识。”《菩萨藏经》云：“总之获得菩萨一切诸行，如是获得圆满一切波罗蜜多，地忍等持，神通总持，辩才回向，愿及佛法，皆赖尊重为本，从尊重出，尊重为生及为其处，以尊重生，以尊重长，依于尊重，尊重为因。”《大乘四法经》中说：“菩萨尽形寿乃至遇到丧命的因缘，毕竟不得舍离善知识。”所以我们应随一地菩萨发大愿，不离同行道友及善知识。

    《华严经》中一地菩萨所发愿：“又发大愿，愿与一切菩萨同一志行，无有怨嫉，集诸善根。一切菩萨平等一缘，常共集会，不相舍离。随意能现种种佛身，任其自心，能知一切如来境界威力智慧，得不退如意神通，游行一切世界，现形一切众会，普入一切生处，成就不思议大乘，修菩萨行，广大如法界，究竟如虚空，尽未来际，一切劫数无有休息。”


别发十大愿：不离师友愿：不离同行道友愿

    庚一、不离同行道友愿

    所有与我同行者，于一切处同集会，
    身口意业皆同等，一切行愿同修学。

    愿与我同行于菩提大道的同参道友，在一切国土，一切场合，现在未来都能常相聚会。即所谓“十方同聚会，皆共学无为。”而且不会因为身份、种姓、地位、财富等的不同而使道友之间有隔阂。因为有着共同的菩提誓愿，所以大众都能和谐融洽，如水乳交融般的和合无争。虽然各自身心不同，但因为都奉持三聚净戒，三业清净皎如秋月。都共同为上求佛果下化众生而修持广大无边的普贤行愿。所以身口意所作事业皆依“誓断一切恶，誓修一切善，誓度一切众生，誓成无上佛道”的尊愿而行，因此等无差别。

    作为修行人此愿特别重要，因为要跨越生死的大沙漠；度过恐怖的罗刹洲；穿过稠密的邪见林；趟过无底的欲泥塘，自己单枪匹马，势单力薄，危险重重，且路途遥遥无际，前途艰难可想而知。所以应当聚集志同道合、智勇双全的诸多道友，结伴而行，于路途中相互鞭策鼓励规劝，遇到困难挫折时，大众团结齐心协力，共御内外魔军，同度难关。

    我们作为身处末法时代的修行人，倍尝没有同行道友的苦头。穿着僧衣法服的被视为异端怪物；礼拜坐禅上庙烧香的被讥为搞封建迷信；研究佛经信奉佛法的被谤为神经病患者。各种风言风雨、挖苦嘲笑、侮辱戏弄、干涉限制、打击阻碍，时时处处总有有形无形的压力一齐涌向自己，真是一人修行，万魔出动。

    《功德藏》中说：「普通的一段树木，放到檀香树林中，不消多时就内外香彻。」然而我们周围的人群中，都发出一股强烈贪嗔痴的毒气，长着“现世美”断无因果的坚固锐利的邪见毒刺，口中所出无非是两舌恶口绮语妄语的臭气，身体也经常排出杀盗淫的秽物，简直如处鲍鱼之肆，久而必将与之俱臭。所以自己的行为见解愿力若要坚持下去，不受外境的干扰破坏，相形之下，显得多么的艰难。遥想当年，正法像法之时，有多少个清净的道场，无数的清净梵行者，以戒合同修、见合同解、身合同住、利合同均、口合无诤、意合同悦六和敬相互亲近，互相切磋砥砺，所以功德学问修持蒸蒸日上。今日处在这样的恶劣环境，闻思修行江河日下。只因往昔没有遇此殊胜妙法，没有发如此微妙大愿。但不能只在无可奈何中叹息怨悔，应该生大庆幸，于此五浊恶世，尚能有缘遇此普贤大愿王，故当至诚恳切地发此大愿。

    智者大师在《摩诃止观》中云：“方等般舟行法，决须好伴，更相策发，不眠不散，日有其新，切磋琢磨。同心齐志，如乘一船，互相敬重，如视世尊，是名同行。”有人只知尊重恭敬三宝上师，对道友却不太恭敬，这是很不正确的态度。智者大师说对同行道友应当看成佛一样。特别学修大乘密乘的僧众道友，难值难遇，皆具大功德大福报大因缘，岂能随便轻视呵毁。经中说对发菩提心的菩萨恶眼瞪视，生生世世中，得无眼睛的果报，何况恶语凌辱、拳脚相加呢？密宗中对道友和合的要求很高，要将金刚道友观成本尊空行，绝对禁止闹矛盾起是非。

    《法句经》云：“如裹香之纸，系鱼之索。佛语比丘，夫物本净，皆由因缘，以兴罪福。”永明禅师解释云：“近贤明，则道义隆。友愚暗，则殃祸集。譬如纸索，近香则香，系鱼则臭，渐染玩习，各自不觉。”由此可见不知不觉中已被道友的如法行为、善业功德香所熏染。中国古代的荀子也说：“蓬生麻中，不扶自直；白沙在涅，与之俱黑。故君子居必择乡，游必就士，所以防邪僻而近中正也。”沩山灵佑禅师也说：“远行要假良朋，数数清于耳目。住止必须择伴，时时闻于未闻。故云：生我者父母，成我者朋友。亲附善知识者如雾露中行，虽不湿衣，时时有润，狎近恶者长恶知见，晓夕造恶。”祖师之语字字句句如良药，请大家铭记心中，平时依此行持，其利益只有切实行持之人才能体会。大乘律中遮止初学菩萨在小乘寺庙中超过七日留住，何况与外道及邪见愚痴凡夫交往。此处佛密意是担心大乘行者被小乘的见解行为所转变。

    我们学大乘的修行人不能孤僻独处，应经常检束自己的身心，皆令合法合律，不违大众丛林的清规纪律，自甘处于卑劣地位，平等恭敬尊重所有道友，不作僧众中的害群之马，愿与志愿相同的道友同聚一起，同心协力，修持一切广大菩提行愿。凭借大众熏修之力，迅速获得无上菩提果，如功课中云：“大众熏修希胜进，十地顿超无难事。”


别发十大愿：修行二利愿：不忘失菩提心愿

    庚二、不忘失菩提心愿

    恒不忘失菩提心，

    愿我在为成办自他二利而修行的过程中，永远不忘失菩提心。

    菩提心犹如种子，能够生出一切佛法；菩提心犹如良田，能够长养一切众生的清净善法；犹如大地，成为一切世间的所依；犹如清净之水，能洗涤一切烦恼尘垢；犹如大风，周行世间无有障碍；犹如烈火，能无余烧尽一切邪见之薪。《大树紧那罗经》中说：「若能自发菩提心，又能劝他人发菩提心，则投生在何处，常能见佛，不远离诸佛。」净土宗的昙鸾大师说：「无上菩提心就是发愿成佛的心，愿作佛的心就是度化众生的心。发菩提心是进入佛道的要门，发心才能成佛，发心才会去度化众生。」若不发菩提心，省庵大师说：「纵经尘数劫，也依然在轮回中，虽有修行，也是枉费辛苦。」净宗十二祖彻悟禅师劝我们发菩提心说：「应该想一想，我有生死的痛苦，想脱离生死，一切众生也都处在生死之中，也需要出离。众生与我本来是同一体性，都是我们多生以来的父母，未来的诸佛。若只求自利，不愿普度他们，则于情理有亏，于心有所不安。所以为了解脱无始以来的恩爱牵缠，消除无始冤愆仇怨，忏除多劫的罪业障垢，积累成佛的大善根，远离修行的障碍违缘及二乘小果，应该发起大菩提心。」道绰法师在《安乐集》中云：“菩提心者，乃无上佛道之名也。若欲发心作佛者，此心广大，遍周法界；此心究竟，等若虚空；此心长远，尽未来际；此心普备，离二乘障，若能一发此心，倾无始生死有沦，所有功德回向菩提，皆能远诣佛果，无有失灭。”《菩提心论》云：“此菩提心能包藏一切诸佛功德法故，若修证出现，则为一切导师，若归本则是密严国土，不起于座，能成一切佛事。”

    菩提心有二种分类：一世俗菩提心，二胜义菩提心。世俗菩提心又分愿菩提心与行菩提心。愿菩提心是发起为度化众生、为成佛果的誓愿。行菩提心是对度众生、成佛果的誓愿发起付诸实践的行动。这在《佛子行三十七颂》、《普贤上师言教》、《入菩萨行论》等中有详细具体的论述，敬请参阅。具体修法在密乘五加行中以精要窍诀汇集，极为扼要易修。

    胜义菩提心是诸佛菩萨的智慧、众生的心性。修法上则中观般若法门、如来藏清净法门与华严等都是胜义菩提心的修法。密宗中则以直接的方便开发证悟此心性，所以大乘的法门，就是修习菩提心的法门，这也是大乘与小乘的根本差别之所在。菩萨若忘失菩提心，则失坏大乘种姓，《华严经》中云：“忘失菩提心，修诸善法，是为魔业。”所以菩萨发愿生生世世之中，菩提心念念增明，时刻不忘。


别发十大愿：受持愿：不忘宿命愿

    庚一、不忘宿命愿

    我为菩提修行时，一切趣中成宿命，

    我为了得到无上菩提的果位而修持普贤胜行时，无论在六趣中那一道中，愿我忆念宿命，不忘修行，心不迷乱。

    清凉国师认为别发十大愿是以一地菩萨所发的十大愿来作回向。要想摄持菩提果，必须生生世世不断地行持菩萨道，要行持菩萨道就应该随所生处不忘宿命，了知前世所行之事所修因缘，这样才能在前世的基础上不断地修道。特别是在娑婆世界这个业障深重之地，投胎转生增加垢障，易于忘失前世因缘，进而随波逐流。如禅宗沩山灵祐禅师和文殊普贤化身的寒山拾得曾经都在灵山会上听佛说法，但沩山作了三世国王之后，就忘记了前世的因缘。还有慈恩宗的窥基大师，他本是一个入定的禅师，玄奘大师在取经路上碰到他，把他从定中请出，劝他从新投胎，等取经回来之后帮助弘扬佛法。但当大师西归寻他出家之时，他却早已忘记自己前世的因缘，花天酒地沉湎于五欲之中。当皇上下诏让他出家，他的要求是：一车女人、一车酒、一车肉相随，故被称为“三车和尚”。他带着女人酒肉前往寺庙，当到达山门口忽闻钟鼓之声，恍然醒悟自己的前世因缘，到此才毅然舍弃尘世间的一切五欲享受，专心一意地跟随大师译经弘法，成为令人瞩目的一代高僧。所以发愿回向不忘宿命，时时忆念自己的菩提行愿，以期历历增明，才能使自己的修行如芝麻开花节节高。


别发十大愿：供养愿：财供养

    庚一、财供养

    愿常面见诸如来，及诸佛子众围绕，
    于彼皆兴广大供，尽未来劫无疲厌。

    菩萨发愿常时面见一切诸佛如来，被诸大菩萨海会围绕，对如此殊胜广大的福田，我悉皆献上清净广大的供物，如此供养纵然穷尽未来一切劫数，心中丝毫不生疲惫厌倦之心。

    初二句指出供养的对境是诸佛如来及一切海会菩萨，他们具有无量功德，所以是最上广大福田。即所谓：“佛法僧三宝，信施良福田。”三句指无量供养资具供品对恒沙诸如来菩萨一一供养，则极辛勤劳苦，然心念广大清净如虚空，所以是发心大。因此我们在修行时，要修大供养应当依此三大而修才可以称得上是大供养。经云：“所谓生广大清净决定胜解，以一切供养具，恭敬供养一切诸佛，令无有余。”《俱舍论》中云：“又财田主异，故施果差别。”因为财物供品福田以及施主自身的不同，所以布施的果报也会有差别。现在有些众生想求得大果报，但或发心不清净，或悭贪难舍，或财物下劣微少，或虽广施钱财但遇不到大福田，所以想修点福报都是如此的困难。

    未入法位的菩萨发愿常能面见诸佛如来是特别重要的。《大智度论》云：“如以少汤投冰面上，虽消少处，反更成冰。菩萨未入法位，若远离诸佛，以少功德，无方便力，欲化众生，虽小利益，反更堕落，以是新学菩萨，不应远离诸佛也。又念：我未得佛眼，如盲无异，若不为所引导，即无所趣。菩萨见佛得种种利，得大智慧，随法修行而得解脱。”佛具有无量无边的身、口、意、事业、功德五部功德，具有殊胜无比的加持，成就度化众生的无量善巧方便，见佛即能消除痛苦烦恼，得到不可思议的功德。所以我们初学者必须发愿往生净土，觐见诸佛如来，得到引导开示，趣大菩提。否则在无佛无善知识的情况下，仅凭自己盲修瞎炼，犹如煮沙成饭，纵经多劫，也无法成就。

    末法时代众生心力狭劣，障缘极多，刚刚修行没多久，又退失道心，造恶如顺水扬帆，行善如逆水迎风。《华严经》中云：“宁受地狱苦，得闻诸佛名，不受无量乐，而不闻佛名。所以于往昔，无数劫受苦，流转生死中，不闻佛名故。”闻佛名即可脱离轮回痛苦，何况面见诸佛，亲承供养，聆听微妙圆音，熏习五分功德香的利益岂能衡量。所以《华严经》云：“若见如来者，为得大善利，闻佛名生信，则是世间塔。”又云：“若得见于佛，除灭一切苦，能入诸如来，大智之境界。若得见于佛，舍离一切障，长养无尽善，成就菩提道。”《大品经》中也说：「菩萨渐渐趋近萨婆若，渐渐身体清净、心清净、相清净，所以不会生起贪嗔痴慢乃至邪见之心，始终不会投生到母胎中，常得清净化身，从一佛国游历另外佛国，成就度化众生，乃至现前菩提，恒常不离见佛陀。」


正行三大愿：常随佛学

    丙三、正行三大愿分三：常随佛学；恒顺众生；普皆回向。
    丁一、常随佛学

    颂曰：
    我随一切如来学，修习普贤圆满行，
    供养过去诸如来，及与现在十方佛。
    未来一切天人师，一切意乐皆圆满，
    我愿普随三世学，速得成就大菩提。

    《维摩诘经》云：“已于诸法得自在，是故稽首此法王。”这说明佛智圆满，对轮涅所摄诸法达到了穷性尽相的地步，朗照诸法无有遗余，所以称之为法王。诚如谚语所云：“欲知山中路，当问过来人。”佛从薄地凡夫历经五道十地而现证大菩提，其往昔所行菩提之道光明坦荡，不会是迂回曲折的偏道邪径，而是直通涅槃大城的解脱道。所以首句提出要追随如来，学习如来，沿着如来走过和开示的道路去行，如此恒常修习普贤菩萨的圆满胜行。要想随如来学，最好能常不离佛，常不离闻法，如此方能如法修行。但要值遇佛陀，要须与过去现在的无量无边诸佛结下胜缘，方能亲睹如来尊容。未来一切诸佛人天导师圆满一切所愿，成办自他二利。对三世十方的一切诸佛世尊我悉皆随学，速疾圆满成就无上大菩提果。

    佛为什么又被称为天人师呢？经中云：“善男子，诸佛虽为一切众生无上大师，然经中说为天人师，何以故？善男子，诸众生中，唯天与人能发阿耨多罗三藐三菩提心，能修十善业道，能得须陀洹果，斯陀含果，阿那含果，阿罗汉果，辟支佛道，得阿耨多罗三藐三菩提果等，故号佛为天人师。”

    只说随佛学，到底学佛的什么呢？又如何学呢？若对这两个问题搞不明白，那么常随佛学也只是落在口头上了。佛值得我们学的东西太多太多，但总的可以从佛的发心、智慧、行为、事业四方面来学。菩提心是成佛的因，也是成佛的开始，所以如佛最初为救度一切众生而发无上大菩提心，求一切智智的果位，我也应如是发心。佛是智者之王，佛法是智慧的学说，没有智慧的眼睛，无法看到解脱的道理，佛的智慧见解作为行持者的眼目，所以必须要闻思佛智慧之结晶——佛法，开启自己正见之眼，才能明见佛陀所开示的解脱之道。进而以布施、持戒、忍辱、精进等各种行为修积二种资粮，成就上求佛果下化众生的二利大业。

    如何学呢？就是把佛从因地直到果地之间的行为以及所作事业作为所缘对境，以智慧来观照，并融于自心，常观此境，由此放下对身心的执著，并能远离悭贪嗔恚愚痴及六尘五欲的迷乱颠倒。如果佛所经历的苦行，常能观想，那么在遇到苦难之时，则会忆念佛陀往昔的悲愿进而对照自身处境而不生怨恼处之泰然，碰到欢乐之时，也不会耽染其中不能自拔。

    今以娑婆世界毗卢遮那佛为随学对境略作宣说：娑婆世界即华藏世界二十重香水海中的十三重。娑婆意为堪忍，此世界众生浊恶，堪忍诸苦而不知寻求解脱。毗卢遮那意为光明遍照，有时指报身，有时指法身，此处指释迦牟尼佛的报身。彼从最初发起志求无上菩提的大心，披大精进铠甲，一切违逆皆不能阻挡他的菩提行愿，将不可说不可说身命布施众生。为尊重法，毫不畏惧地剥皮为纸、析骨为笔、刺血为墨、书写经典，积累法宝高如须弥山，纵舍生命也毫不吝惜，更何况是舍弃国城宫殿妻子儿女及所有财物呢？种种难行苦行无不行持。直至菩提树下、金刚座上，成就大菩提果，示现种种神变，起现种种变化，以种种佛身，处种种众会中，处大菩萨众会中，处声闻辟支佛众会中，处转轮圣王小王其眷属众会中，处刹帝利、婆罗门、长者、居士以及天龙八部人非人等众会道场中，以迦陵频伽圆妙之音，出无碍语，演无上法，如大雷震响随顺众生意乐成熟众生，导诸众生汇入解脱之道以至示现涅槃也是方便度化众生。

    常随佛学首先即当如诸佛为救度一切众生而发无上的菩提心，初发心者即名菩萨，《璎珞本业经》云：“具缚凡夫，未识三宝善恶因果，未于佛法起一念信，乃至从此住佛菩提正教法中发菩提心起一念信，尔时便名信相菩萨。”寂天菩萨的《入行论》中云：“生死狱系苦有情，若生刹那菩提心，即刻名为诸佛子，世间人天应礼敬。”此处菩提心指世俗菩提心，龙树菩萨有明证，《大智度论》云：“若有人言，愿我当来作佛，度脱一切众生苦恼，是名发菩提心。”

    佛在《发心住经》中说：「发起菩提心后有十种相：一、亲近善知识；二、供养诸佛；三、修习善根；四、志求胜法；五、心常柔和；六、遭苦能忍；七、慈悲深厚；八、深心平等；九、爱乐大乘；十、求佛智慧。」经中指出发菩提心后应当具备如是功德，或应如是而行。深信自心本具真如佛性，恒以方便令彼显发出来；信佛有无量功德，常念亲近供养发起善根，得到一切智智果；信正法有大利益，常念修行诸波罗蜜的胜行；信僧众，能正确修行自他二利，常乐亲近诸菩萨众随彼修学。

    有这样志求菩提的意乐心，还需加以精进方能成办。精进指为了成就信心、坚固信心，所以不畏众苦勇猛发起精勤之行。由精进力正念现前，常能念佛三身四智诸功德；为获利益常能念教理正法；常念菩萨圣众是修行道伴；常念菩萨三聚净戒；常念以财法无畏布施众生；常念常乐我净第一义天。

    正念具足应以智慧抉择正见，并正观诸法。正见智慧具足，当修持正行，以定摄心入于正见。之后当奉持三聚净戒，并将一切善根回向大菩提。菩萨处恶世时，见佛法即将毁灭，发心受持如来正法，鼓励他人修行，讲经说法遍洒法雨甘露，广令人知。这是发菩提心后应具备的功德，在此基础之上，以披甲精进、摄善精进、利乐有情精进入四种不退位。不退指不退堕、不退转之义。一信不退：即菩萨列十信位中的第六位时，不会退入外道之中。二位不退：十住位中的第七名不退住，不会退入小乘道中。三证不退：即初地菩萨超越凡夫，证得胜义法，不会再退转到凡夫位。四行不退：即八地菩萨得到无生法忍，必当作佛更不退转，一切法中行一切行，不被有相功用所退转。

    经中剥皮为纸等并非比喻，而是佛在因地修行的真实事迹。佛在因地初修行时，为了求得往昔圣者的言教，所以不惜身命，展转求觅正法，为了珍惜，并令广流传，而剥皮析骨刺血书写。在《集一切福德三昧经》中记载了一个佛因地曾为最胜仙人的公案：

    在过去久远阿僧祇劫前，有仙人名叫最胜，与很多仙人在林中修大慈心。一天他想：“不能仅以慈心救度众生，要以多闻才能灭众生烦恼邪见，树立正见，出离轮回苦海。”因此他到城市聚落之中，到处寻访求觅说法之师。此时天魔现身说：“我有佛所说的一偈法要，要想听受，若能剥皮为纸，析骨作笔，沾血书写，我就为你说，否则休想听一字。”仙人听后，暗自思量：我曾在过去无量百千万劫中，无数次无意义地被他人割截肢体，倍受无量诸苦，然未曾获得丝毫利益，现在为了听闻妙法，求无上道，舍此芭蕉聚沫般虚浮不实的身体，又有什么遗憾？”所以仙人欢喜踊跃地以利刃剥掉皮肤，卸下骨头作成笔，放出血液当墨汁，如此一切就绪后，合掌恭敬，祈请传法。天魔看到此情此景，忧愁万分，隐身遁迹。仙人见此情景，极为恳切地说：“我今为法，不惜躯命，为了度化众生，心无谄曲，志诚不虚。他方世界具大慈悲能宣说佛法的人，鉴我诚心行此难事，应当现于我面前。”此时东方普无垢国净名王佛忽然出现在他的面前，放大光明消除他的痛苦，令其身体完复如初。复为他说集一切福德三昧，仙人听后获得无碍辩才。后来他就到处游化，广泛地为众生宣说妙法，将无量众生安置于大乘道中。过去最胜仙人即是释迦世尊。佛告净威说：“是以当知，若有人能恭敬求法，佛于其人不入涅槃，法亦不灭。虽在异土，而常见佛，得闻正法。”佛在因地为众生修持诸多苦行，当现前佛果时，则任运地显现各种神通变化，为各类不同的无量众生转大法轮，乃至以无碍神通以及示现涅槃的方便度化众生。如是等一一即须随学，方能任运度化无边众生。

    神通：无法测知是神，无障无碍是通。神通有六种即天眼通、天耳通、神足通、宿命通、他心通、漏尽通。十八种变化即转变旧体称为变，从无忽有称为化。神通与变化虽然佛菩萨声闻独觉都具足，但佛菩萨较二乘更为超胜，彼等望尘莫及。佛菩萨的神通变化无量无边，可摄为十八种：

    一、震动大地：佛菩萨以自在定力，普能震动，或一房、一院、一县、一洲、小千界、中千界、大千界乃至无数世界，皆令东涌西没等。二、炽燃身相明显：佛菩萨自在定力，使自身上出现大火焰，全身光明晃耀，放青黄赤白等各色光芒。三、流布：佛菩萨以自在定力，令教法流通广布。如《法华经》中普贤菩萨说：「我当以神通力守护此经，在阎浮提广宣流布，令勿断绝。」四、示现变：佛菩萨以自在定力，变现异形别类种种之身，度化众生。五、转变变：佛菩萨以自在定力，起胜解通，把身体变化大小不定。或变大地为黄金，揽江河为酥酪，变砖瓦为金玉，变草木为饮食，一切万物都可令其随心转变。六、往来变化：山崖岩壁无有阻碍，上至梵天，横行十方，随心就到。如普贤从宝威德上王佛国来娑婆，应时即至。七、卷神变：佛菩萨以自在定力，令须弥山入芥子中，无量世界容一尘内。八、舒神变：展小令大，令一尘一毛都能周遍法界。九、众像入身：身内包容一切形象，如摩耶夫人身中容纳无边世界的大菩萨众集会听法。又如普贤身内佛佛无尽，佛毛孔内菩萨重重无量。十、往同类趣：由定自在力，能在六道中受生，与彼同类同形，以彼语言说法教化。十一、隐：由定自在力，从有现无。如文殊菩萨在灵山会上，答复了弥勒菩萨的问题后，大众忽然看不到他，其实文殊菩萨早已到龙宫之中。十二、显：由定自在力，从无现有。如法华会上从地忽然涌出无量菩萨，一一都是百福庄严。十三、所作自在：由定自在力，在一切世界中，行住坐卧，所作所为无有滞碍，自在利益。十四、制他神通：由定自在力制服一切邪通，如维摩诘居士令魔王神通无法施展。十五、能施辩才：若至心向佛，苦求聪慧辩才，一一能满彼愿。如永明延寿和尚祈祷观音菩萨，蒙甘露灌口即获得无碍灵辩。十六、能加持忆念过去事：佛菩萨加被有情让他自然忆念起过去久远劫所发生的事。十七、施安乐：佛菩萨拔众生苦普施安乐。十八、放大光明：放大光明或照一世界乃至无数无量世界。佛以自在难思神变，应法界众生类，普化身形随类度化。佛悲心平等，所以普入各种种姓众会中为彼说相应之法。

    如上所说毗卢遮那佛过去世的行为以及所作事业皆当随学，对于佛陀因地的行为都应全部承当，处处作为自己行为的楷模，乃至十方三世一切佛刹所有微尘中一切如来因地果地的发心、行为、修持、成就，于念念中皆作随学，念念相续无有间断，身语意业无有疲厌，此为普贤行愿常随佛学的精髓。


忏悔业障：事忏：忏悔三障：忏悔报障

庚四、忏悔报障

    佛说业报至时，“非空非海中，非入山石间，无有地方所，脱之不受报，惟有忏悔力，乃能得除灭。”报障即一切恶报苦果，人中盲聋喑哑、诸根不具及三恶道的苦报，现在不忏，命终地狱相现之时，则一切无能救护。现在自在时当猛厉忏悔。恶报详讲六道都有，尤其三恶道报，最难忍受。其详细情况在《地藏经》、《俱舍论》、《普贤上师言教》、《菩提道次第广论》中都有叙述。

    以上五种前行发心方便加上四种对治力，忏悔上面所述三种障，则会出现各种验相，如见光见花、身心轻利敏捷、信心善心增上、烦恼淡薄等验相。还可以从梦中观察，如梦见洗沐、登雪山、见日月出现、穿白净衣服等。


忏悔业障：事忏：忏悔三障：忏悔烦恼障

庚二、忏悔烦恼障

    有烦恼所以造诸恶业，由恶业为因，感受苦果，因此当先忏除烦恼障。各种经论以种种譬喻呵责烦恼，烦恼是怨家，能断众生慧命故；是劫贼，劫取众生诸善法故；是瀑河，能漂众生入生死大苦海中故；是镣铐，能把众生系在生死牢狱故。六道络绎，三途不绝，恶业无穷，苦果不息，当知都是烦恼过患。烦恼虽有诸种，统而言之以三毒含尽。《华严经》说：「贪嗔痴三业能令众生入三恶道中。纵生人中贫穷孤独，凶狠暴戾，愚钝无知。」应早日忏悔：耽染爱著男女、财物的贪心烦恼。嗔恚忿怒、仇恨损害众生的嗔恨烦恼。心识昏愦、意地暗昧、不了事理的愚痴烦恼。贡高我慢、目空一切、轻视他人的我慢烦恼。疑惑正法、不信三宝的犹豫烦恼。谤无因果、不信三世轮回的邪见烦恼。不知缘起性空、横加执著的常断邪见的实执烦恼。悭贪吝啬烦恼。不摄六根、胡乱攀缘的放逸烦恼。心行弊恶懈怠懒惰烦恼。粗犷强横难以调和、容易发怒凶狠惨毒烦恼。障碍戒定慧的烦恼，障碍修三十七菩提分的烦恼，障碍六波罗蜜的烦恼，障碍二种解脱的烦恼，障碍佛恒沙功德的一切烦恼。恼乱贤圣及一切众生无量无边的烦恼。今日悉皆发露，向十方诸佛、尊法、圣僧前全部忏悔。愿以此忏悔功德，生生世世摧折憍慢高幢，枯竭贪欲爱心，息灭嗔恚烈火，破除愚痴黑暗，拔出疑惑深根，裂破一切邪见之网。修八圣道，断无明根，求大涅槃，永不休息。


忏悔业障

    消除三障，得依正具足报及成就清净戒律。

    颂曰：
    我昔所造诸恶业，皆由无始贪嗔痴，
    从身语意之所生，一切我今皆忏悔。

    菩萨念及过去世在漫长的生死流转过程中，由于以贪嗔痴三毒之因，发动身口意三门遍造无量无数恶业，假设所造恶业有体可见、有相可睹，则广大的虚空也显得狭小，而无法容纳如此众多的业障。这样的业障牵引行人入三恶趣受大痛苦，近则障碍得到人天善趣的果报，远则障碍成就声闻、独觉、菩萨、佛的解脱果。对此恶业、烦恼、业报等，一一都要观想我分身无数，遍到诸佛、菩萨、声闻、独觉一切圣众面前，坦诚发露，全部忏除。忏悔就是指在三宝前内心追悔厌离并陈白发露往昔所造恶业，再以各种方便消除它。


忏悔业障：事忏：忏悔三障：忏悔业障

庚三、忏悔业障

    无始以来至于今日，由贪嗔痴的狂风所鼓动，起身口意而造作恶业，若堆积起来数如恒沙、量满大地。故于今日发露忏悔往昔及今生所造无间深重恶业；轻毁佛语诽谤经书论典解脱法要之业；破灭三宝，摧毁正法之恶业；不信善恶果报、断诸善根、十恶之业；忤逆暴戾、不孝敬父母之恶业；谄诳无信、侮慢上师善知识及一切尊长之罪业；毁犯五篇七聚、菩萨律仪、三皈、五戒、八关斋戒、三昧耶戒，总之一切佛制之戒不能清净守护，多有缺漏之罪业；污坏他人清净梵行之罪业，入邪道中生恶知见、持恶律仪、修持邪法之罪业；或以邪命过活时所造一切诸罪业。

    若具体来说，即身三口四之七种罪业。忏悔杀生恶业：一切众生皆往昔父母兄弟六亲眷属，随业轮回，改头换面，互不相识，而今损害食噉，造如此恶业，死入号叫地狱，后五百世还他命债，此罪深如大海。佛说：“杀害之罪，能令众生堕于地狱饿鬼受苦。若在畜生，则受虎豹豺狼鹰鹞等身，或受毒蛇蝮蝎等身，常怀恶心，感受獐鹿熊羆等身，常怀恐怖。若生人中得二种果报，一者多病，二者短命。”自无始来至于今日，常怀恶毒，无慈悯心，或由于贪心，或由于嗔心痴心，而以种种方便，决裂湖池，焚烧山林，畋猎捕捞，以刀枪箭棍，陷阱机关，弹弓、手枪炸药及各种毒药捕捉飞禽走兽，或以钩网等捞捕鱼蟹虾螺蚌等水族动物，或自养猪狗鸡羊牛马鹅鸭等自杀或教人杀，使其羽毛脱落，鳞甲伤毁，身首分离，骨肉消碎，烧煮煎炸，使彼无辜受大苦难，含恨舍命，历劫寻仇。或作将军、兵卒、刽子手等，挥舞刀枪，杀害人命。或堕胎破卵，挖土掘地，种植庄稼，杀害无数生灵，或扑打苍蝇、蚊子、飞蛾，掐死虱子，喷洒农药杀死诸多小虫，或行住坐卧之中有意无意杀死虫子蚂蚁等。或对众生施以拳脚镣铐棍棒，或绳锁系缚，断水绝粮等种种恶业。今日至诚向十方诸佛、尊法、圣僧以及六道众生前求哀忏悔。愿以此忏悔功德生生世世得金刚身，寿命无量，永断害心杀心，以种种身形救拔众生，遍施无畏。

    忏悔偷盗恶业：众生只见眼前利益，不择手段盗取他人东西。佛说：“劫盗之罪能令众生，堕于地狱饿鬼受苦，若在畜生则受牛马驴骡骆驼等形，以其所有身体血肉，偿他宿债。若生人中，为他奴婢，衣不蔽形，食不充口，贫穷困苦。”今日忏悔往昔盗他人的财物，持刀抢劫，逼迫凌夺，威势压迫，陷害吞并，侵占公物，盗取佛法僧物，或经像财物，或塔庙财物，或常住僧众财物，对三宝财物或误用，或借用不还，或仗势侵吞。经中说：「五逆重罪我尚能救，盗僧物者我所不救。」或对三宝财物混杂不分，随便乱用，所谓“香钱不能买蜡”，如此混乱，过失极大。或常住三宝财物随意乱用浪费作人情。经商时短斤少两，少尺短寸，抵赖债务，逃避租税等。如是诸罪无量无边，今日克诚披露，求哀忏悔。以此忏悔功德，愿生生世世福贵尊荣，如意宝常能随身，降下种种珍宝、衣服、饮食之雨满足众生一切所求，成就布施波罗蜜多。

    忏悔邪淫恶业：众生生死爱为根本，古德云：“爱不重不生娑婆。”佛说：“淫欲之罪能令众生，堕于地狱饿鬼受苦。若在畜生，则受鸽雀鸳鸯等身。若在人中，妻不贞良，不得随意眷属。”如今感受此果报的人很多很多，所以世界上的离婚率也高得惊人，现在造邪淫罪的人多如牛毛，形成一种恶性循环。今日忏悔从无始来至于今日，偷抢他人妻妾，拐骗妇女，毁人贞洁，玷污比丘尼，破坏他人清净梵行，逼迫非道作不净行，染心邪视等无量无边罪业。今日克诚披露求哀忏悔，以此忏悔功德，生生世世莲花化生，不入胞胎，清净光明，相好庄严，远离尘欲，心恒清净。

    忏悔恶口、妄语、绮语、两舌罪业：恶口之业能让众生堕在三恶趣中，转成恶鸟，人皆憎恶，如猫头鹰等。转生人中，口中臭气熏人，说话人多不信，眷属不和，常好斗争。无始以来至于今日，不论尊卑亲疏贵贱，稍不如意顺心，就粗暴恶狠嗔恨恼怒辱骂毁伤。诃责神鬼，贬斥圣贤，诬谤善良等恶口之业无量无边，悉皆忏悔。

    妄语即为希求名闻利养，狡诈虚诳，厚颜无耻，颠倒黑白，妄说是非，欺诳贤圣，蛊惑世人，无论对父母上师尊长，还是儿女常人都无实话。经常自称得四禅、四无色定、四果圣人、菩萨、佛陀。常说见神见鬼，上天堂、入地府、游净土等妄语，如是诸罪无量无边，悉皆忏悔。

    绮语业即出语多涉淫行欲事，言词华丽绮靡。或写淫诗艳词黄色小说，描写谈说妖客淫态。唱淫荡歌曲，撩动人心，鼓起贪欲，使人耽著犬马声色。所造绮语之业无量无边，悉皆忏悔。

    两舌业即表面赞叹背后毁骂，以巧舌利口挑拨是非，离间君臣、父子、夫妇、师徒、朋友，使君臣猜疑，父子不和，夫妇隔阂，朋友疏远等。两舌之罪无量无边，悉皆忏悔。愿以忏悔口业功德，生生世世，具足四种辩才，声音和雅，闻者欢喜，常乐说法，开示众生，令悟实相。

    忏悔对三宝所造罪业：佛说：“人身难得，佛法难闻，众僧难值，信心难生，六根难具，善友难得。”今虽圆满但依三宝所造罪业极重，所以在此专门须要忏悔。无始来，不恭敬并亵渎佛的形象，轻视僧众，残害道友，破塔坏寺，焚烧经典佛像。自己住在高楼大厦中却把佛像安在肮脏狭小卑劣陋舍之中，使烟熏日晒、风刮雨淋、尘土染污、听任鸟雀老鼠随意毁坏。裸形露体于佛像经书之前。殿门紧锁，障佛光明等。如是等罪无量无边悉皆忏悔。

    对于法宝经书则以不清净的手随便抓取、乱扔，在看经时，或在经书附近非法地谈天论地，或放在床尾，或令散失、坏烂、缺漏，自己不看不修也不肯流通。或躺着听经，卧着读诵，高声谈笑，扰乱他人听法。或邪解佛语，非法说法，法说非法。或专为寻找法师的过失并加以辩驳嘲讽挖苦，或轻慢佛语尊重邪教，如是等罪无量无边，悉皆忏悔。

    对于僧则杀阿罗汉，破和合僧，损害发菩提心的修行者，鞭打沙门，任意驱使，随便评说毁谤，如是等罪无量无边，悉皆忏悔。

    以此忏悔功德，生生世世之中，常常遇到三宝，恭敬供养，常修六和敬，得自在力，兴隆三宝，弘扬佛法，度化众生。


别发十大愿：修行二利愿：成就妙行愿

    庚四、成就妙行愿

    一切妙行皆成就。

    此句是总说成办二利的一切无尽妙行，悉皆成就。洛钦大译师说此是消除一切障垢的对治力。

    华严广开二门引导行者入于萨婆若解脱大海，一者文殊理门，二者普贤行门。但很多人知之甚少，妄加评说：“般若空性之中，那里还容你建立行门，因为离言绝相、一切悉皆空寂的原故。又法身体中一切具足，何苦受此无益劬劳呢？”岂不知圆顿门中理行并驾，悲智交融，以文殊智慧印持万行，则无须舍弃差别万行。以普贤万行庄严法身，也不离根本智慧。不坏世俗而入于真如，不离开真如而安立世俗万行。具智慧眼所以不会沉溺生死海中，广运大悲因此不会耽滞涅槃彼岸。一切善法是菩萨入圣者位的资粮，六度万行是助成佛道的阶梯。具足眼目而不行走怎么能到达无热恼的清凉池呢？永明大师云：“方便般若，常相辅翼，真空妙有，恒共成持。”《法华经》中万善都归向菩提佛果，如在三宝前合掌礼敬悉皆成佛等。

    如大摩尼宝或大明镜，虽然光明清净，但有矿秽之垢，如果只是忆念宝珠或明镜本性，不以方便磨砺擦拭，想要光明显发出来是绝对不可能的。众生真如佛性，本来空明清净，但被无量烦恼垢染所蒙蔽，若只是忆念真如，不以方便熏修是无法清净的。因为垢有无量，所以应修习一切妙行而行对治。《大乘起信论》中讲了四种对治方便：“一者行根本方便，谓观一切法，自性无生，离于妄见，不住生死。观一切法因缘和合，业果不失，起于大悲。修诸福德，摄化众生，不住涅槃，以随顺法性无住故。二能止方便，谓惭愧悔过，能止一切恶法，令不增长，以随顺法性离诸过故。三发起善根增长方便，谓勤修供养，礼拜三宝，赞叹随喜，劝请诸佛，以爱敬三宝淳厚心故，信得增长，乃能志求无上之道。又因佛法僧力所护故，能消业障，善根不退，以随顺法性离痴障故。四者大愿平等方便，所谓发愿尽未来，化度一切众生，使无有余，皆令究竟无余涅槃。以随顺法性无断绝故。法性广大，遍一切众生，平等无二，不念彼此，究竟寂灭故。”马鸣祖师指出要随顺法性，开发真如，必须建立无尽妙行，否则执著毕竟空，不行六度万行，则智慧与方便分离，不成究竟正道。如《维摩诘经》云：“无方便慧缚，有方便慧解，无慧方便缚，有慧方便解。”说明智慧方便不能背离，要双融一味。所以说：“智度菩萨母，方便以为父，一切众导师，无不由是生。”华严二祖贤首国师说：「佛的三身以及十波罗蜜，乃至菩萨的利他妙行，都应将自心本具之法转为道用而行持，众生心中有真如体大，现在修行引出法身。众生心中本具真如相大，现在修行引出报身。众生本具真如用大，现在修行引出化身。由心中真如法性本无悭贪，现在随顺法性无悭贪修行引出檀波罗蜜等。应当明确了知，三大阿僧祇劫修行不曾在心外求得一法，都是从自心引出，所以应当以自性清净的妙行而修持。」

    如人广学医术，彻底精通，后采集天下一切药草，没有一样不能治病救人的。所以随顺法性、以智慧摄持的一切行为，都能庄严法身趣向菩提。即使一礼一拜也合于法性，融于智慧，这样广修一切妙行，无不是普贤行。所以菩萨发愿回向成就一切殊妙之行。


别发十大愿：承侍愿

    己九、承侍愿

    于一毛端极微中，出现三世庄严刹，
    十方尘刹诸毛端，我皆深入而严净。
    所有未来照世灯，成道转法悟群有，
    究竟佛事示涅槃，我皆往诣而亲近。

    初二句说明尘刹互融，次二句说明成就智慧与净土，五六句说明佛度化众生的方法，最后两句说明往诣佛前亲承供侍。

    在一毛端极微小的空间中显现过去现在未来三世所有一切的庄严宝刹，十方国土的所有毛端中所显的国土，我悉以甚深智慧往游其中。对如此众多佛刹中安住的未来所有照亮世间之明灯——诸佛世尊，从他们成就无上佛道，转大法轮开导觉悟一切沉睡在无明大梦中的众生，直至化导众生的事业已经究竟圆满，而示现入般涅槃，于其中间，我乘神通力分身各至其前亲近承侍，听受法要。正是所谓的：“于一毛端现宝王刹，坐微尘里转大法轮。”《出现品》云：“佛刹微尘数，如是诸刹土，能于一念中，一一尘中现。”本经中又云：“一一尘中无尽身，复现种种庄严刹。”


别发十大愿：成熟众生愿

    己三、成熟众生愿

    悉除一切恶道苦，等与一切群生乐，
    如是经于刹尘劫，十方利益恒无尽。
    我常随顺诸众生，尽于未来一切劫，
    恒修普贤广大行，圆满无上大菩提。

    菩萨以无尽大愿成熟众生，则能随顺趣入无上正等菩提果位，才能圆满成就普贤菩萨的一切行愿大海。菩萨被悲心牵引，观见恶道众生常常受诸苦恼，无有止息，发愿在无边的十方国土中，历尽现在未来刹尘数劫，拔除一切众生的痛苦，赐予暂时究竟的安乐，此愿此行无有尽期。尽未来的一切劫数，恒常随顺众生的根基意乐，以种种方便善巧引导他们入于无上菩提之道，永无间断地修持普贤广大胜行，究竟圆满无上正等正觉的果位。

    菩萨视每个众生犹如独生子，慈眼观照芸芸众生盲无慧目。欲求安乐，却吞毒物。欲至安乐殿，却行险恶道。又见到如子众生因往昔所造恶业，而今罪报现前，常受无量难忍苦楚，昼夜无有片刻停息。菩萨内心悲伤，为救幼子发如海宏誓大愿：“愿尽虚空遍法界的一切众生，常得安乐，无有诸多病苦。想要造恶不得成办，欲修善法疾速成就。关闭一切恶趣之门，开通人天涅槃安乐大道。若诸众生因昔日所造恶业，而感受极重苦果，我愿全部代替承受，让他们从痛苦中解脱出来，永远安乐幸福，究竟成就菩提佛果。”

    清凉国师说：初句是灭除苦因苦果；二句是等施暂时究竟安乐；三句是指成熟众生的时间竖尽未来一切劫；四句是从空间而言，横遍十方一切国土；五句是概括总说成熟众生；后三句则指长时修持之道与所得殊胜果报。即如《十地经》中云：“令其安住一切智智道。”

    如何拔苦与乐？此处分四略作宣说。一、凡夫位拔苦：虽为具缚凡夫，但深怀广大深切悲心，内心祈愿众生离苦，自身也付诸于行；或者见众生有困难时，热情帮助，看病施药，周济布施饮食衣服等资具；或施钱放生救命，对旁生布施草料水源等；对部多、非人、鬼子母、金翅鸟、游魂、饿鬼及地狱众生，以神咒加持饮食令彼等得以饱足，若常能以悲愍心，不希求钱财名利，放焰口蒙山施食，供施各种荤素熏烟，则对水陆空众生有莫大利益。

    再者，将诵经、拜忏、斋僧、供佛、念佛、持咒、修五加行等各种修行善根回向给罪苦众生，他们一定能息苦得乐，尤其诵大乘经典能拔三恶趣苦。唐朝时，有个姓王的人，一天忽然死去，被两个阎罗狱卒带到地狱中，见到一个出家人，自称是地藏菩萨。菩萨教他诵“若人欲了知，三世一切佛，应观法界性，一切唯心造。”当时就得到解脱，凡他念诵之声所到之处，听闻到的地狱众生都脱离痛苦。过了一天苏醒过来，向很多出家在家人讲述了这件事情的经过。因此《蒙山施食仪轨》中把此颂放在开头。此类诵经持咒念佛号拔三涂苦的公案多不胜数，所以作为修学大乘的人，应该恒常发此大愿，并付诸实施。以我们开口举手之劳，就能止息六道中往昔父母的痛苦。他们在迫切地期待，苦苦地盼望着他们的子女救拔他们，我们岂能置之不顾、木然处之。忆昔养育之情，慈爱之恩，心中孰能坐视不顾！乌鸦有反哺之举，羔羊有跪乳之行。作为有智慧、有头脑的人，不应该连鸦羊都不如，昧却良心。《瑜伽师地论》云：“菩萨于世间，修习哀愍意乐，及非意乐，为利恶趣有情，誓处恶道，如己舍宅。愿身代受，令彼恶业，永不现行。由此悲愿力故，一切恶趣诸烦恼品所有粗重，于自所依，皆得除遣。”《回向经》中说：「大菩萨们看到很多众生造作恶业，感受重苦。由于这些障碍，见不到佛，闻不到法，不知僧众，因此思维：“我应当到恶道中，代替众生受种种痛苦，不舍不避，不惊不怖，不退不怯，无有疲厌。”为什么能如此呢？因为菩萨曾发了荷负解脱一切众生重担的宏大誓愿。菩萨又想：“我所修行，要让所有众生无余得到无上智王的果位，非为自身而求解脱。因为我愿救度一切众生发菩提心、求无上佛果，并非为自身求五欲及三有中的一切快乐，才修菩萨行的。”以三有诸乐都不离痛苦的本性故。」

    二、说法开示正道：开示佛法教诲引导众生，让众生明因识果，进而取舍善恶业，以此断除恶法，消除苦果。或为他们开示人无我空性修法，依靠观修断除我执，斩断烦恼根本，出离三界轮回，安住小乘无余涅槃安乐界中。或为他们开示法无我的修法，以此断除人法二执，入于大乘圣者菩萨果位，以至成就阿耨多罗三藐三菩提果。这是拔苦与乐、成熟众生的最胜方便。

    三、猛厉方便拔众生苦：《梁摄论》云：“菩萨由如是方便，胜智行杀生等十事，无染污过失，生无量福慧，速得无上菩提胜果。”如果有人造五无间罪或毁坏三宝、谤大乘经、驱僧污尼等极其深重的罪业，没有其它方便能阻止他不造如此恶业，若不断除他的命根，决定造此恶行，后世无量劫中住在地狱恶趣之中深受痛苦。唯有断彼命根，他也能因此不堕恶趣，所以菩萨起大悲心，令恶劣众生现世受点小苦，而免去后世大苦。如良医治病，先让患者受点轻苦，才能彻底根除大病，免受长时大苦。菩萨戒中也开许菩萨为利益众生而行持杀盗淫等身口七种恶业。

    菩萨以清净大悲，全心全意利益他众，行持看似恶业的行为，不但没有过失，相反能积累很大的功德。但有些凡夫被强烈贪嗔烦恼心所牵制而不得自在，反而以菩萨戒及经论中开许的条文作为借口，行杀盗淫等恶业，毁坏戒律，罪过极大。导致自他都堕落恶趣之中，对佛法也造成了极其恶劣的影响。正是有这样的根据，所以密宗中开许大悲智慧成就的瑜伽修行者，以威猛法诛灭天魔外道、三宝公敌等造罪众生，将其神识超拔到净土中。《报恩经》中记载了世尊因地杀盗贼的公案：往昔无畏王如来灭度后，正法之中有婆罗门，聪明灵慧，受持优婆塞五戒，行持正法。率领五百同伴经过险道，要到另外的国家去办事。有五百强盗要劫此五百人。其中盗贼中有一人与婆罗门子很友好，便秘密告诉他赶快偷偷溜走，千万不要告诉同伴。婆罗门子经过深思熟虑，下定决心：宁可我入三恶道，也不能让他们受恶趣苦。于是持刀杀死强盗首领。

    四、神力放光及演说秘密陀罗尼：如《华严经》中佛菩萨放种种光明，光明中幻化诸物满足众生，或恶趣众生蒙光所照，痛苦停息，怖畏远离，病痛消除，瘟疫灭绝，或上升善趣，或得相应安乐。如诸佛菩萨宣说陀罗尼时，放大光明，照六道众生，悉令离苦得乐。或大菩萨以大悲心将众生痛苦交换到自身上，取而代受，此等公案在历代祖师的身上时有发生。

    因此我们也要从内心深处发此不可思议无尽大愿，尽未来际度化无量无边的众生，永无休息。这样以广大行愿为因，才能感得广大无尽的无上佛果。


前行七支行愿：称赞如来

丁二、称赞如来

    赞叹佛可消除口业的四种障碍，得到四无碍辩的功德。

    颂曰：
    于一尘中尘数佛，各处菩萨众会中，
    无尽法界尘亦然，深信诸佛皆充满。
    各以一切音声海，普出无尽妙言辞，
    尽于未来一切劫，赞佛甚深功德海。

    佛菩萨证得深寂离戏光明无为法，所以具足小中现大、大融于小的无碍境界。在一微尘中有十方三世一切佛土微尘数的诸佛，每一尊佛都处在无量菩萨海会围绕之中广转法轮。一个微尘中是这样的，法界中微尘，每一粒也都被诸佛海会大众所充满。这种境界不是凡夫狭隘的心量所能接受，只有以法性不可思议力、诸佛如来加持力以及自己闻思修的智慧才能深深胜解，朗然明观。面对如此殊胜的对境，我遍以如大海般无量音声，一一音声中又出生无边美妙悦耳动听的言辞，尽于未来漫无边际的一切时劫，不停地赞叹诸佛如来浩瀚无涯的功德海。

    《法华经》中说娑婆世界以音声而作佛事，因此在这个世界上提到修行，大多都是借助念、诵、读、唱等，如念佛、持咒、读诵、唱梵呗、唱赞文、讲经说法等。《法华经》中云：“或以欢喜心，歌呗颂佛德，乃至一小音，皆已成佛道。”赞叹如来功德也是音声佛事中的主要内容。

    佛的功德无量，所以诠释佛功德的佛名也无量，如阿弥陀佛又称无量光、无量寿、……超日月光等等。因众生心力狭劣无法忆持，世尊才为众生宣说《万佛名号经》及《佛十号经》等，如来即是佛的十种德号之一，《金刚经》云：“如来者，即诸法如义。”又云：“无所从来，亦无所去，故名如来。”《涅槃经》中云：“如过去佛所说不变，从六波罗蜜来，至大涅槃故名如来。”如来这一德号是从法身不迁不变、如如不动的角度来诠示佛的功德。所以念佛就是念佛的功德，就是赞叹称扬佛，因此能感召无量功德。

    当我们翻开大藏经时，会发现称扬赞叹佛功德的经论特别多，有的是佛自己宣说，有的是诸大菩萨、声闻等说，有的是历代的祖师所造。从因地所发大慈悲愿，从行菩萨道时修六度万行，从戒定慧，从三十七道品，从三身、四智、五眼、六通、四无畏、四无碍辩、十八不共法、十力，从成就国土、度化众生等各各角度来赞叹佛的功德，可谓五彩纷呈、各尽其妙，但也只是赞叹了其中的少分。为了消除无始以来口中所造的一切不善恶业，成就如来迦陵频伽圆满妙音，获得四无碍辩才，应尽未来际称扬赞叹诸佛如来。

    长行文中提到辩才天女可以作两种理解：一是指自在天王的名叫善口的婇女，本经《出现品》中说天女善口，舌根微妙，口中发一音声，能和上百千种音乐，而且每一音中又出百千不同的音声。二是指妙音天女，《金光明最胜王经》中宣说了她的功德，她有广大的智慧，能满一切众生的愿求，能赐予众生智慧及无碍辩才。若谁对文字句义有所忘失，经妙音天女加持可令其全部忆持不忘。她也能令人开悟成就，获得陀罗尼总持。偈云：“于诸女中最梵行，发言犹如世间王，辩才胜出若高峰，念者皆与为洲渚，众生若有希求事，悉能令彼速得成，亦令聪辩具闻持，于大地中为第一。于此十方世界中，如大灯明常普照。”宗密大师说她一定是古佛示现。

    现在我们以宗喀巴大师开示的窍诀来观修：如礼敬时一身幻化无数身，亲到诸佛菩萨众会中，且一一身上有无数头，每头之中都有如妙音天女的微妙舌根，一一舌根中流出无量音声，一一音声中演出无尽微妙言辞，尽未来际无有疲厌地赞叹诸佛无尽功德海。

    普贤菩萨赞叹佛云：“刹尘心念可数知，大海中水可饮尽，虚空可量风可系，无能尽说佛功德。若有闻斯功德海，而生欢喜信解心，如所称扬悉当获，慎勿于此怀疑念。”我们如果能对经论中所宣说的佛功德欢喜信解，就能得到所有称扬赞叹的功德。法王如意宝说：“如果要消除修行中的违缘，速疾得到上师三宝的加持，培养坚固的信心，就应该经常作诗词，歌颂上师三宝的功德。”赞颂文无量无边，大家应依各自所好，以念诵吟唱来尽情赞叹诸佛。

    经中所云“念念相续无有间断，身语意业无有疲厌”的大精进行只有在以殊胜智慧断除分别心后安住于解脱境界中才能真正成办，凡夫以分别心只是相似观修，但此等大愿凡夫仍可以发起。


别发十大愿：成正觉愿

    己十、成正觉愿

    速疾周遍神通力，普门遍入大乘力，
    智行普修功德力，威神普覆大慈力。
    遍净庄严胜福力，无著无依智慧力，
    定慧方便威神力，普能积集菩提力。
    清净一切善业力，摧灭一切烦恼力，
    降伏一切诸魔力，圆满普贤诸行力。

    以神通力可以在极短的时间内自由无碍迅速快疾地周遍十方一切世界。以大乘不思议力可以任运地于十方刹尘国土中示现八相成道，普门示现随机赴感度化众生。以功德力广大普遍地修持智慧与成就妙行。以大慈力的威神能周遍覆护一切有情。以殊胜福德力普遍清净庄严依报的国土与正报的有情。以根本般若真智，能远离一切耽著依附。定慧方便的威神大力能普遍救度众生，将彼安置于菩提正道，也能积集菩提资粮。而且发愿成就清净一切善业的力量，摧灭一切烦恼的力量，降伏一切诸魔的力量，圆满普贤无上菩提妙行的力量。

    按洛钦大译师的观点：前两颂是为了成就八种能力而发愿，也就是要求行人发起志求神通力、大乘力、功德力、大慈力、胜福力、智慧力、威神力、菩提力之愿。后一颂是发愿修持对治障碍的法：即发愿修持对治恶业的清净善业，修持毁灭烦恼的对治力，修行降伏一切魔怨的对治力，修行能圆满普贤妙行之法。

    但依华严宗的观点认为：此是愿与一切众生同时都能得到无上菩提，永远不歇地奉行佛的伟大事业。《十地经》中菩萨法愿云：“于一切世界成阿耨多罗三藐三菩提。”前面的九种力量是佛的业用功德，后三力是总结从因得果。前面九力之中具有七种业用功德，而且在理解时，前六句中的内容要倒置理解。七种业用功德是：一自在业：即神通力速疾周遍，成就正觉时现大神通，以法智通、神足通、幻通自由无碍地变化，充满一切世界。《密集金刚力士经》云：“正住神通，建立无衰大业。”二正觉业：即大乘力普门遍入。《法华经》中说：「若有众生从佛听闻正法即能信受奉行，精进进求一切智、佛智、自然智、无师智、如来知见，力、无所畏。愍念利乐无量众生，利益人天，度脱一切有情，称为大乘。」也就是说发起菩提心为度众生誓愿成佛的就是大乘。乘是运载的意思。《十二门论》中解释大乘说：「因为相对二乘来说是上者，故称为大乘；此乘能到达伟大的诸佛最高果位，所以称为大乘；此乘被诸佛如来所乘，所以称为大乘；能灭众生大苦赐予大安乐，所以称为大乘；此乘能穷尽一切诸法的边际与底源，所以称为大乘。」《宝积经》中也说：“如来正等觉所行之道，所以彼乘是大乘、上乘、妙乘、胜乘、无上乘、无上上乘、无等等乘。”藕益大师指出大乘即自性本具不可思议法性，成就恒沙功德妙用，以此自运运他离苦至乐，究竟成佛，即是不可思议大乘。所以菩萨以此不可思议大乘无量功德妙力，于一一毛端中，三世一切国土之中，周遍示现八相成道，度化无量无边的众生。《十地经》云：“不离一切毛端处，于一切毛端处，悉皆示现初生、出家、往诣道场、成正觉、转法轮、入涅槃。”三谛实业：即普修智慧与妙行，此二相辅相成，也就是以智慧摄持妙行，使妙行成为解脱的无漏功德，以妙行证悟巩固增进智慧，使之更加广大圆满，以此二者成就功德，庄严菩萨自己。自身具有真实解脱功德才能利益众生。度化众生要具有大慈大悲心，《无量寿经》中说：“佛的心就是大慈大悲心，用无缘的大慈力摄受众生。”《大智度论》中说：“悲能拔苦，慈能与乐。”所以要用慈心覆护众生，让他们在大慈力的感化之下，自然愿意接受教化，这也就是摄伏门。正因为诸佛菩萨有大慈力，所以或如春天温暖的太阳散发出光热，滋长众生法身慧命菩提苗芽，或显现正好与之相反，威势凛然，如父母慈爱儿女，然见儿女未依彼善諭加以改悔时，即大发雷霆，痛加斥责，甚至棍棒交加，如此方能彻底纠正子女错误，引上安乐正道。佛菩萨也以不可冒犯的大威神力，折伏众生，令生敬畏，予以度化，即折伏门。如佛以平等大慈心观照一切善恶众生，无有差别，对诸弟子们关怀备至，但对刚强蛮横的魔军则内怀大慈，外现神威，一一悉皆调伏。在上面的基础上以广大的胜福力自净净他，自严严他，使国土众生悉皆清净庄严，如阿弥陀佛极乐世界的一切能依所依悉皆清净庄严。四证教化业：菩萨要弘扬佛法度化众生，自己当证悟无生离戏的般若智慧，以此智慧离一切分别执著之戏论，以此根本智慧现前无相基之性净涅槃，所以恒时安住空寂离戏之境。并以所证之法化导众生，所以以上三力称为谛实业。五种种说法业：《十地经》云：“以一音说法，令一切众生心皆欢喜。”即是定慧方便力。六不断佛种业：菩提力普能集积，即令自他发菩提心，行菩萨道，受持佛种不令间断。七法轮复住业：即依靠大智慧清净一切善根。《十地经》云：“示大智慧地，安立一切法。”佛已证大涅槃，但又入世间，示现清净善业，为众生转法轮，所以称为法轮复住业。

    后三力之间是因果的关系，即由摧灭一切烦恼，降伏一切诸魔作为因，才能圆满普贤无上佛道。

    法王如意宝说《行愿品》中的所有愿都可摄在“清净一切善业力，摧灭一切烦恼力，降伏一切诸魔力，圆满普贤诸行力。”一偈中。法王曾经朝礼印度金刚座，转绕菩提塔时，虽然念了很多发愿文，但主要以此四句为主而发愿，所以上师教诲说：在朝礼神山，圣地，寺庙，佛塔，佛像或拜见高僧大德时，若能念《行愿品》最好，若条件有限应念此颂发愿，至为重要。在《布谷鸟道歌》之中，法王如意宝开示了四年来传法的密意：以“清净一切善业力”为主对居士们宣说取舍善恶因果的《百业经》；以“摧灭一切烦恼力”为主对藏族尼众莲花部宣说发菩提心、行菩萨行的《入菩萨行论》；以“降伏一切诸魔力”为内容，针对汉族金刚降魔洲宣说《大幻化网》法；以“圆满普贤诸行力”为内容针对藏族喇嘛而宣说《上师心滴》为主的无上大圆满法。所以此颂包含大小显密的一切诸法精要，因此我们要特别发起如是大愿，受持上师的四部教法，成就无上菩提果位，度化无量无边的众生。


别发十大愿：受持愿：出家持戒愿

    庚二、出家持戒愿

    常得出家修净戒，无垢无破无穿漏。

    愿我一切世中常能辞亲割爱、剃除须发、出家为僧。既出家已纳受清净戒体，如爱护眼珠与命根一样护持戒律，使戒珠如白玉般洁净光莹。在我持戒修梵行的过程中，一切染污戒体、毁破戒律、穿漏戒体的恶因缘全部远离。

    戒律是一切善法的生处犹如大地，戒律是一切善法的基础，戒律是菩提果的阶梯，戒律是人天善趣的根本，是济渡生死大海的浮囊。戒律是佛法长久住世的根本。而菩萨要成就菩提果，必须要修菩萨行，菩萨行即修持佛法。但佛法的成就必须建立在清净戒律的基础上。佛曾说我若不持清净戒律，连狐狸及下贱人身尚且无法得到，何况能成佛转法轮度化众生。《华严经》中也说：“戒是无上菩提本，应当具足持净戒。”戒律若毁一切善法全部失毁，一切圣果永远无份。

    菩萨为什么要出家修行呢？因为在家狭窄逼迫如处牢狱之中，出家宽旷犹如虚空自由自在。《大智度论》云：“孔雀虽有色严身，不如鸿鹤能远飞。在家虽有五欲乐，不如出家功德深。”《大乘本生心地观经》中佛对智光长者比较出家在家的胜劣差别。佛说：「出家菩萨胜过在家无量无边，无法相比。出家菩萨以正智慧，详细观察在家的种种过患。如拥有房舍宅院，财物堆积其中，不知满足，犹如大海容受一切大小江河无有满足。在家人常常妄想纷飞，执著外境，不能了达真如法性，无明昏醉，颠倒攀缘，常生恶心，善念难以发起。因为妄想生起很多烦恼，由烦恼而造业不息，所以转生漂泊五趣之中，生死不断。出家菩萨厌离世间，是真出家。」佛说偈言：“出家菩萨胜在家，算分喻分莫能比，在家迫窄如牢狱，欲求解脱甚为难。出家闲旷如虚空，自在无为离系著。”又说：“若有男子女人，一日一夜出家，二百万劫不堕恶道。”居家修行有很多的障难以及众多的罪恶过失，出家则能远离一切过患。要断生死，出家最为超胜，所以智者们都欢喜出家。若不出家也要思维在家过患出家功德，以此种下觉醒的好习气。在家人，富贵的守护财物极为辛劳，贫穷的追求寻觅倍受艰辛，根本无有一丝一毫的安乐，但他们因愚痴却执著有安乐，应当知道这都是恶业的果报。《本生论》云：“于同牢狱家，永莫思为乐，或富或贫乏，居家为大病。一因守烦恼，二追求艰辛，或富或贫乏，悉皆无安乐。于此愚欢喜，即恶果成熟。”紫柏尊者云：“多算胜，少算败，不如出家为僧快。”西藏的伽喀巴尊者也说：「如果能追随如来大仙之所行，出家住山苦行，这才是释迦文佛的真实养子。」霞惹瓦格西对不能出家的人采取的度化方法是：「我们要披解脱妙衣，让他生起出家快乐的心，种下将来出家的习气。」《勇猛长者请问经》云：“我于何时能得出离苦处家庭，如是而行，何时能得作僧羯磨，长净羯磨，解制羯磨，住和敬业，彼当如是爱出家心。”菩萨再三观察出家的功德和在家的过患，所以常愿出家。寂天菩萨云：“我未登地前，愿蒙文殊恩，常忆己宿命，出家恒为僧。”


别发十大愿：供养愿：法供养

    庚二、法供养

    愿持诸佛微妙法，光显一切菩提行，
    究竟清净普贤道，尽未来劫常修习。

    永永远远地住持诸佛世尊无上正法，宏宣菩提正道，圆满普贤清净行愿，而且经常精进修持，尽于未来一切时劫。也就是说，依止诸佛菩萨善知识广泛听闻、深入思维、随顺修持、断除烦恼、证得解脱的修行过程中，应对大小显密所摄的无量法蕴，悉能闻持不忘，深解无碍，而且善达诸法性相及菩提道次第。能广大光显诸法幽玄隐义，善巧分析解说，犹如日光照明道路，正确无误地引导众生。这样精进光显觉悟的大道，引导趣入普贤清净诸行，悉使究竟清净，尽于未来一切时劫。

    初二句指出所缘因大，即受持一切诸佛微妙正法，光显一切菩提大道，也就是住持教、证二种正法。《俱舍论》云：“佛正法有二，谓教证为体。”这是一切供养中的最胜供养。长行文中云：“善男子，诸供养中，法供养最。”它的原因是：“何以故，以诸佛如来尊重法故，以如说修行出生诸佛故。若诸菩萨行法供养，则得成就供养如来，如是修行是真供养。”三句指出功德果大，即能获得究竟清净普贤无上佛道。因为修持之因广大无边，所以感得广大究竟佛果。四句指出修持时间恒久，即尽未来一切劫而常修习不懈。

    下面讲护持正法的功德及如何护持：护持正法则能摄集一切善愿，趣入甚深境界。《护持正法狮子吼胜鬘经》云：“佛言，菩萨所有殑伽沙数无量行愿，皆应摄入一大愿中，所谓护持正法，护持正法是大境界。复云：譬如有大力士，少触身分为彼损害。佛言：胜鬘，少护正法亦复如是，令魔波旬得大忧恼。我不见余一善法，能令恶魔生此忧恼，如是唯少护持正法之者。譬如须弥山王端正殊特，于诸黑山最为高大。佛告胜鬘：如是大乘舍身命财以摄取心，护持正法，胜余大乘者不舍身命财所护一切善法故。”

    护持正法功德凡夫无法衡量、难思难议，然如来金口诚言所宣犹如大雷震惊醒大乘修行者，岂可坐视教法沦亡湮没，佛之法身舍利无人护持，众生安乐之源的法日就此堕毁，对大悲慈父释迦世尊群经中殷勤咐嘱的遗言，不听不受，而甘心辜负佛陀的教敕。但真正如来的使者，继承如来家业的大丈夫，定会鼎力荷担住持教法的伟大重任。佛在《海意请问经》中云：“护持如来正法者，即为胜尊师摄受，诸天龙王紧那罗，福德智慧皆能摄。护持如来正法者，所生刹土不空过，一切生中见胜尊，见已即得心清净。护持如来正法者，而得宿命大我法，出家善利速能成，所修真实清净行。”又云：“护持如来正法者，得大总持及善利，正使百劫非听闻，由具辩才悉无碍。护持如来正法者，乃至释梵护世等，人中复得转轮王，悉悟菩提安隐乐。护持如来正法者，具三十二殊妙相，大智庄严喜乐身，随所见者无厌足。护持如来正法者，而不舍离菩提心，波罗蜜行不弃捐，普能摄受多种善。”护持正法有如是巍巍功德，为报佛恩大家都应尽力信受奉行。

    那么如何护持佛法呢？佛的正法有两种，护持教正法与证正法都是住持佛法。教正法指佛陀及祖师所宣说的一切经论，所以兴盛光大、弘扬流通教法都属此范畴。因此永明大师大力倡导说：「如果见解不错，契合佛意，虽然弘法利人，但功德归于自身，既能助道修行，又能报佛恩德。如果不求名闻声誉，那么功德一点也不会遗失。所以传持法宝，敷演讲宣大乘佛法，造论解释经典，著文阐扬妙义。拔除不信之疑箭，以智慧光明照亮愚痴黑暗，筑起正法高墙，延续佛陀慧命。或远到西天求法，或翻译大乘经论，润色经文。或广泛施行经典神咒，到处流通教人受持。大开无遮法施之门，延续传灯之焰。能用甘露滋润干涸的心田，善使金錍抉开痴盲者的智慧眼。」经中云：“假使顶戴经尘劫，身为床座遍三千，若不传法度众生，决定无能报恩者。”有人心中暗自疑惑：讲经说法都是具有大智慧、精通佛法的大法师才能做的，象我这样的一个普通人，又没智慧，别说真正去作，就是想也不敢想。持这种错误态度的人，我认为首先他对佛法的责任心不强。再者没有再三思维忆念佛的恩德，没有生起强烈的报恩心。三者对众生的悲心不够强烈。四者过于自卑。人各有不同的智慧与能力，贵在参与，贵在勇于发挥自身的能力。不能因为日月的光明强大，星星与灯炬就不须发光。若每个人都有强烈的责任心、报恩心、大悲心、大信心，积极地发出自身的热量，放出自身的光芒，佛法一定会有个光明的前途。如果我们每个人都推卸责任，消极逃避，任其衰败，则佛法将毁在我们的手中，众生的安乐也被我们葬送无余。如此作为佛子真是不忠不孝！现在佛法看似兴盛，但其实佛法的衰颓，大有江河日下的趋势，真正与正法像法相比较，简直令人痛心疾首，寝食难安。所以一切在家出家藏族汉族的佛弟子，都面临着一个义不容辞的、艰巨的历史使命——荷担如来家业。因此能力大的挑重担，能力小的挑轻担，各尽所能，众志成城，以大家的力量，扭转乾坤，力挽狂澜，使佛法在人间重显辉煌。

    末法的今天急需讲经说法的法师，若能造就踞狮子座、在大庭广众之下作狮子吼无畏说的法门龙象，自然多多益善，妙之又妙。如果不能如此，也要在不求名闻利养的前提下，尽自己的能力，将自己所知所解的正确佛法广泛地为人宣说，纵然不能广讲经论，但就经论中的一部分、一颂一句、一个公案故事，对人宣说也未尝不可。不一定非要坐在高高的法座上，在大众围绕之下，才可以讲经说法。凡是在日常生活中与人接触交往时，善巧地运用佛法，把佛法灌输给别人，让他种下善根，生起信心，就是在弘法。若板起面孔，让人见之如虎，不敢接近，甚至让人误解佛教徒都是孤僻怪异、麻木无情、冷若冰霜的。或者显现极大傲慢，以不屑一顾的鄙夷姿态看待世间的人们，自视清高认为与之接触交谈，会玷污自己的清白。这样的作法，并没有住持佛法的高尚形象，相反使得佛法与世人的隔阂越来越大，更被他们所误解。佛法应该遍及到世间，利益广大众生，这是佛的究竟目的。

    《般若经》中比较：自己忆念修行般若的福德，不如广为人天大众巧妙地作比喻，使听众容易理解般若所获的福德。经中云：“其人戒定虽羸劣，善能说法利多人。若有供养是人者，则为供养十方佛。”戒律禅定虽然有所缺漏，但其人如果善巧说法利益大众，供养他则如同供养十方一切诸佛，供养戒定慧清净的讲法人所获功德又岂能衡量。其它经中还作了一个比喻：在一个伸手不见五指的黑夜之中，险要的道路上有个大恶人手执火炬照亮道路，若有人见此恶人，心生憎恶，也不愿看他手中所持的光明，结果自身落入山谷。佛说此人甚为愚痴，他人虽恶，但他所执火炬却是我们应取的。《阿含经》中也作了一个绝妙的比喻：如人欲过大海，无有船筏，只有一具死尸，若依靠它，则能度过大海。同样我们要过生死大海，如果无缘遇到清净圆满的法师之时，纵然所遇之师，功德少过患多，我们也不能舍弃，应借助他度过生死大海，否则只能徘徊海边望洋兴叹。

    《未曾有经》中说：「说法有二大因缘：一者开示化导人天获得无量福报故；二者为报施主恩德故，岂能不说。财施如灯，只能照亮一室，法施犹如皓日，普照天下。」末法时代，发清净心讲经说法，佛一定以大神力作加被。《大方广总持经》云：“善男子，佛灭度后。若有法师，善随乐欲为人说法，能令菩萨学大乘者，及诸大众，有发一毛欢喜之心，乃至暂下一滴泪者，当知皆是佛之神力。”来果禅师云：“实乃苦海慈航，幽途宝炬，诸佛法身之本，众生慧命之源，龙宫海藏钦崇。经演片刻，诸佛护念，法轮转处，神鬼皈依。”《万善同归集》云：“是以至心读诵演说，证验非常，恒为十方如来，释迦文佛，密垂护念，赞言善哉，授手摩头，共宿依覆，摄受咐嘱，随喜冥加，乃至神王护持，天仙给侍，金刚拥从，释梵散花，成就福田，等法界虚空之量。校量功德，胜恒沙七宝之施。”《贤愚经》云：“行者欲行佛道，当乐经法，读诵演说。正使白衣说法，诸天鬼神悉来听受。况出家者，有道之人。乃至行路，诵经说偈，常有诸天随而听之，是故应勤读诵说法。”

    有人虽然不能登座讲法，但可以印刷经论，广泛流通结缘，带众念佛、诵经、持咒、上早晚课，教一些规矩礼仪。或者如智者大师所说方法诵经，也能利益人天大众：即修行者严净道场，礼敬供养常住三宝；再收敛身心，洁心净意，三业清净安然端坐，观想自处如来金刚座上，道场广博，天龙八部人与非人一时集会，肃然恭敬，渴望听法；后以微妙音声，朗朗读诵，随文入观，不起分别，不紧不慢，徐徐进行，大众闻经欢喜，如此诵经也有无边利益。经中云：“若人读诵处，其地皆为金刚，但肉眼众生不能见耳。”《南岳感通传》中说：「七佛的金塔中有银制的印鉴。若诵大乘者，用银印鉴印他的口，不使遗忘经文。」所以自古读诵大乘经者，有肉身不坏、舌出红莲、口吐紫檀妙香的灵验。听一句毕竟趣向菩提之道，诵半偈而功德无量，书写经卷而生欲界天，真是法威德力不可思议！万种瑞相，千般灵验，皆由佛法感应现前。三贤十圣，从法而生。从古至今的一切凡圣都是以清净三业供养法宝，以十种方法修持并传续不断。如法华会上从地涌出的诸大菩萨也发愿佛灭度后，不但要对他人宣说无上一乘法要，而且自己也发愿受持读诵。

    证正法即戒定慧三无漏学。喇拉曲珠仁波切说：能受持戒律的居士、沙弥、沙弥尼、比丘、比丘尼等七众都是住持证法者。也就是纳受别解脱、菩萨、三昧耶三种戒体，并护持清净，即是护持证法。修持佛经中所开示的一切三摩地，就是住持定学。如首楞严三昧大定、等持王定、狮子奋迅三昧、海印三昧，或如《三摩地王经》中所宣说的百千三昧，能正修持者都属此例。慧学即修大小显密中各种层次的无漏智慧。

    大家对二种正法都应随分随力地护持，不但现在要护持，而且应发愿尽未来劫如文殊、普贤、阿难、迦叶一样护持十方一切诸佛的清净微妙正法。这样上报佛恩下利群众，无有休息。


梵汉对照

乙二、梵汉对照

    贤劫千佛都在印度金刚座现前无上正觉，且都用梵语转法轮，佛虽然具有圆音，但经典的结集却都用梵语。现在此经题仍保留梵语可以说明两个问题：

    一、证明此经是真实可靠的。现在一些居心叵测的人，不怕造大恶业，高声狂吠地毁谤经印汉二土的三藏译师从梵文译成的《楞严经》、《大乘起信论》等是伪经伪论，混淆是非，执持邪见，欺世惑人实属魔说。

    二、现在见闻梵语于八识田中种下种子，将来遇佛闻法。今从华严五祖圭峰宗密禅师的《行愿品别行钞》中摘出梵语经题，大师并说明梵汉如何对照。

    梵语“摩訶”对应汉文中的“大”字，“尾没”对“方广”，“没馱”对“觉”，“巘拿”对“杂花”，“賀”对“严饰”，“素怛”对“契经”，“阿進底也咄”对“不思议”，“尾目乞义”对“解脱”，“尾灑也”对“境界”，“三满多跋捺囉”对“普贤”，“左哩”对“行”，“鉢囉抳馱曩”对“愿”，“鉢囉吠捨”对“入”，“跋哩嚩多”对“品”。译师为随顺汉语习惯译为大方广佛华严经入不思议解脱境界普贤行愿品，如此则大家应毫不怀疑地受持读诵。


前行七支行愿：广修供养

丁三、广修供养

    供养除悭贪障，得大财福。

    颂曰：
    以诸最胜妙华鬘，伎乐涂香及伞盖，
    如是最胜庄严具，我以供养诸如来。
    最胜衣服最胜香，末香烧香与灯烛，
    一一皆如妙高聚，我悉供养诸如来。
    我以广大胜解心，深信一切三世佛，
    悉以普贤行愿力，普遍供养诸如来。

    如前遍法界微尘数的诸佛海会之中，每一尊佛均有无量人天菩萨大众周匝围绕，如此多的海会诸佛，凡夫的身力、心力确实无法一一供养承事，必须仰仗诸佛及普贤菩萨的行愿力，自己也要深心信解自心普贤本来具足这样的妙用，才能作如此广大的供养。接着我们观想法界虚空界中一时出现所有上妙供养资具，一时周遍供养一一诸佛，无空过者。所谓华云、鬘云、音乐云、天伞盖云、天衣服云、天种种香、涂香、烧香、末香等，以三摩地每一种又自然显现无数无量，供品堆聚高如须弥山。（颂词中的“妙高”即须弥山）又燃种种灯，如酥油灯、各种香油灯。每一灯巨大无比，灯炷如须弥山，灯油似大海水，这些灯放出无量光明，一一光明供养诸佛，无有时间空间的限制，如此观修才称得上广修供养。

    一切诸佛都曾广修供养，如释迦世尊在燃灯佛前得值八百四千万亿那由他诸佛，悉皆供养承事，无有空过者。普贤菩萨是古佛应化，尚且发此供佛大愿，修此无边胜行。但有些人认为众生心性中圆满一切功德，或般若法身中一法不立，为什么要徒增执著，妄加分别地修善断恶，简直是推舟于岸劳而无功。说此话的人，正暴露了他没有正确知见，不了解法身更不认识般若。《般若经》中说：「般若虽空，不坏一切法，合于一切法。」正因法身不立一法，而能炽然建立一切善法。《维摩诘经》中云：“菩萨虽行于空，而植众德本，是菩萨行。虽行无相，而度众生，是菩萨行。虽行无作，而现受身，是菩萨行。虽行无起，而起一切善行，是菩萨行。”八地菩萨证得无生法忍，现前无功用行，离一切分别念，但仍然精进供养恒沙诸佛。

    修行无上菩提的人最初依靠善法趣入，最后以善法助成佛果。所以善法是超越生死海的舟航，趣涅槃城的道路，人天善趣的基石，成佛作祖的墙垣，现在将来都不可暂时废除。以贪著心行持善法成有漏小果，心无所著则成无为善道，至于善业本身有什么过失呢？《华严经》也说：「虽无所作，而恒时安住善法之中。」《大智度论》中记载佛说：「我过去曾经作过恶人和小虫，但因为积累善法的缘故，现在才得以成佛。佛陀十八不共法中有欲无减者，佛知善法的恩德，所以常常想修集善法的心念不曾减少。」经中佛告比丘云：“功德果报甚深，无有如我知恩分者，我虽复尽其边底，我本以欲心无厌足故得佛，是故今犹不息，虽更无功德可得，我欲心亦不休。”佛达到了无量功德海的边底，尚且对善法无有厌足，而我等为了趣入解脱道，开显自性三身佛果，更应披上精进铠甲，遍修广大福德。

    马鸣菩萨的《大乘起信论》中开示修习信心的四个法门，其中就有广修供养。论中云：“信有四种。一者信根本，谓乐念真如法故。二信佛具足无边功德，谓常乐顶礼恭敬供养，听闻正法，如法修行，回向一切智故。三信法有大利益，谓常乐修行诸波罗蜜故。四信正行僧，谓常供养诸菩萨众，正修自利利他行故。”菩萨戒本中也要求每日供养三宝三次，否则犯轻垢罪。

    在佛的教法之中不论大小显密都提倡供养，若不供养非佛弟子，是被魔所摄持。《楞严经》中佛详细宣说了五十种阴魔的境界，如同照妖镜，后学者依之可辩邪正，避免误入歧途。经中讲到：「有人入定见色阴消失，受阴明显，就生大满足，无端起大我慢贡高心，以及慢、过慢、增上慢、身劣慢同时发起。此人尚且轻视十方如来，何况声闻独觉？此时大我慢魔附入他的心脏之中，不礼佛塔庙，摧毁经典佛像。对施主说：“佛像是金银铜铁土木铸塑而成，经典是树叶纸墨而已，你们不供养真常肉身，却膜拜恭敬土木，真是迷惑颠倒。”有人深信他的胡言乱语，就依照而行，或毁碎或坑埋。如此误导众生定堕地狱、常劫沉沦。」如此之流过去就有，现在也不乏其人，当来更会嚣张，所以请大家擦亮慧眼，仔细辨认。

    福德是安乐的根本，智慧是解脱的门径，这两支轮子不能舍弃也不能分开。从智慧母、方便父出生一切诸佛、佛子，福慧必须双融才是成佛的正确轨道，拔除痛苦的甚深要因。《大智度论》云：“福德是菩萨摩诃萨的根本，能满愿一切。圣人所共赞叹，无智人所毁咎。智人所行处，无智人所远离。是福德因缘故，作人王、转轮圣王、天王、阿罗汉、辟支佛、诸佛世尊。大慈大悲、十力、四无所畏、一切种智、自在无碍皆从福德中生。”古今善知识都普遍上供十方佛，中供诸贤圣，下施六道群生，毫无差别。

    一般世人所珍惜爱重的无非：妙香、奇花、宝灯、净水、珍果、香茶、美食、财宝、宝珠、妙衣十种。把自己难舍的财物，以清净心彻底舍弃，用来供养法界中的一切贤圣及六道所有众生，这样内可断除悭吝贪嗔之毒、滋长法身慧命，外可培植生生世世福德尊贵之身，乃至成就佛的报化二种庄严身相。看起来是供养他人，其实功德全部都归自己。不同的供物，可以感得不同的果报，宗密大师在《华严经普贤行愿品别行疏钞》中云：“奉嬉常受悦，献笑佛怜悯，奏歌得法音，供舞得神通，奉瓶得宝瓶，进宝获觉分，亦感宝庄严。由供养严树，得庄严觉树。奉幢得妙宝，能遍济贫乏。供幡超胜幡，献铃众归敬，献缨获严具，进鬘得宝冠，上花得佛容，如是一一皆获胜报。”来果禅师说：“供香则身口不臭，供花则相貌端严，供灯则心眼光徹，供水则恶病全消，供果则富乐尊荣，供珠则身钦洁贵，供衣则福寿绵长。”《华严经》云：“以灯供养诸佛故，得成世中无上灯。”《普广经》云：“燃灯供养，照诸幽冥，苦痛众生蒙此光明，得互相见，缘彼福德，拔彼众生，悉得休息。”由此可见燃灯可消除众生的痛苦，超拔众生得以超升。《施灯功德经》云：“佛告舍利弗，若人于塔庙施灯明已，临命终时，得见四种光明。一者临终见于日轮，圆满涌出。二者见净月轮，圆满涌出。三者见诸天众一处而坐。四者见于如来正遍知，坐菩提座，垂得菩提。自见己身，尊重如来，合十指掌，恭敬而住。或散花供养，严饰道场，尽作菩提之缘因，成佛之正行。”《悲华经》云：“若以一花，散虚空中，供养十方佛，乃至毕苦，其福无尽。”

    藏地有个极好的规矩，就是经常以青稞大米等代替鲜花撒在空中供养三宝、善知识、法师、活佛等。打水时先舀上一瓢观想供养上师三宝，吃饭时也随时随地作供养。看到晴朗湛蓝的天空，雪白如玉的云海，霞光万道的朝阳，皎洁清凉的月轮，绚丽动人的彩虹，遍满鲜花的大地，清澈甘甜的溪泉，浩瀚无边的大海，气势磅礴风景秀丽的名山大川等等，凡是自然界一切赏心悦目的美景，都先观想供养给上师三宝。如此时时处处忆念三宝，在不经意中已种下无量无边的福报，这样如靠近炉边，自然会感到上师三宝加持的温暖。

    《法华经》云：“若人散乱心，乃至以一花，供养于画像，渐见无数佛。”散乱心都有这么大的功德，那么至心恳切恭敬献供，其功德谁能衡量呢？不但散乱，就是无意供养也能获得殊胜功德。经中记载：曾经有五百强盗，到一寺中盗取佛眉间的宝珠，因光线太暗，强盗首领用箭挑了挑灯芯，灯焰照亮了佛像。后来到释迦世尊成佛时，这个强盗头子，就成了天眼第一的阿那律尊者。诚所谓“三宝门中好种福”，无意供养都能种下解脱的胜因，确实稀有。世尊成佛时发出十种微笑，其中之一即：佛见种小因能成大果故而微笑。所以我们在殊胜的对境面前虽然只是小小的供养，当来却可成就巨大的福报。如种下一颗芥子大小的无忧树种，会长成参天的无忧大树。

    佛陀时代有位亿耳阿罗汉，过去世曾经用一朵花供养佛塔，以此果报九十一劫受人天妙乐，最后以此福德见释迦文佛，证阿罗汉果。由此可见，有的人虽然条件有限，不能拿出丰盛的供品，但应随分随力，以虔诚心发广大愿来供三宝，同样能感得大福报。如毗婆尸佛时，有一个贫穷人，见到僧众，生大欢喜，无物可供，就采了些野花野草，供养僧众，以此功德九十一劫身体端正庄严，心中若有所需，只需动念作意就会立即现前。净土宗六祖永明延寿大师在《万善同归集》中云：“若有人能于佛法僧，少作微善，如毫发许，所生之处，受报弘大，无有穷尽。”

    《菩萨本行经》中也记载了一个公案：佛在世时，有位名叫娑多竭梨的阿罗汉用神通观察他的宿世：发现他在因地时，曾洒扫定光佛的古塔，除草伐木，庄严清净，洒扫完毕，欢喜踊跃，转绕八匝，作礼而去。命终之后，生光音天，天寿尽后，又作了一百次转轮王，容颜端正，见者欢喜，行走时道路自然清净，九十劫中天上人间，富贵荣华快乐无极。现在又遇到释迦如来，舍弃豪门福贵，出家证果。《正法念处经》云：「若有众生净心供养众僧，洒扫如来塔，命终生意乐天，身无骨肉，亦无污垢，香气能熏一百由旬，其身净洁犹如明镜。」但我们作为求解脱、修大乘法的人，应以菩提心摄持回向成就佛果，往生净土，不能只求人天小果。

    若没有福报或福报不足就不能开悟、证果。无相好佛优波毱多见一比丘无有福报不能得道，就让他供养僧众，后来才证果。类似的公案《百业经》中多有记载，可阅读了解。同样《高僧传》中说：弥天高道安法师精进修行，感得圣僧告诉他说：“你的行为与见解都超于常人，只是缺少福报。如果浴僧众，你的心愿一定能成办。”平时经常听人说福报浅薄，业障深重，所以修行障碍很多，极难相应，遑论开悟成就，这句话很有道理。

    有人心不平等，只认为供佛供僧功德大，不知众生即未来佛，《行愿品》中明文申明三世一切诸佛，都要平等供养。如维摩诘居士上供难胜如来，下济最极贫困之乞丐，并说此二功德等无差别。因为作为未来诸佛的众生极其痛苦可怜，如果以慈悲拔苦心供养施舍，经中说：「所获功德超胜供养佛、声闻、独觉。」《像法决疑经》云：“若人于阿僧祇劫，以身供养十方诸佛，并诸菩萨及声闻众，不如有人施与畜生一口之食，其福胜彼百千万倍，无量无边。”因为见三恶道众生极为痛苦，而以大慈大悲心，拔苦与乐，所以功德极大。

    《丈夫论》云：“悲心施一人，功德如大地。为己施一切，得报如芥子，救一厄难人，胜余一切施。众星虽有光，不如一月明。”所以当发慈悲愍念苦难众生，发愿以身语意成办他们的一切所须，甘心承侍令彼欢喜。如填平坑堑，开通道路，造船修桥，远道中建立亭榭，路旁栽植花果，这样消除来往人的疲乏，给人们带来极大方便。或者施食供水，探病送药，提供住处，制作供养衣服及一切所须。普行六度，遍种八福，一念善因，能感二报。一者花报：在人天中感受快乐。二者果报：成佛作祖。佛在《华严经》中教诲我们应如是发愿，如是行持。所谓：“菩萨乃至施与畜生之食，一摶一粒，咸作是愿：当令此等，舍畜生道，利益安乐，究竟解脱，永度苦海，永灭苦受，永除苦蕴，永断苦觉，苦聚苦行，苦因苦本，及诸苦处，愿彼众生，皆得舍离。菩萨如是，专心系念一切众生，以彼善根，而为上首，为其回向一切种智。”

    广修供养有三种含义。一供事供具多广：即要有外内密供养，或身语意的供养，供品要广大。二供养的对境数量多：即十方三世一切贤圣及众生。三供时长：即尽未来际恒作供养。

    通常说外物为外的供养，如衣服饮食宝物国城等；妻子儿女为内供；自身头目脑髓心肝肢节等是密供；弘法修持安住不可思议解脱境界，证悟心性，安住三摩地等是极密供养。外供众所周知，内供如佛因地为义成王子时舍王妃及儿女等，密供如《法华经》云：“又见菩萨，头目身体，欣乐施与，求佛智慧。”《法华经》中药王菩萨焚身供佛，佛赞叹说：“是真精进，是真供养。”所以为代众生受苦，为供养佛，为消除贪嗔烦恼，舍身焚身烧指燃香都是真供养。

    如大悲释迦导师过去世为求正法，剜身千孔，燃千盏油灯，只为听闻：“常者皆尽，高者必堕，会合有离，生者皆死。”一偈，忍受如此难忍痛苦煎烧，没有一丝一毫的悔恨心。并发下宏誓大愿，愿我将来成佛，以智慧光明照亮众生的心田，把他们从愚痴的黑暗中解脱出来。又如世尊为毗楞竭梨王时，为从劳差婆罗门处求得“一切皆无常，生者皆有苦，诸法空无生，实非我所有。”一偈而身钉千钉，为救度我等愚迷众生舍身求法。世尊过去世曾剥皮为纸，析骨为笔，用血为墨而书：“常当摄身行，而不杀盗淫，不两舌恶口，妄言及绮语。心不贪诸欲，无嗔恚毒想，舍离诸邪见，是为菩萨行。”还有跳入火坑、割肉喂鹰、舍身喂虎等感人肺腑、可歌可泣的事迹，都是真供养的典范。

    自古以来，印藏汉三地的高僧大德多有行持施身之法，或将自身施予众生食啖饮啜，或以身燃香供佛。宁玛巴祖师华智仁波切为度化虻蜂与蚊虫等，夏日常赤裸上身，任它们叮咬，以至身上血迹斑斑，亦毫不移动。现在色达县附近尚有华智施身石。对这位具大悲心，真实行菩萨道的大德，藏地人们经常称扬赞叹，对于他的这一事迹更是津津乐道。汉地古德也有很多行持这种供养的。如僧崕菩萨为代众生受苦，烧焚自手。智者大师的弟子净辩禅师在四十八日中烧身供养，请求智者大师久住世间教化众生。然而现在的有些人却口念佛号，肆意大杀苍蝇蚊子、虱子，对此应该有所反省！

    《楞严经》云：“我灭度后，其有比丘，发心决定，修三摩提，能于如来，形像之前，身燃一灯，烧一指节，及于身上燃一柱香。我说是人，无始宿债，一时酬毕，长揖世间，永脱诸漏。虽未即明无上觉路，是人于法，已决定心。”世人对财物及妻子儿女等执著稍轻，但对自身执著最大，所以若能供养自身，功德也超胜前者。所以《妙法莲华经》云：“若有发心，欲得阿耨多罗三藐三菩提，能燃手指，乃至足一指，供养佛塔，胜以国城妻子及三千大千国土，山林河池，诸珍宝物，而供养者。”所以真实发心清净，树广大志愿，心不追悔，不是如外道逼迫恼害五蕴之身，但为供养上师三宝，报答父母恩德，代众生受苦，而焚香燃指或背烧宝塔、身燃卍字，其诸功德经中明文昭彰，此属密供养。密宗中古沙里施身法也属此类。

    极密供养主要是法供养，这在长行文中广作宣说。归纳而言包括如法修行、利益众生、摄受众生、代众生受苦、精勤修积诸善根、不舍菩萨的殊胜事业、不舍弃菩提心七种。因为诸佛如来尊重法宝，诸佛如来皆从如说修行而出生，所以行法供养，则得成就供养如来，如是修行是真供养，其功德超胜物品供养无量无数倍。

    至于安住解脱境界三摩地及真如中供养的修法，密宗中有很多窍诀，此处不作宣说，有志者当如法而求。

    应强调的一点是，若有甚深智慧摄持，则仅献一花、燃一灯也能同时圆满内、外、密、极密的供养。如焚一香，从一香中出无量香，一时此香遍满虚空尽于法界，香中涌现所有庄严供具，香中幻现无量身，如普贤菩萨一样修十大愿王，遍作一切佛事，普熏一切众生令发善根，普施一切众生安乐。如颂云：“愿此香花云，遍满十方界，一一诸佛土，无量香庄严，具足菩萨道，成就如来香。”能供所供泯灭无形，但仍作广大供养，这样的供养是无上法供养。

    古德云：“万行之中，能净三业，皆名供养。”能行万行才是广修供养。如此大愿虽然不能真实行持或如量观修，但内心也要欢喜踊跃，对诸佛菩萨诚挚地发此大愿，并祈祷三宝放光加被迅速入此大愿。


皈敬礼赞上师三宝的必要

乙一、皈敬礼赞上师三宝的必要

    行文之前首先对上师三宝从内心深处作真诚而深切的皈敬礼赞。虽然礼敬很简单，但其中却蕴含着很多的深义。这并非故弄玄虚之语，因为稍稍涉猎过藏经的人都会很明确地知道，印度及汉地的祖师大德造论之前都有皈敬礼文，这是一个无可争议的事实。然而这个优良的传统现在很少有人继承，这也是末法时代的一种衰相。《楞伽经》、《佛地论》、《瑜伽师地论》等诸多经论各自从不同的角度说明了礼赞的功德及必要。在此归纳七点来说明。

    一、显示吉祥：上师三宝是一切世出世间的最胜第一吉祥，能令所造论典永久流传，吉祥成办自他二利，所以于最初作此顶礼。《成实论》中云：“三宝最吉祥，故我经初说。”。

    二、发生信心：最初赞叹礼敬三宝能令后来的听闻者对上师三宝生起信心，愿意随顺佛法，由此不生疑惑诽谤。

    三、忆念恩德：上师三宝赐予法身慧命的浩荡洪恩，纵然粉身碎骨也难以酬报，所以当如普贤菩萨遍十方刹土，尽未来际，以无尽身遍礼浩瀚的三宝三根本。阿难尊者也云：“将此身心奉尘刹，是则名为报佛恩。”

    四、尊奉礼仪：因为世间的臣子，凡有所作之前，也必须要启请君王与父亲，这样才符合礼仪。上师三宝的恩德远远超过君王与父亲，况佛弟子的感激敬畏心应该远远超过臣子，所以要阐扬正教，先应礼敬上师三宝才合仪式。

    五、表示有传承：要表明所阐述的内容不是分别臆造，都是依靠圣教正理、上师清净传承而作，用来教诲后人。佛陀彻证宇宙人生的真谛，无误揭示万法本性，历代祖师灯灯相续传薪不断，今遵清净法流的传承而造论，诚可信受。否则如外道以世智辩聪，依分别念任意杜撰，随便著书立说，令人无法信服。

    六、乞求加持护念消除障碍成办顺缘：佛意广大如虚空，法性深广犹大海。纵然如文殊、观音、地藏、弥勒、阿难、舍利弗、龙树、无著、世亲、马鸣等要宣说法义，还是恭敬顶礼，请求佛陀威神大力的加被，才能得以如法开显，更何况是一般凡夫呢？否则随顺自己的分别寻思，又不凭借可靠的教理作证明而贸然造论，乖违佛的密意，违背教法正理，则会瞎人天眼目，打开自他地狱之门，所以应精诚地礼敬启请加被，愿能契合佛的密意，随顺法性。再者末法时代，众生福报浅薄，法弱魔强，发清净心造论弘法，则障碍违缘一定很多，必须勇猛祈祷上师三宝本尊护法，祈求大慈悲覆护垂念，令障碍消灭，顺缘成办，所以礼赞。

    七、追随先圣造福自他：西天印度古圣先贤造论之前都要礼赞皈敬，大小乘的论师也都如此，今也理应效仿。再说上师三宝是最胜福田、功德大海，一礼一拜、一称一赞，都会获得无量福报，为自己和读者能在开卷之时就种下大福报，所以作此礼敬文。当然礼敬的意义极多，在此不一一繁述。


正行三大愿：恒顺众生

    丁二、恒顺众生

    颂曰：
    所有十方一切刹，广大清净妙庄严，
    众会围绕诸如来，悉在菩提树王下。
    十方所有诸众生，愿离忧患常安乐，
    获得甚深正法利，灭除烦恼尽无余。

    所有十方世界中的一切刹土，广大无边，地平如掌，清净光洁，微妙难喻，众宝所成，庄严无比，皆如西方极乐世界阿弥陀佛国土一般。在此清净的依报国土之中，无量人天大众周匝围绕，诸佛如来如须弥出于大海般显耀超特，巍然坐于菩提树严饰的金刚法座之上。随顺众生即是随顺如来，所以先当发随顺众生之大愿而严净国土、转妙法轮。十方如来因地发此随顺利益众生之心，所以感得果位时依正二报悉皆清净庄严，我也应以此为目标而努力。十方中所有胎卵湿化、不同色身、不同形状、不同相貌、不同寿命、不同种姓、不同名号、不同心性、不同知见、不同意乐、不同威仪乃至天龙八部人非人等，无足乃至多足、有色无色、有想无想、非有想非无想的一切众生，愿他们都能远离一切忧患，常时安乐，获得甚深正法的解脱利益，依教证二种正法究竟无余灭除一切烦恼。

    诸佛因地及果位的行持，是应当仰慕与遵从的，且如此而行顺于真理，合乎法性，所以应全身心地效仿随学，以此能开正智慧明。众生的善恶行为，都离不开分别迷乱的妄心，背觉合尘，不识真源，所以不能随学。但以普贤行愿之力，见到众生因缘假合，全体空寂，如同幻相，如镜中影像非断非常，因此应当常怀同体大悲，观照众生，常以种种善巧方便令彼返本还源，回归自性之中。以大智慧观众生界无非佛界而随顺入佛境界，以大悲心见彼缘生不灭，因分别迷乱，生灭不息，执著深厚，所以教化令诸众生彻证无生，趋入无上解脱之道。由此普贤妙法，涤荡分别执著，觉悟真性，体认心、佛、众生三者本来无别，凡夫、圣者毫无殊异，则上合十方如来，下合六道含识。这样的见解，这样的用心观修，才能称为具足普贤行愿，得以现前智悲双融、不断不常之境界。

    所顺的众生：《大法鼓经》云：“一切法和合施设，名为众生。”经中宣说由四大五蕴十二处十八界十二因缘等和合假立，称为众生。《般若灯论》云：“谓有情者，数数生故，名为众生。”所谓有情于六道中，数数转生，所以称之为众生。《不增不减经》云：“此法身本性清净，但为恒沙烦恼所缠，随顺世间往来生死，即名众生。”法身被烦恼缠缚，不能显现，生死不断，称为众生。众生形形色色，千形万类，但可摄在四生九类之中，即在胎卵湿化的基础上加入有色、无色、有想、无想、非有想非无想共九类。四生在《俱舍论》中云：“倒心趣欲境，湿化染香处，天首上三横，地狱头归下。”即胎卵生的众生在中阴，生起颠倒心，趋往欲境，远见父母交合，男子贪母，女人贪父，由此入于胎卵中。湿化生的众生因贪染受生处的净秽气味，而随业受生。生天的头向上而上升，入地狱则头下脚上而受生，其它五类有色、无色、有想、无想、非有想非无想，依次由粗渐细。天人及地狱是化生，饿鬼有胎生化生两种，人与畜生则四生都有。饿鬼中的地行罗刹、夜叉及鬼子母都是胎生，其余空行类皆是化生。卵生人如毗舍佉母卵生的三十二个孩子。一般人皆是胎生，湿生如奈女从菴末罗树的湿气生。化生如劫初的人从光音天下生人间，还有如莲花生大师从莲花之中化现而生等。

    此处言恒顺众生者，谓尽法界虚空界十方刹海所有差别种类众生。如何随顺：对如是等类的所有众生，我都随彼所好，恭敬承侍，种种供养，就象恭敬父母，承侍师长、阿罗汉乃至诸佛如来一样，平等无有差别。被病苦所缚的，作他的良医。迷失方向、错走道路的，给他指明道路。处在黑暗中的，施以光明。贫穷困难的让他得到珍宝伏藏，行此种种平等饶益一切众生。《大乘本生心地观经》中说：「父亲有慈爱之恩，母亲有悲愍之恩。父母抚养的恩德比须弥山还高，较大地更重。若忘恩负义，违逆不顺，令母亲怨恨生起恶念，此力量极强超过暴风，子女因此必遭堕落。以百千种上妙饮食资具供养一百个五通仙人，一百个净行者，一百个善友，不如以微少物品供养父母所获得的功德。」《涅槃经》中也说供养父母得到无量的福报。

    为什么要随顺众生？菩萨若能随顺众生，就是供养诸佛。若尊重承侍众生，则如同尊重承侍诸佛如来。能让众生欢喜则诸佛欢喜。

    顺生即是顺佛的密意如何理解呢？《华严经·出现品》云：“佛子，譬如大海，普能印现四天下中一切众生色身形像。是故其说为大海。诸佛菩提亦复如是，普现一切众生心念根性欲乐而无所现。”海即是如来，像即众生。应知海中之像也同海水具有咸湿之性，也具有不容死尸等十种功德，所以海像无别，若顺像即顺海。普观一切众生皆具如来智慧德相，如此观者名随顺众生。

    诸佛以大悲为体性，若不顺众生，不合乎佛体，所以佛不欢喜，长行文中云：“诸佛如来以大悲心而为体故，因于众生而起大悲，因于大悲而起菩提心，因菩提心成等正觉。”月称菩萨的《入中论》可为此做极好的注脚：“悲心于佛广大果，初犹种子长如水，长时受用若成熟，故我先赞大悲心。”大悲心与般若智相辅相成才能成就无上菩提，佛以大悲的种子出生具有大悲大愿大智的菩提果。诸佛如来在因地观见众生，恒处生死，六道轮回，造诸恶因，受诸苦楚，如是生起愍念悲伤，如果没有无边的苦难众生作为对境，则于内心无法生起大悲心，由此也无法发起菩提心，从而也不能成就无上正等正觉的佛陀，所以菩萨因为众生而起大悲。大悲是万行的先导，如《理趣六波罗蜜经》云：“佛告慈氏，菩萨摩诃萨修行静虑波罗蜜多，应当修习大悲无量，为此大悲于诸善业而为导首。譬如命根，于出入息而为其先，轮王七宝为先，大乘万行大悲为先。譬如长者，唯有一子，父母怜念徹于骨髓，菩萨大悲亦复如是。于诸有情，住于极爱一子之地。又此大悲能作方便，成办一切助菩提法故。又此大悲能悟无师自然之智故。又此大悲能除一切自心热恼，随顺有情，为饶益故。是故如来以此为体。”《行愿品》长行文云：“菩萨若能随顺众生，则为随顺供养诸佛，若于众生尊重承事，则为尊重承事如来，若令众生生欢喜者，则令一切如来欢喜，何以故？诸佛如来，以大悲心而为体故，因于众生，而起大悲，因于大悲，而生菩提心，因生菩提心，成等正觉。譬如旷野，沙碛之中，有大树王，若根得水，枝叶花果，悉皆繁茂。生死旷野，菩提树王，亦复如是。一切众生而为树根，诸佛菩萨，而为花果，以大悲水饶益众生，则能成就诸佛菩萨智慧花果。何以故？若诸菩萨，以大悲水饶益众生，则能成就阿耨多罗三藐三菩提故。是故菩提，属于众生，若无众生，一切菩萨，终不能成无上正觉。善男子，汝于此义，应如是解，以于众生心平等故，则能成就圆满大悲，以大悲心随众生故，则能成就供养如来。”

    众生久远生死无依无怙如处旷野，在此生死旷野之中生长着佛菩提大树王，智慧禅定犹如枝叶，菩萨随学喻如树花，诸佛证悟称之为果。一切众生作为树根，大慈悲心作为水，水滋润浇灌树根，则花果繁茂。众生虽具清净本觉之树根，然恒处生死旷野，烦恼沙石之中，不生枝长叶开花结果，所以诸佛菩萨以种种方便，令众生远离粗恶烦恼之沙石，安置于三宝最胜福田之中，广兴慈悲密云，遍降甘露法雨，滋润众生菩提树根，渐令繁茂，从而生长出诸佛菩萨智慧的花果。

    长行文中比喻看似简单，其实喻义极为深刻。一切诸佛皆从众生成就，众生有烦恼，如来具智慧，欲得一切智智宝，应于烦恼海中求觅。烦恼即菩提，生死即涅槃，但于众生心中菩提大树，以大悲水灌溉，以智慧禅定加以扶持，则菩萨及佛陀的花果自然会现前，若舍弃众生而想成就无上正觉无有是处。所以经云：“是故菩提属于众生，若无众生，一切菩萨终不能成无上正觉。”

    我们在修行时，若攀缘妄想则是众生，智慧禅定观照妄念本空，契合觉性即为成佛。内现刹那生灭念念不息的心，任彼纷驰，即为众生。但若随顺观照，则现真性，智慧显发，菩提现前，是名随顺众生也是尊重供养如来。

    在此学习普贤菩萨随顺众生的大愿行，实为大乘行者最重要的修行法要，由此随顺众生的大愿行才能使菩提心，真实生起，已经生起的令其稳固增长，于此大乘行者始能念念不忘众生，诚如长行所云：“虚空界尽，众生业尽，众生烦恼尽，我此随顺无有穷尽。念念相续无有间断，身语意业无有疲厌。”由此行者的一切行为都由为度众生愿成佛的菩提心摄持，心量扩展犹如虚空，从而逐渐消融无始劫来坚固难除的人我执、法我执，步入无上菩提。


回向极乐愿：往生净土愿

    戊四、回向极乐愿分二：往生净土愿；蒙佛授记愿。

    愿我临欲命终时，尽除一切诸障碍，
    面见彼佛阿弥陀，即得往生安乐刹。
    我既往生彼国已，现前成就此大愿，
    一切圆满尽无余，利乐一切众生界。

    以上普贤菩萨发了以十大愿王为主的无量阿僧祇大愿，但能疾速成就现前如上大愿的最胜第一方便即是发愿往生西方极乐世界。所以普贤菩萨以身作则，发愿往生极乐世界，因此我们也应接受菩萨的劝导，求愿往生。普贤菩萨说：愿我临终舍寿之际，能无余遣除一切违缘障碍，亲自面见阿弥陀佛，蒙佛接引顺利往生西方极乐世界。我往生极乐世界之后，即刻现前圆满成就此无上大愿王，彼时功德自在能周遍利乐九界一切众生。

    长行文中云：“又复是人临命终时，最后刹那，一切诸根悉皆散坏，一切亲属悉皆舍离，一切威势悉皆退失。辅相大臣，宫城内外，象马车乘，珍宝伏藏，如是一切无复相随，唯此愿王不相舍离，于一切时引导其前，一刹那中即得往生极乐世界。”往生后得见佛及诸大菩萨，蒙佛授记，之后无量劫中度化众生。真是无独有偶，文殊菩萨也发了几乎与此完全相同的愿。《文殊师利发愿经》云：“愿我命终时，灭除诸障碍，面见阿弥陀，往生安乐刹。生彼佛国已，成满诸大愿，阿弥陀如来，现前授我记。”

    文殊妙吉祥化身的全知麦彭仁波切说：「无边无际的所知法之中，薄伽梵善逝佛果具有无与伦比的功德。能获得佛果之因无非是修无量诸菩萨行。具有无碍大悲愍念救拨一切众生痛苦的佛陀，以深智善加观察之后，发现此等刚强罪苦众生，智力浅陋，难以通达甚深广大圣道。然而能令此等安乐、无难、无勤之中圆满一切普贤行愿的殊胜方便即是发愿往生极乐世界。其原因是：往生彼土是仰仗阿弥陀佛的誓愿力、智慧力，所以仅仅具有信心、发愿就能往生。而且一经往生之后，在无须勤作之中自然获得信心等胜妙功德，住于不退地中，也将很快圆满普贤微妙之行。因此修习此法极为容易而且具有重要意义。」

    没有得大自在的修行人临终时确实非常关键，如果失去正念，则会铸成大错。彻悟禅师云：“生死关头，惟二种力。一者心绪多端，重处偏坠，此心力也。二者如人负债，强者先牵，此业力也。业力最大，心力尤大。以业无自性，全依于心，心能造业，亦能转业。故业力惟强，心力惟重，乃能牵生。若以重心而修净业，净业则强，心重业强，惟西方是趣，则他是报终命尽，必经西方，不生余处矣。”但如果以殷重心，造极重十恶力，则临终心重业强，一定牵往三恶趣中。如一堵墙或一棵树，要知它最终会倒向何方，就要看它平时倾向于哪一方，则最后一定倒在那一方。临终的障碍虽有多种，但最根本的就是忘失正念，退失信心，尤其是贪恋父母妻子儿女、兄弟朋友、功名富贵、文章诗赋、道术技艺、衣服饮食、房屋田园、林泉花卉、珍宝玩物等等。如果有一丝一毫的贪恋耽著，则成违缘障碍，不得往生。

    杨次公云：“爱不重不生娑婆，念不一不生极乐。”因此作为求解脱求往生的行人，对娑婆世界的贪爱，应力求日日淡薄减轻，务使解脱心、往生净土心越来越深切强烈，则临终不会因为亲人的哭泣哀号而生贪爱，也不会因为丰富的家产财物而恋恋难舍，平时能看破，临终自然会放下自在。凡人临命终时想往生西方极乐世界，就该作好充分的心理准备，不应贪生怕死。时常思维：现在我这个身体，由三十六种不净物所构成，种种痛苦日夜不停地折腾，现在若能舍弃这个臭皮囊，往生净土，莲花化身，受无量快乐，见佛闻法，远离痛苦得到解脱。如脱去臭秽破烂的衣服，换上华丽舒服的新衣，高兴都来不及，为什么却忧愁害怕呢？故应放下身心，莫生贪著。如果有疾病，不管轻重，都应思维死亡无常，死期不定，以念佛心、求生净土心安然等待迎接死亡的到来。

    如果临终产生三种疑惑心也会成为往生的障碍，所以应该遣除。所谓“三疑”慈照宗主在《净土十门》中说：「念佛人临命终时，如果有三种疑虑，便不能往生净土。第一、疑我生前所造的业非常重，修行的时间太短，恐怕不能往生。第二、疑我虽念弥陀，但现在有心愿还未了，以及尚有贪嗔痴爱没有息灭，恐怕不能往生。第三、疑我虽然念阿弥陀佛，临命终时，担心佛不来接引。有这三种疑虑就会构成障碍，失掉正念，致使不得往生。所以念佛的人切切要真实谛信佛经，不要生起疑惑。经中说念佛一声，灭八十亿劫生死重罪。上至一心不乱，下至十念都会成功往生，蒙佛接引往生九品莲花之中，辞别五浊恶世。如果能够心心不昧，念念无差，则永断疑情，决定往生无疑。」临终善恶心念的力量都很强，因此千万要断除邪见恶念，再再增上善心正念。古德云：“一切众生临终之时，刀风解形，死苦来逼，生大怖畏。是故遇善知识，发大勇猛，心心相续，十念即是增上善根，便得往生。又如有人对敌破阵，一形之力一时用尽，其十念之善亦如是也。又若人临终时，生一念邪见增上恶心，则能倾三界之福，即入恶道也。”印光大师归纳了临终三条要点，大家都应遵守奉行。三要即：“第一，善巧开导安慰，令生正信。第二，大家换班念佛，以助净念。第三，切戒搬动哭泣，以防误事。果能依此三法以行，决定可以消除宿业，增长净因，蒙佛接引，往生西方。”

    法王如意宝说：“《行愿品》中的临欲命终指外气已断尽，内气尚未断尽之时，此时愿蒙阿弥陀佛与诸圣众，现在行者面前，放光加持赐予安慰，消除一切障碍，使行者身无病苦，心不贪恋，意不颠倒，如入禅定，安祥愉悦，不经中阴，被佛接迎刹那间化生到极乐世界胜莲花中，即刻花开见佛，聆听法音，顿悟无生，成就辩才神通陀罗尼，三身四智五眼六通等一切功德，得大解脱，获大自在，尽未来际，遍十方一切刹，任运度化无边众生。如果于此时不能往生入中阴境界，见阎罗王受彼审问，经历中阴种种险境，身心不得自在，往生还是很困难，所以修行者或助念之人，在此时应特别注意，提起正念，力求此时顺利往生。”


回向七支功德

丙二、回向七支功德

    回向除狭劣障，成就广大善根。

    颂曰：
    所有礼赞供养福，请佛住世转法轮，
    随喜忏悔诸善根，回向众生及佛道。

    以上随普贤菩萨修习礼敬诸佛，称赞如来，广修供养，请佛住世，请转法轮，随喜功德，忏悔业障，所出生的无量无边善根功德，悉皆摄集，以广大心，远离三门执著，回向法界虚空界中的一切六道四生，愿诸众生离苦得乐并以此善根趋向菩提，同时回向自己速速得到一切智智的广大佛果。

    回向与发愿有一点差别，回向一定包含了发愿，但发愿却不一定包含回向，回向则先前必有所修的善根，然后再以发愿来摄持导引此善根令其成熟增长扩大。发愿不一定要有善根，也可以自己发愿立誓。回向有正确的回向与偏邪的回向，正确回向即以殊胜愿文回向自他二利。邪回向即以邪恶之愿回向，成为自他痛苦之因。

    回向有很大的功德和必要，回向可使善根向着既定的方向成熟，来成办事业，而且虽然所作善根很微小，但以广大清净的菩提心摄持回向，则此善根乃至现前菩提之间，只会增长广大，而不会遗失。《入行论》中云：“菩提心树恒生果。”又如《慧海请问经》中所说：「犹如一滴水入于大海之中，乃至大海未干之间，此一滴也不会干涸。同样将善根回向无上菩提，乃至未获得广大菩提果之间也不会耗尽。」

    以此广大回向可以消除坚固我执，众生认为我修善根，此善行功德应归属于自身，由于自私自利，不愿将善根功德布施他人，这样因自私自利的狭隘心，所以善根只能成熟小果。现在不求自己得安乐，但愿众生得离苦，将自己善根毫不悭吝地回向众生，相反自己得到的善根反而会更加增上广大。正如法王如意宝于《胜利道歌》中所云：“究竟虽欲广利自，暂时利他乃窍诀。”放下自利只为天下黎民百姓谋幸福的人，会登上高高的尊胜之位。心中所想、行动所为皆为一切众生离苦得乐，才能成就最极尊贵、功德无边的佛果。众生无始以来皆为自己，现在仍不免为轮回中的风尘客。故行持大乘法要者当以广大回向对治我执心、悭吝心、邪恶心、狭隘心，增长清净心、广大心、慈悲心、无我心。善根若不回向，凡夫人正知正念的心识一旦稍离正堂，则被眼耳鼻舌身意的六贼劫夺善根，或被嗔心大火烧毁善根，所以依回向这一殊胜的法要将善根储存在坚固的功德银行中，则盗贼不会抢去，水火也无法损坏。

    回向又分有相与无相两种：有相即有分别执著心而作的回向；无相回向指泯灭能所安住于三轮体空中作殊胜回向，如此善根直接成为无漏解脱之因，其功德也远远超胜有相回向。

    有人说我还是不知如何回向，那么华智仁波切及法王如意宝等大德教我们一个最简便也是最殊胜的回向：干脆不加自己的过多分别作意，观想三世一切诸佛菩萨如何为成办自他二利事业而回向善根，我也如此回向。

    以上解释了七大愿王，及修持七大行愿所生善根回向的修法。按清凉国师的观点：前七愿只是行愿，后三愿既是愿又是回向，常随佛学是发愿、回向成办自利佛陀果位，恒顺众生则是发愿、回向令众生离苦得乐的利他事业，普皆回向则是回向的正体。所以这一颂是承上启下的过渡文。但藏地分科判时略有不同，将全文分为前行七支供、正行发愿与后行回向。七支供即将礼敬诸佛与称赞如来合而为一，礼敬诸佛，分为身礼敬，口礼敬，意礼敬。其它广修供养及请佛住世都没有不同之处。此颂则判为回向支，以此前行七支，来净治自心，令心清净广大，成为大法器，然后才能发起广大愿行，普作回向，否则心力狭劣，不能胜任。在解释的方法上两者没什么差别。


显示众行利益：获五果功德：获等流果功德

戊二、获等流果功德

    此人善得胜寿命，此人善来人中生，
    此人不久当成就，如彼普贤菩萨行。

    寿命与人生有胜有劣，有恶有善。若一生之中放纵身心，唯恶是造，则不是胜寿命，也不是有益的人生。但由于修习听闻普贤愿王所感等流之果，生生世世健康长寿，而且能奉行普贤菩萨殊胜妙行，于不久的将来获得与彼大士同等的成就。圭峰禅师说：「依普贤行愿修行之人，随各自前世所造业，无论寿命长短，尽此一报之身，修习胜行，不空度时光，称为胜寿命。反之若肆意造十不善业，身心不能调伏。业报所感纵然能历劫住于世间，反而使恶因更加广大，苦果无有穷尽，灭尽善业，增上恶法，就不是胜寿命。」《法句经》中云：“人寿百岁悭贪逾盛，不如一日割舍财色。人寿百岁乐不持戒，不如一日净心守戒。人寿百岁多忿不忍，不如一日含喜不嗔。人寿百岁怠惰不勤，不如一日策励身心。人寿百岁拙御身心，不如一日巧便运致。人寿百岁常怀怯弱，不如一日勇猛慧力。人寿百岁不起善愿，不如一日发行四弘。人寿百岁不生一智，不如一日慧性聪利。”即纵活百年，大造恶业，是恶劣人生是劣寿命。所以当然不如一日修持的胜寿命、暇满人生殊胜。


别发十大愿：利益愿：获功德藏愿

    庚一、获功德藏愿

    我于一切诸有中，所修福智恒无尽，
    定慧方便及解脱，获诸无尽功德藏。

    菩萨为了利益众生，所以乘悲智双融之大船，深入到漫无边际的三有轮回大海之中，将诸众生一一接引度化，送至解脱彼岸。福德是安乐的因，智慧是解脱的根本，所以在修道过程中不能偏于一方，要互相摄持才是正道。法界基的本性是明空双运，所以修道必福智双运，才能感得色法二身或福智二严的无上佛果。所以为了得到自他安乐，断除自他无明业惑的束缚，菩萨于一切时中，三门不住无记或放逸散乱之中，而是念念不断地修持、积累福智资粮。修习广大无边的定慧方便及解脱，因为具足广大无边的福智资粮，以定慧圆明为正因，善巧方便为助行，遇境触缘处处解脱无碍，所以成就取之不尽、用之不竭的功德宝藏，自利利他如意自在。

    清凉国师指出前三句是广大因，后一句是广大果。即因为恒修无尽的福智定慧方便解脱，所以获得无尽功德宝藏，因果诚然真实不虚。

    诸佛菩萨因地遍修一切功德，所以当其成就时，众生若见其身相，或闻其声音法句，乃至生一念信心等，都会获得殊胜安乐利益，所以诸佛菩萨是功德藏。清凉国师云：“谓暂见身，则必定佛法。暂闻音声，则得实智慧。才生净信，则永断烦恼。得如大药王树身，得如如意宝身，名功德藏。”大药树与如意宝都能拔除众生的痛苦，赐予有情安乐，诸佛菩萨功德身也是如此。如《华严经·出现品》云：“譬如雪山有药王树，名曰善见。若有见者，眼得清净。若有闻者，耳得清净。若有嗅者，鼻得清净。若有尝者，舌得清净。若有触者，身得清净。若有众生取彼地土，亦能为作除病利益。如来应正等觉无上药王，亦复如是，能作一切饶益众生。若有得见如来色身，眼得清净。若有得闻如来名号，耳得清净。若有得闻如来戒香，鼻得清净。若有得触如来光者，身得清净，究竟获得无上法身。若有于如来生忆念者，则得念佛三昧清净。若有众生供养所经土地及塔庙者，亦具善根，灭除一切诸烦恼患，得贤圣乐。佛子，我今告汝，设有众生见闻于佛，业障缠覆，不生信乐，亦种善根，无空过者，乃至究竟入于涅槃也。”《出现品》中又将诸佛之如意宝身作了详细的介绍。经云：“复次，佛子，譬如大海，有大如意摩尼宝王，名一切世间庄严藏。具足成就百万功德，随所住处，令诸众生灾患消除，所愿满足。然此如意摩尼宝王，非少福众生所能得见。如来身如意宝王亦复如是，名为能令一切众生皆悉欢喜。若有见身闻名赞德，悉令永离生死苦患。假使一切世界，一切众生，一时等心欲见如来，悉令得见。”经中明说诸佛如来如大药王及摩尼如意宝王，悉由无量功德所庄严，因此菩萨当广修一切善法，成就如此功德之身。

    成就如是功德宝身，当于何处利益众生呢？下颂对此问题详细解答。


显示众行利益：获究竟果功德

丁二、获究竟果功德

    速诣菩提大树王，坐已降伏诸魔众，
    成等正觉转法轮，普利一切诸含识。

    因为修习如此微妙无上大法，所以超胜下乘不可计数，因此能速疾到菩提树王所庄严的金刚座上，得诸佛现身安慰灌顶，以金刚喻智无余摧灭一切微细障碍。降伏八万四千魔众，现前成就无上正等正觉的佛果，成佛之后应梵天帝释劝请，吹大法螺，击大法鼓，震大法雷，澍大法雨，树大法幢，普遍任运利益一切众生。

    诸佛示现化身，临成等正觉之时，都坐菩提树下。如我释迦导师因地中，苦行六年，了知如此修法不能得究竟果。思维过去一切诸佛皆到菩提树下，降伏魔军，才现前正觉。因此菩萨往诣具备十六功德地之菩提树下。为了降伏一切魔怨，以大人相，四方出行，并振动大地，出大音声，足下放大光明，随足所行之处，都出生莲花。安住正念趋向菩提树，直视野而行，具无量威仪。风天雨天洒扫道场，雨天又散无量香花遍覆大地。三千大千世界里的所有大小诸树全部低垂向着菩提树，大小诸山也低垂向着菩提树。天花缤纷而下，七宝栏楯周匝围绕，众宝幡盖处处庄严，金绳交错，其上悬挂宝铎明珠，琉璃点缀其间，行树之间有七宝池，金沙布地，香水盈满，四种妙花芬芳香郁。迦陵频伽鸟出和雅音。诸天彩女散花洒香，演奏伎乐歌舞，称扬赞叹菩萨。菩萨身放无量光明，出无量微妙音声，令无边众生皆得安乐，远离苦恼。菩萨以吉祥草敷金刚座，结跏趺坐，立下伟大的誓愿，若不成佛终不起座。

    后思维欲界波旬最尊最胜，应把他召来降伏。从眉间白毫中放光照三千界，波旬碰到此光，梦到三十二种不吉祥事，醒来心中惊怪，召集一切属下说：“我听到空中声音告诉我悉达多太子苦行圆满，必成菩提，要空掉我的境界，如何才能摧伏他呢？”众属下共同劝谏，他更加恼羞成怒。随即召集魔女，诱惑菩萨，终被菩萨降伏，之后散花供养菩萨返回天宫。魔王即亲自率领千形百类极为丑陋凶恶的魔兵夜叉等，一时间黑云密布，雷电霹雳交加。有的手举大山，有的口吐毒蛇，有的身出猛火，飞沙走石、拉弓射箭、持枪挥剑、魔势炎炎不可一世，极为恐怖。菩萨以大慈定力，砂石箭镞全部变成妙花。恶龙毒气变成香气。无量魔军溃败无术，波旬持剑想亲自害菩萨，被魔子抱住，劝谏千万别造罪咎。菩提树神、无量天人呵责骂詈波旬，赞叹菩萨功德。佛告波旬：“我为断除你的怨恨仇隙，灭除你的恶业，消灭你的嫉妒，你应该回心转意，生大欢喜，你以微小善根就得到天人身体，我无量劫修习圣道，肯定要成正等正觉。”当时地神从地涌出为作证明，并说：“我此地是金刚脐，其它地方都要转动，此处不动。”说完之后大千世界六种震动，发出巨大音声，出现十八相。魔众见此身心迷乱，七纵八横狼狈不堪。波旬惊慌恐怖，昏倒在地。有一地神用水洒面令他苏醒，并告诉他快跑，这里有兵众要来杀你，此时波旬仓皇溜之，其余诸魔退散而去。降魔圆满之后，睹明星成正觉，现法报化身以无碍语转妙法轮，普度恒沙有情，悉皆成佛。愿我以愿王力如佛无异。


显示众行利益：获五果功德：获离系果功德

戊三、获离系果功德

    往昔由无智慧力，所造极恶五无间，
    诵此普贤大愿王，一念速疾皆消灭。

    往昔因为无有智慧力，善恶不分，所以造下如五无间罪等一切如海极恶罪业。但由于诵此普贤大愿王的强大威力，能在一念之间将如此重罪，悉皆一时速疾消灭无余。

    长行文云：“速能除灭五无间业，所有世间身心等病，种种苦恼，乃至佛刹极微尘数一切恶业悉得消除。”无间有四种含义。一受生无间：命终不经中阴直入地狱。二寿命无间：即在地狱中时中间寿命不会夭折。三身量无间：身体遍满整个地狱。四受苦无间：痛苦没有刹那止息的机会。五无间即五种罪业，即杀父、杀母、杀阿罗汗、出佛身血、破和合僧。一旦造下就会感召如上苦报。

    有智慧才能远离系缚，断尽一切结使束缚称为离系果。《瑜伽师地论》中云：“以道灭惑名离系果。”依此普贤行愿妙法断灭一切惑业、诸苦的系缚，从中解脱，犹如日月远离罗睺的障难而自由运行。


显示众行利益：获五果功德：获士用果功德

戊五、获士用果功德

    诸魔外道不能摧，堪为三界所应供。

    由修习普贤行愿的智慧威力，降伏烦恼魔、蕴魔、死魔、天魔等一切魔怨。以神通力、智慧力、威德力、无碍辩才庄严自身，如大地、如须弥，诸魔障外道丝毫不能倾动摧伏。因功德巍巍所以成为人天诸众恭敬供养之处。


显示众行利益：获五果功德：获异熟果功德

戊四、获异熟果功德

    族姓种类及容色，相好智慧咸圆满。

    《瑜伽师地论》云：“诸不善法于恶趣受异熟果。善有漏法于善趣受异熟果。”同样修普贤愿王于善趣中感生在豪门贵族、优良种类之中。而且容色妙好，如彼普贤菩萨三十二相八十种随好，人中最为第一。不但如此而且智慧也深广圆满。

    长行文云：“此善男子，善得人身，圆满普贤所有功德，不久当如普贤菩萨，速得成就微妙色身，具三十二大丈夫相。”复云：“若生人天，所在之处，常居胜族。应该明白三十二相八十随好，都是以十善业为因，百种福报所庄严，才能得以成就。不修福报不但不能感得相好，而且所生之处，环境也不优美。经中说如果修往生法门的人不修福报，则纵然往生，所见依报也不庄严。

    三十二相各有不同的因。《涅槃经》云：“若有菩萨摩诃萨，持戒不动，施心不移，安住实语，如须弥山，以是业缘，得足下平如奁底相。若于父母师长，乃至畜生，以如法财供养供给，以是业缘得足下千辐轮相。若不杀不盗，于父母师长，常生欢喜，以是业缘得成三相，一手指纤长，二足跟长，三身方直等。若修四摄法，摄取有情，得网缦指，如白鹅王。父母师长若疾病时，自手洗拭捉持按摩，得手足柔软。若持戒闻法惠施无厌，得二相，一节踝臃满，二身毛上靡。若专心听法，演说正教，得鹿王腨相。于诸有情不生害心，饮食知足，常乐惠施，瞻病给药，得身圆满，如尼律陀树，立手过膝，顶有肉髻，及无见顶。见怖畏者，为作救护，见裸跣者，施与衣服，得马阴藏相。来近智者，远离愚人，善世间答，扫治行路，得皮肤细软，身毛右旋。若以衣服饮食卧具医药花香灯明施人，得身金色，常光照耀。若行施时，所珍之物，能舍不吝，不观福田及非福田，得七处满。于布施之时，心不生疑，得柔软声。若如法求财以用布施，得缺骨平满，狮子上身，臂肘臃纤。远离两舌恶口恚心，得四十齿齐密。于诸众生修大慈悲，得二牙相。常作是愿，有来求者，随意给与，得狮子颊。随诸所须之食，悉皆与之，得味中上味。自修十善，兼化人，得广长舌。不讼彼短，不谤正法，得梵音声。见彼怨憎，生于喜心，得目绀色。不隐他德，称扬其善，得白毫相。”如上一一个别修习才能感得三十二相，今以普贤行愿一法即能成就三十二相，因此敬请奋力修习此不思议愿王。


显示众行利益：获五果功德：获增上果功德

戊一、获增上果功德

    即常远离恶知识，永离一切诸恶道，
    速见如来无量光，具此普贤最胜愿。

    依听闻此愿王而生信的加持，则可于世世生生之中，远离一切恶知识，永离一切三恶趣险，速疾得见西方极乐世界无量光佛。以佛加被很快也具足行持此普贤最胜愿王。

    长行文云：“悉能破坏一切恶趣，悉能远离一切恶友，悉能制伏一切外道。”恶知识过患极大，如《涅槃经》云：“菩萨摩诃萨观于恶象及恶知识，等无有二。何以故？俱坏身故。菩萨摩诃萨于恶象等心无恐怖，于恶知识生畏惧心。何以故？是恶象等唯能坏身，不能坏心。恶知识者二俱坏故。是恶象等唯坏一身，恶知识者坏无量善身，无量善心。是恶象等唯能破坏不净臭身。恶知识者能坏净身及以净心。是恶象等能坏肉身。恶知识者坏于法身。为恶象等杀，不至三恶趣，为恶友杀，至三恶趣。是恶象等但为身怨，恶知识者为善法怨。”所以不但要发愿而且现在都要如离火坑、如避洪水、如躲怨贼般地远离恶知识。


大方广佛华严经·入不思议解脱境界普贤行愿品略释愿海舟

    大方广佛华严经·入不思议解脱境界普贤行愿品
    略释愿海舟
    益西彭措堪布 著

    梵语云：摩訶尾没没馱巘拏賀素怛·
            阿進底也咄尾目乞义尾灑也三满多跋捺囉罗左哩鉢囉抳馱曩鉢囉吠捨跋哩嚩多
    汉语云：大方广佛华严经
            入不思议解脱境界普贤行愿品

        目　　 录

    大方广佛华严经入不思议解脱境界普贤行愿品
    篇 首 寄 语
    解释此经分三科判：初善、中善、后善。
    甲一、初善序分分三：皈敬礼赞上师的必要；梵汉对照；释题。
      乙一、皈敬礼赞上师三宝的必要
      乙二、梵汉对照
      乙三、释题
    甲二、中善正宗分：十大愿王
      乙一、十大愿王分四：前行七支行愿；回向七支功德；正行三大愿；总结无尽愿。
        丙一、前行七支行愿分七：礼敬诸佛；称赞如来；广修供养；
                                忏悔业障；随喜功德；请转法轮；请佛住世。
          丁一、礼敬诸佛
          丁二、称赞如来
          丁三、广修供养
          丁四、忏悔业障分二：事忏；理忏。
            戊一、事忏分二：总说；忏悔三障。
              己一、总说
              己二、忏悔三障分四：前行方便；忏悔烦恼障；忏悔业障；忏悔报障。
                庚一、前行方便
                庚二、忏悔烦恼障
                庚三、忏悔业障
                庚四、忏悔报障
            戊二、理忏
          丁五、随喜功德
          丁六、请转法轮
          丁七、请佛住世
        丙二、回向七支功德
        丙三、正行三大愿分三：常随佛学；恒顺众生；普皆回向。
          丁一、常随佛学
          丁二、恒顺众生
          丁三、普皆回向分四：别发十大愿；总结十大愿；随学二圣愿；回向极乐愿。
            戊一、别发十大愿分十：受持愿；修行二利愿；成熟众生愿；不离师友愿；供养愿；
                                  利益愿；转法轮愿；净土愿；承侍愿；成正觉愿。
              己一、受持愿分三：不忘宿命愿；出家持戒愿；转法轮愿。
                庚一、不忘宿命愿
                庚二、出家持戒愿
                庚三、转法轮愿
              己二、修行二利愿分五：修波罗蜜愿；不忘菩提心愿；
                                    消除障碍愿；成就妙行愿；自由无碍愿。
                庚一、修波罗蜜愿
                庚二、不忘失菩提心愿
                庚三、消除障碍愿
                庚四、成就妙行愿
                庚五、自由无碍愿
              己三、成熟众生愿
              己四、不离师友愿分二：不离同行道友愿；不离善知识愿。
                庚一、不离同行道友愿
                庚二、不离善知识愿
              己五、供养愿分二：财供养；法供养。
                庚一、财供养
                庚二、法供养
              己六、利益愿分二：获功德藏愿；遍入尘刹利益愿。
                庚一、获功德藏愿
                庚二：遍入尘刹利益愿
              己七、转法轮愿
              己八、净土愿
              己九、承侍愿
              己十、成正觉愿
            戊二、总结十大愿
            戊三、随学二圣愿分三：愿等普贤；愿等文殊；总结回向。
              己一、愿等普贤
              己二、愿等文殊
              己三、总结回向
            戊四、回向极乐愿分二：往生净土愿；蒙佛授记愿。
              己一、往生净土愿分二：净土的殊胜；净土修法。
                庚一、净土的殊胜
                庚二、净土修法分四：实相念佛；观像念佛；观想念佛；持名念佛。
                  辛一、实相念佛
                  辛二、观像念佛
                  辛三、观想念佛
                  辛四、持名念佛
              己二、蒙佛授记愿
        丙四、总结行愿无尽
    甲三、后善流通分分三：显示此经殊胜功德；劝请受持；总集回向。
      乙一、显示此经殊胜功德分二：校量闻经利益；显示众行利益。
        丙一、校量闻经利益
        丙二、显示众行利益分二：获五果功德；获究竟果功德。
          丁一、获五果功德分五：获增上果功德；获等流果功德；
                                获离系果功德；获异熟果功德；获士用果功德。
            戊一、获增上果功德
            戊二、获等流果功德
            戊三、获离系果功德
            戊四、获异熟果功德
            戊五、获士用果功德
          丁二、获究竟果功德
      乙二、劝请受持
      乙三、总集回向


校量闻经利益

丙一、校量闻经利益

    十方所有无边刹，庄严众宝供如来，
    最胜安乐施天人，经一切刹微尘劫。
    若人于此胜愿王，一经于耳能生信，
    求胜菩提心渴仰，获胜功德过于彼。

    用十方所有一切无量无边的刹土那么多最极庄严、最为珍贵的金银、珊瑚、赤珠、摩尼珠、砗磲、玛瑙七宝为主的一切众多宝物，供养一切诸佛如来。而且还把最胜安乐惠施天人为主的诸多众生。如此供养布施经历一切佛刹微尘数的时劫。在如此漫长的时间中，供养布施如此殊胜的供品，供养的对境又是如此殊胜的悲田与福田，自然所获功德大得不可思议。然而如果有人对此殊胜大愿王，偶然一经耳中，当即发出清净的信心，进一步愿依此渴望追求无上殊胜菩提果。那么此人依此所获功德即能完全超胜前者。长行文云：“若有善男子善女人，以满十方无量无边不可说不可说佛刹极微尘数，一切世界上妙七宝及诸天人最胜安乐。布施尔所一切世界所有众生。供养尔所一切世界诸佛菩萨，经尔所佛刹极微尘数劫相续不断，所得功德。若复有人闻此愿王，一经于耳，所有功德，百分不及一，千分不及一，乃至优波尼沙陀分亦不及一。”


回向极乐愿：往生净土愿：净土的殊胜

    庚一、净土的殊胜

    纵观如来无量教法虽大小偏圆权实顿渐不同，但都可统摄于念佛法门之中。佛陀为一大事因缘出兴世间，无非指点众生认取自心佛性。所谓种种譬喻言辞，尘说刹说炽燃说都只为令众生入佛知见，现前法身常寂光土，此为究竟目的。所以如来开示出的无量方便都是念佛法门，或直念自心真如佛性，以六度万行，戒定慧三学来开发，令其显明。或虽知自心具有本觉佛性，但须仰仗已觉悟且具有大力量的他佛，以期感应道交，自他不二时，方知十方诸佛与我无别，自性弥陀，唯心净土，恒时不离分寸。因此可说一切法门都是念佛法门，不念自佛，即念他佛，或念自他不二佛。所以藕益大师云：“原夫诸佛悯念群迷，随机施化，虽归元无二，而方便多门。然方便之中，求其至直捷直圆顿者，则莫若念佛求生净土。”印光大师也说：“普被上中下根，统摄律教禅宗。如时雨之润物，若大海之纳川，偏圆顿渐一切法，无不从此法界流。大小权实一切行，无不还归此法界。不断惑业，得预补处。即此一生，圆满菩提。九界众生离是门，上不能圆成佛道。十方诸佛舍此法，下不能普利群萌。是以华严海众，尽遵十大愿王，法华一称，悉证诸法实相。”禅宗真歇了禅师云：“念佛法门，径路修行，正按大藏接上上根器，傍引中下之机。乃佛乃祖，在教在禅，皆修净业，同归一源。入得此门，无量法门，悉皆能入。”

    《华严经》中海云比丘告诉善财童子说：「佛法大海，深广无边，但我所知道的只有此念佛三昧，依此三昧得见一切诸佛菩萨以及庄严清净的佛刹，令众生远离颠倒妄想。」既然一切法门都是念佛，即念法报化三身佛，那么也就会往生在常寂光净土，实报庄严土，方便有余土，凡圣同居土四种净土之中，所以也可以说一切法门都是净土法门，这是毫不过分也不夸大的说法。而且末法时代净土法门在显宗中可以说是苦海中的慈航，暗夜中的明灯，依此法门，纵然烦恼无明不能断尽，也可仗佛慈力接引往生净土，横出三界。不断烦恼能出三界，在一般教理来说是根本不可能的，所以这是世尊彻底悲心流露，为末法众生开出的最胜第一方便。《像法决疑经》云：“本师灭度，正法五百年，持戒得坚固；像法一千年，坐禅得坚固；末法一万年，念佛得坚固。”又如《大集经》中云：“末法亿亿人修行，罕一得道。唯依念佛，得度生死。”

    文殊菩萨与观世音菩萨也教诫行人末法时代念佛法门最为殊胜。《高僧传》中记载法照大师面见文殊菩萨的请示足可证明。大师问：“末法时代的凡夫障垢很深，距离圣者已很遥远。善知识也渐渐变得陋劣，所以佛性无法开发令其显现。佛法浩瀚无涯，不知修行什么法门最为紧要？唯愿大圣慈悲开示断除我的疑网。”菩萨回答：“你现在修念佛法门，正是时候。一切修行法门，没有能超过念佛法门。供养三宝，福慧双修，这两种法门，是最直接紧要。为什么呢？我在过去的时劫中，由于观佛故，由于念佛故，由于供养故，现在得到一切种智。所以一切诸法，般若波罗蜜，甚深禅定乃至诸佛皆从念佛而生，由此可知念佛是诸法之王。你应当常念无上法王，勿使停息。”又问：“应当怎样念呢？”回答说：“此世界的西方国土中，有阿弥陀佛。他的愿力不可思议，你应当持念不要间断，命终之后，决定往生，永不退转。”唐朝的慧日法师朝印度，在观音像前，七天之中断食磕头礼拜，志诚祈请，观音在空中显现紫金身，长约一丈左右，坐宝莲花中，右手摩法师顶说：“你打算传法自利利他，应当劝化人们念佛诵经，发愿回向往生西方极乐世界阿弥陀佛净土。到彼国之后，即能见佛与我，得大利益。你应当了知，净土法门，胜过诸行。”

    净土念佛法门简便易行，快捷稳当。龙树菩萨在《十住毗婆沙论》中云：“佛法有无量门，如世间道，有难有易，陆道步行则苦，水道乘船则乐。菩萨道亦如是，或有勤精进，或有以信方便，易行疾至阿惟越致。若人欲疾至不退转地者，应以恭敬心，执持称名号。”此法门甚深广大，所以华严法身大士也发愿往生。《法华》、《宝积》、《大集》、《贤护》、《菩萨念佛三昧经》、《无量寿经》、《往生论》、《起信论》、《婆沙论》等千经万论处处指归。龙树、天亲、马鸣、慧远、智者、道绰、善导、永明、百丈、天如、憨山、紫柏等历代祖师再再激励劝发。

    如《那先经》中所说犹如小石若投水中马上沉底，虽是大石若放在船上也不会沉底。没有佛力摄持虽然很轻的业障也会沉于轮回大海，若有佛愿力摄持，虽然很重业力犹如大石也不会沉底。百丈禅师云：“修行以念佛为稳当。”所以我们应随佛语，响应历代祖师的号召，修此简便易行的稳当法门，念佛求生净土，圆满成就普贤无尽大愿妙行，尽未来际度化众生。《往生论》云：“欲游戏地狱门者，必生彼土，得无生已，还入生死，救苦众生，以此因缘，求生净土。”天如和尚说：「先圣有言：没有得到不退转位的菩萨，不得混迹于世俗中度化众生；未得无生法忍，须要恒常不离亲近佛陀，譬如婴儿常不离母，又如弱羽只能传枝。」

    《三昧海经》云：“所念之佛如出胎狮子王，喻佛果也。能念佛人，如在胎狮子王，喻佛子也。因果虽殊，威神相继，论其佛也，更何异焉。”念佛之人《无量寿经》中说是“人中芬陀利花，念佛的人是佛的第一弟子。”《阿弥陀经》中说：“闻经受持的人，皆得诸佛护念。”阿弥陀佛化身的善导大师在《观经四帖疏》中云：“若念佛者，即是人中好人，人中妙好人，人中上上人，人中稀有人，人中最胜人也。”《法华经》云：“若人散乱心，入于塔庙中，一称南无佛，皆共成佛道。”


回向极乐愿：往生净土愿：净土修法

    庚二、净土修法分四：实相念佛；观像念佛；观想念佛；持名念佛。

    辛一、实相念佛

    所谓实相就是诸佛不生不灭、甚深寂灭、远离戏论分别的现空大双运的真实面目，实相在经教中有两种：（一）毕竟空寂的无相实相；（二）远离戏论的无为法大光明的显现实相。虽然说有两种，但本体不二。所以修行人无论持名、观像、观想、参禅、习止观等，如果能心心不离真如实相，念念安住空寂般若实相，远离一切虚妄分别，断除迁流心识，到心行处灭，自心本性弥陀佛，十方诸佛微妙清净法身，常住真心，性净明观，全体显露，如此才能称为实相念佛。百千法门同归方寸之内，恒沙功德总在心源之中，最上乘的了义法以自心为根本，以佛知见，观自心性，清净觉照，永断无明，究竟解脱，这是十方如来最胜秘密心地法门，也是禅教律密的共同交点。

    《宗镜录》云：“何等名为诸法实相，所谓诸法毕竟空无所有。以是毕竟空无所有法念佛，诸想不生，空寂无性，灭诸觉观，是名实相念佛。”中峰禅师云：“此方即净土，净土即此方。我心即阿弥陀佛，阿弥陀佛即我心。”这就是唯心净土、自性弥陀的意义，即十方一切国土唯心所现，三世诸佛如来不离我心。具如此见解时，不能只执空理，废舍修行。因唯心净土、自性弥陀为分别障垢所蔽无法显现，所以急须念自心本具弥陀名号，求生唯心净土之中。正当念佛之时，西方依正在我心中，而且我心也入于西方依正之内。这正是华严因陀罗相互映摄之义。离开心无有外境，离开境也无有心，所以西方极乐世界及阿弥陀佛，本来就是自心，十万亿佛土之外的极乐，从来没离开当下一念。法界遍融遍摄，一念中具无量，虽重重无尽但心体空寂，所以念一尊阿弥陀佛，就能遍念一切诸佛。心就是佛，佛即是心，了知一切境唯心自体，了心即佛，念念不忘，时时相续，没有佛以外的心念佛，没有心以外的佛被心所念。虽念念不息，却是无念，因为能念空无自性，所念也空无自性，犹如虚空合与虚空，无能合所合，所以即念而离念，终日念而未尝念；又空性从来不离妙有的显现，所以在无念之中自念不息。

    万法皆是如如之性，心佛从来无二无别，虽自性空寂，但光明显现恒时不灭，就是无量光佛。虽光明不灭，当体自性空寂无生无灭，穷过去未来现在三世而不尽，即是无量寿佛。如此本性众生本具无欠无差，由持名使始觉与本觉融合无二，也就是指子母光明合二为一。此时众生与佛无有差殊，烦恼菩提、生死涅槃平等不二，以实相心念实相佛，以法界心念法界佛，一念契合实相一念即是佛，念念不离实相，念念是佛。如古德云：“一念相应一念佛，念念相应念念佛。”飞锡和尚在《念佛宝王三昧论》中云：“法界圆融体，作我一念心，我此念佛心，全体是法界。”

    如此修持境寂心空，心佛一如，念念绝待，念念圆融，圆满显发本来空性般若面目，顿时契合灵源妙理，则内外根身器界，一时透脱，此时妙体显露，亲见本来面目，方知西方无量寿，原是主人翁。由此证得三昧，百千法门一时全修，无量功德圆满具足，念佛法身，不离此心，成就正觉。虽悟无生忍，仍发愿往生安乐国得佛授记，然后圆满十大愿王，分身尘刹，返入娑婆，游戏地狱三恶趣中，拔济众生苦难，赐予无上安乐。

    净土法门为无上圆顿大教、第一方便，非空口乱说，也并非指黄叶为黄金，哄小孩止哭。净宗十二祖彻悟梦东禅师云：“一句弥陀，清净实相，绝议绝思，难名难状。一句弥陀圆融法界，觌体全真，交罗无碍。一句弥陀，大圆智镜，身土影含，重重掩映。一句弥陀空如来藏，万法未形，一真绝相。一句弥陀，开般若门，十虚万法，一口平吞。一句弥陀如镜照镜，宛转互含，重叠交映。一句弥陀似空合空，了无痕缝，却有西东。”十三祖印光大师云：“若论其法，必须当念佛时，即念返观，专注一境，毋使外驰，念念照管心源，心心契合佛体。返念自念，返观自观。务使全念即观，念外无观。全观即念，观外无念。观念虽同水乳，尚未鞫到根源。须向这一念南无阿弥陀佛上，重重体究切切提撕，越究越切，愈提愈亲，及至力极功纯，豁然和念脱落，证入无念无不念境界。所谓灵光独耀，迥脱根尘，体露真常。不拘文字，心性无染，本自圆成，但离妄念，即如如佛者，此之谓也，工夫至此念佛法得感应道交，正好著力。现在则未离娑婆，常预海会。临终则一登上品，顿证佛果。”《菩萨念佛三昧经》云：“正念诸法真如之相，是名念佛。”《大集念佛三昧经》云：“当知如是念佛三昧，则为总摄一切诸法。”佛在《文殊师利说般若经》中也广说念实相佛的方法。《大集经》云：“若人称念阿弥陀佛，号曰无上深妙禅，至心想像见佛时，即是不生不灭法。”所以念实相佛者于无所生之中决定往生。虽往生但不离自心净土，所以实无所去。即如彻悟禅师云：“生者决定生，去者实不去。”

    辛二、观像念佛

    指以标准佛像唐卡，经过开光加持，然后端坐像前，一一详细观看，之后闭目逐一观想，或先观顶髻或面容，或眉间，或胸中卍字，或莲花台，或一时全观明明清清。

    辛三、观想念佛

    按《观无量寿经》观想极乐世界依报与正报的清净庄严。《般舟三昧经》云：“念西方阿弥陀佛身真金色，三十二相，光明彻照，端正无比。一心观想，心念口称，念念不绝者。”如赞佛偈云：“阿弥陀佛身金色，相好光明无等伦，白毫宛转五须弥，绀目澄清似大海。光中化佛无数亿，化菩萨众亦无边，四十八愿度众生，九品咸令登彼岸。”即观无量寿佛身相光明，如百千亿夜摩天阎浮檀金色，佛身高六十万亿那由他恒河沙由旬。眉间白毫，右旋宛转如五须弥山。彼佛圆光如百亿三千大千世界。于圆光中有百万亿那由他恒沙化佛，一一化佛有众多无数化菩萨作为眷属。彼佛有八万四千相，一一相中，各有八万四千随形好，一一好中有八万四千光明，遍照十方世界念佛众生，摄持不舍。所以行人观想自坐宝莲花中，放清净光明，处于极乐世界庄严宝刹之中，面对阿弥陀佛，一心瞻仰佛身相好光明，祈求加持摄受，行住坐卧观想自己处于极乐世界之中。由于观见彼佛，即见十方一切诸佛，所以称为念佛三昧。作如此观想，称为观一切佛身，由于观佛身的缘故，也见佛心。佛心即是大慈大悲，以无缘慈，摄受一切众生。喇拉曲珠仁波切在《极乐愿文大疏》中说往生四因即明观福田、积资净障、发菩提心、发清净愿。仁波切依经论广泛宣说抉择观想修法极为殊胜。尤其念佛人于每天晚上临睡之前，依善导大师开示的窍诀来观想，能极快获得感应。观想自己处于极乐世界，面对阿弥陀佛，祈祷观想佛身，并念诵祈请：“弟子众等，现是生死凡夫，罪障深重，轮回六道，苦不可言。今遇知识，得闻弥陀名号，本愿功德。一心称念，求愿往生。愿佛慈悲不舍，哀怜摄受。弟子众等，不识佛身，相好光明，愿佛示现，令我得见，及见观音势至，诸菩萨众，彼世界中，清净庄严，光明妙相等，令我了了，得见阿弥陀佛。”诵此祈祷文，加持特别大，自古以来感应甚多，尤其会在梦中出现不同的征兆。

    辛四、持名念佛

    指在厌离心、欣求心、菩提心、深心、直心、信心、愿心、回向心的基础上执持名号，称为持名念佛。净宗十二祖彻悟禅师总结念佛法门的窍诀云：“一真为生死，发菩提心，是学道通途。二深信切愿，持佛名号，为净土正宗。三以摄心专注而念，为下手方便。四以折伏现行烦恼，为修心要务。五以坚持四重戒法，为入道根本。六以种种苦行，为修行助缘。七以一心不乱为净土归宿。八以种种灵瑞，为往生证验。此八种事，各宜通讲，修净业者，不可不知矣。”

    念佛法门虽有几种，但佛于诸多经中，马鸣、龙树、天亲于各自论中，历代祖师于浩瀚语录中，再再赞叹，指出持名最为容易方便，而且极为适合末法时代众生根基，能普摄上中下三种根机。藕益大师说能否往生，要看信愿之有无，品位高低全在行持的浅深上。文殊般若经》云：“众生愚钝，观不能解，但令念声相续，自得往生佛国。”《宝积经》云：“高声念佛，魔军退散。”飞锡和尚云：“浴大海者，已用百川。念佛名者，必成于三昧。亦犹清珠下于浊水，浊水不得不清。念佛投于乱心，乱心不得不佛。”《业报差别经》云：“高声念佛诵经，有十种功德。一能排睡眠。二天魔惊怖。三声遍十方。四三涂息苦。五外声不入。六令心不散。七勇猛精进。八诸佛欢喜。九三昧现前。十生于净土。”《大涅槃经》云：“佛告大王，假令开大库藏，一月之中布施一切众生，所得功德，不如有人称佛一口，不可校量。”

    所谓信者：即信自性弥陀唯心净土，若回向念佛必能往生。信释迦如来于千经中处处指归净土的金口诚言无有欺诳；信阿弥陀佛四十八愿，愿愿圆满成就，愿者定能往生；信六方恒河沙数诸佛出广长舌所宣准确无误，随诸佛教诲，下定决心往生，更无疑惑。深信纵然散乱念佛也会种下菩提种子，何况净念相续岂能不生净土。深信今日净土及莲池海会清净大众，都是从念佛三昧之因而现前此妙果，加之信事、信理，是名六信，包罗一切信门。而且佛亲自授记龙树菩萨往生极乐世界，马鸣、天亲等也发愿往生，历代祖师圣贤往生的公案班班列列。

    既能深信，一定会发厌离娑婆、欣求净土之往生愿。既有信心之鞭的策励，愿力之牛牵引，自然会发起执持名号的妙行。故于身口意一切善业悉能回向净土，念念不离西方，时时不忘弥陀。广行六度万行皆为净业，遍修无量功德福报无非净土资粮，一切时中无有他愿他念，唯愿生净土念弥陀。深知三界无安犹如火宅，众苦充满，甚可怖畏，轮回一切都是烦恼痛苦之因，如梦、幻、泡、影、过眼云烟，身是假借暂住的客舍，心是虚浮漂泊的旅客，一切财富家资都是暂时拥有，应看破轮回的幻影。身处可怕的深渊，当如出牢狱，如出粪坑，应时刻心怀惊惧，渴求出离。所以立即放下娑婆中一切的生死活计，痛切地提起欣求净土的信愿，早日登上弥陀大愿之船，渡过生死苦海，登上解脱安乐的净地乐土。

    古人警诫云：“不结良因与善缘，苦贪名利日忧煎，岂知住世金银宝，借汝权看数十年。爱欲牵缠没了期，日生烦恼镇相随，官中囹圄犹存赦，家业拘牵没赦时。”贪著家业，爱恋亲人，永远没有解脱之期。此身死后四大散乱各归其所，眼耳鼻舌身意六贼都消散无踪，即生所造善恶业所感苦乐果由主人翁感受，所以现在不要掩耳盗铃自欺欺人。末法时代想依自力解脱生死简直比登天还难，应当乘着现在有限的时光，深信切愿回向往生净土。中峰禅师云：“西方故国早回还，人命无常呼吸间，有限光阴当爱惜，今生蹉过出头难。西方急急早修持，生死无常不可期，窗外日光弹指过，为人能有几多时。”业海茫茫，头出头没，刚一断气，奠了三杯茶，骷髅尚未烧尽，谁知神识又投胎去，铁人听了也会毛骨悚然。优昙大师云：“生死茫茫古渡头，弥陀拨动度人舟，夙生有分今生遇，快上船来归去休。”末世众生造恶者多，修善者少。则临终之时现在每一思及，真是住于地狱门边，只差一口气断，直迈而入。如来最胜方便应马上提起，才能幸免。所以古德白云警策词《望江南》云：“娑婆苦，身世一浮萍，蚊蚋睫中争小利。蜗牛角上窃虚名。一点气难平。人我盛，日夜长无明。地狱尽头成队人。西方无个背修行，空死复空生。娑婆苦，光影急如流，宠辱悲欢何日了，是非人我几时休，生死路悠悠。三界里，水面一浮沤，纵使英雄功盖世，只留白日掩荒丘。何似早回头。”

    在深信切愿的基础上要专心持佛名号，持念时要至诚恳切，全神贯注地用耳朵谛听，从一念乃至百千念，从口中出，从耳中入，心中历历分明。声缘于心，心缘于声，字字句句，心声相倚相托，如猫捕鼠，如鸡抱卵。念念之间都包含着厌离娑婆牢狱，欣求西方乐邦的欣厌心。如步步远离牢狱，步步趋向故乡，此欣厌二心都要痛切。句句佛号都凝聚着我愿往生，愿佛哀怜摄受加被护念垂手接引的意念。这样二六时中，行住坐卧忙闲都念，或端身正坐而念，或跪于佛前一心瞻仰佛像而念，或观想佛相好庄严而念，或忆念佛大悲、愿力、功德而念，或观海会圣众而念，或观刹土清净庄严而念，或大声念或金刚念或默念。持念窍诀历代祖师开示的极多极多。但以摄心口耳三轮，绵绵密密，历历明明，徐徐而念是主要的也是根本念佛。

    如上略微宣说净土法门的梗概。这里必须提醒往生的最大障碍，即造五无间罪及谤法恶业，二者一旦造下则无法往生。这是经中佛严厉告诫我们的忠言。净宗历代祖师、乔美仁波切、喇拉曲珠仁波切、全知麦彭仁波切、全知法王如意宝等大德再三警醒净业行者。

    全知法王如意宝乘大悲愿而来，以显密教理为依。他老人家认为，普度众生的最胜方便就是劝人念佛发愿往生净土。法王此生游化各地，常常聚集成千上万甚至几百万人，开极乐大法会，讲《弥陀经》、《行愿品》、《极乐愿文》，灌弥陀顶，鼎力弘扬此不可思议法门，法王之愿惟欲令此秽土三千界，遍种西方九品莲。所以我等也应至诚恳切地回向发愿，惟愿上师阿弥陀佛哀怜摄受，小小莲花能慈悲赐我一朵，临终哪怕往生下品也心满意足。

    在此本人也劝请诸位有缘人发愿往生，让我们同声共诵：“愿我临终无障碍，阿弥陀佛远相迎，观音甘露洒吾头，势至金台安我足。一刹那中离五浊，屈伸臂顷到莲池，莲花开后见慈尊，亲听法音可了了。闻已即悟无生忍，不违安养入娑婆，善知方便度众生，巧把尘劳为佛事。我愿如斯佛自知，毕竟当来得成就。”


别发十大愿：净土愿

    己八、净土愿

    我能深入于未来，尽一切劫为一念，
    三世所有一切劫，为一念际我皆入。
    我于一念见三世，所有一切人师子，
    亦常入佛境界中，如幻解脱及威力。

    愿我能深入到未来一切时间中，把所有三世一切时劫促于一念之中。于一念之中我能遍入三世一切的时劫，见到三世所有的一切人中师子诸佛如来，并能恒常入佛境界之中，获得如幻的解脱及威力。

    澄观大师认为这是菩萨发愿清净自己的刹土，树立法幢，安置能修行的众生。表面上看颂文似乎并没有净土的意思，但实际内容就是净土。下面略加剖析：净土即世界皎洁清净，可供居住名净土。或者远离障垢染污，清净功德依附其上称为净土。净土有四种，以下分别解释。常寂光净土又叫法性土，是法身佛所居之处。此土不生不灭，无相无为，远离垢染，常时明照，所以称为常寂光。受用土又分自受用和他受用，自受用即报身佛自己受用，他受用即地上菩萨所见的佛土。变化土即佛以大悲愿力为未登地菩萨声闻独觉及凡夫异生所变化的佛土，因为佛因地愿力及众生业力不同，所以净秽大小不同。如阿弥陀佛因地为无诤念转轮王，在宝藏佛前发菩提心，愿成就净土度化众生，所以现在果报成熟，西方极乐世界清净庄严。而释迦佛过去世作宝海仙人，由于愍念罪恶众生，所以发愿成就秽土，摄受浊恶刚强众生，所以成佛居在秽土。众生业力清净则转生净土，恶业缠缚则感生秽土，这就是心净土净、心垢土秽。

    时空都是真空法性，菩萨证悟时空无实如幻，趣入清净时、清净界，所以称为净土。初偈显示于三世一切时劫完全自在无碍，一念入三世，三世摄于一念。即《十地经》中所说：“一切国土入一国土，一国土入一切国土。”因时空悉同法性，自在无碍，一多互融，一多不二。众生的时间观念物质观念都是实有的，所以一不是多，多不是一。正因为一切显现法空无自性，所以什么都不成立之中，什么都可显现。如一个晚上的时间中，有人却能梦到一生或多生的事情，从出生、童年、青年、中年、老年所经历的世间及环境还有自己内心的感受在梦中都是真真切切的，毫不混乱。然而醒来时，只不过是几个小时的短暂时间而已。如古人云：“枕上片时春梦中，行尽江南数千里。”说明短时间中包含长的时间，长时间可以收摄在短时间中。能修习如此如幻解脱则三大阿僧祇劫的修行，可以摄在一念中圆满。这就是华严所谓“促多劫入于一念，延一念成多劫”的念劫圆融观点。

    二偈初二句指出清净自性。因为证得念劫圆融，现前无碍法性时，则心中远离一切障垢烦恼，心花开发遍耀十方无所不照。《华严经》云：“解脱长者告善财言：我若欲见安乐世界阿弥陀佛，随意即见，乃至所见十方诸佛，皆由自心。善男子，当知菩萨修诸佛法，净诸佛刹，积习妙行，调伏众生，发大誓愿，如是一切悉由自心，是故善男子，应以智慧明利自心。应以佛自在开发自心，应以佛平等广大自心，应以佛十力照察自心。”所以净冶自心则得以见到三世一切诸佛如来，如摩尼宝明净则能顿照远近一切外境。

    第三句“亦常入佛境界中”是净因：即以修六度万行庄严国土，转变心识成四种智慧，由智慧妙用显现诸佛如来刹土。（详见《维摩诘经》及《佛地论》）第四句指清净果：即获得如幻解脱威力的清净佛果。如上观点并非杜撰而是参照《十地经》及《华严经·行愿品别行钞》所作宣说。


忏悔业障：理忏

戊二、理忏

    如《维摩诘经》、《普贤观经》等经论中所示观罪性空寂，这样可以彻底消尽一切烦恼障及所知障。《普贤观经》云：“一切业障海，皆从妄想生，若欲忏悔者，端坐念实相。众罪如霜露，慧日能消除，是故应至心，勤忏六根罪。”即以般若智慧观察能产生诸罪的根源即此妄动之心，观彼从何而来，住于何处，最后去往何处。此心有何形状、颜色？大小如何？是在身内，还是在外境？如此遍寻此心如虚空不生不灭。即所谓“罪从心起将心忏，心若灭时罪亦亡，心亡罪灭两俱空，是则名为真忏悔。”理忏的力量极大，所以清凉国师云：“事忏除末，理忏拔根。”初学者事理交替不能偏废，上根则理事圆融，事忏不碍观空，理忏也不妨礼佛诵经念咒经行等。

    在一切忏悔仪轨之中，金刚萨埵百字明及心咒的观修最为殊胜。百字明咒在汉地《焰口施食》中叫作金刚百字咒。金刚萨埵的修法及依四力观修在《汇集经》、《金刚萨埵如意宝珠讲记》、《普贤上师言教》中有详细的宣说。


前行七支行愿：礼敬诸佛

丁一、礼敬诸佛

    礼敬即是以恭敬至诚心，用身口遍礼殊胜对境。礼敬可以消除我慢的障碍，发起恭敬的信心，得到尊贵身。印光大师也说：「佛法从恭敬中得来，有一分恭敬，得一分利益。」为了得到佛法实义，我们应随普贤菩萨发愿行持。

    颂曰：
    所有十方世界中，三世一切人师子，
    我以清净身语意，一切遍礼尽无余。
    普贤行愿威神力，普现一切如来前，
    一身复现刹尘身，一一遍礼刹尘佛。

    所有十方世界之中，过去、现在、未来一切的诸佛世尊，这些世尊如对目前，我恒时以清净的身口意，全部一一礼敬而无有遗余。仰仗普贤行愿威神力及自心信解力的加持，在每一尊佛前，都显现不可说世界微尘数身体，如是每一身体都周遍礼敬不可说世界微尘数的诸佛。

    前二句指出所应礼敬的对境：即尽虚空遍法界的三世一切人天导师佛陀。三句指出能作礼敬的三业清净之人。四句指出周遍。五句指出能如是周遍的因是：仰仗普贤行愿力的加被。后几句指出礼敬的方式。

    在地球的四方四隅上下，每一方向的虚空都是无边无际的，广大无垠的虚空中有难以计数的国土佛刹，将所有的国土都分成微尘，自然微尘的数量多得无法衡量，有这么多不可说微尘数的诸佛如来。这是佛教一般的世界观与宇宙观。在无碍法界的境界之中，大小互容互摄，无量即一，一即无量，重重无尽，此境界已非常情所能测度。我们相信世尊是真语者、实语者、不异语者、不诳语者，所以丝毫不会疑惑。如此多的佛如何能一一礼拜呢？只有借助普贤行愿的威神力及自心的信解力，才能成办。

    礼拜是八万行门中殊胜的一种，地上大菩萨及地藏、弥勒都精勤礼佛，文殊、普贤、观世音为古佛再来，显现上也恒时遍礼一切诸佛。不但他们，就是无等大师、十方慈父、功德海藏的释迦世尊，也在大众中恭敬顶礼骨塔。断尽我慢的诸佛菩萨虚怀若谷，所以经中记载佛与佛之间也互相问讯礼敬。又常不轻菩萨自处卑下，平等恭敬礼拜一切众生。祖师大德们见到牦牛，也会退在一边，合掌恭敬让牦牛先行。但有些凡夫目空一切，傲气凌人，夜郎自大，认为没人能比得上自己，所以我慢比天还高。但请想一想，作为业障深重、福报浅薄的无明凡夫，还生大我慢，不愿礼敬实乃情理难容。“礼佛一拜，罪灭恒沙”，所以自古祖师大德都以身作则常行礼敬，教弟子拜塔、拜经、拜佛、拜忏、拜愿。古德拜《华严》、《法华》，一字一拜；智者大师拜求《楞严经》十八年，风雨无阻；藏地磕几百万大头的人比比皆是，这种诚敬的精神应该激励策发我们也精进不息。

    经中宣说礼敬的功德，让我们向往不已。如《业报差别经》云：“礼佛一拜，从其膝下至金刚际，一尘一转轮王位。获十种功德：一者得妙色身；二出言人信；三处众无畏；四诸佛护念；五具大威仪；六众人亲附；七诸天爱敬；八具大福报；九命终往生；十速证涅槃。”现在我们身体丑陋、容色粗糙，出言人多不信，在大众中胆怯畏惧，魔障缠身，举止粗鲁，众叛亲离，精怪厉鬼作祟，贫困乏瘠，生于五浊恶世。对照佛经这面镜子，确实应该礼佛。《地藏经》中云：“见闻瞻礼一念间，利益人天无量事。”礼敬地藏菩萨能消除一切恶事、灾难、苦恼，同样礼敬其他诸佛菩萨也都能获得如此功德。

    《宝积经》中说身体有四十种过患：身体是牢狱，恒被贪嗔痴等烦恼所束缚；是臭秽坑，八万虫蛆攒食居住；是行动的厕所，被不净物所装满；是愚痴的罗刹，被我见吞吃智慧之身；如恶贼，世人悉皆讥嫌讨厌；如死狗，一切圣贤如弃敝履；危脆不坚如芭蕉水沫；迅速衰败刹那无常如草露电光；百般将养调理反作怨仇不知报恩。身体的过患无量无边，应该深深认识到这一点，不能和一般世人一样，百般滋养这个酒囊饭袋。肆意纵情淫欲，日夜大造杀盗等十种恶业，深深地沉沦在苦海中。现在以此臭秽皮囊礼拜供养，如以毒药换取醍醐，瓦砾换取珍宝。否则虚掷光阴而不修行，一旦老病忽来，杀鬼猝至，欲礼不能。所以当净心诚意，断除身口过患而恒时礼敬诸佛，方不辜负得个人身，否则与畜生之身没有差别。下面对礼敬的修法及种类略作宣说。

    一、我慢礼：指没有恭敬心，内怀我慢，礼拜如翘翘板一上一下。憨山大师费闲歌中云：“拜佛容易敬心难，意不虔诚总是闲，五体虚悬空费力，骷髅磕破也徒然。”甚至有的人礼拜时松松垮垮，歪歪扭扭，东张西望。或头不点地，或起立时弯腰曲背，或顶礼的环节作得不圆满，这些都有很大的过失，所以应该如理如法符合规矩而顶礼，否则为了求福却反而种下恶因，很不值得。《坛经》中有段公案讲：法达法师七岁出家常诵法华，累计达三千余遍，功德确实很大。当他拜见六祖时，怀着贡高我慢心，因此在顶礼祖师时头不着地。大师教训他，礼拜头不碰地，不如不礼。并说偈曰：“礼为折慢幢，头奚不至地，有我罪即生，忘功福无比。”礼拜本为折伏我慢的高幢，但若怀有我慢之心，无有恭敬，头不点地，则依此我慢反成罪过，若能不执著功德之相，才能获得无量福报。由此可见我慢礼应该舍弃，我们应省察自己的礼拜是否如法，若是我慢礼，则应痛改前非，并剋责忏悔。

    二、唱和礼：指礼拜时高声喧哗，为求名闻利养故意显露引起他人的注意，或者惊扰同参的观想修行。词句混乱不清，口中闲言杂话滔滔不绝，同时身体也不停地礼拜，这些都有很大的弊端，应该认清这些过患，谨慎行持。

    三、恭敬礼：即经中所说的以断除身口意十种恶业的清净三门而礼敬佛、菩萨、声闻、缘觉、善知识、正法等。恭敬礼的仪式虽说都是五体投地接足而礼，但藏地、汉地、南传、日本、朝鲜等因地域、宗派的不同，而各有差异，对这种情况无须自是非他，只要是佛法清净宗派中的礼敬，都应该认同。而且礼拜时口中所念、心中所观更是传承各异，但只要内心虔诚观想、发愿，愿词念诵清晰明朗，身体威仪如法，则无论何种都能调制身心。（此处对不同地域诸多宗派的礼法、观法、念法不作一一宣说。）《离垢慧经》中的礼佛方法，大家都可共同行持。经中说：「我今五体对佛礼拜，为断五道，远离五盖，令诸众生常得具五种神通，具足五眼。愿我右膝著地时，令诸众生常得正觉道；左膝著地时，令诸众生虽入外道法中不起邪见；右手著地如世尊坐金刚座以右手指地时，大地震动，现诸瑞相，证大菩提；左手著地愿以四摄法摄受外道进入正法；愿我头著地时，令诸众生远离骄慢心，悉得佛的无见顶相。」

    四、无相起用礼：即安住般若本性之中，泯灭能礼所礼，一切悉皆空寂。虽然诸法微尘许的本性不可得，但缘起显现不灭，所以遍运身心，如水月般，普遍礼敬。如汉地古德造的礼敬颂云：“能礼所礼性空寂，感应道交难思议，我此道场如帝珠，释迦如来影现中，我身影现如来前，头面接足恭敬礼。”

    有人刚听闻般若、中观经论中“诸法空性离戏绝非、远离能所”之理，就舍弃一切礼拜、诵经、绕塔、经行、布施、持戒等事相修行，堕入断见坑中不觉不知。见他人修行积福反而妄加指责、横加干扰。经常以“不执著、不分别”为借口而放弃修行善法，这种人对般若空性连影子尚未梦见，犹不知惭愧，还高谈“顿悟成佛”，其心早已堕入魔界，办好了直入地狱的快速通行证。《华严经》中说：「断除希求善法的心，是菩萨的魔障。」佛在《像法决疑经》中早就揭露出这一类人的丑恶嘴脸，并授记了他们的下场。「佛说：如果有人看到他人修积福报，施济贫穷之人。就讥毁说∶“出家人何用布施，你肯定是邪命之人，为求得名闻利养。只用修禅定智慧就可以了，何用那些纷扰无益之事呢？”只是如此作意，命终之后，堕大地狱，经久受苦。从地狱中出来又生于饿鬼，舍饿鬼身，在五百世中转生为狗。舍狗身，五百世中常生贫贱之家。」经云：“厌离有为功德是为魔业，乐著无为功德亦为魔业。”

    请看悟彻心源、证等诸佛的祖师是如何做的呢？禅宗百丈怀海禅师云：“行道礼拜，慈悲喜舍，是沙门本事，宛然依佛教敕，只是不许执著。”《金刚经》中也说不著相行布施等，所得福德量等虚空。唐朝代宗皇帝当沙弥时，一天看到黄檗禅师在大雄宝殿中礼佛，他就跑过去卖弄口舌说：“不著佛求，不著法求，不著僧求，长老如此辛苦礼拜求什么？”禅师回答：“不著佛求，不著法求，不著僧求，常礼如是事。”谁知他不解禅师的深刻开示，还不知高低地问：“那礼拜什么？”禅师“啪”就给了他一个耳光，当巴掌落在脸上时，他们这类人痛苦万分，早把平时不执著、不分别、大空性等口头禅抛到九霄云外去了。

    五、内观礼：即内观自己身内法身真佛，离言绝相，离念平等，犹如虚空。心不攀缘外境，舍迷妄垢心，契合本觉妙心，即可称为皈依礼敬。

    六、大悲礼：安住实相自然会发起无缘大慈悲心，观三恶趣众生无法礼拜，三善趣众生虽能礼拜，但信敬三宝者少之又少。彼等恒被无明业惑所缠，极为可怜，我应观想带领他们，或代替他们礼拜诸佛菩萨，以此善根令诸众生离苦得乐。

    七、无尽礼：如天帝宝殿因陀罗网上所悬宝珠颗颗圆明，一颗周围有无量珠，无量宝珠的影像都可明清地呈现在一颗之中而不混杂错乱，这样相互映摄，则每一珠中都有无量珠影。同样，法界中的诸佛与我都是一颗宝珠，不用费力观想，我身自然如影般现于佛前，诸佛也一定影现在我这颗宝珠里。所以若有这样的信解智力，一礼拜则礼尽法界所有一切佛，这样一个身体一时普遍显现在每尊佛前广行礼拜，犹如千江有水千江月。这个修法极其轻松自如，但其功德却是无法衡量的。本经中云：“一毛孔中悉明见，不思议数无量佛，一切毛孔皆如是，普礼一切世间灯。”又云：“于一微尘中，见一切诸佛，菩萨众围绕。法界尘亦然，一一如来所，一切刹尘礼。”

    如上所说只是讲了一个端倪，打开一点思路。真正圆顿华严的不共修法必须依赖普贤神力的加被与自己深心信解的智慧力的真实摄持，令所观境如对目前，虽然历历明现，但不分别执著生灭、一多等相状。能见心依智不依分别心识，这样心境一如，佛与自己无二圆融，方能入其不思议解脱境界。如本经云：“一切法无生，一切法无灭，若能如是解，诸佛常现前。”复云：“若有欲知佛境界，当净自意如虚空，远离妄想及诸取，令心所向皆无碍。”

    最后让我们以广大心发宏誓愿：“虚空界尽，我礼乃尽。以虚空界不可尽故，我此礼敬无有穷尽。如是乃至众生界尽，众生业尽，众生烦恼尽，我礼乃尽，而众生界乃至烦恼无有尽故，我此礼敬无有穷尽。念念相续无有间断。身语意业，无有疲厌。”十大行愿每一个都应如是而发。


回向极乐愿：蒙佛授记愿

    己二、蒙佛授记愿

    彼佛众会咸清净，我时于胜莲华生，
    亲睹如来无量光，现前授我菩提记。
    蒙彼如来授记已，化身无数百俱胝，
    智力广大遍十方，普利一切众生界。

    我依普贤大愿王的导引加持及念佛回向发愿等功德力顺利往生西方极乐世界，彼佛海会都是具有功德、三门清净的菩萨圣众。于胜莲花中自由化生，刹那之间莲花开敷，亲睹无量光如来。佛现于我的面前，慈悲地作种种安慰、开示。并于莲池圣众之前宣我名号，赞叹称扬于我，授记我当来成就菩提。得到如来授记之后，智悲力广大无边，所以分身无数到百俱胝的世界中，以种种方便度化众生。

    如长行文中云：“到已即见阿弥陀佛、文殊师利菩萨、普贤菩萨、观自在菩萨、弥勒菩萨等。此诸菩萨色相端严，功德具足，所共围绕。其人自见生莲花中，蒙佛授记，得授记已，经于无数百千万亿那由他劫，普于十方不可说不可说世界，以智慧力，随众生心，而为利益。”彼极乐世界阿弥陀佛的众会眷属，悉皆是得三不退转、一生补处的清净菩萨。其功德详见《无量寿经》、《观无量寿经》、《阿弥陀佛经》等诸多经中。彼佛国土众生都是于殊胜妙宝莲花中自然化生，所以身体清净光莹。阿弥陀是梵语，翻译成汉语即是无量光、无量寿等。《弥陀经》中云：“彼佛光明照十方国，无所障碍，故名阿弥陀。”其寿命无量于净土之经及《悲华经》等皆有宣说。


篇 首 寄 语

    大方广佛华严经·入不思议解脱境界普贤行愿品
    略释愿海舟
    益西彭措堪布 著

    十方三世无边际，刹尘海会调御师，
    救苦大悲遍照尊，毗卢遮那我敬礼。
    光明遍照大觉尊，圣智大海所流出，
    真如清净微妙法，圆顿华严我敬礼。
    智慧甚深难测量，功德广大不可思，
    无边胜行度群迷，文殊菩萨我敬礼。
    重重愿海浩无涯，众生无尽愿不息，
    大阐华严微妙义，普贤菩萨我敬礼。
    发胜菩提涉百城，烟波浩渺历艰辛，
    知识悉皆异常伦，欢喜开示普贤行。
    切念师教不著尘，五十三觅解脱门，
    一生入于如来境，善财童子我敬礼。
    华严海会恒沙众，助佛宏宣妙法轮，
    三贤十圣如云集，清净海众我敬礼。
    离过湛然安不动，最胜善根无能喻，
    智慧深远无涯岸，三业皎净如秋月。
    普观世间无此德，勇猛精进利群生，
    妙法遍洒三千界，法轮恒转破重昏。
    心心切念澍法雨，念念悲愍济有情，
    一切顺逆无能沮，如是甚深大志愿。
    生老病死苦海中，无上最胜大慈舟，
    深恩无极福聚藏，金刚上师我敬礼。
    我今愿尽毛端智，照明广大真教体，
    惟愿三宝垂加护，悉能冥契诸佛意。
    为令法幢恒坚固，开启众生正法眼，
    趋入普贤行愿海，当乘信解智慧舟。

    篇 首 寄 语

    《大方广佛华严经》是我等大师释迦如来三祗劫满，菩提树下初成正觉，现前法界海会普光明智，以万德庄严之报身，为大根机众生称性宣说佛自证圣智境界的宝典。如日初出先照高山，佛宣《华严》使因缘成熟的众生当下直入佛之知见，趣佛境界，一时功成果满，究竟成佛。如经中所谓：「初发心时即成正觉。」祖师也说：“为勇猛大丈夫，说成佛在刹那间。”华严大教是如来根本法轮，犹如百川以入海为究竟，一切法门以入华严法海为归宿，百千三昧以入于华严海印三昧为穷尽。其文丰义富，无量法门无不含容，无碍法界昭然开显。

    有人听说《华严》是为法身大士、上根利智所宣说，且经文卷帙繁多，法义甚深广大。即想如我之流，业障深重，福慧浅薄，根基陋劣，如何自不量力，而敢问津《华严》？还是识趣点敬而远之，免得遭人讥讽嘲弄，反而搞得尴尬难堪，且致高不成低不就荒废光阴。此类人妄自菲薄，高推圣境，妄居卑下，自断善根胜缘。以邪谬见塞解脱门，作茧自缚，确实愚痴可怜。上根者依华严则可顿超十地，直入佛果，下根者也不妨沿着阶梯渐登高峰。难道没有听说仅闻大方广佛华严经七字而不堕恶趣，诵“若人欲了知，三世一切佛，应观法界性，一切唯心造。”一偈而使地狱饿鬼的众生得以超升的吗？经中又云：“欲灭一切苦，安乐诸群生，欲与诸如来，身口意齐等，应发金刚心，究竟此胜行。”经中分明指出想成办自他二利，度一切苦厄，成就佛果必须修学此经。《随好品》中亦云：“虽住海水劫火中，堪受此法必得闻，其有生疑不信者，永不得闻如是经。”说明若有缘纵然龙王及地狱众生也能得闻此经，若内心疑惑不信则永远无缘听闻此经。《出现品》中也说：「此珍宝经典不会落入一切无缘众生之手中，连声闻缘觉也无缘听闻此经，何况受持呢？唯有菩萨摩诃萨方能信解受持。如果有菩萨于无量那由他劫修六波罗蜜多，以及种种菩提分法，但是如果没有听闻此经，或者虽然听闻却不信受，佛说非如来法王真子，是假名菩萨。」

    《普贤行愿品》中说：「读诵受持，或一经听闻即能生信，所获功德超胜将无边刹土中珍宝庄严及人天胜供，于尘数劫中供养诸佛所积功德，且能远离恶友邪知识，永离三涂恶道，速见阿弥陀佛，具足普贤最胜行愿，获大寿命，自在化生人中，不久当获成就，消灭五无间重罪，生于豪门贵族，容色殊妙、相好庄严、智慧圆满，诸魔不能摧伏，堪作人天福田，速坐金刚座，降伏诸魔军，成佛转法轮，广度人天众。」偈云：“若人于此普贤愿，读诵受持及演说，果报唯佛能证知，决定获胜菩提道。”所以为什么要画地为牢、固步自封而失去如是殊胜大利呢？

    再者，佛说佛法大海深广难测，纵如阿难、舍利弗等大智慧者尚无法穷源尽底，而如蚊虫一样的小根众生也能饱腹畅饮。佛陀明示，只要有缘不论根基大小利钝都能获得相应利益。同样华严大教圆被诸机，使上根者一生圆多劫之修行，刹那证无量法门，不历阶级位次，顿时因圆果满，得证菩提。但经中自信向位乃至等觉妙觉菩萨直至佛果，七处九会阶次井然。从初发心至成佛间一切行门、愿门、波罗蜜门、菩提分法，无不具足。虽不能如善财顿成佛果，也不妨依循规矩，步步为营稳扎稳打，不断陶冶心量，渐成大器，最终也能承当大法。

    此《华严经》如优昙花难值难遇，今日得闻，并非没有因缘。如怡山大师云：“手捧目观心口诵，当知夙有大因缘。”所以应当欢喜踊跃庆幸万分，发愿尽于未来的生生世世在在处处眼中常见、口中常诵、耳中常闻、手常书写、心中常悟《大方广佛华严经》。愿与文殊、普贤、海会圣众为伴侣，愿与一切众生同游华藏庄严海，共入菩提大道场。不能甘处下流，应早种圆顿正因，发殊胜行愿，切莫因循怯弱。

    此经由来极为稀奇，昔日龙树菩萨应佛授记，出生在印度南方，智慧雄猛，博览群经无不穷尽。后乘神通力前往龙宫，见此经有广中略三种，披阅之下由衷感慨：“如此难思无上法宝，可惜南赡有情缘悭无法得见。”故菩萨兴大慈愍，迎请到人间，并作广大弘扬。后来出世的世亲菩萨，在显现上坚信小乘贬斥大乘，被其兄无著菩萨方便诱导，阅此大经，信心勃发，翻然悔悟，从此回小向大。为忏悔昔日谤大乘教的罪过，他开始造论阐扬《华严经》深义密旨。论典造毕之日，口中放光遍照四方，大地六种震动。当时国王及诸臣民都感到很诧异，循着光来到菩萨前。国王问：“尊者您是否今日证果，所以才显现如此奇异之兆？”世亲菩萨回答说：“并非我今日证果，而是由于我为弘扬《华严经》所造的一部《十地经论》今日圆满，所以现此瑞徵。可见华严不可思议的感应和加持是如此奇特。”当时大众发起清净信心，竞相受持。从此这部大经弘扬得就更加广泛了。

    此经流传到汉地，对中国文化产生了极其深远的影响。西域国王将梵文《华严经》进献武则天，她下诏迎请印度三藏法师实叉难陀翻译此经。当天夜晚武则天梦见天降甘露，次日开译之时，果然天降甘霖。而且译场前面忽然出现一个大池塘，每天有二童子从池而出伺候笔墨，晚上入池而去，天天如此，直至译毕，这是龙王恭敬《华严经》而化现的。华严宗二祖贤首法藏大师，应无数高僧大德缁素劝请敷演《华严》奥旨，大师登座之时，彩云成盖，瑞彩纷呈，忽然讲堂大地震动，这征示着大师所解深契佛意，佛现神变为彼印可。后大师又作多种著疏极力弘扬，自此修学华严蔚然成风。澄观清凉国师又造了传世之作《华严经疏钞》，使华严风靡华夏大地。大师乃华严菩萨乘愿而来，为造《疏钞》祈请华严海会菩萨加持，夜间于境界中见一巍巍雄峰，万丈金霞，光明皎洁，连天接地，又见自身变成金龙，一龙又化无数条龙，飞往他方世界。大师入于光明遍照之境，是《华严疏钞》大行天下之兆。那时读诵受持礼拜供养者不可计数，真实修习者比比皆是；入无碍境界，证得不思议解脱者亦不胜枚举。华严的各种疏文释论百家争鸣，达到了最极鼎盛。

    时至今日，慧日渐晦，玄宗隐没。但由于祖师深知华严的不可思议，为使后学弟子能种下圆顿大教的正因，结上胜缘，在早晚功课中，巧妙地插入十大愿王、七支供、经名以及《净行品》等偈文，才使得今天汉地佛弟子们没有不知道《华严经》的，所以我们应当深体祖师用心的良苦，而发心读诵、修持、弘扬。

    至于《华严经·普贤行愿品》则将全经推向大结局，也是全经的最高峰、最高潮。此品是毗卢遮那佛的渊府，普贤菩萨的心髓，一切诸佛之所证，一切菩萨之所行。善财童子于印度福城东之古庙中参礼文殊菩萨，经菩萨劝谕发起菩提心，并教令参访善知识。他历经百城烟水，遍参五十三位大善知识，后入于弥勒菩萨楼阁之中，证大解脱。辞别弥勒菩萨之后，善财深心切念寻觅文殊菩萨，尔时文殊师利遥伸右手过一百一十由旬，为善财摩顶加持，并敕令谒礼普贤菩萨。童子依教至普贤菩萨道场，菩萨为他摩顶加持，当时即入于不可思议解脱境界。菩萨为他宣说此重重无尽普贤行愿大海，此时童子所证已与普贤文殊平等，与诸佛平等，圆满无上正觉，至此《华严经》后善即告圆满。所以华严四祖清凉国师云：“西域相传，《普贤行愿》赞为略《华严经》，《大方广佛华严经》为广《行愿品》。以今观之，理实然矣。”

    很早《行愿品》就被单独从经中提出而流通，极受广大佛弟子的欢迎。汉地八宗对《行愿品》都同遵共诵，尤其被列为净土五经之一。在雪域西藏，《行愿品》向来为历代高僧大德所着重弘扬，尤其是宁玛派的历代传承祖师。如大译师洛亲单玛西日、华智仁波切、全知麦彭仁波切、玛呢喇嘛班玛斯德、托嘎如意宝、全知金刚上师法王如意宝等。法王如意宝是如何重视《行愿品》，自己修持并劝他人修持的呢？以下约略介绍一下：

    法王如意宝经常开示徒众说：“《普贤行愿品》是修积净土资粮的最胜方便，往生极乐世界的捷径，入于圣者境界的要门。此中总集了三世一切诸佛菩萨的所有大愿，它是一切愿海中的最胜愿，所以又称为大愿王，诸大菩萨依此而发广大誓愿。”圣者法王以深远的智慧照见了普贤行愿的不可思议功德力用，为了引领众生同遵普贤行愿，共入毗卢性海，法王在在处处，随顺因缘，极力弘扬《普贤行愿品》。

    一九八七年，法王如意宝率领上万弟子浩浩荡荡，举行了空前的五台山大朝礼。朝礼期间，上师带领大众同声共诵《普贤行愿品》，发殊胜行愿，并发愿度化汉地为主的广大弟子。愿力不可思议，尤其普贤愿王更不可思议。没过多久法王的弘法事业如飓风席卷般遍及全世界。

    一九九○年，法王如意宝朝礼印度圣境时，曾经以种种方便善巧摄受宁玛、萨迦、嘎举、格鲁等派的广大弟子。并为之再再解说《行愿品》的殊胜功德，励力劝请，殷殷教诲徒众修持此不可思议法门。此后众弟子谨遵师教不忘修持。特别在每年正月神变月里，金刚座就显得极其壮观热闹，四面八方的佛弟子们如潮水般涌向金刚座，敬献殊妙广大庄严的供品，同修《普贤行愿品》，而且年年都这样。

    一九九七年法王如意宝为了使佛法更加兴盛光大，而发宏誓大愿，再次发起同修共诵一亿遍《普贤行愿品》。海内外弟子闻此法讯，风起云涌般响应上师的号召，欢喜踊跃地参加，很快就圆满此无尽功德海。

    在传法的中心本土色达喇荣五明佛学院，上师法王承继往昔高僧大德的传统，规定传法之前共诵《行愿品》中的七支供，传法结束以《行愿品》后部分回向发愿。一切大小佛事也都依此定规。在陈设供养方面，每年都提供数量可观的资金，平日不间断三千数的五供。在定期七天的普贤云供法会里，每天十万数的五供。看到经堂里供桌上整整齐齐摆放的水供、灯盏、各种花束塑造的八吉祥……形形色色、千姿百态的图案以及粘有美观酥油花的食子，不能不使人信心油然而生。今年年初，上师法王说：“现在我对什么都无所需求，然而对于僧众每天能念一遍《行愿品》却有强烈的希求心。若僧众每天能如法念一遍《行愿品》，我住在世间也觉得有意义。”由此可见，上师法王弘扬《普贤行愿品》的悲愿是何等的深切！

    现在处在五浊恶世斗争坚固的时期，佛法极端衰败，耳闻目睹无非都是令人厌烦伤感的情景。看茫茫众生心中扎着邪见的毒刺，陷入贪欲的淤泥中，耽著轮回的火宅，沉湎于五欲污水里，不求出离，不寻解脱，诚可怜悯。诸多道友以利他心发殊胜愿，再三诚恳劝请造《行愿品》注释，以期同行道友解了经文，依文观修，心中甚为他们的诚挚及发心所感动。然而基于各种原因，一直未能动笔，时光匆匆，倏忽几年已过。今年又有众多道友劝请，念及他们的精诚，以及欲报上师浩荡洪恩，加上自己也对《行愿品》有较强烈的信心，愿与此经结下不解之胜缘，诸多因缘聚合，所以今日才铺纸下笔。在此之前，也泛泛涉猎了汉地古今大德的各种疏文注释。如华严诸祖诸师著作，穷彻源底，句句导归性海，字字消融法界，而且博大无边，恐非现代人的根基所能领会。观近现代的法师大德所作，广略深浅不同，各有针对的对象。我今所作不为与现代诸释比美，也不为标新立异，仅为竭尽智力阐解经义。愿此释文能帮助道友消释文句，解了法义，依文发愿观修。更愿将藏地汉地古德先贤们典籍中的瑰宝搜集一处，这对于探索深义的人也许有会所裨益。但无论如何，若此书能成为道友们开启大乘信心之门的一把钥匙，步入行愿高峰的一级阶梯，本人心愿已满。

    飘飘絮语，不知所言，望诸君见谅！


    大方广佛华严经入不思议解脱境界普贤行愿品
          唐·罽宾国三藏法师般若奉诏译

    梵语云：摩訶尾没没馱巘拏賀素怛·阿進底也咄尾目乞义尾灑也三满多 跋捺囉罗左哩鉢囉抳馱曩鉢囉吠捨跋哩嚩多

    所有十方世界中，三世一切人师子，
    我以清净身语意，一切遍礼尽无余。
    普贤行愿威神力，普现一切如来前，
    一身复现刹尘身，一一遍礼刹尘佛。
    于一尘中尘数佛，各处菩萨众会中，
    无尽法界尘亦然，深信诸佛皆充满。
    各以一切音声海，普出无尽妙言辞，
    尽于未来一切劫，赞佛甚深功德海。
    以诸最胜妙华鬘，伎乐涂香及伞盖，
    如是最胜庄严具，我以供养诸如来。
    最胜衣服最胜香，末香烧香与灯烛，
    一一皆如妙高聚，我悉供养诸如来。
    我以广大胜解心，深信一切三世佛，
    悉以普贤行愿力，普遍供养诸如来。
    我昔所造诸恶业，皆由无始贪嗔痴，
    从身语意之所生，一切我今皆忏悔。
    十方一切诸众生，二乘有学及无学，
    一切如来与菩萨，所有功德皆随喜。
    十方所有世间灯，最初成就菩提者，
    我今一切皆劝请，转于无上妙法轮。
    诸佛若欲示涅槃，我悉至诚而劝请，
    唯愿久住刹尘劫，利乐一切诸众生。
    所有礼赞供养福，请佛住世转法轮，
    随喜忏悔诸善根，回向众生及佛道。
    我随一切如来学，修习普贤圆满行，
    供养过去诸如来，及与现在十方佛。
    未来一切天人师，一切意乐皆圆满，
    我愿普随三世学，速得成就大菩提。
    所有十方一切刹，广大清净妙庄严，
    众会围绕诸如来，悉在菩提树王下。
    十方所有诸众生，愿离忧患常安乐，
    获得甚深正法利，灭除烦恼尽无余。
    我为菩提修行时，一切趣中成宿命，
    常得出家修净戒，无垢无破无穿漏。
    天龙夜叉鸠槃，乃至人与非人等，
    所有一切众生语，悉以诸音而说法。
    勤修清净波罗蜜，恒不忘失菩提心，
    灭除障垢无有余，一切妙行皆成就。
    于诸惑业及魔境，世间道中得解脱，
    犹如莲花不著水，亦如日月不住空。
    悉除一切恶道苦，等与一切群生乐，
    如是经于刹尘劫，十方利益恒无尽。
    我常随顺诸众生，尽于未来一切劫，
    恒修普贤广大行，圆满无上大菩提。
    所有与我同行者，于一切处同集会，
    身口意业皆同等，一切行愿同修学。
    所有益我善知识，为我显示普贤行，
    常愿与我同集会，于我常生欢喜心。
    愿常面见诸如来，及诸佛子众围绕，
    于彼皆兴广大供，尽未来劫无疲厌。
    愿持诸佛微妙法，光显一切菩提行，
    究竟清净普贤道，尽未来劫常修习。
    我于一切诸有中，所修福智恒无尽，
    定慧方便及解脱，获诸无尽功德藏。
    一尘中有尘数刹，一一刹有难思佛，
    一一佛处众会中，我见恒演菩提行。
    普尽十方诸刹海，一一毛端三世海，
    佛海及与国土海，我遍修行经劫海。
    一切如来语清净，一言具众音声海，
    随诸众生意乐音，一一流佛辩才海。
    三世一切诸如来，于彼无尽语言海，
    恒转理趣妙法轮，我深智力普能入。
    我能深入于未来，尽一切劫为一念，
    三世所有一切劫，为一念际我皆入。
    我于一念见三世，所有一切人师子，
    亦常入佛境界中，如幻解脱及威力。
    于一毛端极微中，出现三世庄严刹，
    十方尘刹诸毛端，我皆深入而严净。
    所有未来照世灯，成道转法悟群有，
    究竟佛事示涅槃，我皆往诣而亲近。
    速疾周遍神通力，普门遍入大乘力，
    智行普修功德力，威神普覆大慈力。
    遍净庄严胜福力，无著无依智慧力，
    定慧方便威神力，普能积集菩提力。
    清净一切善业力，摧灭一切烦恼力，
    降伏一切诸魔力，圆满普贤诸行力。
    普能严净诸刹海，解脱一切众生海，
    善能分别诸法海，能甚深入智慧海。
    普能清净诸行海，圆满一切诸愿海，
    亲近供养诸佛海，修行无倦经劫海。
    三世一切诸如来，最胜菩提诸行愿，
    我皆供养圆满修，以普贤行悟菩提。
    一切如来有长子，彼名号曰普贤尊，
    我今回向诸善根，愿诸智行悉同彼。
    愿身口意恒清净，诸行刹土亦复然，
    如是智慧号普贤，愿我与彼皆同等。
    我为遍净普贤行，文殊师利诸大愿，
    满彼事业尽无余，未来际劫恒无倦。
    我所修行无有量，获得无量诸功德，
    安住无量诸行中，了达一切神通力。
    文殊师利勇猛智，普贤慧行亦复然，
    我今回向诸善根，随彼一切常修学。
    三世诸佛所称叹，如是最胜诸大愿，
    我今回向诸善根，为得普贤殊胜行。
    愿我临欲命终时，尽除一切诸障碍，
    面见彼佛阿弥陀，即得往生安乐刹。
    我既往生彼国已，现前成就此大愿，
    一切圆满尽无余，利乐一切众生界。
    彼佛众会咸清净，我时于胜莲华生，
    亲睹如来无量光，现前授我菩提记。
    蒙彼如来授记已，化身无数百俱胝，
    智力广大遍十方，普利一切众生界。
    乃至虚空世界尽，众生及业烦恼尽，
    如是一切无尽时，我愿究竟恒无尽。
    十方所有无边刹，庄严众宝供如来，
    最胜安乐施天人，经一切刹微尘劫。
    若人于此胜愿王，一经于耳能生信，
    求胜菩提心渴仰，获胜功德过于彼。
    即常远离恶知识，永离一切诸恶道，
    速见如来无量光，具此普贤最胜愿。
    此人善得胜寿命，此人善来人中生，
    此人不久当成就，如彼普贤菩萨行。
    往昔由无智慧力，所造极恶五无间，
    诵此普贤大愿王，一念速疾皆消灭。
    族姓种类及容色，相好智慧咸圆满。
    诸魔外道不能摧，堪为三界所应供。
    速诣菩提大树王，坐已降伏诸魔众，
    成等正觉转法轮，普利一切诸含识。
    若人于此普贤愿，读诵受持及演说，
    果报唯佛能证知，决定获胜菩提道。
    若人诵此普贤愿，我说少分之善根，
    一念一切悉皆圆，成就众生清净愿。
    我此普贤殊胜行，无边胜福皆回向，
    普愿沉溺诸众生，速往无量光佛刹。


忏悔业障：事忏：忏悔三障：前行方便

庚一、前行方便

    经中说若罪业有体相者尽虚空无法容纳。因三业而造业，或从眼耳鼻舌身意六根造业，或内心邪思维，或借助外境而造恶业，这样十恶不断，八万四千尘劳门竞相通向三恶道中，三障若能忏尽，则一切烦恼业障都能清净。

    欲灭三障应当发五种增上胜心前行方便。

    一惭愧心：诸佛菩萨三业清净皎如日月，我等无恶不造，又被一切贤圣所呵责，诸多鬼神天仙所指责厌弃，真是又羞又愧。

    二恐怖心：既是凡夫，自然三门恒与恶业相应，这样命终之后应堕地狱饿鬼畜生，受无量苦，这怎么不让人感到惊慌恐怖呢？

    三厌离心：往昔无知愚昧造作恶业，现在罪垢缠身，当生厌烦追悔之心。又观生死之中，常被无常大火所焚，众苦连绵，不净充满，虚假无实，只是一场戏而已，如水泡速起速灭，生老病死如车轮滚动一刻不息，八苦交煎无有暂停，内观自身种种不净，九孔长流污秽。内外诸法丑恶虚假，当生厌离。

    四发菩提心：菩提心能疗一切生死重病，能烧一切障碍，能成就一切善法，能度化众生，严净佛国，能圆满成就如来一切功德，所以当发菩提心。

    五怨亲平等：于一切众生起慈悲心，无人我相，若不如此则妄分怨亲，以邪分别护亲伏敌，滋生贪嗔烦恼，造恶受苦。

    具此殊胜方便，然后观想十方诸佛菩萨，或仅观一佛一菩萨。《佛名经》所云：“缘想十方诸佛贤圣，擎拳合掌，披陈至祷，惭愧改革，舒历心肝，洗荡肠胃，如此忏者，亦何罪而不灭，何障而不除。”否则悠悠缓缓，心浮气躁，身心散漫，罪业不消，一息不来，三途苦报亲身感受，求脱无期，无代受者，智者当扪心深思。


别发十大愿：修行二利愿：修波罗蜜愿

丙一、前行七支行愿分七：礼敬诸佛；称赞如来；广修供养；忏悔业障；随喜功德；请转法轮；请佛住世。

    本品以普贤菩萨为善财童子提出并具体解释十大愿王而展开，诸佛菩萨因地发此十大无尽愿王，并如实修持，现在正安住如此境界，但作为初学者可称性发此大愿，并作相似观修，不一定立刻能真实修持和现前此愿王。所以作注释的目的是：激发初学者使其真实发起无上菩提大愿，并以窍诀开示使根基不同、智慧各异的人都能随分得到不同的利益。

    《华严经》中云：“不发大愿，魔所摄持。舍菩萨行，魔所摄持。不化众生，魔所摄持。”永明延寿大师云：“发大誓愿者，万行之因，能长慈悲，不断佛种。大事成办，所作剋终。成道利生，皆因宏誓，是以有行无愿，其行必孤，有愿无行，其愿必虚，行愿相从，自他兼利。”如果大愿不发，则不能感应诸佛摄受加被，也无法开显自心如来法身本性。上不能报上师三宝的无极深恩，下无法普渡苦海中沉沦的六道父母。龙树菩萨在《大智度论》中云：“作福无愿，无所树立。愿为导师，能有所成。譬如销金，随师所作，金无定也。菩萨亦尔，修净土愿，然后得之，以是故知，因愿获果。”龙树菩萨接着说如果能从心中发愿并说：“愿我当作佛，消灭一切众生的痛苦。”这样的人虽然没有断除烦恼，没有行持难行苦行，因为内心诚恳，所以超胜一切众生。

    诸佛如来都以福慧两种功德庄严法身与色身，我们欲求成佛也必须依此广大的行愿门，修积无边广大的福慧资粮。藏地洛钦大译师、宗喀巴大师等开示我们：修积广大福资粮的殊胜窍诀即是《行愿品》中的七支供修法，普贤菩萨劝请我们说：想要成就如来浩瀚功德应当修十大行愿。


前行七支行愿：请佛住世

丁七、请佛住世

    诸佛若欲示涅槃，我悉至诚而劝请，
    唯愿久住刹尘劫，利乐一切诸众生。

    观想尽于虚空、遍满法界的无数无量诸佛国土之中的一切诸佛如来、一切菩萨海会、一切声闻缘觉、一切善知识，我皆幻化身体，安住彼前哀求劝请，唯愿尽未来一切劫中久住世间，利益众生，赐予暂时与究竟的安乐，切莫入于涅槃。

    涅槃意为入灭、灭度、圆寂。入灭即趋入寂灭界中。灭度即灭除一切障碍，度一切生死苦海。圆寂即功德圆满具足，障碍悉皆净除。

    涅槃有四种：一自性清净涅槃，即真如本性，从无始以来，本来清净，虽有客尘而不能染，所以称之为自性清净涅槃。

    二有余依涅槃：即圣人尚有苦谛所摄身体，但因断尽烦恼障，离诸躁动，寂静安乐，所以称之为有余依涅槃。

    三无余依涅槃：即圣人厌离诸苦欣求寂乐，灰身泯智，余苦所依之身也灭尽，所以称之为无余依涅槃。

    四无住处涅槃：即真如从所知障中现出，大悲般若恒时辅助，因此不住生死涅槃，穷未来际，利乐有情，虽常起用但恒时寂灭，所以称之为无住处涅槃。

    佛为了显示：诸行无常；三有无安；大涅槃安稳快乐离诸怖畏；为令人天舍弃对色身的耽著示现色是无常法，令他们愿求清净之身；无常力强无法扭转；一切有为不随心住无有自在；三有皆如幻化不坚牢；涅槃本性坚固不坏；一切法虽然无起，但有聚散之相。又因为佛事圆满，应度化的已全部度化，所以示现涅槃。如《大般涅槃经》中云：“以佛神力出大音声，随其类音，遍告一切，今日如来应正遍知，怜悯众生，覆护众生，等视众生，如罗睺罗。为作皈依屋舍室宅，大觉世尊，将欲涅槃。”此时世尊面门放大光明，杂色之光，遍照一切诸佛世界，消除众生罪垢烦恼。经中又云：“是诸众生见闻是已，心大忧愁，同时举声，悲啼号哭，呜呼！慈父，痛哉苦哉！举手拍头，搥胸叫唤，涕泣哽咽，大地山海悉皆震动。”诸众即到如来前礼敬请佛住世而说偈言：“稽首礼调御，我等今劝请，远离于大仙，故无有救护。今见佛涅槃，我等没苦海，愁忧怀悲恼，犹如犊失母。贫穷无救护，犹如困病人，无医随自心，食所不应食。众生烦恼病，常为诸见害，远离法医师，服贪邪毒药。是故佛世尊，不应见舍离，如国无君主，人民皆饥饿，我等示如是，失阳及法味。今闻佛涅槃，我等心迷乱，如彼大地动，迷失于法力。大仙入涅槃，佛日坠于地，法水悉枯涸，我等定当死。如来般涅槃，众生极苦恼，譬如长者子，新丧于父母。如来入涅槃，如其不还者，我等及众生，悉无有救护。如来入涅槃，乃至诸众生，一切皆愁怖，苦恼集其心。我等于今者，云何不愁恼，如来见放舍，犹如弃涕唾，譬如日初出，光明甚晖焰，既能还自照，亦灭一切暗，如来神通光，能除我苦恼，处在大众中，譬如须弥山。复以种种譬喻殷勤劝请。”如昔大众劝佛住世，我现在也在诸佛面前如是恳切劝请。

    劝请声闻缘觉：有人本是野干狐狸，常学狮子之语说：“二乘沉空住寂，只求自了，是焦芽败种，独觉如哑羊不能说法。所以请他们住世有何益处？”岂不知二乘断烦恼障，是人天大福田，而你烦恼炽盛，罪障深重，欠十方信施大债，还厚颜无耻，呵谤解脱的圣者，真是不知天高地厚。如须菩提、舍利弗处处请问大乘，激扬妙理，迦叶、阿难结集三藏经文，不住寂灭的诸大尊者，彼等作大佛事广利人天，若能住世利益无边。缘觉出于无佛之时，以神通摄化众生，供养者即生成就果报。如金色王国中十二年大旱，国民粮食用尽。因为供养了缘觉一顿饭，现世中就满了大愿，使五谷丰登、人民安乐，可见缘觉功德无量，所以当诚心劝请声闻、缘觉长久住世。

    劝请善知识：现在众生很少能有机缘听闻佛法，所以特别愚痴，善恶知识不能辨别。本经中说：能让行者发起并安住菩提心的，令生长善根的，教修诸波罗蜜的，令得真实决定辩才的，令不耽著尘世间的，令修行精进无有满足的，令安住行持普贤妙行的，令入于佛智的才是善知识。善知识能解说教法，引导修行，令修行人舍弃邪恶险道，入于解脱安乐，其恩德超胜诸佛，所以应当时常劝请，久住世间。

    了义的请佛住世应当如下理解：诸佛常住一真法界而不动，众生心被业障垢染所蔽，如果心开意解时则为见佛，但若忘失见解，则不见佛。今所劝请，就是离心意识，断除分别，常常观自性佛智慧法身，心清智明时，即常见佛不曾涅槃。若瞥尔乱心又起，客尘烦恼相续生起，观照智慧间断，则不见佛，即是佛般涅槃。《出现品》中云：“如来常住清净法界，随众生心，示现涅槃。佛子，譬如日出，普现世间，于一切净水器中，影无不现，或一处器破，则不现影。”又云：“一切众生净心器中，佛无不现，心器常净，常见佛身。若心浊器破，则不得见。”其实一切修法都是为了显发自心本住佛性，令此觉心常照不失。特别修上师瑜伽，就是令心器清净，令上师的常住法身即十方诸佛如来悉皆常住心中。


前行七支行愿：请转法轮

丁六、请转法轮

    劝请转法轮能消除谤法的障碍，发起慈愍众生的善根、生生世世值遇佛法、不起邪见、得到多闻智慧。

    颂曰：
    十方所有世间灯，最初成就菩提者，
    我今一切皆劝请，转于无上妙法轮。

    诸佛如来成就广大无碍的如所有智与尽所有智，能以此智慧灯，破除世间一切愚痴冥暗，当十方一切如来坐菩提座，降魔已毕，刚刚成佛之时，我即分身到佛座下，合掌恭敬诚恳地祈请说：“为迷惑苦众，燃亮正法灯。”诸佛承我劝请而转于无上大法轮。

    佛不出世的时间称为暗劫，暗劫之中众生没有智慧的眼目，只能踏入黑暗的险道之中，加上一切天魔外道的邪知邪见及邪说横行世间，由此一切众生从暗入暗，从苦入苦。所以佛法是苦海中的慈航，黑暗道路中的明炬，出生一切诸佛之母，一切众生慧命的源泉。

    不用说没有佛法的暗劫，就是五浊横流的今日，因众生业力越来越强大，福报越来越浅薄，所以祖师大德们相继入寂，法日也渐渐地西沉。此时邪魔猖獗，邪知邪说风行世间，多如牛毛，因此使得一般的众生盲目无知，只是追求饮食衣服钱财玩乐，不知尚有解脱之道。就是入于佛门追求解脱的人也感到迷茫不安，无所适从。为了燃亮智慧之灯，照亮解脱之道，我们理当义不容辞地以种种方便、种种善巧，殷勤劝请十方诸佛菩萨、善知识、法师愍念众生苦楚，击大法鼓，吹大法螺，震大法雷，开甘露门，降大法雨，开辟人天解脱之道，堵塞恶趣罪恶之门。《大智度论》中说：「当我们祈请时，虽然见不到佛，但佛常知道我们的心，听到我们的劝请之声。」诸佛正遍知，悲心恳切，愍念有情，常作不请之友，智光彻照遍及一切有情，天眼常垂视我等，天耳恒遥闻我等，所以我等发一念敬信，佛必欢喜安慰，不会无动于衷的，我今代一切众生劝请，速转大法轮，碾碎一切众生的烦恼业障，安置众生于解脱正道之中。

    昔日释迦世尊初成正觉，观察所证之法微妙甚深，无人能解能悟，若对彼说徒劳无益，故默然无言。但忆昔本愿，特为度化此界众生，当为彼等渐次说法。佛于眉间放白毫相光，加被大梵天王，梵王即到佛前，劝请说：“唯愿哀愍，为转法轮。”佛为使众生尊重法的缘故，依旧默然。梵王又邀帝释天同来劝请说：“世尊降伏诸魔怨，其心清净如满月，愿为众生从定起，以智慧光照世间。”佛仍然默然不语。时梵王偏袒右肩，胡跪合掌，劝请说：“如来今已降魔怨，智慧光明照一切，世间根熟有堪度，唯愿世尊从定起。”佛告梵王：“我法深妙，最极寂静，若为人说，彼不能解。”后来梵王见魔界增多，天人减少，又来劝请说：“唯愿三界独尊的大牟尼，开甘露门，宣所证清净离垢到达彼岸之法。常悲愍众生如独子，为何今日舍弃不顾，伏乞以佛法光明，灼破冥暗，祈佛大慈，不舍本誓，如狮子吼，作大雷震，为此众生转妙法轮。”此时世尊以偈告曰：“我今为汝请，当雨于甘露，一切诸世间，天人龙神等，若有清净者，听受如是法。”之后四位树神请问：“当于何处转法轮？”世尊告诉说：“当在过去九万一千俱胝诸佛转法轮处，即波罗奈仙人堕处——鹿野苑中转正法轮。”于是佛到鹿野苑度五比丘。从此三宝出现世间。如《维摩诘经》云：“三转法轮于大千，其轮本来常清净，天人得道此为证，三宝于是现世间。”所以我等也应如大梵王以锲而不舍的精神，幻化无量无边的身体，到微尘数诸佛世尊面前，敬献千辐法轮、右旋吉祥法螺，再三殷勤劝请人天导师转大法轮。

    以上是一般意义上的请转法轮，了义的请转法轮是：众生迷失本性，被声色所障碍，不知水鸟树木一切诸物皆演妙法，念念之间，恒转不息，因此要劝请。即悟入法界本性，常转自性法轮。要恒时了悟一切音声如谷响，一切显现如水月，缘起性空，非断非常，一一全是真如法界，于闻无所闻之性中，终日闻法，心能如此作观，称为请转法轮。《华严经·出现品》云：“知声如响，而请转法轮，了知诸法真实性故。于一音中，出一切音，而转法轮，毕竟无生故。”如此则一切器情所发之声，全是佛语，所以古人云：“溪声尽是广长舌，山色无非清净身。”经中亦云：“能令三界所有声，闻者皆是如来音。”贤首法藏大师说：「诸佛以智慧功德为体，菩萨以穷尽法界的智慧请佛说法，所以一切佛没有不降大法雨的，菩萨只要发愿和行持，诸佛定以本愿力作加持，所以菩萨一定获大利益。」由此可见以大智慧观于法性，则诸佛恒时加被，这就是菩萨常请，诸佛常说。若离开观行则是行者不劝请，诸佛不说妙法。如此才能了知“如来不涅槃，法亦不灭尽”的密意。


劝请受持

乙二、劝请受持

    若人于此普贤愿，读诵受持及演说，
    果报唯佛能证知，决定获胜菩提道。
    若人诵此普贤愿，我说少分之善根，一念一切悉皆圆，成就众生清净愿。

    对于此普贤愿王中的十大总愿或别愿，若有人能读诵，受持，为人演说，如此修行所得殊胜功德果报，一切凡夫、声闻、独觉、菩萨圣位们是无法测知的，只有佛与佛才能证明了知，而且此人不久决定获得菩提佛道。若有人诵此普贤行愿，无须说他获得所有善根，只说少分的善根，仅仅一念间的修持就可以圆满一切善根功德，一切众生的清净愿望依此全部满足。

    修法有十种即书写、供养、转施、听闻、披读、受持、开示、讽诵、思维、修习。也就是如长行文中所说仅对一偈作如上十种修法之一，即能获殊胜利益。一书写：为了尊重佛法，所以经常抄写经典。二供养：常以花香绸缎等供养经法。三转施：自己书写的经书转送他人读诵，或者将自己念经功德回向布施他人。四听闻：参加法会恭敬聆听教法。五披读：披览教法，照着经文读诵。六受持：背会记住经文令不忘失。七开示：自己解了经文法义妙味，经常对他人演说开示。八讽诵：记忆文句，经常以美妙动听的声音唱诵百千万遍。九思维：听闻教法，静心思维义理，出生慧解。十修习：通达教法秘旨，依法观修。《辩中边论》云：“书写及供养，施他听披读，受持及开演，讽诵与思修。”

    贤首大师在《华严三昧观门》中指出真正的修行者、邪恶的修行者，我们应当了知，对照自身，把自己规范在真正的修行轨道中。大师说：「共有十种修行类别：一、有一类众生无知无识，抛开圣教，刚愎自用，以自己愚心分别为导师，又跟随邪师恶友，违背正法而修行。善巧伪装欺诳诱惑，这是恶人。二、有一类众生也是违背圣教，认为只要心地正直就是出生死的法要，勤修苦炼，终是徒劳无益。这两种人有着共同的毛病，都是舍弃圣教，不依义理。三、仅仅读诵圣者的经论教言，不解意义，并且借助圣教，求名求利，违背所诵，所以也是恶人。四、只是寻文逐墨，不解义理，但以直心读诵，虽然没有虚伪巧饰，但也没什么大的利益。这两种人虽然不舍圣教，但都没有得到义理。五、读诵圣教，知道少分义理也略有修行。六、广泛寻求圣教，遍知胜解及修行，之后渐渐放下文字圣教，决心专修实行。七、受持意义，只是修行，不再研究圣教文字。八、依圣教得到要旨，了知一切法无不契合法性，圣教文字也合于法性，因此无须舍弃，依教修行。九、常能受持契合法性的圣教，不舍弃也不执著。恒时观泯绝语言的正理，不舍弃也不滞碍。十、依教得到实相，因此圣教与正理圆融无碍，所以常观理而不碍圣教，常受持圣教也不碍正理。教理全部消融，合成一观，才是究竟修法。」

    此处撮取几例受持此经的灵验事迹，以使有缘者生起欢喜信心，从而依此修行。

    一、抄写感得经放五色祥光：中国后魏时代的王延明、王元熙，英明博知，曾用上等好香掺和金粉，抄写了一百部《华严》。藏于妙香宝函之中，夜以继日地奉持清净斋戒，修行正道善法。由此感得此大经王放射五彩神光，把屋里屋外照得一片光明。因亲眼目睹此希奇景象从而发菩提心的人不可计数。

    二、字字放光：出家为僧的德圆，开垦出了一片清净优美的园子。栽植很多楮树，在楮树行间，鲜花香草点缀其中，很是清幽雅致。每次到园中去，都用香水浇灌楮树，三年之后四处飘香。后来用此树造纸，书写《大方广佛华严经》，下笔才抄数行，即出现神奇之事情：只见字字放大光明。

    三、供养此经瑞鸟衔花：僧人法诚在蓝谷建造了一座华严堂，于殿中描画七处九会说法图，并抄写此经，而且专心精诚地供养《华严经》。从此经常看见有灵瑞之鸟，身体形色长得非常好看，口中衔着妙花到殿堂中，旋绕供养。

    四、洗手水拯救生灵：弥伽多罗是师子国人，得到阿那含果位。后来游化到西太原寺，碰到很多人读诵《华严经》，脸色忽变，惊奇地说：“没想到此地也有《华严经》。”于是恭敬合掌十分欢喜地说：“《大方广佛华严经》功德不可思议。相传在印度有人只是对此经作了称赞之后，洗手的水沾到虫子蚂蚁，它们即时命终都生于天上，何况受持读诵思维观察的功德呢？”

    五、缥然飞空：隋朝禅定寺的僧人慧悟受持《华严经》。后来约受持《大般涅槃经》的一个出家人，到终南山隐居修行。他们都专心专意地修持各自的法门。有一天，一个人迎请应供，他俩互相推让。迎请的人说：“请受持《华严经》的悟和尚去吧。”于是他随着此人前往赴斋。原来这个人是山神，到山神的住宅，一千罗汉也应邀参加，他们一致推举慧悟和尚坐于首座。用斋完毕，山神喊来一个童子伺候法师，小童子忽然蹦入法师口中，此时他得到神通，乘神通回去取经，缥然飞空而去。

    六、受持朗然通达：僧人辩才依止裕法师学《华严经》，很长时间但仍然没有开悟成就。于是发大勇猛住于净室中，精进受持，这样过去三年。一天夜晚梦见普贤菩萨现身指点传授。醒来之后全部通达，如照镜子一样的清楚。

    七、为人开示通达汉语：宋朝三藏求那跋陀罗，本来是天竺人，精通《华严》，游化中国，七百多人请求他讲《华严经》，但遗憾的是汉语不精通。于是面对此经礼拜忏悔，虔诚地祈祷。梦中有人一手执利剑，一手拎着人头，斩下三藏法师的头，安上手中拎来的头。此后法师对汉语通达无碍，讲解此经数十遍。

    八、人天共遵：魏朝时的三藏法师勒那尊者，中印度人，精通汉语游化汉地。一次讲完《华严经》的时候，忽然面前出现一人，手中拿着朝笏，看上去象个天官。告诉法师奉天帝之命特来迎请法师到天上讲《华严经》，而且都讲、维那都要一齐去。法师说等这里讲完再去可以吗？天人说可以。等到讲圆满的那天，法师与都讲维那几人突然圆寂于法座之上，人们赞叹景仰不已。

    九、神光入室：华严三祖贤首法藏大师，十七岁辞亲割爱，到太白山求法。后来母亲得病，回乡探母。当时二祖智俨在云华寺讲《华严经》。深夜贤首看到一道神光照在庭院之中，光明晃耀，知道此地一定有异人，天明拜访智俨大师，恭敬承事依止，自此深入华严甚深境界，后来成为一位伟大的祖师。

    十、讽诵口中出生舍利：唐朝安定郡攀玄智，依止初祖杜顺大师诵《华严经》，每次诵经之时，口中频频出现舍利子，总共累计获得一百多粒。

    十一、神僧诵经：贞观年初，一天，西安苑律师在灞桥店中住宿。邻房也住下一位出家僧人，他肆意饮酒吃肉。律师持戒精严，看到出家人这番行为，勃然大怒严厉地警戒吃肉的僧人。这位僧人吃完喝毕以灰水嗽口，开始诵《华严经》，一会就诵完一轴，不到五更天，一部大华严全部诵完。见到如此超常的功德，律师非常愧疚，就到僧人房中悲痛哭泣礼拜忏悔，天亮后僧人忽然不知去向。

    十二、思维证悟无生法忍：解脱和尚在五台山佛光寺建立精舍，读诵《华严经》，并依照经文修佛光观。祈祷文殊菩萨，现量见到后，菩萨告诉他，不用礼拜我，应该尅责忏悔，后因返观自求，证悟无生法忍，感得诸佛现身说偈赞叹，偈云：“诸佛寂灭甚深法，旷劫修行今乃得，若能开晓此法眼，一切诸佛皆随喜。”他启问诸佛，寂灭之法怎么可以宣说教化他人呢？诸佛隐身不见，只留下空中的声音说：“方便智为灯，照见心境界，欲究真实法，一切无所见。”

    十三、修习感得海神降下应时的滂沱大雨：僧人道英，年方二十，父母给他娶妻，同居五年，不行世间之事，因为听讲《华严经》，就舍俗出家，到太行山柏梯寺修习止观。当时天气大旱，但每天都讲华严，一天，有两人自称是海神专程为听经而来。法师教他们降雨，须臾之间大雨滂沱。

    修学《华严》，感应纷繁昭彰，可见可闻，因此劝勉大家都来积极读诵修持，其功德唯佛与佛才能证知。金刚菩萨云：“闻此法门如一切智行所集福德。”


释题

乙三、释题

    《大方广佛华严经·入不思议解脱境界普贤行愿品》这个经题包含两部分内容：一《大方广佛华严经》是全经的名字；二《入不思议解脱境界普贤行愿品》是经中《入法界品》的一部分。经论取名的方式与必要可参阅其它论典，此处不作宣说。

    总的来说“大方广”是指所证的法，也即指一真法界、众生的心性。“佛华严”指能证的人，指豁破无明烦恼、真智现前的如来。“经”指能诠的教法。“不思议解脱境界”是所入之境，“普贤行愿”是能入，“入”即证入。“品”即章节划分的单位。

    若细说“大方广”则分别代表法界体相用。“大”表法界体大，从时间而言穷尽过去现在未来，从空间而言周遍四方四隅上下十方。一切性相的法无不被包容在其中，而且远离生灭戏论，恒常而周遍，广大无边犹如虚空。“方”字表相大，在大体之中一切万法全同真性离戏绝非。但“大”中没有说明德相如何，“方”字说明体中具足无量无边恒沙功德，对圣者而言没有增加，对凡夫来说也没有减少，犹如大海浩瀚无涯。祖师云：“体上本具恒沙功德，犹如真金本具千种之器，犹如摩尼珠本具千般万般非色之色。”“广”字表用大，无边的相不离体性，一一相都与体无别，所以出生大用。一入一切，一切入一，普遍包容，互涉互入，无障无碍，以致重重无尽。用中出生轮回涅槃所摄的一切染净因果，若能直悟轮涅诸法当体缘生无性，即能顿契本体，入于不生不灭常恒不变的本性中。

    彻证体大、相大、用大，断尽烦恼，智慧朗发，现前菩提者称为佛陀。佛入于一真法界体大、相大、用大，所以佛陀功德也无穷无尽，自成法身佛、报身佛、化身佛，圆满五智，成就般若、解脱、涅槃三德，五眼、六通、十力、四无畏、十八不共法等等如海功德。“佛”的意义是觉，觉又有本觉、始觉、究竟觉。如《大乘起信论》云：“谓心体离念，离念相者，等虚空界，无所不遍，法界一相，即是如来平等法身。依此法身说名本觉。”众生虽具本觉但由无明不觉，所以经佛菩萨善知识宣说教法，导引修行，以外缘熏习之力，显发内具本觉，称为始觉，即开始觉悟。究竟觉即依靠始觉的修习之力，断尽障垢，本觉面目全体显露故称为究竟觉。

    “华”字为比喻，喻义为万德庄严的佛果，是以芬芳绚丽的万行功德之花而严饰。圆教的行不同一般，因契合体大、相大、用大，故一行遍于一切行。“严”如果没有大智慧，纵然勤修万行，但因著相而不能融契法性，就无法庄严法身。庄严法身比喻绘画，彩色喻万行，画师喻大智，如此大智摄持的万行之花，才能庄严一乘无上之佛果。《问明品》中云：“於佛法中，智为上首，则智为正道，万行为助道。”

    “经”有八种意义。一涌泉：法流无尽喻如泉水涌流不竭。二出生：展转出生无量法味。三显示：显明开示事理。四绳墨：辨别判断正邪，犹如墨线矫正弯木，众生的邪心随圣教而正。五贯穿：贯穿所说诸法性相之理。六摄持：摄持所化众生，令其还归本源，杜绝攀缘六尘外境而轮回。七结鬘：喻以绳线将花串成鬘，同样经能把佛法妙花串令不散。八道路：佛经是通向解脱的道路。

    《入不思议解脱境界普贤行愿品》，“不思议”指心意识无法测量，不能分别缘取，一切语言文字无法宣说论议。因为法本离名离相，所以心无法缘取执著，口无法论议。如僧肇法师云：“口欲谈而辞丧，心将缘而虑亡。”此为法身大士之境非二乘所能比，也不是有漏智慧所能揣测。再者法性本来空寂，所以不思议。什么不思议呢？是解脱境界，以两种智慧断除一切二障烦恼束缚，内外圆明无羁无束，自由无碍称为解脱。其实一切诸法本自融通无碍，本来解脱，但众生由于内心执著，妄分能所，显现森罗万象的外境，致使障碍本源真性。所以祖师说：“息心息虑，自然解脱。狂性不歇，歇即菩提。”古人曾有互相问答，问曰：如何才能解脱？答：请问谁把你捆住了。可见一切时中都不离解脱，但以分别妄心，不见不悟。

    “境界”，诸佛菩萨的德用智慧不同，如国界疆域有千差万别。再者所知事理无边，佛与普贤能彻照，这两重意义都可成为境界。如何才能入不思议解脱境界？唯依“普贤行愿”。普贤有极多含义，华严宗讲法与密宗也略有相同之处，为能引发道友信解略作宣说。密宗中有基普贤、道普贤、果普贤之说，密意极深讲法独特，令人耳目一新，有志者应当求之。现在从法和人的角度来解释普贤。法普贤又可分体和用两方面，“体普贤”即万法的本源，本觉心体又名一真法界，此法界周遍一切六道众生与十方所有诸佛菩萨。体性周遍称为“普”，随缘显现轮涅诸法，虽现轮涅诸法，真性不变称“贤”。悟达国师云：“在一尘而广大悉备，随万有而独立不改。”“用普贤”指体上具尘沙德相，此德能起尘沙妙用。虽有尘沙妙用，但恒不离体，如波浪虽然千差万别但不异于水。一即一切称为“普”，一切即一称为“贤”。从人角度讲普贤分三：一、位前普贤：即资粮加行二道菩萨，发弘誓愿遍度众生称为“普”，将登圣位称为“贤”。二、当位普贤：指初地乃至十地等觉妙觉菩萨，因彼功德周遍法界称为“普”，最极调顺善妙称为“贤”。三、位后普贤：指虽然证得无上正觉果位，但不舍万行因门。也就是说菩萨虽已成佛，断尽障碍，具足众德，自利圆满，然不舍悲愿，只为度生，隐藏真实功德，显现菩萨身行。如普贤、文殊、观世音等。因为他遍证最高果位称为“普”，不舍因门称为“贤”。“行愿”二者如鸟双翼，如车两轮，必须同时具足否则无法高飞远行。

    此上略释经题，但应知佛的一切经教言论无非都是指示我们的自心本性。佛经如标月之指，所以我们应借助于此手指返观自心，才能了知经中所诠不思议解脱境界，以及普贤等恒沙圣众实不出自己心性之内。如李通玄长者云：“无边刹境自他不隔于毫端，十世古今始终不移于当念。”

    此略释只依偈颂作解释，在解释的过程中参考揉和了汉藏两土成就大德的可靠观点，并且尽量参照长行文以作补充，力求经义完整无缺。


前行七支行愿：随喜功德

丁五、随喜功德

    修随喜可以消除嫉妒的障碍，得广大眷属。

    颂曰：
    十方一切诸众生，二乘有学及无学，
    一切如来与菩萨，所有功德皆随喜。

    默默观想十方微尘数世界的一切众生、声闻乘缘觉乘的四果圣者以及一切如来和菩萨所修积的善根，我皆欢喜愉悦深深随喜。

    狮子乳非琉璃的容器所不能盛，千斤鼎岂是一发所能提起。同样要修行大乘，必须是大法器，具大力量者方能行持。否则狮子乳放在瓦器中，瓦器立刻崩裂，一根头发欲提千斤之鼎则当下断折。如果心胸狭隘、目光短浅、嫉妒心强，则见人造恶欢喜赞叹、鼎力襄助，而见亲友或他人出家以及修行善法、断除恶法时，心中却难以包容，妒火盛燃不惜口舌身力，以超常的热情为他人的堕落提供各种的顺缘，直至他生起邪见、退失道心、放下修行方为究竟。这样的人不论他是父母还是亲友都是修行者的魔障。学习佛法就是要改造内心，消除嫉妒，使自己的心量等虚空遍法界，才能契入佛菩萨甚深广大的境界。学大乘法的人不但对他人的一毫善法要随喜赞叹，而且对于无端的责难、蛮横的损害等诸种不如法的恶行，也要能坦然相待、宽容包涵。否则如小池塘无法容纳百川众流，不但如此，仅仅一点废品乱物也能将它染污得秽浊不堪，心量小的人也是这样。但大海却能包含纳受一切江河溪流，且无论外缘如何污秽繁杂，海水色味依旧不变。所以大乘行者心胸当广如大海。

    随喜恶行获得罪业，相反随喜善法获得福报也是合情合理的。随喜在轻松愉快之中就能获得福报功德，而且随喜功德极大，如《汇集经》中云：“三千须弥可称量，随喜善根不可量。”佛说三千大千世界及须弥山都能衡量它的大小，但诚心随喜的功德却是无法衡量的。《华严经》中佛对帝释天说：“憍尸迦，三千大千国土中满中海水，可取一发破为百分，以一分发滴取海水可知滴数，是随喜福终不可数。”《法华经》中说：「若有人对四百万亿阿僧祇世界六道众生，在八十年中布施七宝及象马车乘宫殿等，又以佛法教化他们都得到沙门四果，如是所得功德极大。不如第五十人闻《法华经》一偈而随喜的功德百分之一，乃至算数譬喻所不能知。亲临法席听闻随喜的功德就更无法衡量了。」

    有人心中疑惑自己不费吹灰之力，为什么随喜就会获得功德呢？答曰：因为随喜是善心，又对治了嫉妒的恶心，所以当然有功德。如站在旁边看他人卖香，身上自然熏染香气。所以永明延寿禅师云：“随喜赞善，助他胜缘，虽不亲作，得同善根。”论中说：「在无常的世界中，众生都被愚痴所蒙蔽，如果有人作功德，见到的人心生随喜，赞叹称扬，发此大心，就能成就功德。菩萨仅以随喜心即能胜过二乘人。」龙树菩萨在《十住婆沙论》中云：“所有布施福，持戒福，修禅慧福，从身语意生，去来今所有，习学三乘人，具足一乘者，无量人天福，皆随而欢喜。”从能修行福德的对境来分，有六道众生、声闻缘觉、一切菩萨及诸佛世尊。从功德而分有世俗谛与胜义谛的功德。这一切功德我悉皆随喜。此下进一步详细解说：

    一随喜如来功德：在整个大法界中，过去现在未来都有世界微尘数的诸佛如来出兴世间，自从初发无上菩提大愿，中间为求一切智智宝，精进修一切广大福德，不惜身命，在不可记数的大劫中舍弃了不可说不可说数目的头目手足等，修种种难行苦行，圆满布施、持戒、忍辱、精进、禅定、般若、方便、愿、力、智十度波罗蜜，证入一地乃至十地等觉妙觉果位，成就无上菩提。转大法轮度化无边有情，示现大般涅槃，留下舍利造福人天，所有功德悉皆随喜。如我等大师大悲释尊，因地施舍国城七宝妻子儿女之外财尚不足说，仅是舍弃头目脑髓也多如大地微尘。如雪山童子为求半偈而舍弃全身，萨埵王子舍身救虎，六牙象王自献猎人，圆满福智王施舍眼睛，金色鹿王舍身救护同伴，慈力王血肉布施五夜叉，如是种种难行苦行。欲详细了解，当阅《贤愚经》、《菩萨本行经》、《白莲花传》等。《法华经》云：“观三千大千世界，乃至无有芥子许非菩萨舍身命处。”

    如来涅槃人天悲仰，为度化后世的有缘众生，令众生种下当来解脱的种子，如来以智慧火焚燃全身，出八斗四斛舍利，人、天、龙各得一份。后来阿育王遣派神鬼，在南赡部洲建八万四千舍利宝塔，成为人天供养的福田。佛灭度后舍利等同如来真身，若人瞻礼，功德无异。（汉地除佛牙舍利塔外，尚有十九座舍利塔，这也是汉地众生的福报。）《无上依经》云：“若得如来身分如芥子许。一瞻一礼，千返生于大梵天上，受诸快乐。”如《入中论》云：“佛德无边若虚空，弟子菩萨莫能宣。”总之如来的无边功德悉皆随喜。

    二随喜菩萨功德：大乘圣者菩萨出定入定所修戒定慧的解脱资粮悉皆随喜。

    三随喜二乘功德：二乘即声闻乘与缘觉乘。声闻以出离心持清净戒，修头陀行，证悟苦集灭道四谛真理，经五道位断烦恼障碍，得阿罗汉果位。今于预流、一来、不来、阿罗汉果所修功德悉皆随喜。缘觉有两种：部行缘觉与麟角喻缘觉，缘觉在出离心的基础上修十二因缘，圆满百劫资粮，证得独觉果位。总之二乘中有学道或无学道都是人天福田，都应诚心随喜。

    四随喜众生功德：十方六道中胎卵湿化四生有情，发无上菩提心、大慈大悲心、善心、信心、出离心者或有修布施持戒者，或作闻思修如读诵经典、烧香礼拜、绕塔转经、念佛念咒、打坐及观修者，总之若众生有一点一滴的善根，我悉皆发清净心随喜赞叹。


别发十大愿：修行二利愿：消除障碍愿

    庚三、消除障碍愿

    灭除障垢无有余，

    灭除一切障碍垢染，令彼荡涤无余。

    一切修行者之所以不能顺利无碍地修行成就，是因为无始以来在阿赖耶识中留下许多恶业种子习气，它将自性清净心障蔽染污。现在我们要修行开发性净明体真如妙心，这些多生累劫的罪业烦恼之恶势力绝不会善罢甘休，它们尽一切力量阻止修行者顺利成就。因此修行者在修行时会出现各种各样的障碍，如贪欲心炽盛、嗔恨心猛烈、愚痴心深厚、我慢心高大、邪见坚固等等。或自想断恶却好似被一股无形的力量所支配，行不由衷地大造特造十不善的恶业。正鼓足勇气修行时，却心烦意乱，魔障猖狂，重病蜂至，障缘涌来，信心退失，精进难发，这些障碍多得让人发怵，简直令人惊诧。所以很多修行人至此不知所措甚至一蹶不振，终止修行，深为惋惜哀叹。这些烦恼恶势力通常来说由这几部分组成：悭吝、毁禁、嗔恚、懈怠、散乱、愚痴、耽滞、退屈、怯劣、昧事，或归纳来说不出烦恼障与所知障。这些障碍，近障得到人天善趣的安乐，远障得到自利的声缘果位，尤其障碍得到成办自他二利的菩萨佛果。当我们发菩提心修六波罗蜜时，它们就幻变出各种形象来横加干扰，破坏摧毁，且隐蔽难防，修行者平日稍不谨慎即入此烦恼魔障，自己不能省察。现在既然知道烦恼敌军的组成体系，应该发动正义的忏悔军队，以所依、厌患、返回、现行四大得力将军，统领各部人马，一鼓作气地歼灭所有的恶业敌人。下面对四大将军及其本领特长作番介绍：

    “我乃‘所依’大将军，灭敌我有大本领，忏悔大军若要进，首当其冲我先锋。”所依大将军是忏悔军的先行军也是总先锋，是否能旗开得胜，得看它的本领。原来他搬来一切三宝的所依佛像，经书宝塔，还迎请了圆满十力四无畏的所有十方一切诸佛如来，尤其灭罪之王的金刚萨埵主尊作为一切海会的部主，他们都光临压阵，作为所依将军的强大后盾。加上他自己拥有清净信心与广大菩提心的两员虎将，因此它勇气十足，列阵待敌。

    “我乃‘厌患’大将军，机智骁勇具大能，深入罪巢探敌情，提供情报我最行。”厌患大将军机智勇敢，不怕人情面子，深入敌军营垒中，逐一查访，把隐藏在黑暗深处的贪嗔痴慢疑以及三障、十障、二障个个都给纠出来，露形于所依大将军之前。诚如藕益大师所云：“破戒虽恶，覆藏尤恶。无过虽善，改过尤善。改过一途，三世诸佛证菩提之通津也。故五悔法门，凡夫迄等觉，无不藉为进趣方便，忧悔吝者存乎介，震无咎者存乎悔。祸福无门，惟人自召。世人正造罪时，实是大恶，不以为耻，向人发露，善中之善，反以为羞，甘于恶而苦于善，遂成恶中之恶，永无出期，颠倒愚痴，莫此为甚。众中忏悔，能使不犯者倍加警策，已犯者深生惭愧，或亦发心忏悔。学好者增长善根，讥笑者亦植远因，兼可消我夙罪，诫我未来。如来立法，决定不错，违诸佛语者，非佛弟子。矧造已能悔，即是猛勇丈夫，可敬可畏，勇改一念，成佛正因，非具真信心深善根，不能将此法门，流通人世，凡能此者，皆当与勇施比丘同垂不朽。”所以不能认识罪业的过患，或耻于发露坦白，则无法把罪业忏悔清净。藏地大成就者噶玛恰美仁波切说：「如果没有追悔发露罪业的心，则无法忏悔清净，因此对往昔所造的罪业犹如吞食毒药，应当以惭愧畏惧之心而忏悔它。」

    “我乃‘返回’大将军，勇猛果断而著称，竭力乘胜追穷寇，誓当灭除无遗余。”返回大将军雄威大势，堵截一切罪恶敌军，毫不留情，绝不放过一个留下残余，要彼现行大军一举歼灭。如观音化身之恰美仁波切在《极乐愿文》中云：“若无戒心不净故，发誓今后遇命难，亦将不造不善业。”发誓永断造罪恶的相续心，使之即时中断。正如六祖大师所说：“忏者忏其前愆，悔者悔其后过。”否则如大象洗澡，无有休止则罪业永远无法净除。

    “我乃‘现行’大将军，派遣十度万行兵，念佛持咒礼拜频，诵经经行又坐禅，随喜回向菩提门，复借般若空性力，本来清净光明性，刹那灭除恒沙障。”现行大将军镇定自若，从容自在地调遣世俗胜义的两支大部队。世俗上十恶以十善对治，十障以十波罗蜜对治，在以菩提心摄持下念佛、持咒、观想、礼拜、诵经、转绕经行、坐禅静虑、随喜善根、回向无上大菩提的种种方便门来净除。这时烦恼障与所知障微细的魔军，潜形隐身藏到五蕴阿赖耶无明黑暗的堡垒中。大将军对此洞若观火，看得一清二楚，所以观五蕴假立虚幻，其中空无一物，将我执烦恼魔即刻消灭。又复观阿赖耶识所现内外诸法悉皆空寂离戏，法执大魔本体当下被粉碎瓦解。

    如此厮杀混战甚觉劳心劳力。大将军想：“若不费一兵一卒而能大获全胜岂不妙哉！”随即入定观察，发现如来藏恒时清净，有恒沙功德妙用，一切障碍从本以来未曾染污，恒时放大光明，为什么不直下探取这如意宝珠而安然享乐呢？所以大将军以智慧光遍照人们认为的业障烦恼，却惊人地发现：业障本来是清净解脱的，贪嗔痴五毒原来就是五智慧，烦恼却是菩提，众生本来成佛，不差不欠，圆满具足。所以它不降却降伏了八万魔兵，不求却证得了无上佛果，登上永不坏灭的金刚座，任运唱金刚歌“君不见，绝学无为闲道人，不断妄想不求真。无明实性即佛性，幻化空身即法身。证实相，无人法，刹那灭却阿鼻业。顿觉了，如来禅，六度万行体中圆。无价珍，用无尽，利物应机终不吝。三身四智体中圆，八解六通心地印。”


别发十大愿：修行二利愿：修波罗蜜愿

菩萨发起上弘下化的伟大誓愿后，当修行一切妙行来成办二利事业，下面的颂文就是开示修行二利的具体内容。

    庚一、修波罗蜜愿

    勤修清净波罗蜜，

    愿我生生世世之中，都能精进不懈地修持各种清净波罗蜜多。

    波罗蜜是梵语，译成汉文是到彼岸。生死轮回是此岸，烦恼妄念是中间的水流，大空离戏是彼岸。众生没有空性智慧，安住在生死的此岸，沉溺在烦恼的水流之中起惑造业，陷于没有边际的轮回大海中。但依靠修持无相般若智慧，照见五蕴空无一物，就是离开此岸；寂灭一切妄念分别，即是跨越中流；证得法性真如，可以说是到达彼岸。《唯识论》中认为：「现在发起苦谛与集谛就是此岸，没有生起苦集的二乘果则为中流，菩提涅槃是彼岸。六度作为船筏，把修行人度到彼岸。」龙树菩萨在《大智度论》中指出此岸与彼岸有三种意义：「一、生死为此岸，菩提为彼岸。一切如来都是从生死此岸，越过生老病死的中流，到达菩提彼岸。二、有相为此岸，无相为彼岸。三、六种障蔽为此岸，对治彼等的六度为彼岸。」

    波罗蜜有布施、持戒、忍辱、精进、禅定、般若、方便、愿、力、智共十种。

    一、布施波罗蜜：布施有三种，即财布施、无畏布施、法布施。财布施在《瑜伽师地论》中说：「菩萨的所有财物不论多少，都先要发心，布施给一切众生。当真正有众生来求施时，应当象来领取他们自己的东西一样，给的时候就象还他们的财物一般。见到来求者，始终不嗤笑、轻弄他们，也不要让他们惭愧不好意思。不应皱着眉头，心中不高兴，应该开颜含笑，快快给予。」无畏施：当其它众生有恐怖，有灾难祸殃时，菩萨应以种种方便，救护他们脱离出来，远离怖畏。或者对禽兽们应全力以赴地救拔保护，让它们免受恼害，如此可称为无畏施。法施：就是对众生宣讲演说开示正法，将众生引导到解脱正途上来。

    二、净戒波罗蜜分三：摄律仪戒、摄善法戒、饶益有情戒。防止错误，断除恶法称之为戒，对戒不毁不犯称为净。（一）摄律仪戒：断除一切恶法。（二）摄善法戒：修持一切善法。（三）饶益有情戒：以无有罪恶的意乐普遍利益众生。《摄大乘论》中云：“由摄律仪戒，能建立菩萨行。由摄善法戒，能广集佛法。由饶益有情戒，能无罪利益。”

    三、忍辱波罗蜜多分三：耐怨害忍、安受苦忍、法忍。他人加恶称为辱，安然受之称为忍。（一）耐怨害忍：由大悲心不舍弃有情，对怨敌仇害安然忍受，不生恚怒。（二）安受苦忍：修行时遇到寒热饥渴等苦，安然忍受，不生退转。（三）法忍：观察谛审一切诸法不生不灭，安然忍受，并证悟它。无生法忍作为前两种忍的依靠处，因为了达法忍，才能坦然忍受怨害及痛苦。

    四、精进波罗蜜多分三：披甲精进、摄善精进、利乐有情精进。勇捍不退称为进，万行不杂，称之为精。（一）披甲精进：犹如猛将身披甲胄，能摧灭怨敌，心无退屈的菩萨也是如此。披甲精进，修积万行，降伏四种魔怨。（二）摄善精进：修习善法，进取无倦。（三）利乐有情精进：于饶益有情事不生疲厌。

    五、禅定波罗蜜分三：安住静虑、引发静虑、办事静虑。专注一境名禅，摄心不乱名定。总之，分别心澄清寂静称为静虑。（一）安住静虑：心安住时，轻安愉悦，受用法乐，无有厌倦。（二）引发静虑：依此定引发六神通及所欲之事悉能圆满。（三）办事静虑：依此定力成办利乐有情的事业。如以定力止息饥馑灾荒，瘟疫传染等。

    六、般若波罗蜜分三：生空无分别慧、法空无分别慧、俱空无分别慧。（一）生空无分别慧：即声缘所证人无我空性的智慧。（二）法空无分别慧：菩萨所证诸法空无我的智慧。（三）俱空无分别慧：证得人无我、法无我平等是离一切戏论边际的大空智慧。

    七、方便波罗蜜分二：回向方便，拔济方便。自在的摄受度化众生，随机应变，善离诸过，称为方便。（一）回向方便：以前六度所修积的一切善根，善巧回向自他一切众生得到无上正等菩提。（二）拔济方便：所有善根一一都为拔济一切有情脱离苦难。

    八、愿波罗蜜分二：求菩提愿、利乐他愿。专心向乐，志求不退称之为愿。（一）求菩提愿：志求无上菩提佛果。（二）利乐他愿：志求利乐诸有情。

    九、力波罗蜜分二：思择力、修习力。具有殊胜的堪能，不可屈服，称之为力。（一）思择力：思择可作不可作等。（二）修习力：修万行时不退屈。由此二力能令前六度相续不断。

    十、智波罗蜜分二：受用法乐智、成就有情智。决断诸法，能善加了知，称之为智。（一）受用法乐智：由布施等波罗蜜，成就此智，又由此智成立施等，如此自在，称为受用法乐智。（二）成就有情智：由此妙智，能正确了知施戒忍等，而饶益有情。《摄大乘论》云：“由施能摄受有情，由戒能不害有情，由忍遭苦能受，由勤能助他有情所作善事，由定未定者令定也，为未得定诸有情说行相方便，令彼有情成办此定。由慧为已得定者，令解脱等。菩萨自己得出世间慧，断障得解脱已，广为一切得定者，说远离世间解脱功德。不令依定求有忻上，令依已得上地胜定，远起加行，引出世间慧，即断障解脱故，名成熟有情也。”

    因为菩萨有十地，所对治的障蔽有悭贪、毁禁、嗔恚、懈怠、散乱、愚痴、耽滞、退屈、怯劣、昧事十种，所以有十波罗蜜。


随学二圣愿：愿等普贤

    己一、愿等普贤

    一切如来有长子，彼名号曰普贤尊，
    我今回向诸善根，愿诸智行悉同彼。
    愿身口意恒清净，诸行刹土亦复然，
    如是智慧号普贤，愿我与彼皆同等。

    这二颂是激励修行者发愿回向，以普贤菩萨作为榜样，向他学习，向他靠拢，成就与他完全一样的功德果位。普贤菩萨发大菩提心所起愿行及身口意，悉皆平等遍一切处，纯一善妙，具备恒沙功德。所以是一切诸佛的长子，能荷担一切如来的家业，撑持诸佛门户，续佛慧命，令不断绝。《楞严经》云：“普贤菩萨言：我已曾与恒沙如来为法王子，十方如来教其弟子菩萨根者，修普贤行，从我立名。”菩萨的根本修法即普贤行，十方诸佛都教弟子修习普贤行门。因此作为大乘修行人的我们，应当遵佛教导，发菩提心，修普贤行，回向善根，愿如普贤成为一切如来的长子，名称普闻十方一切国土。具足如普贤一样甚深难测的智慧光明，照彻轮涅一切法性，于四无碍法界朗然无余。圆满普贤浩瀚无涯的一切微妙行门。成就普贤端严身相，彼身如紫金山端正微妙，三十二相悉皆具足。其身毛孔放大光明，光中化现无量诸佛。其身一毛孔中有无量无边诸佛刹土，每一毛孔都为无量功德所庄严，十方世界普具金身微妙殊特最为第一。又愿成就普贤清净之口，《华严经》中说普贤之口微妙清净，如佛无异，一音中出无量语，一语中出无量言辞，演说无尽妙义。口中成就无量功德，恒时放大光明。又愿成就普贤清净之意。《楞严经》中普贤自说因地“心闻发明，分别自在，斯为第一。”如果在恒沙界外的一个众生，心中发明普贤行，普贤菩萨即时了知，乘六牙白象，分百千身，降临到彼住所处，摩顶拥护，加持使其成就。一切妙行、刹土与彼无异。如此智慧称为普贤，愿我现前成就与彼同等一味的功德。

    普贤菩萨从外义上来说就是东方宝威德上王佛国的大菩萨，华严三圣之一，位居妙觉，发十大愿王，于中国峨嵋山银色世界应化，乘六牙白象住佛右侧的辅弼大士。从《华严经》、《法华经》、《普贤观经》、《楞严经》中可了知他具有不可思议无边功德，所以应当随学并成就普贤菩萨的果位。佛法当于行人内心建立，从“如是智慧号普贤，愿我与彼皆同等。”可明显看出，普贤是法界智慧之自相，并非仅仅指有形象的普贤菩萨。经中云：“普贤真身遍法界，能为世间自在主，无始无终无生灭，性相常住等虚空。”所以应发愿成就了义的普贤智慧身。


随学二圣愿：愿等文殊

    己二、愿等文殊

    我为遍净普贤行，文殊师利诸大愿，
    满彼事业尽无余，未来际劫恒无倦。
    我所修行无有量，获得无量诸功德，
    安住无量诸行中，了达一切神通力。
    文殊师利勇猛智，普贤慧行亦复然，
    我今回向诸善根，随彼一切常修学。

    菩萨发愿说：我愿普遍地修持普贤菩萨的种种大行，也愿普遍地实践文殊师利菩萨的种种大愿，而且使所修的大行及实践的大愿，清净洁白无有瑕疵。文殊代表智慧，普贤代表行愿，只有智行合一，所修的菩萨行才能成就正觉佛果功德。所以我们应追随效仿两位大士，以他们的行愿作为我们的行愿，这样才能廓开狭窄的心胸，扩展心胸眼界，才能入无尽行愿大海，必使一切行愿获得圆满，一切事业无不成就。如此的愿行精进行持，尽未来际一切时劫毫不厌倦。既然学习文殊普贤两大菩萨的广大境界，自己所修法门就应无量无边，因为因地修行清净广大，亦将获得无量无边的功德。于一身一念之中安住无量妙行，遍于尘尘刹刹浩瀚无边大法界中，以无量身形遍修一切行门，纵然诸法纷繁芜杂，但我以无碍神通悉皆洞明了达。《华严经》云：“往修胜行无有边，今获神通亦无量，法门广辟如尘数，悉使众生深悟喜。”文殊师利菩萨至高无上的勇猛大智，普贤菩萨广大无边的慧行，我都能无有偏颇、等同一味地回向善根，跟随他们恒常修学。


别发十大愿：受持愿：出家持戒愿

    庚三、转法轮愿

    天龙夜叉鸠槃茶，乃至人与非人等，
    所有一切众生语，悉以诸音而说法。

    不同的众生有着不同的语言，要想度化他们，就应以他们各自的语言转法轮，否则他们无法理解并依教行持。所以为消除因语言不通而对度化众生的伟大事业造成的障碍，菩萨们发愿得到佛的微妙圆音，这样对天人、龙王、夜叉、鸠槃荼、人、非人等的一切众生，用他们各自的语言为他们宣说佛法。以期使千差万别的众生都能学习修行佛法、成就佛果。

    如果没有如佛一样的无碍语，则在弘法利生的过程中会有诸多的不方便，弘法的范围也会大大地缩小。正因为过去现在的大译师们发了这个愿，以我们的语言翻译著书造论、讲经说法，我们今天才得以闻思修行，否则我们将被置于佛法的大海之外。因此我们也要发此殊胜大愿，这也是护持佛法，有了语神通就能把佛法广泛弘扬到各类众生界中。


别发十大愿：转法轮愿

    己七、转法轮愿

    普尽十方诸刹海，一一毛端三世海，
    佛海及与国土海，我遍修行经劫海。
    一切如来语清净，一言具众音声海，
    随诸众生意乐音，一一流佛辩才海。
    三世一切诸如来，于彼无尽语言海，
    恒转理趣妙法轮，我深智力普能入。

    普遍穷尽十方空间中的无量无边佛刹国土。一个毛端代表过去现在未来的所有无限时间，所有的一一毛端代表无穷无尽的时间。就在这广大的空间、漫长的时间里，有无量无边的诸佛如来以及佛刹国土，我在一一佛土，一一佛前，广修六度万行，历经一切时劫。一切如来语业难思，故语音清净和雅，一言之中出生无量音声，一一音声随无量众生的不同根基意乐，流出诸佛如来无量无边的无碍辩才。三世一切诸佛如来，发出无尽的语言大海，恒时转动契合真理意趣的微妙法轮，我以甚深勇猛的智慧力一一皆能趣入，善解理趣，深入法性。

    颂中的“海”是形容词，比喻甚深广大不可穷尽。按清凉国师及圭峰宗密禅师的观点：此三颂是普皆回向中别发十大愿第七愿，叫做转法轮愿或称为摄法上首愿。

    第一颂指出转法轮的道场处，即十方一切佛刹国土海中。转法轮的时间即无限的三世一切时劫之中。转法轮者即无量无边的诸佛如来。菩萨发愿一一听受摄持，如说修行，复为其他众生宣说。

    第二颂宣说能转法轮的如来圆音。用十种比喻解释佛的圆音：一、劫尽唱声喻：经中说世界即将坏灭时，无主无作自然发出四种音声，警劝欲界色界众生入四禅天，众生听后自然得生相应禅天。佛音也是如此，无主无作从佛功德海发出四种音声，开示痛苦众生，教令修习人天乘的善行，以及声闻乘、缘觉乘、无上佛乘。二、响声随缘喻：譬如山谷回音，是因为有山谷及音声才产生的，无形无相，无法看见，但随缘即应，丝毫不虚。佛音也是如此，随众生欲乐信解而出生，其声究竟无言无示。三、天鼓开觉喻：譬如天上有大法鼓名叫开悟，无作无主，无起无灭，若诸天放逸时，空中发出音声说：你们应当了知一切法无常虚妄变化坏灭，切勿贪恋不舍，若行放逸终将后悔莫及。”天人听后敛束身心，求法修行，获得安乐。佛音也是如此，无有住处，无有言说，但能演出无功用声，周遍法界，警悟群生。四、天女妙声喻：譬如善口天女，发一妙音，能与百千种音乐节拍相合。每一歌声中又发出百千种音声。佛音也是如此，一音中出无量声，随众生心念，各生意解。五、梵王声喻：比喻度化不失时机。譬如梵王住在宫中发出言语，众梵天同时都能听到，每一个都认为针对他讲话，但梵天外的众生无法听到。佛音也是如此，佛出一音，众人都认为佛针对自己而说，根基没有成熟的众生则不会听到。六、众水一味喻：譬如很多水味道相同，但因为水器不同而有差别，然而水无分别。佛音也是如此，同一解脱法味，但因众生根基不同则所理解的也不同。七、降雨滋荣喻：譬如阿那达多龙王，兴大密云，在阎浮提普降甘雨，百草五谷茂盛成长，江河泉池全部充满，然而水不从龙王身心而出，但能饶益众生。佛音也是如此，普兴慈悲密云，降注甘露法雨，令众生欢喜，增长善法，成就各乘行人，不出不来，饶益一切众生。八、渐降成熟喻：比喻没有快慢。譬如摩那斯龙王，将要降雨，不会立即就降，先起大云，遍布虚空，停留七日，等众生把事情作完，然后渐渐降下，普遍润泽大地。佛音也是如此，先兴法云，等众生根基已经成熟，然后才降澍法雨，令众生得到无上法味。九、降注难思喻：比喻虽有差别，但悉皆同一法性。譬如大庄严龙王，在大海中降下百千庄严雨，但水性无有差别，龙王难思之力使之庄严。佛音也是如此，无有分别，或以十音百音千音八万四千音无量音等说法，随顺众生根基，悉令欢喜。十、遍降种种喻：譬如娑羯罗龙王，以自在神力饶益众生，悉令欢喜，兴云弥漫天空，云都呈现各种斑斓的色彩，形态各异。放出很多闪电光明，然后在四天下普降种种雨。龙的心虽然平等，但众生善根不同则所得有异。佛音也是如此，欲行法化，先行化现无量身云，充满法界，随众生意乐，显现不同身形，振法雷，降法雨。略有如上十种功德，所以称佛清净音声为圆音、一音、迦陵频伽音等，即清净微妙和雅难思之义。

    第三颂初句指出转法轮的法主，次句讲转法轮的语言如无尽之海，三句讲所转法轮，四句讲发愿趣入佛法，即闻思证入诸佛如来所转微妙法轮甚深意趣之中。

    弥勒菩萨说：最究竟的度化众生的方式就是成佛转法轮。所以要普遍劝化救度众生，只有成就如来清净语业，以如佛一样不可思议功德，契合法界一切众生根基，降澍法雨，洗涤众生尘劳，令得解脱甘露法味。菩萨发起宏誓大愿，历经无量佛刹，无尽时劫，亲近无边诸佛如来，遍修如海广大妙行，成就智力，入佛境界，具佛功德。如佛无异恒转法轮济度群迷。所以我们也要培养自身的般若智慧，开发自性本具无量功德妙用，以至能深入重重叠叠圆满无碍的解脱境界，并兴大悲云，于十方三世中转大法轮，无有休止。


别发十大愿：修行二利愿：自由无碍愿

    庚五、自由无碍愿

    于诸惑业及魔境，世间道中得解脱，
    犹如莲花不著水，亦如日月不住空。

    菩萨回向发愿说：愿我成办二利宏伟大业时，在无明业惑四魔境界以及烦恼世间之中自由无碍，随意解脱，犹如莲花出水不被泥水所染著，而恒常纯净香洁。犹如光明遍照的日月，虽在空中而不耽著，运行无碍。

    一般凡夫被无明所蒙蔽，业力烦恼所牵缠，病魔、死魔、蕴魔、天魔、烦恼魔所恼害，沉湎在世间恩爱怨恨的漩涡中，被财食名色睡五条绳索所束缚，兴衰、苦乐、毁誉、称讥八风所飘荡，无有自在。即使有缘遇到善法，也易退失道心、放下修行。但菩萨不会如此懦弱而屈服的，也不会象声闻独觉因畏惧害怕轮回烦恼而独自寻找自己的解脱。菩萨则以大无畏的精神，为探取一切智智宝，为度化无尽的众生，不惜深入烦恼海中，甘作业惑苦海大浪中的弄潮儿。不惧一切无明烦恼及众魔立下庄严誓言：“我要照破一切无明黑暗；解脱一切烦恼束缚；枯竭一切生老病死的苦海；降伏八万四千魔军；在世间烦恼淤泥中盛开微妙香洁的妙莲花——解脱功德果，任一切众生随意享受。愿我成为光明的日月，不耽著空寂乐果，周行天下，照耀大地，乃至生生世世，绝不停息。”

    洛钦大译师指出“犹如莲花不著水”一句对应“于诸惑业及魔境”，“亦如日月不著空”对应“世间道中得解脱”。因为如《维摩诘经》所说：「莲花生于卑地污泥之中，菩提妙花也生在业惑烦恼之中，但不被烦恼所染污，莲花也不会染著泥水。」所以菩萨祖师大德们入于生死惑业魔境之中，不被恶劣外境牵制，常能奉身洁好，不忘菩提心，不舍六波罗蜜，相反借助烦恼业惑魔障，而趣向菩提解脱。《大涅槃经》云：“于生死中，不失念慧，以不失故，虽见五欲，心不贪著。”如释迦世尊历世之中，常得国王尊贵之身，真是“普天之下莫非王臣，率土之滨莫非王土。”数万王妃婇女围绕，数千王子恭敬承侍，迷人的歌舞，醉心的享受，广大的声誉，他却毫不耽著，时常发大悲心、大慈心、菩提心、出离心，未尝被烦恼罪恶染污，也未尝沉溺在声色犬马之中。如悉达多太子，视转轮王位、三万娇妻美妾如草芥而出家修道。不因恩爱而难舍；不因尊贵而怯弱；不因苦难违缘而退屈；不因艰辛病苦而废弃苦行；不因魔障强大而畏惧不前。正好相反，为了解救自他出离烦恼的渊薮而发大誓愿、奋大精进、兴大勇猛，写下震撼三千大千世界、断尽无边无际的烦恼、降伏难以计数的魔障、救拔无量无边众生出离轮回苦海的成佛之歌。

    所以释迦佛遇到提婆达多这个生生世世的冤家对头，却使他提前圆满菩提。古德也说：“八苦为师。”没有痛苦修行者不会希求解脱出离，没有烦恼业惑魔障瑜伽士不会励力修行。《维摩诘经》云：“虽为白衣，奉持沙门清净律行。虽处居家，不著三界。示有妻子，常行梵行。现有眷属，常乐远离。虽明世典，常乐佛法。”又云：“不断淫怒痴，亦不与俱。不灭痴爱起于解脱。”如地藏王、观世音、文殊师利等菩萨皆乘悲愿力，入于轮回业障之海，如处清净刹土，不被系缚，任运度化众生。《经观庄严论》中说：「菩萨在轮回中度化众生，如游观花园，自在快乐。」《涅槃经》也说：「菩萨入地狱中，如受三禅快乐，一切痛苦不能殃及菩萨。」

    如禅宗道树禅师给弟子们说：“过去我住山的时候，天天有许多野人，言谈神秘诡异，幻化莫测。时尔化作佛菩萨，时尔化作罗汉天仙，时尔大放光明，时尔出大音声，这样十个年头中，没有间断。虽然他们眩惑人心的把戏伎俩很多，但是我不见不闻不生执著的见解没有穷尽，最终他们都销声匿迹了。”由此可见若具有强烈的出离心、大悲菩提心、清净智慧，绝对不会被世间所拘缚，而能在世间令自他得到解脱。

    一切诸佛总集的化身法王如意宝为了完成度生的伟大使命，求得大圣文殊师利的加被，在公元一九八七年带领万千大众奔赴金色世界大清凉山，举行了百日大朝圣。上师住在菩萨顶时，按照惯例，每天上午十点钟，到塔院寺为僧众们敷演妙法。一天上师在通向塔院寺的途中想：“我应该观察一下以后弘法利生的缘起如何呢？”如是作意之后，正当阳光普照大地之时，上师登上法座，此时僧众们的海潮音在空中回荡——“于诸惑业及魔境，世间道中得解脱，犹如莲花不著水，亦如日月不住空。”缘起非常殊胜吉祥，法王如意宝如狮子王雄踞于菩萨顶上，以狮吼声对大众宣说：“今天我观察缘起吉祥圆满，这预示着我们弘法利生的事业，任何魔障违缘也无法阻挠，而且会任运自在地展开。”

    在末法的如今，要度化无量烦恼无明深厚的众生，要展开全世界范围内的广大弘法利生事业，十方一切的魔障都会出来作违缘。虽然在法王如意宝二十个年头的弘法度生生涯中，出现过各种各样大大小小的违缘魔障，但都被粉碎无余，而且度生事业广大犹如虚空。在将来因众生的共业，也许还会出现人非人等所制造的各种违缘，或风雨交加、或雷鸣电闪、或冰雹霜雪，但以殊胜的缘起力，上师的誓愿力，佛法僧上师本尊空行护法的加持力，一定会摧灭一切烦恼，降伏一切诸魔悉令无有遗余，最终证明上师金刚语是诚实不虚的。大家都瞩目以待着：魔军的黑幢马上殒落、胜利的法幢高高树起的胜利佳节。


随学二圣愿：总结回向

    己三、总结回向

    三世诸佛所称叹，如是最胜诸大愿，
    我今回向诸善根，为得普贤殊胜行。

    三世一切诸佛悉皆称扬赞叹如此殊胜的大愿王，我今总集三世所造一切善根，作殊胜的回向，祈愿得到普贤的殊胜妙行。

    《华严经》中文殊、普贤都有不同的象征意义。最初修行时，普贤是所信的法界，文殊是能信的心念。所信的法界就是自身中被烦恼缠缚障蔽的如来藏。《般若理趣品》中云：“一切众生皆如来藏普贤菩萨自体遍故。”华严初会普贤即入藏身三昧，也就是这个意思。要通过文殊的信心，对此产生信解。《佛名经》中云：“一切诸佛皆因文殊而发心。”善财童子也是因为见到文殊之后，才发起大菩提心。所以经中说从文殊出生一切菩萨，无有止息。如果初学者对此没有信念与认识，那么可以说他学佛修行的目标尚不明确，因为不知不信自身本具如来藏。

    当修行者深信自心本具佛性，则应发起六度万行，在阿赖耶的矿藏中开发出佛性摩尼宝珠，否则只是心中想想，口中念念，佛性不会无缘无故显发出来。在此阶段是修行起步时，但在迈步前行之前，必须具备如眼睛一样的定解。所以此时文殊表示如目正见，普贤表示正行健足。此时彼二不能偏离。《慈氏章》中云：“汝得见诸善友，闻菩萨行，入解脱门，皆是文殊威神力故。”很多修行人虽然也发心要悟明心地，显发自心真如佛性，但因见解不正，盲修瞎炼，纵经多年，也是徒劳身心。有些虽具知见，但执理废事，不起妙行，终究是说食数宝，对解脱无有大利。

    在以正见妙行如法修持渐趋深入时，要以无漏根本妙智契合清净法界。此时普贤代表出离缠缚障盖的如来藏，如善财修行入于普贤毛孔，一一毛孔广大无边等于法界，所以经中说普贤身相如虚空，又因见到普贤即得智波罗蜜，此即是说因证悟本体所以自然出生大智。文殊表示能证法界体性的大智，此智本来与佛无二一体，所以称为不动智，此智是一切诸佛之母，即般若旨趣。所以善财再次见到文殊，然后才见到普贤，说明依智慧才能证悟契入法界本体。如经云：“无有如外智能证于如，亦无智外如为智所入。”《曼殊干钵经》云：“尔时众中菩萨摩诃萨，一切有情，同修普贤曼殊行愿，证入毗卢遮那如来十大慈佛心观。”

    基道果三者二圣都能代表，所以一切修学都应随彼而修。尤其普贤文殊是得果而不舍因行，彼行愿即佛行愿。大乘的上上根修行者，当如普贤文殊以佛之知见，即站在佛果的高度上，来行持一切因地行门，如是则一行具足一切行，一切行悉同无漏智慧，离言绝相，契合法身，这也就是密宗金刚乘中把佛果转为道用的意趣。但显宗里只有大概道理上的一个说法，具体行持的方便少有解说，而在密宗尤其大圆满中，对这一行门作了深入细致具体的宣说，并以窍诀开示修法，可使行人于此五浊恶世中短暂的一生甚至仅仅六个月中成就毗卢遮那无上佛果，如此才是真正了义的随文殊普贤诸佛修学。

    正因为二大圣者殊胜无比，所以龙树菩萨说：“文殊师利勇猛智”至“为得普贤殊胜行”这两颂是极为殊胜的回向，也能包含一切的回向。


总结十大愿

    戊二、总结十大愿

    普能严净诸刹海，解脱一切众生海，
    善能分别诸法海，能甚深入智慧海。
    普能清净诸行海，圆满一切诸愿海，
    亲近供养诸佛海，修行无倦经劫海。
    三世一切诸如来，最胜菩提诸行愿，
    我皆供养圆满修，以普贤行悟菩提。

    这三颂是把以上分别宣说的十大愿王作归纳总结。一净土愿：愿我能普遍地清净庄严一切佛刹，使所有的国土，都成为净土。其中颂文中的“海”字是形容词，显示广大无边深不可测的意思。二成熟众生愿：愿我能普遍利益众生，使诸众生都能从世间牢狱与无明业惑束缚之中解脱出来，究竟安置在佛果大乐地上。三转法轮愿：愿我以甚深微妙的智慧，无碍通达所有法要。善巧分别暂时与究竟法、了义与不了义法、清净与染污法、善法与恶法、有漏与无漏法、有为与无为法。大小显密一切诸法的性相差别，为无边众生炽然解说无量无边诸法大海，使其趣入不思议解脱功德海中。四受持正法愿：愿我无余受持一切如来正法宝藏，得以深入甚深智慧中。即所谓：“深入经藏，智慧如海。”佛法是智慧的学说，当你畅游佛法大海之中，饱饮甘露法味，自然而然诸佛菩萨的智慧传递渗透到你的相续中。或者你的智慧宝藏经过佛经论典的启迪与开发，也会变得广大无边。五修行二利愿：愿我在修行二利事业时，一切修行都能清净无垢。有执著分别就是垢染，菩萨在修行时通达般若空性，如盲五度以般若智眼导引，自然能超离世间，成为无漏解脱清净善业。所以虽广行六度万行，而实无所行。虽度化无量无边众生入于无余涅槃，实无一众生得度。这样才是清净之妙行。六利益愿：初发心时为了将一切众生安置在无上正觉果位，而不为自己谋利益，只为众生得离苦，故发起无量如海宏誓大愿，修行八万四千如海行门，使一一诸愿悉皆圆满。

    如海大愿都可归纳在四宏誓愿中：即初发心“众生无边誓愿度”；经中说自身尚缚，欲解他缚无有是处，所以发大宏誓断除障碍度化众生的无边烦恼，即“烦恼无尽誓愿断”；要断无尽烦恼没有对治、摧灭烦恼的妙法，也是无济于事的，所以发大愿普遍亲近诸佛菩萨善知识听闻思维修习无量无边的微妙法门，即“法门无量誓愿学”；诸佛大道广阔无边，断除一切过患，成就无量功德，于世出世法最为自在，度化众生任运无碍，所以发愿誓求无上佛道，以诸佛大乘运载无量众生到涅槃城中，即“佛道无上誓愿成”。七承侍愿：即分身刹土遍入诸佛国土，亲近承侍诸佛世尊，尽未来劫际，念念相续，无有疲厌。八供养愿：愿我与彼普贤菩萨以等法界遍虚空的庄严供具周遍供养诸佛如来，念念相续，无有间断，身语意业无有疲厌。九不离愿：菩萨发愿无论处于何时何地，我都发愿与一切诸佛菩萨善知识同参道友，常不分离共同修行。无论经过多少时劫我都欢喜无厌地精进修行。十成正觉愿：即最后一偈所显示的内容。前三句是修的因，后一句是所得果。即三世一切诸如来的最胜无上菩提大道，我都以如法修行的无上法供养作圆满修持，以如普贤菩萨一样的修行证悟菩提正觉果。

    洛钦译师则认为前两颂是以事业而发愿，即发愿成就严净诸佛刹土海、解脱一切众生海、善能分别诸法海、深入智慧海、清净诸行海、圆满诸愿海、亲近供养诸佛海这些大事业。下一颂则是随佛修学的发愿。这样讲也完全符合经文。


总结行愿无尽

    丙四、总结行愿无尽

    乃至虚空世界尽，众生及业烦恼尽，
    如是一切无尽时，我愿究竟恒无尽。

    普贤行愿不论是十大愿王的总愿，还是统摄一切菩萨行的别愿，全部都是无穷无尽的。所以总结：我此行愿乃至于虚空、世界、众生、众生业力、众生烦恼全部灭尽之时，因为如是一切无有穷尽之时，故我行愿亦永无穷尽。


总集回向

乙三、总集回向

    我此普贤殊胜行，无边胜福皆回向，
    普愿沉溺诸众生，速往无量光佛刹。

    我将此普贤殊胜妙行所获得的无边殊胜功德都广大回向，普愿沉溺生死苦海中的一切众生迅速往生西方极乐世界无量光佛的清净刹土。

    虽然皓日已经当空并放射出无量的光芒，但是却仍然有人不见，也未感受到太阳的温暖；虽然甘霖普天而降，但是干涸的心田仍然未被润泽。这确实是件遗憾而悲哀的事情，也是应该同情的。释迦世尊在《文殊根本续》中亲口授记：“名为阿字大德者，受持佛陀之正法，具慧功德诸尊敬，授记获证正等觉，将悟我之诸菩提。”佛陀记莂的这位大德不是别人，正是法王如意宝。法王乘大悲愿力，应佛悬记，在五浊黑暗的今天，犹如大日轮遍照天下，生育众生善根的苗芽。慈悲密云中普降九乘佛法的甘霖滋润众生干涸的心田。然而今日尚有很多苦恼众生没有得到法王接引，尤其想往生极乐世界的修行人，没有与法王如意宝结上胜缘，这令人感到非常惋惜和遗憾。因为法王最大的心愿即是将有缘众生导引往生西方极乐世界，而且法王也完全具备这个能力，但无缘者毕竟诸佛也无法度化。

    几百年前藏地的大成就者菩提金刚授记书中写道：“单坚阿拉木天喇荣沟，邬金莲师化身名晋美，彼于菩萨四众眷属中，广弘显密教法如明日，利生事业顶天立地也，清净所化眷属遍十方，凡结缘者皆生极乐刹。”《法王传记》中说：“我今生最大的愿望就是凡与我结上仇缘或亲缘的所有众生都引到极乐世界。虽然有东方现喜刹土，邬金铜色吉祥山刹土等许许多多清净刹土，可是象极乐世界那样功德圆满，又极易往生的净刹却绝无仅有，而且往生后可以成就一切所愿，无勤度化一切有情……”法王在朝礼拉萨大昭寺觉沃佛像时，发愿悉心毕力地弘法利生，解脱沉溺轮回中的无数众生，使他们往生净土，随即入定，在境界中佛像放射耀眼的光芒，微笑着说：“善男子，以后凡是与你结缘的众生都能往生极乐世界。”这并非是毫无根据地标榜鼓吹自己的上师，而是提醒有缘的人、求解脱的人，尤其是求生净土的人，快快登上法王的大愿船，稳当快速地往生极乐世界，成就普贤行愿。

    《行愿品》的注疏接近尾声，我再次诚恳地劝请诸位有缘人：发愿非常重要，尤其发此普贤无上愿王更为重要。所以为了您快速地踏上解脱正道、成就诸佛功德海藏。请您与我一起追随着大悲世尊、普贤菩萨、文殊菩萨、地藏菩萨、法王如意宝等一切诸佛菩萨的足迹，诚心诚意地发此大愿王并愿在未来的生生世世之中，同行共履菩萨道。愿我们都能成为同行菩萨道的伴侣。

    谁之悲愿云遍覆，华藏世界十三层，
    娑婆罪苦强力牵，悉入释尊解脱门。
    神通三昧悉自在，万德周备号普贤，
    境界广大遍解脱，大行大愿作庄严。
    虚空世界及众生，罪业烦恼无边际，
    文殊佛母大慈尊，无尽愿轮转不息。
    地藏往昔誓愿深，今于三途成依怙，
    众生地狱若不空，愿海波深纳众生。
    文殊宏愿力无穷，无浊法王皓日升，
    传法救世名普闻，永作生死放牧人。
    刹尘诸佛菩萨众，愿赐哀怜紧摄持，
    粉身碎骨不退避，恒驾愿航入生死。
    内外因缘推动力，渴求与此结胜缘，
    无所修证凡庸我，自力岂能阐妙典。
    然借三土圣者教，荟萃精华巧庄严，
    诸有智者应详探，勿因人微弃忠言。
    愚盲如我诸群生，不知发愿遑论修，
    愿同登上愿海舟，泛行华严广大海。
    恳乞一切诸圣众，大兴本愿威神力，
    加持覆护广流通，永作轮回除暗灯。
    如是善根等法界，如佛普作大回向，
    金刚上师久住世，教法兴盛复周广。
    无量众生受蒙熏，断恶奉善发菩提，
    安乐自在住法味，临终往生莲花域。

    圣者金刚上师法王如意宝之所以能在娑婆世界五浊恶世中，以势不可挡的威力，广泛地展开弘法利生的事业。凡他老人家足迹所到之处，无不树起显密无偏的尊胜法幢，以其强大的魅力吸引寻求解脱的苦难众生，轻松自在地把他们安置在解脱正道之中。这是因为他无论在轮回中的何时何处片刻不离地驾驶着普贤行愿的大船。如一九八七年亲自到普贤大士应化道场发此大愿，到五台山、普陀山等也都如此。到印度金刚座反复念诵此愿文，当时普贤如海行愿之门顿时显现，尊者从清净觉性之中自然流露出归纳普贤一切行愿精要的愿文——《愿海精髓——普贤刹之杲日》。尤其在喇荣虹光静地中带领广大僧众恒时修此无上愿王。在尊者座下依止多年的我，在尊者的感染熏习之下，对此愿王颇具信心，决心生生世世依此发愿修行。本人朝礼大士应化道场——峨眉山银色界，在万年寺为主的地方，至诚恳切地祈祷与上师无别的普贤菩萨，并再再念诵此不可思议愿王。当时出现的一些现象，从内外观察缘起都很殊胜，因此当时发起强烈的心愿，要造《行愿品》的注疏。几年来这个夙愿一直萦绕在心头，使我无法忘却。终于仰仗着诸佛如来的加持、法性不变的加持、僧众不退意乐的加持、尤其普贤上师无别圣尊的加持，今日在喇荣大密虹身成就圣地撰著圆满。

    谨以此著疏诚作法供敬献上师普贤大圣，惟愿上师以大威神力摄持，令此法本普遍流通，永远成为众生安乐的源泉。

    益西彭措识于北方莲花洲

    吉祥圆满！


忏悔业障：事忏：总说

己一、总说

    我等各自勿如愚狗逐块，自心外驰，当收敛身心反观自省每天的起心动念、身口所作所为，这样才会忽然惊醒，低头认罪。至此方信地藏菩萨金言不虚，南阎浮众生业障深重，善根微薄，烦恼炽盛，心力狭劣，刚行小善，却又退心，起心动念无非都是罪业。无须远说无始劫中，仅仅如朝露电光的这短短数十寒暑之中，所造杀盗淫妄等十恶业，破别解脱戒，毁菩萨律仪，犯金刚三昧耶等遮罪、性罪，已是罪山岌岌、业海茫茫。

    祸福无门，惟人自召，善恶果报，如影随形。诚如经中云：“假使百千劫，所造业不亡，因缘会遇时，果报还自受。”这是个无法更改的定律真理，我们只能接受，却无法投机取巧，更无法逃避。如此诸多恶业罪障一旦成熟，只能亲赴三恶趣中，品尝自己酿造的杯杯苦酒。此时的我们如即将被洪水淹没的人，忽然伸手抓住了救命的稻草，自然心中又惊又喜，牢牢抓住登上岸来，绝不会疏忽大意随波逐流的。又如犯下死罪的囚犯，即将临刑，愁忧恐怖无法言喻，此时忽然听到特赦令，定会悲喜交集，感激国王再生之恩，誓当以死相报。同样现在我们被恶业烦恼的洪水冲漂，即将堕落三恶趣海底，地狱的一切刑具业已准备妥当，牛头马面日夜相伴不离，时时刻刻伺机下手，此时上天无路，入地无门，但忽然抓住忏悔的救命草，听到无上大悲法王发出的特赦令，业海无边忏悔是岸，自然不胜感恩戴德，誓愿求哀忏悔。

    论云：“菩萨忏悔，衔悲满目，现不蒙大圣立斯赦法，抱罪守死，长劫受殃。”如果大悲世尊不开此殊胜方便，我等业障众生只能束手待毙，在无量劫中忍受一切恶报苦受。现今世间迷愚凡夫平时大造恶业，不信三宝因果，当恶报现前时则怨天尤人，不知仰仗三宝消除恶缘，只能在百般无奈中惊恐死去。现在不忏悔，如世间无依无怙无归无救的牛羊鸡鱼任人宰杀，别无办法，那时悔之何及？

    《大集经》云：“百年垢衣，可于一日浣令鲜净。如是一百劫中所集诸不善业，以佛法力故，善顺思维，可于一日一时尽能消灭。”我等所患顽固沉疴遇此大力神药，定能诸恶消灭，身心清净。譬如铁器有所缺漏，不能因此而自暴自弃破罐破摔，应该以忏悔法修补恢复，以后它仍然能发挥作用。所以经中说：“前心起罪如云覆空，后心灭罪如炬破暗。须知炬灭暗生，要须常然忏炬。”因此法王如意宝让我们每天早晚都要念金刚萨埵等各种忏悔仪轨不能间断，也是这个意思。

    佛在经中说他的弟子中有两种勇士：一者即善护身口意，严持诸律仪，戒珠洁净无瑕。二者，虽偶然失去正念，致使犯戒造恶，但马上追悔勇于发露忏悔，如法还净。犯错造恶虽然不好，但因造小恶业而生大恐怖，勇猛忏悔、洗心革面、改往修来的人如火中莲花，确实让人佩服。忏悔能培植很大的福报。经中云：“然诸福中，忏悔为最，除大障故，生大善故。”如不净粪染在身上，虽然很厌烦也不雅观，但没有它也不会去洗刷，同样依靠恶业可以发起忏悔，依此可以引生诸多善行，修积很大福报。

    《婆沙论》中云：“若人于一时，对十方佛前，代为一切众生，修行五悔，其功德若有形量者，三千大千世界著不尽。”勇施比丘犯重依靠忏悔，早已在东方世界成佛多时。《三昧海经》中佛为父亲净饭王讲述了一个公案：在久远的过去，有四位比丘犯了重戒，心中感到很羞耻，心神恍惚，无依无怙，于道中行走，忽然听到空中说：“你们虽然犯了戒不要认为就没救了。空王如来虽般涅槃，佛像还在，应该到佛塔中，观佛像眉间白毫。”比丘们听到此话，如将死而遇神医令服用灵丹，感激泪流。感慨地说：“佛像尚有如此威力，何况亲见佛的尊容呢？”尔时全身倒地如大山摧崩。他们就是现在已在四方成等正觉的四位佛陀：即东方不动佛，南方宝相佛，西方无量寿佛，北方微妙声王佛。所谓“弥天大罪，挡不住一个忏字”确实此言不虚。

    《高僧传》中记载昙策大师严净道场，专修忏悔，见到七佛现身对他授记说：“汝罪已灭，于贤劫中成佛号普明如来。”南岳慧思禅师修“方等忏”，梦见四十九位印度圣僧叫他重新受戒，之后更加精进苦修，能彻见三生之事，刚一靠墙顿然开悟。智者大师在大苏山修“法华忏仪”，证得旋陀罗尼，辩才无碍，成就无量功德。还有古德精勤忏悔，相继感得地藏、文殊、弥勒现前安慰并授予清净的菩萨戒。所以汉地受大小戒律之前都修忏悔，身心清净才能得到圆满戒体。

    总之，忏悔可以消除烦恼、洗净业障罪垢、铲除恶报、开发心性光明自性、现前禅定智慧、获得清净律仪等，其力用无法一一言宣，只有自己切身实践，才能真实体会到。正因为忏悔的殊胜及有着其他法门无法代替的不共作用，故成为末法众生的赎死灵符，所以各宗祖师都造了各种不同的忏愿仪轨，如《法华忏》、《方等忏》、《梁皇宝忏》、《贤劫千佛宝忏》、《慈悲三昧水忏》、《大悲忏》、《净土忏》、《地藏忏》、《宝王三昧忏》等，广行于世，普救众生，大家可择其相应者极力修持。法王如意宝慧眼彻见，悲心深切，愍念汉地众生，观其根机而造了金刚萨埵的广略修法，此法自问世以来，汉地众生欢喜信受，竞相流通。

    悟达国师云：“夫论忏悔者，本是改往修来，灭恶兴善。人之居世，谁能无过？学人失念，尚起烦恼，罗汉结习，动身口业，岂况凡夫，而当无过？但智者先觉，便能改悔，愚者覆藏，遂使滋蔓，所以长夜积习，晓悟无期。若能惭愧，发露忏悔者，岂止是灭罪，亦复增长无量功德，竖立如来涅槃妙果。”

    罪恶业障如黑暗，要以光明才能遣除，但有人既不愿受罪报，又不愿发露，如欲灭黑暗而严遮窗门，熄灭灯光，如此则只能是暗无天日。只有打开发露的门，引进忏悔的光，才能消除业障。佛在经中呵斥广严城的五百饿鬼说：“你们造恶业时，没有惭愧畏惧，现在恶果现前时，却羞于见人。”确实很多凡夫都是如此，造恶业时胆大妄为，但让他发露出罪时，却又畏首畏尾，胆战心惊，生怕别人知道，以后名声不好，面子上过不去，这样前怕狼后怕虎，以各种邪分别念障碍忏悔的正念，一点勇气也拿不出来，如此正象已服用烈性毒药，命在旦夕，良医以方便令彼吐出，但他却咬紧牙关，不肯开口，这样纵然药师佛也无可奈何，只能是死路一条。如人堕在粪池之中，应该迅速求上岸，马上冲洗涤荡，如果在池中停留的时间越长，那么沾染得越多，越难洗净，同样罪业不马上忏悔，它会如滚雪球般地日日增长。《大乘本生心地观经》云：“若覆罪者，罪即增长，发露忏悔，罪即消灭。”所以传承上师规定，弟子们早晨一醒，立刻端身正坐念百字明二十一遍或一百零八遍，这样可以压制罪业的增长。

    从另外一个角度来说，是不是我们不发露，他人就毫无所知呢？当然不是，若要人不知，除非己莫为。当我们造业时，一切有眼通的天人、声闻独觉及诸佛菩萨、上师道友们如同对面观火一般看得清清楚楚。神鬼们指着我们在詈骂，诸佛菩萨上师们为我们而痛心，但我们却还外现威仪。正如一个明智的人裸形于大庭广众之中，羞耻难堪、无地自容，又怎能心安理得、香睡饱饭呢？佛说若犯戒还自诩清净，这样犯妄语戒重增障碍，且有欺诳如来的过失。人若犯戒，则地行罗刹马上告诉空行罗刹，空行罗刹传到四大天王处，很快恶名遍及天上人间。不发露不忏悔，如人怀里钻进毒蛇，此人漫不经心，他人劝告速速抖出，他也不理不睬，最后中毒而亡，所以不想忏悔的人也是这样，只是自害而已。就算你现在伪装粉饰得很好，但死后到阎罗王那里时，一切生前造罪的情景如播放电影一样，这是你自编自导自演的恶剧，被你心识的录像机完全拍下，现在该轮到自己欣赏了，那时不管如何抵赖，阎罗王是不会客气的。所以现在应该不顾一切虚浮的面子名声，鼓足勇气，坦诚地在上师三宝本尊护法面前发露，求哀忏悔。《业报差别经》云：“若人造重罪，作以身自责，忏悔更不造，能拔根本罪。”

    忏悔，随行者的见解及修持的深入不同，有的可令业力压伏不起，有的以发露等转变业力，有的则可光现暗消般地灭除罪业。忏悔力与罪恶力互相压伏，大恶业要上品忏悔才能消除，如果忏悔力不足，则仍然为恶业所牵，不能将其伏断。同样中小恶罪与忏悔也是这样的关系。

    修忏之前请提前认清要忏悔的对象是什么？《佛名经》说虽然罪相无量，但概括来说有烦恼、业、果报此三种障碍。能障圣道及人天胜妙好事。我等在无始受生之中，一身所造之业即已无量，何况无量身呢？