首页

密勒日巴尊者传

张澄基 译 [image] 清凉书屋校订

依上海佛学书局全集本校对
·小标题为校者所加·
2002.11


译者序

    据我所知，除释迦文佛外，西藏密勒日巴大师（1052-1135）在古今中外佛教史中，恐算是第一人了。他的生平像一首动人心弦、可歌可泣的史诗，他的诗歌是至精至要、千古不朽的教言。在修持上，他的造诣可谓独步古今，比起其他许多佛教的圣哲来，总觉有过之无不及。他说的法是人人能懂的，直接了当的。一般传记中的佛教圣哲们，不是某某佛的化身，就是某某菩萨的示现。密勒日巴却痛快了当的说：“我是一个博地凡夫，此生此世因刻苦修行而得成就。”因此他所说的话和所做的事，总带着极浓厚的“人情味”，使人感到亲切生动。
    密勒日巴尊者可说是西藏“实践佛法”的代表。“实践佛法”是对着那些讲玄学的“哲理佛法”与“缠小足”式的“烦琐佛法”而言的。佛教最初原是重实践的，后来才渐渐的趋向理论化与形式化了。这种现象似乎是很普遍的，一切宗教史中都有这种演变；这也许是所谓“成、住、坏、空”的必然趋势。因而在每一时代中都有新生命、新血液来做继往开来的工作。此种新活力非凭空生成，却是要复活原来教法中的生命和心髓，配合时代的需要综合产生的。此宗教的心髓亦唯有从创教人的言行及初期的教法中去搜求，才能得到正确的答案。密勒日巴所修的宗派和法要是所谓“无上密宗”，但他的作风和精神处处显示出原始佛教中的朴实、艰苦与实践。他的言行和那些摇铃打鼓眩人眼目的密宗行者全不相同，许多地方都有点像似个禅宗的行者。他的诗歌中处处说般若、谈心性，读来全似禅宗的口吻！
    密勒日巴尊者与六祖慧能有甚多相似处，他们二人的传承弟子中，得到殊胜成就的也远驾其他宗派以上。他俩都少谈理论，注重实修。说法平直，易为一般众生所吸收与了解，所谓普被三根者是也。
    密勒日巴尊者最令人钦佩的地方，便是终生不建庙宇，不集僧众，做了一个洒脱自在的游方行者。密勒的成就与教法，在某些方面似较慧能还要“周到”一些。慧能的禅宗只阐扬法身而鲜及“报”、“化”。禅宗虽亦讲大机大用，但总嫌不具体，不够味儿。西藏密宗在报、化的机用上，也许有更多的方便。但话得说回来，这也许是西藏密宗的“难处”。禅宗不谈报、化，直趋法身，也正是它独特的超胜处！
    密勒日巴尊者对佛法最伟大而不共的贡献，是以自己的生平来说明大、小、密三乘的不可分离性。若无小乘的出离和大乘的“发心”为基础，密宗的妙法无非是空中楼阁。他现身说法，以实例来说明如何同时实践并成就三乘教法。这种贡献，在佛教史上确是空前的、独特的！
    我们生在二十世纪这样一个热恼的世界里，读了密勒的传记和诗歌，使我们有一种清凉、滋润和安慰的感觉。能效法他固然最好，不能效法也至少能获得“随喜”和“净信”的益处！
    密勒大师传已译成世界各国文字，足见其文学价值之高。中文译本有“木讷记”和另一种译本，但都残缺不全，也不是由原文直译的。我这个译文也只是原文的“百分之九十”。第一篇赞扬密勒功德的藏文颂词，因嫌其太罗嗦八股，所以省略了。
    正文前的开场白和朝山僧的密勒大师赞，是我个人所撰，与藏文的原本无关，这是要向读者声明的。
    我曾花了多年的时间将藏文的《密勒大师歌集（Mila Grubum）》全部译成了英文，已经在美国出版，本想将歌集再译成中文后连同这本传记，详加考证及注解后再一并出版；可是这样一来，要迟很多时间，所以决定将这本传记提前出版，使中国的读者可多一个修行的榜样，启发善缘，亦不失为有助于宏扬佛法，愿以这点功德，回向中国佛教的复兴与光大。

一九六五年六月重校付印
张澄基


引 赞

    在喜马拉雅雪山近西藏雅鲁藏布江上游处，有一所小小的村落。村民以农牧为生，过着简单淳朴的生活，快乐无忧。他们一生中最重要的事，除了务农游牧之外，就是崇奉佛法和恣情歌舞了。
    这儿，人人都会唱歌，人人都会祈祷。无论在牧场上，在农田里，或在佛寺中，随时都能听见那高昂悲朗的歌声。因为在这一块广阔的自由天地中，人和大地自然已经融成一片。他们没有什么可顾忌的，也没有什么可约束的了。兴之所至，就在一望无涯的大草原上，放声高歌；在高高的雪山顶上，引吭长啸；在潺潺的流水旁边，低回沉吟了。
    一个秋天的晚上，牧童们已从山上放牛归来；女人们都喂完了小牛，挤完了牛奶；男人们已经把马群赶上了山。大家都做完了一天的工作，都高高兴兴的来参加晚间的集会。
    在村庄的尽头处，有一片大草原，苍郁雄劲的古松，像座屏风似的沿着草坪的东边整齐地排列着。松树下一堆熊熊的烈火正旺炽地燃烧着，温暖了每一个围火与会的人。歌声、笑声和孩子们兴奋的喊叫声混杂着，充溢了草坪的每个角落。
    一位白发苍苍的老人，从村中慢步的走向前来，他的身旁跟着一位来自异乡的朝山僧，渐渐地走近了那正在欢笑喧嚷的人群。老者的来临，给草坪上带来了一阵肃静。
    老人走到众人中间，向大家说道：“今晚的庆祝会，恰巧是八月十日莲师节。我们村上，来了一位善歌的远方朝山僧，我特地请他来参加我们的晚会，为我们唱一些他的家乡歌曲，想来你们都很欢喜听吧！”
    “好！好！欢迎！欢迎！”大家都拍手赞成。于是那位朝山僧放下了他手里拿着的书，向大众合掌致敬，然后就站在古树下，火堆之旁，高声歌唱起来：
    “浪涛云海，在广阔的高原上，飞奔浩荡；
    飞絮般的白云，在万里雪山的怀抱里，缭绕飞扬；
    这是人间的净土，佛国西藏！
    我听见密勒的诗歌，在牧场上；
    我听见密勒的诗歌，在道路傍；
    我听见密勒的诗歌，在巍巍的佛寺里；
    我听见密勒的诗歌，响彻了那高耸的山岗！
    尊者的苦行，令我痛哭；
    尊者的遭遇，令我心伤；
    尊者的幽默，令我微笑；
    尊者的成就，令我向往。
    你的胸襟，如恒沙法界的广大！
    你的境界，如华严大海的汪洋！
    你的训示，如慈母叮咛的悲切；
    你的诗词，是圆满佛陀，圣者的歌唱！
    哦！你是万千众生的依怙！
    尘沙世界无比的法王！”
    朝山僧雄壮沉郁的歌喉，优雅的词韵，启发了每一个人的幽思，扣击着每一个人的心弦。半晌，人们方由沉醉中复苏过来，一致求朝山僧再唱一曲。
    但是这位僧人，向大家望了一望，严肃的说道：“这是密勒日巴尊者的后学所作的一个歌赞罢了。密勒日巴尊者，他老人家自己的歌词和传记，才是真正的伟大。尊者的诗歌，虽然在西藏到处流传，但尊者一生的事迹，恐怕你们都还不清楚吧！我想把尊者的传记念一遍给你们听，这比再唱一个歌要有意义得多；一面也可为今晚的盛会助兴，同时也可以答谢各位施主的盛意。这部《至尊密勒传》是由一个无姓名来历但却有神迹的似癫非癫的人所写作，人们称他为“西藏疯行者”，他毕生只写了这部著作。”一边说，一边就坐下来，拿起他的书，藉着熊熊的火光，对着寂静无哗的听众，朗声诵读。


尊者传记之缘起

    敬礼至尊密勒日巴！
    如是我闻（“如是我闻”句以前皆为译者所撰，此句以下，方为原文），一时至尊密勒日巴喜笑金刚（“喜笑金刚”为密勒日巴尊者之法名），在鸭隆地方的中腹崖窟中，宣讲大乘妙法。法会中有他的大弟子惹琼巴、寂光惹巴、雁总惹巴、佛护日巴等登地以上的菩萨，和来赛办、仙多玛等女弟子，以及许许多多的男女施主信士；此外还有长寿王空行母，以及证得虹光成就的许多空行母（“空行母”——梵文 Dakini，藏文译为Mkhai hGro-ma空行女，原指女性修无上密宗而得成就者，后来此名词应用渐广，凡是女性密宗行者，皆可称为空行母。空行母在密宗中占极重要的地位，诠表智慧为一切诸佛之母，亦表事业，为一切诸佛护法及承办事业）和瑜珈行者。
    在那日前一天晚上，惹琼巴做了一个梦，在梦中他似乎到了乌金空行净土（乌金是莲花生大师的“西方”净土，但此处却有“东方”的不动如来说法，见下段）。那是一个多宝琉璃筑成的大城，城内全是穿着美丽的天衣、佩着璎珞的人们和珠宝严饰的男女空行。他们虽都向惹琼巴微笑颔首，但却无一人与他说话。忽然一个穿红色衣服的女郎亲热地向他招呼道：“师弟，你什么时候来的？欢迎！欢迎！”惹琼巴举目一看，原来是从前在尼泊尔第布巴上师处一同学法的巴热玛。
    “你来得真巧，不动如来（不动如来为五方佛中之东方佛）现在正在此说法，如果你愿意听讲，我可以替你去向佛请求。”
    惹琼巴兴奋的说道：“我多年以来就想朝见不动如来，今天能够听他亲自说法，正是千载难逢的机会。请你务必替我请求一下。”
    巴热玛请惹琼巴吃了一席丰美的酒筵。他俩就一起往法会走来。那是一所宏大壮丽的宫殿。不动如来坐在中央的宝座上，相好庄严，非人类所能想象。法会中听法的神人大众，如大海一样的无量无边。惹琼巴从未见过这样广大殊胜的法会，他看见这种景象，心中真是说不出的快乐和兴奋。巴热玛对惹琼巴说道：“师弟！请你等一等，让我先去替你向世尊请求吧！”过了一会儿，不动如来慈悲地望着惹琼巴微笑——惹琼巴知道已经得到了许可，就向如来顶礼，在会中坐下来听法。
    那天，不动如来讲的是过去诸佛菩萨的事业和传记，都是些动人心弦、可歌可泣的故事。最后，不动如来又宣讲谛落巴、那诺巴和马尔巴三位上师的生平事迹，惹琼巴从未听过如此详尽与动人的讲述。
    要散会的时候，不动如来对大家说道：“一切传记中最稀有、最伟大和最动人的，要算是密勒日巴的传记，明天你们再来听我继续讲吧！”
    惹琼巴听见几个人私自在谈论：“如果还有比这些传记更稀有、更伟大的话，那真是不可思议了！”另一个人说道：“今天我们听的这些佛菩萨的传记，他们都是多生多劫以来集资修行的结果；可是密勒日巴却在一生一世中成就了与这些佛菩萨相等的功德，所以更为希有啊！”又有一个人说：“像这样希有的传记，如果埋没了，岂不可惜？如果不为众生的利益来请求世尊讲说，岂不是我们做弟子的罪过吗？所以我们一定要恳切祈祷，请求上师如来讲说尊者的传记才是！”
    “尊者密勒日巴现在在什么地方啊？”那第一个人问。“密勒尊者吗？他不在现喜净土（现喜净土——藏文mngon. agh，为东方不动佛之净土），就在常寂光土（常寂光土——藏文hog. min，原意“非下”，指普贤王如来之不思议报身净土。严格讲，此为一密乘名词，但其所指及含义与常寂光土极相似，故引用之）吧。”另一个人说。
    惹琼巴听了心中想道：“尊者现在明明是在西藏，为什么说在常寂光土呢？但无论如何，他们这些话分明是对我说的，我应该向尊者请求讲说尊者的自传才对。”正想到这儿，巴热玛亲热地拉着他的手轻轻的摇着说道：“师弟，你懂得了吗？”这时，惹琼巴心中更为明白，却猛然由梦中惊醒了。那时天已快亮，惹琼巴心里十分欢喜，想道：“到乌金刹土去听不动如来说法，虽为可贵，但是与上师在一起，乃更为可贵，更为希有。这次，到乌金刹土去听法，是上师加持的力量。那里的人说尊者在常寂光土或现喜净土，我们却以为尊者是在西藏。其实，上师的身、口、意，与十方诸佛等无差别，功德事业，不可思议。我一向以为尊者只在西藏，与我们没有什么不同，一样的过着人的生活；哪里知道尊者早已成佛，法身遍满宇宙，报、化身变化更是不可思议。我们自己的业障深重，所以见圣人亦如见凡夫，真是诬蔑了圣者！昨晚的梦，不是一个寻常的梦，是巴热玛和其他空行叫我向尊者请法的暗示，我一定要向上师请求！”想到这里，心中生起了无比的信心，就合掌当胸，至诚的祈求上师。
    忽然间，光明一现，乌金刹土的庄严景象又呈现在目前。几个美丽绝顶、衣饰华丽的空行母，鲜明耀目的走到惹琼巴的面前。其中一个空行母说道：“明天要讲密勒日巴传了，我们一同去听吧！”
    “请法的人是哪一个呢？”又一个空行母问。
    另一个空行母一面睇视向惹琼巴微笑示意，一面说道：“那当然是尊者的大弟子啦！”
    其他几个空行母也都向惹琼巴凝睇微笑，她们都说：“请求尊者说自传，是自利利他的事。我们不但十分想听尊者的传记，同时也要帮着祈求尊者，请他垂赐慈悲讲述给我们听；以后我们还要守护宏扬这个经传，利益未来的有情！”说完她们便消逝不见了。
    惹琼巴再醒来时，天已大亮。他想：“这明明是长寿王空行母鼓励我去向尊者请求的表示啊！”因此这天惹琼巴便欣喜地来到至尊密勒日巴上师的面前，参加法会，于顶礼问安完毕后，跪在尊者的前面，合掌当胸，向尊者请求道：
    “上师老人家啊！过去无量诸佛，为度众生的原故，示现十二种事业，以种种不可思议的方便广度众生。他们的希有传记，流传于世，令一切有情蒙益，佛法增盛。现在的谛落巴、那诺巴、马尔巴等具大成就的上师，也都自说传记，广利有情，使徒众们都能成就无上佛道。现在也请上师您老人家慈悲，为我们徒众及未来有情，讲一讲您的身世和一生经过的事迹吧。”
    密勒日巴尊者听了，安祥地说道：
    “惹琼巴，我的事情你已经知道得很多了；但你既然问我，我就回答你。
    “我的祖系是琼波，宗姓是觉赛，我最初习黑业，后来行白业（“黑业”即恶业或恶的行为，“白业”即善业或善的行为），现在，白业、黑业都不做了；一切有为的作业已尽，将来什么事也不做了。这些事情，如果详细说来，有许多是要令人痛哭的，也有许多是令人欢笑的。说来话太长，可以不必讲了吧！让我这个老头子闲散地休息休息。”
    “上师！”惹琼巴跪在地上不起来，继续恳请：“您老人家最初怎样精进的修善法，怎样的求佛法，又怎样修行，才达到现在‘法性尽地’（法性尽地——一种密宗术语，指修行之最高最后的境界，已达到穷尽法性的究极地步，故云“法性尽地”）的境界而彻证实相？请您详细的为我们说一说。您的祖系琼波，宗姓觉赛，但是您的姓却为什么会变成密勒呢？您为什么先做恶业，后来又修善法？那些令人可哭可笑的种种事迹，都请您告诉我们。这不仅是我一个人的请求，所有金刚兄弟（“金刚兄弟”就是同坛灌顶的师兄弟，即金刚乘的同道）和施主们也都渴望一听，请您慈悲吧！”
    “你们既然这样请求，我也没有什么可秘密的，我就对你们讲吧！”尊者微笑着慢慢地说。


尊者的族姓

    “我的祖宗琼波族，世居卫地北方的大草原。祖父叫觉赛，是一个红教喇嘛（红教喇嘛即旧教——宁马派——之喇嘛，创教人为莲花生大师）的儿子，他是得到本尊加持的真言行者，具有真言咒术的大威力。有一年，他到后藏去朝山，行到藏地北方的郡波洗地方时，恰巧该地患鬼瘟。因为他的真言威力极大，平灭了许多鬼瘟，信仰的人越来越多，当地的人就要求觉赛喇嘛长住在他们那里。他于是就住了下来，最后竟在那里落籍了。
    “又一年，该地来了一个大力鬼，到处作怪害人。有一家人，平素是最不信仰觉赛喇嘛的；这个大力鬼就在这一家兴妖作怪，牛马死的死，跑的跑，人也个个害病，白日见鬼，种种不祥的怪事，天天出现。无论请什么医生来治病，病都好不了。请什么喇嘛来降妖，不但妖降不住，作法的反都被这个大力鬼弄得狼狈不堪。最后在毫无办法的时候，有一个朋友就对那家人说道：
    “‘唉！你们还是去找一找觉赛喇嘛罢！别人是不中用的！’
    “那家人就说：‘只要能把疮治好，狗油也只得用了！唉！好罢，就去请他来罢。’
    “于是就派人去请觉赛喇嘛来。
    “觉赛喇嘛还没有走到这家人的帐篷时，远远的就看见大力鬼了。大力鬼一见觉赛，拔腿就跑。觉赛喇嘛神威顿发，高声叫道：
    “‘大力鬼，我琼波觉赛专门喝鬼魔的血，抽鬼怪的筋，有本事站住，不要跑！’
    说着向大力鬼飞奔赶来。大力鬼一见，吓得混身颤抖，大声叫道：‘可怕啊！可怕！密勒！密勒（密勒为西藏文的译音，意思是看见巨人时畏惧的表情）！’
    “觉赛跑到大力鬼面前，大力鬼缩作一团，动也不敢动，颤巍巍的说道：
    “‘喇嘛啊！你所去的地方，我没有敢去啊！这个地方，您从不来，所以我才敢来的，请您饶命！’
    “觉赛喇嘛就命大力鬼发誓从此不再害人。大力鬼只得对觉赛喇嘛起誓。喇嘛就把他放了。
    “以后这个大力鬼附在另一个人身上说道：
    “‘密勒！密勒！这个人好历害哟！我一辈子都没有这样的害怕过，好历害啊！密勒！密勒！’
    “因此，觉赛喇嘛的名气就更大了，大家给他起了一个绰号，叫密勒喇嘛，以为虔诚信仰的意思。渐渐的密勒就变成为他这一家的宗姓了。密勒喇嘛的称号，就这样的出了名。
    “琼波觉赛的独子有两个儿子，长子叫密勒多顿生给，生给又有一个独子，叫做金刚狮子。
    “却说金刚狮子，生性极好赌博，尤其喜欢掷骰子。他赌术极精，每掷必赢。
    “有一年，一个流浪江湖的大骗子，来到郡波洗这地方。他的赌术精绝，以赌博为生，赢了很多钱。听说金刚狮子爱赌博，便约他掷骰子。
    “第一天，那赌徒为了要试探金刚狮子的技巧，只是下了小小的赌注，而且故意输给金刚狮子。第二天，这骗子施展身手，很轻易的就将金刚狮子的赌注赢了。金刚狮子从未如此惨败过，心里非常不服，就约那骗子再赌，对骗子说：‘明天我一定要赢回我所输的本钱！你敢和我再赌吗？’
    “‘当然！’骗子毫不在乎地回答。
    “第三天，第四天，第五天，骗子不知是故意，还是运气不好，接连三日，都输给了金刚狮子。
    “于是骗子向金刚狮子提出了最后决定性的挑战：
    “‘金刚狮子！这些日子我天天输，明天我想我们双方均将全部财产，牛、马、田地、羊毛、财物及衣服首饰等都用来作赌注，请村人做证，签立合同，作一次最后的较量，输赢都不许反悔，不知你是否同意和我见一个最后的高下？’
    “金刚狮子毫不犹豫地就同意了。
    “第二天，村中的人验证了双方的赌注，围视着他们，他们俩紧张地掷着骰子。终局时，金刚狮子输得一无所有。
    “在这种情形之下，金刚狮子只得离开家乡族人到外面去流浪了。他的父亲多顿生给就带了他来到芒地贡通间的嘉俄泽地方，在那里落了籍。多顿生给精咒术，能降妖，又善治病，他就藉以谋生，收入颇为不错。金刚狮子也从此改邪归正，断绝赌博的恶习，一心一意的做生意。冬天，把羊毛运到南方去卖；夏天，到北方大牧场上去买牛羊；此外又来往于贡通及芒地之间，经营一些小本生意。辛劳的结果，居然又积聚了许多资产。
    “金刚狮子后来与当地一个美丽的女孩结了婚，生了一个儿子，取名叫密勒蒋采（密勒日巴尊者的父亲）。
    “这时多顿生给已经很老，因病去世了。金刚狮子多年的辛劳，逐渐富有起来。他用大量的金钱换得一块三角形的肥美沃田，并且因为那块地是三角形的，就命名为俄马三角田。此外他还在近处买了一幢大房子。
    “密勒蒋采到了二十岁的时候，与白庄严母（密勒日巴尊者的母亲）结了婚。白庄严母是当地一位富豪的女儿，聪敏能干。一家人就在富裕美满的环境下，过着快乐的日子。
    “过了一些时光，他们在俄马三角田的旁边，又造了一幢三层楼的大房子，房侧又建有一大库房及厨房。正像这块三角形的田因形得名一般，由于这房子有四根大柱子和八支大梁，便称它为‘四柱八梁屋’。
    “这时，密勒多顿生给的亲戚们，在家乡听说金刚狮子在嘉俄泽非常富有，非常幸运，于是密勒蒋采的堂兄雍重蒋采和他的妹妹琼察巴正也都迁居到嘉俄泽来了。
    “密勒蒋采对于自己的亲戚，非常爱护，竭力的帮助他们；借给他们钱，教他们怎样做生意。没有多少时候，他们也变得富有了。


尊者的降生

    “光阴过得很快，过了几年，白庄严母怀了孕。这时密勒蒋采却正从南方办了大批的货物，到北方草原大牧场上做买卖去了。
    “这年秋天八月二十五（水龙年——公元1052年）吉日，我的母亲——白庄严母，生下了我。母亲立刻差人送信给父亲密勒蒋采，信上说：
    “‘余已生一男儿，汝应速归，为渠取名并准备欢宴亲朋，秋收日期亦近，盼汝立回。’
    “送信人很快地就把信送到了。同时送信人又详细地把新生小孩和家中的情形陈述一番，催促我父亲早日回去替我取名字和庆祝。父亲心中异常喜悦，笑着说道：‘好极了！好极了！小孩的名字已经取好，我们密勒一家，一代总是只生一个儿子的，我听见生了个男孩，真是高兴极了，就叫他做闻喜吧！’
    “于是，父亲就匆忙地结束了买卖赶回家来，替我取名闻喜。日后我长大了，喜欢唱歌，听过我唱歌的人，无人不爱我的声音，所以大家都说：‘闻喜，听见了就高兴，这个名字取得真是恰到好处啊！’
    “我四岁的那一年，母亲又生了一个妹妹。母亲先前说过，如果是个男孩，就取名为贡莫，如果是女孩就叫琵达。因为生的是女孩，所以就取名为琵达。我还记得，妹妹和我小的时候，穿的都是最好的绸缎；头发上总是满带着珠宝的饰物；家中出入的人，都是有钱有势的；佣人也是一大群。
    “这时嘉俄泽的乡人私自常说：‘这些远方来的流浪汉，现在这样阔气，外面的马牛、田宅，里面的粮食、财宝，吃不完，穿不尽，真是走运啊！’大家对我们都羡慕而又妒忌。可是，好景不常，这样美满的生活过得不久，父亲密勒蒋采就去世了。”


早年的不幸遭遇

    惹琼巴又问道：
    “上师！您的父亲去世以后，您是不是受过很大的痛苦？听说您的遭遇是最困苦的，您能够讲给我们听吗？”
    密勒日巴微笑的说道：
    “好，我给你们讲吧！
    “我七岁的时候，父亲生了重病，医生们都束手无策，算命的也说父亲的病是没希望了；亲友们都知道父亲已是沉疴难起。父亲自己也知道病势垂危，就决定在未去世前对我们母子三人和家产作一个处理。
    “父亲将伯父、姑母，远近的亲友，以及我们的邻居们都请来齐聚在家中，将他预先准备好的遗嘱在大众面前宣读一遍。
    “遗嘱中详细说明，全部的财产都应由长子继承。
    念完了遗嘱之后，父亲慢慢的说道：‘这一次我的病是没有好的希望了。我的儿女年纪都小，只有麻烦伯父、姑母和亲戚朋友们来照料。我虽不是巨富，但也还有一笔相当厚的家财。在我的牧场上，牛、羊、马三种牲口都有；田地中主要的就是这一块俄马三角田，其他的小田多得不胜枚举；楼下的马厩里，有牛，有羊，有驴子；楼上有家具，有金银做的古玩；有珠宝，还有松耳石；有丝绸的衣服，还有五谷杂粮的仓库。总之，我的产业很是充裕，无须仰给他人。在我死后，应以我财产一部份来安置我的后事。其余的全部财产，要请各位在场的人，特别是伯父、姑母，帮助白庄严母他们母子三人照料一下。等到闻喜成人、娶妻的时候，就请把订妥了的结赛姑娘迎娶过来。结婚的费用应该和我们的身份相称。到了那个时候，我的财产是应该由闻喜承管。他们母子三人的生活，请伯父、姑母加意照拂，请各位关心，不要使他们母子三人受苦；我死了以后，也是要从棺材缝里来看他们的！’
    “说完之后，他就撇下我们去了。
    “我们把父亲埋葬以后，大家商量，都一致决定，所有财产完全归母亲掌管；可是伯父和姑母都坚决的对母亲说：‘你虽是至亲，但是我们比你还亲些，我们决不愿你们母子吃苦，所以要依遗嘱全部财产由我们来管！’我的舅舅和结赛的父亲虽然说了许多应该由母亲掌管的理由，但是他们断然不听。于是男孩子的财产就归伯父管，女孩子的财产就归姑母管，其他的财产，伯父、姑母一人分了一半。
    “他们又对我们母子三人说：‘从现在起，我们要好好的照料你们！’这句话说完了以后，我们母子三人的财产，就全部瓦解了。
    “于是，在酷暑的时候，伯父要我们耕田；严冬的时候，姑母要我们织羊毛；吃的是狗吃的东西；作的是牛马的事；穿的衣服褴褛不堪；系的腰带是用草绳子一根一根接起来的。从早到晚，一点空闲都没有；过度的工作使手脚都破裂了，血液从皮肤的裂口淌出来……。衣服穿不暖，食物吃不饱，皮肤的颜色都转成了灰白，人也瘦得只剩一副骨头架子和一层皮。我记得从前我的头发辫子上有黄金和松耳石的链圈，后来松耳石等装饰品渐渐没有了，只剩下了一条灰黑色的绳子。最后满头都是虱子，虱子蛋在乱蓬蓬的头发丛里长了窝！看见我们母子的人，都痛骂伯父、姑母的刻薄。伯父、姑母脸皮厚得像牛皮一样，全无羞耻之心，更不把这些讽刺挂在心上。所以我的母亲就叫姑母作折母道登（鬼母老虎），不叫琼察巴正了。鬼母老虎这名字后来流行在村人的口中。那个时候，村人都纷纷的说：‘抢了别人的产业，还要把原来的主人当做看门狗，天下真有这种不平的事啊！’
    “当我父亲在世的时候，无论有钱无钱的人，都跑到我们家来谄媚交往。现在伯父和姑母有钱了，生活得像王侯一样，他们这些人都到伯父、姑母那儿去了。甚至还有许多人批评我的母亲说：‘常言说：上好之毛料，细毛始能做；丈夫有钱时，其妻方灵巧。——这句话真说得不错！你看！起先白庄严母的丈夫在世的时候，她真是一个慷慨好施的女人，现在她没有了依靠，就变得这样的穷酸。’
    “西藏有句俗语说：‘人倒一次霉，十方传是非。’我们的境况不好，运数坎坷，人们对我们的同情，不但不增加，却相反地越来越淡薄，闲话和嘲笑也越来越多了。
    “为了怜悯我的不幸，有时，结赛的父母送给我一点衣裳和鞋子穿，还很亲热的安慰我说：‘闻喜！你要知道，世界上的财产不是长住不变的，世间的财物都像朝露一般的无常，你不要悲伤你没有钱，你的祖父起先不也是个穷光蛋吗？将来你也可以挣钱发财的！’
    “我心里十分感激他们。
    “我的母亲有一块赔嫁的田，叫做铁波钱琼，这个田的名字虽然不大好听，倒是一块很好的耕地，收获很不错。这块田由我的大舅舅耕种，每年把收的谷子存下来生利，多年来本利积聚了不少。艰苦的岁月一天一天的过去。到了我十五岁那一年，母亲就将那块地卖去一半，加上谷子生的利息，就用这笔钱买了许多的肉，许多的青稞作糌巴，许多的黑麦子作酒。母亲这番举动，很使村中的人诧异，于是大家都私自揣测：‘恐怕是白庄严母要正式请客讨回家产了吧！’母亲和舅舅把一切都准备就绪后，就在自己的家中，四柱八梁的大客厅里，把从各处借来的垫子，一排排的在客厅里铺起来；请伯父、姑母作主客，招待亲戚朋友、左邻右舍，特别是那些在父亲临终嘱咐时曾经到场的人，都请了来。母亲将最好的肉和菜放在伯父、姑母的座前，所有其他客人的面前都满陈着丰富的食物，每人面前一大碗酒，那真是一个盛大的宴会！
    “‘各位：今天我备了一点薄酒菲菜请各位来，只是表示我的一点小意思。’客人们坐定了下来，母亲就从大众中站起来郑重的说：
    “‘今天虽然是我小孩子的生日，其实也不过是个名义，我想向大家说几句话：先夫密勒蒋采去世留遗嘱的时候，各位老人家们和伯父、姑母都在座，都知道得很清楚，现在我想请在座的各位再听一遍这个遗嘱。’
    “于是舅舅站起来，当众把父亲的遗嘱大声地读了一遍，所有的客人都不发一语。
    “母亲紧接着又说：
    “‘现在闻喜已成人，到了娶亲的年纪了，遵照他父亲密勒蒋采的遗嘱，现在该用合我们身份的礼，将结赛姑娘迎娶过来；闻喜也应依嘱承管我们的家产。至于刚才读过的遗嘱，各位当初在密勒蒋采危殆时都是亲见耳聆的，不必我再重复。今天我就请伯父和姑母把代为保管的财产交还给我们。这么多年来，承伯父、姑母及各位亲友们的照顾，我们衷心十分感谢！’
    “‘嚇！你们还有财产！’伯父、姑母一致同声的大喝：‘你们的财产在哪里？’
    “平常，伯父和姑母无论什么事意见总是不一致的，但是，在吞吃别人财物的时候，却联合起来了。他们一致地说：
    “‘嚇！你们还有财产？你们的财产在哪里？密勒蒋采年轻的时候，借了我们很多的田地、金子、松耳石、马、牛和羊！他既然死了，这些东西当然应该还给我们。你们的财产就是连一星星的金子、一把的麦子、一两的酥油、一件破衣裳、一条老牲口，都没看见！哼！现在还要来说这种梦话！你们这个遗嘱是谁替你们写的啊？我们把你们母子养活到如今都已经很够了！俗语说得好，恩将仇报的就是你们这些东西！’
    “说着气吼吼的，牙齿咬得嘎嘎地直响，从座位上一下就跳了起来，把脚用力地向地上一蹬，大声地叫道：
    “‘喂！你们懂了没有？这个房子是我们的，你们赶快滚出去！’
    “一面说一面就拿马鞭子来打我的母亲，用衣袖子来摔我和妹妹琵达。母亲痛绝在地，大声的哭叫：
    “‘密勒蒋采啊！你看见我们母子三人没有？你说你会从棺材缝里爬出来看的，现在你看见了没有哇？’
    “我跟妹妹与母亲扭在一处，三人哭得死去活来。大舅舅看见伯父有很多人助威，所以也只得敛声藏怒。有一些客人们说：‘唉！他们母子真可怜啊！’并且为我们的不幸伤心地流下泪来，可是也只能悄悄地叹息而已。
    “伯父和姑母的恶气还未发泄干净，索性老羞成怒，恶狠狠地朝我们母子三人狂狺咒骂：
    “‘哼！你们要我们还财产吗？不错，财产是你们的，就是不愿还你们，你们有什么方法取回去？我们高兴用来喝酒请客，也不干你们的事！’伯父和姑母粗野鄙夷地讥笑着我们：
    “‘有本事就多找些人来打一仗，把产业抢回去！没本事找人的话吗，那就去念咒好了！’
    “说完了，就带着他的朋友们掉头不顾的走了。
    “极度的悲伤使可怜的母亲啜泣不止。四柱八梁的大厅中，凄凉地剩下了我们母子三人和一些同情我们的亲友，结赛姑娘和他的父兄好心地劝慰我们；大家愿意送一些东西来救济我们的贫穷。舅舅则主张叫我去学习一种手艺，母亲和妹妹可以帮助他种田；他更坚决地要我们做一点事情出来给伯父、姑母们看——密勒蒋采的家人并不是懦弱无能、轻易可侮的。
    “母亲抑止住了无限的哀痛，拭干了眼泪，悲愤坚决地说道：
    “‘我既然无力取回自己的财产，绝不能靠他人的施给来养活自己的儿子，现在就算伯父和姑母会交还给我们一部份财产，我也决不会要；但闻喜是无论如何，定要学一种手艺的。我们母女两个人，在未报答伯父、姑母的厚赐以前，便是为人家当丫头、当佣人都是心甘情愿的！我们要做给他们看！’
    “母亲又对舅舅说：
    “‘我们愿意替你种田！’
    “大家见母亲的意志坚决，没有什么其他的话可说，就依着母亲的意思办了。
    “在宁察的无上广地方，有一位专修八龙法的红教喇嘛（红教喇嘛——红教为西藏最早期的佛教，藏文宁玛巴原应译作旧教，喇嘛都穿红服，所以俗称红教，实不恰当，今随俗用之，旧教之创教人为莲花生大士），很受当地村民信仰，法事很是忙碌。母亲叫我去依止这位红教喇嘛学习。临行离家的时候，还有两三个亲戚来送我。在这一段时期内，结赛的父母常常叫结赛送些吃的东西、烧的柴和油等到我读书的地方来。当母亲和妹妹找不着工作的时候，舅舅也供给我们一点食物；他为了不使母亲去讨饭，到处想法子替母亲找点工作。在他能力所及之内，对我们母子三人尽了最大的力量。妹妹有时替人跑跑腿，打打鼓，有时替人打扫厂房做点杂工，想尽方法求衣食。但是吃得还是很苦，穿得还是褴褛不堪，除了悲哀之外，毫无快乐。”


修学咒术复仇

    密勒日巴尊者说到这里的时候，听法的人都感伤流泪，生起厌世之心；满座听法的弟子都静静地沉回在唏嘘哀泣的声中。
    惹琼巴说：“尊者！您老人家说起先做黑业，那是怎么回事？”
    密勒日巴说道：“起先做黑业，就是用杀人的咒术和降雹术来造了极大的恶业。”
    “尊者！”惹琼巴又问：“您为什么要修练咒术呢？”
    密勒日巴回答说：
    “当我在无上广地方修学的时候，一天，嘉俄泽平原上的村民要开一个同乐会，请我的师傅为主客。师傅就带我一齐去。村人们准备了极丰富的筵席，并且用上好的美酒来招待师傅。啊！那天他们的美酒可真是多呢！大家都尽情地欢饮，我也忘其所以的狂饮了个痛快，到后来，肚子喝得涨涨地，头也晕沉沉地，醉做一团。
    “师傅看我已经醉了，便叫我拿了供养的东西先回庙去。我醉意熏熏然，身上懒洋洋地，心中快乐无忧地沿着山上的斜坡小路，一路东倒西歪，拖着软绵绵的两腿，蹒跚地向着庙子走去。路上我忽然想起宴会中唱歌的人来了，他们唱得非常动听，想着想着，自己的喉咙也就痒起来了，情不自禁地自己也唱了起来。
    “我的歌喉，在乡人中原负有一点儿名气，这天有了酒意，兴致又好，声音也特别宏亮；同时歌调也好，心神飞扬在虚空，两腿飘然似飞的，且走且跳，且舞且唱，不知不觉走到回家的路上了。一直等到了家门口，我还在手舞足蹈地唱着。那时候我的母亲正在炒麦子，听见这个声音非常的诧异，自言自语的说道：‘这个唱歌人的声音，好象是我的儿子的声音呀！但是世界上再没有比我们母子更苦的人了，我的儿子不会有心情这样快活的唱吧！’母亲又诧异又怀疑，心里不相信，就跑到窗口来看了一看。一看真的是我，气得浑身发抖，立刻把右手拿的火钳往地下一扔，左手拿的炒麦子的棒铲往地上一丢；也不管麦子烧焦了。右手拿起一根棍子，左手抓了一把灶前的灰，连走带跳从楼梯上跑了下来，跑到门外，把左手那把灰望我脸上一洒，拿起棍子就在我的头上乱打，大声喊叫道：
    “‘密勒蒋采爸爸哟！你看看你的这个儿子啊！你的后代绝了种了！你看看我们母子的命呀！’哭着叫着，气极昏倒在地上。
    “这时候，妹妹琵达也从屋里赶出来，一面哭，一面说道：‘哥哥！你好好的想想吧！你看看母亲成了什么样子啊！’
    “我在这样一阵突然紧张的暴风雨之下，迷迷糊糊的；听见妹妹的话，才清醒明白过来。一阵羞愧和悲愤，使我的内心深深的痛疚，泪珠止不住地流着。妹妹和我一面哭，一面握着母亲的手，摇着母亲的身体，呼唤母亲。半晌，母亲才苏醒过来。她用两只含泪的眼睛望着我说：
    “‘儿呀！世界上还有比我们母子更悲惨的人吗？你还有心肠这样快活的唱歌吗？你只要把你的母亲——这个老婆子看一看，你哭都哭不出来了啊！’说完又嚎啕大哭起来。
    “妹妹和我又随母亲一起悲痛地大声哭泣。后来，我抑住了悲痛，毅然地对母亲说：
    “‘母亲，请你不要再这样伤心了，你的话真是一点不错，我现在下了决心：母亲如有心愿，不论要我做什么，我一定要做到！’
    “‘我要你报复那些可恶的上穿毛[纟+曷]下跨肥马的仇人！我们势孤力弱，唯一的报仇方法，只有藉诛法和咒术。我要你去将诛法、咒术、降雹法，彻底的学精，然后回来，用咒术把伯父、姑母和苛待我们的邻人连九族一概杀尽！这是我的唯一心愿，你能做到吗？‘
    “‘我一定办到，请母亲即刻替我准备旅费和上师的供养！’我毅然决然的说。
    “于是母亲就把铁波钱琼这块田地又卖了一半，将这钱买了一颗名贵的‘巨星光’大松耳石。后来又买了一匹叫‘无鞍之狮’的白马，加上一桶染料和一驼牛皮，以便后来供养上师和做我的旅费之用。我就在贡达享的若供错旅店里住了几天，等候可同行的伴侣。
    “不久，从上俄日地方来了五个都是要到卫藏去学法和咒术的好青年。我非常的高兴得到这样难得的机会，就向他们建议结伴同行；他们也很愿意多有一个同伴，就决定和我同行。
    “我将他们请到下贡通地方，在家中住了几天。母亲热忱的款待他们，临别以前，母亲对他们说：
    “‘各位，我的这个闻喜，是个年轻不晓事的孩子，自己不知求上进，请各位时常鼓励他，要他好好的把咒术学会，回来时我一定要好好的酬答各位的！’
    “他们都答应随时照拂我，并请母亲放心。
    “于是我们就动身了，染料和行李都放在马上，松耳石则藏在身边。母亲送了我们很远的一段路，沿路给我们喝酒饯别，又再三叮嘱那些朋友们好好的照料我。后来又特别把我独自叫到一旁，紧紧地握着我的手。别离的滋味充塞在我们母子的心头，窒息了我们的呼吸，我们默默无言地相对着，千语万言想要在这一刹那间说出来，却反不知说哪一桩的是。费了很大的劲，母亲终于打破了这难忍的静默：
    “‘儿啊！你要好好的想一想我们母子的遭遇啊！无论如何你得要咒一咒这个村子啊！你的同伴们学咒术的目的是与我们不同的，他们只是想靠着咒术养活自己！可是，你得要好好的精进啊！儿呀！你要是不能咒倒这个村子就回来了，你的母亲就要死在你面前的啊！’
    “我激动地向母亲发誓说道：
    “‘母亲，我要是学不成功，我是决不回来的！请您放心好了！’
    “我被母亲紧握着的手慢慢抽了出来，回到同伴一起，就向母亲告别了。但是我心里还是舍不得母亲，向前走几步，又回头看看，走几步，又回头看看，眼泪扑簌簌的只往下流。母亲也好象舍不得我，一直到看不清我的时候，还是朝我去的这方向凝视，我很想跑回去再看看母亲。这时在我心灵深处，直觉仿佛已告诉我，这是我们母子最后一次的离别，从此以后，我将再见不到母亲了！
    “母亲一直等到看不见我的背影以后，方才哭着回家去。这几天村上的人们都知道白庄严母的儿子去学咒术去了。
    “我们向卫藏的大路上出发，到了藏州雍地方的雅古太，我把染料和马卖给当地的财主，换了黄金，带在身上。过了藏布江转向卫地前进。到了托烘的汝古那地方，遇见很多卫地的和尚，我向他们打听询问，卫地有什么精通咒术、诛法和降雹法的人。有一个和尚对我说，在波通地方有一位喇嘛名叫雍同多甲，他是得了咒术诛法成就的真言行者。于是我们就启程向波通走去。到了波通，朝礼了雍同多甲喇嘛。同行的五个学生，每人献给了这位师傅一份供养。我把金子、松耳石和所有的一切东西都供养他，并且跪着对他说：
    “‘不但是这些金子、松耳石、这一切物质都供养给上师，连我的身、口、意所有的一切，也都供养给您。师傅啊！我的邻人和亲戚作了极残暴对不起我家的事情，我要用咒术来诛罚他们，请您老人家把最好的咒术传给我吧！同时我在这儿学法期间的衣食等，也要依靠您老人家赐给我！’
    “喇嘛听了我的话之后，笑了一笑，说道：
    “‘我要慢慢的看你所说的是不是真话！’
    “上师并没有教我们最深奥的咒术，只教了一两个恶咒，和一些口诀和修法。这一点法就用了一年多的时间才传授完。授完了这些咒法，我的同学们都准备回去了，喇嘛每人赏给了一件卫地出产的羊毛衣。可是我却没有自信，心中暗忖，如果拿这种咒术来报仇，恐怕不会有什么效力吧，拿着这个没用的咒术回去，母亲一定会自杀的。想了想，就决定还不回去。我的同伴们向我说道：‘闻喜！你不回去吗？’
    “我说：‘我何尝不想回去呢？只是咒术没有学到手，不好意思回去。’
    “他们五个人都说：‘这些口诀也就非常的深奥啦！喇嘛自己也说比这更高深的口诀再也没有了哩！我们都自信回到家乡以后，名誉地位是不成问题的啦！不过你若是愿意再住下去，我们也不反对，听你自己的意思吧！’
    “于是他们五人就到上师面前礼拜告别，动身回家了。我也把上师所赐的衣服穿着，送了他们半天的路程。在返回上师家中的路上，沿路捡拾牛粪，捡了一大兜，在上师一块最好的田上，施了肥料。那时，上师正在卧房里，由窗口中看见了我，他就对另外一位弟子说：
    “‘到我这里来学法的弟子很多，但没有像这个闻喜那么好的，以后恐怕再也没有像他这样好的徒弟了吧！今天早上他未曾到我这里来告辞，是表示他还要回来的。他初来的时候就对我说，他的亲戚和邻居对不起他家，请我传他咒术去报仇。他又说：把身、口、意都供养给我；倒真是一个直心肠的人。如果他说的话全是真的，那么，不传他咒术未免太可怜了。’
    “这位同学就把上师的话告诉了我，我心中很欢喜，知道还有别的咒术可以传我，就欢喜的跑到上师面前来。上师说：
    “‘闻喜！你不回去，是什么道理？’
    “我把上师赐给我的衣服脱下来，又供养给他，顶礼师足，说道：
    “‘师傅老人家啊！我的伯父、姑母和邻居，作了很对不起我们母子三人的事！他们以不正当的手段，占据了我们的资产，给了我们种种的痛苦。我们没有报仇的力量，所以母亲叫我来学咒术；假如我的咒术不精就回家乡去，我母亲说过，她一定会在我面前自杀的！所以我不能回去。请师傅可怜我，传给我最殊胜的咒术吧！’
    “说着，情不自禁地哭了起来。喇嘛就问我说：
    “‘你的亲戚和乡人怎样欺侮了你们呢？’
    “我便将父亲密勒蒋采去世以后伯父、姑母怎样侵占遗产及虐待我们的经过，一面哭着一面说，详细地叙述了一遍。上师听了，也忍不住流下泪来。上师说：
    “‘假如你所说的话是真的，他们实在太不应该了。至于求我咒术的人，从各处来的都有；从哦日三洲来的供养百千的黄金和翠玉；从卫藏来的供养百千的[纟+曷]绒、酥油和青稞；从多、康、贡三处来的供养顶好的茶和绸缎；从恰、他、孔三处来的供养成千的马、牛、羊群。但是，以身、口、意来供养的却只有你一人！可是，我不能就传授你咒术。好吧！我如今先派一个人去调查你的话是不是真的！’
    “在我们的同学中，有一个飞毛腿，跑得比马还要快，站起来像巨象一般高大。上师就派他到我的家乡去调查。过了没有几天，他就回来了，对上师说：‘师傅老人家！闻喜所说的话一点也不假，请你传他一个最好的咒术吧！’
    “上师对我说：
    “‘闻喜！起先我如传你咒术，怕你这个憨头憨脑的人会后悔；现在既然知道一切都非虚构，我当将咒术传授给你。我有两个秘法：一个是‘杀法哼’，一个是‘毁法呸’。有一位叫古容巴功德海的喇嘛，住在藏州西隙村，他精通医药，并且擅咒术。他也有一个秘咒，名降雹法，我们彼此传授了独有的秘法以后，就成为莫逆之交。因此，凡是到我这里来学咒术的人，我都送到他那里去；他也将向他求咒术的人送到我这儿来。今番你也不能例外，就让我的大儿子陪你一同去吧！’
    “师傅为我准备了食物，又给我带了卫州的细毡、毛呢；还给我一些用来供养古容巴师傅的礼品。我们将这些东西都装载在马背上，就向藏州出发。
    “到了西隙村，会见了古容巴喇嘛，我将带来的礼品悉数供奉了给他，然后又将我的悲惨遭遇和所以要求诛法的理由细细的叙述了一遍，恳求喇嘛传授我咒法。喇嘛说：
    “‘雍同多甲喇嘛与我是生死至交，他送你们来一定是有理由的，我自应传授你秘密诛法。不过，你们第一步必须在山下人们所看不见的地方先修筑一个练法堂。’
    “我俩就在山脚下一处僻静的地方，筑成了一个简陋的练法堂。用一块跟牛一样大的石头将房子遮蔽起来。
    “上师就在这练法堂内，传授了我咒术的秘密口诀。
    “我在堂内修了七天法，喇嘛就对我说：‘从前的时候，这法修七天就够了；你现在也只要修七天就够了！’
    “但是我说我所要诛咒的地方很远，请让我再修七天吧！到了第十四天的晚上，上师又来对我说：‘今天晚上，在曼陀罗（法坛）的旁边，当有诛法成果的表现。’
    “果然，当天晚上，护誓三昧耶神（梵文三昧耶含多义，此处为誓语及‘不越’之意，指密教的护法神）手里提着三十五个人头和心胆来对我说：
    “‘你们叫我办的事就是这个吧！’
    “第二天早上，喇嘛又来问我：‘护法神对我说，该杀的人，还有两个，还要不要杀呢？’
    “我心满意足地说：
    “‘让他们留在世上作见证，看看自己的报应，请饶恕了他们吧！’
    “因为这样，才把伯父和姑母留了下来没有诛死。最后，我们又修法供养护誓三昧耶神，送赞护誓三昧耶神回去，散法解坛。
    “那时，在嘉俄泽我的家乡中，咒术灵验的表征是些什么呢？原来那天正是伯父的大儿子娶媳妇，请了很多的客人到家中吃喜酒。那些从前帮着伯父、姑母欺侮我们的三十多个人都一起到了伯父家里来贺喜。另外还有一群同情我们的人们亦在被请之列，正徐徐地向伯父家走来，大家还在议论伯父、姑母的不是。有的说：‘俗语说：客人变主，主人变狗。——这话真是不错；这些可恶的人真是不要脸，霸占了闻喜的家产还要虐待他母子；闻喜去学咒了，如果他的咒术不来，三宝的报应早晚也是要来的啊！’
    “那时候伯父全家和姑母都忙着款待客人，来贺喜的人们都兴高采烈地饮着酒。一个从前在我家做过工而那时又在伯父处做事的丫头，下楼梯去背水；走到楼下，看到满地的大蝎子、大蛇和大螃蟹在乱挤乱动。大蝎子用他们的巨钳夹住屋柱，要把柱子掀倒。她惊怕极了，尖声大叫着跑出门去。
    “那天楼下拴满了客人的马匹，其中一匹雄马想欺侮一匹雌马，其余的雄马不服气，大闹了起来，雌马就狠狠的要踢雄马，可是不知怎地，一脚却把柱子给踢倒了。说时迟，那时快，整个房子哗喇喇一声响就倒下来了，到处都听见一片哭叫的声音。伯父的儿子、新娘和那三十多个人，一起都压死了。满地只见倒塌了的房屋，堆上浮着一片灰尘；断木破瓦之下，压着一群死尸。
    这时我妹妹琵达正在附近张望，看见了这情形，马上飞跑回家去，急急忙忙的对母亲说：
    “‘妈呀！妈呀！你看啊？伯父的家倒了，死了好多人啊！’
    “母亲不大相信，心里却是一阵暗喜，连忙跑出去看。看见伯父的家，只剩下一片瓦砾，漫天都是濛濛的灰尘。母亲又惊又喜，慌忙从她褴褛的衣服上随便撕下了一块布条来，急急地系在一条长棍子上面；一面摇晃这面破布旗子，一面飞跑出去，大声喊叫道：
    “‘大家看啦！天啦！喇嘛啦！三宝呀！请受供养呀！喂！街坊邻居们啊！告诉你们啊！密勒蒋采不是有了儿子了吗？我白庄严母穿破衣裳，吃坏东西，供给我儿子学咒术，目的没有达到吗？各位看啊！伯父和姑母说：‘人多就打一仗，人少就去放咒术。’各位看，现在怎么样？现在闻喜只放了一点小小的咒术，却比打一场大仗还要厉害。你们看啊！上面的人，中间的财宝，和下面的牲口啊！我活到今天没有死，能够看见我的儿子演这一出戏，我白庄严母真高兴死了啊！哈！哈！哈！哈！我一辈子也没有这样快活过！各位看啊！各位看啊！’
    “她把旗子一面摇，一面晃，一面喊叫，一面跑，真是快活极了。伯父、姑母和全村的人都听见了，其中就有人说：
    “‘这个女人讲的话恐怕是真的啊！’
    “另外一个人说：‘真倒是像真的，只是说得太过火了一点！’
    “人们听说我用咒术杀死了这么多人，大家都集合起来说：
    “‘这个婆娘，闹出这样大的事来，还要快活得到处喊叫，我们非把她心肝的血挤出来不可！’
    “有个老头子连忙劝阻道：
    “‘就是把那个女人杀了，又有什么用处呢？这样不过叫他的儿子更恨我们，再多咒死我们几个人而已。我们先要想法子把闻喜杀了，再来杀这个婆娘，就没有问题了！’
    “这样才算没有杀我的母亲。可是伯父听了以后就说：
    “‘我的儿子也死了，姑娘也死了，我也跟她拼了，不要活了！’
    “说着，就要跑出来杀我的母亲。大家赶快把他拦住说：
    “‘都是因为你，才闹出这件事来；现在闻喜还活着，如果你现在把白庄严母杀死，闻喜再放咒术，我们都活不了。如果你不听我们的话，我们就先把你杀了！’
    “这样才把伯父劝阻下来。村人大家便商量怎样派人来杀我。我的舅舅就到母亲这里来说：
    “‘昨天你所说的话和所作的事，使得村人大家都想把你和你的儿子弄死，你有什么防备没有啊？唉！放一次咒术也就够了啊！何必再引起公愤！’
    这样劝了又劝，母亲就说：
    “‘唉！你还不了解我们吗？这些事情我也明明知道，我是报复那些夺我们财产的人，才种下这个恶种子的啊！这个冤仇用尺子量都量不清的哟！’别的话一句也不说，只是哭泣。
    “舅舅叹了一口气说：‘你的话当然也是对的，可是，恐怕杀你的人快来了，你还是把大门关起来吧！’
    “母亲就把门好好关牢，在屋里想来想去，非常不安。我们从前的那个女佣人，因为可怜我母亲，就偷偷的跑过来对母亲说：
    “‘他们现在倒不想害你，他们想害少爷，您赶快告诉他，让他小心一点才好！’
    “母亲听了她的话之后，暂时放下心来。
    “母亲把剩下来的铁波钱琼田又卖了一半，一共卖了七两黄金。想把这笔钱送给我，却不便叫任何村中的人送来。最后，正想自己送来的时候，恰巧有个卫地的瑜珈行者到尼泊尔去朝山，来到我们村上，托钵化缘。母亲把他的来历详详细细的问明白了，觉得他很适合作送信的使者；于是母亲就对他说：
    “‘师傅！请你在这儿小住五、六天；我的小孩子现在卫藏地方学法，我想写一封信给他，要请师傅帮帮忙给他带去。’
    “那位瑜珈行者答应了，母亲就好好的招待他住了几天。
    “当天晚上，母亲点了一个灯，跪在神前发愿说：‘我的心愿如能实现，这个长明灯就不熄灭；若是我的心愿不能如愿，请立刻熄掉；祈请闻喜的祖先、护法神，以此示我。’这样发愿以后，灯点了一昼夜都没有熄，因此母亲相信所谋一定可以如愿成就。于是第二天她就对那个朝山的行者说道：
    “‘师傅，朝山人的衣服和鞋子都是很要紧的，你的衣服让我好好的来补一补，我另外再送你一双鞋底吧！’
    “说完就给了他一块又长又大作鞋底的皮子，把身上那又旧又破的衣裳取下来，用布把破处补好。在衣裳的背心当中，把七片黄金隐藏在内，用一尺见方的黑布片缝上，在黑布片当中用白色的粗线，绣成了六个小星，再用布遮住了这些小星，却不让行者知道。此外又送了那个行者很多的礼物，在信封上盖了一个印，方把信交给行者，请他带去。
    “这时母亲心里暗想：‘现在这些村中的人们，不知道在打什么主意，要想个方法来吓他们一吓。’就对琵达妹妹说：‘昨天那个行者，带来了你哥哥的一封信。’琵达就四处去告诉大家，让大家知道我有信带回家。母亲仿效我的口气写了一封假信，信上说：
    “‘母亲大人膝下敬禀者：诛咒见效，儿心大快。若村人尚有对母亲及琵妹无礼者，请即将其姓名、家族示知，以便放咒。儿以咒术，取人性命，易如反掌，诛其九族，灭其根苗，犹探囊取物耳。若村人尽皆不良，请大人及琵妹移居此处。儿初离乡里，自无分文，今则资财盈库，享用不尽矣，祈释慈注，儿闻喜拜上。’
    “又盖了一个假印，先把信给那些与伯父、姑母相好的人看，随后就把信放在舅父的地方。这样一来，他们便改变了计划，不敢再想杀害我们；也因为这封信的力量，村人们要求伯父把俄马三角田也交还给母亲了。
    “再说那位朝山的行者，听说我住在西端溪，就到西端溪来找我。把母亲、妹妹和乡中的情形，详详细细的向我讲述一遍；又把母亲的信交给我。我把信拿到没有人的地方，拆开来看。信上写道：
    “‘闻儿知悉：母亲甚健，不必挂念。汝母有儿如是，亦可以无憾矣；汝父密勒蒋采纵在黄泉，亦可以含笑无恨矣。儿放咒之结果，压死仇家三十五人。近闻村人将密派刺客，谋杀吾儿，然后再杀汝母，故必须随时警惕。渠等既仍持报复之心，自不能轻恕，应施以九壁层之降雹，毁其稼禾，则汝母愿足矣。若学费已尽，可在北向之山，黑云深处，六星放光之下，有吾家亲戚七户，可向彼等索取。儿若不知彼等亲戚之住处，及山村在何处，于此行者身上求之即得。此山村中，只行者一人居住，不必他求也。母白庄严手字。’
    “我看了信以后，不明白信中的意思，想起家乡，想起了母亲。信中所说的山村和亲戚也都不知道，需要的学费供养也拿不到，不禁眼泪汪汪的流下来。哭了一阵，把泪眼拭干，走去向行者说：
    “‘听说你知道我的亲戚所住的山村，请你告诉我好吗？’
    “行者说：‘我就听说喜马拉雅山下的贡得抗有你的亲戚！’我问他道：‘你还知道别的地方吗？请问你的家乡是哪儿呀？’行者说：‘此外的山村，我知道的很多，但是你的亲戚住在哪儿，我却不知道；我是卫地的人！’我说：“那么，请你等一等，我马上就来！’
    “我就把信拿给上师看，把经过的情形详细的说了一次。上师就说：‘你的母亲瞋心真不小啊！杀了这么许多人还不够，还要降雹！’接着又问道：‘你的亲戚在北方什么地方呀？’我回答说：‘我以前从来没有听说北方有什么亲戚，但是信上明明是这么说的；我问那个朝山的行者，他也说不知道，到底是怎么回事啊？’
    “那时，师母智慧空行也在一起，看了信之后，说道：‘你把那个行者喊进来！’师母就烧了一盆大火，请行者进去烤火喝酒。师母指天画地，东说西说，顺便就从行者的背后，把他的大衣脱下来，披在自己的身上说：‘穿着这样破旧的衣服去朝山，福气一定会来的。’说着，东走西走就走到楼上去了。师母在破衣的当中，取出了黄金之后，照样补好，仍旧把衣服还给行者，招待他吃饭，留他住宿。
    “师母对我说道：‘闻喜！闻喜！到上师那儿来啊！’我与师母一同到了上师面前，师母就给了我黄金七两。我很惊异的问道：‘这黄金从哪里来的呀？’师母就说：‘你的母亲真聪明啊！在行者的身上把这七两黄金藏得这样好！信上所说的，北向的山村，就是太阳照不到的地方，行者衣裳的里层，不是太阳照不到吗？黑云就是用黑布缝着的意思；六个星放光，就是用白线缝了六处的意思；底下的七家亲戚，就是有七两黄金的意思；若找不到的话，要知这个山村里只有行者住在里面，用不着找别人；这就是说黄金在瑜珈行者的身上，用不着找别的人了！’上师仰天哈哈大笑，一面说：‘人们都说你们这些女人聪明，这话真不错！’
    “我给行者一钱金子，行者真是快活极了。我随后供养了师母七钱金子，供养上师三两金子。又对上师说：
    “‘我的母亲还要我降雹，请上师传给我一个最秘密的降雹法吧！’
    “上师说道：‘你要学降雹法，却是要到雍同多甲上人那里去求！’
    于是上师就写了信和带了些土产的东西，着我又到波通去了。拜见了上师以后，供养了三两黄金，又把信和土产也一并供养了，详细的陈述求学降雹法的原委。上师问道：‘咒术成功了吗？’我说：‘咒术成功了，杀了三十五个人；我又接到母亲的信叫我降雹，所以要请上师传给我！’上师说道：‘好！满你的心愿吧！’就把降雹法传给我。我又在练法堂处修了七天。在第七天的时候，由对山的石隙间出了一团黑云，电光闪闪，雷声轰轰，满天大风暴要降临的样子。我知道我的本领已能指挥降雹了。
    “上师来问我：‘你现在能够降雹了，可是不知道你们家乡的麦子熟了没有，长得有多高了？’我想了一想说道：‘大概还只有可以藏斑鸠那样高！’
    “于是又过了十几天，上师又来问，我说：‘大概有小芦草那样高了！’上师说：‘嗯，还稍为早一点！’
    “又过了些时，上师又问，我说：‘现在是正要长穗的时候了！’上师说：‘那么，你应该去降雹了！’就派从前曾到我家乡去调查过的那个同学送我一起去。我们都装着行脚僧的模样出发。
    “那一年，家乡的麦子长得异常的丰盛，许多老人家都说从来没有看见过这样的好收成。村人约定不准各自任意收割，要在大家庆祝以后，才同时动手。我等到再隔一两天村人就要开始割麦子的时候，在村前溪水的上流处，结了一个法坛，预备了咒术用的种种材料，开始作法，喝诵咒语。那时空中，万里无云。我大呼一声护法神之名，陈述村人虐待我家的事实，捶胸拍衣，大声的哭叫起来。
    “真是不可思议！空中忽然起了一团黑云，一层卷一层，瞬刻间变成一大堆的浓云，电光闪闪，雷声隆隆，一霎时，大冰雹纷纷降下来；下了一阵又一阵，把村人眼看着要收割的麦子打得一粒不剩。山上又冲出一股洪水，把麦子也一起冲走了。村人看见麦子随洪水流去，都放声嚎啕大哭。最后，空中起了一阵风暴，我们两个人身上觉得冷簌簌的，就跑到北边的山洞里，生起火来取暖。那时，村中的人，为着庆祝丰年摆酒宴而准备肉食，派了一伙人出来打猎。这些打猎的人，恰巧经过崖洞的前面，有一个人说道：
    “‘哼！再没有比闻喜把这个村子害得更惨的人了。以前杀了那么多人还不甘心，现在又把这样好的麦子弄得一粒都不剩了！要是把他捉到了，我要把他的血挤干，活生生的把他的胆挖出来，都还不能消我的恨。’
    “当中就听见有一个老头子说：‘嘘！嘘！不要声张！低声点说话！你看那个崖洞里在冒烟，是谁在里头啊！’一个年青的人说：‘那准是闻喜！那个混蛋没有看见我们，我们赶快招集人来杀死他，不然他要把这个村子都害得精光了！’一面说一面大家急急地都跑回去了。
    “我的同伴看见下面有人走过来，知道大概已经有人发现我们在这里了，就对我说：‘你先回去吧，我装着你的样子，跟他们玩一玩！’我们就约好，四天后晚上，在滇目的客舍中相会。当然啰！我知道他多力好勇，所以也就很放心地让他一人留在那里。
    “那时我很想会会母亲，但又怕村人会害我，所以只得离开家乡，绕道往宁哦去了。不幸在路上让一只野狗咬了我几口，腿上到处是伤，一路走一路跛，结果不能够如期到达客店。
    “我的同学到底干了些什么事呢？那天我走了以后，村中就集合了大队人马来杀我，他就奋然鼓足勇气，向人马群中冲了过去，冲得人和马纷纷两边倒。当他冲过去之后，村人又一齐集合追赶过来。村人追得急，他就跑得快些；追得慢，他又从从容容的走得慢些；村人丢石头过来，他就丢掷更大的石头过去，他大声的叫道：
    “‘谁要敢打我，我就不客气用咒术诛死他！我杀死了那么多的人，你们还不怕吗？今年这样好的收成，弄得一粒麦子都看不见了，你们还不够吗？今后你们要是不好好的待我母亲和妹妹，老子就在村中的进口处放下鬼池，出口处放下魔咒，让你们这些活着未死的人，九族都要一起死完！不把这个村庄化为灰烬，决不甘休！你们不怕吗？’
    “村人听完他的话都吓得混身发抖，大家你望我，我望你，一个推一个，叽哩咕噜的说：‘你说！你说！’说着，却一个个都悄悄的溜回去了。
    “他倒比我先到滇目。到了客店之后，就问老板，有没有这样这样的一个行脚僧到你们这个店里来呀？老板想了想说：‘来是没有来，可是你所说的那个行脚僧，现在好象正在那个举行宴会的村子里面，像是受了些伤似的。你大概没有带碗吧？我可以借一个给你。’说着就借了一个碗底灰色而形状像阎王面孔的碗给我的同学。他就拿着碗到村上的宴会来行乞。他在宴会中找到了我，走近来坐在我的身旁说：‘你昨天怎么没有来呢？’我说：‘前几天，我在路上去要饭的时候，让野狗咬了几口，所以走不动，现在才好了一点，大概不要紧了！’于是我们两人就一同回波通。拜见了上师以后，上师对我说道：‘你们俩作了一件了不起的事！’我俩觉得奇怪，向上师说：‘在我俩回来之前，是谁告诉你老人家的呢？’上师说：‘护法神等将士，在十五月圆的时候回来告诉我的，这一次是我差遣他去的。’说完，大家都觉得很高兴。”


晋见马尔巴上师

    那时尊者密勒日巴，对听法的弟子说完上面的故事之后，就对弟子们说道：“我就是这样为了报仇而作黑业的！”
    惹琼巴问道：“上师，你说过先作黑业，后作白业，白业只有正法。尊者！您是以什么因缘得遇正法的呢？”
    密勒尊者说：
    “我渐渐对于放咒和降雹的罪恶，起了后悔之心。要想修正法的心念，一天比一天的强烈起来。常常白天不想吃饭，夜晚睡不着觉；走时想坐，坐时想走；对所犯的罪恶，十分后悔，因此厌世之心，常常涌上心头。但是又不敢说想修正法的话，总是在想：‘上师这里，有没有修正法的机会呢？怎样办才好呢？’
    “正在这样不断苦想的时候，遇到下面这件事：原来上师有个很好的檀越（就是施主）。他的家产富足，对上师的信心很好，恭敬承事上师不遗余力。不知怎地忽然得了重病，盼上师为他加持祈祷，请上师到他家里去。
    “过了三天，上师青白色的脸上，带着苦笑回来了。我就问上师说：‘师傅！你的脸色为什么这样难看啊？为什么老是这样苦笑呢？’
    “上师说道：‘世间的一切都是无常。昨天晚上，我那个最好的最有信心的施主死了。因此，唉！我对这个世界就起了悲哀之心哟！我这个老头子从青年时代到现在白了头的暮年，一直在做咒术、诛法、降雹三种作业。你这个弟子虽然是年轻，和我一样，也犯了咒术和降雹的大罪恶，这笔帐将来恐怕也是要算在我头上的！’
    “我心中生出了疑问，便问上师说：‘我们所杀的那些有情，上师难道不能够使他们生兜率天（弥勒菩萨所居之净土，西藏修弥勒净土的人颇多）或解脱吗？’上师说：‘有情的自性就是法性，在理趣上，原有这样可以令他们生兜率天和解脱道的说法，这种仪轨修法我也知道，但是这些不过只是解说文句，事实上真正能够使他们得救获解脱的，一个都没有。从现在起，我要修习对自他二利都有实效的正法。你来教导我的徒众好了，以后我要引导你到兜率天及解脱道去。或者，你去修正法，做我生兜率天与解脱道的引导者。你求正法所需要的东西，我都供给你。’
    “啊！当时我听了，心里多么高兴啊！我日夕渴望着的事竟要实现了，连忙对上师说：‘我愿意去修正法！’上师说：‘你的年纪轻，精进心与信念也强，那么就请你一心一意的去修正法罢！’
    “上师就忙着替我准备行装，把宁哦出产的毛布与藏片装在一匹马上，连马一起送给了我。告诉我：在察绒那地方，有一个雍登喇嘛尊者，这位老人家，通达正法大圆满（红教所传的无上心地法门）教授，是一位得了成就的上人；你到他那里去修习正法好了。我拜别上师和师母，来到察绒那，看见了雍登上人的太太和几个徒弟，他们对我说：‘这就是雍登喇嘛的本庙，但是上人现在却在宁拓惹弄的分庙里，不在此地。’我对他们说：‘我是雍同多甲喇嘛派来的，请你们派一个人领我去见上人。’又把来历详详细细的说明了，上人的太太就派了一个喇嘛领我去。到了宁拓惹弄，拜见了上人，我把毛布和藏片一起献上说：‘我是从上方来的，是一个罪大恶极的人，请您慈悲，传我一个今生解脱轮回的法门。’
    “上人说道：‘我的成就大法：根，本性殊胜；道，获得殊胜；果，使用殊胜；昼思维，昼成就；夜思维，夜成就；根基好的，有宿因善根的人，无思维的必要，闻法即解脱。我就把这个法传给你吧！’于是上师就为我灌顶（密乘传法，即为灌顶），又授给了我口诀。那时我暗想：从前我修咒术的时候，只修了十四天就有了效应，降雹法只修了七天就得了成就。现在上师传给我比咒术和降雹还要容易的法，昼思维，昼成就；夜思维，夜成就；有宿善者闻法即成佛，无思维的必要，我能够遇此大法，自然也是有善根的人。因此生起我慢，全不思维修习，人与法相离。
    “这样过了几天以后，一天，上人来看我，对我说道：‘你说你是上方来的大罪人，这话真不错。我的法，也稍为夸大了一点，我不能引导你，你现在立刻到罗白来克的扎绒地方，去依止印度大行者那诺巴的亲传弟子，至尊译经大师——马尔巴尊者。他是新派密宗的行者，得了三种无分别的大成就者；他与你前生有缘，你去好了！’
    “我听见译经王马尔巴译师的名字，心里就说不出的欢喜，全身的汗毛直竖，眼泪如潮水般的涌出，生起了无量的欢喜虔诚和无比的信心。
    “我带着旅行的食粮与上师的介绍书信，就动身上路了。一路上老是想，恨不得马上会见上师才好。
    “在我要行抵扎绒的前一天晚上，马尔巴上师梦见大善巧者那诺巴上师降临灌顶，那诺巴尊者给了马尔巴上师一个五股琉璃金刚杵，在杵的尖端上，略微沾有一些尘垢；另外又给了一个盛满了甘露的金瓶子，说道：‘你拿这个瓶子里面的水来洗净金刚杵上的尘垢；把金刚杵高悬在大幢之上，上令诸佛欢喜，下令众生获益，这样就能成就自他二种事业。’言毕逝去。马尔巴上师就依照尊者的话，用瓶中的甘露洗净金刚杵，把金刚杵放在大幢之上，金刚杵忽然大放光明，普照三千大千世界。光明照在六道众生的身上，消除了所有的痛苦和悲哀。众生快乐踊跃，向马尔巴上师和大幢顶礼；恒河沙数无量诸佛都向着这个大幢开光（就西藏佛教一般习俗言，开光者即诸佛亲自降临加持祝福）。
    “上师早上醒了以后，心里非常高兴，正在思量夜间的梦。却见师母慌慌忙忙的跑来说道：‘上师！昨天晚上我做了一个梦，梦见北方乌金刹土来了两个年轻的美女，手里捧着一个琉璃的宝塔，上面稍为有一点尘垢。她们对我说：‘这是上师那诺巴的意旨，要你把这个塔开光以后放在山顶上。’你就说：‘既是那诺巴上师的意旨要我开光，我当然是要做的。’于是你就用水洗净了宝塔，又开了光，把宝塔放在山顶之上，宝塔忽然放出了如日月般无量的光明，光明中又化现出无数的宝塔来。我做了这样的一个梦，上师你看这个梦有什么意思呢？’上师听见师母说了这个梦以后，知道师母的梦与他自己做的梦完全相合，心里虽然非常高兴，但是表面上却一本正经的说：‘梦都是幻想无实的，我也不知道你的梦有什么意思。’接着又说：‘今天我要到地里去种田，你给我准备一下！’师母说：‘像您这样一位大上师去做这种事，别人会笑话我们的！请您还是不要去吧。’上师不听，又吩咐说：‘给我拿一坛酒来，我还要招待今天来的小客人！’上师带着酒，拿了工具，下田去了。
    “马尔巴上师到了田里以后，先把酒坛子埋在地下，用帽子盖起来，锄了一会儿地，就坐下来，一面休息，一面喝酒。
    “那时，我已快到罗扎乌谷（罗扎乌谷即罗白来克扎绒之简称）的边缘了，沿路到处向人探听至尊马尔巴大译师住处，不料竟是连一个听说至尊马尔巴译师这个名字的人都没有遇到。等我走到要看得见罗扎乌谷的一个十字路口时，遇见了一个人，我又问了他一遍，他说：‘马尔巴，倒有这么一个人，可是至尊马尔巴大译师却没听说过！’‘那么，罗扎乌谷到底在什么地方呢？’他指着对面的山谷说：‘罗扎乌谷倒不远，就是对面那个地方！’‘谁住在那儿呢？’‘马尔巴就住在那儿！’‘他还有别的名字吗？’‘有人叫他马尔巴，也有人叫他马尔巴上师！’于是我知道这一定就是我急于要寻访的马尔巴上师了。
    “我又问他：‘这个山坡叫什么名字呀？’‘此地叫做法广坡！’我心里想，在法广坡上看见了上师的住所，缘起非常好！心里很是高兴，一面走上来，一面又向人询问。走不一会儿，遇见了一群放羊的人，我又问他们马尔巴译师住在哪里？一个老头子说不知道；其中有一个很漂亮很可爱的小孩子，穿的衣服很讲究，口齿也很伶俐，对我说道：‘喂！你大概是说我的父亲吧！我父亲把家产都卖光了，换成金子，带到印度去，回来的时候带了很多长页子的经书回来。他一向不种地的，今天不知道是什么缘故，在那边田里种起地来了！”我心想大概不会错了，但是又疑惑，怎么大译师会自己种起地来呢？一面思忖，一面走着，忽然看见路旁田里面，有一个身材魁伟健壮的喇嘛，生就一双大眼睛，眼光炯炯的在那儿锄地。我一看见他，心里就有说不出的愉悦，在不可思议的快慰热情中，忘记了现世的一切。过了一会儿才苏醒过来，我就走到这喇嘛的面前问道：
    “‘有没有一个印度那诺巴大师的徒弟马尔巴译师住在这里啊？’
    “这个喇嘛把我从头上到脚下仔仔细细的看了很久，说道：
    “‘你是谁？你找他干吗？’
    “我说：‘我是后藏上方的一个大罪人，马尔巴的名气很大，我是到他这里来学法的？’
    “喇嘛说：‘我一会儿带你去见他好了，你快替我锄锄田吧！’
    “说着就把帽子拿开，把地下藏着的酒坛拿起来，尝了尝酒，好象很好吃的样子。尝完了酒，他把酒坛放下就走了。
    “他走了之后，我把酒坛拿起来，一咕噜把酒都喝光了；随着我就锄田。不一会儿，刚才放羊人群中的那个穿得很漂亮很伶俐的小孩跑过来对我说：‘喂！上师叫你进去呢！’我说：‘我要先把这个田耕完了再来，刚才那个人帮我去传话给上师，我也一定要替他把田耕完才对，请你先通禀一声说我马上就来了！’我就一口气把田全部都耕完了。以后这块田就叫做顺缘田。
    “耕完了田，小孩子就带我去见上师。刚才我见到的那个肥壮的喇嘛坐在一个铺有三层厚垫子的高座上，座上刻有金牛星和大鹏鸟的花纹。他好象刚刚洗完脸似的，但是我仿佛还看得见他的眼毛上有一点灰尘；他肥胖的身体，坐在那里正好一大团，肚子胖胖的凸了出来。我打量着，这就是刚才种地的那个人呀，马尔巴在哪里呢？于是就东张西望的到处看。上师就笑着说：
    ‘这小子是真的不认识我啊！喂！我就是马尔巴，你磕头吧。’
    “我就恭敬的顶了礼，说道：‘我是藏地来的一个造了恶业的大罪人，我以身、口、意都供献给上师；请上师给我衣食和正法，并请慈悲赐我‘即身成佛’的法门。’
    “上师说道：‘你是个大罪人，管我什么事？罪业是不会到我的头上来的！而且又不是我叫你去造业的！喂！你究竟造了些什么业呀？’
    “我就把过去的事详详细细的说了一遍。
    “上师说：‘哦！原来如此！把身口意都供养上师倒是应该的，可是我不能又给你衣食，又传给你法！要么给你衣食，你到别处去学法；要是传你法，你就得到别处去求衣食去。这两样只能给一个，你好好的选择一下好了。再者，我就是传给你法，也不一定是今生就能成佛，这是完全要靠你自己的精进的！’
    “我说道：‘我是到上师这儿来学法的，衣食我另外想法子去。’说完了，我就拿着一本经书到佛堂里去。
    上师看见了说：‘你的书拿到外面去，我的护法神嗅了你的邪书气说不定会打喷嚏的！’我诧异地想：上师大概已经知道我的书里面有咒术和诛法了吧！
    “上师让了一间房子给我住。我在里面住了四、五天，做成了一个放东西的皮口袋；师母又给了很多好吃的东西，待我非常的好。
    “为了供养师傅，我就在罗扎乌谷到处去要饭，讨来了二十一升麦子。用十四升麦子买了一个毫无破损锈烂的四方形的大铜灯；用一升麦子买了肉和酒；把其余剩下来的麦子都装在我自己做的皮口袋里。又把大铜灯捆在口袋上面，背着走回来。背到上师的住宅前时，身体已经疲惫不堪；扑通一声，把东西从背上拿了下来。满满的一口袋麦子的份量很重，把房子都震动了。上师正在吃饭，马上出来看，瞧见是我，就说道：‘这个小子，气力倒真不小啊！喂！你是不是想把我的房子弄倒，压死我呀！真混帐！快点把口袋拿出去！’说着提起脚就踢我。我只好把麦子拿到外面，心里暗想：这位上师真不好惹啊！以后总得好好的谨慎侍候才是。但是心里却并没有起一点不满意的心思或邪见。
    “我向上师顶礼，把买来的大铜灯供养给上师。上师手里拿着铜灯，闭着眼默思了一会儿，不禁流下泪来。他很欢喜、很感动的说道：‘缘起太好了！这是供养大梵学者那诺巴上师的。’上师结印作了供养之后，用棍子把铜灯敲了敲，铜灯发出铿铿的声音来。上师把铜灯拿到佛堂去，在铜灯里装满了酥油，装好灯心，把灯点了起来。
    “我心里很着急，急于想求法，就跑到上师的面前请求说：‘请上师就传给我大法和口诀吧！’
    “上师说：‘由卫藏要到我这里来学法的徒弟和信士很多，但是蜀大和令巴地方的人捣乱，常常抢劫他们，不准他们送食物和供养给我。现在我要你对这两个地方下冰雹，要是成功了，我就传法给你！’
    “为了求法，我就又一次的使了降雹术，果然是成功了。我又回到上师面前来求法，上师就说：‘你不过下了两三块冰雹，就想要得到我从印度苦行得来的正法吗？如果你真要想求法的话，那么，让我告诉你：卡哇地方的人们曾打我的徒弟，一向专门跟我作对，你要真是有厉害的诛法，你就应该放咒来咒他们；成功以后，我就把那诺巴上师传下来的即身成佛的法传给你。’无奈，我又开始放咒了。不久，卡哇地区果然起了内乱，杀死了很多人，与我们作对的都死了。上师看见我的咒术真的灵验了，就说：‘人家说你的诛法厉害，咒力很大，倒不是假的啊！’自此，上师就呼我为‘大力’。
    “我再次又向上师请求传正法，不料上师大笑道：‘哈！哈！哈！你造了这么样大的罪，还要想我把这个不惜身命到印度，用黄金供养上师的口诀，空行母的心要，轻轻易易的给你吗？就是开玩笑，也未免开得太过了。再说，你这善使诛法的人，今天若不是我而是另外一人，恐怕你早就把他杀掉了。好！现在你要是能把蜀大、令巴的收获恢复，卡哇杀死的人都弄活，我就给你传法，否则你就不要在我这里住了。’将我痛骂了一场。我失望已极，放声痛哭，师母看我可怜，就跑过来安慰我。


艰难的灭罪苦行

    “第二天一早，上师到我这里来说：‘昨天，我对你说得也未免太狠了一点，不要生气！你的身体很强壮，我想要你给我建造一间装经书的石屋。这个石屋修好了，我就传法给你，你所需的衣服食物都由我供给！’
    “我就说：‘要是我在造房子的时候，法还没有求到就死了，那又怎么办呢？’
    “‘我担保你在这个期间决不会死！一个人没有勇气是不能修法的，你却像是一个有毅力能精进的人。即生成佛或不成佛，完全要看你自己的精进如何。我的教派与别人不同，具有不共的加持力。’上师和颜悦色很亲切的对我说。
    “这样一来，我就非常的欢喜起来，即刻请求上师将造房子的图样给我。上师说：‘我的这个房子，要筑在一个险要的山上。可是这个地方，以前族人曾经议定不许在上面造房子；幸亏当时文约上我并没有署名，所以不必受他们的约束。我想在东方的山头上造一所圆形的房子，你也可以借此消除你的业障！’
    “我就这样奉了上师的命令，开始造起房子来。大约在房子做了差不多一半的时候，上师来了，对我说：‘前些时我没有想妥，这地方不大好，你现在把石头和材料都运回原地去吧！’我只得把石头木料，一块块的从山上背到山下。上师又带我到西方的山头去，把他的一件半月形的上衣，层层叠叠的摺起来，放在地上说：‘你就照这个样子替我起一个房子吧！’这一次真是非常费力，一个人造一所房子，每一件材料都要自己从几里路的山下背到山顶上，真是苦不堪言。等到盖了一半的时候，上师又来了，说道：‘这个房子看起来好象还是不对，请你把它拆掉；木头、石头和材料仍旧送回原地去吧！’我只得照上师的话办，一块一块的又把房子拆下来！
    “上师又带我到北方的山头上去，对我说：‘大力，那几天我喝醉了酒，没有说清楚；现在，在这里好好的给我修一所房子吧。’”
    “我说：‘修好了，又拆掉，我白吃苦，师傅白花钱，这一次要您老人家仔细的考虑考虑才好。’
    “‘我今天既未喝酒，而且已经充分的考虑过了；真言行者的房子是需要三角形的，你就盖一所三角形的房子吧！这一次当然我不会再叫你拆毁了！’我又重新开始造这个三角形的房子。等到做了三分之一的时候，上师又来啦！他说：‘大力！你现在做的房子，是谁叫你做的呀？’
    “我急了，马上回答道：‘这是上师你亲自吩咐的呀！’
    “上师搔了搔头说：‘嗯！我怎么想不起来呀！你说的话要是真的，我不是发了疯了吗？’
    “‘当时我就怕有这个样子的事发生，所以请您老人家仔细考虑。您老人家说已经充分的考虑过了，说一定不会再拆毁的，您应该记得清清楚楚的呀！’我急急地说。
    “‘哼！那时有什么证人在场吗？在这种坏风水的地方造三角形的房子，像修诛法的坛城，你是不是想来害我呀？我没有抢你的东西，更没有抢你老子的财产呀！你要是不打算害我，真正想求法的话，就应该听我的话赶快把这座房子拆掉，把木石材料搬回山下去！’
    “因为背石头，做苦工，做得太久，又因为每次都是急于想造好房子，可以求法，所以工作得太拼命，太厉害。那时，我背上的肉磨破了好几个洞，结了疤，疤又磨穿；磨穿了又长疤，痛苦难熬。我本来想给上师看，但是知道除了打骂之外，决不会有别的结果的；如果给师母看罢，又好象是故意诉苦似的，所以连师母也都没有告诉，只有请求师母帮忙向上师求法。师母马上就到上师面前说：‘这样无意义的做房子，不知道为的是什么？你看大力真可怜，苦死他了！赶快传他一个法吧！’
    “马尔巴上师说：‘你先去做一个好菜来给我吃，再给我把大力喊来！’师母准备好了食物，与我一起到上师面前来。上师对我说道：‘今天的我，不是昨天的我，不要那样呕气吧；你要求法，我就传给你好了！’说了之后，就把普通显教的三皈、五戒传给我了。上师说：‘现在传的不过是些普通的法要而已，如果想求不共（不共——显教密宗通用的术语，密乘用得尤多，意思是特别的，超胜的，他人所没有的）的秘密口诀，应该如此如此的做。’说着就把那诺巴上师苦行的传记讲给我听。又对我说：‘这样的苦行，恐怕你办不到吧！’那时我听了那诺巴上师苦行传记以后，感动得流泪，生起了坚固的信心。心里发誓说：‘上师的一切话，我都要听从；一切的苦行，我都要克服。’
    “过了几天，我跟上师一同出去散步，又走到族人禁止造屋的要隘地方。上师对我说：‘在这里给我造一所四方形的房子，要九层，上面再建一个库房，一共十层。这一次决不毁掉，房子盖好了，我传你口诀，修法的资粮我也供给你！’
    “我想了一想说：‘那么，我请师母来作证人，好不好？’
    “上师答应我的要求，说：‘好！’
    “上师画好了建筑图样，我就请师母来，在上师和师母前顶礼三次，说：‘上师命我盖房子，我起了三次，拆了三次，第一次是因为没想好；第二次呢，师傅您老人家说是喝醉了酒，没有计划好；第三次呵，师傅你说你是发疯了，怎么会要我盖三角形的房子？等我解说了以后呢，您老人家就又说谁是证人？大骂我一场。今天我要请师母为我这第四次盖房做个证人。师母，请您替我做一次证人可以吗？’
    “师母说：‘我一定替你做证人。上师！我要作确实的证人。但是这个做房子的计划，非常困难。这样高的山，一块石头，一根木料，都要你一个人从山下搬上来，不知道这个房子要修到哪一年才好呢！其实根本就用不着在这儿造房子，做了更用不着拆掉。这个地方不是我们自己的，族人大家都发过誓说不许在这里修房子，以后恐怕会有口舌纠纷的！’
    “我说：‘师母，上师他老人家恐怕不会听您的话啊！’
    “上师说：‘你要做证人就作证人好了，不要多嘴！’
    “于是我就开始建筑这个四方形的大堡了。在我替房子奠基的时候，上师的三个大弟子，卫地的俄东去多、多日地方的吐通网太、擦绒地方的麦通总波，他们游戏耍着帮忙，替我搬了很多的大石头来；我就用他们搬的这些石头作为基石的一部份。等到做好了两层房子的时候，马尔巴上师来了，他仔仔细细的到处看了一看，指着那些三大弟子搬运来的石头说：‘这些石头是哪里来的？’
    “‘这……这……是俄东、网太帮着我搬来的。’
    “马尔巴说：‘你不能拿他们的石头造房子，赶快把房子拆掉，把这些石头搬开！’
    “‘但是，您，您老人家已经发过誓，决不拆毁这个房子的啊！’
    “‘不错，我是说过的，但是我的弟子们，都是修无上二次第（二次第即‘生起’和‘圆满’次第，为无上密宗修法之根本）的瑜珈行者，不能叫他们做你的佣人。再者，我也不是叫你一起拆掉，只是要你把他们搬的石头搬回原处罢了！’
    “我无可奈何，只得又从顶上拆起，拆到基层，把那些石头从山上都背回山下原地去。上师又来了，对我说：‘现在你可以再把这些石头搬回去作基石了！’
    “我问：‘您不是不要这些石头吗？’
    “上师说：‘我不是不要这些石头，是要你自己搬石头，不能占人家的便宜。’
    “三个人搬的石头，我一个人来搬，当然用了很多的时间和气力。以后我搬的那些石头，大家就叫他们为‘大力石’。
    “当我在山顶上把屋基奠好了的时候，族人大家商量着说：‘马尔巴在禁地上造房子，我们去干涉去！’有个人说道：‘马尔巴发疯了，不知从哪里来了一个气力很大的青年。凡是高的山头，马尔巴就叫他在那里修房子，修了一半，又叫他毁掉，把木石材料又运回原处。这一次恐怕还是要毁掉的。等他不毁的时候，我们再去干涉不迟，我们且等一等，看他毁不毁！’
    “可是这次上师却并没有叫我毁房子。我继续的建筑房子，盖到了第七层的时候，我的腰上又磨了一个大疤洞了。
    “那时族人就聚议说：‘哼！这一次看样子像不会毁掉了，起先毁了几次，原来是想在这个地方盖房子；这次我们一定要把它毁掉！’于是集合人马冲到这个房堡中来。哪里知道上师变了许多化身，房堡的内外，早已满布着兵将。族人大为惊异，不知马尔巴是从那里请来这么多的兵将！这奇迹震慑住了来攻击的人们，大家都不敢妄动，反而礼拜磕头，向上师请求饶恕。以后他们也都变成了上师的施主。
    “那时擦绒的麦通总波正请求胜乐金刚（无上密宗主要本尊之一，亦为白教（口传派）修法之主尊）的灌顶，师母就说：‘这一次，你无论如何要受一次灌顶了！’我自己也想：‘我盖了这么多的房子，即使是一块石头、一箕土、一桶水或是一块泥，都没有人帮过忙，这一次上师一定会替我灌顶了！’
    “在灌顶的时候，我就礼拜了上师，坐在受法者的座位上。上师说道；‘大力！你灌顶的供养在哪里？’
    “‘上师跟我说过，修了房子之后就赐给我灌顶和口诀，所以现在我敢来向您求法。’
    “马尔巴上师说：‘你不过略略做了几天小房子而已，这决不能够得到我从印度苦行求来的灌顶和口诀；有供养，就拿来；如没有啊！就不要坐在密乘奥义的灌顶座上！’说完，劈！拍！就打了我两个嘴巴，一把抓住我的头发，往门外直拖，口中还怒气冲冲的说：‘滚出去！’
    “师母看见这个情形，过意不去，跑来安慰我说：‘上师他老人家常说：他从印度求来的法要，是为一切众生而求的；平常，就是一条狗走过他的面前，上师也要对它说法和回向的。但是上师对你，总是不如意，我也莫明其妙，不知道是什么缘故。但是请你千万莫要起邪见啊！’
    满腹说不出的委曲，绝望与悲哀交萦着，我心里痛苦已极。夜晚，我翻来覆去的想：还是自杀了吧！
    “第二天早上，上师来看我，说：‘大力，你现在暂时不要修房堡了，先替我做一所城楼形的大客店，要有十二根柱子的，旁边还有个客堂；造好了，我就传你灌顶和口诀。’于是我又从头奠房基，开始修造客店。师母常常拿些好吃的东西和酒给我，同时也常常很亲切的安慰我。
    “在大客店快要修好的时候，日多地方的错通网崖来求密集金刚（密集金刚是无上密宗的主要本尊之一）的大灌顶。
    “师母说：‘这一次，你无论如何非要受灌顶不成！’就给了我一口袋黄油、一匹毛布和一个小铜盘，做为供养的东西。我满心希望，欢喜地拿着供养物走进佛堂的求法座。
    “上师望着我说：‘你怎么又来了？你有什么灌顶的供养吗？’我心里很安定很有把握的说道：‘这些黄油、毛布和铜盘就是我给上师的供养。’
    “‘哈！哈！哈！你的话真妙！这个黄油是某甲施主供养给我的，毛布是某乙供养我的，铜盘是某丙施主供养我的。真妙！拿我的东西来供养我，天下有这种道理吗？你自己有供养就拿来，没有就不准坐在这里！’说着，立起身来，又将我大骂一场，用脚把我踢出佛堂来。我当时恨不得钻到地下去才好。苦苦的想了一阵：这是不是我放咒杀了很多人，降雹毁了很多收成的报应啊？也许是上师知道，我根本不是法器、不能受法的原故吗？还是上师不够慈悲、不肯授法给我呢？不管怎样，留着这个受不得法的，没有用的，充满了罪恶的人身，还不如死了好，还是自杀了罢！正在百思不解的时候，师母带了会供的食物来给我，竭力的安慰了我一阵。
    “失望与痛苦使我丝毫不想吃师母拿来的食物，哭了一整夜。第二天，上师又来了，说：‘现在把客店和房堡快点做好，一修竣工，我就传你正法和口诀。’
    我千辛万苦，好容易才把客店修好。那时，背上又磨破了一个洞，长了背疮。这个疮有三个脓头，腐肉伴着脓血，烂得像一团稀泥。
    “我就去请求师母说：‘现在客店已经修好了，恐怕上师又会忘记答应传法的事，所以特来请您帮我求法吧！’说着，因背疮痛得很历害，脸上止不住露出了很痛苦的样子。‘大力，你怎么啦！害病了么？’师母很是骇然的问。我只得把衣服脱掉，把背疮给师母看。师母一看，忍不住眼泪直流，马上就说：‘我要去告诉上师去！’立刻匆匆跑到上师面前说：‘上师啊！大力这样的造房子，手脚都伤了，皮肤也裂了；在背上还长了三个大背疮，又磨成三个洞，有一个疮还有三个眼孔，脓血模糊。以前只听说骡马驮东西驮得太重太久了才会长背疮；人长背疮还没有听见说过！更没有看见过！像这样的事，人家看见或是听见了，岂不要耻笑我们吗？上师！因为你老人家是一个大喇嘛，所以他才来服侍你的，起先你不是说造好了房堡就传他法吗？他实在太可怜了，现在请您传法给他吧！’上师说：‘说倒是这样说过的，不过我说的是要造十层楼，现在十层楼在哪儿呀？’
    “‘那个大客店不是比十层楼还要大吗？’
    “‘你不要东说西说的多嘴！修好了十层楼再传他法！’上师申斥师母，忽地又想起了我背上的疮：‘喂！你刚刚说什么？大力背上长了背疮吗？’
    “‘满背都是疮！请你自己去看看好了！脓血一团，烂得可怕，谁看见了也不忍心！唉！真可怜极了啊！’师母说。
    “上师马上跑到楼梯口上说：‘大力，到上面来！’
    “我想：咦！这回对了！一定要传法了！赶紧三步并作两步跑上了楼。上师说：‘大力！把背疮给我看看！’我就给他看。上师仔仔细细的看了一看说，‘至尊那诺巴，十二大苦行，十二小苦行，比你这个还要历害得多！大小种种二十四种苦行，他都忍受了。我自己也是不顾生命，不惜财产地来奉侍那诺巴上师。你若是真想求法，快不要这样故意做作，装做了不得的样子，赶快去把房堡做好吧！’
    “我低头仔细地想，上师的话实在不错。
    “上师就在我的衣服上做了几个盛东西用的口袋，并且说：‘马和驴子长了背疮，都用口袋装东西来驮，我现在也替你做几个口袋，好用来装土、装石头。’
    “我忍不住问：‘背上有疮，这东西有什么用处？’
    “上师说：‘有用！有用！口袋里装土，可以免得沙土粘上背疮！’我一想，这又是上师的吩咐，就又忍住疼痛运了七口袋的沙到山顶上去。
    “上师看见我对凡是他老人家所说的一切话，无不谨守奉行；知道我是百折不挠、难行能行的大丈夫，真令人感动和赞叹。在无人的地方，偷偷的也流下许多泪来。
    “背上的疮一天天的大了起来，渐渐地痛不可忍，我就告诉师母说：‘可否请您向上师说，最好是先传我法，或是至少请他让我休息休息，养一养疮伤。’
    “师母将我的话转禀给上师。上师的意思仍旧是：房子不做好，决不能传法的。如果疮实在需要调养，那就休息几天也好。师母也劝我调养一些时候，等疮好了再继续做工。
    “我养伤的一段时间，师母给了我很多好吃的和滋养的东西，更是常常来安慰我。我暂时把不能得到法的忧虑忘怀了一些。
    “这样休养了一阵，到背疮快要痊愈的那一天，上师又来叫我，却对传法的事情一字不提；他对我说：‘大力！现在马上造房子去！’
    “那时我原已经准备要去工作，可是师母为了同情我，安排要用计来请上师早日传我法。所以悄悄和我商量妥了，要装一次假。我从上师处出来后，就细声的哭泣着，装着收拾行李，带了些糌巴（西藏人民的日常主要食物，是一种炒熟的大麦粉）要走的模样；在上师看得见的地方，装着要走出去，师母就假装留我的样子，拉着我说：‘这一次我一定要求上师传法给你，不要走了！不要走了！’半晌，两个人拉拉扯扯地引起了上师的注意。上师叫师母道：‘达媚玛！你们俩在干吗？’
    “师母一听，以为机会到了，就说：‘这个大力徒儿，从远方来上师这儿求法，不唯学不到正法，反只落得打骂和作牛马的苦工。他现在怕求不到法就死了，所以要到别处去寻师了。我虽是保证他一定可求到法的，但是他好象还是要走的样子。’上师听了，怒气冲冲跑进房去拿了一根皮鞭子，跑出来照着我混身乱打，说：‘你这个混帐东西，起初你来的时候，把身口意都给我了，现在你还想往哪里走啊？我要高兴的话，就可把你的身、口、意割成千条万片，这是你给我的，所以我有这个权利。现在不管怎样，你要滚，就滚好了，为什么把我的糌巴拿走？这是什么道理？你说说看？’皮鞭子无情地一顿乱抽，把我打倒在地。上师又来把糌巴抢了过去。那时我心中真是难过已极，但又不能向上师说这是和师母商量好了的假圈套。无论怎样做作也抵不过上师的威力，只好跑进房去痛哭一场。师母也叹气说：‘唉！现在就是和上师扯皮拉筋，他也不会传法的。无论如何我要想法子传你一个法！我自己有一个‘金刚亥母’（‘金刚亥母’为密宗本尊之一，为表诠般若波罗密多自性之佛母）的修法，我传给你吧！’我依着这个法修，虽然未生觉受，但是心中觉得很安慰、很和平。我觉得师母对我太好了，总想报师母的恩。又想，因为上师和师母，我的罪业已净除了不少，我就决定再留下来。在夏天的时候，就帮师母挤牛奶、炒青稞。有时，我也的确想找别的上师去，但是仔细想了想，即生成佛的口诀，只有这个上师才有。今生若不成佛，我做了这么多罪业，如何解脱呢？为着求法，我要修那诺巴尊者一样的苦行，无论如何，要想方法使这个上师欢喜，得到他的口诀，即生证果。于是我就一心一意的背石头，搬木料，修筑大客店旁边的修定室。
    “卫地的俄东去多，和他的眷属，带了很多的供养来求‘喜金刚’的灌顶。师母就对我说：‘马尔巴只爱钱！像你这样的苦行修者，他就不传法给你，我替你去想法子办一份供养，无论如何要使你得个灌顶。你先把这个供养上去请求，若是还不传法的话，我再替你去求。’说着，师母就从自己的内衣里取出一块龙形玉的红宝石来给了我。我拿了这块鲜明放光的红宝石，走进佛堂，礼拜上师，把宝石供上，说道：‘这一次的灌顶，无论如何请您老人家慈悲传给我。’说完了就坐入受法座上了。
    “上师把红宝石转过来，转过去，看了又看，说道：‘大力，这个东西是哪里来的？’
    “‘这是师母给我的。’
    “上师微笑说：‘把达媚玛喊来！’
    “师母来了，上师就问：‘达媚玛！这个红宝石是怎么得来的呢？’
    “师母磕了头又磕头，战战兢兢的说：‘这个宝石原来与上师没有关系。我的父母在我出嫁的时候对我说，上人的脾气好象不好，假使以后生活发生困难的时候，是要钱的，所以就给了我这个宝石，叫我不要给人家看见。这是我秘密的财产，但是现在这个徒弟实在是太可怜了，所以我把这个宝石给了他。请上师接受这个宝石，开恩传授大力的灌顶。从前你屡次在灌顶的时候把他赶出去，使他非常失望。这一次，请俄巴喇嘛及大众徒弟帮我，一同请求上师。’说完了，磕头又磕头。
    “但是上师面带怒容，俄巴喇嘛和大家一句话都不敢说，只是和太太一起礼拜向上师请求。上师说：‘达媚玛！你作这样糊涂事情，把这样好的宝石给人家，哼！’说着就把宝石戴在头上说：“‘达媚玛！你想错了，你的一切都是我的，这个宝石也是我的！大力！你有财产就拿来，我就给你灌顶！这个宝石是我的东西！不能算是你的供养。’
    “但是，我想，师母一定会再三说明供养宝石的原因的，大家也都在替我求，所以我还等着，老脸皮厚的不肯走。
    “上师大怒，从座上一跃跳下，大骂我说：‘叫你滚出去，你不滚出去，是什么道理？’提起脚，在我身上乱踢。我的头俯着地的时候，他把脚踏在我的头上，昏暗得像天黑了一样。一下子又用脚把我踢翻，头突然仰面过来，就象天忽然发亮，金星乱冒。乱踢了之后，又拿起鞭子，大打我一顿。俄巴喇嘛来劝止上师的时候，上师那个样子真是可怕极了。在大厅里，跳来跳去，他的愤怒威势真是达到极点了！我想，除了痛苦以外，什么都得不到，还是自杀了吧！正在痛哭的时候，师母满眼含泪的来安慰我说：‘大力啊！不要伤心啊！比你更好的徒弟，世界上再也找不着了。假定你要找别的喇嘛去，我一定替你介绍，学法的费用和上师的供养我都会给你的啊！’照例，师母必定要参加会供轮的，但是那一次，我哭了一夜，师母也就陪了我一夜。
    “第二天早上，上师派人来喊我去，我以为是传法，又跑去了。上师说：‘昨天没有给你灌顶，你心里不高兴吗？起了邪见没有？’
    “我说：‘我对上师的信心毫未动摇。我想了很久，这是我的罪太大的原故，心里伤心得很。我一面说一面哭。上师说：‘在我面前哭，而不忏悔，是什么道理！滚出去！’
    “我出来之后，好象得了神经病症一样，心神痛苦万分。我心中想到：‘真奇怪！我造罪的时候，学费也有，供养也有。怎么学法的时候，学费也没有了，供养也没有了，穷得变成这个样子。只要有造罪时候的一半的金钱，也就可以得到灌顶和口诀了。现在这个上师没有供养物是不会传我口诀的，到别处去也没有供养物，有什么用！无财则不能得法，与其将无法的人身来集聚罪业，不如自杀了罢！唉！到底怎样好呢？’这样东想西想，胡思乱想，结论是：求财第一！那么去替有钱人家当差，贮一点工钱来作求法的资粮好吗？还是作恶事放咒术来找钱呢？还是索性回家乡去吧！看见母亲多么高兴啊！回家乡倒好，就是不一定能找到钱！唉！不管怎样，求法也好，求财也好，总要求得一样，在这里总不是办法。于是决定离开。又因为拿一点上师的东西，就只有挨打挨骂，所以连一点食物都没有带，只拿着自己的书物就走了。
    “走在路上，想起了师母的恩德，心中很难过。我走到离扎绒只有半日路程的时候，已是中午要吃午饭的时候了。我就讨了点糌巴吃。又向人家借了一个锅，在外面草地上烧起火来，烧了点水喝。过了半天，我心里想：我在上师处做的工作，虽然一半是为服侍上师，一半也是自己吃饭的工钱；安慰我内心的精神食粮，有师母的慈爱。师母待我这样好，今天早上，我却没有向师母辞行，不说一声就走了，实在岂有此理。自己这样一想，就想回去了，但是却没有勇气。等到我去交还水锅的时候，那个主人老头子对我说：‘年纪青青的，什么事不好做，要来讨饭吃？你要是识字，就可以替人念经；不识字，替人做工也可以混到衣食的啊！喂！小伙子，你识字不识字啊？会不会念经呢？’
    “‘我虽然不常念经，但会却是会的！’
    “‘那么，正巧极了，我正要请人念经，就请你替我念五、六天经吧！我会给你供养的！’
    “我欢欢喜喜地说：‘好！’
    “于是我就在老者的家里念《般若八千颂》。经中述说着有一个名叫常啼菩萨的故事。那位常啼大菩萨跟我一样穷，但是他为了求法，连生命都不顾。人人都知道，把心挖出来是只有死的；但是他为了求法，仍旧毅然把心挖出来。跟我比起来，我这点苦头，真算不得是苦行了！于是我想，上师也许会传法的，不传也不要紧，师母不是说过介绍我给别的喇嘛吗？这样一想，于是我又动身回去了。
    “在上师那一方面，等我走了以后，师母就对上师说：‘您老人家把一个无比的仇人赶走啦！他不在这儿了，现在你该快活了吧！’
    “马尔巴上师说：‘你说的是谁啊？’
    “‘你还不知道吗？就是那个你见了跟仇人一样的，专给他苦吃的大力呀！’
    “上师一听，脸色马上变成青白，泪如雨下，合掌祈祷道：‘口授传承的历代上师啊！空行及护法啊！请使我那宿善的好弟子回来啊！’说完了，默然无言。
    “我回去之后，先去顶礼师母，师母非常欢喜说：‘啊呀！这一下我放心了，上师这一次恐怕要传给你法了。当我告诉他，说你走了，他老人家喊着说：‘使我宿善的好弟子回来啊！’他连眼泪都流了出来了！大力！你已经把上师的慈悲心引出来了！’我心里想：这不过是师母安慰我的话罢了；假使是真的流眼泪，而又叫我为宿善的弟子，那当然是满意我的表现，不然只是说：把他喊回来，而仍不给灌顶和口诀，那么我这个所谓‘宿善’也是最下的。我如果不到别的地方去，痛苦又会找上身上来的！正在这样暗自思量的时候，师母就告诉上师说：‘大力不肯舍弃我们，他又回来了！叫他到你面前来顶礼好不好！’
    “马尔巴上师说：‘哼！他倒不是不肯舍弃我们，他是不肯舍弃自己！’
    “我去顶礼的时候，上师就说：‘你不能性急，不能胡思乱想，要是至心求法的话，应该为法舍弃性命。去替我做一间三层楼的房子，做好了就给你灌顶。我的粮食也不多，也不能让人白吃的。你要是心里想不过，要出去旅行，随时你都可以走的！’
    “我一句话也说不出，就出来了。
    “我跑到师母那里，对师母说：‘我很想我的母亲，上师又不肯传法给我。他仍说把房子盖好了再传法，可是等到房子真的盖好了，又是决不肯传，还要打骂。我决定回家乡去了，愿上师和师母两位老人家，平安无事，百事吉祥。’说完了，卷起行囊就准备走路。
    “师母说：‘大力呀！你说的话不错。我一定帮你去找一个好上师。俄巴喇嘛是上师的大徒弟，他是得了口诀的，我要想一个办法把你送到他那里去学法，你先不要忙，暂时住几天。’于是我就没有走。
    “至尊大梵学者那诺巴上师，每月初十，一定要举行广大的会供轮（即每月举行一次的集会，密乘修行人在这种集会时供养诸佛、念诵仪轨）。承继这个规则，马尔巴上师也经常在每月初十行会供。那一天，又是初十，照例修会供轮，师母用了一大口袋麦子，酿了三种酒：一种是浓酒，一种是淡的，一种是中平的。师母请上师多喝浓酒，其余的喇嘛喝中平的酒，我跟师母就喝淡酒，而且只是装样子略略的沾了一点。那天敬酒的很多，喇嘛们都喝得醉倒了。上师也喝醉了。等到上师醉意朦胧的时候，师母就偷偷的走进上师的寝室里去，从上师的手提小箱内拿出了上师的图章和印件，和那诺巴大师的身庄严（身庄严即上师身上所用的饰物）及红宝石印。师母把早就准备好了的一封假信拿出来，偷盖了上师的印，把印悄悄的仍旧放回箱子里。把假信、红宝石和身庄严用美丽的布包着，用蜡封了口，交给我。对我说：‘你说这是上师送给你作为供养俄巴喇嘛的，现在你赶快到俄巴喇嘛处去。’
    “我叩别了师母，带着信件就动身到卫地去。过了两天之后，上师问师母说：‘现在大力在做什么事？’
    “‘他走了！别的我都不知道！’
    “‘他到哪里去了？’
    “‘他那样苦苦的做房子，您不但不传法，还要打他骂他。他现在走了，去找别的上师去了。他本来想告诉您的，但是又怕您老人家打他，所以没敢告诉您就走了，无论怎样我也留不住他。’
    “师母说完之后，马尔巴上师的脸马上就变青了，问道：‘他哪天走的呀？’
    “‘昨天走的！’
    “上师默然思维了一下说：‘我的徒弟不会走远的！’
    “我走到卫地孔庆山的时候，俄巴上师正在与许多喇嘛讲‘喜金刚本续’。正讲到：
    “‘说法是我法亦我，听法诸众亦是我，我为成就世界主；世出世间亦为我，我即俱生欢喜大自在。’
    “正讲到这里的时候，我就在远远的地方向俄巴上师礼拜，上师就脱帽答礼说：‘这是马尔巴学人礼拜姿势，修法的缘起很好，将来这个人当成就为一切法之王。你们去看看，是哪一位？’一个比丘跑过来看我，他原是认识我的，就说：‘哦！原来是你！你为什么到这里来呀？’
    “我告诉他：‘因为马尔巴上师非常忙，没有时间给我传法，所以到这里来请法的。马尔巴上师叫我带那诺巴的身庄严和红宝石的印章，作为许可求法的凭证。’
    “那个比丘就跑回去跟俄巴上师说：‘大力来了！’又一五一十的把我的话说了一遍。
    “俄巴上师非常欢喜的说：‘上师那诺巴的身庄严和玉印到我这里来，真如优钵昙花开，甚是难得希有，不可思议！我们应当恭敬迎接。现在暂时停止说法，你们听众快点到庙里去把华盖、胜幢、庄严、乐具等拿出来；再叫大力在外面稍为等一下。’
    “那个比丘就叫我在外面等候片时。后来我顶礼的这块地方就被叫做‘礼拜岗’。
    “不一会儿，在华盖宝幢和音乐齐奏的盛大欢迎中，大众拥着我进了大殿。顶礼完毕，供养了礼物；俄巴上师流着泪把身庄严顶戴在头上；祈请加持之后，把它放在坛城的中央，又用各种胜品妙物围绕供养者。然后方拆开我带来的书信，信上说：
    “‘俄巴法身金刚知悉，余正闭关入定，无暇教导大力，故令彼来汝处求法，汝应予以灌顶及口诀。兹赠汝那诺巴大师身庄严及红宝石以表印可。’
    “俄巴喇嘛看完了信，对我说：‘这是上师的命令，灌顶和口诀无论如何要传给你。我很久以前就想要叫你来我这里学法；这次你自己来了，真是上师的恩惠。’说到这里，忽然停顿了一下，又说：‘啊！大力！我想起来了！雅绒、恰抗和打开通这些地方，时常有很多喇嘛要到我这里来，但是多雅波地方的那些坏蛋，总不让他们供养我。你先去向他们降雹，然后我就传你灌顶和口诀。’
    “我听了心中一惊，暗想：我真是个罪恶深重的人啊！每到一个地方就要作恶！我到这里来原不是为了降雹害人，而是为学正法才来的；没料到一来就又要造罪。设若不去降雹，就违背了上师的意旨，不用说，法一定也是求不到的了；倘若真去降雹，那就又要造一次罪过。唉！只好还是遵照师傅的吩咐去再降一次雹吧！
    “我无法，只得准备了修法的材料，以真言加持后，带到了多雅波村中。刚修完了法，在冰雹将要降下来的时候，为了要躲冰雹，我赶忙地找到了一个老婆子家里去借宿。一霎时，空中雷电交作，黑云层层的奔驰而来。在大冰雹还未来，先头的一阵小冰雹降下的时候，那个老婆子就哭着说：‘天啊！冰弹子把我的麦子打了，以后我拿什么来生活啊！’
    “老婆子的话又令我的苦恼涌上了心头：‘唉！我真是做大罪恶的人哟！’就向老婆子说：‘老婆婆，你的田在哪里？是什么样子？快画一个图给我看！’老婆婆说：‘我的田是这样的！’就画了一个像长嘴唇皮一样的三角形。我立刻结了‘指示印’，用一个锅盖在那三角形的图上。老婆子的田因此而得了保全，没有被冰雹损坏。但是有一小块角落，因为没有盖好，所以那一小块地的收成就被一阵狂风暴雨吹得无影无踪了。半晌，冰雹停止了，我跑出屋去一看，两个村子的山上都发生了大洪水，把所有的田都冲得一点不剩。只有老婆子的田无多损害，禾苗依然欣欣向荣。却也奇怪，以后任何降雹的时候，这块田总是不落冰雹。这个老婆子也就再不用出钱去请喇嘛修法防雹了。
    “我在归途中，遇见两个老牧羊人，他们的牛羊都给大水冲跑了，我对他们说：‘今后不要再抢俄巴喇嘛的弟子了，要是还要再抢的话，我会再来降雹的！’
    “受了这次的威吓，果然这两处地方的人再也不敢抢劫，并且慢慢地都向俄巴上师生起了信心与恭敬，变成俄巴上师的檀越了。
    “我在一块长满荆棘的草地上，拾集了很多小鸟的尸体和很多被冰雹打死的山鼠。我用衣服把这些尸体包好，装了满满的一包，背了回来。回到庙中，一见上师，我就把这一大堆鸟兽的尸体堆在上师的面前说：‘上师老人家啊！我是来求正法的，谁知又做了恶业，请上师慈悲看看我这个大罪人吧！’说着就唏嘘痛哭起来。
    “俄巴上师很安祥地说：‘大力！用不着害怕，那诺巴、梅纪巴的法统加持，能令大罪人于清净法性中超度解脱。于一刹那间令几百鸟兽皆能得度的口诀，我是有的！这一次给冰雹所打死的一切众生，未来在你成佛时，都将往生你的净土为听法的第一会众。这些众生在未能往生之前，靠我的力量，可以不堕恶趣；若是不信，你看！’上师静思片刻，于一弹指顷，一切鸟兽的尸体，都苏醒复生，忽然间都动转起来，走的走，飞的飞，都跑掉了。
    “我看见这样希奇殊胜的真实道行，心中无限的欢喜与羡慕，倒悔恨当时杀得太少了，否则岂不是可以多度一些众生吗！
    “于是俄巴喇嘛就传法给我，在喜金刚的坛城中得了大灌顶和口诀。
    “我找到一个古老的崖洞，崖洞的入口朝向南方，从洞口处可以看见上师的住宅。我把崖洞略事修补，就开始在洞内精进思维上师所传的法。但是因为马尔巴上师没有印可，所以我虽然努力修习，仍是毫无解证效验。
    “一天，俄巴上师来问道：‘大力！你早就该有如是如是的觉受了，你现在怎么样啦？’
    “‘我什么觉受都没有！’
    “‘什么？你说什么？在我这个法统传承之内，若是戒律没有毁犯，觉受证解的功德，没有不马上成就的；何况你又是相信我才来的！’上师又沉思了一忽儿，接着又仿佛是自语：‘若是没有马尔巴上师的许可，他不会给我许可的表记呀！咦！真奇怪，这是什么道理呢？’然后又对我说：‘你再试着好好的精进思维吧！’
    “上师的话使我心里非常恐怖，可是又不敢说出这事的原委，就心中盘算着：无论如何要得马尔巴上师的许可才是，一面则仍旧精进不懈努力的修持。
    “那时，马尔巴上师替他的儿子起了一所住屋，写了一封信给俄巴喇嘛说：‘余子住宅，现需木材，汝处所出产之杉木可尽量送来。房屋筑成后，将诵《大般若经》，并举行庆祝典礼。尔时，汝应前来参加。大力是恶人，现时谅必仍在汝处，携之同来可也。　　马尔巴字’
    “俄巴喇嘛就把信拿到我这里来，对我说：‘上师信上为什么称你为恶人呢？这究竟是怎么回事啊？看起来恐怕你没有得到上师的许可吧！’
    “我只得照实地说：‘是的！我并没有得到上师自己真正的许可，信和那些送给你的东西，都是师母给我的！’
    “‘哦！哦！原来如此啊！那么我们两人都做了一件无意义的事情了。不得上师的许可生不起功德，是当然的。唉！那也是没有办法的事！他要你与我一齐去呢！’
    “我说：‘好吧！我也只有去！’
    “‘那么，等我送了木料以后，选个好日子去吧。现在你还是可以继续在这里修定。’俄巴喇嘛很慈祥地对我说。
    “过了几天，俄巴喇嘛这里的人都知道我快要走了，于是都跑来我这里闲谈，谈些庆祝新宅和庆祝马尔巴儿子成年的事情。其中有一个刚从马尔巴上师处回来的喇嘛，过来找我，我就问他：‘他们有没有问起我在做什么事情啊？’那个喇嘛说：‘师母曾经问我：我的大力在做什么事啊？我就告诉她：你正在修定。师母又问：除了修定之外，他还做什么别的事情没有？我说：他只是一个人住在无人的崖洞里静坐。师母说：他忘记把这个东西拿去了。他在我这里的时候，只喜欢玩这个东西，请你带给他罢！说着就把这几个土做的骰子给了我。’喇嘛当时就把带来的骰子交给我。我手里摸着骰子，心里不由地便想着师母。
    “那个喇嘛走了以后，我玩弄着骰子，心中暗想道：我从来没有在师母面前玩过骰子，为什么师母说我只喜欢玩这个东西，是不是师母不喜欢我了呢？我又想起我的祖父为了几个骰子才流落在外。东想西想，忽然一不留神，骰子掉在地跌碎了，碎成两片，中间有一张小纸片露了出来。拿起来一看，上面写着：‘徒儿！上师会传给你灌顶和口诀，请你跟着俄巴喇嘛一起回来吧！’我看完信，欣喜极了，就在洞中喜得东转西转的乱跑。过了几天，俄巴喇嘛对我说：‘大力！你也要准备动身了！’
    “俄巴喇嘛除了留下马尔巴上师所赐给的加持品之外，把一切佛像、经典、法器、铃杵和一切黄金、玉石、绸缎衣着、日用品等一切的一切都一起带走；只留下一条跛足的老山羊。这条跛山羊，不但年老，而且性情怪僻，从来不肯与别的羊在一块儿走，所以只好留下。其余所有内外全部的财产，都准备一齐供养马尔巴上师。
    “俄巴喇嘛给了我一匹绸子，对我说：‘你是个好弟子，你把这匹绸子拿去，做拜见马尔巴上师的礼物好了。’
    “俄巴上师的太太，也给了我一口袋的酥油点心，对我说：‘你拿这个去供养达媚玛师母吧！’
    “带了俄巴上师和师母给的东西，我就和俄巴喇嘛大众动身了。快要到罗扎乌谷的时候，俄巴上师就说：‘大力，你先去告诉师母，说我们来了，看看能不能给我一杯酒喝！’我就奉命先去了。见到了师母，把一口袋的酥油点心供上，说：‘俄巴喇嘛来了，请你给他一杯欢迎酒喝。’
    “师母见了我非常欢喜，说道：‘上师现在正在睡房里，你去向他说一说吧！’我心惊胆战的走进上师的寝室。上师正在床上面向东方入定。我就对上师礼拜，把一匹绸子供上。上师不看我，把头转到了西方去；我又走到西方，再礼拜，上师又掉转头向南方去。我只有说：“上师，您老人家为着谴责我，不受礼拜。”但是俄巴喇嘛带着身、口、意及其一切所有，金、银、玉石、牲畜，及其他财产来供养您老人家，他希望您赐一杯欢迎酒，请您发一发慈悲满他的愿！’马尔巴上师听了立刻示现出大我慢相，弹指一鸣，用愤怒而可怕的声音说：‘当我从印度把不可思义的三藏秘密、四乘心要、殊胜的口诀带回西藏的时候，前来欢迎我的连一个老鼠都没有，现在他是什么东西！把他那一点财产拿来，就要我这个大译师去欢迎他！还是不要来的好！马上给我滚回去！’
    “我退出房来，把上师的话告诉师母。师母说：‘上师的脾气实在太坏了！俄巴喇嘛是个了不起的人物，我们应该欢迎的，我们母子二人去迎接吧！’我说：‘俄巴喇嘛不敢希望上师父母亲自迎接，只希望给他一杯酒就够了。’
    “但师母说：‘嗯！不不！我还是要去！’就带了几个喇嘛，拿了很多酒，一起去迎接了。
    “开庆祝会的时候，罗扎乌谷三村的大众，都聚集在一起，大开酒宴，庆祝马尔巴上师的儿子成年和新宅完成。在酒筵前，马尔巴上师唱了一首吉祥歌：
    祈请承恩上师前，我此法统真堪宝；
    无坏无漏吉祥好，愿更光大添吉祥。
    殷勤为向上师祷，法广且隆吉祥添；
    不毁不堕不倾倒，吉祥充溢误谬少。
    捷径能通无上道，但愿吉祥与时增；
    吾道光明如云兴，我乃译师马尔巴。
    愿以深广身口意，祝此吉祥无有涯；
    惟望吉祥日日加，上师本尊与空行；
    加持成就吉祥盛，愿更光大添吉祥。
    徒众眷属蔚成行，如子如女在一堂；
    信心净戒起芬芳，吉祥光大叹无疆。
    施主乡人与亲戚，结缘集善福来赐；
    一切事业与行为，利生成佛交相期；
    愿更光大吉祥添。天神鬼众遍三有，
    威猛勇断吉祥厚，愿更光大吉祥添。
    胜哉此会集人天，庆喜福德兆绵绵；
    愿更光大吉祥添。
    “马尔巴上师唱完了吉祥歌之后，俄巴喇嘛就把所有的东西供上，说道：‘上师啊！我的身、口、意一切都是属于您老人家的。这一次来，家里只剩下一只跛足的老母山羊；她是羊群的祖母，但是因为老得不堪，又是跛脚，所以才把她留下了。除此之外，我所有的一切都带了来，都供养给上师。请您传我深远殊胜的灌顶与口诀；特别希望您传我耳承派（这派的传法极端秘密，由上师亲口传授口诀，弟子亲聆耳承，所以叫做耳承派）的奥义口诀！’说完又向上师礼拜。
    “马尔巴上师欢笑的说道：‘哦！哦！深远殊胜的灌顶和口诀，乃金刚乘的捷径，依此口诀，无须旷劫修行，此身即可成佛，乃一切口诀中的特别口授。为上师、空行之所付嘱。你既是要求法，你那个母羊虽是又老又跛，不拿来仍是不能称为全体供养的。我这口诀还是不能传给你的，别的法我早都已经传给你了！’说完了，大众都一起哈哈大笑起来。
    “俄巴喇嘛说：‘把这个老母羊供养了以后，您老人家肯传我法吗？’马尔巴上师说：‘要你亲自去拿来，我就传！’
    “第二天散会以后，俄巴喇嘛就一个人跑回去，把母羊背回来供养给上师。马尔巴上师非常欢喜的说：‘所谓秘密真言乘的学人，就是要像你这样的弟子。其实，一匹老山羊，对我有什么用呢？不过为了奉法和重法的原故，这样做，是必需的！’后来马尔巴上师就传了他灌顶和口诀。
    “过了几天，远方来了几个喇嘛，和上师这里的少数几个人，大家都集合起来，正在做会供轮。马尔巴上师在自己身边放了一根很长的旃檀木的棍子，眼睛张得大大的瞪着俄巴喇嘛，手结忿怒印，声色俱厉的说：‘俄顿琼巴！你对闻喜这个恶人，传给他灌顶及口诀，理由何在？’一边说着，一边瞧着身边的棍子，手也慢慢的伸过去拿那根棍子。俄巴喇嘛吓得发抖，一面磕头一面说：‘是您老人家给了我一封信，许可我传法给闻喜。同时又赐给我那诺巴大师的身庄严和红宝石玉印；我之传法与大力是奉命行事的。还要请您老人家原谅！’说了之后，吓得东张西望，不知怎样才能使上师息怒。
    “上师以忿怒的威吓印指着我说：‘你这个混帐东西！这些都是从哪里来的？’那时，我心里痛得跟刀割一般。因为过于恐怖，混身颤栗，话都几乎说不出来了！战抖抖的勉强说道：‘那……那……那是师母给我的！’上师一听，一下子就从座上跳下来，拿起木棍就去打师母。师母早就知道这件事会发生的，所以远远的站在外面，她一见情势不好，拔腿就往房里跑；跑进房，‘八达’一声把房门关上了。上师一面咆哮着，一面追过去，用棍子狠狠的打门；打了半天才回到座上来，说道：‘俄顿琼巴！做了这种不合道理事情的你！赶快去把那诺巴大师的身庄严和玉印拿来！’一面说一面摇头吁气，大发雷霆。俄巴喇嘛急忙磕头，马上就去取玉印和身庄严。
    “这时我和师母一起跑到外面，看见俄巴喇嘛出来了，就哭着对他说：‘将来求你引导我！’俄巴喇嘛说：‘没有上师的允许，我来引导你，是会跟这次一样的。对于我们两人都没有益处。所以还是要请你住在这里，等你得到上师的加持许可之后，无论如何我是要帮助你的！’
    “我就说：‘我的罪障很重，上师和师母都为我受这样的痛苦，今生此世不能修法成就，还是自杀了吧！’就拔出小刀来自杀（藏人多随身佩带小刀）。俄巴喇嘛一把抱住了我，眼泪不住流着说道：‘啊！大力，我的朋友啊！莫要这样做啊！世尊教法的究竟，是秘密金刚乘。金刚乘的教义说：自身的蕴、界、处，就是佛陀，在寿命未终的时候，即使行转识法（六种成就法之一种，为密宗修净土之方便，此法成就可得生死自在），都有杀佛之罪。世上再没有比自杀更大的罪了。就是在显教中也说：没有比自断生命更重的罪了。你要好好的想想，放弃自杀的念头吧！上师也许会传法给你的；就是不传也不要紧，向别的喇嘛去请法也是可以的。’正说的时候，所有大众喇嘛都对我表示同情，有的来安慰我，有的到上师处看有没请求传法的机会。那时我的心大概是铁做成的吧，不然一定会痛碎了的！我密勒日巴半生积罪如山，为求正法便受了这样的大痛苦！”


依止上师修法

    尊者说完之后，听法的大众中，没有人不在流泪；有的生起厌世和出离的心，有的听了悲伤过度竟晕倒了！
    惹琼巴就向密勒日巴尊者道：“上师尊者！马尔巴上师最后是以什么因缘传法给您，加持于您的呀？”
    密勒日巴说：“我想自杀的时候，喇嘛们跑上跑下的劝我，求上师。一会儿，马尔巴上师心情平息下来了，说道：‘哦！喊达媚玛来！’师母来了以后，上师问道：‘俄巴法身金刚他们到哪里去了？’
    “师母说：‘俄巴上人因为您老人家的命令去取那诺巴的身庄严和玉印，走到门外的时候，正遇见大力要自杀，求俄巴上人在他死了以后超度他。他们现在都在劝解大力呢。’
    “上师听了，两眼禁不住流下泪来，说道：‘这样好的弟子！将秘密真言乘学人所应具的条件都具足了，真是可怜悯。你把他们都喊进来吧！’一个徒弟就跑过来请俄巴喇嘛说：‘现在上师已经心平气和了，派我来请您老人家和大力一同进去！’
    “我听了这话，情急起来，抢着说：‘我去怕没有人欢喜吧！像我这样一个罪人，就是上师心情平静了，也不配到他的面前去；即使硬着头皮去，恐怕也只有被打骂的份儿而已！’说完仍是不止地痛哭。俄巴上师就对那个徒弟说道：‘你把大力的话去告诉上师，看大力能不能到上师的面前去。我要在这儿照护他，不然也许又会出什么意外的事呢！’这个徒弟就跑回去一五一十的告诉了马尔巴上师。师母也跟了一同进去。
    “上师说：‘他说的话，照以前的情形倒是真的；不过现在不同了，他用不着再害怕了。这一次，大力将是我招待的主客。达媚玛！你去喊他来吧！’师母万分欢喜地来对我说：‘上师对你起了最深的怜悯心！这一次将招待你作主客，叫我喊你去！你要知道，他并没有骂我哩。你快高高兴兴的去吧！’我信疑参半，不能相信自己的耳朵，就在糊里糊涂的当中走进房子里去。
    “大家就坐以后，上师说：‘照过去的事看起来，我们谁也没有错。我为了要清净大力的罪业，所以故意给他苦行，又叫他修房子，这样方得由清净道，净除其罪业；现在已经完成，所以我并没有错。达媚玛是个女人，心肠太软、太慈悲，难怪她；可是假做印信，却铸了一件大错。俄巴也没有错，但是先要把身庄严和玉石交还给我，我以后再给你。至于大力，他因为求法心切，用尽一切方法想得法，也实在难怪他。这一次，俄巴不知道是达媚玛所造的假信，便传给了大力口诀和灌顶。因此，我再没有办法给他痛苦，所以大发怒火，你们的请求我都不听。但是你们要知道，这种发怒与世间一般人的发怒是不相同的，过去任何表现出来的事情，都是为了法的缘故，其自性皆随顺于菩提道（即是和佛法的精神和教义相符合相应的意思）。你们不懂得解脱方便的人，不要起邪见！再者，我的这个儿子大力，如果能受九次的大痛苦、大磨折，他将不受后有（即是不再转入六道轮回的意思）；不尽此蕴，便可任运即身成佛。现在未能如此，还有一点点剩余的罪业，这完全是达媚玛女人心软的原故。话虽如此，但是他大部的罪业都已于八次的大苦行和无数的小苦行中根本清净了。从今以后，我要加持他，传给他灌顶和口诀，传授与他我最秘密的心要口诀，还要给他修行的资粮，帮助他一切修行的助缘，让他好好的修行。大力！你现在可以真的欢喜了！’
    “那个时候，我暗想：‘这是梦呢？还是真的呢？如果是梦，我希望永久都不要醒啊！’心里生起了无量的喜悦，欢喜的眼泪直涌如泉，一边哭一边向上师礼拜。师母、俄巴喇嘛及与会的一切大众，有的想：上师根绝罪业的方便真是善巧啊！有的想：上师的加持慈悲真大啊！有的则想：上师真是与佛陀无分别啊！师母和俄巴上人都怜悯我，为我欢喜，双眼流泪，替我向上师顶礼说：‘实在感谢您老人家！’于是大家都在欢笑与眼泪中修完了会供轮。
    “那天夜晚，大家聚集起来，作完会供之后，上师说：‘我替大家都授别解脱戒（别解脱戒是大、中、小三乘及显教密宗佛法共通的戒，使身心清净遮止恶行，最根本的戒律）。’就为我剃发净身。上师对我说道：‘你的名字，在我与你初见面的时候，就取好了。我梦见那诺巴上师为你起名，叫做密勒金刚幢。’于是就以此为我的法名，为我授了居士戒和菩萨戒。
    “上师对内供天灵盖（天灵盖是密乘修持所用的一种法器），作究竟心意之加持后，天灵盖忽然大放五色光明，与会大众都看见了。将加持之甘露上供祖师及诸佛后，马尔巴上师自己取饮甘露，然后把甘露给我，我接过来一饮而尽。上师说道：‘缘起真好！’
    “‘我的内供比其他传承的正式四灌顶（瓶灌、密灌、慧灌、大手印灌，此四者为无上密宗之四部灌顶，摄一切密法尽）更为殊胜，明天早晨，我再为你授灌顶！’上师又说。
    “第二天早晨，建立胜乐六十二本尊的大曼陀罗，传授灌顶。在开显坛城的时候，上师指着表图坛城说：‘这是人间颜料绘成的表相坛城，真正的坛城，你们看！’说着，手指虚空，一弹指间，空中显出具德总集轮（具德总集轮为上乐金刚的别名）二十四胜处、三十二胜境、八大尸林。空行大众，环翔围绕。尔时，上师及所有诸佛圣众同声说道：‘为汝取名为喜笑金刚。’
    “上师复为我广说秘密本续（本续——密宗的经典通称为‘续’Tantra），指示我观法和密修的口诀；又把手放在我的顶上说：‘儿啊！你初来的时候，我就知道你是有根器的弟子；你到我这里来的前一夜，我做了一个梦：这个梦兆，表示出你在佛法上将有广大的事业。达媚玛也作了一个同样的梦，那是守庙的护法空行的显示。因此，你是上师、空行母带给我的弟子，所以我才装作耕田的样子来迎接你的。
    “‘你把我给你的酒都喝完了，把田耕得一点不剩，这是你将领受口诀成为法器，达到圆满大觉的征兆。后来，你供养了我一个有四个柄的铜钵，这是表示你将成为我四大弟子之一。铜钵上毫无一点破隙，表示你烦恼垢轻，身享‘拙火定’大暖乐的征兆。你用空钵来供养我，表示将来在你修行的时候，会有食物困难，遭受饥饿的痛苦。我为了使你的后半生与你的弟子法统得大受用的原故，又为了使有根器的弟子依着口诀的精要生起喜乐的原故，我就装满酥油在空钵中，燃成明灯。为着使你生起广大的名声，所以我敲铜钵让它发声。为着净除你的罪业，所以我叫你来建筑息、憎、怀、诛的房屋。我把你从灌顶的会座中赶出去，又做了很多不合情理的事情，可是你不起丝毫的邪见；这表示将来你的弟子和法统，学道时能具足信心、精进、智慧、慈悲等一切弟子应具的条件。修道之时，皆能于此生无大贪着，有忍苦精进修行的毅力；最后生起觉受证解，具足慈悲和加持，成为圆满具相的上师。我此口授传承法统将会发扬光大，如月轮增长，光辉无限。儿呀！你要高兴啊！’
    “这样为我授记、鼓励、安慰和赞叹。我从此以后，就踏上修正法的幸福之途了。”

    惹琼巴又问道：“尊者，您得了口诀之后，是立刻就到山里去修行呢？还是仍旧住在马尔巴上师那里？”
    密勒日巴说：“上师叫我就在他跟前宽心的修行，又给我准备了很好的衣食，让我到近处罗扎乌村的卧虎崖洞去修定。
    “我在洞中修定的时候，点了一盏酥油灯在头顶上；灯不点完，身体不动，也不下座。这样终日终夜的修定，过了十一个月。
    “一天，上师和师母带了会供轮（每月一定的节日或者有灌顶等特别法会时，密乘行人举行集会，供养诸佛本尊，祈祷发愿，陈设供品，叫做会供轮）的上好饮食到洞中来看我。在洞门口，上师说：‘儿啊！你自习定到今天，恰好已是十一个月了，你能不令座垫变冷，如是精进修行，我真是高兴。现在，暂时打破窟门到你父亲这儿来，谈谈话，休息休息，恢复一下疲劳，把你的觉受证解，向我说一说。’
    “我在洞内，听见上师的话以后，说道：‘休息倒用不着，但是这是上师的命令，不能不出去！’正要想打开窟门的时候，心里踌躇着，觉得出去很可惜。这样一犹豫，就更失去了打破窟门的勇气。师母就过来说；‘儿啊！你是不是在打门啊！’
    “‘我没有勇气打门。’
    “师母就说：‘你出来是毫无过失的，这是秘密真言乘深远的大缘起。特别是上师的脾气燥，你不要失掉缘起。母亲来替你打破窟门，请你早点出来吧！’师母说完就把窟门毁掉了。于是我就随着上师、师母回到庙里。
    “到了庙中，上师就说：‘现在让我们父子来修‘现观’的仪轨吧！达媚玛请你准备会供！’在会供当中，上师说；‘儿啊！你对于口诀有了怎样的了解？有什么觉证悟境没有？慢慢的对我说吧！’
    “我就跪在上师的面前，合掌当胸，流着泪唱了一首七支供养的歌：
    于诸不净众生境，示现种种幻化身；
    示现清净所调众，圆满报身前敬礼。
    以各不同众生语，妙音宣说圣法要；
    开显八万四千法，敬礼声空无别语。
    不为有相所掩蔽，法身虚空光明性；
    遍满宇宙一切法，无转法身意前礼。
    清净法性宫殿中，常寂无我幻化身；
    三世诸佛之佛母，慈母达媚玛前礼。
    遵奉教谕诸弟子，如法修持之徒众；
    所有一切眷属前，以大虔敬我敬礼。
    十方世界一切中，所有供养及我身；
    悉以供献尊者前，一切罪业我皆忏。
    一切善业我随喜，无比法轮请常转；
    乃至轮回未空际，请求上师恒住世；
    一切功德所累积，悉以回向诸众生。
    “供上七支之后，我又继续向上师启禀道：‘与金刚持无别的上师父母啊！您无比的慈悲和加持，令弟子感到您无比的恩德。现在让我把些微的悟解，呈现尊前，祈求您在法性寂如的心境中，悲悯垂听！
    “‘我们这个缠绕含聚的身心，是由‘无明’等十二缘起而产生的；我们的这个人身，一方面固然是血肉所系、业果所牵、精神所执的一个混合物；可是这个人身啊！对于那些有福德、有宿善的人们，却是一个无价的宝船。这个宝船将用来筏渡生死的河流，驶抵解脱的彼岸！对于那些作恶造罪的人们，这个人身却是诱入恶趣的渊薮。同样的人身，作善、作恶，向上、向下，招来快乐或痛苦，却如此的不同！我觉悟了——如何在分歧的道路处有所选择，如何运用这个人身，实在是人生最重要的事。
    “‘一切痛苦根源的轮回大海，它是如此的难于渡过，今日幸有慈悲上师的接引，在浩然无际的生死大海中指示我一个方向。
    “‘我亦了悟：最初趋入佛道，应该皈依上师三宝，次第如法学习。一切的学习之中，最要紧的是依止上师，因为上师是一切幸福的根源；上师的一切训敕都要遵从；如法守护三昧耶戒（三昧耶戒即为密宗戒），持戒是最要紧的基础！
    “‘在万千不同的众生中，人的比例是如此的稀少；千千万万的人群中，能够听闻佛法，知道解脱的途径，能够走向菩提大道的人，更是稀有；如此，在所有无穷的众生当中，有机缘趋入佛法的人，比例起来，更是多么的稀少，多么的难得啊！
    “‘我们虽幸运的得了这样的一个人身，却不能确保生命的安全，谁也不知道哪一天会死，哪一天会失掉这个宝贵的人身，所以应当宝贵这个人身，珍惜这个人身。
    “‘宇宙的万物万象，皆受因果律的支配，善因得善果，恶因得恶果；了解三世的因果律，才能了解苦乐的报应和贤愚贵贱的源由。又因为宇宙的一切皆是变化无常的，所以有作为的一切善恶行为所得的果报，也不是永恒不变的。积善所得的福德，努力所得的富贵，情爱所引的眷属，与一切享受和快乐，也都是暂时的，会坏灭的，不可恃的，不可靠的，不究竟的。而人生的快乐比起他的痛苦来，却更如沧海之一粟！三恶道的苦痛，更是不堪想象，轮回无尽的生死大海中，众生尝尽了苦痛和悲哀。我思维这无尽生死的疲劳和苦痛，令我自然地一心向法；求解脱的渴望，令我决心作佛。
    “‘清净的身心为进入佛法的基础，所以第一步要先受别解脱戒，此后渐次的学习正法；守护学处，应如护自己的眼睛，勿使损坏堕败。然而寻求个人的解脱，只是小乘的有限道而已。如为了悲悯一切众生，令众生皆解脱苦海，须要发大慈悲心和大菩提心。思念一切如父如母的众生对我的恩德和情爱，我将何以报答？所以在菩提道上所作的善行，都应回向给所有的一切众生。这样，为了一切如父如母众生的缘故，便誓求佛果，发大菩提心，修习一切菩萨行处。
    “‘有了这样的大乘心根底，才能进入金刚真言乘。以清净见，依止一位具相的上师；承受对轮回自性之指示，同时要求得具足方便智慧的四大灌顶；以灌顶力得甚深见；而后次第修观，精进修持‘共道的人无我观’（‘人无我观’即为蕴、界、处中‘实我’不可得的观行，为大小显密诸乘所共依的教观，故曰‘共道之无我观’）；由佛陀的教授和理智的思维，寻求何处是我，竟不可得；如是证悟人无我理。这样以无我见而修正定，妄念断，不相续，心进入无分别，持定不起座，可经年月；如此可谓得定了。
    “‘如是，以正念力恒持守护，不堕昏沉掉举，渐次明觉增长；虽显现而无自性，明朗而无分别，赤裸裸，明朗朗；然这只是定相的觉受而已。许多人以此执为胜观。但是众生凡夫是难生起如量的胜观（如量的胜观，即真实现量之殊胜慧观；慧观即透彻的智觉观照也）的！只有证得初地（出世道十地中的初步，名为欢喜地，行者初得圣性，欢喜无量，故名欢喜地）以后，才能真实的见到胜观，因此应该依于胜观入道。其他定境如看见佛像等，只是修习的一点征验，毫无重要的价值。
    “‘总之应增进定境的觉受，以各别抉择慧，观甚深理，不能没有胜观的方便；如楼梯一样，要有一步步的阶梯才行（译者意见：此段见解，不像密勒祖师的口吻，因为此处涉及要紧的空观见，即是黄教与红、白、萨加各教分歧之处，译者所依的版本是拉萨版，可能这段不是原著，所以保留存疑的态度，请读者注意）。在修任何有相无相定以前，必须发慈悲心，一切都是为了众生，然后以清净见进入无观行。最后回向功德与一切众生。在无分别中作这些事是一切道中最殊胜的。我现在如实地知道了这些道理！
    “‘那些饥饿的人，虽然知道食物可以止饥；但仅是‘知道’又有什么用？终不能解决饥饿之苦。解决饥饿之苦，是要真真的去吃食物才行的！和这一样，于空性的道理，只是了解，又有什么用处？要证悟空性才行，慧观之方便应在后得净积中增进。瑜珈行者所观的空性，正是那无言说、无分别、法尔平等性（法尔平等即本来平等，既非由于做作而使之平等，也非由增和减少使之平等，亦无所谓净和垢，是清清净净一味的平等性）的密宗见。这是我的一点点了解。为了圆证此胜解，所以应该忍受疲劳、饥苦，抛弃一切世间的爱染，如死尸一样，不怕死，无挂碍的精进修持。在无比恩德的上师父母之前，我密勒日巴没有任何物质钱财的供养；只能在我的一生中，以修行和成就来供养；以究竟证解，报身庄严净土来供养您。’
    说完了又唱了一只歌：
    大恩上师金刚持，诸佛生处达媚玛；
    佛子化身诸眷属，请听弟子解悟义。
    未解误解与错谬，一切过失祈宥恕；
    由尊大悲之坛城，流放加持悲暖光。
    我心智慧莲花开，觉证缭绕如香溢；
    恨我无由报师恩，惟以生命精进修。
    成就利生以报恩，弟子所有未当语，
    一切求尊祈宥恕。
    “上师听毕，非常高兴的说道：‘儿啊！你已经到达了这个境地了吗？’师母也高兴极了，说道：‘我的儿子，精进和智慧真不小啊！’于是又与我谈了许多关于修法的话。后来我就又回到崖洞里修行去了。


梦兆与授记

    “有一次，上师到卫地去宏法，在做完会供的一个夜晚，想起对尊者那诺巴的教敕有不懂的地方，空行母也对上师作了表示，上师就想再去印度觐见那诺巴大师。
    “上师由卫地回到罗扎乌村以后才几天，一天晚上，我做了一个梦，梦见一个穿绿色衣服的妙龄女郎，身穿绸衣，骨饰庄严，眉间和腰间都有黄丹严饰，她对我说：‘儿啊！你长期修行，虽然得到成佛的大手印（大手印Mahamndra，为密乘修般若心地的最高法门，其见行修持皆颇似我国禅宗）口诀，和六法（指密宗的六种成就法，即①拙火 ②化身 ③梦修 ④光明 ⑤中阴 ⑥转识）心要；但是于一刹那间成佛的‘夺舍’法（得心气自在之行者，依此口诀能以神识转入他人的已死或未死之身体，故曰‘夺舍’法）口诀，你还没有得到啊！’
    “我心里想，这个女郎的样子和打扮，都像是空行母，但是不知道究竟是魔障呢？还是真的空行母授记？不过无论如何，凡是三世诸佛知道的法，我的上师都知道；上至成佛，下至降伏野老鼠的口诀，他全都有。如果是空行母的示意，那我就决定要求‘夺舍’法的口诀。于是我就打破窟门，出了崖洞，来到上师的面前。上师说：‘儿啊！你为什么不好好的闭关，出来做什么呀？究竟为什么出关呢？当心生魔障啊！’
    “我说：‘昨天晚上我梦见一个女郎说我应该求‘夺舍’法，不知道是魔障呢？还是空行母的授记？如果是授记，我想求您传我‘夺舍’的口诀。’上师静默了片刻说道：‘这不是魔障，是空行母的授记；我从印度回来的时候，至尊那诺巴说起关于‘夺舍’法的口诀，我向上师求法，上师叫我去找经书；结果师徒二人找了整整一昼夜，‘迁移’法的书倒找着了不少，可是‘夺舍’的书，始终没有找着。前几天我在卫地北方的时候，也梦见一个征兆叫我去求这个法，同时还有些对口诀不大明了要请问上师的地方。所以我决定再去印度一趟觐见那诺巴上师！’大家听了，都劝上师不要去，说：‘上师，您老人家年纪大了，不要去吧！’上师不听，决心要去。就把弟子的供养，换成一碗多黄金，带在身旁，动身到印度去了。
    “这时正值那诺巴尊者出外修行去了。马尔巴上师不顾生命的找他，以种种的方法打听他，都没有找到。但是因为他有能够遇见那诺巴上师的预兆，所以继续至心访求。后来终于在一个大树林中会着了，就请尊者到普来哈慈寺中去，传授‘夺舍’法。大梵学者那诺巴问道：‘你来求这个法，是你自己想出来的呢？还是诸佛授记的？’
    “马尔巴上师说：‘也不是我自己想出来的，也不是空行授记的。是因为，我有一个名叫闻喜的弟子，空行母向他授记，他向我求这个法，因此我才来印度的。’
    “那诺巴尊者惊奇的说：‘哦！真是希有难得啊！在黑暗的西藏，竟会出生这样一位大丈夫，真像太阳照耀着雪山一样。’说着两手合掌，恭敬地置于头上，唱道：
    ‘北方黑暗中，如日出雪山；
    其名号闻喜，我至心敬礼。’
    “唱毕，合掌闭眼，向北方俯首着地，敬礼三次；当地的山林树木，也一起向北方屈身点头三次。直到现在普来哈慈地方的山和树仍然都是向着北方西藏屈身点头似的。
    “于是那诺巴尊者就把空行母的口诀和‘夺舍’法都完全传给马尔巴上师了。
    “那诺巴尊者为观察缘起，示现了虚空坛城。马尔巴上师先向坛城本尊敬礼，却未先向那诺巴上师敬礼；那诺巴上师就得了预兆，知道马尔巴的子系传承将不能久传，但是他的事业法统传承，却如大江之无尽，将恒久住世的。
    “马尔巴上师得法之后，就回到西藏来了。
    “因马尔巴上师顶礼之缘起，他的儿子打马多得夭逝了。在他逝世一周年的时候，徒众们大家聚集起来，由几个大徒弟请问马尔巴上师道：‘与三世诸佛等无有异的上师啊！因为我们众生没有福德的原故，所以您也示现衰老了；此后口授传承的教法如何弘扬，我们弟子的弘法度生事业将会怎样？请你一一为我们授记吧！’
    “上师说：‘我的那诺巴口授传承，无论由梦兆或缘起看来，都是会发扬光大的；那诺巴尊者自己也有很好的授记。你们先回去祈梦，明天再来告诉我你们的梦兆。’第二天，各弟子都把梦兆说了，大家的梦兆虽然都非常之好，但是还不能完全与授记相合。
    “我就到上师面前，把我梦见四个大柱子的梦境详细禀告上师，唱道：
    秉承金刚持教语，昨夜梦境现如是；
    我以至诚恭敬心，启禀上师祈垂听。

    广大南赡部洲之北边，我梦雪山初延绵；
    雪山之颠可及天，日月环绕四周沿。
    日月光明照宇宙，绿草欣欣遍大地；
    四方江河不绝流，流润众生足所求。
    万川争向大海趋，众水汪洋尽一如；
    我梦花草尽向荣，万花齐放花吐舒。
    与佛无异上师尊，听我略陈所梦境。

    浩浩须弥雪山之高岗，我梦梁柱起东方；
    雄狮起舞梁柱顶，宝鬃缦垂雄狮颈。
    雄狮四爪跨雪山，仰视长空目有光；
    雄狮腾跃雪山巅，威怒迸发吼连连。

    浩浩须弥雪山之高岗，我梦梁柱起南方；
    猛虎起舞梁柱顶，吼啸之声动四疆。
    忽然大啸三声后，四蹄纵向深林走；
    仰空顾盼猛生姿，奔跃树丛有所思；
    苍莽森林接平原，我梦如是雪山南。

    浩浩须弥雪山之高岗，我梦梁柱起西方；
    大鹏起舞梁柱顶，两翼伸展掩四方。
    大鹏翱翔碧霄里，双目睥睨空中视；
    大鹏遨游入太虚，雪山西方梦蘧蘧。

    浩浩须弥雪山之高岗，我梦梁柱起北方；
    灵鹫起舞梁柱顶，危巢巧筑悬崖旁。
    我梦灵鹫生一子，百鸟横空目环视；
    鹫目电扫长空间，飞入太虚恣盘桓。

    三世诸佛我上师，弟子昨夜梦如斯；
    我心欢喜如雀跃，意乃吉兆应无疑。
    祈兴无缘大悲智，为我广说且授记！
    “马尔巴上师听了以后，高兴极了，说：‘梦兆太好了！达媚玛准备最好的食物和会供轮来！’师母准备好了会供轮和食物以后，大徒弟们都聚集起来参加会供轮。上师就说：‘密勒金刚幢昨天晚上作了这样一个梦，实在是希有难得！’大徒弟们都向上师请求解释这个梦兆，上师欣然允诺，就向大家唱了一首释梦歌：
    万千众生所依恃，那诺巴尊前敬礼；
    与会我子诸徒众，谛听汝父为授记；
    如是梦兆诚希有，我今为汝言其旨：

    赡部以北地方者，佛法弘化西藏也。
    地上雪山长成者，汝父教法宣扬也；
    口授传承广大也，未来事业无尽也。
    雪山嵯峨上参天，见道无与比伦也。
    日月环绕山之巅，悲智双运修观也。
    光明遍满虚空者，大悲净除无明也。
    遍地草木茂盛者，事业无尽宏传也。
    四方河川不断流，成就四灌口诀也。
    河水浸润诸众生，成就解脱有情也。
    河水趋入大海者，子母光明（密乘中的所谓子母光明，颇似我国《大乘起信论》中所说的始觉及本觉）相会也。
    万千花卉吐放者，离垢觉受果位也。
    此梦非恶此梦善，与会诸子应谛听！

    雪山东方起梁柱，此乃错顿网崖也。
    雄狮起舞梁柱顶，渠为人中狮子也。
    宝鬃缦垂雄狮颈，口传教授持续也。
    四爪雄跨雪山者，四无量心圆满也。
    双目脾睨仰视者，解脱轮回之兆也。
    雄狮跳跃雪山者，趋入解脱彼岸也。
    此梦非恶此梦善，与会弟子应喜欢！

    南方兴建梁柱者，雍境俄顿去朵也。
    梁上猛虎起舞者，渠为人中虎王也。
    四周虎啸庄严者，口传教授持续也。
    猛虎大吼三声者，彻证三身自性也。
    四爪纵游森林者，四种事业成就也。
    双目睥睨仰视者，解脱轮回之兆也。
    猛虎森林跳跃者，趋入解脱彼岸也。
    平原树林相连者，传承弟子持续也。
    此梦非恶此梦善，与会弟子应喜欢！

    西方兴建梁柱者，藏地米顿寸波也。
    梁上大鹏飞舞者，渠为人中大鹏也。
    大鹏展翼四方者，口传教授持续也。
    大鹏翱翔太空者，断除修观错谬也。
    双目睥睨仰视者，不受轮回后有也。
    大鹏遨游太虚者，趋入解脱彼岸也。
    此梦非恶此梦善，与会弟子应喜欢！

    北方兴建梁柱者，贡地密勒日巴也。
    梁上灵鹫飞舞者，渠为人中灵鹫也。
    灵鹫展翅四方者，口传教授持续也。
    灵鹫巢栖危崖者，生命坚如崖石也。
    灵鹫复产雏鹫者，有一无比弟子也。
    小鸟遍集空中者，口授教法宏扬也。
    双目睥睨仰视者，不受轮回后有也。
    灵鹫遨游太虚者，趋入解脱彼岸也。
    此梦非恶此梦善，为我诸子说如是。

    汝父事业今将毕，汝等弘法时至矣；
    我年老迈语若验，教法宏扬定可期。
    “马尔巴上师说完之后，与会诸大弟子都生起了无量的欢喜心。
    “于是上师对大弟子开秘密口诀藏，白日为弟子说法，夜间令弟子修行；大家都意乐炽然，觉受增长。
    “一天夜晚，上师为诸弟子授母续灌顶时想到：我当为诸弟子各各随其时节因缘，分别授与法要。次日拂晓，上师在曙光中为诸大弟子一一观其缘起，知雍地俄顿去朵当广说喜金刚法要；藏地米顿寸波应修光明成就法（六种成就法之一种，夜间修法身光明之法也，取无明昏沉以为道之法也）；多地错顿网崖应修颇哇成就法（亦六法之一，密乘之净土法门也）；我则应修拙火成就法（六法之根本，为修心气合一之法，能转业识及业气成智慧及光明），而且日后各人都有不同的时节因缘和事业。
    “上师如是观察以后，就授俄巴喇嘛以如摩尼宝六门四相之方便，演释续部之口诀，又赐以那诺巴六庄严、红宝石印、护摩盛杓，以及梵文经典论集的注疏，使他以说法之门弘扬佛法。
    “对多地的错顿网崖，授以‘转移’开顶（开顶即转识成就之征兆也）如鸟飞空之法，并赐给那诺巴的头发、指甲、甘露丸、五佛冠庄严等等，叫他以‘迁移法（即转识法）’度众生。
    “对藏地米顿寸波授以夜中明灯之光明成就法，并且赐以那诺巴的金刚铃杵、小鼓和天灵盖，嘱他致力于‘中阴成就法（六法之一种，于中阴身时成就之法也）’。
    “对我则授以如薪生火之拙火成就法，赐给我梅纪巴尊者的帽子和那诺巴大师的衣服，对我说：‘你应该在雪山峻岭间修行。’
    “上师授记传法完毕，大小喇嘛都来参加法供轮，依次而坐。上师说道：‘我已经按照你们各人的时节因缘而传授了口诀，你们各人应各以自己的因缘而弘法，将来你们的传承弘法事业一定会发扬光大的。我的儿子打马多得已经死去了，我现在把父子传承的口诀和加持传承一齐都给你们了。你们应该精进，一定会成就广大的利生事业！’
    “以后，各大弟子都回到自己的地方去了。上师就对我说：‘你再在我这里住几年，我还要传你灌顶和特别的口诀，你的觉受证解也要在上师的面前得到抉择，你快闭关去吧！’于是我就到那诺巴授记的铜崖洞中去修定了。
    “上师父母常常把自己吃的食物和会供的好物品送来给我，对我实在慈悲到极点了。”


辞别恩师

    惹琼巴又问密勒日巴尊者说：“上师老人家，您是不是遵照马尔巴上师的吩咐住了好几年呢？”
    尊者说：“我并没有住几年。在那里住了不久，我就回到家乡去了。我把回乡的原因，给你们说一说吧！
    “我闭关的时候，精进修定，颇有进境。一向我是从不睡觉的，有一天早上，忽然昏昏的睡去，做了一个梦，梦见我已回到嘉俄泽老家了。看见我那四柱八梁之家破烂的像老驴的耳朵一样，传家至宝的《大宝积经》，也被漏下的雨水淋得破烂不堪，屋外的俄马三角田里生满了荆榛蔓草，母亲死了，妹妹变成了乞丐，流浪到他乡去了。我想起自己从小就遭遇不幸，与母亲远离，这多年来，母子未能见面，心头生出了无限的悲痛，忍不住大声哭叫：‘母亲呀！琵达妹妹啊！’便从梦中哭醒过来，泪水把衣襟流湿了一大片。想着母亲，使我更无法抑止那夺眶奔流的热泪，便决心要回家看母亲去。
    “天一大亮，我不顾一切地打破窟门，来到上师的卧房，要求上师准予我回乡。恰巧上师仍在睡觉，我就跪在他床前，在上师的枕头边禀告道：
    圣不动自性大悲者，许我一返乡里行！
    我乡凶村嘉俄泽，乡人与我尽成仇；
    可怜母子俩无依，痛在生时早别离。
    我今不堪孺慕情，祈师许我返乡行！
    但愿一见高堂面，见已仍归侍尊前。
    “说完，上师就醒了。那时，清晨的太阳，射过了窗户，照在靠着枕头的马尔巴上师的头上。同时，师母正拿了早餐进房来。马尔巴上师说：‘儿啊！你突然出关，是何缘故？怕是中断魔障，快回去修定去！’
    “我就又重复将梦境和思念母亲的心情禀告上师，唱道：
    圣不动自性大悲者，许我一次还乡里；
    业缠凶村嘉俄泽，忽然梦牵魂神萦。
    家贫纵已如锥立，难抑心头思念情；
    欲知四柱八梁家，而今已见颓坏否？
    《大宝积经》正法藏，而今风雨渍蚀否？
    三角麦田俄耳马，而今蔓草丛生否？
    生我育我之老母，而今慈体安康否？
    琵达宫赛我弱妹，而今流浪飘零否？
    业缘所累彼结赛，而今已嫁他人否？
    至凶伯父勇加尔，而今仍在世间否？
    残毒姑母母老虎，而今还在世上否？
    正法般若十万颂，而今依然无恙否？
    最于生我之老母，不堪思慕孺子情！
    愿许一返乡里行，归来还侍我师前。
    “上师说道：‘儿啊！你最初来的时候，曾经说过，不要乡里和家族的了！现在你离开家乡已经这么多年，即使回去，也不一定能够遇见你的母亲吧！至于其他的人，能不能够碰见，我也不敢说，你在卫藏住了很多年，又在我这里也住了这么多年了。你如一定想回去，我可以让你走。你说你回乡之后再回到我这里。你虽然这样想，恐怕很难办到了。刚才你进来的时候，正值我在睡觉，这就是我们父子今生不能再度相见的缘起啊！
    “‘但是，太阳照着我的屋子，象征着你的教法，将如朝阳一般照耀十方；尤其是太阳正照着我头顶，这是修传派的教法将得到发扬光大的缘起。达媚玛恰巧拿饮食进来，这表示你将能以三昧定食养身。
    “‘唉！现在我也只好让你走了！达媚玛，请你准备一个好的会供！’
    “于是师母预备供养，上师建立曼陀罗，把空行耳传的成熟道表示灌顶，以及解脱道闻所未闻的口诀，完全都传授给我了。
    “上师道：‘哦！这些口诀，都是至尊那诺巴为我授记，叫我传给你的，你也应该根据空行母的授记把这些口诀传给最上根的弟子直至第十三代。
    “‘如果为了财宝、名利，或希望受人恭敬，或因为个人的偏爱，而传此法，那就违犯了空行的誓语！所以你应该特别谨慎珍惜这些口授，好好的依‘诀’修行。若遇见有善根的弟子，纵然他非常贫穷，没有任何物质的供养，也应该传他灌顶口诀而摄受他以弘扬佛法。至于像谛洛巴祖师予那诺巴大师的种种苦难和我给你的种种磨折，这些方法对于今后那些下根人，将会毫无利益，所以不可再用，现在即使是在印度，法行已是较前松懈了；所以今后在西藏，这种过于严格的方法，也不宜再用了。
    “‘空行大法，一共有九部，我已经传了你四部，还有其他五部，以后在我的传承弟子中，将有一人到印度去向那诺巴的父传弟子去求法，对众生将有大利益。你应该努力地去求这些法要。
    “‘你心中也许会想：我很穷，又没有供养，上师是不是把口诀完全都传给我呢？——你不要有这种怀疑。要知道我对于财物的供养，根本就不在意；你拿努力精进修行来作供养，才是我真真欢喜的供养！你务必精进努力，建立成就的胜幢！
    “我已经把那诺巴尊者的不共法要、空行耳传的教谕统统传给你了。这些口诀，那诺巴尊者没有传给其他弟子，只是传授了我一个人。现在我将这些口诀传予你，好象将这一瓶水倒在另一个瓶里一样，一滴无遗。为了表明我的话没有半句虚言，或是过与不及，现在，我在上师与三世诸佛本尊护法前虔立此誓：
    南无
    承恩诸尊祈加持！历代上师之传记，
    即是口诀与教法。多闻徒为扰乱因，
    切持要言取精粹，若更多求无实义。
    树枝虽多果不生，学问虽博无胜义；
    知解虽了实证无，解说虽多无实义。
    利他之心是真实，求无价宝需利他；
    法可降伏诸烦恼，坚持法要即上道。
    心恒知足即虎将，痛苦轮回决弃舍；
    一切勇中勇之首。
    无人崖洞即佛地，清净独居即神仙；
    以心御心为良马，自身即是佛寺堂；
    心不散乱即法王。
    我于善根之弟子，尽授口诀无遗技；
    师父徒子与法要，尽未来际无坏耗。
    授此法种于子手，愿得花开枝叶厚；
    硕果丰收垂运久。
    “说完，将手放在我的头顶上说：‘儿啊！这一次你要走了，我心里非常难过！但是一切有为法，原是无常的，我也没有什么办法。你休要急急的走，在这里再住几天，把所有的法要口诀仔细的复习一下；有什么疑问便提出来，我可以替你解答。’
    “我遵从上师的意思，就又住了几天，把所有疑难之处都弄清楚了。上师就说：‘达媚玛！准备一个最好的会供轮为密勒送行。’于是师母就预备了上师佛菩萨的供品、空行护法的食品及金刚兄弟的供物，陈设了一个广大的会供轮，上师大显神通，忽而变成喜金刚，忽而变成上乐金刚，忽而又变成密集金刚等本尊庄严身，具足金刚铃、杵、轮、宝、莲花、宝剑等庄严；红、白、蓝、翁、阿、吽三字（翁、阿、吽三字是一切密咒的根本。翁字为红色，阿字为白色，吽字为蓝色）放出无量光明，示现前所未显的种种神变。说道：‘这些都只是身神通而已，即使能够广大显现，还是虚妄幻景，没有多大的用处，今天为了给你密勒日巴送行，我才显现的。’
    “我眼见上师的功德与诸佛无异后，心中生出了无量的欢喜之心，想道：‘我一定要努力修行，也得到与上师一样的神通。’
    “上师问我道：‘你看见没有？生出决定心没有？’
    “我说：‘看见了，上师！不由我不生出决定的信心啊！我想努力修行，将来也可以得到与上师一样的神通。’
    “上师说：‘是啊！你应该好好的修行，记住我所指示的诸法如幻的传授，修如幻境。至于修行的处所，应该依止雪山的崖洞、峻险的山谷和森林的深处。在这些山洞崖穴中，多甲的喜日山是印度诸大成就者所加持的胜地，可以到那里去修行。那其雪山为二十四圣处之一，也是修行的胜地。芒玉的巴拔山、八玉的玉母贡惹为《华严经》上所授记的胜地，亭日的曲巴为护地空行母集会的地方，也是修行的胜地。其他，任何无人的处所，顺缘具足时，也都可以修行。你应该在这些地方建起修行的胜幢来！
    “‘在东方诸胜地中，有得哇多替和咱日。现在因缘未到，尚未现出，将来在你的说法中，要出一批人材来在这些地方发扬光大。
    “‘你应该在上面所授记的胜地去修行。要是得了成就，也就是对上师的供养、对父母的报恩和对众生的利益。除了究竟成佛之外，任何事都不能算做最上的供养、究竟的报恩和真实的利他事业。如果没有成就，纵然长寿百岁，也不过是活着多做一点罪恶而已。所以你要舍弃今生一切的贪着和对尘世的爱恋，莫与那些兢兢于世间俗务的人来往，莫谈无意思的闲话，要一心努力修行啊！’
    “上师一面说着，一面流下眼泪来，望着我慈悲地说道：‘儿啊！我们父子今生再也不能见面了，我是永远也不会忘记你的！你也不要忘记我啊！你若是能够照我所说的话去做，将来，我们在清净空行的刹土中一定会见面的。儿啊！你应该欢喜啊！
    “‘将来你修行的时候，会发生气脉的严重障碍，到了那个时候，再把这个东西拆开来看。不到那个时候，切莫拆开。’说着就给了我一件用蜡封好了的信。我那时把上师嘱咐的言语，紧紧的记在心头，上师的教谕对我实在有说不尽的利益。以后每每想起上师的教谕，善心就会增长，修行就会有进步；上师的深恩，真是说不尽哟！
    “上师遂对师母说：‘达媚玛！你准备明天与密勒大力送行啊！我心里虽然万分难过，我还是要去送他的。儿呀！今天晚上和我一起睡，让我们父子好好的谈谈话吧！’
    “当天晚上，我就在上师的房中，伴着上师；师母也在一起，师母悲伤万分，不住的流泪。上师就说：‘达媚玛！哭什么呀！他已经在上师面前得了空行耳传的最深口诀，就要到崖洞里去修行了，有什么可哭的呢？众生的本性原是佛性，由于无明的原故，不但不能自证佛陀本觉，却冤枉地在痛苦中生生死死。其实那些得了人身而不能遇见正法的人，才是真正可悲的，那些人，才是真正值得被痛哭的。你要为那些人哭的话，那么，恐怕你一天到晚都要哭了！’
    “师母说：‘上师的话是对的，但是谁能够一天到晚都有这样的慈悲啊？我亲生的儿子，无论对世法、出世法都聪慧异常，对自他二利一定能够作广大的事业，但是他却死了。我心里已是万分的悲痛；现在这个凡所嘱咐无不听从、无丝毫过失的、有信心有智慧又有悲心的徒儿，也要与我生离了。我从来没有这样一个好徒儿，我实在忍不住心中的悲痛……’话未说完，眼泪已越流越多，最后索性嚎啕大哭起来了！
    “我也忍不住痛哭起来，上师也不断的用手拭去他的泪珠。师徒三人相互依依不舍，悲伤无已，谁也说不出什么话来；所以当晚，实际上并没有能够谈什么话。
    “第二天早晨，拿着会供的食品，师徒十三人送了我十几里路，路上大家心中都很惆怅凄凉，不胜惜别之情。到了法广坡，四方的远景都在目下，大家就在山坡上坐下来，陈设会供轮。
    “上师拉住我的手说：‘儿啊！你要到卫藏去了！藏地萨儿马等地方，强盗出没非常历害，我本来想派一个人送你去的，可是因缘的表现，只合你一个人去。现在你虽是一人独行，但是我会祈请上师本尊加持，命令护法空行来保护你的；你不必担忧，路上不会出什么事的。话虽如是说，你却还是应该小心一点才是。
    “‘你可以先到俄巴喇嘛那里去，和他比较比较口诀，看看有什么差别。再从那里一直回家。在你的故乡，只许住七天，以后就应该到山中去修行，以成就自利和利他的事业。’
    “我就即席唱了一只藏行别离歌：
    圣不动自性金刚持，我今一次返藏地；
    贫儿还乡何所寄，慈父上师恩足恃。
    儿经险恶萨马时，十二明妃来相护（‘明妃’是空行母的旧译）；
    祈请无比加持师，三宝尊前求庇助。
    三处空行护送勤，菩提萨埵伴行处；
    天龙八部来相从，我心无仇亦无怖。
    依然祈请大恩师，今生他世重会时；
    祈请消除中断障，祈请护持身口意。
    祈请因缘善愿偿，祈请大慈悲灌顶；
    祈请作我正法依，祈请无病常吉祥。
    祈请上师常住世，汝子祸福与哀乐；
    一切上师自知悉，祈兴无缘大悲智；
    加持令我得山居。
    “上师说：‘是的！儿啊！父亲对你说的‘心要语’，不要忘记了，应该好好的记在心中啊！’上师把手放在我的头上，唱道：
    敬礼传承诸上师，祈祷加持我弟子；
    具足因缘法器身，愿彼成就法身佛。
    金刚句语如甘露，愿成缘起报身佛；
    菩提树干为心根，愿千叶化身无尽。
    上师教敕金刚句，愿勿遗忘常在心；
    本尊空行加持力，愿终汝身常伴随。
    空行护法诸依怙，愿恒不离常守护；
    甚深缘起此大愿，愿速应现得成就。
    一切法行慈悲力，愿于三时恒摄受；
    汝至藏萨儿马时，十二明妃来相迎。
    明朝漫长旅途中，勇父空行为相送（与空行母相对的男性密宗菩萨）；
    于汝家乡故园里，当见无常幻化师。
    姑母爱妹亲眷处，当见幻化无实师；
    无人山居崖洞中，会有轮涅双忘时（不见轮回、涅槃的存在，了达二者皆空）。
    具有毅力身庙中，当有如来会供处；
    无瑕会供食轮中，当有空行妙甘露。
    拳法精要转换处，当生妙果之稼禾；
    莫恋乡园故旧处，当求出离增上缘。
    人声犬吠渺寂处，静居必得智慧见；
    非物自身三昧食，定乐必能除饥渴（得到三昧之行者，能以定力维持生命，长期无饮食，故名三昧食）。
    无垢本尊越量宫，当见自利之游戏（本尊之坛城，超越一切衡量，故称为越量宫）；
    无覆无藏胜妙法，当有净戒大事业。
    如法修持稼田处，当有种种成就藏；
    空行心命妙法处，当越轮涅二边际。
    马尔巴口授传承派，当得广大之美名；
    蜜勒日巴坚毅力，佛法命根住持处。
    荷担如来家业士，传承绵延愿吉祥；
    本尊加持愿吉祥，喜、乐、集、密赐吉祥。
    正法宏扬大吉祥，空行心命赐吉祥；
    空行加持大吉祥，三处空行赐吉祥。
    护法加持大吉祥，护法天母赐吉祥；
    徒儿密勒大吉祥，如法修持愿吉祥。
    传承延续大吉祥，吉祥不变常坚固；
    勿忘此义精进修！
    “唱完了，上师又高兴地笑了起来。于是师母就把为我置备的衣服、帽子、鞋子和路上用的干粮等等，一齐赐给我。含着眼泪说道：‘儿啊！这不过只是一点物质上的表示而已，这是我们母子今生最后相聚的一刻了。我祝你一路平安，此去圆满幸福。要发愿我们母子二人将来在乌金刹土能够见面啊！母亲现在对你说两句正法的心要语，希望你不要忘记！
    敬礼恩师马尔巴前！
    能忍劳苦具恒心，坚忍雄毅我爱子；
    且饮上师智慧露，且饮汝母送别酒；
    愿于未来清净刹，故旧依然得相遇。
    勿忘汝父与汝母，常常怀念求加持；
    利心口诀善妙食，愿饱餐之为送行；
    愿于未来清净刹，故旧依然得相遇。
    勿忘大恩之父母，思量报恩恒精进；
    甚深空行口诀衣，暖暖穿着好送行；
    愿于未来清净刹，故旧依然得相遇。
    勿忘可悲诸众生，自心趋入菩提道；
    发大乘心有正法，奋勇担荷为送行；
    愿于未来清净刹，故旧依然得相逢。
    宿根善良达媚玛，所有教汝心要语；
    愿勿忘失常忆心，汝母亦当恒念汝。
    慈悲孝敬我母子，愿于未来清净刹，
    故旧依然得相逢。祈望此愿得成就，
    为法酬恩而会聚。
    “师母说完了以后，又很悲哀的哭泣起来。送行的人也都陪着落下泪来。我虔敬地礼拜上师和师母，顶戴尊足；师父和师母为我摩顶加持发愿之后，我们就分别了。
    “我十步九回首，看见送行的人，大家都仍在不住的流泪，我简直不忍心再回头看。慢慢的山路回曲，渐渐地看不见上师和师母了。
    “当我走完了一段小路，渡过了一条小溪，回头一望时，虽然因为距离太远看不大清楚；但仍可依稀看见上师和大众等，还舍不得我似的向我走的这个方向凝视着。我黯然神伤，忍不住几乎想跑回去；但是一想，我已经得了圆满的口诀，只要不做非法的恶业，时时忆念上师，顶戴上师，也同与上师在一起没有什么分别。将来在清净刹土中一定会再遇到上师和师母的。这一次，先回家乡去看看母亲，再回来看上师不也可以吗？于是努力镇抑住心里的悲哀，取道向俄巴喇嘛的地方而来。
    “见了俄巴喇嘛，把他的口诀和我的作了一个比较；在密续的解释和说法的善巧方面，他比我强；可是在修行的口诀上，我绝不比他弱；特别是空行口传，我知道的确比他多。最后我向俄巴喇嘛顶礼，发愿以后，就一直回自己的家乡了。
    “十五天的路程，三天就走到了。我心里想：修气功的能力，真伟大啊！”


返乡悟无常

    惹琼巴又问：“上师老人家啊！您回乡以后，家乡的情形是不是和梦中的预兆一样呢？究竟会见你的母亲没有呢？”
    尊者说：“家中的情形，正如梦兆一样，我并没有遇见我的母亲。”
    惹琼巴说：“那么您回家以后，究竟是怎么样的情形？在村子里先碰见些什么呀？”
    “我走到离家乡不远的时候，先是到村子上边的溪流旁边，从那里可以看见我的房子。附近有许多孩子正在那儿牧羊，我就向他们说：‘朋友！请问你们，那所大房子是谁家的啊？’
    “一个年纪比较长的牧童说：‘那个房子叫做‘四柱八梁之家’，房子里除了鬼以外，一个人影也没有！’
    “‘房子的主人是死了吗？还是到远方去了呢？’
    “‘从前那家人是这个村庄里最有钱的一家人，家中有一个独子，因为父亲早死，死的时候，遗嘱没有弄妥当，以致他们的一切家产就都让亲戚们给夺去了。那个儿子长大成人的时候，要求归还，可是亲戚们不肯还他。于是那个儿子发誓去学咒术，果然他后来放咒和降雹，杀死了很多的人，把这个村子害得很惨！我们村庄上的人，都畏惧他的护法神；不用说到他家里去了，就连看都不敢看一眼呢！我想现在那房子恐怕只有那个儿子的母亲的尸首和鬼住在里面。他还有一个妹妹，那个女孩子穷困得抛弃了她母亲的死尸，不知到哪里去要饭行乞去了。至于那个儿子，毕竟是死是活，多年来一点音讯都没有。听说那房子里面还有许多经典，你若有胆量，不妨进去看一看。’
    “我追问那个牧童：‘这个事情经过有多少年了？’
    “牧童说：‘他的母亲死了大约有八年了。放咒和降雹的事情，我倒记得很清楚；别的那些事都是我很小的时候听见人家说的，如今已记不大清楚了。’
    “我心里暗想：村人们怕我的护法神，也许不敢害我。又知道母亲确实是死了，妹妹到外乡流浪行乞去了，心中无限的哀痛。
    “在黄昏无人的时候，我独自跑到河边，痛哭了一场，天一黑就走进村中。一切所见的情形果然和梦中所见一样：外面的田庄上长满了野草和荆棘；那金碧辉煌的房子和佛堂现在都腐朽了。走进房子里面一看：《正法宝积经》被漏下的雨水淋得七零八落，墙上的污泥和鸟粪也零乱的洒落在上面；一部经几乎变成老鼠和小鸟的窝巢了。
    “看见这些，想起了从前，一阵凄然悲凉的感觉直袭心头。走到近门处，看见一个似乎是土和破烂衣服裹在一起的大土堆，上面长满了野草。我用手搬开土堆，发现里面有一大堆人骨头。起先心里感到一阵迷惘，忽然想起，这是母亲的尸骨！悲哀扼住了我的喉管，心中一阵剧痛，竟昏倒在地上。一会儿醒来，立即想起了上师的口诀，就观想把母亲的神识和自己的心与口传上师的智慧心融合在一起。我将头枕在母亲的骨头上，身、口、意连一刹那都不散乱地印入大手印三昧。如是经过七昼夜，亲眼见到父亲和母亲都脱离了苦趣，超升到净土中去了。
    “七天以后，我从三昧定起。仔细思量，所有轮回一切法都毫无实义；世间的一切，实在一点意思都没有。我想就把母亲的骨头作一个佛像，把《正法宝积经》供养在佛像的前面；自己则决心到护马白崖窟去不分昼夜地拚命修行：如果心不坚持，为世间八风（苦、乐、贫、富、毁、誉、贵、贱，此八者能煽动行者之心，故名八风）所动，宁愿自杀也不愿为其所诱惑。如果心中起了丝毫求安逸快乐之心，愿空行护法断取我的生命。这样屡次的对自己发誓，下了决心。
    “最后，把母亲的残骨收集好；把《宝积经》上面的鸟粪扫干净，发现雨淋损毁之处还不太多，字迹还看得很清楚。便把母亲的骨头和《宝积经》一齐背在背上，心中无限的凄凉，对轮回世间生出极端的出离心，决计舍弃世间，去勤修正法。我走出家门，满心悲哀，一边行一边唱了一首觉悟世间虚妄的歌：
    圣不动自性大悲尊，一如上师所预示；
    于此恶魔故乡里，示现无常幻化师。
    愿依如实此教师，令我顿生大决心；
    世间所现一切法，无常无依恒变易。
    轮回诸业无义利，与其勤求世间利，
    宁修佛陀解脱法。
    父在之时子不在，子在此时父已逝；
    二人纵聚亦无实，孺子我往修正法；
    修禅护马白崖窟。
    母在之时子不在，游子归时母已逝；
    二人纵聚无实义，孺子我往修正法；
    修禅护马白崖窟。
    妹在之时兄不在，兄归家时妹飘零；
    二人纵聚无实义，兄修有义之佛法；
    修禅护马白崖窟。
    有家之时主不在，主归家时家已败；
    二者纵聚无实义，主修有义之佛法；
    修禅护马白崖窟。
    圣经有时无供者，供者归时经已坏；
    二者纵聚无实义，行者我往修正法；
    修禅护马白崖窟。
    耕田在时主不在，主人归时田已芜；
    二者纵聚亦无实，主人我往修正法；
    修禅护马白崖窟。
    故乡故家与故园，皆是轮回无实法；
    播弄爱着无实义，行者我往求解脱。
    修禅护马白崖窟，承恩法父马尔巴师，
    加持令我得山居。
    “我一面唱一面走，走到从前教我识字的老师家里。可是那老师亦已经去世了；我就把《宝积经》全部供养给他的儿子，说：‘这个经的全部都供养你，请你把我母亲的残骨塑成一尊佛像。’
    “老师的儿子说：‘不！你的经有护法神在背后，我不敢接受；塑佛像的事，我倒可替你做。’
    “我说：‘你放心好了！这是我亲自供养你的，护法神不会来的。’
    “他说：‘这样我便放心了！’于是他就帮助我把母亲的骨头塑成佛像；行了开光礼，安置在塔内。一切就绪之后，他很诚恳的对我说：‘请你在我这里多住几天，我们好好的谈一谈。’
    “我说：‘我没有时间和你长谈，我急于要修行去了！’
    “他说：‘那么就请你今天晚上在我这里住一宵，明天我还要供养你修行的资粮。’于是我就答应在他那里住一个晚上。他说：‘你年轻的时候，修诛法，放咒术；现在修学正法，实在是希有难得；将来一定可以得大成就。请你告诉我，你遇见了怎样的一位上师？得了些什么法要啊！’
    “我就把最初依红教喇嘛得大圆满法，及以后遇见马尔巴上师等情，详详细细的告诉了他。
    “他听了之后说：‘真是希有难得啊！如此说来，你可以学马尔巴上师的榜样，自己弄一所房子，把你的未婚妻结赛娶过来作太太，承继上师的宗风不是很好吗？’
    “我说：‘马尔巴上师为了利益众生的原故，才娶太太，我没有这样的力量。‘狮子跳跃的地方，兔子不自量力跟着去跳的话，一定会摔死的。’何况，我对轮回世间，又是极端的厌恶呢！在世上，除了上师的口诀和修行之外，其他的一切我都不要。我到崖洞里去修行，就是对上师的最好供养；就是承继上师的宗风；也就是令上师欢喜的最好方法。利益众生，弘扬佛法，也只有修行才能办到；超度父母也只有修行才能办到；自利也必须有赖于修行。舍修行之外，别的事我一概不知，也不愿管，更不发生兴趣。
    “‘这一次我回到家乡，看见家园破毁，亲人亡散，使我深深地觉悟到人生空幻无常。人们拼命赚钱，千辛万苦成家置业的结果，亦只不过是一个幻梦；使我更生出了无比的出离之心。
    “‘房屋就象火宅一样，许多没有受到人生痛苦的人，和那些忘掉人生终要一死以及死后轮回恶趣之苦的人，才会要寻求世间的快乐。但是看透了人生的我，将不顾贫穷饥饿和他人的讥笑，决心是要尽我的寿命，为自己众生的一切利益去修行的。’
    “我流着泪向他唱了一支歌：
    敬礼胜士马尔巴足，加持穷子生厌离；
    贪恋执着世间众，可悲可叹亦可悯。
    每念众生我心悲，作兮为兮徒苦恼；
    流兮转兮堕轮回。
    业力所转可怜众，欲超度之惟勤修；
    圣不动自性金刚持，加持穷子得山居。
    幻化无常世间域，过客空留野遗冢；
    昔日可爱草原上，牛羊野马逐鹿处；
    而今唯闻鬼啾啾。此即无常幻化证，
    我今依此而修行。
    昔日四柱八梁家，而今一如破狮爪；
    房柱屋梁与四壁，而今一似死驴耳；
    此即无常幻化证，行者依此而修行。
    昔日俄马三角田，而今野草四处生；
    昔日亲友与乡里，今已大部成仇人；
    此即无常幻化证，我今依此而修行。
    我父米勒喜惹蒋，而今生死两隔绝；
    我母抑察葛锦母，而今唯留枯骨具；
    此即无常幻化证，我今依此而修行。
    贡却那崩我塾师，而今亦已离人世；
    《大宝积经》藏妙法，而今鸟雀栖巢处；
    此即无常幻化证，我今依此而修行。
    阿库勇加我伯父，而今已成死仇敌；
    琵达贡加我爱妹，而今流落在何方？
    此即无常幻化证，我今依此而修行。
    圣不动自性大悲者，加持令我得山居。
    “我唱完了之后，他很感慨地说：‘你的话真是不错啊！’他和他的太太听了我的歌之后，都感动得流下泪来。
    “家园的颓败，母亡妹离的事实，给予我刻骨铭心的教训，深深体验到无常的真谛。我禁不住嘴里屡次发出‘到深山修行去’的呼声来。我内心的深处，也再三的下了最大的决心，决计抛弃世间的一切享受，尽我的形寿，终生去修行。”


了断世缘

    惹琼巴问道：“上师老人家，您是怎样修苦行的？是在什么地方修行的呀？”
    密勒日巴说：“第二天早上，老师的儿子就给我预备了一口袋糌巴和一包好的供食，对我说道：‘这是供养你修行的，请你为我们发愿不要忘记我们！’我就拿了这些食物，到自己老家后面的大山上一个崖窟中去修习禅定。我很节省的用水调着糌巴吃，时候久了，身体变得非常衰弱，但是功夫却增长了不少。这样修了好几个月，最后粮食全吃完了，身体弱得不能再支持下去。我心里想：还是到牛场上去要一点酥油，到田庄上去要一点糌巴；好维持这个身体不至于饿死，才可继续修行。
    “我就由山上下来，到了近处一个牧场上，看见有个牛毛帐篷。我就在帐篷前说：‘施主啊！瑜珈行者来募化酥油！’谁知冤家路窄，刚巧碰见的是姑母的帐篷。姑母一听，知道是我的声音，不由怒火三千丈，立刻就放出猛狗来咬我。我赶紧用石头打狗自卫；这时姑母把牛毛帐篷的撑柱拿了下来，飞跑到我的面前，大声的詈骂：‘你这个败家子！亲友的仇敌！乡里的魔鬼！不要脸的东西！你来要什么？有你的好老子才生出你这种儿子来！’口里不住地骂，手里将棍子打将下来。我拔腿就跑，不幸因为营养不良，体力衰弱；一个石头绊着脚，立刻就跌倒在一个小溪里。姑母不住的大骂，用棍子没头的乱打；我拚命的挣扎，才站了起来。手依着行杖，双眼流泪，对姑母唱道：
    敬礼大恩父，马尔巴尊师！
    不祥嘉俄泽，罪恶渊薮里；
    亲族全为敌，母子失所依。
    值我行乞时，杖击纷如雨；
    虐岂应如是？姑母请再思。
    我作他乡客，老母忧悲死；
    穷苦所逼迫，乞食妹流离。
    我心忧未释，归返故乡隅；
    老母已死别，爱妹亦生离。
    我心实悲苦，吞声时饮泣；
    母子三人苦，是谁所给予？
    苦恼令我觉，发心修悉地；
    依上师口诀，山居静思维。
    为此幻化身，寻求食物来；
    如虫食物尽，觅食进蚁巢。
    我来汝门前，恶犬肆咆哮；
    猛扑追呼咬，欲御身无力。
    恶语及毒骂，我心哀凄凄；
    幕柱作武器，扑我身难立。
    杖击如雨降，弱躯命将绝；
    我为修行者，应怒亦不怒。
    姑母请勿怒，施我修行粮；
    慈主马尔巴尊，愿加持我等，
    怒气速平息。
    “跟着姑母一起出来的一位小姑娘听了我的歌，忍不住流下同情的泪。姑母也觉得不好意思了，就回到帐篷里去，然后叫那个女孩子拿着一皮袋的酥油和乳酪来给我。于是我就一步一跛的离开姑母的帐篷，依次地又到别个帐篷去乞食。这些人我都不认识，但是他们却都知道我。看见我来了，都仔细注视着我，都布施我很多很好的食物。这时我心里想：姑母既然对我如此，伯父也一定不会轻易饶我，还是走到别处去要吧。就带着求得的食粮走到村庄的下头。
    “谁知伯父因为自己的房子倒了，多年来已经搬到下村来住。我全然不知地走到他的门前。伯父见是我来了，跳起来叫道：‘你这个王八蛋！败家子！我虽然老得剩几根骨头了，但是我一辈子要找的，就是你！’说着，拾起石头如雨点般朝我打来。我急急地回身逃跑。伯父飞奔回家，拿了弓箭出来大叫道：‘狼心狗肺的败家子啊！你把这个村庄害得还不够吗？街坊啊！邻居啊！快点出来啊！我们的仇敌来了啊！’许多年轻人，听见伯父叫喊，连忙出来，帮着丢石头打我。原来他们都是从前吃过我的亏的人。
    “我一见情势不好，恐怕被他们打死，只得假装结起忿怒印大声叫道：‘教敕传承派的上师本尊啊！兮鲁噶具誓大海啊！修行人遇见要命的敌人了！请护法神还给他们黑箭啊！我就是死了，护法神是不会死的啊！’
    “大家听了都害怕起来，连拖带拉地把伯父拉住。有些同情我的人也都前来调解，丢石头打我的人们也走近来请求我饶恕。他们都布施了我很多粮食，只有伯父始终不与我妥协，也不给我任何布施。我拿着食物，慢慢回到山洞，自己在路上思索：我住在这村子附近，只是引起他们的忿怒与不安，还是赶快离开此处吧！
    “当夜，我做了一个梦，梦兆好象叫我再住几天才走。所以我就决定再暂住几日。
    “过了几天，结赛来了，拿着很好的食物和酒来看我，见了我就抱着我放声痛哭。她啼泣着把母亲死的经过和妹妹流浪远方的情形详细地告诉了我。听了母亲和妹妹的悲惨经过，使得我忍不住也痛哭起来。
    “后来，我忍住痛哭，问结赛说：‘你到现在还没有出嫁吗？’
    “‘大家都怕你的护法神，谁也不敢要我。即使有人要我，我也不要出嫁！你这样地修正法，真是稀有难得啊！’
    “停了一下，结赛又问我：‘你的家和田园现在打算怎样处置呢？’
    “我就明白她的意思了，我心里想：我离世弃家专修正法，完全是马尔巴上师的恩德；对于结赛，我应对她在佛法上发一个善愿，这比一切都好。对于世间的事，她应该自己决定，我须将这意思明白的告诉她。
    “我就对她说：‘如果你遇见了琵达妹妹，就把家和田都给她吧！在未遇见她之前，你可以享有这些家产。如果琵达妹妹证实是死了的话，那这家和田我就送给你了。’
    “‘难道你自己不要吗？’
    “我说：‘我是修苦行的，过的是跟老鼠和鸟雀一样的生活，所以田园对我没有什么用。即使我拥有全世界的财产，死的时候一样也带不走。如今我放弃一切，不但将来快活，现在也快活。我的行为与世人是相反的。从现在起，请你不要把我当人看待好了。’
    “她说：‘那么，你对于其他一切修法的人都不赞成吗？’
    “‘学佛的人如果最初就为了要在世界上出风头而学会讲经说法，自己的宗派得胜了就欢喜，别人输了就高兴；一味求名求利，空挂一个学佛的名称，穿上一件黄袍，这种学佛人我是反对的。如果意乐清净真诚，那么一切宗派的学人，都是趋向菩提的，我绝不反对。所以说，根本上不清净的人我是不赞成的。’
    “结赛说：‘我还从来没有见过像你这样穷苦褴褛的学佛人呢！你这是大乘中哪一派的办法啊？’
    “‘这是一种诸乘中最殊胜的法乘，舍弃世间八法，即生成佛的最上乘法。’
    “‘你所说所行的，都与别的法师们不同。这样看来，二者之中必有一个是错的。假定两个都是法，那么，我还是喜欢他们的。’
    “我说：‘你们世俗人所喜欢的法师，我却不喜欢。他们的宗义虽然与我相同，但是身穿黄袍为世间八法所转的，究竟都无实义；纵使不为八风所动，其间成佛迟速之差，判若天渊。这一点，你是不会了解的。总之，你倘是能够立志，最好便去努力修法；如果不能够呢？就还是去照管田园吧！’
    “结赛说：‘我不要你的房子和田，你还是给你的妹妹吧！佛法我是要修的，可是像你这样的修法，我是办不到的。’说完她就走了。
    “又过了几天，姑母听说我不要田宅了，很是诧异，想道：听说他依着上师的训示，不要田园了，我去看看是不是真的！于是就带着酒食来看我。她一见面就和我说：‘侄儿！前几天是我不对，你是学佛的人，请你要忍耐饶恕！我有意思替你种田，每月给你纳租；不然你的田荒废了也可惜，你看好不好？’
    “我说：‘很好！我只要每一个月有一开（‘开’是西藏重量的单位，‘一开’约相当于二十五斤）粮食就行了，其余的就都送给姑母吧！’姑母便很满意高兴的走了。
    “如是又过了两个月，姑母又来了，对我说：‘大家都说耕你的田，你的护法神会发怒放咒的。请你不要放咒啊！’
    “我说：‘我怎么会放咒呢？你是有功德的，请你放心耕田给我拿粮食来好了。’
    “她说：‘既然如此，我就放心了，请你发一个誓好不好？’
    “我心想：她是什么意思呢？就是不怀好意，也可以作为逆增上缘。我就向她发了誓，她欢欢喜喜的又去了。
    “我继续在山洞里精进修行，虽然尽了最大的努力，却仍旧不能生起暖乐的功德。正思量着该怎样办才好的时候，当天晚上就做了一个梦，梦见我在耕一块很硬很硬的田，怎么都挖不动。方想放弃的时候，马尔巴上师忽在空中显现，说道：‘儿啊！用力耕啊！只要你勇敢向前，不要怕他硬，总会成功的！’说完，马尔巴上师就在前面耕，我在后面耕，果然遍地都长出了丰盛的禾苗。
    “醒来以后，心中非常欢喜；但又一想，梦境不过是由习气的显现而已，凡夫尚不执着重视，我为梦境而欢喜，岂不是太愚痴了吗？虽然如此，我知道这是一种征兆，如果努力精进一定能生功德的，就唱了一支释梦歌：
    祈请大恩上师尊，加持穷儿得山居；
    实相法尔平等田，施以坚信之肥料；
    播以善心无垢种，猛利祈祷如雷震。
    加持大雨降纷纷，心意无二事耕耘；
    方便智慧为耒耜，一心不乱勤耕耘；
    以大精进之铁拳，粉碎五毒之烦恼。
    除却自心众缺点，灌溉无散无乱水；
    因果不坏果实上，收获善良无尽果。
    依持胜妙口诀修，无所有藏当充满；
    空行制配殊胜食，为我行者资生具。
    此梦真义实难释，言语难描真实境；
    诠说终难契真如，为劝执着名相士；
    应勤精进实修行。如能忍苦具恒毅，
    希有难成亦能成；愿诸勤求菩提士，
    修行路上无障碍。
    “我这时已有意到护马白崖窟去修行了。恰值姑母带了三斗糌巴，一件破皮衣，一块布料子，一块黄油与牛油混起来的油团来看我。对我悻悻地说道：‘这些东西就是你卖田的代价。你拿了这些东西，请到远方我耳朵听不见、眼睛看不见的地方去。因为村人大家都说：闻喜害得我们这样惨，现在你又把他喊回来，将来村上的人可能都要被他杀尽斩绝的！你要是不把他弄走，我们就把你跟他一起杀掉！所以我特地来告诉你，最好请你还是到远方去吧！你假使一定要在这里，他们怕不会杀我，倒是真的要杀掉你！’
    “我明白村人一定不会这样说的。我是一个真正的修行人，我决不会为了姑母夺我的田地而赌咒的。我发誓不放咒，并不是要让姑母欺骗夺我的田。心里是如此想，我还是对姑母说：‘我是一个修行的人，修行人最要紧的是修忍辱，如果对逆境不能忍耐，那又该怎样才能修忍辱呢？我要是今天晚上就死了，不但田没有用处，就是世界上的任何东西都没有用处。成佛以修忍辱为最紧要，姑母就是我修忍辱的对象。我之能够遇见正法，也是伯父和姑母的恩德；为了报答你们的恩德起见，我发愿希望你们未来成佛。不但田我不要，就是连房子送给你也可以。’说完我就唱了一支歌：
    依上师恩德，消遥居山中；
    弟子之祸福，师尊咸知悉。
    世人为业牵，生死难出离；
    若贪着世法，绝解脱命根。
    世人作恶忙，终受恶趣苦；
    贪着与痴爱，引人入火坑。
    寻求财物故，冲突常招敌；
    美酒如毒药，饮之难解脱。
    爱财之姑母，若贪心无厌；
    啬吝世间物，恐坠饿鬼趣。
    姑妈所有言，尽是是非语；
    多言类若此，于汝实不利。
    一切我家田，悉赠于姑母；
    人依法得净，佛殿在自心。
    慈悲度苦灵，灾苦业风运；
    我为向上者，胜不动自性。
    承恩大悲者，愿加持弟子，
    消遥得山居。
    “姑母听了我的歌，就说：‘像侄儿你这样的人，才是真正的修行人啊！’就心满意足地下山去了。
    “我受了这种种的刺激之后，对于人世间起了更大的厌离之心；因为决定了舍弃家宅和田园，心中反而觉得坦然无事。所以我就立刻想到护马白崖窟去修行。这一个崖洞是我开始修行以至日后获得成就的地方，所以后来被大家称做‘发足崖窟’。


护马白崖窟精修

    “第二天，我拿着卖田所得的物品和随身所带的零碎东西，在人未起身、天尚未亮的清晨步行到了护马白崖窟。白崖窟是一个很适宜居住的崖洞。到达以后就把一张硬毡子铺起来，上面垫了一个小垫子，作为禅座。布置定当，我就唱了一首誓愿歌：
    我未证道前，誓志常住此；
    即令冻饿死，不往觅衣食。
    疾病宁至死，不下山求医；
    忍苦宁舍命，不下山寻乐。
    乃至一刹那，不以此色身，
    寻求世间利；唯以身口意，
    争取大觉位。祈请上师尊，
    十方一切佛；赐予大加持，
    令此誓不违。祈请胜空行，
    及护法守者；助我以胜缘，
    令此誓成办。
    “接着我又发誓道：‘我若是不得成就，不生殊胜的证解，纵使饿死也不为觅食下山，冻死也不为求衣下山，病死也不为找药下山。决定彻底舍弃今生与俗世有关的一切一切。三业不动（身业、口业、意业为三业，身、口、意不为一切诱惑所摇动，故名三业不动），一心修行成佛，请求上师、本尊、空行护法加持此愿成就。如果违背此誓，与其留着一个不修正法的人身，不如即死。所以如果我一旦违誓就请护法大海众立刻断绝我的生命。我死之后，还须请上师、本尊加持得投生一个能修正法的人身。’发愿毕，接着又唱了一首决心歌：
    圣那诺巴子传解脱道，加持穷子得山居；
    不为世间散乱扰，由定修观得增长。
    安住无散三昧地，开放无生胜观花；
    不为熙攘戏论扰，愿离戏绿叶增长（有无、是非、断常、一多、来去、染净及生死、涅槃一切法、一切见皆是戏论，如小儿言无足轻重。离戏者，离却此一切戏论，直趋真如不可说境也。此处所谓绿叶者譬喻也，接前句与后句成为花、叶、果三种譬喻）。
    崖居一心无二意，愿结证解觉受果；
    不为魔障所中断，我心决定克服之。
    于方便道不生疑，父传宗风子承继；
    圣不动自性大悲者，加持穷子得山居。
    “自立誓起，我每天只吃一点点的糌巴，日复一日地苦修下去。
    “我的心分虽然有大手印的把握，但是因为食物太少的缘故，体力不足，气息不调，毫不生暖乐（‘暖相’及‘乐相’为一切定的共相，‘拙火定’更为显著），身上寒冷非常。就一心祈请上师。一夜，在光明的觉受中，好似看见马尔巴上师，有许多女郎围绕着行会供。其中有人说：‘那个密勒日巴，如果生不起暖乐，怎样好？’马尔巴上师说：‘他应该如此如此的修。’说着就把修的姿势做给我看。醒后，我就依法结六灶印（一种特殊之坐式）。以求生体乐，调匀呼吸，以命根风（‘命根风’即命气也，八识之所依也）而束语业，以法尔解脱方便调伏妄想，心趋宽坦。这样修行以后，果然生起了暖乐。
    “如是过了一年，心里就想到外面去散散步，到村庄上去走一走。正准备要走的时候，忽然想起我从前所发的誓来，就自己唱了一首警策自励歌：
    大金刚持马尔巴，加持穷子得山居；
    密勒日巴尔怪人，自唱自听自策励；
    无人伴居无人语，欲出散心寻攀谈。
    世间火宅烦恼窟，岂有遣心解忧诀；
    勿动勿动住本然，心若浮飘招恶缘；
    勿散勿散持正念，心散恐被恶风牵。
    勿行勿行洞中坐，外出当被业石绊；
    莫望东西莫抬头，抬头张望心散乱；
    勿睡勿眠勤精进，贪睡则被烦恼算。
    “歌唱毕，自己勉励自己，便愈加昼夜不息地勇猛精进，道行更渐增长。这样又过了三年。
    “我虽然一年只吃一开糌巴，但是过了这几年以后粮食也就要吃完，最后终于一点没得吃的了。眼看着这样下去只有饿死一途。我想世人以宝贵的人身孜孜于求财，得了一点就欢喜，失去就苦恼，真是可怜。以充满三千大千世界的黄金，比之于成佛的事业，实在藐不足道。若是不成佛而白白舍弃了这个身体，真太可惜。那么，我是不是要去找一点食物来维持这个生命呢？同时我又想起了从前的誓言，究竟应不应该下山去呢？思之再三，觉得现在出去，并不是因为贪玩，而是为了要得到修法所需的资粮，所以此行非但不算违背誓言，而且是应该做的。为了求得一点苦行的资粮，我于是就走到了护马白崖窟的前面。
    “那个地方，一望宽阔，日光温暖，溪水澄清，遍地长着茸茸青草和绿色的野荨麻。我一见之下，大为欢喜，心里想：‘这样就不用下山去了。就可专食荨麻好了。’从此以后我就以荨麻度日，继续修行下去。
    “再过了很久，外面穿的衣服破烂得连一片布都不剩了。因为专吃荨麻没有一点其他的食物，身上也弄得只剩下了一付骨架，头发和毛孔因为吃荨麻的缘故也都变成了绿色。
    “我想起上师给我的锦囊信符，我把信符顶戴在头顶上，心里说不出的高兴，虽然一点吃的也没有，但是就好象吃了甘美的食物一样，我感觉到非常舒适满足。我想打开信符看一看，可是有一个兆头表示，拆开信符的时候尚未到。所以就没有打开。这样又过了一年。
    “一天，一群猎人带着猎狗，在行猎的时候，什么都没有打到，无意中走到我的洞前，一见我，吓得大叫：‘你是人是鬼啊？’
    “我说：‘我是人，是一个修行的人！’
    “他们说：‘你怎么变成这个样子啊？怎么混身是绿的呢？’
    “‘因为吃荨麻吃久了，才这个样子的。’
    “‘你修行的粮食在哪里呢？把你的粮食借给我们吃，我们以后还你钱。你要是不拿出来，我们就把你杀掉！’他们就在洞里到处看了一遍，狠狠的威胁我。
    “‘我除了荨麻以外，什么都没有。如果有，也用不着隐藏，因为我相信对于修行人，只有供养粮食的，而决没有抢修行人的粮食的！’
    “其中有一个猎人说：‘供养修行人有什么好处啊？’
    “我说：‘供养修行人会有福气来的。’
    “他就笑着说：‘好！好！我就来供养你一次吧！’说完，就把我从座上抱起来向地上一掼，又提起来向上一抛，跌下来，又一掼。这样的抛和掼，我瘦弱的身体自然不能禁受，痛苦万分。但他们虽然这样侮辱我，我心中却对于他们生出了慈悲，十分可怜他们，不住的流下泪来。
    “另外一个坐在一旁没有折辱我的一位猎人就说：‘喂！你不要这样做。他倒真是一位修苦行的行者啊！就算他不是一个修行的人，把这样一个骨瘦如柴的人拿来欺侮，也不算是英雄好汉哪！何况我们的肚子也不是因为他而饿的。这种不讲道理的事，快不要做了！’又对我说：‘瑜珈行者啊！我实在佩服你。我没有扰乱你，请你回向保护我。’那个欺侮我的猎人说：‘我已经好好献上献下的供养过你了。你也应该回向保护我呀！’说着哈哈大笑的走了。
    “我倒没有放咒术，也许是三宝处罚，也许是他自己作恶的报应，以后听说过了不久，为了一件事，法官将那猎人判了死刑，除了说不要欺侮我的那个猎人没有受罚之外，其余的人都受到了很重的处罚。
    “又过了一年，所有穿的衣服实在破烂不堪了，姑母因我卖田而送给我的那件皮袄也和死尸皮一样了。我想把这几件东西缝起来做一个座垫。但是又一想，人命无常，也许我今天晚上就会死，还是多修一点定吧。就把那件烂皮衣垫在我身底下，下身随便用一些什么东西遮住；那个破糌巴口袋的一块皮就披在上面，一块烂布就补在身上必要的地方。可是那块布实在太破太旧了，没有法子用。我想把它缝一缝，但是又没有针线。最后我只得用毛草作了一根绳子，把这三样东西扎起来，捆在上身和腰间，下身也稍微遮盖着一点。就这样将就的过下去。晚上把皮衣和烂垫子又用来应付过夜，依然每日静坐思维。这样又过了一年。
    “一天，忽然听见人声嘈杂，有许多人跑到洞前来了。他们向洞内一望，看见一堆绿茸茸的人形，吓得大叫道：‘有鬼！有鬼！’说完飞也似的掉头就跑。后来的人不信说：‘青天白日之下怎会有鬼？你们看清楚了没有啊？让我们再来看看。’他们走近一看，也怕起来了。我就对他们说：‘我不是鬼，我是在这个洞里修定的行者啊！’就详详细细的把自己的来由告诉给他们听。
    “起初他们不相信，等到在洞内仔细看过一遍，发觉什么都没有，只有一些荨麻，他们才相信。于是就给了我很多糌巴和肉，并且对我说：‘像你这样的修行人，我们实在敬佩，请你超度我们所杀的动物，净除我们的罪业啊！’随即虔诚礼拜而去。
    “我这么多年以来，这是第一次得着人做的食物，心里极为高兴，就把肉煮来吃了。立刻身体觉得非常安适，健康也改进了，智慧也敏锐了，道行上生起了又深又广的证解，与以前不同的空乐也产生了。我心中想：供养大量财宝与世间上养尊处优的法师，远不如供养真正修行人一碗饭的功德来得大啊！世人锦上添花的多，雪里送炭的少，真是可叹！
    “我很节省的吃糌巴和肉，过了些时，未吃完的肉上生满了虫；我想把虫弄掉再吃。但仔细一想，这又是违背菩萨行的，把虫在吃的东西抢来吃是不应该的，所以仍旧只好吃荨麻了。
    “有一夜，一个小偷想得着我的粮食和财物，偷偷地跑进洞来到处摸索。我不禁哈哈大笑起来，我说：‘喂！朋友！我连白天都找不到，你晚上还想找得着什么东西吗？’他想了一想也跟着大笑起来。过了一会，很不好意思地悄然溜走了。
    “又过了一年，我的家乡嘉俄泽的猎人们，什么野物都没有打着，跑到我的洞前来了。见我绿茸茸地缩成一堆，披着三块布，形如骷髅地坐在那里，便吓得战战兢兢的拉开弓向着我，颤声问道：‘你是人吗？还是鬼？是兽吗？还是影子？从任何方面看来都像是一个鬼啊！’
    “我咳嗽了一声说：‘我是个人！不是鬼！’
    这些人里面因为听见我的声音，有个认识我的就说：‘你不是闻喜吗？’
    “‘是的，我就是闻喜！’
    “‘啊！那么今天请你给我们点东西吃，我们打了一天猎，什么都没有打着。请你借点东西我们吃，以后我们多多的还你。’
    “我说：‘可惜我没有什么东西可以给你们吃的。’
    “‘哦！不要紧，就把你吃的东西给我们吃好了！’
    “我这里只有野荨麻！你们烧火去煮荨麻吃罢！’
    “听了我的话，他们就生起火来煮荨麻。他们说：‘我们需要一点酥油放在里面一齐煮。’
    “‘有酥油就好啦！我不用酥油已有好几年了，荨麻里面有酥油的！’
    “‘那么请你给我们一点调味的东西好吗？’
    “‘我没有调味的东西也已经好几年了，这荨麻里面有调味的香料。’
    “那些猎人说：‘那么，无论如何盐总要给我们一点吧！’
    “我说：‘有了盐还说什么，我没有盐也已经过了好几年了，荨麻里面有盐！’
    “猎人们说：‘你的衣食真不成话，哪里像是人的生活啊！你就是替人家当佣人作工，也至少能吃得饱穿得暖。唉！唉！世界上再也找不出一个比你更悲惨更可怜的人了。’
    “我说：‘请你们不要这样说吧！我是人群中最殊胜难得的人。我遇见大译师马尔巴，得了即身成佛的口诀，住在寂静无人的山中，放弃今生的想念，修行禅定，成就三昧，名、闻、恭敬、衣、食、财、利，无一样能动我的心。因此我已经降伏了一切世间的烦恼。世上再没有比我更称得上男子汉大丈夫的人了。各位虽然生长在佛法鼎盛的国土中，但不用说修行了，就连闻法的心思都没有；你们这一辈子，忙于犯罪作恶，入地狱惟恐不深，时间惟恐不长。像你们这样才真是世界上最悲惨、最可怜的人哩！我心里是经常安稳快乐的。现在让我来唱一个修行快乐歌给你们听。’
    “他们都好奇的、很有兴味的静静听我唱：
    敬礼大恩马尔巴师，愿弃此生求加持；
    护马白崖窟顶里，有我密勒瑜珈士。
    为求无上菩提道，不顾衣食舍此生；
    下有薄小坐垫乐，上有八波棉衣乐（八波是地名，在今尼泊尔地区）；
    修带系身安稳乐，饥寒平等幻身乐；
    妄念寂灭心性乐，无不安适即快乐；
    此亦乐时彼亦乐，我觉一切皆快乐；
    为告劣根无缘辈，我为自他究竟利。
    毕竟安乐而修行，汝等悲我实可笑；
    夕阳今已下西山，诸君速返自家园。
    我命不知何时死，无暇空作尘俗谈；
    为证圆满佛陀位，幸勿扰我修禅观。
    “他们听了我的歌就说道：‘你的歌喉真不错啊！你所说的这些快乐，也许是真的。但是我们却都办不到。再会吧！’便都下山去了。
    “我的家乡嘉俄泽的村人每年要举行一个塑佛像的大集会。在这一年的集会中，那些猎人们都异口同声的唱我那支修行快乐的歌。大家都称赞这首歌真是不错。那时琵达妹妹也跑到集会上来行乞，她听见了这歌词就说：‘这只歌的作者，恐怕是位佛爷吧！’
    “一个猎人大笑着说：‘哈！哈！是佛爷还是众生我倒不知道，可是这只歌啊！就是你那个饿得只剩一身骨头的闻喜哥哥在饿得要死的时候唱的！’
    “琵达说：‘我的父亲、母亲死得很早，亲戚朋友都变成了仇敌，哥哥也不知道跑到哪里去了，剩下我这个苦命要饭的女孩子，你们还要拿我来开玩笑，未免心太狠了！’说着就唏嘘的哭将起来。那时结赛也在会中，看见琵达哭，就劝她道：‘不要哭！不要哭！作这首歌词的人，倒很像是你的哥哥。前几年我也曾看见他的。你何不到护马白崖窟去看看，究竟是不是他呢？我也同你一起去好了！’
    “琵达觉得很有理，就把喇嘛施舍的一瓶酒和一些糌巴米饭，带着到护马白崖窟来了。
    “琵达走到护马白崖窟，到了洞门口，向里面张望，看见我坐着，眼睛下凹，陷成两个大洞；身上的骨头，一根根向外凸出来，像山峰一样。浑身一点肉也没有，皮肤和骨头像要脱离似的，周身的毛孔都现着绿茸茸的颜色；头发又长又松，乱蓬蓬的一堆披着，手脚都干瘪，显得要破裂也似的。琵达一瞧，起初以为是鬼，害怕得要逃走，忽然想起了‘你的哥哥快饿死了’的那句话，就怀疑的问道：‘你是人还是鬼呀？’
    “‘我是密勒闻喜啊！’
    “她一听知道是我的声音，跑进洞，抓住我就喊：‘哥哥啊！哥哥啊！’马上就昏倒在地上。
    “我一见是琵达妹妹，悲喜交集。想尽了办法才将她唤醒。她用手蒙着脸，哭着说：‘母亲想你想死了。村上没有人肯帮助我，受不住苦，我只得四处去流浪乞食。心里总是惦念着：哥哥是死了呢？还是活着？要是还活着的话，日子该过得很快活吧！谁料你又变成了这个样子。这个世界上还有比我们兄妹更悲惨的人吗？’说着就大叫父亲、母亲的名字，捶胸顿足，嚎啕大哭起来。
    “我竭力的劝慰她，但是毫无效果，便很悲哀地对着琵达妹妹唱了一首劝慰歌：
    敬礼一切大恩师，加持穷子得山居；
    忘怀悲世琵达妹，宽心且听阿兄歌：
    一切苦乐本无常，我故如是苦修行；
    终当获得究竟乐。一切众生如父母，
    于我恩德无有量；为报一切众生恩，
    如是苦行又何妨。崖栖穴居如野兽，
    见者孰不生怜悯；我所食者如狗食，
    人见呕吐且难忍。我身有如骨骷髅，
    仇敌见之亦泪泣；观我行迹似疯狂，
    知者知我与佛同；恒沙诸佛孰不喜？
    下有冰冷石床坐，刺我肌肤令精进；
    外内身彻荨麻香，绿色一味无转变。
    无人山中崖洞居，断除忧恼如佛陀；
    上师三世一切佛，心中礼拜常不疏。
    如是猛修得精进，必生觉证无疑问；
    觉受正解若得生，此生快乐任运成。
    未来决定能作佛，琵达我妹悲应释；
    宽舒汝怀勿啼哭，同享正法修行乐。
    “琵达就说：‘果真如此的话，倒真是希有难得，但实际上恐怕靠不住吧！若真是这样的话，为什么其他学佛的人不像你这样呢？即使不完全像你这样，也总应该有一部份相像呀！你这种修行的人，我从来连听都没有听人说起过。’一面说着，一面就把带来的酒和食物给我吃。我吃完了食物，立刻觉得智慧明朗。当天晚上，道行就有了极大的增长。
    “第二天早上，琵达走了以后，我的身心同时感受到从来未有的安乐和疾锥的刺痛，心境中出现了善与不善的各种变化和征兆。虽然努力修观，也无济于事。过了几天，结赛带了许多陈年的酥油和老肉，又有一坛好酒，和琵达一起来看我。恰巧碰见我出去打水去了。打水回来，因为身上几乎一点衣服都没有了，绿茸茸的光身子一个，所以她们俩都不好意思看我，把头掉了过去，站在一旁哭泣起来。
    “我进洞里坐下，她俩就把糌巴、酥油和酒、肉拿给我吃。
    “琵达对我说：‘哥哥啊！无论从哪方面看起来，你都不像个人！出去化一点人吃的食物来修行不好吗？我也去想法子替你弄一件衣服来穿！’
    “结赛也说：‘无论怎样，化点粮食总是应该的，我也要想方法替你弄一件衣裳来。’
    “我说：‘我什么时候死都不知道，去化缘只有浪费时间，有什么意思呢？就是冻死、饿死，也是为了法而死的，我将毫无后悔。放弃修行，为衣食而奔走，努力聚集财宝，吃好的，穿好的，与亲戚朋友们大吃大喝，乱唱瞎聊，嬉笑度日，过这种生活是虚度宝贵的人生，我是绝对反对的。所以你们也不必替我找衣服；我也更不会去化缘。大家各行其是好了！’
    “琵达说：‘你简直是自己找苦吃，我不知道你怎样才能满意，看样子你也再没有别的方法磨折自己，使自己更加痛苦了吧！’
    “我说：‘我这算什么，三恶道才是真正的痛苦呢！但是众生易作恶，自己去找这种痛苦受的人正多得不胜枚举。我对于我的现状，已经很满意了。就唱一只满意歌给她们俩人听：
    敬礼三身上师前，加持穷子得山居；
    既无亲朋为挂念，亦无仇怨相牵缠；
    如是死于崖洞里，无悔无恨心满意。
    亲朋不顾我将老，弟妹莫认我死期；
    如是死于崖洞里，无悔无恨心满意。
    我死悄悄无人知，我尸鸟鹫亦不见；
    如是死于崖洞里，无悔无恨心满意。
    我尸一任苍蝇食，我血一任虫蛆饮；
    如是死于崖洞里，无悔无恨心满意。
    洞内死尸无血痕，洞外杳然绝人迹；
    如是死于崖洞里，无悔无恨心满意。
    我尸周围无人绕，我死不闻人嚎哭；
    如是死于崖洞里，无悔无恨心满意。
    我行何方无人问，我止我住无人知；
    如是死于崖洞里，无悔无恨心满意。
    无人寂静崖洞处，穷人所发此死愿；
    为利一切有情故，诸佛加庇使圆满。
    “结赛听了我的歌，大为感叹，说道；‘你从前所说的，与现在所行的，完全一致，实在令人佩服！’
    “琵达说；‘不管哥哥怎样说，你一点衣服和食物都没有，我心实不忍。无论如何我去想法子先弄一件衣服给你。你说为了修行不去找衣食，死也无恨，但是在你没有死以前，我还得要替你想法子弄衣食来。’说完她俩就一起走了。
    “我因为吃了好的食物以后，身上苦乐刺痛和意念的烦扰等越来越大，后来简直无法修下去了。于是我就把上师的信符拆开来看。上面写着有除障增益、转过患为功德的种种口诀，特别叮嘱我，现在应该吃好的食物。由于我过去不断努力修行的力量，使身体的要素（原文为‘界’或‘大’，即指地、水、火、风四大。即是所谓物质之要素）都集于脉内。这些，都因为食物太坏的原故，所以没有力量可以化解。
    “我就将琵达带来的一点点酒和结赛带来的食物吃了，照着信符上的指示，依心要、气要和观要，努力修行。打开了身上小脉的脉结，中脉脐间的脉结也打开了，生出前所未有的乐、明、无念的觉受。其境界非语言所能形容。这种不共的觉受证解功德，坚固、广大，转过失而成为功德。我通达了妄念即是法身，了知轮回、涅槃一切法皆是缘起；自心一切种识本离一切方所，行为错误则招致轮回，善行解脱则获得涅槃。而此生死、涅槃二者之体性皆为不二空性光明（‘不二空性’就是《维摩诘经》里所说的不二法门。《维摩诘经》所示是遮诠；密乘于不二空性后加‘光明’字样，是表诠，明说也）。生出此种不共功德的因地，即是苦修净行的累积；生出此不共功德的缘助，乃食物及甚深口诀，以因缘和合而得成功。因此对真言方便道，会物欲而菩提的殊胜善巧，起了决定信心。深知琵达、结赛供食的恩德亦不可思议。为报她们之恩，特为发愿，回向菩提。回向已毕，我就唱了一只缘起心要歌：
    敬礼马尔巴大译师，加持穷子得山居；
    善良施主来供食，二利缘起成于斯。
    人身难得却易坏，养以食物始不衰；
    芸芸物种遍大千，会合天公降时雨；
    则能成就利生缘。
    缘起心要为佛法，父母所生幻化身；
    会遇上师妙口诀，则能成就法缘起。
    缘起心要为精进，无人深山崖洞住；
    会和寂静无言说，则能达成一切事。
    缘起心要为空性，密勒日巴之恒毅；
    会和众生之信心，则能成就利生业。
    缘起心要为慈悲，崖居修行瑜珈士；
    会和净信供养主，行者施者俱成佛。
    缘起心要为回向，大恩上师之慈悲；
    会和弟子之苦行，则成住持佛教因。
    缘起心要为持戒，神速加持之灌顶；
    会和至心之祈祷，则成速见本师因。
    缘起心要为吉祥，圣不动自性金刚持；
    穷子苦乐尊师知。
    “我继续努力修行，慢慢地觉得在白昼中身体可以任意变化，腾入空中及示现种种神通。夜晚梦中，可以游行世界之顶，可以粉碎山川。能化成百千化身，往诸佛刹土听闻法要，为无量众生说法。身能出入水火，得不可思议的种种神变。我心里生大欢喜，一面受用，一面继续修持。不久，我真正地能飞行自在了。我就飞到惹门去自山顶去修观，生出前所未有的拙火暖乐。
    “在飞返护马白崖窟途中，经过一个绒俄小村的时候，有父子二人正在耕田，他们原是伯父的一党。那父亲正拿着锄头在掘地，儿子正在赶牛耕田。儿子一抬头看见我在天空中飞行，马上叫道：‘父亲看啊！你看天上有一个人在飞啊！’他忘记了耕田的工作，两眼不住的望着我在空中飞行的姿态。他的父亲说道；‘唉！有什么好看的，嘉俄泽的仰察葛锦白庄严母生了一个恶鬼的儿子，饿也饿不死，人称做‘恶魔密勒’的，大概就是他吧！莫要让他的影子遮着你，好好的耕田吧！’那个老头子怕碰着我的影子，就东躲西躲的闪在一边。那个儿子说：‘看着活人飞行，实在有趣啊！我要是能飞的话，就是跌断了腿也是愿意的。’于是他田也不耕了，双眼直瞪着空中的我。
    “那时，我认为我已经有力量可以做利益众生的事业了，我应该去弘法度生才对。但是本尊示现对我说：‘应该依照上师的嘱咐终生修行才对，世上再没有比修行更能利生弘法的事了。’我心中就想：终生修行的事迹，可以为以后的行者做榜样，对未来的众生和教法将有广大的利益。所以就决定仍旧终身在山中修行。
    “又想：‘我住在此处已经多年，知道我的人已渐渐多了。今天这个小孩子又看见我飞行，以后恐怕来的人会越发多起来。如果继续住下去，可能堕入世间八法，由于天魔和名闻恭敬的利诱，究竟悉地（‘悉地’是成就的意思）可能中断。还是到上师授记的胜地‘曲巴’去修行吧。’我就背起煮荨麻的土锅，离开了护马白崖窟。


度化有缘众生

    “因为长期苦修的原故，我的体力不继，褴褛的衣服满地上拖着，一不小心，失脚滑跌在路旁。绳子一断，土锅也打破了。锅子里还有一堆鲜绿的麻草，伴着破锅散落在地上。我看见这个景象，想起了‘无常’的道理，生出了更深的出离精进的心，不觉唱道：
    昔日土锅今已破，一切无常顿显示；
    此身无常尤应觉，应无懈惰勤精进。
    密勒仅有之财产，惟此土锅今已破；
    锅破正堪为我师，物我无常同一例。
    “我正在唱歌的时候，山坡背后恰巧有一个猎人在吃东西，他听见了我的歌声，就走过来对我说；‘瑜珈行者啊！你的歌声真是好听极了！’又看见我手里拿着的破锅片，便问：‘那个土锅已经打破了，你还拿着它做什么呀？你的身体这样瘦，又是绿颜色的，是什么道理呀？’
    “我简单的告诉他我修行的经过。他听了说；‘这真是希有难得啊！请你到山坡上面和我们一起吃饭好不好？’我就随他一起上了山坡。那里还有好几个猎人坐着，其中一位对我说道；‘喂！朋友，我看你的眼睛长得很不错，如果以你这样的苦修来作世间上的事，一定可以骑乘如狮子般的骏马，家里会有最好的牲口和奴婢，享受荣华富贵，谁也不敢欺侮你。你可以过很舒服的日子。不然最低限度，你做做生意，也可以养活自己，日子过得舒舒服服的。就是再倒霉，替别人当佣人的话，也可以吃得饱、穿得暖，总比你现在这个样子要好得多。以前你也许不知道怎样做，今后你照我的话去做，一定不会错的。’
    “另外一个老头子就说：‘算了！算了！你不要乱说了，这位倒像是一个真修行人，他哪里会听我们世俗人的说哟，快莫要多嘴吧！唉！先生！你的声音真美，请你再唱个歌给我们听听吧！’
    “我说：‘你们看我，觉得我悲惨已极。但是在这个世界上，比我更幸福，生活得更快乐的人，恐怕再也找不出了。我这样说，也许你们不大明白，请你们听我唱一只“瑜珈走马歌”吧！
    敬礼大恩马尔巴师，我身譬诸山间寺；
    北首有一大佛殿，三角心脏根脉畔。
    心猿意马如风驰，欲降此马如何降？
    欲拴此马用何缰？此马饥时饲何食？
    此马渴时饮何浆？此马逃时何以圉？
    降马唯用不二绳，拴马只有三摩地；
    恩师心诀供马食，以正念水解马渴。
    真空可圉马逃亡，智慧方便为鞍辔；
    不二坚固秋带系，命根风速如箭驰。
    明慧童子为御人，闻思修如护身铠；
    大菩提心为甲胄，身后负着忍辱盾。
    手执锋利正见矛，腰佩无俦智慧剑；
    调和一切种识箭，远离忿怒与憎怨。
    四无量心如机铦，明利智慧同镞尖；
    无生空性弓张满，甚深方便箭在弦。
    直射广大双运境，飞入无边佛净土；
    射不失鹄净信士，射死我执之魔王。
    射毁烦恼之仇敌，超度六道出罪累；
    驰马大乐平原上，奔向佛位大觉地。
    舍弃轮回于脑后，菩提树下可息荫；
    驰马如斯证佛果，此愿比汝愿何似？
    斯乐比汝乐如何？
    “猎人们听了我的歌，顿时都生出了信心。
    “我离开了猎人们，向曲巴行来；走过了巴库，到达亭日，便在路旁躺下来休息片刻。有几个姑娘打扮得漂漂亮亮的，准备去参加法会，经过这里，看见了我这枯瘦如柴的身体，一个姑娘说道：‘你们快看啊！这人真可怜啊！我们要发愿，来世不要得到这样的一个人身啊！’
    “另一个姑娘说道：‘真是可怜啊！这个样子谁看见了都会伤心的。’
    “她们却未料到我心里也在想着，这些无知的众生真是可怜啊！不由得对她们起了极大的悲悯心，就站起来对她们说道：‘喂！请你们不要这样说，也用不着这样难过。老实说，你们就是发愿，想要得着我这样一个人身，还不容易呢！你们悲悯我吗？可怜我吗？告诉你们，邪见才是真可悯，愚痴才是真可怜啊！现在听我唱一个歌吧！
    祈请我之大恩师，马尔巴尊前我敬礼；
    恶业所损诸众生，不见己过见人过。
    罪业多集小女子，一味贪着自家园；
    爱美恋身如火炽，我叹众生真可怜。
    于此五浊恶世里，事欺诈师如事佛；
    求学虚言妄语师，如同求财与求宝。
    于诸真实修行人，弃置不顾如废石；
    我叹众生真可悯，汝等美丽小女子！
    与我贡通穷密勒，相顾彼此两可怜；
    尔怜我兮我悯汝，汝我皆执悲悯枪。
    比科一场看谁胜，我知汝说等梦呓；
    密勒示汝胜口诀，得我碧玉换顽石；
    饮我美酒弃白水。
    “一个女郎听了我的歌就对身旁另一个女郎说道：‘他就是密勒日巴啊！我们只看见别人，不看见自己，说了这些不合理的话，让我们向他忏悔发愿吧！’
    “她们二人就来到我面前向我顶礼求忏悔，还供养了我七个小蚌壳，其余的女郎们也一起向我顶礼，又请我说法。
    “于是我又唱道：
    祈请大恩上师前，我以短歌说正法；
    上自兜率天宫中，不求了义求权义；
    下至海底龙宫处，不求深法求浅术；
    中于赡洲人间世，不学善巧学骗子！
    西藏雪国四区中，不重修行重口说；
    末劫法灭未来世，不求善人求恶人；
    爱俏女郎心目中，不求行者求美男；
    女心但悦音声好，不爱法语爱歌喉！
    汝等忏悔我已知，答汝供奉七蚌壳；
    为此教汝口诀歌，欢喜为汝传妙法。
    “我的歌，使得那几位女郎们都生了信心，欢喜信受而去。
    “我来到布林，打听了关于曲巴和寄普两地的祥细情形，便决定到寄普的太阳窟中去修行。在太阳窟中住了几个月，觉证都有很迅速的进步。布林的居民常常拿食物来供养我，零零星星的时常有许多人来看我，渐渐地我觉得对修定有一点妨碍，就想到师傅指示的无人深山中去修行。
    “这时琵达已经弄到了些羊毛，织成了一卷毛尼，她带着毛尼跑到护马白崖窟去找我，可是我已经离开了，她就四处打听我的下落。有人告诉她说：‘在上方贡通有一个瑜珈行者长得像个麻草虫一样，从巴库过了那托向南方走了。’她一听知道是我，就跟踪到南方来找。走到布林，恰巧遇见大译师巴日正在大开法会。巴日译师的法座上，铺放着的垫子有几层高，堂皇的胜幢大伞，高高的悬在头顶上，五色绸缎的飘带，向四方飘荡。小喇嘛徒弟们吹着法螺，喝酒饮茶，忙做一团，到会的人们非常拥挤，真是一场热闹的盛会。琵达看见这种盛况，心中想到：‘别人学佛，有这样的场面和享受。我的哥哥学的那个佛真特别！除了自找苦吃以外，毫无好处，还要受人们的耻笑，亲戚们也跟着丢脸。这一次遇见哥哥，一定要与他好好的商量一下，想法子来给这位巴日大喇嘛做徒弟才是办法。’
    “琵达向会上的人打听我的下落，有人告诉她说我在寄普，于是琵达经过布林来至寄普，找到了我。一见面就对我说：‘哥哥啊！你所修的这个法是一个教人口无吃、身无穿的法，实在可耻，使得我实在无颜见人。别的不说，你的下身都没有一点东西遮住，多难看啊！现在请你拿这毛布做一个围裙吧！
    “‘你看看别的学佛的人！看看巴日大译师那位老人家，下面坐的是几层厚的垫子；上面张的是大宝伞盖；身上穿的是绫罗绸缎，又喝茶，又饮酒；他的学徒和弟子口吹法螺。集会的大众围绕着他，献上的供养不计其数。这样才对大众和亲戚朋友都有利益，大家自能心满意足。所以我看他是修法人当中最好的修法者。你看看有没有办法在他手下做个学徒，就是做一个最小的喇嘛，也可以过得舒舒服服的。否则，哥哥啊！你这个法和我这个命啊！我们兄妹二人怕活不长哟！’说着就放声大哭起来。
    “我对琵达说道：‘你不要这样说，你们以我赤身裸体为可羞，我以为这是人人本有的身体，露出来没有什么可耻。父母生下我来时就是这样，那又有什么可耻？那些明知罪业不可造作的人却偏偏不顾羞耻地去造作罪业，令父母忧心，偷盗上师三宝的财产；又为了要满足自己的私欲，想尽方法欺骗众生，害自己，害别人。这种人，是为神人所不齿的。这种人的行为，才叫可耻，他们不仅是今生可耻，将来也可耻。再者，如果你说父母所生的身体是可耻的话，那么父母初生你的时候，你的胸部并没有两个大乳房，为什么你对于这个乳房现在也感到羞耻呢？
    “‘你以为我没有吃的，没有穿的，那样勤苦修行，是因为我找不到吃的，找不到穿的缘故，那就错了。我所以那样苦修的缘故，一来是因为我害怕三恶道的痛苦；二来是因为我看轮回就象投活人入火坑一样的可怕。俗世的散乱纷杂，世人的争名夺利，一切世间八法，对于我就象病人呕吐出来的臭食一样可憎厌而令我恶心，我一见这些，就象看见被杀死的亲生父母的血肉一样，心中说不出的难过。三来是因为马尔巴上师对我的训示是：舍弃世间八法和散乱，不顾衣食与别人的议论，要住在无人的深山中，弃绝一切今生的希望和念头，专心精进修行。所以我之想要勤苦修行，也是为了遵守上师教训的缘故。
    “‘我遵守上师的训示而修行，不但对己有益，而且对一切众生都有究竟的利益。人生在世，随时可死，与其为世间八法缠扰烦恼，不如寻求究竟的解脱。至于你说叫我去做巴日喇嘛的学徒，这话实在可笑！如果我要想在世间出头，至少也不会比巴日喇嘛差。我因为要即生成佛，所以才修苦行。琵达妹妹！你也应该舍弃世间八法，好好的学佛，跟随你的哥哥到雪山中去修行，将来对自他一切的利益，会同太阳的光辉一样灿然照遍大地的，你且听我唱一只歌吧！
    三世佛陀众生依，不为八法所染污；
    恒常加持弟子者，马尔巴译师前顶礼。
    琵达我妹恋世法，且听阿兄为汝歌：
    宝伞盖上有金顶，五色绫罗饰奇殊；
    伞面孔雀绣庄严，檀木为柄光炎炎；
    阿兄于此若有意，得之有如反掌易。
    舍弃世间八法故，我视此物如敝屣；
    遗忘世间八法故，快乐阳光照大地；
    琵达我妹不须怯，亟应断舍彼八法；
    随我前往那其贡，勤修苦行雪山中。
    白色海螺声远振，吹螺善巧自可信；
    海螺尾飘五色带，螺音召开此法会；
    阿兄于此若有意，得之有如反掌易，
    舍弃世间八法故，我视此等如敝屣。
    遗忘世间八法故，快乐阳光照大地；
    琵达我妹不须怯，应舍亟断彼八法；
    随我前往那其贡，勤修苦行雪山中。
    村里山头有寺庙，小僧唱赞声音妙；
    细心斟上茶一钟，侍众献尽殷勤貌；
    阿兄于此若有意，得之有如反掌易；
    舍弃世间八法故，我视此等如敝屣。
    遗忘世间八法故，阳光快乐照大地；
    琵达我妹不须怯，亟应断舍彼八法；
    随我前往那其贡，勤修苦行雪山中。
    巫咒卜卦与算命，惑众巧言常动听；
    贪心大众群赴召，欺骗愚民歌小调；
    阿兄于此若有意，行之有如反掌易；
    舍弃世间八法故，我视此等如敝屣。
    遗忘世间八法故，阳光快乐照大地；
    琵达我妹不须怯，亟应断舍彼八法；
    随我前往那其贡，勤修苦行雪山中。
    高楼大厦仑奂居，肥田沃土营稼穑；
    悭心深重财宝聚，仆从眷属竞趋奉；
    阿兄于此若有意，得之有若反掌易；
    舍弃世间八法故，我视此等如敝屣。
    遗忘世间八法故，阳光快乐照大地；
    琵达我妹不须怯，亟应断舍彼八法；
    随我前往那其贡，勤修苦行雪山中。
    轻骑骏马昂头嘶，银鞍宝蹬饰金辔；
    怨亲是非纠葛里，从人眷属竞围绕；
    阿兄于此若有意，得之有如反掌易；
    舍弃世间八法故，我视此等如敝屣。
    遗忘世间八法故，阳光快乐照大地；
    琵达我妹舍八法，随兄雪山修净行；
    若不舍弃彼八法，不往雪山习禅定；
    亲怨是非常扰心，恋此生乐难修行。
    何时命尽不可知，谁教尔曹修法迟；
    心不散乱常精进，依上师教益我思；
    恪遵口诀修观利，大乐解脱有证时；
    是故应往那其贡，琵达妹兮舍八法。
    雪山崖洞是吾家，崖深无人静不哗；
    造业作恶徒害己，沉溺轮回悔无已；
    三恶道苦莫更深，千万须怀畏惧心；
    断除八法免世恋，随兄修行绝挂牵。
    “琵达听完了我的歌马上便说道：‘你所说的世间八法就是人间的幸福啊！我们兄妹用不着舍弃它们吧！你明知道自己不能够做到巴日大喇嘛一样，为了遮羞，故意说了许多像是真有道理的话。你叫我嘴里没有吃的，身上没有穿的，跑到那其贡雪峰去受冻捱饿，我不干！从今以后，我到哪里去自己也不晓得。哥啊！请你不要像被狗赶慌了到处乱跑的野鹿一样。住定在这里好不好？你也可以修行，我也容易找你，这里的人好象对你都还相信似的，所以顶好常住在这里。否则请你小住几天，先把这一卷毛布作个围腰，把下身遮住。我去一下，几天就会再来。’
    “于是我答应了琵达在此再住几天，她就到布林村去讨饭去了。
    “琵达走了以后，我就把毛布分成了几块，用一大块作了一个把整个头部都装得下的大帽子，又用一块作了一双鞋，又用一块做了廿个小套子，把十个脚指和十个手指都套起来，又做了一个套子，把我的下身私处也套起来。
    “过了几天，琵达回来了，问我衣服缝好了没有？我说缝好了，就把那些套子拿给她看。
    “她一看就大叫道：‘哥哥哟！你简直不是个人哪！一点羞耻都不知道，把我辛辛苦苦讨饭换来的毛布弄成碎片，完全都糟塌了！你有时好象一点空闲都没有，忙着修行。有时你却有许多闲工夫来做这样开玩笑的事！唉！你真不像个人哪！’
    “我说：‘我是一个正人，作有意义事业的人。我最知道羞耻，所以一切的戒律和誓语我都守持得很好。因为你这个妹妹，觉得我的私处露出来不好看，感到羞耻，我又不能把它割掉，所以虽然耽误我修行，但是为了满足你的要求，我便耐心地做了这些套子。我又想如果下身突出来的部份可耻，那么，手、足、头、手指、一切突出的部份都应该觉得可耻。所以我统统作上了一个套子。我并没有糟塌毛布，我用它来做了遮耻的套子，说起来，好象你比我更知道羞耻似的，如果我私处可耻，那么你的私处可不可耻呢？集聚可耻的财宝还不如没有的好！’她听着我的话，一声也不响，气得脸色发青，青里又带黑似的。
    “我接着说：‘世间上的人，以不可耻为可耻，以可耻为不可耻。做欺骗害人、造罪作孽的事，反倒不以为耻！你再听我唱一个知耻歌：
    敬礼大恩诸上师，加持穷儿知羞耻；
    为羞所缚琵达妹，且听阿兄歌此曲：
    汝等愚痴世俗人，以不可耻为可耻；
    明耻知羞瑜珈士，调伏三门安然住；
    何有羞耻取舍心？人生既有男女相，
    尽人皆有男女根；自命知羞世俗人，
    所行皆是羞耻事；财物买得知羞女，
    怀中拥抱知羞男，恼恨邪见因此生。
    犯罪说谎偷与恨，多由男女相恋生；
    此真人生可羞事，知羞世上有几人！
    断此世心诸行者，心持精要胜口诀；
    修习甚深金刚密，终生为法而行道。
    何用故作知羞态，是故我劝琵达妹；
    通达此义心坦然，何必为我兴悲哀。
    “我唱完了歌之后，琵达的面色还是青中带黑似的，把讨来的食粮和酥油交给我说：‘不管怎样，你总是不肯照我所说的话去做的。但是我总舍不得哥哥，请你食用这些东西，我再下山去找粮食去。’说完就要走，我心里想：难道琵达的心真是不能够以法来化度的吗？我就对琵达说：‘你不要先走开，等到这些东西吃完了再走。在留此时间中，纵使你不修法，你也就可免得下山去造罪，且在这里住几天吧！’
    “琵达也就留下来，这期间，我尽量的为她说因果善恶的道理。她对于佛法渐渐的有了正确的认识，性情也稍稍改变了一些。
    “那时候，伯父在家乡已过世了。他死了以后，姑母生出了真诚的忏悔心，带了一大批东西到布林找我来了。她把带不动的东西寄放在村庄上，拣她背得动的都带着上山来。琵达在外面看见是姑母来了，立刻告诉我说：‘哥哥啊！姑母来了！她害得我们好苦，死也不要见她啊！’说完就跑出去，跑到山窟的崖前把吊桥拉起来。姑母走到桥边叫道：‘侄女啊！请你莫要把桥拉起来，这是你的姑母来了！’琵达听了说道：‘就是因为你来了，所以我才把桥拉起来的！’
    “姑母说道：‘侄女呀！这也难怪你，我现在实在悔恨以前的错待你们，所以特意来向你们道歉，希望与你们兄妹相会的，如果你实在不要见我，至少也请你告诉你的哥哥说我来了。’
    “这时我也走到崖边坐下来。姑母看见我，就向我礼拜，再三地恳求我见她。我暗想：我如果不见她，就不是一个学佛的人了，但是最好我要先让她忏悔忏悔，就对她说道：‘我已经与一切的亲戚断绝了关系，特别是与伯父、姑母断绝了关系，以前你们给了我们那些痛苦，以后在我修行乞食的时候，你们仍不饶我，又给了我许多痛苦，我是决定与你们断绝关系了！我唱道：
    大悲慈父马尔巴，我今礼拜师尊足；
    穷儿无亲惟慈尊，此外未尝有亲属。
    我今正语非诋诃，曾记当年旧事否？
    姑母若忘己所作，且听阿侄为汝歌：
    我乡罪薮嘉俄泽，幼失慈父遭坎坷；
    田园家宅尽被夺，寡母孤儿任磨折；
    姑母残狠既如狼，不断亲缘更断何！
    流浪日久忆家乡，十年归来省高堂；
    高堂已逝成千古，弱妹无依又流亡。
    我悟世事皆无常，抚今思昔倍心伤！
    发奋修行殚精力，饥饿所逼来乞食；
    乞至姑母宅前地，心知原是修行士；
    居然挟怨起怒瞋，唤来猛犬扑我身。
    姑母手持撑幕柱，击我如谷杖如雨；
    我身坠入水池中，宝贵生命几丧失；
    恶口骂我是屠户，诟辱百般刺心语；
    挣扎呼吸苦哀嚎，弱命如丝一发间。
    吞声饮泣我欲哭，姑母二次狡计作；
    骗我田园与家屋，汝心本有魔鬼在；
    我绝汝缘合理无？
    乞食伯父之门前，伯父见我怒勃然；
    骂我败家卖乡子，掷石击我如雹雨。
    凌辱石击心未厌，回身取弓箭在弦；
    箭如雨下无处躲，宝贵生命几丧却；
    伯父心有杀人魔，亲情不绝当如何！
    当吾穷苦无告际，亲戚虐我胜妖厉；
    山居修行精进时，贞坚结赛来访我；
    一心不舍旧情痴，怜爱交深来相随；
    倾诉真情语委婉，穷士枯怀雨露滋。
    疗我饥渴随泪垂，施我上妙珍馐食；
    彼虽待我恩情厚，我为法故难相酬；
    但思结赛深情谊，接待姑母复何义？
    奉劝姑母速归去，西山斜阳日已迟。
    “姑母听完了我的歌，放声大哭，向我顶礼数次，流泪说道：‘侄儿啊！你说的话一点也不错，请你宽恕我，我如今是真心真意地来求忏悔了。我心中非常难过，不能舍弃亲族的爱心，所以才来会你们兄妹的。无论如何请你们要接见我，否则我就决定在你们的面前自杀了。’
    “我于心不忍，就前去要把吊桥放下来。但是琵达在我的耳边悄悄地细声叫我不要会她，又说了许多不要会她的理由。我说：‘通常与破戒的人在一处饮水都要发生障碍，可是现在这回事，与佛法上的所谓破戒无关，我是一个修行人，无论如何是应该会她的！’我就把吊桥放下，等姑母过来，为姑母广说因果之法。姑母的心起了彻底的改变，皈依了佛法。从此以后依教修行，成为一个非常好的瑜珈行者，获得了解脱。”


一生事业之总结

    尊者说完以后，希哇俄行者就启禀尊者道：“您老人家在求法依师的时候，对于上师那样的虔诚信从，忍耐受苦；得法以后，在山中那样的精进修行。无论从哪一方面看来，都不是我们能够做到的！我们都不敢再修这个法了。可是解脱不了烦恼轮回，应该怎样办才好呢？”说完竟大声痛哭起来。
    尊者说：“你不要失望，我告诉你，只要你常常想到轮回和三恶道的痛苦（畜生、饿鬼、地狱三道众生，缺乏智慧思判力，恒常为苦恼所逼，无由解脱，所以叫做‘三恶道’），那么你的精进心和求法心就会自然生起的。凡是有心的人，听了‘因果法’既能相信，一定也能做到像我这样精进修持的。如果对于佛法不能生起极深的信仰，仅了解一些道理，是没有用处的。因为这样就很难不为八风所动。所以学佛，第一要相信因果，那些对因果报应都不相信的人，嘴里虽然谈论些与圣理二量（即‘圣教量’及‘理量’，前者是佛陀的训示，后者是根据理性所推出的结论，所以学佛的人皆应以此二量作为判断是非之准绳）相合的空性，可是实际上也只不过是说说而已，并没有什么真实的价值。因为空性这件事，非常微妙，难解难信，如果对空性能生起决定的信解，那便一定可体会到空性并不离开因果，即因果而显空性。因此对因果的取舍和去恶行善，一定格外注意，比一般人尤为谨慎。所以一切法的根本就是相信因果，努力行善去恶，这是学佛最要紧的事。
    “我最初并不懂得空性，但是对于因果却有坚定的信心；知道自己作了大恶业，将来会堕恶趣，所以心生恐怖。因此对上师的虔诚信服和修行的刻苦精进，都自然而然的办到了。你们也应该同我一样，独自住在山中修持真言乘（即密乘或密宗）。如果能这样做，我保证你们一定能够解脱成就的！”
    于是藏顿巴普提惹昨就启禀尊者说道：“上师啊！您一定是大金刚持的化身，为了度众生才化现人世，示现这样一个希有的事迹；否则最少也是无量劫来修行佛道，已经登了不退转地的一个大菩萨！你为了法，不惜身命的去修行，所作所为，处处表现出你是一位非凡的菩萨。像尊者这样的苦行和忍耐，在我们这些凡夫弟子来说，不用说做不到，连想都不敢想！就是想要学，身体也受不了。所以上师您老人家一定是佛菩萨的化身。我们虽然不能像您那样的修行，但是也都知道凡能够见到上师及闻法的众生，都能解脱轮回，这是一定无疑的。能否请您告诉我们，您究竟是哪一个佛菩萨的化身？”
    尊者答道：“我自己也不知道是谁的化身，最可能的恐怕还是三恶道的化身吧！你们以我为金刚持，当然会得到加持，可是你们以为我是化身，这对于我固然是净信，然而对于法却成了无比的大邪见！这是因为你们对于佛法的伟大果利不了解的原故。譬如像我原来只是一个普通的凡夫，而且前半生还作了大恶业；为了相信因果业报，决心抛弃了今世的一切，一心修行，现在离开成佛的阶段也可说是不太遥远了。尤其是遇见一位条件具足的上师，能够受到他的摄受。得到真言捷径的心要口诀和不为言诠所染、彻见本来面目的指示灌顶，依法修持，所以即身成佛是决无疑义的。如果此生只是造作恶业和五无间罪，那么命终以后，一定马上就会堕入无间地狱的，这就是不信因果和没有精进修行的结果。如果由内心的深处，对因果的道理生起坚决的信心，怖畏恶道的苦痛和希求无上的佛果，那么人人都可以和我一样对上师有绝对的虔诚，在修行时有最大的努力和觉证。这是任何人都能够办到的。你所说的什么佛菩萨的化身，完全是因为对密宗未能确切了解。你们应该多读古德们的传记，思维轮回之理，要常常记取人身难得和寿命无常的话，去努力修行！我曾不顾名闻和衣食，发大勇猛，忍大痛苦，独自住在无人的山中修行，因而获得觉受和证解的功德。希望你们也学我一样去好好修行。”
    惹琼巴说道：“尊者！您的这些事业，实在是希有难得，令人惊叹佩服。可是你所说的都是些可悲可泣的事，现在请您老人家讲一些令人高兴的事好吗？”
    尊者说：“令人高兴的事么？那也许是由精进而得来的成果，超度一切人与非人（‘非人’藏文是Mis ma yin，意思是凡非人类的一切精灵，阿修罗及其他的鬼神都统称非人）和弘扬佛法的事迹吧！”
    惹琼巴问道：“你是先超度人的呢？还是先超度非人的呢？”
    尊者说：‘起初有许多非人来向我挑战，我就降伏他们，以后又超度了他们。以后又超度了许多人类的徒弟。最后长寿王神女来显示神通向我挑战，我又超度了她。我的教法在非人中，长寿王神女将为继承光大者；在人类中则乌巴顿巴（即冈波巴大师）将为弘扬光大者。”
    色问惹巴就请问尊者道：“尊者！您主要的修行地方是那其贡雪山和曲巴两处，除此之外，您还在其他什么地方修行过呢？”
    尊者说：“我修行的地方有尼泊尔的约莫贡惹和六大出名山窟、六小隐名山窟和六个秘密山窟，连同另外两处，一共是二十处山窟。另外尚有四个出名的大山洞，有四个不出名的山洞，还有其他各处山间有缘会的小洞。在这些地方修行的结果，我已经证到“无有可修的法，无有能修的人’的境界。现在我已没有什么可修的了。”
    惹琼巴说：“尊者法性尽地的无缘大悲，使我们徒众得到了无颠倒的正见和坚固的信心，我们心中非常的快乐，真是感谢您老人家。现在为了利益未来的众生，可否请您告诉我们外、内、密各处修行胜地的名称？”
    尊者说：“有名的外山窟有六个，就是：
    护马白崖窟、明雀只马窟、饮哇著马窟
    惹马菩提窟、将潘郎卡窟、著甲多结窟
    不著名的内山窟有：
    结巴尼马窟、库虚问巴窟、谢普去薪窟
    白则多盐窟、则巴刚替窟、琼龙庆给窟
    秘密的山洞有六处：
    甲照郎卡窟、到碰生给窟、白普麻母窟
    来普白马窟、龙哥卢多窟、著甲多结窟
    其他二处是：
    结普尼马窟、播它郎卡窟
    四大著名的山洞是：
    雅龙的著巴普、来喜的多肚、亭日的哲借普、的色的真处普
    不出名的四个山洞是：
    咱地的刚楚窟、绒地的俄萨窟、惹那的则俄窟、古通的播绒窟
    在上面说的这些山窟中修行，可以得到顺缘和传承的加持。你们应该到这些地方去修行。”
    尊者说完了他的故事，参加法会的会众，对佛法都生起了信仰和厌世出离及慈悲的心，大家都对世间八法极生厌离，虔诚慕乐正法。
    尊者的大弟子们，都向尊者发愿：愿意断舍世欲，终生精进修法，作利益众生的事业。天神诸弟子也都发愿维护佛法。世俗的听众中，有很多上根的人，都皈依了尊者作为弟子，如法修行，终于成为得证实相境界的瑜珈行者。中根的人，都愿以月计或以年计来专门修法。下根的人，也决定终身不做恶事，常做善业。参与闻法的大众都得到了究竟的利益。
    以上是尊者自述的传记，由他的弟子们所记录的。尊者一生的事迹，如果详细叙说，可以分为三大类：第一是非人的神鬼向尊者的挑战和尊者降伏超度他们的事迹；第二是对诸具有善根大弟子的化度和成功的事迹；第三是对一般弟子及普通世人说法及其他应化的事迹。
    关于化度非人的事迹，大致说来：
    尊者在红崖谷降伏魔王毕那牙嗄，而说《六种忆念上师法》。此后尊者依马尔巴上师嘱，赴那其贡修行。在那其贡雪山调伏了许多山神，在当地说了《那其去宋法要》。次年，尊者往那其雪山中窟，说众所闻名之《雪山大歌集》。此后又依上师嘱，往芒地德燃山及尼泊尔之约母雪山。继乃回至贡通饮哇崖，说《魔母歌集》。然后往德燃山惹马菩提窟降伏女神，说《降神歌要》。又先后往展利虚空窟，及生嗄那森林狮虎窟。调伏人与非人，为数极众。既而尊者返回西藏，常住深山之中，以修行示现而度众生；在西藏贡通某山窟中，说《鸽诗集》。
    尊者化度诸大弟子的事迹，可略述如次：
    尊者居白崖金刚窟，广利众生。其时金刚瑜珈母为尊者授记诸弟子之缘起，得空行耳传口授之弟子惹琼巴金刚称特别授记。尊者往贡通普利崖时，遇心子惹琼巴。后来惹琼巴赴印度治病，返后与尊者同住雍普光明窟（此山窟不在所授记之三十个山窟之内，《密勒歌集（Mila Grubum）》中曾提到）。尊者复于惹马菩提窟遇惹巴佛护。于鸭龙著窟为昔已皈依之弟子觉放释迦古那授灌顶及口诀而化度之。于雄打各遇罢打马，于归途中遇色问惹巴，于上喜热遇只贡巴，于冬惹良遇惹巴寂光，于剑龙遇俄踪惹巴；后来又到那其雪山修行，空行母嘱尊者往的色，途中遇当巴甲普。于哥鸟各遇卡琼惹巴，于贡市遇打马网去。复上行至的色，以神通法降伏那若般琼。下归至白崖金刚窟遇若郡惹巴。时空行母又嘱另往一处所，发现了密洞麻母窟，尊者住了数日，遇一牧羊童子，其名为乐则惹巴，他日后得了大成就。于来普莲花崖遇谢贡惹巴，他以善妙饮食供养尊者。于觉罗成遇惹琼妈，于蒙尼香遇岂惹巴。因此尊者之名传扬十方。又因度母授记，故尊者度可可马国王；自后国王时时供养尊者。旋惹琼巴与谢贡惹巴迎师返那其雪山多念元窟；次年住郡龙窟（此二山窟不在所授记之三十个山窟之内，《密勒歌集》中曾提到）。再赴曲巴为长寿女次第演说《长寿女王歌集》。于亭日遇惹巴多杰自在。后来尊者住在鸭龙著普时，印度的打马菩提前来参见。以此种种因缘，尊者名益大显。有一个博学善辩的喇嘛与尊者兴辩，尊者以神通将他折服，说《惹琼的补歌集》。于著普遇梅贡惹巴。于鸭龙遇萨来俄。尊者赴著马托显时，适值惹琼巴自印度回来，尊者去迎接他，说《牛角歌》及《野驴歌》。接着又到曲巴，遇达波领贡惹巴。又于亭日吉祥快乐坡遇释迦文佛于《悲华经》中所授记的大士，心子最胜士夫密行比丘，大菩萨月光童子，为利益众生事业的缘故，投生人世，示医师相，称做抑未达波那结（意为达被无比良医，即冈波巴大师）。
    又于曲巴俄马琼住时，化度昔日敌视尊者之罗顿比丘。于结普太阳窟遇折顿吉祥光。诸比丘中，因里果普汝对尊者礼拜的缘故，以致大众也都皈依了正法。
    空行母曾授记：尊者之弟子中有二十五人得大成就。其中如心弟子八人；如子弟子十三人；如女弟子四人。其化度之经过，具载于《大歌集》中。
    第三、关于尊者其他应化等事迹。歌传中所记载，与内密诸山窟中，遇诸如心弟子的时间，稍有出入之处。其中有答比丘问及答弟子问等歌颂，与冈波巴同住时说《降伏笨教歌颂》。于鸭龙有灌顶及开光等歌颂，及咱马谢多与来色歌颂，又说《无惧乐死歌》。后与惹琼巴赴那其时说《降魔歌》及《除忧歌》。后又说《让顶郎普歌》。后由诸弟子迎请住于鸭龙普著，尊者受惹琼巴请，自说传记。空行狮王佛母为缘助，使印度大成就者当巴桑结与尊者于贡通相遇。在来醒说《死法悲钩歌》及《报母恩歌》。对咱马雅等鸭龙人说《死别歌》。于去俄说《顶日那杰雍日歌》。于曲巴说《入中后世歌》、《真言问答歌》。为了令诸弟子雀跃欢喜，更示现诸神通事迹。
    尊者以种种方便转大法轮，以不可思议方便，令无量上、中、下根有缘众生成熟解脱。上根者得大成就，中根者成其道，下根者也发菩提心、行菩萨行。于无根诸人也广播善法种子习气，令得人天快乐。悲心广大与虚空等，光耀佛法如旭日升天；使无量众生，除恶道苦，脱轮回缚；于无量痛苦生死海中，作大救护，为大依怙，其恩德事业诚不可思议也。


入灭因缘

    尊者经过了无量利生的事业，最后在亭日地方，遇到一位名叫操普博士的行者。操普爱财如命，可是因为他是学者，亭日地方的老百姓很恭敬他；每逢有宴会的时候，总是让他坐在上首。在他见到尊者后，表面上表示恭敬信仰，实际是内怀妒忌。屡次在众人集会之前，故意向尊者提出许多难题，想使尊者当堂出丑，但总未成功。
    在木虎年秋季第一日，亭日村民召集了一个大宴会，请尊者坐在最上首，操普博士坐在第二位上。
    操普博士在会众之前向尊者顶礼，心里想尊者一定会还他的礼的。但是尊者一向的习惯，除了对上师顶礼之外，决不向任何人顶礼，所以就没有回操普博士的礼。操普博士因而很不平，心中暗想：我这样博学多才的学者，向他这样一个毫无学问的人顶礼，他居然不回礼，高坐上首，昂然不动；真是岂有此理，非要报复一下不可！于是就拿了一本因明的论典，放在尊者的面前说：“请你把这本书逐字讲解，解答疑问，同时发挥所见，并加评述！”
    尊者说：“论典的语义，你也许都能逐句讲解，但是真正的意义，是克服世间八法的欲望和降伏我执，以轮回、涅槃一味而清净法执。除此之外，那些教人如何问如何答的论辩之学，根本没有什么大用处，所以我没有学过，更是不懂；如果亦曾学过，或是曾经了解过，现在也早已忘记了。忘记的理由，请听我这首歌：
    敬礼译师马尔巴前，远离言说祈加持；
    为有上师加持力，此心不受动摇害。
    恒修慈爱与悲悯，遂忘自他之执着。
    顶戴上师恒修观，遂忘威势之官府。
    不离本尊而修观，遂忘卑小蕴、界、处。
    思维耳传之口诀，遂忘文字与经典。
    守护本来平常心，遂忘无明之误谬。
    自身观作佛三身，遂忘希冀与畏怖。
    此生来生平等观，遂忘死生之恐惧。
    护持证解独自居，遂忘亲朋之照顾。
    一心定慧之进益，遂忘宗派之异同。
    思维生灭皆无实，遂忘教义宗派见。
    思维现象皆法身，遂忘着相之修观。
    无整宽坦而安住，遂忘世间礼仪行。
    身语归住于下位，遂忘富贵之骄淫。
    以此幻身作我庙，遂忘各自宗派寺。
    言语道断为作证，遂忘诠表解说义。
    言诠义语君能说，请君勿为法所执！
    操普博士说：“像你们这样专门修行的人，当然是用这一套话来回答；但是我们讲学理的，依着逻辑的道理来思辩，则你所说的话，全不合佛法的大义。我因为你是一个好人，才向你顶礼的……。”嘴里唠唠叨叨地还在讲。
    施主大众听了，大不满意。大家一致说道：“博士！无论你知道多少佛法教理，像你这样的人遍地皆是，塞满了世界都装不满尊者一根毛孔！你还是不要做声，安份的做做我们的上席；想法子去增加你的财产好了，不要再在法会上出丑了！”
    他听了勃然大怒，但是怯于众怒难犯，就是大闹一场也无胜算。只得怒气冲冲的硬忍下去。嘴里虽是默默无言，心中却好不懊恼，暗自盘算道：“这一个无知识的密勒日巴，行为疯狂，口说梦话；以虚言妄语来欺骗大众，赚他们的供养，为佛法丢脸！像我这样有学问、有声望、有财产的博士，在法的一方面看来，大家看我却比狗还不如，真是岂有此理！这非想个办法不可！”
    这位操普博士，在布林村上有个情妇。他就叫这个女人在奶酪里面放了毒药，拿去供养尊者，准备毒死他。操普答应这女人如将此事办妥，一定送她一块大碧玉。这个女人以为他说的话是真的，就把毒药放在奶酪里面到崖城来供养尊者。那时尊者早已知悉一切。尊者观察因缘，知道有缘的众生都已经化度。毒药虽不能伤害自己，但自己涅槃的日子也将到了，就准备接受毒药的供养。但是尊者知道：如果在供养毒奶以前，这个女人没有拿到玉石，那么，她就再也不会得到了。因为操普博士是决不会再把玉石给她的。所以尊者就对这个女人说：“现在我不要吃，请你以后再拿来，也许那时我就要吃了。”
    她听了尊者的话，心中又疑惑又害怕，猜想尊者大概已经知道奶里有毒了，就在十分不安的情绪中回去了。
    她见了操普博士，就把经过的情形告诉他，并且说尊者一定有神通所以不肯吃。
    操普说：“哼！他要是有神通的话，就不会叫你以后再拿给他，或是会叫你自己把这毒奶吃掉的！他不这样做而叫你以后拿来，明明表示他没有神通。现在你先把这块玉石拿去罢，你再把奶酪拿给他，你这次去一定要他吃掉！”于是就把玉石给她了。
    她说：“大家都相信他一定是有神通的，因为他有神通所以昨天没有吃。今天再拿去，他也决不会吃的。我怕得很，不敢去，我宁愿不要这块玉石。请你宽恕我，这桩事情我无法替你办到。”
    操普说道：“世上只有愚人凡夫才相信他有神通，因为他们不看经书，不懂道理，所以被他的诳话欺骗了。我看的经书中，有神通的人，不是像他这个样子的！我负责保证他没有神通。现在你再把有毒的奶酪拿去给他吃，若是我们目的达到，我一定不会辜负你的。我们相恋了这么久，以后也用不着怕人说闲话了，你要把此事办成功干脆我就跟你结婚，那时不但这块玉石是你的，我外面的财产和家中的财产，也一齐都交给你管，我俩祸福相共，白头偕老，你看好不好！”
    这个女人以为他说的话都是真的，就又把毒药放在奶酪里回到愿乐吉祥坡来供养尊者。尊者破颜微笑的接受了。那个女人心里想：博士的话真不错，他真没有什么神通！
    尊者就微笑地对她说道：“你做这个事情的代价——那块玉石，拿到手没有？”
    她一听，口张得大大的，惊骇得一句话也说不出来。一时惭惧交集，吓得混身发抖，脸色全青；一面礼拜，一面哭着颤声的说道：“玉石得到手了，但是请您不要吃这奶酪，将它给我吧！”
    尊者说：“你要它干什么？”
    她哀泣道：“让造作罪业的我吃下去算了！”
    尊者说：“一来我不忍叫你吃下去，因为你太可怜了；二来如果我不接受你的供品，我就违背了菩萨学处，犯根本堕。特别是我此生的自、他度生事业都已经圆满，到别的世界去的时候也已经到了。其实呢，你的供品并不能伤我，吃与不吃丝毫没有什么关系。如果我吃了你前次送的奶酪，那么你的玉石恐怕就得不到手了，所以我没有吃。现在既然你的玉石已经到手，我也就可以安心地吃，同时他也就可以满足他的愿望了！再说，他虽然答应你将此事办成之后，给你这个，给你那个，可是这些话是靠不住的。他所说的关于我的话，一句真的也没有。日后你们二人会发生很大的懊悔！那时你们最好从此真正的忏悔，好好的学佛；即使不然，至少也要牢记，将来如果遇有性命交关的事切莫再造罪业了！向我及我的传承虔诚祈祷吧！
    “你们两人常常抛弃快乐幸福，自找痛苦。这一次你们所造的罪业，我要发愿替你们清净忏除。为了你们的安全，这一次所做的事情，虽然迟早都会为大家知道，在我没有死以前，却切不要对人说。我这个老头子，从前所说的话究竟是真是假，你们没有亲眼看见，也许不相信。这一次你亲眼看见，总相信我的话不是假的吧！”
    说完，尊者就把毒奶喝下去了。
    那个女人回去告诉操普博士经过的情形，操普说：“锅里的菜不一定都是好吃的，人说的话不一定都是真的！只要他吃了毒奶，我的目的达到了。你少说话，悄悄的不要作声好了。”
    尊者于是传话给亭日、鸭龙各处的信士施主和其他各处从未见过他的人们，都来朝见。他的徒弟们原都在准备法会的。听见这个消息，许多人都不相信，大家都来集会了。尊者就连续地向他们大众说了许多天的法，详尽地解说世俗谛的因果道理，和胜义谛的心要指示。他说法的时候，许多上根弟子都亲眼看见无量佛菩萨在空中听尊者说法。有的人看见空中地上充满了人与非人的听众都在欢喜的听法。大家又都看见，天空中显出五色的虹光，胜幢等各种彩云遍满了虚空；五色鲜花如雨一般的从天空中降下来，异香阵阵扑鼻；同时悦耳的音乐也从空中传出来。
    听法的弟子中有人就请问尊者：“我们觉得天上天下到处都有天人在听法，眼前又亲见这许多的稀有瑞兆，究竟是什么原故呢？”
    尊者回答说：“天人和善神在空中听我说法，供养我胜妙五欲。因为你们听法的人都是瑜珈行者和有善根的信士，所以你们也心生欢喜，看见这许多的瑞兆。”
    有的人则问道：“为什么我们不能看见这些天人呢？”
    尊者说：“天人里面，有许多是登地的菩萨和得了不退转位的，想要亲见他们，一定要有天眼通，至低限度也需福慧二种资粮聚集得够，烦恼所知二障的习气不太深重才行。如果能够见到佛菩萨，那么其他的眷属也就自然见到了。你们若要想见到佛菩萨，一定要忏罪集资，努力修行，将来一定可以见到最殊胜的佛陀——自心——的。”
    尊者就为他们唱了一只见佛歌：
    敬礼大恩上师前，加持教法令增长；
    神众欢喜齐集会，听我密勒说妙法。
    十方虚空齐布满，俗世凡夫不能见；
    五通不具何能见，我观万众如在掌。
    口传上师大悲力，大众齐见希有兆；
    虚空布满五色虹，天花馥郁如雨降；
    异香芬芳天乐鸣。与会听法之大众，
    皆生净信欢喜心；此乃上师慈悲力，
    悲悯加持而示现。依此无尽大悲力，
    佛陀菩萨齐会集；若欲亲见佛菩萨，
    汝应谛听我此歌。前生多造罪业故，
    今世即爱造恶业；于诸善事全不喜，
    虽老犹不思善行；此辈必受异熟果。
    若问罪业如何忏，恒念善业罪清净；
    世上知恶作恶辈，忘净羞耻与利益。
    自身不知何处去，而欲教导他人者；
    不但害己亦害彼。己若不愿受苦恼，
    何可损害及他人？上师佛陀诸尊前，
    忏除过去所作罪；以后永远不复作；
    罪业即可速清净。有罪之人多聪明，
    全无定性喜散乱；心中若不常念法，
    是为罪业未净相！此应精勤求忏悔，
    努力忏罪并集资；如是一心精进修，
    非仅可见佛菩萨；一切佛中最胜佛，
    自身如来亦得见。若见自心法身佛，
    十方上下一切世，轮回涅槃如游戏；
    一目了然若观剧，更无修行可为矣。
    尊者说完法，听法的大众中，上根的人都证悟了自心法身的道理；中根的人生起了乐、明、无念的殊胜觉受，趋入大道；所有与会的人都生起了大菩提心。
    尊者说：“来听这一次法会的僧、俗、人、天大众都曾在前生发了善愿，所以现在大家能在此聚集，这是佛法因缘的集会。我这个老头子，现在已经非常衰迈了，今生我们能否再见面，实在很难说。但是我向你们所说的法，都是真实不虚的，希望你们如法修持。在我的佛刹中，当我现身成佛的时候，你们将都是我说法第一会中的闻法弟子，所以你们应该欢喜！”
    鸭龙地方的弟子们就问尊者嘱咐的用意，是不是因为度生已毕要涅槃了？大家请求尊者如果真是就要涅槃，无论如何要在鸭龙去涅槃，不然的话最少也要到鸭龙去一次。他们哭哭啼啼的坚持着要求尊者到鸭龙去；亭日、曲巴和其他各地的人也都要求尊者到他们的地方去。
    尊者说：“我这个老头子不到鸭龙去了，我在布林和曲巴住着等死好了。现在我们大家发一个善愿吧：愿将来都在空行净土中相见。”
    弟子们就说：“尊者倘使真不能去，那只好请尊者对所有从前到过的地方都发愿加持，祝福吉祥；一切曾经见过尊者和听过尊者说话的人，以及一切众生，都要请尊者发愿加持祝福吉祥。”
    尊者说：“你们都具有这样的信心，使我非常感动；我已本着善心早曾为你们说法，将来我自然更要为自、他一切众生的快乐幸福发愿。”
    于是尊者就唱了一支发愿歌：
    究竟大愿众生依，敬礼马尔巴译师前；
    听法会中诸学子，汝等于我恩情重！
    心生欢喜听我歌，我亦有恩于汝等；
    彼此有恩我师徒，愿于净土得相遇。
    所有一切诸施主，愿皆长寿具福德；
    心意清净无邪见，如法心愿皆成就。
    此地光大并吉祥，无病无灾无战争；
    年岁丰登人快乐，一切生活皆如法。
    见我闻我说法者，思维我之传记者；
    闻我名号事业者，愿皆相会净土中。
    于我事业与传记，若有效法力行者；
    听闻思问研究者，供养礼拜恭敬者；
    持续我之宗风者，愿皆会聚净土中。
    未来一切诸众生，若有修行之志愿；
    以我苦行修持力，愿无错谬无障碍。
    若有为法修苦行，当得无量之福德；
    劝人修行或自修，皆获无量大功德。
    若有闻我传记者，当获无比大加持；
    三门无量加持力，仅闻名号得解脱；
    愿依思念即满愿。我之国土及住处，
    所有一切诸众生；所往无处不安乐。
    空等五大所遍处，我亦长久周遍住；
    天龙八部与山神，不作丝毫之损恼。
    心愿如法得成就，乃至虫蚁鸟兽等；
    亦皆不堕于轮回，愿我皆得超度之。
    听法的大众都非常欢喜，却又不敢相信，想道：尊者大概不会涅槃罢！鸭龙和布林的徒众都到尊者面前请求加持及祝愿。然后听法大众都各自回去。天上的虹彩等异征也慢慢的消失在太空中了。
    布林的人众竭诚地恳请尊者的大弟子惹巴寂光等，请求尊者到毒龙顶窟茅篷去居住，尊者就在那里去住了些时，为布林村的施主们说法。一天，尊者告诉所有的徒众说：“你们如果对于法上有什么疑问，应该赶快问我，我快要走了。”于是徒众们就预备了会供轮，大家向尊者祈请问法，质疑口授。最后智贡巴和萨问日巴二人启禀尊者说道：“上师老人家啊！由您的话看起来，您很快就会涅槃了，我们简直不能相信。请您长久住世，可以多作利生的事业啊！”
    尊者说道：“我的世寿将要尽了，应该化度的众生，也已经化度完了。凡物有生必有死，其实，生亦不过是死的表征罢了！”
    过了几天，尊者果然现出生病的征象，弟子雁总惹巴因为尊者生了病，就集合所有的施主及所有的徒弟前来，祈求上师、本尊、空行护法，举行会供。同时对尊者说：“上师啊！您老人家是知道长寿法和药物疗治等法的，现在请您本着慈悲来用一下好吗？”
    尊者说道：“从根本上讲起来，瑜珈行者是用不着修什么法的！一切逆、顺境界莫不是道，病也可以，死也可以。尤其是我密勒日巴，把大恩上师马尔巴的法都已经修完了，现在用不着修法求神来帮忙；我可以将仇敌做为心爱的伴侣，还要修法求菩萨做什么用？若说那些妖魔鬼怪呢，早经我降伏，都已变成守护佛教的护法了，所以念咒降妖摇铃打鼓这一套法更用不着。我已经转五毒（‘五毒’即贪、瞋、痴、慢、嫉五种烦恼；此五烦恼即是五智如来或五如来的自性）成五智如来（‘五智’是成所作智、平等性智、妙观察智、大圆镜智、法界体性智。‘五如来’是不动佛、宝生佛、阿弥陀佛、不空成就佛、大日如来佛），还要医药六味何用？现在时间已到，生起次第的幻化佛身，法尔要趋入圆满次第的光明法性中，这是无庸更改的！
    “世上的人，由于从前所作恶业的果报，今生受生、老、病、死等等的痛苦，虽然用医药来治疗或是求佛修法，仍旧不能够解除痛苦。无论国王有怎样的权势，勇士有怎样的雄力，富豪有怎样的资财，美人有怎样的姿色，聪明人有怎样的机智，和演说家有怎样的辩才，他们都要终归幻灭和死亡，这一切都不是用任何息、增、怀、诛的方便所能挽救的。你们如果怕痛苦、喜安乐，我有一个方法，可以使你们不受痛苦，常享安乐。”
    弟子们说：“那么请上师告诉我们吧！”
    尊者说：“轮回的一切法，成者终将坏，聚者终将散，生者终将死，爱者终将离。能于此理有决定的觉悟，就应彻底放弃招致苦果的作业：不求财，不营利，依止一位条件具足的上师，依教修行无生法要。你们要知道修行无生空观，是一切修行中最殊胜的。此外我还有其他要紧的话，以后再对你们说。”
    大弟子惹巴寂光和总惹巴两人齐向尊者说道：“上师！您老人家如果身体健康，长久住世，不是可以多救度一些众生吗？您也许不受我们的请求，住世百年；但是无论如何要请您修一修秘密真言乘的殊胜仪轨，服一点药物，早一点恢复健康。”他们再三的这样恳求。
    尊者就说：“如果不是时节因缘已经到了，我原可以照你们二人的话去做。可是如果不是为了利他的原故而求自己长寿，利用真言仪轨请佛菩萨降临，就等于把皇帝从王座上请下来当佣人使唤一样，这是有罪的。所以你们不应该为了自己，为了此生，而修真言法。如果是为了利益众生的原故而修真言法，那自然是很好的。我为了一切众生，在无人山中终生修习最了义的仪轨，所以我也再用不着修其他任何的仪轨了。我的心境已经达到了与法界体性一如、不可分离的境界，故不需要再修什么住世法。依着马尔巴上师的口诀良药，把我的五毒完全拔除净尽了，所以我更用不着任何医药。你们如果不能以逆缘为助道，则不能算是真正的学人。如果时节未到，遇见逆境，障碍菩提道，那么服药修法都是应该的。像这般除遣逆缘转成助缘的时节，并非没有。为了超度下根众生的原故，世尊释迦牟尼也曾经受耆婆童子（Jivaka Kumara）医师诊病服药。但是时节因缘一到，佛陀自己也示现入了涅槃。现在呢，我的时节因缘已到，所以根本用不着服药修法了。”
    两大弟子又请问道：“尊者一定要为着利他的原故到他方世界去，那么就请您告诉我们尊者身后和涅槃时供养的方法，怎样料理遗体，怎样做像建塔。此外，再请您告诉我们徒众，如何以闻、思、修而行道修习。”
    尊者说：“我依着上师马尔巴的恩德，轮回、涅槃一切作业皆已净尽。身、口、意三业在法性中解脱了的瑜珈行者是不一定要留下尸体的；你们用不着造像，也用不着建塔。我没有贪爱寺庙的执着，既没有庙宇，就用不着嘱咐什么人来作住持。你们将高山雪山无人寂寞之处来当做自己的寺庙好了。在高山上你们为了悲悯六道众生而修行，这就是四时最殊胜的造像。了达一切法本来清净，即是修塔建幢。心口如一，从内心的深处发起祈祷就是最胜的供养。
    “如果甘与烦恼及我执深重的人为伍，作损恼众生的事情，那就是违背了学佛人应有的操守了。如果是为了降伏五毒和利益众生，表面上好象是在作恶业，实际上却是在行佛道，这是没有关系的。
    “仅是了解佛法而不实际修行，虽然多闻却反成障碍；结果一定堕落在三恶道的深渊里去。所以要思维人命无常，对自己所知道的善恶业努力警策与防护，即使绝命亦决不作恶事。简单的说来，学佛人要对自己知耻，才能行道。你们这样地去修行，可能与某一些宗旨乖谬的论典和书籍所说的话相违反；但是这样做去，是与诸佛菩萨的本意相契合的。所有一切闻思的心要，略言之亦不过如是。我也以为这样就足够了。你们若能按照我的话去做，我也就心满意足。你们对轮回、涅槃的一切作业，也可以达到究竟。否则以世俗的眼光和方式来满足我的心愿，是毫无利益的。你们且听我唱一只如何有益歌：
    敬礼恩师马尔巴前，在此集会诸徒众，
    听汝老父密勒歌，最后咐嘱应谛听！
    依于上师马尔巴恩，瑜珈行者我密勒，
    一切作业皆已毕。汝等后学诸徒众，
    应如我教而修行；十方诸佛皆欢喜。
    我及诸佛欢喜故，自他事业皆成就；
    违我所教诸行业，自他二利俱难成；
    坏自他故我不喜。
    若师不具净传承，求得灌顶有何用？
    自心与法不相合，手持法典有何用？
    若不舍弃世间法，依诀修观有何用？
    三业与法不相合，念诵仪轨有何用？
    恶语利嘴不对治，修行忍辱有何用？
    亲仇爱怨不舍弃，纵行供养有何用？
    自利之心若不除，徒行布施有何用？
    不识六道皆父母，寺庙虽佳有何用？
    此心不生清净见，修造佛塔有何用？
    若难四时修瑜珈，造佛形像有何用？
    心坎深处不祈祷，依时供养有何用？
    心中若不化口诀，自讨苦死有何用？
    死时不生大信心，观摩佛相有何用？
    不生悲哀出离心，舍此弃彼有何用？
    不修爱人逾爱己，口说慈悲有何用？
    若不降伏烦恼因，承事供养有何用？
    若不持续上师教，徒众虽多有何用？
    无用无益之作业，招损恼故应舍弃！
    所作已作我密勒，于诸烦扰无聊事，
    无须多作可休矣。
    弟子们听了尊者的歌唱，深为感动，大家都把这个训示铭记在心。
    不久，尊者示现疾病沉重。那时，操普博士带了很精美的酒肉假装着要来供养尊者；来到尊者的面前，讥笑的说道：“唉！像尊者这样的大成就者，是不应该害这样重病的啊！你怎么也会害起病来了呢？如果病能够分给别人的话，你可以分给各大弟子；如果病可以转送的话，就请你把病转送给我吧！您现在是一筹莫展，怎样了局呢？”
    尊者安祥地微笑着说道：“我本来不必生这一场病的。目下不得不生病的原因，你应该很清楚吧！一般凡夫的生病原与瑜珈行者的生病性质不同，缘起亦不同。我现在的病，实为佛法庄严之表现，让我唱一只歌来给你听：
    生死涅槃一切法，法界体性显光明；
    以大手印印一切，诸法无二等一味；
    我知顺逆皆法性，心无挂碍大自在。
    魔病罪恶一切障，安住气脉明点处（气、脉、明点是密乘身金刚的三要素，也是人的三种基本：‘气’即是动能，包括呼吸气息及现代的所谓电波电子作用；‘脉’凡管状的器官及神经系统均属之；‘明点’是一切内分泌）；
    为我修持作庄严，为我德行作庄严；
    愿大罪人罪清净。此病原可作移转，
    而今可以不必矣。
    操普博士心中想着：尊者似乎在怀疑着他，可是不敢决定。因为尊者说病可以转移，这一点，是决定不可靠的，天下哪里有病可以移让给人的事呢？于是他就说道：“我对于尊者的病因不很清楚。如果病由魔鬼附身而起，就应该修驱魔法；如果是由四大不调和而起，就应该调身服药。如果病真的能够转移到别人身上来，就请尊者把病移到我身上好了。”
    尊者说：“有一个大罪人，心中的魔鬼跑出来损伤我，使得我四大不调生了病。这场病你是无此能力把他除掉的。我这个病虽然可以移给你，只是恐怕你一刻都受不了，所以还是不移的好。”
    操普心想：“这个家伙根本不能把病让给什么人，所以故意说这些风凉话。非使他出丑不可！”于是就再三坚持请求尊者一定要把病转让给他。
    尊者就说：“你既然这样坚持请求，我就暂时把病移向对面那扇门上去。倘若移给你，你是受不住的！你看好了！”尊者就以神力把病苦移到对面那扇门上。门最初发生吱吱的响声，似乎是要分裂的样子，一会儿真的裂开来成为许多的碎片。再看尊者，果然现出无病健康的样子来。
    操普博士心里想：“这根本就是障眼法的魔术！骗不了我。”就说道：“啊！这真是稀有啊！但是还是请尊者把病移给我好啦！”
    尊者说：“你既然这样苦苦的要求，我就把病的一半移给你好了。全部移给你，你决无力承受的！”尊者便把病苦移了一半给他。操普博士顿时痛得要昏了过去，颤抖都不可能，呼吸也出不来。差不多即要断气的时候，尊者就把移给他的病收回了一大部分，又问他道：“我才给了你一小半病，怎么样？受得住吗？”
    操普亲自尝试过这一场剧痛之后，心里生起了猛利的忏悔心。跪下来，顶戴尊足，满面流泪的哭道：“尊者！尊者！圣人！圣人啊！我诚心的忏悔了！求您饶恕我啊。我把所有的家产一切都供养给尊者，我的罪业果报，请尊者想办法啊！”操普哭得非常的伤心。
    尊者看见他是真心忏悔，非常高兴，就把他身上还剩下的一小部分病也收了回来，对他说道：“我一生从不要田宅财产，现在快要死了，更用不着这些了。你保留着好了。以后就是断命也莫要再作恶事了。你这一次所作罪业果报，我答应替你消除好了。”于是尊者就唱了一个歌：
    敬礼具相马尔巴师，五无间罪虽已作，
    疾速忏悔得消除。依我善业与功德，
    三世诸佛善愿力，众生罪业愿除净。
    汝之一切大痛苦，我皆代受愿清净。
    上师恩重如父母，毒害恩师实可悯；
    此业所招异熟果，我愿代受净汝罪。
    于一切时一切处，愿离罪业之伴侣；
    生生世世任何时，愿常伴遇善知识。
    不以恶业而聚财，亦不损恼任何人；
    愿尽法界众有情，皆发慈悲菩提心。
    操普听了尊者的歌以后，非常感动欢喜，对尊者说道：“我从前作恶的原因，大半都是为了钱财，我现在也无需任何财产了。尊者自己虽然不要，但是尊者的弟子们修行总是需要资粮的，请您替他们收下了吧！”他虽然这样请求，尊者还是没有接受。后来弟子们接受了，就把这笔财产作为集会供养之用。到了现在，曲巴地方还有这个集会供养。操普博士此后果然放弃他一生的贪恋，成为一个很好的修行人。
    尊者对弟子们说：“我所以要住在这里，就是要令这个大罪人真心忏悔从罪苦中解脱。如今此事已毕，我该要走了。本来大修行人在村镇中圆寂，就如同皇帝在平民家中死去一样，所以我要到曲巴去找死的地方了。”
    弟子色问惹巴就说：“上师啊！您老人家这样重的病，走去实在太辛苦了，我们去弄一个轿子来抬您走吧！”
    尊者说：“我不一定真是在害病，我死也不是真的死，只是示现病相、死相而已！用不着什么轿子。年青的徒弟们，你们先到曲巴去吧！”
    等到年青的弟子们走到了曲巴的时候，尊者早已在炽结崖洞等候他们了。许多年长的徒弟们说：“是我们伴随着尊者一起来的。”另一个人说：“尊者在毒龙顶窟上害病休息。”曲巴村后到的施主们却说：“我们看见尊者在著卡顶窟说法。”又有些施主则说：“是我们和尊者一同来的。”还有许多人却都说：“我们各人在自己的家中都有一个尊者前来承受供养。”那些最先从曲巴来的人就说：“尊者先到曲巴去的！是我们侍候尊者一起来的！”于是后来的，看见尊者说法的，和承事供养尊者的，大家各执一词，争辩起来，不知谁是谁非。尊者听了笑道：“你们都是对的，我之所以如此，不过是同你们开一开玩笑罢了！”
    尊者在炽结窟示现病态。那时天空中出现了像说法时一样的虹彩、花雨等瑞征。于是大家就知道尊者真的要到他方世界去了。寂光惹巴、雁总巴、色问惹巴等弟子就请问尊者说：“尊者涅槃以后，到哪一个净土中去？我们徒众们应该向何处祈祷？”
    尊者说：“你们随便在什么地方祈祷都是一样。只要有信心，虔诚祈祷，我一定会在你们的面前的。你们祈求的事，我一定赐给。
    “这一次，我要到东方现喜净土去朝礼不动如来。我从前曾提起过还有话对你们说，那就是我的遗嘱。我密勒日巴死后，除去极少的几件用品外，什么财产也没有。你们可将我的棉衣和手杖交给惹琼巴，他很快就会回来的，告诉他这两样东西与修气功的缘起有关。在惹琼巴没有到之前，千万莫要触动我的尸体。
    “这个主梅纪巴的帽子和沉香木杖，具有以善见善观而弘扬佛法的缘起，付给卫巴顿巴。这个木碗，寂光你拿去吧！这个灵盖，雁总顿巴给你吧。打火石给色问惹巴。这双骨头匙子给炽贡惹巴。把这块布垫子分成碎片，分给其他的弟子们，一人可以拿一片去。我这些东西并没有什么金钱的价值，送给你们的意义，主要的在显示缘起而已！
    “我最重要的遗嘱与我密勒日巴多生来聚集的金子，都藏在这个灶头底下。我死了以后，许多无识的弟子也许会因为我的后事而争吵，那时你们可以把那遗嘱打开来看。那里面还有指示你们修行的办法。
    “又有某些只有少量福德的学佛人，为了今生的名闻恭敬，表面上东做佛事，西做功德；实际呢，他供施一百，心里却想收回一千。这些贪求果报而行佛事的世俗人，就等于把毒药混在美味里进食一样。所以你们不应该为了今生的名闻恭敬而饮下这个‘好名’的毒药。那些表面上是佛法，而实质上是世法的事，你们都要彻底舍弃，一心精进，修行纯净的佛法才好。”
    诸弟子又请问尊者说：“如果对于众生有利益，我们是否可以行一点点世法？”
    尊者说：“行世法的动机，如果丝毫也不是为了利己，那是可以行的。可是照这样行，实在是太困难了。如果为了一己的贪欲而行利他，则自利尚不成，更谈不到利他了。就象不会游水的人去游水，不但游水不成，反而为水所淹毙一样。所以在没有证得实相空性以前，最好不要谈利生的事业！己无修证，就要利生，等于瞎子引盲人，最后终究要堕入自私的深渊中去。本来虚空无尽，众生亦无尽，自己修行成就了以后，度生的机会实在太多了；任何时间，任何地点，都可以度化众生。在未成就以前，你们应该以‘清净意’发‘大悲心’，为利益一切众生的原故而勤求佛果。放弃衣食名利的思想，身耐劳苦，心负重荷，如是修行才是。这就是度众生，也就是修行入道完成自他一切的究竟利益。我有一歌，你们仔细听着：
    敬礼马尔巴译师前，凡欲学佛修行者，
    若不依止具相师，虽有恭敬无加持。
    甚深灌顶若不获，执续部义徒自缚（密乘的经典统称为续Tantra）；
    不以续部为依准，一切作仪成谬误。
    若不修观深秘诀，舍世间法徒自苦；
    不能降伏诸烦恼，巧舌如簧皆空语。
    不明甚深方便道，虽常精进无利益。
    不明玄奥三要点，虽勇猛修路遥远；
    不集广大之福德，徒求自利轮回因。
    虽集福德不求法，勤修亦难成功德；
    知足乃是无价宝，远胜黄金千万亿。
    身内安乐若不生，寻求外乐痛苦因；
    爱名魔心若不除，终将自败惹烦恼。
    贪乐则为五毒恼，物欲终使慈悲离；
    骄傲自慢是非因，独居自无口舌灾。
    心离散乱修专注，寂处能邀胜伴来；
    安守卑下得上位，缓行偏能成速达。
    舍离诸事大事兴，守甚深道道速成；
    若证空性悲心生，悲心生处自他泯。
    无自他故能利生，利他事成重见我；
    由见我故成佛陀；我与佛陀暨佛子，
    无差别观应祈请。
    尊者又继续说道：“现在我不能再久住了，你们应该记住我的话，继持我的宗风！”
    说毕就入大定，示现圆寂。享寿八十四岁，于木鼠年（1135年）冬季末月十四日黎明，星光欲没，朝阳正升之时，尊者之色身入法界体性，显示涅槃之相。
    这个时候，天人空行集会的胜相，较前更为广大殊胜。空中出现广大鲜明的虹彩，这虹彩清楚得好象手都可以摸得着一般。各种颜色交织在空中，虹彩的中间有八瓣莲花的形象，莲花的上面，有极美丽的坛城；世界上最好的画家也画不出这样美丽的坛城来。尖端的五色彩云，变成胜幢、缨络、宝幡等无尽的形状，各色各样的花朵自天而降，纷落如雨。彩云缭绕在四周的山顶。宝塔状的云朵向曲巴的中心围拥着。大家都听见悦耳的天乐和赞语。异香流溢大地。世间的俗人也都能看见天人神像满驻虚空，行广大的供养。人们看见天神们赤身裸体亦不以为怪；天神们却个个都怕嗅着人体的臭味，碰见了人常掩面而过。有的天神和人互相谈话招呼。人人都看见这种种的稀有奇迹。


荼毗法会

    鸭龙的施主们，听见尊者已入涅槃，都跑到曲巴来，对诸大弟子和曲巴的施主们陈述了很多的理由，要把尊者的遗体请到鸭龙去埋葬，却被尊者的大弟子们拒绝了。于是鸭龙的施主们要求暂缓举行大礼，给布林以及各地的信士们一个最后的机会，来瞻仰一次尊者的圣容。曲巴的施主们答应了这个要求。鸭龙的人便回去紧急集议，结果带了一群勇武有力的人来准备抢走尊者的遗体。遂与曲巴施主双方争吵起来，骚乱得几要动武。大弟子们看见这种情形，立刻对他们说道：“大家都是尊者的信徒！请不要争吵。尊者既然在曲巴涅槃了，当然不合在鸭龙举行大礼，请你们在此地等着，大礼举行完毕后，你们一定可以分到尊者的舍利和骨灰来供养的！”但是鸭龙的人们仗着人多，不肯听话，仍要准备硬抢。忽然空中出现了一个天神，口中发出尊者的声音，唱道：
    在此集会诸徒众，毋用争辩听我歌：
    我乃尊者一学子，专为排难解纷来。
    密勒日巴圣者心，已入无生法界性；
    惟圣者心为真身，除此更无他真身。
    应身溶入法身时，物所聚身复何用？
    若于此义能通达，宁因腐尸起争纷！
    可怜汝等尽愚痴，为此朽尸作争持；
    斗争辩驳焉能决？殷勤祈祷乃可得。
    若能专心作祈祷，无生法身纵难证；
    亦为大悲宏愿摄。随顺不同之缘起，
    变成无尽之化身；定住尊者悲护中。
    歌声甫毕，空中天神像虹光一样的消逝不见了。施主和徒众们如同又见到尊者一样，说不出的欢喜和高兴，大家都不再争吵了，就一心一意的祈祷。终于在不可思议的幻化中，除诸大弟子和曲巴施主们保有原有的遗体以外，鸭龙地方的人民却也得到了另一具尊者的遗体，他们就抬着这个遗体，到那其雪山的大鹏蛋窟的顶上举行火葬。空中又出现了与前次涅槃时一样的五色虹光、彩云、天乐、异香和其他种种的奇征。
    在曲巴这一边，诸大弟子和施主们连续的至心祈祷了六天，尊者的面孔忽然容光焕发，年青得好象八岁小童一般的模样。这时几个大弟子就议论道：“惹琼巴恐怕不会来了。如果我们再延迟的话，可能什么都留不下来了。甚至一点供养的骨灰都拿不着了。我们还是赶快举行火葬吧！”大家商量以后，就依次作最后一次的尊者的圣容瞻仰。同时把圣体移到炽结窟前面的法座崖上，并架起火葬的台子，然后把圣体安放在台上，划好坛城。虽然比不上天人的供养，却把人间最好的供品陈列起来。在黎明之际，举行了各种祈祷与仪式，大家就想举行火葬。但是无论如何，火总点不起来。在这当儿，天空中忽然出现一道虹彩，带来了五个空行母，齐声唱道：
    智慧拙火圣者火，瑜珈行者常修故；
    何用世间业火薪？
    即此肉身本法身，常修本尊佛陀故；
    岂留肉身之腐尸？
    本尊庄严之坛城，身中瑜珈早圆满；
    何用绘画之坛城？
    心气不二拙火灯，尽未来际得长明；
    何用汝等泥油灯？
    胜妙受用五甘露，昼夜恒常享受故；
    汝设食品为谁供？
    身着持戒清净衣，二障习气咸净涤；
    汝持净瓶欲谁洗？
    香云华盖虚空遍，坛城香溢妙庄严；
    汝等世间愚痴辈，引火爇香欲何为！
    四方空行启妙声，智慧佛母歌法音；
    汝等世间愚痴辈，唱念仪轨欲谁听！
    恒沙持明皆围绕，亿万勇父作祈祷（密乘的修行人统称持明，这里指像恒河中沙那么多的密乘修行人）；
    汝等世间愚痴辈，喋喋咻咻欲何为！
    彻证真如实相士，遗体任意可处置；
    人天福田共依处，何用尔等为守护！
    上师尊前发宏誓，依誓行事免祈请；
    尊者遗体如宝藏，勿劳守护任自然！
    上师佛陀有密语，何用汝等饶舌为？
    口诀秘密空行持，静处独坐闭关修。
    终身勤修之传记，违缘虽多得成就；
    依从希有父传诀，当得成就定无疑。
    至尊密勒日巴传，勿劳汝辈为宏传；
    是乃智慧空行歌，具大加持应雀跃。
    密勒子传承继者，成就无量如大海，
    善根弟子如群星。此方他方所有地，
    人畜无病常吉祥。今日在此集会众，
    将不堕落诸恶趣；愿证真如大坛城，
    心境一如忘二执。尊者今日之涅槃，
    具大义利应生信；依尊者教如法修，
    速疾能得究竟乐。
    于是雁总惹巴就说：“尊者的遗训和几位空行的歌词，都教我们在惹琼巴没有到以前，不要触动尊者的遗体。但是惹琼巴到现在还不来，恐怕不久遗体要腐烂了，怎么办呢？”
    寂光惹巴说：“从尊者和空行的训示，以及火烧不着遗体的种种因缘看来，惹琼巴一定很快就回来的。我们还是恳切祈祷吧！”大家把圣体移回洞中，都又一致恳切的祈祷。
    却说，惹琼巴那时正在罗若多寺修法。一天晚上的后半夜，在光明与睡眠混然一体的觉受中，他看见在曲巴地方，有一座水晶塔放出了周遍虚空的光明；无数空行拥着这个宝塔，迎请着向他方世界去了；地上到处都是自己的金刚兄弟和尊者的施主们。天神与空行的歌声响遍了天空，到处都是不可思议的大供养云。惹琼巴就向宝塔顶礼，忽然间尊者的面庞从宝塔中现了出来，对惹琼巴说道：“儿啊！虽然你没有照我的话及时赶回来，但是如果我们父子能够再见一面，我是非常快乐的。你我父子今后恐怕不能常常见面了，不要再失去这难得的机会，让我们父子好好的谈一次话吧！”说完了，尊者就把手放在惹琼巴的头上，满面含笑的看着他。惹琼巴心中又悲又喜，生起前所未有的信心和稀有难得的感觉。
    惹琼巴醒了以后，想起了尊者从前对他说过，要他在某时回去的话，心中大为惊惶道：“难道尊者涅槃了吗？”顿时生起难以忍受的悲哀和猛利的信心。乃一心向尊者祈祷道：“上师啊！我没有及时赶到，真是后悔哟！但是我马上就要回来了！”正想间，空中出现了两个少女，对他说道：“惹琼巴！尊者要到净土去了！你要不赶快走，恐怕今生再也看不见尊者了！快点走吧！”
    惹琼巴这时心中专念着上师，归心似箭，立刻就起身回去。罗若多寺的鸟雀，这时正在吱吱的报晓。
    惹琼巴一心祈祷上师，一面运起气功，如箭驰一样的飞来。驴马须走两月的路程，半个早上就飞过了。到了亭日和布林交界的钵赛山顶时，天才大亮，太阳刚刚出来。他就坐下来，稍微休息了一下。抬头一望，到处都是祥云异彩；特别是尊者入寂的山顶上，有一个广无边际的大云伞盖，放出万丈的光芒。无数天神、空行正在以五欲供云大兴供养。有的天人在祈祷，有的在发愿，有的在礼拜，有的在唱着赞美歌。惹琼巴见了，心中又悲又喜，怀疑地向一个天神问道：“你们这样供养礼拜，是为的什么呀？”
    天神答道：“你这个人难道耳聋了么？眼瞎了么？这样人天兴供的非常缘会，你都不知道吗？这是密勒喜笑金刚大士到空行刹土中去，天人大众对他都在供养祈祷，难道你不知道吗？”
    惹琼巴听了这个话以后，心如刀割，向尊者入寂的山窟处飞跑而来。跑到曲巴一处像宝塔形状的平地时，像作梦一样，看见尊者满面含笑的向自己说道：“是不是我的儿子惹琼巴来了啊！”
    惹琼巴一见，心中说不出的欢喜，以为尊者并没有涅槃，连忙上前顶礼尊足，祈祷问安。惹琼巴又向尊者问了许多的问题，尊者都回答了。最后尊者对惹琼巴说：“儿啊！我先走了，你随后来吧！将来我会来接你的！不要忘记我的话呀！”说完，忽然一刹那间，尊者就不见了。
    惹琼巴心中七上八下地向曲巴赶来，到了尊者入灭的山窟前，看见徒众施主们正在尊者的遗体旁边悲哀地祈祷环绕。有许多新来的徒弟们，他们从来没有见过惹琼巴，就阻挡住不要他进洞走近尊者的遗体。惹琼巴心中说不出的哀痛，痛哭流泪，唱了一只七支供养歌：
    三世诸佛的悲心，十方众生的依怙；
    我恩重的慈父上师啊！
    您那无缘大悲的心智中，难道听不见徒儿的哭诉？
    您那无缘大悲的心智中，难道不悲悯您徒儿的痛苦？
    唉！我慈父的上师啊！
    停了一下，惹琼巴又继续唱道：
    如今父子成死别，我心恻恻不胜悲；
    为瞻尊者遗容故，无福弟子来朝谒。
    大悲上师宁不见，慈父见儿宁不悯？
    大慈大悲雄力父，无异三世诸佛陀！
    弟子三门敬礼赞，如教修持为供养；
    罪业邪见我忏悔，所有善业皆随喜。
    请转甚深妙法轮，哀求住世莫涅槃；
    一切修行所作善，回向能满上师意。
    愿此回向得圆满，令我下劣恶根者，
    得睹尊者之遗容。
    昔为尊者之爱徒，如今不能见师颜；
    虽无现前谒师福，愿见上师之遗容。
    由见尊者遗体故，愿生亲见之觉受；
    修行二种次第时，愿赐除障之口诀。
    我此悲痛之祈请，尊者慈心宁不护？
    不悲弟子复悲谁？愿父无缘大悲钩；
    恒常钩摄勿舍我，平等性中常悯我！
    薄慧劣根惹琼巴，慈父三世慧眼视；
    五毒所恼惹琼子，慈父五智慧眼视；
    一切众生祈勿舍，悲视汝子惹琼巴。
    惹琼巴的歌声刚一传进洞去，尊者的遗容突然大发光彩，面貌如生。尊者的遗体忽然自己生起火来。寂光惹巴、雁总顿巴和各大弟子施主们一听见惹琼巴的歌声，都赶快出来迎接。但是惹琼巴因为新来那些弟子不认识他，不要他进去，心中非常难过，所以没有立时进去。等唱完了七支供养歌之后，才走进洞内。因为惹琼巴热情和至诚的歌声祈祷感动了尊者，虽然尊者已经趋入了光明法性的大涅槃，这时又从光明而起，坐了起来，对那些新来的徒众们说道：“你们初修的徒众啊！莫要这样做！惹琼巴是人中狮子，你们应该敬重他。”又对惹琼巴说道：“儿啊！你不要这样难过，到你父亲的身旁来吧！”
    大家见了这种奇迹，都惊叹不已，心中生起无量的欢喜。
    惹琼巴马上走到尊者遗体的前面，抱住尊者放声痛哭。因为过度的悲伤，惹琼巴竟晕倒在地上。等到他醒转来的时候，看见徒众施主们都环绕在祭坛的周围，尊者的无垢金刚双运身并没有倒下，在八叶莲花形的火聚中，安稳的坐着，尊者的身体就好象花朵中的蕊一样，坐在八瓣莲花的熊熊火叶之中，右手持说法印下垂压于火尖，左手托住面腮，作唱歌的姿态，对着惹琼巴和众弟子们说道：“你们听我这个老人的最后一个歌吧！”就在祭坛上唱了一首六种心要歌：
    我之爱子惹琼巴，听我遗嘱最后歌：
    三界轮回火海中，五蕴幻身是关键；
    贪着衣物事奔走，世事永无了结期；
    舍世法兮惹琼巴！
    于此幻化身蕴中，无体自心是关键；
    此心若为身所使，法性实相永难证；
    善持自心兮惹琼巴！
    心物取舍之微义，本来智慧是关键；
    追逐变化诸缘起，永难得证无生义；
    善观无生兮惹琼巴！
    此生他生之取舍，中阴心识是关健；
    常伴有身或无身，永难得证实相义；
    善观实相兮惹琼巴！
    六道迷乱无明城，罪障恶业如山聚；
    贪瞋烦恼不除灭，永难证入平等性；
    舍贪瞋兮惹琼巴！
    万千诸佛刹土中，诸佛善巧说似法；
    若依权巧相似理，永难解悟究竟义；
    舍权教兮惹琼巴！
    上师本尊与空行，作一体观而祈请；
    正见胜行与正修，三无差别而修行；
    此生来世与中阴，作一体修而熟谂。
    我今传汝最后诀，此为最后之遗言；
    舍此更无他心传，依此修行是我子。
    尊者说完最后的教训，又趋入光明法性之中。尊者刚一圆寂，祭坛就放出光明，变成一个四方形的越量宫，种种光明伞盖、彩霞、宝幢等丰盛的供养，无尽庄严。光明中又化现出无数的天女，在美妙的音乐中唱歌起舞。在祭坛上的虚空中，天子和天女捧着满盛甘露的宝瓶为尊者供养。徒众和施主们，有的看见祭坛中尊者是喜金刚，有的看见尊者是上乐金刚，或密集金刚，有的看见是金刚亥母，依各人的因缘根器不同，各各看见不同的佛身。
    这时，遍满虚空的无数空行，一齐同声唱道：
    如宝至尊入灭时，人天大众同此悲；
    或乃痛哭泪如丝，或乃眩蹶不自持。
    自生之火自燃烧，焰作八叶莲花形；
    具有七宝八吉祥，如意斋供万千现。
    琴瑟管弦诸乐具，演出无量众妙音；
    火中化出众天女，陈献广大内外供。
    妙香环绕气氤氲，宝伞雨盖与华鬘；
    吉祥天女为献供，奉骨归去有净身；
    蕴身不留一微尘，上师遗骨稀有甚。
    法身若与虚空等，悲愿报身如法云；
    化身事业如花雨，无尽成熟诸有情。
    法性空寂本无生，此中既无可生者；
    空性亦离生灭相，生灭亦即是空性；
    于此甚深‘空有’义，幸勿有疑生谬见。
    空行们唱完了这只歌，时间已近黄昏，天渐渐地黑了，祭坛上的火也已熄灭。但是祭坛内外却是一片透明的光。徒众们觉得非常奇怪，向祭坛里面看，原来在祭坛的中央，出现了一个光明的宝塔。宝塔的中央，有人看见上乐金刚，有人看见亥母或喜金刚，有人看见金刚铃、杵、宝瓶、手印、身、口、意的种种字形。有人看见一片金色的光明，有人看见一片海水，或一团烈火，也有人什么都看不见。
    徒众们于是打开祭坛的门，让热气散发，以备第二天来取舍利子。这时又出现了许多不可思议的异征。当日晚上，大家都把头朝着祭坛的门，在地下睡着了。次日一早，惹琼巴刚刚醒的时候，看见五部空行母们拿着缨络骨饰众宝庄严及种种五欲供养品，进入祭坛来行供养。一会儿，看见五个主要的空行母，从祭坛中捧着一团光明的东西飞了出去。惹琼巴正看得出神，忽然想起，必是空行母们把尊者的骨灰舍利子拿走了，心中一急，连忙赶出来，这时空行母们已经捧着舍利，腾在空中。惹琼巴立刻回去把所有的师兄弟喊醒。大家打开祭坛的门，向里面一看，连一颗舍利子都未留下！惹琼巴悲痛忧伤万分，就请求空行母慈悲分一点舍利子给人间的弟子们。
    空行母说道：“你们这些大弟子们，已经得到了最殊胜的舍利，亲见法身了，如果这个还嫌不够，可以祈请尊者，尊者自然会给你们的。至于其他的人们，比起光明如日月的尊者来连萤火虫还不如，这些人给他们舍利子作什么？这些舍利子是属于我们的。”说完就停住在空中不动。徒众们听了空行母的话后，大家一想，这个话说得不错，心生懊悔，殷切的祈祷道：
    至尊依止上师时，敬信如教而行故；
    获致甚深了义诀，成就有缘令解脱；
    愿赐舍利作福田，一切众生求悯怜。
    至尊山窟独居日，断离贪着精进修；
    现得神通大成就，名称普耀于十方；
    愿赐舍利作福田，悲护所有见闻者。
    至尊摄受弟子时，亲疏普及无偏私；
    神通智慧复何限，善巧慈悲利生衍；
    愿赐舍利作福田，悲悯有缘诸弟子。
    至尊莅止诸法会，广大慈悲恩普盖；
    一切有缘令解脱，悲摄业重者为最；
    愿赐舍利作福田，悲摄我等诸蒙昧！
    至尊舍此幻身时，示证空行大成就；
    化现象界成法身，一切空行尊为首；
    愿赐舍利作福田，与会弟子咸蒙悲。
    大家这样悲痛殷切的祈求以后，就看见空行母的手掌中放出五色毫光，尊者的舍利子大如鸟蛋，降落在祭坛上。弟子大众看见舍利子降下来，都伸手想去拿，舍利子忽然又飞到空中，重新溶合到空行母掌中所发的毫光里去了。忽然毫光又分为两道，一道变成为日月座垫的狮子座，另一道变成一座内外透明的琉璃宝塔，塔中放出红、白、蓝、黄、绿五色光明，遍照三千大千世界，由一千零二尊佛四周围绕着，中间端坐至尊密勒日巴。亿万空行海会云集，供养赞叹，有两个天女在塔的下面捧着宝塔。尊者密勒日巴唱道：
    徒子乐获与寂光，雁顿总巴等弟子；
    具足善根诸惹巴，诚心祈祷呼我名。
    舍利本是福田因，为众有情而施舍；
    若由至诚祈祷力，能见三身三舍利；
    则能不堕诸恶趣，若生信心当成佛。
    法身明彻本一味，舍利乃是佛因依；
    我与我所尚不得，何有彼境及彼住？
    法尔真理虽如是，然尔至心所祈祷；
    诸佛大悲定摄受，此是如来三昧耶。
    上乐父母本尊佛，尸林骨饰为庄严；
    坛城遍满大虚空，勇父空行法云绕；
    圆满受用智慧尊，灌顶当得速成就。
    若能于彼勤恳祷，当得不思议加持；
    此是空行三昧耶，法身事业能成办。
    万千化身随意观，于此琉璃宝塔周；
    显教千佛作围绕，密教本尊四部现。
    现前降临甚希有，若得诚心作祈祷；
    事业广大自然成，此是护法三昧耶。
    上师三身本无别，能现不思议神变；
    小中能显广大境，如是神变甚希奇。
    若能一心而恳请，当得殊胜大成就；
    此是一切成就者，誓语金刚三昧耶。
    若能善持密宗戒，一切具誓赐成就；
    若能独自山中修，空行慈母常围绕。
    于法若无谄媚心，身当速得成就相；
    内心若不贪欲乐，烦恼根本立时断。
    若不执我不执物，鬼魔障难即时除；
    若不执着宗派见，一切见解自清净。
    若了生死本来空，一切修观自清净。
    内心持戒若有恒，一切所行悉清净。
    若得上师之授记，一切誓戒皆清净。
    若能利益诸众生，一切果利悉清净。
    师徒心意如合一，一切因缘悉清净。
    若见成就殊胜相，心境自然生净信；
    维护禁戒得暖相，汝等徒子应受持。
    尊者说完了，空行母捧着宝塔，便准备迎请尊者到空行刹土中去。这时寂光惹巴心中想道：“我应该为人间众生福田计，恳求空行母赐下这个宝塔，作为人间弟子供养之用。”就哀痛迫切的祈请道：
    上师慈父应化身，圆满受用瑜珈士；
    法性无生普遍满，祈请至上法身前！
    空行手中之宝塔，恳祈赐予我徒众。
    若欲朝觐获加持，礼拜师尊即成办；
    无价之宝瑜珈士，祈请究竟清净者；
    空行手中之宝塔，恳祈赐予我徒众。
    供养承事师尊时，即能回忆上师教；
    普利一切瑜珈士，具大悲者我祈请；
    空行手中之宝塔，恳祈赐我徒众辈。
    至尊舍弃世法时，一如明王大仙人；
    坚不动摇瑜珈士，祈请雄毅大勇者；
    空行手中之宝塔，恳祈赐我徒众辈。
    依师口诀修观时，尤如猛虎食人肉；
    无有疑义瑜珈士，祈请雄毅大勇者；
    空行手中之宝塔，恳祈赐我徒众辈。
    无人崖洞独居时，一似铁制无缝石；
    无有转变瑜珈士，圣心不动我祈请；
    空行手中之宝塔，恳祈赐我徒众辈。
    至尊显现神变时，犹如狮子龙象舞；
    无所恐怖瑜珈士，离诸畏惧我祈请；
    空行手中之宝塔，恳祈赐我徒众辈。
    觉受暖相生起时，犹如十五月正明；
    遍满世界瑜珈士，无偏袒爱我祈请；
    空行手中之宝塔，恳祈赐我徒众辈。
    至尊遇有财物时，弃如水银之泻地；
    不染浊气瑜珈士，离过失者我祈请；
    空行手中之宝塔，恳祈赐我徒众辈。
    至尊莅止法会时，有如太阳照大地；
    世间黑暗顿时消，具悲智者我祈请；
    空行手中之宝塔，恳祈赐我徒众辈。
    师往空行刹土时，如妙宝瓶赐成就；
    随愿成办瑜珈士，大希有者我祈请；
    空行手中之宝塔，恳祈赐我徒众辈。
    师以神通授记时，视未来事如掌物；
    略无谬误瑜珈士，具三世智我祈请；
    空行手中之宝塔，恳祈赐予我徒众。
    至尊赐我成就时，有如父传宝与子；
    永无二语瑜珈士，具大悲者我祈请；
    空行手中之宝塔，恳请赐予我徒众。
    寂光惹巴祈请之后，宝塔中的尊者就回答寂光的祈祷，唱了一只辨了不了义歌：
    噫嘻善根具信人，至心悲切祷告诚；
    稀有惹巴我徒子，听我密勒为汝歌：
    我之法身遍一切，空性本离得与失；
    色身趋入法性故，出生世俗之舍利。
    独一舍利放光芒，为诸众生集资粮；
    往生净土所依故，五部空行为守护；
    天人神众为供养，若留人间终毁灭。
    汝等善根诸弟子，证得自心法身后；
    已具最胜之舍利。修行道上多慎思，
    何用世俗舍利为？执着相似即违道，
    切记斯语勿忘之。
    依止汝父具相师，与依具足福德者；
    表面相似实不同，二者差别应当知。
    心性显现本来空，着意修成无念境；
    表面相似实不同，二者差别应当知。
    修观本来现成性，较之修定习等持；
    表面相似实不同，二者差别应当知。
    法尔任运之显现，千奇百境妄心见；
    表面相似实不同，二者差别应当知。
    无染心性自显现，修善作福取舍心；
    表面相似实不同，二者差别应当知。
    缘起事上显成就，纷扰福德之作业；
    表面相似实不同，二者差别应当知。
    慈母空行之授记，以及魔鬼之招使；
    表面相似实不同，二者差别应当知。
    无垢法身之舍利，以及物质舍利子；
    表面相似实不同，二者差别应当知。
    法性化现之花朵，欲界天人所降花；
    表面相似实不同，二者差别应当知。
    佛陀示现之宝塔，魔鬼化身之窣波；
    表面相似实不同，二者差别应当知。
    显有光明示彩晕，四大缘起所生虹；
    表面相似实不同，二者差别应当知。
    往劫因缘所生信，遇缘临时之信心；
    表面相似实不同，二者差别应当知。
    内心深处之信心，责任羞愧所生信；
    表面相似实不同，二者差别应当知。
    至诚真实之修观，取悦上师之修行；
    表面相似实不同，二者差别应当知。
    所求立赐于掌中，口头允许如空风；
    表面相似实不同，二者差别应当知。
    空行慈母之宝塔，即是三世诸佛刹；
    勇父空行之宫殿，至尊上师之修室。
    我在东方现喜刹，无量空行围绕处；
    上乐金刚薄伽梵，大悲观音与度母；
    无量佛陀菩萨众，诸圣大士所游止。
    汝等若能一心求，默然饮泣而祈祷；
    毫无虚饰勤礼拜，投掷锐利智慧花。
    甘露洗涤菩提心，无转信心善守护；
    不二智慧得灌顶，是为成就之初征。
    歌声一住，空行母捧住宝塔，飞到诸大弟子的顶上，宝塔忽然放出许多道毫光，每一个弟子的头顶上也都有一道光照射出来。大家都看见宝塔中央的尊者腾入空中，变成喜金刚、上乐金刚、密集金刚、至尊母坛城、无量佛陀，为空行母所围绕。最后诸佛菩萨皆化成光明，溶入尊者的心间。在天乐齐鸣中，尊者被迎请到东方现喜刹土中去了。
    有的徒弟看见尊者报身庄严，坐狮子座，四部空行捧送，金刚亥母导引，于不可思议天乐供养云中，往东方现喜刹土中飞去。
    诸大弟子看见尊者已经悄然飞去，无法取得舍利供养，于是大家都嚎啕大哭，悲哀祈祷。忽然听见空中尊者的声音说道：“徒儿们啊！你们用不着这样的悲伤，在崖石的下面找到四个字的铭训以后，你们就会发现供物的。”于是大家就在崖石的周围四处找寻，果然发见了铭训。这个崖石，现在在曲巴寺还可以见到。
    诸弟子看见尊者已经到他方世界去了，心中虽然十分悲伤，但是都知道将来一定可以往生尊者的净土，同时也明白尊者的一切示现，都是为了佛法和众生的原故。大家都抱着献身二利事业的决心，来看尊者的遗嘱和灶下面的金子究竟是怎么回事。
    大家虽然知道尊者决不会埋藏什么金子，但是为了遵守他的遗训，大家都到灶下面去看个究竟。果然在灶下发现有一块棉布，里面包着一把小刀，小刀的刀口还很锐利。刀柄上并且系有一个椎子，此外还有一小块糖，和磨刀石一同包着在布里。他们仔细一看，在刀上面还刻有几行小字：‘用这把刀，切这块糖及割这块布，它们永远都不会被切完的。你们就这样把糖和布切了分给所有的人；凡是吃了这个糖，或分到这块布的人，便不会堕入三恶道了。密勒日巴的三昧食和衣服，是上师和诸佛都加持过了的。若有众生，听见我的名号，生一念信心，在七生之中，也决不会堕入恶趣，并能忆念七生之事。此是诸佛菩萨之授记。如果有人说密勒日巴有金子，那人就应该吃粪。’诸弟子们在极端悲伤中看到了这个遗嘱的最后一句，实在忍不住大笑起来，他们皆大欢喜。又继续的念最后一段话！那是一首歌词：
    此乃行者三昧食，具二成就大悲食；
    若有幸运尝此者，必不堕入恶鬼趣。
    此布拙火智慧衣，若有幸运佩带者，
    必不堕入苦地狱。一切得我加持者，
    必能不堕三恶趣。一切有我法缘者，
    永不堕入三恶道；渐次必能成佛陀。
    若有闻我名号者，生一念信诸众生，
    能忆过去七生事。密勒日巴大丈夫，
    已转三界为黄金；黄金珠宝何用为？
    我徒遵行我训示，现前以及究竟利；
    凡有所求皆成就。
    于是大家就用刀来切糖，的确无论切多少次，那块糖还是切不完。布也是一样，割了许多次，原来的一块布丝毫也不减少。这样无穷尽的切去，大家都分到了布和糖。许多患病的人，吃了糖以后病立刻就好了。下根烦恼重的人，吃了糖之后，慢慢地智慧增长，慈悲也增多了。
    在举行葬礼会供的时候，天上降下五色的鲜花。这些花降下来的时候，大半皆在离人顶不高的地方就融化不见了。有的花落到地上的，拾起来看，却跟蜜蜂翅膀一样的细薄，美丽异常。
    在曲巴村一带，降下来的天花遍满大地，堆到足膝一样高；其他附近的地方，花朵也如下雪一样，降下了很多。等会供仪式完毕后，各种异征奇彩就慢慢的消失了。
    以后许多年当中，每逢纪念尊者的日子，天空中就现出长虹，降落花雨，鸣奏天乐，飘散异香，生出种种的奇迹来；同时地上也长出许多不同的奇花，年岁丰稔，人无灾病，也没有战祸。这种种奇迹，说也说不完。


结 语

    尊者涅槃之后，他的那些已登不退转地（即登地以上入圣者流的菩萨，已得永不退转，不为烦恼业力所使，能破一切障难，直趋菩提）以上的大弟子们，为了要使密勒日巴大师的事迹和教训永留人间，普利一切有情，令所有见闻者皆发大菩提心，趋向佛道究竟正觉，特将尊者一生事迹和法语，记录下来，并广为流布，希望一切恒沙世界的众生，早日脱离生死苦海，超登无住涅槃彼岸。
    尊者每次要遇见他的徒弟的时候，多是先由空行母事前授记。譬如他遇见寂光的时候，事前就在梦中授记。
    尊者有两大弟子，一个是如日轮一样的仰妹达波冈波巴，一个是如月轮一样的贡通惹琼巴。另外有如明星一样的雁总顿巴菩提胜王、寂光惹巴、色问惹巴、喜惹巴、炽贡惹巴、佛护惹巴。一共八个如心的弟子。又有现贡惹巴、领贡惹巴、妹贡惹巴、咱铺惹巴、卡琼惹巴、若琼惹巴、倒贡惹巴金刚自在、觉贡惹巴打马网去、觉巴甲普、领各下惹哇、罗顿格顿、觉顿释迦古那、则顿札喜巴等十三个亲近的弟子。心子冈波巴及最后五个亲近弟子都是出家比丘。大女弟子有鸭龙的萨来俄、错思的惹琼玛、宝地的罢打马和尊者的妹妹琵达四大弟子。其他还有二十五个得究竟成就的女弟子，结波惹巴等如星弟子（此处所谓‘如星’乃指低于日、月，所谓如日，如月，如星也）；得见实相自心本来面目，得不退转地者，为数一百。得殊胜觉受暖相增长之弟子一百零八。舍弃世法，一心修行，与道相应之弟子，为数一千。结得佛法之善缘，永离恶趣之弟子，不可数计。非人弟子，有长寿王空行母及领哇普生玛等善神无量无边。于是，人间的弟子们，在尊者涅槃众会完毕之后，都依着他的教训，到各处深山寂静之处，终生从事修行。
    惹琼巴拿着尊者赐给冈波巴的东西，到卫地去找冈波巴大师。冈波巴虽然迟了没有赶上尊者的涅槃胜会，但是上师的加持正使他也向曲巴行来，因此在半途中他们俩就互相见到了。惹琼巴就把梅纪巴的帽子和阿嘎惹手杖交给冈波巴，又将尊者入灭的经过告诉了他。冈波巴一听，悲伤得昏了过去。醒来以后，唱了许多祈请上师的歌。这些歌词，都存在冈波巴大师的传记中。
    冈波巴就迎请惹琼巴到他的庙中去。同时惹琼巴把上乐耳传的教授，全部都传给了冈波巴。
    惹琼巴随即就又回到罗若多寺去修行。最后，他即以肉身飞到空行刹土中去了。
    寂光、喜惹巴、惹琼玛、萨来俄等弟子也都即身飞入空行刹土。至于其他的弟子，也都于圆寂时，往生空行刹土。那些把自己肉身飞入空行刹土的固然希有难得，就是临终往生的弟子们，也有种种的神异，留下许多舍利子，为佛法和众生作了广大的利益。
    以上就是至尊喜笑金刚密勒日巴从最初作世间法到最后入涅槃，一生一世成就无上正觉的传记。
    愿此稀有殊胜的传记，能感化一切有情，趋向佛道，成就自利利他的究竟事业。
    至尊密勒日巴传，放出无量大光明；
    显示无上诸佛法，圆成众生一切愿；
    人间供养此最胜。一听诵读尊者传，
    信心恭敬自然生；并发坚决出离心，
    能断烦恼与罪障。我愿此传广流传，
    普及一切四天下；感应默化弘正教，
    庄严佛法及道场。
    为撰此《至尊密勒日巴传》，余曾搜罗有关尊者各种传记，悉心考校并请诸不共弟子们口述尊者事迹，亲为记录，最后择要去繁，编成此传。
    游行尸林骨饰庄严瑜珈者，木星年秋月初八日，于诸空行母会聚雪山胜地，圆满完成此书。愿以此功德，于轮回未空之际，普利一切众生，增长一切佛法！吉祥，如愿成就。

一九五二年十月十一日（壬辰年八月十一日）正午时译毕
张澄基时于美国旧金山