目录

莲师教言集


极微心要口授

极微心要口授
    敬礼上师！
    卡珍之措嘉妈自八岁侍化邬金莲师，如影随形。时大师欲离藏土赴罗刹地，吾·卡珍妈供金与松石曼达，并转会供轮已，白言：大师！汝正往调伏罗刹众，吾则留藏土，纵吾侍大师多年。但将来命终之时并无把握。特此恳请师教授，撮而为一，乃易于修习者。大师答言：具信至虔具德者，谛听！从身要有甚深诸点，宴坐放松，自觉任运。一切皆只此矣。从语要有持气持明等法，无言住于声哑。一切皆只此矣。从心要有守意、任运、舍弃、融入、内视等诸要，一切皆只住于大自然、游戏自在、别无散乱。然心于此并非寂灭。若念无欤？如阳焰亦续照耀，若念有欤？无表色、形色即为空与完全觉醒----此为汝心本性。得了此体，再加保任，即为“见”。住于此境不乱、不守不散，即为“修”。于此境地，对六入无执无染、无取舍、无期望或恐惧，即为“行”。一有迟疑，即祈请上师。勿住市集，修于静处，放下此生最依附之执着及连系最深之人而修。以此，身纵是凡相、心已与佛无二。
    于死之时，如下而修。地收入水，身形变重而自不支。水收入火，口鼻干涸。火收于风，身热变无。风收于识，呼如风吸如喘。于此之时，感重山所压、困于黑中，跌入虚空。又伴以巨响无余震，漫无强光如展绸缎。再者，汝心自现寂静、忿怒与半忿怒诸尊，多首者充满空虚。住于虹光蕴中。手持武器呼言：“打、打！”“杀、杀！”“、！”“呸、呸！”等怒言。又有如百万日照之强光。于此之时，汝内本尊将促促汝觉，言：勿散乱…勿散乱！汝内魔障则纷扰诸境，使其破坏，并以尖刺声欲使汝乱。于此之时应知：被压者非为山压！此四大分离故也。勿惧！困于漆黑亦非黑，五蕴分离故。跌于虚空亦无一跌，身心分离心失所依故，而息已断矣。虹光骤现为心之本然示相，寂忿诸尊亦为心所显现，一切光均为自光，无疑。一有疑即堕轮回。了知一切为自现显，觉而住于光明空性中，只以此即可证三身而得悟。若能此则纵投轮回亦不能矣！内心本尊为不乱观照之现所持心。自此刻起，最要为无求无惧、染着或实执。对六尘、心境、喜忧等皆然。于即时起，若能得定，则可于中有住本性而得证悟。故于此刻起，无散乱修持保任是为重要。内魔则为现前之无明、疑与惑。于其时也，一切音响、色彩、光等可怖境之出现，勿迷、勿疑、勿惧、纵须臾有惑，即流浪轮回，故应得定也。
    于此时，胎门示若宫殿，勿为所引，此为至要！勿着期望与恐惧！吾可实言可免再生而得证悟。
    于此，非有佛之加持也。汝之觉性本自证悟，亦非有地狱之祸。执着任运清净，轮回之怖与涅槃之翼，连根而断也。觉悟者，犹如无渣之水、无杂之金与无云晴空。既为已之故，得如虚空法身，为众生故，而遍满虚空。为他得化报身，以意所及饶益有情。
    若本教授向重罪者，如杀父母者诵三遍，亦不致堕进轮回，于能证悟无有稍疑。
    纵人受各甚深法，若无如此教授，则仍远也。以不知将流转何处故，应恒常修此法。
    汝应将此法传与具大信、勇猛精进，并大根器者，能恒念其师。于口授具信，投入修持，心安忍及出离世法者。以上师托付之印、本尊秘密之印及空行付嘱之印同授。吾莲华生，虽曾于三千六百寒暑中事无数上师，向彼求法、受法、研习、说法、修及行，吾不曾见有法深若此者。吾即赴罗刹土，汝应照此而修。母，汝将于本尊土中成就，故故应恒持此法。说已，莲师骑日之光往罗刹土，以此，措嘉母得解脱。故将此法结集藏作宝库，并立下此愿：于未来世，将付与咕噜多杰乐宁巴，由此利益众多有情。此圆满圣极微心要口授，应死时及中有自解脱之问而答。
    沙玛也，秘，秘，秘。
    摘于〈〈历代龙多丹增桑布活佛略传〉〉色达喇荣五明佛学院


金刚上师莲花生大士密咒利益

金刚上师莲花生大士密咒利益
-----莲花生大师教言伏藏

    移喜磋嘉佛母 藏岩
    嘉玛宁巴 开启岩藏

    梵云：阿那渣沙玛哇霞玛嘉玛
    汉云:圣莲花生一切事业
    藏云：班渣咕噜打坚尼吽
    唵啊吽班渣寠噜贝玛悉地吽
    皈依上师本尊空行母
    “一介女子，移喜磋嘉，我于师尊，供献广大，外内及密，曼陀罗已，如是启请：嗟嗟!大师莲花生，于现在世，尽未来世，于我等辈，西藏人民，祈请赐予，无尽救护，及于助援。有如尊者，广大觉悟，前无古人，后无来者。我虽女众，决定无疑，必将获赐。有如甘露，纯净珍贵，尊者仪轨。”
    “我见久远，未来众生，心志软弱，见解善变，轻易动怒，不住安忍，轻致暴乱。于圣教法，持外道见；尤于密咒，尊胜教法，轻蔑诽谤。是时众生，病患贫穷，恐怖武器，战争之祸，如是三者，巨大灾厄，炽盛增长，尤于西藏，极大苦难，一时降临。是时藏民，仓惶苦恼，如蚁破穴，蜂拥而出，遍怖三境；汉土藏地，与及中亚。”
    “嗟嗟!师尊!宣说甚多，善巧方便，救治此等，种种苦难。惟是彼等，末世众生，修行仪轨，所需闲暇，与及圆满，皆不具足。纷扰散乱，势力极大。众生甚难，互相调协。献供所需，种种物料，修行仪轨，所需准备，难得圆满。于彼恶世，避免反转，该等劣势，甚难极难!”
    “嗟嗟!师尊!于彼未世，若有众生，仅依赖于，师尊仪轨，所谓《金刚上师密咒》，当能出生，何等利益?为彼末世，下根众生，乏甚深见，祈请宣说。”
    是时大师宣说：
    【具信女儿，如汝所说。惟于彼等，未来恶世，修习能使，一切众生，种种现法，及究竟利，得以出生，是事决定!我将埋藏，十八库藏，所谓地库，水库岩库，天库等等，含藏无量，仪轨与及，秘密教法。于彼恶世，有等众生，具足善业，与及种种，吉祥缘起。彼等所传，善巧法门，极难圆成。彼等恶世，所具特徵，即是众生，所能具有，一切功德，悉皆竭尽。】
    【惟是倘若，于大圣地，二十四处，或于寺庙，或于村落，或大山巅，或大河岸，或天及魔，鬼等所居，高地低地，若有众生，具三昧耶，与及密咒，或有比丘，具僧律仪，乃至白衣，信念虔诚，或具德性，善良女子，精勤长养，菩提正念，彼等众生，若能诵读，《金刚上师密咒》心要，若满百遍，若满千遍，若满万遍，若十万遍，若百万遍，若万万遍，或尽其力，所能致量，如是出生，力势利益，人之心智，不可思议。十方虚空，病患贫穷，战祸恶军，民乱饥馑，恐怖预言，凶恶徵兆，如是所有，种种灾厄，悉皆避除。一切方所，牲畜平安，五谷丰收，风调雨顺，如是福善，悉皆来临。现在世中，未来世中，乃至中有，狭窄险道，于上根者，在其梦中，我将教授。彼等众生，渐次圆满，诸道及地，以圣位身，男女持明，入胜坛城，是事决定!】
    【若有众生，仅诵此咒，日满百遍，无有间断，彼等众生，于众心中，现称意相，丰饶食物，财宝福禄，无庸费力，悉皆降临。若有众生，诵读此咒，满于千遍，或满万遍，或复增上，彼等众生，力能支配，他人心意，更能获得，力势加持，决定无疑!若有众生，诵读此咒，满十万遍，或千万遍，或复增上，彼等众生，积集一切，三界力势，支配三界。天及魔等，皆为仆役，四事业法，无碍成就。彼等众生，所能利乐，有情数量，随其愿欲，无有边际。若有众生，诵咒满于，三千万遍，或七千万，过去现在，与及未来，三世诸佛，常与同在。彼等众生，实即与我，无二无别。一切天神，夜叉罗刹，猛厉山神，皆将应允，听彼号令，臣服于彼，圆满承办，彼所咐属。】
    【上根众生，即于此生，成就虹身，中根众生，于死有时，即能现证，自明净光。乃至有等，下根众生，于中有时，观我面已，即能解脱，诸相生起，彼往生于，胜坛城已，当于众生，饶益无量。】
    空行移喜磋嘉重作启请曰：
    “嗟磋!大师!我等铭感，汝所施惠，广大难量，力势利益，宏大恩典。惟为利益，未来众生，如彼经续，所具法式，更请宣说，《莲花上师密咒》秘字，无量无边，力势利益。”
    如是大师宣说：
    【具信女儿，所谓《金刚上师密咒》，并非仅是，我之名号，实仍表示，本尊圣众，四部密续，九乘与及，八万四千，种种法门，最极最极，心要自性。如是密咒，圆满无瑕，因彼密咒，及三世佛，一切上师，本尊空行，及护法众，最极心要。】
    【若有众生，询问何者，标帜如是，圆满之因，应令彼等，谛听并与，铭记于心，令彼反覆，诵读此咒，令彼书写，乃至令彼，于未来世，一切众生，教授解说，此咒意义。】
    宝之印、密之印、托付之印。


密咒道十基础及甚深口诀乘教授答问

密咒道十基础及甚深口诀乘教授答问
    莲花生大师口授移喜磋嘉佛母岩藏
    杨奴宁玛俄些及生幾宁巴取岩
    艾历啤玛恭桑英译
    黄毅英汉译

    敬礼上师
    大师莲华生于莲花中生，不受凡胎所染。彼经各种难行，究竟达生命自在之持明位，超生死之流。
    大师曾示八万四千法门，瞭知六道众生、八类天、魔等之语言。其梵音能利乐一切有情。
    其意拥有遍知之证量，其已瞭达超乎生灭之自性，而对本性不会割裂视之。
    以此生起应具功德故，其为一切显著事物之源。且大师善巧于调伏众生之方便。
    其大行乃应诸善逝心，而拥有八类天、魔之心命。
    莲师于邬金国地界海中小岛上生。并修于八尸林，于印度修苦行已，以大悲心故入藏。此为应藏王之愿，并令印藏诸国和平故。
    此大悲上师纳余：嘉珍国公主磋嘉玛为明妃，其时余年十三。余只一介女子，具信、大悲、利他、坚定与敏捷而已。
    于大师住藏百一十年中，余承事之，令其欢喜。其时，余纪录书写大师所有教授，并藏于岩库中。
    甲一、修行十基础
    甲二、时过患
    甲三、十要
    甲四、十表面
    甲五、十种誇大
    甲六、除十过
    甲七、十种功德
    甲八、十相
    甲九、十事
    甲十、七种败坏
    甲十一、错谬之危险
    甲十二、四法
    甲十三、戒
    甲十四、离禅天
    甲十五、身语意之三昧耶
    甲十六、十五逆境
    甲十七、十五顺境
    甲十八、二十一种徒劳
    甲十九、四种不还
    甲二十、四不能
    甲二十一、善用
    甲二十二、五无谬
    甲二十三、修六度
    甲二十四、三种追求
    甲二十五、五种真哀悼
    甲二十六、耕耘四法
    甲二十七、八种寂静
    甲二十八、魔罗之诱惑
    甲二十九、四基本功德
    甲三十、五种从根斩断
    甲三十一、调心
    甲三十二、五种见
    甲三十三、五所得
    甲三十四、五种伟大
    甲三十五、五掌握
    甲三十六、五种多余
    甲三十七、五必须
    甲三十八、五妄语
    甲三十九、五决定语
    甲四十、五徒劳事
    甲四十一、六尊贵
    甲四十二、四不足
    甲四十三、虚荣心
    甲四十四、十四应弃
    甲四十五、除三病
    甲四十六、解脱轮廻之道
    甲四十七、至诚修法
    甲四十八、守三昧耶
    甲四十九、恒常之信
    甲五十、十三种出离
    甲五十一、十三要事
    甲五十二、法之道
    甲五十三、坚毅
    甲五十四、修法之难
    甲五十五、安乐之道
    甲五十六、欢喜之道
    甲五十七、偏离
    甲五十八、无可避免
    甲五十九、无所得
    甲六十、自大
    甲六十一、断善恶之交错
    甲一、修行十基础
    大师云：“修法者，必先圆满十基础。”
    磋嘉玛白云：“何谓修行十基础？”
    大师云：
    汝应于见决定，瞭悟一切教授，如金翅鸟翱翔于空。
    汝应于行坚定，不为威吓所动，如象过河。
    汝应以正定修，除无明黑暗，如暗室中燃灯。
    汝应藉教授圆满目标，于汝自性中解脱诸相，如获如意之宝珠。
    汝应以灌顶进诸次第，离堕轮廻之惧，如王子升于宝座。
    汝应以三昧耶守护诸根，不令行为空过，如肥沃之地。
    汝应以学习自作解脱，于法之各方面娴熟，如良马得脱羈绳。
    汝应比较一切法源，瞭解佛法一切学理，如蜂觅巢。
    汝应收集为一点，瞭知无数教法实为一味，如商人加其盈利。
    汝应达知见显著处，清楚瞭悟一切教法，如达须弥山峰。
    藏土之人若欲不以上诸基础而得学养，实不能得入要义，而仅能为宗见之徒，此为不以以上十基础而作娴熟之过患也！
    甲二、十过患
    莲师云：“若不能具足上列之十基础，汝则有修法不成就之十种过患。”
    磋嘉玛白云：“此等过患何谓也？”
    大师云：
    若不能以见决定，则有肯定之过患。
    若不以品行得坚定，则有见与行为不配合之过患。
    若不知以正定而修，不能入于法性。
    若不以口授圆满目标，不懂修行之法。
    若不以灌顶渐次，非为修法之器。
    若不以三昧耶守护根基，所种者只为地狱种子。
    若不以学习得解脱，则不能尝法味。
    若不能比较诸法源，则不能打破宗派之界限。
    若不能收集于一点，则无能瞭悟诸法根源。
    若不能达知见之显著处，则无以通达法之本性。
    未以法修炼之所谓尊师，不知法超乎宗见。其人以偏见互相攻击。以各乘皆自成立故，勿涉诸争辩，任运放下。
    甲三、十要
    莲师示云：“修法时应具十要。”
    磋嘉玛白云：“何谓十要？”
    大师云：
    汝应具不动之信为要点，如河。
    汝应具无仇之悲之要点，如日。
    汝应具无私之捨之要点，如泉。
    汝应具无瑕之三昧耶之要点，如水晶球。
    汝应具离边之见之要点，如虚空。
    汝应具离沉掉之定之要点，如黎明。
    汝应具离取捨之行为之要点，如猪狗。
    汝应具离拼除之果之要点，如到纯金之岛。
    汝应渴求法如飢人求食或渴人求水。
    总之，令人逃避以法为至要，只以世财为目的。汝于死时实无能将财富带走者，故无令堕于恶趣为至要。
    甲四、十表面
    莲师示云：“甚多人将修法沦为表面。”
    磋嘉玛白言：“何谓也？”
    大师云：
    以不信诵经为表面。
    无大悲而云利他为表面。
    吝嗇而行布施为表面。
    若为密人不守三昧耶流于表面。
    为僧不守戒为表面。
    居士不勤修流为表面。
    只研学理不修法为表面。
    修法而不知法要流为表面。
    若不按法而行反而教人乃为表面。
    言行不一，指导他人为表面。
    总之，吾以厌于听“有学”之人，不以法降其心者，徒增纷扰；其所大谈者，只为表面之说而已。
    甲五、十种誇大
    莲师云：“修法时，有十种誇大。”
    磋嘉玛白言：“何谓也？”
    大师云：
    佯称认识法要，实未闻法为誇大。
    若未修仪轨，而谓具力（此所谓神通力也）为誇大。
    无信而谓得加持为誇大。
    若未得定，而谓得达佛境乃为誇大。
    若未承事，而谓得师为誇大。
    佯称已得解脱，实未得有传承之教授为誇大。
    若无口传，而谓证悟为誇大。
    从未修法，宣称解脱为誇大。
    若不精进，自谓修法为誇大。
    不守三昧耶，而谓得殊勝境遇者为誇大。
    总之，若欲轻心修法，不假辛劳者，无乃自誇者，终不成就！
    甲六、除十过
    莲师云：“修法时，勿堕十过为至要。”
    磋嘉玛白言：“何谓为十过？”
    大师云：
    汝纵有修行，若不以之作为妄念之疗治，则有不善用口授之过。
    汝纵已瞭悟自心，若不能以知解脱，使见离二边，则有不获不共教授之过。
    汝纵有诚信心，若不获加持，则有不与已得证悟上师联系之过。
    汝纵勇猛精进，若修法无进境，则有心未完全清静之过。
    汝若于修法时感疲累，则有未悟觉性自然之过。
    汝纵作修行，然心仍散乱，则有修法未决定之过。
    若境界非由汝心直接生出，则有只于奢摩他中迷失之过。
    若觉性之力用，非由汝生，则有不知以诸相作助道自过。
    若觉难于离妄念之执，则有不知以五毒为道之过。
    若不知于苦困中自处，则有不知如何将心转离轮廻之过。
    总之，若自称修法而内里充满过患，又何能达至好之境地（與+欠）？
    甲七、十种功德
    莲师云：“汝需十种功德为修行之相。”
    磋嘉玛白言：“何者为此功德？”
    大师云：
    若能调伏散乱，为瞭悟觉性自然之相。
    若心性之智慧离边展现，为口诀奏效之相。
    若见上师为佛，为对上师生信之相。
    若无碍得加持，为成就之传承不断之相。
    若以觉性生力用时，能无碍改变自心，为觉性能力，锻炼生功德之相。
    若日夜修法仍不觉疲，为达心气精要之功德。
    若修法与否，明觉性无异，为修定得决定之相。
    无论何念或相生起，均能悟知法相，则为能以诸相为助道之相。
    若诸妄念不起，或起后即可平伏，为即能调伏五毒之相。
    若能于苦困中勝，为瞭悟轮廻无常之功德。
    总之，若法于心生，功德自汝而生。藏人中若无信、不勤、乏智难生任何功德也。
    甲八、十相
    莲师云：“若以法住于心，当有十相。”
    磋嘉玛白言：“何者为十？”
    大师云：
    若执著渐减为驱执实相魔之相。
    若染著少生，为远离驰求之相。
    若情绪渐减，为五毒于内寂息之相。
    若自私渐减，为驱我执魔之相。
    若已离尴尬，并无取捨，为染污概念崩溃之相。
    若已无修法者、与修法对象之概念，又不离自性，为见法性母之相。
    若见一切生起之意念，均为离执之境界，为能入见与修之道之相。
    若知轮涅无分，为圆满证悟，由内生起之相。
    总之，若于何物，乃至汝身，均不执著，乃为离诸染著之相。
    若不为苦困所伤，为知一切相，皆是虚幻之相。
    若对八风只轻微关注，为知心性之相。
    无论如何，若内相外显，即如树发嫩叶。如外相他人可见，则如树结果，可供享用。
    甚多行人，连一功德亦无，得悟者甚少，故当勤精进修持也。
    甲九、十事
    莲师云：“对修法者言，须知十事。”
    磋嘉玛白言：“何谓也？”
    大师云：
    既得人身又闻佛法，为过往生中积集也。
    有趣法之意乐，亦遇具口诀之上师，则如盲者觅得如意宝珠。
    既得人身，又具信与根器，则为过往所修之善业已醒。
    若既富裕，又同时遇到乞丐，即为圆满布施之时。
    若苦海溢满时，欲注心修法，为恶业与障碍得清静也。
    若心转向法之时，突遇仇敌，为引导往安忍之道之时。
    若瞭解一切诸相无常，并对所得甚深法要具信，则表示已到出离世间法之时。
    若见他人死去，而触及对死之恐惧，即极大信心生起之时。
    总之，若欲先圆满世间法，再修佛法，即会发觉此乃无可能者！此亦能于轮廻中解脱者甚少之故也。
    甲十、七种败坏
    莲师云：“修法者有七种败坏。”
    磋嘉玛白言：“何谓也？”
    大师云：
    若汝信不足，而具智慧，则会被自比为师之败坏。
    若有甚多听众，自又以为高位，则会被自认为善知识所败坏。
    若未将佛法置于心中，而自以为高位，则为自以为领袖所败坏。
    若未修法而传人口诀，则被成为空洞佛法专家所败坏。
    心中无有佛法，而喜无聊争辩，乃自成为盗世行者所败坏。
    若少修学，又未得教授，则纵具信心，亦为平庸所败坏。
    真正修行人按正教而行，必以智慧解脱，以信调心，以听法斩断误解，摒弃交际，将心融入于法，以修习与自省圆满其学识，以口诀解放其心，并以见与修得最后决定，然此为甚难也。
    甲十一、错谬之危险
    莲师云：“入佛之门后，有甚多错谬之可能，慎之！”
    磋嘉玛白言：“何谓也？”
    大师云：
    有将以智性研习之老师，误为以实学与自省解脱之善友之可能。
    有将未有修法之空洞佛学专家，误为于修行中具境界之可能。
    有将骗人伪善者，误为能以佛法调心之尊者之可能。
    有将空洞雄辩者之言，误为具口诀者证量之可能。
    有将自誇者高谈佛法，误为具信者修法投入之可能。
    总之，以心融入佛法为至要，空谈佛法，自称行人，又自与佛法疏离者，不能于修法中得成就！
    甲十二、四法
    莲师云：“汝当确知所修之法为真法，当确知汝法以之为真实道，汝应确令此道清除迷乱，汝应确使迷乱化为智慧！”
    磋嘉玛白言：“何谓也？”
    大师云：
    汝若能将诸教法摄为一乘，得离取捨之知见，则汝之修法已成真实之法。
    若毗钵舍那生起乐、明、无念之境界，则知其为法身。
    总之，不少住于木然的奢摩他境地者，其或转生于诸禅天，又纵不转轮，亦不能利乐诸有情者。
    甲十三、戒
    莲师云：“皈依与受戒为修法之根本！”
    磋嘉玛白言：“何时当受皈依戒，又何时当受其他按自生起之戒？”
    大师云：
    若惧下道时，应生起皈依戒，敬信三宝。
    深信因果时，受居士戒。
    远离诸恶趣时，应受具足戒。
    生起大悲，见己与人平等，受愿菩提戒。
    若以他人比一己更高，受行菩提戒。
    若于任何修法，具皈依与发心，并以生圆次弟共，得方便智慧双运，汝之法已成真实法。
    若见、修、行、果与道合，则汝之法已清除迷乱。
    于见修中决定，并于修持精进，迷乱已开始转为智慧。
    总之，任修何法，不能合生圆次第、见与行持、方便与智慧者，则如欲以独足而行！
    甲十四、离禅天
    莲师云：“修法者，应远离下道！”
    磋嘉玛白言：“何谓也？”
    大师云：
    勿著乐、明、无念之奢摩他境界。若著之，则无法脱离声闻独觉之地也。
    藏人每以皈依为低法，僧众无有纪律，自言修大乘者无菩提心，密乘行者不守三昧耶，瑜伽行者无正定。故此藏人难有悉地
    甲十五、身口意之三昧耶
    莲师云：“修法者，必须守三昧耶！”
    磋嘉玛白言：“如何守三昧耶？”
    大师云：
    见上师为佛化作人身者，得觉身三昧耶。
    见其语之教授为如意宝珠，得觉语三昧耶。
    见其口诀为甘露，得觉意三昧耶。
    若对本尊已离取捨，得身三昧耶。
    若对密咒决定，得语三昧耶。
    若悟心性之自然境界，得意三昧耶。
    总之，若心清静，则戒清静也。
    甲十六、十五逆境
    莲师云：“修法者，有十五逆境必须离者！”
    磋嘉玛白言：“何者为十五？”
    大师云：
    绮语、嘲弄、轻心能障正定，故须远离弃。
    眷属、朋友、弟子令修法分心，故应离弃。
    物质、生意、与享乐使修法散乱，亦应离弃。
    得、誉、称，为修法之绊，应离之。
    眠、惰、怠为修法之主敌，应离之。
    总之，修法者最危险者为中断。
    甲十七、十五顺境
    莲师云：“修法时，应具十五顺境！”
    磋嘉玛白言：“何谓也？”
    大师云：
    闻、思、修为修法之基本架构。
    勤、诚、信为修法之三柱。
    见、戒、善为修法之三功德。
    不染、离著、离执为修法之三种和合要素。
    总之，现无一行者共如上任何之三，故难以与佛法之主旨配合也。
    甲十八、二十一种徒劳
    莲师云：“修法者，有二十一种徒劳！”
    磋嘉玛白言：“何谓也？”
    大师云：
    若不摒弃伤害有情，发菩提心为徒劳也。
    若不守三昧耶，受灌顶乃徒劳也。
    若对己之心无裨益，博闻教法徒劳也。
    若行功德时，混杂以恶行乃徒劳也。
    若行不善，依止上师乃徒劳也。
    若为导师，不作修法，并行恶业，为徒劳也。
    若为八风所动，乃徒劳也。
    若随一导师，而凶恶以对如母有情者，为徒劳也。
    若常作不善，自称畏地狱，为徒劳。
    若不以菩提心，又无虔信，布施为徒劳。
    若不决定坚守，受戒徒劳。
    若不调治嗔心，修安忍徒劳。
    若常沉掉，修禅定徒劳。
    若不慕觉道，修精进徒劳。
    若嫉妒及五毒增，修般若徒劳。
    若修大乘教法，而无大悲，徒劳！
    若不知自性，修定徒劳。
    若不实行，受口诀徒劳。
    若作利乐有情事，而非由菩提心起乃徒劳。
    总之，纵此等皆为徒劳，而作此诸法皆无益，然无知者，不会听从。
    甲十九、四种不还
    莲师云：“修法者，当具四种不还！”
    磋嘉玛白言：“何者为四？”
    大师云：
    常念死，不堕于此生之世法。
    积十善功德，不堕三恶道。
    具大悲不堕恶趣。
    观空性不堕轮廻。
    总之，修法者应远离此世界之关注。
    甲二十、四不能
    莲师云：“修法者，有四种不能，故当弃之！”
    磋嘉玛白言：“何谓也？”
    大师云：
    若不念死,无有修法之闲暇。
    不信因果者,不会放弃恶业,不能成就上道并得解脱。
    不怖轮廻过患，不知出离，于解脱道不能成就。
    若欲为一己得出离解脱，而不为他得解脱之想者，无能达圆满佛位。
    总之，若不转离规限此生之目标，无法于修法中得成就者，能弃世间法者，实如麟角也。
    甲二十一、善用
    莲师云：“修法者，应善用四无用物！”
    磋嘉玛白言：“何谓也？”
    大师云：
    善用无用之身者，当守清静之戒。
    善用无用之所有者，发菩提心，并慷慨。
    善用无用之好景者，以积福资粮作因，以积慧资粮为果。
    善用无用之学识者，当精进修持。
    若不能善用彼等，一切所作皆为世法已。
    甲二十二、五无谬
    莲师云：“修法者，应有五无谬！”
    磋嘉玛白言：“何谓也？”
    大师云：
    汝当无谬守所受之戒！
    汝必须无谬修慈、悲、及菩提心。
    当观业因果时，应无谬回避最细之黑业。
    当观上师与佛无二时，应无谬常观在汝顶上。
    总之，观一切相皆空时，汝当无谬。
    甲二十三、修六度
    莲师云：“修法者，当修六度！”
    磋嘉玛白言：“何谓也？”
    大师云：
    若无（文/口））啬或偏见，此为六度之布施。
    若能善巧消除妄念，此为六度之持戒。
    若全离嗔愤，为六度之安忍。
    若不懈怠，为六度之精进。
    若离散乱，又不著味静虑，为六度之禅定。
    若汝喜离概念分别，此为六度之智慧。
    甲二十四、三种追求
    莲师云：“修法者，当有三种追求！”
    磋嘉玛白言：“何者为三？”
    大师云：
    下根者，一切追求只为未来世之故，未及其他者，故无法不趣上道。（按：此指六道中之较上者。）
    大师云：
    中根者，厌弃轮廻，求诸功德，故无法不得解脱。
    大师云：
    上根者，只知为一切有情发菩提心，故无法不得圆满觉悟。
    总之，一般人自破晓至入黑所求者，均为此生。被妄乱所困，无法不于来世中，入于恶趣。
    甲二十五、五种真哀悼
    莲师云：“修法者于亲属去世时哀悼，此为正确之法，修法者有五种真哀悼！”
    磋嘉玛白言：“何谓也？”
    大师示云：
    当与大师分离，应以祭品哀悼。
    与善友别时，应以积集资粮作哀悼。
    若竟与师违背，当发露忏悔作哀悼。
    若心为八风所飘，以深出离心作哀悼。
    总之，人不知一切之无常者，无法除净其哀伤。
    甲二十六、耕耘四法
    莲师云：“修法者，当具耕耘四法！”
    磋嘉玛白言：“何谓也？”
    大师云：
    当以虔信翻心中粗糙之土。
    以修持作施肥以改心态。
    发菩提心以种善根种子。
    如耕夫以精勤将智慧之耙系于方便智慧双运之耕牛，完全除去五毒。
    如上所作，无法不含觉悟之芽，结佛果之位。
    总之，甚多人不会为解脱之耕耘，却对世间之耕作不倦，悲乎众生！
    甲二十七、八种寂静
    莲师云：“修法者，应守八种寂静！”
    磋嘉玛白言：“何谓也？”
    大师云：
    守身之寂,住于静处不堕边见,以此离爱嗔。
    守语之寂，住于哑子，以此不会于修法中受与人綺语所扰。
    守意之寂，不为散乱所制，能使住于无念法身之自性中。
    守意欲之寂，离净与不净食物之想，此等令生活简朴及使空行聚集。
    守口授之寂，非器勿说，此能得传承之加持。
    守德行之寂，即时而作不落虚伪，此能得进境，而避收集诸障。
    守境界之寂，离诸著相或希冀，并勿将境界语人，此能令一期得大手印成就。
    守觉悟之寂，远离野心、不落边见而住，此能令觉悟时即得解脱。
    总之，不能以纵一食时间而修者，不能于念咒圆满前守寂静者，不能闭多言之口者，无能于守寂中得少许成就。
    甲二十八、魔罗之诱惑
    莲师云：“修法者为魔罗之惑然不察者！”
    磋嘉玛白言：“何谓也？”
    大师云：
    有权势者为傲慢之魔罗所蔽。
    高官为雄辩与污染之魔罗所蔽。
    平民为愚痴之魔罗所蔽。
    富人为忙碌与致富业务之魔罗所蔽。
    修法者为增其资产之魔罗所蔽。
    彼等为养儿与眷属之魔罗所蔽。
    彼等为大弟子之魔罗所蔽。
    彼等为钟爱（亻+庸）仪之魔罗所蔽。
    彼等为仇敌之魔罗所蔽。
    彼等为眷属软语之魔罗所蔽。
    彼等为善妙严饰之魔罗所蔽。
    彼等为美语甜言之魔罗所蔽。
    彼等为其染著之魔罗所蔽。
    彼等为美貌与爱慕之魔罗所蔽。
    一切染污之行为，均为魔罗之蔽障。
    内心之五毒，为汝心之魔罗。
    六根习气，为外物之魔罗。
    著味静虑为内境之魔罗。
    希求大圆满之果为见之魔罗。
    一切无上功德亦均为魔罗。
    一切无明与染污亦魔罗。
    最大之魔罗为我执。
    其不在任何一处，而只在汝边。汝必须于内杀之，若能如是者，其不会从外而侵。
    甚多人不知此魔罗。
    甲二十九、四基本功德
    莲师云：“修法者,应具四基本功德！”
    磋嘉玛白言：“何者为四？”
    大师云：
    具大悲者有正觉心。
    离伪善者，能守戒。
    无欺诈者，具清静三昧耶。
    离爱染者，无愧具无不共患难之交。
    总之，若具诚信，于修法必成；若具决定，必能守戒。若欲修法必须谨慎；如汝心中之骨般稳固。
    甲三十、五毒从根斩断
    莲师云：“修法时,应将五毒从根断！”
    磋嘉玛白言：“何谓也？”
    大师云：
    具嗔者痛苦最大。
    愚痴者如畜牲不懂佛法。
    大傲慢者，不能积集功德，并多仇敌。
    具大贪欲者，不能守戒并多诽谤。
    大妒忌者，喜好阴谋。
    勿追逐此五毒，从内杀之，并于生时即脱离之。
    纵于此五毒者，自制哀愁。
    甲三十一、调心
    莲师云：“修法者，应先调心！”
    磋嘉玛白言：“此何谓也？”
    大师云：
    当以慈爱之水，熄嗔心所烧之火。
    以强力之药所成之桥，跨贪之河。
    以燃妙察智之炬，驱无明暗。
    以精进之凿，夷平傲慢之山。
    以穿著安忍之煖衣，挡嫉妒之风。
    总之，此五毒，汝之首敌，若沉溺之，将败坏轮廻三界中之尔。勿令之放任，此甚危险者也。
    甲三十二、五种见
    莲师云：“修法者，应具五种见！”
    磋嘉玛白言：“何谓也？”
    大师云：
    当见非物质之心性，超乎佛法之语言。
    当见若离执著，一切法均自解脱。
    见一切境界，均为离物质之大乐。
    以尊敬诚言，当见上师为佛陀之示现。
    总之，修法者见一切均莫执著。
    甲三十三、五所得
    莲师云：“修法者，应具五所得！”
    磋嘉玛白言：“何谓也？”
    大师云：
    莫因懈怠弃上师教，应具真切之修持。
    当以投入修行具自利。
    当以得传承，具指导弟子之能力而利他。
    当以解脱诸相至空性，具无做作之自然本性。
    当以具自本面具心与佛无二。
    今世藏土行人不得其一，乃无法成就任一所求。
    甲三十四、五种伟大
    莲师云：“修法者，应具五种伟大！”
    磋嘉玛白言：“何谓也？”
    大师云：
    当有具口授伟大之上师。
    此等口授当得深道善巧方便之伟大。
    汝当具刻苦坚忍之伟大。
    当具希求修法之伟大。
    当具决定修之伟大。
    除非具足上五，解脱轮廻者不会成就。
    甲三十五、五掌握
    莲师云：“修法者，应具五掌握！”
    磋嘉玛白言：“何谓也？”
    大师云：
    以掌握佛法，当具知一遍脱道。
    觉悟法性，让无生自内而起。
    掌握三昧耶，具心之圆满。
    以精勤掌握精要，能作坚忍。
    以掌握口授，能应机教授他人。
    甲三十六、五种多余
    莲师云：“修法者，有五种多余！”
    磋嘉玛白言：“何谓也？”
    大师云：
    若无出离轮廻之意，虔诚乃为多余。
    若对物质染著不弃，观空性为多余。
    若不息渴望，修法为多余。
    若不弃执著与愤嗔，阐述口诀为多余。
    若不依方便法，给与明智忠告为多余。
    甲三十七、五必须
    莲师云：“修法者，应有五必须！”
    磋嘉玛白言：“何谓也？”
    大师云：
    必须为大师摄受，以得口诀精要。
    必须对上师有甚深及日增之诚信，以自然得加持。
    必须收集资粮，以令心柔顺。
    必须使心柔顺，以便生起三摩地。
    必须生起三摩地，以便速达遍知佛地。
    甲三十八、五妄语
    莲师云：“自谓修行者，有五事为妄语者！”
    磋嘉玛白言：“何谓也？”
    大师云：
    若仍沉醉此生，而谓怖畏未来投生者，为妄语。
    不离欲望，而谓修法者为妄语。
    不知因果，而谓了知正见者为妄语。
    未越轮廻深渊，而谓成佛者为妄语。
    甚多人自称佛法行人，而自欺欺人者，身命尽时，此等妄语，均返害其身！
    甲三十九、五决定语
    莲师云：“修法者，应具五决定语之教授！”
    磋嘉玛白言：“何谓也？”
    大师云：
    不修持时，境界与证悟决定不生起！
    于大乘修法中，若方便与智慧分开，决定堕声闻乘！
    若见与戒不知结合，决定入于谬道！
    不见心之真性，决定仍有善与恶行。
    不见自性，决定不得佛果。
    甲四十、五徒劳事
    莲师云：“修法者，有五种徒劳。避之！”
    磋嘉玛白言：“何谓也？”
    大师云：
    随一不具心要之上师为徒劳。
    向一不守戒弟子传法，乃徒劳者。
    不用以实修者，听法为徒劳。
    若不能上进，其心修持为徒劳。
    沉于低下法之空言，而不自救为徒劳者。
    总之，甚多人之修法为徒劳者，以愚痴故，不知分别。
    甲四十一、六尊贵
    莲师云：“修法者，当具六种尊贵！”
    磋嘉玛白言：“何谓也？”
    大师云：
    欲掌握正见,当知一切唯心。
    于戒律中防伪善故，当令心清静染著。
    以修布施时无执故，当远离所得或偿励之希冀。
    为调伏修安忍时种种难处故，当远离对仇敌嗔恨。
    以闻思调心故，当能以五毒及逆缘为道。
    以能修持故，当避免为“恭敬魔罗”所扰。
    然此等行人乃不按佛法而行者。
    甲四十二、四不足
    莲师云：“修法者，当弃四不足！”
    磋嘉玛白言：“何谓也？”
    大师云：
    空余时修法不足，当无间修持如流水。
    只达见鬼魅之境界不足，当以佛法解脱自心。
    行为伪善不足，当守自然与当下。
    尊敬与承诺不足，当真实承事上师足前。
    总之，今世行人，被此等不足所困，于死时如常人死去而业果必熟。
    甲四十三、虚荣心
    莲师云：“此等行人以大傲慢常自誇，比普通人更差！”
    磋嘉玛白言：“何谓也？”
    大师云：
    其自称修法并随上师，其伪装为师，或云有甚多僧众。其自己管理寺院，并作庄严供养，其装作投入修持，并得高戒。其自称闭刻苦之关，并有最高教授，却以伪善愚众，自却不离世间追求，只导致死时可悔之境！
    甲四十四、十四应弃
    莲师云：“若于内心极欲修法，有十四事应弃者！”
    磋嘉玛白言：“何谓也？”
    大师云：
    如野鹿之子住于荒山。
    食禁食之食，修“摄精华”之苦行。
    勿游于大都之上层，行为应保持低调。
    作令仇敌欢喜，并断与家乡之牵连。
    衣被扔之衣，并常自谦仰。
    摒弃亲友之染著，并断一切牵连。
    求赶过诸佛，并投入修持。
    以本尊为最内精要，并诵其真言。
    以恶行为最卑劣者并弃之。
    对上师开放心怀，并将一切奉献。
    弃轮廻于后，并生厌离。
    以勝利与人，并勿于权斗。
    自勝之并发露己过。
    如此作者，修法上进，以正法与汝已背离轮廻故也。
    甲四十五、除三病
    莲师云：“修法者，当除三病！”
    磋嘉玛白言：“何谓也？”
    大师云：
    若不除家乡病，弃汝乡里，必困于五毒之囚，及堕入下道。
    若不除住处之病，弃家园财物之执，必困于执著与我执之牢，无能断执著之魔罗。
    若不除眷属之病，弃子嗣与家庭，必困于轮廻泥沼，无有解脱之期。
    住于轮廻之宅，不能除此三病，并竟不知为三毒病垢所扰，实甚难忍也。
    甲四十六、解脱轮廻之道
    莲师云：“修法者，有解脱轮廻之道！”
    磋嘉玛白言：“如何为之？”
    大师云：
    若欲生起不共诚信，观上师外内功德。
    若欲与每人和谐，勿迟疑于助人。
    若欲与师之心相应，实践其口授。
    若欲疾速得悉地，绝不违犯三昧耶。
    若欲离生、老、病、死四洪水，不断融于法性中。
    若欲于修持中无牵，弃诸世间追求。
    若欲无动而利有情当修慈悲无量菩提心。
    若惧来生入于下三道，此生勿作十恶。
    若欲于现及未来世利乐，当行十善。
    若欲至心修法，于辛劳及颠沛时修持。
    若欲背向轮廻，于自心求勝觉悟。
    若欲证三身之果，致力积二资粮。
    如此修持，当得利乐，不远离轮廻者，无有乐处。
    甲四十七、至诚修法
    莲师云：“若于内心极欲修法，乃有一途！”
    磋嘉玛白言：“何谓也？”
    大师云：
    修仪轨时，当远离执著与嗔恨。
    正确学习时，当披坚忍之鎧甲。
    住于僻处时，勿著食与财物。
    欲渴求成就法，依得成就之上师。
    若遇尊贵上师，勿违而尽力令之欢喜。
    对法有疑时，请问汝师以求教导。
    当眷属叛离时，断此牵连。
    远离被魔障之扰。
    即刻修持勿延。
    勿渴伴侣，但求寂静。
    友伴与所有，眷属与物质，一切虚幻，当弃之。
    执著与嗔心增上，勿与人共。
    独居并投入修持。
    甚多旁务徒扰修持，当弃之。
    总之，不投入修持者，无能得真乐！
    甲四十八、守三昧耶
    莲师云：“修法者，必须守三昧耶。吾见众人无所作，只破三昧耶，以其不能坚忍故！”
    磋嘉玛白言：“何谓也？”
    大师云：
    有破戒者，不使人知其师，自言博学，只顾自誇伟大。
    有破戒者，本欲供养上师，后又转意，收回供物作自己财富。
    有破戒者，欺师及同修之友。
    有破戒者，轻蔑上师，并自炫己名。
    有破戒者，迁其过于上师，并竟言三昧耶清静。
    有破戒者，欲点评其无可评论之上师。
    有破戒者，虽宣扬上师功德，然乃欲与之竞争者。
    甚多顽固之人，自言不闻，即已博学，自言已熟，然未受灌顶，及自言口诀，然实未有。故只有小数能获加持与能力者。
    甲四十九、恒常之信
    莲师云：“修法者，单言恒常之信，已甚重要，此有十种生信之因！”
    磋嘉玛白言：“何谓也？”
    大师云：
    了知现有之行为，所得及名声无乐者。
    信黑白业果。
    知必死故，乃感厌离。
    知财富与所有、子嗣配偶、及眷属，乃不重要者，以死时不能作伴故。
    了知无能选择来生之境，以剩于何处不定故。
    知若不修法，得此圆满人身后，将空手而去。觉知任生于六道轮廻中，何处均不离苦。
    闻三宝最勝功德。
    知上师不共大行为功德。
    与善友游并住于善处。
    忆念或生起上者，渐离轮廻。然只生起其一亦甚难哉？
    甲五十、十三种出离
    莲师云：“若于内心极欲修法者,当具十三种出离！”
    磋嘉玛白言：“何谓也？”
    大师云：
    若不出离家乡，无能勝漫之魔罗。
    若不弃家长之作为，无能腾出修法之时。
    若具信时而不投入修法，所作业无有了期。
    对自己亦无信故，勿谤他人。
    若不能弃己所有，无法断世务。
    若不与眷属保持距离，难断执著与嗔心。
    若不当下修持，不知来生生于何处。
    若望未来方作，而非于当下有机会为之，当知将来未必有此机。
    勿自欺矣，断汝希求，并修圣法。
    弃诸眷属与朋友，爱人与所有。若能当下为之，乃甚重要。
    勿争不德之社会地位，而不能带走者。作诸善行，乃甚重要。
    勿为明天筹备此乃需或不需者。以修法为死而备，此为甚必需者。
    若投身修法，不必为食与著牵挂。一切任运得，吾从未闻见修法而饿死者也。
    甲五十一、十三要事
    莲师云：“以至诚修法者，当修十三要事！”
    磋嘉玛白言：“何谓也？”
    大师云：
    依具德上师为要。
    长久依具口诀上师为要。
    对至勝三宝坚信为要。
    离纵最微细不善为要。
    昼夜各三观无常为要。
    修法精进为要。
    对众生慈爱为要。
    善巧离诸相，及物质执著为要。
    对无谬口授，具决定为要。
    正守戒律与三昧耶为要。
    对自心清明为要。
    勿将密法授与不当之人为要。
    修法时，竭力并住僻处为要。
    若如此修者，修法必成。
    甲五十二、法之道
    莲师云：“若欲修法，此为其道！”
    磋嘉玛白言：“当如何行之？”
    大师云：
    若欲了空性，当随上师。
    若欲解脱轮廻，当弃家作。
    若知必死，当修法要。
    若欲修无二，当弃所作。
    若欲具功德，当圆满修持。
    若欲离苦恼，当弃随侍及仆从。
    若欲得境界，当常修山法。
    若欲离执著，当弃家乡。
    若欲观景象，当自心之明镜观。
    若欲得成就，当顶戴上师、本尊与空行。
    似无有一人修解脱法者。
    甲五十三、坚毅
    莲师云：“若自心修法者，当具坚忍！”
    磋嘉玛白言：“何谓也？”
    大师云：
    食物与财富，皆为幻象，故当弃之。
    娱乐、名誉及善境皆为大障，故当弃之。
    朋友、眷属与侍从为轮廻根本与执著并嗔心之因，故当弃之。
    年与月、日与须臾，均损减死前所余之时，故当尽速修行。
    无坚毅及正目标者见其眷属、食物、财富与子嗣为甚珍贵，其以散乱为善境，以友伴为乐，不知年月日之逝去，而却数其寿，于死之时，其只有自己作引导。
    甲五十四、修法之难
    莲师云：“修法为甚难者！”
    磋嘉玛白言：“何谓也？”
    大师云：
    此有持邪见之虞。
    修法误为意之造作。
    大敌为破三昧耶。
    德行为身、语、意不善所污。
    教法为野心所毁。
    法为欲得财富所衰。
    戒为评论他人而坏。
    道误以执著为实。
    谦恭为渴求可欲者所漂。
    果误以为此身得名声。
    无修法之师，至为难堪，而此等行者，令人沮丧。
    甲五十五、安乐之道
    莲师云：“若会者，有安乐之法！”
    磋嘉玛白言：“敬请明示？”
    大师云：
    离边见时，见为安乐。
    离沉掉散乱时，修为安乐。
    若执著净如虚空，德行安乐。
    心之染垢清静，境界安乐。
    心离苦恼，住处安乐。
    边见清静，慈悲安乐。
    执著自内清静，布施安乐。
    知食物与财富虚妄，受用安乐。
    若无我慢，日用安乐。
    若不作家长，离去诸恼，生活安乐。
    若不争得恭敬，友伴安乐。
    远离幼稚与我执，自得安乐。
    依具慈悲与口诀上师，自得安乐。
    知空性乃于六道一切有情中，安乐而知其为己亲属。
    若断染著时，一切所作皆安乐。
    诸相与诸有当下解脱时，大乐而得安乐。
    知色声皆幻时，安乐断诸苦恼。
    觉知本面时，无勤无功而安乐。
    一切意念觉为空性，安乐而以一切所见作修。
    知此，一切所作皆安乐。
    黑暗时期的众生，永不离我执而无乐，故甚可怜也！
    甲五十六、欢喜之道
    莲师云：“若能随此等教法,有欢喜之道也！”
    磋嘉玛白言：“如何行之？”
    大师云：
    执著与染著乃无底深潭,弃汝家园乃能欢喜。
    学思之领域无涯，觉自本心乃能欢喜。
    空言绮语无尽，默然乃能欢喜。
    世法思惟乃无止者，住于静处乃能欢喜。
    行为无止无作，乃能欢喜。
    积财永无厌足，弃所执著，乃能欢喜。
    仇敌永难歼灭，自净其意，乃能欢喜。
    所著眷属永难满足，断自希盼乃能欢喜。
    轮廻根本永不断，断我执乃能欢喜。
    意念不止，断意之流乃能欢喜。
    总之，众生不断我执者，无有欢喜，其长受苦于轮廻诸道中。
    甲五十七、偏离
    莲师云：“甚多瑜伽行者偏离，受戒后又还復庸人！”
    磋嘉玛白言：“何谓也？”
    大师云：
    行人不明自性，大谈且却，从各其他方向说之，乃为偏离！
    行人困其自心，不知了解，终日作“呆禅”，乃为偏离。
    行人所作不检，却谓一切唯心，乃为偏离。
    磋嘉玛白言：“如何免之？”
    大师云：
    行人若自诸相唯心，并以法身为道，乃无偏离。
    行人断一切思维，具决定见，乃无偏离。
    行人以此修持，并以觉为道，乃无偏离。
    行人知诸相为助缘，并远离染著及执著，乃无偏离。
    总之，末世时大多行者均偏离，不偏者甚少。
    甲五十八、无可避免
    莲师云：“修法者，有重要事乃难免者！”
    磋嘉玛白言：“何谓也？”
    大师云：
    当觉自剩智乃俱有时，无可免已得觉悟。
    觉轮廻自性，乃无间苦恼，并弃离之时，无可免于轮廻中解脱。
    对诸哲理见解无执时，无可免得无涯学问。
    觉知轮廻本性，乃无间苦，并离之时，无可免远离轮廻。
    以智无定型故，若知如何当下清除五毒时，无法可终于地狱。
    今者无人有此等法，故长于轮廻中流转也。
    甲五十九、无所得
    莲师云：“令人修法者一无所得！”
    磋嘉玛白言：“何谓也？”
    大师云：
    说法者，只知誇大与诽谤。
    研读者，偏于希冀与恐惧。
    主会供者，堕于饮食之执著。
    修持时，流于沉掉。
    生功德时，堕于求恭敬与物质。
    得知识善巧时，落于更大渴求。
    连于众多弟子，落于紧张其修法。
    甚多行人与法背驰！
    甲六十、自大
    莲师云：“自谓修佛法者，甚欲自誇与自大！”
    磋嘉玛白言：“何谓也？”
    大师云：
    有以其所得知识与教法自大者。
    有以其虔修佛法自大者。
    有以其住于山僻处修法自大者。
    有以其具大能与大力自大者。
    有见财富或可欲境，犹如蝇（虫+内）嗅血腥者。
    见不可欲，或有害者，则奔如犛牛解韁。
    对自德行自誇，犹如以孔雀毛上之眼睹物。
    又妒他人之德，如犬隻守财。
    总之，此等自大行人，为其死敌，对此等愚痴执著魔罗者，吾甚觉其可怜也！
    甲六十一、断善恶之交错
    莲师云：“修法者，当断善与恶行之交错！”
    磋嘉玛白言：“何谓也？”
    大师云：
    自我观念尽时，无法、无业、无业之熟。此其时也，已断善恶之交错。
    如此，直至自我观念终，不善行会积集业并得果。善行亦会积集业力，并得其果。
    意念尽时，无有善恶行之聚故，无有果可得，此名为“因与缘之尽”，亦名为“勝义谛”。
    于未来世，末法中百五十年，人不觉我执，并不知灭其意念故，沉于粗黑业。
    自称具勝义见，并称慎善恶行之果，乃为下见。
    蔑视因果，其自称已得证悟。
    其作轻浮不羇。
    其行邪道，自引及引人于谬道。
    故莫须臾效之！！！
    余，磋嘉，一愚妇，久事化身大师。于不同时，师教及修法，而余常铭衷无谬记忆，收集后书写，以利未来世故。
    以其不为现世故，余藏此等教法于岩库，愿遇堪能者。
    此教授“以问答教法之续”乃于猪年秋季二月二十五日于尖蒲上洞结集。
    宝之印、密之印、托付之印。
    邬金上师心严诀，今乃于此而示付
    普愿见闻转诵者，同证邬金解脱地


于藏王弟子赤松德真之教言

于藏王弟子赤松德真之教言
-----莲花生大师教言伏藏

    艾历俾玛恭桑、黄毅英译

    奇矣哉!莲花生大师受藏王赤松德真之请，调伏工地并建光荣即时圆满无量之桑耶寺。及后，王请身披深栗色斗蓬之上师坐于中央上殿丝垫宝座之上。王献上师以米酒并左右两手捧满杯之金与银。王献不同供物及七宝置于一腕尺松石花许之金曼达盘上。又于项上取下名为放光摩楼之松石饰物作日，另一颗名为金楼恭初者作月。又以不同宝物表四须弥四洲，供献上师并赞言：
    不靠父母莲花中成就化身，
    住金刚身调众生断生死流。
    于无边证悟对具缘示佛性，
    善巧方便调伏缚鬼魔以戒。
    三身圆满行化身最为无量，
    莲样金刚多寿前赞叹顶礼。
    纵受五欲时无有执着染着，
    慈悲而受令众生生起功德。
    祈得无上甚深内义请纳受！
    大师答言：‘王!汝喜见吾相耶?’
    王答:‘如是?’并赞唱言：
    远离病与四大超脱生与死，
    具极大慈悲为众生利乐故。
    汝心常住于法界内之本性，
    诚然众生依（忄+古）汝相见之喜！
    大师复言：
    当知上师更重要，
    较此劫中之千佛。
    皆因此劫之千佛，
    以随上师后示现。
    未有一上师之前，
    佛之名亦不存在。
    又云：
    上师为佛又为法，
    以此故亦为僧伽；
    其为三宝之根本，
    摒除一切他礼拜。
    至诚承事汝上师，
    令喜得一切成就！
    王乃白莲师言：【大师，因地凡夫欲达佛果，觉悟之见为至要。何谓:‘具觉悟之见？’】
    大师答言：【一切见之顶为觉心之菩提心要。一切大千世界十方善逝，乃至三界一切众生，其自性无上而皆乃觉心之菩提心要。此处之心乃指无生所起之万象。
    汝或问：佛与众生又有何别耶？全为觉与不觉心之别。诸佛觉性本性乃于汝边，只汝迷矣。不知自心，众生流转六道。
    汝或问：‘觉心之法为何？’此则如教法所言必须上师口授！
    如此,‘心’为思维了别者故,有觉之境。勿假求心,观内!让心寻自!对心之自性具决定见!
    首先,心与何处起?当下,住于何处?最后,又往何处!若心自寻自,即知所起,所住,所去皆无所得。‘如如’无有解释。‘心’无内外.其无观察者亦无所观.其为大元始觉醒无有中边,无量遍满本来空与自在.此元始觉醒内在及本有.非今时作而自始即在汝边.当具觉如是见之决定见!
    具决定信者了知犹如虚空,心自始本然存在。如日,离无明黑暗之根。如莲花,不为过失所染。如金,自性不变。如海,不动。如河,不断。如须弥山,完全不变。一觉此如是,此即名为‘具觉悟之见’】。
    王问：【何谓‘具修之觉受?’】
    大师答言:【王,于此谛听!具修之觉受者,令汝心勿预设,勿坏并保持自在。勿置汝心于外或集中于内,无有专注点。于此本然自性之平等,不动,如灯火不为风所动也。
    于此境界,或有觉受:觉识或感满溢,光明或顿停;大乐,光明或断思维;或感昏暗,混沌,与世间生活不调.若此之时,勿执其重要性,以其短暂生起故。勿实执之,此为‘具修之觉受’】。
    王问：【何谓‘具行之平等味?’】
    大师答言:【‘行’者修之无碍;无有散乱,纵无有修之所。如河不断之流,任何境中,行 住 坐 卧皆不忘失。‘平等味’者,所见者或五境起时,均以之为内性之觉醒,无有执着,无有取舍。犹如临宝贵之金山。此即为‘具行之平等味’】。
    王复问：【如何‘跨妄念危险之污垢?’】
    大师答言:【若静坐时妄念生起，一切所生均为心生。以心不实故，妄想无有实性。如云于虚空生，亦于虚空散。妄念于心中起亦于心中散。要之，思维亦为自法性。
    ‘跨危险之污垢’者当心于不同之思维中流动，当专注于心。如贼入空楼，空思维无戮害空心之处。此即为‘跨妄念危险之污垢’】。
    王问大师：【如何‘得果之不变决定?’】
    大师答言:【谛听！菩提心之觉心非为因所生亦非为缘所灭。其非为智慧之佛所造亦非聪明之人所作。其本来在汝边为自然所有，当由上师口授而得认识，以心为诸佛之父故，即犹如认识已认识之人。
    一切三世诸佛于得定得不断由觉心证悟，犹如王子上座，觉自始即时存在。远离惊恐，即为避免‘得果之不变决定’】。
    王问大师：【如何‘断除 歧途与过患之障?’】
    大师答言:【王，冀望与恐惧源自不具见之过患。觉之醒觉菩提心，非谓期望误证悟或恐惧堕于凡夫。
    执修者及修之对象乃为未断二法思维之过患。汝法性本然自性离诸构作，无有修之对象亦无有修者，或有修之法。
    取舍乃未断执着之过患。本来自在与空心之自性无有所得使汝执着，亦无有为敌者得以舍弃，无有取之功德亦无有舍之念故。
    执着行持乃不知修法之过患。修法者远离对象及专注及知执着与染着无有根基。
    一言以蔽之：见者离散乱，修者心住无处，行者不着于味而果为离有得，除此之外，三世诸佛不曾有教、现未有教、将来亦不教也！此谓‘断除歧途与过患之障’】。
    王问上师：【何谓‘除散乱之过患？’】
    上师答言：【纵已了悟心即是佛，勿弃汝师！纵已了悟相即是心，勿碍善缘！纵无成怫之希冀，恭敬三宝！纵无惧轮回，避去最微之过失！纵得本然自性之不动决定，勿低估任何教法！纵得三摩地觉受及高见等，勿作欺妄！纵悟轮涅非二，勿断众生之慈！】
    王复白言：【何谓‘得决定？’】
    大师答言：【自无始来汝心即为佛果之觉地具决定。一切诸法为汝心之幻相得决定，果在汝边不假外求得决定。汝师为佛之人化得决定，见之自性与修为佛之觉性得决定。如是得决定者汝应修！】
    王复问曰：【何谓‘得口耳传承？’】
    大师答言：【由普贤王如来之加持过口耳传与金刚萨埵，金刚萨埵传与极喜金刚之耳腔，极喜金刚交付师利星哈之心，师利星哈交与我 莲花生。赤松德真，于心中当保任！】
    大师开示藏王日：【王，除非觉悟法性得无生自性，纵生为元首以如水中泡沫之化！
    除非觉受离思维法性之自性，汝之国度与权力如虹之无常将褪减及消失！
    除非与本有觉性如友之同伴，当离此生时，无法断王后、仆人与子民之执着，一切均如旅途中偶遇而必弃！
    除非与见修之自然位娴熟，于此生轮回至下生时，如水车之边，流转生死！
    除非以圣谛治国，竣法如毒树自毁。大王，祈汝能以法治国！
    大师复开示藏王日：【吾王，于此世末，众生渴求胜法而不解。不随佛法然自称行人。于此之时，不少夸言者而少成就者。当汉、藏、蒙之佛法灭，如盔甲之破坏，众生难驯。当此之时，此等教法必须护持佛法，故当藏诸岩库。
    吾王，汝之最后世将遇此教法及护持佛法者，汝将断生死流并得持明位，故现将此发表！
    藏王大喜，即献金曼达并作无数礼拜及绕佛。
    宝之印。密之印。托付之印。
    伏藏教言胜妙法
    应缘于此而出现
    普愿见闻受持者
    无碍现证佛悉地


珍宝伏藏---无垢修持晶鬘（节录）

珍宝伏藏---无垢修持晶鬘（节录）
    莲师口授.移喜磋嘉佛母藏岩
    杨奴宁玛俄些及生叽宁巴取岩

    莲花生大师云：【苟不能以方便知见双融，密咒将流入歪道。】
    磋嘉玛白言：【何谓也？】
    大师答言：【方便者，修法之无诳原则，或为生起、或为圆满次第。知见为见，法界空性之义及自光明。若不瞭知见为自空性；於己体现，则非入於知见之道。无方便之知见，无能有任何境界；以无知见之方便，法性不能入於修持中，故须将二者双融无令分离。
    总之，将方便与知见分离，犹如鸟欲以单翼飞行，无能达佛境。紧记之！
    莲花生大师云：【若不修根本后得无分，无法入空性界。】
    磋嘉玛白言：【何谓也？】
    大师答言：【於上座时，住於如幻法性中，觉受而非分别。於下座时，了知一切皆为空性、无自性。对空之觉受无动触与执著，必可超越上座下座，离於所观之境及特徵，如云雾於空中即时消散。（上所云觉受乃指现量之实证诸佛法身，徒呈意识分别之能事而造作者，皆戏论也。）
    总之，无论上座下座，观法性者超乎明与障，如揽镜观物者。】
    莲花生大师云：【修待时若不能自然清除沉掉，纵有修法，仍不免堕入两端之过患。】
    磋嘉玛白言：【何谓也？】
    大师答言：【於上座时，住於自然法性中，於沉掉生起观照之，见昏沉本亦法之空性。於掉举生时亦观掉举，所掉举者亦为空也。
    若执著於摈弃沉掉之念已除，则无染於认定其为实体，沉掉即自解脱，而不会推之至极则。若能修习自然清除沉掉者，自生之定境已生。
    总之，一切定境为对治沉掉者，则变为思维之定。了知沉掉之根乃空性为至要。紧记之！】（此中亟需领受无垢灌顶、实际修持乃可生起表里如一之解脱自性，徒依文解义作理解者，皆增上慢人也。如下知之！）
    莲花生大师云：【若不能将法与生活融合，各座修法即变成脚绊。】
    磋嘉玛白言：【何谓也？】
    大师答言：【修法时，平等住中所觉受无造作之法性，应带进下座後之每一境；或行、或走、或卧、或坐。於一切所为，若不离此修法，即能长住於此法性。修法即超越各座之限。
    总之，修法者困其身心，不运用修法之精要，即为枷锁所绊。紧记之！】
    莲花生大师云：【若不行献供与忏罪，则业障无法清除。】
    磋嘉玛白言：【何谓也？】
    大师答言：【于修口授之时，应（以法为道）。即以观想、献供、绕行、造渣渣（小泥塔像）及食子、朗诵、讽颂、抄经等法行，转为无修整之道。不断行此。若以染著，懈怠等，则无法圆满目的。
    总之，若不以无分别执持诸法，所作善业只引轮廻中之乐为果：彼等不能成觉悟之道。此则成为无意义。
    以此之故，于无执染之境界中行身、语、意之善行，尤为至要。紧记之！】
    莲花生大师云：【若于修法中无有示相，则教法仍未生用。】
    磋嘉玛白言：【何谓也？】
    大师答言：【内示相为内在而生之乐、明、无念。离诸实执，不为妄念所牵，心即自解脱也。
    获得法的加持之中示相，为能断恶念，超诸艰难，不为病、垢、魔所乱，此时加持，即于自身语中现。
    外示相为心以修法得自在，不为八风所动，我执之结自解。
    总之，若缺法之上师者，定法无从生。以此之故，依止具相续传承、妙成就之上师为极至要。紧记之！】
    莲花生大师云：【甚深教法无结集。】
    磋嘉玛白言：【何谓也？】
    大师答言：【若殊勝之上师宣说甚深法，纵为一言，具器弟子即依之修习，定法即生，果能圆满。
    磋嘉，汝无生之心为空、明、遍满。当常感受之。
    总之，若法之上师殊勝，无论何往，汝均得甚深角教法。紧记之！】
    莲花生大师云：【纵修何法，若非为众生者，修之法，只导致声闻断灭之境。】
    磋嘉玛白言：【如何引致耶？】
    大师答言：【将口授作为修持，修习佛心以得觉悟，乃为众生利乐故。为成就他人之利故。此非共乘之目的。为己之平静喜悦，放下与解脱，乃下乘之道。
    总之，只为一己之平静，为苦之源，且无义利。
    修法只为自利，而得乐者鲜也。以此故，只为他利而修实为至要。为他而修之时，即离我执而自身利益即得成就。紧记之！】
    莲花生大师云：【若不以无缘大悲作修持之依据，一切功德源即浪费。】
    磋嘉玛白言：【何以故？】
    大师答言：【有执之功德源，无法增长故，必尽。若善以无执廻向所修，功德之源无尽，此亦即最上觉之主因。
    无执者何？无“我”、无“他”、亦无功德源之想。将一切想，溶于空性中。
    总之，功德之本无误，若为无执所持。现有所执之我已行善！并将功德廻向世法或名声，为颠倒之廻向。】
    莲花生大师云：【具善巧方便之功德源，超乎其他。】
    磋嘉玛白言：【何谓也？】
    大师答言：【若以善巧而行口授；练於真义，印以无执之廻向。此即能远超实执之修持，纵修何法，功德之源增长。
    要之，至为扼要者为令功德之源无尽，不断增长，
    直至得无上觉。无论如何，放下廻向之处、廻向之能与所，不著任何痕迹。紧记之！】
    化身大师莲花生云：【与三调谐之伴和合，即能除魔罗之障。】
    磋嘉玛白言：【何谓也？】
    大师答言：【向调谐之真实上师依止；观之常在顶上，使得向之祈祷及献供。
    与调谐修法并具同一誓句之友作伴；其为不追求世间法，为未来故决意修善行者。
    依附调谐无错三教法，将之实践，遵照具德上师之敕，修生圆次第之甚深教法。
    若与此三无分，魔罗无能障也。
    总之，以自心为证，作三宝不唾弃之行，结果必为殊勝。紧记之！】
    莲花生大师云：【修法者，得好基础为要。】
    磋嘉玛白言：【何能得之？】
    大师答言：【首者，若缺积聚资粮，则无能遇具口诀之上师。若缺数勅修习之业，无法瞭悟教法。若无诚信，无能见师之功德也。又若缺戒律及誓句，则与修法背道而驰。若无口诀之导，不能知修持之法。若无精进坚忍，无法入修持之道，而功德转堕于懈怠。若无决定出离轮廻中之追求，无有能于修法得圆满果。
    若均无上列之过失，修法必至成就。无上觉悟之成就，须无数因缘之和合，故当精进。
    要之，捨所应揲，为所应为，勿令身、语、意堕于凡俗而加努力，其果殊勝。紧记之！】
    莲花生大师言：【谨知佛法无有义利，必以之住心中，并实行之。】
    磋嘉玛白言：【如何行之耶？】
    大师答言：【对见广大瞭知，对教法无边见。夺修法之宝座，将一切法之义，集与心中。启行为之门，莫令见于行不合一。具得果之信，使轮涅一于法性。知守三昧耶之规范，不越此戒！如是修者，修法则无所谬误。
    总之，勿让修法堕于平凡，将之吸收于心，及以之实践。紧记之！】
    莲花生大师云：【於未来世，末世黑暗时期降临时，有自称修行人者，未得允许，却教人修法，自不修持，却教人修持，自不解脱，装作教人解脱之道。充满私欲，而教人抛弃染著枷锁、叫人慷慨。对自己所为之善恶，一无所知，而信口道人家所为是善是恶。自无定境，诳称利他。吾知将来以佛法之名，装作伪善、欺诈、行骗者多矣。
    於未来世欲修佛法者，当读此莲华散人所造之嘱言并自验证之！
    当观轮涅过患！此生一切均为无常，至为明显，应自内省思维！多闻成就大师之传记；知其如何自律。觅得具德上师，以身、语、意至诚承事之。
    於初，勿与之如平辈之交友；而以学习与观想断诸邪妄。
    次不断修持，并作坚忍。
    最後，以修持将法融合於心，并对治妄念等。
    常守誓句与戒律，无令退转。修法无令间断、或推迟，应即修之，以实践所发之愿。
    纵吾一散人已得成就者，无有散乱之时。见诸迷失众生，正受驰求世法、烦恼、欲望及黑业之苦时，悲欲泣也。心为愤慨而痛。
    已得人身，由善恶业而受乐与苦，不期以即身成就者，纵修一座皈依亦无，而代以追求、野心、散乱、今生之享乐，而积集恶业，实无有心者，其心已腐朽，魔罗之鬼已潜入其心，其为诸魔所骗矣。
    若由心深处以三宝作依估，修即身成就之法，绝无被三宝所欺之可能也。
    受欠缺衣食之苦，实无可能也。人常称缺修法用之衣食，故无暇皈依或修法，并谓无有馀暇；其实为无耻而自欺也。
    当下，当诸根具足，并有暇之时，若不努力修觉悟之法，转瞬即被业风所吹，直至死主之处，而死之时逾
    近。於此之时，方才发狂想诸法，则只惜迟矣。紧记之！！！
    总之，修法者无有成就，除非紧记死字於心。
    未来世具器者，吾莲华散人，无诳语者。任何所为，尽力使死时无悔！自顾而尽力，望有救他之能力。
    此教授，名为“无垢修持晶鬘”，显为无死甘露之心要，向化身大师莲花生处所求者，以身语意至诚而求者．卡珍磋嘉。
    以使世利益故，将之纪录将之岩藏，以不应宣说故！
    若遇具器者，当使之实践。
    此为“无瑕无垢修特晶鬘”之讲授。
    宝之印、密之印、托付之印。
    空行心要最勝法
    今乃于此而略述
    普愿见闻受持者
    同证邬金解脱地


椎击三要诀

    椎击三要诀

    大善解功德主（巴珠仁波切）著

    敬礼无比大悲主， 具恩根本上师前。 见宗广大无有量， 定即智悲之光明，
    行即如来之苗芽。 如是受持修行故， 即身必能证妙觉， 否亦心安阿拉拉。
    见宗广大无边量， 椎击三要诀扼尽。 最初令心坦然住， 不擒不纵离妄念。
    离境要闲顿时住， 陡然斥心呼一“呸”！ 猛利续呼“也马火”！ 一切皆无唯惊愕。
    一切皆无唯惊愕， 愕然洞达了无碍， 明彻通达了无说。 法身自性当认之，
    直指本相第一要。 复次起住皆适可， 嗔恚贪欲及苦乐。 恒常及暂一切时，
    旧识法身认知之。 今昔光明子母会， 住于无说光明境。 所现乐明数数除，
    猛施方便般若字。 出定入定无差别， 上座下座亦无别， 恒久住于无别境。
    然于未得坚固间， 须勤舍离喧闹修。 且须闭关专行持， 恒及暂时一切处。
    保任唯一法身用， 决定信此无他胜。 一决定中坚决定， 是为第二关要者。
    是时贪嗔及喜忧， 妄念忽而无尽者。 旧识境中无连续， 知是解脱之法身，
    比如水中之图画， 自起自灭续不断。 所现明空赤露食， 所起法身妙用王。
    随妄本净阿拉拉， 显相与串习相同。 解法殊胜最妙要， 无此解修皆谬道。
    具解无修法身境， 解道坚定第三要。 具三要之见宗者， 融合悲智之定者。
    万法即真如， 真如即万法。 随契佛子一切行， 三世如来虽聚议，
    较此无有他胜法。 自性妙用法身库， 智慧藏中宝库藏， 不同他石诸精英。
    胜喜金刚遗嘱教， 三种传承之心印。 付与心子记持之， 是诚深义与心腹，
    具诚心语义扼要， 义要不可轻弃之， 慎勿漏失此方便。

    椎击三要诀胜法解
    大善解功德主（巴珠仁波切）著
    贡噶上师讲解
    释满空译文

    敬礼无比大悲主，
    具恩根本上师前。
    敬礼于彼上师前者，今欲演说见、定、行三要诀之行持理趣。上师者，为三宝之总集体，唯于彼乃有所皈处，故首须礼敬。
    见宗广大无有量（本法门之初祖无垢光尊者，别号广大无量），
    定即智悲之光明（本法门之二祖名智悲光），
    行即如来之苗芽（本法门之际三祖名无畏佛芽）。
    凡诸所有演说义中，开首应知一切根本传承诸上师者，与我心无有分别，既见、定、行一切行持，皆总摄于彼而无余故。今演说见、定、行三要，首当具根本传承上师之名号尊义，相合解说。且初言见者，夫彼一真法界，离绝戏论之法尔如来藏心，无垠广大界中，无量显现染净诸法，彼诸一切，皆亦圆满具足法尔平等性义。如是而了之，是即见宗之最殊胜者也。
    如上之见宗，离绝诸戏论性，唯有般若之光，可以智慧观照抉择。然彼空性，不离大悲、般若与菩提，等持双在，住于一处，故必空悲双融，方为正定。
    如具上见宗及正定者，契合诸佛出生之苗芽，即菩萨行趣。一切利他六度与万行也。
    如是受持修行故，
    即身必能证妙觉，
    否亦心安阿拉拉。
    如是受持见、定及行之人，谓之能得劫者，谓能得贤劫之善机也。复次，行者能依寂静山林等处，放下现生世间之一切事缘，而一心精进，唯道是修，必定能于即此一生，本净心体，得正解脱，而登妙觉。
    即或未能，但能专一其心向于此见、定、行门者，应善了达一切生趣于恶缘道中者，即不当起任何贪、嗔、痴等，于此生世之诸作业及挂碍，于未来世，亦能由乐转乐。
    以下依次演说，具得如上利乐之见、定、行三要诀。初说见宗行持理趣者。
    见宗广大无边量，
    椎击三要诀扼尽。
    此谓椎击三要诀行持之法门，能断惑妄之命根，即于未得见宗者，亦具直指之方便。其在性相两乘之见宗，乃以教理抉择。即在共道密乘，亦只依第三智慧灌顶之譬喻智，而令趣证第四义之真实智，是诸教义甚多。惟本法门为诸已成就宗祖大德所印契，立超而直指自心实际之法门。
    最初令心坦然住，
    不擒不纵离妄念。
    夫心当起伏生波时，因随境而转之粗妄念等，遮盖自心本相，虽直指之，亦不能见，故当先使粗念澄清也。
    无为而住之自心性，即是智慧光明。若以有为为道而修，必不能了悟本元。故表诠者，谓此为自心无所俱生智。但初修时，虽欲此心自然住定于本元境，然所住分，仍不能超越于贪着乐、明、无念等功力之境中。
    离境要闲顿时住，
    陡然斥心呼一“呸”！
    猛利续呼“也马火”！
    故当谴离贪着如是等功力境，顿然安住，方可现出赤裸了彻自性本元体。当是之时，急促猛然厉声呼一‘呸’字，即能顿断妄想之流，息灭粗妄心所。如是住定，是为最要。
    一切皆无唯惊愕，
    愕然洞达了无碍，
    明彻通达无言说。
    如是即离彼攀缘一切法之境，其自性分明彻赤显，离心智慧，如如现住。
    既然洞然了达于彼，离生灭有无诸边，超绝语意分别境，而自安住离言思之智慧性境中。
    法身自性当认之，
    直指本相第一要。
    如上要义，即指法身体性智，亦即瑜伽本净道、离绝戏论之见宗。如不识此妙谛，其间纵令如何修行，仍未离心作用及有为之见，必与自性大圆满道天地悬隔，不能获得无修光明轮。是故首当了知此妙谛为最重也。
    如是之义，乃是椎击三要之初要也。若于见宗未获印证，虽修亦无保任之境，是故以印证见宗为首要。后可印证自住之智慧，是即住自本性故，非由他来，亦非昔无今有。（此为初要）
    复次起住皆适可，
    嗔恚贪欲及苦乐。
    次说第二要，等持之理趣者，令心如河流，任运自然而住，观照时及一切时，皆如是故，虽有起伏，亦不作成立与遮谴，即得法身之自相。若心起时，但知为智慧之功用，观照及一切时皆如是。是即放逸不修者与勤积修习者，法性原无增减也。
    夫由妄念所生集谛之贪嗔等烦恼，及苦谛之苦乐等感受，若知此等之自性，皆是法尔，即得法身之妙用。若无此见宗，以印证修持，不达自然任运者，必妄念纷驰，仍落凡愚。此为任妄念作主，而被缚于生死之法，与自性分离，即与凡夫同道，故应当常恒不离无修之大自然住。
    恒常及暂一切时，
    旧识法身认知之。
    无论何时心有起伏时，只以一法对治，不可于各各妄念起伏上，作各各调伏对治。 故唯以认识上面直指见宗一种，则一切尽摄也。
    今昔光明子母会，
    住于无说自性境。
    又凡起妄念与烦恼，即是法身本觉智慧相。其自性亦即法身本体光明之真实。知此者，即名本体住之光明。由前上师直指自性光明之见宗，能熟其自相，便名行道之（始觉）光明。若能任运于此二无分别之体与道两光明之自相，即是光明母子相会也。（本觉母，始觉子也。）
    若能恒久忆念，认识见宗自相之光明，于其境界功用中之妄念烦恼，更不起任何遮谴与成立，及取于舍等，斯为至上之要妙也。
    所现乐明数数除，
    猛施方便般若字。
    又若恒久护持如是之境，初学者有由乐、明、无念诸功力，遮盖本元自面者，当揭去此等功力之皮壳，则自性之相，方能赤裸呈现，是为智慧由内明朗者也。故宜勤除乐、明，曰：泉水汹涌激流妙。生乐、明之力及现世乐、愉快等相时，如《笃哈语录》颂曰：“瑜伽修习频除妙，泉水汹涌激流妙”，即此意也。
    复次，云何除法？谓将生乐明之力，及现喜乐愉快等相时，要力念方便能摄之‘ニヘ’（音扎）字与般若能断之‘己’（音帕）字二者相合之“ニヘ己”（音呸）字，猛然从上落下，即破坏贪着功力之皮壳矣！（按此合成之字，即为“呸”，其所合成之二字母，一为帕，一为扎，旧译音泼口乇。）
    出定入定无差别，
    上座下座亦无别，
    恒久住于无别境。
    如是由一切时，能保任离绝道验之关要、无可言说之自性了彻者，则入定出定，行持无有差别。又上座时静体之修持，与下座时动作之修持，亦无别也。如是者乃不修之大修，自住等遍之智慧。如河流之瑜伽，无有毫发修整，然刹那也未驰散。如颂云：“未曾修习未曾离，亦不离无修习义”。
    然于未得坚固间，
    须勤舍离喧闹修。
    于此自性大圆满之根本道，有成如‘+ ’字之器者（谓于圆满法如量得解者），或顿闻而得解脱，则为色心大离体所显一切法身之妙用，无有能修所修。其它起现妄念，为他力所转之下机渐道凡夫，于未得坚固中，尚须修习。如彼修习，自应具足之禅定固聚，方生道验，故于喧闹及驰散之处，纵如何长久修习，道验亦不生也。
    且须闭关专行持，
    恒及暂时一切处。
    如上言，修习时虽出入定行持无有分别，然在初机，于根本定之自地道验智（即道力证验之智）与后得智（或出定之后得智）未得相融时，虽常勤行道，而行仪上仍易生习性之染污，故必须闭关。闭关修持者，虽有护持依赖于根本定体之行持，然不知长养后得（智），使与行仪相合者，则徒以对治法，仍不能克治他缘，致被妄想之缘牵引，反入于凡愚障中，故长久护养了彻于后得，尤为最要也。
    保任唯一法身用，
    决定信此无他胜。
    其实也不须另求他法，唯不离此本定法身见，无能所是非等分别，自然任运，保任于惺惺寂寂之境。此之行持，诚为无分别之止观，离戏论之本元瑜伽，无为俱生法尔之自相。能保任者，既得金刚密乘本续中，一切行持之心要，四灌顶义之智慧传承，摩尼妙宝之胜法，印藏新旧宗派等之稀有密意也。如是而生决定信心，则不垂涎于其它要门矣。如彼象置家中，而于林中觅象迹，以分别心入有作为之网者，无有解脱时也。 故于自之行持，须坚定信之。
    一决定中坚决定，
    是为第二关要者。
    此实即法身自住之赤露智，本未曾迷之觉性心。决定信之，护持其相续。是为第二之密要义也。
    是时贪嗔及喜忧，
    妄念忽而无尽者。
    今第三，广说行之要。上所说若无解脱智之道力，唯住休息之行持，仍不能超越色、无色界，因其不能克制贪嗔之缘起，也不能断诸行之业流，以未得决定心之道力故。若于喜欲境生贪爱，于不适境生嗔恨，于顺缘及受用等生欢喜，于逆缘及病等生苦受，如是所起一切，要知其皆是自性功用之显现。故认识于解脱体智为至极切要。又行持者，若未得起灭之要，则心所渗漏之妄念，皆是集积轮回之业因，故无论起粗细之妄念，须要起灭随无，而善护修，是为紧要。
    旧识境中无连续，知是解脱之法身，
    比如水中之图画，自起自灭续不断。
    谓于凡所生起妄念不纵之使炽，亦不以念治念，唯不离自然本体，以观照之。妄念所现，知其自相，即可护持起灭，使无连续性，如水中绘画然。
    是时妄念虽自灭，而未清净，盖仅了知妄念，而尚不能断惑乱之业流。若了知彼时，且同时即识知显见自识之智性，则自然安住。妄念灭处，清净随得，且更为重要。如水上绘图，即绘即消，绘与消同时故，念起念灭亦同时，而本皆清净，自起自灭，密密绵绵，相续不休，得任运矣。是于对起妄念，不做遣除，起者任其起，其所起者，皆为本元清净性中之道行，修持者应知之。
    所现明空赤露食，
    所起法身妙用王。
    盖依于妄念，调修法身，则所现之妄念，皆调现为自性之妙受用，即五毒妄念所现之粗者，皆令具自性解脱之光力，明空成受用也。又凡所起一切妄念，皆为由自性通彻之境所起之妙用，以无取舍心护持之，因其生起及灭，固未能超越于法身妙用王之境也。
    随妄本净阿拉拉，
    显相与串习相同。
    妄念虽具无明色相，而其自性未出智慧法身之清净中，故于广大不断之光明所照中，一切妄念所起，自性原空也。如是长久串习行持，则妄念自起调治，动静无分，得无坏住。
    解法殊胜最妙要，
    无此解修皆谬道。
    极其功用，虽现喜忧疑虑等妄念，与凡夫同，然不如凡夫起成坏之实执，集诸行业，而随贪欲力成转移。故瑜伽行者当念生时，初认识妄念之相，其相随灭，如遇旧识之人相同；次则妄念必自然灭，如蛇结然（自结自解）；最后，妄念亦无利无害而隐灭，如盗入空室然，是为解法之最要妙。颂曰：“知修不知解，与禅天相同”。若不具如是解法妙要之修习，虽心坚住禅定，亦落于上界之禅定。或有以了知妄念起住为足者，此与下劣狂惑，有何差别？或偏于空性，求法身印契等思量，然遇恶缘时，则所修持不能解除，而反自现过失也。
    具解无修法身境，
    解道坚定第三要。
    起灭、自灭、定灭等，虽如何立名，然皆是妄念自灭，随妄本净。此灭解相，即自解脱现量唯一之要，亦即自性大圆满殊胜法门不共之妙。若具此要者，无论所生是何烦恼妄念，皆显现为法身，妄念净为智慧，逆缘成为助伴，烦恼成为道行。不舍轮回，而住清净。解脱染净之缠缚，无功用修证而任运也。如无此解法之道力，虽骄矜有至高尚之见宗，甚深之修持，而实于心无利，烦恼之力未退，非真实之道也。若得此自起自灭之妙要，虽至高见地之持法与甚深修法之缘依，微尘分亦无有者，其自性亦决然能从二执之缠缚中得解脱。如到金洲，求他石了不可得。任何所起之动静妄想，皆唯现成之真实定境。复求迷乱自性者，了不可得。如是解法，方为判别得要、不得要之准绳。
    具三要之见宗者，
    融合悲智之定者。
    万法即真如，
    真如即万法。
    如上三要,乃自性大圆满之见、定、行、果四者，在自性了彻之境中，统摄为一面，行之最极心要。亦是即定即行之要，也是既定既行之要门也。其他宗论，皆于所知境中，以教理正语种种度量而抉择见宗，本法门不取于彼，于何时了悟赤裸裸之智慧性，即何时得其自性智之见宗。见与定虽分述，而体实一，故于行持中分见、定、行之三要，亦无失也。
    如此行持自性大圆满本清净之无失要道者，实为九乘之顶巅，如王行时，必有眷属持卫，随从而具。其余一切乘之道即随从，而为此要道之台架与助伴。尤有进者，若见本净自性般若光明相时，则由定所生般若之功用更炽，其智慧广廊中，如夏水瀑流，由空性之本住，起现大悲，入无方悲悯，是亦法尔然也。
    随契佛子一切行，
    三世如来虽聚议，
    较此无有他胜法。
    如是空性与大悲双运之要道，若现证时，其他六波罗蜜道所摄之佛菩萨如海诸行，一一自现作用，似日之与光。如是与福德资粮合作，而广为利他之行，以圆成真实之见宗，而为无染寂乐之助伴。如是 見、定、行三要乃过去、现在、未来诸佛密意之中心，一切乘之頂巅，一切心要之王。金刚心之要道门中，实无有较此至极果义再殊胜者。
    自性妙用法身库，
    智慧藏中宝库藏，
    不同他石诸精英。
    此方便所说义，实为传授要门之心血，文句虽少，然此述作，皆由于自性所起妙用也。上述等义，虽修慧无多及，然于上师示教，能由闻慧断增益，思慧善抉择，即具修慧，实一切智慧之宝中宝。非同于世间之库藏，仅解暂时之贫乏而已也。
    胜喜金刚遗嘱教，
    三种传承之心印。
    此三要开示椎击三句义，为化身胜喜金刚入涅槃时，由天空中，示与上师文殊知识，文殊知识上师既契合祖心，印成无二无别之要门，而传出承之。后分三传：（1）于如是方便要义，了解妙要之遍智法王祖师，即身现证一切本净法门之密意，而得妙觉圆满如来心印传承。（2）于持明无畏洲，示现智慧身，以持明表示，摄受及传授与无畏洲祖师。（3）于吾等具恩根本上师以口语耳传方便，直指即见法尔现量，即现在所住之众生功德主（指大德上师）。
    付与心子记持之，
    是诚深义与心腹，
    具诚心语义扼要，
    义要不可轻弃之，
    慎勿漏失此方便。
    如是口诀，乃库藏之精英，心之明点，于不行持之人，示之可惜。然如彼能行持要义且能即身成就之人，若不示之，又殊失悲，故此口诀，总应如保生命而护持之。
    附：贡噶上师椎击三要诀撮要口示：
    心注眼，眼注空，为一切要中要（须参仰兑修法）。
    三要者：（一）见：知自心相。依妄念缘念之起，而观察自心本相，认知法身自性。（二）定：决定信之。融妄念为法身妙用，熟识法身。（三）行：坚固定之。于念灭上坚固而定，念无连续，法身之见不忘。
    心注眼，眼注空，为一切要中要（须参仰兑修法）。


大圆满法性自解脱论本颂

    大圆满法性自解脱论本颂

    无垢光尊者

    梵云:摩诃珊底达摩达都阿麻果拿麻
    藏云:卓巴钦波却尼郎卓
    汉云:大圆满法性自解脱论

    敬礼吉祥普贤王如来

    本初不生光明平等体 心性不动无执极广大
    三身任运大乐奥明处 基圆满无迁转前顶礼
    我于众生心性虽正觉 随无明力漂流轮廻境
    欲于有趣解脱妙车辙 了义藏要法轨此当说
    诸友于此无边之轮廻 种种苦痛滔滔汹涌浪
    我执迷妄无明中所出 珍视此中对治之本理
    如此现有轮涅诸法等 元始不生本来平等性
    无有证违无常断来去 离边无二法性虚空性
    种种法相不紊虽任运 显时是中自性离戏论
    外境无实心之所现理 非心亦非心之所生法
    所现五境如翳如游丝 如无而现执二成迷妄
    犹如迷梦虚幻之大象 误见敌军众所包围时
    执自所出诸馀而怖畏 彼之自性他或心孰有
    其时外内何者悉不成 知自性者怖畏处解脱
    如彼无二执为二之时 未善巧者执实而迷有
    达者了知二现无有二 轮廻自性解脱涅槃中
    噫(山戲)此现本初本不生 种种无二犹如镜中影
    空之自性所现非相异 如水水沤双融而无二
    离幻化边亦如幻化城 约生性中不生本初体
    显现安住亦不住法身 约灭性中不灭无增减
    如何显现如彼不成立 凡诸观察如彼无自性
    本解同等普贤之状态 於基根本无实之诸法
    为谓此故无执无认持 如空能作无缘所作空
    是诸是何是此无意向 以执方分宗义许和合
    见修行之法门虽甚多 难见藏要心性原始义
    声缘唯识自续中观宗 虽以人法无我之区别
    正行见修空等四谬故 显现成立无数芸芸众
    事部行部瑜伽无上密 续义生圆修整虽多法
    无造自恣任运原始中 不得亲谒终为戏网转
    谓此心觉见修行果具 或有遮灭想与受以及
    若干虽于三时断连繫 谓为当下之识洞然澈
    其馀施设诸等生灭数 谓元始义分别浪涛涌
    如彼制气二合乐明中 谓本然义受执贪有缚
    陷于轮番取捨妄罟中 藏要义理永远悉不见
    彼诸以意观察法迷妄 轮廻所缚无有解脱期
    悲夫不知观察妙宝故 弃如意珠反寻琉璃瓦
    捨自性心性原始勝理 修整疑虑幻化罅所限
    纵以黾勉心亦无解时 所寻之事復为寻者染
    噫(山戲)欲知自性心妙义 寻伺观察诸多有何为
    随现为何随现无所执 无执离际无需作取捨
    一切无著令不作修染 境心此现即为空性理
    谓空以见於彼有何需 若无虽观亦不转为空
    无义徒劳於彼有何为 如彼生圆自性不需修
    取捨诸法依此何易持 若具彼义不需辛勤苦
    若无无义焦炭不成金 是故心观诸法悉不成
    令彼不以修整对治染 此是无上金刚藏要义
    无咒无续亦不许宗义 无持此说无见修行果
    一切等圆同一坛城体 宗义圆满见修行果圆
    轮涅等圆法性大平坦 无整无解本来菩提者
    无作勝王任圆法身体 种种色身幻化之游戏
    不即不离现有三身智 断证无缘一切悉清静
    大轻安矣一切自然高 诸法任圆一切平等性
    无生勝王离中边方分 若无执能所者原始义
    不需断证破立同等位 见地顶巅即为大圆满
    无著勝王了知无执著 所为一切缘想悉缠缚
    若起无缘随即智当体 本置自空自然原始义
    无执离边见地令決断 噫(山戲)此等诸现放逸行
    无察欢喜观察无认持 若极观察自性超边际
    若观此理开解彼性心 三时无缘无有生住灭
    离色离形体性无认辨 升景升时升处升者无
    外内无缘超越能所边 虽于外境所现迁流转
    彼无迁流仅升现于心 若迁流时以自性粗色
    刹那本明转为有二类 升基无定本解如虚空
    升现无二犹如镜中像 于义无二亦如水浮沤
    不需取捨大圆满意义 自性即为本净之正觉
    现心本初无有自性中 而今吉祥上师教示语
    今为一切決断法身者 离诸是非犹豫与戏论
    孰亦不问心性本然义 无作即见原始之体性
    彼时迁住法身游戏中 不需断证随现大庄严
    住亦不动唯一法性体 即为一切任圆无迁转
    现达三时正觉之密意 大乐任运基圆普贤王
    于诸时中普悉无迁转 一切同等本初地解脱
    噫(山戲)具执方分之心思 无解脱时能缚彼自性
    乃至解脱执持离方边 为无二义无有他表徵
    视之不见觅之不可得 此说无表徵凡常自恣
    令不以贪执心作缚解 虽许凡诸无二离边际
    然缚离边中心之心性 虽许二谛復堕其边际
    虽许双运然非本始理 凡所審度执著籠所缚
    未断无始能所迷妄故 固执观察心思纹绘缚
    悲夫迷妄之心实可愍 此说若有认持即非见
    种种戏论樊籠不必需 随现无所拣择之明中
    以无广狭高低捨执著 此是离诸意向之现心
    不作断治修改任自恣 此是了义藏要之究竟
    种种诸法平等之自性 随现为彼即是无二智
    不以意观不以心追寻 令能执不缚所执不染
    了知凡诸诸法如虚空 幻化等观无有执著境
    最勝无二自性见地王 为悟离边证量极稀有
    有寂无二本明湛然澈 知自本体基根无实有
    缚解无二大圆满奥义 于众生心无馀常续住
    见彼性故离喻甚深义 无垢光明显明作开示
    现心无执幻化游戏中 通达离方本明见顶礼
    大圆满法性自解脱.证基解脱品第一
    最勝金刚顶巅无二道 随现本明于彼无执体
    凝眸睇观毕竟安置时 了知性澄如水入水中
    无二自解起乐明无念 復虽一迁亦不动安住
    彼时不生心性法身体 升解本明色身出苦趣
    不需断证迁止悉安乐 升住止观方慧悉双运
    意不修整令不作造作 若有些微破立取捨者
    彼时犹豫二执樊笼缚 不达希欲处反堕染处
    于随现义珍视无取捨 诸友心乃颠倒如骆驼
    若执则行若释则安住 自恣宽坦自解本始性
    能所自处解脱得心乐 为彼缘故捨所缘心者
    安置无缘随起无整染 住无能所执大自解脱
    无碍本明昭空智升起 种种迁流为所现方便
    以解脱故观慧任运成 安住彼中性澄闍摩他
    乐明无念静虑任运成 不作不坏大自恣自然
    安住迁转间罅故伏住 自恣迁止无边功德者
    以迁不沈灭心住执著 观慧拔除烦恼之根本
    心由色无色界中解脱 以住不掉裂破戏论网
    闍摩他智制伏诸烦恼 为由欲界之心中解脱
    如彼之修不作自然成 断证无二自心起助伴
    能所自解功德圆满具 即为心觉无上大等引
    由彼而起后得放任行 所现自性如梦亦如幻
    如阳焰光影声响影像 亦如水月幻化体性空
    如无现有恍恍渺茫然 杳杳惚惚枉枉放任然
    行于现分无执之状态 时时出离厌离由衷生
    恒作死念习力捨筹谋 净相无分敬信续不断
    勤修皈依发心二资粮 善恶业果轮廻过患观
    总之念照省察于心中 恒常了知谨慎当所依
    暂以现有幻化之习力 根本后得契恶缘道用
    于见修义中出诸得益 六聚自解观五门戏剧
    间或置于性澄专一义 专一即成闍摩他禅定
    如彼本明不入于闲暇 入于外内徧计五毒流
    刹那自解勝观当习力 破转恶缘心之戏剧生
    暂趣山顶尸林寂静处 喜怖愁苦生处当寻至
    身则但观六道诸苦乐 刹那不闲精进习自解
    观照择定之于见修行 其后学习现有如梦幻
    迅速得证勝共二悉地 不顺恶缘障碍无馀除
    间或若生大病魔变异 海洲林薮崖谷洞窟间
    行至鬼于部多出没处 皈依发心信解上师行
    随后身即幻化如须弥 随其所欲破裂施十方
    障者遂意六道债主净 復次现病魔鬼诸执鬼
    心中決定心乃空性体 安置念思诸意之寻求
    一切同等离畏安于眠 种种变异自升自平息
    因此止息病魔诸障碍 无有心之苦乐与取捨
    诸如虚空了悟无能所 原始体中本明力自在
    復又日夜六时如此习 黎明性澄犹如无云空
    识无分别如天星罗列 午前迁流安止无二中
    刹那自解勝观赤裸置 正午净相信解无方分
    种种诸法习如梦如幻 午后生起厌离出离法
    由衷无常念死应当修 黄昏蕴集聚会荟供轮
    修习慈悲乐明与无念 午夜心性无生之体中
    本明收散住融中安眠 眠与梦寐升起大光明
    如彼威仪六时中修习 轮廻徧计习气自息后
    心性自解涅槃趣寂灭 天眼神通种种功德成
    最初能转恶梦成美梦 中能执受后销于法界
    彼时轮廻解脱趣涅槃 地道圆满生圆至究竟
    即生心性圆满正等觉 此是了义藏要之妙乘
    要诀心藏确定之验兆 次第修习事业依此生
    由衷无常捨诸籌謀计 厌离出离慈悲无量生
    净相信解悟证无方分 贪执自解执实迷妄销
    彼时入于无讹道验兆 最极增上成就殊勝地
    诸法不生幻化自性中 以见修行善加习力之
    藏要心性解脱善妙殿 握持法性光明之常有
    一旦瑜伽四大种之蕴 彼其时中地水火风识
    虚空法身光明成就时 六聚根境阿赖耶藏识
    入于含藏融真性法身 彼时明增得及近得相
    极无分别光明四种相 依此升现八十性妄没
    识本面目解脱法身界 復次报身五佛之中有
    静虑清静五日次第现 识本面目报身解脱时
    化身中有种种相纷现 行利他故復又融报身
    报身极融法身之状态 法身不动汇集归乐界
    身智内昭不即亦不离 于升基之相细微本智
    居一切智无有区分别 如空不生不灭任运成
    若有所化于彼外显明 报身五佛现化身升基
    復次如前基始任运成 此即中根中有解脱法
    下根有趣中有次第显 如梦种种显现之时分
    无实性澄幻化生圆法 皈依发心上师之瑜伽
    遮轮廻因修塞阻胎门 当行迁识转往生净土
    来世自显于法受用身 得具七功德后即解脱
    此是更深秘要之教诀 诸友日夜不闲精进行
    见之习力修之实践法 行之得益于义当切实
    粗劣方所刹那不放捨 如语所云修行精进为
    当下之心若未得自主 未来之心亦不得解脱
    人寿迅疾轮廻无边际 因此今朝当寻解脱法
    总之无始轮廻漂流转 二执熏染我执所生故
    常行无实空性之自性 心性勝王无劬劳修习
    直至具有我执迷妄心 见修习力重善恶取捨
    一旦二执若本地解脱 不需断治超越见修法
    彼时升起现有於法身 妙哉众友轮涅无有他
    一切法界心性游戏体 基解道解果本来解脱
    一切自解幻化之游戏 此是升起无意向所现
    一切为彼是故捨执著 究竟义中无妄无妄者
    决定无有修与无修者 行与所行繁多任意为
    随现义中即为无执著 无执无著无谋无偏私
    无我空性无二任运成 不住轮廻亦不住涅槃
    即诸经续口诀之密意 此是佛子无垢光所造
    藏要教授无馀悉开显 後世欲求即生解脱者
    持此甚深妙义精进行
    大圆满法性自解脱·修道解脱品第二
    如彼基道证悟究竟后 无垢自性心性极清静
    销没种种心之诸用者 法界及与本智成一味
    为持法身勝王之常有 彼时如空自性离戏论
    超越一切偏堕广狭边 具二清静法性无迁转
    彼性体中任运之报身 自显清静奥明密严境
    光明五种智之净土中 寂静忿怒五种姓坛城
    上下方隅所显遍虚空 证知无数主眷同一体
    相好庄严光辉赫燃盛 一切悉具五身五种智
    不动不语大离言诠者 力等功德渡海至彼岸
    行相事业三身显神变 此是本智报身之导师
    由彼体中于所化世间 显现能化导师五种姓
    犹如虚空月映水月影 行住刹土奥明妙喜界
    妙宝悉遍极乐之世界 事业极成毗卢不动佛
    宝生无量光不空五佛 愚昧嗔恨我慢及贪欲
    嫉等净故各显之导师 相好照镜而所行之事
    勝者之身及汇光明性 不见自身伦比之类者
    由此证悟法性极净治 十地十垢次第清静治
    行做安置普光之事业 所化乃至能化显现者
    虚空所遍诸等亦同遍 此是所谓自性之化身
    由彼体中出六道世间 以六能仁无尽之神变
    利益众生如理如意示 自与所现如其而利益
    此是所谓化众之化身 由此体中种种变化身
    工巧自至身语意所依 天与图绘文字诸等等
    池潢度桥妙舍与林苑 地水火风莲花悦意树
    珠宝灯炬医药勝妙食 衣服严具等需之变现
    现世幸福究竟妙善道 具诸安置众生之事业
    无心以现粗色作利益 稀有无边勝者大悲心
    此谓种种不定之化身 如彼三身导师虽无量
    无所化时能化没法界 如前彼之自性无分别
    彼又由下渐次一一融 漩归任运法身一乐界
    内昭升基智极细微性 一切智性寂中常安住
    若有所化如上如前显 为行一切相智之利益
    此是究竟決定之妙果 无垢光作显明阐开示
    有缘欲求了义善道者 当持常有任运自然地
    大圆满法性自解脱中·殊勝果解脱品第三
    如彼法理深广大 无垢光所开显之
    廻善众生离有暗 愿开心性正觉莲
    藏要口诀此云鬘 雪山蜕嘎咕处造
    有缘澍以甘露雨 愿显善妙广十方
    大圆满法性自解脱，吉祥邬坚大阿闍黎狮子吼声之随行得加持，瑜伽士无垢光，造于雪山蜕嘎咕。众妙吉祥，善哉！

    注释
    无边：深度及广度二者均无边际。
    本理：指诸法之体性或实有圆满之自性。亦有译为实相或本性者。
    虚空性：指如虚空之状态。
    翳：眼睛上所生一种障蔽视线的薄膜，眼疾之一。
    游丝：眼疾之一，类灰蚊症，视物时眼前似有如发丝粗细之线条游移。
    怖畏处解脱：了知怖畏其自性者，即能于其处中得解脱怖畏，不復怖畏。
    迷有：迷于轮廻。
    二现：能所二执所显现之能显现与所显现法。
    噫(山戲)：具稀有意味之惊叹词。
    约：就...而言之谓。
    如何显现如彼不成立：云不论如何而显现，即如彼所显现而不成立。
    本解同等：本来解脱同等无有高下。
    空：指虚空。
    执方分宗义：原云执方成就之极限，亦即有所执著成就之极就，「成就之极限」即「宗义」一词之词义，故译「执方宗义」。
    声缘唯识自续中观宗：即显教四大宗义诸见趣，声缘中为说一切有部经量部、唯识分真相、假相唯识、中观分中观自续派、应成派等诸流。
    正行：即显宗各宗趣所修之主要范畴。
    四：指 是常非断边、是断非常边、是常是断边、非常非断边，或指生灭、有无、常断、现空四边。
    事部行部瑜伽无上密：即密宗的四续。
    其余施设诸等生灭数：其余诸派或有认为于第一刹那生起妄念，能于第二刹那上灭除，如于生灭上施设诸法，以为大圆满法。
    本然：原始、本原之意，从仰兑译名。
    等圆：平等圆满之略词。
    体：指其状态而言。
    无缘：无所缘求，无所攀缘。
    粗色：即指物质。
    无垢光明：即龙钦巴祖师之名讳，无垢光尊者。
    性澄：本明状态性质中之澄净部分谓之。或为本初以来之澄净。
    沈：昏沈、掉举之略称，集论云：「云何昏沈？谓：痴分摄，心无堪能，与一切烦恼及随烦恼助伴为业」，「云何掉举？净相随转，贪分所摄，心不静照，障止为业」，昏沈障明显，掉举障无分别住（坚固），对治昏沈掉举当用正知正念之法。
    掉：（释详上释）
    彼：指前所开示之法均为根本位中事。
    恍恍、渺茫然、杳杳、惚惚、枉仼、放任然等句，均为古藏文藻饰词，同表似真非真、若有若无之意。
    观五门戏剧：观色声香味触如戏剧虚假。
    部多：梵云Bhutah，无色身，能作恼害的一种鬼魔。
    所化：所教花之对象，指弟子之属。
    有趣中有：或译为投生中有。
    具二清静：自他二种清静。
    「相好照镜......之事业」之句：本段意义十分晦涩，阿闍黎释时云：「大约指十地菩萨欲等至十一地佛地时，需受灌顶，灌顶时由五佛自五刹土放光灌顶之事业。」创古仁波且则云：「报身佛体性如照镜反影般，显现相好庄严之像，勝者（佛）身放射汇集光明，佛身光明无有伦比，吾人循此而修证悟法性，极净治垢障渐次渐次依禅定力，清静十地，十种修断之垢染，就近到达第十一地（佛地），如前成就庄严功德。」
    由下渐次：由化身依此向上至殊勝化身、报身、法身。


大圆满平等性自解脱论本颂

    大圆满平等性自解脱论本颂

    无垢光尊者

    梵云:摩诃珊底萨麻果拿麻
    藏云:卓巴钦波谅尼郎卓
    汉云:大圆满平等性自解脱论

    敬礼吉祥普贤王如来
    诸法平等性本初菩提 无诠超思空界平坦界
    无住无缘大圆满本性 清静菩提心前虔敬礼
    一切金刚顶巅之妙乘 超越因果离取捨犹豫
    是诸是何无有认持故 离堕偏私义理当谛听
    现有轮涅本解奥明处 种种无碍智慧越量中
    平等圆满示法性无异 情器六续三身眷属众
    三时无时基圆清静时 教示无有取捨勤修法
    外内作业之法虽无量 圣教九乘开演所讲说
    彼等自性根器次第者 于了义中彼诸如虚空
    无有宗乘亦无有出离 无来无去无断治离得
    一切法性无迁转体性 如何所显依何无自性
    假立因果外内菩提心 是为本初光明任运体
    成立除遣无缘自生智 外内劬劳无有何可寻
    无整安置本然法性体 三时无迁转之任意为
    谓此无有所缘之能所 及与破立取捨置本地
    烦恼不断自生之五智 随现性中自解无取捨
    不需断转心觉大圆具 本置自生当下任运成
    种种凡常自圆大坛城 无作自生广大越量宫
    于色受想行识诸蕴处 五佛地水火风空之界
    五佛母自性现有清静 不需取捨修整对治空
    一切等味大圆满体性 了知基圆满本初清静
    本空离根本之心性者 无作任运成就之正觉
    如是安置如彼平等住 无始终时无前后迁转
    无计无偏超越诸蓋障 无所至境亦无所行道
    于无体性所欲何净行 彼等虚空能修整穷尽
    自生智离诸修染造作 月亮之海染浊本来无
    净与不净一界大游戏 此为更深密要密意界
    一切遍作法性极宽广 一切藏要自性广微妙
    体性显明大悲无遮碍 如是性中如实任运成
    一界法性虚空自性中 馀法纵如微尘亦无缘
    法相现空法性神变中 自性任运乃升起游戏
    情器现有三世正等觉 如来性外馀诸无所缘
    本初无作自性清静故 倏尔不契体性知解脱
    不需劬劳离诸因与缘 自性是他是诸无认持
    如何观察彼为僅倏尔 若观不住观已体性空
    是非为心离心为法身 非有他离随现为无执
    一之自性如犹虚空者 相异心之宗义诸多显
    总摄大圆满菩提心者 如虚空周遍而划分故
    即是一切诸法大生处 种种诸法等圆游戏中
    苦乐高下幻化水月影 无中生有于义无所染
    任运圆满无二本体性 纵如何现如彼不成立
    因果无二离增益减损 具有观待授记善恶乘
    与真实义何时亦不遇 圣义之中不生本清静
    显时无缘离能所戏论 除彼馀者任何亦不缘
    超越因果故本然不见 又復若许因果业缘法
    是以此现自性而观察 外在五境初因果为何
    心之自性为何何所生 如彼究竟如虚空无实
    超因果故本初之法性 不作不生決定任运成
    于彼执著劬修有何为 诸法本来即空即无我
    无明执故漂流有趣中 从而显现种种诸苦乐
    犹如梦中实事不成立 不作自性清静之正觉
    本空离诸基根应当知 诸等以心观察体性空
    一与相异无二诸法等 未擅执实有故自性缚
    种种宗义樊笼无解脱 权实因果教义随行者
    以心安立法轮恒常转 如此因位之乘有三种
    用以断灭对治净心性 自生本智自然无整染
    三大劫等不转得解脱 承许果乘宗门有二类
    外三秘密咒乘事续者 一切一界清静之法性
    主仆规式二执作取捨 犹豫樊笼何时亦无解
    执一与二故为所沾染 行续自性清静之法性
    如亲友故二执迷妄染 一体性中区别二取捨
    何时亦无能睹真实藏 瑜伽五现觉及四神变
    真如性中作修染亦尽 本来不生其后亦无成
    心性真义之藏无得见 一切均为十六七三世
    障蔽元始自性解脱地 内三乘中摩诃清静心
    四种近修集散作修治 若是本有无需修整治
    若非本有无益如空结 不见无有取捨之体性
    阿鲁瑜伽界智无有二 于一藏中作修整因果
    虚空自性无二清静中 以乐与空任何有何为
    阿底生圆无二菩提心 远离边际性中心性缚
    以虚空绳缚于心性尽 唯空方分深邃孰能制
    不识一切所显之实性 不知诸法等圆同一义
    与之断分相顺之瑜伽 了知心者孰人极依止
    如是彼等劬修与断取 无所缘性自心无垢缚
    无有证知藏要真如力 恶缘恶法恶宗义之故
    不见无有断证之自性 趣行于道復且行于地
    以辛勤病苦恼之誓句 禁戒不净轮廻之因缚
    无能达至自生智密义 菩提性亦虚空之自性
    菩提性亦虚空之体性 菩提道中孰人有行趣
    行于虚空界中趣行心 乃见无又取捨造作义
    诸法不生无有蓋障蔽 以心执取乃生二染障
    无体性中用行而沾染 于无观中用观生蓋障
    依因果乘中各宗本论 如何辛勤乃至极精进
    以染障故不能见本然 以依何善觅求善妙时
    如何觅求如许染蓋障 若欲得见不觅求妙法
    自性善妙坚决定观待 如彼清静之心而觅心
    所觅之事觅者反作迷 此为本来清静之心性
    修整对治不寻本自安 同一自生观之为九乘
    染障不起如水波不兴 视之不见觅之不可得
    本无证违安置自性中 本智无知无深寂细微
    无二无系超越增损边 何如自如本如任运成
    是何彼中是诸大安置 不需辛勤黾勉于任运
    观待无有有何所观见 因此诸法不生之法性
    超绝因果真如明显观 此乃上师口诀藏要义
    法性之义虚空无中边 不依因果生圆次第道
    心性勝王任运功德圆 无执希求安置之禅定
    藏要心性不见超思境 种种戏论增益分别伺
    本初本理不见超心思 种种方便法海之妙宝
    如实性乃如始不可见 悉置若离犹疑彼自性
    有于何处观见即非见 除此馀诸修造诩善妙
    犹豫二意发起障自性 种种法数异门同一义
    藏要心性本然无整治 三身净土导师眷属处
    教法等五圆满自性者 如彼之识无作宽坦住
    过未三时轮涅游戏心 无馀摄一安住之体性
    藏要自安菩提真如性 本来正觉当下之法性
    升起不坐本来净密意 种种相帜而表无可示
    言词文字真性安可尽 臻至宗乘名数顶巅心
    菩提心集真性证悟故 一切一界分别而阐释
    此乃无馀決定秘密藏 以此为见心之真性理
    恶缘众等何时亦不悟 如于愚盲人前示影相
    相与缘起方便知何有 善缘众前如日光莲花
    上师恩德悟证生于内 自之体性三时平等性
    法与法性无念自然置 本来菩提自性清静故
    倏尔（耳+訦-言）执不缚任意游 法与法相法性平等体
    随现本明自生游戏时 自解自恣无整染安置
    心性不造法身游戏中 无散执持静虑之椿橛
    涵摄一多悟不悟平等 优劣得失尘许亦不缘
    令不缚于见修行锁镣 本来即是无散不散逸
    归一执心犹疑迷妄意 执持无缘是中作束缚
    心与心性二者无所缘 空与不空平等之体性
    升住为何本来即如何 于彼破立贪嗔悉不为
    依何所现如彼而契入 无念如空清静之法身
    种种现心游戏大戏剧 不生离戏具生起神变
    分别伺念思寻悉不染 为何体中随现入游戏
    一切均是法性悉平坦 不作取捨置于真如性
    如何不动如彼平等住 本如无有高下本始住
    无念无有中边真如置 离勤法身无色无表示
    离执寂灭无实真如性 离作虚空心性无所修
    悟与不悟平等率意置 所居无道众等之大病
    辛劳之毒心中作忧苦 如何黾免亦轮廻因果
    于解脱道何时亦不至 粗品之心串习黑与白
    彼欲界中执持善恶趣 明分之心诸善能涵(氵+需)
    色界性中投四种静虑 凡诸无念之心极不动
    彼无色中四相边等转 本然心中谁作修整染
    如何整治彼以无念生 无由轮廻处得解脱时
    三时同一本初大菩提 如空离思自性平等体
    唯名无缘无伦无有相 稀有珍奇广大之游戏
    基圆离诠无说任运成 无执不动自性清静土
    无泯不没勝幢大虚空 一切心性光明之藏要
    不紧不缓众聚庄严众 无二任置如实离戏论
    离劬现分空之境心中 谓此非表自性宽坦置
    依其而空不造法身体 无念平等勝王任运成
    勝王无垢如是无取捨 元始正觉超越因果性
    不生任圆当下之心性 随现无整染者见地义
    自性大圆满之本性矣 法性不动虽不逾于一
    法相无碍各各显分明 极寂不生如虚空清静
    不生如是智无葢障蔽 普遍离方勝密大圆满
    基根无有实之自性中 不需能所劬劳修法成
    如是体中如实以了知 秘密大海极喧扬之语
    任运圆满游戏随现戏 取捨无缘本解大宽广
    了知自解自恣本初体 证悟山王极其不动故
    游于任运广大明点界
    大圆满平等性自解脱论.上根证悟基解脱品第一
    如彼见地大勤作之体 了知自恣如是宽坦时
    随现自解性澄如汪洋 无修无散离二执思诠
    自生本明无有修整治 即为自性本净之修行
    悟与不悟平等法性中 静虑执心缚而故不染
    置于迁住无二本初体 不集不散不修平常体
    任置本明等圆无所为 无有修与不修悉決断
    如是体中如始宽坦置 生圆禅定乐明无念等
    乃至作意而为无念智 习气彼唯轮廻之因果
    有相无相极寂如虚空点 上界生处相续轮廻成
    于诸业与习气悉无二 不修禅定超越寻伺意
    彼无有趣亦无有趣苦 无生离尘无相离希冀
    不寻自置修习之勝王 如是体中无纤毫动摇
    以见基性一如证悟义 如何而释无有取捨心
    自置离恃本置本明者 握持无执法身王常有
    一界本初之地当下至 至已无有成就三身果
    所谓正觉菩提之自性 远离现前二种犹疑虑
    自生任运普贤王刹土 无整置大本然任运成
    藏要心性无轮替之道 无修如河流续而安住
    染障无二汇流一乐界 以无成不成就心得乐
    无是无非同一同等故 一切基圆即是普贤王
    无有颜色认辨之本明 无有成不成就而決断
    如是无整平常闲缓置 种种集散自生智光華
    如水水波善与恶无缘 一切亦即自生无劬劳
    自解本初清静之见地 不断自任普圆同一体
    松紧无二自生大本智 离劬体中超越念思想
    即为光明心性清静修 现有诸法不生空性体
    三修宽坦安置真如性 世俗藏要建立本明体
    即是外内能所执无二 随现义中于彼无所执
    保认自升本明自解义 密意不动座座间一体
    三时无时平等任运成 境心如何而显亦法性
    基置为最勝修超念思 等空等引摄一任圆者
    一切不生升起大乐戏 无有自生修习藏要者
    了知平常无造湛然中 若迁自解若住平等性
    烦恼本性空明五种智 不需断治净转本初体
    等虚空无生法身游戏 藏要无有表相之智中
    自声无修之作任意为 无思远离犹豫之识中
    缚解本初无缘无基根 由何所缚彼中而解脱
    烦恼对治无二真如性 如是境中功过亦无二
    遍作本明大自恣而置 无整本然置无方分体
    所谓空与无相无缘故 一界真如性中心安置
    谛听如此归一于了义 世间所造诸业与诸法
    作而不持自性置即持 因此无需劬劳修习法
    如何審察依何束缚因 为成不成就犹豫樊笼
    自恣自置如是性中住 以遮过去诸法无有修
    未来不生无有所修境 当下之心无修与能修
    三时平等性超诸修境 因此不执所修习之心
    了知自恣任置安彼中 不可思议大乐決定诀
    于诸安住平等大圆性 方便智慧无二藏要义
    不生离方超越诸增减 不灭诸想境等真如性
    不缘能执断治本地解 不修宽坦平等大圆满
    不堕宽窄高下偏私方 不断犹疑绝断之体中
    不思集散坏灭菩提心 普昭自性清静体中置
    种种现称诸法心本体 心性不动自性本初体
    无法法性中所決定故 轮涅不缘平等圆满体
    无有念思寻探平等置 涵摄一多不执为有二
    任运远离犹疑虚空中 无散逸离戏论之识中
    离堕偏私方分法而置 增广高矗中边平坦生
    不收不放自昭观摄一 平整普遍一界本初体
    思圆满智光明内中生 虽普欲入于无二之义
    意持法中众生不超越 乘门高低同义无藏要
    了义离诠不生极清静 新性不动正觉自性中
    整治劬修由外欲清静 断轮廻而寻求出苦趣
    以愚蒙故不见藏要义 于修之后无修圆满法
    如空无垢所欲生为何 不见于彼见地之本性
    于外清静无修如何生 以此悟观串习起功德
    然则证悟善恶无迁转 如彼了知为善巧士夫
    愚夫不解执持因果量 因缘实有缘起无量法
    心性无实义理劬修作 此是观见种子能生芽
    净治虚空希欲因果尽 极其无关彼此具违碍
    于无实心整治有何为 如虚空林园植生苗芽
    于无实真如性不整治 如此法理不可思议者
    地等实有显现之诸法 因生缘转能为诸种种
    空与真如性法清静中 劬劳黾勉不成无迁转
    如彼于心习气迷妄遍 依此劬劳轮廻续不断
    心性不动始终无迁转 因此心性清静之正觉
    不作整治置于真如性 修整虚空徒劳故不为
    成不成就无有自性故 证与不证二者亦无执
    于自生法所生如实置 不整如实安置本初体
    藏要光明相续无间断 任置体中置于大自恣
    性澄光明如日月之心 于焉而生具喜乐饶益
    于此无有优劣之法故 离缘无劬以乐遍身心
    普解本初如是无所缘 不作自性清静之勝王
    离方分智显现能生起 总摄自置不异藏要义
    如是不改安住修本体 依此而为升起所修习
    无修随起而置无散逸 即为究竟大任运修行
    见修得益行之次第者 幻化变化无二如水月
    六时威仪行于普贤行 于诸若有善恶即非行
    当知离于取捨与犹疑 希欲诸境无论为何者
    若有执著破立即非行 依此以幻幻化之诸境
    如何而行亦如无执著 瑜伽行者无执游戏行
    于法一切无些许认持 如无而现于义无所执
    无二自解大圆满本体 如是性中如彼而所行
    谓此为有二所行之心 不是元始自性迷妄意
    虽行离边復堕彼之边 所欲幻化何者之笼缚
    于自心本解脱大法性 行与无行取捨无有二
    以辛勤病不作忧苦恼 如是无二如是性中置
    一切一界平等之体性 本初之智心性大圆满
    自生之意藏要何易行 任运圆满令不作劬修
    以为原理令不作修整 以为本始令不成新造
    无有证违令不作改治 以无偏私令不执谓此
    以无轮涅令不作犹疑 以无善恶令不作取捨
    虽依彼修及与其所行 自心以外馀诸不动摇
    于彼断捨供忏有何为 受缚静虑于心之大病
    于清静心执持而不染 随现勝王如是而游戏
    若无善恶取捨即为行 于何谓此有尘许执著
    于彼彼中述说大染障 无量虚空之界无所执
    清静心性虚空表为行 现境方便于意乃为慧
    能所不缘大放任而行 福德智慧生圆悉清静
    游戏无碍幻化任运成 现心体性不生法身中
    自性无碍昭空受用圆 灿然升解化身同等中
    一切三身大智中而行 现而无念游戏升现时
    因果乘之功德无馀圆 彼亦心性静虑大宝藏
    为有寂平等性大圆满 本初清静体性观见时
    假名安立所谓极喜地 二执无染无垢无垢地
    能法悟光发光焰慧地 非诸等境难勝现前地
    出有远行法性不动地 具足诸中最勝善慧地
    智日无有垢染法云地 以分区别如此开十地
    见无二义资粮加行合 极证悟见义熏习修道
    执持常有故谓无学果 三门大智基处清静故
    瓶密慧词四种灌顶法 境心现空生圆双运等
    尽有分别如彼具功德 不寻任运成就大圆满
    超越作法思惟为所见 视之不见修之无所成
    觅之不得超诸劬黾作 自心藏要不异正等觉
    有即一切轮涅本初有 遍即三时无有前后遍
    是即超越法界因果是 见之因相无实如虚空
    于自生智基处不动摇 如海本性光明极澄净
    于境无念昭显真如性 如脸本在不观待缘法
    若观待境即非本自生 为他生故成种种动摇
    因此诸时自生无迁转 升基无碍三身无聚散
    于自性空体性昭明中 大悲无碍本明藏安住
    内昭不动如是任运成 于境随现分别之本智
    称为功用或可成韵智 如浪或如镜中之影像
    有境为缘升起于心中 无则不生系属成立者
    升于自体假立为自生 非常续故他生缘之境
    即为集散游戏无有碍 復又于为基处自生界
    于境所起之识为智者 如是安置即为无有二
    不知此义愚昧之静虑 或有置于界性或有寻
    以持息灭想受之执心 色与无色习气轮廻成
    或有境智观之于外者 谓自解脱集散分别引
    徧计戏论缚欲界轮廻 界智无二其无有分别
    或有生圆种种因果法 障蔽藏要心性本然义
    轮廻都邑无有解脱期待 于此随现无有取捨时
    性澄法界之中決本明 无二归一汇流乐界时
    迁止无二解脱大等圆 为体为本亦为大圆满
    不需取捨即为大心觉 本初无有分别之心性
    当下随现不应不耐持 现心无念解脱法身土
    后于等圆真如无所成 同一自生升现六境时
    不需伺察如是宽坦置 如镜镜相无二二清晰
    界与智亦无二任运成 随现于境不散释于外
    心性澄净色相唯游戏 一切一界本来了知故
    自生本智无修染之义 为示超越因果之体性
    如何以心庄严之诸法 为习气故因果漂轮廻
    苦乐善恶种种各各显 犹如种子相异而生果
    如是不整心性光明者 因果无二本来无劬劳
    如空不生不灭亦不住 三时无诠迁转逾思惟
    不寻任运而成无功过 游戏无有碍故于法界
    于一自性令不作整染 行之不至治之不得净
    觅之不得如是宽坦置 身智功德任运而成就
    无整真如性中安置成 不作殷勤心性大虚空
    本来清静不需劬因果 若欲自心法身任运义
    弃执缘取随所现境心 若无谓此专执则现前
    为诸为一以无意向故 任置离方本明无等性
    于法不作作已无所执 无执自置不作修整染
    为何为诸为此不定故 置于离边界广大圆满
    若有安处即非大圆满 为何为此令不作认持
    大圆满平等性自解脱论.串习道解脱品第二
    如彼基道界明究竟时 基圆满果本初任运成
    自利法身利他二色身 界智无二不即亦不离
    轮涅无二本明界同一 安住涅槃离诸戏论时
    即谓普贤无分别之地 此是不住思圆法身性
    自性本初清静之法性 真如性中细微之智者
    内昭升基无碍一切智 身与智者不即亦不离
    禅定不动平等大圆地 如是体中安立于外相
    光明现故普贤王父母 集散游戏轮大会集地
    如是性中寂静五佛刹 光明任圆自所现清静
    处与师法眷属时等等 五种圆满显现于五者
    法界圆镜平等妙观察 成所作智此五五自性
    即谓所云密严之刹土 如是性中忿怒之刹土
    显现坛城自圆五种性 身与智等虚空相和合
    即是所谓金刚持刹土 如是性中十地之勇识
    毗卢不动宝生无量光 不空成就眷属续净故
    行大圆镜利益于所化 即谓不住具莲之净土
    如是性中不净所化众 调众六种能仁与受生
    事业及与必需诸资具 总之应机显现示色身
    各各显现利益于众生 此即所谓普光之净土
    以日光辉能显四大洲 如莲含苞能生起欢喜
    变化之光显明能周遍 普贤无分别与禅定者
    无二法身地息诸戏论 大资粮密严与金刚持
    自显报身刹土光明及 开敷具莲及与普光辉
    自性御众种种化身土 行相事业无量任运成
    如彼身与智刹土众等 犹如虚空恒常遍无为
    直至解脱众生不断显 此是究竟本初之体性
    即为自性大圆满之果 非因果生为本来任运
    不作自性清静之心性 得见不为无劬造作义
    自恣本解自安界成者 即是本初任运而现前
    大圆满平等性自解脱论.大任运果品第三
    如是法理极稀有 雪山白顶宝藏处
    无垢光所发显明 此善愿除众生暗
    吉祥格萨显明王 采我心蜜生欢喜
    善说妙曲当聆听 具缘之士应欢喜

    大圆满平等性自解脱论本颂注释
    六续：即六道。
    外菩提心：外指显教性相宗，内指密教。
    越量宫：本尊所居之因与规模之量及功德均不可比拟之宫殿，或称无量宫、安堵宫。
    五佛：
    清静色蕴、毗卢遮那佛
    清静受蕴、宝生佛
    清静想蕴、无量光佛
    清静行蕴、不空成就佛
    清静识蕴、不动佛
    五佛母：
    清静地界、佛眼佛母
    清静水界、摩摩枳佛母
    清静火界、白衣佛母
    清静风界、三昧耶佛母
    清静空界、法界自在佛母
    净行：所净之烦恼五毒及所行之五道十地等途之略称。
    月亮之海：指无边之虚空。
    游戏：云所有行止活动一切无实，譬如游戏，种种行仪，无非虚假。大圆满、大手印之教法中没用此表吾等凡夫之行为作业。
    五现觉：亦称现觉五次第，生起次第观想时，观莲座上有韵母（阿哩）生起月轮，声母（嘎哩）生起日轮，中央生起本尊手帜，标以种字，由此放射回摄光芒合悉转成本尊身形出现，此五段生起名现觉五次第，此中有表清静四生习气，具足五智之功用。若缺此步骤不能称为修生起次第。
    四神变：指禅定、加持、灌顶、供养此四种神变。
    十六七三：十六生、七生、三生之义也。
    四种近修：生起次第实修中，以闭关专修欲与本尊相应之四种层次之法，即诵修支、近诵支、修成支、大修成支。
    空结：虚空结。
    悉置：指一切完全不加思索、直接不造作而安置任凭之意。
    等空：如虚空平等普遍之义也。
    现称：现指现分，一切所显现之人、物。称指有情无情所出所称之声音。
    界明：法界与本明之合称。
    轮大会集地：指报身自显五佛刹。
    毗卢：藏文作清静，以五佛之名号应为毗卢，故译之。
    普贤无分别与禅定者：法身普贤无分别地及法身禅定地二者。
    大资粮密严与金刚持：报身之大资粮净土、密严净土、金刚持净土。
    开敷具莲及与普光辉：化身之具莲及普光土。


大圆满心性自解脱论本颂

    大圆满心性自解脱论本颂

无垢光尊者

    梵云:摩诃珊底即打大索木帝那麻
    藏云:卓巴钦波森尼郎卓
    汉云:大圆满心性自解脱论
    敬礼吉祥普贤王如来
    体性清净超越思惟境 自性任运藏要韵升起
    性相灿然能所清净心 离诸广狭偏堕前顶礼
    诸法不生平等体性中 现心本解无执平坦然
    希有勝王心性自解脱 依我所证解说当谛听
    见地清净无有中边分 此谓非表无广狭高低
    超越常断离诸四边垢 觅之不得视之不可见
    离诸方分普超思惟境 无成就际亦无空非空
    无证不证无筹计意向 诸法本来清净菩提故
    不生不灭无言诠思惟 净与不净自性清净界
    一切无缘大平等圆性 无缚解故无住无来去
    现空徧计能所幻化中 轮涅苦乐如同善恶梦
    显现时中自性离戏论 由此广大生灭缘起性
    如同梦幻阳焰寻香城 声响影像等无有体性
    生等诸法自性不生故 何时不灭三时无迁转
    无所从来亦无所从去 无有所住如梦亦如幻
    未解於此执谛实显现 恒常於法有我持我执
    如触虚幻少女而坏漏 受欺不实所显而行事
    六道处所及与诸佛地 非微尘集众生心自显
    依彼梦境佛与有情众 谛与似谛自性虽无量
    若醒觉时刹那意境相 如此当知轮涅之诸法
    现分所反空性无所有 犹加火与火之自性热
    信解相异心作分别者 水与水月无别同一沼
    如是现空大法性同一 此现本初不生妙法身
    无垢自性清净如影像 於彼有无意察迷妄者
    随现事中令不作攀缘 彼所现境亦为心影相
    犹加容颜及与镜中像 即如无二而所现二者
    无始习气串习之自性 心与眠梦虽无有二事
    如沈睡中所现之梦境 当知是中体性无有异
    犹如幼童揽镜照影时 以蒙昧故外境作破立
    其母见已拂拭彼镜明 以因果乘外境作修整
    妙母见时如彼作拂拭 如是了知谛观内心性
    此乃无实藏要之宗乘 心何体性无有中种种
    外境为缘升现於内在 一如镜中显现海影相
    体性空中自性无遮碍 性相灿然显现之变化
    同一心性引出轮涅二 一如黑白布中里晶石
    体性不异升基缘所现 所现种种现时虽变异
    於义不异加晶石澄净 本空离根本之心性中
    轮涅诸法显现而不染 三时无时普贤之状态
    基圆满无迁转之体性 六境显现不染如水月
    如无而显幻化之轮涅 取舍破立犹豫令不作
    了知幻化自性故解脱 虽见幻化军众而执持
    知其自性之故无怖畏 所现诸境不需排遣除
    轮廻自性即心之体性 本初不生以离苦趣者
    有趣自性见心性解脱 彼时寂灭馀无有成立
    自之军队为他怖畏中 其後了知复而得安乐
    而今吉祥上师加持下 有趣徧计直指即法身
    自恣大乐之内而升起 不需取舍现有起上师
    教授无尽一切菩提友 寂灭乐中心乐续不断
    一切意乐法性坦然中 种种法相无碍游戏者
    法身色身现空二资粮 方便慧根本後得任运
    无造自恣五身五种智 现心无执明体中圆满
    地道总持及与禅定等 功德任圆法性元始中
    离方本明广大自升中 能执不染所执无所缚
    幻化自性无二清净中 思惟言诠禅定修为何
    无生圆次无二无能所 无有宗义无宗乘差别
    彼等褊计心之绘摹者 自升体中自解唯假立
    为此无有意向本明中 调此之故无执绝超意
    无造自圆满之心性中 不染修整对治任意施
    证舆不证平等法性中 若不缚於静虑之樊笼
    本性义中无有无现空 离一多诸等无所表示
    超越见修无证违来去 离边无二谓幻化梦景
    二谛义理破执谛实後 本然义中无世俗勝义
    如何假立如彼无所住 谓此执著樊笼所束缚
    依何所欲亦堕执著边 以劬劳法流转而不息
    受善恶业报漂流有趣 苦乐高低还似辘轳转
    三时轮廻三界漂流转 无明徧计劬劳病所苦
    无始终时有情实可愍 悲夫彼诸一切唯梦幻
    了义中无轮廻轮廻者 一切本来解脱普贤体
    基根无实之故心安乐 无造本初清净心性中
    现有诸法不染如影像 所现之境能执无所缘
    自升意中所执无所缘 无二智中所显二出现
    是故境心无碍大庄严 无执大象漫游平原中
    自解脱行无二璎珞饰 踏平取舍疑虑芦苇丛
    持证悟力入于无二海 升解次第率性任流荡
    执断证对治绳而不缚 巨浪圆满见地护放任
    大力圆满现有起法身 六境无碍现者体性空
    离边心性无施解脱者 轮涅无二明至基元始
    谓得最胜成就当为之 自他二利圆满达究竟
    奥明天处现证正等觉 噫嚱有如牲畜静虑者
    遮止诸想後住无念中 调本性理执持增上慢
    如是熏习投生畜生道 未熟亦堕静虑无色界
    於轮廻中永无解脱时 因此执持至高增上慢
    执著各自宗义之邪魔 随奉作意徧计迷妄法
    徧计垢染不见法性义 所量二谛亦堕常断边
    所量离边亦示有顶见 如何而为亦受宗义缚
    元始之智何时亦不见 本然义受言思所缘蔽
    言思所缘不识本然故 所寻之义寻者作染污
    心智二者如水与湿性 一切时中悉不即不离
    取舍之意各分别所染 随现境心元始体性中
    执著方分分割虚空际 现若欲求无缘法身义
    於元始之境不作寻求 随起勝王弃捨执著缘
    不执方分此乃无认辨 如何而起如何亦不成
    依何显现依何无自性 平凡现心本解极湛然
    即是自性大圆满之见 诸法自性虽以虚空表
    虚空自性诸法无所缘 心性不生诸法加虚空
    唯人所云唯相唯假名 离是非方超越於思惟
    此谓无表本圆平等矣 噫嚱现有自性清净中
    无执本明倏尔清净升 仅升性中无住於任何
    一朝得见自解大圆满 离根本初清净之心性
    无所作因能作者意乐 一切无有意向本明中
    此是以摧专执实欣悦 於无偏方分堕之见修
    以无广狭高低实欢喜 无有取捨疑虑之行果
    无有证与不证实俨然 一切等圆幻化之自性
    无有善恶取捨实可喜 现心惚惚恍恍茫茫然
    杳杳冥冥洞然元始中 随现即是即现无所执
    是非即心离心为法身 无施於境无定起所现
    了知无执无二解脱时 现心诸法心之大游戏
    基根无实有之心性中 不作任运自成功德圆
    破立解脱法身心得乐 专为所缘一切修造者
    无缘随起起时智当体 取捨本地解脱心得乐
    取捨本地解脱超心境 无余自性清净之正觉
    自心性中不假外寻求 寻者染污所寻无颠倒
    如同幻化种与阳焰影 轮涅无二执著有二者
    自生本明无修整治尽 凡诸观见诸法平等义
    心性不生如虚空证悟 现有情器自性清净土
    不生而至自圆平等体 现心体性空故法身义
    自性无碍报身之显现 性相灿然了知化身故
    一切三身本智清净土 以无修整断治故心安
    噫嚱众生执著有二故 住此梦境迷妄轮廻时
    如何劬劳亦轮廻因果 无念含藏熏染故无色
    明空含藏识为色界中 六聚识中熏染迷欲界
    以心修整轮廻之阶梯 欲解脱者无造本然义
    於心无事悠然人闲缓 平常之识无作宽坦中
    执轮涅不染本地解脱 如彼解脱自恣刹那中
    於处无念法身体性中 升基无碍昭空受用圆
    若驰升解决断於化身 轮廻徧计决定出苦趣
    噫嚱现心自性虽变化 法身离意向之镜观待
    无施法中升起无所执 心之秘密馀者无所表
    任运本明随起藏要义 自性本安令不作修染
    诸法无实有之自性中 无执之心虚空无中边
    无作无有阻碍之自起 无执破立性相本然义
    当知三时无有迁转变 境心无二元始之本智
    由证故知所表示无示 胜义心性自性处庄严
    静虑不动伺察分辨慧 诸多经教口诀仅知境
    赤裸本智何时无能得 谓此虚空虽以指所表
    非所见境仅分辨了解 以上师恩现起於通达
    如以日光普消诸暗冥 以刹那明无间见法身
    无明世智烦恼为所表 以诸实有近侍无动摇
    即生当得勝共二悉地 愚氓劬求涅槃出苦趣
    永无得时弃捨如意珠 弃捨事业宝珠取其馀
    除拭净垢如寻琉璃瓦 心性自解脱之妙宝珠
    识本面目清净迷妄垢 了知此故功德大宝藏
    即为自他二利富足藏 若起心性本义之证悟
    如水水波迁住法身体 如何生起无需破立故
    一切时中心安之瑜伽 即为水流相续大瑜伽
    一切等圆大自性体中 唯明升起性澄净光明
    虽復一出真知法性体 光明本明无有中边时
    烦恼对治以无二之故 断治离得疑虑本地解
    宝珠明灯安立若不识 於灯火光执为宝珠光
    自解觉受静虑若不辨 执升解本身故作束缚
    不识觉受证悟之分别 串习觉受误执为证悟
    悟後诸时善恶无迁转 此中串习故生功德受
    如虚空中四大种迁转 任时不动虚空如前住
    如是心性证悟之瑜伽 增减觉受之悟无善恶
    若生善恶为觉受非悟 寻於决断殊勝证悟前
    其後不动如是平等住 修此即为了义之见地
    復又上根见此得解脱 不待串习一切生证悟
    以无所断无串习对治 如无病者何需服药石
    知离方分故无所持见
    大圆满心性自解脱论-----证悟基解脱品第一
    修行自恣大自解脱中 不需修整随起大圆满
    不需取捨本初状态中 外内轮涅诸法悉平等
    随生本明六聚悠宽坦 无造本明安置如赤子
    离根体中离意超绝出 无思勝王无变异任运
    平常之识无作悠闲缓 自恣之识如水入水中
    无二之识安置离整染 不作之识安住大法性
    心闲宽坦体性心安中 自恣巍然安置如耄耋
    座间不计大自升起体 自解脱明住於大放任
    无施本明广大洞澈中 无执本明放置如颠疯
    禁行本明无偏方分中 种种恶缘法性游戏起
    种种自心本明之变化 无有毁退安置如狮子
    镇伏妄相大智体性中 生力本明起大自解脱
    悟证体性於界不变异 昼夜无二安置如狐眼
    串习交契母子相会时 一切同等升起大恍惚
    离边本明无有中边中 此谓无表安置如虚空
    无修本明无有整染义 自生本明自性内升起
    离烦恼浊大自澄净中 性澄本明安置如大海
    升解本明犹加大波涛 面容与镜星曜影像升
    心性不动无迁转之中 法性不动安置如须弥
    等圆本明任圆满无为 勤作无二等捨任运成
    元始心性自起自解脱 相续不断安置如水流
    任生分别法身同一味 无需断证同等出苦趣
    总之随起法性游戏中 无缘自解等引自任运
    轮置无缘大修时体中 无有懈怠证悟当习力
    其之得益於道分缘中 以虚幻行取捨无二故
    恶缘为道正後得契故 山顶尸林海洲市集等
    趣至以境旌摇心之处 身舞足蹈口咏吟哦唱
    心作种种徧计戏论行 相契刹那自解见修体
    之後一切乃悉汇於道 间或现有上师之感戴
    集资净障无常死观修 现有诸法梦幻体性中
    如同声响阳焰影像幻 光影水月自性空性体
    种种所现非真惚惚中 学习刹那刹那无认持
    昼夜不散根本後得习 升解自住乐明无念中
    自住修习相续无间断 迷妄之梦无谛实光明
    昼夜相契轮涅本地解 以见耐久以修耐散漫
    以行耐缘以果耐歧途 证悟自性无念之智中
    诸时一切悉住无迁转 尔时同一自性本初地
    为於无修义中持常有 其後无有寻觅大乐果
    随起之明三身自任运 无有劬劳自他利益成
    起明功德离方分唯一 如彼即生解脱瑜伽士
    地水火风识光明融入 智性体中法界极相契
    为於本初之地持常有 利他二身之智如梦境
    为显众生所需之功德 此乃本明自性心秘密
    刹那本地解脱殊胜明 最极高大增上之功德
    受持一日增至十五间 如至月圆世间虽显现
    於义无有任何增减事 悟证之事见修力虽圆
    悟证不动串习功德生 以月明故遮障即为小
    或有小障蔽遮於圆月 二执离故觉受证增长
    证悟增长烦恼则转微 断证功德虽至究竟处
    体性不变自性无阻碍 法性种种困缘解脱净
    总之烦恼若不起证悟 於断五毒无有他勝道
    若不识此一身自解密 由执烦恼对治二所欺
    关要能所本地若不解 口说高见亦唯魔密语
    善静虑亦仅上趣乐果 如何劬劳唯轮廻因果
    见地宽广修习相圆融 行则珍重和缓解专执
    於诸升解无二广袤体 无施法中无散升起时
    瑜伽有趣大海离驰相 能执不缚所执无执著
    一切等圆法身汇乐界 翻山越岭过隘无所惧
    以臻自境超越诸疑虑 如被熏习四大种诸相
    无所执道煖相依此生 夙业及与上师之悲心
    时善方便缘起和合时 自生本明洞然澈充满
    升解无执增上悟证时 即为法性现前大现分
    观察外内所现定法身 如何起亦无取捨修整
    证悟习力一切悉升起 彼中了知辗转增上时
    学习外内破立恶缘道 升起解脱安住得安乐
    熟习故得天眼诸神通 若起本明种种诸功德
    当知即为验相增长现 由此更甚熏修转於界
    本明昭空赤裸之智中 沈掉无二亦无散不散
    根本後得无二恒如河 功德煖量殊胜证得时
    明量进诣得见显现时 如是体中恒常不动摇
    超相执无缘断治执境 一切等圆离专执意向
    执著外内之诸法若尽 为见法性穷尽之现分
    復次本明於基达究竟 法身体中色身得涅槃
    超越现执空性解脱时 为於本初之地持常有
    如彼串习时道未熟故 梦量亦有显示三种相
    初於现心以升解习力 若由恶梦转变成美梦
    恶业清净善业一味相 如火有烟种子生苗芽
    中为熟习故能持梦境 刹那解脱同时而出生
    对治性亦本地解脱相 转变於界极为熟习者
    梦境断续日夜住光明 轮廻编计法界隐没相
    自性涅槃之後同等故 近持常有於本初尽地
    三界三门解脱三身地 不住寂静法界而涅槃
    本来无证无违之心性 不需修整对治元始体
    执持方分偏狭诸解脱 无修无所修任运自然
    如彼了知凡常自解脱 外内无缘超越能所边
    破立自解断治元始起 为何为此无意向解脱
    不需取捨周遍之本智 离方大乐不寻自然成
    本解本原安置大全解 为何为此为诸无认辨
    无施无执超越有无边 噫山戲一方本来悉解脱
    无劬本明解脱平等性 任运圆满勝王无生灭
    无住无缘自性无言诠 一切无为元始体性中
    噫山戲 自性本初清净之现分 稀有开怀欢笑本明升
    境心无二现者体性空 此谓解脱大无表无施
    方便与慧平等同圆满 一切不动真如平等住
    曜舆星宿日期无所缘 超越时与会合而为境
    不住四洲须弥日月空 不缘坛城无诵念苦行
    不缘诸境脉界轮等空 外境亦如所现无所缘
    诸世间界五境体性空 一切不生自生越量宫
    不缘作者藏要义之尊 寻思集散本智大游戏
    诸境供云供养智尊故 资粮自圆言词大密咒
    烦恼本智自生圆次中 不需劬劳自性自运成
    地道圆满波罗蜜体中 不住中道双运而清净
    断治染障尘许亦不缘 随起不作修习自任运
    分别及与无分别诸法 黑白善恶业果唯缘起
    自体性空如影随不捨 普悉超越自解脱当知
    由善恶业成善恶轮廻 若超於业自性出苦趣
    苟作取捨决定解不善 虽成善业然不缚执著
    後寻无有取捨之义理 殷勤修成正士所证量
    断捨无益欺妄愚昧法 恒常依止殊勝善知识
    证悟前行无谬作闻思 孤独坚毅荒山寂野处
    於心坚决乃求勝义藏 行诸无常厌离捨营谋
    由衷(口/电)勉正法殷重修 今生若不趣行解脱道
    来世甚难值遇暇满法 修行勝幢立定寂静处
    观现立死有何可攜取 如此日夜以法为终结
    虽捨幻身心性无生死 即为执持不异法身王
    此生有义当得勝悉地 补特伽罗虽有中下根
    中有得解或来世善果 轮廻业中得取解脱道
    大乐处中执心性关要 此则即是了义之藏要
    行堕歧途则甚多染障 藏义真性何时亦不得
    今生劬劳来世无善果 因此当寻无讹见修道
    若无慈悲及与菩提心 决定沦为大乘道门外
    如何修习自续亦亏负 法与修士心是各自行
    若执修行外境与实有 证悟无二之缘决定无
    若不忆念出离厌离死 必为执著今生之魔欺
    虽修亦无能生新功德 蓋染深厚必生沈掉障
    失闍摩他即不握勝观 非为勝观则为妄念画
    面对知境虽说无二理 难敌恶缘五毒为伴侣
    以勝观力不持闍摩他 非止仅为愚痴之心住
    虽善静虑亦为善趣因 沈掉愚昧旁生之修行
    常行无执勝观本智力 圣士教示无垢证悟时
    持修行法一切菩提友 无造乐明无念於焉生
    非真如性亦非决定藏 若不悟此当下本明密
    修此执彼取捨网罟缚 所欲甚罕不欲如雨降
    希冀不成疑虑常损扰 饬身口意虽乐明无念
    童蒙持瓶破坏不得益 不作不坏功德出生处
    殷重探寻自恣元始证 饬身禁口摄心遮分别
    倏然朗然本明之前立 所持体中遮止想舆受
    静虑无色轮廻显成立 根官现境无分别昭现
    五毒自解大智之体性 沈掉中隙细微之明识
    执著所断谓粗中细者 驴等众精进所断方便
    前分之识後分作忆念 谓唯以受即见元始义
    生灭置数分别之补续 执无二义之修行错妄
    如何劬劳亦为分别网 後分生时前分遮遣法
    执著解脱非前後自解 方便道根大乐承修习
    执贪有故多生恶趣因 纵得善趣亦生卑贱处
    为谓瑜伽百途之某道 染蓋分大证理见者稀
    二资粮生圆有无更替 所谓了义纵勤乐果小
    善趣中彼无力断轮廻 总之所生宿业福缘薄
    居邪染污劣道实可愍 一旦悉入善妙无谬道
    愿如是得如是获解脱 凡诸无谬空性与大悲
    刹那解脱自住法身道 升起正慧勝观赤裸中
    住为方便止平等体性 自恣双运普离诸整染
    以转而散以住而制伏 沈掉无二离烦恼根本
    依何升起亦自解法身 如何安住亦无二平等
    不需取捨心性本然义 元始体性法性本智中
    串修习力相续不间断 此是本性元始自解脱
    为最勝修亦甚深无上 摄束藏粹復又摄粹取
    此为一切金刚顶藏要
    大圆满心性自解脱论---中根方便道串习解脱品第二
    果位任运暂时究竟二 暂时中以见修得功德
    烦恼能所本地中解脱 显示得证外内之诸法
    成就天眼神通诸神变 证量增上出生利他悲
    彼时刹那本明之智中 以分区判此等功德矣
    现分为法生次福资粮 断诸烦恼徧计能持念
    空慧圆满次第慧资粮 知障俱生所执本地解
    (忄+坚)吝犯戒嗔(圭/心)懒散逸 邪慧未博验小无愿力
    愚暗诸等十种清净法 施戒忍精静虑慧方便
    力愿智等十波罗蜜圆 上师恩被证悟升起时
    喜乐最勝生处极喜等 烦恼自解脱之离垢地
    能为乐明无念发光地 散驰徧计自解焰慧地
    殊勝非殊之境难勝地 证悟现前而为现前地
    远脱轮廻之中远行地 证悟不动须弥不动地
    为诸最勝具妙善慧地 意遍虚空第十法云地
    福智清净资粮加行中 见悟内义熏修见修道
    即是所谓解脱之果地 解脱三毒三藏悉齐具
    三门清净三学处清净 一切所解此中所行之
    成证悟界无上之瑜伽 四续具全自利声缘众
    利他大乘证悟事续部 熏修行续行部瑜伽矣
    方便与慧摩诃阿鲁法 自圆阿底九次第诸同
    具足总持禅定智藏要 自解刹那分别所住者
    地道正觉所知同一义 元始之智心觉大手印
    等圆任运广大同高低 究竟果位不住本初体
    法身净土超思绝言诠 界与智二若能成一味
    现证菩提三身任运成 微细之智汇集虚空界
    一切智性升起而安住 无所证违法性任圆满
    不生不灭虚空之自性 由彼清净密严之净土
    自显光明坛城任圆满 五佛导师相圆放光明
    法界圆镜平等妙观察 成所作等五智自性中
    十方四时自显所化眷 坛城五姓得如芝麻聚
    遍住上下十方际虚空 门拱城垛栏循围墙等
    随顺各各种性作装饰 一切任圆同一坛城中
    等圆满法周遍无中边 三时无时一切普贤时
    基圆无迁转之体性矣 復次自性化身五佛土
    奥明现喜妙宝悉周遍 莲华丛集事业极成就
    五佛导师十地眷属众 三时普悉妙色示明镜
    光明漩澓十地障清净 居普光中而行诸事业
    彼土显现佛子清净聚 报身之面放射诸光明
    於其天与非天及人等 旁生饿鬼地狱六世间
    显示帝释绮画王释迦 狮子坚固焰口天及与
    牛首阿瓦随顺之现身 行不净事依寂灭法界
    种种变化事业与受生 沼地桥梁莲花如意树
    医药珠宝明灯诸等等 常作众生幸福欢喜处
    究竟则行决定善妙业 所化既尽能化隐法界
    復次於彼三相当了知 种种变化调伏众生没
    如无水皿水月则消失 仅为自性游戏集散戏
    一旦住所化地寂灭者 能化自性幻化五种姓
    自显报身无二自消融 犹如晦朔月隐没法界
    法身界中自显报身没 外境不现自体大坛城
    无前後增减迁转安住 显现增减如月不映夺
    若尚有一所化如前现 此等即为究竟解脱果
    大圆满心性自解脱论---大任运果品第三
    如此善说日藏要本论 由我无垢光所作开显
    当今乱世恶见愚暗蔽 此能除故安置决定道
    用以是善於如我众生 无馀同等解脱本初地
    断证二德达至究竟处 愿作利他任运妙法王
    ○本[大圆满心性自解脱论]为吉祥邬坚大阿闍黎贝玛森巴瓦（莲花生大师）所加持之瑜伽士无垢光所书於雪山蜕嘎山颈之 邬坚宗圣地，为後世之利益而造圆满。善哉！

    大圆满心性自解脱论本颂
    注释
    --------------------------------------------------------------------------------
    1．心性自解脱：本论於大圆满中本净立断（且却）、任运顿超（妥噶）二法中，属於远离迷妄之本净立断部分所摄教授；原文本无「论」字，今依瑜伽师地论卷十五所云六种论理中所谓『教修习增上心学、增上意学、补特伽罗心未定者，令心得定，心已定者，令得解脱。所有言论，令彼觉悟真实智故』。故安「谕」字，馀二论亦同理。
    本论阐释心性不染诸垢，本来解脱之理故名之。
    2．吉祥：圆满具足福德、智慧二资粮者，谓之吉祥，又喜金刚续云：『室利』乃为无上智。「室利」梵义为吉祥，有功德殊胜有寂（轮廻有趣、涅槃寂灭）之吉祥，及现空方便智慧无二之义，故谓「吉祥」。
    3．普贤王：本初佛名，密咒道次第宝鬘释中云：从二执一切错误而觉悟为「桑」，无二智慧自性扩展为「杰」，无馀密意为「衮」，向一集中为「杜」，行境清净圆满为「桑波」，（桑杰衮杜桑波为普贤王加来名号之藏音）。
    4．韵：大圆满术语，概指本明之效能、形态，与本明相应而显现於外者，为一种具有生而不灭之状态，此字汉文旧译中大圆满广大心要本觉道次第一书译「功用」，大圆胜慧中未译（上二书同本异铎），仰兑亦未译出，然「功用」一词，大圆满法中另有字词契合故，本书译「韵」取其与汉文中「神韵、气韵」义趣相当，又藏文此字普通用法中作「曲调」、「音韵」解，故权译为「韵」。
    5．现心：显现之现分及心，约指心物二元，外境内心二者。
    6．本解：本来解脱，大圆满四大解脱法之一，自生之明，其无始以来，与自体性中即不染轮涅诸法故，穷尽有趣之近取因，乃称本解。仰兑一书引应成续云：四大解脱为；本解脱故本无修，自解脱故无对治，赤裸解脱无见地，徧解脱故无勤勇。
    7．平坦然：平等平坦无有高下之谓。
    8．此谓非表：云所谓「见地清净无有中边分」之语亦无可表示。
    9．四边：是常非断边、是断非常边、是常是断边、非常非断边，或指生灭、有无、常断、现空四边。
    10．方分：「方」指上下东南西北等十方，「分］指善恶良（穴/瓜+瓜）之分，意指抽象、具体之偏颇。相当於禅宗所云之善、恶、有、无、内、外、中间、空、不空、定、不定之一切处。
    11．无成就际：或译为「无宗义」，藏文中将成就之边际作为宗义之标准，本宇梵云： Siddhyanta；Siddh指成就、成立，anta指边际、极限，字义为以自心内所有之真实原理或意义本理为际，除此更无有其他理趣，其原理、本理即为成就、成立之极限；此处所用之意义较广，故舍「宗义」而逕用「成就际」。
    12．意向：心所施加安立之对象，意象上指望之处，或心意之对象，在意义上汉文甚难表达其概念，仰兑一书译为「诠表」，译者对「意向」之译词仍不满意。
    13．净：此处指清净佛身及净土。
    14．不净：此处指三界轮廻之自性。
    15．界：此处指法身普贤王如来之界域。
    16．现空：一般指现分与空分之略称，然此处为轮涅诸法虽有显现，然体性为空。
    17．徧计：自执取分别妄念所增绮之假名安立。
    18．轮涅：轮廻与涅槃。
    19．戏论：大日经疏十九日：「戏论者，如世戏人以散乱心动作种种身口，但悦前人而无实义，今妄见者所作者亦同於此，故名戏论也」。
    20．缘起：吉藏撰中论疏十末中有曰：「缘起者。体性可起，待缘而起，故名缘起」。
    21．我执：依五蕴任一而执为我之心或觉感，此有二，即人我及法我。
    22．虚幻少女：指魔术师或术士所变现虚妄不实之少女影像。
    23．非微尘集：云前句所言之六道处及佛刹，并非由微尘物质所集合形成，乃众生自心自所显现而成。
    24.谛与似谛：真实不虚为谛或谛实，似谛即似真实而非真实，旧译均直接译为「假」。
    25.刹那意境相：云前句之梦境中虽显现无量诸事，宛然如真，然于梦醒时刹那即知是意境之梦相。
    26．现分所反空性无所有：云现空二者为一体两面，现分之反面除空性外别无所有。
    27．信解相异：现空二者本为同一，然吾人咸认相信此二相异不同，实乃心所作分别迷妄而误。
    28．意察：心意所伺察分别。
    29．因果乘：指声闻、缘觉、菩萨三乘。
    3O．无实藏要之宗乘：本段大意云：一颜面有污秽之小童照镜，以蒙昧故不知镜中之影为自身而於镜外寻他人，喻末学凡夫；其母见已,虽知镜外无有他人，然以为镜面污秽故拂拭明镜，喻菩萨乘人以外境作修改整治之对象；若为聪慧妙黠之母则知其童面有污秽，去污则影自明晰，喻直指本心之行人为外境无实有之精要宗乘。
    31．升基：大圆满术语，有八分法、三分法，於法界元始本来之基上，具体性、自性、大悲、态势、自如、自性、本净性及任运，以其本质同一，於概念上而分为此八，于此形态中升起基显现时同时能作为解脱迷乱二者之部分,称总基；作为解脱基者称「解脱基」，能为有情迷妄基者称「迷妄基」，此理甚为深奥，须需慧眼者方能证知，但此处作升起升现依据基础之谓。
    32．基：大圆满术语，土观宗义晶镜云：最初实相不为生死涅槃所污染，亦不为迷乱所垢障，实相赤露，未曾迷乱，亦无需证悟，不是一切，能现一切，此即是「因地」（基）。（刘立千译本，西藏人民出版社铅印本p．41）。
    又龙钦七藏中词义藏则云：基有七理：本净、任运、不定、决定义、可变、可许、种种，虽分为七，然其明则同一，并且离一切语言文字主张，为令人便于了解之故而分别叙述，而此等所说之理亦不能执持。
    又，其「基」本净，离言诠思惟，超越有无之边，以体性本净故而断「有」之常边，实有性相等诸法悉不成立，以自性任运故而断「无」之断边，光明空性法尔清净，自性本初证觉，法身无变异之密意，轮涅一切均悉不立，是中本空大智元始如虚空安住。
    此外普贤六界续云：
    「本初自置所成基，有乃无有逾於一，
    清净所现迷妄方，由证悟者择定之，
    次第而现七法理，虽示次第七法理，
    体性同一之权现，以一不解如此显，
    然则其义如是观，安住任运本性中，
    摄集种种显精要，住於无有决定中，
    具能变意显诸相，亦住决定自体性，
    能念显现无迁异，安住能有变迁中，
    勤黾显现心诸相，安住何之体性中，
    随现显现自体性，安住纷然灿烂中，
    显现种种各别理，安位元本清净中，
    垢染本始无所显，此诸意之次第中，
    自之体性本清净。」
    是颂包括「基」之内义及妙用，「基」之概念甚是重要，为大圆满见之根本，若不能了解「基」之理则难以了解大圆满理趣，然此理此处甚难尽述，志於此道者，可取龙钦七藏之词义藏，无畏洲（吉美林巴）大师之功得藏自疏一切智车疏，第一辈工珠活佛（蒋贡康慈）之知识宝藏论，深入参考，此处难引周全，仅节录片段，聊供案右，本词郭元兴译为「体」，又有译「基」道果为「根」或「境」道果，在大圆满译名中并不适合。
    33．无迁转：即无变异，常之所属。大圆满禅定休
    息清净车解中译「无迁变」。
    34．有趣：即轮廻，以有业烦恼习气而有往来六趣之谓。
    35．自恣：随其自然，自然恣意放任之。
    36．法相：藏文原作有法，此处泛指一切事物，尽一切所有之事物，旧译多作「法相」，此处为与因明学中前陈之「有法」作区隔，故援旧译名称。
    37．根本後得：修定之中谓根本，出定之後谓後得。
    38．明体：指於本明之状态中，不同於旧译所指本明之明体。
    39．离方：离於方分偏堕之处。
    4O．生圆次：生起圆满二种次第，密宗内对为求净治胎卵生习气，解脱凡常之所现、闻听、心思之拂，转成本尊之尊身坛城、密咒法音、智慧法性而修习之瑜伽法称之生起次第，简称「生次」，民初译威德金刚法本时作「起分」。
    另直扼金刚身要，依堪能之脉气明点，以四空引致光明，以四喜引致俱生智现证殊勝慧方便法门，简称「圆次」，威德法本作「证分」。
    41.绘摹：云一切轮涅诸法均为徧记之心所描摹之虚绘。
    42.本性：或译原理、实相本理等，直译为住理，原来安住之理。
    43.证违：心中已以正量掌握成立，于事中则居正量之相违除遣。
    44.升解：升起与解脱、现起与解脱之谓。
    45.无施：无施加依附之对象。
    46.牲畜:藏文中指反（媰-女）类之牲畜。
    47.增上慢:以无为有虚张声势澳门自得之心。俱舍论十九曰:“于未证得殊勝德中,谓已证得,名增上慢。”
    48.有顶：即无色界最高处，轮廻有趣之顶。
    49．湛然：清澄、剔透、纯净，禅定休息清净车解一书中译「清明」。
    5O．平等：平等同一高下之意。
    51．惚惚恍恍：此为修藻词，云不确定、不清楚，未可捉摸之意。
    52．茫茫然：此为修藻词，云不确定、不清楚，未可捉摸之意。
    53．（木/日）（木/日）冥冥：此为修藻调，云不确定、不清楚，未可捉摸之意。
    54．洞然：透澈、无有遮阻障碍。
    55．静虑：亦译三摩地，禅定、定、等持、止，心不散乱、专注而住，详见俱台论分别定品，瑜伽师地论菩萨地静虑品。
    56．性澄：体性状态澄净无染。
    57．证悟基解脱品第一：第一品对上根者而言得见地，则当下解脱如禅宗之领悟。
    58．六聚：眼、耳、鼻、舌、身、意。
    59．座闻：瑜伽正修行时及二段修行间之休息时间。
    6O．放任：散漫之意，仰兑译为「放浪」。
    61．禁行：禁止平凡庸行为禁，奉行不共非常之约为行，故日禁行。此指无任何取捨之行为，即瑜伽行。
    62．界：指范围而言。
    63．孤眼：云於所证悟之范围中无有变异，无分昼夜诸时，均能保持，一如狐狸之眼，昼夜均灵活警觉。
    64．母子相会：法界本体与小我所净二者相契相融之谓。
    65．等引：梵云samahita，在定心专注之性曰等引，等谓身心之安和平等也，人苦修定则依定力而引生此等故名等引。
    在修行中有关「定」之类术语，现论定义如下：
    ①止。梵钿samatha，或译闍摩他，解深密经第六品云：「即於如是善思惟法，独处空闲，作意思惟，復即於此能思惟心内心相续，作意思惟，如是正行多安住故，起身轻安及心轻安，是名闍摩他」。
    宝云经云：「合摩他者，调心一境性」。
    ②静虑：梵dhyana，或译禅定，俱告论二十八云：「善性摄心一境性」。瑜伽师地论三十三云：「言静虑者，于一所缘，系念寂静，正审思虑，故名静虑」。
    ③定：梵samadhi，或译三摩地，集论一云：「何等三摩地？谓於所观事，令心一境为体」。俱告论二十八云：「等待与定名异体同」。
    ④等引：梵samahita，或译三摩呬多，成唯识论述记卷第六本云：「言等引者，一引等故名等引，调身心中所有分位安和之性，平等之时名之为等。此由定力故此位生引生等故名等引。二等所引故名等引」。
    ⑤等持：梵samadhana，或译三摩地，同上论云：「平等持心等但於境转，名为等持」。
    ⑹等至：梵samapatti，或铎三摩钵底，同上论云：「其等至者，亦有二义，一云至等，谓在定定数势力令身心等有安和相，至此等位名为等至。二言等至由前加行伏沈掉等能力，至此安和分位名为等至」。
    有关定的探讨可参致近人林崇安先生之「佛教教理的探讨」一书所录部分。
    由上可知，静虑、禅定、定、三摩地、等持，名异义同，与止、等引、等至，意义有别不可混用。
    66．习力：指学习调练令自成功力，如同锻炼、修炼之意，仰兑一书中译「习力」，惟击三要中译「调修」。令从仰兑译名。
    67．正後得：即根本、後得二位。
    68．集资净障：积集资粮、清净罪障蓋障。
    69．常有：指恒常不异所有之方面，如法界、佛、真如等。
    7O．道煖相：指大圆满立断（且却）道验相之煖相。
    71．法性现前：大圆满四种成就验相之第一种，内在本明初得现前，而显於外境，於所现境中见清净法界光，如虹霓如孔雀翎光彩，其中央显明点空光圆光微细明点，其中复现金刚链等。详见仰兑及大圆胜慧中所述；或译「现见法性」、「法尔现量」、「法身现前」、「法性明悟」。
    72．验相增长：大圆满四种成就验相之二，所现验相较前更明显坚固增长之；或有译成「觉受增长」、「力显增长」、「悟境日进」。
    73.昭空：一般多译成明空，此明字常与藏文中本明之明，明分之明混用，本字有清楚分明、光明等多义，故择汉字中义相契之「昭」较能贴切本义，及与本明、明显、明分等词作区隔，但乐、明、无念之明，因流传甚广，已相约成俗，故仍沿用而不改。
    74．明量进诣：大圆满四种成就验相之三，所现验相虽未与自身相联，但已诣觉受之量，无有转动，无须修整，并无变迁；或有译成「明体进诣」、「自性进诣」、「自心进诣」。
    75．法性穷尽：亲见究竟法性之显现，无有身心一点执著，外所现增长觉受尽，内幻化身之法尽，密六识分别心尽，一切迷乱显现，本性清净，及显不显之执著心尽，而轮廻涅槃无有分别；有译「穷尽法性」、「法性尽」、「诸法尽入法性」。
    76．基：此处为藏文诸释用词之推巧备考，故不录之。
    77.三种相：即后所云之一味相、解脱相、隐没相。
    78.法界：此处为藏文诸释用词之推巧备考，故不录之。
    79.一方：指法性密意唯一之处。
    80.地道：十地、五道之略称。
    81.正士所证量：此中所云正士所得量即如莲师、密勒日巴诸大师成就之相。
    82.暇满：八暇、十圆满之略词。远离地狱、餓鬼、畜生、蛮人（边地）、长寿天、邪见、佛不出世、暗哑等八有暇及生为人、生于中土、诸根全具、未造无间业、敬信佛法、值佛出世、值佛说法、佛法住世、入于佛法、遇善知识等十圆满为具暇满。
    83.寂静处：表面泛指安静之处，详究之则需具身口意三寂静处，身寂静处（门*臭）无人迹，无见友朋冤仇敌寇；口寂静处无喧嚣声音，包括有情无情之声侵入耳根，勾引心念；意寂处，不起烦恼妄念，不起诸不乐不适之处；具德之处实极难得。
    84．幻身：四大假合凑合而成危脆身，如幻易灭故云幻身，与圆满次第中所云虽无形相然有种种现分，其现分虽有，然无自性之幻身名同义异。
    85．悉地：梵又Siddhi，义为成就，此中有殊胜悉地（成就）及共同（成就）悉她，殊胜悉地指成佛，共通成就有八：宝剑、丹丸、眼药、神行、摄粹、飞天、隐身、遁地。
    共同悉地内外道籍禅定能力均可获得，殊胜悉地唯内道不共所有，此处乃指殊胜悉地。
    86．补特伽罗：梵pudgala之译因，依附五蕴任何一蕴所施设基，其所安立之人、士夫、有情众生之相续中有功过二者时增时减，数数聚散故名之，汉译以「数数往来诸趣。故译「数取趣」，此处以为人之代称。
    87．中有：俱舍论卷八云：「於死有後在生有前，即彼中间有自体起，为至生处故起此身。二趣中间故名中有」。俱舍说「有」体为五取蕴，中位别分析有四，中有、生有、本有、死有，然密宗说六中有：处胎中有（自性生处中有）、睡梦中有（梦境中有）、禅定中有、命尽中有（临终中有）、法性中有（实相中有）、投生中有（顺次有趣中有）等六中有，显教中生有同於处胎中有，死有同於命尽中有，中有即含法性中有、意生身、投生中有，本有即处胎後直至死前，或有译此名为「中阴」。又，此处之中有指命尽中有、法性中有、投生中有三分位。
    88．勝观：梵 vipasyana亦译毗婆舍那、观；解深密意经云：「彼由获得身心轻安为所依故捨离心相，即於如所善思惟法内三摩地所行影像观察勝解，即於如是胜三摩地所行影像所知义中，能正思惟、最极思择、周徧寻思、周徧伺察，苦思、苦乐、若觉、若见、若观，是名毗钵（婆）舍那」。
    89．画：喻如画，为造作境非真实。
    90．知境：仅概念上所了知之境，非经由证悟而得之境。
    91．沈掉：昏沈、掉举之略称，集论云：「云何昏沈？谓：痴分摄，心无堪能，与一切烦恼及随烦恼助伴为业」，「云何掉举？净相随转，贪分所摄，心不静照，障止为业」，昏沈障明显，掉举障无分别住（坚固），对治昏沈掉举当用正知正念之法。
    92．驴等众：藏原作佳喉众，佳喉为驴子之藏文藻饰异名。此处用以影射愚昧如牲畜者。
    93．方便道：即指会道，以二根为道。
    94．止：旧译「三摩地」、「闍摩他」，为一切禅定的总括或因，心不散驰外境，专一安住所修之静虑中谓之，解深密经之分别瑜伽品云：「即於如是善思惟心独处空闲，作意思惟。復即於此能思惟心，内心相续，作意思惟。如是正行多安住故，起身轻安及心轻安，是名闍摩他」。
    又，此处觅止之法，略似於大圆满广大心要本觉道次第一书中之心业清净部分。
    95.显示：藏本作显示，阿闍黎云应作坚固，本句当作坚固得证外内之诸法。
    96．知障：所知障，唯识论九日：「所知障者，谓执徧计所执实法萨迦耶见而为上首，见疑无明爱（圭/心）慢等覆所知境无颠倒性能障菩提名所知障」。
    97．九次第：声缘菩萨，事行瑜伽续，摩诃阿鲁阿底等九乘次第，详见导论中九乘见修行果。
    98．总持：梵Dharani亦云陀罗尼，以持久不忘诸法词义之念力和神验不测之智力为基体性，以受特善法，遮止不善法为其功用，注维摩经一曰：「肇曰，总持谓持善不失，持恶不生，无所漏忌谓之持」。
    99．界与智：法界与本智。
    1OO．自显：自所显现，非由他力、外力产生而显现。
    101．奥明：奥明刹土，居中，为清静法身毗卢遮那佛净土。
    102．现喜：现喜刹土，居东，为不动佛之净土。
    1O3．妙宝悉周遍：妙宝周遍刹土或具吉祥刹土，居南，为宝生佛净土。
    1O4．莲华从集：即极乐刹土，居西方，为阿弥陀佛净土。
    1O5．事业极成就：事业极成刹土，居北方，为不空成就佛净土。
    106．牛首阿瓦：牛首阎罗，此为佛於六道所化现六导师之名讳，具列加下：
    天道导师 帝释
    人道导师 释迦牟尼佛
    阿修罗道导师 毗摩质多
    畜生道导师 狮子坚固
    餓鬼道导师 焰口天、焰口
    地狱道导师 阎摩法王、牛首阿瓦
    107.事业与受生：指三种变化化身，殊勝化身指前所述之释迦牟尼佛，事业受生或工巧化身，如利益众生所需之沼池桥梁莲花树医药珠宝等物，受生化身如转世诸古等。
    108.贝玛森巴瓦：莲花生大士之梵号也。
    109.雪山蜕嘠山颈：禅定休息及虚幻休息译颓格雪山，龙钦巴祖师曾长期在此闭关、著述、度过大部分时间。


大圆满祖师遗教

    大圆满祖师遗教

    金字书---喜金刚遗教
    这里是上师喜金刚的大圆满三要诀，及大圆满早期上师们的开示与记述。
    1、开示本觉；
    2、决定正见；
    3、直印自圆。
    敬礼决定正见!
    阿！ 法尔当下明朗本觉，无生而自在。本初根源应于万显随处起现，无障亦无间。一切起现未别法身，依当下觉瞬起还瞬解。此中真意——圆满如实性，即诸佛心中无二大觉，实圆摄于一切有情皆具之法尔当下究竟本觉之中。
    吉祥文殊友于上师喜金刚化虹时昏厥于地。为去除心子心中一切轮涅妄念之残余， 唤醒吉祥文殊友，喜金刚开示了《三要诀》。此最胜遗教在上师辞世时授予，应善护持。
    阿！ 当下法尔本觉，超越一切心念，无生，离缘。
    三要诀：
    阿底！
    对法尔当下本觉即法身本初根源的无谬开示如下：
    1、开示本觉，即直指彻显本来面目即法尔如实性，赤裸当下。进而开显其性无生无染。「此处只是直示法尔如实性，类此，其他如嗔恨同样自解。」
    2、决定正见，即于万境中直荐此无二如实性，在处不离，顿超主客二元。
    3、直印自圆，即以完全的把握常契诸妄自解。从而如实性亦消融于自身(不依因缘、造作)。如实性法尔自起自解故，无有有情而不证解脱。能念之心所念之境自相遇自消融(当下瞬解，不 涉主客二元)。若不了此，则生自他二元(内觉为我，外境为他)主客二见。
    此即当下消融、确证解脱唯一密要。
    第一诀：开示本觉
    阿底！
    一切外境即本体之显现。万象看似秩序井然，却非实存，了无可得。如实性与现象本谐，依于本觉无外潜能，万象自解于自身，无需对治。 (这个自解的过程是) 现象起现于识心时， 当下直契自性。就像操同种语言的人相逢于外语异国，他们会立即相认相识。「与此同理，认知嗔心自性，其嗔自解」。当识知外境与幻觉之心寻求其母(即其来源)时，它直遇母光明(即空性)而得自解脱，此即幻觉依幻而自解。如同奶油溶于奶油。当识心即子光明寻找自己时，它直契自身，即觉依觉而自解。如水溶于水。当寻求无二之如实性时，如实性直契自身，其义超越一切言说。如空合于空。亦如蛇结自解。此独一无二法尔本觉只能自证于自身。那就是说，若行者自了其性，万象即时证入究竟觉。就像相恋男女之幽会。此唯一究竟只能自会于自身。外显之境虽纷繁，却依始觉于纷繁识了本源而自解于本初体。如同百结之绳断其结心则百结俱解。此唯一究竟解脱只能自获于自身。始觉法尔自显故，本初现起之觉心别无所获，只能自解于自身。就像进入一座由百千条大路汇达的大城。「关于根之第一要释竟」
    第二诀：决定正见
    于此当下法尔如实性，行者瞬证终极圆光(final vision)起现于自心。同样，行者既自了自性，则常在定，法尔明觉远离无明二见(或称失照)。如人虽于多处有多名， 以任意名称招呼他仍会答应。因称谓虽多，义则不出此人。于此究竟当下法尔如实性，行者瞬证所有均自体所现，于此解脱门中确证无疑，则此修习亦自解于自身，因觉依觉而解。同样，由于了知如实性法尔自在，则一切所解所证亦自消融。如同遇到阔别多年旧时老友一般。「关于自解之到第二要释竟。」
    第三诀：直印自圆
    宝贵的实在个人自性经验给行者以信心。一切心念自解于自身，这就像拥有如意宝珠。拥有关于他人及外境的具体经历给行者以如转轮圣王般的自信。幻相于当下如实性体中明显现起，以此光相现于自体非由他生，故行者之自在如实性实如转轮王般临四天下。进而因本觉具转四大之潜能，行者并因此(化虹)而获解脱，不再依赖世俗身体而拥有实在的解脱经验。行者的信心将如空合于空般坚定不移。完全的自信源于对万象离修自解消融于无垢本初法身(实相)的体认。这就像空入于空，又像云霭消散于苍穹。起现于自身者瞬解于自身，万象自解不依外缘。这就像以石破石，以铁锻铁，或以土清土。于此究竟当下体中，万象解脱于对当下本觉的领会。正像火中取火，倒水入水或溶奶油于奶油。从而母(本体)子(觉心)相会相融。因子之法性即是母(无他、无实、归空)。也可以说空依空性而解脱。从而行者的身心觉知(于化虹时)消融于圆光自身。证会到本然状态即本觉，行者直契万法根源，确证(修习托嘎时所现)圆光只是自心显现就像照镜自见。已契法源故，此证又如同母子久别重逢，了悟此即究竟解脱。以此圆光瞬即自解于自身故，可了知此显现当体即空(无实性)，而其明晰即行者当下本觉。已证此圆光或显现自解于自身故，则解其从无始来即现无明相，亦即轮回乃轮回中自认(如持镜对镜，镜镜相照)。对于涅盘，行者确证已超越轮回，故无明已自解于自身。就像以土擦除土迹。已自证存在之实义即自在本觉故，妄念当下自解，因而无需其他对治。妄想解脱于本体故，行者恒处定即当下实相，而无疑惑。就像注水入水或倒油于油。因常在定四事不离故，行者之修如蛇结自解，不假功用。但若自弃他寻(而不自知)，行者将再入绝境。瞬即自解故，当下明觉自持自在。因此，恒契自在如实性是关键之要。「关于证果之第三诀释竟。」
    结语
    喜金刚开示此完全超越轮回苦趣之心要时，正是吉祥文殊友发出“噢啊啦”之悲呼，昏厥于地之时。为唤醒吉祥文殊友，韦他拉舍玛(即喜金刚)于空中虹光环中辉煌显现，为一切众生的彻底解脱，开示此三要诀于此密秘遗嘱。遗嘱从空降于吉祥文殊友右手掌中，其文字以天蓝色熔化青金石写成，盛于一拇指大小筒中，小筒又置于一宝石镶嵌的小盒子中。接到遗教，吉祥文殊友由昏迷中苏醒，了达教法， 成为无误的传承持有者。这一心要封藏于他心际曼陀罗内成为密要。此三要之甘露传承，上师口传遗教，成为他心中洋溢的灿烂光明，如黄金晃耀。此事发生在印地施达瓦那(Shitavana)火葬场。从此，这一圣教在但丁河(Dan-tig)的源头开花结果，成为给轮回苦趣中一切有情带来解脱的唯一道路。
    这一当下解脱于诸佛净土之心要竟!

    吉祥狮子遗教·七钉镢

    版本之一：老狗 译
    吉祥狮子遗教·七钉镢·
    吉祥狮子（师利辛哈）造
    （ "宋慧寿"是“吉祥狮子”的中文名）
    老狗·嬉笑游舞 译
    礼敬大圆满人间三祖吉祥狮子！
    礼敬受持本法者智经尊者！
    吉祥妙善！（以上归敬译者加）
    正 文
    我指示本初心性的贤美圆成，
    正如明光与虚阔的无二合和；
    遍知所有一切，
    永远开放，没有边际。
    犀锐的彻穿不动的大地，
    用这七根钉镢，穿透习气轮回的狭路，
    从中得以自由解脱，
    法喜永远从你心中涌现。
    用心性的无碍空、明，将“有依”和“无依”一起钉住。
    用俱生光明，将“能观分别”与“所观对象”一起钉住。
    用自动显现的无染本质菁华，将“心”与“物”一起钉住。
    用定解之见，将“断边”与“常边”一起钉住。
    用超越形体的殊胜明觉，将“形象外表”与“内核本质”一起钉住。
    用，一切感觉听其任运自解，将“欣”与“厌”一起钉住。
    用法身的本来完美，将“显现”和“无际”一起钉住。
    （完）
    七钉镢深意璎珞·译后记
    嗳吗好！
    吉祥狮子大师是大圆满人间传承第三位祖师，十五岁从汉地到印度求学佛法，遍学显密教法后，依止二祖 妙吉祥友学大圆满持明指示传承二十五年，后隐居于吉祥旃檀林神变宝塔，最后返回中国五台山。他教导出智 经(JanaSutar)、无垢友(Vimalamitra)、莲华生(Padmasambhava)、遍照（Vairochana）等大圆满祖师。吉祥狮子涅盘时，正值智经在其胁侍，大师的肉身融入圆相虹光之际，为智经唱出遗教朵哈---《七钉镢》 。此朵哈正如其名，简洁却具有刺透力，将见、修、行、果圆成和合，概要托出。在此略采撷其深意精华之璎 珞。
    文中“本初心性的贤美圆成”，也可浓缩翻译为“俱生普贤”。在声闻学地中，将烦恼取持为可畏怖者而 断除；在显宗安立清净因、道、果，有所建立与破坏；在金刚乘立安立自在转化，仍有造作之功用；大圆满视 一切乃意金刚之变化游舞，本来都是普遍贤善。本来、本俱、自显就是“俱生”，普遍贤善完满就是“普贤” 。并非故意对立仇视一切显现，而陷入脱离之极端，反而不能去任运心性的游舞庄严。所以在光明心性的基础 地上，不应一味仇视任何显现，而应任其自然解脱，空明观察之意是不依靠任何立足点的，说名为心性也毕竟 没有自性可以得到，并且更能观察到戏论也是心的游舞作用，从而更尊重业果，总体来说，现量无勤任运的通 达中观智慧。所以一开始大师就称赞：“我指示本初心性的贤美圆成，正如明光与虚阔的无二合和；”
    文中“遍知所有一切，永远开放，没有边际。”，遮止了很多邪见和相似见，比如昏沉、无分别、没有定 解而修无念定、意识上的认取自赞等等，具体的要门品类应该依靠上师传授来学习。
    文中“用这七根钉镢，穿透习气轮回的狭路”有两层甚深含义，最肤浅的是“解脱”，而深一层说明“穿 入”。钉镢穿入同时，也就包含进了所穿透物的内部，这就是说明了一切本俱解脱的内涵。
    文中第一钉，是将显现的条件分为“有依”、“无依”。审视其本质是可嬉笑而无绝对的，所以说用用心 性的无碍空、明将其钉住。这里可以看到心性不依两边且极其具有观察智，一下子说明了“空、明”的本质。
    文中第二钉，说明心性作用的方便，俱生之中最无勤、自显的法性光明，将一切能见和所见无二和合，在 口诀部中有此深道的讲述，此不累絮。此处应说明其俱生之光明，从自性中任运而其，不是从方便造作而来， 是俱生之中大俱生。
    文中第三钉，将显现与分别打通，心不仅追逐外显现，更进一步追逐自造的内显现，产生建立和破斥，其 实如同蛇自己打结，但本来还是一条“通”蛇。一切显现自动显为解脱，但心识使其不解脱，而本质是无迷更 无悟，这里就是本质自显的含义。
    文中第四钉，定解之见很重要，不能将见、修、行、果割裂开来。单单靠一个口诀去自肯自己的修行是很 危险的，很多人盲目否定业果是很荒唐的。所以有人将超越因果误认为拨无因果是不对的。昔日二祖妙吉祥友 初为佛教五明大学者，尚不信服此法，以为超越二元之法破坏因果，乃是邪见，其不知此法澈察中道，反而更 能尊重因果，巧用轮涅；后来与五百弟子僧众，同时归依胜喜金刚祖师。三祖之时，国王畏怖超越因果之法而 遂禁流通，遍照大师也是白天佯学续部，晚上才能向吉祥狮子大师秘密学此法。超越因果之法不是滥杀无辜， 反而更能运用因果的游舞庄严，所以说中观缘起见极为甚深这是不假的啊。
    文中第六钉，可以借用一句朵哈来说明：“将烦恼当作烦恼是错误，让烦恼成为烦恼是方法”。人们极端 的排斥烦恼，却不看自己对烦恼的恐惧心，自己给自己打结多么可笑。烦恼真的是不好的，为什么不安住于烦 恼中？当烦恼仅仅是它自己的时候，又有什么可以驱除的呢？那时烦恼还是烦恼吗？烦恼也不见了。所以说显现的一切当下解脱。
    文中第七钉，表现的俱生普贤----本来的完美，把有量的显现，和无碍的通达贯穿。普贤王如来代表无始的法身，其真正含义是本来自然的心地。
    这个心地如同开放的天空，又充满了游云的活性，不故意排斥而广大包含。当然，也没有这样一个绝对的展现给你，那时是超越一切语言和上述譬喻的，如同惊愕的时候而没有任何立足点而已；但是要配合见、修、行，才能完全的认直，只是心意上度量也是不够的。如果跟从上师学习这些“活”的教法，一定很平常的会相应的。这里，吉祥狮子大师从其心中滴处此七滴精髓，对其心子智经作了最后的开示，其中深甚的含义和相应广大的修持要门是很难用几句话展开的，在此仅仅以只言片语勾缀其中光明璎珞，愿启发读者随其经线填充真实的感悟。
    老狗 2000年9月11日译记于北京

    版本之二：林居士 译

    吉祥狮子(诗利辛哈)略传
    吉祥狮子(诗利辛哈)尊者诞生于中国汉地秀夏洲(Sosha Island)，父为具善，母为光明慧，十五岁于阿阇黎哈德白拉处学习五明三年后通达无碍。尊者稍后往西游时，空中现出观世音菩萨的净相，并对他说：“幸运的善男子，你如想得到成就之果，应前往印度索萨维拔城的尸陀林。”尊者虽对授记感到高兴，但自想：“我仍应先学习所有其他的内外密续，以利于掌握不共的教法。”他因此往文殊圣地五台山，于七年间从贝拉科提上师学习全部内外密续。其后受具足戒严持毗尼、精研三藏三十年。其时观世音菩萨再次重复之前的授记。于是尊者想：“为免途中受阻，我应用神通前去索萨维拔较佳。”尊者修持有关仪轨三年后，便得到所需之神力。于是尊者便如风般离地两尺许飞行，抵达索萨维拔并见到文殊友(Manjushrimitra)尊者，并从之受教修行达二十五年。
    根据空行心髓(Khandro Nyingthig)和其他资料，吉祥狮子尊者也曾去了释他哇那尸林，亲见极喜金刚(Garab Dorje)并获授心髓教法，尊者后来将之传予莲花生大士与毗卢遮那。
    此后文殊友大师示入涅盘，其肉身在索萨维拔城中尸林的塔顶消失。当时空中充满了音乐和虹光。吉祥狮子尊者悲哀地祈请：
    “呜呼哉！广大虚空！
    金刚上师光被障，
    谁将能除世间暗？！”
    此时文殊友大师忽然现于空中，伸出右手将一指甲大小之宝盒置于吉祥狮子尊者掌中。尊者在盒中找到用百种宝物之墨写于五宝金属的叶子上的文殊友遗教《修定六受》(Six Experiences of Meditation)。
    吉祥狮子尊者对自己的证量再没有疑惑，并能完全无误明了不共密续的句与义。他将文殊友秘藏于菩提伽亚金刚座下的典籍取出后返回汉地。
    在汉地，他把大圆满口诀部(Me-Ngande)的教法分为四部：外、内、密、极密。他称此中前三部为“广教法”并将之秘藏于汉地近菩提树寺的阳台里。尊者将极密部(也就是宁体)随身收藏。然后，依于空行之指示，他将该部典籍秘藏于吉祥万门寺的一条柱子内，并付托于护法独发母。尊者此后自受密行之乐(enjoying esoteric exercises)，并住于汉地的展寒尸林，为所在之空行勇父之师。
    尊者将大圆满口诀部的外、内、密部口传授予无垢友(Vimalamitra)。他将口诀部的四部口授和典籍全部授予迦纳思扎(Jnanasutra,智经)，并给他大圆满口诀部的教法与灌顶，包括广灌顶、略灌顶、甚略灌顶、和最略灌顶。
    随后尊者的肉身化成虹光，其遗教《七根钉》则下降之迦纳思扎掌中。内写了：
    (逐句翻译连英译原文)
    homage to the perfection of primordial wisdom, [the union of] clarity and emptiness.
    敬礼明空之不二之圆满本初智慧。
    The awareness wisdom, which pervades all and appears in all,
    遍及一切亦显于一切之觉性智，
    is open and impartial.
    乃开放与无偏。
    For nailing [the awareness] on the changeless ground,
    为把[觉性]钉于不变之地
    by putting the seven great nails of the narrow paths of samsara and nirvana.
    将七根大钉钉于轮回与涅盘之狭路上，
    changless great bliss arises in my mind...
    我心生起不变之大乐...
    [a]strike the nail of unhindered wisdom of clarity at the juncture of samsara and nirvana [in order to unite them as oneness].
    将清明无碍智之钉击于轮回与涅盘之际[以令二者无二双运]。
    [b]strike the nail of self-appearing light at the juncture of mind and objects.
    将俱生光明之钉击于能观与所观之际。
    [c]strike the nail of natural-pure essence at the juncture of mind and matter.
    将自然无染菁华之钉击于心与物之际。
    [d]strike the nail of freedom from views at the juncture of nil and eternity.
    将离见之钉击于断与常之际。
    [e]strike the nail of awareness, which is beyond phenomena, at the juncture of phenomena and the nature of phenomena.
    将超越诸法的觉性之钉击于法与法性之际。
    [f]strike the nail of totally liberated five-doors [sense faculties] at the juncture of exitement and torpor.
    将完全解脱之五门[根]之钉击于欣与厌之际。
    [g]strike the nail of primordially perfect dharmakaya at the junction of appearance and emptiness.
    将本自圆满的法身之钉击于显现与空性之际。
    (按：与老狗·嬉笑游舞之译有少异处。)
    ------------------------------------------------------
    本文意译自东杜祖古之《龙钦宁体传承祖师传记》吉祥狮子章
    (masters of meditations and miracles: the longchen nyingthig lineage of tibetan buddhism, tulku thondup. shambala:boston, 1996.)
    并参考敦珠法王之《宁玛佛教史》
    (the nyingma school of tibetan buddhism, dudjom rinpoche. wisdom publications:boston, 1991.)
    以水平所限，谬误恐难免，谨此先向诸大圆满祖师忏悔。----林居士


莲苑歌舞

    莲苑歌舞

    巴珠仁波切著

    嗡，金刚锐利菩萨！
    一切吉祥最吉祥，名称吉祥美名称，高树胜利正法幢，文殊智尊赐护持！
    某时，于彼曾由水莲天尊赐福、戒莲王者亲临、莲花瑜伽度母身居之地，高峰莲花山下，方广林海中央，胜似皎月凌空的水晶莲花洞里，住有一位来自北野乐园的婆罗门徒少年，本名白玛杰巴，人称莲喜。他原是什么都懂，到处都去，随遇而安，逢人皆和，行佛子行有如芙蓉无瑕，修菩提心一同水莲无染，尔时，去此不远，有一周匝茂林环绕，草地绿茵如镜、名为聚荷乐园之中，别有一所莲苑，欣欣向荣。但见苑里那些莲花：骄纵的茎梗长扬，旺盛的花瓣舒张，成熟的蜜露盈盈，华丽的绿叶田田，未熟的新芽怒放，含苞的拱手合掌，衰颓的蕊丝飘零，落拓的津液枯槁，萎谢的落英掸地，欢笑的花心浮光，隐伏的浓荫潜形。自然的也都随宜生长，各得其所。就中另有三株莲花，出落得更为骄纵成熟，庄严华丽。三中之二俱极旺盛，二中之一，尤其娇丽，从来未被他人亵玩。
    如是乐园之中众多蜂群，飞舞回旋，徜徉游乐。别有一对夫妻蜜蜂，一名小金蜂莲花达旺，一名小玉蜂莲花阿宁。金蜂青春年少，芳华正茂，智慧聪明，胸怀豁达，未结新交，行止悠闲，爱好施舍。玉蜂性亦乐施，心存济世，秉性温和，喜爱佛法，不谄不诳，嫉妒轻微。他俩彼此情谊亲密，笑容微露，爱语温存，同气唱随，结伴不离，低声倾诉各自心中所怀：
    哎呀可爱青春韶华，非由画师神笔描绘，是乃善行变化所成。能与上界诸天比富，
    财物资具非我储蓄，是乃前世业力所感。花朵软褥非由织成，最极柔和自我享受。
    花心琼浆非由烹调，百味美饮长生甘露。今此幸福非可力求，前生积福天然自成。
    自心若能依存佛法，即此身躯可称暇满，无庸羡他能言解义，造作恶业两足人身。
    哎呀请听意中情人：眼前鲜花乐园艳艳，琼浆甘露滋味津津，同声相应蜂群济济，
    夏令风光为时短暂，灾害因缘其来突如，痛苦欢乐变生刹那，死神使者来迎渐近。
    贪求安乐度却此生，现世舒适终无所得。轮回世事纷乱匆匆，长时短时永无了息。
    长期图谋此命久留，寿数一尽终无所得。如意乐园景象安乐，一需别离全无利益。
    言念及此君意当决，尔我夫妻立趋佛道，有缘同心修学佛法，意中良友君意云何？
    对方答道：
    善哉善哉君言真实，诚哉诚哉感人心声，心声深入我心深处，化为我心不死甘露。
    今此眼前赏心花园，非由天界移来人间，有缘同心凤蝶共享，皆因宿业好施感得。
    美亦无常轮回本性，富亦无常如幻资财，享受无餍迷人五欲，轮迥世间如此无益！
    卿心披挂精进铠甲，我意亦已铭刻良言，议论已空何容更改，有缘同心求法首途。
    积得货财终归无益，辛苦求来他人受用。抚养亲眷终归无益，恩爱育成招怨旌旗。
    修就宫宅终归无益，欲益反成丧身悬崖。耕耘土地终归无益，良田反成蝼蚁屠场。
    但今尚需从容稍待，仓卒从事不能到头。至心盟誓铭刻心中，心中仍有宽缓自由。
    且说当时有一心地仁慈、行止温和、最喜利人、名号端衮珠巴的仙人，也到达此地。夫妻蜜蜂随即迎上前去，恭敬施礼，供奉甘美的蜂蜜，口说悦耳的言词请求道：
    哎呀呀，大天仙！你是导师的绍圣，请讲述导师的法语，你是佛教的明灯，请指示修行的要道；你是登地的圣僧，请宣说菩萨的行径。我们甚愿作为你的后学。仙人听了他们的请求，显示出喜悦的笑容，身中焕发神光，口中高唱法言道：
    南无圣者师尊！
    圣人救主天中之天，无比导师调御大士，释迦尊前我恭顶礼，请挽六道心向正法！
    嗟尔宿业有缘双峰，心若向道当念此理，此乃佛旨应当思察，此乃法要应当牢记：
    呜呼流转六道有情，往昔长此漂流轮迥，今后业感妄景无穷，百千万劫不可胜数，
    三宝名号难得耳闻，值遇佛教寥若晨星。今第四佛净饭王子，胜能仁王来临世间，
    初中后三转妙法轮，十五百年教期未尽，汝自有心寻求圣道，有缘获得善士接引。
    若不决心寻求圣道，来生不复生此圣域，三宝名号且难耳闻。呜呼迷惑幻景凡夫，
    有为虚幻妄执无常，外器世间大种无常，内情世间寿命无常，中间四季时令无常，
    佛及佛子大圣大贤，皆般涅磐无常宜详！世间主宰最大梵王，死魔犹牵余复何说？
    何时何地死皆无定，死缘众多生缘寡鲜，是故若不速成求圣道，死魔何时来无定期，
    众生必死如牲就屠。呜呼死后不归空无，行行复来轮迥受生，随生何处无容安乐：
    十八地狱寒热苦逼，饿鬼饥渴旁生相食，人命短浅修罗斗争，诸天放荡临死随落，
    到处不安到处火坑，生生世世苦难连绵，面对轮迥当生厌离！呜呼苦难唯业所造，
    业如画师无所不作，业力成熟百劫不灭。自作永不变为他受，善引善趣上种解脱，
    恶引恶趣痛苦轮迥，少因亦能成熟众果，上种天界幸福富足，恶趣地狱痛苦难忍，
    自业所感别无他因。是故随时随地皆当，正知正念谨慎为本，因果取舍郑重其行！
    呜呼接引解脱道灯，众德根本圣德上师，功业等同浊世真佛，慈悲无量恩比佛深。
    若不依随正善知识，等同生盲无相登途。是故首当择事圣师，作如意珠作如意树，
    终学德行师我会心，有此善缘魔力难逞，能得诸佛所喜圣道。呜呼涅磐寂静乐处，
    远离轮回沉疴妙法，永尽苦及苦因边际，具无漏道解脱圣域，佛及佛子圆满毕集，
    声闻独觉圣众栖息，此解脱道亟宜寻觅！呜呼无欺圣归依处，恩德无比最胜至宝，
    我因于彼归依受益，汝亦亟宜于彼归依。衷心信仰恭敬归依，永不我欺无如三宝，
    三宝能救轮回众苦，一经归依富与天齐，今生八难士六难等，来生一切恶趣恶途，
    轮回痛苦定能永除，永世勿忘随念三宝，再再归依返复祈祷！呜呼无数如来蹊径，
    一切佛子唯一坦途，无比圣财菩提心宝，若愿若行皆当生起。从此便得菩萨称号，
    由安乐道趣安乐境，离正等觉已不遥远。三界众生恩深父母，无依无友如盲漂泊，
    欲求安乐反造苦因，慈悲怀念此情此景，众生诸苦我应代除。披挂无比大勇铠甲，
    自他相换爱他甚己，四无量心六度四摄，衷心勤勉身体力行，佛说佛子万行无余，
    皆在妙道六度中摄，此是如来所喜妙道，精化之精心中牢记！呜呼轮回既久且长，
    无始积恶既深且重，若不凭依四力窍决，励行方便忏罪悔恶，难从恶趣轮回解脱。
    善逝诸佛毕集一身，本传诸师共聚宝道，金刚萨锤螺月身色，微笑安住白莲月座，
    如仪念修百字大明，永摧一切恶业堕罪，拔除一切那落伽狱。是故随力方便善巧，
    意想变化供养佛国，想于三千世界化身，密严报身法身刹土，上师三宝三身本尊，
    供尽身财三世善根，自资得圆佛刹得净，众生得熟福德无垠，故以积资为窍决根。
    呜呼无始以来无明，无我执我漂泊轮回，无身恋身生起爱憎，故于所爱虚幻蕴身，
    不惜回向作供施品。甘露为性上供三宝，下施六道圆满二资，孽债邪魔心满障息。
    意想变化供品百物，上供下施迥向利生。万法惟是心思差别，真舍自身福与天齐，
    能与大舍种植习气，资圆障净中阴光明，死亡得赎病魔被阴，故是积资善巧方便。
    呜呼深恩三宝总体，诸佛本性最上珍宝，灵应三续教藏主宰，导行本师是应祈祷！
    修在顶门修在心中，福德等同普修诸佛，三续上师灵应感心，师心我心融合无别。
    为求有利证悟真实，殷重修习上师瑜珈，从三字光受四灌顶，四障清净种植善缘，
    以证四身四持明位，修习四道长养誓言，生死涅磐皆师游戏，暂息逆境所愿得成，
    今生不掌法身五政，来世必生莲花光中，从彼行经四持明道，如幻直趋自性法身，
    利济众生量等虚空，身智光明充盈世间。呜呼此乃诸佛独路，三续持明传承教言，
    八万四千法蕴总结，决窍关节心中心要。纵令百圣千贤降临，再无更深妙法开示，
    此乃妙法甘露精华，千万圣众心法中心。愿由听讲此道福力，能令无边一切众生，
    依此善道于一生中，尽皆证得正等觉果！
    劝诫既毕，又对双蜂赐福、发愿，然后自往四云游，利济所见、所闻、所念、所触一切有情。后在弥门提勒寺中，如同薪尽之火，圆满证得肉身无余涅磐。
    此后双蜂，一般能依照仙人教诲行事，但也有时放浪嬉游，纵情贪恋景物，渡过一段长久时期。一日，阿宁正在吮吸花心甘露，达阳正在花间飞舞，突然间阳光黯然失色，云影飘然落地，刹那间莲花都合闭拢来，阿宁被包裹在一朵莲花里面，呼吸闭塞，惊惶恐惧，不能出声，只得噗噗噗噗地喘气。达阳也愕然发愣，不知所措，坠落在莲梗旁边，展转翻滚，心情沉痛地悲呼道：
    呜呼哀哉多么可怕，哎呀哎呀祸起突然，怎了怎了灾害严重，是何魔鬼骤然来临？
    天上高悬美丽日轮？是何暴君忽然遮掩？地上敷陈灿烂百花，是何恶缘倏尔收拾？
    心中爱侣何处去耶？达阳所恋何处去耶？悠扬歌手何处去耶？密谈慈友何处去耶？
    笑靥丽人何处去耶？翻飞所欢何处去耶？睨眸绿姬何处去耶？六足皓腕何处去耶？
    光艳精华何处去耶？乌发髻女何处去耶？我心头肉何处去耶？达阳我心空空奈何？
    悠悠情侣阿宁闻否？达阳悲诉不闻回音，段段分裂此心碎矣！何故残暴无情黑云，
    顿成无辜蜂蝶苦难？达阳恩人百瓣莲友（太阳），君岂已经失去自由？
    晖光普照大地主宰，请勿潜形残暴云中，请放大悲温暖光芒！横扫残暴乌云大风，
    若是风神能有多好！开放百瓣莲花力士，若是巨人能有多好！弱小蜂蜜如此遭遇，
    噫嘻苍穹老天知否？望降严旨谴责恶云！阿宁阿宁我心精英，阿宁阿宁我心藤罗、
    阿宁阿宁亲爱伴侣，阿宁阿宁天女情人！呜呼哀哉达阳伤心！
    他一面悲泣，一面在地上翻来覆去。此时，阿宁也稍微缓过气来，能够小声说话，从花苞里呼唤着：达阳，达阳。达阳一听，心中大喜，想到阿宁已经苏醒，急忙起身面向莲花呼唤阿宁。阿宁也听到达阳呼唤，知道自己被卷在莲花里面，仔细想到：哎呀呀，我俩从前虽曾在端衮珠巴仙人门下受了很多深奥的教言，但是丝毫未曾修习；虽曾立下志愿想要修习正法，但也只是想修想修之中，耗尽寿数，现在莲花苞里，或将长时忍受有如诸天死堕之苦，最后归于死亡；或将再得阳光照射，花瓣重开，可能解脱不死。但是，无论如何，达阳正陷于悲伤之中，亟应答言，不知他能否听到？随即答道：
    喂喂达阳喂喂达阳，广瓣达阳天之爱子，君声优美耳中甘露，我今已闻心生喜悦：
    但君风姿眼中甘露，我今未见不幸若何？骤然阴霾死神使者，何时来临我全不觉，
    光天普照耀晖日轮，不在太空何处去耶？柔软花瓣华美卧褥，甜蜜精华淋漓甘露，
    馥郁香气扑鼻芬芳，红粉韶华人眼醉迷，芙蓉花朵如意资具，何故竟成害命屠夫？
    柔细花朵凶残牢狱，粘腻甘露缚人镣铐，坏苦之情一至于此！吁嗟深恩盛德仙人，
    当时赐予教诲甘露，所说无常轮回本性，今朝都现我俩眼前，幸福享受可与天齐，
    转到悲惨阎罗城门，不待双目启闭转瞬，呜呼死堕如此痛苦！心中虽有修道志愿，
    未能立即勤奋修习，及至需入中阴狭路，却无正法可资信托。心中虽念死亡将至，
    未念何时死亡无定，放荡疲沓优游岁月，死神邪魔倏尔便临。心中虽念轮回痛苦，
    但恋暂现好景不舍，五境妖精诱惑五官，轮回根基痛苦遂成。心中虽信业果无期，
    但未作到取舍深密，疏忽散漫耗尽人生，曾修某善无可指明。吁嗟情郎少年蜜蜂，
    往昔曾闻世有怨敌，死神魔王凶残可畏，今兹似已现在眼前。长时栖息莲花乐园，
    本心虽实不愿舍去，此时横被死神魔君，牵至阎罗城堡门前，长时享用甘美食物，
    本心虽实不愿断绝，今受天条不由自主，食物须寻气味烟香。盘桓道路广阔天空，
    除此虽不愿往余处，此时强被阎罗牵走，即将进入中阴狭路。慈祥至亲深恩父母，
    心中虽不愿与别离，此时须往阎罗法场，无亲无友流亡漂泊。养就眷属蜂蝶昆虫，
    心中虽不愿与分散，此时终须零丁无伴，独自往趋来世长途，被体柔细绵软衣服，
    心中虽然不愿卸除，此时已被死神捆绑，赤身裸体无衣牵走。相伴爱侣金蜂达阳，
    心虽不愿从此永诀，有为原形今已毕露，似将往赴难见闻处。哎呀可爱年少情郎，
    自从相伴乃至于今，慈容微笑常开丽颜，从未曾见蹙额怒容。爱语相叙悦耳美言，
    从未曾闻厉声相责。仁慈心情伴随美意，从未曾见无视决绝。必需享用身外货财，
    从未曾分尔我各别。长时短时举止行为，从未曾露姿态不悦。善良心意深长情谊，
    相待厚恩永在心头。亲密相伴不辨离合，眷恋深情永在心头。谈言称心情投意合，
    爱怜词气永在心头。同心相爱不辨离合，亲密意向永在心头。所栖住地似将离别，
    为是住地思之不悔。所积货财似将别离，为是货财思之不悔，所蓄奴仆似将别离，
    为是奴仆思之不悔。所爱身躯似将别离，为是韶华思之不悔。所惜生命似将别离，
    现世安乐思之不悔。但虽与君恩爱情郎，永远诀别痛苦穿心，此番离愁遗除无方，
    想念娇好慈祥容颜，眼底泪流如雨涟涟。想念亲切相爱深情，痛苦遮心阴暗朦胧。
    想念温情慰藉爱语，心中悲伤如火熊熊。命已至此今复何为？谁为驱遗死神魔军，
    谁抗轮回苦难历程？请君亦念此情此景，请君心中勿过悔恨！若得太阳重放光明，
    君有可能幸得解脱，愿君宽怀安闲居留。倘不解脱就此命尽，亲爱相伴心友如君，
    往昔深情温存备至，相待再无更甚于兹，毕生企求已达终极。往昔我辈身在福中，
    心头留有志愿誓约，此时君心尚能记否？纵令从此竟自永别，愿君永不背弃盟誓，
    向往之道及时力行，除此别无其余叮嘱！
    达阳听后随即答道：
哎呀阿宁哎呀阿宁，璁玉小蜂歌手阿宁，莫怕莫怕镇静尔心，勿恐勿恐振作精神！短暂疾苦不会长在，空中乌云不会久留。太阳光辉不会衰败，临时乌云转瞬逆境，此番灾难当可解脱，相交亲眷蜂蝶众多，派作使者多方请托，当能完成心中所求，蓄积货财蜜汁满仓，放手施予当能禳灾。往询郡国众多贤能，当知抗御灾难方法。指望其他豪杰壮士，当能逆阴外来乌云。无边村落山石岩穴，中有玄羽乌鸦噪鸣，云向通国宣说神通，若请问当得 预 言，巍峨碉楼天窗檐头，褐羽麻雀群集喳喳，云是念诵摧魔神咒，迎此雀群可为诵修。水井池塘低湿泽国，貌现丑恶褐皮蛤蟆，云是乌黑孽龙使徒，若往请问当有良谋。洞中树下落叶深处，多有凶恶乌黑毒蛇，云是恶毒水神本郄，若往依靠容阻黑云。山头土穴以为居处，长年修道大士龈鼠。云彼参禅已得定力，若往启请容赐照扶。赏心惬意高树叶端， 嘤嘤其鸣绿衣杜鹃，云是召集降雨密云，若施贿赂容停呼唤。北国草地欢乐平原，天帝使者白口野骡，云有宝珠呼唤日光，往请容或延颈掀唇。居无定处时在本穴，嗜杀老猪九脚蜘蛛，云是黑屠恶龙化身，若往请见容施计策。或从高空山顶悬岩，刺耳长鸣赤褐鹞鹰，云是妙翅鸟王使者，向彼祈请容施威力。未有灾害拒不能抗，未有恶业忏不能净，未有障碍制不能伏，未有邪魔禳不能解。有识有谋金蜂达阳，我身宽缓得有自由，如何妥善当尽百计。说毕，即往请询于乌鸦。乌鸦答道：龙是祸根鹏能制，疾风针对解法多，暂时凶险终无妨。如此走遍各处请询，麻雀群长道：僧团灵应如烈火，焚毁宿业如毁林，何况草芥暂时灾？供养承事须殷勤，答毕，各自诵经修行而去。蛤蟆答道：貌现丑象我蛤蟆，本是乌云孽龙徒，乌云根源屠夫龙，向彼请求能驱除。说毕，两眼噔视着天空。黑陀答道：水神忿怒肉冠中，气涌黄黑浓云出，凶猛肉冠蛇所有，驱除乌云我有术。说毕，蜿蜒而逝。龈鼠答道：我本专心修禅定，也闻金蜂诉哀情，为尔洞中修佛事，最后必定无灾星。说毕，瞑目而坐。杜鹃答道：两云诸天护法神，翠兰杜鹃是使臣，去留我有少自在，尽善图谋以助君。说毕，摇曳而立。野骡答道：独身警觉我野骡，上唇本是如意青年人，横扫乌云是扫帚，对我指望准莫错。说毕，上唇仰天。蜘蛛答道：黑屠恶龙口嘘气，无有余计可驱除，若能聚集百虫肉，禳灾解魔我能作。说毕，口吐蛛丝，网结灵器。鹞鹰答道，伏龙我是大鹏鸟，吞蛇食龟硫碎龙珠，利爪威猛如霹雳，勇武一施齐粉碎。说毕，冲飞云霄呜呜长鸣。达阳当时心想，由些辈远迩驰名奇异生灵之言观之，空中乌云终将散去，阿宁获得解脱亦有可能。方才放心稍事喘息，忽然间天空乌云翻滚，阴霾四合，南方响起隆隆雷声，狂风同时呜呜怒吼，一切莲花更加紧闭收缩。阿宁仍被包卷在莲花蓓蕾之中，手脚不能屈伸，呼吸短促，出声困难，低声诉道：呜呼达阳天之孙，花瓣重重紧封闭，花蕊粗利如刺戳，瓣片棱角紧如石，裹得手足难伸缩，气息短促难呼吸，言语哽咽难诉说，今已定不能解脱。八方惊雷隆隆响，狂风骤起呜呜呜，莲花苞里摇复摆，池塘震颤如簸扬，行看黑云洒冰雹，冰雹来势甚凶猛，生就绿草披且靡。亭立荷梗碎且裂，装点枝叶断且折，成熟果实散且灭，盛开花朵凋且零，天地止下将翻覆，坚固山岩将崩裂，高树也将改旧观，凶猛霹雳当头来，君当立即自逃避，阿宁难脱势已必，生死分际最后语，言多无益义总结：往昔大仙所赐教，今朝益发念心头，轮回本性即痛苦，今朝益发亲印证；所说一切皆无常，今朝益发现眼前。一切聚会空别离，君似为此太伤怀，我却坚毅心不悔。昔日约言丝绢结，是否未散尚紧勒？石上所刻志愿纹，是否未泯尚鲜明？心中所钉盟誓橛，是否未脱尚坚定？轮回景象苦难情，厌离由衷生也未？死神不定何时来，坚信由衷生也未？五境妙欲欺诱饵，贪恋从根拔也未？一切聚会定别离，坚定信念得也未？虽钉也得遇圣士，从未决疑我好悔！虽然也得闻佛法，未曾实修我好悔，虽钉也得暇满身，未取精义我好悔，虽钉也知死无常，死道未备我好悔！虽然也闻因果名，取舍失宜我好悔！虽然告我轮回苦，未生厌离我好悔！眼前死亡骤来临，死神怒容黑阴森，睁目滴溜我惊惶！可怖黑暗迎面来，不见道路我惊惶！业力狂风卷身后，不由自主我惊惶！呼杀喊打吼如雷，幻景眼前我惊惶！咬牙切齿阎罗卒，行凶逞暴我惊惶！死神套索系颈间，强力牵走我惊惶！面向来世大迁徙，孤苦零丁我惊惶！陌生地域远漂泊，无所适从我惊惶！六道幻景如繁星，无怙无恃我惊惶！修学佛法虽有心，我悔未能立即行，意中情人小蜂君，慎此忖心出世法，照明心佛教莫迟延，决意修行莫散漫，坚毅迫切莫缓期，及时勤奋莫迟延！临危终不舍正法，丧命亦当守誓言。计议眼前是鬼话，应当鄙弃莫记存。放荡懈怠欺人因，戒之如毒莫贪恋。修行期同寿命齐，终身与法连紧密，奉行正法到究竟，君应探取涅 境，我亦证得解脱道，最后同登大乐刹，生死皆能亲相遇。肯作不作全在君，希望寄托在来生，死后相期在墓穴。除此三言无余嘱，紧记此语意中人！君今速避坚固城，我虽陷入死亡境，有君留后我心宁，修道若成俱受益。趁此永远长住世，愿君修道得成就，愿君志趣得竟成。从今祝你居安宁。
    说毕，奄奄一息，达阳此时猛觉痛苦如利刺穿心，悲极不能对答。刚才哎呀一声，突然狂风里洒下猛烈冰雹，高空里哗啦啦响起迅雷，天上闪电像鲜红的火练飞舞起来。达阳不知所措，慌忙躲进断岩穴中，连呼啊哟啊哟！接着冰雹愈益猛烈，飞洪滚石漫山遍野，霹雳吼声破天裂地，河下到处惊涛翻腾，骇浪滔天，高山夷为深谷，平原布满卵石，池水沸扬如血，芳草鲜花，大者摧毁，小者倒伏，长者断折，短者淹没，纤细者皆已散尽，沓无踪影。过了一阵以后，乌云都散净了，明朗的太阳出来了。此时达阳起身向莲苑走去，但见那些生长在草地和池塘里的花朵：粗大的还倒伏在地上，细小的连痕迹都不见了。生长在水里的莲花，冰雹下降时全都淹没在水下；雹过天晴，便又伸出水面，重新开花，蜂蝶三五，飞舞嬉戏，颇为欢乐。阿宁所在的花朵虽然未被冰雹毁灭，由于深深淹在水底，阿宁气息闭塞已经死去，尸体卷曲，附着花心。面对此景，达阳横被极度悲伤之所压抑，痛苦钻心，珠泪满目，往昔灿烂的阳光，怒放的莲瓣，欢舞的蜂蝶等一切引发欢乐的景物，都成为痛苦的增益，以非常悲哀的声音哭诉道：呜呼呜呼呜呼，好苦好苦好苦！轮回痛苦本性，请看如此苦景！无常幻化村落，请看如此废墟！无常迷眼宅舍，请看如此倾圯！欺诳不实妙欲，请看如此变异！适才锦绣花团，此时落英残敝；适才肥硕绿叶，此时飘零满地；今晨幸福乐圭，现时悲苦毕集；从前相伴良友，而今身心分离，前此乐观达阳，而今希望断绝，从前可爱妙欲，而今都成苦因；今晨妖好六足，此时已为死尸！言念此情此景，哀哀我心悲哀，昏昏我心昏迷，攘攘我心昏迷，攘攘我心扰攘，战战心惊肉战！骤然死神魔鬼，已经先临她身，何时来临我体，知此唯有师尊！苦也达阳苦也，愿得师尊赐福，转我心向于法！
    达阳如此哭诉多时，心中异常悲伤，无心在此久留，随即飞向高峰莲花山前，在波罗门徒少年莲喜住地附近满垂露珠的翠柏叶间盘旋悲歌道：
    呜呼可喜百花快乐园，本是不可喜爱苦难村，可爱妙欲五境诸享受，本是可憎无常迁流苦；倾心爱侣终身永世伴，已成不可爱怜腐烂尸。知晓知晓三宝全知晓，思念思念自念出世法，急迫急迫急趋正法路。筑成皆倒宫室有何用，积来皆散财物有何用，会聚皆离亲戚有何用，高位皆颠权力有何用，有生皆死现世有何用？业作之合亲爱好配偶，此刻容或已入人中阴境。死后指望唯有出世法，有用佛法自己若不修，资财虽富有钱无处飞翔，朋党虽众有力无所夺，意气虽投有朋无处赎，善业馈赠礼物无可献，阎罗判决缓期无可延。搁置不修多闻终无益，荒弃不耕田土终无益，放置不骑马良终无益，从今始念一切皆不需，有生余年一心修佛法。不思怨仇不谋克敌术，不思亲友不劳结纳心，不思货财不暇累积蓄，不思禄位不含笑奉承，不思朋党不求互爱怜，不思衣裳不待温柔软，不思食物不择甘美味，不思居住不据城郭堡，不思今生观世是魔鬼，不思一切幻景是怨敌。无分别中舒畅安然住，无思虑中平等自缓弛，无修习中亲自见法身，高卧山谷证士真安乐！幻景息灭寻思不复多，去取息灭不矫揉造作，疑望息灭远离希求欲，错乱永灭通人真安乐！心不造作平常本来心，发不修饰披发自下垂，行不造作任性不检点，断绝造作瑜珈师安乐！脐轮火燃无衣坦荡荡，定力驯熟无食乐融融，内证通达赤身无拘束，道相淳厚得道真安乐！毅力坚强自心乐苦行，能守誓言独自安然住，饮水吞石便足养生命，戒禁成就仙人真安乐！如法修行一切皆安乐，贪恋今生是谁也痛苦，幽静山野永时皆安乐，轮回城邑随处皆痛苦！依靠三宝经常称心愿，贪图名誉恒常遭祸殃！上对宫家交纳复交纳，交纳无已就此可罢休；下对仆役尝赐复尝赐，尝赐无已就此可罢休；中对亲友抚育复抚育，抚育无已就此可罢休；怨家仇敌争斗复争斗，争斗无已就此可罢休；熟地良田种植复种植，种植无已抛舍成荒地；造就宫室居住复居住，居住无已徒步入空山；充饥食物吞咽复吞咽，吞咽无已就此修苦行；御寒衣裳穿着复穿着，穿着无已赤身自远离。立刻就行立即行佛法，立刻就修立即修死道，此即誓言诸佛请垂念，此即诺言我心自主张。
    对此，仙人莲喜心中揣度：金蜂达阳心虽早已热爱佛法，诸事稳重，心地纯良。此番遭逢时变，偶尔生起出离之心，难免不能长久，我且先作考验。因而唱道：
    喂喂金蜂达阳心中友，独自引吭悲歌所为何？今朝宿业注定终身侣，突然死魔套绳牵引去，不当灰心但应更坚毅。出世法基世法宜圆满，不为安乐出世法何益？勤修佛法就为求安乐。一友死去何至便无友？世上从死一死便计穷。时苦时乐本是轮回性，心觉安乐还有百次来。偶尔厌离天王所幻化，君岂不知此心不久长？孟浪布施本是轻率行，君岂不知此举无后果？突遭厄难暂现一刹那，君岂不知于意无得失？二道圆融圣者所力行，君岂不知内有解脱道？妙欲会道密乘巧办法，君岂不知其中有捷径？争取王位取是佛子行，君岂不知中有利生事？聚敛货财有力兴布施，君岂不知彼具六度行？当知心意不完多许诺，最后终成各种违怨因；毅力不坚许诺修苦行，小心终成邪见生起因；持续不久厌世想出离，小心终成自己失策因；示得完力独自隐深山，小心终成感觉厌烦因；未证空见孟浪人险地，小心终成鬼神捉弄因；大道未成率尔行戒禁，小心终成堕进地狱因；本性未移外表改装束，小心终成被人耻笑因；不给观察草率多心计，小心终成生起悔恨因；事无定准行为多纷异，小心终成完全厌恶因；未证见道为人说先知，小心终成自他俱毁因；悲心不淳许诺行利生，小心终成生起执着因；未曾谨严思考与观察，不可随心所欲撞口出，不可口中所说都实行，做到掌握不失是关要，做到执持不舍是关要，做到言不虚妄是关要。精明金蜂君意善存念，此是散人莲喜心中言，是我由衷体验莫讥笑，是我亲切密语莫指责，此是实语留心审观察！
    说到这里，金蜂觉得有些于心不合，随即唱道：
    哎呀幽静山林中，婆罗门仙多悠闲，白玛杰巴多欢快！对我孤零小蜜蜂，肯作哀友情义深，对我悲吟小达阳，讲说密言心意长；对我忧伤小金蜂，赐予安慰恩德厚！尊言二谛圆融中，若有至理真奇怪！面对痛苦轮回情，小蜂我心生厌离。往昔我曾依善士，一心向往如来教，修道誓言铭心中，决非偶尔故作态，一心眷恋幽静林，一心景仰上人行，凡夫意想决不存。全意倾向佛法僧，恭敬顶戴大恩师，归心处所决无误。宽宏大度对怨敌，情意长远对亲戚，恶斗嗔恨决不作。供物上供三宝前，布施下舍弱无力，无效施舍决不作。自己功德深隐匿，他人功德张幡旗，卤莽傲慢决不作。注定终身永久伴，忽被死神套索牵，今日亲眼见无常，悲伤厌离由衷生，言下决无假造作。誓言铭刻在心中，勤勉修行自鞭策，所说决无虚伪情。意气相投莲喜君，曾经亲谒上师佛，深妙教言已得否？曾经闻思诸经纶。话里虚言已断绝？曾经修道处空闲，真实证悟已生否？曾经欢歌山岩前，证境功能已显否？行经旷达多随便，圣道一味已跻否？轮回城里观剧来。厌倦由衷已生否？请君出言顺正法，请君唱歌合圣道，请君为讲无常喻，请君摧破轮回城，讲论解脱道功德，赞美幽静深山谷！金黄小蜂我达阳，定把空林当居处，定把佛法当爱侣，观剧要从自心观，同君共谈同心话，请赐教言勿隐曲！
    诉完之后，婆罗门仙人莲喜，也自觉得金黄小蜂达阳，秉性善良，志趣坚定，不同一般盂浪轻浮，杂念众多之辈。总之，就其现在口气看来，似于佛法深怀信念，故我说话应当契合其机。随即唱道：
    哎呀同气心中友，金黄小蜂达阳君，汝心所向在三宝，信念殷切对正法，厌患出离收乱心，有志自甘力修行，足见前生有宏愿。有为无常知为幻，轮回城中生厌倦，远弃八风现世心，乐自独处空山谷，足见于法有宿缘。闻思境中智慧生，深思业果去取明，了知妙善佛子行，已经获得圣道门，足见已得贤师引。得为贤师弟子我，特为有缘小蜂君，提醒美好抉择慧，愿君增加勇气魄！
    下界某一轮回城，器世闻名虚幻境，情世闻名顽固迷。一时情器两会聚，行恶争夺复杂夺，痛苦蔓延如林火；行善背离复背离，安乐稀疏如晨星；恶行志愿连志愿，世道衰如夜幕临。凶恶嗔恨石磨中，贪欲执着磨眼里，注进人趣炒麦花，磨粉堕进恶趣底。上界减少日益甚，下界增加日益多，因果道理细且微。往昔瞻洲人世间，村落边际紧连绵，交往近便鸡飞至，享受安乐与天齐，转轮圣王作主宰，运转权威凭金轮，仆从小洲饶四洲，纲纪十善盛流行，人世增上生天界，天增花朵满乐园。而今劫浊恶世间，村落边际颓垣连，荒芜田地连成片，享受血肉作饮餐，地狱走卒充主宰，运作权威凭屠杀，恶业有情作仆从，狡诈相食作纲纪，后继之人唯奸佞，恶趣门边奸佞盈，寒热地狱增益多，战地罗刹修罗胜，婚姻瘟神配鬼王。座上国君行奸诈，施展毒计害无辜，裁诬列举臣仆罪，奸诈殃及自与他。伞下喇嘛行奸诈，值得佛法作掩体，冒充神通说似疑，买卖灌顶如货物，凭借咒力谀官家，作法禳灾走乡曲。山中修士行奸诈，身处山寺作尸卧，一见凡人便端居，暗中隐藏私有财，谄曲奉承施主前。世俗凡夫行奸诈，存心如同陶人车，且看所需且转盘；出言如同铁匠锤，相机随宜转话头；行事如同初夏天！眼前晴明眼前黑；情义如同蜜蜂口，吮时尚有过时无；情面如同卷轴画，画面美好画底无；信心如同肺片汤，汤面似有汤底无。佛教信徒行奸诈，闻思如同蝌蚪形，头部粗大尾部细；求道如同蛤蟆口，听时便有修时无；凭借诳言欺上师，诈将非法充正法，诡言修行徒空谈。大地奸诈风行时，真实正道何处寻？邦国虚伪遍布时，贤善道理向谁说？国君自毁王法时，臣明疾苦望谁怜？师尊寻求私利时，利济贫困谁实作？主人残害仆从时，弱小照拂指望谁？呜呼噫嘻再噫嘻，小子由衷心厌离，无常罗刹牙齿间，三界有情流且转，仍执有常被束缚。此生反复谋自利，临终懊悔椎胸泣。一心追求明日计，来世佛法往后推，且看今晨活身体，今夜即便名死尸。明日来世谁先到，事前已曾知也未？今我小子莲花喜，有幸亲身遇佛师，幸蒙慈悲赐接引，信仰信任心专诚，诈现恭敬来尝作。所告皆是直爽言，设词装腔末尝作。行为朴实浑且厚，狡猾两面末尝作；倾心一师一本尊，别寻皈依末尝作；圣贤门下长时居，善良上师依止多，无类经教见闻广，是故能辨法似法。金色小蜂达阳君，若时真心欲修行，若时衷心生厌离，须戒似是而非法。初期寻求正法道，厌离心有近似法；一是逢苦始厌苦，二遇逆缘隅灰心，三对密友存怨望，四因劳苦怨艰辛，五恨时移身衰老，近似厌离非厌离，出离心有近似法：一爱盛装改旧衣，二图安逸处幽闲，三图咒力修念诵，四为游览朝圣地，五因疑怨舍八法，近似出离非出离，住岩棚有近似法：一是表严里懈弛，二是凌乱心故荡，三为研学巧技术，四为临时琐事多，五为寝卧度人生，虽住岩棚终无益。厌世心有近似法：一是事败图逃避，二是冲动妄轻狂，三夸大口未思量，四是无聊轻货财，五是愚鲁计谋穷，似是厌世非厌世。游方域有近似法：一是好奇观景物，二无信仰朝圣地，三不知益转经轮，四贪财食行狡诈，五不思索但浪游，似是巡礼非巡礼。闭关亦有近似法：一无本尊乱讽诵， 弃知念修生圆，三欲咒力修诛法，四计遍数耗时日，五贪现世修羯磨，似是闭关非闭关。中期实行修行时，归依变有近似法：一但口头累遍数，二昧专信三宝知，三味殊胜归依境，四味三宝胜功德，五存怨望修归依，近似归依实无益。发心亦有近似法；一思独善故发心，二思获得异熟果，三为悲心存偏向，四说发心徒空谈，五昧戒条作耳风，名为发心实无益。生次亦有相似法：一离光明唯佛慢，二无佛慢但光明，三执平庸存疑望，四修威猛无悲心，五不结合净圆熟，名生次实轮回因。圆次亦有相似法：一昧光明修风脉，二不习幻观梦境，三脉未解行方便，四昧自解修印圆，五执现分修超越，名为圆次实无益。最后修出成果时，利他亦有相似法：一待证景说前知，二凭鬼神显成就，三为八风讲正法，四聚徒众非佛徒，五无证景妄指引，貌似利生实无益。凡此廿五近似法，非照他人过失镜，我亦依此自省察，愿君亦常系心间。是否误将近似法，当作如理真实行，应当郑重细改正。所言虽不甚悦耳，含义深奥滋味多，无等上师亲口传。倘若真心修妙法，不可夸口托空言，不可铺张讲排场，不可定期选时刻。佛法不须别追求，出世法如肢与体，随时需要皆在侧。刹那刹那须勤勉，顷刻顷刻须记明，瞬间瞬间段改正，日日回向须检点，朝朝须发宏誓愿，座座皆须细观察，附带顺便须不离，经常永时须不忘。若不实地行修习，大事张扬称佛徒，形似佛法终无益。一为偷懒避深山，二为放荡居寺院，三为安逸寻幽静，较此更坏世上无。知否金蜂天之孙，乐不可爱苦可爱，乐时烦恼五毒盛，苦时宿积恶业尽，苦是上师大慈恩。
    称不可爱讥可爱，称赞我慢傲心盛，讥毁自罪全布露，责言都是天赐礼。高不可爱卑可爱，居高遭忌生骄慢，处卑悠闲增福善，卑是高位敷座垫。富不可爱贫可爱，富时守财忧苦多，贫时苦行佛法就，乞丐身是法所托。与不可爱夺可爱，赐与增添来世欠，劫夺清偿前世债，知足实乃总圣财。亲不可爱仇可爱，亲戚障碍解脱道，仇敌都成忍辱田，平等一味修道关。如法修行须如此。深妙教诲六关键，唯一父师亲口传，唯一弟子心所托。精华之精华六言，除却唯一良友君，一定未向他人说。吁嗟金蜂天之孙，圣地高峰莲花山，唯一本尊度母刹，大悲观音菩萨宫，莲花王者修行地。且看此山形圆满，心性安息圣者身，且看岩上无量数，天生六字圣者语；且看林间满盛景，璁叶净土苍翠苑；凶猛毒蛇周匝饶，无缘凡夫难侵入：普陀灵山风物全，前有意化莲花生，放散化身利有情；近有圣母华丽宫，圣母利生时机熟；大悲观音心胸间，莲喜修道仙人窟，本尊依止观自在，真言念诵六字明，修习妙法慈与悲，路遵佛子安乐道，心欲受苦反得乐，今安后乐啊啦啦！启白应请上师尊，大悲不舍啊啦啦！启请本尊观世音，成道不远啊啦啦！啊啦啦，真美好！美好也否天之孙？一则我心有誓愿，二则君意怀希求，二人同趣高士行，远弃八风如路尸，永断现世如怨毒，勤勉修习细检点，正对过失行教诫，扬弃浮夸与空谈，发心直奔菩提道。当否眼前须定议，同心协议两兄弟，解脱道上结伴行，轮回边际乘愿往，生生世世缔善缘，共同人行菩萨行，善否愿否天之孙？名言毕矣啊啦啦，至理备矣唉吗嗨！
    话至此处，达阳非常称心合意，证得究竟智慧云云。
    俨然秋夜月满空，相好韶华妙音尊，一切胜者智勇识，一切有情心法性。
    无边有情苦自性，慈手爱抚目不瞬，一切胜者大悲心，六道众生解脱种。
    执掌大乘密深藏，诸佛密主持金刚，诸佛智慧与功业，明空净存众生界。
    佛师三姓主无别，恭敬启白求加持，紧随部主至成佛，大悲常赐大悲摄！
    《出世法言· 莲苑歌舞》乃依门弟子札西格勒劝勉，散人· 宝利著。


一刹那即能成佛之捷径道

一刹那即能成佛之捷径道·诸佛名号念诵次第

虹身成就者白玛邓灯　造
喜饶俄热仁波切　传
堪布向久迦造　译

    为了遍虚空的众生而归依具九传承上师以及四、六续部坛城本尊、母续空行海。(念诵一遍的功德若有形象尽虚空亦不能容纳)

    南无顶礼、供养、出有坏应供正等觉毗婆尸佛、尸弃佛、毗舍浮佛、拘留孙佛、迦那迦牟尼佛、迦叶佛、释迦牟尼佛等等贤劫千佛父母儿眷属。(念诵一遍与诸佛的智慧无二无别，并与念诵八万四千法门的功德等同)

    南无百千俱胝恒河沙数应供正等觉。(诵一遍的功德诵一遍大藏经的功德等同)

    南无十二现等觉。(诵一遍的功德能清净十二万劫以来的罪障恶业)

    南无三摩地日光应供正等觉。(诵一遍的功德能消除七万劫间的诸众生之迷暗)

    南无上师日光支、多罗树现圣妙应供正等觉。(诵一遍的功德能消除断众生肢以及杀生、食肉的罪障过)

    南无光德、无垢无边善逝应供正等觉。(诵一遍的功德能清净无始以来偷盗的罪障过)

    南无月光、如月明、威严应供正等觉。(诵一遍的功德能清净邪淫的罪障过)

    南无得乐、无垢光应供正等觉。(诵一遍的功德能清净由于贪爱而破戒的罪障过)

    南无尊胜音应供正等觉。(诵一遍的功德能清净十恶业罪障过)

    南无月灯、具尊胜、月光宝、鼓音王应供正等觉。(诵一遍的功德能清净四重的罪障过)

    南无无量光、诸香、香王、掌花王应供正等觉。(诵一遍的功德能清净破戒律、破菩萨戒的罪障过)

    南无宝藏、宝幢应供正等觉(诵一遍的功德能清净骑马、骑牛的罪障过和积累无量资粮)

    南无宝源、设花光应供正等觉(诵一遍的功德能具十万劫不可思议的菩提心和成就佛果无违缘)

    南无诸佛海应供正等觉(诵一遍的功德能清净破密乘三昧耶戒的罪障过)

    南无大势、精进、实现应供正等觉(诵一遍的功德与念诵一遍经藏的功德等同)

    南无金刚勇士、稳固、平息、降伏他势应供正等觉(诵一遍的功德与念诵一遍三藏的功德等同)

    南无威严须弥山、宝光塔应供正等觉(诵一遍的功德能清净五毒烦恼，生生世世不离诸佛)

    南无威严藏、圣宝盖应供正等觉(诵一遍的功德直至成佛，得佛摄受)

    南无无量寿、持长寿宝瓶、无贪莲眼应供正等觉(诵一遍的功德能免除死因和投生三十三天道)

    南无宝花诸量光德、狮子吼、圣幻化相德圣应供正等觉(诵一遍的功德能清净无量无边大劫的诸罪障过)

    南无宝月光庄严妙音王应供正等觉(诵一遍的功德能投生为转轮圣王)

    南无一切有法、无迷威严之源王应供正等觉(诵一遍的功德能即生成佛)

    南无清净月应供正等觉(诵一遍的功德能迅速成就佛果)

    南无具足三摩地定、初次发心无疑不动应供正等觉(诵一遍的功德能清净罪障直至成佛之间，不投生三恶道，成就究竟圆满佛的果位，往生不动佛的刹土，莲花化生)

    南无无量光、圣宝德王、功德宝王应供正等觉(诵一遍的功德从现在起直至九十六亿劫，无量恒河沙数劫皆往生极乐世界决定无疑)


生生世世摄受愿文

    生生世世摄受愿文
    法王如意宝晋美彭措 著
    益西彭措堪布 译

    三世一切善逝诸如来，自前显现殊胜善知识，
    无比胜恩功德大海藏，祈祷于您上师如意宝。
    您度众生善巧方便行，无论显现何种之形象，
    乃至刹那邪见亦不生，一切所作见善求加持。
    师您慈悯教诲之善说，只言片语亦不作违越，
    犹如倾注宝瓶诸加持，愿悉无余融入我相续。
    怙主您于净秽刹土中，示现各种幻化戏舞时，
    愿我幸能成您胜随从，同时趣入菩提萨埵行。
    何时自现清净刹土中，至尊显现获得正觉果，
    吾亦随从最初得安置，愿成增盛殊胜事业者。
    总之从今乃至世世中，与您依怙圣者不分离，
    既获菩提亦成种姓主，祈愿灭尽六道轮回城。
    此文于五台清凉山，应金刚弟子日珠堪布诚心恳求，造一上师如意宝生生世世摄受之愿文，阿旺洛珠宗美即刻任运而作。


祈祷加持日光文

    祈祷加持日光文
    法王如意宝晋美彭措 著

    三世一切佛陀总集身，无余引导诸众大商主，
    如海空行主尊嘿日呷，于您如意宝前敬顶礼。
    较您殊胜上师我无有，除您教言之外无所修，
    诸时唯一希欲依靠您，如意宝之称呼当具义。
    智慧狭劣学识浅薄我，无力奉持广大之修学，
    殊胜上师及文殊童子，二者无别顶轮或心间。
    观想安住深信作祈祷，大悲恩赐加持莫乏少，
    灌顶成熟教言解相续，四现趣于究竟祈加持。
    生生世世与您不分离，如海禅定功德愿自在，
    犹如文殊童子尽空际，利益无余众生愿精进。
    于善弟子日顿前五台山静处阿旺洛珠宗美所著。善哉！于五台山静处，应贤善弟子日顿所请，阿旺洛珠宗美所著。善哉！


成就真实戒经

    成就真实戒经
    释迦牟尼佛 造
    益西彭措堪布 译

    梵语云：希喇桑耶意达思札
    藏语云：赤诚扬达巴波丹多
    汉语云：成就真实戒经

    顶礼一切智智佛！如是我闻，一时，佛在舍卫城祗树给孤独园，与大比丘僧一千二百五十俱。尔时，世尊告诸比丘：诸比丘，若分别心渐减、性命断趋于断灭、舍弃寿相，则导师之法亦将灭尽，云何不起精进并披坚固甲而修持也？人身极为难得，已得人身，值遇佛陀正法，得以出家，被不合解脱之义所欺狂而遭痛苦。诸比丘，宁可离命而死，非可摧坏戒体。何以故？离命而死，唯令此生寿命穷尽，毁坏戒体，乃至百俱胝生，常离种姓，永失安乐，当受堕落痛苦。
    是故世尊赞戒言，具戒之人值遇佛，
    具戒之人最胜饰，具戒之人妙香涂，
    具戒之人诸喜处，具戒之人清凉水，
    具戒之人世间赞，人天圣位以戒得，
    毒蛇黑龙亦不害，具戒之人何况它？
    具戒比丘具光芒，具戒获得名声乐。
    犹如无眼不见色，无戒之人不见法，
    犹如无足不入道，无戒之人不解脱，
    犹如妙瓶珍宝器，戒律能生诸法因，
    如破瓶不成宝器，毁戒之人灭诸法。
    首先成为无戒者，后欲获得涅槃耶？
    何人无鼻残鼻等，彼者不需要明镜，
    虽耳未闻眼未见，护教者定转善趣，
    多闻受持趋善趣。岂能依止女人耶？
    岂会喜欢王宫殿？受用岂能恒久存？
    一切女人不能依，一切国政无欢喜，
    一切水泡无实质，一切受用无实义。
    一切受用如流水，彼舟如何家亦然，
    鲜花如何色亦然，生命好似水中泡。
    世尊说此偈已，优婆离等众比丘悉皆欢喜赞叹世尊所言。


三戒之教言

    三戒之教言
    法王如意宝晋美彭措 著

    无等具恩上师住心间，宣说甚深修法与挚友。
    请听无边功德所依基，若具清净戒律之胜饰，
    天等诸众定会长时供。
    遍空有情安住佛果故，五髻佛子铠甲披身已，
    心当不懈行持六度行。
    其为浩瀚诸佛已行道，若恒修习生圆二次第，
    俱胝法色身藏您喜得。
    此三戒修持之三句文，为小和尚才旺，加日（上师之名）所写。（此教言是上师法王如意宝少年时，在石渠江玛学校安住时所说。）


红黄文殊成就诸事业 ——平日智慧修法

    红黄文殊成就诸事业 ——平日智慧修法
    精要仪轨
    全知麦彭仁波切造

    欲实修红黄文殊成就诸事业，平日瑜伽精要略修法者，首先皈依、发心、积资
    加倍咒
    嗡 桑巴Ra 桑巴Ra 布玛纳萨Ra 嘛哈奘巴巴 吽啪d梭哈（三遍）
    安住虚空遍满虚空者 上师本尊空行诸会众
    诸佛正法以及圣众前 我与六道众生敬皈依
    （三遍）
    吙！
    如同三世佛佛子 已发最胜菩提心
    我亦为度遍天众 愿发无上胜觉心
    （三遍）
    之后念诵下文观想而祈祷：
    阿 明观诸法光明本净中，
    任运自成皆现大悲力， 出现红黄德字光云聚，
    放光供圣净众之二障， 觉醒器情清净大坛城，
    摄收我身刹那转变成， 一面四臂文殊金刚尊，
    郁金形色相好韶华满， 上之右手挥舞智慧剑，
    左手持执绽放青莲上， 置有智慧波罗蜜经函，
    下二手持智悲之弓箭， 严饰绫罗珍宝与鲜花，
    放射无边种种之光芒。 无量三根本佛聚集众，
    犹如芝麻荚开之相状， 二足妙严金刚跏趺坐，
    盛开千瓣莲花心蕊间， 无垢满月座垫悠然住，
    彼身一一汗毛孔隙中， 悉皆现出一切庄严刹，
    现空遍空虚空金刚身， 观如幻化水月彩虹般，
    誓言智慧本来无二致。（一遍）
    念诵供养偈：
    吽
    真实财物意幻化， 无上普贤之供云，
    庄严广大净虚空， 献内外密如海供。
    嗡 阿雅玛则西日、萨巴热、瓦Ra、班札阿刚、巴当波败，德败，阿六给、甘得、那为得、夏达、玛哈班匝、阿讷达、Ra达、巴郎达玛哈色卡布匝火。
    （一遍）
    念诵赞颂偈：
    锐利金刚断痛苦，殊胜妙慧身智尊，
    智慧圣尊语自在，礼赞成熟众生您。
    尔后再诵：
    心间白色莲花中，无垢明月坛城上，
    红黄德字光灿灿，周围环绕心咒鬘，
    自然心咒声妙力，放光现有诸轮涅，
    显现悠悠荡荡相。觉醒无别身语意，
    自然智慧坛城轮，成就金刚文殊尊。
    （一遍）
    嗡啊Ra巴匝那德
    七字心咒咒中王，远离念诵之过患，
    不动等持印持诵，对应验相百千万。
    后座供赞取悉地，摄起念诵吉祥赞，
    后为自成诸事业，依照宝瓶气修法。
    观想射收之次第，《诸源宝珠聚业》中，
    如何所说七日等，对应验相而实修。
    尔后当如教所说，行持无量之事业。
    萨玛雅鄂特！嘉！
    甚深教藏之经续次第中，归纳窍诀藏而于铁龙年二月二十一日怀业时，称为文殊欢喜之自相盛开莲花心蕊者径直而书，愿成为圆满善妙之因。芒嘎郎！
    祈祷文殊增长智慧
    全知麦彭仁波切造
    德 十方三世善逝佛子众，
    身之殊胜语之大自在，智慧勇士至尊之文殊，
    吾心莲花之中恒供养。
    您乃一切如来之慈父，生育诸圣僧众法界母，
    示现三世佛子之形相，恭敬礼赞无与伦比您。
    遍满法界幻化网游舞，虚空界尽众生利乐藏，
    一切等性智慧金刚身，恭敬礼赞文殊童子您。
    红黄旭日青春韶华尊，心中赐无等乐童子相，
    严饰天衣绫罗珍宝花，顶具五髻双足跏趺坐。
    依靠炽燃慧光智慧剑，摧毁魔众遣除重重暗，
    童子手持悦意青莲花，满足一切所愿作胜施。
    忆念至尊您身刹那间，能尽迷现轮回之黑暗，
    惠见真实善道之光明，赐予心升日轮之福德。
    殊胜妙慧身智文殊尊，我心绽放莲花花蕊中，
    敬献憩处且以心咒王，恳切祈祷怙主本尊您：
    令我具有辨别句义力，敏锐深广殊胜智慧力，
    等同遍照圆满日月轮，心中速燃智慧之烈火。
    远离退怯一切不能摧，无碍相续永远不间断，
    无有畏惧犹如金刚杵，令我成就殊胜之辩才。
    赐我具有永远不忘失，一切词句以及其意义，
    广大无边犹如大虚空，无尽陀罗尼之大宝藏。
    喉间乳海妙音游嬉力，扣动智者心弦词优美，
    具甘露味舒心极惬意，祈请成就如是语自在。
    佛及菩萨声缘圣僧众，天龙夜叉人与仙人等，
    一切世间所有智慧德，祈请悉皆广集我心间。
    愿以圆满闻思修坛城，令讲辩著光明更显耀，
    无慢寂静利他慈悲心，信等功德大海为庄严。
    愿以彼力于佛之教法，竭力行持殊胜大事业，
    文殊圣尊欢喜摄受后，任运自成自他之二利。
    与器情清净明点数相同之此十四偈，能增长智慧之赞颂愿文，乃为不败文殊欢喜者于火马年藏历九月初六之吉祥日善撰。芒嘎郎。
    赞颂文殊加持大宝藏
    全知麦彭仁波切造
    嗡 顶礼胜身文殊童子尊；
    顶礼语之自在妙音尊；顶礼遍知智慧勇士尊；
    顶礼诸佛智慧金刚尊；顶礼手持智慧宝剑尊；
    顶礼手握方便青莲尊；顶礼放射妙慧利箭尊；
    顶礼手执慈悲大弓尊。我以忆念怙主文殊您，
    诚心诚意恭敬作祈祷，愿蒙大本尊您亲摄受，
    令我自在获得八辩才。
    嗡啊Ra巴匝那德舍
    此乃德者于铁蛇年九月威力大修日间歇时造，芒嘎郎，善哉！
    金刚结愿文
    持明不变金刚造
    祈请上师本尊众垂念，今此精进修持之善法，
    以及三世积累一切善，一同回向无上大菩提。
    从今直至菩提果之间，种姓高贵聪慧无我慢，
    具有大悲恭敬上师尊，愿能永住具德金刚乘。
    灌顶成熟具足誓言戒，究竟念修生圆二次道，
    无有困难证得持明果，愿能顺利成就二悉地。
    一切显现圆满幻网轮，一切声音离说密咒音，
    一切心念自明无为法，愿证无有离合大安乐。
    毁戒念障本净不需断，证外内密无别而酬补，
    所现自解普贤法界中，愿泯恶趣有寂现本性。
    广大明点圆满身刹土，广大誓言清净取舍相，
    广大周遍解开希忧结，愿证大圆满之法身果。
    三传上师加持入心间，心中圆满幻网秘密道，
    依靠四种任运之事业，愿能救度无边之众生。
    寂猛化身尊众作授记，一切空行爱护如亲子，
    一切护法遣除诸违缘，愿成心中一切所希欲。
    如来教法兴盛且增上，持教大德一切心愿成，
    无余遣除有情诸逆缘，愿令一切圆满如意成。
    明朗伏藏大师持明不变金刚造


怀业时语——空乐赤电闪烁之光

    怀业时语——空乐赤电闪烁之光
    法王如意宝晋美彭措 著
    益西彭措堪布 译

    心间不坏明点虹宫中，觉空智慧了义文殊尊，
    加持甘露喜宴利乐雨，降入众生大海愿欢喜。
    三学如意树顶竟绽放，三信莲花善缘之道友，
    请听净心乳海中流出，年迈老父大恩此心语。
    我等善业愿歌所招引，聚于清凉雪山之圣地，
    师徒不离趋入佛子行，积资净障修行我心语。
    切莫偏袒执著各宗派，造下毁坏自他舍法业，
    修持有缘本尊之法门，净观一切他宗我心语。
    三界众生皆为父母亲，当以大慈大悲平等护，
    勿执自族亲友他怨敌，成苦众生商主我心语。
    正法精华即是此善心，世法根本依赖利他行，
    无愧谄诳恶行如毒弃，护持高尚善规我心语。
    今起我等师徒之会众，依于稀有总集之事业，
    怀柔心境善巧之方便，令众往生乐国我心语。
    以此善根汇合三世资，祈愿彼果成熟于众生，
    趋至究竟断证功德海，无勤广利无边诸有情。
    此乃藏历十七胜生铁龙年五月初八上午座间时，轮涅自在（即法王尊名）即性而言，随即由戒律清净、受持三藏之堪布南震与齐美仁真造成文字。芒嘎郎！
    公元二〇〇〇年七月九日。


纪律教诫甘露文

    纪律教诫甘露文
    法王如意宝晋美彭措 著
    益西彭措堪布 译

    五浊恶世极恼有情众，大悲视为我所具恩者，
    无等导师释迦能仁王，身心苦痛呼唤祈垂念。
    现今我及如我形象僧，出离净戒弃如厌患物，
    种种恶行穿著非法衣，遍知您能无睹尽舍弃。
    无量方便大悲智幻化，祈转众生心向菩提道，
    持教僧众和合戒清净，安乐之源圣教愿兴盛。
    现在对住于大密光身成就静处及其它分校之徒众，宣说应听受之纪律。
    分三：遮止、守持及开许。
    一者分二：根本学处、支分学处。
    根本学处：已被各支具足之根本罪所染且覆藏者、及饮酒、吸烟者不可住在学院；如是失坏金刚乘誓言不可恢复者不能参加密乘灌顶及僧众法事活动；复次，自己于闻思修不精进且对他人作障碍之散乱者，于好转之前应离开此地去往他处；于僧众中起大争论、心怀怨恨、长久不舍、恶行不改者，及同乡亲友拉帮结伙、起争斗、作离间、已平息之争论又复挑起者，须依摈除羯磨处理。
    支分学处：被支分学处中僧残罪过失所染者，当依大堪布托嘎如意宝之作法予以严厉呵斥；如是不听上师教言且于道友少悲悯、唯以散乱行度日、依止恶友、常时携带伤害他命之器械者等等，未见好转且恶劣过失不断增上者，须给予温和之教诫，令其迁往山林静处或其它寺院。
    纯以贪嗔而起，于他宗派及持教者生邪见作诽谤，及于他寺院因竞争、嫉妒心而争论，如是诸等皆须遮止；被他十方僧众开除之人不能住于此处；复次，新来无担保人之喇嘛、觉母（大僧、二僧），接待人员又不认识、不能确信，则由各组管家按律藏要求，于四个月期间作观察，观察期未满，不属真实僧众之列；穿衣、行住威仪、或参加诵戒、会供等应止语。喊叫、大笑、拥挤、游戏、竞赛、取外号、揭人短、说淫秽语等，如何劝令改过，由分区组长负责，不可违越；尤其讲法、听法过程中，未得堪布与辅导者开许而擅自中断传承之劣行，须彻底断除。
    管家是僧众总的代表，违背其教言、扰乱其心、或作讥毁、争辩等，其行为之对境即是整个僧众。依戒律所说，以上座为主之一切善知识应负起责任，令其发露、忏悔依戒而住，或呵斥、威慑治罚、开除，须何种处罚亦应如是而行。上师及管家等在宣布僧众纪律、取舍学处时，唯应依佛陀之教言，不应说各种其它语言。
    另外，喇嘛、觉母经常会面、说各种绮语等如是因异性而生堕罪之行为须遮止；去城镇等时，作污家行、以烦恼引发争论、玷污僧众高尚形象等诸形象僧人，当时，僧众应善加商议，依其恶作给予相应处罚，令其断除；喇嘛、觉母无论是谁，若无其他戒友在旁而与异性一起坐车等，或有戒友在旁，然与异性身体相接触而坐，皆为不可；如是以烦恼及散乱引起而看各种电影、电视等、去热闹处、作游戏、唱歌、跳舞、受用各种军人用品、穿戴各种戏具、去城中闲逛等，均须舍弃。
    另外，盗用上师与僧众名义获非法财、欺骗、狡诈等与佛法及戒律相违之事，舍出家衣穿在家衣，尤其是违背前人良好传统、令他人不生信心之装束、行为等，须彻底断除。以此为例须遮止的其它恶作亦分愿意悔改和不愿悔改二种，如律经中所说而作处理。
    二者守持学处：如教诲甘露明点中所说：人格贤善、戒律清净及善学无垢智慧处，归纳为此三者，应如是行持。
    三者开许学处：任何行为，诸具智慧者若遇到戒律中所说之遮止与需要二者发生冲突，则所遮不为主，所需为主；观待不同之时境，别解脱、菩萨、密乘三者之学处，略说推制戒之理以自己智慧衡量类推，佛陀所制定之戒律及僧众纪律未包括之学处，有把握者应行持；
    若智慧较低，不能如是衡量者，应问堪布管家等，获开许后，方可行持。
    如是所说之所有要点若归纳宣说，一切功德之基础即清净戒律如眼而守护；佛子菩萨之愿行承担后，不放松讲闻大乘法；作为最后有之妙法无垢光明大圆满之见彻底认识后，于修行恒时精进。此三者以外更甚深之法，即便三世一切佛陀聚为一体亦无能宣说，请大家牢记于心。政治之宪法、法律、法规中之各种政策，在其它地方有说亦应了知。
    此为导师所制戒，清净僧众之纪律，
    一切挚友之学处，切勿舍弃当行持。
    阿白拉江嘎Ra所著


教诲甘露明点

    教诲甘露明点
    法王如意宝晋美彭措 著

    何者圣号耳闻顷，心中久住愚痴暗，
    根本断者妙吉祥，祈赐善妙鲜花雨。
    人格贤善戒清净，勤学无垢智慧源，
    彼即三世佛之子，亦吾究竟之挚友。
    何为贤善之人格？心善诚实少欺诈，
    温和稳重耐性强，广学多闻心量宽。
    何为清净之戒体？佛经论典所宣说，
    一切取舍护如眼，于此浊时虽极难，
    然于显密三乘教，各乘得果直接障，
    根本堕罪于自续，当恒远离精进行。
    何为无垢之智慧？真实教诲诸经论，
    日日精进闻思修，彼将速获菩提果。
    未入正道初学者，愚痴形象盲修者，
    世智辩聪傲慢者，此文将成消毒药；
    为利自心修习故，亦为挚友作良药，
    净心善言所生善，诸众愿等妙吉祥。
    此具八瑞相数之颂，以大密成就光身静处之僧众为主，凡是愿依吾教言行持之徒众，望牢记词句，会融妙义于心中。土蛇年三月十六日，阿旺洛珠宗美所说也。


敬献给巴先（老维那师）

    敬献给巴先（老维那师）
    岩洞老人颤抖道歌
    法王如意宝晋美彭措 著

    佛陀以及佛子三密舞，九乘佛法引导大车轨，
    恭敬祈祷大恩上师父，说此教言当利诸众生。
    获得善基人身之此时，若不获得解脱之坚地，
    恐怖险地恶趣漂泊时，诸善之名亦是难听闻。
    寿命无常犹如日落时，彼无住留渐趣死亡处，
    若不迅速修持甚深法，至身次第隐没心必悔。
    虽生六道高低任何处，除苦之外无有安乐时，
    恒时不变究竟胜安乐，修持无漏之果正是时。
    于此因果无欺正道中，若不慎重行持取舍理，
    堕落痛苦泥潭之中时，颠倒心相真正显露出。
    青春妙龄少男少女众，心中若不思维定死亡，
    死主怨敌似空中劈雳，不知何时降临真可悲。
    获得大势威力众尊主，心中傲慢如旗高飘扬，
    然于狭长陌生中阴路，无伴漂泊之时定忧愁。
    拥有众多财富诸富人，若为此生利故大散乱，
    眼睛现量变为灰白时，心欲看财眼神无力住。
    自认英勇傲慢权势者，欲想于自领地长久住，
    若勤造作诸多无义罪，转生地狱之时心定颤。
    身之四大衰败诸老人，欲求长久住世许多年，
    好似彼与死主阎罗军，共同达成之常住协议。
    法体渐衰具慧老修行，圣法三学修持弃山涯，
    不净信财赡养其家人，好似后世定与家人聚。
    具有名望某位大上师，欲求效仿世间之尊主，
    好似集结众多之军队，作战降伏威猛大阎罗。
    现今世上一切诸士夫，放弃一切善法福德业，
    好似地狱世界已灭尽，若非如此一切皆疯狂。
    一切有缘之士男女众，心应放松静静作思维，
    现时若不精进行善法，此后与法相遇则极难。
    彼者具有法相之上师，以欢喜心传此深教言，
    难得如意宝珠无法比，不应舍弃彼教当修持。
    值遇圣教三乘法船时，应当渡过轮回大苦海，
    若不到达解脱之彼岸，此心之外何有更劣者。
    三学正道坚固之图画，若心决定无变善描绘，
    一切众生虽作赞或毁，抓住关要从乐行于乐。
    听闻此歌一切有情众，皆乐趋向十种善法行，
    愿于具乐刹土得安慰，三身佛地之中获自在。
    胜生木蛇年四月二十九日，日落之时阿旺洛珠宗美所说，愿增吉祥。


三世佛语合而为一——文殊童子欢喜笑音

    三世佛语合而为一——文殊童子欢喜笑音
    法王如意宝晋美彭措 著

    自心无生光明性，即是了义文殊尊，
    住于本无离合中，了悟本面而顶礼。
    信心莲花初绽放，朝向文殊之太阳，
    著此善说精华蜜，滋养欲解脱蜜蜂。
    三世一切诸如来，所有深广之法理，
    摄于善心善行中，诸具缘者当实修。
    于诸钝根之面前，略而言之无大利，
    利根略说能领会，广而说亦无必要。
    自己累世实修法，心语献与诸密友，
    一切窍诀之精髓，汝当铭刻心田中。
    复依根机次第性，略中广之方式说，
    定能真实有利故，请以净心而谛听。
    善心信心大悲心，信心犹如能见目，
    乃为诸法之前行，无此不见真实道；
    悲心犹如能行足，乃为诸法之基础，
    依此趋向三菩提，何时皆当珍惜之。
    贤善行为有二种：永断害他及根本，
    主要精勤求自利，即是声缘之行为；
    唯一成办利他事，六波罗蜜四摄法，
    恒时不舍而行持，即是菩萨佛行为。
    于具无等智悲力，究竟二利佛陀前，
    以清净信而引发，立誓佛陀为导师；
    二谛双运圣法前，当以无垢欲乐信，
    无误取舍四谛法，立下誓言而实修；
    于具智断僧众前，当以猛烈胜解信，
    持久慈爱之心意，立誓僧为永道友。
    以缘众生之悲心，现见轮回之苦海，
    解脱清凉乐洲后，生起厌离出离心；
    以缘诸法之悲心，谛观世俗如梦幻，
    证悟胜义如虚空，当修二种菩提心；
    以无所缘之悲心，即生为获双运身，
    净等无别中实修，明空乐空觉空性。
    断除害他之行为，居士沙弥与比丘，
    开遮止作诸次第，当依如海律藏行；
    无论直接或间接，除利众生无他行，
    广大行为当依照，大乘藏中所说行；
    以如幻术巧方便，依照甚深如海续，
    所说之义而实修，生圆大圆满要义。
    于此广说有无量，昔日文殊勇士尊，
    将诸佛陀及经典，摄于钵中即此故。
    如是实修此法者，今生实现诸所愿，
    后世往生极乐刹，成就无量寿佛果。
    以造此论善根愿，众生乃至虚空尽，
    具足无量功德行，等同妙音文殊尊。
    此乃于众师徒胜伏内外密违缘之际，为生生世世顺利无阻成办广大弘法利生事业而发愿随词句忆念意义诵《大自在祈祷文》及《普贤行愿品》各一亿时，为庆贺开启吉祥之门，十七胜生之火鼠年五月二十日旭日初升之同时，依如日般觉空境界中所现，阿旺罗珠聪美脱口而出。芒嘎郎！
    公元一九九六年十月一日


显示寿命无常的悦耳道歌——瀑布妙音

    显示寿命无常的悦耳道歌——瀑布妙音
    法王如意宝晋美彭措 著

    广集诸尊坛城之作者，无上恩师法王麦彭尊，
    安住吾心莲花盛妙垫，唱起一串自然悟道歌。
    夏日清凉树林鲜花园，美境宛如欢乐之天境，
    一旦秋霜冬雪狂风时，导致悲伤心中起厌离。
    点缀绚丽多彩花丛中，蜜蜂欢唱胜似妙音天，
    虽欲享受长久之欢悦，无奈业感显现花凋零。
    茂密林中杜鹃之欢唱，婉转悦耳优美如献歌，
    寒秋来临情景又如何，细想即是无常之善师。
    蒙蒙细雨氤氲五彩虹，赤橙黄绿绚烂浮云间，
    瞬间不知消失于何处，如理思察无常现量显。
    秋日白云堆积如雪山，刹那无迹消失虚空中，
    现世如是无有可靠处，此喻堪为厌世良教言。
    广阔坚固三千大千界，终被火水风灾所毁坏，
    遑论所居房屋及墙院，此等更是无有可信处。
    具有神变通灵寿长劫，禅悦为食天神与仙人，
    无法躲避阎罗与怨敌，未念己亡即是颠倒想。
    昔日四洲权势圆满者，虽有少数闻名转轮王，
    如今忆念只剩名字已，微弱自身更无坚固性。
    断证圆满能仁与佛子，虽曾现如空中群星般，
    正因揭示无常而涅槃，回想此义深知皆无常。
    寂静净土桑耶宝顶洲，师君三尊 眷属在世时，
    一切圆满真是甚欢喜，如今思忆实乃极悲伤。
    若未如理闻思圣教海，以估计心不能断无明，
    年老而成家眷九人官，临终阿伯无善转恶趣。
    舍弃实修经续窍诀义，甚深法要只当吹敲唱，
    无厌贪享信众之财物，临终命断自罪极明显。
    机灵善辨学法之僧童，心中贪求讲辩诸名望，
    苍螺白发可得博学位，汝于人间得乐亦短暂。
    轻视三学修道之功德，耽著今生积福伪僧徒，
    临死之时仍不知餍足，奈何阎罗法律无情面。
    白发苍苍衰败之老人，尤作多年计划度人生，
    不思己如即灭之油灯，将到中有应备行路粮。
    风华正茂倨傲之青年，心中无有死亡等忧怖，
    忽然瞬间阎罗狱卒到，捆缚脖颈时生大忧恼。
    彼此相恋韶华之男女，心中无尽甜言与蜜语，
    妄想终身不分同度日，怎奈不知寿命能长否？
    往年家世圆满富饶者，今日众多变迁受痛苦，
    无常本性现于意端时，必当厌离一切有漏境。
    白牙三十颗颗自散落，满身皱褶犹如盘山路，
    如是临近死神之呼唤，懵懂如初岂不如牦牛？
    再过一年至明年今日，众多健者已命赴黄泉，
    谁人敢说此中无自己，故而死路并非很遥远。
    世间之人再过百余年，不留一人决定都死亡，
    正如梦中短暂迷乱现，追求今生有何精要义？
    与己童年友好之同伴，多数飘零东西无定处，
    眼见众多流转中阴身，自己决定不可常住世。
    难忍阎罗使者来到时，无缝坚固城堡中躲避，
    图以十万甲胄作护卫，然终无法人间停一时。
    设若尔曹财宝遍三界，岂料阎罗魔众拒受贿，
    威慑三界梵王与帝释，想免死道亦无有办法。
    身体美貌犹如彩云般，通达诱人种种巧幻术，
    无奈夺命阎魔众威军，微汗毛许不为汝所动。
    昔人有病无病皆死亡，请你静心慎重细思维，
    以己决定死亡为鞭策，由此当速精勤解脱道。
    管理万户人众之官员，死时无权带走一伙伴，
    亦无权享一口食物故，唯一有利正法勿退失。
    今生灭尽显现业惑苦，虽多亲友不能替一分，
    泪流满面无可奈何故，如今精勤求法莫懈怠。
    若能观想一切内外法，乃为指示寿命无常书，
    自然道歌虽然无边际，仅以此歌奉献忠心友。
    再听诚挚情深知心言，轮回万物非有依靠故，
    为得恒时无漏之圆满，现今应当修法披誓甲。
    愿我从今乃至虚空尽，怙主文殊上师常敬礼，
    为度困苦众生传深法，誓同文殊勇士伟大心。
    此同于三十二妙相数字之颂，乃以道友俄仔亚纳反复劝请为助缘，兼以自己心相续中对无常生起厌离心为能作因，故依心中显现如实而作，阿旺罗珠宗美于甲辰年元月二十七日。愿一切吉祥！


厌离今生之歌——森林杜鹃妙音

    厌离今生之歌——森林杜鹃妙音
    法王如意宝晋美彭措 著

    遍智诸佛自色显现善知识，无量总持辩才功德宝藏主，
    百部化基麦彭智慧无垢尊，祈愿无离无合欢喜住心莲。
    今生安乐圆满如梦之诸法，日夜不断贪执苦恼众有情，
    心中显现众多无义世事时，情不自禁唱起厌离之道歌。
    所谓财富虽为众人希求处，实为劳碌身心增加诸痛苦，
    即便善妙衣食亦不忍受用，临终引起贪执障碍解脱道。
    如何圆满唯仅衣食二者外，于己带来快乐丝毫绝无有，
    若人拥有赡洲所有诸财物，其犹不知满足贪求散乱住。
    卑微贫穷之身众人虽不齿，然思不断积护被盗之痛苦，
    具有多财之人生活情形时，我想乐睡即眠乞丐真幸福。
    夏季鲜花以及富人之财富，现时看似美妙然其难稳固，
    若于无有实义此物太执著，难忍恶趣险路岂能不须行。
    昔曾拥有四洲所有圆满乐，青春美饰胜似天人之尊主，
    无常亦如空中彩虹悉灭尽，吾等财富受用定如草尖露。
    去年富比龙王多数富贵人，今年步入痛苦乞丐行列中，
    此等虽非梦境然如梦显故，于此轮回之乐不得不生厌。
    众人交口称赞某某获高位，恰似秋云无有恒常坚固性，
    无有实义定同夏日彩虹故，反复思维难道不增厌离心。
    恼乱众多开示解脱僧人心，属民无过亦以法律作惩处，
    自诩贤善状如毒蛇具威严，步入后世险道之时当如何。
    现时自部下中高高在上状，待见阎罗卒时汝貌当不同，
    难以解脱恶趣感受痛苦时，领地眷属受用虽多亦无益。
    风华正茂蜜蜂享受花精粉，陶醉悦意花园难舍又难离，
    秋末寒冷使者突然降临时，烦乱萦绕心头无法排遣去。
    如是于此现世耽执众士夫，死主阎罗怒目现量见到时，
    回想一生懈怠散乱行为时，心中虽生猛厉后悔已不及。
    与己俱生以及终生守护之，自身若欲带走自亦无自主，
    亲友受用如空繁星虽耀眼，然定一切留于后世独自行。
    高贵喻如粉饰华丽众妙屋，无有稳固终成沙土瓦砾堆，
    于此显现应作详细之观察，于诸喜爱处所贪执将减弱。
    自己父辈祖辈前代诸世中，不断希求此生然亦未成功，
    我虽如何精勤亦如彼无成，故修甚深圣法岂非已是时。
    前半生敌多数下半生为友，今日爱重之友然于明日时，
    亦有可能成为断命之怨敌，亲怨无有定准何必强贪嗔。
    自己身体所生可爱诸子女，犹如自己心脏爱重而守护，
    何日其身力圆当报恩德时，不作利益只令生起厌烦心。
    青春韶华同龄少男少女众，互相含笑睥睨恋恋又不舍，
    情投意合心中虽愿长相聚，来日苦乐谁知由然悲心生。
    不定长久相聚一家众亲属，犹如集市旅客虽然暂相聚，
    然以昔业六道不定而去时，互相各奔东西何方亦不知。
    虽愿与胜上师相聚不分离，昔日所积业感谁人能遮止，
    相聚犹如杜鹃时至南飞去，金刚道友决定相离无须疑。
    上面尊主如何恭敬无法喜，下面眷属如何守护无满足，
    于此轮回世事无有成办时，坦然放松安然休息正是时。
    如何降伏敌人数量却愈增，如何慈护亲属烦恼却更多，
    虽吃众多美食愈加增不净，现时乞丐流浪之行应希求。
    于他如心守护合意之密友，于自当面背后无有高兴时，
    其心之中唯有新交之女友，无友独自心喜安住正是时。
    虽遇具足戒智利生善知识，然初见时一切恭敬又欢喜，
    若常相聚则唯精进宣过失，浊时利益众生自利难成办。
    赞颂具德大士之语不欲说，微细恶行闻时不作少观察，
    遇到何人即便精进广宣说，于此众生秉性如何不生厌。
    自境所住智者看亦不欲看，他处而来精通欺骗手段者，
    老奸巨滑敬如天尊思此景，佛教真实接近隐没之征兆。
    戒律智慧虽为持教之胜饰，然今众人不敬具有功德者，
    绸衣严饰唯得活佛名字者，虽无一丝功德然居显耀位。
    自己充满十万过失亦不观，于他过失明里暗里精进宣，
    见到与我相同此等朋友时，厌离之心于己心头久萦绕。
    所积五谷春天播撒于田中，心思秋季果熟收获虽如此，
    然而人寿无增渐减之显现，岂有于前无灭存在之把握。
    心中虽有人生定死之信念，然而未于死时无定精进修，
    从生至今之间多年已逝去，修此圣法成就心中无把握。
    自然而然之中造下诸多罪，渐积各种恶行心中无处容，
    若于今日死主阎罗忽降临，去处唯有恶趣此外更无有。
    虽获暇满未得佛法精华义，虽遇上师未勤习学密意行，
    虽获甚深教言烦恼未对治，一生空过生起猛厉悔恨心。
    现今风烛残年修持善法后，昔日所造堕罪异熟净无余，
    祈愿大恩上师如雨而降下，临终无悔圣法成就之加持。
    净与不净浩瀚刹土范围中，依于人与非人等等无定身，
    文殊怙主上师利生行者前，我亦不离而住发此吉祥愿。
    无始以恩养护慈母众有情，无有遗余大乐清净刹土中，
    容易引导威力吾身独获得，愿能成办文殊上师所欲义。
    何者耳闻此歌愿与吾一同，消净耽执今生如雾分别念，
    无勤作中自在菩提三十七，成就究竟二利十力功德主。
    具三十七菩提分数之颂文，殊胜木龙年七月三十日，阿旺洛珠宗美口中流出未作丝毫修改瞬间而成。茫呷郎！


引导取舍之教言

    引导取舍之教言
    法王如意宝晋美彭措 著

    诸佛至亲佛子童子相，仅以忆念遣除三有暗，
    身色桔黄手持宝剑者，祈愿为您散下吉祥花。
    暇满难得此生无空闲，业果无欺轮回诸痛苦，
    反复思维三有之圆满，无贪出离之心当依止。
    世出世间一切之功德，究竟精华即为贤善心，
    无此其他功德无希望，请戴唯一贤善之心饰。
    智慧戒律犹如眼与足，各自分开无法行善趣，
    以及决定胜之欢喜洲，是故诸时此二当双融。
    孩童之时受制于父母，青壮之年受制于上司，
    年老之日受制于儿孙，愚人远离自主极痛苦。
    是故恒时自己应自主，犹如善财常啼之传记，
    依止上师寻求胜教言，当依无厌披甲精进心。
    于此浊时寿短多疾病，种种恶缘如风遍吹荡，
    精通广大教理虽极难，然依窍诀调伏自相续。
    总之无论行持何种行，念知无放逸心护自续，
    自己作为自之善知识，一切所作当令具实义。
    求解脱聪慧丹增嘉措，虽曾劝请写篇此类文，
    如翁被童拉至歌舞场，自己劳累他人耻笑因。
    然为新来相逢之弟子，满其所愿并为长相聚，
    圣地五台山之刹土中，放逸老人流出如是语。
    阿旺洛珠宗美所著。


给巴先（老维那师）之教言

    给巴先（老维那师）之教言

    法王如意宝晋美彭措 著
    益西彭措堪布 译

    诸佛智悲力之幻化舞，如海坛城本尊射收主，
    吾之唯一依处麦彭尊，愿菩提间相聚蒙守护。
    少顷一心专注请谛听，暇满所依若不令具义，
    堕落无边恶趣险地时，修善乐趣之名亦难闻。
    现今于此能有自主时，恭敬加持来源根本师，
    念修悉地来源胜本尊，祈请遣除违缘护法众。
    尤其一切胜法之精华，信心大悲恒时调伏心，
    圣法基石善学贤人格，护心方法铭刻于心田。
    虽不能作广大利他事，不欺自己临终无后悔，
    应善思维何种善方便，愿于每日皆亦不空过。
    歌舞乐等大寺诸法事，伏敌护亲尊主诸事业，
    汝作如此事业时已过，衣食避寒裹腹当知足。
    善恶因果苦乐无欺故，现时显现唯由昔业生，
    勤于希求无有大实义，安乐放下自心转向师。
    无德唯具过失老人我，作为上师何言亦顶戴，
    如心如眼爱重大喜悦，不作报恩他笑亦无妨。
    吝啬贪财之故不显财，秉性恶故不会说好话，
    然与性情相应此忠言，为满汝愿令喜而奉献。

    敬献给巴先（老维那师）