封 面

略讲观修佛法僧三宝功德及其意义

任杰　编撰

中华佛典宝库制作　2004.10.23


目 录

      略讲观修佛法僧三宝功德及其意义
                   任杰　编撰

序言
第一、观三宝出现世间甚为稀有、难值难遇
第二、别观佛法僧三宝
      一、 佛宝
      二、法宝
      三、僧宝
第三、皈依三宝的建立
      一、抄经《大乘理趣六波罗蜜多经》（卷一）
      二、抄经《增壹阿含经》（卷十二）
      三、译论/依论释经皈依三宝的建立
      四、结语
第四、住持三宝的重大责任
      一、住持佛宝：
      二、住持法宝：
      三、住持僧宝：
第五、爱国爱教与人间佛教问题


序 言

    这里提出“略讲”，是就初入圣教之门的四众弟子，首先应当学习三宝，略知三宝的功德意义，以观修三宝为正因。初以信解智力随时深入思维，观察和忆念三宝的功德利益，以培养自己的清净正信，令信根增长，引发自己对佛法的乐欲希求，成熟自己的善根。若以究竟智力观察三宝，唯第十地菩萨乃具此功德。
若要广讲三宝，那就是佛教的三藏十二部经。佛教的大小乘三藏，无不是说三宝的功德利益，若离开三宝而谈修习，既非佛教，更谈不上是佛教徒。
    作为佛教徒，为利益一切众生，住持如来圣教，令正法久住，成就圣果，都必须以观修三宝为修行的所依境，直至成佛的中间，都必须贯以三宝而修观行，所以佛弟子观修三宝是不可缺少的根本法门。由此原因，本文仅依经论略谈三宝的功德行相，及修学三宝的重要意义，仅供三宝弟子以观修三宝功德为修行的所依境而作参考。
    本文分为以下几科：一、观三宝出现世间甚为稀有，难值难遇；二、别观佛法僧三宝；三、皈依三宝的建立；四、住持三宝的重大责任；五、爱国爱教与人间佛教问题。


第一、观三宝出现世间甚为稀有、难值难遇

    佛经中说，十方世界有无量诸佛。《三劫三千佛名经》说此世界，过去庄严劫有千佛出世，现在贤劫有千佛出世，未来星宿劫有千佛出世。我们的本师释迦牟尼佛即是现在贤劫中的第四尊佛。在人寿二万岁时，有迦叶佛出世，减至人寿百岁五浊逼恼时，我们的本师释迦牟尼佛出现于世。在释迦牟尼佛出世以前，有很长很长的时间没有佛法，众生不闻三宝之名，自释迦牟尼出世、出家、成佛、转法轮，现在在此南赡部洲才有三宝出现于世。
    我们的本师释迦牟尼佛出世是具有大事因缘的，无因无缘佛决不出现世间。如《华严经·如来出现品》说：“非以一缘，非以一事，如来出现而得成就，以十无量百千阿僧祗事而得成就。”是由“无量功德乃能成。”我们的本师释迦牟尼佛，最初在古释迦牟尼佛前发无上菩提心，中间经过三阿僧祗劫亲近、承事和供养诸佛，积集福慧二种资粮，修习菩萨万行，严净佛土，成熟众生，位证十地，最后受一切智智胜职位，得一生补处，升住睹史多天(即兜率天，Tusita Heaven)内院。菩萨观诸众生根性业已成熟，成佛时机已到，为度一切众生故而降生人间，如《菩萨处胎经·游步品》云：菩萨“即自思惟，多诸众生，皆是初发心已来所成熟者，堪能受于清净妙法。”菩萨为度一切众生趣入涅槃城故而应化人间。
    释迦牟尼佛出世以前，在印度的上古时期，人们不了解宇宙现象，畏敬和崇拜日、月、云、风、水、火、雷、电、山川等自然现象，信奉有神灵主宰一切。而对这些神灵进行祈祷，认为神灵能赏善罚恶，祈祷赐予现世幸福及家庭繁荣等。于是就出现了祭祀，崇拜神灵的赞咏，而集为四种《吠陀》(吠陀译为《明论》。意为知识、智慧之义。)《梨俱吠陀》意为赞诵明论，赞诵多神或一神。次后，为讽咏之便，又集成《娑摩吠陀》，记祭祠的为《夜柔吠陀》，咒术，禳灾之类的为《阿闼婆吠陀》。如《大唐西域记》卷二云：“其婆罗门，学四吠陀论。一曰寿，谓养生缮性；二曰祠，谓享祭祈祷；三曰平，谓礼仪占卜，兵法军阵；四曰术，谓技能伎数，禁咒医方。”因此即由吠陀论师们创造出婆罗门、刹帝利、吠舍和首陀罗四种不平等的种姓阶级制度，如《譬喻经》云：“诸外道人计，梵王生四姓，王口生婆罗门，臂生刹利，胁生吠舍，足生首陀。四姓之别，自韦陀论师而起，因韦陀论为最古盛行也。”
    又如提婆论：“外道韦陀说，那罗延天脐中生大莲花，从莲花生梵天祖公，彼梵天作一切命无命物，从梵天口中生婆罗门，两臂中生刹利，两胁中生毗舍，从两脚跟生首陀。”
    又如《南海寄归内法传》卷四：“五天之地，皆以婆罗门为贵胜，凡有坐席，并不与余三姓同行。”当时的婆罗门(意为净行，有在家、出家两种)，掌握宗教、哲学、文学、历学、数学、医学以及祭祀祈祷和一切精神的统治大权，压制余三种姓，利用神权，违害社会，极不平等，人们希望有圣人来救济这个不平等的社会现象，宣扬平等圣教。
    刹帝利虽为王种，奕世君临，统辖国政，但也受婆罗门的神权统治。毗舍种姓，为商贾贸易的庶民中层阶级。首陀罗种姓，为农民及奴婢，是身勤劳作的下层贱民阶级。
    另一种情况是各种外道的勃兴，各自对宇宙人生的理解不同，由于社会的不平等而厌恶人生，他们入山修行，希求通过修各种苦行的方法而得解脱(山林派)。但他们不知道解脱的次第、方法和目的，认为解脱即是生天，以求安乐而为究竟。在这种情况下，菩萨(释迦菩萨)在兜率天内院依五方面的观察选择而降生人间：
    一、观察国土，为迦毗罗婆窣堵或云劫比罗伐堵，即迦毗罗卫，尼婆罗城，即今之尼泊尔，国王净饭王为生父。
    二、观察种姓，为刹帝利王种。
    三、观察血统、氐族，为甘庶释迦。
    四、观察母亲，为摩诃摩耶夫人。
    五、观察时会，为五浊恶世人寿百岁时。
    菩萨经过五种观察之后，看到诸众生根性成熟，成佛时机已到，为度一切众生入涅槃城，于是降生人间。如《菩萨处胎经》卷五云：“导师出现世，非缘不降神，要度为度者，示现无为城。”
    释迦牟尼，释迦为种姓之名，义为能，牟尼为仁，寂默或贤人之义。合译释迦能仁或能寂，即释迦族的能仁或圣人。释尊的实名为悉达多，译为一切义成，姓乔达摩(旧译瞿昙)义为最胜，及瞿答摩之裔。
    摩耶夫人即将分娩时，从其土俗应归娘家分娩(亦说出城外游)，遂于沙罗树(或娑罗树，即毕钵罗树，无忧树之类)下产生悉达多，时在公元前六百余年的四月八日降生。菩萨即降生人间，无扶侍者即自行七步，举其右手，作狮子吼：“我于一切天人之中，最尊最胜，无量生死，于今尽已。”
    摩耶夫人产后七日病逝，由其妹钵罗阇底代育王子。菩萨生下不久，即有阿私陀仙人入宫占相说：“王子具三十二相，八十种好。若在家者年一十九为转轮圣王，若出家者成一切种智，广济天人，转清净法轮。”
    菩萨七八岁时，从婆罗门学者受学诸文事教育，从武士习诸武艺。十六岁纳拘利城主善觉之女耶输陀罗为妃，后生一子名罗睺罗或称罗怙罗。
    菩萨虽在王宫，但不为五欲所染，常观感老、病、死、苦，经常思惟世间苦痛如何避免之法。一日出游，见农夫种田，鸟食虫类，于是即在树下禅思众生之苦。后游四门见老、病、死者及沙门，深思解脱之法，于是即决心舍弃王位及眷属而出家。一日，夜半逾城在一树下自剃须发，脱下王服宝冠，着上沙门衣服而去寻求解脱之道。
    其父见菩萨既已出家，即遣宗亲五人为侍，此五人即憍陈如、跋提、跋波、摩诃罗、阿说示。菩萨偕侍者五人东南行至毗舍离城附近的仙人阿罗逻迦兰所，就学解脱之道。但此仙人以无所有处定为最上涅槃，即以超越一切有之思想。菩萨知此定不是解脱究竟之道，于是即舍此仙而去王舍城外森林中，访郁陀罗摩子仙人。彼仙执非想非非想处定为真涅槃，虽较“无所有”更进一步，但泯想非想之差别住于平等寂静之知见，菩萨知此亦非真正解脱之法，不能究竟解脱。于是即舍此仙人乃去优楼鞞罗聚落尼连禅河畔苦行林中，独自思考，静坐禅思六年。
    六年之间，与诸魔军斗争，如《方广大庄严经》第七云：“第一贪欲军；第二忧愁军；第三饥渴军；第四爱染军；第五昏睡军；第六恐怖军；第七疑悔军；第八忿覆军；第九悲恼军及自赞毁他称供养等诸魔军。”虽然精进不懈修习苦行，然亦徒劳无获，即悟专修苦行无益，因此而舍极端苦行之法。先趋尼连禅河浴去六年之积垢，得牧女善生乳糜之供，气力渐复，颜色渐润。此时五侍者见其状，以为释迦菩萨信行退转，即舍菩萨而去至婆罗捺斯(波罗奈斯)。菩萨乃独自趋毕罗树(菩提树)下，敷吉祥草东向而跏趺坐，端身正念，发大誓愿曰：“我今若不证无上大菩提，宁可碎是身，终不起此坐。”（《方广大庄严经》第八）于是即入金刚喻定，降伏烦恼魔、蕴魔、死魔、天子魔四种魔军。魔王虽遣眷属，百方娆乱，终不可动，只得忧愁而去。菩萨即入狮子奋迅三摩地，顺观和逆观十二缘起，观众生生死根本，在于无明，故无明灭即生死之苦尽；观四谛之真理，集乃为因，由集而生苦果；解脱苦根当灭集因而得解脱者，当修道谛为因。菩萨因起勇猛心，定力之深使身升高七多罗树，由是旭日东升，长夜奄灭，智明忽起，生死永寂，豁然大悟，终成无上正等正觉。成就法报化三身，欢喜无喻。
    菩萨于成道后，观缘起甚深无我之义，众生难于悟解，故四七日间默然而不说法。如《方广大庄严经》卷十，劝请品云：“我得甘露无为法，甚深寂静离尘垢，一切众生无能了，是故静处默然住。”又如圣龙树《中观宝鬘论》第二品云：“此法甚深故，众生难悟解，故佛成道时，默然不说法。”是故遂于附近树下自受解脱之法乐。第一七日在菩提树下；第二七日在阿输波罗树下，此时魔来劝佛入灭；第三七日在目真邻陀树下，遇暴风雨，目真邻陀龙王以身护佛；第四七日在罗阇耶恒那树下，时有二商主道过，一名提谓，一名婆利迦，献佛麦蜜，皈依佛与皈依法，闻佛说法而去。
    佛陀确信独悟所得究竟解脱的真理，欲弘布于众生，以是令其他有情出离生死。于是，佛陀慈悲之念难禁，即从事宣布自证之妙法。先欲向曾事师之阿罗逻迦兰与郁陀迦罗摩子说法，观察彼等适已死去。由是佛陀向婆罗捺斯城外的婆罗泥斯(即鹿野苑)走去。时先舍佛而去的五侍者住在此处，五人相约见佛不起问讯，以为佛是净行退转之沙门，然而佛到来的时候五人不知不觉都起来敬礼，或为敷坐，或执衣钵而称长者瞿昙。佛告之曰：“汝等不应称如来为长者，令汝长夜无所利益。”又语五人曰：“我已证得甘露之法，我今能知何甘露道，我即是佛，具一切智智，寂静无漏，心得自在。汝须来，当于此法，教授于汝，汝应听受如说修行，即于现身得尽诸漏，智慧明了，解脱而住，禁行成就，所作已办，不受后有。”(见《方广大庄严经》第十一)时五人皆皈依佛，为佛弟子，请佛说法，于是佛应五人之劝请而为五人三转四谛法轮。佛告五人：此是苦，此是集，此是灭，此是道，此为第一示转，指出四谛之体；此是苦汝应知，此是集汝应断，此是灭汝应证，此是道汝应修，此为第二劝转，指出应了知苦谛之果，断除集谛为苦之因，欣慕灭谛之解脱果，修习道谛而得灭谛涅槃之次第；苦者我已知，集者我已断，灭者我已证，道者我已修，此为第三证转，指出佛陀自己已亲证四谛。于此三转即名三转十二行法轮。初示转上根悟道；二劝转中根悟道；三证转下根悟道。转谓佛所亲自证得之法转入于听者五人的身心；法轮谓此四谛法能摧伏一切邪说生死苦海，犹如转轮王之轮宝。如《法华经方便品》云：“思惟是事已，即趣波罗奈，诸法寂灭相，不可以言宣，以方便力故，为五比丘说，是名转法轮，便有涅槃音，及以阿罗汉，法僧差别名。”于是，佛成无上正等正觉为佛宝成就；佛说四谛法轮为法宝成就；五人各有所证悟而求出家成为五比丘僧，为僧宝成就。从此，在此世间始有三宝成就。


第二、别观佛法僧三宝

    一、 佛宝
    (分二：一略述身相；二别述四身)
    （一）略述身相。关于对佛陀的身相，虽然有大小乘的不同说法，但三身之说却是大小乘所共通的名目。
    小乘所说的三身：(1)法身者，谓戒、定、慧、解脱和解脱知见五种功德为佛法身。“戒”谓如来身语意业已离一切过患，戒德清净圆满，以为戒法身。“定”谓如来之真心寂静，离一切妄念，以为定法身。“慧”谓如来之真智圆明，观达一切法性，以为慧法身。“解脱”谓如来之身心解脱一切烦恼系缚，圆满涅槃妙德，名为解脱法身。“解脱知见”谓如来已知如实解脱，以为解脱知见法身。由戒生定，由定发慧，由慧而得解脱，由解脱而得解脱知见，如来已圆满成就此五种功德法体，总佛功德以为佛身，故曰“五分法身”。(2)报身者，谓佛从兜率降生王宫，所生三十二相和八十种好的妙相庄严之身以为报身。(3)化身者，佛以大悲心化现猕猴鹿等救济众生以为化身。
    大乘经论里所说佛身有六种说法，说一身者，谓以佛自性身及果法身合为一身，这是就法体而说的。也就是以一切法唯一真如法性。说二身者，如圣弥勒菩萨《宝性论》云：“自利及利他，第一义谛身。”是以自利法身和利他色身为二身。又如圣龙树菩萨《宝鬘论》云：“一切佛色身，从福资粮生，大王佛法身，由智资粮生。因此二资粮，即是成佛因。”又如圣龙树萨的《六十正理论》云：“以此之善根，回向诸众生，集福智资粮，愿得福智身。”这是就福智资粮为因。成就福德报身和智慧法身为二身。
    说三身者，如《佛地经》云：“自性法受用，变化差别转。”《金光明经·三身品》说：“一切如来有三种身，一者化身，二者应身，三者法身，如是三身摄受阿耨多罗三藐三菩提。”又如月称论师的《皈依七十颂》云：“能仁之三身，法圆满报化。”说四身者，如《楞伽经》说，一应化身，二功德身，三智慧身，四如如身。《佛地论》亦说四身。
    说五身者，总以佛陀的五智功德为身，一法界体性智，二大圆镜智，三平等性智，四妙观察智，五成所作智。此五智虽为如来一身所具之圆满智德，但为摄引众生而表现的五种体相，只是作用和德行不同而已。由此则为佛陀的五身。然此五身以智慧法身所摄。
    说十身者，如《华严经·十地品》说：菩提身、愿身、化身、力持身、相好庄严身、威势身、意生身、福德身、法身和智身为十身。此十身是第八地菩萨观一切智智所行境，而了知如来的十种身。此以二谛三身所摄。又如《大般若经》卷五百六十八说佛十身：平等身、清净身、无尽身、善修身、法性身、离寻伺身、不思议身、寂静身、虚空身和妙智身以为十身。此十种皆法身摄，因所证法身以无相为相，无有差别，唯能证功德智身有异，一切诸法皆同一法性，以就法身体性而无差别所说。
    总的说来，对佛身的说法虽然有所不同，但并不相违，只是开合不同，其义以四身三身为通用名目。如《华严经·如来出现品》云：“如来身无身故，为众生故，示现其身；如来身无有分别，亦无戏论，一切执著戏论皆断故。”这是说法身无相，无染无著，无有分别，为众生利益而现三身。如《华严经·佛不思议法品》说：“一切诸佛同一法身，境界无量身。”《如来十身相海品》又说：“一切如来智慧法身，诸色相海充满法界。”所以如来三身或四身都是以佛所证功德而表其身，三身体性并无异相。
    （二）别述四身。如来四身是依佛地果位功德广大而安立为身。今依《般若经》、《现观庄严论》说佛四身。
    1．自性法身：自性法身有自性清净的自性法身和离垢清净的自性法身二种，总称为自性法身。初自性身是佛本具清净究竟体性。现离垢清净是佛三阿僧祗劫修菩萨行，积集智慧资粮，断尽烦恼所知二障，远离一切垢染，作业圆满究竟清净之果德，所以称为果法身。
    自性法身，或称自性身，即于法界自性清净中永离一切垢染，无为法所摄之究竟功德，又称无为身、常身。自性法身又称真如法身，或称胜义法身。自性身谓以法性或空性为体，是说诸法体性本来自性清净，如来圆满证得具足清净究竟之法界，即是自性身的相，此即以自性清净为相，界限唯在佛地。
    自性身具有五种相和具有五种功德。如圣慈氏菩萨《宝性论》云：“此中诸佛者，自性身五相，若略应当知，具五功德性。”此五种相者，谓具足远离生灭之无为相；断证功德体性无差别相；永断增益损减二边相；断尽烦恼障、所知障和定障的三障相；及具足自性光明功德清净相。此五相是由自性无垢清净界圆满究竟故，是故《宝性论》云：“无为无差别，永断二边净，烦恼所知定，三障者解脱。无垢无分别，瑜伽所行境，由法界自性，清净故光明。”自性身具有五种功德，如《宝性论》云：“无量及无数，无思无等净，究竟诸功德，真实自性身。大故无数故，非分别境故，唯永断习故，无量等如次。”谓有无量功德、无数无边功德、不由四句分别心而无思功德、无等功德、及具有离一切垢障清净的究竟诸功德。于无量诸功德如次即：广大故名无量；齐此功德数量不可等计，故名无数；不是所有分别心所行境，故名无思；由于唯佛身心中有此功德，故名无等；由于永断二障习气，具有清净究竟功德，故名光明。自性身具此五种清净功德，以此功德即名为身。其余三身，皆以胜义法性体性真实，以众生胜解根性而显现世俗境而建立的。
    2．智法身：以佛究竟无漏智慧为身。若略说则为五智，亦说四智者谓除“法界体性智”。若广说之则有二十一聚无漏究竟智德。佛成就二十一种无漏智所依的佛地圆满究竟圣智，即如所有智和尽所有智，通为一切种智，或译一切相智、一切智智，是为佛智。由于如来已圆满究竟证得念住等二十一聚无漏法故，其范围唯在佛地。现证如所有性和尽所有相的究竟智，即是智法身的相。今依《现观庄严论》及其《略释》，略述法身二十一聚无漏智如下：
    “第一聚，谓三十七菩提分法。”又名三十七道品，是道谛所包括的三十七种法，故名道品。道是能通向涅槃，是到达涅槃道路的资粮。因为与菩提法相顺，故名顺菩提分法。此三十七法，总分七类：
    [1]四念处，又名四念住；
    [2]四正勤，又名四正断，四正胜；
    [3]四如意足，又名四神足；
    [4]五根；
    [5]五力；
    [6]七觉支；
    [7]八正道。(见后法宝处道谛中说。)
    “第二聚，谓慈等四无量心。”
    [1]慈无量心，能与众生安乐之心；
    [2]悲无量心，能拔众生苦之心；
    [3]喜无量心，见众生离苦得乐生欢喜庆悦之心；
    [4]舍无量心，指对如上三心不存耽着，舍怨舍亲，怨亲平等。由此四心能善缘无量众生，能引发无量福德，故名无量心。
    “第三聚，有色观色等八解脱。”
    [1]内有色想观外色解脱，内身有色想之贪，为除此贪，观外不净青瘀等色，令贪不起，故名解脱。
    [2]内无色想观外色解脱，内身虽无色想之贪，而欲令更为坚牢，观外之不净青瘀等色，使不起贪，故名解脱。此二为不净观。
    [3]净解脱身作证具足住，谓观净色，故名净解脱，于定中除不净相，唯观色等光明清净光洁如妙宝之色，观净色而不生贪，足以显示观之转胜，证得此性解脱于身中，故名身作证，具足圆满而得住于此定，故名具足住。
    [4]空无边处解脱，行人厌患色，心欲舍离，即舍色想而缘无边虚空之心，与虚空无边相应。
    [5]识无边处解脱，行人更厌前外尘，舍虚空而缘内识为心识无边，心与识无边相应。
    [6]无所有处解脱，行人更厌其心识，观心识无所有想，心与无所有相应。
    [7]非想非非想处解脱，舍前现有想名为非想，舍无所有，无想为非非想，观苦空无常无我，生厌离心而弃舍，故名解脱。
    [8]灭受想定身作证具足住，灭受想定者，或名灭定或灭尽定，即息灭粗分受想之定，已离无所有处贪著，弃舍非想非非想的一切所缘，故名解脱。
    “第四聚，谓九次第等至。”即四禅，四无色及灭尽定，此以深心智慧利行的九种禅定，不杂他心，不令异心间生，次第自一定入于一定之法。若有异心间生，故非次第。
    [1]－[4]初禅次第定至四禅次第定为四定，此四为色界四禅天之根本定；
    [5]空处次第定；
    [6]识处次第定；
    [7]无所有处次第定；
    [8]非想非非想处次第定；(此四为无色四处之根本定)
    [9]灭受想次第定，即止息一切心识之定，是九次第定的最后定，以是禅定之至极。
    “第五聚，谓十遍处”。遍以增上缘依止静虑，所缘缘为地、水、火、风四大种能造色及青、黄、赤、白四大种所造色，并空识二境，令其如欲遍一切处，即世间定慧相应之十种等至(定)。所余诸处不立为遍者，以诸根不能向外展，声处不能相续，香味二处色界无故。遍者谓相续普遍开展义。又名十一切处，谓观青、黄、赤、白、地、水、火、风、空与识之十法(见《大智度论》二十一卷)，令其如欲周遍于一切处。十中前八观色之清净，即依第四禅缘欲界，后二以空无边处，识无边处定为所依，缘其他受想行识四蕴，依青、黄、赤、白所造色，知依于四大种能造色故地水火风一一观为无边。再思此觉以何所依而广大，了知由于虚空，故次观虚空无边，次观识无边。
    “第六聚，谓八胜处”。发起胜知胜见以舍贪爱的八种禅定，是为起胜知胜见之依处，故名胜处。
    [1]内有色想观外色多胜处：观内不净，观境渐成熟则多观外色亦无妨，观一死尸至一千万死尸等，由观境扩大到外色清净，谓观外色多胜处。
    [2]内有色想观外色少胜处：即内心有色想，观外色少，但观内身不净，或观外色清净。
    [3]内无色想观外色多胜处：谓由内心无色想，观外色多。如第二说。
    [4]内无色想观外色少胜处：观境渐胜妙，虽观外色，而内心亦不存色想。以上四种为净不净杂观，为形色胜处。
    [5]青胜处：观外诸色，转变自在，使少为多，使多为少，于所见之青相不起法爱。
    [6]黄胜处：观黄色而不起法执，如青胜处中说。
    [7]赤胜处：观赤色如青胜处说。
    [8]白胜处：观白色如青胜处说。以上四色观，以为胜处，为显色胜处，此四为净观。凡观净色，必远离不净色。此与八背舍同，此二胜处，为使八解脱之观心，自在胜妙，对于所缘色境，不起执著染感，如人骑马能破前阵，故名胜处。如《现观庄严论略释》云：“由此形显诸胜处，发生奢摩他(止)胜知与毗钵舍那(观)胜见之定慧相应也，前四胜处从初二解脱因生，后四胜处从净解脱因生。”
    “第七聚，谓无诤，由佛无诤三摩地力能令众生有拔除烦恼之功能”。此即安住解空与他无诤之定，此定声闻亦能证得。如《智度论》卷十一云：“舍利弗，佛弟子中智慧第一；须菩提，于弟子中无诤三昧最为第一。” 如来无诤三摩地则胜出声闻，如《金刚经》中“佛说我得无诤三昧，人中最为第一，是离欲阿罗汉。” 无诤三昧定相，常观众生令心不恼，多行怜愍慈悲之念。
    “第八聚，谓愿智”。及至生死未空随愿成办众生义利，乃至生死未空，安住三摩地的作用恒常而住。
    “第九聚，谓六神通”。神者不测之义；通者无碍之义。即神妙莫测，无碍自在之六种智慧，是曰六神通。
    [1]神境智证通，又名身如意通，又云身通、神足通。即变化不思议境界之通力，故云神足通，即自身能得变化自在之通力，故云身如意通。
    [2]天眼智证通，得色界天眼根，能见微细色境，观照外境无碍。
    [3]天耳智证通，得色界天耳根，听闻微细音声无碍。
    [4]他心智证通，知他人心念而无碍。
    [5]宿命智证通，又云宿命住随念智证通，知自己及六道众生宿世生涯而无碍。此五通有依有漏之禅定，或依药力咒力而得，故外道仙人亦能成就，但此五智证通者，是各依无漏智慧而证得之通力故。
    [6]漏尽智证通，三乘之极至，诸漏断尽为无碍，成就此六通只限于三乘之圣者，故名无漏，唯佛乃能圆满究竟清净无碍。
    “第十聚，谓四无碍解”。又名四无碍智、四无碍辩，意为解、为智、为辩。
    [1]法无碍，于名句文能诠教法名为法，于教法无有滞碍，故名法无碍。
    [2]义无碍，知教法所诠内容之义理而无滞碍。
    [3]辞无碍，又云词无碍，于诸方言名辞通达自在无碍。
    [4]乐说无碍，又云辩无碍。以上三种之智慧为众生乐说自在无碍。
    “第十一聚，谓四一切种清净：所依身清净、所缘受用清净、心三摩地清净、智清净是为究竟四清净。”
    “第十二聚，谓十自在：能住寿一劫名寿白在；于无数三摩地获得自在名心自在；已得虚空藏定名资具自在；开示一切工巧艺术等事业名事业自在；能随愿而受生名生自在；能现佛身充满一切世界名胜解自在；成就无数调伏众生大愿名愿自在；能于一切时顿现无量神变调伏众生名神通自在；获得殊胜四无碍解名智自在；如欲能演讲十二分教名法自在”。
    “第十三聚，谓十力”。
    [1]处非处智力，谓佛悉能了达一切法的因果。如《入中论善显密意疏》云：“若彼果法定从此因法生，知者诸佛，即说此因为彼果之处，如从不善业生不可爱果，从圣有学道得涅槃次第等。若与上说相违，名为非处。”又云：“如是处非处境无量无边，佛智无碍著转，说名处非处智力。”
    [2]业异熟智力，又云知三世业报智力，佛能如实了知一切众生三世因果业报处，是为业异熟智力。
    [3]种种解智力，诸佛遍知一切众生贪等烦恼，等取信等诸法，所生种子，由彼种子之力，所发欲解，此有下、中、上殊胜极不相同之种种差别，然佛妙智遍三世转，了达一切众生欲解，名为种种解智力。
    [4]种种界智力，《入中论善显密意疏》云：“诸佛善巧一切界之差别，谓眼根等，等摄耳至六根，色至法六尘，眼识至意识六识，说彼(根境识)之内空等本性名界，正等觉智，遍于一切界差别转，说明种种界智力。”
    [5]知根胜劣智力，谓诸众生虚妄增益分别，于生贪等诸根有自在力，总摄有胜、中、劣根，眼等二十二根及诸根互能生果。佛一切种智于彼一一根性皆甚了达，无碍著转，说为诸根胜劣智力。见《俱舍论释》卷三云：二十二根：眼、耳、鼻、舌、身、意、女、男(男女身中起色欲之处)、命根，有情一生寿命；苦、乐、忧、喜、舍，上五为受根；信、精进、念、定、慧，上五根为信等之五根；未知当知根，已知根，俱知根(即三元漏慧根)。
    [6]知遍趣行智力，《入中论疏》云：“颇有行道能趣佛果，有行能趣独觉菩提，有行能趣声闻菩提，有行能趣天、人、饿鬼、畜生、地狱诸趣。正定邪定等种种诸行，于彼一切智无障碍，说为遍趣行智力。
    [7]杂染清净智力，同上《疏》云：“无边世界中，行者各差别，如四静虑，八解脱，奢摩他等持，及九次第等至，与杂染清净无边差别，佛智于彼一切均无滞碍，说名杂染清净智力。”
    [8]宿住随念智力，同上《疏》云：“始从愚痴展转传来，于过去世住三有中。随念他一一有情一切生事，尽有情数无有边际，并念其因，并念相貌，谓念自他如是色类。并念处所，谓念从彼处没来生此处，于彼一切随念境上，所有彼彼无障碍智，说为宿住随念智力。”
    [9]生死智力，同上《疏》云：“尽虚空边际诸世界中，诸有情类，一一有情死时、生时，由种种业感种种果，佛清净智于彼众多境界，无障碍转，说名生死智力。”
    [10]诸漏尽智力，同上《疏》云：“诸佛由一切种智之力，永断贪等一切烦恼及诸习气，佛智一刹那顷，最细种子，习气尽皆断除，声闻与独觉辈，以无漏慧灭诸烦恼，佛智于彼无障无碍，是名漏尽智力。”
    “第十四聚，谓四无畏。”又名四无所畏。
    [1]一切智无所畏，佛于大众中云：我为一切正智之人，无有怖畏心。如佛自云：我成正觉无能如法攻难，名智无所畏。
    [2]说障道法无所畏，佛于大众中作狮子吼，说障究竟佛道之法无有怖畏心。
    [3]说苦尽道无所畏，佛于大众中作狮子吼，说尽苦道无有怖畏心，宣说一切智等道定能出生之菩提，无能如法攻难，名为说出离无所畏。
    [4]说漏尽无所畏，佛于大众中说：我已断尽一切烦恼，无有怖畏心。自云：我已断尽一切漏，无能如法攻难，名为说自断德圆满无所畏。
    “第十五聚，谓三不护”。如来身语意行，究意清净故，不恐他知三业邪行而护过失，如来三业纯净，远离诸过，不须防护故。阿罗汉三业虽净而常须防护，方能离过，如来与彼异。
    “第十六聚，谓三念住”。佛说法时于善听者不起贪心、于不善听者不起瞋心、于间杂者不起二心，唯念住于舍。当佛说法时，念住法界平等之中，毕竟无有灭退之相，故众生虽不一心听法，亦不以为忧，是为第一念住；又念住法界平等之中，增进之相，毕竟不可得，故于众生虽一心听法，亦不以为喜，是为第二念住；又念住法界平等之中，毕竟生死涅槃之相不可得，故常行舍心于一切时，利益众生，而无利益众生之念，是为第三念住。
    “第十七聚，谓不忘失法，利益有情不越时”。佛不忘失所作事业及迟误时间等念不忘失。
    “第十八聚，永离随眠，永断烦恼所知二障习气种子。”
    “第十九聚，谓大悲心。昼夜六时以饶益心恒观一切众生谁已成熟，谁未成熟，谁成增上生器，谁成决定胜器。”
    “第二十聚，谓佛十八不共法”。此十八种不共法，只限于佛之十八种功德法，唯佛具足，而不共同于其他声闻、缘觉和菩萨，故云不共。
    [1]身无失。佛自无量劫以来，常用戒定慧，以智慧慈悲而修其身，此等一切功德圆满具足，由于一切烦恼悉皆断尽，是名身无失。
    [2]口无失。佛具无量智慧辩才，所说之法随众之机宜而使皆得证悟，是名口无失。
    [3]念无失。佛修甚深之禅定，心不散乱，于诸法中心无所著，得第一义谛之安稳，故名念无失。
    [4]无异想。佛于一切众生平等普度，心无间杂，是名无异想。
    [5]无不定心。佛之行住坐卧常不离甚深之胜定，是名无不定心。
    [6]无不知已舍。佛于一切诸法皆悉照知而方舍，无有了知一法而不舍者，是名无不知已舍。此六种是名六不共行。
    [7]欲无减。佛具众善常欲度诸众生，心无厌足，是名欲无减。
    [8]精进无减。佛之身心，精进满足，常度一切众生，无有休息，是名精进无减。
    [9]念无减。佛具三世诸佛之法，一切智慧，相应满足，无有退转，是名念无减。
    [10]慧无减。佛具一切智慧无量无边不可尽，故名慧无减。
    [11]解脱无减。佛远离一切执著，具二种解脱，一者有为解脱，谓无漏智慧相应之解脱；二者无为解脱，谓一切烦恼净尽而无余，是名解脱无减。
    [12]解脱知见无减。佛于一切解脱中，知见明了，分别无碍是名解脱知见无减。此六种是名六不共证。
    [13]一切身业随智慧行。佛示现一切殊胜妙相调伏众生，称于众生之智而演说诸法，各使证入解脱，是名一切身业随智慧行。
    [14]一切口业随智慧行。佛以微妙清净之语随智而转，化导利益一切众生，是名一切口业随智慧行。
    [15]一切意业随智慧行。佛以清净之意业随智而转，入于众生之心，为说法而除灭众生无明痴惑之膜，是名一切意业随智慧行。此三种是名三不共事业。
    [16]智慧知过去世无碍。佛以智慧照知过去世所有一切，若者众生法，若者非众生法，悉能遍知而无所碍，是名智慧知过去世无碍。
    [17]智慧知未来世无碍。佛以智慧照未来所有一切，若者众生法，若者非众生法，悉能遍知而无所碍，是名智慧知未来世无碍。
    [18]智慧知现在世无碍。佛以智慧照知现在世所有一切，若者众生法，若者非众生法，悉能遍知而无所碍，是名智慧知现在世无碍。此三种是名三不共智。(见《大智度论》卷第二十六)
    “第二十一聚，谓一切相智”。“及”字亦摄究竟道相智，一切智，如是二十一聚无漏智，即说明智慧法身。一切相智，又译一切种智，或名一切智智，即智中之智，是为佛智；菩萨智为道相智，或道种智；声缘智为一切智。如《大智度论》第二十七卷云：“佛说一切智，是声闻辟支佛事，道智是菩萨事，一切种智是佛事，声闻辟支佛，但有总一切智，无有一切种智。”
    智慧法身具足以上二十一聚无漏智慧功德，然此智法身，是由三无数劫修习智慧资粮因而究竟圆满之果位，故又称果法身。法身虽不是分别心行境，是寂灭身，但能作众生利益事，如摩尼珠随类所显，成办众生欲乐。如圣龙树菩萨的《法界赞》说：“于无垢法身，安住智慧海，如种种牟尼，作众生义利”。广则如《般若经》等诸大乘经所说。
    ３．圆满报身：圆满报身和胜应化身，是依法身体性所显的二种色身。如《华严经·二十回向品》云：“依法性身，为现色身”。“随顺法身，为现清净妙色之身”。上经《十身相海品》云：“一切如来智身法身，诸色相海充满法界”。是故报化二种色身皆依法身为体，所现三十二相、八十种随形好的妙相庄严之身。如来报身，又称圆满受用身。旧译“卢舍那佛”，为利益一切众生故，尽未来际长久住世，如《现观庄严论颂》云：“许三十二相，八十随好性，受用大乘故，名佛受用身”。《略释》云：“具足五种决定之究竟色身，是受用身的相，界限唯在佛地”。五种决定者：
    [1]处决定，唯住色究竟天密严宫；
    [2]身决定，唯是圆明庄严之身；
    [3]众决定，唯圣位菩萨之所围绕以为眷属；
    [4]法决定，唯说大乘法，如《华严经》等；
    [5]时决定，乃至生死未空而久住，显示报身如来身语意事业无尽。详如《宝性论》和《大乘经庄严论》等中所说。
    佛圆满报身的三十二种妙相：
    [1]由于往昔在有学道时，极善迎送师长等故，感得能仁手足具足轮相；
    [2]由于往昔正受律仪，坚固安住故，感得能仁足下平整如龟腹状；
    [3]由于往昔修习四摄事故，感得能仁手足指间缦网相连。犹如鹅王；
    [4]由于往昔布施善妙食物等故，感得能仁手足柔软细嫩；
    [5]由于往昔布施善妙饮物等故，感得佛手足四背双肩及颈间七处皆充满；
    [6]由于往昔救脱被杀、被缚、被打诸有情故，感得能仁手足诸指纤长可爱；
    [7]由于往昔饶益他活命故，感得足跟宽广；
    [8]由于往昔远离杀生事故，感得佛身洪直；
    [9]由于往昔正受布施等善法故，感得能仁足踝膝骨皆不突现；
    [10]由于往昔自所行善辗转增长他故，感得能仁诸毛皆悉上靡；
    [11]由于往昔将医方明、工巧明等传授他故，感得能仁双腿渐次细圆如瑿泥耶仙鹿腿；
    [12]由于往昔不舍诸来求财物者故，感得能仁双臂长妙；
    [13]由于往昔安立一切有情于梵行律仪中，及善护秘密语故，感得能仁阴藏相密最为第一；
    [14]由于往昔施他妙好敷具故，感得能仁皮肤如金色清净鲜明；
    [15]由于往昔施他胜妙宫殿故，感得能仁身皮细薄润滑；
    [16]由于往昔远离愦闹散乱等故，感得能仁一一毛孔各一毛生皆向右旋；
    [17]由于往昔恭敬承事一切众生及师长等，亦令他恭敬承事故，感得能仁眉间毫相庄严，量如橄榄核许形如银管，洁白软柔，展长三肘，缩即右旋毫端上靡；
    [18]由于往昔未曾轻毁他故，感得能仁上身犹如狮子；
    [19]由于往昔随顺他善说故，感得能仁臂膊圆实；
    [20]由于往昔施他医药等故，感得能仁双肩之中项部极善丰满；
    [21]由于往昔承事众生作看病人等故，感得能仁于非上味中亦得上妙味；
    [22]由于往昔建造园林等故，感得能仁身量与弓相等如诺瞿陀树；
    [23]由于往昔施他寺院等故，感得能仁顶上乌瑟尼沙高显周圆；
    [24]由于往昔三无数劫说和爱语等故，感得能仁舌相薄净广长如红莲色；
    [25]由于往昔以一音为一切世界有情宣说正法故，感得能仁成就五支梵音；
    [26]由于往昔远离绮语过故，感得能仁两颊如狮子王；
    [27]由于往昔承事称赞一切众生故，感得能仁齿洁白相；
    [28]由于往昔远离邪命，正命清净故，感得能仁齿平齐相；
    [29]由于往昔修谛真实语故，感得能仁齿细密相；
    [30]由于往昔远离离间语故，感得能仁整四十齿；
    [31]由于往昔视一切众生如一子故，感得能仁眼如绀青宝相；
    [32]由于往昔视一切众生无贪瞋故，感得能仁两眼上下睫毛不相杂乱犹如牛王。
    此等即是能仁圆满报身定能感得此三十二相，谓由能感得此诸相之彼彼因，皆圆满故。迎送师长等因，随各各相时已广宣说，最重要是观察其因而得三十二相之果。此等名为妙相者，谓由谁具足此三十二相即能表现彼是大丈夫故。
    《大智度论》卷八十八曰：“随此间阎浮提中天竺国人所好，则为现三十二相。天竺国中人于今故治肩膊令厚大，头上皆有结为好。如人相中说，五处长为好，眼耳鼻舌臂指髀手足相，若轮若莲花若贝若日月，是故佛手足有千辐轮，纤长指，鼻高好，舌广长而薄，如是等皆胜于先所贵，故起恭敬心”。佛感此相者，由于百劫之间，一一之相，积百种之福。《法界次第》下曰：“如来应化之体现此三十二相，以表法身众德圆极，使见者受敬，有胜德可崇，人天中尊众圣之王故现三十二相也”。此三十二相，依《法界次第》、《大智度论》八十八及卷四、《涅槃经》二十八、《中阿含经》中之《三十二相经》、《大般若经》卷四百六十九等所载，皆大同小异。
    佛受用身有八十随好：
    [1]由于一切诸行离贪爱究竟故，感得能仁爪如赤铜色鲜红光明；
    [2]由于一切有情增上利益意乐到究竟故，爪色润泽；
    [3]由于上等族姓生故，爪甲高起；
    [4]由行境无罪故，诸指圆形；
    [5]由集善根究竟故，诸指丰满；
    [6]由渐次修三种智德故，指渐细长；
    [7]由往昔善护十不善业道及邪命故，筋脉不现；
    [8]由已解脱烦恼结故，筋脉无结；
    [9]由能了知甚深密义，踝骨不现；
    [10]由从生死等难可行处度诸众生故，足无不平；
    [11]由善巧映覆人故，行步如狮子；
    [12]由善巧映覆龙故，行步如象王；
    [13]由善巧腾空故，行步如鹅王；
    [14]由善引有情至安乐处故，行步如牛王；
    [15]由顺绕路而行故，回身右旋；
    [16]由行步善巧端庄故，行步善妙；
    [17]由心常无曲屈故，行步直进；
    [18]由称赞他功德故，身盘紧密；
    [19]由不染著诸恶法故，其身光洁；
    [20]由说称机法故，身次第相称；
    [21]由行清净故，身最洁净；
    [22]由心具大悲故，身柔妙；
    [23]由意垢清净故，身善清净；
    [24]由法毗奈耶圆满故，众相圆满；
    [25]由为他说广大妙法功德圆满故，身广大微妙；
    [26]于一切有情心平等故，行步安详平等；
    [27]由说清净法故，双目清净无翳；
    [28]由说易解法故，身极细嫩；
    [29]由于难行处心不退故，身容无怯弱；
    [30]由修善根胜出一切世间故，身最充实；
    [31]由尽后有故，身善策励；
    [32]由善分别缘起顺逆故，支节善开展；
    [33]由说清净法义故，顾视清净无翳；
    [34]由弟子戒圆满故，其身圆满；
    [35]由未染著生死过故，身部相称；
    [36]由摧伏我慢故，身无歪倒；
    [37]由说无尽法故，身相平等无诸高下；
    [38]由通达甚深法故，脐底深妙；
    [39]由弟子受持顺自之教授故，脐纹右旋；
    [40]由诸徒众行端严故，威仪端庄众所乐见；
    [41]由意净故，三业行净；
    [42]由于非时不说法毗奈耶故，身无疣赘及诸黡点；
    [43]由说身等安乐法故，双手柔软如睹罗棉；
    [44]由得光明大沙门故，手纹光明；
    [45]由住甚深法故，手纹甚深；
    [46]由数数说真净法故，手纹长直；
    [47]由为众生宣说众多学处故，面门不太长；
    [48]由通达一切世间犹如影像故，唇红如频婆果；
    [49]由柔和语调伏众生故，舌极柔软；
    [50]由说众多功德正理故，舌极微薄；
    [51]由所说法毗奈耶诸著我我所之凡夫难测度故，舌赤红色；
    [52]由无一切怖故，语雷音；
    [53]由说和爱语故，音韵美妙；
    [54]防护三有结故，四牙圆整；
    [55]调伏难调故，四牙锋利；
    [56]降伏烦恼法毗奈耶最洁白故，四牙洁白；
    [57]安住通达生死涅槃平等地故，四牙相平齐；
    [58]渐说三乘现观故，四牙渐细；
    [59]安住方便所持胜慧故，鼻相高修；
    [60]具足众生信仰净行故，鼻清净；
    [61]由说广大法故，眼目宽广；
    [62]由度众生出生死故，眼睫厚密；
    [63]由善能令众生欢喜称赞故，眼目青白分明圆满如莲花叶；
    [64]由常时回顾诸有情故，双眉修长；
    [65]由善巧和缓调伏非以五火炙身等故，眉毛细软；
    [66]意为善故，双眉润泽；
    [67]遍见贪等过患故，眉毛齐整；
    [68]由遮遣有情损害故，手长圆满；
    [69]由战胜贪等故，两耳相齐；
    [70]令诸有情相续不坏故，耳根不坏；
    [71]不由边执见等扰动心故，额部与发际极善分展；
    [72]由摧坏一切邪说故，额部开展宽大；
    [73]由圆满胜愿故，顶圆如盖；
    [74]由于色等断除贪爱故，发绀青色如蜂；
    [75]遍尽见修所断随眠故，头发稠密；
    [76]由说圣教妙慧遍知故，头发柔软；
    [77]由意不为贪等乱故，头发不乱；
    [78]常时不说粗恶语故，发不粗涩；
    [79]由于三宝前散布妙花故，出妙香等夺众生意；
    [80]手足拇指有德纹相犹如金刚，手足掌中有四方吉祥纹，其外无名指等有七纹右旋，而善庄严。此八十种名佛随好者，由身外现功德相表内心功德故”。
    4．胜应身：化身佛又名胜应身，亦称胜应化身。佛以大悲心随应众生之机而作利益，随应化何类，皆在此类为最殊胜者，故名胜应化身。
    《现观庄严论》云：“若乃至三有，于众生平等，作种种利益，佛化身无断”。不具足五种决定所显之究竟色身(三乘并说及人天善法)，是化身相。又此分生化身、巧化身和菩提化身之三种。
    如化现大桥、桥梁和禽畜鹿鸣等，名生化身；如化现鼓琴师，及化现铁木工和缮写人等，名巧化身；如释迦牟尼从兜率降生至菩提树下成道乃至涅槃一生经历的十二种宏化事业，名菩提化身。如《宝性论》云：“[1]兜率降世；[2]入住母胎；[3]圆满诞生；[4]少年嬉戏；[5]受用妃眷；[6]从家出家；[7]行苦难行；[8]趋金刚座；[9]降伏魔军；[10]成等正觉；[11]转妙法轮；[12]入大涅槃。或八相成道之事业：[1]兜率降下；[2]入胎；[3]住胎出胎；[4]出家；[5]降魔；[6]成道；[7]转法轮；[8]入涅槃。如《大乘经庄严论》云：“佛化现无量，是名为化身。”又云：“工巧生菩提”。又如清辨论师《中观心要论》云：“如所化化现，现化满诸方，说法降宝雨，生起出世乐”。佛为利益无量众生，所作事业常无间断。如《略释》云：“若有乃至三有未空，于净不净众生，同时而作增上生决定胜等种种利益之身，即能仁佛世尊之化身，以是不具五种决定所显之究竟色身故。佛作事业亦常无间断，乃至生死未空于一切世界事业相续无断故。
    法身作用有二十七类事业：
    [1]安立众生解脱寂静；
    [2]安立他成熟四摄事；
    [3]安立众生取舍四谛正见，此三是安立资粮道。
    [4]安立自他证真实义；
    [5]安立他令圆满六度行；
    [6]安立他二利行；
    [7]安立他于清净正见；此四是安立于加行道。
    [8]安立他于见道亲证空性；
    [9]安立他于修道中第二尸罗；
    [10]安立第三地安忍；
    [11]安立第四地了知顺菩提分妙慧；
    [12]安立第五地了知四圣谛慧；
    [13]安立第六地了知缘起妙慧；
    [14]安立第七地方便善巧成熟有情；
    [15]安立于第八地中了知三道道相智；
    [16]安立遣除现行实执；
    [17]安立令得佛宝之菩提；
    [18]安立于严净佛土；
    [19]于第九地中安立于自决定成佛不堕小乘；
    [20]安立他令成就作无量有情义利；
    [21]于第十地中安立亲近诸佛善知识功德；
    [22]安立菩提支善；
    [23]安立令知诸业无失坏；
    [24]安立令现见四谛；
    [25]安立远离四颠倒，令知彼颠倒无所依之根本，无有实执生诸颠倒之根本；
    [26]安立资粮圆满证得平等清净；
    [27]安立于道果证得生死涅槃平等之无住涅槃。安立于资粮道有三种，安立于加行道有四种，安立于见道一种，安立于修道有十八种，安立于佛果无住涅槃一种，共成法身二十七种作用事业。


二、法宝

    佛教所讲的“法”字范围较广，一般有三义：
    第一、法指宇宙间一切事，如佛教经论中有译作“事”，“一切事”，是泛指世间存在的一切事物，皆称作“事”，如玄奘法师译的《五事毗婆娑论》(是法救尊者解释世友尊者的《五事论》，说的色事、心事、心所事、不相应行事和无为事，此五事即包括宇宙一切事物的规则，对此五事，亦有译作“法”。有为事具有生住异灭的规则，能生自己果法的功能作用，使人所见即能了知，即名“能持自相，轨生物解”义；无为法，它不具有生灭作用，是对有为而立无为。如龟毛、兔角和虚空花等非事，或非法，因为它是非存在的事物，所以佛教立为非法。
    第二、“法”指一切所知境像或事物现象，义为法则、法律、风俗、习惯和思想方法等，都称作法。法是梵语达磨意译，义谓“能维持自体者”。如世亲菩萨所著的《注疏明论》中解说“达磨”一词，有十种含义，如云：“有为法及无为法”之法字指知识；“道谛之法”的法字指道路；“灭谛之法”的法字指涅槃；“法处之法”的法字指意根所对之环境；“与诸妃眷少年共同享法”，法指福泽；“凡夫贪爱现法”法指寿命；“毗奈耶法”法指佛经；“身及老法”法指未来；“四沙门法”法指确定；“世出世法”法指规范。今此十义，通约为三：1、指规范；2、指佛经；3、指知识。
    第三、法指佛陀所说的教法，谓佛陀如实亲证为众生如实宣说的法，称作佛法。佛陀所说教法，称为法宝，总可分为教道果三法：1、教法，即三藏十二部经；2、道法，修行的方法，包括四圣谛，及十二缘起和六波罗蜜等法；3、果法，即是有余依和无余依二种涅槃，即佛陀与无学声闻独觉身心相续中的灭谛——涅槃功德，以及三乘有学圣者身心相续中的道谛功德，以为法宝。
    （一）教法：即大小乘经律论三藏十二部契经，为戒定慧三学。律藏属律学，经藏属定学，论藏属慧学。藏文《甘珠》(甘珠尔)即是依律经论编次，正表戒定慧三学之顺次。所谓十二部经者，是从文义体裁而分为十二部类：
    [1]修多罗，此云契经，即长行经文；
    [2]重颂或应颂经，即重宣长行经文的颂文；
    [3]讽颂经或孤起经，即经中直说的偈颂；
    [4]因缘经，即见佛闻法及佛陀说法教化的因缘，如契经之序品；
    [5]本事经，即佛说弟子过去因缘本事之经文；
    [6]本生经，即佛说自身过去因缘之经文；
    [7]未曾有或稀有经，即记述佛陀种种神变力不思议之经文；
    [8]譬喻经，即经中所说的种种譬喻；
    [9]论义经，即经中以法理论义问答之经文；
    [10]自说经，即无请问者佛自宣说之经文；
    [11]方广经，即佛说方等广大甚深真理之经文；
    [12]授记经，即佛为菩萨及声闻弟子等授成佛记别之经文。佛说八万四千法蕴，结集成大小乘三藏经文，都是佛陀教诫不同根性众生依法修行的方法次第，故称教法。
    （二）道法，即三藏经文所说三乘人修道的方法次第。这里总摄为：四圣谛、十二缘起和六波罗蜜多等法，作为三乘人修行的所缘境。
    １．四圣谛：
    释迦牟尼成道前，念念不忘如何解脱众生之苦，此即是佛陀舍王位出家求道的出发点。当他在菩提树下，思维今世的苦果(即苦谛)，皆依过去之因(集谛)；未来苦果又依今世之烦恼惑业的苦因。唯有如是烦恼业因而感苦果令生死相续，除此之外别无所有。若要断此集因和苦果的锁链，即能真解脱，此即是灭谛涅槃。得灭谛之方法为修道。苦集灭道真实不虚，是名为谛。但此四法皆是圣者乃能所知、所见和所证，故名四圣谛。由四圣谛即组成修道时内心观察的总体而命名。佛陀自初转四圣谛法轮之始，开示五贤者乃至入涅槃时所说的遗教，中间虽有般若无相法轮和最后善辩法轮，三次转法轮，说无量法门，但皆不出于此四圣谛。故此四圣谛属于佛陀一代时教之基本教法，为三乘人共修的中心。
    (1)苦谛：世间有情悉皆是苦，即所谓“有漏皆苦”是也。欲界，有爱欲饮食和男女等贪欲所属之界，故以欲为别名；色界，为色物质所属之界，(界为种族之义，自类之法)以色为总名；无色界，非物质所属之界，但有心识。从三界有情果报观察，则为五趣，加上修罗，或称六趣。众生之果报，即所谓：地狱、饿鬼、傍生、人、天、修罗六趣或称六道。三界万象可分成五蕴，即色蕴、受蕴、想蕴、行蕴、识蕴。蕴是积聚之义，故名为蕴。由五蕴法不同而有宇宙万象，皆以积聚因缘之力而成，即万法有为造作之义。所以五蕴所成众生世界无不皆苦。苦者逼恼性，逼恼六道众生故。广则有无量诸苦，略则总有三苦，八苦之分。
    三苦者：谓苦苦、坏苦、行苦。三界众生毕竟不能避免生灭变化，逼恼身心之苦，故名一切皆苦。
    八苦者：[1]生苦，从死苦尽时，而转至余处入母胎中所生苦故，名曰生苦。与生时之苦相应，与粗重我、我所、我慢等相应。从有身时即成烦恼住处，成为苦处所依，并且不欲乐分离，与苦结合；[2]老苦，从少年时分刹那变坏乃至衰老，皆是苦故，名曰老苦。即时节代谢从少壮衰退，能力衰损，力量衰减，行动迟缓，诸根衰损，眼不辩色，念力多忘，所受用境衰损，饮食难消，腰弓、头白、发落、面皱、不可爱乐，此等为老苦；[3]病苦，由地、水、火、风诸大种不调，产生变坏，种种诸苦来集其身而生痛苦故，名为病苦。如《金光明最胜王经》卷五云：“地水火风共成身，随彼因缘招异果，同住一处相违害，如四毒蛇居一箧，于此四种毒蛇中，地水二蛇多沉下。风火二蛇性轻举，由此违背众病生”。由是因缘即令身起变更性，令苦增长，忧愁不悦，忧苦增长，不可爱乐所行境界，心情急迫，不悦意行，渐渐变为与命根分离，如人生诸病，其苦难忍，总括病苦名，有四百四病。如《大智度论》六十五云：“四百四病者，四大为身，常相侵害，二大中百一为起，冷病生二百二，水风起故，热病二百二，地火起故”。这是四大不调所生病苦，而烦恼病则有八万四千，如《智度论》五十九云：“八万四千病，根本四病：贪、瞋、痴等分。淫欲病分二万一千，瞋恚病分二万一千，愚痴病分二万一千，等分病分二万一千”。故佛说八万四千法门对治八万四千烦恼；[4]死苦，寿命渐变坏，其身四大即将分散之苦性故，名为死苦。一切众生都爱自己的生命，为求生存，不乐于死，但在即将死时与受用财物分离，与亲眷分离难舍难分，与身所悦意之事及财物分离，其心感受猛厉忧愁之痛苦。身苦与心苦交织，难舍难分，最后寿尽命根断绝时，万苦交煎，即名为死苦；[5]怨憎会苦，谓与怨恶仇敌相会，其怨报怨，逼迫生命等时而生的痛苦，名曰怨憎会苦。以上五苦，总名苦苦，苦苦即苦受。谓由生老等苦事所成而更生苦恼，此苦多在恶趣，故名苦苦。[6]行苦，行谓迁流之义。一切有为事物迁流三世，无有刹那安静常住，有情常随业烦恼力迁流而转，流转三世不息之苦，即名行苦；[7]爱别离苦，谓与亲眷别离时发起忧恼、愁叹、悲哭、爱恋，所生的极端逼恼身心等痛苦，故名爱别离苦；[8]求不得苦，所有希求名利盛事，一切所求之事皆与愿违，劳而无果等苦恼，名求不得苦。此[7][8]两苦，在三苦中，名为坏苦。由与乐事和合将生苦恼，乐事虽暂顺自己，但乐事本性不断变易，不断坏灭，故名坏苦。
    由是应知，由前五苦总名苦苦；第[6]名行苦；[7][8]二苦名为坏苦，此即三苦。坏苦和苦苦为世俗苦；行苦为胜义苦。如《显扬圣教论》卷十五云：“如是诸苦略有二种，谓世俗胜义别故。世俗谛所摄苦有二种，谓苦苦及坏苦；胜义谛所摄苦有一种谓行苦，亦名遍行苦，遍至欲等三界故”。又如《阿毗达磨集论》云：“由安立真如门出世智境界故，初后二苦(坏苦、苦苦)为世俗苦，世俗智境界故”。总集诸苦，不出二义，一是外界身病等苦，二是内心烦恼逼迫之苦。若圣者审观此义真实不虚，即名苦圣谛。
    (2)集谛：人生之苦果绝非偶然，而有引起苦果的原因。苦果之因则为集。集谛之因，以业为正因，烦恼为助因，由此二因招感后世，遍生众苦，流转生死，轮回不息，故集为众苦之因，如疾病因，是所应断。业分为身三、口四、意三。身三业为杀、盗、淫；口四业为妄言、绮语、两舌、恶口；意三业为贪、瞋、邪见。此十不善业，而以意业为主，意即是思业，谓由贪瞋而生邪见，拨无因果，诽谤三宝与四谛真理。
    烦恼有六根本烦恼，即贪、瞋、痴、慢、疑和邪见。见又分为五种：[1]己身见，或有身见，即萨迦耶见，以缘我为境；[2]边执见，谓执断常二边；[3]邪见，谓拨无因果；[4]见取见，谓计己见为胜；[5]戒禁取见，谓计邪戒为解脱生死真因。由此根本烦恼与邪见而造有漏善恶业，所得果报，即三界六趣而受大苦。由业与烦恼而招感大苦，又由苦而生业及烦恼，如是无始以来循环不息，皆以集为其因，故名集谛。若圣者审观此义真实不虚，即名为集圣谛。
   (3)灭谛：明集谛理，断尽烦恼业，则得解脱，是名为灭谛，又名涅槃。义为寂灭，即寂灭一切烦恼苦果，惑业既尽，则无生死累患，以诸业烦恼结使灭故，三界业亦尽灭，即得解脱涅槃，则名为灭。若圣者审观此义真实不虚，即名灭圣谛。涅槃之体乃解脱一切烦恼所显之妙境，非语言所能诠说，重在知苦断集而修道谛，乃能获得，其真相非凡夫智所能现观。
    (4)道谛：道谛为随顺趣向涅槃之道。道谓能得涅槃所应修证必经之道路，是名为道。为离苦断集，不著苦乐断常诸边而行中道者，乃得涅槃，故云为得涅槃之正道。因佛陀的方便善巧，即开道谛为七科三十七品，名为三十七道品，或云三十七菩提分法，或云顺菩提分法。
    三十七道品者，分为七科：
    第一科，四念处，或名四念住。由般若慧使念住境，观察自身内体，故名念住，其自体即是五蕴之身。依五蕴而分身、受、心、法。由此四种念处，能除世间贪忧，为趣入修道谛之初门。[1]身念处，观身不净。[2]受念处，观受是苦。[3]心念处，观心无常。[4]法念处，观法无我。由观此四念住，则能如次对治净、乐、常、我四种颠倒执著。
    《法蕴足论》卷五；念住品云：“尔时世尊告比丘众，吾当为汝略说修习四念住法，谓有比丘于此内身住循身观，若具正勤正知正念除世贪忧，于彼内外身住循身观。……
    内身者谓自身若在现相续中已得不失，于此内身循身观者，谓有比丘于此内身，从足至顶随其处所，观察思惟种种不净秽恶充满，谓此身中惟有种种发毛爪齿，尘垢皮肉，筋脉骨髓，脾肾心肺，肝胆肠胃，肪膏脑膜，脓血肚脂，泪汗涕唾，生熟二藏，大小便利。如是思惟不净相时，所起于法拣择。……觉明慧行，毗钵舍那。……
    复有比丘于此内身，观察思惟诸界差别，谓此身中，惟有种种地界水界火界风界空界识界，如是思惟诸相时，所起于法拣择，乃至毗钵舍那。……
    复有比丘于此内身，观察思惟多诸过患，谓此身者如病如痈，如箭恼害，无常苦空，非我转动，劳倦羸笃，是失坏法，迅速不停，衰朽非恒，不可保信，是变坏法，如是思惟身过患时，所起于法拣择，乃至毗钵舍那。……
    于彼外身循身观者，谓有比丘于他身内，从足至顶随其处所，观察思惟于彼处身循身观者种种不净，秽恶充满，谓彼身中惟有种种发毛爪齿，广说乃至大小便利。如是思惟不净相时，所起于法拣择，乃至毗钵舍那”。(观界差别及诸过患，如此类加)
    第二科，四正勤，又名四正断、四正胜。[1]对已生之恶，为断除故，而勤精进。[2]对未生之恶，更使不生，而勤精进。[3]对未生之善，使之生起，而勤精进。[4]对已生之善，为使增长，而勤精进。由于一心精进，行此四法，故为四正勤。能断除懈怠，故名四正断。能正策励身语意业中善法此为最胜，故又名四正胜。如《大智度论》卷十九云：“破邪法，正道中行，故名正勤”。
    第三科，四如意足，又名四神足。如意谓所求所愿一切如意自在，故名为神，此四胜行为禅定之果，此定即名为足。是以信为基础之义，此分为欲、勤、心、观四种：[1]欲如意足：即由欲三摩地(定、静虑)成就神足，谓于佛法僧生起净信，生起乐欲听闻正法，由欲乐增上故，成就三摩地，由成就此定能生种种神用，故名欲神足。[2]勤如意足：由勤三摩地胜行，成就神足，于教授教诫之法，炽然精进，由增上故，成就三摩地，故名勤如意足；[3]心如意足：即心三摩地胜行成就神足，由思惟内法，心增上故，成就三摩地，是为心如意足；[4]观如意足：以观三摩地胜行成就神足，多闻、闻持、多闻积集，以慧抉择微细观察，由观增上故，成就三摩地，故名观如意足。
    第四科，五根：[1]信根：谓深信三宝、四谛者；　[2]精进根，又名勤根：谓勇猛精进修诸善法者；[3]念根：谓忆念正法者；[4]定根：谓使心止于一境而不散乱者；[5]慧根：谓思维真理或谛理者。此五法为能生一切善法之本，故名五根。如《俱舍释》卷三云：“于清净法中，信等五根有增上用，所以者何？由此势力伏诸烦恼，引趣圣道故”。
    第五科，五力：[1]信力：谓由信根增长力，能破诸邪信者；[2]精进力：谓由精进根力增长，能破身之懈怠；[3]念力：谓由念根增长力，能破诸邪念；[4]定力，谓由定根增长力，能破诸散乱者；[5]慧力：谓由般若慧根增长力，能破三界一切烦恼者。能破邪法，故名为力。如《大智度论》卷十九云：“五根增长，不为烦恼所坏，是名为力”。又云：“天魔外道不能阻坏，是名为力”。
    第六科，七觉支，或云七等觉支：[1]择法觉支，谓以智慧简择辨别诸法；[2]精进觉支，谓以勇猛心离诸邪行，修行真法；[3]喜觉支，谓心得善法而生欢喜；[4]轻安觉支，谓断除身心粗重散乱，使身心轻利安适；[5]念觉支，谓明记定慧而不忘夫，调适均等；[6]定觉支，谓使心住于一境而不散乱；[7]行舍觉支，谓舍诸妄谬，舍一切法，持心平等性，更不追忆，此乃行蕴所摄之舍心所，故名行舍。觉谓有觉，有觉有观，观察觉了之义。此七为道道品中的第六，觉法分为七科，故名七觉支。
    第七科，八正道：[1]正见：谓远离一切邪执恶见，于法抉择，观察明达的正观；[2]正思惟：谓由正见所起，远离一切虚妄分别心，随顺一切智的如法思惟。此即是正思惟四谛理，远离贪欲瞋恚害意等烦恼。[3]正语：谓远离妄言、绮语、两舌、恶口过患的正言说。[4]正业：谓远离杀盗淫等身过之正施作。[5]正命：谓远离各种邪缘活命，即为正命。此有五种邪命，比丘所营不如法事以求利养而为生活，谓之邪命。<1>诈现异相，意欲使人恭敬承事，于世俗之人前诈现威仪之相，以求利养者；<2>自说功能，说自己功能，以求利养者；<3>占相吉凶，学占卜而说人之吉凶，以求利养者；<4>高声现威，大言壮语而现威势，以求利养者；<5>说所得利养以动人心，于彼得利，则于此称说之，于此得利，则于彼称说之，以求利养者。如《遗教经》中佛说：“持净戒者，不得贩卖贸易”。“占相吉凶，仰观星宿，推步盈虚，历数算计，皆所不应，节身时食，清净自活”。佛陀教诲，是为比丘，如法求得衣食卧具汤药的清净正命。[6]正精进：谓远离种种身心懈怠，止恶修善，向解脱而勇猛精进，常不止息的正确方便。[7]正念：谓远离邪念，忆念正法，明记不忘的正确思念。[8]正定：谓远离杂想，住心不乱，坚固摄持的无漏清净禅定。
    (5)四谛十六行相。四谛法为声闻(闻佛说法而证道者)缘觉(又译为独觉、独胜、辟支佛，出生无佛之时，而独自证道的圣者)修行所缘的境，主要缘四谛无常等十六行相而修行证道，大乘菩萨亦缘此四谛十六行相。十六行相，谓于四谛法上每谛各有四相。
    苦谛四相者：谓无常、苦、空、无我。[1]无常：谓是一一刹那生灭法故，因缘所生故，名为无常相。[2]苦：谓随顺烦恼业转，三苦损恼连续不断，毕竟苦故，故名为苦相。[3]空：谓无有常一自在异体主宰之我，故名空相。[4]无我：谓五蕴非常一自在之我，即五蕴无有自性主宰之我，故无我相。
    集谛四相：谓因、集、生、缘。[1]因：谓诸业惑生苦之因，乃生苦之根本，故名因相。[2]集：谓诸苦因渐渐发生，遍生三界六趣，数数生苦，故名集相。[3]生：谓能招感业烦恼而猛厉生众苦故，相互系属，名为生相。[4]缘：谓由业及烦恼逼恼众生令其于三界中与后世生众苦果作助缘故，名为缘相。
    灭谛四相：谓灭、静、妙、离。[1]灭：谓是永断业烦恼之离系，故名为灭相。[2]静：谓寂静，能寂灭苦果之离系，故名为静相。[3]妙：谓其本体即是利乐寂静自性之离系，不再受三界之众苦，故名为妙相。[4]离：谓苦不再生，解脱轮回，决定出离安趣涅槃之离系，故名为离相。
    道谛四相：谓道、理、行、出。[1]道：谓能从凡夫众生往趣圣位，尽其苦源，趣向解脱涅槃之道，故名为道相。[2]理：又称为“如”，谓道谛三十七道品，是能对治烦恼的不颠倒之正理，故名为理相。[3]行：谓心住正理现证体性，是成就道业的不颠倒之加行，故名为行相。[4]出：谓能从其根本拔除诸苦及诸业烦恼故，名之为出。义为出离，决定能出离生死之苦，往趣涅槃，是名出相。
    总上四谛，佛陀教诫五贤者应知苦断集，即应了知苦而断集因，是为应了知现在逼恼三界众生的诸苦果，寻其原因，是由过去集聚有漏善及不善诸业，及诸烦恼为集因，应当断除，此能招感三界生死，轮回循环不息的原因，此为迷之因果。应证灭修道，是为希求灭除生死诸苦之解脱――涅槃，应修道品为其正因，此为悟之因果。说明迷悟二重因果的关系如下：
    苦谛——迷果┐此为流转法，为流转三界生死之世间因果，属有漏有为法，
    集谛——迷因┘凡属有漏毕竟是苦。
    灭谛——悟果┐此为还灭法，为还灭生死的出世因果，属无漏法，如《俱舍论》云：
    道谛——悟因┘“无漏谓道谛”，道谛为无漏有为法，灭谛为无漏无为涅槃法。
    2．十二缘起：十二缘起，又称十二缘起支、十二有支、十二缘生支，此为内缘起，即有情内在缘起的必然规律。如经说“佛出世佛不出世法尔如是”。说明有情世间一切众生生死流转状况的定律，有此十二个顺次规律。如经云：“此有故彼有，此生故彼生”。是为观待缘起性，此中随缺一支余则不转。此为佛教的根本原理，是三乘行者共修之法。
    有情流转的情况，总有十二支分差别之行相。
    (1)无明支：什么是无明？如《华严经·十地品》云：“世间受生皆由著我，于第一义谛不了故名无明”。众生由于执著五蕴实有我体的痴烦恼，不了解真如法性，体空无我，即名无明。由执有我，能障真实之事理，起虚妄分别心，即不能如实了知三界业果谛理之道，则起烦恼生杂染贪著而造业，是为流转三有之根本，故曰无明支，无明有二种业：[1]令众生迷于所缘境，[2]与行作生起因。
    (2)行支：行以无明支为缘而起烦恼，造诸恶行，所作业果，积集福非福业等，与识相应，现前造作之业，名为行支。行有二种业：[1]能生未来报；[2]能与识作生起因。
    (3)识支：识以行支为缘，依止初心是识，即依过去善恶业行，能招后有，能牵引轮回生死之处，随事贪欲与心共生，现入母胎正结生相续时的刹那五蕴之一念，故名识支。识有二种业：[1]令诸有相续，[2]与名色作生起因。
    (4)名色支：名色以识为缘与识结合托于母胎，生四种取蕴，识支结生后有之第二刹那际，使受想行识四种名色取蕴及住胎五位之色蕴(凝酥、膜疱、血肉、坚肉、支节五位)，互相依存，发育成身，故名名色支。名谓心法，受想行识皆是心法，而无形体可见，但以名而能了知，故曰为名。色谓眼耳等之身根，即结生以后，六处生起之前，中间诸分位阶段，皆叫做名色。名色有二种业：[1]互相助成；[2]与六处作生起因。
    (5)六处支，又名六入支：六处依名色位继续增长，生起眼耳鼻舌身意内六入处，令身支六根圆满，胎儿渐成眼等之六根，即将出胎之位，称为六入支，六处有二种业：[1]名取自境界；[2]与触作生起因。
    (6)触支：胎儿出生后有根境识三事和合，触境但未有苦乐明辨之感觉，如三四岁间，虽于根境识三和合起用，但对外境事物，未识别苦乐受之差别，但有欲触事物之位，名为触支。触亦有二种业：[1]能触所缘外境；[2]与受作生起因。
    (7)受支：受依于触支生感觉，如五、六岁至十四、五岁间，渐渐对事物已有识别苦乐感受位，虽起衣食等贪著，但未起淫欲贪爱，名为受支，受亦有二种业：[1]能领受爱憎等事；[2]与爱作生起因。
    (8)爱支：爱以受支为因，于受染著无厌是名爱，如十七、八岁以后，虽贪著外境，资具之味著，生起淫爱现行，强盛喜爱欲著，但未广泛追求，名为爱支。爱亦有二种业：[1]染著可爱事；[2]与取作生起因。
    (9)取支：取以爱为缘，由爱增长所摄而不舍是名取，如十七、八岁成人已后，爱欲愈盛，贪妙资具，驰驱诸境，追求取可爱欲乐之位，乐欲于忍可取著，于了别四取，即欲取、见取、戒禁取和我语取四取蕴等，能取内外诸事物的有一百八烦恼，起功用力，名为取支。取亦有二种业：[1]令诸烦恼相续；[2]与有作生起因。
    (10)有支：有依爱为缘取所起的有漏业令诸有支生是名为有，由身语意造业，作种种有漏善恶业力，此为决定当来之果报位，故名为有。有者有三界生死轮回之来去，有支即能招感后有之业，有生存之分位，故称三界为“三有”以为当来三界生存之处所，故名有支。有亦有二种业：[1]能令于六趣中受生；[2]与生作生起因。
    (11)生支：生依有支为缘，从业起蕴是生，一遇顺缘，即以现在之业力，于未来转生位中，直接受生之位，正结当有，六根圆满，位众同分第一受生，成就苦蕴，称为生支。(住众同分：众同分，同类，身体相似的有情类，若人，若傍生等同生一趣，各各类别相同，如人与人同分)生亦二种业：[1]能起诸蕴；[2]与老作生起因。
    (12)老死支：出生以后，诸蕴相续变异、成熟，名之为老；蕴相续坏灭，名之为死；年龄寿命起变异故，属于未来老死之位，名为老死支。老亦有二种业：[1]令诸根变异；[2]与死作生起因。死亦有二种业：[1]能坏诸行；[2]不觉知故相续不绝。
    总括十二缘起为四支，称为“缘起四支”。|
    (1)刹那缘起：每一刹那出现的生灭缘起之相，具有贪等业行的作用都具有十二支。
    (2)连缚缘起：或前后刹那无间相续，而为同异类相属缘起(十二支缘起，由前因生后果相之连续的关系)之因果相属而起，即无间相续义。
    (3)分位缘起：或一一支的分位阶段无有间隔而因果相续。
    (4)远续缘起：或一一支分，必定不同类，因果相属，而中间有其余因果间隔于其中间，但久远相续开始，而未断灭，如《佛戒经》说：“假使百千劫，所作业不亡，因缘会遇时，果报还自受”。
    3、十二缘起与四谛的关系
    缘起十二支，支支相连，相互依存，环环扣接，令诸有情循环生死，无始无终。如《华严经·十地品》云：“佛子，此中无明爱取不断是烦恼道，行有不断是业道，余分不断是苦道”。可总摄为烦恼、业和苦三种之因果关系，又如龙树菩萨的《缘起心要论颂》云：“十二支差别，能仁说缘起，烦恼业及苦，尽摄三种中，初八九烦恼，二及十是业，余七皆是苦，十二法三摄，从三生于二，从二生于七，从七复生三，有轮数数转”。
    此十二有支，总摄为惑业苦三种。“惑”即烦恼，使有情相续而有起因；“业”即所作业障而为引生苦果之因；“苦”为苦果，是为连续引生有苦性之果。行、有二支为业，即三界有情如顺次循环相续而不绝，此即由集能招集苦果，烦恼与业为集，其余七支皆摄为苦。如是从无明、爱、取三烦恼，生起行、有二业；又从行、有二业生于识、名色、六处、触、受、生和老死七支的苦果；又从七苦生于三烦恼，复从三烦恼生于二业，由此使三有轮回，数数流转不息。如是轮转无有初、中、后、始终之别。列表如下：

    此十二缘起支，诸异生世间，虽然数数流转，次第生于三有，但不决定都具十二支。如在“名色”位命终，唯具二支，乃至“取”位命终，但具七支，以及出生后，中间夭亡命终者，则依情况不同而立支数。色无色界无有“名色支”，及“六入支”。
    十二缘起有流转与还灭二种缘起，为生死流转与解脱还灭二义。
    流转缘起，即十二缘起依无明生行，行生识等顺序次第生起，此称顺缘起、顺次缘起，即以顺序计算十二缘起。此属于流转生死的缘起，属染缘起，以苦集二谛所摄。
    还灭缘起，即十二缘起依无明灭则行灭，行灭则识等次第止息，此称逆缘起、逆次缘起，即逆次计算十二因缘。此属于还灭缘起，属于净缘起，以灭道二谛所摄。在《华严经·十地品》云：“复次无明缘行，无明因缘能生诸行，无明灭行灭者，以灭无明，诸行亦灭，余亦如是。又无明缘行者，是生系缚，无明行灭者，是灭系缚，余亦如是”。
    此十二支又分为三世，如《华严经·十地品》云：“复次无明缘行者是观过去，行乃至受是观现在，爱乃至有是观未来，于是以后展转相续，无明灭行灭是观待断”。经义是说：了知缘起性空无我、无人、无众生等，断除我执，证第一义谛，无有我执无明之所起因，无明则灭；无明灭已，余十一支亦灭，惑业苦无依处则得解脱灭谛涅槃。如龙树菩萨《缘起心要论颂》：“于真性见真，见真即解脱。”
    概括十二缘起，分为能引支、所引支、能成支、所成支四支，称为“缘起四支”如下：
1． 无明支┐此三支为能引支，能招引轮回，故名能引支，
    行 支 │又名能行支。
    识 支 ┘
2． 名色支┐此四支为所引支，以无明为缘起行，以行造业，
    六入支│以识染著习气，可招引之后果，故名所引支，
    触　支│又名所行支。
    受　支┘
3． 爱 支┐此三支为能成支，现前成就生支之故，
    取 支│名三能成支，又名现行支。
    有 支┘
4． 生 支┐此两支为所成支，依于生支及老死支，众生
          │各别出生等诸支，
    老死支┘故名二成就支，又名所成支。
    四有流转，如下所示：
    (1)本有：从结生入胎第二刹那起，至死有的前刹那，尚未舍身命时期的身心。
    (2)死有：正舍今生身命时或临命终时的刹那五蕴。
    (3)中有：死后未结生前，介于死有和生有之间的五蕴。
    (4)生有：中有结胎之间的一刹那所有之五蕴。

    四圣谛虽说是声闻种姓所修，但不能说不修十二缘起，只是以修四谛为主。十二缘起虽说是独觉种姓者所修，但不能说独觉不修四谛。因为独觉种姓在因位时闻佛说法亦修四谛，只是在最后生出于无佛之时，无师自证缘起之理而证涅槃。
    4、六度
    前面讲的四圣谛，十二缘起，为大小乘行者所共修，但在小乘契经中佛亦说有六度，以使小乘种姓能舍小转大，发菩提心，修菩萨行，成无上正等菩提，唯各处散说而不系统。大乘经中则广说六波罗蜜多等法，是大乘菩萨主要所修之法宝，二乘人所修的一切法，都摄入六波罗蜜多，菩萨修此六度而成就无上正等菩提。如圣龙树菩萨的《转有论》云：布施戒忍辱，精进静虑慧，恒修彼业者，速能得菩提”。是说六度即是大乘法，菩萨以修六度而成佛。又如圣龙树菩萨的《宝鬘论》云：“施戒忍进禅，智慧悲为体，此即是大乘，有何错误语。由戒施利他，进忍行自利，定慧解脱因，总摄大乘义。自他利解脱，总则佛圣教，六度中全有，因此是佛语。佛说菩提道，福智资粮体，此即是大乘，诸痴盲不忍”。又云：“一切佛色身，从福资粮生，大王、佛法身，由智资粮生。因此二资粮，即是成佛因，如是应常依，此福德智慧”。
    以上颂文，其义易了，例表如下：

    总上诸义，菩萨以大悲心为体，发愿菩提心及行菩提心入大乘门，受持愿行二种律仪，通达人法二种无我，修习三十七菩提分法，广行六度四摄，历经五道十地，圆满福智二种资粮，断尽二障，究竟证得佛位。
    （三）果法
    以上教法、道法解说竟。果法者即是有余依、无余依和无住涅槃。佛陀与无学声闻和独觉身心中的灭谛涅槃功德，及三乘有学圣者身心中的道谛功德，以为果位法宝。


三、僧宝

    僧谓僧伽，亦云和合众，即比丘众和比丘尼众。和合者，具有六义，亦名六合敬，谓僧伽以行六和敬而安住。
    六和者：1．身业和敬，谓共同礼拜等身业和敬；2．口业和敬，谓共同赞咏三宝等语业和敬；3．意业和敬，谓信心相同等之意业和敬；4．戒和敬，谓同一戒法、同一说戒、同一羯磨和敬；5．见和敬，谓共同信解空、无我，共同修行道谛，同证灭谛涅槃之见解和敬；6．利和敬，谓共同衣食等之利养和敬。如《仁王经》卷下云：“住在佛家修六和敬，所谓三业，同戒、同见、同行”。此谓僧伽若行六种和敬，即堪称为僧宝。
    僧宝可分为三：1.凡夫僧宝;；2.有学僧宝，3.无学僧宝。
    （一）凡夫僧：亦名异生僧，即未证圣位以前的僧伽，称为凡夫僧。如月称论师的《皈依七十颂》云：“若未生圣道，是凡夫异生，彼非学、无学，是诸论中说”。这是说明凡夫僧。此凡夫僧要受近圆戒，五人以上的比丘众，或比丘尼众，如法如律修行，如法羯磨，如法传戒(在边地有清净比丘五人即可传戒)，如法安居，如法诵戒的和合众，则称为僧宝。
    （二）有学僧：如月称论师的《皈依七十颂》云：“摧烦恼故学，七人是有学”。此谓从预流向至阿罗汉向七者为有学僧宝。
    (1)预流向：住于顺抉择分和见道十五刹那中者。
    (2)预流果：安住于见道八智之圣者，由永尽见道所断三结(我见结、戒禁取结、疑结)故。
    (3)一来向：向往一来果位，谓尚未断欲界第六品修所断烦恼而正策励断除者。
    (4)一来果：永断欲界第六品烦恼者。
    (5)不还向：励力修行断除欲界第七品至第九品修道所断烦恼者。
    (6)不还果：断除欲界后三品烦恼之残余，不再还欲界之位也。
    (7)阿罗汉向：勤行能断初禅乃至有顶之间一切烦恼之加行者。
    此上七行者因正在断烦恼故，名为有学僧宝。
    大乘圣僧从证八忍八智，位登初地，始称入如来家，绍隆佛种，乃至第十地菩萨，名为大乘有学僧宝。此依圣慈氏菩萨所著的《现观庄严论》，列二十种譬喻僧宝，即五种预流，三种一来，十种不还，阿罗汉向及麟喻独觉，以喻大乘菩萨圣位僧。因为菩萨不入无色界，不证阿罗汉果，立阿罗汉向以喻第七地菩萨为断尽烦恼障而精进修行。麟喻独觉喻十地菩萨，是由十地菩萨不依师教，以自然智而成正等菩提故。
    （三）无学僧：亦名真实僧宝，或称第一义谛僧，无为僧。此即烦恼已尽，所作已办，梵行已立，不受后有的圣位阿罗汉，名为无学僧宝。如月称论师著的《皈依七十颂》云：“尽无余过故，第八说无学”。此无学僧只限于小乘的阿罗汉果。大乘圣者至第十地菩萨属于有学僧，成就无上正等菩提者为佛宝所摄。
    独觉圣人分为二种：一是部行独觉，谓同时多人出世修道而证无学位者；二是麟角喻独觉，谓此独觉圣人出世证无学位时，唯独一人，犹如麟角，更无第二者，这二种独觉圣者，都是出于无佛法之时，其共同点都不说法，以神通变化示现一些境界化导众生，由于都出于无佛之时，又不说法，一般不列于僧数。二十种譬喻僧者，列表如下：

阿罗汉向：为欲尽断烦恼障而精进修行七地菩萨。
麟喻独觉：喻十地菩萨，不依师教，以自然智而证菩提故。


第三、皈依三宝的建立

    第三、皈依三宝的建立

                    一、抄经
          《大乘理趣六波罗蜜多经》（卷一）
                唐罽宾国三藏般若奉诏译

皈依三宝品第一
    如是我闻，一时薄伽梵，在王舍大城迦兰多迦竹林精舍，时与众多菩萨摩诃萨，住不退转，位阶十地，十波罗蜜多悉已圆满；复有众多诸大苾芻，皆阿罗汉，诸漏已尽无复烦恼，逮得己利心善解脱，慧善解脱；复有阿僧企耶诸有情等，皆发阿耨多罗三藐三菩提心。
    尔时慈氏菩萨摩诃萨，于此会中而作是念：此会众中诸有情类，贫穷孤露无所依怙，流转生死沈溺爱河，欲达彼岸为闻法故，愿见世尊求一切智无有力能。尔时慈氏菩萨，为欲谘问甚深义趣，一切有情云何发菩提心，求佛决定三无数劫无有疲倦，今佛世尊意趣难解，广大甚深，文句巧妙具足圆满，记别有情因果差别。希求速疾无上菩提。
    于是弥勒菩萨摩诃萨发如是心，即从座起整理衣服，善调六根，身口意业皆悉寂静。然其六根，百福所生，妙相庄严，八十种好，三无数劫之所圆满，摩诃般若波罗蜜多等，百千万日光明相庄严其身，一切有情瞻仰无厌，近无等等佛果菩提。以如是身往诣佛所，五体投地礼佛双足，又以无量功德庄严之手，如新生莲华，合掌恭敬而白佛言：如来世尊于一念中，能知一切有情过去未来现在之心，或有有情因谘问时获清净心；或有有情受记之时，获须陀洹果乃至阿罗汉果，辟支佛果；或得阿耨多罗三藐三菩提记，为此义故仰谘如来，惟愿世尊分别解说。世尊今为三世有情所依之主，或有有情行大乘行，其心柔和，唯愿世尊慈悲愍念，获甘露法不独受用而同其味。云何令诸有情趣大涅槃安稳正路，此等有情当作何事，于一切智得不退转？云何圆满檀波罗蜜乃至般若波罗蜜多？又此般若波罗蜜多，与前五种波罗蜜多而为其母，云何修习而能圆满？又此大愿云何显发？又诸有情云何修习涅槃彼岸？唯愿世尊分别解说，为欲利益安乐一切有情令得欢喜。
    尔时薄伽梵赞慈氏菩萨摩诃萨言：善哉善哉，善男子，汝今乃能利益安乐一切有情，问是深义，劝诸有情修善业故，常为有情勤修习故；汝今一心广为有情，顿绝羁锁勤求法故；汝今以此大慈悲心，于三阿僧企耶，圆满六种波罗蜜多大海法故；汝今已近菩提道场涅槃岸故，犹如明星没已旭日便照，汝今亦尔当作佛日，汝今谛听，善思念之，我今为汝具足分别甚深之义。
    如有智人能善思惟，观察生死险道之中，莫能过于无所依怙。譬如大海舟船而无商主，其中有情多所漂溺，涌浪洄澓，破坏沈没，种种诸难，常有忧患，求于吉祥无上船师以为依怙。
    又诸有情于生死中常多恐惧，所以求于力势之人而为恃怙，不被怨贼之所侵害，纵彼怨贼有大狂力，为此之人依附王者，而彼怨贼必无更能作损害者；又彼怨贼既见力势，永舍怨心顺从正化。一切有情亦复如是，各作是念谁能与我作皈依处。除其衰患令得安乐。于此三界五道之中，天、龙、药叉、阿苏罗、迦噜啰、健达婆、紧捺罗、摩怙洛迦、人非人等诸众之中，而求觅之无有能作皈依者。所以者何，彼诸天等自未能免生死羁锁。烦恼系缚流转三界，无量无边众苦吞啖诸怖畏事，以贪欲网之所缠缚，况能为我作归依处。又诸天等常被甲胄斗战之具，心怀怖畏彼阿苏罗，而况于人及余诸趣，以是观察三界六道，无有堪能拔济我者，以是应当皈依佛法僧，除佛法僧更无有能救护我者。一切有情若欲求于阿耨多罗三藐三菩提涅槃乐者，应当皈依佛法僧宝，以是因缘令诸有情归佛法僧。
    尔时慈氏菩萨摩诃萨，白佛言：世尊，云何名为佛法僧宝，云何皈依？佛告慈氏言：佛宝者则有二种，一者佛身；二者佛德。
    言佛身者，所谓如来、应供、正遍知、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊，已于过去无量无边阿僧祗劫，不惜身命勤修六度，万行圆满，菩提树下坐金刚座，降伏魔军断诸结贼，获一切智成等正觉，具足如是诸妙功德，号之为佛。
    言佛德者，即佛身中，具足十力四无所畏十八不共法，大慈大悲大喜大舍、三解脱门、三示导、六神通、随心三摩地、四智二智、离于知境，断烦恼障及所知障，离诸习气，无功用道起如如化，若远若近游止自在无有障碍，于一芥子能纳无量诸妙高山，如是功德无量无边，诸佛如来悉皆具足；又从一劫至无量劫，寿命自在无能损减，于神境通往来变现，无有障碍随意自在。诸佛世尊之所经行城邑聚落，先放微妙金色光明照曜其处，其中众生遇斯光者，身病心病皆得除愈，心火灭已身得清凉，偻者能申，跛者能行，盲者得视，聋者能听，哑者能言。其心乱者便复本心，鬼魅癫狂魍魉所持悉皆除愈，裸者得衣，憍慢心者而得谦下，忧恼者心安隐，失道者得正路，饥渴者得饮食，囚系者得解脱，恐怖者得无畏，丘陵坑坎、山涧堆阜，皆悉平正犹如抵掌。门第卑小自然高大，衢路隘狭并皆宽广，市肆廛里自然开豁，秽恶不净应时香洁，荆棘毒刺瓦砾沙石悉皆不现，日光晃曜而无炎毒，香风和畅无诸尘坌，白鹤孔雀、鹦鹉舍利、迦陵频伽、拘枳罗、拘那罗、命命等鸟，其声美妙出和雅音。象马牛羊，水牛、犛牛、犎牛、竹牛，各出本音其音微妙。箜篌萧笛琴瑟鼓吹，如是乐器不鼓自鸣，及余种种巧妙希奇，诸神通事，悉皆变现。如是种种诸希有事，日日各异转加殊胜，皆是如来威神之力。
    若有众生疑佛世尊及佛功德有一异者，当作是说，佛与功德不一不异。譬如燃灯膏炷与明不一不异，离于膏炷无别灯明，若言灯明离膏炷者，明所及处悉应焚爇。佛身功德亦复如是。此微妙身是佛功德无漏法身，自他受用平等所依。然此佛身亦非是体，离是体外无别法身。若是体者同于外物有四大相，故知非相亦非无相。若非相者同太虚空，同太虚者性即是常，无方便过，自性清净无染无著，甚深无量，无有变易。难解难知微妙寂静，具无边际真常功德，绝诸戏论，唯佛证知非余所及，亦非譬喻之所校量。慈氏当知，如此身者，即是过去未来现在殑伽沙等诸佛世尊法身之相。
    佛报身者，谓诸如来三无数劫，修集无量福慧资粮，所起无边真实功德。常住不变诸根相好，智慧光明周遍法界，皆从出世无漏善根之所生故。不可思议超过世智，纯熟有情为现兹相，演无尽法广利无边，慈氏当知，此即如来报身圆满。
    言化身者，为彼有情随所应化，故现无量阿僧企耶诸化佛身。其所化身或于地狱以现其身，度彼有情令离众苦，导以正法令发胜心，便生人天受胜快乐，于佛法中深生信乐，得佛法分获圣道果；或生鬼趣化彼有情，令离饥渴种种逼迫，化以正法使发胜心，便生人天受诸快乐，深入佛法得圣道果；或化傍生在于彼趣，或作迦噜啰身或作龙身，或作狮子象马熊罴、虎豹豺狼野犴狐兔。螈蛇蝮蝎、鱼憋鼋鼍、白鹤孔雀凤凰鸳鸯鹦鹉舍利种种之身，令诸有情离相残害，慈心相向，能离种种诸怖畏事，示以正法令深信乐，归佛法僧，得生人天获诸快乐，得佛法分证圣道果。
    或化有情于余国土，或日月光所不能照，如是种种无佛法处建立正法，令诸有情归佛法僧。剃除须发受佛禁戒，而作苾芻及苾芻尼，或作邬波索迦邬波斯迦，建立僧坊护持正法。安立无量无数有情，置于人天涅槃彼岸而得果证。或生天趣化彼有情，令离五欲心无染著，导以正法发菩提心，归佛法僧深入正法，置于涅槃解脱果证。
    或生人趣现处王宫生释种家，以巧方便化诸有情，断除三界烦恼忧患生老病死，故现受生逾城出家，菩提树下取吉祥草，坐于道场处金刚座，降伏魔军成等正觉，为化有情转正法轮，放大光明周遍一切照曜世间，自利利他悉皆圆满，或现寂静入大涅槃，是即名为佛化身也。如是种种善巧方便无量无边，皆是如来自在神力，此即三身体无异相。
    尔时薄伽梵告慈氏菩萨摩诃萨言：善男子，于意云何？若有善男子善女人皈依佛者，当皈依诸佛清净法身，若欲求于佛法身者，当作如是发大誓愿：愿我及彼一切有情，当得如是功德法身。云何乃令发如是愿，为佛应身刹那迁变，化身佛者疾入涅槃，功德法身湛然常住，以是皈依清净法身，归法身者即是皈依过去未来现在诸佛，若我舍于众生取涅槃者，即同受于地狱诸苦，若与有情同解脱者，虽处地狱无异涅槃，以是因缘令诸众生，归佛法身证涅槃乐，究竟如如体无增减，如是法身是真安乐，是故但令归佛法身。
    复次慈氏，云何名为清净法宝，言法宝者亦有三种。云何为三？第一法宝，所谓涅槃甘露解脱，常乐我净而为体性，能尽一切生老病死忧悲苦恼。
    云何生苦？谓依父母牉合之时，不净种子处母胎中，业力风持时经九月，住居黑暗无有光明，生熟藏间污秽不净，八万户虫之所和杂，出息入息随母而行，口不能言眼不得视，饥渴寒热种种诸苦逼切身心，如是诸苦无量无边，令诸众生不得自在故名生苦。虽受此苦而有一德，一切怨家所不能见，亦不能说是非过恶，无比涅槃安乐法中无如是苦。
    云何老苦？所谓众生从少至老时节代谢，所有充实悉皆损减，筋力衰朽行止战掉，发白面皱，眼耳昏暗牙齿疏缺，颜貌丑陋身相伛偻人所恶贱，所有言教随说废忘，而以此身为其重担。譬如燃灯膏油既尽，不久将灭，老亦如是。壮膏既尽不久将死。又如苏莫遮冒覆人面首，令诸有情见即戏弄，老苏莫遮亦复如是。从一城邑至一城邑，一切众生被衰老冒，见皆戏弄，以是因缘老为大苦。除非死至无药能治，虽受老苦而不厌之，祈祷神祗恒愿长寿，无比涅槃安乐法中无此老苦。
    云何病苦？所谓地水火风互相违害，种种诸苦来集其身，一切众生无问老少皆共有之，安乐适身、胜妙五欲，金银珍宝，家族眷属悉皆舍离，所有教诏，男女亲戚，皆不承顺，一切怨家诈来亲附，如此病苦皆不愿求，以是当知病为大苦，安乐涅槃无比法中，清净寂然无斯病苦。
    复次慈氏，云何死苦？所谓众生气绝识灭无所觉知，一切苦中莫过死苦，生老病苦五趣之中有无不定，此死苦者皆共有之。譬如贫苦能劫荣华，如怨憎苦能劫亲爱，死苦若至不拣老少，愚智贵贱一切尽劫。舍此身已入幽暗处，衣服卧具一切财宝莫能用之，裸露而行，复无伴侣，货财不免披诉无地，咄哉！无常，能作斯害，甚大鄙恶不拣怨亲，三界众生无能免离，皆被死伐何能救之，设转轮王那罗延力皆被擒获，当知死苦无量无边，以是观之死为大苦。解脱涅槃无比法中，寂静安乐无兹死苦。譬如有人瀑河漂溺，登陟高山得免怖畏。众生亦尔常为一切生死瀑河之所漂溺，登涅槃山离生死畏，亦如天雨能除毒热尘秽等障，人民安乐身意清凉，百卉滋茂成就果实，如来法雨亦复如是，能除一切烦恼毒热，众生安乐解脱清凉，滋长一切白净善种，成就果实令得涅槃，以是因缘，诸佛世尊舍无常身证涅槃乐。
    尔时世尊欲重宣此义，而说偈言：
        如来妙体即法身　清净解脱同真谛
        如日与光不相离　如来功德即涅槃
        真我与佛无差别　一切有情所归趣
        生死涅槃等无二　其性不坏无造作
        垢净如如性不异　唯佛世尊独能了
        众生悉有如来藏　三宝于是现世间
        一切有情入佛智　以性清净无别故
        佛与众生性不异　凡夫见异圣无差
        一切众生本清净　三世如来同演说
        其性垢净本无二　众生与佛无差别
        空遍十方无分别　心性平等亦复然
        譬如一切众生界　遍在虚空受生灭
        诸根生灭亦如是　处在无为界亦然
        譬如虚空火不烧　生死不坏无为性
        地水风轮转相依　虚空无有所依相
        蕴处界三亦复然　恒住业种烦恼性
        彼业烦恼住何处　常居妄想无明源
        妄想之心何所居　恒在无为净心性
        蕴处界三假施设　一切法性本无住
        业惑相持如地水　妄想转动犹如风
        心性本净如虚空　妄想依空无所有
        烦恼业苦从妄起　业苦还为烦恼因
        惑业循环无定居　无因无缘无所会
        无生无灭性空寂　本体光明智清净
        自性无生无变异　烦恼无明垢所覆
        亦如翳眼见二月　众生二执亦复然
        烦恼犹如众蜜蜂　其蜜即喻如来藏
        此蜜众蜂共围绕　智者护身能取蜜
        无相六度为方便　而能证彼法界身
        譬如五谷糟未除　不堪与人充美膳
        菩萨烦恼糠未遣　不能施人甘露饭
        行人遗宝落秽处　设经万岁无损污
        天眼见宝知所在　收取洗拭随意用
        佛见众生性无二　为欲涤除烦恼秽
        大乘甘露而为水　涤尽尘劳佛性现
        譬如新生五谷芽　说米有无未决定
        佛性不离有无中　唯佛自证方明了
        法宝自性恒清净　诸佛世尊如是说
        客尘烦恼之所覆　如云能翳日光明
        无垢法宝众德备　常乐我净悉圆满
        法性清净云何求　无分别智而能证
        譬如池水净无垢　其中莲花妙无染
        如月蚀已重光明　亦如皎日出云翳
        无垢功德遍庄严　涤除烦恼光明现
    佛告慈氏，当知第一法宝，即是摩诃般若解脱法身。
    复次慈氏，应知第二法宝者，谓即戒定智慧诸妙功德，所谓三十七菩提分法，谓四念住、四正断、四神足、五根、五力、七觉分、八圣道。此三十七法与前清净法宝而为方便。云何方便？以修此法而能证彼清净法身。当知此即第二法宝。
    复次慈氏，云何名为第三法宝？所谓过去无量殑伽沙诸佛世尊所说正法，我今亦当作如是说，所谓八万四千诸妙法蕴，调伏纯熟有缘众生，而令阿难陀等诸大弟子，一闻于耳皆悉忆持，摄为五分：一素呾缆，二毗奈耶，三阿毗达磨，四般若波罗蜜多，五陀罗尼门，此五种藏教化有情，随所应度而为说之。若彼有情乐处山林，常居闲寂修静虑者，而为彼说素呾缆藏；若彼有情乐习威仪，护持正法一味和合，令得久住，而为彼说毗奈耶藏；若彼有情乐说正法分别性相，循环研覈究竟甚深，而为彼说阿毗达磨藏；若彼有情乐习大乘真实智慧，离于我法执著分别，而为彼说般若波罗蜜多藏；若彼有情不能受持契经调伏对法般若，或复有情造诸恶业，四重、八重、五无间罪、谤方等经，一阐提等种种重罪，使得销灭速疾解脱，顿悟涅槃，而为彼说诸陀罗尼藏。此五法藏譬如乳、酪、生酥、熟酥及妙醍醐。契经如乳；调伏如酪；对法教者如彼生酥；大乘般若犹如熟酥；总持门者譬如醍醐。醍醐之味乳酪酥中微妙第一，能除诸病，令诸有情身心安乐。总持门者契经等中最为第一，能除重罪令众生解脱生死，速证涅槃安乐法身。
    复次慈氏，我灭度后，令阿难陀受持所说素呾缆藏；其邬波离受持所说毗奈耶藏；迦多衍那受持所说阿毗达磨藏；曼殊师利菩萨受持所说大乘般若波罗蜜多；其金刚手菩萨，受持所说甚深微妙诸总持门。如是教门能除有情生死烦恼长夜黑暗，速能出离证解脱果。譬如明灯能除暗暝使得见道，佛亦如是，燃智慧炬能照有情十不善暗，使见善道。设彼有情悭吝财宝，闻此法已，便能惠施一切贫穷，若有恶业众生，闻此法已，舍恶修善，若瞋恚者便能忍辱，懈惰有情闻已精进，散乱众生闻已寂静，愚痴有情闻是法已便发智慧，得智慧已悉能回心修种种善，又诸有情闻此法已，闭恶趣门开涅槃路，犹如甘露证解脱果，当知此即第三法宝。
    是三法宝，一切众生应当皈依无为法宝。一切法中最尊最胜莫过无为，何以故？以于生死大苦海中能为船筏，能作有情甘露良药。又是殑伽沙等诸佛菩萨，三无数劫六度万行所证之果。如是妙法功德圆满，以是皈依无为法宝。若有众生受持经者当发是愿：愿我皈依如是法宝。归是法已，愿令五道一切众生，亦发是愿，我今皈依，亦令有情安住于此功德法中，引至涅槃真实宝所。慈氏当知，此即名为第三法宝。
    复次慈氏，云何名为真实僧宝？言僧宝者亦有三种，一者第一义僧，所谓诸佛圣僧如法而住，不可睹见，不可捉持。不可破坏，无能烧害不可思议，一切众生良祐福田，虽为福田无所受取，诸功德法常不变易，如是名为第一义僧。
    第二圣僧者，谓须陀洹向须陀洹果，斯陀含向斯陀含果，阿那含向阿那含果，阿罗汉向阿罗汉果，辟支佛向辟支佛果，八大人觉三贤十圣，如是名为第二僧宝。
    第三福田僧者，所谓苾芻、苾芻尼等，受持禁戒，多闻智慧，犹天意树能荫众生，又如旷野碛中渴乏须水，遇天甘雨霈然洪霔应时充足，又如大海一切众宝皆出其中，福田僧宝亦复如是，能与有情安隐快乐。又此僧宝清净无染，能灭众生贪瞋痴暗。如十五日夜满月光明，一切有情无不瞻仰，亦如摩尼宝珠能满有情一切善愿，如是名为第三僧宝。
    是三僧宝一切有情云何皈依？应作是说，当令归依第一义谛无为僧宝，所以者何？以是无为常住僧故，而此僧宝无漏无为，不变不异自证之法，皈依如是无漏僧宝，能灭有情一切苦故。复愿有情当获如是无漏功德，得此法已演三乘法度脱有情，我所皈依佛法僧宝，不为怖畏三恶道苦，亦不愿乐生于人天，誓救有情出生死苦，是则名为皈依僧宝。
    复次慈氏，若有众生，皈依三宝应发是心：我今此身已生人趣，得离八难，难得能得，以善方便当习一切胜妙之法，若我违于如是上愿，不求善法则为自欺，亦如有人乘船入海，至于宝所空手而归，如是皈依佛法僧宝脱苦方便，若不皈依后悔何及！既知是已当须勉励，精勤修习速愿成就，善法既成，过去罪愆，应当忏悔使令除灭。
    复作是说，我从无始生死已来，身口意业所作众罪无量无边，皆从虚妄颠倒心起，而于父母和尚师长，佛法僧宝尊重之境，所作诸罪今皆忏悔，复为二事造作诸罪，极重恶业如妙高山。云何为二？一者亲爱，二者怨嫌。若于生死急难之中而彼二类怨亲有情，而于我身不能利益，应作如是遍观察之，彼与我身悉归磨灭，而我云何乃作斯罪。
    又于十方世界一切有情造诸善业，及学无学独觉声闻佛，及弟子一切贤圣我皆随喜。
    复次，于无始际生死轮转受五趣身。无量怨亲于我未曾获得毫氂利益之事，现在未来亦不可得，我于无始为彼怨亲所作诸罪我愿自受，誓不扰他一切众生。若我重患之时求亲爱人，慈心瞻省扶侍我身。摩抆沐浴供给饮食，病瘦医药种种相资，虽则如斯而于我身病苦之中无相代者，况于未来而能救我生死大苦。而我此身于现世中无依无怙，何况未来，我身既然，有情亦尔，自我及他皆无恃怙，是故皈依真实三宝，何以故？以常住故。譬如有智之人于险难中，求有力者以为救护，众生亦尔，生死险难，皈依三宝以为其主，方能越渡生死大河，我若得已亦为其主，覆护一切苦难众生。能发如是大誓愿者，得大信心而于佛前，长跪合掌偏露右肩，作是皈依佛法僧宝。譬如世间贫贱之人，一切有情见皆轻蔑，策役驱使种种呵骂，凌辱其身，既被轻贱，遂求尊贵有力之人以为其主，便能免离种种欺辱。有情亦尔，或生恶趣及在人中，恒被诸苦逼迫其身，为求免离皈依三宝。如是诸苦悉得解脱。
    归三宝已，复发是愿：愿我救护一切众生，渡生死海到涅槃岸，如大商主导诸商人，度大旷野沙碛险路至无畏处。三宝导师亦复如是，导引有情度空旷处生死长夜，至大涅槃得无所畏。慈氏当知，发心修行大乘行者，应作如是皈依三宝。


二、抄经

二、抄经《增壹阿含经》（卷十二）

          《增壹阿含经》（卷十二）三宝品
    如是我闻，一时佛在舍卫国祗树给孤独园。尔时世尊告诸比丘，有三自归之德，云何为三？所谓归佛第一之德，归法第二之德，归僧第三之德，彼云何名为归佛之德？诸有众生，二足四足众多足者，有色无色，有想无想，至尼维先天上，如来于中最尊最上无能及者。由牛得乳，由乳得酪，由酪得酥，由酥得醍醐，于中最尊最上无能及者。此亦如是，诸有众生，二足多足众多足者，有色无色，有想无想，至尼维先天上，如来于中最尊最上无能及者，诸有众生承事佛者，是谓承事第一之德，以获第一之德，便受天上人中之福，此名第一之德。
    云何名为自归法者？所谓诸法，有漏无漏有为无为，无欲无染灭尽涅槃，然涅槃法于诸法中最尊最上无能及者。由牛得乳，由乳得酪，由酪得酥，由酥得醍醐。然复醍醐于中最尊最上无能及者，此亦如是。所谓诸法有漏无漏有为无为，无欲无染灭尽涅槃，然涅槃法，于诸法中最尊最上无能及者，诸有众生承事法者，是谓承事第一之德，以获第一之德，便受天上人中之福，此名第一之德。
    云何名为自归圣众？所谓圣众，大众大聚有形之类，众生之中，如来众僧于此中最尊最上无能及者。由牛得乳，由乳得酪，由酪得酥，由酥得醍醐。然复醍醐于中最尊最上无能及者，此亦如是。所谓圣众者，大众大聚者，有形之类众生之中，如来众僧于此众中最尊最上无能及者，是谓承事第一之德，以获第一之德，便受天上人中之福，此名第一之德。
    尔时世尊便说此偈：
        第一承事佛　　 最尊无有上
        次复承事法 　　无欲无所著
        敬奉贤圣众　　 最是良福田
        彼人第一智 　　受福最在前
        若在天人中 　　处众为正导
        亦得最妙座　　 自然食甘露
        身著七宝衣 　　为人之所敬
        具戒最完全 　　诸根不缺漏
        亦获智慧海　　 渐至涅槃界
        有此三归者 　　趣道亦不难
    尔时诸比丘闻佛所说，欢喜奉行。


三、译论/依论释经皈依三宝的建立

    教授三宝分二：（一）总义，（二）支分义。
    （一）总义分四：一认识不共三宝，二皈依总建立，三世俗与胜义皈依之差别，四如何皈依之理趣。
    1．认识不共之三宝：如《宝性论》云：“无为任运成，非他缘能证，智悲力具足，二利具足佛。”是说二利圆满，三身自体具足，是名佛宝。上论云：“无思无二无分别，清净显明对治品，谁能离贪所有著，彼即二谛相有法。”是说具足清净二谛性相，即是法宝。上论云：“如尽所有内，智观清净故，圣者不退众，无上功德体。”是说具足解脱智见功德，是不退僧宝。
    2．皈依总建立：《宝性论》云：“学佛教法义，三乘作用三，从胜解增上，建立三皈依。”于彼总的说来，契经中所说，是显建立三皈依的所为者，当知已入大乘种姓道，在自己身心中所得的佛果皈依，及修行成就所摄的佛因皈依。其余声闻独觉二种姓亦有因皈依；虽然未入道，但能于佛供养承事等作殊胜事业，由能以信解为增上而建立皈依佛宝。已入独觉种姓道，在最后有时，不依他教希求自得涅槃等为果皈依；虽然未入道，但能于妙法作殊胜事业，由诸信胜解为增上，即是建立皈依法宝。已入声闻种姓道，在最后有时，依随顺他教希求得涅槃等，是名果皈依；虽然未入道但能于僧众做殊胜事业，由诸信胜解为增上，即是建立皈依僧宝，在自身心中虽不希求所得，然于谁皈依的法宝和僧宝，观待彼当知为因皈依。依建立大乘不共三皈依，对其余二种姓（声闻独觉），亦应了知因三皈依及二种果皈依，此乃显示诸经中所说总建立三皈依的所为。
    3．世俗与胜义皈依之差别：《宝性论》云：“断故妄法故，无故有畏故，二种法圣众，终非胜皈依。”是说于彼世俗和胜义皈依义者，谓如定姓声闻，在自己意乐心前，唯求寂灭生死苦，除彼以外，执为不需希求上进，住实有法以为道行，即非究竟皈依者，是名世俗皈依；虽在意乐前执为究竟行，但于彼义是究竟的胜义皈依义，亦不是修行教法等究竟的法身，于谁补特伽罗亦无欲乐了知，唯不合理。是故虽是大乘教法，但非胜义皈依者，谓仅是显示义现观的方便，若已得义现观究竟，则不需要得彼尚未得的方便，犹如船筏唯所应舍。于此，总的来说，全面辨别是修行的支分，不是主要义。圣者菩萨身心中现证无我的般若智慧者，谓在观见前虽然似现远离一切垢染，但未尽一切垢染，于自性垢染尚未灭除，于彼显现境未尽一切垢染自性，是故是空聚虚诳的有法，显然不是胜义皈依。若是有为法，许为悉非究竟皈依者，谓佛的道谛，及两种色身是究竟皈依，当知一般是为灭除邪执分别，应长久断除。对于声闻乘的理趣，谓声闻无余涅槃，不是究竟皈依，因为仅无苦集所显故，由此未尽所知障的怖畏还能引发作用，于声闻独觉阿罗汉行相，如执剑刽子手有所知障的怖畏。是故胜义皈依者，如《宝性论》云：“趣入于胜义，皈依唯佛陀，能仁法身故，资粮究竟故。”是说唯有具足三身自体的佛是胜义皈依。
    4．如何皈依之轨则：当善了知诸经所说三宝的功德，及略抉择皈依三宝所学之次第。总的说来，自己观生死过患；特别是观恶趣过患，善于思惟，意念怖畏。依此二因了知唯有三宝乃有离怖救护之功能，对于三宝系心思惟，观待其心依止之皈依意善调柔以为前行，于皈依学处应如法修学。若如是作，随佛悲心令功德展转向上增长，于此已得坚固暇满之身，心意极善调柔皈依。若无希求，纵于闻思修能精进者其果极小。此处正说者是谓建立大乘三皈依，其后以清净信心所缘佛功德等，是显皈依的境。
    （一） 支分义分三：
    1．教授佛宝：教授佛宝者，谓菩萨修行般若波罗蜜多时，于色不作一切相智行，因真实中不见色等，是为于佛宝断除实执之教诫，因为了知所缘能缘谛空平等性的究竟智，是教诫佛宝故。应是这样，因为一切相智在胜义中不可得，教诫于色等境与有境心，性相与所表，界与见在胜义中无行无所著故，于一切相智教授即是于佛教授，因为是能表一切相智佛法的性相故。一切相智在胜义中不可得，佛与二种清净具足菩提清净皆谛空一相。
    2．教授法宝：教授法宝者谓不行色有法，不行色无法等，显示教授法宝，因为由三智所摄境，即体、对治和行相所摄一切，即总摄一切法在胜义中皆无自性故。
    3．教授僧宝：教授僧宝谓指圣者菩萨有学不退僧，入胜义中无生性。教诫传经说法僧，是为教诫破除实执僧宝修作助伴故。问：僧亦有多种行相，因住果有三，向有四种之差别，七大士圣位菩萨及独觉共有八种圣僧「有法」，应有多种差别，因为有利钝根差别，其数有二十种故，岂不都是住果向八种圣僧吗？答：除大乘阿罗汉不属此处僧宝内所摄，因为属于佛宝。对于三宝是为破除在胜义中耽著皈依。
    （译自甲操杰大师所著《现观庄严论释·心要庄严疏》）
    《现观庄严论》云：“佛陀等三宝，”是说开示教授三宝为修行的所依境。此中分《般若经》中所说之理，及由论释之理二种。今初佛宝，如《般若经》云：“复次舍利子，修行般若波罗密多时，于色不作一切相智行，如是于真实中不见色性”。二如《论》释经义云：“佛陀等三宝。此是就经的词义门而释，于佛与佛陀”。此分别释与略义二种。
    1．别释，分教授佛宝、教授法宝、教授僧宝三种。第一教授佛宝，如《般若经》云：“菩萨摩诃萨修行般若波罗密多时，于色”乃至“菩萨，一切相智者谓菩提，舍利子，菩萨摩诃萨应如是精进”。经义是说，于佛陀与菩提以清净相一性，为修行佛法相一切相智皆不可得，不行于色等，当如是能缘所缘平等性。其义是说，“于色不作一切相智行”等经「有法」，是教授佛宝，是为破除于彼佛宝真皈依处执为谛实故而教授，是经的词义故。
    第二教授法宝，如经云：“复次舍利子，菩萨摩诃萨修行般若波罗蜜多时，于真实中不见色有法，真实中不见色无法”乃至“不生恶慧心”。《论》释经义，谓于法由三智性所摄，由体、对治以及所有一切行相所摄的一切法皆无自性。其义是说，“不行色有法”等经「有法」，是教授法宝，是为破除作证彼法宝执为谛实故而教授，是经的词义故。
    第三教授僧宝，除以上所说诸大菩萨修行般若波罗密多所余已，“具寿舍利子白佛言：世尊，菩萨摩诃萨住般若波罗密多，从何处没来生此间，从此没当生何处。佛告具寿舍利子，舍利子，菩萨摩诃萨安住此般若波罗蜜多，有从余佛国土没来生此间，有从睹史多天没来生此间。”《论》释经义，所摄于此僧伽属于佛宝，除阿罗汉，由有住四果四向之差别，七圣位菩萨及麟角喻独觉合为八种，由于有利钝根等之差别，说为趣入无生二十种住圣位菩萨有学不退僧。其义是说，菩萨摩诃萨“从何处没而生此间”，等经义「有法」，是教授僧宝，是为破除于彼僧宝修行善友执为谛实故而教授，是经的词义故。
    2．略义，谓开示教授三宝
    观察此处经义，可分为三种，一依《宝性论》中所说轨则；二依《大乘庄严经论》中所说轨则；三受持修行之次第轨则。
    (l)依《宝性论》中所说轨则分四：①辨别不共三宝；②释皈依总建立；③释世俗皈依和胜义皈依之差别；④释宝的名义。
    ①辨别不共三宝，谓具有八种无为等功德的究竟皈依处，是佛宝的定相。其差别分为世俗佛宝和胜义二种。世俗佛宝，如佛的报、化二种色身；胜义佛宝，如佛的法自性身和智慧法身。如《宝性论》云：“自性圆满住，是为胜义身，诸仙称号身，波罗密圆处”。立量云：佛宝「有法」具有八种功德，<1>远离生灭的无为功德；<2>息灭有功用行的任运成就功德；<3>于内心自显现境不是由似现能诠声及分别心所能如实通达的功德；<4>如所有智和尽所智的功德；<5>大悲心的功德；<6>势力作用功德；<7>自利功德；<8>利他功德。如《宝性论》云：“无为任运成，非他缘能证，智慧势力具，二利具足佛”。此若略说，可摄为二，初三种是自利功德，后三种是利他功德，如《宝性论》云：“初三句自利，后三句利他”。
    无思等八种功德随一具足的圣者身心中的清净谛（四清净：自性清净、所缘清净、成办清净和证得清净）。是法宝的定相。其差别，从言诠正理门可分为世俗法宝和胜义法宝两种。初世俗法宝，如十二部契经；二胜义法宝，如灭谛与道谛。立量云：大乘法宝「有法」，具有八种功德：<1>非由四句分别心所能如实思惟的功德；<2>无有业及烦恼随一种类的功德；<3>无有非如理作意分别的功德；<4>道体障碍及不共法悉皆清净的功德；<5>显示如所有智和尽所有智的功德；<6>具有能对治(能对治烦恼等方法)所对治(实执障碍和烦恼等)的功德；<7>具有远离所有贪著的灭谛功德；<8>具有谁能远离贪欲的道谛功德。如《宝性论》云：“无思无二无分别，清净显明对治品，谁能离所有贪著，彼即二谛相有法”。此若略说，可摄为二，初三种是灭谛的功德，后三种为道谛的功德。如《宝性论》云：“二离贪者灭，道谛清净摄”。
    具有解脱智八种功德随一的圣补特伽罗，是僧宝的定相。其差别，从言诠正理门可分为世俗僧宝和胜义僧宝二种。初世俗僧宝与圣补特伽罗是一义；二胜义僧宝，如(圣者身心中的)灭谛与道谛。立量云：大乘僧宝「有法」，具有八种功德，<1>如所有智的功德；<2>尽所有智的功德；<3>内明处的功德;<4>、<5>、<6>三种随其自己根性贪、著、劣三种随类悉皆清净的三种功德；<7>智功能；<8>解脱功德。如《宝性论》云：“如尽所有内，智观清净故，圣者不退众，无上功德体”。此若略说，可摄为二，初三种摄为智明处功德；后三种摄为解脱功德。
    ②释皈依总建立。如《宝性论》云：“学佛教法义，三乘作用三，三胜解增上，建立三皈依”。其义，立量云：总的说来，佛经中所说三皈依的建立「有法」，是有所为(目的、宗旨)的，因为是诸菩萨趣入大乘道，自己所得佛果的皈依处；其余众生身心中修行所摄的佛是因的皈依处；以及其余声闻独觉二种种姓亦是因的皈依处；虽然未入道，但能信解恭敬供养佛宝，作诸殊胜事业为增上，是为建立皈依佛宝。已入独觉种姓道所得的果位，及虽然未入道，但能信解正法作诸殊胜事业为增上，是为建立皈依法宝。已入声闻种姓道所得的果位，及虽然未入道，但能信解僧宝作诸殊胜事业为增上，是为建立皈依僧宝故。以三种正因成立：佛宝是两足尊之殊胜，法宝是离诸贪欲之殊胜，僧宝是和合众的殊胜故。
    ③释世俗皈依和胜义皈依之差别。此分世俗皈依及胜义皈依二种。
    <1>世俗皈依。如《宝性论》云：“断故妄法故，无故有畏故，二种法圣众，终非胜皈依”。其义，立量云：由所化众生身心中所摄的十二分教「有法」，非究竟皈依，因为现证教义究竟时犹如船筏所应舍故。又如《大乘庄严经论》云：“由知义诸法，正理如船筏”。又如《宝性论释》云：“法者有二种，谓教法及证法，此中教法者谓言说经等教法，由名句文声所摄，彼是为了现证道的究竟放，犹如船筏”。立量云：有学圣者身心中的道谛「有法」，非究竟皈依处，因为在自己的观见前，似现远离一切自性垢染，实则尚未远离一切垢染，是虚妄的有法故。又有学圣者身心中的道谛「有法」，非究竟皈依处，因为从有垢染分位至远离垢染分位尚须异转，是无常法故。又如《宝性论释》云：“证法者谓由有因果二种差别，此谓道谛和灭谛，因为由谁与谁名为所应证，此中道者属有为相，名为有为相所属，此中道者属有为相，彼即是虚妄的有法故，若法是虚妄的有法，彼即非谛，凡非谛者彼即是无常，若是无常彼即非皈依处”。立量云：无余涅槃「有法」，非究竟皈依，因为仅以无烦恼及苦差别显示故。如《宝性论释》云：“若不属道谛的灭法。如声闻理趣，如灯断灭，仅以无有烦恼及苦而无有显示者都不堪为皈依或非皈依处”。立量云：第十地者、声闻、独觉诸阿罗汉「有法」，非究竟皈依处。因为有所知障的怖畏故。如《宝性论释》云：“僧者具有三乘之名易于了知，然彼常有怖畏，尚有所学寻找出离皈依，不是趣入圆满无上正等菩提”。问：有何怖畏？答：阿罗汉虽然断尽三有，但习气未断故，未尽恒常相续一切想，即住于怖畏想中，譬如执剑的刽子手欲来害己，是故彼等并非毕竟无有出离，皈依者谓是正理寻求皈依。
    <2>胜义皈依。问：何为胜义皈依？答：有，唯独佛陀乃是究竟皈依故。因为佛陀是二谛究竟功德法的所依故。如《宝性论》云：“趣入于胜义，皈依唯佛陀，能仁法身故”。然于究竟皈依不全为三宝，何以故？全为三宝者谓三皈依圆满所显的僧，彼僧若成佛时乃成为彼僧皈依的究竟故。如《宝性论》云：“虽众究竟故”。又如《金鬘论》(宗喀巴大师的《现观庄严论疏·金鬘论》)云：“虽众究竟故，谓于究竟皈依，是为断除于三宝全与不全之疑的邪分别故所说”。
    ④释宝的名义。立量云：三宝「有法」，说汝是稀有珍宝是有因由的，因为与如意宝一样有六种法相似，作如是说故。六种法相似者，谓出现世间稀有、明净无垢、具有通慧等势力、善思惟诸庄严殊胜、诸功德最胜、及不随贪瞋所转变故。如《宝性论》云：“真宝世稀有，明净及势力，能庄严世间，胜上不变等”。是说宝有至宝、真宝之义，为最上稀世之珍，1、由于未积集福德智慧资粮者而不能见，故是希有；2、本非染浊之法，故是明净无垢；3、能成办自他利益，故是有势力；4、是诸众生善心之因，故是能庄严世间；5、最胜第一超出世间，故是最上；6、及性非可变，故是不变，具此六德者，堪称为宝。
    (2)依《大乘庄严经论》中所说轨则分三：①略示五大皈依；②广释；③大乘皈依成就殊胜。
    ①略示五大皈依，立量云：凡是为胜乘故而皈依「有法」，名为诸皈依内最极殊胜，因为所缘遍行，修行誓愿广大，证得殊胜，映蔽声闻独觉，从差别自性门是为特殊殊胜故。如《大乘庄严经论》云：“遍行誓证及映蔽，差别自性四相别，胜乘故善皈依宝，名诸皈依最殊胜”。
    ②广释有五：<1>立量云：智者佛子「有法」，是遍行一切有情，因为是为度脱一切有情出离生死故。彼「有法」，是遍行一切乘，因为是善巧修习三乘道故。彼「有法」，是智慧遍行，因为具有善巧二种无我故。彼「有法」，是涅槃遍行，因为证得三有涅槃法我空一味故。当知此处是智者菩萨所缘遍行，是为修行所摄故。如《大乘庄严经论》云：“若向度脱诸有情，善巧遍行智慧乘，生死涅槃寂一味，当知智者此遍行”。
    <2>立量云：圣佛子「有法」，多由欢喜希求殊胜菩提，因为彼是了知菩提功德的菩萨故。圣佛子「有法」，具有修行殊胜，因为利他无有厌足的难行能真实行故。圣佛子「有法」，具有所得殊胜，因为从佛至佛一切断证功德悉皆平等故。当知此是圣者菩萨的誓愿殊胜，是为修行所摄故。如《大乘庄严经论》云：“多喜希求胜菩提，无厌难行真实行，从佛至佛悉平等，当知智者誓愿胜”。
    <3>圣佛子「有法」，具足证德殊胜，获得福德大蕴，成为三有之上师，得三有之大乐，能息灭纯大苦蕴，获得胜慧无分别智之大乐故。圣佛子「有法」，具足果殊胜，因为积集众殊胜法蕴恒常身力资粮，息灭（止）二障习气，获得远离三有与寂灭涅槃边故。如《大乘庄严经论》云：“获大福聚三有师有乐，息灭纯大苦聚胜慧乐，众胜法蕴常身善资粮，息灭习气离有寂灭边”。
    <4>圣佛子「有法」，是映蔽声闻独觉诸众，因为胜出声闻独觉善根广大，义利广大，恒常无边相续不断，具足无尽智的功德故。圣佛子四种善法根「有法」，（四种善法根：一世间善根、二出世善根、三成熟善根、四神通自在善根，以四种善根胜出声闻独觉。）具足三种作业，谓能成熟世出世间诸有情，获得自在功德，能作无余功德无尽智故。如《大乘庄严经论》云：“智胜声闻众善广大义，恒常无边无尽智映蔽，彼善世出世间能成熟，彼获自在寂蕴无尽智”。
    <5>此大乘皈依「有法」，体义具足，由于乐欲佛陀殊胜法，能誓愿皈依佛陀故。此大乘皈依「有法」，因义具足，当知是从大悲心所生故。此大乘皈依「有法」，果义具足，能获得一切相智性(或一切种智)故。作用具足，能安立一切有情利乐，利他难行无有厌足故。诸功德具足，出离所断事，显示福智二种资粮的功德具足故。其差别有二：第一、粗则从语表名称所生；第二、细则以法性力所得。此诸智者的皈依者，谓胜出小乘皈依最为殊胜，是为修行所摄持故。如《大乘庄严经论》云：“乐欲佛法誓悲智，相智利难无厌足，出离诸乘德常具”。
    ③大乘皈依成就殊胜。立量云：此大乘皈依「有法」。具足自利广大，成为增长无量功德故；具足利他广大，能遍满悲憋诸众生故；具足加行殊性，能广作无等圣教大法事业故。如《大乘庄严经论》云：“于此皈依义广大，增长无量功德故，悲愍众生意乐遍，广大无等大圣法”。
    (3)受持修行之次第轨则分五：①依何境；②依何因；③如理皈依之轨则；④皈依的功德利益；⑤]皈依后所学之次第。
    ①依何境。皈依的境者，谓诸希求解脱者，于无上究竟皈依处，是希有至宝。如《妙幢经》云：“诸遭怖畏人，多皈依山林，及皈诸园囿，皈所供树木，其皈非尊胜，其皈非第一，虽依其依处，不能脱众苦，若时有皈依，佛法及僧伽，由知苦苦集，正超越诸苦，八支圣道乐，当趣般涅槃。如寂天菩萨《入行论》云：“故自今皈依，诸佛众生性，勤救众生事，大力除诸畏”，又如《百五十赞》云：“若谁一切过，毕竟皆永无，若是一切种，一切德依处。设是有一心，即应皈依此，赞此供养此，应住其圣教”。月称论师《皈依七十颂》云：“佛法及僧伽，是求脱者依”。是故，立量云：三宝[有法]，是求解脱者所应皈依处，善巧远离自己一切怖畏，解脱他一切怖畏之方便，随顺大悲心，悲愍他无有远近一切而转，作一切有情皈依怙主及亲友正士故。
    ②依何因。皈依的因者，谓了知自己一切苦而生怖畏，欲远离诸苦怖畏唯有三宝乃能救护，是皈依的因圆满，从依彼皈依圆满之因生起皈依之心坚定无疑故。
    ③如理皈依之规则。皈依的规则有道和体二种之别，依此二种因，系心思惟三宝，令心转变唯三宝能解救一切苦难，而安住许诺誓言所显之正理，是皈依的体故。如《入行论》云：“我由怖畏故，将自奉普贤”。这是从皈依三宝体性门，以身语意业的三皈依，其所相(事相)者如以身顶礼等。
    从皈依三宝胜劣门有下中上三士之差别。下士为自己解脱恶趣苦故而皈依三宝；中士为自己解脱生死轮回苦故而皈依三宝;上士为解脱一切有情生死苦故而皈依三宝。从界限门分，有因时的皈依及果时的皈依二种。初因时的皈依，如有情身心中的皈依;次果时的皈依，如佛地的皈依。从粗细门分亦有二种，粗分谓从诸语言所表生起的皈依；细分谓由法性力所得的皈依。又粗分如由其他和尚阿阇黎等说法受持的皈依;细分如由过去生中皈依宿业的习惯势力忽然现起所生的皈依；及由通达法性色之力所生的皈依。
    ④皈依的功德利益。皈依具有特别殊胜利益，谓能摧毁一切罪堕；能圆满广大福智二种资粮；能救护一切灾害；能新得别解脱戒等功德；及已得不失坏并能令增长；能令种姓醒觉；能速得无上菩提等功德利益故。如《摄般若波罗蜜多论》云“皈依福有色，三（千）界器犹狭，如大海水藏，非握能测量”。
    ⑤皈依后所学之次第。皈依后所学之次第分二：一别所学，二共所学。初别所学又分遮所学及修所学二种。初遮所学者，如《涅槃经》云：“若皈依三宝，是谓正近事，终不应皈依，诸余天神等。皈依正法者，应离杀害心，皈依于僧伽，不共外道住”。二修所学，如龙树菩萨《亲友书》云：“随工巧拙木造等，智者应供善逝像”。二共所学者，应学恒常忆念、爱惜、护持三宝比自己生命更为重要；并及应当恭敬、顶礼、供养三宝等。不信的心仅一刹那顷亦不应生，如是所作当成为一切乐善的基础故。如宗喀巴大师说：“众生怖畏生死险，孤独无伴遍漂游，因无三宝皈依处，是故至心而皈依”。
    （译自极尊却吉坚赞著的《现观庄严论释·总义游戏海》）


四、结语

    以上所引经论，已将皈依三宝说竟。这里再讲三个问题，以作皈依结束语。
    1． 皈依的意义：
     皈依有两重含义：(1)是皈向，即皈向如来的智慧法身。如《华 严经·如来出现品》云：“如来智慧无处不至，何以故？无一众生而不具有如来智慧，但以妄想颠倒执著而不证得”。“永离妄想执著，于自身中得见如来广大智慧，与佛无异”。是说一切众生本具如来智慧法性。又如《涅槃经》卷六说：“一切众生悉有佛性”，具有三宝性，若能断除客尘烦恼，“则见佛性，成无上道”。所以皈向即是回过头来认识自己身中具有的佛性以为正因，而趣向自性清净的涅槃，成就如来自性清净法身以为究竟胜果。(2)是皈救，或依护、依托、依仗及其救护等义。一切众生虽有佛性、法性和僧性，具有如来智慧，但这只是本具的因性，要圆满成就如来清净法身功德以为究竟归宿，还是经过皈依发菩提心，修菩萨行，断除妄想执著，断尽客尘烦恼，才能证得，犹如金矿要经陶冶锻炼，乃成纯金。所以在修行的过程中，必须依仗如来救护威力，依靠四圣谛等诸法之力，依护贤圣僧宝教导接引之力，乃能到达涅槃彼岸，成就菩提圣果。
    2．皈依的仪则：
    皈依三宝与不皈依三宝，是区分佛弟子与非佛弟子的根本原则。真正的佛弟子必须至心皈依三宝，必须承认佛陀是自己的大师，必须依止佛陀所说应止应行的一切教法而修行，必须尊重依止贤圣僧以为良师善友，将自己的身心依托于三宝，求三宝救护，才是真皈依三宝，是趣入圣教之初门。“佛法僧三宝，天上第一尊”。（《涅槃经》所说）皈依三宝后，不能再皈依其他一切天神外道，否则就失去皈依之体，不得再称是三宝弟子。如《涅槃经》云：“归依于佛者，真名优婆塞，终不更皈依，其余诸天神。归依于法者，则离于杀害。归依圣僧者，不求于外道。如是归三宝，则得无所畏”。皈依后，应行的学处详见《菩提道次第广论》。如果只承认二宝或一宝，而皈依一宝或二宝者，就不是佛弟子，因为违背佛陀所说三宝教义的根本原则，故依佛法教义，不能承认他们为佛教徒。
    皈依三宝一定要依止比丘僧受皈依。有比丘僧的地方，比丘尼不能授他人皈依。沙弥及在家男女二众居士，更不能为他人授皈依，因为他们不属于僧宝所摄。要比丘五人以上或比丘尼五人以上的僧团，才能称僧宝。一比丘僧是代表僧宝而授皈依；归授的皈依弟子，亦属三宝，不能属为己有。受的意义，一为表示自己对三宝的信心，二为乞求三宝力加持救护，乞求三宝救离一切生死痛苦，怀着真诚的清净信心，祈请三宝慈悲容受作为依靠，如是发心皈依即成皈依之体。
    3．皈依发心：
    皈依为入圣教之门，发菩提心为入大乘之门，发出离心为入解脱之门，此为入行三门。是说，皈依三宝为三乘人共同修行的所依境(从皈依为因，直至成佛为果，在未成佛的中间应永远皈依三宝)，发大乘心者依靠三宝修行而成佛法身，发出离心者依靠三宝修行而得解脱涅槃。若只求人天安乐，依靠三宝救护而修善法，定得人天安乐。若依如来的究竟本意，是愿一切众生都发大乘菩提心，住持圣教，利益有情，令三宝种不断，圆满无上正等菩提。


第四、住持三宝的重大责任

    住持三宝，是佛般涅槃后的佛法僧三宝。如佛像、三藏经典和贤圣僧宝尚住于世间，佛法僧宝继续在世弘传利益众生，故称住持三宝。
    一、住持佛宝：
    以佛像为宝。历代所造的木质、泥塑、石刻、绘画，以及金银铜等各种佛像，及佛舍利遗形，都称为住持佛宝。如现在一些佛教寺庙中所供奉的三世佛，三方佛、三身佛、五佛、七佛以及千佛等佛像和一些石窟佛像，作为三宝弟子都应当尊重恭敬礼拜供养。如圣龙树菩萨的《亲友书》云：“随工巧拙木造等，智者应供善逝像。”是说对佛像应当恭敬礼拜供养，得诸佛加持，以培养自他信心，增长善根，获无量福慧功德。
    佛陀虽然灭度，但佛陀的法身事业尽生死际尚在利益众生，佛陀的庄严妙相尚在人间为诸众生所恭敬尊重供养。如佛在忉利天为母说法时，优填王思念佛陀，用旃檀木造佛形像，佛从忉利天方下宝阶，旃檀像起立，礼敬迎接，世尊摩顶而对像言，未来住持广作佛事。又如《观佛三昧海经》卷七云：“时像合掌叉手为佛作礼，尔时世尊亦复长跪合掌向像时，虚空中百千化佛亦皆合掌长跪向像。尔时世尊而语像言，汝于来世大作佛事，我灭度后，我诸弟子以付嘱汝。空中化佛异口同音，咸作是言，若有众生于佛灭后造立形象，幡花众香持用供养，是人来世得念佛清净三昧，若有众生知佛下时种种相貌，系念思惟必自得见。佛告阿难，佛灭度后，佛诸弟子知佛如来下忉利天及见佛像，除却千劫极重恶业，如是观者名为正观”。这是佛在世时的第一尊佛像，佛已印可嘱累此像为未来住持广作佛事、利益众生。如《华严经》中演说十种佛，其中即有“住持佛”之称号。
    佛灭度后，此旃檀像在古印度广受众生供养，如《大唐西域记》卷五云：“城内故宫中，有大精舍，高六十余尺，有刻檀佛像，上悬石盖，优陀衍那王（优填王）之所作也。”“初如来成正觉已，上升天宫为母说法三月不还，其王思慕，愿图形象，乃请尊者莫特伽罗子以神通力接工人上天宫，亲观妙相，雕刻旃檀，如来自天宫还也，刻檀之像起迎世尊，世尊慰曰：教化劳邪，开导末世，实此为冀。”上《记》卷十二云：“战地东行三十余里，至妣摩城，有雕檀立佛像，高二丈余，甚多灵应，时放光明，……闻之土俗曰：此像者昔佛在世，憍赏弥国，邬陀衍那王所作也。”
    佛还为优填王说《造立形象福报经》（汉代和东晋时已译汉），又为诸王说《造像功德经》（唐代已译汉），佛升忉利天为母说法前，舍利子请问佛，佛升天为母说法人间众生思念圣容，如何造像量度，佛对舍利子说《造象量度经》，由此舍利子著《造像量度论》广传于世，后人造佛形象，皆依此《造像量度论》为准则。所以佛灭度后，古印度造立佛像甚为普遍，极为精美庄严。据《造像量度经》序（清乾隆时由藏译汉）云：“我佛中年之时，中天竺国瓶沙王，为遗远友，乞得世尊画容，为伥像之始。时工被佛神光射眼，眩目不能注视，乃请世尊令坐河岸，而谨取水中影像为式，描得圣容，因被微波，由作曲弯长相，故称谓：水丝衣佛。今你波罗国（尼泊尔）所出佛像，其摹似乎。”可见，在古印度诸国王造立像，都是依佛在世时，亲睹妙相，而雕塑绘画圣容，量度尺寸极其精确。
    佛教自汉明帝永平十年传入中国，从古印度来华贤圣大德，多携来佛像，特别是玄奘法师请回佛像百十余尊。所以自汉唐以来中国汉地造像，一般都合符量度，如敦煌石窟、龙门石窟等古代雕刻绘画，都极其精美庄严。
    到了宋代、辽代造像就改变了圣容，如辽刻《契丹藏》扉页，及四川宝顶山宋刻佛像，将佛顶肉髻，移至顶门。
    到了元代，“元世祖混一海宇之初，你波罗国（尼泊尔）匠人阿尼哥，善为西域梵像。”“以工巧称，而其门人刘正奉，以塑艺驰名天下，因特设梵像提举司，专董绘画佛像，及土木刻削之工，故其艺绝于古今。”（见《造像量度经》工布查布序。）当时造像要经鉴定合格乃能供于寺庙。所以现见元明代所造佛像，尺度不差，极其庄严。
    清乾隆年间虽译出《造像量度经》，但未能弘传推广，塑画佛像已违元明尺度，将佛顶髻移至顶门，胸前刻一“卐”字，并是左旋。凡左旋者皆属外道，如西藏笨教。此“卐”字出自《华严经》，据《大周录》所记，是为武则天定为“万卐”字，以表万德庄严之义，在佛胸间不能外现。而在西藏一般用于法座，以表吉祥。
    自清代改佛圣容，直到文化革命后，佛教寺庙恢复，所塑造的佛像，一般都出于泥水匠之手，擅改佛像，使人见之非常痛心。还有一些庄严古寺，塑一些土地王母等牛鬼蛇神，破坏了一座庄严古刹，失去了住持三宝的重大意义，其原因是对佛信心淡薄，没有辨别能力，塑工又无信仰，以讹传讹，导致乱造佛像，破坏了佛宝的形象。
    佛教寺庙是住持三宝的圣地，寺庙修得庄严美观，佛像塑的合符量度，僧团如法如律，三宝即在人间。


二、住持法宝

    （一）序分
    佛陀所说的一切教法，弟子们在佛陀涅槃后将其结集成三藏经文，传译制目，刻版流通。使后世众生依之读诵修学，讲说弘传，令诸众生依法依律修行，积极培养善根，获得人天安乐之增上生和解脱涅槃之究竟胜，使法种不断，皆是住持法宝所摄。
    佛教法藏在印度历史上有过三次结集的事实。如佛涅槃后，大迦叶尊者为审定佛语，令佛法久住，使佛陀所说的一切教法而不散失，令后世弟子有法可依，依法和合修行而证圣果，即召集五百阿罗汉第一次结集三藏，录成文字。如《三藏传》卷三云：“阿难升座诵经，诸众随口而录，录讫。”“三月安居中集三藏讫，书之贝叶，广遍流通”。此与西藏所说“笔之于书”相同。其后又有七百阿罗汉结集和一千阿罗汉结集法藏，还有菩萨结集大乘法藏的事实，以及大小乘贤圣众广作论著以解经律论义。
    佛教从东汉明帝永平十年(公元67年)，传译到中国，历经一千余载的翻译。
    在这一千余年的中间，除翻译外，还有许多先贤大德搜集、抄写、整理、校刊，编目者就有四十余家。佛教经籍的缕梓镌刻，最早始于北齐的磨岩石刻，逐步发展成隋代碑刻至明代末年的房山石经。自宋太祖开宝四年(971年)在四川成都雕刻大藏经始，后经辽代、金代至近代刻印大藏经，总有十余次，才保存了现在的五千余卷经藉，这是无数先贤大德为正法久住，不惜身命，为法忘躯，才令这些经籍能流传至今。还有不少经籍未曾传译过来，已经传译的经籍有译无本者，约有千余卷(见《开元录》)。从中可以了知住持法宝，来之不易，是故应当尊重佛说的一切教法，及贤圣大德所作的论著，令其保存流传，久住世间，广利众生，以报佛恩。
    僧人住持法宝，应当了知佛经的意义。佛经称为契经，一，契合时处，即叙说何时何处为何人所说；二，契合相性，即叙说世俗和胜义谛的相性；三，契合法，即叙说蕴处界等法数法相；四，契合义，即叙述深密义理。佛经或佛语，要具三义，一，佛陀亲口所说；二、佛加持菩萨等说，如《般若心经》佛入定加持观世音菩萨说；《华严经》佛只说了两品，其余各品都是佛加持菩萨所说；三，佛开许说，如《法集经》是佛教敕舍利子说，有些天龙八部在佛前发愿护持正法，利益众生，所说的咒语或愿文，都是佛语，收编在经藏中。但加持说或开许弟子说，必须需在佛前，经佛认可才算为经。《大智度论》中说“经通五人说”，有人误解此义，以为任何人说的都是“经”，这是大错。所以没有经佛认可，没有在佛前说，或佛灭度后，所出现的“经”，都是伪经。经目中弟子们作的佛传等，也有译作经者，但《开元释教录》都编入“西土东土贤圣集传”类，可见古德对经目审定的重视。
    佛灭度后，小乘藏经过三次集结，集经的涵义，是通过集体审定佛语，非佛语者均不能入于经中。佛教自汉明帝永平十年传入中国，翻译传播日盛，难免会有伪经出世，自释道安法师的《综理众经目录》一卷出世，就摘出伪经二十六部三十卷，法师非常悲痛曰：“见泾渭杂流，龙蛇并进，岂不耻之。”后各家经目无不刊校伪妄乱真，列伪经目录。如《大唐内典录》卷十说：“良足寒心，悲哉！没法遂及此乎。昔隋祖开皇创定经录，校阅伪经，卷经五百，已总焚除。今人中流传犹未铨叙，既是法秽不可略之，故隋代显明，庶知博观之弘益也。”这是道宣律师见前诸家经目，刊校伪经，于佛经之弘益的称谓。
    到了《开元释教录》出，佛教传入中国，历经七百载，刊校经目已告定型，分为：般若部、宝积部、大集部、涅槃部和华严部，五大部类，以大小乘三藏及西土东土贤圣集传七大类编次。它将以前四十一家经目，作了全面审定刊校，是一部经目之本母，后来刻经皆依此录为准。在卷十八别录中疑惑再详录中，总结疑惑经十四部十九卷（《贞元录》同此），同卷总结伪妄乱真经，共三百九十二部，一千五十五卷。《贞元录》卷二十八的伪妄乱真经，共三百九十三部，一千四百九十一卷。审定伪经至此结束，因为经目已定，后来宋辽刻经藏，皆依《开元入藏录》，凡属伪经除国王旨定均不入藏，如《贞元录》中的《大佛名经》是奉国王旨意编入经目（此“经”是隋唐所撰，收编佛法僧名，供人尊仰，但此“经”有引《马头罗刹》伪经，故《开元录》作了详细说明，列入伪经目录）。又如明《北藏》属于官刻，将明孝皇后的《梦感经》刻于藏末。
    关于诸经目录的“抄经”，亦应了知。凡属抄经，是从大藏经中抄出一品别行，又称别行经，故名。如《观世音菩萨普门品》，是《妙法莲华经》中的一品，古代刻此品，都冠有《法华经》名的第二十五品。经目中抄经很多，如《阿含经》古代就分出许多部经，《开元录》将这些抄经都收归为《阿含经》内。所以凡属抄经，是将大经中某经抄出单独流通，便于持诵，但不能增减或修改一字，否则即是伪经（如齐竟陵王的抄经，诸目皆列疑经），如《开元录》卷十八云：“右华严经下，四十三部，二百九十八卷，勘校群录并是南齐司徒竟陵文宣王萧子良抄。”“参杂惑乱正文”。又如三阶教杂法二十二部二十九卷，“奉证圣元年恩敕，令入伪经。”见《大周刊定众经目录》卷十五。
    近代有人出自己见，妄列“伪经”，如本世纪二、三十年代出现的“楞严百伪”之诤。现今有些佛教徒不知经目，乱印伪经，将一些民间俗语流传，妄加“如是我闻”等，经乱真经，虽出自好心“弘法”，但因无知妄造伪经，实属妄语，反造谤法恶业，实可悲哉！故此有必要谈谈佛教《大藏经》的结集、传译和刊刻。若欲广知，当读各家所著《印度佛教史》及《中国佛教史》。
    （二）佛教《大藏经》的组成
    佛教《大藏经》是佛陀示寂后，弟子们将佛陀一生所说的教法结集成一部全书的总称。其内容主要由经律论三部分组成，总称“一切经”、“三藏经”和“大藏经”，分别称为经藏、律藏和论藏。将佛陀一生所说一切法的文义，分类总集于此三者之中，故称为“藏”，有容纳收藏之义。
    总集一切经名为经藏。梵语修多罗或素呾缆，译之为经，或云契经，经有延贯佛法，令不散失之义。一切经总分为十二类，称为“三藏十二部经”，是指佛陀所说的全部契经，依经文体裁及其含义归纳为十二部分的总称。（见“法宝”中1、教法）
    大小乘各有九部契经之称，谓十二部经中除去“方广经、授记经、自说经”三部，既是小乘教之九部契经。大乘教之九部经者，谓十二部经中除去“因缘经、譬喻经、论义经”三部者是。此为定学。
    总集佛陀为七众弟子所制定的一切别解脱戒法，名为律藏，或名调伏藏，在经目中分：声闻调伏藏、菩萨调伏藏二类。梵语为毗奈耶，此译为灭，调伏和戒律，义为灭诸过非，止恶修善，调伏诸根，令其如法如律，如世间法律，必须遵守之规则，故称为律。此为律学。
    律分为大乘律和小乘律二种，小乘律汉译最广，现存有五部律。
    1．《萨婆多部》，译曰《十诵律》六十卷。鸠摩罗什共佛若多罗译。
    2．《昙五德部》，译曰《四分律》四十卷或六十卷。佛陀耶舍共竺佛念译。
    3．《沙弥塞部》，译曰《五分律》三十卷。佛陀什共竺道僧译。
    4．《摩诃僧伽律》四十卷。佛陀罗共法显译。
    5．《根本说一切有部律》五十卷。唐义净三藏译。
    据《出三藏记集》梁僧祐律师著，卷三所载，有：《婆粗富罗部》，译言犊子，律本未传汉。
    《迦叶唯部》戒相与《五分律》同，此土未传。若欲详知，当见《出三藏记集》、《开元释教录》及《贞元释教录》。唐义净法师为求《一切有部律》，遍游天竺，寻回此本，翻译最全。汉地所行为《四分律》，藏地所行为《一切有部律》。
    论的梵语为阿毗达磨，简称“毗昙、阿毗昙”，义为对观，有对向涅槃诸谛之真实义；详明辨析，反复演说一一法等的真义；克敌制胜；依此能通达一切经义，以此四因，说明为对，此即胜法和对法之义。总集佛陀所说的一切对法，即名为论藏。弟子们所造的大小乘论著亦编者按入论藏。此为慧学。
    总集一切佛语，若依所诠内容解释义理，如此即可分为戒学、定学和慧学；若能依诠解释文字体裁可分为三藏十二部经，或十二分教。将戒定慧和十二分教，总集于此三藏之中，故称为三藏经或大藏经。
    （三）《大藏经》的结集分二：１小乘结集；2、大乘菩萨藏的结集
    1． 小乘结集
    小乘藏的结集，一般都认为是佛灭后弟子们结集佛语，其实，佛在世时已有结集的记载，如佛令舍利弗为诸比丘说法，“时舍利弗对诸比丘说，今此波婆城，有尼乾子命终不久，其后弟子分为二部，常共诤讼，相求长短，迭相骂詈，各相是非。”“诸比丘，唯我释迦无上尊法，最为真正可得出要”，“诸比丘，我等今者宜集法律，以防诤讼，使禁行久立，多所饶益，天人获安。”于是舍利弗即对诸比丘从一法说至十法，集诸法义，如来知已即予印可。“尔时世尊印可舍利弗所说”，如来称赞言：“善哉善哉”，“是佛所说”，“于此大集法门，受持读诵，宣通流布。”（见《长阿含经》卷八，《众集经》卷九，《十上经》及《大集法门经》。）
    可见，结集三藏的宗旨，是审定佛语令佛法久住，使佛陀所说的一切教法而不散失，以防诤讼，令后世弟子有法可依，依法依律和合共住，修习圣道而证解脱涅槃。结集有诵、合诵、等诵之义，即选一人诵说，大众合诵，经过集体问答，确认为佛语者，经集体通过，分类编辑而成三藏，即名佛教大藏经。
    第一次结集，是佛涅槃后由大迦叶召集五百大阿罗汉，共安居于王舍城外的七叶窟，以大迦叶为上座，先使优波离诵出毗尼藏，次使阿难诵出修多罗藏和阿毗达磨藏，集成三藏经，此称五百结集。
    第二次结集，是佛灭度后约百年间，（藏文为一百一十年时）因毗舍离城比丘行十事非法，长老耶舍召集七百阿罗汉，依毗奈耶（律）制止非法，宣明圣教，此称七百结集。
    第三次结集，是佛灭度百年之后，（藏文为一百三十七年），阿育王时，由大天五事非法而乱圣教，由目犍连子帝须为上座，会集千阿罗汉，于波吒利子城结集法藏。
    第四次结集，是佛灭度后四百年时，五百圣贤结集三藏，释三藏各十万颂，此为有部宗所传。藏文只记三次结集，未见有第四。又因是有部一宗所传，经部宗不一定承认为佛语，所以这次结集一般不列入结集内。
    小乘三藏的结集，虽有四次之说，但并非一次集成，每次结集都有所补充。如阿育王的事迹，本在佛灭度一百年之后，但小乘经中确有所记载。又小乘分派之后，各部派亦有所集，如义净法师在《南海寄归传》卷一说：“诸部流派，生起不同，西国相传，大纲唯四：一、圣大众部，分出七部，三藏各有十万颂，合三十万颂，唐译可成千卷；二、圣上座部，分出三部，三藏多少同前；三、圣根本说一切有部，分出四部，三藏多少同前；四、圣正量部，分出四部，三藏有三十万颂，律有三万颂。然而部执所传，多有异同，且依现事言其十八，分为五部，不闻于西域耳。”可见小乘各部派所传的三藏，多有同异，特别是律传五部，律藏虽是大同小异，但都属于小乘部派各部所集。
    2．大乘菩萨藏的结集
    （1）依《菩萨处胎经》所说，佛灭度后七日七夜，由大迦叶召集五百罗汉，“使阿难升七宝高座，大迦叶告阿难言：‘佛所说法一言一字，汝慎勿使有缺漏，菩萨藏者集著一处，声闻藏者集著一处，戒律藏者集著一处。’” “尔时阿难最初出经，胎化藏第一，中阴藏第二，摩诃衍方等藏第三，戒律藏第四，十住菩萨藏第五，杂藏第六，金刚藏第七，佛藏第八。是为释迦文佛经法具足矣。”这次共集成八藏。
    （2）依《大乘理趣六波罗蜜多经》卷一：“复次慈氏，云何名为第三法宝，所谓过去无量殑伽沙等诸佛世尊所说正法，我今亦当作如是说。所谓八万四千诸妙法蕴，调伏纯熟有缘众生，而令阿难陀等诸大弟子，一闻于耳皆悉忆持，摄为五分：一素呾缆，二毗奈耶，三阿毗达磨，四般若波罗蜜多，五陀罗尼门。此五种藏教化有情，随所应度而为说之。”这是佛陀教示集为五藏。
    （3）依《大智度论》卷一百所说，有文殊、弥勒诸大菩萨将阿难结集大乘三藏，谓之菩萨藏。如论云：“复次有人言，如摩诃迦叶，将诸比丘在耆阇崛中集三藏。佛灭度后，文殊师利、弥勒诸大菩萨，亦将阿难集是摩诃衍。”“摩诃衍经名大修多罗”，“以经大事异故别说，是故不在三藏之中。”这是说除声闻三藏外，别有大乘摩诃衍经，阐述大乘藏广大无量之义。
    （4）依藏文记载：“佛示寂后七日，百万菩提萨埵，集王舍城南净生山中，由文殊诵阿毗昙藏，弥勒诵毗奈耶藏，金刚手诵修罗藏，笔之于书，称为大乘结集。”
    （5）依清辩论师的《分别炽然论》所说：“是故大乘是佛所说，主要的结集者是普贤、文殊、秘密主和弥勒菩萨等故。”结集的方法和处所，如《白伞盖释》云：“结集圣教者，金刚手菩萨住柳叶宫时，眷属都是十地菩萨，即普贤和金刚法等，以五百上衣而敷其座，并启白云：‘转法轮经藏，善逝何处说，愿金刚汝说，愿智子汝说。’如是启白之后，结集主金刚手即说‘如是我闻’。”这在《显明灯》和其他教典里也有类似的说法，这主要是说明大乘非声闻的境界，唯有菩萨乃能结集。
    （6）月称论师的《皈依七十颂》云：“依声闻增上，许为三藏教，以菩萨增上，决定彼非有。圣者西山说，及东山声闻，以菩萨增上，说为七藏是。如是菩萨藏，持明及经藏，毗奈耶对法，方广及本生，是名为七藏。”此即：菩萨藏、持明藏、经藏、毗奈耶藏、对法藏、方广藏和本生藏，共为七藏，说明小乘部派许为三藏，菩萨藏为七藏，大小乘对藏的结集虽有所不同，但大乘亦总摄为三藏，即称大乘三藏。
    （四）汉译《大藏经》可分为：1．传译制目大藏经；2．刻本大藏经
    1．传译制目大藏经
    汉译佛教典籍，编制经目，历经千有余载，制目者总有四十一家（见《开元录》）。据诸家经录记载，佛教从东汉明帝永平十年（公元67年），竺摩腾译出《四十二章经》一卷开始，经汉桓帝汉灵帝以来，经典的翻译随之而兴，翻籍日富，部帙逐渐增多，于是使弘法之士，为了正法久住，护持法藏，便综理存亡，研核异同，因而则有编制《经目》的创制。自东汉明帝至东晋释道安时，近二百年间，虽有制目者十余家，但都以一寺所藏，一时期和一译师所出之经籍等各别制目。到了东晋释道安法师（312或314~385）的《综理众经目录》一卷出世，才为经录的发展奠定了良好的基础。如《出三藏记集》卷二说，“迩乃桓灵，经来稍广。安清朔佛之俦，支讦严调之属，翻译转梵，万里一契，离文合义，炳焕相接矣。法轮届心，莫或条叙，爰自安公，始述名录，铨品译才，标列岁月。妙典可征，实赖伊人。”卷五引安公自述：“此土众经出不一时，自孝灵光和（178~184）以来，迄今晋宁康二年（374），近二百载，值残出残，遇全出全，非是一人，难卒综理，为之录一卷。”
    但《安公录》太简，早已亡佚，见存于《出三藏记集》。此录总分七种：一《经论录》，二《古异经录》，三《失译经录》，四《凉土异经录》，五《关中异经录》，六《疑经录》，七《注经录》。
    梁僧祐律师（445~518）在《安录》的基础上，将近五百年的译经，进行全面搜集核对，详校前录，旁证博考，研核异同，新集经论，述其列传，撰成《出三藏记集》十五卷，全录总分四个部分：一《撰缘典》，二《诠名录》，三《总缘录》，四《述列传》。此是现存最早最完备的一部经目。
    其后，隋开皇四年（584）沙门法经等二十大德撰《众经目录》七卷。
    隋仁寿二年（602）翻经沙门及学士等撰《众经目录》五卷。
    唐敬爱寺沙门静泰等撰《众经目录》五卷。此录是唐显庆际至龙朔三年（656~663）敕令写新旧所译经论八百一十六部，四千六十六卷入藏，古有目无本者随访随写而录。
    唐麟德元年（664）西明寺沙门道宣律师撰《大唐内典录》十卷。唐大慈恩寺翻经沙门靖迈撰《古今译经图记》四卷，从东汉明帝至唐玄奘法师译经止，将历朝译师所译经论等，按其年次编辑而成。其后西崇福寺沙门智升将玄奘法师以后至开元金刚智译经止撰《续古今图记》一卷。
    武后天册万岁元年（695）敕东都佛授记寺沙门明诠等撰《大周刊定众经目录》十五卷。这次刊定是将以前诸家众经目录作了全面详细刊定，其刊校人数总有七十大德，都有是学识渊博的法师，其中翻经沙门有十八人，如三藏法师义净、菩提流支、宝思惟以及圆测、法宝和神英等，参与校刊，明佺任都检校，刊定经条及经真伪，其有五大德刊定真伪经，四十四大德为校经目僧，检校二人。辑制经目从释道安及《僧祐录》起，发展至此已达到成熟阶段。
    唐开元十八年（730）崇福寺沙门智升在过去诸经录的基础上撰《开元释教录》二十卷，为广录。又总括广录撰《开元释教录略出》四卷，为入藏录，正式依《千字文》帙号编目，分为大乘三藏，小乘三藏，西土及东土贤圣集传七大类。此录自后汉永平十年至唐开元年间，将译经年代、译经人数及所译出处和所译经论部卷等，总括群经作了全面审定。如《录》卷一云：“自后汉孝明皇帝永平十年岁次丁卯，至大唐神武皇帝开元十八年庚午之岁，凡六百六十六载，中间传译缁素总一百七十六人，所出大小二乘三藏圣教，及贤圣集传并及失译，总二千二百七十八部，都合七千四十六卷，其见行缺本并该前数。”智升总览群录，详校刊定，“删繁略重”，将重复的经论作了归类。卷第十九入藏录：合大小乘经论及贤圣集传见入藏者，总一千七十六部，合五千四十八卷，成四百八十帙。《大藏经目》至此已成定型，为后来《经目》所依之本母。
    自唐开元十八年以后，至贞元十年（794）又经六十五年间所译经论等，西明寺翻经沙门圆照奉旨修撰《贞元续开元释教录》三卷，至十六年（800）又撰《贞元新定释教录》三十卷，重新刊校《开元录》未收入及开元十八年后所译的经论。入藏录总一千二百五十八部，合五千三百九十卷，五百一十帙。
    北宋太宗和真宗两朝译经，翰林学士杨亿等编《大中祥符法宝录》二十二卷。此录今残存。至祥符五年所译经律论三百八十四卷。宋仁宗天圣元年至五年（1023~1027），译经三藏法护、译经沙门惟净等共二十一人，奉旨编《天圣释教总录》三册。此录上册缺，中册残，中册“若”帙前缺四经，至“竟”帙后缺。今检上中册是依《开元释教录略出》帙号编辑，其《千字文》帙号与本目仅错后一号，则与《随函录》同。《天圣录》下册，收编的是《贞元续开元录》，按帙号缺前八帙，实收《贞元录》二十七帙，与《贞元录》一致。《天圣录》宋朝新译经律论，西方东土贤圣集传，见入藏者总二百三十二部，五百六十九卷，共六十帙，此是至祥符五年五月止。五年后所出经论总一十七部，一百七十卷，十一帙。
    天圣五年之后所译经论，大学士吕夷简编修《景佑法宝录》二十卷，总录一卷，所记经律论十九部，一百五十卷。今检此录仅存十四卷。据《至元法宝勘同录》所载《景佑录》所记经律论十九部，一百五十卷。
    元世祖至元二十二年至二十四年（1285~1287），召西番和汉僧大德二十九人，编撰《至元法宝勘同总录》十卷，除总集开元、贞元、祥符、景佑弘法入藏录诸家经目总数外，主要是汉文与藏文作对照勘同。如云：“自后汉孝明皇帝永平十年戊辰（丁卯为正）至大元圣世至元二十二年乙酉（67~1285），凡一千二百一十九年，中间译经朝代历二十二代，传译之人一百九十四人，所出经律论三藏，一千四百四十部，五千五百八十六卷。”但此录未提及《契丹藏》和辽代译经，并误以辽代译经为宋译。大藏辑目至此告终，明蕅益法师的《阅藏知津》仅是个人读经所记，其编次与《开元录》等不同，虽冠以华严为首的一宗之见，但亦可作为经目之列。
    佛教经籍汉译仅有五千余卷，还有许多尚在西土未曾传译，已译入汉地有不少经论等已经遗失缺本，如《开元录》所记：“合大小乘经律论及贤圣集传缺本者。总一千一百四十八部，一千九百八十卷。”以此为鉴，我们对于先贤大德翻译的经律论著应尽力将其保存，出版流通，以防其孤本遗失。
    自本世纪初，不少求法志士入藏求法，如能海上师、法尊法师、观空法师等近代高僧，他们费尽心髓血汗由藏译汉的大量经律论著和修法仪轨，以及其他译师从藏译汉的经论仪轨等，至今尚未能完整系统的整理出版。有些孤本仅存于个人手中，若尊师重法，为法久住流传者应将其贡献出来，以免先贤血汗付之东流，后人无以秉卷受益矣！
    ２． 刻本大藏经
    佛教经籍的镂锌镌刻，最初是摩崖石刻，逐步发展成碑刻，唐时亦有单本木刻经的出现。
    木刻大藏经始自宋太祖开宝四年（971）敕张从信在四川益州雕造，至太平兴国八年（983）完成，世称《开宝藏》，亦称《蜀藏》或蜀板，内容本《开元释教录》同，但此藏早已亡佚，现存十余卷残篇。
    在此之后，北方辽王朝又编制刻造《契丹藏》，亦称《辽藏》。约从统和至清宁（983~1064）历经圣宗、兴宗和道宗三代而编制刻成。此藏本包括《开元录》、《贞元录》，宋译三十帙，及广集经籍并辽代译经，从“天”至“灭”字帙，共五百七十九帙，比四百八十帙的《开元录》多出九十九帙，但此藏亦已亡佚。1978年在山西应县木塔佛像中发现十余卷残篇，经与《房山石经》对勘，石经与《契丹藏》完全相同，证明《房山石经》是《契丹藏》的复刻本无疑。《房山石经》辽、金刻经部分，现有二百二十九帙。
    在北方金代又刻《天宁藏》，世称《金藏》或《赵城藏》，为女崔法珍断臂募刻，金太宗皇统九年（1149）刻于山西解州，世宗大定十三年（1173）完成。此为私刻本，现存五千余卷，现在新编印的《中华大藏经》即依此藏为蓝本，缺本者则以其他藏本补之。
    历代都有刻造《大藏经》的事业，如在南方北宋元丰三年至崇宁三年（1080~1104）刻造的《崇宁藏》。政和五年至绍兴二十年（1115~1150）刻造的《毗卢藏》。其后有《资福藏》，《圆觉藏》，《碛沙藏》。《普宁藏》是元世祖时在南北两地分刻。北方为至元十四年敕在北京弘法寺开雕，至元三十一年（1277~1294）完成，称为《弘法藏》。在南方浙江余杭县南山普宁寺，释道安、如一等募刻，称为《普宁藏》。明代有太祖洪武五年至宪宗成化元年（1372~1465），在南京刻造，称为《南藏》。明成祖永乐八年至英宗正统五年（1410~1440）刻造的《北藏》，后又有续刻。明紫柏大师发起募缘刻造的《径山藏》，易梵夹为方册，从“天”至“碣”帙，总六百二十七帙，现存。清代所刻《大藏经》称为《龙藏》，刻五百五十六函，现存。清宣统二年至民国二年，上海频伽精舍印《频伽藏》为方册本，现存。
    汉译本辑刻制藏经目录，自后汉至开元年间，如《开元释教录》卷第十云：“合从古录至开元释教，新录取续补旧缺，总有四十一家。”但缺失很多，如云：“在从古录已以下三十一家，诸录之中虽皆备述，欲寻其本难可备焉，且列名题知其有据。”至于刻本藏经，自宋《开宝藏》至《频伽藏》出，总有十余种，但多已亡佚或存残篇，唯明《径山藏》、明南北二藏和清《龙藏》现存全。若欲广知历代辑目及刻经目录，可阅《大正藏》第五十五卷，日本《昭和法宝总录》共三册详。
    （五）藏译《大藏经》的分类与比较
    我国西藏佛教，自唐代传入，历代翻译三藏教典，极为丰富，今标刻本藏经目录函数，各家经目稍有不同，今以德格板经目录出供参考。
    一《甘珠》部，译为佛说三藏四续经典汇编的一部丛书，全书约一百零二、一百零四或一百零八函左右，每函约译汉文三十卷。总分六大类，一律部十三函，二般若部二十一函，三华严部四函，四宝积部六函，五经部三十二函，六续（密）部1.十万颂续部二十函，2.古续部三函，3.时经疏部一函，4.陀罗尼集二函，总合一百零二函。
    二《丹珠》部，译为论藏，全藏约二百一十五或二百一十八函左右。1.礼赞部一函，2.续（密）部七十八函，3.般若部十六函，4.中观部十七函，5.经疏部十函，6.唯识部十六函，7.阿毗达磨部十一函，8.律部十八函，9.本生部五函，10.书翰部一函，11.因明部二十函，12.声明部四函，13.医方明部五函，14.工巧明部，15.修身部共一函，16.杂部九函，17.阿底峡小部集一函，18.目录部二函。总计二百一十五函。总全《甘珠》、《丹珠》共三百一十七函。
    可见藏译《大藏经》的分类与汉译《大藏经》不同：1.它以律经论编次，以表戒定慧顺次；2.不以大小乘三藏排列：《丹珠》以礼赞部为首，先礼赞佛法僧功德为主；次以部派经疏之分；再以书翰五明之分类。特别是五明论籍之丰富，是汉译本所缺。3.几乎没有异译本，如一本经论译出后经数次决择校刊而成，法相名辞亦多统一，而汉译本的异译本很多。但汉译本有而藏译本缺的经籍也不少，因此有寄于后哲发弘誓愿，广作汉藏互译补缺之弘法事业。
    从《大藏经》的结集、弘传、翻译、制目和刊刻，可以了知无数先贤大德为住持如来圣教所作出的艰辛努力。以此为镜，时至教日西沉，众生苦恼日增的今天，身为佛子当发弘誓愿，不惜身命，以住持三宝为己任，以报三宝之深恩。


三、住持僧宝

    佛灭度后大小乘贤圣僧伽，如法如律行六和敬法，和合共住，世代相传，护持正法，利益众生，皆属于住持僧宝所摄。
    作为住持僧宝，为了住持正法，绍隆三宝，应当了知佛灭度后大小乘诸贤圣者为住持如来圣教，结集三藏，先贤大德传译、搜集编目以及刻藏流通，弘扬圣教，教化众生，继承保护法藏而作出的广大业绩，作为自己的典范，继承先代遗业，令法藏流传不绝，作为己任。而且还应依法修行，学修并重，三学增上，次第不乱地亲身实践佛法。
    如何能令佛陀正法久住呢？《大方广佛华严经》卷十八云：“佛子，菩萨具有如是智慧，令三宝种永不断绝，所以者何？菩萨摩诃萨教诸众生发菩提心，是故能令佛种不断；常为众生开阐法藏，是故能令法种不断；善持教法无有乖违，是故能令僧种不断”。修六和敬法，于诸众生下佛种子，建设道场，护持正法，不惜身命，统理大众，无有疲倦，如法传戒，如法接引后学，令三宝种不断。故上经又云：“于去来今佛所说法，所制之戒，皆悉奉持心不舍离，是故能令佛法僧种永不断绝。菩萨如是绍隆三宝，一切所行无有过失，随有所作，皆以回向一切智门”。偈曰：“昼夜勤修无懈倦，令三宝种不断绝，所行一切白净法，悉以回向如来地”。
    又如《杂阿含经》卷三十二：佛告“迦叶，有五因缘令如来法律不没不忘不退，何等为五？若比丘于大师所，恭敬尊重下意供养依止而住，若法、若学、若随顺教、若诸梵行，大师所称叹者恭敬尊重下意供养依止而住”。与此五因缘相反，则能令如来正法沉没。故住持三宝的重大责任，主要在于住持僧宝的僧众具有担荷如来圣教住持正法的弘法大愿，如法如律修习梵行，有学有修有证，又能说法教化众生，宣扬佛法为人师表，如此方能令三宝久住世间。正如《俱舍论》中云：
    佛正法有二，谓教证为体，
    有持说行者，此便住世间。
    总上颂义，是说住持佛法的僧伽，要广学多闻，精通教理，如法如律修行，有所证受。有持教者，讲说者，如法修行者，佛教方能久住。最根本的问题，是有接引出家弟子，传戒，学戒，安居诵戒等，如法如律修行的僧团，有这样的僧宝在世，佛法即在世间 。佛陀制戒的目的是令正法久住，因过去有的佛未制戒佛法未曾久住，由舍利子的请求，佛乃制戒。佛在世以佛为师，佛灭度后，佛说“以戒为师”。别解脱戒是三乘人共学的戒律，如《华严经》云：“戒为无上菩提本，应当具足净戒，欲能坚持于净戒，是则如来赞叹。”现在有人提出“居士化佛教”，否定僧宝住持佛教的说法，值得大家注意。也许会说是指菩萨僧，但菩萨僧宝，是有菩萨示现在家居士相，不过一定要证圣位的菩萨或僧相，一个人才可算僧宝。凡夫僧一定要有五个比丘僧，能传戒安居诵戒，才能说僧宝，一个僧人只能称比丘，不能称僧宝。在家居士，个人或集体研习佛法，印经流通，宣扬教法，古今皆有。但要以护持三宝，护持僧人学法学律，修行弘扬佛法为宗旨，这就即可称作护持三宝的清净近士，是真正的佛弟子。如果否定僧人或凡夫僧宝，只是居士们学习一点佛言佛语，无修无证就谈不上佛法，更谈不上是护持三宝。


第五、爱国爱教与人间佛教问题

    “爱国爱教”与“人间佛教”两个问题，是当今佛教徒修学佛法，弘法利生，继承佛教事业的重要课题之一。为什么呢？因为符合佛教教理，符合释迦世尊以言传身教为弟子们作出的示范，符合国家和人民的利益。
    一、爱国爱教
    佛教虽然没有国界，但是佛陀与其弟子们都各有自己的国藉。在佛陀出生的迦毗罗卫国，即今尼泊尔境内，当时古印度有“十六大国”，有“四种种姓”的阶级制度。各国的社会虽然稳定，经济比较繁荣，但“四种姓”阶级之间的矛盾显得十分突出。佛陀一生在这些国家里说法教化，遵守这些国家的法律政策，并以言行示范，为这些国家的安定团结，社会稳定作出了极大的贡献。
    爱国爱教是佛陀亲自制定的。据《四分律藏》及其他律藏所载，曾有比丘要到国外弘法布教，到佛前请示教诫，佛告比丘要“遵守国王法，不违毗尼行”，这就成为比丘弘法传教都必须遵守的戒律。佛灭度后，历代高僧大德在世界各国弘法传教，无不遵守佛陀所制的这条戒律。此即是二千余年来佛教徒在世界各地弘传佛法并使之能够发展的主要因素。
    佛陀自己就是爱国者。佛陀成道后不久，即回到自己的祖国说法教化，以后又曾多次回国说法。当“琉璃王召四种兵，伐迦毗罗卫”时“佛知其意，从精舍出止于路，坐于黄枯树下，王问世尊，有菩提等七种树，其荫高大有德茂盛，何因弃舍，处枯槁多刺树耶？佛告琉璃王，虽有七树其荫茂盛，盛岂有常？吾坐刺树，以为安稳，用哀愍伤亲属故也”。(见《佛说琉璃王经》)琉璃王知佛愍伤亲属，爱自己的祖国而退兵。如是三返阻止琉璃王，由于释迦族没有遵循佛告坚持内部团结“舍夷人，不与外仇，有往来缘，国可全也”的教诫，违背了佛陀提倡“四姓平等”的主张，使舍夷人招来这场灾难。当琉璃王兵至舍夷时，“佛恣容无耀，项无光明”。愍伤祖国被侵略，亲属被杀害。直到佛陀最后般涅槃时，还在思念自己的祖国，以头朝北示寂，用以教示弟子不要忘记自己生长的祖国。
    反对侵略战争，保卫世界和平，也是佛陀的教诫。如佛在舍卫国时，摩竭陀国阿阇世王与波斯匿王战斗，这次战斗，波斯匿王“败退星散，恐怖狼狈，单车驰走还舍卫城”。佛知战争的胜负都会给国家和人民带来不幸的痛苦灾难，希望和平与安宁，即对诸比丘而说倡言：“战胜增怨敌，败苦卧不安，胜败二俱舍，卧觉寂静乐”。第二次阿阇世王再起兵侵略拘萨罗国时而遭惨败，被波斯匿王“生擒阿阇世王身，载以同车俱诣佛所”，经佛说法教化，“波斯匿王与阿阇世王韦提希子，闻佛所说，欢喜随喜作礼而去”。其后两国又重新和好，和睦相处。
    又如摩竭陀国阿阇世王欲侵略跋祗国，跋祗国人亦正在积极防御，两国关系非常紧张，将要发生战争。时阿阇世王命婆罗门大臣禹舍，持名字而至佛所，请佛诫敕。佛陀同情跋祗国人，以七事赞跋祗国人的团结和顺，道德高尚，使阿阇世王不敢妄图，制止了这场战争。在佛教史上，有不少高僧大德传播友谊，制止战争，为和平事业作出了贡献。例如永嘉六年（312）石勒屯兵葛坡，准备南攻建业，佛图澄见石勒，劝他少行杀戮，制止了这场战争。
    佛在世时，提倡“四姓平等”，主张团结合作，首先是僧团内部的团结，亦使各国各民族之间和睦相处。为了利益广大众生，佛陀教诫国王们以善法治国，利益众生。如《佛说諫王经》中，因国界有灾患，佛告不离先王：“王治当以正法无失节度，常以慈心养育人民；王治行不平，海内皆忿仇；王治国平正，常以节度，臣民叹德，四海归心。”国家的各项政策法律，都是从实际出发，是为国家利益和人民利益而制定的。所以佛教徒应该全面遵守国家的各项政策法律，切忌宗教偏见。政府的有关宗教政策，并不是管理信仰和教义，而是管理有关政策事务方面的一些问题，帮助佛教徒作好佛教事业。如果没有政府的大力支持，许多事情仅凭宗教徒本身是无法解决的，所以应该理解宗教政策的重要性，自觉遵守政府的法纪法规。
    再说，国家管理宗教，并不是现在有之，而在佛灭度百年后，阿育王时因僧团出现争执分裂，阿育王就插手管理。这在古印度历代王朝都对佛教事务有所管理，如圣龙树菩萨的《宝鬘论》云：“一切法事主，应委精进人，不侵蚀聪智，知恩委大臣。”是说作为一切寺庙法事和转法轮的主管者，应委派精进的人管理佛教事务。在中国，自姚秦时姚苌就设僧官以僧契为僧正，其后历代有僧正司、僧主，僧录，僧录司等，虽是义学沙门戒德清严的僧人做僧官，管理僧人寺庙等，但都属政府部门管辖。清代有国师等，直到乾隆时废除僧官制，佛教则处于杂乱现象。在西藏管理更严，汉地喇嘛寺庙教区，亦派僧官管理，如五台山的扎萨克，就是由达赖喇嘛派遣经汉地政府允许，而到汉族教区管理喇嘛寺庙至解放时止。
    爱国爱教并不相违。佛教徒是国家的公民。有公民信仰宗教的权利，就有爱护自己祖国的义务，祖国是生育我们的母亲，有大恩德。既然是国家公民，一切要以国家利益和人民利益为重，至于信仰仅仅是个人的问题，不能把个人的信仰驾御在国家和人民利益之上。爱教的关键在于信佛者通过自身的努力修行，以信解智力培养建立对三宝的深厚感情，保护三宝荣誉，息世讥嫌，维护佛弟子的尊严。《起信论》云：“护持如来所制禁戒，不令见者有讥嫌，能使众生舍罪修善。”历史事实证明，凡古今中外持戒修行，学德兼备，利国利民，对佛教事业有所贡献的长者和大德法师，无不受到国家和人民的敬仰和尊重。如果处理好个人信仰与国家的主次关系，爱国爱教不仅没有矛盾，而且完全能够统一起来。
    佛教传入中国近二千年，形成了中国佛教文化，对中国的历史、政治、经济、哲学、文学、绘画，以及雕刻艺术都产生了巨大的影响作用，使佛教文化成为了中国文化宝库中的有机组成部分。中国各民族的先贤大德们所创造的佛教文化事业，正等着当今的佛弟子去搜集整理研究，继往开来发扬光大，为祖国的民族文化事业各尽微薄之力。因此，作好各项佛教事业，有利于国家建设，有利于民族团结，都是在为民族争光，为中国佛教增添光彩，这是国家的希望，也是广大佛教徒的希望。
    二、人间佛教
    有人说佛教是出世法，大乘人希求成佛，小乘人希求得解脱涅槃，为什么说“人间佛教”呢？对此很不理解。
    其实，佛陀主张一切事物都是因缘所生，宇宙万物都不是独立存在的（非自性有），而是“此有故彼有，此生故彼生”（《杂阿含》经卷十）。龙树菩萨在《中观宝鬘论》中云：“此有故彼有，如由长有短，此生故彼生，如由灯有光，有长故有短，非从自性有，如无有灯故，光亦不能生”。中观宗称此法义为“观待缘起”或“相待缘起”，为缘起性之一。故法不孤起，相輔相成，出世法是对世间法而言，没有世间就没有出世间，世间与出世间是相互观待而立名。如没有此岸生死，就没有彼岸涅槃，断尽三界烦恼，不受生死后有即名涅槃，不是另有涅槃可得。所以大乘人希求成佛，小乘人希求得解脱，都是在人间发心，人间修行而成圣果。若离开人间，即无圣果可言。
    释迦佛及一切诸佛，都是在人间发菩提心，在人间积集二资粮，修习难行能行的菩萨行，成无上正等正觉及说法教化亦在人间，其教法亦流传在人间，法身事业乃至三有未尽亦在人间利益众生。如《造像功德经》云：“诸佛如来人中生故，复于人中成等正觉，人中多有阿罗汉而得果故，诸大威德辟支佛，复于人间出现故”。是说三乘圣人都在人间发心、修行、证果和度生。他们都是人而不是神。如《增一阿含经》卷十八，佛告比丘“如来亦当有此生老病死，我亦是人数”。是说凡在人类，有五蕴之身，就免不了生老病死的自然规律，故佛告诸比丘，当寻求安乐寂静之法。
    可能有人会说地上菩萨不是往来天上人间及他方世界，一来圣人的“家家”往来天上人间，不还圣人的“三超”、“五般般”不是也在天上般涅槃吗？菩萨往来天上人间是为修菩萨行利乐有情，一来和不还圣人是在人间修行功期未满而示寂生天，证道在天中或在人间，因为烦恼的起因在于人间，断烦恼证菩提还得要利用人间有漏圆满之身的素质，方能断除有漏而证圣果。三恶道众生及天人之身都不具备修定断烦恼的条件，此即是人间佛教的原理。
    佛陀还教诫弟子应知恩报恩。佛陀认为不知恩报恩者就是无智之人。如《杂阿含经》卷四十七云：“是故诸比丘，当如是学知恩报恩，其有小恩尚报，终不忘失，况复大恩”。佛教徒深受三宝之法恩，父母养育之深恩，师长教诫之恩，国家和人民的护育之恩，是故，佛弟子应知恩报恩。
    释迦牟尼佛在人间说法四十九年，教法流传人间。人间佛教是说我们现正处在人间；佛陀所说的法又并没有离开人间实际；佛法还在人间存在，得闻佛法，又得暇满人身，正有为利乐有情发心修行，培植善根，积集福智二种资粮的良好机缘。菩萨在人间修行，主要应圆满三件大事，一是“庄严国土”（亦为“严净佛土”，或“严净佛刹”。又为在修庄严人间国土而感自己将来成佛的佛刹净土）；二是“利乐有情”（亦为“成熟有情”，又为在人间利益一切有情，令其善根成熟，为自己将来成佛而能受度）；三是愿圆满，如阿弥陀佛有四十八愿，其中就有愿自将来成佛的佛刹净土，及成佛应度的众生。所以在人间修行，只要有菩提大愿，将此身心奉献给祖国，奉献给人民，为利益人民所作的一切善法，无不是修菩萨行，无不是积集福智二种资粮，为自成佛道感得报化二身之福德资粮之因，如果了知诸法体空无我而修菩萨行，即是智慧资粮之因，为成就法身之体。所以佛说的三藏十二部契经，无不是说明世间与出世间的缘起因果关系，三乘圣人或修人天安乐者，都是在人间，只是各自发心的大小和修行的广狭不同，各自所得的果位有别，若离开人间，就没有审谛观察人间的苦乐和善恶因果缘起等所缘境，就无有情可利乐。这些缘起之理，真实不虚，因果宛然，法尔如是。

                回向偈
    愿消三障诸烦恼，愿得智慧真明了；
    普愿罪障悉消除，世世常行菩萨道。

    一九九五年复，任杰编撰并初讲于五台山塔院寺