目录

《大乘无上续论》
（《究竟一乘宝性论》新译）

    大乘无上续论
    弥勒菩萨 造
    堪布益西彭措 译

    大乘无上续论科判

    大乘无上续论释·善说日光
        遍知多罗瓦（笃补巴）著
        堪布益西彭措　译
         缘起品
         辨三宝种性中如来藏品第一
         辨三宝种性中菩提品第二
         辨三宝种性中功德品第三
         辨三宝种性如来事业品第四
         辨三宝种性中校量功德品第五


大乘无上续论

    大乘无上续论

    弥勒菩萨 造
    堪布益西彭措 译

    梵语云：摩诃衍那俄达Ra丹扎西扎
    藏语云：特巴钦波吉喇嘛丹珠
    汉语云：大乘无上续论

    顶礼一切佛菩萨！

    缘起品

    佛法僧及如来藏，菩提功德与事业，
    论体一切摄略说，如是七种金刚处。
    应知七种相次第，依照总持自在王，
    经序有三余四处，菩萨如来差别分。
    从佛有法从法僧，从僧获得藏智界，
    终获智慧胜菩提，力等具利众生业。
    谁无初中后三际，寂静自觉而证知，
    既已觉悟令他觉，宣说无畏常恒道，
    执胜智悲剑金刚，割截一切苦苗芽，
    摧诸见林疑虑墙，如是佛陀我敬礼。
    无为法体任运成，不依他缘而证知，
    具有圆满智悲力，具足二利唯佛陀。
    非初非中非后际，自性故是无为体；
    寂静法身自性故，应知称为任运成；
    唯以各别自证故，不依他缘而证知；
    证此三相故为智；宣说道故为大悲；
    依于智慧及大悲，断除苦惑故为力；
    以初三者成自利；末后三者成他利。
    非无非有非有无，亦非非有非无边，
    不可思量离言语，各别自证及寂灭，
    无垢智慧具光明，能破一切攀缘境，
    贪欲嗔恚愚痴暗，如是法日我敬礼。
    不思不二无分别，清净显现对治故，
    何法依何离贪欲，具二谛相是为法。
    远离贪欲自性者，灭道二谛所摄取，
    如其次第彼等亦，应以三三功德知。
    不思量故无言故，圣者自证故不思，
    寂故不二无分别，净等三者犹如日。
    此心自性光明故，照见烦恼本无实，
    真实证悟诸有情，无我真实际寂静，
    见众如来常随逐，具有无障净智者，
    见众清净遍无量，如是具慧我敬礼。
    如所尽所各别证，智慧见者清净故，
    具慧不退之僧众，定具无上之功德。
    众生寂灭之法性，证悟故为如所性，
    彼亦本来清净故，烦恼本来消尽故。
    所知究竟证悟心，现见一切有情众，
    具有遍知法性者，是故具有尽所性。
    如是证悟之彼者，依于各别自证见，
    无垢法界无著碍，是故彼等为清净。
    智慧见者清净故，佛陀智慧无上故，
    不退转众之圣者，是诸有情皈依处。
    由说佛法僧功德，依照三乘三供养，
    不同信解六种人，是故安立三皈依。
    可舍弃故虚妄故，无故具有怖畏故，
    二种法及圣者众，非为究竟皈依处。
    了义之中诸有情，皈依唯一是佛陀，
    能仁法性之身故，亦彼僧之究竟故。
    少出现故无垢故，具势力故世严故，
    殊胜故及不变故，以此六因称胜宝。
    真如有垢及无垢，无垢佛德佛事业，
    从彼生起三宝善，证悟胜义诸佛境。
    如是三宝此种性，遍知诸佛妙境界，
    彼亦四相依次第，以四根据不思议。
    清净而具杂染故，无而杂染而净故，
    法不离而不现故，任运而无分别故。
    所觉以及觉悟体，觉悟支及觉他故，
    依次所觉为净因，其余三者为净缘。
    大乘无上续论缘起品终

    如来藏品第一

    佛陀法身能现故，真如无有差别故，
    具种性故诸有情，恒时具有如来藏。
    佛智入诸有情故，自性无垢彼无二，
    佛性假立彼果故，说众皆具如来藏。
    本体因果业相应，行及分位遍行义，
    常恒不变德无别，是说胜义界密意。
    如净宝珠虚空水，自性恒时无杂染，
    信法以及增上慧，三昧大悲而出生。
    自在势力及不变，滋润本体自性故，
    彼等宝空水功德，是为相似对应法。
    于法嗔恨及我见，怖畏轮回之痛苦，
    舍离利乐众生事，是为四种障碍性。
    大欲有情及外道，声闻以及辟支佛，
    增上信等四种法，应知是为能净因。
    信解胜乘为种子，般若为母生佛法，
    禅乐胎处悲乳母，具足彼等诞佛子。
    净我大乐及恒常，功德波罗蜜多果，
    厌离轮回求涅槃，欲愿彼等之作业。
    彼等果者若总摄，以于法身四颠倒，
    不净无我苦无常，相反对治而获得。
    法身自性清净故，及断习气故为净；
    我与无我诸戏论，寂灭之故为圣我；
    彼意生身及其因，舍离故为大安乐；
    三有轮回及涅槃，证悟平等故为常。
    智慧断除我爱执，悲悯众生不住寂，
    智悲菩提方便力，圣者不住有寂边。
    倘若无有佛种性，不能厌离轮回苦，
    及不希求于涅槃，亦无希欲之愿心。
    于彼轮回及涅槃，观见苦乐之功过，
    此依具有种性有，何故于无种性无。
    犹如大海器宝水，无量功德无尽处，
    具有无别功德性，是故犹如酥油灯。
    法身以及如来智，大悲之因蕴涵故，
    如以具有器宝水，是故宣说如大海。
    神通智慧及漏尽，于彼真如体无别，
    犹如灯之明暖色，故与无垢界相似。
    依于凡夫及圣人，佛陀真如分类行，
    见真实者于众生，宣说如此如来藏。
    一切凡夫心颠倒，已见真实异于彼，
    如来如实不颠倒，远离一切诸戏论。
    不净以及不净净，极为圆满清净者，
    如是次第而宣说，凡夫菩萨与如来。
    于彼本体等诸义，以六所摄之法界，
    彼者于三分位中，以三异名而宣说。
    犹如具无分别性，虚空遍行于一切，
    心之自性无垢界，如是遍行于一切。
    共相法性能周遍，过失功德究竟位，
    犹如虚空能周遍，下中上等色相器。
    具有过失客尘故，具有功德自性故，
    本初如是后亦尔，真如法性无变易。
    犹如虚空遍一切，由体细故尘不染，
    如是佛性遍众生，一切烦恼亦不染。
    犹如器界一切法，依于虚空而生灭，
    如是有情之诸根，依无为界而生灭。
    犹如虚空以诸火，往昔何时未曾烧，
    如是佛性死病老，诸火亦复不能烧。
    地者依于水而住，水则依于风而住，
    风复依于虚空住，虚空不依地等住。
    如是一切蕴界处，住于业及烦恼中，
    此等行业及烦恼，住于非理作意中，
    此等非理作意者，住于心之清净中，
    心之自性诸法者，不住彼等诸法中。
    知蕴处界犹如地，有情业惑犹如水，
    非理作意犹如风，净心如空无基住。
    非理作意分别者，住于心之自性中，
    依于非理之作意，生起诸业及烦恼，
    依于业及烦恼水，生起有漏蕴处界，
    空中器界成坏般，如是有情生而灭。
    心之自性如虚空，无因以及无有缘，
    无有和合及无生，无灭亦无安住相。
    心之自性为光明，犹如虚空无转变，
    妄念所生诸贪等，客尘诸垢不能染。
    依于业及惑水等，不能令彼新生起，
    以死病老猛烈火，亦复不能焚烧彼。
    劫末地狱普通火，三者依次而对应，
    死病老之三种火，应知彼等相似法。
    菩萨如实知佛性，解脱生老病死等，
    离生等贫由证因，悲悯众生示生死。
    死病老之诸痛苦，圣者悉皆永灭尽，
    依于烦恼业力生，彼者无彼故无生。
    如实真实已见故，虽于生等已超离，
    然以大悲之自性，示现生死老病等。
    诸佛意子已证悟，不变法界真如性，
    无明令盲诸众生，见现生等诚稀有。
    若得圣者之境界，凡夫境界中显现，
    是故众生之至亲，善巧以及悲殊胜。
    彼者超越诸世间，依然安住于世间，
    为利世间现世间，世间障垢无染污。
    犹如莲花出于水，不为彼水所染污，
    如是佛子生世间，不为世间法所染。
    行持利他之事业，智慧恒如火炽燃，
    寂灭静虑之等持，恒时入此定境中。
    以宿善愿推动力，及离一切分别故，
    为令成熟诸有情，十地菩萨无勤作。
    说法以及现色身，利行及与诸威仪，
    何者以何如何调，此者如是皆通达。
    如是对于虚空际，无边有情恒时中，
    具慧任运无障碍，真实广行利生业。
    菩提萨埵后得时，事业相与诸善逝，
    真实救度诸有情，于此世间视平等。
    然如大地与微尘，亦如大海牛迹水，
    彼等差别极悬殊，佛与菩萨亦如是。
    不变性具无尽法，众皈无后际究竟，
    此常不二无分别，无灭法性非作故。
    清净法界无有生，无死无病亦无老，
    依次常故坚固故，寂灭故与不变故。
    佛性依于意生身，无生其性恒常故；
    依于不可思议死，无死其性坚固故；
    依于无明习气病，无害其性寂灭故；
    依于无漏之行业，无老其性不变故。
    当知以二复二句，亦复具有二二句，
    依次无为法界中，具有恒常坚固等。
    具有无尽功德故，如如不变常恒义；
    如同轮回无边故，皈依自性坚固义；
    无分别智自性故，无二法性寂灭义；
    具非造作功德故，自性不灭不变义。
    法身如来及圣谛，涅槃如光不离日，
    如是功德无二故，除佛之外无涅槃。
    总之无漏法界中，依于四种义差别，
    当知四种相应名，称为法身如来等。
    佛陀诸法不相离，及彼佛性如是得，
    不妄不欺之法性，本来自性寂灭性。
    遍知一切现菩提，已断障垢及习气，
    如来以及涅槃者，于胜义中无二性。
    一切诸相无数量，无思无垢之功德，
    无别体相即解脱，解脱彼者为如来。
    譬如种种绘画师，各自善巧各不同，
    某师了知能绘分，此分余人不知晓，
    此后于此由诸师，我之形貌当共绘，
    具权国王于彼等，下谕布绢赐与彼，
    从彼听闻此事已，着手绘画国王像，
    绘画王像画师中，若有一人去他方，
    由于彼人远行去，缺少彼者一人故，
    圆满王像遂不成。此喻此处如是知，
    所言彼等画师者，布施持戒忍辱等，
    具有殊胜诸方便，空性即说圆身像。
    般若以及智解脱，光明照耀及清净，
    无二是故如光明，光芒日轮无二般。
    是故乃至未得佛，真实涅槃不可得，
    如舍光明及光芒，日轮永时不可见。
    如是已说如来藏，十种意义而安立，
    今说烦恼所缠藏，当以九喻而了知。
    萎花中佛蜂中蜜，皮壳中果粪中金，
    地中宝藏果中芽，破衣之中宝佛像，
    贫贱丑女腹中王，焦泥模中妙宝像，
    客尘烦恼所障覆，众生如是佛性住。
    障垢犹如萎莲花，蜜蜂皮壳及粪秽，
    地蕴果皮破坏衣，苦逼丑女黑泥模。
    无垢佛性如佛身，蜂蜜果实及黄金，
    宝藏胚芽宝佛像，四洲圣王妙宝像。
    譬如萎败莲花中，安住相好庄严佛，
    具净天眼人见已，去除花叶显佛身。
    如是善逝佛眼见，阿鼻亦遍如来藏，
    无碍大悲于轮回，常住令众解脱障。
    犹如萎败莲花中，安住善逝佛陀身，
    无垢天眼见此已，去除凋残败坏叶。
    如是众生贪嗔等，烦恼缠中住佛性，
    大悲能仁见此已，善作摧毁障垢业。
    譬如上妙美味蜜，为诸群蜂所围绕，
    须者见已设方便，驱散群蜂而取蜜。
    大仙一切智眼见，犹如蜂蜜之佛性，
    彼之障垢如蜜蜂，善作彻底断除业。
    譬如蜜为百千万，蜜蜂障覆须求人，
    驱散彼等诸群蜂，随意而作蜂蜜事。
    如是众生所具有，无漏智慧如蜂蜜，
    善巧摧毁如蜂惑，智者佛陀如丈夫。
    譬如具壳之果实，众人不能得受用，
    凡欲食用果实者，去除皮壳取果实。
    如是众生所具有，佛性为诸惑垢杂，
    乃至未脱烦恼垢，三有不能作佛事。
    譬如稻谷麦等粮，果未脱壳具芒者，
    倘若果实未善治，众人不能享美味。
    如是众具法自在，未离烦恼之佛身，
    于为烦恼所逼众，不能赐予法喜味。
    譬如有人行路时，黄金遗失粪秽中，
    具有不坏之黄金，于彼安住百千年。
    具净天眼见金已，以语告示余人言，
    此中现有真金在，汝当还净起金用。
    如是能仁分明见，陷溺烦恼粪秽中，
    众生功德欲令净，于诸众生澍法雨。
    譬如腐烂粪秽中，坠入黄金天眼见，
    为令清净胜美金，认真显示于他人。
    如是佛陀已明见，烦恼不净大粪中，
    堕入有情圆觉宝，令净于众说圣法。
    譬如贫人家地下，具有无尽珍宝藏，
    主人于此无所知，宝藏不言我在此。
    如是意中珍宝藏，不增不减净法性，
    由未证故诸众生，恒时备受贫乏苦。
    譬如贫家地层下，已有宝藏对主人，
    宝藏不言我在此，主人不知有宝藏。
    如是意家法藏住，一切众生如穷人，
    为令彼等获此故，大仙真实降世间。
    譬如郁多罗等树，果中种芽未朽坏，
    种于地中灌水等，渐次生长成大树。
    一切有情无明等，果皮中缠法界善，
    如是若依彼彼善，渐次成为能仁王。
    譬如依水日风土，时间虚空之众缘，
    郁多罗及菴摩罗，果皮之内生长树。
    有情烦恼果皮内，具有正觉之胚芽，
    如是彼彼善缘力，见法次第渐增长。
    譬如宝成之佛像，臭秽破衣所缠裹，
    天人见彼在道中，为除秽衣此示他。
    佛陀无碍眼现见，诸惑缠裹如来藏，
    下至旁生亦具有，为令解脱示方便。
    譬如珍宝之佛像，臭秽破衣所缠裹，
    置于路中天眼见，为令解脱示他人。
    如是烦恼破衣缠，佛性安住轮回道，
    佛见旁生亦具有，为令解脱说妙法。
    譬如丑陋无怙女，住于无有依怙处，
    胎藏住持吉祥王，自腹有王不觉知。
    转生三有无怙家，不净众生如孕妇，
    具有怙主无垢界，如彼腹中转轮王。
    譬如身著破垢衣，丑女胎中轮王住，
    然于无怙寒舍中，感受猛厉之痛苦。
    如是心住佛性怙，无怙具心诸有情，
    由于烦恼心不静，是故安住痛苦处。
    譬如模中融金铸，宝像外有焦泥模，
    见已知者为清净，内金除去外泥障。
    佛见自性常明净，以及障垢亦客尘，
    众生犹如金泥模，令净诸垢成菩提。
    譬如无垢金铸成，象马等像藏模中，
    彼无垢故寂灭性，铸师知已除泥模。
    如是遍知佛陀见，犹如纯金寂灭意，
    以说妙法巧方便，善破模障令清净。
    萎败莲花与蜜蜂，皮壳粪秽及土地，
    果皮破坏垢秽衣，女人胎藏及泥模，
    佛身蜂蜜与果实，纯金宝藏及大树，
    佛像以及转轮王，纯金所铸宝像般。
    宣说众生无始来，具有烦恼客尘垢，
    无垢自性清净心，无始不离而安住。
    贪欲嗔恚痴随眠，猛厉现行及习气，
    见道修道不净地，清净地之所断障。
    如是九种障垢相，依于萎莲等显示，
    以随烦恼所缠覆，差别之相无有数。
    贪等九种障垢者，概要略说如次第，
    萎败莲花等九喻，依彼真实而宣说。
    以彼等垢令凡夫，罗汉学人及具慧，
    如其次第四一二，复二成为不清净。
    譬如淤泥水莲花，初敷荣时人欢喜，
    后萎悴时人不喜，欢喜贪欲亦如是。
    譬如爱命之蜜蜂，极其扰乱刺蜇击，
    如是生起嗔恚故，内心产生诸苦恼。
    譬如稻等内果实，外为皮壳所包裹，
    如是现见如来藏，痴心蛋壳所覆蔽。
    譬如粪秽不合意，如是具贪诸有情，
    依止五欲之因故，猛厉现行如粪秽。
    譬如财富由覆障，不知不得珍宝藏，
    如是众生自生智，无明习气地所覆。
    譬如芽等渐生故，种子皮壳即破裂，
    如是由见真实性，断除见道诸所断。
    依与圣道相连属，摧毁坏聚见核心，
    修道智慧诸所断，宣说犹如破坏衣。
    依于七地诸障垢，犹如胎藏之障垢，
    如同远离于胎藏，无分别智成熟般。
    随逐三地诸障垢，当知犹如泥土染，
    巨大智慧之自性，金刚喻定所摧毁。
    如是贪等九种垢，如同萎败莲花等。
    由三自性归摄故，种性如同佛身等。
    此之自性即法身，真如以及种性者，
    其中由三及一种，五种比喻当了知。
    当知法身有二种，法界最极清净体，
    以及依彼之等流，宣说深及种种法。
    当知由超世间故，世间此喻不可见，
    不可见故佛自身，所说与彼界相同。
    所说微细甚深法，犹如蜂蜜一味性，
    所说种种广大法，犹如种种壳中实。
    由于自性无变异，以及胜善及清净，
    是故宣说此真如，与彼真金性相同。
    犹如地藏及果树，当知佛性有二种，
    无始自性住种性，真实纳受胜种性。
    承许依此二种性，获得如来三种身，
    依于初者得初身，依于次者得后二。
    当知庄严自性身，犹如珍宝之佛像，
    自性本来非所作，摄集功德宝藏故。
    具大法王国政故，报身犹如转轮王，
    唯是影像自性故，化身犹如黄金像。
    自生诸佛之胜义，唯是依信所证悟，
    犹如日轮光晃耀，无眼目者亦不见。
    此无任何所遮遣，亦无纤毫所安立，
    真实正观真实性，真实见已即解脱。
    具有分离之体性，如来藏以客尘空，
    无有分离之体性，藏以无上法不空。
    处处经说诸法空，如云如梦如幻相，
    此中如来云何说，众生皆具如来藏？
    心怯轻慢劣众生，执著虚妄谤正法，
    增上我执五过失，为具过者断彼说。
    究竟清净真实际，以诸有为法而空，
    烦恼行业果报义，说为犹如浮云等，
    一切烦恼犹如云，行业犹如梦受用，
    烦恼行业之果报，五蕴犹如幻变化。
    先前如是安立已，复于无上续此中，
    为令断除五过失，宣说具有如来藏。
    如是未闻此善法，而以轻视自身过，
    心中生起怯弱者，菩提心者不生起。
    何者已生菩提心，由此故生我慢心，
    众生未生菩提心，于彼生起下劣想。
    如是于此思惟者，真实智慧不生起，
    是故执著虚妄法，及不能知真实义。
    由于改造客尘故，众生过失非实有，
    真实此过无有我，功德自性为清净。
    执著虚妄之过失，诽谤真实功德者，
    具慧自身与众生，不得现见平等慈。
    如是依于听闻此，勇悍敬众如导师，
    生起般若智大慈，由于生起此五法，
    无罪以及观平等，无有过失具功德，
    自与有情平等慈，依此疾得如来果。
    大乘无上续论辨三宝种性中如来藏品第一终。

    菩提品第二

    净得远离及二利，其依深广大自性，
    常住世间如实性，以此八义而宣说
    本体因果与事业，相应以及分类行，
    常住以及不思议，由此建立如来地。
    所谓自性之光明，犹如日轮与虚空，
    以客烦恼所知障，厚重云聚而遮蔽，
    遍具无垢佛功德，常坚不变之佛体。
    此依于法无分别，以及拣择智获得。
    佛性是由无别异，清净妙法所安立，
    犹如日轮与虚空，智慧离染二体相。
    光明非是所作性，无别超过恒河沙，
    是故本来即具足，佛陀功德之诸法。
    是由自性不成立，周遍以及客尘故，
    烦恼所知二障位，宣说犹如厚重云。
    断除二种障碍因，承许即是二种智，
    一者无分别智慧，二者依彼后得智。
    犹如具有无垢水，莲花渐荣遍满池，
    亦如圆满之月轮，罗睺口中得解脱，
    复如圆满之日轮，云聚烦恼中解脱，
    具有无垢功德故，具光明者即彼体。
    唯佛如同佛身蜜，果实真金及宝藏，
    果树无垢宝佛像，转轮圣王纯金像。
    如水池等贪欲等，客尘烦恼得清净，
    简要无分别智慧，其果如是而宣说；
    具有一切相殊胜，佛陀之身决定得，
    是依出定拣择智，其果如是而宣说。
    由断贪欲之浊尘，且于所化众莲中，
    降禅定水滋润故，佛如清净之池水；
    由脱嗔恚罗睺罗，且以大慈悲光明，
    普照一切众生故，佛如无垢之满月；
    由脱厚重愚痴云，且以慧光照群生，
    遣除无知黑暗故，佛如无垢之日轮。
    获得无等等法故，赐予无上法味故，
    远离二障皮壳故，佛如佛身蜜果实；
    净故真实妙功德，遣除有情贫穷故，
    解脱果赐众生故，佛如真金宝藏树。
    现前珍宝法身故，两足主尊最胜故，
    显示种种宝色故，佛如佛像王金像。
    无漏周遍不灭法，坚固寂常不变处，
    诸佛法身如虚空，能作圣者六根境，
    令见非大微妙色，令闻清净微妙音，
    令嗅善逝戒妙香，令尝大圣妙法味，
    令受三昧妙乐触，令知甚深胜妙理，
    倘若仔细而思惟，佛如虚空离诸相。
    总说二智之作用，应当如此而了知，
    成就圆满解脱身，及成清净法性身。
    解脱身与法性身，应知二相亦一相，
    无漏性故周遍故，无为法故依处故。
    烦恼习气灭尽故，承许即是无漏法；
    无著以及无碍故，承许智慧周遍行；
    毕竟无灭自性故，承许即是无为法。
    不灭性者为略说，由坚固等广说彼，
    当知灭者有四相，翻此坚固等法故，
    谓腐变异及间断，不可思议变易死，
    当知无彼故次第，坚固寂静常不变。
    为白净法所依故，无垢智慧是为处，
    犹如无相虚空界，见色闻声与嗅香，
    尝味觉触知诸法，皆由彼者作为因，
    如是为于佛二身，无碍加行坚固者，
    殊胜六根行境中，无漏功德能生因。
    不思常坚寂不变，静编离念如虚空，
    无著无碍除涩触，非见取善佛无垢。
    依于解脱法性身，显示自利及他利，
    自利他利之依处，具有不思等功德。
    一切种智之行境，如来非是三慧境，
    是故当知此智慧，一切有情不可思。
    微细故非闻慧境，胜义故非思慧境，
    法性甚深故亦非，世间修慧等行境。
    此因如盲不见色，凡夫从来未曾见，
    且如产房内婴儿，不见日轮圣亦尔。
    远离生故是恒常，无有灭故是坚固，
    无彼二故是寂灭，法性住故是不变。
    证悟灭谛故极静，觉悟一切故周遍，
    无所住故无分别，断烦恼故无耽著，
    清净一切所知障，是故一切皆无碍，
    无二堪能且调柔，是故远离粗涩触。
    彼无色故不可见，亦无相故不可取，
    自性净故胜善根，障垢断故极无垢。
    非初中后无别异，无二离三垢分别，
    证悟法界之自性，入定瑜伽师得见。
    无量超过恒沙数，具诸不思无等德，
    如来无垢法性身，尽断过失及习气。
    种种妙法光明身，勤修众生解脱义，
    事业犹如摩尼王，能现种种非彼体。
    世间令置寂静道，成熟授记因色身，
    不离法界恒安住，犹如诸色不离空。
    自生诸佛之遍知，唯称彼者为如来，
    最胜涅槃不思议，各别自证出有坏。
    彼者分类由深广，大自性三功德法，
    当知如是自性等，安立法报化三身。
    其中一切诸如来，自性身之五体相，
    摄略宣说当了知，具足五种功德相。
    无为法与无别异，以及遣除二种边，
    烦恼所知三摩地，三障决定得解脱，
    无垢无有分别心，诸瑜伽师境界故，
    由于法界自性力，本来清净故光明。
    无量无数不思议，无等清净之究竟，
    当知彼等诸功德，真实自性身具足。
    广大故及无数故，非为寻思境界故，
    唯佛习气亦断故，次第是为无量等。
    圆满受用诸法故，显示自性之法故，
    大悲清净之等流，利益众生无息故。
    无有分别任运中，所欲如实满足故，
    以如意宝神通故，圆满受用身安住。
    说法示现业不息，无有加行功用相，
    显现不是彼自体，此处种种示五相。
    如由种种形色物，摩尼中现非彼体，
    亦由众生种种缘，如来显现非彼体。
    依大悲心知世间，观照一切世间界，
    法性身中不动移，幻化种种之事业。
    天界出生圣白幢，从于兜率天宫降，
    入于母胎及降生，善巧通达工巧处，
    王妃眷属中嬉乐，出家修习诸苦行，
    往诣菩提道场中，降伏一切诸魔军，
    圆满菩提转法轮，趋入大般涅槃界，
    普于不净刹土中，轮回未空恒示现。
    演说诸法无常苦，无我寂静知方便，
    先令众生厌三有，后令悟入于涅槃。
    既入声缘寂灭道，具有已得涅槃想，
    妙法莲华等诸经，宣说诸法真实性，
    遣除彼等先前执，若以智慧方便摄，
    令彼成熟于胜乘。授与殊胜菩提记。
    甚深圆满大势力，善引凡夫同利故，
    彼等次第应称为，甚深广大大自性。
    此处初者为法身，其后二者为色身，
    如于空中色安住，于初身中后身住。
    由无量因众无尽，慈悲神足智具乐，
    得法自在灭死魔，无体世尊故常法。
    弃舍身命财三者，护持诸佛正法故；
    为利一切诸有情，究竟圆满本愿故；
    佛身净洁及澄清，大慈大悲生起故；
    神变神足力显示，彼者住世行持故；
    成就妙智于轮涅，取舍二执脱离故；
    恒常圆满而具足，无量等持大乐故；
    常住世间利益他，不为世间染污故。
    获得无死寂静处，无有死魔现行故；
    无为自性之能仁，本来极为寂静故；
    恒常是诸无依者，皈依处等合理故。
    由前七种无误理，显示色身恒常性，
    由后三种无误理，显示法身恒常性。
    非言语境胜义摄，非心所观超譬喻，
    无上轮涅不摄故，佛境圣亦不可思。
    不可思议离言故，离言胜义所摄故，
    胜义所摄非思故，非思超越比量故，
    超越比量无上故，无上轮涅不摄故，
    轮涅不摄不住故，不取轮涅过德故。
    前五正理微细故，如来法身不思议；
    第六正理自在故，如来色身不思议。
    无上智悲等功德，至德彼岸佛不思，
    是故诸佛最后相，自在大仙亦不知。
    大乘无上续论辨三宝种性中菩提品第二终。

    功德品第三

    自利他利胜义身，及依彼者世俗身，
    离系果与异熟果，功德分类六十四。
    自利圆满功德处，即一切佛胜义身，
    他利圆满功德处，即一切佛世俗身。
    初者法身十力等，离系功德皆具足，
    二者大丈夫相等，异熟功德皆具足。
    力破愚痴如金刚，处众无畏若狮子，
    善逝不共类虚空，佛现二身同水月。
    知处非处业异熟，种种根基种种界，
    种种信解遍趣行，染净二种静虑等，
    忆念自他之宿命，了知生死天眼通，
    寂灭烦恼习气智，如是宣说十种力。
    是处非处异熟界，众生种种信解性，
    遍趣行与染净定，种种根机忆宿命，
    天眼通及漏尽智，无明铠甲墙与林，
    能刺能摧能截故，佛力犹如金刚杵。
    诸法圆满觉菩提，一切诸障能禁止，
    宣说道谛及灭谛，如是四种无所畏。
    诸法自知令他知，道障自断令他断，
    入道自得令他得，说二利谛佛无畏。
    林中兽王常无畏，百兽群中自在行，
    佛陀狮王处众中，无畏善住坚势力。
    如来无过亦无诤，无有心意失念过，
    亦无不定散乱心，及无轮涅种种想，
    并无不择而舍置。志欲精进与正念，
    以及智慧与解脱，解脱知见不退失。
    三门事业随智转。智慧无碍知三世。
    如是十八及余法，是为佛陀不共德。
    佛身语意悉无过，心无动摇无异想，
    不择舍置亦远离，志欲精进清净念，
    无垢智慧及解脱，解脱知见均不退，
    诸业普随智导转，三世无碍广智行。
    觉彼不共大菩提，为众无畏转妙轮，
    此唯具足大悲者，一切中胜如来得。
    地等体相空中无，虚空体相色中无，
    然五大种世间共，不共世间尘许无。
    善住平满轮辐相，足跟广长趺不隆，
    手足诸指悉纤长，及如鹅王网缦相，
    肌肤柔软且细嫩，身体七处极隆满，
    伊尼延鹿王腨相，阴藏犹如大象王，
    上身犹如狮子王，肩脖隆满极丰腴，
    臂膀浑圆丰腴相，手软浑圆无高下，
    正立不俯手过膝，清净之身具圆光，
    颈项无垢如海螺，两颊平广似兽王，
    齿具四十上下等，亦极清净且密严，
    净齿长短粗细匀，大牙极胜洁白性，
    难思无边广长舌，品尝诸味得胜味，
    迦陵频伽自然声，梵音清澈深远闻，
    眼如莲花牛王睫，具净白毫严饰面，
    顶有肉髻肤金色，清净细薄众生尊，
    一孔生一细柔毛，右旋细轮向上靡，
    净发严如琉璃宝，身量端似尼拘树，
    普贤无譬大仙人，那罗延力坚固身，
    不思议相三十二，佛说此是人王相。
    犹如无云空月色，秋季湛海水中见，
    如是正觉坛城中，佛子能见遍主身。
    如是六十四功德，各自所具成就因，
    如其次第当依照，宝女问经而了知。
    由无毁坏无羸劣，无与伦比无动故，
    次第金刚狮子王，虚空水月喻显示。
    初六中三后一力，依此十力之次第，
    遣除所知三昧障，以及习气诸障故，
    如甲如墙如稠林，刺穿摧毁截断故。
    重精坚固不坏故，大仙势力如金刚，
    何以沉重由精华，何以精华由坚固，
    何以坚固由不坏，不坏是故如金刚。
    无畏惧故善住故，坚故势力圆满故，
    释迦狮子如狮子，处大众中无畏惧。
    正遍知故于何者，无所畏惧而安住，
    清净有情与自身，亦见不等故善住，
    心于一切诸法中，一缘安住故坚固，
    极细无明习气地，彻底越故具势力。
    凡夫声闻及独觉，具慧菩萨与如来，
    愈上智慧愈细微，故以五大喻显示。
    一切世间受用处，故如地水火风大，
    超越世出世间相，故不共法如空大。
    此等三十二功德，依止法身无别异，
    如如意宝光色形，彼等三者无别故。
    见时喜足功德者，所谓妙相三十二，
    依二色身即化身，圣法圆满受用身。
    依于垢净远近众，世间如来坛城中，
    见此有情有二种，如现水空月轮色。
    大乘无上续论辨三宝种性中功德品第三终。

    事业品第四

    所化界与调方便，所化界之调伏事，
    随所化处应时行，遍主恒时任运转。
    具足功德胜宝聚，智慧水海福慧日，
    诸乘无余定成就，广无中边如空遍。
    佛性功德无垢藏，已见众生无别具，
    烦恼所知云罗网，诸佛大悲风令散。
    何者依于何方便，调所化业何处时，
    于彼不生分别念，是故能仁恒任运。
    何者种种所化界，彼彼诸多调方便，
    所化种种之事业，何处何时任运行。
    出离以及彼显示，彼果以及摄受彼，
    彼障以及断障缘，于此无有分别故。
    所谓出离即十地，二种资粮是彼因，
    彼果乃为大菩提，菩提摄受诸有情，
    彼障无边诸烦恼，及随烦恼与习气，
    一切时中断障缘，彼者乃为大悲心。
    应知此等之六处，如其次第而宣说，
    犹如大海与日轮，虚空宝藏及云风。
    智水功德宝具故，诸地犹如广大海；
    为诸众生资生故，二种资粮如日轮；
    无有中边广大故，菩提犹如虚空界；
    正等正觉法性故，众生界如珍宝藏；
    客尘周遍无体故，彼障烦恼如云聚；
    具能散尽彼障故，大悲犹如猛烈风。
    由于他因得出离，自身有情见平等，
    事业尚未圆满故，轮回未空业不息。
    譬如帝释法鼓云，亦如梵天与日轮，
    摩尼宝王与谷响，以及虚空与大地。
    犹如自性净无垢，琉璃所成大地基，
    以其清净故映现，天主帝释天女众，
    以及胜利妙宫殿，此外其余诸宫殿，
    帝释无量宫种种，天界诸物皆现见。
    此后地上所居住，善男善女诸群众，
    已见彼等诸显现，心中能发如是愿，
    我亦无须极久远，即与帝释成同等，
    为获彼者真实持，白净善法而安住。
    彼等由于白善法，仅见此等影像现，
    虽不如实而了知，地上命终亦升天。
    显现影像彼等者，虽极无念无动摇，
    然而于此地基上，成就大义而安住。
    如是无垢信心等，修持信心等功德，
    自心中现正等觉，具有妙相及随好，
    从容行步及站立，端然而坐与卧息，
    作诸威仪妙姿态，有时宣说寂灭法，
    有时默然入禅定，显示种种神变相，
    具大威光极晃耀，有缘众生能见此。
    见已发起欲求心，为能成佛善修习，
    真实纳受成佛因，所欲之果能获得。
    净心显现之佛陀，虽极无念无动摇，
    然而于此世间中，成就大义而安住。
    此乃自心所显现，虽诸异生不能了，
    然由现见色身相，亦于彼等有义利，
    依见色身亦逐渐，安住大乘诸士夫，
    以智慧眼能照见，内具胜义法性身。
    犹如诸地离险难，具摩尼德光严净，
    如是无垢琉璃成，地面平正清净故，
    映现天主诸住处，天主及天眷属像，
    净地功德渐离故，则此不复再显现。
    为得彼者而修持，近住禁戒布施等，
    男女诸众发愿心，向空抛散妙花等。
    为能获得如琉璃，净心中现能仁果，
    具极欢喜诸佛子，善能发起如是心。
    犹如清净琉璃地，映现天主身影像，
    如是众生净心地，亦现能仁身影像；
    犹如帝释现不现，由地净与不净故，
    众生现不现影像，由心浊与不浊故；
    佛影虽现生与灭，然不能作生灭观。
    如天界中由诸天，往昔白法善业力，
    法鼓无勤无生处，亦无意色与分别，
    同时能说无常苦，无我寂静之法音，
    依此数数作警策，令诸天人不放逸。
    如是遍主虽远离，勤等然于诸有情，
    如来法音能周遍，于诸有缘宣说法。
    犹如天界妙法鼓，其音依于自业生，
    如是世间佛说法，其音众生自业生。
    如离勤作处身心，妙音令天得寂静，
    如是离勤等法音，令诸众生得寂静。
    譬如天城妙鼓声，彼因产生无畏施，
    烦恼心起战斗时，破诸修罗与嬉戏。
    如是由佛于世间，说法四禅四无色，
    彼因摧毁烦恼苦，开示无上寂静道。
    由于能遍众生界，具有利乐三神变，
    是故如来妙语声，超胜天界铙钹等。
    天界妙鼓发巨响，地居众生耳不闻，
    佛鼓妙音能遍行，轮回下界诸世间；
    天界乐器百千万，为增欲火而演奏，
    大悲诸佛仅一音，亦令息灭痛苦火；
    天界美妙铙钹声，唯增心之掉举因，
    大悲自性如来音，能令心入三摩地。
    总之宣说尽世间，天及地住安乐因，
    此等无余皆依靠，普世遍现佛圆音。
    犹如远离耳根故，不能听闻细音声，
    亦如具有天耳者，亦非遍闻一切声。
    如是微妙胜法音，微细智慧之境界，
    若心无有烦恼垢，彼人耳中方闻受。
    犹如夏季之云聚，庄稼茂盛圆满因，
    水蕴丝毫无勤作，自然降澍于大地。
    如是依于大悲云，佛陀圣教妙法雨，
    众生善根庄稼因，无有分别自然降。
    犹如世间行善时，风起云涌降雨霖，
    如是慈风为增善，佛云降澍圣法雨。
    于彼三有依智悲，不染轮涅住虚空，
    三昧总持净水藏，佛云善根庄稼因。
    犹如云聚中普降，清凉甘甜轻软水，
    由合地层盐咸等，遂成种种诸异味。
    如是广阔慈悲云，普降八支圣道雨，
    由合众生分类处，遂成种种异解味。
    于此最胜大乘法，具信中等及嗔者，
    此等三聚似三类，人类孔雀与饿鬼。
    犹如夏季无云雨，人苦孔雀住舍受，
    夏季地上降澍雨，令诸饿鬼受灼苦。
    诸佛大悲云聚中，法雨世间降不降，
    于法具信及嗔者，世间之中此譬喻。
    犹如空中降大雨，冰雹石类金刚火，
    微细含生入谷人，云于彼等无分别。
    善巧方便智悲云，普降细广妙法雨，
    惑净我见随眠众，佛于彼等无分别。
    轮回生死无始际，众生流转于五道，
    犹如粪秽无香气，五道之中无安乐。
    轮回痛苦恒如触，烈火利刃盐生苦，
    大悲云降圣法雨，善能平息此诸苦。
    已知天中死堕苦，人中亦有寻求苦，
    是故具有智慧者，人天殊胜亦不求。
    智慧以及随佛语，生起信解此是苦，
    此等业惑是苦因，此灭由智所见故。
    如病应知因须断，乐住当得药当依，
    苦因苦灭如是道，应知应断应触修。
    犹如梵天于住处，梵宫不动之同时，
    遍于欲天一切处，无勤自然而示现，
    如是能仁法身中，毫不动摇之同时，
    于世有缘无勤作，自然示现变化等。
    如梵恒住无量宫，不动遍入欲界天，
    诸天见彼妙色相，由此遣除五欲乐。
    如是佛于法身中，不动示现诸世间，
    有缘众生见欢喜，由此恒能净诸障。
    如依梵天昔誓愿，及与诸天善业力，
    梵天无勤而显现，佛陀化身亦复然。
    降入胎诞往父国，嬉乐苦行降魔军，
    证大菩提转法轮，涅槃无缘者不见。
    如日普照诸莲花，有花闭合有花绽，
    日于功过无分别，佛陀日轮亦复然。
    犹如日轮无分别，光明一时普照射，
    能令水花得增长，亦令他物得成熟。
    如是如来大日轮，放射圣法无量光，
    于诸所化众生莲，无有分别而照入。
    依靠法身及色身，菩提精藏虚空中，
    显现遍知大日轮，智慧光芒照群生。
    由于所化清净故，于彼一切水器中，
    如来日轮之影像，无量一时皆显现。
    恒时周遍于一切，法界虚空之中央，
    升起佛陀大日轮，应所化山次第照。
    如具千光日初升，照亮一切世间已，
    高中低山次第照，佛日次第照众生。
    一切国土虚空中，日轮不能普照射，
    无力破除无明暗，亦不能示所知境。
    大悲体性遍放射，种种彩色光明网，
    能为众生照明了，真实微妙所知境。
    佛陀进入聚落时，无目盲人重得目，
    远离无义诸恶法，见佛获利而觉受。
    无明瞎却溺有海，邪见暗覆诸有情，
    依于佛日光明照，慧光当见不见处。
    犹如如意宝珠王，虽无一切诸分别，
    一时同处诸有情，亦随所愿皆能满。
    如是依佛如意宝，种种意乐诸有情，
    虽闻种种差别法，然佛于彼无分别。
    如如意宝无分别，无勤赐予所求物，
    能仁无勤应众机，利他恒住三有中。
    蕴藏深海地下住，于彼心虽有欲求，
    然彼善妙如意宝，薄福众生亦难获。
    如是劣缘诸有情，为诸烦恼所执持，
    当知于彼垢心前，极难亲睹诸善逝。
    犹如一切谷响声，依于他缘而得起，
    无有分别无造作，不住外亦不住内。
    如是如来声亦然，依于他心而生起，
    无有分别无造作，不住外亦不住内。
    譬如无物无显现，无有所缘无所依，
    超过眼识之境界，无色不可示虚空，
    纵然于彼见高下，而彼虚空非如是。
    如是于佛见一切，然而其义非如是。
    譬如种种诸草木，依止大地得生起，
    大地无有分别心，亦令增固及成就。
    如是众生诸善根，依止佛地得生起，
    佛陀无有分别心，亦令增固及成就。
    由于未见无勤作，而能成办事业故，
    为除所化之疑惑，宣说此等九譬喻。
    于彼修多罗教中，广说此等九譬喻，
    经名佛境智庄严，亦示此等之必要。
    由闻此等所生智，广大光明所庄严，
    具足智慧之菩萨，速入佛陀诸境界。
    为示无勤事业义，已曾广说琉璃地，
    帝释影像等九喻，摄彼要义当了知，
    示现言说与周遍，幻化智慧放光芒，
    身口意之三秘密，获得大悲自性者。
    一切勤作相续灭，无有分别之智慧，
    犹如离垢琉璃上，映现帝释影像等。
    寂灭勤作是所立，无分别智是能立，
    为能成立自性义，喻者帝释影像等。
    此处所表此义者，已说示现等九种，
    导师远离生与死，无有勤作任运转。
    犹如帝释妙鼓云，梵天日轮如意宝，
    响空地般尽轮回，无勤利他瑜伽知。
    现身如宝现帝释，善说教诫如天鼓，
    遍主智悲广大云，遍至有顶无边众，
    如梵不动无漏界，示现种种变化相，
    如日智慧放光明，意密如净摩尼宝，
    佛语无字犹如响，身遍非色恒如空，
    如地众生白法药，一切所依为佛地。
    犹如琉璃净心地，彼为现见佛陀因，
    即彼清净心地者，增长不夺之信根。
    由自善根生与灭，故佛色身现生灭，
    然如帝释天主身，法界之身无生灭。
    如是远离诸勤作，无生无灭法身中，
    乃至三有未空时，转入示现等事业。
    以此诸喻摄要义，及其前后之次第，
    前喻难表不同分，后喻就同分宣说。
    诸佛如来如影像，非具音故非如彼，
    具妙音故如鼓音，非普利故非如彼，
    能普利故如大云，非断惑故非如彼，
    能除贪故如梵天，非竟熟故非如彼，
    能竟熟故如日轮，非常照故非如彼，
    能常照故如摩尼，非难得故非如彼，
    不可得故如谷响，依他缘故非如彼，
    不依缘故如虚空，非善依故非如彼，
    如是世间出世间，众生一切之圆满；
    乃为彼等所依处，是故犹如大地般，
    即依如来大菩提，出生出世间道故，
    亦成善法与诸禅，四无量及四空故。
    大乘无上续论辨三宝种性如来事业品第四终。

    校量功德品第五

    佛种性与佛菩提，佛陀法及佛事业，
    清净有情亦难思，此等唯是诸佛境。
    具慧信解佛境界，成佛功德聚之器，
    于此不思德聚喜，映蔽一切有情福。
    若人为求菩提果，珠宝严饰黄金刹，
    佛刹尘数日日中，供养一切诸法王，
    余人于此仅闻句，闻已生起胜解信，
    依此所生之福德，较前布施德更多。
    若有具慧为求取，无上菩提经多劫，
    身口意业无勤作，能护无垢诸律仪，
    余人于此仅闻句，闻已生起胜解信，
    依此所生之福德，较前持戒德更多。
    若人修持能息灭，三有烦恼火静虑，
    修持天梵至究竟，菩提不动之方便，
    余人于此仅闻句，闻已生起胜解信，
    依此所生之福德，较前静虑德更多。
    何故以施得受用，持戒升天定伏惑，
    慧断烦恼所知障，此胜闻彼为慧因。
    自性住与彼转依，彼功德及成就义，
    如来智慧之境界，四处如上已宣说。
    于彼具慧信解有，力及具足诸功德，
    成就速疾能获得，善逝果位之缘分。
    如此不可思议境，信有如我亦可得，
    得果具足诸功德，于此由信胜解故，
    欲勤正念及静虑，智慧等诸功德器，
    菩提心于此等中，定当恒时善安住。
    彼者恒住菩提心，故彼佛子不退转，
    圆满福德波罗蜜，以及诸善得清净。
    福德五种波罗蜜，于此无有三轮执，
    是故彼等皆圆满，断除违品是清净。
    施所生善是施福，戒所生善是戒福，
    忍定二种是修福，精进遍行于一切。
    三轮虚妄分别心，承许彼为所知障，
    悭等虚妄分别心，承许彼为烦恼障。
    若离智慧无余因，能断烦恼所知障，
    是故智慧最第一，慧依闻故闻最胜。
    如是依于正教理，为令自心纯一净，
    具信善圆之智者，亦为摄彼宣说此。
    依灯电宝日月光，具眼能见众色法，
    如是依佛义词法，乐说光明说此法。
    何者具义相应法，能断三界烦恼语，
    显示寂静之利益，即是佛说余翻此。
    何者唯依佛教法，无散乱心而宣说，
    与得解脱道相应，亦如佛经当顶受。
    何故较佛善巧者，于此世间一亦无，
    无余真如殊胜者，如理遍知知非他，
    是故大仙自安立，如是契经勿错乱，
    若坏能仁圣教规，故彼亦损圣教法。
    烦恼愚痴诸恶人，毁谤圣者并轻蔑，
    彼所说法彼皆以，妄计邪见而造作，
    是故具执邪见垢，智者与彼勿相合，
    犹如净衣可染色，垢腻染色非如是。
    慧劣远离白法信，倒慢往昔谤法障，
    执不了义为了义，贪著利养恶见制，
    亲近毁谤正法者，远离受持正法士，
    信解劣故将舍弃，出有坏之诸圣法。
    如畏毁谤甚深法，如是智者于猛火，
    毒蛇仇怨及霹雳，不应极生畏惧心。
    火蛇怨敌金刚火，彼等仅能断命根，
    不能令人深陷堕，极为可怖阿鼻狱。
    若由数近恶人故，具有恶心出佛血，
    杀父杀母杀罗汉，破坏最胜和合僧，
    若能思惟修法性，此人速疾从此脱，
    若人恶心谤圣法，此人焉能有解脱。
    三宝以及净种性，无垢菩提功德业，
    此七义处如理说，由此我获诸善根，
    以此普愿诸有情，面见无量光寿佛，
    见已生起净法眼，得证殊胜菩提果。
    依于何因何必要，如何宣说何者义，
    于彼等流何者说，以四偈颂已显示。
    四偈自净之方便，二偈损坏圣法因，
    其次依于四偈颂，即为显示诸果报。
    由说入佛眷属中，获得法忍菩提法，
    总之二种果法依，末后二偈作显示。
    大乘无上续论辨三宝种性中校量功德品第五终。

    吉祥无比城之大智者婆罗门宝珠金刚叔伯班智达萨迦那与释迦比丘具慧译师共译于无比大城。

    二○○四年藏历一月三十日

    译于圣地色达喇荣五明佛学院


大乘无上续论科判

    大乘无上续论科判

缘起品
    甲一、相应正论之名义
    甲二、成就大义之总礼
    甲三、具殊胜义之正论分三
      乙一、安立论体分三
        丙一、总标略说
        丙二、对照经典
        丙三、决定次第
      乙二、广说论支分二
        丙一、广说所得三宝之支分分三
          丁一、抉择三宝各自体相分三
            戊一、究竟皈依处佛宝之体相分三
              己一、以赞叹说佛宝
              己二、别说彼义
              己三、广说彼等对应
            戊二、佛所说圣教法宝之体相分四
              己一、以赞叹说法宝
              己二、别说彼义
              己三、彼等摄于二谛中
              己四、广说彼等对应
            戊三、持此法僧宝之体相分三
              己一、以赞叹说僧宝
              己二、彼等功德摄于二种之中
              己三、广说彼等对应分四
                庚一、广说证悟如所有法之功德
                庚二、广说证悟尽所有法之功德
                庚三、宣说彼等清净
                庚四、宣说彼是一切众生之殊胜皈依处
          丁二、安立三皈依之理分三
            戊一、观待必要安立三皈依
            戊二、后二者非究竟皈依
            戊三、抉择了义之皈依处
          丁三、宣说三宝之释词
        丙二、广说能得因缘之四金刚处分三
          丁一、共同宣说分四
            戊一、四金刚处唯是佛之境界
            戊二、显示彼等不可思议
            戊三、广说彼之根据
            戊四、安立因与缘
          丁二、别说各自体相分四

辨三宝种性中如来藏品第一
            戊一、所觉法界义分八
              己一、法界遍满一切
              己二、总标略说能遍者
              己三、其义广说分八
                庚一、以本体与因清净义分二
                  辛一、合能净所净
                  辛二、别说各自本体分二
                    壬一、所净本体义
                    壬二、能净因义分二
                      癸一、断除四障
                      癸二、以对治成为佛子
                庚二、果与业成就义分二
                  辛一、合说所得能得
                  辛二、广说各自体相分二
                    壬一、所得果义分三
                      癸一、断除颠倒相
                      癸二、获得四种果
                      癸三、解脱于二边
                    壬二、能得作业分二
                      癸一、若无种性不能了知取舍
                      癸二、若有种性则有了知功过之作业
                庚三、诸功德相应义分二
                  辛一、合说因果功德
                  辛二、别说各自功德分二
                    壬一、因功德相应义
                    壬二、果功德相应义
                庚四、以补特伽罗分类之行义分二
                  辛一、以三者宣说分类之行义
                  辛二、彼等渐次清净理
                庚五、分位差别唯名分析分二
                  辛一、于三分位安立异名
                  辛二、以三名摄六义之理
                庚六、如空遍行义分二
                  辛一、无分别周遍一切
                  辛二、共相无差别理
                庚七、恒时不变义分二
                  辛一、宣说不变之分位
                  辛二、其义广说分三
                    壬一、不净位不变分二
                      癸一、如空无变理分三
                        子一、略说
                        子二、广说分五
                          丑一、有法显现生灭理
                          丑二、法性无灭理
                          丑三、广说实相分三
                            寅一、比喻
                            寅二、意义
                            寅三、彼等对应
                          丑四、以客尘成立轮回理
                          丑五、自性无变理
                        子三、摄义
                      癸二、宣说彼等差别分二
                        子一、无变法性以生灭空
                        子二、变异与三火相同
                    壬二、不净净位不变分二
                      癸一、宣说以生等不变之真实义分二
                        子一、不变似现变之理
                        子二、其义广说分二
                          丑一、以痛苦不能转变
                          丑二、以大悲示现变异
                      癸二、认定十地佛子功德分五
                        子一、已生菩提心之功德
                        子二、已入殊胜行之功德
                        子三、获不退转之功德
                        子四、成最后有之功德
                        子五、成办二利差别之功德
                    壬三、极净位不变分二
                      癸一、略说不变易
                      癸二、其义广说分三
                        子一、远离生等义分二
                          丑一、分别宣说
                          丑二、广说对应
                        子二、摄义并承上启下
                        子三、安立常等之根据
                庚八、功德无二义分二
                  辛一、以名略说
                  辛二、其义广说分三
                    壬一、广说异名分二
                      癸一、以四义说四名
                      癸二、名义对应而说
                    壬二、广说意义分二
                      癸一、广说无二义
                      癸二、广说解脱义
                    壬三、彼等以比喻了知分二
                      癸一、绘画喻之义
                      癸二、日轮喻之义分二
                        子一、以四法与日轮相似
                        子二、除佛外无究竟涅槃之理
              己四、摄义并启下义
              己五、依启下义以喻宣说分二
                庚一、有垢真如共同相似对应分三
                  辛一、如来藏周遍众生之理分二
                    壬一、略说
                    壬二、宣说喻义对应
                  辛二、广说其喻义分九
                    壬一、萎花中佛之喻义对应分三
                      癸一、萎花中佛身之喻
                      癸二、烦恼中佛性之义
                      癸三、喻义对应
                    壬二、群蜂中蜜之喻义分三
                      癸一、群蜂中蜜之喻
                      癸二、烦恼中佛性之义
                      癸三、喻义对应
                    壬三、壳中果实之喻义分三
                      癸一、壳中果实之喻
                      癸二、烦恼中佛性之义
                      癸三、喻义对应
                    壬四、粪中金之喻义分三
                      癸一、粪中金之喻
                      癸二、烦恼中佛性之义
                      癸三、喻义对应
                    壬五、地下宝藏之喻义分三
                      癸一、地下宝藏之喻
                      癸二、烦恼中佛性之义
                      癸三、喻义对应
                    壬六、果皮中胚芽之喻义分三
                      癸一、果皮中胚芽之喻
                      癸二、烦恼中佛性之义
                      癸三、喻义对应
                    壬七、破坏衣中宝佛像之喻义分三
                      癸一、破坏衣中宝佛像之喻
                      癸二、烦恼中佛性之义
                      癸三、喻义对应
                    壬八、贫贱丑女腹中怀轮王之喻义分三
                      癸一、贫贱丑女腹中怀轮王之喻
                      癸二、烦恼中佛性之义
                      癸三、喻义对应
                    壬九、泥模中金像之喻义分三
                      癸一、泥模中金像之喻
                      癸二、烦恼中佛性之义
                      癸三、喻义对应
                  辛三、总摄而说无前际之理
                庚二、宣说各自相似对应分二
                  辛一、显示障垢之差别分四
                    壬一、能障障垢之分类
                    壬二、以彼等障覆法界之理
                    壬三、广说各自喻义对应
                    壬四、再摄总义
                  辛二、显示自性法界分三
                    壬一、略说九喻显示三法
                    壬二、显示分别喻义
                    壬三、广说分别喻义分三
                      癸一、法身之喻义分二
                        子一、显示法身之分类
                        子二、彼等与比喻对应
                      癸二、真如之喻义
                      癸三、种性之喻义分三
                        子一、以喻显示二种性
                        子二、由此获得三身之理
                        子三、彼等与比喻对应
              己六、所说义以信心了知
              己七、认定所证空性
              己八、以彼等宣说之必要分二
                庚一、以问答略说分二
                  辛一、提问
                  辛二、答复
                庚二、其义广说分二
                  辛一、二转法轮宣说空性之密意
                  辛二、此无上续典中宣说法界如来藏之功德分三
                    壬一、为除过失而说法界如来藏
                    壬二、过失如何产生之理
                    壬三、由遣除过失速得功德之理

辨三宝种性中菩提品第二
            戊二、觉性之菩提义分三
              己一、略说所讲义之分类
              己二、讲法总标而说
              己三、其义广说分七
                庚一、净得本体及因义分二
                  辛一、略说净得
                  辛二、其义广说分二
                    壬一、具二净本体之义分二
                      癸一、真实
                      癸二、差别分二
                        子一、自性光明之差别
                        子二、离垢清净之差别
                    壬二、能得智慧因义
                庚二、远离障垢之果义分二
                  辛一、以喻略说无垢
                  辛二、其根据广说分三
                    壬一、以二智慧出生二身之理
                    壬二、由断三毒成就二利之理
                    壬三、由净障垢获得实义之理
                庚三、自他二利之事业义分二
                  辛一、略说成就二利义
                  辛二、其义广说分三
                    壬一、总说成办二利之理
                    壬二、别说自利圆满
                    壬三、别说他利圆满
                庚四、具足功德义分二
                  辛一、以异名略说
                  辛二、广说根据分二
                    壬一、于何者具功德之理
                    壬二、所具之功德分二
                      癸一、广说甚深之根据分三
                        子一、总标不可思议之理
                        子二、广说彼之差别
                        子三、根据与比喻对应
                      癸二、宣说其余之根据分三
                        子一、不变之功德
                        子二、断证之功德
                        子三、清净之功德
                庚五、三身分类之行义分二
                  辛一、略说体相之异门分三
                    壬一、自性身之体相及五种功德
                    壬二、报身亦具五种差别相
                    壬三、化身具有三种功德
                  辛二、其义广说分三
                    壬一、略说共同安立分类
                    壬二、安立各自体相分三
                      癸一、安立自性身体相分二
                        子一、略说体相及功德
                        子二、广说彼等分二
                          丑一、广说体相
                          丑二、广说功德
                      癸二、安立报身体相分三
                        子一、广说报身体相
                        子二、复摄彼义
                        子三、随缘示现
                      癸三、安立化身体相分二
                        子一、殊胜化身示现十二相
                        子二、其作业次第引导众生分三
                          丑一、安置平凡者于小乘道
                          丑二、安置小乘于大乘道
                          丑三、安置大乘于解脱位
                    壬三、彼等摄义分二
                      癸一、对应根据摄于三义之中
                      癸二、对应实际摄于二义之中
                庚六、于众生未尽间彼等常住义分二
                  辛一、略说常住之根据
                  辛二、其义广说分三
                    壬一、色身常住之根据
                    壬二、法身常住之根据
                    壬三、对应二身摄义
                庚七、如实不可思议义分二
                  辛一、略说
                  辛二、广说分三
                    壬一、依次宣说根据
                    壬二、对应二身摄义
                    壬三、功德不可思议之理

辨三宝种性中功德品第三
            戊三、觉之功德义分二
              己一、对应二身功德之分类分二
                庚一、分别宣说身与功德
                庚二、彼等各自分类
              己二、抉择功德之分类分四
                庚一、总标略说喻义对应
                庚二、广说各义分二
                  辛一、广说自利胜义法身具离系功德分三
                    壬一、十力分二
                      癸一、所表义之本体
                      癸二、依能表比喻了知
                    壬二、四无畏分二
                      癸一、认定本体之义分二
                        子一、认定本体
                        子二、其作用
                      癸二、以比喻了知彼义
                    壬三、十八不共法分二
                      癸一、真实义分二
                        子一、十八不共法各自之分类分二
                          丑一、广说分四
                            寅一、行所摄六法
                            寅二、证所摄六法
                            寅三、事业所摄三法
                            寅四、智慧所摄三法
                          丑二、摄义并说余义
                        子二、复说上义及获得之理
                      癸二、喻义对应
                  辛二、色身异熟果功德分二
                    壬一、所表之三十二相
                    壬二、以能表比喻归摄
                庚三、以经教了知彼等功德
                庚四、以喻义复摄其义分二
                  辛一、总说喻义相同
                  辛二、别说彼等各自喻义对应分二
                    壬一、宣说离系果法身之功德分二
                      癸一、展开以比喻表示分三
                        子一、以金刚喻表示十力分二
                          丑一、别别表示
                          丑二、共同表示
                        子二、以狮子喻表示无畏分二
                          丑一、略说
                          丑二、广说
                        子三、以虚空喻表示不共法
                      癸二、归纳无差别之理
                    壬二、宣说色身异熟果之功德分二
                      癸一、三十二相依报化二身而住
                      癸二、以月喻表示二色身
            戊四、觉他行之事业义分二

辨三宝种性如来事业品第四
              己一、显示任运相续不间断分二
                庚一、略说分二
                  辛一、略说任运
                  辛二、略说相续不间断
                庚二、广说分二
                  辛一、宣说任运
                  辛二、宣说相续不间断分五
                    壬一、以名宣说分类
                    壬二、宣说义之本体
                    壬三、以比喻表示彼等
                    壬四、广说喻义
                    壬五、相续不间断之摄义
              己二、以比喻了知分四
                庚一、总标以比喻分类
                庚二、对应意义别别宣说分九
                  辛一、应以帝释喻宣说显示种种神变之理分三
                    壬一、虽无分别成就他利分二
                      癸一、能表比喻分四
                        子一、净地基中现影像
                        子二、由此安置善业中
                        子三、以彼善业获得所欲果
                        子四、无勤成办利益之理
                      癸二、所表之义分四
                        子一、于净心中现色身
                        子二、以彼成就所欲果
                        子三、无勤成就利益
                        子四、渐次得究竟法身
                    壬二、与彼者善加对应而宣说
                    壬三、摄义说无生灭相
                  辛二、应以妙法鼓喻了知宣说教诫之理分三
                    壬一、以天鼓妙音宣说圣法分二
                      癸一、广说喻义相同之根据分三
                        子一、无勤作
                        子二、由业出生
                        子三、由此成就寂灭
                      癸二、又复善加对应摄义
                    壬二、亦超此等诸喻分二
                      癸一、略说
                      癸二、广说
                    壬三、彼等由缘而入
                  辛三、应以云喻了知智悲周遍之理分四
                    壬一、与生长庄稼相似而对应分二
                      癸一、略说无勤作之理
                      癸二、宣说由缘而入
                    壬二、与器变异相似而对应分二
                      癸一、宣说比喻
                      癸二、宣说其义
                    壬三、与不观待相似而对应分三
                      癸一、以三喻略说
                      癸二、广说其义
                      癸三、无观待而入
                    壬四、寂灭诸火相似而对应分三
                      癸一、能寂灭苦火聚
                      癸二、次第生起能寂灭之智慧
                      癸三、依照了知取舍而修行
                  辛四、应以梵天喻了知种种幻化相之理分二
                    壬一、于有缘者示现显现分三
                      癸一、宣说无勤作故相似
                      癸二、宣说除过失故相似
                      癸三、宣说对有缘者示现故相似
                    壬二、于无缘者不示现显现
                  辛五、应以日轮喻了知智慧照射之理分四
                    壬一、于利害无分别
                    壬二、无分别而利他分三
                      癸一、由无分别利他
                      癸二、由放射光明利他
                      癸三、由一时同现利他
                    壬三、由缘分差异而次第显现分二
                      癸一、略说
                      癸二、广说
                    壬四、超胜比喻之理分二
                      癸一、由光明超胜之理
                      癸二、以作用超胜之理
                  辛六、应以如意宝喻了知意之秘密分二
                    壬一、成就所欲故说相似分二
                      癸一、无分别成就一切所求
                      癸二、无勤作恒时安住之理
                    壬二、难得故说相似
                  辛七、应以谷响喻了知语之秘密分二
                    壬一、比喻
                    壬二、意义
                  辛八、应以虚空喻了知身之秘密分二
                    壬一、比喻
                    壬二、意义
                  辛九、应以大地喻了知遍入之理分二
                    壬一、比喻
                    壬二、意义
                庚三、宣说必要并归摄该处之义分二
                  辛一、宣说必要并以喻义分类分四
                    壬一、成就必要与必要之必要之理
                    壬二、归摄彼等喻义而说
                    壬三、所立等三义之对应
                    壬四、该处无勤作之理
                  辛二、别说以比喻表示之理分二
                    壬一、宣说比喻之分类
                    壬二、宣说喻义对应
                庚四、复归纳说差别分二
                  辛一、色身显现生灭而法身无生灭之理分二
                    壬一、以帝释喻说无生灭
                    壬二、相似故以所有比喻宣说相续不断。 237
                  辛二、相似故显现相同法然亦超胜彼者分二
                    壬一、略说
                    壬二、广说

辨三宝种性中校量功德品第五
          丁三、于四金刚处生起信解之利益分二
            戊一、以殊胜赞叹之方式宣说分二
              己一、四金刚处难证之理
              己二、证悟彼者获益之理分二
                庚一、超胜其余方便善根分二
                  辛一、略说
                  辛二、广说分三
                    壬一、超胜布施供养
                    壬二、亦超胜持戒
                    壬三、亦超胜修行
                庚二、能得殊胜智慧之根据
            戊二、以异门说彼分二
              己一、得究竟利益
              己二、得入道利益分二
                庚一、发心生起无上菩提心之利益
                庚二、加行趣入六度之利益分四
                  辛一、圆满波罗蜜
                  辛二、彼等摄于三类福中
                  辛三、认定违品二障之体相
                  辛四、获殊胜对治之智慧
      乙三、圆满作业分二
        丙一、广说所讲之义分三
          丁一、如何造论之理分五
            戊一、依何而说
            戊二、为何而说
            戊三、依如何宣讲之理而说
            戊四、所讲经典之体相
            戊五、恭敬顶受彼之等流
          丁二、断损害正法之理分三
            戊一、认定清净之方便而教诫依止分二
              己一、断自臆造
              己二、断偏袒执
            戊二、认定毁坏之因而教诫断除
            戊三、断除失坏甚深法之果分二
              己一、断恶趣之理
              己二、断轮回之理
          丁三、回向造论善根
        丙二、由讲解之方式摄义而宣说
    甲四、善巧翻译此论


大乘无上续论释·善说日光　缘起品

    大乘无上续论释·善说日光

    遍知多罗瓦 著
    堪布益西彭措 译

    敬礼具德诸圣师，敬礼吉祥圆成实，
    于有于无不损増，如实安住证悟说，
    此等一切圣众前，敬礼供赞诚皈依。
    实相甚深之究竟，基果究竟如来藏，
    金刚瑜伽道究竟，敬礼承诺说彼义。
    世俗诸法空之基，无变十二圆成实，
    得彼证彼说彼者，诸佛菩萨我敬礼。
    善显彼义弥勒怙，圣者无著与世亲，
    以及龙树父子等，传承上师我敬礼。
    何论畅演如来藏，于彼我今撰略释。
    于此《大乘无上续论》相合具德圣者无著的注释宣说，其义分四：一、相应正论之名义；二、成就大义之总礼；三、具殊胜义之正论；四、善巧翻译此论义。
    甲一、相应正论之名义：
    梵语云：摩诃衍那俄达Ra丹扎西扎
    藏语云：特巴钦波吉喇嘛丹珠
    汉语云：大乘无上续论
    甲二、成就大义之总礼：
    顶礼一切佛菩萨！

    缘起品
    今当以三义宣说具殊胜义之正论：
    甲三、具殊胜义之正论分三：一、安立论体；二、广说论支；三、圆满之作业。
    乙一、安立论体分三：一、总标略说；二、对照经典；三、决定次第。
    丙一、总标略说：
    佛法僧及如来藏，菩提功德与事业，
    论体一切摄略说，如是七种金刚处。
    所谓总标，即是从广大义中摄集精粹要义授予弟子，由此极易使其了知而且也能断除广说论支时的增减，或者也是为了使讲者不致于紊乱论体并且易于宣讲，以及明确显示本论含摄于几种法义中之相。
    此亦，所得即是自他二利究竟的正等觉佛陀之义，具有离欲二谛自性的圣法之义，以及具有二智不退转的圣僧之义。能得彼等之理是：真实之所证——众生种性或界的自性清净如来藏之义，证悟的本体是如来藏一切障垢净除的无上菩提之义，证悟的支分是与大菩提相属并以离系与异熟所摄的诸功德之义，能令他人证悟的方便是由功德力任运自成且相续不断的如来事业之义，此是最后所说之义。
    若概略而说，下文所说一切论支的总体或有事即是如是如金刚般的七处或句，亦即，彼等七义不是语言所能诠说而是各别自证智所证的缘故，以闻思所成智慧难以证悟，故如金刚宝一般。《密续》云：“金刚称为不可分。”如是所说。能诠的语言文字也能显示彼等自性并能使人理解，故称为处，以渐次成为证悟诸所诠义的基或所依的缘故。
    丙二、对照经典：
    应知七种相次第，依照总持自在王，
    经序有三余四处，菩萨如来差别分。
    当知如是七种金刚处各自的体相或本体之间相互关联的严密次第，如本论般，在《陀罗尼自在王菩萨请问善说如来大悲经》1的序分中显示了前三种金刚处。彼经云：“薄伽梵平等证一切法，善转法轮，善能教化调伏无量弟子众。”等。其余四种金刚处在序分后，复说具慧菩萨有六十种道法净治功德垢染，以此显示初者如来藏。如《赞法界颂》云：“有藏勤作故，能见黄金等，无藏虽勤作，唯一生烦恼。”以有净除障垢之基的法界自性清净如来藏，为令彼现前而修净治则为合理故。何为六十种净治法？即是菩萨的四种庄严、八种光明、十六种大悲以及三十二种事业2。复次，后三种金刚处由经中宣说如来八十种差别法可以了知。彼亦，宣说佛种性后，又以宣说有十六种无上菩提大悲心显示菩提；又以宣说有十力、四无畏、十八不共法显示功德，当按下文所说；又以宣说如来三十二种无上大业显示事业，如经云：“善男子，此等为如来三十二种事业。”同时宣说了事业与具事业者。
    丙三、决定次第：
    从佛有法从法僧，从僧获得藏智界，
    终获智慧胜菩提，力等具利众生业。
    何故次第如是？由觉悟一切诸法大平等性的正等觉佛陀转妙法轮才有圣法，由依教奉行出生所调伏的无量弟子圣众，由成僧众，各自藏智界获得部分障垢清净的具缘后，在渐次修持三摩地的最终，获得自性法界智慧远离一切客尘障垢而圆满显露的殊胜菩提，与彼同时，也获得其支分的十力等无量诸功德后，由彼等产生具有成办所化一切利益的诸事业法。因此如是宣说本论的次第。
    乙二、广说论支分二：一、广说所得三宝之支分；二、广说能得因缘之四金刚处。
    丙一、广说所得三宝之支分分三：一、抉择三宝各自体相；二、安立三皈依之理；三、宣说三宝之释词。
    丁一、抉择三宝各自体相分三：一、究竟皈依处佛宝之体相；二、佛所说圣教法宝之体相；三、持此法僧宝之体相。
    戊一、究竟皈依处佛宝之体相分三：一、以赞叹说佛宝；二、别说彼义；三、广说彼等对应。
    己一、以赞叹说佛宝：
    谁无初中后三际，寂静自觉而证知，
    既已觉悟令他觉，宣说无畏常恒道，
    执胜智悲剑金刚，割截一切苦苗芽，
    摧诸见林疑虑墙，如是佛陀我敬礼。
    佛陀无有初际生、中际住、后际灭的有为法三相故，是无为法；寂灭戏论与虚妄分别故，是任运自成；如来不依其他、唯以各别自证智自觉自悟故，是不依他缘而证知；如是由具有此等三法自已成佛后现量证悟一切所知故，是智慧圆满；欲令未如是证悟的众生都证悟自己所证的境界而为彼等宣说不畏轮回并能现量现前不退转常恒法身的妙道故，是大悲圆满；如是执持如宝剑金刚杵般的智悲，依次以宝剑般的智悲割截如苗芽般能生后后刹那痛苦的近取蕴，以金刚杵般的智悲摧毁如稠林般的我执我所执等诸见所围绕的如坚固牢墙般的疑虑故，是力圆满。对于具足如是六法及二利究竟的佛陀，我恭敬顶礼！
    己二、别说彼义：
    无为法体任运成，不依他缘而证知，
    具有圆满智悲力，具足二利唯佛陀。
    前颂宣说佛陀所具有的六种或八种功德是：非以因缘生故，是具有无为法不迁变的功德；毫无勤作故，是任运自成的功德；自证自知故，是不依他缘证知的功德；具足此三相故，是智慧功德；安置他众于彼中故，是大悲功德；能遣除众生的苦因与苦果故，是具力功德；以彼本体分为六种。或者，以反体分为两类，前三种是自利圆满的功德，后三种是他利圆满的功德。若总摄一切而言，唯独佛陀具有八种功德。
    己三、广说彼等对应：
    非初非中非后际，自性故是无为体；
    寂静法身自性故，应知称为任运成；
    唯以各别自证故，不依他缘而证知；
    证此三相故为智；宣说道故为大悲；
    依于智慧及大悲，断除苦惑故为力；
    以初三者成自利；末后三者成他利。
    以先前赞叹宣说的彼等根据及其后所说的分类依次安立并作宣说，即是：佛非是初中后三际生住灭的有为法自性故，是无为法；是无余寂灭一切身口戏论及虚妄分别等勤作的法身自性故，称为事业任运自成；唯是以各别自证自生智慧的所证故，是不依他人宣说等缘而证知；证悟具足如是无为法等三种功德的法界于一切有情无有差别故，是具足圆满智慧；为引导所化众生并将他们安置于究竟地，契合机缘极明显宣说出世间正道故，是具足圆满大悲；具足圆满力之事业者，是以上述智慧与大悲二者能遣除诸有情痛苦的近取蕴以及其因一切烦恼故；其中，以前三种功德成就自利圆满，因为法界无为法任运自成是各别自证智的行境，并且断尽一切有漏贫乏、具足无漏大乐故，自利究竟；以后三种功德成就他利圆满，因为如同智慧照见所化界般由大悲趋入后，以事业也随欲能成就一切利益。
    戊二、佛所说圣教法宝之体相分四：一、以赞叹说法宝；二、别说彼义；三、彼等摄于二谛之中；四、广说彼等对应。
    己一、以赞叹说法宝：
    非无非有非有无，亦非非有非无边，
    不可思量离言语，各别自证及寂灭，
    无垢智慧具光明，能破一切攀缘境，
    贪欲嗔恚愚痴暗，如是法日我敬礼。
    圣法——法界真如自性胜义谛在各别自证的境界中具有故，不堕断无边；世俗客尘诸法从本以来无生故，不堕常有边；彼等不是别别异体遮另一者故，互相相违故，也不是有无和合的二俱边；由不成立有无二俱故，破除有无二俱之外的非二俱边也不可思惟衡量，是故从四边戏论中解脱；以能表名言不可言说并真实超越语言境界故，离能诠词句；以比喻及比量等无法抉择并超越分别心的境界故，唯是诸圣者各别自证智之所证，因此不可思议；寂灭轮回根本的业惑二者故，是不二；寂灭其因的非理作意故，无分别。彼等都是灭谛所摄。以无有根本烦恼及随烦恼习气的障垢故，是清净；以具足远离所知障的一切种智光明故，是显现；以尽断于一切所缘境中悦者生贪、不悦者生嗔、中品者生痴的如黑暗般的一切烦恼故，是对治。以三种义成为如日轮般的圣法，彼等为道谛所摄。我恭敬顶礼！
    己二、别说彼义：
    不思不二无分别，清净显现对治故，
    何法依何离贪欲，具二谛相是为法。
    前颂宣说了法宝所具有的六种或八种功德，即是：以名言与分别心不可思议的功德，无业惑二者的功德，无彼等之因非理作意的功德，清净烦恼障的功德，显明（所知）智慧光明的功德，遣除三毒烦恼的对治功德，以本体分为六种。或者，以反体分为两类，即前三者果之“何法”是离欲之灭谛，以后三者因之“依何”是能离欲之道谛。具有涅槃二谛体相的八种功德者，即是圣法。
    己三、彼等摄于二谛之中：
    远离贪欲自性者，灭道二谛所摄取，
    如其次第彼等亦，应以三三功德知。
    所谓离欲的自性是圣法，彼由离欲之果的灭谛及能离欲的道谛所摄。如其次第，应知彼等二谛依次以不思、不二、无分别三种功德宣说了具有二种清净的灭谛之义，由清净、显现、对治三种功德宣说了能净的道谛之义。
    己四、广说彼等对应：
    不思量故无言故，圣者自证故不思，
    寂故不二无分别，净等三者犹如日。
    以先前赞叹宣说的彼等根据以及其后所说的分类依次安立并作宣说，即是：所得究竟灭谛法者，执著有、无、有无二俱、非二俱四边的寻思分别不能思量故，非是声音、名言、词句等言说境界故，是圣者入根本定各别自证智证知故，由如是三种根据，以世间分别心不可思议；寂灭有漏业及能引生彼者的烦恼故，是不二；寂灭彼等之因的非理作意故，是无分别。如《不增不减经》云：“舍利弗，如来法身清凉3，以不二法故，以无分别故。”；能得此法身之因是见修道的功德——清净及“等”字所摄的显现与对治，当知此三相由三种相似故，犹如日轮，彼亦，与日轮的清净相似者是远离随烦恼的障垢，与能显色法相似者是能照见一切所知相，与对治黑暗相似者是能对治见真如的一切障碍的缘故。
    戊三、持此法僧宝之体相分三：一、以赞叹说僧宝；二、彼等功德摄于二种之中；三、广说彼等对应。
    己一、以赞叹说僧宝：
    此心自性光明故，照见烦恼本无实，
    真实证悟诸有情，无我真实际寂静，
    见众如来常随逐，具有无障净智者，
    见众清净遍无量，如是具慧我敬礼。
    彼不退转菩萨已现量现前对治法的自性光明故，照见所断烦恼本体本来无生。从菩萨真实证悟一切有情自性无有人法二我之际或法界寂灭戏论的角度，是如所有智，从见法性正等觉如来法身周遍随逐于一切有法众生的角度，是尽所有智。彼等亦，如其次第于境著碍之障无有的智——出世间智具有的角度，具有了知一切有情之法界清净及彼于无边有情周遍的能境故，具足于一切所知智见清净，因此成为一切众生殊胜的皈依处。于彼，我恭敬顶礼。
    己二、彼等功德摄于二种之中：
    如所尽所各别证，智慧见者清净故，
    具慧不退之僧众，定具无上之功德。
    前颂宣说僧宝所具的两种功德，即是：缘如是本具的所境法性真如后，诸圣者与其他不共的内各别自证智之见以著清净故，是如所有智的功德；缘所境有法一切有情周遍具有法性后，诸圣者与其他不共的内各别自证智之见以碍清净故，是尽所有智的功德。由具有彼等故，于正觉大菩提不退转的具慧菩萨僧宝决定超胜声缘，故具有无上智慧的功德。
    己三、广说彼等对应分四：一、广说证悟如所有法之功德；二、广说证悟尽所有法之功德；三、宣说彼等清净；四、宣说彼是一切众生之殊胜皈依处。
    庚一、广说证悟如所有法之功德：
    众生寂灭之法性，证悟故为如所性，
    彼亦本来清净故，烦恼本来消尽故。
    以各别自证智现量证悟一切有情之心是本来寂灭戏论的法性故，称为如所有智性。彼亦，由证悟心的本体是极为清净光明故，由证悟彼客尘烦恼以本来无生而消尽故。
    庚二、广说证悟尽所有法之功德：
    所知究竟证悟心，现见一切有情众，
    具有遍知法性者，是故具有尽所性。
    以证悟所境一切所知有事及彼究竟真如的出世间智慧心，现量照见一切有情周遍具有一切种智的法性如来藏，亦即以各别自证智现量见，故是具有尽所有智。此见者从一地开始生起，已证悟法界遍行义故。
    庚三、宣说彼等清净：
    如是证悟之彼者，依于各别自证见，
    无垢法界无著碍，是故彼等为清净。
    如是以如所有智与尽所有智证悟出世之道，即是以不共于其他的诸圣者各别自证智照见，彼亦，由转入周遍一切的自性无垢法界故，无烦恼之著，以及证悟彼者周遍一切所知故，无所知之碍，是故彼等二智观待仅见少分的智慧也是极为清净的。
    庚四、宣说彼是一切众生之殊胜皈依处：
    智慧见者清净故，佛陀智慧无上故，
    不退转众之圣者，是诸有情皈依处。
    以如所有智与尽所有智见所境以著碍清净故，邻近佛陀无上智慧故，现量见法性且于正觉菩提不退转的诸圣者是从痛苦中救度众生的皈依处。
    丁二、安立三皈依之理分三：一、观待必要安立三皈依；二、后二者非究竟皈依；三、抉择了义之皈依处。
    戊一、观待必要安立三皈依：
    由说佛法僧功德，依照三乘三供养，
    不同信解六种人，是故安立三皈依。
    由宣说究竟皈依处导师佛陀的功德，见彼功德后，三乘中欲求获得佛果的诸大乘人，以及在能作三供养中向二足尊佛陀着重殊胜供养的信解者，针对他们将三皈依中的佛陀安立为第一皈依处；由宣说佛教圣法的功德，见彼功德后，三乘中寻求证悟甚深缘起法的诸缘觉人，以及在能作三供养中向离欲尊正法着重殊胜供养的信解者，针对他们将三皈依中的圣法安立为第二皈依处；由宣说入佛教法修学弟子僧众的功德，见彼功德后，三乘中追随他人寻求获得彼果的诸声闻人，以及在能作三供养中向众中尊僧宝着重殊胜供养的信解者，针对他们将三皈依中的僧宝安立为第三皈依处。
    总之，以三种义对六种人安立三皈依，此是使诸有情渐次趣入而宣说的。
    戊二、后二者非究竟皈依：
    可舍弃故虚妄故，无故具有怖畏故，
    二种法及圣者众，非为究竟皈依处。
    此颂宣说暂时的法与僧不是究竟皈依处。其中，以名词文句所摄的教法，虽是了知总相的唯一所依，然而现量证悟时则如已过河的船筏般应当舍弃；证法也有两种，以何者能证之道法具有有为法的体相故，是无常、非谛实如浮云之相，故具有虚妄欺诳性；由彼所证的灭法中，佛陀所证的虽是究竟者，但声闻所证的无余涅槃则如灯灭般仅是没有烦恼和痛苦；僧者，即使断尽三有的阿罗汉于五蕴也如有人执剑欲来害己而恐怖般寻求从彼中出离，以及诸菩萨亦须修学故，未达无畏佛位故，彼等一切也以具有怖畏的方式皈依佛陀。由此等诸因，教证二法和除佛外的圣僧是暂时皈依处，并非究竟果位时也是恒时殊胜的皈依处。
    戊三、抉择了义之皈依处：
    了义之中诸有情，皈依唯一是佛陀，
    能仁法性之身故，亦彼僧之究竟故。
    在了义之中，从痛苦中救度无量有情并恒时不灭的殊胜皈依处唯一是正等觉佛陀，而法与僧虽说是暂时皈依处，彼等究竟者也是如来，因为以上述“谁无初中后三际”等安立的能仁是具有涅槃二谛相离欲究竟的法性身，三乘僧众是以断证而分判，彼等究竟者也是现前佛陀法身的缘故。
    丁三、宣说三宝之释词：
    少出现故无垢故，具势力故世严故，
    殊胜故及不变故，以此六因称胜宝。
    梵语“那”具有稀有殊胜与宝二义，此处以六种相似法故，三宝与宝相似。彼亦，与宝在世间极少出现相似，多劫未修二资善根的诸人对于三宝连值遇也不可得，因此少出现；与宝清净无垢相似，三宝也无有一切过失障垢；与宝具有能遣除衰败并赐圆满的势力相似，三宝也具有神通等功德聚的不可思议势力；与宝成为世间庄严相似，三宝也是使一切众生的内心成为贤善之因故，成为一切世间的殊胜庄严；与宝珠超胜一般制造品相似，三宝超胜世间故，于一切法中成为殊胜；与宝以赞呵不变相似，三宝是无为法的自性故，以信与不信等缘何时也不变易。以此六因，三宝是稀有殊胜。
    以下，由何等获得出世清净之源将成就三宝，依彼而广说。
    丙二、广说能得因缘之四金刚处分三：一、共同宣说；二、别说各自体相；三、彼等利益。
    丁一、共同宣说分四：一、四金刚处唯是佛之境界；二、显示彼等不可思议；三、广说彼之根据；四、安立因与缘。
    戊一、四金刚处唯是佛之境界：
    真如有垢及无垢，无垢佛德佛事业，
    从彼生起三宝善，证悟胜义诸佛境。
    所谓有垢真如，是未从烦恼壳中解脱的众生位的法界，也称为如来藏。所谓无垢真如，是如来藏以修道远离一切客尘障垢而究竟转依的体相，在佛地，称为如来法身。所谓无垢佛功德，是以与法身不离的十力、四无畏、十八不共法等离系果及三十二妙相等异熟果所摄的一切诸佛法。所谓佛事业，是以十力等真实功德力相应各各众生的无上事业，利益众生任运成就并相续不断恒时饶益。如是从彼等四金刚处的因缘中出生三宝善的妙理，唯一是具有现量证悟法性胜义谛究竟智慧的诸佛的境界。
    戊二、显示彼等不可思议：
    如是三宝此种性，遍知诸佛妙境界，
    彼亦四相依次第，以四根据不思议。
    出生三宝果的种性——因缘四金刚处，彼等如实之义唯一是现量见一切所知的诸佛智慧的微妙境界，亦即彼等义——如来藏等四金刚处依次以下颂所说的四种根据，诸士夫不可思议。
    戊三、广说彼之根据：
    清净而具杂染故，无杂染而清净故，
    法不离而不现故，任运而无分别故。
    何为四种根据？即是：
    有垢真如如来藏之义，是具有心的自性本来清净的同时也有以暂时客尘障垢杂染的缘故，似现两种相违法集于一体，因此不可思议。所谓不可思议，意即不是信甚深因缘法的声缘的境界。如《胜鬘经》云：“佛告胜鬘言：‘天女，自性清净心而有染污难可了知。有二法难可了知，谓自性清净心难可了知，彼心为烦恼所染亦难了知。天女，如此二法，汝及成就大法菩萨摩诃萨乃能听受，诸余声闻辟支佛等，唯依佛语信此二法。’”
    无垢真如菩提之义，是丝毫不被前际垢染所染污，又由修道后令一切障垢极为清净的缘故，看似显现相违，因此不可思议。如经云：“心自性清净，自性清净心本来清净，如彼心本体，如来如是知，是故如来一念相应慧得阿耨多罗三藐三菩提。”
    无垢佛功德之义，是十力等无量胜义功德在遍具杂染的凡夫位也是本来不离具有而不现前的缘故，看似显现相违，因此不可思议。如《华严经》云：“复次，佛子，如来智慧无处不至。何以故？以于一切众生界中，终无有一众生身中不具足如来功德及智慧者，但众生颠倒不知如来智，远离颠倒，起一切智、无师智、无碍智。”
    佛事业之义，是无勤作任运自成且恒时相续不断相应所化机缘而作，能满所欲，也没有作此作彼的分别的缘故，看似显现相违，因此不可思议。如《陀罗尼自在王经》云：“善男子，汝依此譬喻，应知如来业不可思议故，平等遍至故，一切不可呵故，三世平等故，不断绝三宝种故，诸佛如来虽如是住不可思议业中，而不舍离虚空法身，虽不舍离虚空法身，而于众生随所应闻名字章句，为之说法，虽为众生如是说法，而常远离一切众生心所念观。何以故？以如实知一切众生诸心行故。”
    戊四、安立因与缘：
    所觉以及觉悟体，觉悟支及觉他故，
    依次所觉为净因，其余三者为净缘。
    以此等四金刚处也能总摄一切所知。其义如何呢？彼亦，有垢如来藏自性清净是所觉之处，远离一切障垢的菩提是觉悟自体之处，与菩提相属的诸功德是觉悟支分之处，功德力的事业是能令他人觉悟之处，故四金刚处依次：第一金刚处有垢真如是清净之因，由如来藏清净障垢而出生三宝故；后三金刚处是能净助缘。
    丁二、别说各自体相分四：一、所觉法界义；二、觉悟本体菩提义；三、觉悟支分功德义；四、觉他行之事业义。


大乘无上续论释·善说日光　如来藏品

    如来藏品第一

    其中就有垢真如，为了宣说一切众生都具有如来藏而首先讲解：
    戊一、所觉法界义分八：一、法界遍满一切；二、总标略说能遍者；三、其义广说；四、摄义并启下文；五、依启下义以喻宣说；六、以信心了知所说之义；七、认定所觉之空性；八、诠示宣说之必要。
    己一、法界遍满一切：
    佛陀法身能现故，真如无有差别故，
    具种性故诸有情，恒时具有如来藏。
    佛智入诸有情故，自性无垢彼无二，4
    佛性假立彼果故，说众皆具如来藏。
    由正等觉佛陀之法身照见一切法而周遍故，轮涅一切之法性真如无有差别故，一切众生都有佛性法界自性清净且障碍能净故，一切有情无始以来恒时相续不断具有胜义如来藏。如经云：“世尊云：一切众生恒时具有如来藏。”
    己二、总标略说能遍者：
    本体因果业相应，行及分位遍行义，
    常恒不变德无别，是说胜义界密意。
    下文所说的内容归纳而言，即是：法身真如如来藏本来自性清净本体义；如来藏上客尘障垢能遣方便的信解等因义；彼法界离一切障垢而获佛位功德的四波罗蜜果义；以具有如来藏为根据而有见轮回过患后生起厌离、见涅槃功德后生起欲求的业义；如来藏中具有信解等因功德及神通等果功德的相应义；以不同所依补特伽罗有法对能依法性也作三种分类的行义；虽抉择行义自性无差别，然以三种补特伽罗分类，在三分位中唯以异名宣说的分位义；如是如虚空般法界随行一切分位的遍行义；虽周遍一切所依但恒时不为彼等过失功德所改变的不变义；于不变真如中诸断证究竟功德的无别义。
    当知以如是十种义善加辨别而抉择了法性胜义谛法界自性清净的密意。
    己三、其义广说分八：一、以本体与因清净义；二、果与业成就义；三、诸功德相应义；四、以补特伽罗分类之行义；五、分位唯名分析义；六、如空遍行义；七、恒时不变义；八、诸功德无别义。
    庚一、以本体与因清净义分二：一、合说能净所净；二、别说各自本体。
    辛一、合说能净所净：
    如净宝珠虚空水，自性恒时无杂染，
    信法以及增上慧，三昧大悲而出生。
    犹如如意宝珠自性清净、虚空自性清净、水自性清净般，如来藏法界也具有恒时自性无杂染障垢的清净本体义。对于大乘法的信解、证悟无我的增上智慧、无量具足安乐的三摩地以及缘一切有情的大悲，此四法是客尘障垢的能净因，从彼等出生的菩提，则是离系果。
    辛二、别说各自本体分二：一、所净本体义；二、能净因义。
    壬一、所净本体义：
    自在势力及不变，滋润本体自性故，
    彼等宝空水功德，是为相似对应法。
    当知依次就三自性的自相而言，如来法身具有能如意满足一切所愿等的自在势力故，与如意宝珠相似；真如在一切分位中自性不迁变故，与虚空相似；种性是周遍一切众生的大悲滋润本体的自性故，与水的功德相似。也应了知，就彼等三者的共相而言，是恒时无障垢且自性本来清净故，与如意宝珠、虚空、水三者自性清净的功德相似。
    壬二、能净因义分二：一、断除四障；二、以对治成为佛子。
    癸一、断除四障：
    于法嗔恨及我见，怖畏轮回之痛苦，
    舍离利乐众生事，是为四种障碍性。
    大欲有情及外道，声闻以及辟支佛，
    增上信等四种法，应知是为能净因。
    对大乘法嗔恨、执着补特伽罗等我见、怖畏轮回痛苦而自求寂灭安乐以及舍离利乐众生事业的四种人，依次是大欲者、外道、声闻及辟支佛。以彼等障碍现量现前如来藏故，是四种障碍性。能清净彼等之因，是恒时修习对大乘圣法的增上胜解与“等”字所摄的智慧度、无量三摩地、大悲此等道法四相。
    癸二、以对治成为佛子：
    信解胜乘为种子，般若为母生佛法，
    禅乐胎处悲乳母，具足彼等诞佛子。
    譬如具有种子、生母、安乐胎藏、乳母这四种因缘，则能生育转轮王子。如是，此处信解三乘中的殊胜大乘是一切殊胜功德的根本，故如种子；证悟无我的智慧是能出生一切诸佛功德法之因，故如生母；不失坏且增上虚空藏等禅定的安乐，故如安乐胎藏处；大悲能养育，故如乳母。如是具足此等四法者，是由能仁正等觉佛意所生之子并能延续慧命的缘故，是佛子菩萨。
    庚二、果与业成就义分二：一、合说所得能得；二、广说各自体相。
    辛一、合说所得能得：
    净我大乐及恒常，功德波罗蜜多果，
    厌离轮回求涅槃，欲愿彼等之作业。
    如是修习四种对治遣除四种障碍后，获得如来法身净波罗蜜、我波罗蜜、乐波罗蜜及常波罗蜜，即获得具有胜义的四波罗蜜功德，是果义；生起厌离轮回、希求寂灭涅槃以及欲愿修道，则是具种性的作业义。
    辛二、广说各自体相分二：一、所得果义；二、能得作业义。
    壬一、所得果义分三：一、断除颠倒相；二、获得四种果；三、解脱于二边。
    癸一、断除颠倒相：
    彼等果者若总摄，以于法身四颠倒，
    不净无我苦无常，相反对治而获得。
    彼亦，信解、智慧、禅定、大悲是能清净法界的四种因，简略而言，彼果即是获得为了遣除法身不净、无我、痛苦、无常四种颠倒而依次以对治所安立的具有净、我、乐、常四种波罗蜜功德。
    癸二、获得四种果：
    法身自性清净故，及断习气故为净；
    我与无我诸戏论，寂灭之故为圣我；
    彼意生身及其因，舍离故为大安乐；
    三有轮回及涅槃，证悟平等故为常。
    究竟果如来法身者，由共相自性本来清净及其别相无余断尽一切客尘障垢及习气故，是净波罗蜜；寂灭以外道等遍计的我执戏论及以声闻等遍计的无我执戏论故，是圣我波罗蜜；灭尽痛苦故，离意生身，灭尽业惑之集故，舍离其因无明习气地的烦恼并且也灭尽一切无漏业故，是大乐波罗蜜；如是证悟彼三有轮回与寂灭涅槃于究竟真实义中自性平等故，是二利相续不断的常波罗蜜。亦即，胜义法界自性者，本来清净故，所减轮回无常的过失丝毫无有，故不堕断无边；本来任运自成故，所增涅槃常法的功德丝毫无有，故不堕常有边，因此成立是离二边的大般涅槃。
    癸三、解脱于二边：
    智慧断除我爱执，悲悯众生不住寂，
    智悲菩提方便力，圣者不住有寂边。
    以智慧无余断尽爱著五蕴的我执及随眠故，不会如大欲有情堕于三有边；以大悲心悯怜一切众生故，为成办彼等利益的具慧菩萨也不会如声缘堕于仅获寂灭痛苦之边。如是依靠证悟无我的智慧和缘有情大悲，即依靠修习能得无上菩提的两种殊胜方便，诸圣者菩萨不住三有轮回或寂灭涅槃的任何一边而现前无住大涅槃。
    壬二、能得作业分二：一、若无种性不能了知取舍；二、若有种性则有了知功过之作业。
    癸一、若无种性不能了知取舍：
    倘若无有佛种性，不能厌离轮回苦，
    及不希求于涅槃，亦无希欲之愿心。
    倘若根本不存在佛种性或法界自性清净如来藏，则应成诸有情不会生起见轮回过失后对轮回痛苦的厌离心，也不会生起见涅槃安乐的利益后希求获得彼者的心，也不会欲求能得彼者的方便之道，以及无有希欲行持其义之心，但实际并非如此。
    癸二、若有种性则有了知功过之作业：
    于彼轮回及涅槃，观见苦乐之功过，
    此依具有种性有，何故于无种性无。
    于三有轮回及寂静涅槃，依次见彼等有彼彼苦乐功过后，生起对三有痛苦过失的厌离心及对涅槃安乐功德的欣求心，此等是由具有佛种性而出生的。何以故？彼等取舍之心，暂时对于无增上种性的邪定聚者，如《亲友书》所说“生中依善友，以发于正愿，先身为福业，四大轮全获”般，乃至对三乘中任一法未生信解之间，无有此见有寂功过故。
    庚三、诸功德相应义分二：一、合说因果功德；二、别说各自功德。
    辛一、合说因果功德：
    犹如大海器宝水，无量功德无尽处，
    具有无别功德性，是故犹如酥油灯。
    犹如广阔海器中蕴涵着无量宝珠和海水，如是，信解法界的广大器也是具有无量定慧功德宝珠与大悲水的无尽处，故具有因功德义。并且于自性无别而具有神通、无漏智及漏尽等功德，故如酥油灯的光明、暖热及色相无别般，法界具有果功德义。
    辛二、别说各自功德分二：一、因功德相应义；二、果功德相应义。
    壬一、因功德相应义：
    法身以及如来智，大悲之因蕴涵故，
    如以具有器宝水，是故宣说如大海。
    清净法身之因的信解、获得如来智之因、转入大悲之因或界，彼等无余蕴涵而住故，依次与巨器、宝、水三者相似，由此宣说法界如大海。
    壬二、果功德相应义：
    神通智慧及漏尽，于彼真如体无别，
    犹如灯之明暖色，故与无垢界相似。
    在自性无垢处的如来藏中，五神通、无漏智、真如无余转依的漏尽通，彼等无别而住，故如灯的光明、暖热、色相彼等无别安住一般。
    庚四、以补特伽罗分类之行义分二：一、以三者宣说分类之行义；二、彼等渐次清净理。
    辛一、以三者宣说分类之行义：
    依于凡夫及圣人，佛陀真如分类行，
    见真实者于众生，宣说如此如来藏。
    依于凡夫的真如、圣人的真如、圆满正等觉的真如而作三种分类，现量见真如的一切种智佛陀于诸有缘所化众生极明显地宣说此自性清净如来藏法界。
    辛二、彼等渐次清净理：
    一切凡夫心颠倒，已见真实异于彼，
    如来如实不颠倒，远离一切诸戏论。
    一切凡夫想、行、见解都是颠倒；现量见四谛法性真如的诸圣者与彼相反，即想、行、见解无倒见真实；如来如实无颠倒见一切法并断尽二障与习气故，无任何戏论。如是依所依三类补特伽罗的分类，也将能依法界真如分为三类。
    庚五、分位差别唯名分析分二：一、于三分位安立异名；二、以三名摄六义之理。
    辛一、于三分位安立异名：
    不净以及不净净，极为圆满清净者，
    如是次第而宣说，凡夫菩萨与如来。
    彼如来藏有以客尘障垢不净、不净净以及极善清净的三种分位，如是依次以三种异名宣说为凡夫、菩萨与如来。
    辛二、以三名摄六义之理
    于彼本体等诸义，以六所摄之法界，
    彼者于三分位中，以三异名而宣说。
    由以上广说本体义及“等”字所摄的因义、果义、作业义、相应义、行义此六种义所摄的自性清净法界者，于彼不净、不净净、极善净的三分位中，仅仅是以假立的凡夫、菩萨、如来三种异名分别宣说而已，实际在本体上没有丝毫差别。
    庚六、如空遍行义分二：一、无分别周遍一切；二、共相无差别理。
    辛一、无分别周遍一切：
    犹如具无分别性，虚空遍行于一切，
    心之自性无垢界，如是遍行于一切。
    犹如具有无分别且无质碍的虚空无差别遍行于有事的色法般，如是，心的自性光明本来无垢法界也如是无差别而遍行于凡圣一切分位。
    辛二、共相无差别理：
    共相法性能周遍，过失功德究竟位，
    犹如虚空能周遍，下中上等色相器。
    自性清净法界是一切诸法的共相或法性，故能平等周遍于具过失的凡夫位、具功德的菩萨位及功德究竟的如来位，犹如虚空能平等周遍于下品色相的土器、中品色相的铜器及上品色相的金器一般。
    庚七、恒时不变义分二：一、宣说不变之分位；二、其义广说。
    辛一、宣说不变之分位：
    具有过失客尘故，具有功德自性故，
    本初如是后亦尔，真如法性无变易。
    有人认为：彼法界先前有垢而后来具功德，故有变易。并非如此，因为先前有垢位的过失客尘也是能远离且非自性，后来清净位所现前的十力等诸功德也是自性无离具足，并非忽尔生起，所以如同先前安住轮回时是存在，后来涅槃时也如是恒时不变，不变者即是此法界的法性或自性。
    辛二、其义广说分三：一、不净位不变；二、不净净位不变；三、极净位不变。
    壬一、不净位不变分二：一、如空无变理；二、宣说彼等差别。
    癸一、如空无变理分三：一、略说；二、广说；三、摄义。
    子一、略说：
    犹如虚空遍一切，由体细故尘不染，
    如是佛性遍众生，一切烦恼亦不染。
    譬如虚空虽能周遍一切色法，然由其体微细即非色法之粗故，以色法的无常等过失不染污，如是周遍安住于一切众生的心之自性光明如来藏自性本来清净，以众生的烦恼等过失何时也不染污。
    子二、广说分五：一、有法显现生灭理；二、法性无灭理；三、广说实相；四、以客尘成立轮回理；五、自性无变理。
    丑一、有法显现生灭理：
    犹如器界一切法，依于虚空而生灭，
    如是有情之诸根，依无为界而生灭。
    犹如器世间的一切法，最初依于无质碍的虚空生起，最终灭于虚空，而虚空无生灭，如是依于非因缘所作的大无为法的法界如来藏，内之有情诸根最初生起，最终灭尽，然而法界无有生灭。
    丑二、法性无灭理
    犹如虚空以诸火，往昔何时未曾烧，
    如是佛性死病老，诸火亦复不能烧。
    譬如一切有为法虽然以劫末、地狱、普通三火可烧尽，但无为法的虚空以彼等三火往昔何时也未曾烧过，如是诸有情以病等三火可烧毁，然此法界如来藏以死之劫末火、病之地狱火、老之普通火三者何时也不能烧毁。
    丑三、广说实相分三：一、比喻；二、意义；三、彼等对应。
    寅一、比喻：
    地者依于水而住，水则依于风而住，
    风复依于虚空住，虚空不依地等住。
    譬如器世界的形成与安住，即地轮依止水轮，水轮依止风轮，风轮复依虚空而安住，而虚空不须观待因缘，故不须依止风轮、水蕴、地界等任何有为法的有事而极为安住。
    寅二、意义：
    如是一切蕴界处，住于业及烦恼中，
    此等行业及烦恼，住于非理作意中，
    此等非理作意者，住于心之清净中，
    心之自性诸法者，不住彼等诸法中。
    如是以有漏所摄的五蕴、十八界、十二生处的一切生杂染，依于能生彼等之因的业烦恼而住，业与烦恼恒时依于执无常为常等的非理作意分别心而住，非理作意者，是依于心的自性光明法界自性清净而住，而心的自性光明胜义真如是无为法自性的缘故，何时也不依于一切非理作意、烦恼业及生杂染的客尘诸法而安住。
    寅三、彼等对应：
    知蕴处界犹如地，有情业惑犹如水，
    非理作意犹如风，净心如空无基住。
    当知，如地轮依水成立，如是近取五蕴、十二生处、十八界依于业烦恼成立；如依水界能作成立地轮之缘，如是诸有情的有漏业烦恼是能成立诸蕴处界之缘；以非理作意引起业烦恼故，如依风界能作水轮的所依；犹如以空界能作一切的所依，然彼不住任何中，如是心的自性如来藏能作一切客尘的所依，然其自性无有任何依靠基且不住于任何法中。
    丑四、以客尘成立轮回相：
    非理作意分别者，住于心之自性中，
    依于非理之作意，生起诸业及烦恼，
    依于业及烦恼水，生起有漏蕴处界，
    空中器界成坏般，如是有情生而灭。
    犹如风轮住于虚空般，不相应诸法实相的执著——非理作意的分别心，彼以障碍的方式住于心的自性光明法界中；犹如依风能作水的所依，如是依诸非理作意，转生轮回之因的诸有漏业及贪欲等烦恼发挥而增上；犹如以搅动水蕴成就大地，如是以业烦恼水生起有漏蕴处界痛苦所摄的生杂染。总之，如同在无为法的虚空界中以不同时位器世间前有新灭、前无新成，如是无漏法界中诸有情随分别心及三杂染而转，初生终灭。
    丑五、自性无变理：
    心之自性如虚空，无因以及无有缘，
    无有和合及无生，无灭亦无安住相。
    心的自性光明法界犹如无为法的虚空界不须观待近取因及俱有缘，故也不须观待彼等和合，因此最初无生、最终无灭、中间亦无住，故以有为法的三相何时也不迁变。
    子三、摄义：
    心之自性为光明，犹如虚空无转变，
    妄念所生诸贪等，客尘诸垢不能染。
    犹如虚空不被云烟转变般，一切众生心的自性光明如来藏以障垢净与不净何时亦无转变，亦即，以非理作意所生的贪嗔痴等烦恼杂染、业杂染、生杂染的诸客尘障垢根本不能染污法性，以自性本净故。
    癸二、宣说彼等差别分二：一、无变法性以生灭空；二、变异与三火相同。
    子一、无变法性以生灭空：
    依于业及惑水等，不能令彼新生起，
    以死病老猛烈火，亦复不能焚烧彼。
    以如水蕴的业惑等不能令前际无有的心之自性光明法界新生，以是无为法的自性故，如是彼法性不会被无量猛烈的死之劫末火、病之地狱火、老之普通火所焚 烧或毁灭，以自性不会转变为其他故。
    子二、变异与三火相同：
    劫末地狱普通火，三者依次而对应，
    死病老之三种火，应知彼等相似法。
    劫末能毁灭器世间之火、能烧坏诸地狱众生之火、以普通薪柴所燃之火，此三者依次对应命迁变的死火、界迁变的病火、寿迁变的老火，应知彼等互为相似法。
    壬二、不净净位不变分二：一、宣说以生等不变之真实义；二、认定十地佛子功德。
    癸一、宣说以生等不变之真实义分二：一、不变现似变之理；二、其义广说。
    子一、不变现似变之理：
    菩萨如实知佛性，解脱生老病死等，
    离生等贫由证因，悲悯众生示生死。
    诸圣者菩萨已从五蕴新起的出生、相续灭尽的死亡、能生痛苦的疾病、相续变化的衰老中获得解脱，由如实现量了知如来藏法界的自性或实相而安住故。彼菩萨既已了知，故能远离以业惑所致的生等贫乏之苦，虽是清净也是不变，然而以如实了知法界为因，具慧菩萨对于未能如是证悟的众生发起欲拔一切痛苦的大悲而安住故，为了利他以愿力等随欲投生于轮回之中，并为断除众生的常执示现死亡，或有必要而示现病老等安住于轮回中，故在所化众生前示现不清净与变化相。
    子二、其义广说分二：一、以痛苦不能转变；二、以大悲示现变异。
    丑一、以痛苦不能转变：
    死病老之诸痛苦，圣者悉皆永灭尽，
    依于烦恼业力生，彼者无彼故无生。
    获得意生身的诸圣者菩萨彻底断尽不自在的死苦、病苦及老苦，因为通常是以彼等之因——非理作意、业、烦恼而转生轮回，而彼菩萨无有彼等因故，无有以苦果转变。
    丑二、以大悲示现变异：
    如实真实已见故，虽于生等已超离，
    然以大悲之自性，示现生死老病等。
    诸圣者佛子如实现量见法界无生无变故，虽已超越而脱离不自在转生轮回的诸种痛苦，然对未如是证悟的有情已成为大悲自性故，示现投生轮回并有死、病、老等众多迁变的显现，以此成熟有缘的所化众生。
    癸二、认定十地佛子功德分五：一、已生菩提心之功德；二、已入殊胜行之功德；三、获不退转之功德；四、成最后有之功德；五、成办二利之差别。
    子一、已生菩提心之功德：
    诸佛意子已证悟，不变法界真如性，
    无明令盲诸众生，见现生等诚稀有。
    若得圣者之境界，凡夫境界中显现，
    是故众生之至亲，善巧以及悲殊胜。
    安住一地的诸佛子菩萨最初现量证悟以生等不转变的心之法性界自性清净后，自己虽从生老病死的真实痛苦中解脱，但以无明障瞎却智慧眼的众生见生及“等”字所摄的老病死的显现，由此成熟诸所化，诚极稀有又极希奇！如是已超越凡夫不善法、现量见法性且获得从生死中解脱的圣者菩萨，在未解脱生死的诸凡夫境界中，示现生等诸多游戏且能成熟诸所化，因此，成为众生殊胜至亲之自性的诸菩萨以四摄法修持利他的善巧以及能引生彼者的大悲是极为殊胜的。
    子二、已入殊胜行之功德：
    彼者超越诸世间，依然安住于世间，
    为利世间现世间，世间障垢无染污。
    犹如莲花出于水，不为彼水所染污，
    如是佛子生世间，不为世间法所染。
    安住二至七地的菩萨，虽以智慧力真实超越一切世间行为，然以大悲力不离世间，为了成熟世间有情于世间中示现生等，丝毫不被世间过失染污而行持伟大的菩萨行，犹如莲花出于水而不为水的过失或障垢所染污般，如是菩萨为利他虽生于世间然不为世间法——烦恼与过失等染污。
    子三、获不退转之功德：
    行持利他之事业，智慧恒如火炽燃，
    寂灭静虑之等持，恒时入此定境中。
    安住第八地的菩萨行持利他事业，自己的智慧恒时无有勤作，如干薪自然起火般炽燃转入。不仅如此，同时也能恒时相续不断入于远离戏论相的寂灭静虑等持的定境中。
    子四、成最后有之功德：
    以宿善愿推动力，及离一切分别故，
    为令成熟诸有情，十地菩萨无勤作。
    说法以及现色身，利行及与诸威仪，
    何者以何如何调，此者如是皆通达。
    如是普于虚空际，无边有情恒时中，
    具慧任运无障碍，真实广行利生业。
    安住第十地的菩萨以往昔十地之前善愿力的推动，无勤行持利他事业，以及一切分别念以转依方式遣除而远离的缘故，最后有的十地菩萨为成熟诸有情不需勤作和加行。虽即如是，而语的事业相应众生意乐宣说法要、身的事业相应信解示现种种色身、行持伟大利他菩萨行以及示现种种行住等威仪，应于何等所化、以何种方便、如何调伏的事业，此菩萨如是悉能通达。如是无勤作的事业普被于浩瀚虚空界的一切有情，恒时之中一切无碍任运自成，具有极大利益。具慧菩萨以此种方式为成熟诸有情而真实无倒地广行利生事业。
    子五、成办二利之差别：
    菩提萨埵后得时，事业相与诸善逝，
    真实救度诸有情，于此世间视平等。
    然如大地与微尘，亦如大海牛迹水，
    彼等差别极悬殊，佛与菩萨亦如是。
    安住第十地的菩萨后得位转入广行利众的事业，断证究竟的诸善逝从轮回大苦海中真实救度有情的事业，此二者于世间任运成就且相续不断的缘故，视为平等，因为此菩萨已获六神通、十自在等殊胜功德故。虽然利他这样相同，但就自利的断证功德而言，则如大地与微尘、大海与牛蹄迹水有天壤之别一般，正等觉佛陀的究竟功德与十地菩萨道的功德的差别也如是极为悬殊，彼亦，以诸菩萨无明习气等诸微细障未断除而善逝佛已断除彼等并获得法身功德四波罗蜜的缘故。
    壬三、极净位不变：一、略说不变易；二、其义广说。
    癸一、略说不变易：
    不变性具无尽法，众皈无后际究竟，
    此常不二无分别，无灭法性非作故。
    法界极清净位如来法身，是无有舍此身成彼身的变易性的常住义，以无余涅槃界时也具有无尽无量胜义功德故；也是一切众生的无欺殊胜皈依义，以是尽轮回后际未究竟之间具有诸救度功德故；此无垢法界恒时是轮涅不二的寂灭义，以具足对彼等功过不分别的功德故；也是恒时不灭不变的法性义，以具有非由业惑所作的自性功德故。
    癸二、其义广说分三：一、远离生等义；二、摄义并承上启下；三、安立常等之根据。
    子一、远离生等义分二：一、分别宣说；二、广说对应。
    丑一、分别宣说：
    清净法界无有生，无死无病亦无老，
    依次常故坚固故，寂灭故与不变故。
    极为清净且自性光明的藏法界最初无生，最终无死，中间以病无害、无迁变或衰老，其根据依次是常故、坚固故、寂灭故与不变故。
    丑二、广说对应：
    佛性依于意生身，无生其性常恒故；
    依于不可思议死，无死其性坚固故；
    依于无明习气病，无害其性寂灭故；
    依于无漏之行业，无老其性不变故。
    如来藏种性最初以意生身无生，以其自性是不变恒常故；最终以不可思议死不能令佛性死，以其自性是无欺坚固性故；中间以微细无明习气病不能害，以其自性是已寂灭二取执著等故；并且以诸无漏业不能令彼衰老，以其自性不灭且不变故。如是以意生身等也无迁变，何况以凡夫粗大的生老病死呢？
    子二、摄义并承上启下：
    当知以二复二句，亦复具有二二句，
    依次无为法界中，具有常恒坚固等。
    以无常等根据安立无生等，对于略说不变异处的“不变性具无尽法”等的广说分别有“具足无尽功德故”等二句，“如同轮回无边故”等二句，“无分别智自性故”等二句，以及“具无造作功德故”等二句，依次指明在非因缘所作的无为无漏法界如来藏中具有常恒义、坚固义及“等”字所摄的寂灭义与不变义，应当如经典而了知。
    子三、安立常等之根据：
    具有无尽功德故，如如不变常恒义；
    如同轮回无边故，皈依自性坚固义；
    无分别智自性故，无二法性寂灭义；
    具非造作功德故，自性不灭不变义。
    现量现前的此法界自性法身，即使无余涅槃法界时也具有无尽功德故，是何时也如如不变的常恒义；如轮回的无边相续不断摄受故，众生皈依的自性，是坚固义；是不分别二边的智慧自性故，是轮涅无二法性寂灭义；具有非因缘所作的无为功德故，是恒时不灭不变义。
    庚八、功德无二义分二：一、以名略说；二、其义广说。
    辛一、以名略说：
    法身如来及圣谛，涅槃如光不离日，
    如是功德无二故，除佛之外无涅槃。
    如来藏极清净位，即是诸佛法身，如是彼者也是如来，也是圣谛，也是胜义的涅槃，故此四者仅是不同异名，如同光明与日轮无二，如是，与十力等诸胜义功德无二故，除如来外无有真实涅槃。
    辛二、其义广说分三：一、广说异名；二、广说意义；三、彼等以喻了知。
    壬一、广说异名分二：一、以四义说四名；二、名义对应而说。
    癸一、以四义说四名：
    总之无漏法界中，依于四种义差别，
    当知四种相应名，称为法身如来等。
    总之，应知在无漏法界如来藏本体中，依于下文所说的“佛陀诸法不相离”等四种差别义，安立法身等四种异名。
    癸二、名义对应而说：
    佛陀诸法不相离，及彼佛性如是得，
    不妄不欺之法性，本来自性寂灭性。
    于此法界自性清净，从具足佛陀十力等胜义功德法的无二的角度，称为法身；从具足无始以来安住的佛性如是获得或现前的角度，由乘如如之性而来，故名如来；从具足何时不妄、恒时不欺或无变的实相或法性，以及彼是圣者智慧所境的角度，称为胜义谛；从本来自性清净且寂灭一切客尘障垢的角度，称为涅槃。
    壬二、广说意义分二：一、广说无二义；二、广说解脱义。
    癸一、广说无二义：
    遍知一切现菩提，已断障垢及习气，
    如来以及涅槃者，于胜义中无二性。
    一切种智照见如所有尽所有的一切相而现证菩提，称为如来；已断除客尘二障及其习气，称为涅槃。故从证德究竟的角度安立为如来，从断德究竟的角度安立为涅槃，仅仅是异名而已，在真实际中唯是同一如来藏，因此于圣者各别自证的行境无漏法界中无二无别。
    癸二、广说解脱义：
    一切诸相无数量，无思无垢之功德，
    无别体相即解脱，解脱彼者为如来。
    广大而一切种类无有欠少故，是一切相功德；无边差别且无法衡量故，是无数量功德；甚深难测故，是不可思议功德；彻底清净二障及习气故，是无垢功德。现前无漏法界中具有无别体相的法身，称为究竟解脱涅槃。于彼解脱，从现量圆满证悟真如的角度，也是如来。
    壬三、彼等以比喻了知分二：一、绘画喻之义；二、日轮喻之义。
    癸一、绘画喻之义
    譬如种种绘画师，各自善巧各不同，
    某师了知能绘分，此分余人不知晓，
    此后于此由诸师，我之形貌当共绘，
    具权国王于彼等，下谕布绢赐与彼，
    从彼听闻此事已，着手绘画国王像，
    绘画王像画师中，若有一人去他方，
    由于彼人远行去，缺少彼者一人故，
    圆满王像遂不成。此喻此处如是知，
    所言彼等画师者，布施持戒忍辱等，
    具有殊胜诸方便，空性即说圆身像。
    其义之比喻如何？譬如国中有画天等的种种画师，对于首足等不同分各自仅擅长一分，一人所知能绘的部分，余人都不知晓。其中一人去他方，则其应绘部分无法描绘，这是概略总说。某时，权势自在的国王下谕：汝等画师当于此布画我圆满身像，说完赐布给画师，众师受命于各自所知分着手描绘，画师中有一人如画首者前往他方，由于缺少所应绘的一分，故像一切支分不能圆满。应知，此处是依《宝髻所问经》中的比喻而宣说的。以能圆满画一切支分的众多画师的喻义是无贪著的布施、无障垢过失的持戒、何时也无动摇的忍辱以及“等”字所摄的于善法勇悍的精进、一缘安住的静虑、测知诸法的智慧。如是具足诸殊胜方便者，即是方便无缺的空性究竟法身，宣说此法身如同所绘的圆满王像。
    总之，所有画师中若缺一人，则不能圆满王像，若全部具足，则得圆满成就。如是，诸方便缺一也无法成就圆满功德，相反由全部具足则能成就一切功德。与彼等无二的解脱涅槃是于究竟的一切果相同。
    癸二、日轮喻之义分二：一、以四法与日轮相似；二、除佛外无究竟涅槃之理
    子一、以四法与日轮相似：
    般若以及智解脱，光明照耀及清净，
    无二是故如光明，光芒日轮无二般。
    与四功德无二的般若、智、解脱三者依次是光明、照耀、清净故，三者也无异故，与日轮的光明、照耀、清净以及三者无二相似。
    子二、除佛外无究竟涅槃之理
    是故乃至未得佛，真实涅槃不可得，
    如舍光明及光芒，日轮永时不可见。
    从无始即安住的界——自性清净的如来藏中，无二具有十力等一切胜义功德，若圆满现前彼者方是究竟解脱，是故乃至未获得具有无障照见一切所知法智慧的正等觉佛陀之间，尚未获得从一切障碍中解脱的究竟涅槃，如同舍弃光明与照耀后无法见清净日轮一般。
    己四、摄义并启下义：
    如是已说如来藏，十种意义而安立，
    今说烦恼所缠藏，当以九喻而了知。
    如是以上广述中，于无后际常恒法性胜者如来藏法界抉择之理或安立，以本体至功德无二义之间的十种义已作明显宣说。此处是宣说完毕的摄义。
    于无始以来安住然而不相属之自性的无量客尘障垢烦恼缠缚之中，安住无始以来安住并相属之自性的清净法性如来藏，以九种譬喻显示，应当依照《佛说如来藏经》如是了知。这是承上启下之义。
    己五、依启下义以喻宣说分二：一、有垢真如共同相似对应；二、障垢与如来藏二者各自相似对应。
    庚一、有垢真如共同相似对应分三：一、如来藏周遍众生之理；二、广说其喻义；三、摄义并说无前际理。
    辛一、如来藏周遍众生之理分二：一、略说；二、宣说喻义对应。
    壬一、略说：
    萎花中佛蜂中蜜，皮壳中果粪中金，
    地中宝藏果中芽，破衣之中宝佛像，
    贫贱丑女腹中王，焦泥模中妙宝像，
    客尘烦恼所障覆，众生如是佛性住。
    犹如在萎败莲苞中安住相好庄严的佛身，如是在无量客尘烦恼所缠的众生相续中安住法界自性清净的如来藏。以下也应如是对应，即是：在群蜂围绕中有美味圆满的蜂蜜，在皮壳中有未失坏的稻等果实，在不净粪堆中有不变异的圆形真金，在地层深处有无尽大宝藏，在果及皮壳中有渐次能生树芽等的功能，在破垢衣包裹中有珍宝所成的佛像，在贫贱丑女腹中有人主转轮王，在焦泥模中有以真金所铸之像。如是，以客尘烦恼所缠缚的诸有情决定具有此佛性或法界自性清净如来藏。
    壬二、宣说喻义对应：
    障垢犹如萎莲花，蜜蜂皮壳及粪秽，
    地蕴果皮破坏衣，苦逼丑女黑泥模。
    无垢佛性如佛身，蜂蜜果实及黄金，
    宝藏胚芽宝佛像，四洲圣王妙宝像。
    于自性清净成为能障的诸客尘烦恼障垢，犹如莲花、蜜蜂、皮壳、粪秽、地蕴、果皮、破坏衣、无怙等痛苦逼迫的丑女、焦黑泥模。所障的本来清净无垢如来藏，犹如佛身、蜂蜜、果实、黄金、宝藏、郁多罗等树、珍宝佛像、四洲之主转轮王、妙宝像。
    辛二、广说其喻义分九：一、萎花中佛之喻义对应；二、群蜂中蜜之喻义对应；三、壳中果实之喻义对应；四、粪中金之喻义对应；五、地下宝藏之喻义对应；六、果皮中胚芽之喻义对应；七、破衣中宝佛像之喻义对应；八、贫贱丑女腹中怀轮王之喻义对应；九、焦泥模中妙宝像之喻义对应。
    壬一、萎花中佛之喻义对应分三：一、萎花中佛身之喻；二、烦恼中佛性之义；三、喻义对应。
    癸一、萎花中佛身之喻：
    譬如萎败莲花中，安住相好庄严佛，
    具净天眼人见已，去除花叶显佛身。
    譬如在萎败的莲花中安住相好庄严、千光赫奕的佛陀，具清净天眼者见后欲令他人瞻仰，去除萎花败叶，令佛身朗然全显。
    癸二、烦恼中佛性之义：
    如是善逝佛眼见，阿鼻亦遍如来藏，
    无碍大悲于轮回，常住令众解脱障。
    此义与比喻相同，即善逝以无碍佛眼现量见自法——自性清净的法性如来藏能周遍自他，下至阿鼻地狱的众生，大慈大悲的诸佛为了开显众生的如来藏，尽轮回后际常住三有轮回救拔众生，令彼等从障碍中逐渐解脱。
    癸三、喻义对应：
    犹如萎败莲花中，安住善逝佛陀身，
    无垢天眼见此已，去除凋残败坏叶。
    如是众生贪嗔等，烦恼缠中住佛性，
    大悲能仁见此已，善作摧毁障垢业。
    犹如具有无垢天眼者见到未开敷的萎败莲花中有妙相庄严的佛身后，为了开显佛身而去除能障的残花败叶。如是，佛眼现见具有贪嗔等无量客尘垢染的一切众生相续中安住着法界如来藏，为令如来藏显露，具有无量大悲的能仁怜悯未如是证悟的众生，犹如去除能障花叶般，善作摧毁一切有情的客尘障垢烦恼的事业。
    壬二、群蜂中蜜之喻义分三：一、群蜂中蜜之喻；二、烦恼中佛性之义；三、喻义对应。
    癸一、群蜂中蜜之喻：
    譬如上妙美味蜜，为诸群蜂所围绕，
    须者见已设方便，驱散群蜂而取蜜。
    譬如上妙圆满美味的蜂蜜被群蜂密密匝匝地围绕守护着，须求美味的智者见到爱命群蜂围绕之中的美蜜后，以烟熏等种种善巧方便驱散群蜂后取得美蜜。
    癸二、烦恼中佛性之义：
    大仙一切智眼见，犹如蜂蜜之佛性，
    彼之障垢如蜜蜂，善作彻底断除业。
    如是大仙正等觉佛陀以现量见一切所知相的智慧眼，见到如美蜜般的各别自证智的佛性以及佛性障垢如蜂般的烦恼及种子后，宣说彻底断除彼等的妙道而善作现前法身的事业。
    癸三、喻义对应：
    譬如蜜为百千万，蜜蜂障覆须求人，
    驱散彼等诸群蜂，随意而作蜂蜜事。
    如是众生所具有，无漏智慧如蜂蜜，
    善巧摧毁如蜂惑，智者佛陀如丈夫。
    譬如百千万亿那由他数毒蜂遮障了上妙圆满美味的蜂蜜，须求美蜜的具慧丈夫见蜜后，驱散群蜂随意食用或配药等。如是一切众生具有如美蜜般的无漏各别自证智如来藏，为摧毁如蜂障垢客尘烦恼而令法界现前的通达善巧方便的智者如来，则如同取蜜丈夫。
    壬三、壳中果实之喻义分三：一、壳中果实之喻；二、烦恼中佛性之义；三、喻义对应。
    癸一、壳中果实之喻：
    譬如具壳之果实，众人不能得受用，
    凡欲食用果实者，去除皮壳取果实。
    譬如外有皮壳的稻等果实被皮壳包裹，乃至未脱壳之间，不成为众人受用的美食，而若脱皮壳则成为美食等，因此，凡是想寻求饮食等的人们定会从皮壳中取出果实。
    癸二、烦恼中佛性之义：
    如是众生所具有，佛性为诸惑垢杂，
    乃至未脱烦恼垢，三有不能作佛事。
    如是一切众生所具有的正等觉佛性自性清净如来藏被烦恼障垢所杂染，乃至未从混杂的烦恼障垢客尘中脱离之间，善逝佛陀的诸多不可思议事业不能在三有欲界、色界、无色界中显示而作，一旦远离障垢，则会放射佛陀事业的光芒。
    癸三、喻义对应：
    譬如稻谷麦等粮，果未脱壳具芒者，
    倘若果实未善治，众人不能享美味。
    如是众具法自在，未离烦恼之佛身，
    于为烦恼所逼众，不能赐予法喜味。
    譬如稻麦等果实未脱离各自皮壳的具芒者，若未善作从壳中取出果实的彼等之事时，众人不能享用美食等。如是，众生所具有的一切法自在之如来藏未从皮壳般的烦恼缠中解脱的佛身，对于如饥饿般被烦恼所逼迫的众生，不能成为赐予法喜及安乐味的自性。若断烦恼，则当演说广大法门。
    壬四、粪中金之喻义分三：一、粪中金之喻；二、烦恼中佛性之义；三、喻义对应。
    癸一、粪中金之喻：
    譬如有人行路时，黄金遗失粪秽中，
    具有不坏之黄金，于彼安住百千年。
    具净天眼见金已，以语告示余人言，
    此中现有真金在，汝当还净起金用。
    譬如有一携带宝中圆形巨金之人，走在人流不息的路上，由忘失正念等，黄金失落在粪秽充满的坑中，以腐烂粪秽不能蚀坏的真金如前一样，于彼处安住了百千年。具有清净天眼者看见彼处有黄金后，以饶益心出语告诉其他人：此处有超凡殊胜珍宝，你们捞出洗净后，应当让它发挥本有的作用，造佛像或打制饰品等。
    癸二、烦恼中佛性之义：
    如是能仁分明见，陷溺烦恼粪秽中，
    众生功德欲令净，于诸众生澍法雨。
    如是能仁佛陀也现见遍行于众生的功德法界真如如真金陷溺在粪秽般的烦恼之中，欲清净如粪秽般的烦恼，故对一切所化众生宣说如妙雨般的圣法。
    癸三、喻义对应：
    譬如腐烂粪秽中，坠入黄金天眼见，
    为令清净胜美金，认真显示于他人。
    如是佛陀已明见，烦恼不净大粪中，
    堕入有情圆觉宝，令净于众说圣法。
    譬如不净粪秽中坠入的黄金，后有天人发现，为清净黄金上的一切粪秽，将胜美黄金认真为人显示。如是，正等觉佛陀发现在如极多不净粪般的烦恼中坠入的如珍宝黄金般的诸有情的圆满正觉藏真如后，为了清净佛性上的烦恼客尘障垢，对所化诸有情，相应各自的机缘宣说圣法。
    壬五、地下宝藏之喻义分三：一、地下宝藏之喻；二、烦恼中佛性之义；三、喻义对应。
    癸一、地下宝藏之喻：
    譬如贫家地层下，具有无尽珍宝藏，
    主人于此无所知，宝藏不言我在此。
    譬如为饥饿贫乏所逼迫的穷人家的地下深处，已有随欲可得的无尽宝藏，尽管如此，主人却对地下宝藏一无所知，宝藏也不对主人说“我在地下此处，你可取出随意受用”，因此在具宝的同时枉受贫乏之苦。
    癸二、烦恼中佛性之义：
    如是意中珍宝藏，不增不减净法性，
    由未证故诸众生，恒时备受贫乏苦。
    如是，在一切众生心中自然安住如宝藏般的“由清净无垢的自性故，在自性住种性胜义功德中无有新增也无有先有后减的过失”的法性，然而如来藏被客尘烦恼所缠故，未证悟自具之自性的诸众生恒时相续不断感受无漏功德财宝贫乏的三有痛苦。
    癸三、喻义对应：
    譬如贫家地层下，已有宝藏对主人，
    宝藏不言我在此，主人不知有宝藏。
    如是意家法藏住，一切众生如穷人，
    为令彼等获此故，大仙真实降世间。
    譬如贫家地下已有无尽大宝藏，宝藏不会对穷主人诉说我在此处，主人也不知自家地下有此宝藏，故未解脱贫乏的痛苦。如是，在众生意家虽安住具有无量无漏功德的法界藏，但未如是了知的一切众生却如有宝藏而不得的穷人一般；如同善巧丈夫传授开掘宝藏的方便般，为令一切所化有情从客尘障垢的地下开出法界藏并现量现前具有二种清净的法身，大仙正等觉佛陀真实降临于无量世间宣说圣法。
    壬六、果皮中胚芽之喻义分三：一、果皮中胚芽之喻；二、烦恼中佛性之义；三、喻义对应。
    癸一、果皮中胚芽之喻：
    譬如郁多罗等树，果中种芽未朽坏，
    种于地中灌水等，渐次生长成大树。
    譬如菴摩罗、郁多罗等树果中具有能生大树功能的种子，如遇助缘则生苗芽，因为没有朽坏的障碍，种植在沃土之中，如果及时浇水、施肥等，就可以渐次长成圆满大树王。
    癸二、烦恼中佛性之义：
    一切有情无明等，果皮中缠法界善，
    如是若依彼彼善，渐次成为能仁王。
    如是，一切众生如果皮般的无明等烦恼客尘中有法界或佛性如来藏的无漏善法，亦如具缘渐次长成大树，如是依于福智二资彼彼善根，渐次经历地道而成为能仁王正等觉佛陀。
    癸三、喻义对应：
    譬如依水日风土，时间虚空之众缘，
    郁多罗及菴摩罗，果皮之内生长树。
    有情烦恼果皮内，具有正觉之胚芽，
    如是彼彼善缘力，见法次第渐增长。
    譬如若依潮湿的水、能成熟的日光、不腐坏的风、能住持的地、春天等的暖和时节、无碍的虚空等众缘，则从郁多罗及菴摩罗的果皮内渐次出生大树。在有情如果皮般的客尘烦恼内具有的如胚芽般的圆满正等觉，也从积聚助缘中产生，如是依于成为解脱因的二资粮的彼彼善缘力，则现量见法界逐渐增长后获得正等觉之果。
    壬七、破坏衣中宝佛像之喻义分三：一、破坏衣中宝佛像之喻；二、烦恼中佛性之义；三、喻义对应。
    癸一、破坏衣中宝佛像之喻：
    譬如宝成之佛像，臭秽破衣所缠裹，
    天人见彼在道中，为除秽衣此示他。
    譬如以种种珍宝所制成的殊胜胜者如来佛像缠裹在臭秽破衣之中，此像放在十字路口，众人未见，某时天人以天眼见后，为了去除能障的臭秽破衣而将道中安住的佛像之事如实对人宣说并作指示。
    癸二、烦恼中佛性之义：
    佛陀无碍眼现见，诸惑缠裹如来藏，
    下至旁生亦具有，为令解脱示方便。
    如是，诸佛如来以无碍见一切法的智慧眼，见到被贪等种种客尘烦恼所缠裹的如来藏下至蛆等旁生也具有，如从破衣中取出佛像般，佛陀为令法界如来藏从客尘中解脱而指示修道的方便——无量圣法。
    癸三、喻义对应：
    譬如珍宝之佛像，臭秽破衣所缠裹，
    置于路中天眼见，为令解脱示他人。
    如是烦恼破衣缠，佛性安住轮回道，
    佛见旁生亦具有，为令解脱说妙法。
    譬如珍宝自性的佛像被臭秽破衣所缠裹，放于十字路口，具天眼的天人见后，为令佛像从能障的障垢中解脱而将此像指示于人。如是，被如破衣般的烦恼缠裹而安住于轮回道中的佛性如来藏，诸如来见到下至旁生等下劣者也具有，为令佛性从障碍中解脱，正等觉佛陀相应所化众生的机缘宣说圣法。
    壬八、贫贱丑女腹中怀轮王之喻义分三：一、贫贱丑女腹中怀轮王之喻；二、烦恼中佛性之义；三、喻义对应。
    癸一、贫贱丑女腹中怀轮王之喻：
    譬如丑陋无怙女，住于无有依怙处，
    胎藏住持吉祥王，自腹有王不觉知。
    譬如无依无怙的丑陋女人住在无有依怙之处如客栈、十字路口等，彼胎藏能住持具有吉祥转轮王相的胎儿，但以胎藏障蔽的缘故，能住持的丑妇腹中怀有人主而不自知，故枉受被人歧视等的痛苦。
    癸二、烦恼中佛性之义：
    转生三有无怙家，不净众生如孕妇，
    具有怙主无垢界，如彼腹中转轮王。
    如是，转生在具有种种痛苦的三有中，就象住在无依无怙的寒舍，客尘烦恼的不净众生虽有怙主而不觉知故，就象胎藏中有人王的孕妇；如同彼孕妇怀有人王的缘故将会有怙主，如是彼有情有法性故，自性清净无垢的法界如来藏现量现前时，成为具有从怖畏中救护的殊胜怙主者，故如孕妇腹中怀有转轮王。
    癸三、喻义对应：
    譬如身著破垢衣，丑女胎中轮王住，
    然于无怙寒舍中，感受猛厉之痛苦。
    如是心住佛性怙，无怙具心诸有情，
    由于烦恼心不静，是故安住痛苦处。
    譬如身著破垢衣的丑女腹中虽有转轮王安住然未如是了知的缘故，在无依无怙的寒舍中枉受被人歧视的猛厉痛苦。如是，自心之中虽有自性光明怙主佛安住，然未如是证悟的缘故，无依无怙的具心诸有情以客尘诸烦恼力自心不得寂静故造作有漏业，以此因安住在感受怖畏的痛苦轮回之中。
    壬九、泥模中金像之喻义分三：一、泥模中金像之喻；二、烦恼中佛性之义；三、喻义对应。
    癸一、泥模中金像之喻：
    譬如模中融金铸，宝像外有焦泥模，
    见已知者为清净，内金除去外泥障。
    譬如泥模中以融金所铸成的铸像，量与相都已圆满成就，以自体是障垢寂灭故，虽是清净，但外面被焦泥覆障，有具慧智者见彼之后，为了净除内金上的障垢及除去外部焦泥等障而作种种方便。
    癸二、烦恼中佛性之义：
    佛见自性常明净，以及障垢亦客尘，
    众生犹如金泥模，令净诸垢成菩提。
    如是，佛见本来自性清净光明如来藏以及贪等诸能障烦恼也是可断尽的客尘后，包裹珍宝黄金所作像的泥模般的诸有情见法界的客尘障碍能被净除的方便，即是宣说圣法最终成就无上菩提果。
    癸三、喻义对应：
    譬如无垢金铸成，象马等像藏模中，
    彼无垢故寂灭性，铸师知已除泥模。
    如是遍知佛陀见，犹如纯金寂灭意，
    以说妙法巧方便，善破模障令清净。
    譬如以自性无垢清净具有光泽的纯金熔化而铸成的象马等像藏于泥模之中，彼铸像自性无垢故寂灭，铸师了知彼宝像自性之后，即依次以轻敲等除障的方便除去能障的外部泥模等能障。如是，遍知佛陀的智慧见到如纯金所成的铸像般烦恼本来寂灭之意——法性如来藏周遍一切有情，尔后施行除障的方便——以相应各自机缘宣说妙法如轻敲外模般善破现前佛性的障碍。
    辛三、总摄而说无前际之理：
    萎败莲花与蜜蜂，皮壳粪秽及土地，
    果皮破坏垢秽衣，女人胎藏及泥模，
    佛身蜂蜜与果实，纯金宝藏及大树，
    佛像以及转轮王，纯金所铸宝像般。
    宣说众生无始来，具有烦恼客尘垢，
    无垢自性清净心，无始不离而安住。
    所谓萎败莲花、爱命蜜蜂、果实皮壳、不净粪、土地、树果之皮、破坏垢衣、女人胎藏、泥模是能表示障垢的比喻，相好庄严佛身、具足美味蜂蜜、稻芽等果实、无变纯金、无尽大宝藏、大果树、珍宝制成的庄严佛像、转轮王、纯金铸成的宝像则是能表示如来藏的比喻。以彼等比喻所显示的意义即是宣说：有情界之真如的能障诸烦恼缠与心的自性不相属，故是客尘，然而彼也是无始以来即与法界并存，何处有彼等，彼处即有心的自性如来藏本来无垢俱生智慧，且从无始而安住。
    庚二、宣说各自相似对应分二：一、显示障垢之差别；二、显示自性法界。
    辛一、显示障垢之差别分四：一、能障障垢之分类；二、以彼等障覆法界之理；三、广说各自之喻义对应；四、再摄总义。
    壬一、能障障垢之分类：
    贪欲嗔恚痴随眠，猛厉现行及习气，
    见道修道不净地，清净地之所断障。
    如是九种障垢相，依于萎莲等显示，
    以随烦恼所缠覆，差别之相无有数。
    贪等九种障垢者，概要略说如次第，
    萎败莲花等九喻，依彼真实而宣说。
    自性清净法界的能障诸客尘障垢，若归纳，种类有九种。彼亦，世间离欲者相续中具有的、能作不动业之缘、能成就色界无色界果报、以出世间智慧所摧毁者，即是贪欲随眠、嗔恚随眠及无明愚痴随眠，彼等恶取处或三种种子各算一类；未离贪欲等的相续中具有的、能作福业与非福业之缘、仅能成就欲界果报、以修不净观等智慧所摧毁者，即是贪嗔痴的粗大现行，此等三毒现行算一类；诸阿罗汉相续中具有的、能作无漏业之缘、能成就意生身果报、以大菩提智慧所摧毁者，即是以无明习气地所摄的障碍；诸凡夫学人相续中共有的、以最初出世间现量见法性的智慧所摧毁者，即是见道所断；圣者学道相续中具有的、以已现量见法性的修道智所摧毁者，即是修道所断；不究竟菩萨相续中具有的从初地至七地之间的违品、以三清净地修道智慧所摧毁者，即是依止不净地的所断；究竟菩萨相续中具有的三清净地的违品、以金刚喻定所摧毁者，即是依止三清净地的所断。如是从粗略易知的角度所说的贪心等九种障垢依次以萎莲、蜜蜂等九喻显示。于如来藏，如果以能障的随烦恼自体划分，则有八万四千及成无量无边等，如同如来智慧无量无边一般。
    壬二、以彼等障覆法界之理：
    以彼等垢令凡夫，罗汉学人及具慧，
    如其次第四一二，复二成为不清净。
    出有坏云：“一切众生悉具如来藏。”于彼能障的九种客尘障垢所障的有情种类为：一切凡夫、声闻阿罗汉、缘觉阿罗汉、见修道菩萨、共同安住学道者、不共诸具慧菩萨。此义归纳，依如是次第，以萎莲、蜜蜂、果皮、不净粪等九喻宣说能障，以佛身、蜂蜜、果实、黄金等真实宣说法界，诸凡夫、诸阿罗汉、学人、具慧依次是四种不净。彼亦，依次以前四种障碍中的三毒随眠令上界凡夫不净，以彼等粗大现行令欲界凡夫不净，以无明习气地一者令阿罗汉不净，如是以诸见道所断、修道所断二者分别令凡夫学人及圣者学人二者不净，以依止不净七地的障垢及依止三清净地的障垢二者分别令不究竟及究竟菩萨不净。彼彼补特伽罗主要具足彼彼所断障碍的缘故，对现前究竟法界作障碍。
    壬三、广说各自之喻义对应：
    譬如淤泥水莲花，初敷荣时人欢喜，
    后萎悴时人不喜，欢喜贪欲亦如是。
    譬如水莲花最初从淤泥中敷荣绽放时，见者当即心欢喜，后来不须多久而萎悴时即不欢喜，如是，贪欲随眠依非理作意生起贪欲时人皆欢喜，待其灭尽时则不欢喜，故也如见水莲的欢喜般，因此贪欲随眠犹如莲花。
    譬如爱蜜之蜜蜂，极其扰乱刺蜇击，
    如是由生嗔恚故，内心产生诸苦恼。
    譬如爱蜜的蜜蜂遇人取蜜时，其心被嗔恚极度扰乱，则以锐刺蜇击而生痛苦，如是，由嗔恚随眠增上生起嗔恚现行的缘故，自他内心也产生痛苦忧恼，因此嗔恚随眠犹如蜜蜂。
    譬如稻等内果实，外为皮壳所包裹，
    如是现见如来藏，痴心蛋壳所覆蔽。
    譬如稻等果实外面被皮壳包裹而不能现见，如是，以如蛋壳般的无明痴心随眠对如理现见如来藏法界自性光明义作障碍而不得现见，因此愚痴随眠犹如皮壳。
    譬如粪秽不合意，如是具贪诸有情，
    依止五欲之因故，猛厉现行如粪秽。
    譬如不净粪秽是与悦意相违的怖畏处，如是，贪著欲界的诸有情依止五欲等诸多恶行的因是猛厉三毒现行的缘故，彼如不净粪聚般是生起忧恼与厌恶心之处，因此三毒现行犹如不净粪。
    譬如财富由覆障，不知不得珍宝藏，
    如是众生自然智，无明习气地所覆。
    譬如无尽大宝藏财富被地蕴所障而隐藏时，诸穷人不知有财而不得受用珍宝藏，如是，于功德圣财贫乏的诸有情，无尽功德的自然智慧被无明习气地覆障而不得现见，因此无明习气地所摄的烦恼犹如地蕴。
    譬如芽等渐生故，种子皮壳即破裂，
    如是由见真实性，断除见道诸所断。
    譬如由树的芽、茎、枝等渐次生起故，诸种子皮壳逐渐破裂，如是，由渐次见法界胜义真如的智慧能断除诸见道所断烦恼故，诸见道所断将渐次断除，犹如果皮。
    由与圣道相连属，摧毁坏聚见核心，
    修道智慧诸所断，宣说犹如破坏衣。
    依靠与圣道现量见四谛法性相连属而摧毁执五蕴为我及我所的坏聚见等所断核心或主要者见道所断，诸阿罗汉相续中所具以现量见法性后的修道智所断的诸障碍是断除粗大后的残余者，宣说如破坏垢衣，因此诸修道所断如破坏衣。
    依于七地诸障垢，犹如胎藏之障垢，
    如同远离于胎藏，无分别智成熟般。
    依于七地的诸障垢对所见障碍并有勤作故，如胎藏诸垢秽，于如离胎藏般从彼等障垢中脱离的八地等，以无勤作并任运现前无分别智故，如转轮王于胎中成熟即降生，因此一至七地的诸障垢犹如胎藏。
    随逐三地诸障垢，当知犹如泥土染，
    巨大智慧之自性，金刚喻定所摧毁。
    随逐三清净地的诸微细障垢无勤即能断除的缘故，当知犹如金像上所染着的薄土，彼亦，被诸大菩萨金刚喻定的对治所摧毁，故说随逐三清净地的障垢犹如泥土。
    壬四、再摄总义：
    如是贪等九种垢，如同萎败莲花等。
    以上相似之法广作对应，如是贪嗔等能障法界的九种客尘障垢依次与莲花、蜜蜂等九喻相似。
    辛二、显示自性法界分三：一、略说九喻显示三法；二、显示分别喻义；三、广说分别喻义。
    壬一、略说九喻显示三法：
    由三自性归摄故，种性如同佛身等。
    由下文所说三自性所摄的缘故，种性如来藏与佛身、蜂蜜等能表九喻相似。
    壬二、显示分别喻义：
    此之自性即法身，真如以及种性者，
    其中由三及一种，五种比喻当了知。
    何为三自性？此如来藏的自性是自然智慧法身及不转变的真如义，也是成佛的种性，共有三种。彼等以九喻如何表示？应知三自性依次以佛身、蜂蜜、果实三喻表示法界具有法身自性，以真金一喻表示真如自性，以宝藏、果树、宝佛像、转轮王、金像五喻表示彼是成就三身的种性自性。
    壬三、广说分别喻义分三：一、法身之喻义；二、真如之喻义；三、种性之喻义。
    癸一、法身之喻义分二：一、显示法身之分类；二、彼等与比喻对应。
    子一、显示法身之分类：
    当知法身有二种，法界最极清净体，
    以及依彼之等流，所说深及种种法。
    当知法身以真假分为两种：法界如来藏最极清净自性光明诸佛各别自证智的所缘境，称为真证法身；证悟或获得彼者的等流因，是由所化缘分如实现在识前的诸教法，称为假教法身。当知彼等是以所诠与能诠或果与因而划分的。假教法身又分两种，即是依真胜义谛从菩萨藏展开宣说的甚深法藏，相应种种有情的意乐依世俗谛从因缘经等十二部经展开宣说的广大种种法。
    子二、彼等与比喻对应：
    当知由超世间故，世间此喻不可见，
    不可见故佛自身，宣说与彼界相同。
    所说微细甚深法，犹如蜂蜜一味性，
    所说种种广大法，犹如种种壳中实。
    应知，由所证自性清净法身真实超越一切世间法故，在世间丝毫不见有能表示法身的比喻，因此宣说萎莲中安住的自生佛身与法界自性清净如来藏二者仅有一分相同。证悟彼者的等流者，具有微细难测之功德故，是微细甚深，显示胜义之相即是所说一切诸法真如一味的缘故，比喻如同一切蜂蜜甘甜一味，所说广大十二部经等种种方便之相即是为了证悟如来藏与次第引导的种种意相应的缘故，比喻如同种种皮壳中安住所受用的不同果实。
    癸二、真如之喻义：
    由于自性无变异，以及胜善及清净，
    是故宣说此真如，与彼真金性相同。
    如《般若经》云：“若佛出世若不出世，诸法法性恒常安住。”所谓心的自性看似与烦恼痛苦相连，然而清净光明实无迁变，由此称为真如。因为如真金的不变，在一切分位彼自性毫无迁变；如黄金的庄严，彼自性本善而殊胜；如黄金唯以垢秽而净，法界真如自性清净，所以宣说真如与真金之性相同。
    癸三、种性之喻义分三：一、以喻显示二种性；二、由此获得三身之理；三、彼等与比喻对应。
    子一、以喻显示二种性：
    犹如地藏及果树，当知佛性有二种，
    无始自性住种性，真实纳受胜种性。
    如同不须新作、自性安住地下、具有无尽受用的宝藏，以及依勤作在园中渐次生起的果树，当知能生三身的佛种性也有两种，即无始以来自性安住的法界清净自性住种性，以及缘彼（自性住种性）依靠听闻等勤作重新真实纳受的善根，成为顺解脱分故而殊胜，彼是增上种性。
    子二、由此获得三身之理：
    承许依此二种性，获得如来三种身，
    依于初者得初身，依于后者得后二。
    承许依此二种性之因获得正等觉如来三身之果。彼亦，初者自性住种性以智慧资粮究竟而远离一切客尘障垢获得初者具有二种清净的法性自性身，依于后者增上种性究竟福德资粮，获得后二者相应远近众生5显现的报化身。
    子三、彼等与比喻对应：
    当知庄严自性身，犹如珍宝之佛像，
    自性本来非所作，摄集功德宝藏故，
    具大法王国政故，报身犹如转轮王，
    唯是影像自性故，化身犹如黄金像。
    当知，胜义自性身本来清净光明并具功德庄严，犹如珍宝所成的佛像，以自性本来安住、非是以勤作新生的所作法故，及十力等功德如无尽宝藏故。具有大乘深广法圆满的王政故，对清净圣者显现的受用大乘的报身犹如自在受用七宝、四洲的转轮王。依靠现前胜义身的功能在所化众生前显现的种种影像，唯是显现之自性故，在共同所化前显现的化身犹如黄金铸像。
    己六、所说义以信心了知：
    自生诸佛之胜义，唯是依信所证悟，
    犹如日轮光晃耀，无眼目者亦不见。
    本来任运自成非依他缘新生的无为法自生诸佛的法性胜义如来藏，是诸凡夫、声闻、缘觉、初发心菩萨唯一依于了义经和解释其密意的论典以信心信解的所证，因为不具见甚深真如的眼目不能如实现量证悟的缘故，犹如光明晃耀的大日轮无眼盲人也不能现见一般。
    己七、认定所证空性：
    此无任何所遮遣，亦无纤毫所安立，
    真实正观真实性，真实见已即解脱。
    具有分离之体性，如来藏以客尘空，
    无有分离之体性，藏以无上法不空。
    远离二边的空性自相如何呢？自性清净如来藏之种性胜义谛真如，于此，丝毫无有所遣的前际有的杂染过失，以本来远离一切客尘障垢是其自性故；如是，也丝毫无有重新所立的前际无的清净功德，以十力等诸胜义功德本来任运自成无分离的法性是其自性故。如是远离所境二边的真实义法界真如，以能境了知胜义的智慧真实现量见且入定观修串习究竟，以及以如实现量见真实法性的智慧渐次生起后，从所断客尘障垢中获得解脱。彼亦，见道位从见道所断障垢中获得解脱，修道位从修道所断障垢中获得解脱，究竟道位从一切二障及习气中获得解脱。
    因此，于法性具有别别可分离的体相且能遣除的客尘障垢诸世俗有为法，如来藏以彼等空故，是远离有边；于法性具有不可别别分离的体相且不能遣除的自性胜义无上如来法，如来藏以彼等不空故，也是远离无边；互相相违故，也解脱有无二俱边，以此也解脱遮破彼二者的非二边，故是解脱二边或四边的空性，唯此是无颠倒之理。
    己八、以彼等宣说之必要分二：一、以问答略说；二、其义广说。
    庚一、以问答略说分二：一、提问；二、答复。
    辛一、提问：
    处处经说诸法空，如云如梦如幻相，
    此中如来云何说，众生皆具如来藏？
    犹如不坚且无自性的云、虽有感受然无自性的梦以及虽有种种显现然无自性的幻相，如是，在二转无相法轮的广中等6般若经中，处处广说从色法乃至一切种智之间的一切所知法虽现一切相而空无自性，然而，在此第三转法轮胜义决定《如来藏经》等诸多佛经中，正等觉诸佛如来的谛实语为何宣说一切众生的相续中本来具足如来藏法界自性清净光明任运自成法？前面说无、此处说有岂不相违？
    辛二、答复：
    心怯轻慢劣众生，执著虚妄谤正法，
    增上我执五过失，为具过者断彼说。
    无有此二者相违的过失，因为先前说无是为破实执，故说无客尘障垢，此处说有是为了五种殊胜必要，故说有法界如来藏。彼亦，若不宣说有如来藏，诸有情由于不知自具胜义如来，故想如我如何能修菩提，由此心生怯弱而导致不能勇悍入道的过失；由于不知他众也具胜义如来，故视彼等有情为下劣而心生轻慢不敬的过失；由不知自他平等具有胜义如来，故有将无自性非真实虚妄诸客尘障垢执着为有而增益的过失，以及本有与诸真实功德无别周遍一切的法界反执为无有而毁谤的过失；由不知自他自性在法界中平等，故自身执著增上我慢的过失。何者具有此等强力五过，为了使他断除此等，并为生起希求无上菩提之勇悍、于一切众生之恭敬、证悟客尘本无之般若、证悟有自性之智、了知自他平等之大慈，宣说一切有情周遍具有如来藏法性真如。
    庚二、其义广说分二：一、二转法轮宣说空性之密意；二、此无上续典中宣说法界如来藏之功德。
    辛一、二转法轮宣说空性之密意：
    究竟清净真实际，以诸有为法而空，
    烦恼行业果报义，说为犹如浮云等，
    一切烦恼犹如云，行业犹如梦受用，
    烦恼行业之果报，五蕴犹如幻变化。
    如是有如来藏若是了义，则于《般若经》等中宣说“一切诸法空性虽现而无自性，如梦如云如幻化”的密意如何呢？此无颠倒所证真实际胜义法界无为法，以世俗有为法客尘障垢生灭住的一切显现空，于此密意宣说无自性。此等空的诸客尘障垢有为法是何者呢？即是贪等烦恼杂染、不善等业杂染以及彼等异熟蕴等生杂染。宣说此三者依次如浮云等的相似，其中烦恼者，周遍障碍如虚空般的有情自性且是客尘的缘故，犹如浮云；由彼引生的有漏业者，是由颠倒心所生且是迷乱之境的缘故，犹如梦境的受用；烦恼与有漏业的异熟果——五蕴等义者，是观待因缘才显现种种，然而以理善察则无实有的缘故，犹如幻相与变化等。
    辛二、此无上续典中宣说法界如来藏之功德分三：一、为除过失而说法界如来藏；二、过失如何产生之理；三、由遣除过失速得功德之理。
    壬一、为除过失而说法界如来藏：
    先前如是安立已，复于无上续此中，
    为令断除五过失，宣说具有如来藏。
    于此法界实相，为了依次引导诸所化而在最初转了四谛法轮，但有人执著色等实有存在，为了破除此执，在先前二转无相法轮中宣说一切诸法空性以及虽现而无自性如云如梦如幻化，如是着重安立无自性之后，仅以此点即能不舍精进。又复宣说殊胜甚深的缘故，在无上或三转法轮转决定胜义法轮的后者显示法界相续不断故如密续般宣说究竟义的“此处”，为了遣除自心怯弱想、鄙视他众、执着障垢自性是有、执著法界为无、增上我执这五种过失，且能获得欢喜勇悍等诸功德，以众多比喻根据等极明显地宣说一切众生皆具种性自性清净如来藏。
    壬二、过失如何产生之理：
    如是未闻此善法，而以轻视自身过，
    心中生起怯弱者，菩提心者不生起。
    何者已生菩提心，由此故生我慢心，
    众生未生菩提心，于彼生起下劣想。
    如是于此思惟者，真实智慧不生起，
    是故执著虚妄法，及不能知真实义。
    由于改造客尘故，众生过失非实有，
    真实此过无有我，功德自性为清净。
    执著虚妄之过失，诽谤真实功德者，
    具慧自身与众生，不得现见平等慈。
    如是，若未宣说一切众生都有如来藏，则不得听闻，由未闻此，则想我自身如何能得菩提，由轻视自身的过失导致心生怯弱者不能生起欲现量现前自性胜义如来的殊胜菩提心的过失。如果何人为利他稍许发起希求佛果的菩提心，但执着我是安住大乘故为胜者或上者而生贡高我慢，若见未发菩提心的其他众生，由于不了知也具真如，会导致产生彼等众生下劣之想的过失。如是思惟无有如来藏的补特伽罗不能生起真实远离增损的实相义智慧的缘故，有将虚妄世俗客尘诸障垢执着为有的增益过失，不通达真实义法界胜义与无二之功德任运自成安住则产生损减的过失。如果善加观察，是因缘所作及能遣除的客尘的缘故，众生的过失客尘障垢在真实中无有，而在真实中无有人我法我的过失客尘的缘故，十力等诸胜义功德是于自性本来清净中具有。如是由执著虚妄过失客尘有自性而增益，将具有真实功德的法界本来任运自成安住毁谤为无有的缘故，诸具慧菩萨不能获得现见自己与众生自性胜义如来平等的大慈心，而且产生增上我执的过失。因此，为了断除此等过失极明显地宣说法界如来藏。
    壬三、由遣除过失速得功德之理：
    如是依于听闻此，勇悍敬众如导师，
    生起般若智大慈，由于生起此五法，
    无罪以及观平等，无有过失具功德，
    自与有情平等慈，依此疾得如来果。
    如是一切了义经典中宣说一切众生都具有法界如来藏，对此善听闻者，由于已了知自己的自性现前即是大菩提，故生起苦行修道的勇悍心，由于了知众生自性是佛，故如导师般恭敬，而且生起于世俗客尘障垢二无我的自性了知为无的般若、于胜义法界有的自性了知为有的智，并由见自他自性如来平等而生起欲作他利的大慈，如是产生五种功德法。依于此等功德——心中远离怯弱等罪过、观一切众生平等具有如来藏、了知无有诸客尘障垢过失、了知自性清净本具诸功德、由见自己与有情平等具有如来藏所生起的大慈，渐次修道，无疑速疾获得二利究竟的无上如来果。
    大乘无上续论辨三宝种性中如来藏品第一终。
    大乘无上续论辨别三宝种性中如来藏品第一释竟。


大乘无上续论释·善说日光　菩提品

    菩提品第二

    现在从彼法界远离一切障垢的诸佛出有坏无漏法界中无余转依果的角度来宣说。
    戊二、觉悟之菩提义分三：一、略说所讲义之分类；二、讲法总标而说；三、彼等对应而广说。
    己一、略说所讲义之分类：
    净得远离及二利，其依深广大自性，
    常住世间如实性，以此八义而宣说。
    所知之事无垢真如究竟果的大菩提，以八种所知展开论述。彼亦，当知上述法界自性清净从一切客尘障垢中解脱具有二种清净的转依，即是菩提本体义；能获得此具有二种清净者的方便——入定无分别出世间智与后得世间智二者双融而修，即是因义；由彼等智慧修持究竟而远离一切烦恼障、所知障及其习气，即是果义；由远离烦恼障而超胜一切有漏衰败并获得无量无漏财富,成就自利圆满，由远离所知障而成就一切时中无碍转入的他利圆满，即是业义；能成就彼等二利圆满的所依----具有不可思议无量功德，即是相应义；具有功德的彼菩提,难测难量故而甚深的法身，具有力等无量功德故而广大的报身，契合相应根机作他利故是大自性的化身，以此三身所分类，即是行义；彼等三身乃至虚空与众生未尽之间安住，即是常住义；彼等如实性不是佛以外余者的境界，由难证故，即是不可思议义。如是以八种义宣说。
    己二、讲法总标而说：
    本体因果与事业，相应以及分类行，
    常住以及不思议，由此建立如来地。
    如是法界自性清净远离所断客尘障垢、具有二种清净的本体义，能得彼者修行入定与出定道的因义，由修道远离二种障垢的果义，断障而成就自他二利的事业义，彼等所依诸不可思议功德的相应义，彼者以自性身、圆满受用身、应化身三身所分类的行义，彼等乃至虚空与众生未尽之间的常住义，以及究竟如实之相以诸凡夫不可思议义，由此八义建立了果究竟的佛地。
    己三、彼等对应而广说分七：一、净得本体及因义；二、远离障垢之果义；三、自他二利之事业义；四、其所依具足功德义；五、以三身分类之行义；六、众生未尽之间彼等常住义；七、如实不可思议义。
    庚一、净得本体及因义分二：一、略说净得；二、其义广说。
    辛一、略说净得：
    所谓自性之光明，犹如日轮与虚空，
    以客烦恼所知障，厚重云聚而遮蔽，
    遍具无垢佛功德，常坚不变之佛体,
    此依于法无分别，以及拣择智获得。
    诸多了义经云：“心之自性本来光明。”彼者具有如日轮般所知真如显露的证德以及如虚空般自性清净的断德，是具有此断证二者,彼亦，在先前凡夫位被厚重云聚般的客尘障垢——烦恼障与所知障所遮覆，最终以真实道无余灭尽一切障垢的断德以及佛陀的十力等一切功德无余不分离而具足,并从生老死中解脱故，获得恒常、坚固、不变的佛体，此即是具有二种清净的本体之义。如是菩提，依靠诸菩萨入定缘法性如所有义的无分别智以及后得位缘有法尽所有义的拣择智修道，由此渐次能得，即是因义。
    辛二、其义广说分二：一、具二净本体之义；二、能得智慧因义。
    壬一、具二净本体之义分二：一、真实；二、差别。
    癸一、真实：
    佛性是由无别异，清净妙法所安立，
    犹如日轮与虚空，智慧离染二体相。
    所谓胜义佛性，是由自心清净中一切无别安住、最终客尘障垢也远离的具有二种清净的妙法所安立。彼亦，如日轮自性光明般的智慧光明的证德，以及如虚空本来清净般的二障清净的断德，即是具有断证二者圆满的体相。
    癸二、差别分二：一、自性光明之差别；二、离垢清净之差别。
    子一、自性光明之差别：
    光明非是所作性，无别超过恒河沙，
    是故本来即具足，佛陀功德之诸法。
    无漏法界自性光明的法身非是以因缘所作，本是与一切有情自性无别相应，是故，彼者超过恒河沙数的一切佛功德法如十力等本来就任运具足。
    子二、离垢清净之差别：
    是以自性不成立，周遍以及客尘故，
    烦恼所知二障位，宣说犹如厚重云。
    诸障垢自性以本来不成立实有故，于一切不净位能周遍故，是能断尽的客尘性故，以这三种根据宣说解脱的障碍——烦恼障与一切种智的障碍——所知障,彼二者在众生位犹如以重云障蔽日轮与虚空般障碍自性光明，由断除此二障，将获得具足二种清净。
    壬二、能得智慧因义：
    断除二种障碍因，承许即是二种智，
    一者无分别智慧，二者依彼后得智。
    远离烦恼障与所知障的果，即是解脱身与法身，此二身的能得因，即是修持如所有与尽所有双融的两种智慧。彼亦，诸菩萨入定中修行对治三界的无分别智故，主要清净烦恼障；彼后得位修行深广等尽所有所知法义的拣择智故，主要清净所知障。故承许是彼等二智，并应精勤修持与彼相应之道。
    庚二、远离障垢之果义分二：一、以喻略说无垢；二、其根据广说。
    辛一、以喻略说无垢：
    犹如具有无垢水，莲花渐荣遍满池，
    亦如圆满之月轮，罗睺口中得解脱，
    复如圆满之日轮，云聚烦恼中解脱，
    具有无垢功德故，具光明者即彼体。
    唯佛如同佛身蜜，果实真金及宝藏，
    果树无垢宝佛像，转轮圣王纯金像。
    犹如充满离尘的无垢净水且被逐渐荣茂的莲花遍满的美丽水池般从贪欲烦恼中解脱,亦如于罗睺罗口中解脱的满月般从嗔恚烦恼中解脱,复如日脱重云般从痴心烦恼中解脱,以此根据，如日轮光明般无客尘障垢而具有断证圆满的诸究竟功德故，具有见如所有与尽所有的光明显现者，即是如来的本体。又如从萎莲中解脱的能仁佛身般，从客尘障垢中解脱的唯一是佛陀，如是对应：犹如远离蜜蜂的蜂蜜，从皮壳中脱出的果实，远离粪秽的真金，从地中显露的大宝藏，从种子中出生的具果大树，远离破衣无垢珍宝所成的佛像，从胎藏中出生的转轮圣王，以及远离泥模的纯金铸像，从一切障垢中解脱的唯一是胜伏一切违品的胜者正等觉佛陀。
    辛二、其根据广说分三：一、以二智出生二身之理；二、由断三毒成就二利之理；三、由净障垢获得实义之理。
    壬一、以二智出生二身之理：
    如水池等贪欲等，客尘烦恼得清净，
    简要无分别智慧，其果如是而宣说；
    具有一切相殊胜，佛陀之身决定得，
    是依出定拣择智，其果如是而宣说。
    法界自性清净如同澄清浊尘的水池，也如“等”字所摄的从罗睺罗口中解脱的月轮、从云层中脱出的日轮，如是，是从缘悦意境的贪欲以及“等”字所摄的缘不悦意境的嗔恚、缘中品境的愚痴，即从客尘障垢三毒烦恼得清净，能获得具有断德圆满的解脱身。彼者虽有多因，但简要言之，是以修持入定无分别智远离烦恼障现前的果。如是，证德圆满的所依——具有一切空性光明殊胜相的佛陀身者，相应缘分各别自证智的境界决定获得，也是以后得世间智已对深广法串习听闻等，故也是宣说远离所知障现前的果。
    壬二、由断三毒成就二利之理：
    由断贪欲之浊尘，且于所化众莲中，
    降禅定水滋润故，佛如清净之池水；
    由脱嗔恚罗睺罗，且以大慈悲光明，
    普照一切众生故，佛如无垢之满月；
    由脱厚重愚痴云，且以慧光照群生，
    遣除无知黑暗故，佛如无垢之日轮。
    由无余断尽自相续中如浊尘般的三有贪欲心，而且于如莲花般的其他所化的相续中，以宣说妙法降下禅定水并以止观滋润故，二利究竟的佛陀如同净水盈满的悦意莲池。如是对应,由自相续从如罗睺罗般的不悦凶恶嗔恚中解脱，而且以欲令其他相续离苦的大悲及欲赐安乐的大慈如同光明般普照一切所化众生而作摄持故，二利究竟的佛陀如同从罗睺罗口中解脱的圆满月轮；由自相续从重云般的三有无明愚痴中解脱，而且相应所化群生的相续说法，依诸智慧光明遣除一切无知黑暗故，二利究竟的佛陀如同从重云中解脱的无垢明日。
    壬三、由净障垢获得实义之理：
    获得无等等法故，赐予无上法味故，
    远离二障皮壳故，佛如佛身蜜果实；
    净故真实妙功德，遣除有情贫穷故，
    解脱果赐众生故，佛如真金宝藏树；
    现前珍宝法身故，两足主尊最胜故，
    显示种种宝色故，佛如佛像王金像。
    具有凡夫声缘菩萨无等、唯与诸佛平等的功德法故，能赐予所化众生无上圆满的圣法味故，远离如皮壳般的二障及习气故，究竟佛陀依次犹如莲花中现出的佛身、远离蜜蜂的蜂蜜以及从皮壳中脱出的果实。如是对应,以自性无有障垢且从客尘障垢中清净故，以诸无尽真实微妙功德能遣除所化众生的一切贫穷故，能对诸所化众生赐予从痛苦中解脱的大乐果故，从障碍中解脱的佛陀依次犹如净除粪秽的真金、地中出生的大宝藏以及具果大树；已现前能出生一切所需的似如意宝般具有无量功德的法身故，获得主要所化两足的主尊或殊胜引导者的报身故，如以黄金宝所成铸像之像般显示种种化身像故，圆满三身的佛陀依次犹如远离破衣的珍宝佛像、远离胎藏的转轮王以及远离泥模的黄金铸像。
    庚三、自他二利之事业义分二：一、略说成就二利义；二、其义广说。
    辛一、略说成就二利义：
    无漏周遍不灭法，坚固寂常不变处，
    诸佛法身如虚空，能作圣者六根境，
    令见非大微妙色，令闻清净微妙音，
    令嗅善逝戒妙香，令尝大圣妙法味，
    令受三昧妙乐触，令知甚深胜妙理，
    倘若仔细而思惟，佛如虚空离诸相。
    丝毫无有有漏及习气的断德究竟以及周遍如所有、尽所有的一切所知的证德究竟，即此具有断证圆满的胜义如来,是毕竟不灭的无为法，因为彼由无老故坚固、无病故寂静、无生故恒常、无死故不变,成就如是的如来能自利究竟，也是一切白法的源泉故，能他利究竟,因为已达法性真如的如来，犹如以无为法的虚空开辟道路故能看见色法等般，如是在有缘圣者的殊胜六根前能作感受并了达相应各自威仪之因故。彼亦，如此所化者由眼根殊胜故，能令现见不是四大所成亦非微尘聚合的自在种种微妙的如来色身之义；由耳根殊胜故，能令听闻与世间法不杂染、清净、恒时、无相、真实的圣法妙音之义；由鼻根殊胜故，能令嗅觉何时也不被过失所染的诸善逝的净戒妙香之义；由舌根殊胜故，能令品尝诸大圣者所受用如甘露般的殊胜圣法之义；由身根殊胜故，能令觉受三摩地轻安所生的真实无漏大乐触之义；由意根殊胜故，能令产生证悟一切诸法实相从本以自性甚深难证的无我殊胜之义。彼亦，如果依于法性理仔细思惟观察，他利究竟也是能令感受胜义无漏的大安乐，以胜义如来如无为虚空般远离生灭住等一切有为法的相状，是无变任运自成故。
    辛二、其义广说分三：一、总说成办二利之理；二、别说自利圆满；三、别说他利圆满。
    壬一、总说成办二利之理：
    总说二智之作用，应当如此而了知，
    成就圆满解脱身，及成清净法性身。
    解脱身与法性身，应知二相亦一相，
    无漏性故周遍故，无为法故依处故。
    总说成办二利及其分类之理者，虽然众多，但归纳而言，学道时证悟如所有与尽所有的二种智慧双修的作用，当知即是成就二身。彼亦，由入定时对法性如实义以无分别智串习故，圆满获得断德究竟者——从客尘障碍中远离的解脱身；由出定时对甚深广大法等以证悟尽所有的智慧串习故，证德究竟者——十力等功德所依的法身净除障垢而按清净般现前无垢境界。应知：从障碍中解脱之身与智慧所依的法身，分别有无漏相与周遍相的“二相”，又共有无为法的“一相”,亦即，由解脱身具有无丝毫有漏的断德故，法身具有周遍一切所知的证德故，以及二者都是非以因缘所作的自性故，宣说了自利圆满。彼者是一切白法的依处故，也能他利圆满。
    壬二、别说自利圆满：
    烦恼习气灭尽故，承许即是无漏法；
    无著以及无碍故，承许智慧周遍行；
    毕竟无灭自性故，承许即是无为法。
    不灭性者为略说，由坚固等广说彼，
    当知灭者有四相，翻此坚固等法故，
    谓腐变异及间断，不可思议变易死，
    当知无彼故次第，坚固寂静常不变。
    以客尘——诸烦恼及其习气无余根除而灭故，解脱身具有无漏之相。如是，以如所有智断尽颠倒而于所境无著，以尽所有智现量现前一切相而于所境无碍故，承许法身具有以证悟智慧周遍一切所知。并且，二者是毕竟无灭或无变的自性故，是非因缘所作之相。
    对此，不灭性是略说无为法的根据，由坚固及“等”字所摄的寂灭、恒常、不变，则是广说不灭。彼者也是以认定违品而宣说的缘故，当知诸有为法有四种灭相，即是与坚固相反的非坚以及“等”字所摄的与寂灭相反的非寂、与常法相反的无常、与无变相反的变易故。四者意义如何呢？即诸有为法成熟后腐坏之老，四大界迁变痛苦之病，断尽前世而成就后世之生，不可思议且种种变易之死，共有四种。当知，解脱身与法身无有彼等四种灭相故，依次是：无老故坚固，无病故寂灭，无生故恒常，无死故不变。
    壬三、别说他利圆满：
    为白净法所依故，无垢智慧是为处，
    犹如无相虚空界，见色闻声与嗅香，
    尝味觉触知诸法，皆由彼者作为因，
    如是为于佛二身，无碍加行坚固者，
    殊胜六根行境中，无漏功德能生因。
    如是无垢的断德与智慧现前的证德，是具缘诸所化相续中产生诸多白净善法殊胜性功德的所依或根本故，也是他利圆满之处。彼亦，犹如不是能生因也没有色等相状的虚空，对于眼根见色、耳根闻声、鼻根嗅香、舌根尝味、身根觉触以及意根了知诸法，是以提供发挥场所之因，如是，佛身是由实修无碍见佛二身的加行道因而具缘的诸坚固佛子的殊胜六根境界之中，以世俗中见色身等能生妙相随好等无漏功德之因，以及以胜义中见法身等能现量产生力无畏等无量无漏功德之因。
    庚四、具足功德义分二：一、以异名略说；二、广说根据。
    辛一、以异名略说：
    不思常坚寂不变，静遍离念如虚空，
    无著无碍无涩触，非见取善佛无垢。
    以闻所成慧等不可思议，无生故恒常，无老故坚固，无病故寂灭，无死故不变，无苦故寂静，以尽所有智周遍所知，以如所有智离分别心，遣除烦恼障故如空无著，遣除所知障故何时何地一切无碍，遣除三摩地障故无涩触，离色故不可见，离相故不可取，自性清净故具善根，清净客尘障垢故无垢，具有此胜义十五种异门功德者，即是获得大菩提的如来。
    辛二、广说根据分二：一、于何者具功德之理；二、所具之功德。
    壬一、于何者具功德之理：
    依于解脱法性身，显示自利及他利，
    自利他利之依处，具有不思等功德。
    依于断德自性的解脱身与证德自性的法身二者，显示成就自他二利圆满，从所断一切束缚中解脱成就自利故，依于证德法身功德的事业成就他利故。当知如是成就自他二利所依的二身具有不可思议等十五种功德。
    壬二、所具之功德分二：一、广说甚深之根据；二、宣说其余之根据。
    癸一、广说甚深之根据分三：一、总标不可思议之理；二、广说彼之差别；三、根据与比喻对应。
    子一、总标不可思议之理：
    一切种智之行境，如来非是三慧境，
    是故当知此智慧，一切有情不可思。
    圆满法身唯一是一切种智的行境，胜义如来不是闻等三慧的行境，是故当知：此究竟智慧具有除佛以外一切有情不可如实思议的功德。
    子二、广说彼之差别：
    微细故非闻慧境，胜义故非思慧境，
    法性甚深故亦非，世间修慧等行境。
    不是三慧行境的道理如何呢？此胜义如来极微细而难证故，不是闻所成慧的行境；如是胜义谛是各别自证智的所证故，不是思所成慧的行境；法性真如是甚深难测究竟故，不是世间修所成慧等一切分别心的行境。
    子三、根据与比喻对应：
    此因如盲不见色，凡夫从来未曾见，
    亦如产房内婴儿，不见日轮圣亦尔。
    如是如来以凡夫难证的根据如何呢？因为犹如生盲丝毫未曾见过种种形色的色法般，一切凡夫丝毫未曾见过无垢真如，亦如产房內的初生婴儿只见少分日光色相而无力见其全分，如是安住十地的诸佛子也仅仅现量见少分法身而无力见圆满法身。
    癸二、宣说其余之根据分三：一、不变之功德；二、断证之功德；三、清净之功德。
    子一、不变之功德：
    远离生故是恒常，无有灭故是坚固，
    无彼二故是寂灭，法性住故是不变。
    此无垢如来本来远离以因缘生故，具有恒常的功德；于彼无生，亦无彼灭故，具有坚固的功德；以生灭二者不能坏灭故，此如来具有寂灭的功德；由此具足不变的功德，以法性自性涅槃本来安住而无变易故。
    子二、断证之功德：
    证悟灭谛故极静，觉悟一切故周遍，
    无所住故无分别，断烦恼故无耽著，
    清净一切所知障，是故一切皆无碍，
    无二堪能且调柔，是故远离粗涩触。
    此如来是具有一切痛苦极为寂灭的大安乐功德，以所断无余灭尽的灭谛已究竟现前故。如是，现量证悟一切所知之相故，是具有尽所有智周遍一切所知的功德；不住任何所缘或相故，是具有如所有智无分别的功德，以上是大乐及证德的差别。此外，净除障碍获得解脱的烦恼障及其习气故，是具有于如所有义无著的功德；净除障碍获得一切种智的一切所知障故，是具有于尽所有义一切无碍的功德；远离沉掉二者等三摩地障，以此身心调柔且堪能安住三摩地故，是具有远离粗涩触的功德，以上是断德的差别。
    子三、清净之功德：
    彼无色故不可见，亦无相故不可取，
    自性净故胜善根，障垢断故极无垢。
    胜义如来不是微尘聚合所成的色身并超越一切有为法的范畴故，凡夫根识无法见，是具有力的功德。如是，无有比量等相并清净分别心之法故，是具有以平凡心不可取的功德；具有法界自性本来清净故，是具有胜义善根的功德；净除一切客尘障垢及习气故，是具有最极无垢的功德。
    庚五、以三身分类之行义分二：一、略说体相之异门；二、其义广说。
    辛一、略说体相之异门分三：一、自性身之体相及五种功德；二、报身亦具五种差别相；三、化身具有三种功德。
    壬一、自性身之体相及五种功德：
    非初中后无别异，无二离三垢分别，
    证悟法界之自性，入定瑜伽师得见。
    无量超过恒沙数，具诸不思无等德，
    如来无垢法性身，尽断过失及习气。
    自性身具有五种体相，即是：以无有最初生、中间住、最后灭的有为法三相故，是无为法的体相；以无漏法界与究竟智慧完全融合一体故，是无别的体相；以从有无中解脱故，不堕增益损减二边，是无二的体相；以远离烦恼障、所知障、三摩地障故，是远离三障的体相；以证悟无有杂染障垢、不是分别心境界的法界本来清净并恒时不动而安住法性的大瑜伽士佛陀现量现见故，是无垢无分别光明的体相。
    如是当知自性身具有五种功德：以自性广大故，是以比量无法衡量的功德；以功德不可计数故，是超过恒河沙数的功德；以不是分别寻思境界故，是以识不可思的功德；以与其他不共且究竟故，是无等的功德，具有如是证圆满的功德；以由如来现量现前最极无垢的法界，断尽诸二障及其习气过失故，是具有断圆满的功德。
    壬二、报身亦具五种差别相：
    种种妙法光明身，勤修众生解脱义，
    事业犹如摩尼王，能现种种非彼体。
    彼亦，以宣说大乘种种深广圣法光明故，言说相续不断；圣法光明或示现具足妙相及随好的具无量光明之身相续不断；精勤诸所化殊胜众生解脱义的精进事业相续不断；如是作业亦如摩尼宝王满足一切所欲般，无有分别勤作，任运自成；随所化的意乐差别显现种种形相及身量等，不是以彼等的自体存在。具足如是诸种差别。
    壬三、化身具有三种功德：
    世间令置寂静道，成熟授记因色身，
    不离法界恒安住，犹如诸色不离空。
    彼亦，对于未入道的诸世间凡夫令其厌离三有后安置于寂灭道中,对于已入解脱道者则将彼等安置于大乘深广之中而作成熟，并以大乘极为成熟于清净地中渐次安置后,授记令获解脱，如是成为事业圆满之因并以所化差别而显现种种的化身，于前者法身不变界中，乃至轮回未空之间恒时不断安住，犹如无为法虚空界中诸有为色界生灭相续不断一般。
    辛二、其义广说分三：一、略说共同安立分类；二、安立各自体相；三、彼等摄义。
    壬一、略说共同安立分类：
    自生诸佛之遍知，唯称彼者为如来，
    最胜涅槃不思议，各别自证出有坏。
    彼者分类由深广，大自性三功德法，
    当知如是自性等，安立法报化三身。
    对于具有不依他缘而自生的诸佛的一切种智，从断证究竟的角度称为如来，以不住轮涅二边故是最胜涅槃，以超越分别寻思者的境界故是不可思议，以摧毁轮回一切过患故是出有坏，并且唯是各别自证智自性的彼大菩提者,其分类即是，对于以难证而称为甚深的功德，以具力而称为广大的功德，以相应众生缘分而普行化度而称为大自性的功德三者，依次安立自性身、报身和化身的种类。由此转入自他二利任运自成相续不断。
    壬二、安立各自体相分三：一、安立自性身体相；二、安立报身体相；三、安立化身体相。
    癸一、安立自性身体相分二：一、略说体相及功德；二、广说彼等。
    子一、略说体相及功德：
    其中一切诸如来，自性身之五体相，
    摄略宣说当了知，具有五种功德相。
    如是对究竟菩提分类后，彼三身之中，诸如来的自利圆满自性身具有无为法等体相或五种差别，并应了知：虽有极多功德，但归纳而言，以无二的方式具有“无量”等五种功德相。
    子二、广说彼等分二：一、广说体相；二、广说功德。
    丑一、广说体相：
    无为法与无别异，以及遣除二种边，
    烦恼所知三摩地，三障决定得解脱，
    无垢无有分别心，诸瑜伽师境界故，
    由于法界自性力，本来清净故光明。
    此胜义自性身无有有为法生住灭故，是无为法不变的体相；无漏法界与究竟智慧二者完全融合为一故，是无别的体相；世俗无自性而胜义有自性故，是遣除增益损减二边的体相；贪等烦恼障、非烦恼的一切种智障——所知障以及其差别的于三摩地随意趋入的三摩地障，决定从彼三障中解脱，是无障的体相；于本体本无障垢及分别心，唯是于方便智慧双融中恒时入定的诸究竟瑜伽士各别自证的境界故，甚深法界本性本来清净故，是自性光明的体相。如是具足五种差别。
    丑二、广说功德：
    无量无数不思议，无等清净之究竟，
    当知彼等诸功德，真实自性身具足。
    广大故及无数故，非为寻思境界故，
    唯佛习气亦断故，次第是为无量等。
    以比量不可衡量的功德，以数量不可计量的功德，以分别心不可思议的功德，不与他法等同的功德，清净究竟的功德，彼等真实中与自性身无二悉皆具足。彼亦，以自性如虚空广大故，无以尽数故，非寻思者的境界故，唯是佛所具有的功德故，无余断尽二障及习气故，当知“无量”等诸功德依次与“广大故”等五种根据对应。
    癸二、安立报身体相分三：一、广说报身体相；二、复摄彼义；三、随缘示现。
    子一、广说报身体相：
    圆满受用诸法故，显示自性之法故，
    大悲清净之等流，利益众生无息故，
    无有分别任运中，所欲如实满足故，
    以如意宝神通故，圆满受用身安住。
    以圆满受用大乘种种深广妙法而安住故，语宣说教诫相续不断；以具有报身自性的妙相随好等法，在诸有缘者前恒时示现故，示现身相相续不断；以欲从痛苦中救拔一切众生的大悲清净的等流果——利益有缘众生相续不息故，以大悲作事业相续不断；彼等也无有分别勤作而任运成就随欲满足所化故，无有功用加行；犹如以基础不同如意宝显现种种而不是彼等自体般，如是随顺无量的所化界性、意乐与信解,虽然显现种种形色、身量等幻化,但不是彼等自体。如是具有五种差别相圆满受用大乘法的报身安住。
    子二、复摄彼义：
    说法示现业不息，无有加行功用相，
    显现不是彼自体，此处种种示五相。
    如是，语说教诫相续不断，示现身相相续不断，大悲作利生事业相续不断，于彼等无有勤作的功用而任运成就，由缘分的差别虽然示现种种，但显现不是自体。在以彼等五法宣说受用圆满身的此处，论述示现种种等五种差别相。
    子三、随缘示现：
    如由种种形色物，摩尼中现非彼体，
    亦由众生种种缘，如来显现非彼体。
    譬如摩尼宝放在具有种种形色的布基上，本非摩尼宝的真实形色，然而以清净而显现种种形色，如是，由所化众生的根机、意乐、信解等种种因缘，以大悲周遍一切众生的自性正等觉诸佛也是虽非彼体而幻现形色、身量等。
    癸三、安立化身体相分二：一、殊胜化身示现十二相；二、其作业次第引导众生。
    子一、殊胜化身示现十二相：
    依大悲心知世间，观照一切世间界，
    法性身中不动移，幻化种种之事业。
    天界出生圣白幢，从于兜率天宫降，
    入于母胎及降生，善巧通达工巧处，
    王妃眷属中嬉乐，出家修习诸苦行，
    往诣菩提道场中，降伏一切诸魔军，
    圆满菩提转法轮，趋入大般涅槃界，
    普于不净刹土中，轮回未空恒示现。
    颂词中的“示现”应当对应“能现”宣说。彼亦，由何因示现？即由摄受无量一切众生的不可思议大悲等因。如何示现？即以尽所有智对于所有世间界中成为自己所化的一切所化世界善加普照之后，以如所有智在法身不变的境界中入定、何时不动移而示现。示现何种义？即示现种种幻化自性之相——稀奇的十二种事业相。以第四导师为例，先在兜率天，圣者白幢天子示现出生后，将诸天安置于成熟及解脱位中,尔后示现十二相，即自兜率天降于南赡部洲的事业，入母胎的事业，从母胎中诞生的事业，善巧通达工巧处的事业，王妃眷属中嬉戏的事业，舍弃王宫妃眷而出家的事业，苦行的事业，往诣菩提树金刚座的事业，以大慈力降伏一切魔军的事业，得证圆满正等觉大菩提的事业，三转法轮的事业，趣入大般涅槃的事业。在何处示现？即在娑婆秽土等无量世界之中。示现多久？即乃至所化三有轮回未空之间相续不断任运示现。
    子二、其作业次第引导众生分三：一、安置平凡者于小乘道；二、安置小乘于大乘道；三、安置大乘于解脱位。
    丑一、安置平凡者于小乘道：
    演说诸法无常苦，无我寂静知方便，
    先令众生厌三有，后令悟入于涅槃。
    了知调伏所化众生方便的诸佛演说四法印——诸行无常、有漏皆苦、诸法无我、涅槃寂静，即对于贪著轮回的所化众生数数宣说三有的过患，使其产生厌离之后，先将彼等安置于仅仅寂灭轮回过失的声缘道中。
    丑二、安置小乘于大乘道：
    既入声缘寂灭道，具有已得涅槃想，
    妙法莲华等诸经，宣说诸法真实性，
    遣除彼等先前执，而以智慧方便摄，
    令彼成熟于胜乘。
    由进入能寂灭自己轮回痛苦的方便——声闻独觉道而获得声闻阿罗汉果及独觉菩提时，未得究竟涅槃作已得想，对于彼等，在《妙法莲华经》《大涅槃经》等经典中宣说“唯是诸法真实性空性大悲双融的一乘，由此趣入的涅槃也唯有一个”，以此遣除彼等声缘先前把未得究竟涅槃执为已得之心。尔后，依靠欲救度一切众生痛苦的大悲与证悟诸法空性的智慧摄持福慧二资，将彼等安置并成熟于三乘中的殊胜大乘道。
    丑三、安置大乘于解脱位：
    授与殊胜菩提记。
    如是于大乘道中渐次成熟后当获得八地等时，佛亲自授彼三种解脱菩提中的无上法王位记莂：汝于某国土，号某如来，某劫成等正觉，眷属数量几何，圣法住世几时等。如《大乘庄严经论》云：“刹土及名号，时节与劫名，眷属并法住，记复有六种。”
    壬三、彼等摄义分二：一、对应根据摄于三义之中；二、对应实际摄于二义之中。
    癸一、对应根据摄于三义之中：
    甚深圆满大势力，善引凡夫同利故，
    彼等次第应称为，甚深广大大自性。
    由微细难证甚深，具有成就他利的事业圆满，以及相应所化凡夫众生的意乐从轮回中善加引导故，当知与彼等依次对应的是甚深自性身、广大报身及大自性化身。
    癸二、对应实际摄于二义之中：
    此处初者为法身，其后二者为色身，
    如于空中色安住，于初身中后身住。
    应知：在宣说佛陀的此处，初者甚深殊胜是法身，以是一切诸法的自性且非他证境界故，其后报化二身是色身，以是相应所化众生的显现故。彼等也如在无为法虚空界中有为的种种色法安住般，如是，是在初者法身不变界中，后二者报身和化身显现种种而安住。
    庚六、于众生未尽间彼等常住义分二：一、略说常住之根据；二、其义广说。
    辛一、略说常住之根据：
    由无量因众无尽，慈悲神足智具乐，
    得法自在灭死魔，无体世尊故常法。
    是由“对何者也不贪著而护持圣法”等无量因成就的果法故，依色身利他的事业恒时相续不断。如是对应，由承诺调伏一切众生且所化众生无尽故，以成就他利的发心对一切众生大慈悲相续不断故，成就他利的方便－－于四神足获得自在故，依智慧证悟轮涅自性无二、以此永时不生厌离故，圆满具足无漏三摩地安乐、以此不为痛苦所害故，虽得诸法自在安住于世间中然不为其过失所染故，以色身利他的事业恒时相续不断。以得无死果位摧毁死魔故，从本以来是无为法、无有有为法的体性故，乃至轮回未空之间永为一切世间的救护尊及怙主故，法身是不变的常法。总之，以十种根据安立如来三身常住之义。
    辛二、其义广说分三：一、色身常住之根据；二、法身常住之根据；三、对应二身摄义。
    壬一、色身常住之根据：
    弃舍身命财三者，护持诸佛正法故；
    为利一切诸有情，究竟圆满本愿故；
    佛身净洁及澄清，大慈大悲生起故；
    神变神足力显示，彼者住世行持故；
    成就妙智于轮涅，取舍二执脱离故；
    恒常圆满而具足，无量等持大乐故；
    常住世间利益他，不为世间染污故。
    往昔学道中毫不耽著身之头等、寿命、宝珠等受用普作布施，以此护持圣法等无量因成就故，彼等色身恒时相续不断。如是对应：为了广大利益一切众生，最初立誓救脱苦轮，由所承诺之义究竟圆满以及所化无尽故，圆满正等觉以所具有的烦恼障净洁、所知障澄清的大悲相续不断普照一切众生故，由一变无量、无量变一等神变以及于诸三摩地足获得自在而随所化缘分显示色身者，彼佛尽轮回际能安住并相续不断行持故，清净智慧从三有轮回与寂灭涅槃自性二执中解脱后证悟无二，以此远离厌离利他故，恒时圆满具足不可思议的无量三摩地大安乐，以此不为苦行的痛苦损害故，为利他常住世间并随顺众生缘分而相应行持者，不为惑业苦等世间法染污故，以二种色身利益众生的事业恒时相续不断。
    壬二、法身常住之根据：
    获得无死寂静处，无有死魔现行故；
    无为自性之能仁，本来极为寂静故；
    恒常是诸无依者，皈依处等合理故。
    现前诸善逝法身，是以对治究竟的方式不变而常住，因为没有业惑所致的死亡，在获得安住生灭无余寂灭的殊胜涅槃中无有死魔之现行故。如是以自性也是常住，因为非因缘所作自性的能仁法身是本来极为寂灭一切有为法的体相故；以无欺诳也是常住，因为恒时作为无依怙无量有情的究竟皈依处、怙主、至亲等是合理的缘故。
    壬三、对应二身摄义：
    由前七种无误理，显示色身恒常性，
    由后三种无误理，显示法身恒常性。
    由“无量因”等前七种根据显示色身利他恒时相续不断，由“灭死魔”等后三种根据显示导师如来法身不变而常住。
    庚七、如实不可思议义分二：一、略说；二、广说。
    辛一、略说：
    非言语境胜义摄，非心所观超譬喻，
    无上轮涅不摄故，佛境圣亦不可思。
    无余转依所安立的无垢真如大菩提，超越声音的所诠而非语言境界故，唯一由各别自证所证胜义谛具有二种清净所摄故，不是心识所观处或所缘境故，真实超越能衡量的一切比喻、比量等故，是超越世间的无上最胜究竟故，不属于三有轮回、寂灭涅槃二边所摄故，唯一是圣者圆满正等觉一切种智的行境，对此,纵然安住大地的诸圣者也不可如实思议，何况诸凡夫岂能思议？
    辛二、广说分三：一、依次宣说根据；二、对应二身摄义；三、功德不可思议之理。
    壬一、依次宣说根据：
    不可思议离言故，离言胜义所摄故，
    胜义所摄非思故，非思超越比量故，
    超越比量无上故，无上轮涅不摄故，
    轮涅不摄不住故，不取轮涅过德故。
    之所以此圆满三身的菩提除佛外余者不可如实思议，因为非是语言境界而以语言不可言说故。之所以以语言不可言说，因为是胜义谛各别自证的所证故。之所以彼是胜义谛，因为非是心识所观境或处故。之所以彼非心识所观，因为不是以世间比喻及三相等的比量故。之所以彼非比量境，因为超越世间而成无上故。之所以彼者无上，因为以三有轮回及寂灭涅槃不摄故。之所以轮涅不摄，因为不住彼等二边故。之所以不住，因为对寂灭功德及三有自性过失无有分别故。
    壬二、对应二身摄义：
    前五正理微细故，如来法身不思议；
    第六正理自在故，如来色身不思议。
    由“非语言境界故”等前五种根据，极为微细甚深难测故，宣说法身以诸凡夫不可思议的根据；由第六“轮涅不摄”的根据，虽现有寂生灭等法而非彼有事存在故，宣说色身无量幻化不可思议的根据。
    壬三、功德不可思议之理：
    无上智悲等功德，至德彼岸佛不思，
    是故诸佛最后相，自在大仙亦不知。
    依靠以现证如所有与尽所有一切所知而成为无上的智慧，以及欲从轮回中救度一切众生的大悲事业等无量功德，到达功德究竟的彼岸，因此，诸佛所获得的大菩提除佛陀外余者不可如实思议。是故，不依他缘以自己修行而生的诸如来八相安立的最后不可思议相，或观待初发心等现前此圆满菩提相，纵然是安住清净并获十种自在的诸仙人大菩萨也不能现量如实了知，何况余者呢？欲如实了知者应获如来之果。
    大乘无上续论辨三宝种性中菩提品第二终。
    大乘无上续论辨别三宝种性中菩提品第二释竟。


大乘无上续论释·善说日光　功德品

    功德品第三

    现在宣说由安住大菩提以离系及异熟果所摄的诸殊胜功德。
    戊三、觉之功德义分二：一、对应二身功德之分类；二、抉择功德之分类。
    己一、对应二身功德之分类分二：一、分别宣说身与功德；二、彼等各自分类。
    庚一、分别宣说身与功德：
    自利他利胜义身，及依彼者世俗身，
    离系果与异熟果，功德分类六十四。
    所谓如来是以自利圆满与他利圆满究竟而安立的。彼亦，所依自利胜义法身和依彼的能依他利世俗色身，是二身的自性。于彼等，所有的能依功德也可分为法身所具有的三十二种离系果功德以及色身所具有的三十二种异熟果功德，共计六十四种功德。
    庚二、彼等各自分类：
    自利圆满功德处，即一切佛胜义身，
    他利圆满功德处，即一切佛世俗身。
    初者法身十力等，离系功德皆具足，
    二者大丈夫相等，异熟功德皆具足。
    获得一切自利圆满并且任运自成的依处或根本，即是现量现前的圣者殊胜智慧境界义的法身；能出生一切所化的他利圆满并且任运自成的依处或根本，即是诸佛的世俗色身。其中，初者法身无二具足十力、四无畏等仅以智慧资粮远离障垢所安立的功德，二者色身具足大丈夫三十二相等以积累福德资粮渐次异熟的功德。
    己二、抉择功德之分类分四：一、总标略说喻义对应；二、广说各义；三、以经教了知彼等功德；四、复说喻义摄义。
    庚一、总标略说喻义对应：
    力破愚痴如金刚，处众无畏若狮子，
    善逝不共类虚空，佛现二身同水月。
    如来的十力能无碍摧毁无明等障而不为余者所摧故，如同金刚能摧一切而不为一切所摧；以四无畏身处无量眷属中毫无畏惧而说法故，如同狮王在群兽中无所畏惧；善逝十八不共法与余者不共故，如同虚空与四大种不共；能仁对诸所化众生显示以相好严饰的化报二身，虽由缘分显现种种而彼等自体不存在故，如同水月与空月。
    庚二、广说各义分二：一、广说自利胜义法身具离系功德；二、广说他利世俗色身具异熟功德。
    辛一、广说自利胜义法身具离系功德分三：一、十力；二、四无畏；三、十八不共法。
    壬一、十力分二：一、所表义之本体；二、依能表比喻了知。
    癸一、所表义之本体：
    知处非处业异熟，种种根机种种界，
    种种信解遍趣行，染净二种静虑等，
    忆念自他之宿命，了知生死天眼通，
    寂灭烦恼习气智，如是宣说十种力。
    以往昔学道时对于大乘法作坚固勇猛的修习，最终获得如来法身时，对于如“二种自觉7及转轮王从男身出生是处，从女身出生是非处”般的因果合理与不合理之相，一切无碍现量证悟，是处非处智力。
    如是，以往昔对于因果法心极坚固，对于如“不善业产生不悦意异熟、善业产生悦意异熟”般的因果别别决定的规律相，一切无碍现量证悟，是业异熟智力。
    以往昔观察众生根机并契机说法，对于诸有情的信心等利钝中等的根机差别相，一切无碍现量证悟，是种种根机胜劣智力。
    以往昔已契入诸所化界，对于如将诸有情暂时安置于三乘不同种性或界的差别，一切无碍现量证悟，是种种界智力。
    以往昔随顺众生的信解普施妙法，对于如“有些有情于三乘中某乘具有信解”般的信解意乐的不同差别，一切无碍现量证悟，是种种信解智力。
    以往昔串习一切乘，对于如三种界及三菩提等所有轮涅的行道分类，一切无碍现量证悟，是遍趣行智力。
    以往昔修行无量三摩地，对于他相续中所生的四禅、四无色定、八解脱、三等持、九等至等有漏杂染以及无漏清净的差别，一切无碍现量证悟，是染净二种静虑等智力。
    以往昔善根未损坏并作护持，对于自他一切宿世诸行及其根据，无碍现量了知，是宿命智力。
    以往昔未曾怖畏（众生）而且成为彼等光明如实宣演妙法，对于一切有情从何处死亡、转生何处之相以及中有贤劣的一切差别，无碍现量了知，是天眼通智力。
    以往昔为了断除有漏宣说妙法寂灭自他的烦恼，对于断尽漏法之相，一切无碍现量证悟，是寂灭智力。
    如是相应各自之因所现量现前的从所断中获胜的十力，对于自他违品的四魔能作摧毁。
    癸二、依能表比喻了知：
    是处非处异熟界，众生种种信解性，
    遍趣行与染净定，种种根机忆宿命，
    天眼通及漏尽智，无明铠甲墙与林，
    能刺能摧能截故，佛力犹如金刚杵。
    了知因果的处与非处的智力，业及异熟的智力，种种所化的界或种性的智力，种种遍趣行的智力，种种众生的信解或意乐的智力，诸所化的信心等根机胜劣的智力，禅定及等至等具染净差别的智力，能忆宿命的神通的智力，以天眼观知死生的智力，了知自他漏法灭尽之理的智力，如是以此等十种智力，对于如坚甲、牢墙、稠林般的各自违品无明等障，依次能刺、能摧、能截故，佛陀的十力犹如金刚杵。亦即如下文所说般，以处非处等前六种力能刺穿如铠甲般的所知障故，如同金刚杵；以染净差别智力、宿命智力、天眼通智力三种力能摧毁如牢墙般的三摩地障故，如同牢墙；以漏尽智力一种力能截断如稠林般的烦恼障故，如同金刚杵。
    壬二、四无畏分二：一、认定本体之义；二、以比喻了知彼义。
    癸一、认定本体之义分二：一、认定本体；二、其作用。
    子一、认定本体：
    诸法圆满觉菩提，一切诸障能禁止，
    宣说道谛及灭谛，如是四种无所畏。
    往昔以平等心无悭吝为众生说法故，现量证悟如所有与尽所有的一切法，由此从自利角度自言“我圆满觉悟菩提”，无所怖畏；往昔未曾依止障碍法故，由此从他利角度自言“贪等烦恼是障碍解脱之法，当须遣除”，无所怖畏；往昔信解白法趋入涅槃道故，由此从他利角度自言“能断一切三乘道”，无所怖畏；往昔无慢说法故，由此从自利角度自言“断尽所断的灭谛我今已得”，无所怖畏。如是从四种义展开后，即是诸佛的四种无畏功德。佛陀在具有大福德的尊胜众中高声唱言，在眷属众中作狮子吼，在梵天处转法轮，毫无怖畏。于此，依仗苦行、种性、受用、势力以及远离世间贪欲而生我慢的人，依次是沙门、婆罗门、天、魔、梵天等，不见彼等谁有如理遮破之相，由身无不乐、语无怯懦、意无怖畏故，即是诸佛的四种无畏功德。
    子二、其作用：
    诸法自知令他知，道障自断令他断，
    入道自得令他得，说二利谛佛无畏。
    依靠获得四种无畏，从自利利他展开，即佛陀承诺自说“所知有事痛苦等一切相我今已知”，为令他知而宣说所知痛苦等诸法；佛陀承诺自说“所断有事集业惑等我已彻断”，为令他断而宣说集之所断障碍一切法；佛陀承诺自说“所依之道我已圆满依止”，为令他依而宣说一切道法；佛陀承诺自说“所得极为清净的无上灭谛具有二种清净者我今已得，为令他得而宣说漏尽灭谛法”，因此，如是承诺自说我已善证、也为利他令如实证悟而宣说四谛何时也无有畏惧故，诸大仙正等觉佛陀任处沙门、婆罗门等何种坛城8之中宣说圣法均无障碍。
    癸二、以比喻了知彼义：
    林中兽王常无畏，百兽群中自在行，
    佛陀狮王处众中，无畏善住坚势力。
    犹如兽王狮子恒住林中而无丝毫畏惧，在具大力的虎象等兽群中无畏自在游行时，狮王独自善住，无须观待，心意坚固，势力圆满。如是，在具有傲慢的沙门、婆罗门等众会之中，能仁佛陀狮子毫无怖畏，由自身最胜故善住，不依他缘故无观待，恒时入定故心意坚固，极微所断也断尽故具足圆满势力，如是而安住。
    壬三、十八不共法分二：一、真实义；二、喻义对应。
    癸一、真实义分二：一、十八不共法各自之分类；二、复说上义及作用与获得之理。
    子一、十八不共法各自之分类分二：一、广说；二、摄义并说余义。
    丑一、广说分四：一、行所摄六法；二、证所摄六法；三、事业所摄三法；四、智慧所摄三法。
    寅一、行所摄六法：
    如来无过亦无诤，无有心意失念过，
    亦无不定散乱心，及无轮涅种种想，
    并无不择而舍置。 a
    此处宣说如来身口意行无有颠倒。即是，由往昔学道中修习为迷路众生无误指路等，最终成佛时身体没有以三毒引发的跳跃等过，是为身行不共之一德；由往昔行持无诤且断除妄语绮语等，佛没有以烦恼引发的诤论、绮语等杂乱语过，是为语行不共之一德；由往昔修习六随念9，导师佛没有忘失往事之过；由往昔修习善护他心等，没有不能一心安住三摩地的散乱心；由往昔修习断除颠倒的心与想等，没有执著轮涅异体的种种过失；由往昔修习自他平等以及轮涅平等性等，没有不经抉择舍置根熟众生的过失，合为意行不共之四德。
    寅二、证所摄六法：
    志欲精进及正念，以及智慧与解脱，
    解脱知见不退失。
    此处宣说如来根无有从未得因果中失坏。即是，由往昔修习求取深广法等，绍隆三宝种性及利益众生的志欲不退失；由往昔勤修依止上师、成熟众生等，勇悍利他的精进不退失；由往昔修习四念处等，如实照见诸法的正念不退失；由往昔无厌足求法并生起三慧，能辨诸法的智慧不退失；由往昔断除愦闹而安住静处修习瑜伽及三解脱门等，远离障碍的解脱不退失；由往昔为令他人证悟而说法并以修行串习了知缘起律等，于法自在的智慧——从障碍中解脱且照见一切诸法的智慧不退失。此处未说禅定，但也可摄于“无有不定散乱”中，有些经论未说正念，但可摄于“无有心意忘失念”中，有些经论则全部具足，按此应志欲与精进合为一法或解脱与解脱知见合为一法。
    寅三、事业所摄三法：
    三门事业随智转。
    不共的事业即是，由往昔修习远离谄曲、欺诳、狡诈等梵行，身业显示神变等以智慧为导随智而转；由往昔修习断除妄语等,语言具有利益而且语音适中,并演说正法，语业宣说正法等以智慧为导随智而转；由往昔修习断除贪欲等,并且修习正见等，意业入禅定等以智慧为导随智而转，故身语意一切业均以智慧为导，随彼而转。
    寅四、智慧所摄三法：
    智慧无碍知三世。
    不共安住智慧者，即是由于往昔对“过去、未来、现在三世诸佛获得无著无碍的智慧”没有怀疑，并且自己欲求获得彼者的信解以及欲自他也如是趋入修行，由此依次对过去世以无著无碍的智慧了知，对未来世以无著无碍的智慧了知，以及对现在世以无著无碍的智慧了知，因此，了知三世的智慧没有著碍二障。
    丑二、摄义并说余义：
    如是十八及余法，是为佛陀不共德。
    如是有以行所摄的六法、以证所摄的六法、以事业所摄的三法、以智慧所摄的三法，共计十八种。此外，无量身,胜伏一切且殊胜超越无见顶相，如善见药树般一见即能寂灭众生过失等，也唯独导师佛陀具有，故是与其余补特伽罗不共的功德。
    子二、复说上义及获得之理：
    佛身语意悉无过，心无动摇无异想，
    不择舍置亦远离，志欲精进清净念，
    无垢智慧及解脱，解脱知见均不退，
    诸业普随智导转，三世无碍广智行。
    觉彼不共大菩提，为众无畏转妙轮，
    此唯具足大悲者，一切中胜如来得。
    大仙佛陀身行无错乱过，语行无嘈杂杂乱过，意行无失念过，心无动摇不定过，无有执著轮涅自性异体等种种异想，无有不择所化而舍置之过，此是以行为所摄的六种功德。寻求利他的志欲无退失，勇悍利他的精进无退失，照见一切义的清净正念无退失，无烦恼垢的智慧无退失，恒时从障碍中出离的解脱无退失，现量见一切如所有与尽所有的所知义的解脱知见何时无退失，此是以证所摄的六种功德。佛身语意三门的事业也是以智慧为导随智而转,此是以事业所摄的三种功德。于过去、未来、现在三世所摄的一切所知法恒时无著无碍决定的广大智慧，此是以智慧所摄的三种法。如是依靠现证如来的十八不共法后，对于所化有情无所畏惧转动圣法大法轮者，唯一是具足欲从痛苦中救度众生的大悲且已胜伏四魔的导师胜者,这也是以诸佛往昔已修持相应之道远离客尘障垢而现量获得的。
    癸二、喻义对应：
    地等体相空中无，虚空体相色中无，
    然五大种世间共，不共世间尘许无。
    譬如地等四大种所具有的地大体相坚固、水大体相湿润、火大体相暖热、风大体相动摇等有为法的体相,不是无为虚空的体相，虚空的体相无障无碍无为法等差别在四大种色中无有，故相互不混杂。如是，余人所具有的生灭等法佛陀没有，而佛陀诸究竟功德余人也未现前故，诸不共功德如同虚空。或者连比喻也已超越，即是地水火风空五界都与大种分相同故，是世间所共，然而与佛陀不共法相同者，在世间纵然极微尘许也没有的缘故， 以虚空也无法如实表示。
    辛二、广说色身异熟果功德分二：一、所表之三十二相；二、以能表比喻归摄。
    壬一、所表之三十二相：
    善住平满轮辐相，足跟广长踝不隆，
    1 2 3
    手足诸指悉纤长，及如鹅王网缦相，
    4 5
    肌肤柔软且细嫩，身体七处极隆满，
    6 7
    伊尼延鹿王腨10相，阴藏犹如大象王，
    8 9
    上身犹如狮子王，肩脖隆满极丰腴，
    10 11
    臂膀浑圆丰腴相，手软浑圆无高下，
    12 13
    正立不俯手过膝，清净之身具圆光，
    13 14
    颈项无垢如海螺，两颊平广似兽王，
    15 16
    齿具四十上下等，亦极清净且密严，
    17 18
    净齿长短粗细匀，大牙极胜洁白性，
    19 20
    难思无边广长舌，品尝诸味得胜味，
    21 22
    迦陵频伽自然声，梵音清澈深远闻，
    23
    眼如莲花 牛王睫，具净白毫严饰面，
    24 25 26
    顶有肉髻 肤金色，清净细薄众生尊，
    27 28
    一孔生一细柔毛，右旋细轮向上靡，
    29
    净发严如琉璃宝，身量端似尼拘树，
    30 31
    普贤无譬大仙人，那罗延力坚固身，
    32
    不思议相三十二，佛说此是人王相。
    （1）由往昔学道时立坚固誓愿，故最终成就如来色身足掌善住如龟腹般平满相。
    （2）由往昔布施种种资财，故成就手足掌千辐轮相。
    （3）由往昔不轻视他人，故成就足跟广长踝不突隆渐圆相。
    （4）由往昔以正法救度众生，故成就手足诸指纤长相。
    （5）由往昔不破人眷属，故成就手指足趾金网缦相。
    （6）由往昔布施种种妙衣，故成就皮肤柔软且身善住细嫩相。
    （7）由往昔布施殊胜美食，故成就身体双脚背、双手背、双肩、颈后七处隆满相。
    （8）由往昔护持佛法，故成就如伊尼延鹿王腨圆满结实渐细相。
    （9）由往昔不说淫秽语并断邪淫，故成就如象王或马王阴藏相。
    （10）由往昔渐次行持广大善业，故成就如狮王上身宽广相。
    （11）由往昔行持真实善法，故成就肩脖无凹处隆圆丰腴相。
    （12）由往昔对众生布施无畏并赐安慰，故成就臂膀圆实庄严相。
    （13）由往昔恒常欢喜助人成事，故成就柔软、形圆、无粗细高低、不须俯身即能过膝的手臂相。
    （14）由往昔无厌足行持十善，故成就障垢清净、身具圆光相。
    （15）由往昔于病者惠施众药，故成就如海螺具三纹理无垢颈相。
    （16）由往昔圆满修持善法加行，故成就如狮王平广脸颊相。
    （17）由往昔于一切众生心恒平等，故成就四十齿且上下各二十数量相等相。
    （18）由往昔平息纷诤、和合破裂，故成就清净密严齿相。
    （19）由往昔布施极悦意如意宝，故成就无垢清净、无长短粗细齐整齿相。
    （20）由往昔三门一切作业未被过失染污而行持，故成就如螺大牙洁白相。
    （21）由往昔一切时中持真实语，故成就细薄能覆自面的广长舌相。
    （22）由往昔布施悦意美味，故成就无边或无量、所有不可思议殊胜妙味并且劣臭之味亦成美味之相。
    （23）由往昔断除恶语说柔和语，故成就不须观待发心动机而自生之语如迦陵频伽悦耳音以及如梵天清澈远闻音之相。
    （24）由往昔以慈悲心养育众生，故成就如青莲叶黑白分明修长妙眼相。
    （25）由往昔心无谄诳，故成就厚密油黑无有混杂如牛王睫毛相。
    （26）由往昔赞叹应赞处，故成就严饰面容、若抽则长一肘不抽右旋而住的眉间无垢白毫相。
    （27）由往昔恭敬顶礼上师，故成就一切众生不见的顶髻相。
    （28）由往昔内心堪能并施悦意卧具，故成就具足清净障垢且无皱缩、细薄如金色的肤相，此为一切有情中最殊胜的佛陀所具有。
    （29）由往昔断除愦闹、增上善根并且平等纳受堪布阿阇梨的教授，故成就诸毛善妙细柔、每一孔生一毛、向上右旋之相。
    （30）由往昔断除殴打及持器械等，故成就无垢如琉璃宝般善住的绀发相。
    （31）由往昔将自他一切安置于三摩地中，故成就如圆满尼拘陀树长宽均等佛身相。
    （32）由往昔修复佛像佛塔并于诸怖畏中救度有情，故成就普贤无比大仙人相，即是佛陀具那罗延力如金刚身坚固、正直、各方皆具庄严之相。
    如是凡夫不可思议的显赫功德——三十二种天人师一切种智人王大丈夫相的功德，在经藏中已作明显宣说，此处仅是摘录而已。
    壬二、以能表比喻归摄：
    犹如无云空月色，秋季湛海水中见，
    如是正觉坛城中，佛子能见遍主身。
    犹如秋季，在无云虚空中见到圆满月轮，在净水盈满的湛蓝大海中见到圆满月影，如是，十地诸佛子、诸平凡众生分别在正等觉坛城及世间坛城中见到遍主佛陀的报身与化身二种色身，其中菩萨见报身如见空月，凡夫见化身如见水月。
    庚三、以经教了知彼等功德：
    如是六十四功德，各自所具成就因，
    及其次第当依照，宝女问经而了知。
    应当了知：如是善逝十力、四无畏、如来十八不共法、大丈夫三十二相等六十四种佛功德，彼等各自的因——法身所具诸功德能离垢的离系因与色身所具诸功德渐次能生的异熟因，此处所说的诸因数量与次第，都是如实依照《宝女请问大乘窍诀经》宣说的。
    庚四、以喻义复摄其义分二：一、总说喻义相同；二、别说彼等各自喻义对应。
    辛一、总说喻义相同：
    由无毁坏无羸劣，无与伦比无动故，
    次第金刚狮子王，虚空水月喻显示。
    善逝十力由各自违品不能坏故，如同金刚；四无畏由辩才无羸劣故，如同狮子；十八不共法由声闻等不可相比且不共故，如同虚空；具有妙相的二种色身在如虚空般的法身中无动移的同时于所化前显现故，如同月轮。是故，四部功德以有质金刚喻、兽王狮子喻、无为法虚空喻以及净水中所现的水月喻依次而显示。
    辛二、别说彼等各自喻义对应分二：一、宣说离系果法身之功德；二、宣说异熟果色身之功德。
    壬一、宣说离系果法身之功德分二：一、展开以比喻表示；二、归纳无差别之理。
    癸一、展开以比喻表示分三：一、以金刚喻表示十力；二、以狮子喻表示无畏；三、以虚空喻表示不共法。
    子一、以金刚喻表示十力分二：一、别别表示；二、共同表示。
    丑一、别别表示：
    初六中三后一力，依此十力之次第，
    遣除所知三昧障，以及习气诸障故，
    如甲如墙如稠林，刺穿摧毁截断故。
    以处非处智力等十力中的前六力、中间三力、最后一力次第可遣除所知障、三摩地障、习气诸障故，如同金刚；三种障碍则如坚甲、牢墙与稠林，依次被十力刺穿、摧毁及截断故。
    丑二、共同表示：
    重精坚固不坏故，大仙势力如金刚，
    何以沉重由精华，何以精华由坚固，
    何以坚固由不坏，不坏是故如金刚。
    由具足沉重、精华、坚固、不可坏四种功德法，诸大仙正等觉佛陀的十力犹如金刚。对此宣说如下：为何是沉重？是轮涅诸法之精华故；为何是精华？是无为且任运自成的坚固性故；为何是坚固？一切分别心、执著相等违品不可坏故。如是摧毁一切所断而自身不被所断摧坏故，十力犹如有质的金刚。
    子二、以狮子喻表示无畏分二：一、略说；二、广说。
    丑一、略说：
    无畏惧故善住故，坚故势力圆满故，
    释迦狮子如狮子，于大众中无畏惧。
    对何者也无畏惧故，对何者也无须观待而善住故，智慧力坚固故，能摧违品的势力圆满故，如是具足四种功德法故，如同具足四法的狮子王在兽群之中无畏安住般，人王释迦狮子在眷属大众之中无所畏惧而安住。
    丑二、广说：
    正遍知故于何者，无所畏惧而安住，
    清净有情与自身，亦见不等故善住，
    心于一切诸法中，一缘安住故坚固，
    极细无明习气地，彻底越故具势力。
    如是所具四法以何者而了知呢？即是具足：由现量正遍知一切所知故，能无误解答一切问难，以此对敌者等何人也无畏惧而坦然安住的功德，如是，分断障碍的清净有情声闻罗汉及住十地菩萨者也见与自己不等且能超胜故，毫无观待他人而善住的功德，于如所有尽所有的一切法自心无分别且能一缘安住故，具足于三摩地中坚固的功德，极难断的极细无明习气地也善超越故，能彻断违品的势力圆具的功德。
    子三、以虚空喻表示不共法：
    凡夫声闻及独觉，具慧菩萨与如来，
    愈上智慧愈细微，故以五大喻显示。
    一切世间受用处，故如地水火风大，
    超越世出世间相，故不共法如空大。
    执著我的世间凡夫、证悟无我的圣者声闻、证悟人无我与部分法无我而行一方寂灭的独觉、证悟人法二无我的具慧菩萨以及现量遍知一切的自生正等觉如来，彼等愈上智慧也愈细愈深故，能表示彼等的比喻依次是地水火风空，即与五大前前粗大、后后细微相同。或者，佛陀诸功德是世间资生受用的殊胜依处，故如能依的坚地、摄集的湿水、能成熟的暖火、能不腐坏的动风，是与世间的受用相同。再者，佛相续中现前的功德法，超越世间凡夫与出世间声闻等诸功德法的体相，与彼等不共故，如同虚空超越四大体相般。
    癸二、归纳无差别之理：
    此等三十二功德，依止法身无别异，
    如如意宝光色形，彼等三者无别故。
    如是十力、四无畏、十八不共法的此等离系果三十二种功德，是自利胜义法身所具有，并于彼中无别安住，以如如意宝的光色形三者无别般，此等功德在同一法身中也是无别故。
    壬二、宣说色身异熟果之功德分二：一、三十二相依报化二身而住；二、以月喻表示二色身。
    癸一、三十二相依报化二身而住：
    见时喜足功德者，所谓妙相三十二，
    依二色身即化身，圣法圆满受用身。
    以“善住平满轮辐相”等妙相庄严的佛身，所化一见便知此是大丈夫而得心意满足并且能生信心，具有此等异熟果功德者，即是所谓的三十二种妙相。彼者是依止共同所化前显现的化身以及圆满受用大乘法的报身，也就是依止二种色身。
    癸二、以月喻表示二色身：
    依于垢净远近众，世间如来坛城中，
    见此有情有二种，如现水空月轮色。
    依于清净见色身的障垢，远的凡夫声闻等、近的安住十地诸菩萨，依次于世间坛城中在诸平凡者前显现化身，于如来坛城中在诸菩萨前显现报身，如同在净水中见月影以及在虚空中见真月色相一般，如是见妙相庄严二种色身的所化有情的种性有两类，故欲现前色身者应当具足清净的缘分。
    大乘无上续论辨三宝种性中功德品第三终。


大乘无上续论释·善说日光　事业品

    事业品第四

    现在宣说由获得彼等功德的功能成就如来任运自成相续不断的事业。
    戊四、觉他行之事业义分二：一、显示任运相续不断；二、以比喻了知。
    己一、显示任运相续不断分二：一、略说；二、广说。
    庚一、略说分二：一、略说任运；二、略说相续不断。
    辛一、略说任运：
    所化界与调方便，所化界之调伏事，
    随所化处应时行，遍主恒时任运转。
    诸佛在行持利生事业时，虽了知一切所化众生不同的界、意乐与随眠种性，而无此者彼者的分别勤作任运而行。如是对应：相应所化众生各自意乐，显示折摄等种种调伏方便，无勤作任运而行，如《妙臂请问经》云：“何者自性离贪嗔，于贪有情示贪相，所化嗔怒显怒姿，顶礼安住胜菩提。”如是，将种种界的所化众生安置于种种增上生、决定胜的调伏事业，也无勤作任运而行；无边世界中何处有所化众生，佛即前往彼处，无勤作任运而行；何时所化众生堪可调化，佛即应时往赴，于此遍主正等觉佛恒时无有分别念等勤作任运而行。这是略说任运自成。
    辛二、略说相续不断：
    具足功德胜宝聚，智慧水海福慧日，
    诸乘无余定成就，广无中边如空遍，
    佛性功德无垢藏，已见众生无别具，
    烦恼所知云罗网，诸佛大悲风令散。
    由出离因——具足陀罗尼、三摩地等功德胜宝聚并以无垢智慧水充满的菩萨十地大海，及显示因——能成熟诸有情的福慧资粮日光，由此令众生成就无余道乘的因圆满具足故，如来事业相续不断。如是，彼等之果圆满是获得无有中边广阔如虚空般周遍一切的大菩提故，如来事业相续不断。得菩提后，见如宝藏般具有力等无垢功德的胜义如来藏于一切有情本来无丝毫差别安住而作摄受彼等的事业故，摄受的根据也是对如虚空般的如来藏须遣除能障客尘烦恼障及所知障的云网故，能遣除彼等障碍之缘也以诸佛如飓风般的大悲能吹散如云诸障垢故，如来事业相续不断。此外，也可如此解释：将诸有情暂时安置于十地及二资粮道中，究竟安置于大菩提中，由此诸有情的一切障碍以大悲作摧毁事业，故事业相续不断。
    庚二、广说分二：一、宣说任运；二、宣说相续不断。
    辛一、宣说任运：
    何者依于何方便，调所化业何处时，
    于彼不生分别念，是故能仁恒任运。
    何者种种所化界，彼彼诸多调方便，
    所化种种之事业，何处何时任运行。
    为何者所化，以何种方便调伏以及调伏的事业，前往所化之处，时机成熟而作调伏，对于彼等此者彼者的所化事业不生分别且无勤作动摇，故能仁正等觉佛陀的事业恒时任运成办彼等。彼亦，为何者种种意乐的所化界，相应所化各自信解，以三乘等彼彼诸多调伏方便而作调伏任运而行，以及如安置于暂时增上生及究竟决定胜的何种调伏事业任运而行；于何处何时即随所化之处及应化之时前往彼处，于彼等也无分别勤作任运而行。
    辛二、宣说相续不断分五：一、以名宣说分类；二、宣说义之本体；三、以比喻表示彼等；四、广说喻义；五、相续不断之摄义。
    壬一、以名宣说分类：
    出离以及彼显示，彼果以及摄受彼，
    彼障以及断障缘，于此无有分别故。
    诸佛利益众生的事业相续不断，因为出生事业的出离因、彼之显示的缘、彼等因缘成就的果相、摄受彼果事业的行境、应断除彼所行境的障碍、能断彼障的事业，于此等所缘，佛无任何分别念自然而行故。
    壬二、宣说义之本体：
    所谓出离即十地，二种资粮是彼因，
    彼果乃为大菩提，菩提摄受诸有情，
    彼障无边诸烦恼，及随烦恼与习气，
    一切时中断障缘，彼者乃为大悲心。
    何为义之六种根据？即：到达究竟出离位的因是菩萨十地依次行持，福慧二资粮是使殊胜十地功德辗转增上的显示因，如是由因圆满中出生故，如来事业相续不断。而且彼等究竟果是获得无上正等觉殊胜大菩提故，如来事业相续不断。而且得菩提后见一切众生皆具如来藏而摄受故，摄受的根据也是众生如来藏上有能障的无边烦恼、随眠烦恼及习气诸客尘障垢须遣除故，一切时中恒时具有能断障碍的助缘——大悲心显示正道故，如来事业相续不断。
    壬三、以比喻表示彼等：
    应知此等之六处，如其次第而宣说，
    犹如大海与日轮，虚空宝藏及云风。
    成为如来事业相续不断之根据的此等六处，以喻义对应依次而了知，即是：菩萨十地如大海，福慧二资如日轮，彼等之果大菩提如虚空，由大菩提所摄受的众生界如宝藏，彼障垢诸烦恼如云，能断彼等的大悲如猛风。
    壬四、广说喻义：
    智水功德宝具故，诸地犹如广大海；
    为诸众生资生故，二种资粮如日轮；
    无有中边广大故，菩提犹如虚空界；
    正等正觉法性故，众生界如珍宝藏；
    客尘周遍无体故，彼障烦恼如云聚；
    住能散尽彼障故，大悲犹如猛烈风。
    具有无垢智慧水及神通等功德宝珠故，出离因菩萨十地如大海。能作一切众生利乐之受用故，显示因福慧二资如日轮。由遍一切故广大、无中边故甚深，彼等之果大菩提如虚空界。本来任运安住正等正觉的法性无尽功德财故，所摄受的诸有情界——自性清净如来藏如宝藏。所断法是客尘、于自性能周遍、及胜义中不成谛实故，自性清净佛性的障碍诸烦恼如重云聚。安住于开示能散尽如云般彼障的近道故，断障助缘的大悲如无尽猛烈风。
    壬五、相续不断之摄义：
    由于他因得出离，自与有情见平等，
    事业尚未圆满故，轮回未空业不息。
    往昔于十地修集二资时立誓救度一切有情，由此依他因圆满得出离故，见自己所得大菩提与众生界自性清净毫无差别而平等后了知作事业有义故，以大悲能断世间界中无边众生障碍的事业尚未圆满故，乃至所化轮回未空之间，如来事业相续不断。
    己二、以比喻了知分四：一、总标以比喻分类；二、对应意义别别宣说；三、宣说必要并摄该处之义；四、又复归摄而说差别。
    庚一、总标以比喻分类：
    譬如帝释法鼓云，亦如梵天及日轮，
    摩尼宝王与谷响，以及虚空与大地。
    诸如来事业以无分别任运自成且相续不断的方式相应所化缘分而行，对此能表之喻有九种，即是：以身示现无量游舞，犹如帝释安住天界不动的同时，影像现于人间诱导他人行善；以语善说种种教诫，犹如天鼓演说四法印利益诸天；以意之智悲周遍一切有情，犹如云聚普覆一切且降雨能成熟庄稼；以身语作种种幻化，犹如梵天于自处不动而诸欲天见彼幻身获得利益；以意智慧照射无量，犹如日光渐次能遣诸暗；以意之秘密作他利，犹如摩尼宝王无分别的同时赐予一切所需；以语之秘密作他利，犹如谷响虽无谛实而演说种种诸义；以身之秘密作他利，犹如虚空虽周遍一切然不成有为色法之体；以转依之大悲成办他利之理，犹如大地为一切所依而作利益。
    庚二、对应意义别别宣说分九：一、应以帝释喻宣说显示种种神变之理；二、应以妙法鼓喻了知宣说教诫之理；三、应以云喻了知智悲周遍之理；四、应以梵天喻了知种种幻化相之理；五、应以日轮喻了知智慧照射之理；六、应以如意宝喻了知意之秘密；七、应以谷响喻了知语之秘密；八、应以虚空喻了知身之秘密；九、应以大地喻了知遍入之理。
    辛一、应以帝释喻宣说显示种种神变之理分三：一、虽无分别成就他利；二、与彼者善加对应而宣说；三、摄义而说无生灭相。
    壬一、虽无分别成就他利分二：一、能表比喻；二、所表之义。
    癸一、能表比喻分四：一、净地基中现影像；二、由此安置善业中；三、以彼善业获得所欲果；四、无勤成办利益之理。
    子一、净地基中现影像：
    犹如自性净无垢，琉璃所成大地基，
    以其清净故映现，天主帝释天女众，
    以及胜利妙宫殿，此外其余诸宫殿，
    帝释无量宫种种，天界诸物皆现见。
    譬如，一时南赡部洲整个大地基由自性清净的琉璃如意宝所成，由地基极清净故，如明镜中映现色像般映出：须弥顶上住在三十三天的天主帝释，由天女等无量眷属围绕，天主住处胜利妙宫，地皆四宝所成，有四方台阶，柱子由金、银、琉璃、天然水晶合成，柱墩、头棋、柱头等则由螺宝等构成，宫中有百一楼阁，每一楼阁亦有七楼等严饰。
    天主宫殿外，有众多悦意舍宅，金色罗网四面环绕，院墙均由金、银、琉璃筑成，有四层胜妙屋檐，九百九十九扇门，每扇门都以众宝严饰，一一门中都有五百执戈披甲武士守卫，一切街道遍布金沙等。
    帝释无量宫中有牵引马车等种种排列，其余宫殿由种种宝珠所成，楼阁、庭榭、凳椅、罗网交错之诸窗均由诸悦意物善妙严饰。诸天受用五欲的处所悦意花苑中，有天树等如意树，凡衣食、服饰、香花、乐器等都能随欲化现，又有天池，八功德水充满其中，池中复由花鸟严饰。所有街道遍立手执乐器的姝丽天女，大地遍布曼陀罗花等。
    如是种种天物的影像显现时，人间可以善见此等。
    子二、由此安置善业中：
    此后地上所居住，善男善女诸群众，
    已见彼等诸显现，心中能发如是愿，
    我亦无须极久远，即与帝释成同等，
    为获彼者真实持，白净善法而安住。
    此后南赡部洲地居男女众看见显现的三十三天无量圆满后，生起大欢喜并欲求取，心中能发如是诸愿：“我等也无须久时即能与受用圆满的帝释成为同等。”此后为获得彼帝释果，以真实行持受一分戒等白法而安住。
    子三、以彼善业获得所欲果：
    彼等由于白善法，仅见此等影像现，
    虽不如实而了知，地上命终亦升天。
    彼等诸男女由于行持持戒等白净善法，仅见帝释等的影像，并非真实天等降临，纵然不能如实了知而把影像执为真实，但以此行持善法故，在人间地上命终后，即可升于各自所欲的天界。
    子四、无勤成办利益之理：
    显现影像彼等者，虽极无念无动摇，
    然而于此地基上，成就大义而安住。
    在琉璃地上显现的帝释天等影像，彼等无有丝毫欲将南赡部洲人类安置于善法的分别念，亦无以勤作之动摇。虽然如此，但使地居诸人直接入于善法、间接入于所欲果位中，故是具有成就大义而安住。
    癸二、所表之义分四：一、于净心中现色身；二、以彼成就所欲果；三、无勤成就利益；四、渐次得究竟法身。
    子一、于净心中现色身：
    如是无垢信心等，修持信心等功德，
    自心中现正等觉，具有妙相及随好，
    从容行步及站立，端然而坐与卧息，
    作诸威仪妙姿态，有时宣说寂灭法，
    有时默然入禅定，显示种种神变相，
    具大威光极晃耀，有缘众生能见此。
    如是远离信心、精进等的违品无信等障垢，自相续渐次修习信心、精进、正念等功德，遂于自己清净心中现出具有三十二相、八十随好的正等觉佛陀，或行或立，或坐或卧，或入城市聚落等，显示种种威仪妙姿，有时对所化众生宣说寂灭涅槃法，有时不说法而内观入定，或显示神足通等种种神变，具有广大威势晃耀的圆光等无量幻化，有缘众生能见此等。
    子二、以彼成就所欲果：
    见已发起欲求心，为能成佛善修习，
    真实受持成佛因，所欲之果能获得。
    见到自己清净心中显现的色身后，以具有欲求佛果之心，为能速得成佛，修持闻等善法，如是渐次修行能成就佛果之因——发无上菩提心、加行真实受持六度等后，能获得所欲之果——究竟佛果。
    子三、无勤成就利益：
    净心显现之佛陀，虽极无念无动摇，
    然而于此世间中，成就大义而安住。
    清净心中显现的彼佛无有丝毫对众生欲作利益的此种彼种之分别念，并且何时也无有以勤作动摇，虽是如此，然于世间，由见佛，诸所化能直接趣入广大善法，间接则被安置于一切种智之中，故是具有成就大义而安住。
    子四、渐次得究竟法身：
    此乃自心所显现，虽诸异生不能了，
    然由现见色身相，亦于彼等有义利，
    依见色身亦逐渐，安住大乘诸士夫，
    以智慧眼能照见，内具胜义法性身。
    此色身无量幻化仅是自己清净心中所现的胜义如来之影像，并非究竟的如来。对此，虽然诸凡夫不能真实了知，但见如来色身，也对彼等见者所化有大义利，因为由见色身后为得如来果而逐渐安住大乘甚深实修道的有缘士夫，以入定无分别智慧眼，现量照见内各别所证胜义心性光明法身具一切殊胜相的空性。
    壬二、与彼者善加对应而宣说：
    犹如诸地离险难，具摩尼德光严净，
    如是无垢琉璃成，地面平正清净故，
    映现天主诸住处，天主及天眷属像，
    净地功德渐离故，则此不复再显现。
    为得彼者而修持，近住禁戒布施等，
    男女诸众发愿心，向空抛散妙花等。
    为能获得如琉璃，净心中现能仁果，
    具极欢喜诸佛子，善能发起如是心。
    譬如南赡部洲一切大地远离悬崖、险难等可怖之处，以具有摩尼宝光明、妙严、离垢等功德的无垢琉璃宝自性所成的地面平正如掌，由大地如此清净明亮故，如镜面般彼中映现出天主住处胜利宫等、诸天主帝释、其余各部众天以及天物无量受用的影像，最终由地的明净等功德逐渐消失，彼等色像不复现前。由见显现为获得受用圆满的帝释果而持八关斋戒等禁戒并决定上供下施等的男女众人，发起愿得天主果而散花烧香等白净善行。如是，为了获得如离垢琉璃般的自心所现能仁果，对佛具有极大欢喜的诸佛子，也如众人为得天主而行善般，善能发起殊胜菩提心，随后精勤修行六度。
    这是说明：犹如地基不净则影像不现，如是诸无缘者不能得见如来。
    壬三、摄义说无生灭相：
    犹如清净琉璃地，映现天主身影像，
    如是众生净心地，亦现能仁身影像。
    犹如帝释现不现，由地净与不净故，
    众生现不现影像，由心浊与不浊故。
    佛影虽现生与灭，然不能作生灭观。
    犹如人间远离尘垢等的琉璃净地上映现天主身和受用的影像，如是所化众生远离不信等的清净心地上，显现具有相好的能仁身像。虽然如此，所化前佛身影像的隐没与显现，是由自心无有不信等尘垢而清净故，显现色身，由自心有不信等尘垢而不净故，色身隐而不现。犹如世间虽由地基的净与不净，天主的影像有显现与隐没，但天主于自住处毫无移动，如是虽由所化心地有净垢差别，如来色身有生灭的显现，但何时也不能把胜义法身视为有生灭，以法身是无为法无迁变故。
    辛二、应以妙法鼓喻了知宣说教诫之理分三：一、以天鼓妙音宣说圣法；二、亦超此等诸喻；三、彼等由缘而入。
    壬一、以天鼓妙音宣说圣法分二：一、广说喻义相同之根据；二、又复善加对应摄义。
    癸一、广说喻义相同之根据分三：一、无勤作；二、由业出生；三、由此成就寂灭。
    子一、无勤作：
    如天界中由诸天，往昔白法善业力，
    法鼓无勤无生处，亦无意色与分别，
    同时能说无常苦，无我寂静之法音，
    依此数数作警策，令诸天人不放逸。
    如是遍主虽远离，勤等然于诸有情，
    如来法音能周遍，于诸有缘宣说法。
    犹如在天界中，由于诸天往昔积累白法善业之力，法鼓虽无想说等的勤作、舌鄂等发音生处，也无意色与分别的动机，但能演说诸行无常、有漏皆苦、诸法无我、涅槃寂静，以此对在欲妙中散乱而放逸的诸天数数警策令行善法。如是，遍主诸佛虽然远离想说此者彼者的勤作等，但在所化有情前，相应彼等各自的语言，佛语都能周遍，以此对三种种性的诸有缘者广说三乘妙法。
    子二、由业出生：
    犹如天界妙法鼓，其音依于自业生，
    如是世间佛说法，其音众生自业生。
    犹如天界，诸天妙鼓宣说四法印，是由诸天各自积累的共同善业力所出生。如是，在世间，能仁佛陀契合所化意乐宣说无量法门也是由众生各自的广大善业力所出生的。
    子三、由此成就寂灭：
    如离勤作处身心，妙音令天得寂静，
    如是离勤等法音，令诸众生得寂静。
    犹如远离想说等的勤作、声音生处、意身及分别动机的天鼓妙音，能令诸天成就寂灭放逸之果。如是，佛陀法音以远离勤作等四者的方式，相应各自缘分宣说妙法，也能令无量所化的相续中成就寂静涅槃之果。
    癸二、又复善加对应摄义：
    譬如天城妙鼓声，彼因产生无畏施，
    烦恼心起战斗时，破诸修罗与嬉戏。
    如是由佛于世间，说法四禅四无色，
    彼因摧毁烦恼苦，开示无上寂静道。
    譬如天界城中，以妙法鼓声为因出生并赐无畏是：当诸天以嗔烦恼为与非天作战而进入战场时，法鼓发出“汝等天人切莫怖畏”等声音，由此胜伏非天，消除怖畏；当以贪烦恼耽著嬉戏在欲妙中放逸时，以四法印之声断除放逸。如是，在无量所化世界中，以佛说法为因而出生修持四禅、四无色静虑等善根增长，极能摧毁众生烦恼与痛苦的怖畏，并能显示无上寂静涅槃之道，由此能得彼果位。
    壬二、亦超此等诸喻分二：一、略说；二、广说。
    癸一、略说：
    由于能遍众生界，具有利乐三神变，
    是故如来妙语声，超胜天界铙钹等。
    由于能周遍契合无量所化众生的各自意乐，故非少许；由于具有安置于究竟决定胜，故是利；由于具有安置于暂时增上生，故是乐；由具三神变——身之变化神变、意之普化神变、语之教诫神变，故能使众生在痛苦中获得安慰。具有此四种功德故，能仁佛陀妙音极为超胜不能作利乐出离的普通铙钹等。
    癸二、广说：
    天界妙鼓发巨响，地居众生耳不闻，
    佛鼓妙音能遍行，轮回下界诸世间。
    天界乐器百千万，为增欲火而演奏，
    大悲诸佛仅一音，亦令息灭痛苦火。
    天界美妙铙钹声，唯增心之掉举因，
    大悲自性如来音，能令心入三摩地。
    总之宣说尽世间，天及地住安乐因，
    此等无余皆依靠，普世遍现佛圆音。
    虽然在天界中妙鼓的巨响遍行，但地居众生的耳中不能听闻，故是少分，而佛鼓妙音在应化时，住于轮回的下界所化世间也能遍行，故非少分，由此而超胜。如是对应：天界中百千万种不同乐器只是为增欲火而演奏，故非利，而大悲自性的正等觉诸佛虽仅一音，也令有缘者获得苦火及苦因极为息灭的涅槃，故是利，由此亦超胜；天界排布庄严并且闻已心悦的种种铙钹妙音，仅是令心增长于所缘境掉举与散乱的声音，故非乐，而大悲自性的如来妙音则是能劝引所化令心入于禅定、三摩地之因，故是乐，由此亦超胜。总之宣说天界的铙钹等不是出离，而在尽世间界中，天与地居人等遣除苦因及苦果后增长无漏大乐之因，即是依靠具足三神变尽世间界周遍显现的如来圆音，故能令痛苦出离，由此亦能超胜。
    壬三、彼等由缘而入：
    犹如远离耳根故，不能听闻细音声，
    亦如具有天耳者，亦非遍闻一切声。
    如是微妙胜法音，微细智慧之境界，
    若心无有烦恼垢，彼人耳中方闻受。
    犹如离耳根故不能听闻并察觉细声，如是诸无缘者不闻佛陀妙音。亦如具天耳者虽能听到有些细声，但也不能遍闻一切差别声，如是佛陀甚深微妙法音仅是微细智慧的境界，并非一切所化者的耳中都能闻受，仅是某些具大因缘无烦恼的胜慧者的耳根中方能闻受。
    辛三、应以云喻了知智悲周遍之理分四：一、与生长庄稼相似而对应；二、以器变异相似而对应；三、与不观待相似而对应；四、与寂灭诸火相似而对应。
    壬一、与生长庄稼相似而对应分二：一、略说无勤作之理；二、宣说由缘而入。
    癸一、略说无勤作之理：
    犹如夏季之云聚，庄稼茂盛圆满因，
    水蕴丝毫无勤作，自然降澍于大地。
    如是依于大悲云，佛陀圣教妙法雨，
    众生善根庄稼因，无有分别自然降。
    犹如夏季大云涌聚，农民庄稼圆满之因的水蕴无勤普降大地。如是，依佛无量大悲云聚，佛语圣教妙法大雨是众生善根庄稼增上之因，也是无有分别心之动机与勤作的同时任运而降。
    癸二、宣说由缘而入：
    犹如世间行善时，风起云涌降雨霖，
    如是慈风为增善，佛云降澍圣法雨。
    于彼三有依智悲，不染轮涅住虚空，
    三昧总持净水藏，佛云善根庄稼因。
    犹如世间凡夫不放逸行持善法时，则由诸天之力，缓缓起风并搅动云聚，而渐次降下雨水。如是，也由所化众生信心、精进等善根增长故，以诸佛大慈悲风搅动的云聚中降下圣法大雨。如是与云相同的根据是：为了利益住于三有轮回的所化之田，依靠真实智慧与大悲，以智慧证悟一切无我故，不染变迁轮回之过，以大悲摄受一切有情故，也不染无变涅槃偏堕之过，如是住于虚空中央并具有无漏无量三摩地门、陀罗尼门的无垢净水库藏的能仁正等觉佛云，是增上无尽善根庄稼之因故。
    壬二、以器变异相似而对应分二：一、宣说比喻；二、宣说其义。
    癸一、宣说比喻：
    犹如云聚中普降，清凉甘甜轻软水，
    由合地层盐咸等，遂成种种诸异味。
    犹如从空中降下具有触觉清凉、滋味甘甜、不损身故柔软、易提升故轻、澄净、无臭、多饮亦不损肠胃、咽喉等如是八种功德的一味之水，而从云中逐渐降下时，由于和地层有盐咸与无盐咸等异处相合，故成苦、甘、咸等诸异味。
    癸二、宣说其义：
    如是广阔慈悲云，普降八支圣道雨，
    由合众生分类处，遂成种种异解味。
    如是，佛陀所说之法具有八圣道支及甚深真如的一味之雨从极广阔的慈悲云聚中次第降下时，由于和众生相续的界、根、意乐等种种异处相合，遂成三乘等种种异解之味。
    壬三、与不观待相似而对应分三：一、以三喻略说；二、广说其义；三、无观待而入。
    癸一、以三喻略说：
    于此最胜大乘法，具信中等及嗔者，
    此等三聚似三类，人类孔雀与饿鬼。
    依诸佛降下一切法真如一味相的胜乘法雨，对此具有净信的正定聚、信与不信之间的中品不定聚以及嗔恨大乘的不信邪定聚，此三者依次如降雨时人类欢喜接受、旃达嘎住于中品、诸饿鬼嗔恨不信般。
    癸二、广说其义：
    犹如夏季无云雨，人苦孔雀住舍受，
    夏季地上降澍雨，令诸饿鬼受灼苦。
    诸佛大悲云聚中，法雨世间降不降，
    于法具信及嗔者，世间之中此譬喻。
    犹如春末夏初，在无云不降雨时，人们忧愁不喜，一旦降雨则内心欢喜；对于不能在空中飞翔的旃达嘎鸟而言，何时也不观待水故，住于喜与不喜的中品中；诸饿鬼则不欢喜，当夏季大雨普降大地时，现出热沙故，彼等感受剧苦不喜而住。如是，在世间，由诸佛大悲云聚中降与不降深广法雨，依次：对法具信的正定聚在降法雨时欢喜，不降则不欢喜；不定聚对法住于喜与不喜的中品舍受中；对法嗔恨的邪定聚，如不降法雨则欢喜而住。此等三义应与世间中三种能表之喻对应。
    癸三、无观待而入：
    犹如空中降大雨，冰雹石类金刚火11，
    微细含生入谷人，云于彼等无分别。
    善巧方便智悲云，普降细广妙法雨，
    惑净我见随眠众，佛于彼等无分别。
    犹如空中降下倾盆大雨时，会落下大雨与冰雹，有些地带由业力也降下石砾与金刚火，对于大地上安住的微细含生受害以及避入山谷的有情不受害等，云聚均无分别、不观待而降。如是，以善巧方便从诸佛智悲云聚中降下微细深广的妙法雨时，对某些将清净烦恼的有缘者产生广大利益，而对某些具嗔恚我见随眠坚固的无缘者则暂时无利益，然对彼等的利害恒时无分别、无观待而降。
    壬四、寂灭诸火相似而对应分三：一、能寂灭苦火聚；二、次第生起能寂灭之智慧；三、依照了知取舍而修行。
    癸一、能寂灭苦火聚：
    轮回生死无始际，众生流转于五道，
    犹如粪秽无香气，五道之中无安乐。
    轮回痛苦恒如触，烈火利刃盐生苦，
    大悲云降圣法雨，善能平息此诸苦。
    由于以三种杂染所摄的十二缘起轮转生死等，痛苦本无从此开始的初际，对不修解脱道的有情而言，也无至此终止的后际。众生流转之道有五种相，即地狱、饿鬼、旁生三恶趣与人、天两种善趣，所以，如不净粪中无有香气般，如是五道轮回中何时也没有丝毫安乐的机会，因为恒时都住于三苦、八苦等极苦之中。此轮回痛苦的差别也是恒时相续不断，就如以烈火焚烧、利刃割截、新伤撒盐等触所生之苦般，住于极为难忍之中。从欲救拔此等痛苦的佛陀大悲云聚中，相应各自机缘相续不断降下的深广圣法大雨，能极善寂灭诸痛苦之火。
    癸二、次第生起能寂灭之智慧：
    已知天中死堕苦，人中亦有寻求苦，
    是故具有智慧者，人天殊胜亦不求。
    智慧以及随佛语，生起信解此是苦，
    此等业惑是苦因，此灭由智所见故。
    已了知“天中有死堕苦，人中也有无者寻求、有者守护、饥渴劳累等苦”故，了知轮涅真实相的诸智者对于天中自在帝释等以及人中自在转轮王等的胜位也不希求，因为以俱生智慧以及在今生也以净信随顺无垢佛语而作如理闻思后，以证悟无我道的清净智慧真实照见有漏果反体的一切都是苦，业惑此等一切是彼因集，轮回苦因苦果无余灭尽是寂灭涅槃故。
    癸三、依照了知取舍而修行：
    如病应知因须断，乐住当得药当依，
    苦因苦灭如是道，应知应断应触修。
    犹如希求离苦获得痊愈安乐的具慧者，应当了知病的自性，病因——忌物等是所断，安住无病之乐是所得，彼方便之药是应善巧依止。如是，对于希求远离轮回痛苦获得涅槃安乐的具慧者，以有漏果所摄的一切轮回痛苦是所应了知，其因以业惑所摄的一切集是所应断除，彼等障垢远离之灭即涅槃安乐是所应现量触或证得，其方便无漏五道依次是于相续中所应依止。
    辛四、应以梵天喻了知种种幻化相之理分二：一、于有缘者示现显现；二、于无缘者不示现显现。
    壬一、于有缘者示现显现分三：一、宣说无勤作故相似；二、宣说除过失故相似；三、宣说对有缘者示现故相似。
    癸一、宣说无勤作故相似：
    犹如梵天于住处，梵宫不动之同时，
    遍于欲天一切处，无勤自然而示现，
    如是能仁法身中，毫不动摇之同时，
    于世有缘无勤作，自然示现变化等。
    犹如色界大梵天于梵宫——初禅无量殿中安住毫无动移的同时，在欲天一切六处无勤而示现幻化相。如是，能仁正等觉诸佛也于胜义法身中何时不动而在无边世间界的有缘众生前，无勤任运示现以世俗幻化色身调伏所化的种种神变。
    癸二、宣说除过失故相似：
    如梵恒住无量宫，不动遍入欲界天，
    诸天见彼妙色相，由此遣除五欲乐。
    如是佛于法身中，不动示现诸世间，
    有缘众生见欢喜，由此恒能净诸障。
    犹如大梵天恒时安住于自己无量宫中毫无动移的同时，以幻身遍入欲天一切处，见彼妙相，依于见色界天的吉祥圆满后，诸欲天为求得梵天果而能断除对于欲界悦意色、悦耳声、妙香、美味、滑触等五欲功德的贪著。如是，圆满善逝诸佛在法身中何时也不动移而安住的同时，以化身尽所有世间界遍现无量幻化，有缘者将会见到，而且依靠见色身幻化，也为获得佛之圆满而能恒时精勤断除一切二障及习气的障垢。
    癸三、宣说对有缘者示现故相似：
    如依梵天昔誓愿，及与诸天善业力，
    梵天无勤而显现，佛陀化身亦复然。
    犹如依靠梵天往昔所发利益诸天的誓愿力以及欲界诸天共同积累的能见梵天之善根力，梵天无勤而幻现于欲界天处。如是，自生圆满诸佛的化身也以宿愿及诸所化的善根力，在法身中无勤而于世间示现种种幻化。
    壬二、于无缘者不示现显现：
    降入胎诞往父国，嬉乐苦行降魔军，
    证大菩提转法轮，涅槃无缘者不见。
    在所化机缘成熟时，诸佛示现从兜率天降生南赡部洲，入于摩耶夫人等母胎，蓝毗尼等园中诞生，前往父国迦毗罗卫等城中，与八万等妃眷嬉乐，出家后在静处修持苦行，往诣菩提座降伏魔军，依金刚喻定获得大菩提果，由转法轮对有情开显能趋入寂静涅槃城的正道等，善巧开示后暂时见利益所化之事业已圆满，诸能仁示现涅槃。此等于无缘见如来的诸众生前，则不显现。
    辛五、应以日轮喻了知智慧照射之理分四：一、于利害无分别；二、无分别而利他；三、由缘分差异而次第显现；四、超胜比喻之理。
    壬一、于利害无分别：
    如日普照诸莲花，有花闭合有花绽，
    日于功过无分别，佛陀日轮亦复然。
    犹如强烈日光一时普照诸莲，水莲开敷，白邬波罗花闭合，而日轮对水莲开启的功德与白邬波罗花闭合的过失无分别而行。大圣圆满佛陀日轮亦复如是，即放射圣法光明，一时之中，所化智慧水莲开敷，非所化心识白邬波罗花闭合，而佛陀对此等利害无分别而行。
    壬二、无分别而利他分三：一、由无分别利他；二、由放射光明利他；三、由一时同现利他。
    癸一、由无分别利他：
    犹如日轮无分别，光明一时普照射，
    能令水花得增长，亦令他物得成熟。
    如是如来大日轮，放射圣法无量光，
    于诸所化众生莲，无有分别而照入。
    犹如日轮无分别的同时放射出无量光芒，令诸水莲开敷并得增长、其它庄稼圆满成熟。如是，善逝圆满如来日轮也一时放射无量圣法光明，增盛所化众生莲花的功德花瓣，且能成熟善根庄稼，于彼等无有分别任运自成而行。
    癸二、由放射光明利他：
    依靠法身及色身，菩提精藏虚空中，
    显现遍知大日轮，智慧光芒照群生。
    犹如由虚空界中显现的日轮光明能破世间黑暗，如是，在依靠圆满自利胜义法身与他利世俗色身二者现前的远离一切戏论之菩提精藏极净虚空中显现的遍知法王日轮，也无余对所化众生，由智慧放射种种圣法光明，遣除无明黑暗。
    癸三、由一时同现利他：
    由于所化清净故，于彼一切水器中，
    如来日轮之影像，无量一时皆显现。
    犹如净水盈满的诸水器中一时同现日轮影像，如是，由无量所化心相续中烦恼等垢极为清净故如净水盈满的水器般的彼等一切之中，如来色身如日轮影像般一时无量同现而作圆满他利。
    壬三、由机缘差异而次第显现分二：一、略说；二、广说。
    癸一、略说：
    恒时周遍于一切，法界虚空之中央，
    升起佛陀大日轮，应所化山次第照。
    恒时于一切有法无分别周遍的法界极为清净如同虚空之中央，彼中显现正等觉如来大日轮，随所化众生山峰次第照射。
    癸二、出广说：
    如具千光日初升，照亮一切世间已，
    高中低山次第照，佛日次第照众生。
    犹如具足广大千光的日轮在虚空界中升起，光明照射一切四洲世间后，依次初照高山，次照中山，后照低山。如是，具足广大智慧光明的如来一切种智日轮在法界虚空中央显现，也依次照射所化众生，即初照具殊胜缘分者，次照中品缘分者，最后照劣缘者，由此作成熟他相续的事业。
    壬四、超胜比喻之理分二：一、以光明超胜之理；二、以作用超胜之理。
    癸一、以光明超胜之理：
    一切国土虚空中，日轮不能普照射，
    无力破除无明暗，亦不能示所知境。
    大悲体性遍放射，种种彩色光明网，
    能为众生照明了，真实微妙所知境。
    较一般日轮，佛日更为殊胜，因为：日轮虽有限于某一区域能遍照光明的热力，但不能遍照一切，而佛陀具有无余刹土虚空中央照射智慧光明之力，并能周遍，故为超胜。如是，日轮仅有能破一般黑暗及能显明某些色法之力，却没有能破无明痴暗后显明所知实相义之力，然由大悲自性正等觉佛日中所放射的具有三乘等种种彩色的无量善说光明，善作破除无明黑暗后，显明智慧光明，由此具有对无量所化众生照明如所有、尽所有的所知实相甚深义之力，故具大义也能超胜。
    癸二、以作用超胜之理：
    佛陀进入聚落时，无目盲人重得目，
    远离无义诸恶法，见佛获利而觉受。
    无明瞎却溺有海，邪见暗覆诸有情，
    依于佛日光明照，慧光当见不见处。
    一般日轮虽现于世间，但无力使盲者见色以及遣除轮回痛苦、现见甚深法性等，而佛日照入所化聚落时，能使盲者见色、聋者闻声、狂者得正、贫家获宝，以及能使人远离以无所求义的恶趣等所致的诸忧恼后，见如来之有义，当即感受所欲的安乐。总之，为无明翳瞎却智慧眼而沉溺于不见痛苦边际的三有大海中并被种种邪见黑暗覆盖心性的无量有情，由佛日显现世间的事业光明，以智慧光明次第照明所知故，诸凡夫现量见到以前不知不见之处——法界甚深真如，故从作业的角度也成为殊胜。
    辛六、应以如意宝喻了知意之秘密分二：一、成就所欲故说相似；二、难得故说相似。
    壬一、成就所欲故说相似分二：一、无分别成就一切所求；二、无勤作恒时安住之理。
    癸一、无分别成就一切所求：
    犹如如意宝珠王，虽无一切诸分别，
    一时同处诸有情，亦随所愿皆能满。
    如是依佛如意宝，种种意乐诸有情，
    虽闻种种差别法，然佛于彼无分别。
    如同如意宝王，虽无对此人施此物的分别动机，但对同处安住并作祈祷的具不同意乐的诸有情所祈求的衣食粮药屋等，一时之中，无有错乱能随各自所愿使其满足。如是，依靠圆满佛陀如意宝王，三种种性等种种意乐的无量有情，虽闻到相应各自意乐的三乘等种种法，且能圆满作彼等利益，但佛为彼说法时毫无对此人说此法的分别心。
    癸二、无勤作恒时安住之理：
    如如意宝无分别，无勤赐予所求物，
    能仁无勤应众机，利他恒住三有中。
    犹如如意宝珠无分别的同时，对于诸祈祷者无勤能赐予所求财物。如是，诸能仁佛陀无有分别等勤作的同时，相应众生各自根机，为利他宣说法等，为成就所化一切利益，乃至三有轮回未空之间，相续不断恒时安住。
    壬二、难得故说相似：
    蕴藏深海地下住，于彼心虽有欲求，
    然彼善妙如意宝，薄福众生亦难获。
    如是劣缘诸有情，为诸烦恼所执持，
    当知于彼垢心前，极难亲睹诸善逝。
    譬如由于蕴藏深海之中且住于地下的缘故，诸求宝者虽寻求能满一切所愿的善妙如意宝，但薄福众生难以获得。如是，住于轮回的无量众生缘分极劣，且被种种根本烦恼及随烦恼所持的缘故，当知于彼等各自垢心前见善逝二身的显现极为难得。
    辛七、应以谷响喻了知语之秘密分二：一、比喻；二、意义。
    壬一、比喻：
    犹如一切谷响声，依于他缘而得起，
    无有分别无造作，不住外亦不住内。
    譬如山谷回响显现种种音声，仅是相应诸闻者各自所说从耳识中出生而显现，山谷无分别也无对此人说此语的造作或勤作，声音自体不住谷外，也不住谷内。
    壬二、意义：
    如是如来声亦然，依于他心而生起，
    无有分别无造作，不住外亦不住内。
    如是，显现诸佛种种圣法音也仅是由所化差别、相应闻者各自的意乐在心中生起而显现，佛虽无动机之分别，也无任何对此人说此语的造作或勤作，佛音自体不住身外，也不住身内。
    辛八、应以虚空喻了知身之秘密分二：一、比喻；二、意义。
    壬一、比喻：
    譬如无物无显现，无有所缘无所依，
    超过眼识之境界，无色不可示虚空，
    纵然于彼见高下，而彼虚空非如是。
    譬如毫无自体、于根识前无显现、无有所缘境、亦无所依处、若分别而言亦超越眼识境界、无有质碍色法、他人眼前不可指示——具有此等体相的无为法虚空，于彼中，人们虽见中部高、周边低、方圆、蓝黄等种种相，但胜义之中，彼虚空并非真实如种种显现那样。
    壬二、意义：
    如是于佛见一切，然而其义非如是。
    如是，具有各种种性的所化，虽然见圆满佛陀有入胎、诞生、涅槃、行住、种种身色、异类刹土等无量游舞相，但胜义如来并非真实如生灭等显现那样，因为如来无有迁变故。
    辛九、应以大地喻了知遍入之理分二：一、比喻；二、意义。
    壬一、比喻：
    譬如种种诸草木，依止大地得生起，
    大地无有分别心，亦令增固及成就。
    譬如种种草木花卉等依止大地而生起，但大地无有欲生彼等的分别念及勤作，也能令无者新增、前有者根本加固以及彼等展转增上广大成就，故能作众生的受用。
    壬二、意义：
    如是众生诸善根，依止佛地得生起，
    佛陀无有分别心，亦令增固及成就。
    如是，如大地般的胜者圆满佛陀虽无作此等利益的分别、勤作，也能令无量所化众生的二资善根庄稼一切无余增长、坚固以及广大成就，故能作一切众生的受用。
    庚三、宣说必要并归摄该处之义分二：一、宣说必要并以喻义分类；二、别说以比喻表示之理。
    辛一、宣说必要并以喻义分类分四：一、成就必要与必要之必要之理；二、归摄彼等喻义而说；三、所立等三义之对应；四、该处无勤作之理。
    壬一、成就必要与必要之必要之理：
    由于未见无勤作，而能成办事业故，
    为除所化之疑惑，宣说此等九譬喻。
    于彼修多罗教中，广说此等九譬喻，
    经名佛境智庄严，亦示此等之必要。
    由闻此等所生智，广大光明所庄严，
    具足智慧之菩萨，速入佛陀诸境界。
    因为凡夫心识境界中，何时也未曾见过毫无勤作而能任运成办之事，诸所化心中生起“佛事业若无勤作怎能任运成办众生利益”的疑惑，由此，为断所化之疑，以帝释影像等九喻极明显地开示无勤而作事业之理。彼亦，在彼修多罗教中，广说表示如来事业的此等九喻及其根据故而极为显示的经典，名为《度一切诸佛境界智严经》，依此经譬喻也善显了其必要及必要之必要义，即：由听闻此经及解释此经密意之本论而生的清净智慧大光明所庄严的具慧菩萨，速入成为诸佛境界事业一切无勤任运自成之相，最初是以了知方式趋入，最终也能以修行方式证入，如是直接断疑是必要，间接入佛境界是必要之必要。
    壬二、归摄彼等喻义而说：
    为示无勤事业义，已曾广说琉璃地，
    帝释影像等九喻，摄彼要义当了知，
    示现言说与周遍，幻化智慧放光芒，
    身口意之三秘密，获得大悲自性者。
    为表示无勤能作利他事业，上面已广说琉璃地所现影像等九种比喻，当知此处宣说彼等的摄要，即是：以帝释喻宣说相应所化示现种种身之变化，以天鼓妙音喻宣说随顺机缘语之圣法教诫，以云喻宣说意智悲周遍一切，以梵天喻宣说身语无量事业幻化相，以日轮喻宣说依智慧放射圣法光明，以摩尼宝喻宣说无有分别念赐予所欲的意秘密，以谷响喻宣说虽无文字而善巧宣说的语秘密，以虚空喻宣说虽无色法而所化能见的身秘密，以大地喻宣说一切功德成就之所依——转依大悲的自性，显示彼者能作一切众生的受用。
    壬三、所立等三义之对应：
    一切勤作相续灭，无有分别之智慧，
    犹如离垢琉璃上，映现帝释影像等。
    寂灭勤作是所立，无分别智是能立，
    为能成立自性义，喻为帝释影像等。
    正等觉诸如来为利他时，寂灭一切勤作的戏论相续而转入，以无一切分别的大悲自性之光明智慧已现前故，喻如人间已成无垢琉璃地中映现帝释影像等，此像无勤作亦能作业。对此，极为寂灭一切勤作戏论相续是所立，无分别智究竟现前是成就彼者的能立。如是虽无任何勤作而任运成就他利之自性者，为于所化心识前成立，能表之喻是以上所说的帝释影像、天鼓妙音等。
    壬四、该处无勤作之理：
    此处所表此义者，已说示现等九种，
    导师远离生与死，无有勤作任运转。
    在宣说如来事业的此处，以九喻表示的此义即是：上述身示现变化、语宣说教诫等九种义，显示了导师圆满诸佛是以远离生灭等有为法、无分别且无作此者彼者的勤作与加行而对所化成办事业的方式，任运转入。
    辛二、别说以比喻表示之理分二：一、宣说比喻之分类；二、宣说喻义对应。
    壬一、宣说比喻之分类：
    犹如帝释妙鼓云，梵天日轮如意宝，
    响空地般尽轮回，无勤利他瑜伽知。
    能表示如来事业任运相续不断的比喻是：如帝释于自处不动而影现于大地以此利益众人，如妙鼓无勤作而宣说四法印，如大云遍布虚空成熟诸庄稼，如梵天于色界不动而幻化示现欲界以此能利益诸欲天，如日轮无分别放射无量光芒而能遣除黑暗，如殊胜珍宝的如意宝王虽无分别而赐予一切所需，如虽无实有而显现种种山谷等的回声，如虽无色法而周遍一切的虚空，如虽无分别及勤作而能作一切所依的大地。乃至无边轮回未空之间相续不断且无勤任运的利他事业之相，唯有诸殊胜瑜伽士堪能了知，以平凡者不可思议。
    壬二、宣说喻义对应：
    现身如宝现帝释，善说教诫如天鼓，
    遍主智悲广大云，遍至有顶无边众，
    如梵不动无漏界，示现种种变化相，
    如日智慧放光明，意密如净摩尼宝，
    佛语无字犹如响，身遍非色恒如空，
    如地众生白法药，一切所依为佛地。
    正等觉诸佛利他事业者：
    犹如由琉璃宝所成的人间大地上映现出天主帝释的影像，如是法身不动中于有缘诸所化前示现无量的色身变化，即是身之显现。
    如是，为令心未入定者入定、已入定者解脱，语善说教诫与随示之相，犹如天鼓宣说四法印般。
    以意周遍一切所知自性的诸佛了知尽所有与如所有的智慧以及欲从轮回痛苦中救拔的大悲，犹如遍覆一切的云聚般，周遍乃至有顶间的无量所化众生而行。
    犹如梵天于色界不动而在欲界显现幻化般，于无漏法界处丝毫不动而相应各自的信解也示现种种不同的身语幻化。
    犹如日轮放射光芒般，依于智慧放射无量圣法光芒。
    犹如离垢清净的如意宝王般，具有虽无分别然能赐予一切所需的不可思议意秘密。
    胜者正等觉诸佛的语秘密，犹如山谷等的回响般，虽能听闻种种，然不成文字的自性。
    身秘密犹如虚空般周遍一切，虽现种种形色，然不成立色法的自性，且是恒常。
    犹如大地能作出生庄稼等的所依般，在无量所化众生的相续中，能增长、坚固以及广大成就一切白法草木庄稼的根本或所依，即是获得具有一切无余转依大悲的如来地。
    如是具有九种义。
    庚四、复归纳说差别分二：一、色身显现生灭而法身无生灭之理；二、相似故显现相同法然亦超胜彼者。
    辛一、色身显现生灭而法身无生灭之理分二：一、以帝释喻宣说无生灭；二、相似故以所有比喻宣说相续不断。
    壬一、以帝释喻宣说无生灭：
    犹如琉璃净心地，彼为现见佛陀因，
    即彼清净心地者，增长不夺之信根。
    由自善根生与灭，故佛色身现生灭，
    然如帝释天主身，法界之身无生灭。
    问：诸佛出有坏恒时无生无灭而又能见其生灭的根据如何呢？
    答：依靠积累善根犹如琉璃地般的自心无垢清净，即成为见正等觉佛身之因。或者，能清净自心的方便，是使以无信等违品不夺的信根等增长并坚固。彼亦，如由地有净与不净，影像也有显现与隐没，如是由诸所化信心等善根的生与灭，诸如来世俗色身也依次显现生与灭；又如帝释自身于三十三天处不动移，如是能仁一切种智自体于胜义法身无迁变故，无有生灭。
    壬二、相似故以所有比喻宣说相续不断。
    如是远离诸勤作，无生无灭法身中，
    乃至三有未空时，转入示现等事业。
    若又认为：诸佛无勤作而能事业相续不断，有何根据呢？
    答：犹如帝释等虽无勤作然显现影像等能作他利，如是，诸如来亦无分别等任何勤作，然于现前本来无生无灭的法身中不动的同时，乃至所化三有轮回未空之间，示现身之变化、语之宣说教诫及意之智悲周遍等事业任运自成，并且彼等都是相续不断而转入。
    辛二、相似故显现相同法然亦超胜彼者分二：一、略说；二、广说。
    壬一、略说：
    以此诸喻摄要义，及其前后之次第，
    前喻难表不同分，后喻就同分宣说。
    能表示如来事业的此等九喻之摄义是下文所说内容，不仅如此，须紧接前喻宣说后喻的次第决定的根据彼处也将宣说，这是因为前前比喻不能完全表示如来事业，诸不同分须依次以后后比喻排除不同分而就相同分作宣说的缘故。
    壬二、广说：
    诸佛如来如影像，非具音故非如彼，
    具妙音故如鼓音，非普利故非如彼，
    能普利故如大云，非断惑故非如彼，
    能除贪故如梵天，非竟熟故非如彼，
    能竟熟故如日轮，非常照故非如彼，
    能常照故如摩尼，非难得故非如彼，
    不可得故如谷响，依他缘故非如彼，
    不依缘故如虚空，非善依故非如彼，
    如是世间出世间，众生一切之圆满，
    乃为彼等所依处，是故犹如大地般，
    即依如来大菩提，出生出世间道故，
    亦成善法与诸禅，四无量及四空故。
    正等觉诸佛作利益的事业者：
    示现无量身的变化，犹如琉璃大地上映现帝释影像般，然彼帝释影像不具妙音，而如来具有说法妙音，故与彼不同并超胜于彼。
    如是从具有语言妙音方面，宣说种种语之教诫，犹如天鼓宣说四法印般，然天鼓仅是少分，彼不能周遍一切普作利益，而如来能周遍一切所化世间普作利益，故与彼不同并超胜于彼。
    如是从周遍一切世间界方面，以智悲能成熟诸所化相续，犹如大云周遍一切能成熟庄稼般，然云不能除无义种子，而如来能令他人遣除无义贪等烦恼种子，故与彼不同并超胜于彼。
    如是从遣除诸无义烦恼种子方面，显现无量幻化，犹如大梵天之幻化能遣除对五欲的贪心般，然梵天仅能作一次利益，不能究竟成熟，而如来相续不断能毕竟成熟所化相续，故与彼不同并超胜于彼。
    如是从能毕竟成熟所化庄稼方面，是放射智慧无量光明，犹如日轮光明能毕竟成熟庄稼般，然日轮仅是有时出现，不能昼夜恒时遣除黑暗，而如来恒时相续不断能破无明黑暗，故与彼不同并超胜于彼。
    如是从恒时破除黑暗方面，意之秘密放射无分别智光明，犹如如意宝的光明能恒时破除昼夜一切黑暗般，然如意宝、龙等旁生也具有，并非难得出生，而于诸无缘者如来极难出现，故与彼不同并超胜于彼。
    如是从难得方面，语之秘密显示种种善说，犹如谷响内外皆无实有故难得般，然谷响是依他缘而生起，而如来是自生无为法，非依他缘而生，故与彼不同并超胜于彼。
    如是从不依他缘出生的无为法方面，身之秘密示现种种幻化，犹如虚空显现种种且是无为法般，然虚空不是善根的根本或依处，而如来是一切白法的根本或依处，故与彼不同并超胜于彼。
    如是佛为世间与出世间有情一切圆满的无余所依或根本，故与大地能作一切万法的所依相同。亦即，佛为一切出世间圆满的根本，因为依于圆满诸如来获得大菩提出生出世间圆满三乘之道等诸圣法故，如是亦为一切世间圆满的根本，因为依于大菩提成就欲界圆满之因——十善业道、色界圆满之因——四禅四无量以及无色界圆满之因——四空定故。
    大乘无上续论辨三宝种性如来事业品第四终。
    大乘无上续论辨别三宝种性中如来事业品第四释竟。


大乘无上续论释·善说日光　校量功德品

    校量功德品第五

    丁三、于四金刚处生起信解之利益分二：一、以殊胜赞叹之方式宣说；二、以异门说彼。
    戊一、以殊胜赞叹之方式宣说分二：一、四金刚处难证之理；二、证悟彼者获益之理。
    己一、四金刚处难证之理：
    佛种性与佛菩提，佛陀法及佛事业，
    清净有情亦难思，此等唯是诸佛境。
    自性清净佛性具有客尘障垢的分位如来藏，彼上客尘障垢极为清净的分位获得佛陀大菩提，具有与大菩提无二的佛陀法十力等诸殊胜功德，由获诸功德之力成办佛陀任运相续不断的事业，此等即是相应成就三宝的四金刚处，对此，即使多分客尘障垢清净的有情住地大菩萨也不能真正如实思议，何况诸凡夫与声缘，如上所述不可思议故。那么，彼等是何者的境界呢？如上四种金刚处真正如实唯是一切众生导师圆满诸佛智慧的境界，然而于善逝具信解者，也可以信解作意的方式成为所证，此义上文也已宣说。
    己二、证悟彼者获益之理分二：一、超胜其余方便善根；二、能得殊胜智慧之根据。
    庚一、超胜其余方便善根分二：一、略说；二、广说。
    辛一、略说：
    具慧信解佛境界，成佛功德聚之器，
    于此不思德聚喜，映蔽一切有情福。
    诸具慧菩萨仅是胜解胜者圆满诸佛智慧境界义的四金刚处，彼等也将成为十力等如来无量功德聚之器，因为由苏醒大乘种性可速得究竟果故。如是，对此具有不可思议功德聚的四金刚处，诸平凡者生起欢喜而胜解的功德极多，故能映蔽未与彼相应的一切众生由布施等所积的一切福德聚。
    辛二、广说分三：一、超胜布施供养；二、亦超胜持戒；三、亦超胜修行。
    壬一、超胜布施供养：
    若人为求菩提果，珠宝严饰黄金刹，
    佛刹尘数日日中，供养一切诸法王，
    余人于此仅闻句，闻已生起胜解信，
    依此所生之福德，较前布施德更多。
    若有善男子善女人，所为是发起欲求无上大菩提的意乐，妙物是黄金所成的广大刹土以无量宝珠严饰而充满，无量是等同无量佛刹极微尘数的供物，时间是日日相续不断，殊胜对境是于一切法王出有坏恒时供养，以此虽增极多福德，但相比而言，若有余人，不必说证悟此甚深四种金刚处之义，即便是仅闻文句后,无颠倒以信任方式增胜信解，于此所获善根也超胜前面布施所生的广大福德。
    壬二、亦超胜持戒：
    若有具慧为求取，无上菩提经多劫，
    身口意业无勤作，能护无垢诸律仪，
    余人于此仅闻句，闻已生起胜解信，
    依此所生之福德，较前持戒德更多。
    若有具慧善男子善女人，所为是发起欲求无上大菩提的意乐，时间是历经无量多劫，体性是依身口意极为串习而成为不须加行勤作自然能护持无堕罪障垢、断尽一切恶行的戒律，以此虽增极多福德，但相比而言，若有具慧者不必说证悟此甚深四金刚处之义，即便是仅闻文句后，无颠倒以信任方式增胜信解，于此所获善根也超胜前面持戒所生的广大福德。
    壬三、亦超胜修行：
    若人修持能息灭，三有烦恼火静虑，
    修持天梵至究竟，菩提不动之方便，
    余人于此仅闻句，闻已生起胜解信，
    依此所生之福德，较前静虑德更多。
    若有善男子善女人，所断是于世间为了息灭如火聚般的欲界、色界、无色界三有烦恼，静虑自性是修持天住之四禅、梵住之四无量等至于圆满究竟，所得是于正等觉大菩提果不动的方便，以此虽增极多福德，但相比而言，若有具慧者，不必说证悟此甚深四金刚处之义，即便仅闻文句后,无颠倒以信任方式增胜信解，于此所获善根也超胜前面静虑所生的广大福德。
    庚二、能得殊胜智慧之根据：
    何故以施得受用，持戒升天定伏惑，
    慧断烦恼所知障，此胜闻彼为慧因。
    如是相比于施戒修所生的广大福德，听闻四金刚处所生的智慧更为殊胜，何故如是？因为以广大布施仅能成就受用圆满的异熟果，以持戒仅能获得善趣身，以修习静虑仅能压伏三界烦恼，而依靠证悟自性清净种性从客尘障垢中解脱以此将得无上菩提功德及事业的智慧，能够无余断除一切烦恼障、所知障及习气，善知实相真实义的此智慧能超胜布施等所生的福德资粮，而此殊胜智慧之因是无倒听闻彼等四金刚处故。
    戊二、以异门说彼分二：一、得究竟利益；二、得入道利益。
    己一、得究竟利益：
    自性住与彼转依，彼功德及成就义，
    如来智慧之境界，四处如上已宣说。
    于彼具慧信解有，力及具足诸功德，
    成就速疾能获得，善逝果位之缘分。
    如来藏从本以来遍住于一切的自性住种性，此法界远离客尘障垢无余转依的大菩提，于彼大菩提无二具有的十力等功德，依靠彼等功德成就他利的事业，即是成为胜尊一切种智境界殊胜义的四处，如上本论已说。对彼等，诸具慧菩萨如是依次对于一切有情周遍具有种性生起胜解信，对于以彼力能从客尘障垢中远离而获得大菩提生起欲乐信，对于获此大菩提具有二利究竟的功德生起清净信，亦即由具有三种清净增上信解，对菩提的清净修行将会极精进地转入，因此具有能速得究竟果善逝无上果的缘分。
    己二、得入道利益分二：一、发心生起无上菩提心之利益；二、加行趣入六度之利益。
    庚一、发心生起无上菩提心之利益：
    如此不可思议境，信有如我亦可得，
    得果具足诸功德，于此由信胜解故，
    欲勤正念及静虑，智慧等诸功德器，
    菩提心于此等中，定当恒时善安住。
    从成为凡夫不可思议境界的甚深四种金刚处，开出自性清净种性具有周遍一切众生，彼者遣除客尘障垢无余转依的大菩提如我也能获得，以及所获之果是具有如是十力等自他二利究竟圆满的功德，即由具此三种信心的方式生起增胜胜解故，于圣法之欲、于善法勇悍之精进、于教诫诸所缘不忘之正念、于所观一心专注之静虑、于诸法辨别之智慧等不可思议功德之器——为利有情欲求正等觉的菩提心者，将会在证悟四金刚处的诸菩萨相续中恒时安住。
    庚二、加行趣入六度之利益分四：一、圆满波罗蜜；二、彼等摄于三类福中；三、认定违品二障之体相；四、获殊胜对治之智慧。
    辛一、圆满波罗蜜：
    彼者恒住菩提心，故彼佛子不退转，
    圆满福德波罗蜜，以及诸善得清净。
    福德五种波罗蜜，于彼无有三轮执，
    是故彼等皆圆满，断除违品是清净。
    彼者以恒时安住上述菩提心故，诸佛子将于无上菩提中不退转，以如此殊胜发心的推动，加行以福德聚所摄的前五波罗蜜已能圆满并得清净。彼亦，能利益有情的方便布施等摄于福德聚的前五波罗蜜，于彼等无有能作、所作、作业的三轮分别故，彼等波罗蜜圆满，而善根清净者，则是由于断除布施等违品悭吝等五障的缘故。
    辛二、彼等摄于三类福中：
    施所生善是施福，戒所生善是戒福，
    忍定二种是修福，精进遍行于一切。
    施所生福是布施度，戒所生福是戒律度，忍辱、禅定二度是修类福，于彼等勇悍的精进遍行于三者，故归纳而言与上述三类福相同。
    辛三、认定违品二障之体相：
    三轮虚妄分别心，承许彼为所知障，
    悭等虚妄分别心，承许彼为烦恼障。
    承许于施者、受者、施等三轮的虚妄分别心是五波罗蜜圆满的障碍——所知障，承许悭吝、贪欲、嗔恚、懈怠、散乱等虚妄分别心是波罗蜜清净的障碍——烦恼障，故当断除彼等。
    辛四、获殊胜对治之智慧：
    若离智慧无余因，能断烦恼所知障，
    是故智慧最第一，慧依闻故闻最胜。
    若远离此善证真实义的智慧，则无有其余能彻底根除二障的因，因为以远离智慧的布施等虽能作一点压伏粗重障碍，但不能根除种子，而以智慧究竟能根除二障及其习气，故相比于以福德资粮所摄的前五波罗蜜，智慧度所摄的智慧最为殊胜。如是智慧增长之根本即是如理听闻宣说四金刚处之义的诸经论，故相比于施戒修三类福，听闻此甚深法的智慧最为殊胜。
    乙三、圆满作业分二：一、广说所讲之义；二、由讲解之方式摄义而宣说。
    丙一、广说所讲之义分三：一、如何造论之理；二、断损害正法之理；三、回向造论善根。
    丁一、如何造论之理分五：一、依何而说；二、为何而说；三、依如何宣讲之理而说；四、所讲经典之体相；五、恭敬顶受彼之等流。
    戊一、依何而说：
    如是依于正教理，
    上述七种金刚处不是以臆造或杜撰宣说，而是依靠《陀罗尼自在王经》《佛说如来藏经》《胜鬘经》《不增不减经》《度一切诸佛境界智严经》等主要宣说了义故可信赖的清净教典，以及暂时“因之作用理”“果之观待理”“证成理”与究竟“甚深法性理”而作宣说。
    戊二、为何而说：
    为令自心纯一净，具信善圆之智者，
    亦为摄彼宣说此。
    从自利角度而言，作者自己为了获得纯一法界所断微细障垢也极为清净的究竟涅槃；从他利角度而言，为了以善说喜筵摄受彼等具有殊胜缘分的所化——对极殊胜此义具有不可夺信解而自知能获超胜三类福之圆满善根的智者，总之以此二因宣说此论。
    戊三、依如何宣讲之理而说：
    依灯电宝日月光，具眼能见众色法，
    如是依佛义词法，乐说光明说此法。
    犹如依靠灯光、电光、摩尼光及日月光，诸具眼根者能见所境色法，如是，依靠能仁正等觉佛陀了知诸法自相共相之义的广大无碍解、无碍了知一切异名的法无碍解、无碍了知一切众生语言的词无碍解以及无碍了知一切诸法分类的辨无碍解此四种无碍解的光明，并以智慧眼照见甚深真如后，弥勒我宣说了此论。
    戊四、所讲经典之体相：
    何者具义相应法，能断三界烦恼语，
    显示寂静之利益，即是佛说余翻此。
    何等圣法所诠真实具有深广大义，能诠无垢词语与法相应并成为能断三界一切烦恼的语言，显示对治寂静涅槃究竟的功德并能获得，彼等即是大仙正等觉佛陀的真实善说，故是所应抉择。与此四义相反的余者则是真实善说范畴之外的颠倒邪说，故非所应趋入。
    戊五、恭敬顶受彼之等流：
    何者唯依佛教法，无散乱心而宣说，
    与得解脱道相应，亦如佛经当顶受。
    善显佛经密意的论典，无论何者，所讲差别是唯以胜者正等觉佛陀的教法之义为所诠义，并非自己臆造，造论者差别是善达法义且无希求利养等散乱心而善说的士夫，果差别是为了获得解脱无上的涅槃果，方便差别是与能得彼果之道相应。若是具有此四种功德之论，也应如大仙正等觉佛陀的经典般，以信心顶戴受持。
    丁二、断损害正法之理分三：一、认定清净之方便而教诫依止；二、认定毁坏之因而教诫断除；三、断甚深法失坏之果。
    戊一、认定清净之方便而教诫依止分二：一、断自臆造；二、断偏袒执。
    己一、断自臆造：
    何故较佛善巧者，于此世间一亦无，
    无余真如殊胜者，如理遍知知非他，
    是故大仙自安立，如是契经勿错乱，
    若坏能仁圣教规，故彼亦损圣教法。
    何故在世间界中，较胜者正等觉佛陀更善巧者一个也没有呢？因为一切所知相之尽所有法与殊胜真如之如所有法，除佛陀能如理无颠倒以遍智照见之外，余者不能了知，是故对于大仙佛陀自己安立种种了义及不了义相的如是诸经，切勿以自已臆测而将不了义说为了义或了义说为不了义，若错乱将会毁坏佛陀圣教之规故，彼也将损坏圣法，并造下舍弃正法的极大罪过。
    己二、断偏袒执：
    烦恼愚痴诸恶人，毁谤圣者并轻蔑，
    彼所说法彼皆以，妄计邪见而造作，
    是故具执邪见垢，智者与彼勿相合，
    犹如净衣可染色，垢腻染色非如是。
    以无明烦恼等令心愚昧的恶劣众生毁谤佛陀等圣者、轻蔑彼等善说之圣法等的彼等过失，都是以自己妄计恶劣宗派的邪见而造作，由此也成为被种种痛苦逼迫的苦恼众生，是故，诸具慧者何时也不应相合具有妄执的恶劣宗派的邪见垢染，若与彼相合，则有自心不能与正见正行融合的过失，犹如净衣由无垢清净可以染料染色，然以油渍具有垢腻者非能如是。
    戊二、认定毁坏之因而教诫断除：
    慧劣远离白法信，倒慢往昔谤法障，
    执不了义为了义，贪著利养恶见制，
    亲近毁谤正法者，远离受持正法士，
    信解劣故将舍弃，出有坏之诸圣法。
    如是大乘法的究竟了义如来藏极为殊胜并具极大利益。若想：对此为何有人不生信解反而舍弃呢？这正显示过失在人而不在法。彼亦，有些由辨别甚深义的观慧微劣而智慧极劣故，将会舍弃圣法，如是对应：有些由未苏醒增上种性而远离对白法的信解故，有些依于将所具非功德妄执为功德的颠倒傲慢故，有些依于宿世造集匮乏圣法的极大罪障，此是于真实义障碍之自性故，有些将不了义教法执为诸法无颠倒真如的了义法故，有些由于对衣食资财等五欲利养有巨大贪著而被缠缚故，有些被极为执著坏聚见等恶见制伏故，有些恒时亲近毁谤并舍弃一切深广圣法的恶友并受其控制故，有些远离护持大乘圣法并具殊胜相的诸善知识故，有些由不信任真实之法与真实之人，并喜颠倒之法，信解下劣故，舍弃诸善逝出有坏圣法，尤将舍弃宣说甚深真如的诸法。虽然此等仅是毁坏自己之因，但诸智者切莫如此行之。
    戊三、断甚深法失坏之果分二：一、断恶趣之理；二、断轮回之理。
    己一、断除失坏恶趣之理：
    如畏毁谤甚深法，如是智者于猛火，
    毒蛇仇怨及霹雳，不应极生畏惧心。
    火蛇怨敌金刚火，彼等仅能断命根，
    不能令人深陷堕，极为可怖阿鼻狱。
    其义如何？对于毁谤、舍弃极殊胜圣法的怖畏，善巧取舍的诸圣者对于世间所谓的可怖之处——猛火焚烧、毒蛇噬咬、仇怨杀害、霹雳击穿等，尚不应极生如是怖畏之心，相比之下，诽谤圣法更为可怖，故当断除。何以故？因为以猛火焚烧、毒蛇噬咬、仇怨杀害、霹雳击穿等仅能断绝今生命根，不能令人堕入极可怖的无间地狱，而由舍弃圣法，决定将会感受无间地狱的痛苦故。
    己二、断轮回之理：
    若由数近恶人故，具有恶心出佛血，
    杀父杀母杀罗汉，破坏最胜和合僧，
    若能思惟修法性，此人速疾从此脱，
    若人恶心谤圣法，此人焉能有解脱。
    若有恶人，由长时数数亲近恶友并被摄持故，对于殊胜无上皈依处的正等觉佛陀也有杀害恶心而出佛身之血，对于世间别别决定的士夫——具有大恩的上师、父母也行弑杀，对于众生普皆恭敬的不应杀者——阿罗汉也作杀害，对最胜和合僧也作破坏，此等恶人，如果决定思惟并一心专注而修持诸法真如具有殊胜甚深一切相的空性以及无缘大悲，也速疾从五无间等极深重的业障中解脱后获得无上菩提。然而，若有人以恶心嗔恨并舍弃大乘究竟精华了义法门，此人焉能获得无上解脱的菩提？！因为无有修解脱道的缘分故。
    丁三、回向造论善根：
    三宝以及净种性，无垢菩提功德业，
    此七义处如理说，由此我获诸善根，
    以此普愿诸有情，面见无量光寿佛，
    见已生起净法眼，得证殊胜菩提果。
    所获果佛法僧三宝之义，成就彼等之因的自性清净种性如来藏之义，彼无客尘障垢而极为清净之位的大菩提之义，彼菩提所具以离系、异熟果所摄的功德之义，以彼功德力极善成就他利的事业之义，对于此等所诠义七金刚处的无颠倒相，由如理善说故，宣说者我获得诸多清净善根，以此善根普愿轮回中沉溺的一切众生速疾获得暂时果——生于佛陀眷属坛城中，面见光明、寿量、智慧悉皆无量的大仙正等觉佛陀，见佛之后，从彼佛闻法、修行而获得见道等清净眼，并生起不畏深法的清净忍，最终得证究竟果——无上正等觉殊胜大菩提。
    丙二、由讲解之方式摄义而宣说：
    依于何因何必要，如何宣说何者义，
    于彼等流何者说，以四偈颂已显示。
    四偈自净之方便，二偈损坏圣法因，
    其次依于四偈颂，即为显示诸果报。
    由说入佛眷属中，获得法忍菩提法，
    总之二种果法依，末后二偈作显示。
    “依于何义而说”者，由“如是依于正教理”一句显示；“以何种根据或必要宣说”者，由“欲令自心纯一净，具信善圆之智者，亦为摄彼宣说此”三句显示；“以何种方式宣说”者，由“依灯电宝日月光”等一偈显示；“何者是所讲义之本体”，由“何者具义相应法”等一偈显示；“于彼等流能诠是何者”，由“何者唯依佛教法”等一偈显示。如是，如何造论之理，由“如是”等四偈已广作显示。
    此后，由“何故较佛善巧者”等四偈，显示能令自己清净的方便——谨慎舍弃圣法的罪障。
    其次，由“慧劣远离白法信”等二偈，显示积集舍弃圣法罪业是毁坏自己之因，故教诫断除。
    再次，由“如畏毁谤甚深法”等四偈，真实显示断除舍弃甚深法的两种果报——暂时堕入恶趣、究竟不得解脱。
    最后，以宣说（此论善根），回向暂时生于净土佛陀眷属坛城之中，现量证悟法性，并获得对甚深法的无畏法忍，究竟获得无上大菩提果，归纳即是，诸趋入圣法者成就暂时与究竟的二利圆满果，是由“三宝以及净种性”等末后二偈显示。
    大乘无上续论辨三宝种性中校量功德品第五终。
    大乘无上续论辨别三宝种性中校量功德品第五释竟。
    大乘无上续论怙主弥勒撰著圆满。

    如是对佛陀大补处具德弥勒怙主所造大乘无上续论，相应大阿阇梨圣者无著的注疏圆满释竟。

    甲四、善巧翻译此论：

    吉祥无比城之大智者婆罗门宝珠金刚叔伯班智达萨迦那与释迦比丘具慧译师共译于无比大城。
    未证邪证及怀疑，一切冥暗能根断，
    即此善说日光明，愿此善根除众暗。
    于持三藏之巴丹宗哲、彭措巴二位祈请者前，佛教无偏袒行者依四依撰著于觉囊吉祥神山，愿成就广大弘法利生事业。茫嘎郞！（愿吉祥！）

    二○○四年藏历一月三十日
    译于圣地色达喇荣五明佛学院

    附　录
    四种庄严：《陀罗尼自在王经》云：“菩萨有四璎珞庄严：一者戒璎珞庄严，二者三昧璎珞庄严，三者智慧璎珞庄严，四者陀罗尼璎珞庄严。”
    八种光明：《陀罗尼自在王经》云：“菩萨摩诃萨有八光明，以是八明能坏诸暗净菩萨行。何等为八？一者念光，二者意光，三者行光，四者法光，五者智光，六者实光，七者神通光，八者无碍智光。”
    十六种大悲：《陀罗尼自在王经》云：“菩萨摩诃萨修集大悲有十六事。何等十六？一者菩萨摩诃萨见诸众生贪著我见，以我见故增长诸见，常为生死之所系缚，是故菩萨为此众生修大悲心，悲因缘故宣说法化，为坏众生如是妄见。二者见诸众生心怀颠倒，常见无常无常见常，苦见於乐乐见於苦，净见不净不净见净，我见无我无我见我，是故菩萨为此众生修集悲心悲因缘故宣说法要，为坏众生如是四倒。三者见诸众生心怀憍慢，实无有物而生物想，实无有事而生事想，以是因缘起七种慢，以是慢故增长恶法，是故菩萨於此众生修集悲心，悲因缘故宣说法要，破坏众生如是憍慢。四者见诸众生五盖所覆，以覆盖故，心多生疑不解深义，是故菩萨於此众生修集悲心，悲因缘故宣说法要，为坏众生如是五盖。五者见诸众生沉六入海，眼取色相，耳取声相，鼻取香相，舌取味相，身取触相，意取法相，是名为沉，是故菩萨於此众生修集悲心，悲因缘故宣说正法，为拔众生如是沉没。六者见诸众生有七种慢：一者慢，二者大慢，三者慢慢，四者我慢，五者增上慢，六者下慢，七者邪慢。菩萨摩诃萨，於下慢者，自言胜汝；於慢慢者，自言最胜我色胜乃至识胜；於增上慢者，菩萨语言，汝实非圣，不应便起圣人之想；为邪慢者，宣说正见。是故菩萨於此众生修集悲心，悲因缘故宣说正法，为断众生如是憍慢。七者见诸众生离於圣道，乐行世道恶道，是故菩萨於此众生修集悲心，悲因缘故宣说正法，为断众生世道恶道。八者见诸众生造恶道行，属无明爱妻息所系不得自在，是故菩萨於此众生修集悲心，悲因缘故宣说正法，为断众生如是系缚，出离恶道。九者见诸众生亲近恶友远离善友，其心甘乐造作恶业，是故菩萨於此众生修集悲心，悲因缘故宣说正法，为断众生如是恶业，远离恶友亲近善友。十者见诸众生造作悭贪，於无明爱心无厌足为施智慧，是故菩萨於此众生修集悲心，悲因缘故宣说正法，为断众生如是悭贪无明及爱，施与智慧。十一者见诸众生我见断见，为施众生十二因缘真智慧故，菩萨於此而生悲心，悲因缘故宣说正法，为断众生我见断见，施与十二因缘智故。十二者见诸众生行无明暗，我见众生见命见士夫见，别异见邪见著见，菩萨为施智光明故，於此众生而生悲心，悲因缘故宣说正法，为断众生如是所见。十三者见诸众生乐於生死，於五聚阴而生亲想，是故菩萨於此众生修集悲心，悲因缘故宣说正法，为断众生如是三有。十四者见诸众生为魔所缚，是故菩萨於此众生修集悲心，悲因缘故宣说正法，为坏众生如是魔网。十五者见诸众生甘乐快乐，而不能知真实乐因，是故菩萨於此众生修集悲心，悲因缘故宣说正法，示诸众生真实乐因。十六者见诸众生求涅槃门不能知处，是故菩萨於此众生修集悲心，悲因缘故宣说正法，为此众生开涅槃门。善男子。菩萨修悲。悉因如是十六因缘。”
    三十二种事业：《陀罗尼自在王经》云：“何等三十二？一者众生不请而往亲附；二者见他福德不生妒心；三者至心修集无量善根；四者营他事业不生愁恼；五者至心不浊身口业净；六者不为利养改四威仪；七者如说而住；八者於诸众生其心清净；九者终不放舍菩提之心；十者清净庄严檀波罗蜜；十一者清净尸波罗蜜，怜愍毁禁故；十二者净忍波罗蜜，不惜身命故；十三者净精进波罗蜜，得十力无畏故；十四者净禅波罗蜜，远离烦恼故；十五者净般若波罗蜜，除烦恼习故；十六者修勇健定，坏诸魔业故；十七者至心度脱诸众生故；十八者修四摄故；十九者心平等故；二十者不舍一切诸众生故；二十一者知恩报故；二十二者护持正法故；二十三者修助道法不休息故；二十四者於诸善法无厌足故；二十五者破憍慢故；二十六者供养三宝故；二十七者於一切法不生诤故；二十八者善解十二深因缘故；二十九者具七财故；三十者於一切法得自在故；三十一者修六神通故；三十二者修集定慧故。”
    1 简称《陀罗尼自在王经》。
    2 四种庄严、八种光明、十六种大悲、三十二种事业的内容见书末附录。
    3 清凉：即寂灭。
    4 荣敦巴大师说，此颂不属本论，是无著菩萨注释中的偈颂。
    5 远近众生：远者指凡夫、声闻等障重众生；近者指地上大菩萨。
    6 “广般若”指《般若十万颂》，“中”指《般若二万五千颂》，“略”指《般若一万八千颂》，“极略”指《般若摄颂》。
    7 二种自觉：指佛与独觉阿罗汉。
    8 坛城：即众会中。
    9 六随念：集异门论十六卷一页云：“六随念者：云何为六？答：一、佛随念；二、法随念；三、僧随念；四、戒随念；五、舍随念；六、天随念。
    10 腨（shuàn）腿肚子。
    11 金刚火：即霹雳。