大通方廣懺悔滅罪莊嚴成佛經
又名《大通方廣經》
藏文經題《聖大解脫經》
藏文經題《大方廣懺悔滅罪成佛莊嚴大乘經》

大通方廣懺悔滅罪莊嚴成佛經卷上

    敬禮一切佛及菩薩。
    如是我聞。一時佛在王舍大城。與大比丘八萬人俱。諸菩薩三萬六千人[一]。於一生中。遠離一切蓋障。具足威德自在[二]。於如來前。勸請宣説。方便密意[三]。能使佛地。悉皆清淨。如來事業。任運成就[四]。以諸佛威德而爲建立[五]。爲守護法器故[六]。受持大乘。能[七]師子吼。震大法雷。名聞十方。其德高大[八]。如須彌山。智慧深廣。猶諸大海[九]。降伏衆魔。攝諸外道。使令清淨[一○]。具足諸力。無礙解脫。安住不動[一一]。念定總持[一二]。樂説辯才[一三]。四等六度[一四]。無量方便。一切法義。無不具足。隨順衆生。轉不退輪。示有無智[一五]。善解法相。現入三界[一六]。五眼所見。知衆生根。威德無量[一七]。蓋[一八]諸大眾。禪定智慧。以[一九]修其心。相好嚴身。眾相第一[二○]。心如虛空。捨諸世間所有色好[二一]。達諸法性。無礙智慧。善知眾生。往來所趣。具諸三昧。近無等等[二二]。久種善根[二三]。得佛自在智慧。具足十力。四無所畏。十八不共法[二四]。通達善趣門。關閉諸惡道[二五]。等視眾生。如視一子。而生五道。示現其身。欲[二六]度眾生。作大醫王。處於生死。善療眾病。應病與藥。令得服行。永離生死。其有聞者。無不解脫。具足如是無量功德[二七]。昔[二八]曾供養過去無量諸佛。明見佛性。知如來常[二九]。常說眾生等。盡有佛性[三○]。
    其名曰文殊師利菩薩摩訶薩。定光菩薩摩訶薩。龍樹菩薩摩訶薩。觀世音菩薩摩訶薩。大勢至菩薩摩訶薩。藥王菩薩摩訶薩。藥上菩薩摩訶薩。普賢菩薩摩訶薩。法自在王菩薩摩訶薩。師子吼菩薩摩訶薩。陀羅尼菩薩摩訶薩。寶藏菩薩摩訶薩。常精進菩薩摩訶薩。不休息菩薩摩訶薩。信相菩薩摩訶薩。無勝菩薩摩訶薩。彌勒菩薩摩訶薩[三一]。如是等菩薩摩訶薩三萬六千人。復有八十萬億威力諸天。及諸比丘。比丘尼。優婆塞。優婆夷。天龍夜叉。人非人等。釋提桓[三二]因與無量天人。在於空中。雨寶天華。無量音樂。自然而作。梵摩三鉢天[三三]。燒妙天香。供養如來。香煙遍至十方無量世界。願皆普同供養十方一切諸佛。供養十方一切諸法。供養十方一切諸大菩薩。是諸天等。為利如是。供養諸佛。為求大乘。無上之道。
    爾時世尊。與如是等無量無邊大眾。前後圍遶。發向娑羅[三四]。二月十五日[三五]。臨欲涅槃時。以佛神力。大悲普覆。欲攝眾生。出大音聲。其聲徧滿。乃至十方。隨其類音。普告眾生。今日如來應正遍知。憐愍眾生。覆護眾生。攝受眾生。等視眾生。如是一子。無歸依者。為作歸依。未見佛性者。令見佛性。未離煩惱者。令離煩惱。無安隱[三六]者。為作安隱。未解脫者。為作解脫。未安樂[三七]者。令得安樂。未離疑惑者。令離疑惑。未懺悔者。令得懺悔。未涅槃者。令得涅槃。爾時道邊[三八]。清淨平正。吉祥福地。縱廣正等。十千由旬。佛見此地。平正清淨。即便止住。告諸比丘。今於是中。可以說法。爾時。阿難比丘白佛言。世尊。如來世尊[三九]昔常性好山林。清淨流水。華果園林。今於是中。亦無流水。亦無林樹。亦無聚落國土人民。今日如來。安居說法。遠來者眾。饑勞疲乏。性命不濟。有食有命。有命有身。有身有道。無食無命。無命無身。無身無道。今於是中。無有如是可意之事。云何世尊。於中說法。爾時大智舍利弗。以佛智力。告阿難言。先應為法。不須餘念。如來世尊。不但十力。四無所畏。如來世尊。有如是無量力。一切無所畏。智慧無量。威神無量。無歸依者。為作歸依。未見佛性者。令見佛性。未離煩惱者。令離煩惱。未安隱者。為作安隱。未解脫者。令得解脫。未安樂者。令得安樂。未涅槃者。令得涅槃。如來世尊。有如是等無量神力。何懮如來。而無自然。我念往昔。維摩[四○]大士。為眾說法。他方菩薩。聲聞緣覺。威力諸天。龍神大眾。集在方室。未曾有食。我時念言。此諸大眾。云何得食。大士維摩。即語我言。聲聞少智。應念正法。云何先觀。邪[四一]命衣食。及以床坐[四二]。維摩大士。說是語時。天人得道。我懷慚愧。汝今所念。亦復如是。
    爾時如來。即告阿難。實如大智舍利弗語。應念大乘。莫念安身。作是語已。即入三昧。以威神力。即時其地。有一金華。從地涌出。其華出高。四十萬由旬。遍覆三千大千世界。琉璃羅網。彌覆金華。其金華下。有眾寶浴池。與華平等。名為八功德。香水彌滿[四三]。其池四岸有種種名華。所謂優鉢羅華。拘物頭華[四四]。波頭摩華。分陀利華。有如是等。種種無量名華。莊嚴寶池。若見如是金華寶池。得法眼淨。何況入中。而得洗浴。若入洗浴。即得清淨無生法忍。其金華下。有寶師子座。其師子座。高百由旬。爾時如來。坐於寶座。身諸毛孔。上下枝節。放大光明。如來金光明。與金華同色。從華四面。金光流出。普照十方一切佛土。佛光金華。所照之處。山谷國土。高下平正。皆作金色。無有穢惡。地獄休息。餓鬼解脫。除一闡提[四五]。謗方等經。以佛神力。他方國土。及此國中。悉皆一等。無有殊異。十方諸佛。觀此光已。異口同音。俱歎釋迦。善哉善哉。大慈世尊。今放光明。異於常明。昔日放光。先照東方。今日放光。四面一時。普照十方。當知此光。欲度苦惱一切眾生。使出三界。到大涅槃。爾時。他方十方諸佛。異口同音。告其侍者。大菩薩眾。諸善男子。汝等當知。今日中國娑婆世界。釋迦牟尼如來。放大光明。必說妙法。度苦眾生。汝等今者。應往彼土。供養彼佛。請決所疑。聽受經法。彼土眾生。昔來剛惡。虛偽不實。不信一乘。釋迦大慈。萬善方便。為開三乘。度脫三有。雖說三乘。上語亦善。中語亦善。下語亦善。義味甚深[四六]。純備具足。彼佛世尊。百千萬劫。不可值見。所說經法。不可得聞。彼諸大眾。不可時會。釋迦所生。殊妙金華。不可得見。是故汝等。今往彼土。得見彼佛。請問所疑。自得利益。複利眾生。作是語已。十方佛土。一一各有。十億菩薩。即從座起。為佛作禮。俱同發來。一一菩薩。各有百千音樂。雨寶妙華。來到佛所。到佛所已。遶佛七匝。為佛作禮。卻坐一面。俱共發聲。異口同音。而白佛言。世尊。我等今者。欲有所問。唯願世尊。當為說之。利益眾生。爾時。佛告諸來菩薩摩訶薩眾。諸善男子。若有所疑。今悉可問。吾當為汝。決定說之。
    爾時。諸來菩薩白佛言。世尊。我土如來。唯說一乘。云何如來。今說三乘。
    爾時世尊。以無礙智。告諸菩薩[四七]。汝等今者。為利眾生。諮問是意。諦聽諦聽。諸善男子。譬如有人。一人三名。小時名小。二十名中年。過八十名為老者。我今三乘。亦復如是。為初小心聲聞之人。說於小乘。為於中心緣覺之人。說於中乘。為大菩薩大道心人。說於大乘。諸善男子[四八]。汝今復聽。理無二邊[四九]。趣必同歸。解雖殊律。終為一觀[五○]。理是一乘。分之為三。聲聞緣覺乘。皆入大乘。大乘者。即是佛乘。是故三乘。即是一乘。
    說是法時。會中十千菩薩得無生法忍。八百比丘得阿羅漢果。二萬天人得法眼淨。百千萬人即發阿耨多羅三藐三菩提心。
    爾時。十方諸來菩薩。俱共合掌。而白佛言。我等今者。以彼佛力。來到此土。得見世尊。復聞大乘。願聽我等。受持是經。於佛滅後。在此國土。及餘他方。山林樹下。神仙居處。城邑聚落。曠野塚間[五一]。樹下露地。塔寺僧坊。講法眾會。俗人住處。家家人人。廣宣流佈。常使不絕。何以故。是經之住。令得惡道永息。所以爾者。曾聞佛說。地獄不閑。若誦是經一句[五二]。諸天歡喜。常來親近。自然修善。若人聞是方廣經典。歡喜信敬。書寫讀誦。受持禮拜。稱是經中。一佛一菩薩名者。是人現世安隱。不見諸惡。若其命終。我等菩薩。前導是人。迴向我國。共生一處。何以故。受持是經故。受持是經者。即持佛身。持佛身者。當知是人。即是菩薩。是故是人。即我同學。以是因緣。受持是經。願生一處。不相捨離。
    爾時。復有諸鬼神王。大梵天王。三十三天。護世四天王。金剛密跡。諸鬼神王。散脂大將。那羅龍王等。難陀龍王。婆難陀龍王。阿修羅王。迦樓羅王。大辨天王。鬼[五三]子母天王。諸山鬼神神王。樹神王。河神王。海神王。地神王。水神王。火神王。風神王。如是無量無邊諸神王等。及大諸天。即從座起。頭面禮[五四]足。合掌恭敬。而白佛言。世尊。我等今者。常當護持。世尊所說。方廣經典。有是經處。我等神王。常在於前。為作清淨。若在塔中。若在坊中。若在白衣舍。若在空處[五五]。或復有人。以不淨手。抃[五六]捉是經。或不恭敬。讀誦是經。我使是人。行住坐臥。身心不安。處處怖畏。橫罹[五七]惡事。現身不安。死入地獄。若人恭敬清淨。捉持此經。洗浴燒香。讀誦受持。或復書寫。憶念不忘。憶是經典。不行惡事。若能如是。我等神王。為是經故。守護是人。是人若臥。立其人前。不使見惡。亦復不為。惡人惡鬼。橫害其人。若其住處。護其宅舍。若欲行來。我等神王。於其人前。為作開導。須者給與。四方行來。無所障礙。常見善事。命終生天。因是值佛。不失大乘。
    爾時世尊。告諸大菩薩鬼神王等。如是如是。如汝所說。如是經典。不可得聞。何況可見。若欲受持。讀誦是經。當淨洗浴。著淨衣服。淨掃[五八]坊舍。以懸繒幡蓋。莊嚴室內。燒種種妙香。旃檀香。末香。種種涂香。禮拜。如是六時。從初一日。乃至七日。日日中間。讀誦是經。正心正憶。正念正觀。正思惟。正思議。正受持。正用行。正教化。日夜六時。禮拜是經中。諸佛菩薩。十二部經。若能如是。禮拜讀誦。信敬之者。如是經中。所說重罪。悉皆除滅。無有疑也。何以故。是大方廣經典。十方諸佛。之所修行。之所護持。諸佛之母。諸經之王。妙義之藏。菩薩之道。今是大乘方廣深妙經典。亦如世間所有六大不可思議。何等為六。一者大地。二者大水。三者大火。四者大風。五者大日。六者大空。是經亦如大地。普載一切淨穢好惡。是經亦如大水。洗除一切穢惡不淨惡物。是經亦如大火。普燒一切煩惱穢惡不淨惡物。是經亦如大風。普吹一切不淨穢惡。是經亦如大日。普照一切所有黑暗。是經亦如大空。悉能容受所有好惡。今是大乘方廣經典。廣大無對。上至菩薩。中至聲聞。下至有形。悉能容忍。是故汝等。受持是經。流佈是經。信敬是經。常使汝等諸大菩薩。入佛智慧。明見佛性。當令汝等諸天神王。及受持經者。常得見我。及見未來一切諸佛。轉大法輪。坐於道場。
    爾時大眾中。有一菩薩。名曰信相。於大眾中。即從座起。正理衣儀。頂禮佛足。而白佛言。世尊。我等今者。欲有所問。唯願世尊。當為說之。世尊所說。能大利益。無量眾生。
    爾時。佛告信相菩薩。善哉善哉。善男子。若有所問。隨意問之。吾當為汝。分別解說。汝所問者。亦大利益。無量眾生。
    信相菩薩白佛言。世尊。我念往昔。久遠過去。無量世時。有佛世尊。名曰寶勝。一聞名者。皆得生天。於後不久。天自在光王國內。曠野澤中。有一大池。其水枯涸。於彼池中。有十千大魚。為日所曝。欲入死門。有一大士。名曰流水。見是大魚。心生慈悲。施水飲食。少日得活。知命不久。即為三稱。寶勝佛名。是魚聞已。即便命終。生忉[五九]利天。以是因緣。今願世尊。為是大眾。及未來眾生。說諸佛名。及聞世尊釋迦名號。亦得無量無邊利益。無邊功德。常處富樂。見了佛性。以是因緣[六○]。故求此願。唯願說之。度脫重禁迷惑眾生。
    爾時。佛告信相菩薩摩訶薩。善男子。我若廣說十方諸佛所有名號。百千萬劫。說不能盡。一切諸水。可知渧數。無有能知。諸佛名字。諸須彌山。可知斤兩。無有能知。諸佛名字。一切大地。可知塵數。無有能知。諸佛名字。虛空世界。可知盡邊。無有能知。諸佛名字。吾今為汝。略說三世。諸佛名字。若人聞者。一逕於耳。其人命終。亦得生天。聞已信敬。復能盡形書寫。稱名禮拜。得滅無量。生死重罪。得福無量。其人命終。十方世界。隨意往生。亦得見我。及見未來。賢劫諸佛。
    爾時世尊。告諸大眾。汝等應當。正理衣服。正心正身。正憶正念正觀。欲聞法者。一心當敬禮須彌燈王佛。敬禮寶王佛。敬禮寶勝佛。敬禮阿彌陀佛。敬禮毘婆屍佛。敬禮多寶佛。敬禮釋迦牟尼佛。敬禮攝持一切法。敬禮過稱量。敬禮無譬類[六一]。敬禮無邊法。敬禮難思議。敬禮住力力中力。敬禮十力無所畏。敬禮三界尊。敬禮一切大導師。敬禮能斷眾結縛。敬禮已到於彼岸。敬禮已度諸世間。敬禮永離生死道。敬禮三昧得解脫。敬禮如空無所依。敬禮眾中大法王。敬禮破壞四魔眾。敬禮一子大慈父。唯願世世值諸佛。明見佛性。到大涅槃。何以故。一切有形。皆有佛性。是諸大眾。十指合掌[六二]。一心諦聽。一心供養
    聽我說三世　　十方諸佛名　　乃至五無間
    當生解脫相　　若人無善根　　我亦為說之
    彼自不能解　　燋種自然去　　唯有真實在
    除去小乘相　　唯有大乘在　　除去二乘者
    唯有一乘在　　若人無善根　　不得聞是音
    曾供無量佛　　今得聞佛名　　當知受持者
    少分解脫人　　安住清淨地　　今於我法中
    經行作佛事　　受持及讀誦　　禮拜是佛名
    去離眾魔事　　除滅四重禁　　無間一闡提
    是人未來世　　必得成佛道　　若人不生信
    定墮三惡道　　生信勤禮拜　　當見無量佛
    應當一心禮　　願除無量罪　　是故今敬禮[六三]
    是諸大眾。合掌諦聽。攝持身心。勿得動轉。五體投地。一心諦聽。
    爾時世尊。稱名唱曰。南無過去無量諸佛。南無二萬日月燈明佛。南無三萬燃[六四]燈佛。南無大通[六五]智勝佛。南無十六子佛。南無空王佛。南無多寶佛。南無雲自在燈王佛。南無威音王佛。南無無數光佛。南無思善佛。南無分身諸佛。南無無量化身佛[六六]。南無日月淨明德佛。南無淨華宿[六七]王智佛。南無淨莊嚴王佛。南無龍尊王佛。南無雲雷音王佛。南無雲雷宿[六八]主華智佛。南無寶王佛。南無娑羅樹王佛。南無上[六九]威德寶王佛。南無光明王佛。南無百億定光佛。南無光遠佛。南無月光佛。南無旃檀香佛。南無善山王佛。南無須彌天冠佛。南無須彌等曜佛。南無月色佛。南無正念佛。南無離垢佛。南無無著佛。南無龍天佛。南無不動地佛。南無妙花佛[七○]。南無琉璃妙花佛。南無琉璃金色佛。南無金藏佛。南無炎光佛[七一]。南無炎根佛[七二]。南無地種佛。南無月像佛。南無日音佛。南無解脫華佛。南無莊嚴光明佛。南無海覺神通佛。南無水光佛。南無大音佛[七三]。南無大香佛[七四]。南無離虛垢佛。南無捨厭意佛。南無寶炎佛。南無妙頂佛。南無勇立佛。南無功德持慧佛。南無弊日月光佛。南無日月琉璃光佛。南無無上琉璃光佛。南無最上首佛。南無菩提華佛。南無月明佛。南無日光佛。南無華色王佛。南無水月光佛。南無除疑冥佛。南無度苦行佛。南無淨信佛。南無善宿[七五]佛。南無威神佛。南無法慧佛。南無鸞音佛。南無師子音佛。南無龍音佛。南無處世佛。南無自在佛。南無無量壽佛。南無無量光佛。南無無邊光佛。南無無礙光佛。南無無對光佛。南無光炎王佛。南無炎光佛[七六]。南無炎根佛[七七]。南無清淨光佛。南無歡喜光佛。南無智慧光佛。南無不斷光佛。南無難思光佛。南無無稱光佛。南無超日月光佛。南無相好紫金佛。南無遠照佛。南無寶藏佛。南無無量音佛。南無甘露味佛。南無龍勝佛。南無勝力佛。南無師子音佛。南無離垢光佛。南無德首佛。南無妙德山佛。南無人王佛。南無金剛王佛[七八]。南無無上華佛。南無畏力王佛。南無龍自在王佛。南無師子依王佛。南無師子威光王佛[七九]。南無自在王佛。南無普光佛。南無普明佛。南無栴檀香光佛[八○]。南無多摩羅跋栴檀香佛。南無栴檀香光佛[八一]。南無歡喜藏寶積佛[八二]。南無摩尼幢佛[八三]。南無上大精進佛。南無普淨佛[八四]。南無摩尼幢佛[八五]。南無摩尼幢燈光佛。南無慧炬照佛。南無海德光明佛。南無金剛牢強[八六]佛。南無普散金光佛。南無大強[八七]精進佛。南無勇猛佛。南無悲光佛。南無慈力王佛。南無慈藏王佛。南無栴檀窟莊嚴勝佛。南無賢善首佛。南無善覺佛。南無莊嚴王佛。南無金山寶蓋佛。南無金華炎光相佛。南無大炬光明佛。南無寶蓋照空自在力王佛。南無金華光佛。南無虛空寶華光佛。南無琉璃莊嚴王佛。南無普現色身光佛。南無不動光佛[八八]。南無降伏諸魔王佛。南無千光明佛。南無慈慧勝佛。南無彌勒鮮光佛。南無世淨光佛。南無善寂月音佛。南無妙尊智王佛。南無寶蓋燈王佛。南無龍種上智尊王佛。南無日月光佛。南無日月珠光佛。南無慧幡勝莊嚴王佛。南無無垢藏佛。南無光明相佛。南無金炎光明佛。南無金焰光明藏佛。南無師子吼自在力王佛。南無妙音勝王佛。南無常光幢佛。南無常光幡佛[八九]。南無觀世燈[九○]王佛。南無慧依燈王[九一]佛。南無法常勝王佛。南無須彌光佛。南無須摩那華光佛。南無優鉢羅華[九二]光佛。南無強勝力王佛。南無慧力王佛。南無阿閦[九三]毘歡喜光佛。南無無量音聲王佛。南無才光佛[九四]。南無金海光佛。南無山海慧自在通王佛。南無大通光佛。南無大解脫光佛[九五]。南無一切法常滿王佛。南無現無愚佛。南無過去無量分身諸佛。南無過去一佛十佛百佛千佛萬佛。能除無量劫以來生死重罪。南無一億十億百億千億萬億那由他恆河沙無量阿僧祇[九六]佛。若人聞是過去無量阿僧祇佛名。是人八十萬劫。不墮地獄苦。是故今敬禮。
    若人因禮拜　　過去諸佛者　　滅罪得本心
    更不造十惡　　及以五逆等　　常得聞正法
    具足大乘戒[九七]　　是故今敬禮　　唯除二種人
    一者謗方等　　二者一闡提　　若人心淨清[九八]
    不名一闡提　　常見無量佛　　是故今敬禮
    若有犯重罪　　及以五間無[九九]　　復能清淨信
    亦得如法住　　皆由敬禮故　　滅除十惡業
    悉得大乘戒[一○○]　　是故今敬禮
    說是過去諸佛名時。十千菩薩得無生忍。八百聲聞發少分心。五千比丘得阿羅漢道。一億天人得法眼淨。
    南無現在無量諸佛。南無十億光明王諸佛[一○一]。南無離垢紫金沙佛。南無無量明佛。南無日輪光明王佛[一○二]。南無香積佛。南無師子億像佛。南無師子遊戲佛。南無普光功德山王佛。南無善住功德寶王佛。南無寶莊嚴王佛。南無難勝佛。南無須彌相佛。南無須彌燈[一○三]王佛。南無寶德佛。南無寶月佛。南無寶炎佛。南無寶嚴[一○四]佛。南無難勝師子吼佛[一○五]。南無大光王佛。南無不動光佛。南無藥王佛。南無莊嚴佛。南無樓至佛[一○六]。南無月蓋佛。南無普光佛。南無寶王佛。南無維衛佛。南無式王佛。南無隨葉佛。南無拘樓秦佛。南無拘那含牟尼佛[一○七]。南無迦葉佛[一○八]。南無雷音王佛。南無祇法藏佛[一○九]。南無栴檀華佛。南無栴檀葉佛。南無妙意佛。南無無上勝佛。南無甘露皷[一一○]佛。南無毘婆屍佛。南無日月光明佛。南無無勝光佛。南無具足莊嚴王佛。南無光明遍照功德王佛。南無破壞四魔師子吼王佛。南無金剛不壞佛。南無琉璃光佛。南無須彌山王佛。南無淨光明王佛。南無善德佛。南無無量光明佛。南無陀羅尼遊戲佛。南無首楞嚴三昧力王佛。南無善見定自在王佛。南無勇行定力王佛[一一一]。南無無上功德佛。南無神通自在佛。南無無色相佛。南無無聲[一一二]相佛。南無無香相佛。南無無味相佛。南無無觸相佛。南無三昧定自在佛。南無慧定自在佛。南無相覺自在佛。南無寳相王佛[一一三]。南無普攝佛。南無報德普光佛。南無屍棄佛。南無毘舍浮佛。南無迦羅鳩村大佛。南無迦那含牟尼佛[一一四]。南無迦葉佛[一一五]。南無意樂美音佛。南無歡喜佛。南無阿閦佛。南無須彌相佛。南無須彌頂佛。南無師子音佛。南無師子相佛。南無虛空住佛。南無雲雷自在佛。南無常滅佛。南無常寂佛[一一六]。南無帝相佛。南無不梵相佛。南無阿彌陀佛[一一七]。南無梵相佛。南無度一切世間苦惱佛。南無多摩羅拔栴檀香佛。南無須彌相佛。南無雲自在王佛。南無壞一切世間怖畏佛。南無百億我釋迦牟尼佛[一一八]。南無現在一佛十佛百佛千佛萬佛。能除無量劫以來生死重罪。南無一億十億百億千億萬億那由他恆河沙等無量阿僧祇佛。若人聞是現在無量阿僧祇佛名。是人六十萬劫。不墮地獄苦。是故今敬禮。
    若人因禮拜　　現在十方佛　　度脫諸惡業
    滅除五逆等　　常住清淨地　　安住釋迦法
    永離三惡道[一一九]　　得見彌勒佛　　及以見千佛
    是故今敬禮　　復見十方佛　　常生清淨土
    得聞第一義　　了知如來常[一二○]
    說是現在諸佛名時。二恆河沙菩薩。得入陀羅尼門。四十二億諸天及人。皆發無上菩提道心。
    南無未來賢劫無量諸佛。南無彌勒佛。南無淨身佛。南無華光佛。南無華足佛[一二一]。南無光明佛。南無華足佛[一二二]。南無名相佛。南無閻浮那提金光佛。南無法明佛。南無寶明佛。南無普明佛。南無普相佛。南無普光佛。南無山海慧佛。南無自[一二三]在通王佛。南無神變自在王佛[一二四]。南無寶莊嚴佛。南無弗沙佛[一二五]。南無百億自在燈[一二六]王佛。南無寶相佛。南無喜見佛。南無二萬光相莊嚴王佛。南無三萬同號普德佛。南無雲雷音王佛。南無四萬八千定光佛[一二七]。南無寶月王佛。南無離垢光佛。南無妙色佛。南無妙色光明佛。南無破一切眾難佛[一二八]。南無眾香佛。南無眾聲佛。南無十千光明莊嚴佛。南無八十億莊嚴光明佛。南無寶華莊嚴佛。南無上首德王佛。南無紫金光明佛。南無五百授記華光佛。南無那羅延不壞佛。南無好華莊嚴佛。南無金剛定自在佛。南無未來一佛十佛百佛千佛萬佛。能除無量劫以來生死重罪。南無一億十億百億千億萬億那由他恆河沙無量阿僧祇佛。若人聞是未來無量阿僧祇佛名。是人四十[一二九]萬劫不墮地獄苦。是故今敬禮。
    若人因禮拜　　未來諸佛名　　三障及五逆
    唯除一闡提　　悉皆得除滅　　安住佛法中
    得見無量佛　　常得聞正法　　是故今敬禮
    若人因禮拜　　三世十方佛　　滅除過去罪
    未來及現在　　所造十惡業　　今現得除滅
    未來見佛性　　是故諦信之　　書寫讀誦經
    世世所生處　　不生惡邪見　　常正得解脫
    不生在邊地　　不生在惡國　　不見惡國王
    四億萬劫中　　不墮地獄苦　　是故今敬禮
    滅除十惡業　　得大陀羅尼
    說是未來諸佛名時。五萬菩薩住不退地。七百比丘尼得阿羅漢道。六十二億諸天人民得法眼淨。
    南無總持大陀羅尼。十二部經[一三○]。修多羅。祇夜。授記。伽陀那。憂陀那。尼陀那。阿波陀那。伊帝目多伽[一三一]。闍陀伽。毘佛略。阿浮陀達摩。憂波提舍。所有大藏。諸波羅蜜。若人聞是。十二部經。諸波羅蜜。贊誦禮拜。信樂受持。是人二十萬劫中。不墮地獄苦。得宿命智。是故今敬禮。
    說是十二部經名時。八萬五千菩薩。得金剛三昧。十億聲聞。發大乘心。十千比丘比丘尼。得羅漢道。無量天人。得法眼淨。
    南無十方無量諸大菩薩。南無文殊師利菩薩。南無觀世音菩薩。南無大勢至菩薩[一三二]。南無常精進菩薩。南無不休息菩薩。南無寶掌菩薩。南無藥王菩薩。南無藥上菩薩[一三三]。南無勇精進菩薩[一三四]。南無勇施菩薩[一三五]。南無寶月菩薩。南無月光菩薩。南無滿月菩薩。南無大力菩薩。南無無量力菩薩。南無越三界菩薩。南無[颭-占+(犮-乂+又)]陀婆羅菩薩。南無彌勒菩薩。南無寶積菩薩。南無導師菩薩。南無德藏菩薩。南無樂說菩薩。南無龍樹菩薩。南無寶檀華菩薩。南無上行菩薩。南無無邊行菩薩。南無安立行菩薩。南無淨行菩薩。南無陀羅尼菩薩。南無金剛那羅延菩薩。南無常不輕菩薩。南無宿[一三六]王華菩薩。南無喜見菩薩。南無妙音菩薩。南無德勤精進力菩薩。南無無盡意菩薩。南無無盡慧菩薩[一三七]。南無淨藏菩薩。南無淨眼菩薩。南無普賢菩薩。南無妙德菩薩。南無慈氏菩薩。南無善思議菩薩。南無空無菩薩。南無神通華菩薩。南無光英菩薩。南無光明菩薩[一三八]。南無慧上菩薩。南無慧光明菩薩一三九]。南無智幢菩薩。南無寂根菩薩。南無願慧菩薩。南無香象菩薩。南無寶英菩薩。南無寶明菩薩[一四○]。南無中住菩薩。南無制行[一四一]菩薩。南無解脫菩薩。南無法藏菩薩。南無等觀菩薩。南無不等觀菩薩。南無等不等觀菩薩。南無定自在王菩薩。南無法自在王菩薩。南無法相菩薩。南無光相菩薩。南無光嚴菩薩。南無大嚴菩薩。南無寶積菩薩。南無辯[一四二]積菩薩。南無寶手菩薩。南無寶掌菩薩。南無寶印手菩薩。南無常舉手菩薩。南無常下手菩薩。南無常慘菩薩。南無常慈菩薩[一四三]。南無喜根菩薩。南無喜王菩薩。南無辯音菩薩。南無虛空藏菩薩。南無攝寶炬菩薩。南無寶勇菩薩。南無寶見菩薩。南無諦網菩薩。南無明網菩薩。南無無緣觀菩薩。南無慧積菩薩。南無寶勝菩薩。南無天王菩薩。南無壞魔菩薩。南無電德菩薩。南無自在王菩薩。南無功德相嚴菩薩。南無師子吼菩薩。南無雷音菩薩。南無山相擊音菩薩。南無香象菩薩。南無白香象菩薩。南無妙生菩薩。南無華嚴菩薩。南無梵網菩薩。南無寶杖菩薩。南無無勝菩薩。南無嚴土菩薩。南無金髻菩薩。南無珠髻菩薩。南無光嚴童子菩薩。南無持世菩薩。南無善德菩薩。南無難勝菩薩。南無照明菩薩。南無上功德菩薩[一四四]。南無華光菩薩。南無寶檀華菩薩。南無薩陀波論菩薩[一四五]。南無曇無竭菩薩。南無法自在菩薩。南無德守菩薩。南無不眴[一四六]菩薩。南無德頂菩薩。南無善宿菩薩。南無善眼菩薩。南無善根菩薩[一四七]。南無妙臂菩薩。南無弗沙菩薩[一四八]。南無師子菩薩。南無師子意菩薩。南無淨解菩薩。南無那羅延菩薩。南無善意菩薩。南無現見菩薩。南無普守菩薩。南無電光菩薩。南無喜見菩薩。南無明相菩薩。南無妙意菩薩。南無無盡意菩薩。南無深慧菩薩。南無寂根菩薩。南無無礙菩薩。南無上善菩薩。南無福田菩薩。南無華嚴菩薩。南無德藏菩薩。南無月上菩薩。南無寶印手菩薩。南無珠頂王菩薩。南無樂實菩薩。南無樂諦菩薩[一四九]。南無慧見菩薩。南無登王菩薩[一五○]。南無深王菩薩。南無華王菩薩。南無妙色菩薩。南無善問菩薩。南無善答菩薩。南無了相菩薩。南無定相菩薩。南無定積菩薩。南無發喜菩薩。南無安住菩薩。南無怖魔菩薩。南無慧施菩薩。南無救脫菩薩。南無慧燈菩薩。南無勇施菩薩。南無智導菩薩。南無願慧菩薩。南無四攝菩薩。南無教音菩薩。南無海妙菩薩。南無法喜菩薩。南無道品菩薩。南無總持菩薩。南無慈王菩薩。南無大自在菩薩。南無梵音菩薩。南無妙色菩薩。南無寶檀林菩薩。南無師子音菩薩。南無妙聲菩薩。南無妙色形菩薩。南無種種莊嚴菩薩。南無釋幢菩薩。南無頂生菩薩。南無明王菩薩。南無大光菩薩。南無奢提菩薩。南無無畏菩薩[一五一]。南無密積菩薩。南無華睒[一五二]菩薩。南無上首菩薩。南無普現色身菩薩。南無神通菩薩。南無海德菩薩。南無無邊身菩薩。南無醫王自在菩薩[一五三]。南無迦葉菩薩。南無無垢藏王菩薩。南無持一切菩薩。南無救一切菩薩[一五四]。南無高貴德王菩薩。南無琉璃光菩薩。南無無畏菩薩。南無海王菩薩。南無師子吼菩薩。南無陀羅尼菩薩。南無那羅延菩薩。南無信相菩薩[一五五]。南無持地菩薩[一五六]。南無光嚴菩薩。南無光明菩薩。南無大辯菩薩。南無慈力菩薩。南無大悲菩薩。南無依王菩薩。南無依力菩薩。南無依德菩薩。南無普濟菩薩。南無普攝菩薩。南無定光菩薩。南無普光菩薩。南無真光菩薩。南無拘樓秦菩薩[一五七]。南無天光菩薩。南無寶王菩薩。南無彌光菩薩。南無教道菩薩。南無導師菩薩。南無大忍菩薩。南無華王菩薩。南無華積菩薩。南無慧光菩薩。南無海慧菩薩。南無堅意菩薩。南無釋摩男[一五八]菩薩。南無金光明菩薩。南無金藏菩薩。南無常悲菩薩。南無法上菩薩。南無才首菩薩。南無山光菩薩。南無山慧菩薩。南無大明菩薩。南無總持菩薩。南無山剛菩薩。南無登王菩薩[一五九]。南無山頂菩薩。南無山幢菩薩。南無山王菩薩。南無伏魔菩薩。南無雷音菩薩。南無雨王菩薩。南無雷王菩薩。南無寶輪菩薩。南無寶英菩薩。南無寶首菩薩。南無寶藏菩薩。南無寶明菩薩。南無寶定菩薩。南無寶印菩薩。南無寶場菩薩。南無寶嚴菩薩。南無寶水菩薩。南無寶光菩薩。南無寶燈菩薩[一六○]。南無寶現菩薩。南無寶造菩薩。南無寶作菩薩[一六一]。南無樂法菩薩。南無淨王菩薩。南無頂相菩薩。南無金光菩薩。南無寶髻菩薩。南無千光菩薩。南無原嶮菩薩。南無淸净菩薩[一六二]。南無照味菩薩。南無智慧菩薩[一六三]。南無月辯菩薩。南無月光菩薩。南無法輪菩薩。南無光淨菩薩。南無常施菩薩。南無普德菩薩。南無普明菩薩。南無勝幢菩薩。南無濡[ 一六四]音菩薩。南無德炎菩薩。南無相光菩薩。南無海月菩薩。南無海藏菩薩。南無勝月菩薩。南無淨慧菩薩。南無超光菩薩。南無月德菩薩。南無日光菩薩。南無金剛菩薩。南無炎幢菩薩。南無尊德菩薩。南無海明菩薩。南無海廣菩薩。南無照境菩薩。南無慧明菩薩。南無功德菩薩。南無明達菩薩。南無密教菩薩。南無須那菩薩。南無布施菩薩[一六五]。南無色力菩薩。南無調伏菩薩。南無隱身菩薩。南無一菩薩。南無十菩薩。南無百菩薩。南無千菩薩。南無萬菩薩。南無一百萬菩薩。二百萬三百萬四百萬五百萬六百萬七百萬八百萬九百萬千千萬諸大菩薩摩訶薩。能除無量劫以來生死重罪。南無一億十億百億千億萬億。南無萬萬億諸大菩薩摩訶薩。能除無量劫以來生死重罪。南無一那由他十那由他百那由他千那由他萬那由他。南無萬萬那由他諸大菩薩摩訶薩。能除無量劫以來生死重罪。南無一恆河沙。南無二恆河沙。南無三恆河沙。南無四恆河沙。南無五恆河沙。南無六恆河沙。南無七恆河沙。南無八恆河沙。南無九恆河沙。南無十恆河沙。南無百恆河沙。南無百億無量恆河沙諸大菩薩摩訶薩。能除無量劫以來生死重罪。若人聞是大士。諸大菩薩摩訶薩名者。是人四十千劫中。不墮地獄苦。不屬三界獄。常屬解脫王
    不生邊地　　不生惡國　　不受惡身
    不生邪見　　不生下性　　不生外道
    身根具足　　常聞正法　　不受禁戒
    常得具足　　大乘威儀　　常見佛性
    是故今敬禮　　安住佛法中　　來世成佛道
    說是諸大菩薩名時。八十八億清淨信男女悟阿那含果。九十四億諸天得斯陀含果。七千八億失心比丘還得本心。悟阿羅漢果。十億菩薩得大陀羅尼。來世成佛道。

大通方廣懺悔滅罪莊嚴成佛經 卷上　終


上卷備註

大正藏原題，上卷以鬆本文三郎氏藏敦煌本為底本。注釋中除注明出處的外，其餘皆依於胡老師根據拉卜楞寺版藏文經文的校注。
[一]「與大比丘八萬人俱。言诸菩薩三萬六千人」：原文為「□□□□□俱諸菩薩三萬六千人」。
[二]「於一生中。遠離一切蓋障。具足成德自在」：原文為「一生補□□□□□威德日在」。
[三]「於如來前。勸請宣說。方便密意」：原文為「顯說如來方便蜜□」。
[四]「能使佛地。悉皆清凈。如來事業。任運成就」：原文為「□□□□□□作佛事皆悉成就」。
[五]藏文為：以諸佛加被而為建立。
[六]原文為：□□藏。
[七]藏文為：作。
[八]藏文為：彼功德位。
[九]原文為：猶大海。為對仗故。依藏文義，持者可隨自己的意樂擇一而誦。以下類似情況同此。
[一Ｏ]藏文為：今心清凈。
[一一]藏文為：安住平等。
[一二]藏文為：念定悉持。
[一三]藏文為：「具足智慧。宣說教法」。
[一四]藏文為．四攝六度。依丁保福《佛學大辭典》（以下簡稱丁氏辭典），四等為慈悲喜捨四無量之義，四攝為布施愛語利行同事。
[一五]藏文為：具足知道有無的智慧，依丁氏辭典，有無為術語指有法和無法。
[一六]藏文為：住正知定中。
[一七]藏文為：無量威德。
[一八]藏文為：使。
[一九]藏文為：而。
[二○]「相好嚴身。眾相第一」。藏文為「端嚴相好。具足最勝」。
[二一]色好：藏文為身色。
[二二]藏文為：依住平等。依丁氏辭典，平等亦指一切眾生平等成佛之法，漢文中無等等指佛道及佛之尊號。
[二三]藏文為：長久生起善根。
[二四]此段藏文為：「得佛自在。具足智慧。十力。四無所畏。十八不共法」。
[二五]「通達善趣門。關閉諸惡道」：藏文為「開善趣門。關閉惡道」。
[二六]藏文為：為。
[二七]無量功德：藏文為大功德位。
[二八]藏文有往昔之義。
[二九]藏文為：并知如來恆常安住。
[三○]「常說眾生等。盡有佛性」：藏文為「於眾生中。皆有佛性。於尋常中。如是說云」。
[三一]以上講菩薩名後．藏文均有摩訶產之謂。
[三二]桓：音環。
[三三]指大梵天。
[三四]娑羅：指娑羅樹。
[三五]藏文為：四月十五日，此處日期的差异可能來自漢藏歷法的不同。
[三六]安隱：指心的安樂。
[三七]安樂：指身的安樂。
[三八]藏文特指道的左右兩邊。
[三九]藏文此處僅有如來之謂。
[四○]維摩：亦名無垢稱，藏文此處為無垢稱。
[四一]邪：原文為耶。
[四二]座：原文為坐。
[四三]此處「與華平等。名為八功德。香水彌滿」藏文無此數字之義。
[四四]原文此處有「波頭華」三字，藏文此處無此數字之義，大正藏亦校作刪。
[四五]一闡提：依丁氏辭典，闡提為之略稱，不成佛之義也。此有兩種．一斷善闡提，起大邪見而斷善根者；二大悲闡提，菩薩有大悲心欲度盡一切眾生而成佛，眾生無邊，故已畢竟無成佛之期者。此處含義為前者。
[四六]藏文此處有「語句亦善 」。
四七]藏文此處有諸善男子，原文無。
[四八]原文此處有諸善男子。藏文無。
[四九]原文為：理無二極。此處采用現慣用譯法 邊，指斷常二邊。
[五Ｏ]此句藏文義為在智慧的觀察下最終是一體。
[五一]邑：音義．都市縣；塚：音腫，墳墓。
[五二]原文為：若誦經一句。藏文特指本經，為顯此經殊勝，故依藏文，持者可依自己的意樂擇一而誦。
[五三]原文為：九。
[五四]禮：原文為體。
[五五]空處：指寺廟。
[五六]抃：音變。
[五七]罹：原文為：羅。藏文為遭遇之義，故校為罹，音利。手抄本亦校如此。
[五八]掃：原文為持。
[五九]忉：音刀。
[六○]「見了佛性。以是因緣」。原文為「見了佛以。是性因緣」。疑排版之誤。
[六一]原文自此以上至敬禮賓王佛，敬禮前均有當字，藏文無，爲格式規整故，依藏本刪去。
[六二]原文為：合十指抓掌。
[六三]敬禮：原文為敬信，為與後文格式一致，故依藏文。
[六四]燃：原文為然。
[六五]通：藏文為無礙之義。
[六六]此處漢文為南無分身諸佛．藏文為南無無量化身佛，義為此佛名為無量化身。由于本經譯出的年代久遠、可能所依的梵文版本不盡相同以及在輾轉流通和整理中產生的訛誤等，在佛教術語用法方面與現在有一些差異，另外行文格式也不太嚴格，雖與藏文內容非常吻合，但在佛菩薩名號處略有差异。特遵師囑，為不失加持故，凡漢、藏本中佛名有差异者，漢文佛名不減．藏文佛名於後補充，并列刊出；漢、藏佛名位置不同者，按藏文原序列出；漢、藏佛名意義相當者，藏義佛名于後注出；少數漢、藏文佛名含義相當而漢文文字與當今習慣用法差异較大音．為便于當今持誦者念誦時緣想，特依藏文佛名修正，原佛名于後注出，供念誦者參考選擇。以下類似情況同此處理，不再說明。
[六七]宿：藏文為星宿之義。
[六八]宿：同上。
[六九]上：藏文為無上之義。
[七Ｏ]藏文此處有此佛名而漢文無。
[七一]在藏文中此佛名位置見後。
[七二]在藏文中此佛名位置見後。
[七三]藏文此處有此佛名而漢文無。
[七四]藏文此處無此佛名而漢文有。
[七五]宿：藏文指宿命通。
[七六]藏文此處有此佛名，漢文位置見前。
[七七]藏文此處有此佛名，漢文位置見前。
[七八]漢文此處為南無人王佛，藏文為南無金剛王佛．并列刊出。
[七九]漢文此處為南無師子依王佛，藏文為南無師子威光王佛，并列刊出。
[八Ｏ]此佛名在藏文中位置見後。
[八一]藏文此處有此佛名，漢文位置見前。
[八二]藏文為南無實積歡喜藏佛。
[八三]藏文此處有此佛名．漢文見後。
[八四]藏文此處無此佛名
[八五]在藏文中此佛名位置見前。
[八六]牢強：藏文為堅固之義。
[八七]大強：藏文為堅固之義。
[八八]藏文中光指智光。
[八九]漢文此處為南無常光幢佛，藏文為南無常光幡佛，并列刊出。
[九○]燈：原文為登。
[九一]燈：原文為登。
[九二]優鉢羅華：夜間開放的蓮花。
[九三]閦：音杵。
[九四]藏文為中才指智
[九五]漢文此處為南無大通光佛，藏文為南無大解脫光佛，并列刊出。
[九六]衹：音其。
[九七]原文為：具足大乘□，屬大正藏排版漏字，依藏文補上。
[九八]清凈：原文為凈清，依藏文改正。
[九九]無間：原文為間無，依藏文改正。
[一ＯＯ]戒：原文為式，依藏文改正。
[一Ｏ一]漢文此處為南無十億王明諸佛。
[一Ｏ二]漢文此處為南無日轉光明王佛。
[一Ｏ三]燈：原文為登。
[一Ｏ四]嚴：藏文為莊嚴之義，以下佛菩薩名號中嚴義同此．不再一一列出。
[一Ｏ五]漢文此處為南無難勝師子響佛。
[一Ｏ六]依丁氏辭典，樓至佛，又謂盧至、樓由、盧遮等，譯曰愛樂、啼哭之義，賢劫千佛之最後佛也，今之執金剛神或名密跡金剛是也。
[一Ｏ七]漢文此處漢文諸佛名「南無維衛佛．南無式王佛。南無隨葉佛。南無拘樓秦佛。南無拘那含牟尼佛」，藏文為「南無威光佛。南無尊勝佛。南無救一切佛。南無除邪性佛。南無金力佛」。依丁氏辭典．維衛佛，又謂毘婆沙、弗沙等名，七佛之首，譯曰勝觀種種觀種種見；隨葉佛，又謂毘舍浮等名，一切勝之義；拘樓秦佛，又謂拘留秦、拘留孫、迦羅鳩村大等名，七佛之四，譯曰所應斷已斷、滅累、成就美妙等；拘那含牟尼佛，又謂迦那伽牟尼等名，譯曰金寂、金仙人，賢劫第二佛，七佛之五。式王佛，未見注釋。
[一Ｏ八]迦葉佛，藏文義為飲光佛，迦葉．音加設。
[一Ｏ九]祇法藏佛，藏文為大法藏佛。祗：音其，有大之義。[一一Ｏ]皷：鼓之異體。
[一一一]漢文此處為南無善見定自在王佛，藏文為南無勇行定力王佛，并列刊出。
[一一二]聲：原文為散。
[一一三]漢文此處為南無相覺自在佛．藏文為南無寶相王佛，并列刊出。
[一一四]漢文此處諸佛名為「南無尸棄佛。南無毘舍浮佛。南無迦羅鳩村大佛。南無迦那含牟尼佛」，藏文為『南無具尊勝佛。南無救一切佛。南無除邪性佛。南無金能佛」。依丁氏辭典，尸棄佛，尸棄又謂式，勝及最上義亦有持髻和火等義。毘舍浮佛、迦羅鳩村大佛，見前注。迦那含牟尼佛，未見注釋。
[一一五]同[一Ｏ八]。
[一一六]漢文此處為南無常滅佛，藏文為南無常寂佛，并列刊出。寂：寂靜之義。
[一一七]藏文此處無此佛名
[一一八]藏文此處為百億化身釋迦牟尼佛。
[一 一九]三惡道：原文為四惡道。
[一二Ｏ]常：藏文爲恆常安住。
[一二一]藏文此處有南無華足佛。足即圓滿之義。原文見後。
[一二二]此佛名在藏文中位置見前。
[一二三]原文為南無目在通王佛．目：疑為自。
[一二四]原文此處為南無目在通王佛，藏文為南無神變自在王佛，并列刊出。
[一二五]藏文為南無上士佛。弗沙佛，見前注。
[一二六]燈：原文為登。
[一二七]藏文為南無四萬八千不動定光佛。
[一二八]藏文為南無破一切障礙佛。
[一二九]四十：原文為十四。
[一三Ｏ]十二部經名釋：依丁氏辭典，據智度論三十三之說：一修多羅，此云契經，經典中直說法義之長行文也。契經者，尤言契於理契於機之經典。二祗夜，譯作應頌，又作重頒，應於前長行之文重宣其義者即頌也。凡定字句之文體，謂為頒。三伽陀，譯作諷頌又作孤起頓。不依長行、宜作偈頌之句者。如法句經是也。四尼陀那，此譯因緣。經中說見佛聞法因緣及佛說法教化因緣之處。如諸經之序品即因緣經也。五伊帝目多，此譯本事。佛說弟子過去因緣之經文。如法華經中藥王菩薩本事品是也。六闍多伽，此譯本生。佛說自身過去世因緣之經文也。七阿浮達摩，新云阿毘達磨，此譯未曾有。記佛現種種神力不思議事之經文也。八阿波陀那．此譯譬喻。經中譬喻之處也。九優婆提捨，此譯論義。以法理論義問答之經文也。＋優陀那，此譯自說。無問者佛自說之經文。如阿彌陀經是也。十一毗佛略，此譯方廣，說方正廣大之真理之經文也。十二和伽羅，此譯授記。於菩薩授成佛之記之經文也。此十二部中，修多羅與祗夜及伽陀三者，為經文之體裁 餘九部從其經文所載之別事而立名。
一三一]原文為：伊帝曰多伽，黃懺華的《佛學概論》中，音譯為伊帝目多伽，與本經譯音類似，故而釆用此種譯音。
[一三二]原文為南無得大勢菩薩，依丁氏辭典．得大勢菩薩即大勢至菩薩。
[一三三]藏文此處無此菩薩名。
[一三四]藏文此處有南無勇精進菩薩。
[一三五]藏文此處無此菩薩名。
[一三六]宿：藏文為昔之義。
[一三七]原文此處為南無無盡意菩薩，藏文此處為南無無盡慧菩薩，并列刊出。
[一三八]原文此處為南無光英菩薩，藏文為南無光明菩薩，并列刊出。
[一三九]原文此處為南無慧上菩薩。藏文此處為南無慧光明菩薩，并列刊出。
[一四○]原文此處為南無實英菩薩，藏文為南無寶明菩薩，并列刊出。
[一四一]製行：戒律之義。
[一四二]辯：藏文為智慧辯才之義。
[一四三]原文此處為南無常慘菩薩，藏文為南無常慈善薩，并列刊出。
[一四四]原文此處為南無照明菩薩，藏文為南無上功德菩薩，并列刊出。
[一四五]藏文此處無此菩薩名。薩陀波論菩薩，依丁氏辭典，即常啼菩薩。
[一四六]眴：音瞬，眨眼之義。
[一四七]原文此處為南無善眼菩薩，藏文為南無善根菩薩，并列刊出。
[一四八]同[一二五]。
[一四九]原文此處為南無樂實菩薩，藏文為南無樂諦菩薩，并列刊出。諦，諦實之義。
[一五○]藏文為南無得王位菩薩．
[一五一]原文此處為南無奢提菩薩，藏文為南無無畏菩薩，并刊刊出。
[一五二]睒：音閃，眨眼之義。
[一五三]原文此處爲南無衣王自在菩薩，依藏文將衣改為醫。
[一五四]原文此處為南無持一切菩薩，藏文為南無救一切菩薩，并列刊出。
[一五五]藏文此處無此菩薩名，
[一五六]藏文此處無此菩薩名。
[一五七]原文為南無拘樓菩薩，依此處藏文為南無除邪見菩薩之義，拘樓應為拘樓秦。
[一五八]釋摩男：釋迦族之義。
[一五九]南無登王菩薩：藏文此處無此菩薩名。
[一六Ｏ]藏文為南無寶熾燃菩薩。登：依藏文之義，同燈。
[一六一]原文此處為南無寶造菩薩，藏文為南無寶作菩薩，并列刊出。作，造作之義。
[一六二]原文此處為南無原嶮菩薩，藏文為南無清凈菩薩，并列刊出。嶮：音演，高峻之義。
[一六三]原文此處為南無照味菩薩，藏文為南無智慧菩薩，并列刊出。
[一六四]濡：音軟，柔軟之義。
[一六五]原文此處為南無須那菩薩，藏文為南無布施菩薩，并列刊出。布施，梵音為檀那。


大通方廣懺悔滅罪莊嚴成佛經卷中

    爾時。佛告信相菩薩摩訶薩言。善男子。汝向自説。過去有佛名寶勝。苦惱[一]眾生。一聞名字。命終生天。今復請我。説諸佛名。使諸眾生。離苦出世。是故我今。爲汝及眾。具説三寶。理是一寶。隨順説三。若人聞者。至心憶念。欲壽[二]終時。值善知識。教令三稱。三寶名字。作如是言。
    南無佛陀 南無達摩 南無僧伽
    如是唱已。其人命終。不到三塗。隨意所樂。十方世界。皆得往生。應奉諸佛。見諸菩薩。文殊普賢。宣説大乘大通方廣。即聞法已。應時獲得。無生法忍。善男子。若人曠劫。廣修諸行。深種善根。今得聞此。三寶名字。
    爾時。信相菩薩白佛言。世尊。云何名爲三寶。一相耶。二相耶。三相耶。如其一相。即是一歸。如其三相。即是三歸。如其三歸。佛法别體。僧亦如是。若是三歸。眾生見三億劫行道。不會一乘。唯願世尊。利益眾生。爲我说之。我聞是已。亦爲眾生。分别解説。於佛滅後。若有聞者。即得住於。三菩提道[三]。
    爾時。佛讃信相菩薩。善哉善哉。善男子。乃能問佛大事。問佛大事者。非一地二地三地七地八地。唯有十地。法雲大士。乃能問佛。如是大事。汝今諦聽。當爲汝説之。善男子。一切眾生。曠劫以來。無明所蔽。三界牢獄。生死流轉。眾怖交集。六道往來。無歸依處。是故歸命天神。投身外道。自縛手足。害生求命。無免[四]時患。兼復避火投淵。俱不免患。是故大埾如來。哀從定起。愍彼長迷。開演三寶。爲[五]眞依處。初爲始末學二乘之人。説於梯橙[六]别體三[七]寶。後爲久修梵行大士。説於究竟一體三寶。於一佛寶。即有法僧。善男子。何故名寶。譬如世間七寶。可以濟命。是故三寶在世。導養法身。能續行者。智慧身命。謂之寶也。别相三寶者。佛現王宫。二應法身[八]。言是菩薩。爲度眾生。修行苦行。道場樹下[九]。現[一○]成正覺。自覺覺人。故號爲佛。佛名覺者。僧名受化。弟子從教得理。故名爲僧。僧有二種。一者和合。得名爲僧。二者無爲。亦名爲僧[一一]。得無爲者。以[一二]眞空解慧。性空無爲。迷惑[一三]相續。證結盡無[一四]。爲已滅諸結。聖眾共住。和合不諍。以此二義。故得名僧。善男子。法者一切善惡之法。有爲無爲。諸佛道理。惡法可離。善法可崇[一五]。并爲心軌。皆是法寶。是故佛僧二寶。人異體别。法與僧佛。體同難别。何以難别[一六]。或有人言。佛僧二寶。但取假名行人。行人所得五分法身。諸善功德。泮爲法寶。此義不然。何以故。今因以此諸善功德。得成於人。離法無人。何得别人。并爲二寶。今釋人法。有同有異。以法成人。法屬於人。是以故説。五分法身。十力無畏。三十二相。八十種好。諸波羅蜜。無量三昧。以爲佛寶。小乘五分。説爲僧寶。此諸功德。有爲無爲。法相道理。可爲軌用[一七]。復名法用[一八]。此則同體。雖説二義。亦有法體[一九]。異佛法僧。如是法寶。已説此三。眾生歸依。得免三界。生死怖畏。一切行人。雖得免麁[二○]。細苦未盡。是故爲説。至極三寶。明昔日三寶。言佛有苦。法是無常。僧亦無常。是苦。非眞依處。今説常住行者。覺了法性理空。永離八倒[二一]。無有生滅。動求之苦[二二]。爲眞依處。名爲佛寶。所得常法。軌用至極。名眞法寶。常住行者。會眞法性。證常住無爲。故名爲僧。亦以八倒永盡。與九聖眾。一切和合。永無諍訟。故名爲僧寶。昔日三寶。異人别法。今之三寶。於一佛一體。分爲法僧。以是義故。我爲法説。一相三寶。今諸眾生。趣向一乘。
    信相菩薩白佛言。世尊。當觀何事。求於大乘。佛言。善男子。當觀三界無常。以求大乘。
    信相菩薩復白佛言。云何名爲。觀於無常。佛言。欲觀無常。除其煩惱。當行正念。慈悲爲首。説法度人。而不取證[二三]。是名菩薩。不捨眾生。爲求大乘。善男子。譬如一城。縱廣一由旬。多有諸門。路險黑闇。甚可怖畏。有入[二四]此城。受於快樂。復有一人。唯有一子。愛之甚重。遥聞彼城。受樂無窮。即便捨子。欲入此城。是人方便。得過險道。到彼城門。一足已入。未舉一足。即念其子。尋作是念。我唯一子。來時云何。竟不將來。誰能養護。令離眾苦。即捨樂城。還向子所。善男子。菩薩慈悲。亦復如是。爲憐愍故。修集五通。既修集已。垂得盡漏。而不取證。何以故。愍眾生故。捨漏盡五通。乃至行於凡夫地中。善男子。城者。喻於大解脱樂。多諸門者。喻於八萬四千諸三昧。路險難者。喻諸魔道。到城門者。喻於五通。一足入者。喻於智慧。一足未入。喻諸大菩薩未證解脱。言一子者。喻於五道一切眾生。顧念子者。喻大悲心。還子所者。喻調眾生。實得解脱。不取證得。即是方便。善男子。是故菩薩摩訶薩。大慈大悲。救攝不捨。不可思議。復次。善男子。菩薩大士。從初發心。必至菩提。常爲眾生。受十善法。何等爲十。一不殺[二五]生。二不偷盜。三不婬逸。四不妄語。五不兩舌。六不惡囗。七不無義語。八不貪嫉。九不瞋惱。十不邪[二六]見。菩薩如是。慈悲具足。慈能教善。見世所樂[二七]。悲能濟苦。地獄度之。見諸眾生。求涅槃門。不能知處。菩薩應當。於此眾生。修集悲心。悲因緣故。爲諸眾生。開大涅槃門。顯示安隱處。使得大乘果。是名菩薩摩訶薩行。
    信相菩薩復白佛言。世尊。云何正念。當行不生不滅法。世尊。何法不生。何法不滅。
    善男子。使惡法不生。善法不滅。若修此行。行於三界。清習五欲。無能爲汙。善男子。欲行三界。濟度眾生。應以十法。遊於三界中。順世俗文字。説有三世。無上菩提。不在三世。究竟菩提。不墮眾數。何況三世三界眾生中。何者爲十。一者於譽於毀。心無增减。二者若聞善惡。心無分别。三者於諸愚智。等以悲心。四者見上下眾生。意常平等。五者於輕毀供養。心無有二。六者於他闕失。莫見其過。七者見種種乘是一乘。八者若聞三惡[二八]。亦勿驚怖。九者於諸菩薩。生如來想[二九]。十者佛出五濁。生希有想。菩薩如是。具足十法。斷除愚痴[三○]。煩惱結習。無能爲障[三一]。菩薩大士。遊三界中。以大悲爲本。處此穢土。和光不同塵。是名難思議。若人於净國。持戒滿一劫。此土須臾閒[三二]。行慈及大悲。身語及意業。悉皆獲清浄[三三]。應墮三惡道。現世受得除。菩薩生此土。不應懷憂怖。設有惡道罪。頭痛則得除。所以者何。若人欲斷縛。滅除諸煩惱。雖生此惡土。護法增智慧。億劫在净土。常受净戒行。不如生此土。從旦至明日。我見阿閦佛國。西方安樂土。二國甚清净。亦無苦惱名。於此作功德。未足以爲奇。若人於此土。能忍不可事。亦教前人[三四]忍。其福最爲勝。是故菩薩。行於此惡土。濟度諸眾生。勿懐煩惱憂。堅固菩提心。必得無上道。
    爾時。虚空藏菩薩白佛言。我等今者。欲問菩薩菩提因緣。若佛聽許。當敢發問。佛言。善哉善哉。善男子。汝於無量劫。百千佛所[三五]。種諸善根。久達菩薩。所行方便。爲諸菩薩。問於堅固菩提之道。隨意決問。吾當爲汝。分别解説。
    時虚空藏菩薩已蒙許可。白佛言。世尊。何謂菩薩。其心堅固。而不疲倦。何謂菩薩。所言決定。而無中悔。何謂菩薩。增長善根。何謂菩薩。無所恐畏。威儀不轉。何謂菩薩。成就善法。何謂菩薩。善知從一地。至於十地。何謂菩薩。善知方便。何謂菩薩。善化眾生。何謂菩薩。世世不失。菩提之心。何謂菩薩。能一心而無雑行。何謂菩薩。善求法寶。何謂菩薩。善出毀禁犯律之罪。何謂菩薩。能障[三六]煩惱。何謂菩薩。善能隨順。入諸大眾。何謂菩薩。善開法門。何謂菩薩。得先因力[三七]。不失善根。何謂菩薩。不由他教。而能自行六波羅蜜。何謂菩薩。能捨禪定。現生欲界。何謂菩薩。於諸佛法。得不退轉。何謂菩薩。行於三界。教化眾生。使增善根。不斷佛性。
    爾時世尊。讃虚空藏菩薩言。善哉善哉。能問如來。菩薩之事。汝今諦聽。善思念之。唯然。世尊。願樂欲聞。領納聽受。
    佛告虚空藏菩薩。復有四法。堅固其心。而不疲倦。何等爲四。一者於諸眾生起大悲心。二者精進不懈。三者生死如夢。四者正意思惟佛之智慧。菩薩有此四法。堅固其心。而不疲倦。
    復有四法。所言決定。而無中悔。何等爲四。一者決定説法。了知無我。二者決定説諸生處。無可樂相。三者決定常讃大乘。四者決定説罪福業。不失果報。是名爲四。
    復有四法。增長善根。何者爲四。一者持戒。二者多聞。三者布施。四者出家。是名爲四。
    菩薩復有四法。無所怖畏。威儀不轉。何等爲四。一者失利。二者惡名。三者毀辱。四者苦惱。是名爲四。
    菩薩復有四法。成就白法。何等爲四。一者教人令信罪福。二者布施不求果報。三者守護正法。四者以大智慧。教諸菩薩。是名爲四。
    善男子。復有四法。善能了知一地。至於十地。一者久種善根。二者離諸過咎。三者善知方便。四者懃行精進。廻向菩提。是名爲四。
    善男子。復有四法。善知方便。何等爲四。一者順眾生意。二者於他功德。起隨喜心。三者有罪悔過。四者勸請諸佛。轉大法輪。是名爲四。
    善男子。復有四法。善化眾生。何等爲四。一者常求利安眾生。二者自捨己樂。三者和柔忍辱。四者能除髙慢。是名爲四。
    善男子。復有四法。能世世不失菩提之心。何等爲四。一者常憶念十方一切諸佛。二者所作功德等。以施之於一切眾生。常爲菩提。三者親近善知識。四者稱揚大乘。是名爲四。
    善男子。復有四法。能具一心。而無雑行。何等爲四。一者離聲聞心。二者離辟支佛心。三者求法無厭。四者如所聞法。廣爲人説。是名爲四。
    善男子。復有四法。善求法寶。何等爲四。一者於大法中。生寶想。以難得故。二者於大法中。生救藥想。療眾生病故。三者於大法中。生財[三八]利想。以不失故。四者於大法中。生滅苦想。至涅槃故。是名爲四。
    善男子。復有四法。善出毀禁犯律之罪。何等爲四。一者得無生法忍。以諸法無來故。二者得無滅忍。以諸法無去故。三者得因緣忍。知諸法因緣生故。四者得住忍。無異心相續故。是名爲四。
    善男子。復有四法。善障煩惱。何等爲四。一者四憶念[三九]。二者障諸根[四○]。三者能得善法力故。四者獨處遠離[四一]故。是名爲四。
    善男子。復有四法。善能隨順。入諸大眾。何等爲四。一者求法不求勝故。二者常生恭敬。心無憍慢。三者唯求法利。不自顯現[四二]。四者教人善法。不求名利。是名為四。
    善男子。復有四法。善開法施。何等為四。一者守護正法。二者自益智慧亦益前人。三者常行善人之法。四者不示人分别垢淨之法[四三]。是名為四。
    善男子復有四法。得先因力。不失善根。何等為四。一者見他人闕。不以為愚。二者於瞋怒人。常修慈心。三者常說諸法因緣[四四]。四者常念無上菩提。是名為四。
    善男子。復有四法。不由他教。而能自行六波羅蜜。何等為四。一者常以法施。施導與人。二者不說他人毀禁之罪。三者善知攝法[四五]。教化眾生。四者解達深法。是名為四。
    善男子。復有四法。能捨禪定。現生欲界。何等為四。一者其心柔軟。二者能得諸善根力。三者不捨一切眾生。四者常能善修。智慧方便之力。是名為四。
    善男子。復有四法。於佛法得不退轉。何等為四。一者於無數生死中。不生厭離[四六]。二者常能供養。無量諸佛。三者修行無量慈心。四者信解無量佛慧。是名為四。
    善男子。復有四法。不斷佛性。何等為四。一者為諸眾生。不退本願。二者受信施行[四七]。三者大欲精進。四者常能深心。行於佛道。是名為四。菩薩摩訶薩遊於三界。行種種行。利益眾生。常修出世。不斷佛性。
    說是大乘四法之時。四萬天人皆發三菩提心。二萬五千人得無生法忍。四萬八千菩薩得達法界忍[四八]。善入[四九]佛慧。
    爾時。佛告虛空藏菩薩摩訶薩言。汝今應當。受持是經。虛空藏菩薩白佛言。世尊。當何名之。云何奉持。
    佛言。此經名為。大通方廣。能破魔境。壞外道軍。消除煩惱。能解五欲邪見繫縛。破三界獄。放諸生死。向涅槃舍。潤益久涸正因種子。雨大因緣六度法雨。增長眾生三乘芽華。成就一乘菩提極果。善男子。汝問經名。我說如是。汝當受持。
    爾時。虛空藏菩薩白佛言。世尊。我從過去。無量佛所。無量會處。無量眾中。聞種種法。種種事。種種相。種種乘。未曾聞此。希有之法。希有之事。希有之相。希有大乘。我常受持。使不斷絕。世尊。如來常住。法僧不滅。三界眾生。自生自滅。不見如來。及以法僧。唱言滅度。我等今者。承佛威神。遊於三界。順從時宜。假唱滅度。世尊。我等今者。於佛滅後。當與八萬久達佛慧法身大士。流通此經[五○]。使法界眾生。受持讀誦。如說修行。一時成佛。猶不放捨。世尊。若善男子。善女人。於佛滅後。濁惡世中。若有受持讀誦。書寫經卷。得幾所福。
    佛言。善男子。若人以三千大千世界。滿中珍寶。以用布施。不如聞此經名。福勝於彼。復置是事。若人以十千世界。滿中珍寶。以用布施。不如有人。攝持經卷。福多於彼。復置是事。若人以十方世界。滿中珍寶以用布施。不如有人。書寫大乘方廣經典[五一]。乃至一字一句。或復一偈。福多於彼。復置是事。雖施無量國之珍寶[五二]。不如至心讀誦一偈。復置是事。雖施十千世界。滿中眾生命。不如至心解義一句。為人說一偈之義。福勝於彼。所以者何。財食佈施。是世間佈施。長養性命。不出世間。大乘法施。長養眾生。菩提道根。能續三乘。智慧常命。善男子[五三]。讀持是經者。本雖惡人。今是善人。本雖苦人。今是樂人。本雖縛人。今是脫人。本雖未度。今是度人[五四]。本雖無智。今是論師。本雖有漏。今是無漏。本雖凡行。今是聖行。本雖失道。今入聖道。身雖凡夫。讀持是經。智同聖慧。本雖煩惱。讀持是經。共諸佛如來。同有涅槃。
    虛空藏菩薩白佛言。世尊。如佛所說。本是凡行。今是聖行。本是煩惱。讀持是經。共諸佛如來。同有涅槃。破戒五逆。誹謗正法。讀持是經。斷除煩惱。同得涅槃。此義難明[五五]。唯願世尊。當為說之。
    佛言。善哉善哉。善男子。汝能善問。我能善答。一切眾生。以不值佛故。邪見犯戒。誹謗正法。若佛在世。終無犯戒。誹謗正法。何以故。譬如長者。唯有一子。愛之甚重。若父在時。日夜教令。事事順之。其子孝順。受父教令。都無所犯。若父遠行。不時來還。其子忘誤[五六]。多有所犯。以不時來。唱言死滅。悲啼[口*睾]哭。復似起逆。愁憒失心。忘父本教。似若不順。謂如謗法。其父久時。遠行來歸。而子歡喜。憶父本教。受持不犯。以得見父。信知不死。不名墮逆。捉父本勅。順教而行。不名誹謗。善男子。長者即是如來。一子者即是一切眾生。令者即是教戒。遠行者即是餘化。不見父故即是唱滅。愁惱故即是障弊。不持故即是犯戒。唱滅故即是逆罪。迷理故即是誹謗。如來世尊。餘化廻來。眾生見之。即生信心。知佛不滅。佛為說法。還得本心。不名犯戒。以知不滅[五七]。不名墮逆。順教而[五八]行。於理得解。不名謗法。
    善男子。讀持是經者。即能消除無量生死煩惱重惡之罪。聞是經名。即得聞佛。見是經者。即得見佛。持是經者。即持佛身。行是經者。即行佛事。說是經者。即說佛事。解是經者。即解佛義。若行佛事。善解佛義。如此之人。永無煩惱。何以故。得值是經。斷除煩惱。
    善男子。若八萬劫以為一日。以是三十日為一月。十二月為一歲。以此歲數。過百千萬億[五九]劫。得值一佛。復過是數。得值一佛。此經難值。復過於是。得值此經。即值十方三世諸佛。是故智者。受持讀誦。書寫解說。能除邪見無明煩惱結漏重罪。住於福田。能除[六○]世間。無量供養。
    虛空藏菩薩白佛言。世尊。辟支佛尚不能消世間供養。何況凡夫得消[六一]供養。
    佛言。善男子。辟支佛不消供養。無有是處。雖不能說法度人。入禪三昧。從三昧起。現大神通。度諸眾生。得消供養。
    爾時。虛空藏菩薩白佛言。世尊。經中所說。邪見破戒。不得共一國同住。一河飲水。說戒布薩。懺悔自恣。此人名為。退失聖道。不入眾數。云何而言。得消供養。若消供養。即與諸佛。同受應供。過於羅漢。辟支佛等。唯願世尊。分別說之。我聞此已。亦為眾生。如佛解說。令得度脫。
    佛告虛空藏菩薩。善哉善哉。善男子。汝等今者。慈悲具足。哀愍眾生。而問此事。諦聽諦聽。善思念之。吾當為汝。分別解說。善男子。此經境界。非聲聞緣覺所知。亦非諸魔外道。凡夫思惟境界。唯佛能知。汝亦得達。善男子。我常為行菩薩道者。說施行檀[六二]。不觀好惡。福田成就[六三]。
    而說是言。布施畜生。得百福報。布施闡提。得千福報。善男子。斷善根者。死趣闡提。無慚愧者。死趣畜生。畜生闡提。果報熟者。尚能受供。種人福田。何況此人。以是義故。今此大乘。大通方廣。威德力大。不可思議。能使破戒五逆。誹謗正法。邪見煩惱。悉得除滅。能受供養。
    虛空藏菩薩白佛言。世尊。諸佛如來。不可思議。大通方廣。威神之力。亦不可思議。受持經者。其人功德。亦不可思議。佛言。如是如是。如汝所說。得不可思議無邊功德。
    爾時世尊。告虛空藏菩薩摩訶薩言。善男子。我念往昔。過去有劫。名曰清淨。我於此劫。供養九十二億那由他諸佛如來。以行小乘。多諸過罪。犯戒無量。是諸如來。不見授記。復過此劫。劫名樂見。我於此劫。供養四十二[六四]億諸佛如來。是諸如來。亦不見授記。復過此劫。劫名梵音。我於此劫。供養二十二億諸佛如來。是諸如來。亦不見授記。復過此劫。劫名心喜。我於此劫。供養八萬四千諸佛如來。是諸如來。亦不見授記。復過此劫。劫名救苦。國名莊嚴。佛號大施如來應供正遍知。十號具足。我於此劫。供養四十億諸佛如來。得聞此經[六五]。煩惱永除。自猶未覩。我於爾時。皆以一切不可思議供養之具[六六]。而供養之。是諸如來。亦不見與我授記。善男子。我於往昔若干劫中。供養若干諸佛如來。尊重贊嘆。煩惱得除。具足聲聞威儀禁戒。淨修梵行。學行佈施。一切持戒及行頭陀。離於憍慢瞋恚愚癡。忍辱慈心。如聞能說。懃行精進。一切所聞。受持不失。獨處遠離。入諸禪定。出禪定已。隨所聞慧。讀誦思議。是諸如來。亦不見授記。何以故。所受禁戒多毀犯故。深著聲聞二乘行故。不聞大乘方廣經故。以是義故。若諸菩薩摩訶薩等。應當遠離二乘之行。修集大乘方廣經典。則得授記。若我從一劫至另一劫[六七]。說是佛名。不可得盡。善男子。我過是後。得見定光佛。為無量大眾。說是大乘大通方廣。我於爾時。得聞得見彼佛所説[六八]。受持讀誦。思惟其義。即得無生法忍。定光如來。即授我記。汝於來世。當得作佛。號釋迦牟尼如來應供正遍知。是故。善男子。受持是經。疾至佛地。況消世間。人天供養。善男子。是故。大乘經典力施寶藏不可思議。惠施破戒貧窮依儀[六九]寶珠。善男子。大乘如大海。小乘牛[七○]跡水。大乘如須彌。小乘蟻子城。大乘如日月。小乘打失星[七一]。是乘名大乘。不可思議乘。容受諸眾生。猶如虛空中。一切諸乘中。此乘為第一。如是大乘者。超出一切乘[七二]。小乘有限量。不能度一切[七三]。唯此無上乘。悉能度眾生。若行此無量。虛空之大乘。虛空無有量。亦無有形色。大乘亦如是。無量無障礙。一切諸眾生。乘於此大乘。當觀是乘相。廣博多容受。若於無量劫。說大乘功德。及乘此乘者。不可得窮盡。一切諸乘中。大乘最為勝。至心受大乘。得趣菩提樹。無縛無障礙。今此無上乘。能勝下劣乘。坐於道樹下。觀於十二緣。哀愍眾生故。為說大乘經。十方諸眾生。若乘大乘者。亦復[七四]無增減。容受如虛空。大乘叵思議。神通大智慧。是故諸眾生。當懃修集之。一切諸天眾。天魔及外道。欲除煩惱縛。歸依於大乘。具足六神通。三明三達門。能壞魔外道。並及諸邪見。大乘最為要。能破諸煩惱。具足諸善根。是故大乘力。其實難思議。一切世間法。及以出世法。有學無學法。攝在大乘中。若有眾生行惡道。親近邪見惡知識。遠離此事歸大乘。若人不樂求大乘。不能破壞煩惱結。欲求解脫學大乘。若有大人解大事。聞說大乘心歡喜。當知即是大乘人。得心寂靜具神通。皆由大乘自莊嚴。若人有能行大行。是則不斷三寶種。若有趣向大乘者。是人即得無量福。能到十方諸世界。供養十方無量佛。如是大乘方廣經。世間諸乘無能勝。具足威德破生死。是故大乘難思議。得於[七五]色力得自在。具足成就常法身。若有乘此大乘者。是人受於無上樂。捨身自施修慈悲。是故得此無上乘。持戒精進修梵行。能以神通障日月。皆由久修大乘行。自心懃修常精進。是人則得於大乘。應有無量苦惱報。修集大乘得除滅。若能安住大乘典。長受快樂如諸佛。具足正念懃精進。獲四如意神通力。依止正法及真義。皆由久修大乘經。具足十力無所畏。相好莊嚴三十二。金剛三昧一切智。皆由修於大乘久。善男子。若有持此大乘經典。一字一句乃至一偈。永脫諸苦難。終不墮惡道。得到安樂處。於後惡世時。若得是經者。我皆與授記。究竟成佛道。若持此經者。佛常近是人。是人常近佛。是人護佛法。諸佛護是人。獲大神通慧。能轉大法輪。度諸生死趣。能破壞魔軍。我於定光佛。聞此方便經。住忍得授記。號為釋迦牟尼。於我滅度後。若有學是經。我亦與授記。若人來世中。能解此經義。為諸愚者說。佛雖不在世。不斷於三寶。亦如佛現在。所以者何。我從無量佛受持此經。於末劫中為人廣說。是以獲得三十二相。虛空藏菩薩白佛言。世尊。一切諸佛皆亦說此三十二相。佛今復說三十二相。是何業因之所成就。唯願世尊。當為說之。
    佛告虛空藏菩薩言。善男子。如來成就無量功德。是故得成三十二相。我若廣說。窮劫不盡。今當為汝。略而說之。善男子[七六]。如來至心護持淨戒得足下平相。修種種惠施故得手足千輻輪相[七七]。不欺一切諸眾生故得足跟傭[七八]相。護正法故得指纖長相。不破壞他故得指間網縵[七九]相。以妙衣服[八○]奉施故得手足軟相。以淨食施故得七處滿相。喜聞法故得鹿王膊相。覆藏他罪過故得馬陰藏相。修十善法故得上身如師子王相。常以善法化眾生故得缺骨[八一]平滿相。救護怖畏故得臂肘傭相。見他造三寶業[八二]樂佐助故得手摩膝相。常修萬善法故得清淨身相[八三]。常施病者藥故得所食之物至味[八四]悉現相。按時説善法[八五]故得師子頰相。於諸眾生心平等故得四十齒相。喜和合諍訟故得齒密相。以珍寶施故得齒齋相。身口意淨故得二牙白相[八六]。護四口過[八七]故得廣長舌相。成就無量功德故得味中上味相[八八]。於諸眾生常以軟語故得梵音相。修集慈心故得細長目相[八九]。至心求於無上菩提故得牛王[目*妾]相[九○]。贊歎他人所有功德故得白毫相。恭敬供養父母和上阿闍梨師故得肉髻相[九一]。樂說大乘法故得身柔軟相。喜施敷具房屋[九二]故得金光明相。遠離聚說世間故得一一毛孔右旋生[九三]相。樂受善友師長教勅故得一切支分汗毛上旋相[九四]。不以惡事加眾生故得髪色精相[九五]。常勸眾生修三昧故得圓滿如尼拘陀相。所生之處喜造佛像故得那羅延力相。善男子。菩薩摩訶薩成就如是無量功德。獲得如是三十二相。
    虛空藏菩薩白佛言。世尊。我觀諸法。都無相貌。又觀如來。亦非是行。云何而言。廣修諸行。我觀諸佛法僧。苦集滅道。陰入界等。十二因緣。諸波羅蜜。內外因果。空無相願[妨六]。不見出生。不見滅沒。如幻如化。如炎如響。如水中月。龜毛兔角。如空中之花。如石女之子。如著影衣。乘幻化象[妨七]。如有如無。及以有無。非有非無。非常非斷。非生非滅[九八]。非內非外。非見非識。猶如虛空。云何而言。我修諸法。我觀如來。亦非眾生壽命士夫。亦非眼非色非眼色相行[九九]。非耳非聲非耳聲相行[一○○]。非鼻非香非鼻香相行。非舌非味非舌味相行[一○○]。非身非觸非身觸相行[一○二]。非意非法非意法相行。非識非色非識色相行。非色非苦非色苦相行。非我非願。非行非陰[一○三]。非實非虛。非聚非散。非出非入。受想行識。亦復如是。非去非來。無有住處。無心意意識。無有身口意業。非一非二。非去來現在。非垢非淨。非我眾生壽命士夫。非常非斷。無生無滅。無修無行。無捨無受。畢竟常住。云何而言。廣修諸行。
    爾時。佛贊虛空藏菩薩摩訶薩言。善哉善哉。善男子。汝過去世時。曾已供養。無量諸佛。久達大乘。無上空義。了知萬法。皆悉空寂。亦知如來。畢竟常住。善男子。譬如清淨琉璃寶珠。雖在泥中。逕歷千年。其性常淨。出已如本。汝等今者。亦復如是。了知法相。本性清淨。汝等今者。雖在三界五濁泥中。助佛揚化。亦復不為泥之所污。以不污故。能問此義。善男子。汝今復聽。當為說之。一切萬法。實無相貌。有文字故。說言有法。法中無字。字中無法。為流佈故。說有文字。文字之中。亦無菩提。菩提之中。亦無文字。第一義諦。雖無文字。世俗道中。說有文字。眾生佛性。無上菩提。不離文字。善男子。實如所說[一○四]。如來無盡無生。不修不行。離諸修行。不入正位。亦不退轉。一生不生兜率陀天。不從天下。不處世胎。於一切法。心無所住。亦不說言。我已過去於生老病死。亦不四維七步而行。亦不自言。我是世間無上之尊。不處中宮婇女娛樂。不習世間伎樂之事。亦復不學槃馬角力。欲度眾生入涅槃故。示現老相為壞貪身。示現病相為壞貪壽。示現死相為壞貪欲及我我所。示現沙門相為令眾生不求梵天帝釋之身。懃求出世無上之法。踰出宮城示現出離三界牢獄。及顯此非終極之果故示現無瞋愛。是故三十二相莊嚴其身。為示眾生良佑福田剃除周羅棄捨瓔珞。遣馬令還放闡陀羅示現遠離一切煩惱。現剃鬚髪示現無貪著於一切法。受持袈裟示現調伏眾生。從欝陀伽阿羅邊諮問受法示現破壞自高之心。六年苦行為調伏外道。現受飲食隨世俗法。現受藁草示於知足。坐草褥上示壊憍慢。諸天龍神贊嘆恭敬示現功德莊嚴果報[一○五]。降伏外道示勇猛力。右手指地示作福力。大地震動示報恩故。修無相願。獲得無上菩提之道。示現了知一切法相。觀法平等。名之為佛。佛之智慧。無能勝者。所說法要。知去來現佛[一○六]。以是義故。名為如來。了了見知。三世之事。善不善法。名薩婆若[一○七]。真實語故。名天人師。若有學者。能作是觀。是名菩薩。若作異觀。不名菩薩。則名欺誑一切諸佛。善男子。一切諸佛。不出不入。不生不滅。為度眾生。唱言出世。為度眾生。唱言滅度。
    虛空藏菩薩白佛言。世尊。我實久知。法相理空。諸佛如來。無出無沒。不生王宮。雙樹不滅[一○八]。畢竟常住。為度眾生。修諸苦行。而入涅槃。實無動轉。諸佛如來。真實常存。應身三界。現五種法身。何等為五。一者實相法身。二者功德法身。三者法性法身。四者應化法身。五者虛空法身。所以名為實相法身。超越實相勝果。恒住法界。是故名爲實相法身[一○九]。所以名為功德法身。為度眾生[一一○]。施功積行。萬善備足。是故名為功德法身。法性法身者。達悟一切法相。理無不周。從境[一一一]生於空解。空解滿足。從境得名。稱為法性法身。何故名為應化法身。如來出世。備應五道。善惡悉現。物無不濟。從化物得名。是故名為應化法身。所以復名虛空法身。虛空無邊。法身無邊。虛空不可度量。法身亦不可度量。如來之身。猶如大虛。為度眾生。應身五分。故知如來。無生無滅。諸法亦爾。為度眾生。佛現法興[一一二]。
    爾時。佛告虛空藏菩薩言。善男子。汝與如來。同解法相。一切境界。無障無礙。善男子。未來有劫。名曰清淨。國名快樂。彼國悉以諸大菩薩論議大乘[一一三]。初不聞二乘之名。況餘惡道。汝於此劫。當得作佛。號曰清淨莊嚴佛如來應供正徧遍知。他方大方。皆往詣彼。聽受大乘大通方廣。是故一切眾生。若聞虛空藏菩薩名者。禮拜供養。皆得生彼快樂世界。若有眾生。求於大乘。未得無生[一一四]。受持是經。當知是人。不過十佛。使得授記[一一五]。

大通方廣懺悔滅罪莊嚴成佛經 卷中　終


中卷備註

中卷以大谷大學藏敦煌本為底本，經題為大正藏後加，首缺三千多字。二○○○年三月該三千多字於北京法源寺房山石經編委會所藏之拓本中發現。注釋中除注明出處的外，其餘皆依於胡老師根據拉卜楞寺版藏文經文的校注。
[一]原文為：惚，依藏文義應為惱。以下文中惱．原文皆作惚，不再一一注出。
[二]原文為：受．依藏文義改為壽。
[三]藏文為：無上菩提，依丁氏辭典，二者意義基本一致。
[四]原文為：勉，依藏文義應為免。以下文中免，原文皆作勉，不再一一注出。
[五]此處房山石經原文為「開演三寶□真依處」，留有一字空缺未刻，依藏文，特補「為」。
[六]橙：椅前放脚之凳。
[七]原文為：二。
[八]二應法身：依丁氏辭典，小乘謂王宮所生之身為生身，戒定慧等之功德為法身。大乘謂理智冥合之真身爲法身，隨糧現生之應化身為生身，即合法報應三身中法報二身為法身，應身為生身。藏文為佛於王宮。示現化身。
[九]藏文為：菩提樹下。
[一Ｏ]原文為：始。
[一一]原文為：亦名僧。
[一二]以：依靠之义。
[一三]惑：原文為或。
[一四]證結盡無：藏文為漏盡已滅。
[一五]崇：藏文為增。
[一六]難別：原文為取別。
[一七]軌用：藏文為行道之義。
[一八]法用：藏文為法寶。
[一九]法體：藏文為法寶。
[二○]麁：同粗。
[二一]八倒：原文為八到。
[二二]動求之苦：藏文為皆為緣起。
[二三]取證：藏文為究竟之義。
[二四]入：原文為八。
[二五]殺：原文為煞。
[二六]邪：原文為耶。
[二七]見世所樂：藏文為安立到樂處之義。
[二八]三惡：指三惡趣名字。
[二九]想：原文為相，依藏文義應通想。以下文中想原文皆作相，不再一一注出。
[三○]「菩薩如是。具足十法。斷除愚痴 」：為依藏文經義後補，原文為「菩薩□□□□□□□□□□□」。
[三一]原文為：無能為□。
[三二]閒：間之異體。
[三三]「行慈及大悲。身語意罪障。悉皆獲清凈」：為依藏文經義後補，原文為「行慈□□□□□□□□□□□□」。
[三四]前人：他人對方之義。
[三五]原文為：□佛所。
[三六]障：藏文為滅。以下同。
[三七]得先因力：藏文為依靠前世因緣之力之義。
[三八]財：原文為則．藏文為財利之義。
[三九]四憶念：即四念住。
[四○]障諸根：即令慣用守護根門之義。
[四一]獨處遠離：藏文為獨處静處遠離喧鬧。
[四二]此處至中卷首文字為本次發掘整理過程中在房山石經拓本中所發現，大正藏經文原缺，且與大正藏銜接部為「□無憍慢。三□□□法利□自顯現」，現依房山石經補上。
[四三]原文為：四者不示人垢凈青白。藏文義為不示人分別垢净之法，一律平等。
[四四]原文為：諸因緣，房山石經拓本此處為：諸法因緣。
[四五]攝法：指四攝法。
[四六]依此段文義取藏文義，指菩薩慈悲不捨眾生，為救拔一切有情出離苦難而現受六道輪回生死之中毫無怨言之義。原文為：一者離受無量生死。
[四七]受信施行：藏文義指受持信奉布施之道。
[四八]法界忍：藏文此處為忍波羅蜜。
[四九]入：原文為人。
[五○]「當與八萬久達佛慧法身大士。流通此經」：此處依房山石經校正，原文為「當與八萬久遠慧法身大士流通此經」。
[五一]藏文此處特指此經，原文為：大乘方廣經典。
[五二]藏文指無量國土的珍寶，原文為：無量國珍寶。
[五三]原文為：「能續三乘智慧。常命善男子」。疑斷句有誤。
[五四]度人：藏文指度別人的人。
[五五]此處依房山石經校正，原文為：此義雖明。
[五六]忘誤：此處依房山石經校正，原文為忘悟。
[五七]此處依房山石經校正，原文為：以不知滅。藏文亦為信之不滅之義。
[五八]原文為：人，藏文為：入；房山石經為：而，此處依房山石經。
[五九]此處依房山石經校正，原文為：百千億。
[六○]除：藏文為消受之義。
[六一]消：藏文為消受之義。
[六二]檀：藏文指檀波羅蜜。
[六三]「不觀好惡。福田成就」：藏文為不分別有情善惡的布施，則布施的福田圓滿之義。
[六四]藏文為：四十。
[六五]藏文為：得聞此經名字。
[六六]原文為：一切供善之具。
[六七]原文為：若我以一劫若滅一劫。
[六八]原文為：彼佛所，語義不詳，故依藏文。
[六九]依儀：藏文為讚頌．指法寶。
[七Ｏ]牛：原文為中。
[七一]打失星：打鐵時的火星。
[七二]原文為：如是大乘者□□□□乘。
[七三]「小乘有限量。不能度一切」，藏文此處無此數字義。
[七四]原文為：亦，為對仗整齊易于讀誦，故依藏文。
[七五]原文為：得，為對仗整齊易于讀誦，故依藏文。
[七六]藏文此處有善男子。
[七七]修種種惠施：藏文詳指供養寺廟塔及法；手足千輻輪相：原文為千輻輪相。
[七八][月*庸]：康熙字典亦無此字，疑爲臃之異體。
[七九]綢縵：原文為同縵。
[八Ｏ]炒衣服：原文為妙眼。
[八一]缺骨：即鎖骨。
[八二]造三寶業：藏文詳指建造大殿與塔。
[八一]清凈身相：藏文詳指身材宏直。
[八四]味：原文為鳴。
[八五]原文為：常發莊嚴修善法。
[八六]二牙白：藏文為牙白。
[八七]□過：藏文指語過。
[八八]藏文無此句義。
[八九]細長目相：藏文為目中無翳視物黑白分明相。
[九Ｏ]牛王[目*妾]相：眼睫毛象牛王的那樣修長美麗，保護眼睛不進塵埃。[目*妾]：依康熙字典，音潔，睫毛之義。
[九一]和上阿闍梨師：藏文為上師堪布阿闍梨等；和上：即和尚；肉髻：原文為內髻。
[九二]原文為：喜敷具。
[九三]原文為：得一一毛孔生相。
[九四]原文為：得身毛上靡相。
[九五]藏文無此句義。
[九六]指主、無相、無願。
[九七]原文為：多乘白鳥。
[九八]非：原文為無。
[九九]原文為：非眼色非色相行。
[一ＯＯ]原文為：非耳非聲非聲相行。
[一Ｏ一]原文為：非舌非味相行。
[一Ｏ二]原文為：非身非觸相行。
[一Ｏ三]願：藏文為我所；陰：指蘊界。
[一Ｏ四]實如所說：原文為實如説。
[一Ｏ五]此處依藏文之義重新斷句，原文為：欲度眾生示現老人。為壞貪身示現病苦。為壞貪壽示現死相。為壞欲及我我所示現沙門。爲令眾生不求梵天帝釋之身懃求出世無上之法。踰出宫城示現出離三界繫縛。及示非果前后故。示現無嗔愛。是故三十二相莊嚴其身。為示眾生良祐福田。剃除周羅棄捨瓔珞。遣馬令還放闡陀羅。示現遠離一切煩惱。現剃鬚髮。示現貪著於一切法。受持袈裟。示調眾生從欎陀伽阿羅邊諮問受法。示現破壞自高之心。六年苦行為外道現受飲食。隨世俗法現受藁草。示於知足坐草辱上。示懐憍慢諸天龍神讚嘆恭敬。示現功德莊嚴果耜報。闡陀羅：世尊的馬名。
[一Ｏ六]知去來現佛；藏文指了知三世諸佛如何成佛之義。
[一Ｏ七]薩婆若：指一切智。
[一Ｏ八]雙樹不滅：藏文指佛不於雙樹林入涅槃．
[一Ｏ九]藏文此處有：「超越實相勝果。桓住法界。是故名為實相法身」，手抄本校：「超越實相勝果。恆住自性。是故名為實相法身」。原文此處無數句，疑為遺漏，依藏文增補。
[一一Ｏ]藏文為：為利眾生入涅槃。
[一一一]境：原文為竟，依藏文經義，指境界，以下同。
[一一二]興：藏文為興盛之義。
[一一三]論義大乘：原文為論義大耳。
[一一四]無生：藏文作無生法忍。
[一一五]中卷後有：開皇十年（公元五九○年，隋煬帝時。校勘者注。）十一月二十日清信女董仙妃稽和南十方一切三寶令謹亡夫曾雅造此經一部流通供養願亡夫泳此善因遊魂凈土面覩諸佛永雖（疑為離）三途（亦多寫為塗）長超八難耳飡法音心悟智忍普共六道同向菩提。


大通方廣懺悔滅罪莊嚴成佛經卷下

    爾時[一]。釋迦牟尼佛因信相菩薩。為一切眾生及自己身。問諸佛名。佛說十方三世諸佛十二部經大菩薩僧已。復欲大師子吼。師子吼者。名決定說。決定說者。明知如來。常住不滅。并說眾生。盡有佛性[二]。諸魔怖畏。外道歸伏故。是名師子吼。如是顯説已[三]。舌遍覆三千大千世界。一切世界。六種震動。六種震動者。東涌西沒[四]。西涌東沒。南涌北沒。北涌南沒。中涌邊沒。邊涌中沒。是名大地六種震動[五]。舌根放大光明。大光普照。大光普照者。轉無常以為常。轉不淨以為淨。轉苦以為樂。轉無明以為明。爾時[六]佛光所照之處。山林國土。江河大海。鐵圍山川。一切地獄。高下平正。皆悉清淨。無諸穢惡。猶如東方清淨莊嚴滿月世界。
    爾時。釋迦分身諸佛[七]。從空化下[八]。猶如雨華。從地化出。猶如涌雲。遍滿虛空。間無空處。是時化佛。異口同音。皆言如來。常性不滅。說諸眾生。盡有佛性。并云諸法。皆歸於空[九]。萬行因果。皆歸一乘。眾生見之。說是語已。忽然不現。唯見釋迦。在本座[一○]上。當於爾時。一切大眾。皆見化佛。所以見者。皆是釋迦。威神之力。釋迦慈父。現此神通威德力時。是時眾中。四十恆河沙菩薩得無生法忍。八萬聲聞發大乘心。十千比丘得阿羅漢道。一萬[一一]八千比丘尼得阿那含道。四億優婆塞得斯陀含道。十億優婆夷得須陀洹道。無量天人得法眼淨。自識宿命。知有為法。悉皆無常。
    爾時眾中。師子吼菩薩摩訶薩。即從座[一二]起。正理衣服[一三]。頂禮佛足。而白佛言。世尊。如上所說。聞佛名亦滅罪。聞法名亦滅罪。聞僧名亦滅罪。為佛力。為法力。為僧力。如其佛力應求佛。如其法力應求法。如其僧力應求僧。何須求三。如上所說。唯有一乘。眾生見三。佛自說三。何況眾生。佛告師子吼菩薩摩訶薩言。善哉善哉。善男子[一四]。快問是義。利益眾生。諦聽諦聽。今當為汝。分別解說。非但佛力。非但法力。非但僧力。皆是眾力。佛是眾生歸處父母。菩薩僧者是證明知識。迷子眾生。若有惺悟。自生厭離。念力多故。求出三界煩惱大海。方廣經典為作大船。善男子。佛即是法。法即是僧。僧即無為。無為是空。無為空。有為空。內空外空。大空小空。皆歸一空。更無別空。善男子。汝向所問。應當求一。何須求三。善男子。譬如有人。怖畏虛空。處處遊行。藏護其身。不離虛空。善男子。十方佛說。及我所說。萬善因緣。三寶三乘。不過有一。為初中後善。一切眾生。分別說三。是故名為。一相三寶[一五]。師子吼菩薩言。善哉善哉。實如聖教。我以久知。為諸眾生。問如此事。
    師子吼菩薩摩訶薩復白佛言。世尊。如佛所說。無二無三。是方廣經典諸佛之母。菩薩大道。學者眼目。攝諸邪見。救護散失心。斷除三惡道[一六]。開無上菩提門。進[一七]諸聲聞。趣於大乘。我當以大陀羅尼呪。以守護之。淨持戒行。修學是經。亦當護之。或復有人。敬是經典。修行七日。或有惡魔。欲來惱亂。使諸惡魔。不得其便。世尊。我護是經。令得久住。盡菩提性[一八]。佛言。善男子。汝護是經。即護三寶。亦護行教者。
    爾時。師子吼菩薩。即於佛前。而說呪曰
    南無佛陀。南無達摩。南無僧伽。阿亶地。陀羅尼。多陀。呵阿伽闍尼。婆毗。薩婆達摩尼。婆毗。伊捨摩陀。毗婆舍那。毗摩羅修鉢離。達摩尼。佉那。婆樓尼叉夜。多摩隸遮隸。睺樓睺樓。師鞞帝。曼哆羅曼哆羅。娑訶[一九]。
    一讀百遍。右遶七匝。如是七日。一日三時。於其七日。勿念餘經。存心方廣。更莫異境。世尊。是陀羅尼呪。八百萬億諸佛所說。我今說之。若有謗此呪者。即為謗此諸佛如來。已謗此呪者。世世與道不成。不出三界。何以故。是呪能令失心者使得本心。是陀羅尼呪。一經於耳。聞以書寫。不食酒肉。齋戒自守。去離戲論[二○]。不入憒市。常行大慈。貴於坐禪。是人或從無量劫來。三障重罪。聞此呪已。至心受持。日日讀誦。經念不忘。是人乃至菩提。不墮三塗。
    佛告師子吼菩薩言。善哉善哉。能護三寶。慈念眾生。令出三有。說如是呪。大作利益。無量學人。開闡導教。斷諸邪見。善男子。一切眾生。聞汝名者。呪音聲者。信敬不毀。是人現世安穩。及其命終。常見諸佛。亦得見我。亦見汝身。並諸菩薩。自知得作佛。決定無有疑。一切見佛性。都由清淨信。萬善成佛道。會捨一切惡。佛言。若有善男子。善女人。能於我滅後。或復一日。或復一夜。或復一時。或復一念。禮拜三世十方諸佛。十二部經。諸大菩薩。心念大乘。思第一義。是人一念。一彈指頃。十惡五逆。及謗方等。一切惡業。悉皆除滅。無有遺餘。若有比丘。比丘尼。若菩薩。若沙彌。若沙彌尼。或失本心。身犯四重。八禁六重。十惡五逆。誹謗方等。今若生信。禮拜如是十方三世諸佛名者。如是惡業。悉得除滅。無有遺餘。作是語已。爾時定光佛時。善見王子與三千人俱。忽然之頃。來至佛所[二一]。頂禮佛足。同聲白佛言。世尊。我等或從無量劫來。造作惡業。不可具說。或犯十惡。或犯五逆。及謗方等。或造無量阿僧祇罪。求依如來。十二部經。諸菩薩眾。發露懺悔。唯願聽許。佛言。善哉善哉。善男子[二二]。怖心難生。善根難發。欲懺十惡。欲懺五逆。乃至一闡提。欲見佛性者。應當如是。隨意說之。
    爾時三千人。聞佛慈音。正理衣服。合掌作禮。偏袒右肩。右膝著地。作如是言。世尊。我等今者。歸命十方佛。歸命十方法。歸命十方僧。復次歸命稽首東方阿閦佛。亦復歸命南方寶相佛[二三]。稽首西方阿彌陀佛。亦復歸命北方勝妙佛[二四]。稽首上方香積如來。亦復歸命下方億像如來[二五]。稽首東方普賢大士。亦復歸命南方持世。稽首西方觀音大士。亦復歸命北方滿月。稽首上方虛空藏[二六]大士。亦復歸命下方堅德大士[二七]。稽首本師定光如來。亦復歸命未來佛性。稽首他方分身化佛。歸命今者我師釋迦。稽首大士維摩文殊[二八]。亦復歸命阿難迦葉[二九]。稽首出現四道聖人。亦復歸命有教初心。稽首大藏十二部經方等正典。亦復歸命諸餘經法。稽首八分舍利形像。亦復歸命現在諸佛[三○]。四方四王。忉利釋梵。三十三天。虛空天上。地上地下[三一]。有諸山林樹下。一切神仙。有大神足者[三二]。有天眼者。有天耳者。願使聞知。皆為證明。願一切眾生。若未懺者。皆得滅罪。作如是言。我等或從無始世界及今惡身。狂惑心亂。無量倒見。煩惱惡業。不可具陳。所作眾罪。不自覺知。惡心熾盛。不見後世。但見現在。樂習煩惱。遠離善根。惡業障隔。近惡知識。於比丘比丘尼邊作非法事[三三]。於父母邊作非法事[三四]。或復自在用僧鬘物[三五]。於五部僧邊或作是非。或說世間無量惡業。或殺菩提善根眾生。或謗法師。法說非法。非法說法。謂如來無常。正法無常。僧寶無常。不樂慧施。信受邪法。是故今日。無量怖畏。無量慚愧。歸依三寶。諸佛慈悲。方等[三六]父母。菩薩知識。聽許我等。發露懺悔。願除無量劫以來生死重罪。願後更莫造[三七]。
    復次世尊。我等或從無量劫來造作五逆。或犯過去未來現在諸佛禁戒。作一闡提行。發麁惡言。誹謗正法。造是重業。未曾改悔。心無慚愧。或犯十惡五逆等罪。自知定犯如是重事。本心初無怖畏慚愧。默受供養。未曾發露。於彼正法。未有護惜建立之心。於其中間。毀呰輕賤。言多過惡。或復說言。無佛法僧。或造如是。十惡五逆。無間重罪。是故今日。無量怖畏。無量慚愧。歸依三寶。諸佛慈悲。方等父母。菩薩知識。聽許我等。發露懺悔。願除無量劫以來生死重罪。願後更莫造[三八]。
    復次世尊。我等或從無量劫來。或四倒見。四重之法。說偷蘭遮。偷蘭遮法。說為四重。犯說非犯。非犯說犯。輕罪說重。重罪說輕。淨見不淨。不淨見淨。或復邪見。贊說世典。不敬佛經。諸惡論義。畜八不淨。真是佛語。以為魔語。真是魔語。以為佛語。或復信受。六師所說。或作是言。如來今日。畢竟涅槃。三寶無常。身心起惑。無量倒見。是故今日。無量怖畏。無量慚愧。歸依三寶。諸佛慈悲。方等父母。菩薩知識。聽許我等。發露懺悔。願除無量劫以來生死重罪。願後更莫造。
    復次世尊。我等或從無量劫來。及今一形。或犯招提僧物[三九]。或犯十方僧物。或犯現前僧物。或犯五部僧物。乃至一比丘物。一切檀越物。或復自稱。我得正法。四禪四果。緣是惡業。不善因緣。或本出家。造作四重。八禁六重。十三僧殘。二不定法。三十捨墮。九十一墮。四懺悔法。眾多學法。七滅諍法。或犯如是。一一諸戒。從突吉羅[四○]。復至四重。或復五逆。誹謗正法甚深經典。造一闡提行。覆藏不悔。日夜增長。曾聞佛說。若犯四重。乃至五逆。或謗正法。若不發露。定墮地獄。諸佛菩薩。聲聞緣覺。無能救護。師僧父母。諸天世人。亦不能救。是故今日。無量怖畏。無量慚愧。是故今日。歸依三寶。過去多寶。未來千佛。現在分身諸佛釋迦[四一]。諸佛慈悲。方等父母。菩薩知識。聽許我等。發露懺悔。願除無量劫以來。煩惱障。業障。報障。四重無間。十惡重罪。
    復次世尊。我等今者。為諸眾生。及自己身。十方佛前。今者懺悔。一切眾生。無量劫來。不識諸佛。及父母恩。不解善法。造作眾惡。自恃種性。及諸財寶。盛年放逸。作諸惡業。隨心所作。不見其過。凡夫愚行。無智闇覆。親近惡友。煩惱亂心。五欲因緣。心生忿恚。不知厭足[四二]。故作眾惡。親近非聖。因生慳嫉。貧窮因緣。而造諸惡。及以女色。姦諂作惡。繫屬於他。常有怖畏。不得自在。諸結惱熱。貪欲恚癡。嬈動其心。渴愛所逼。造作眾惡。身口意惡。所集三業。是眾罪等。今悉懺悔。或不恭敬。佛法聖僧。如是眾罪。今悉懺悔。或不恭敬。菩薩緣覺。如是眾罪。今悉懺悔。以無智故。誹謗正法。不知恭敬。父母師長[四三]。如是眾罪。今悉懺悔。愚惑所覆。憍慢放逸。因貪恚癡。造作諸惡。如是諸罪。今悉懺悔。我今供養。十方諸佛。願諸眾生。令住十地。悉令具足。如來正覺。
    爾時。佛告善見王子。善哉善哉。大士大士。自能觀身。不善惡業。生大怖畏。發露諸惡。復為眾生。懺悔眾罪。以是名汝[四四]。是真大士。自離眾惡。復令眾生。遠離眾惡。是故名汝。是真大士。不自願身。先願眾生。令得正覺。是故名汝。是真大士。
    爾時。善見王子三千人。懺悔以訖。以偈贊佛
    唯佛一人獨第一　　三界父母一切智
    於一切等無與等　　稽首世尊希有比
    凡人行惠為己利　　求報以財而給施
    佛大慈仁無此事　　怨親憎愛以等利
    大精進人我歸命　　佛二足中尊最上
    智慧眼人能知見　　諸天不解此智慧
    過去未來今諸佛　　一切我皆稽首禮
    如是我今歸命佛　　亦如恭敬三世尊[四五]
    爾時。十方諸佛。即為善見王子及三千人。而說偈教[四六]
    若欲求佛道　　常隨多聞人　　如事善師想[四七]
    成佛亦不久　　若持戒清淨　　是名實比丘
    若有能觀空　　是名得三昧　　若有能精進
    是名行道人　　若有得涅槃　　是名為實樂
    持戒大沙門　　大戒清淨尼　　半月常布薩
    結淨行乞食　　身被僧伽梨　　衣鉢行隨身
    諸天皆歡喜　　恭敬合掌禮　　我使諸天人
    以為作給使　　亦如諸小天　　奉事天帝釋
    今日得現報　　未來不可量　　出家持禁戒
    是名報佛恩　　復次善見王　　除我及菩薩
    世間一切人　　心生清淨信　　了知十方佛
    常住不涅槃　　法僧亦復然　　如是諸人等
    是名報佛恩
    復次善見王　　世間一切人　　心無分別相
    了知一乘道　　過去並未來　　十方及現在
    唯有一佛乘　　無二亦無三　　若能發是意
    心無分別相　　如是諸人等　　是名報佛恩
    復次善見王　　若能有一人　　於我滅度後
    心常生信解　　皆言諸眾生　　悉有如來性
    如是諸人等　　亦名報佛恩　　若修一念善
    不求天果報　　直向無上道　　亦名報佛恩
    復次善見王　　於我滅度後　　若能有一人
    須臾讀是經　　敬重佛法僧　　孝順供養師
    如是諸人等　　亦名報佛恩　　若人捨一財
    飮[四八]食及衣服　　普施諸大眾　　亦名報佛恩
    復次善見王　　於我末法中　　有能化一人
    須臾聽是經　　復勝別供養　　百億菩薩眾
    如是大乘經　　諸佛菩薩母　　念佛敬是經
    並諸菩薩眾　　等心無彼此　　是名報佛恩
    復次善見王　　有能末法中　　若欲報佛恩
    一念在禪定　　勝活三千界　　滿中一切人
    謗禪壞亂眾　　如殺三千界　　滿中一切人
    及諸眾生類　　謗禪壞亂眾　　其罪亦如是[四九]
    若人見修善　　誹謗不信受　　斷壞三寶種
    不名報佛恩
    爾時。善見王子三千人。蒙佛教已。歡喜頂受。重說偈言
    我等今者　　稽首過去　　未來現在
    三世諸佛　　亦復歸命　　釋迦文佛
    稽首八萬　　四千法藏　　亦復歸命
    諸餘經法　　稽首過去　　維摩文殊
    亦復歸命　　多聞大智　　阿難舍利
    稽首無學　　五分法身　　亦復歸命
    始學初因　　稽首以訖
    重說偈言[五○]
    諸佛說何實　　何者是不實　　實之以不實
    二事不可得　　如是真實相　　不戲於諸法
    憐愍眾生故　　方便轉法輪　　諸聖所從來
    佛示如是來　　實相及所去　　佛亦爾無異
    諸聖如實語　　佛亦如實說　　以是故名佛
    多陀阿伽度　　忍鎧心堅固　　精進弓力強
    智慧箭到利　　破憍慢諸賊　　應受天世人
    一切諸供養　　以是故名佛　　以為阿羅漢[五一]
    正知苦實相　　亦實知苦因　　知苦盡[五二]實相
    亦知苦盡道[五三]　　真正解四諦　　定實不可變
    是故十方中　　號三藐三佛　　得微妙三明
    清淨行亦具　　是故號世尊　　鞞闍遮羅那
    解知一切法　　自得妙道法　　或時方便說
    愍念一切故　　滅除老病死　　令到安穩處
    以是故名佛　　以為修伽陀[五四]　　知世所從來
    亦知世盡道[五五]　　以是故名佛　　為路迦鞞陀
    戒定慧等眼[五六]　　無及況出上　　以是故名佛
    為阿耨多羅　　大悲度眾生　　軟善教調御
    以是故名佛　　富樓沙曇藐　　智慧無煩惱
    說最上解脫　　以是故名佛　　提婆魔[少/兔]舍[五七]
    三世動不動　　盡及不盡法[五八]　　道樹下悉知
    是故名為佛
    爾時。十方諸佛入神通三昧。而自舉身。處於空中。異口同音。唱如是言。是善見大士及以三千人。汝等罪性。不在外。不在內。不在中間。心實故善力實。心解故罪性解。空慧故罪性空。信力故福力多。若能如是懺悔者。則為己見我。亦見多寶佛及諸分身者。懺悔滅罪。以常見我今日教化諸菩薩。如是懺悔者。令我及分身。滅度[五九]多寶佛。一切皆歡喜。十方現在佛。並過去未來。亦見亦供養。亦令得歡喜。順此大乘經。得入菩提門。
    佛告諸弟子。有罪欲懺悔。當如善見王。禮是三世佛。十二部尊經。諸大菩薩僧。一一心禮。亦如遭我想。值我想。見我想。見一佛想。二佛想。十佛[六○]想。見百佛想。千佛想。萬佛想。亦如見無量佛想。如是一一心禮。是人福德無量。滅除生死重罪。阿僧祇劫中。不墮三惡道。安住於佛道。決定無有疑。是故悔諸罪。至心諦信之。定得滅重罪。
    爾時。善見王子三千人等。俱發聲言。以偈贊佛
    世尊大慈悲　　釋種大法王　　處眾師子吼
    普攝諸眾生　　視眾如一子　　無彼亦無此
    以見無上尊　　是故今敬禮
    爾時。佛告善見王子及以三千人等。若能如是。發露懺悔。不覆藏罪。是真菩薩。汝於來世。必得作佛。復次善男子。於我滅後。有能眞[六一]心禮是十方諸佛。十二部經。諸菩薩僧者。是名報三寶恩。即滅十惡五逆及謗方等。滅是罪已。應以須陀洹得度者。授與須陀洹果。應以斯陀含得度者。授與斯陀含果。應以阿那含得度者。授與阿那含果。應以阿羅漢得度者。授與阿羅漢果。應以闢支佛得度者。授與闢支佛果。應以菩薩得度者。授與菩薩果。今是經中諸大菩薩摩訶薩。得一生實相。皆由禮是十方三世諸佛。或有菩薩得二生法界[六二]。皆由禮是三世諸佛。或有菩薩得畢竟智。皆由禮是三世諸佛。或有菩薩得悟第一義諦。皆由禮是三世諸佛。或有菩薩得首楞嚴三昧。皆由禮是三世諸佛。或有菩薩得虛空三昧。智印三昧。皆由禮是三世諸佛。或有菩薩得不退忍。如法忍如法界忍[六三]。皆由禮是三世諸佛。或有菩薩得陀羅尼。大念心無礙智。皆由禮是三世諸佛。或有菩薩得師子吼三昧。金剛三昧。五智印三昧。皆由禮是三世諸佛。或有菩薩得平等三昧。大慈大悲阿耨多羅三藐三菩提佛行。皆由禮是十方無量三世諸佛。
    爾時。文殊師利法王子菩薩摩訶薩而白佛言。世尊。一切眾生。狂惑心亂。造作惡逆。云何自知。而得滅罪。
    佛告文殊師利。如上所說。若人聞是方廣經典。及[六四]聞十方三世諸佛名。十二部經。諸大菩薩[六五]。心生歡喜。無量信敬。書寫受持。讀誦通利。空淨之處。淨治一室[六六]。香埿[六七]塗地。以好幡蓋。莊嚴其內。先燒好香。然後請佛。不問多少。香水洗浴。著淨衣服。一上廁一洗浴。安置寶座[六八]。久修是經。了知法相。無人我見[六九]。請命令上。分別稱揚[七○]。燒好妙香。一心除亂。正憶正念。一心念佛。是諸行人。和合為上。若不和合。瞋恚諍訟。不名懺悔。瞋恚俱懷。與道相違。想念大乘。思第一義。七日七夜。不得眠臥。一日三時。讀誦是經。日夜六時。燒香供養。禮拜懺悔。稱是經中諸佛菩薩。十二部經名號[七一]。心心不亂。心心不錯。心心不異。心心時進。心心日進。心心生信。心心歡喜。心心相次。心心相續。心心深重。心心不離。心心思罪。心心念佛。心心念法。心心念僧。心心念戒。心心念捨。心心念天[七二]。是人如是讀誦。如是禮拜。如是至心。如是懺悔。從初一日。至第六日。復以香埿塗地。復以香水浴身。燒種種妙香。深心供養。以此至心。是人懺悔。震動十方。我於爾時。與無量無邊恆沙諸佛。無量無邊恆沙菩薩。隨其音聲。入其室內。與作證明。如是七日。定得滅罪。净除罪業。決定無疑[七三]。所以知者。凡夫之人。未合真諦。當取夢相。若見一夢。即滅一逆[七四]。見此五夢。即滅五逆。是人其夜。夢見自身。欲渡大河。上大橋行。當知是人。定得度脫。其人或時。夢見自身。人與洗浴。天雨其身。當知是人。定得清淨。其人或時。夢見自身。入沙門大會之中。入次而坐。當知是人。真佛弟子。其人或時。夢見自身。入塔寺中。見好大像。及見菩薩。當知是人。得正門已[七五]。其人或時。夢見自身。自得菓食而食。當知是人。還得果報[七六]。
    佛告文殊師利。若有比丘。比丘尼。菩薩。清信士女。沙彌。沙彌尼。失心錯亂[七七]。身犯如是。一一禁戒。如是懺悔。若不滅罪。無有是處。除不至心懺悔者外[七八]。
    文殊師利問佛言。世尊。行此法時。得多人不。佛言。一人以上。二十人以下。行此法時。亦勿曾念諸餘經典。從此悔已。後更莫造。是名悔法。應作是念。我等今者。如死還活。我當持戒。我當精進。我當讀誦大乘方等。是人爾時。應作是念。從今日始。堅持禁戒。願如金剛。是人作是念時。維摩大士。復與無量菩薩。立其人前。為作時證。大德普賢。為作羯磨。大德迦葉。與作依止。佛告文殊。是名滅罪。是名解脫。是名具戒。是名得住[七九]。
    爾時世尊。復告文殊師利菩薩摩訶薩言。若有犯四重八禁。六法十戒。三歸五戒。八禁十善。一一戒律。乃至五逆。及謗方等。除一闡提。若不懺悔。發露諸罪。其人命終。決定必墮。阿鼻地獄。
    文殊師利白[八○]佛言。世尊。云何名為阿鼻地獄。唯願如來。為一切眾生。說其因緣。形狀大小。苦樂受報。劫數多少[八二]。
    佛告文殊。快哉快哉。快問是義。諦聽諦聽。及諸大眾。善思念之。吾當為汝。廣開分別。云何名為。阿鼻地獄。阿者言無。鼻者言間。間無暫樂。故言無間[八二]。阿者言無。鼻者言遮。阿者言無。鼻者言救。阿者言無。鼻者言不動。阿者言極熱。鼻者言極惱。阿者言不閑。鼻者言不住。不住不閑故。名阿鼻地獄。阿者言大火。鼻者言極熱。猛火入心故。名阿鼻地獄。
    佛復告文殊師利菩薩摩訶薩言。善男子。阿鼻地獄。縱廣正等。八萬由旬。七重鐵城上。有七重鐵網。下有十八鬲[八三]。周匝七重。是皆[八四]刀林。其七重城內。復有劍林。下有十八鬲。其一一鬲。八萬四千重。於其四角。復有四大銅狗。其身長大。四十由旬。眼如電光。牙如劍樹。齒如刀山。舌如鐵鉤。抓如鐵杈。尾如鐵蟒。一切毛孔。皆出猛火。其煙臭惡。世間臭物。無以可比。其獄四門。一一門邊。復有十八獄卒。頭如羅剎頭。口如羅剎口。頭上十八角。手捉鐵叉。七重城內。有無數鐵幢[八五]。幢頭火涌。如沸涌泉。其鐵流迸。滿阿鼻城中。阿鼻四門。其一一門上。復有十八銅釜。沸鐵涌出。四門漫流。滿阿鼻城[八六]。一一鬲間。復有八萬四千鐵蟒大蛇。吐毒吐火。身滿城中。其蛇哮吼。如天大雷。雨大鐵丸。滿阿鼻城中[八七]。此城苦事。八萬億千。苦中苦者。惱中惱者[八八]。皆集此城。阿鼻地獄。四方有門。一一門外。各有猛火。東西南北。交過通徹。八萬由旬。周匝鐵牆。鐵網彌覆。其地亦鐵。上火徹下。下火徹上[八九]。四維上下。周匝一時。苦事俱起。如上所說。四重八禁。犯戒五逆。及謗方等。若不依此經中懺悔。而無慚愧。其人命終。如大壯士。屈申臂頃。落入阿鼻地獄。身滿其中。熱腦急故。口噤不語。唯復張眼合口。合口張眼。此人罪故。萬億刀輪。從空而下。頭入足出。一切苦事。過上所說。百千萬倍。若有具犯四重。受大苦惱。具足五大劫。八禁復倍。五逆復倍。謗方等經復倍。謗三寶。偷僧祇物。污淨行比丘。污比丘尼。謗師害師者[九○]。若人姦母。如此人等。復倍加上。除一闡提。永斷善根。不出阿鼻。是等罪人。受苦之時。猛火入心。悶絕而死。獄卒羅剎。以鐵叉打地。喚言活活。應聲即活。一日一夜。萬死萬生。受大苦惱。如上所說。其人從阿鼻地獄出。以破戒因緣。虛食信施。復入諸小十八地獄。所謂寒冰地獄。黑闇地獄。燋熱地獄。刀輪地獄。劍輪地獄。火車地獄。沸屎地獄。濩湯地獄。灰河地獄。劍林地獄。鐵床地獄。銅柱地獄。鐵機地獄。鐵輪地獄。鐵窟地獄。鐵丸地獄。尖石地獄。飲銅地獄。各八百萬歲。然後得出。常生下處。五百世中。不識三寶。值善知識。得發菩提。不值知識。還墮地獄。犯突吉羅罪。若不懺悔。地獄受苦。如四天王日月八百萬歲。波夜提罪復加二倍。僧殘罪復加二倍。是諸罪人。受苦之時。更無餘言。唯得唱言。阿波波。阿吒吒。阿羅羅。阿婆婆[九一]。是故有罪。當急懺悔。還歸三寶。
    復次。文殊師利菩薩摩訶薩。若欲速疾除滅罪者。如是經中。懺悔發露。行道七日。一日一食。思惟正觀。憶念如來成佛時。大人相。覺人相。不動人相。解脫人相。光明人相。滿智慧人相。具足諸波羅密相。首楞嚴等諸三昧海相。菩薩摩訶薩。從勝意慈三昧起入滅意定。從滅意定起還入首楞嚴定。從首楞嚴定起入慧炬三昧。從慧炬三昧起入諸法相三昧。從諸法相三昧起入光明相三昧。從光明相三昧起入師子音聲三昧。從師子音聲三昧起入師子奮迅三昧。從師子奮迅三昧起入師子振动三昧。從師子振动三昧起入海意三昧[九二]。從海意三昧起入普智[九三]三昧。從普智三昧起入陀羅尼印三昧。從陀羅尼印三昧起入普現色身三昧。從普現色身三昧起入法界性三昧。從法界性三昧起入師子王三昧。從師子王三昧起入滅諸魔相三昧[九四]。從滅諸魔相三昧[九五]起入空慧三昧。從空慧三昧起入解空相三昧。從解空相三昧起入大空智[九六]三昧。從大空智三昧起入遍一切處色身三昧。從遍一切處色身三昧起入觀心相三昧。從觀心相三昧起入菩薩摩訶薩金剛相三昧。從菩薩摩訶薩金剛相三昧起入金剛頂三昧。從金剛頂三昧起入一切海三昧。從一切海三昧起入一切陀羅尼海三昧。從一切陀羅尼海三昧起入一切佛境界海三昧。從一切佛境界海三昧起入一切諸佛解脫解脫知見海三昧[九七]。從一切諸佛解脫解脫知見海三昧起然後入無量無邊諸三昧海[九八]門。從諸三昧海門起入寂意滅意三昧[九九]。從寂意滅意三昧起入金剛喻定[一○○]大解脫三昧門。
    佛告文殊。於我滅後。若有善男子。善女人。生一念信心。若能書寫讀誦一偈。念是相。憶是相。觀是相。信心成就。一念之頃。除卻九十億那由他恆河沙等微塵數劫生死重罪。永離闇障。明知如來。常住不滅。
    爾時世尊。為諸大眾。重說偈言
    力士諸鬼神　　畜生惡象王　　婬女及惡龍
    無量諸惡人　　婆藪阿闍世　　提婆殃崛魔
    身心起逆罪　　應墮阿鼻獄　　生信禮三世
    十方無量佛　　釋迦臨涅槃　　為住無量劫
    摩伽陀國人　　悉發菩提心　　皆由恭敬禮
    十方三世佛　　阿若憍陳如　　五百聲聞等
    來世成佛道　　皆由恭敬禮　　十方三世佛
    外道婆羅門　　十仙大梵志　　今[一○一]得阿羅漢
    乃往過去世　　皆由恭敬禮　　十方三世佛
    自悟第一義　　十方佛土中　　一切菩薩眾
    往生無量壽　　皆由恭敬禮　　十方三世佛
    復次善見王　　我昔作國王　　名曰大仙與[一○二]
    佛日未出時[一○三]　　供養出家人　　五百婆羅門
    飲食及衣服　　房舍及臥具　　悉滿二十年
    我時即告言　　師等發菩提　　是諸婆羅門
    雖復受供養　　實不信三寶　　師便答我言
    世間無菩提　　及以無解脫　　我等聞是語
    實護方等經　　斷是婆羅門　　五百人命根
    是人命終已[一○四]　　即墮阿鼻獄　　既墮地獄已
    即時發三念　　禮是三世佛　　敬信方等經
    大士菩薩僧　　作是三念已　　即時出地獄
    往生甘露鼓[一○五]　　壽命十小劫[一○六]　　皆由生信心
    敬禮十方佛　　是諸波羅門[一○七]　　初謗墮地獄
    後信便得出　　況汝大菩薩　　具足慚愧者
    本自實無罪　　為諸眾生故　　懺悔四重禁
    及以五無間　　乃至一闡提　　若有凡夫人
    身犯如是罪　　若能如是懺　　除滅四重禁
    五逆一闡提　　必得成佛道　　唯除不信者
    若有信解心　　恭敬禮諸佛　　不成無是處
    爾時善見王　　及以三千人　　同聲白佛言
    若我等得[一○八]佛　　願度生死流　　唯願天人尊
    為我分別說　　其有受持者　　書寫及讀誦
    功德為云何　　佛言善見王　　汝今當善聽
    吾為汝說之　　若人以七寶　　供養千世界
    施與一切眾　　復能善說法　　化得羅漢果
    不如有一人　　聞是諸佛名　　乃至一念信
    或復一時[一○九]禮　　其福復過彼　　何況讀誦書
    敬信禮拜者　　功德不可量　　若人能書寫
    受持及讀誦　　發心時禮拜　　勝以起塔寺
    遍千世界中　　爾時大迦葉　　阿難舍利弗
    護塔金剛士　　諸梵及帝釋　　轉輪四天王
    頭面禮佛足　　同聲白佛言　　如來去世後
    我等當流佈　　教化諸眾生　　護念禮拜者
    得心[一一○]常安隱　　或犯破重禁　　五逆謗方等
    使得聞[一一一]佛名　　安住清淨地　　亦如善見王
    來世見佛性
    爾時。釋迦牟尼佛告諸大眾。汝等善聽。我今為汝。說本因緣[一一二]。我於往昔。過無量劫。於妙光佛所。聞是十方三世佛名。心生歡喜。合掌頂受。在在處處。教化無量無邊眾生。聞是佛名。爾時眾中。唯有三千人。共我法儀。生無量信心。從我禮拜。是諸佛名。今覩現在[一一三]十方悉皆成正覺。
    佛告大眾。諸善男子。欲滅四重。無間重罪。謗大方等。一闡提罪。皆由信心。復次善男子。若人不信。輕呰不敬。則為謗此十二部經。及謗金剛色身[一一四]。及謗大士文殊師利。及以謗此十方諸佛。是人定墮地獄而無虛也。何以故。而不信故。謗正法故。謗上人[一一五]故。謗一切十方三世佛故。定墮地獄。信是佛名。至心禮拜。若不除滅。十惡五逆。及謗方等。無有是處。唯除不信者。斷善根人。一闡提者。諸善男子。百億釋迦。一一分身。國土教化。末後釋迦。則我身是也
    爾時所將三千人等[一一六]。今皆成佛。初千人者。華光為首。中千人者。樓至[一一七]為首。後千人者。彌勒為首。是故汝等。應當禮敬如是十方三世諸佛名號之者。汝於來世。當為大眾。開闡道[一一八]教。廣濟群盲。令出三界。寂然閑居。安處道場。如我無異
    爾時陀羅尼菩薩。即從坐起。正理[一一九]衣服。合掌恭敬。而白佛言。世尊。當何名此經。云何奉持。云何修行。
    佛告陀羅尼菩薩。善男子。是經名為大通方廣。亦名懺悔除罪得福。如是受持。亦名三千人莊嚴成佛經。如是受持。廣大無對。如是受持。普攝一切。如是受持。無量藏門。如是受持。金剛寶藏。如是受持。濟諸重禁。如是受持[一二○]。
    陀羅尼菩薩白佛言。世尊。如佛所說。是經如是。唯大利益。無量眾生。滅罪成佛。是經即是。諸佛之母。菩薩之道。聲聞之眼。天人之舍。有如是等。不思議事。我當受持。天上人中。在在處處。廣宣流佈。常使不斷。令得久住。
    佛言。善哉善哉。如是大士。總持無量。一切大藏。當於來世。坐我座處。行我行處[一二一]。
    佛說是經時。無量菩薩住不退不動地。八萬聲聞發大乘心。十千比丘得阿羅漢果。八萬四千天人得法眼淨。百千眾生髮阿耨多羅三藐三菩提心。
    佛說是經已。金華寶池。忽然不現。佛攝光明。娑婆世界。高下不淨。穢惡如本。人行惡故。地獄如本。說是經已。發向娑羅。一切大眾。歡喜奉行[一二二]。

大通方廣懺悔滅罪莊嚴成佛經　卷下　终


下卷備注
卷下大正藏以知恩院藏寫本為底本，以大英博物館藏敦煌本S.1847互校之。注釋中注明出處的外，其餘皆依於胡老師根據拉卜楞寺版藏文經文的校注。
[一]原文為：□□。
[二]原文為：□說眾生盡有佛□。
[三]「諸魔佈畏。外道歸伏故。是名師于吼。如是顯說已」。原文為「□魔怖畏外道歸伏故□□□□□□□□□□□ 」。
[四]藏文為東高西低之義。
[五]原文為：是名六□□□□□□。
[六]原文為：□□。
[七]釋迦分身諸佛：即釋迦佛無量化身之義。
[八]從空化下：即從天而降之義。
[九]「說諸眾生。盡有佛性。并云諸法。皆歸於空」。原文為「說諸眾生皆有□□□□□法皆歸於空」。
[一Ｏ]座：原文為：坐。
[一一]原文為：萬。
[一二]座：原文為：坐。
[一三]正理衣服：原文為正衣服。
[一四]藏文此處有善男子。漢文原無。
[一五]原文「為初中後善。一切眾生分別說三。是故名為一相三寶」，此數字義，藏文中無。
[一六]「救護散失心。斷除三惡道」。原文為「救護失□□三惡道」。
[一七]進：藏文為回轉之義。
[一八]盡善提性：藏文為一直到成佛之義。
[一九]原文無斷句，依藏文斷句。
[二Ｏ]戲論：原文為論戲。
[二一]原文為：「善見王子與三千人 俱忽然之頃來至佛所」，疑斷句有誤。
[二二]藏文此處有善男子，漢文原無。
[二三]藏文為：寶生佛。
[二四]藏文為：不空成就佛。
[二五]藏文為：妙色身如來。
[二六]虛空藏：原文為虛空。
[二七]堅德大士：原文為堅德。
[二八]藏文為無垢稱大士。
[二九]迦葉：音加設，飮光之義。
[三Ｏ]現在諸佛：原文為現有佛事。
[三一]藏文此處無地下二字義。
[三二]原文為：有大神足。
[三三]「於比丘比丘尼邊作非法事」：原文為「於比丘邊作非法。比丘尼邊作非法」。
[三四]「於父母邊作非法事」：原文為「於父母邊作非法」。
[三五]僧鬘物：依丁氏辭典，此為梵語，譯為對面施之物。
[三六]方等：依丁氏辭典，為周徧之義，藏文為遍一切虛空之義。
[三七]原文為：願又更莫造。
[三八]同上。
[三九]招提僧：依丁氏辭典，為四方僧之義。招提乃梵語！，四方之義。
[四Ｏ]突吉羅：五無間罪。
[四一]現在分身諸佛釋迦：原文為現在分身諸來釋迦。
[四二]「五欲因緣。心生忿恚。不知厭足」：藏文為：「五欲因緣。不知厭足。心生忿恚」。
[四三]師長：藏文中明確指出為堪布、阿闍黎。
[四四]汝：原文為以。
[四五]三世尊：原文為二世尊。
[四六]偈教：藏文為偈頌。
[四七]想：原文為相，依藏文義應通想。以下文中想原文皆作相，不再一一注出。
[四八]原文為欲。
[四九]「謗禪壞亂眾。其罪亦如是」：藏文此處無此二句義。
[五Ｏ]自此上溯至「我等令者。稽首過去」，藏文此處無以上數句義。
[五一]阿羅漢：原文為阿羅呵。
[五二]苦盡：依上下文義，當屬四諦的滅諦。盡：藏文為寂。
[五三]苦盡道：依上下文義．當屬四諦的道諦。
[五四]伽陀：即偈頌。
[五五]盡：藏文為邊際。
[五六]戒定慧：原文為禪戒智；眼：藏文為觀察之義。
[五七]提婆魔[少/兔]舍：藏文為指天及人的導師。
[五八]盡：藏文為邊際。
[五九]滅度：依丁氏辭典，為般涅槃之義，而藏文此處無此義。
[六Ｏ]十佛：原文為七佛。
[六一]原文為：直。
[六二]二生法界：藏文義為於第二生得法界空性。
[六三]法界忍：原文為法界
[六四]原文為：反。
[六五]十二部經諸大菩薩：藏文特指十二部經諸大菩薩名號。
[六六]原文為：「心生歡喜無量。信敬書寫受持讀誦。通利空凈之處凈治一室」。疑斷句有誤。
[六七]香埿：特指雪山牛糞加六香等。
[六八]座：原文為坐。
[六九]原文為：無我見人。疑文字有誤，故依藏文。
[七Ｏ]「請命令上。分別稱揚」。藏文為初者應當分別明白宣說。
[七一]原文為：「十二部經。諸大菩薩」，藏文特指十二部經諸大菩薩名號。
[七二]此段中「心心」，藏文為「至心」。
[七三]「如是七日。定得滅罪。凈除罪業。決定無疑」：原文為「如是七日。定得滅」。
[七四]一逆：即一個無間。
[七五]得正門已：藏文為已經入門之義。
[七六]還得果報：藏文為現得功德果報。
[七七]失心錯亂：藏文指信心失壞。
[七八]除不至心懺悔者外：原文為除不至心。
[七九]得住：指定。
[八Ｏ]白：原文為自。
[八一]多少：原文為多小。
[八二]無間：原文為無聞
[八三]鬲：音格。層之義。
[八四]皆是：原文為是皆。
[八五]幢：原文為憧。以下文中幢原文皆作憧。
[八六]原文為：「復有十八銅釜沸鐵。涌出四門漫流滿阿鼻城」。疑斷句有誤。
[八七]原文為：「其蛇哮吼如天大雷雨。大鐵丸滿阿鼻城中」。疑斷句有霰。
[八八]原文為：腦，依藏文義應作惱。以下文中惱原文皆作腦，不再一一注出。
[八九]原文為：「周匝鐵墻鐵網彌覆其地。亦鐵上火徹下。下火徹上」。疑斷句有誤。
[九Ｏ]師：藏文詳指堪布阿闍黎。
[九一]吒：藏文音耷，羅：藏文音拉。
[九二]「從師子奮迅三昧起入師子振動三昧。從師子振動三昧起入海意三味」：原文為從師子奮迅三昧起入海意三昧。
[九二]智：原文為知。
[九四]滅諸魔相三昧：藏文此處為法王三昧。
[九五]同上。
[九六]智：原文為知。
[九七]解脫、解脫知見：屬五分法身後二種。五分法身，即戒定慧從因受名，解脫、解脫知見從果受名，由慧斷惑斷惑惑無之處名解脫，出纏破障反觀照心名解脫知見。
[九八]無量無邊諸三昧海：藏文此處為喻方便海。
[九九]寂意滅意三昧：藏文此處為滅及寂三昧。
[一ＯＯ]金剛辟定：藏文此處為金剛喻定。辟疑為譬。
[一Ｏ一]今：原文為念。
[一Ｏ二]與：藏文為布施之義，原文為譽。
[一Ｏ三]時：原文為昧。
[一Ｏ四]是人：指五百婆羅門。
[一Ｏ五]甘露鼓：佛土名。
[一Ｏ六]壽：原文為：受。
[一Ｏ七]婆羅門：原文為波羅門。
[一Ｏ八]得：藏文此處為作。
[一Ｏ九]一時：藏文指一剎那。
[一一Ｏ]得心：藏文此處為身心。
[一一一]使得聞佛名：原文為使得佛名。
[一一二]本因緣：指釋迦佛過去世本生因緣。
[一一三]令覩現在：藏文此處為於今普照。
[一一四]金剛色身：藏文此處為金剛不壊身。
[一一五]上人：藏文指上師。
[一一六]藏文此處為我及三千人等。
[一一七]樓至：藏文此處為金剛身。
[一一八]導：原文為道。
[一一九]藏文為整理之義。
[一二Ｏ]藏文此段為：是經名為重罪得福。如是受持。亦名金剛寶心。如是受持。無量藏門。如是受持。普攝一切。如是受持。廣大無比。如是受持。三千人悉皆成佛。如是受持。懺悔還凈得福。如是受持。大解脫遍一切方。如是受持。
[一二一]藏文為：「行我行處。坐我座處」
[一二二]下卷尾有「知識數二十七人下寸主水通勢部座麿造奉。
天平三年十一月十六日奉」


《大通方廣懺悔滅罪莊嚴成佛經》
    ——藏傳佛教《聖大解脫經》漢文本尋找、發掘和整理略記

    《聖大解脫經》的漢文本是今年二月在本人的至尊恩師雍和宮的拉西仁勤喇嘛啟發和指導下開始尋找的。這部經文是藏傳佛教三大解脫經之一，在蒙藏地區持誦得十分普遍，並且有為亡故的眷屬持續念誦此經四十九天的習俗。為激勵弟子們的善法意樂，上師多次強調這部經文對當今眾生懺悔業障十分重要，具有很大加持力，並答應儘快按藏傳佛教儀軌給弟子們傳這部經。幾年前，賽倉活佛也曾敦促北京居士尋覓過此經的漢文本，雖然沒有找到，但從《藏漢大辭典》中查知《聖大解脫經》有對應的漢文本，經名為《佛說大方廣解脫懺悔梵行淨罪成佛莊嚴經》。這個線索非常重要，依據這個經名提供的關鍵詞，終於在北京法源寺中國佛學院圖書館首先查到了一部線裝手抄本的經文（藏書編號no.2871），它的經名為《大通方廣懺悔滅罪莊嚴成佛經》，與《藏漢大辭典》中的經名極為類似，經上師核查，它的內容完全符合藏文《聖大解脫經》的內容，因此可以斷定，它就是《聖大解脫經》的漢文本。這部手抄本實際是一部與藏文《聖大解脫經》對照的校譯本，校譯者姓氏不詳，從紙張和字跡上推斷，成文至少已五六十年。在佛學院性慈法師的指導下，最終在《大正藏》中找到了《大通方廣懺悔滅罪莊嚴成佛經》——也就是手抄本的出處。
    《大通方廣懺悔滅罪莊嚴成佛經》，又名《大通方廣經》，分上中下三卷。近代日本學者在編纂《大正藏》時，分別從四處（日本松本文三郎氏藏敦煌本、大谷大學藏敦煌本、知恩院藏寫本以及大英博物館藏敦煌本s.1847）搜集到了經文的絕大部分內容，這些內容主要來源於敦煌藏本，經整理校勘後，連綴成文，收錄在《大正藏》第八十五卷（倒數第二卷），很少引起人們的注意。
    周叔迦居士的《法苑叢談》一書曾援引《廣弘明集》上的記載：此經在梁朝前後，是與《金光明經懺》併列的、非常盛行的懺法之一，當時還有依此經製定的《大通方廣懺》，然而後來由於種種原因，不幸佚失。在《大正藏》中收錄的此經，沒有譯經的朝代和譯師的姓氏，只是中卷的結尾有如下一段文字：「開皇十年（公元590年，隋煬帝時。校勘者注。）十一月二十日清信女董仙妃稽和南十方一切三寶今謹亡夫曾雅造此經一部流通供養願亡夫泳（疑為沐）此善因遊魂淨土面覩諸佛永雖（疑為離）三途長超八難耳飡法音心悟智忍普共六道同向菩提。」這段記錄向我們披露了這部敦煌藏經底本的造經原因及年代，真可謂年代久遠。如果沒有二十世紀初敦煌藏經洞的發現，這部經文不知還要隱沒到何時。
    由於收錄的經文原件年代久遠的緣故，文中有許多缺字的地方，急待校勘。因為《大正藏》收錄的這部經文是目前已知的唯一的漢文版本，所以，校勘工作衹能借助於藏文的《聖大解脫經》，因此，在這方面，這部手抄本的校勘者作出了巨大的貢獻，是他們首先發現並確立了《聖大解脫經》與《大通方廣經》之間的聯係，為校勘《大通方廣經》找到了依據。然而，手抄本雖然通過藏文《聖大解脫經》補譯了一些缺字之處，但是中卷卷首仍缺三千五百多字沒有補譯。
    由於當時精通漢藏經文的善知識們的利他工作都十分繁忙，很難抽出時間在近期完成這項補譯工作，因此讓《聖大解脫經》漢文本——佚失千年之久的《大通方廣懺悔滅罪莊嚴成佛經》儘快面見世人，將成為一個迫在眉睫的問題。在焦急躊躇中，本人偶然於北京法源寺房山石經編委會，在法映法師的幫助下查找到了《大通方廣經》的拓本（編號 8 洞 0682）。不可思議的是拓本的內容僅為中卷卷首的前三頁，多餘更無，除二十多字因石碑年久風化無法辨認外，其餘恰好將《大正藏》中所缺的三千多字基本補齊，就好像為了這一天這部分經文專門等候在那裡似的。這個進展不僅使全文的補譯總工作量減少至少至八十餘字，而且保持了原譯風貌，令人驚喜異常。
    房山石經洞歷史上曾多次打開，最近的一次為二十世紀五十年代，比敦煌藏經洞的發現晚五十多年。從事幾十年房山石經整理工作的法映法師十分高興，對此項工作的意義給予了充分的肯定。據老法師講，在房山石經拓本中，這是一部「無頭」經，很特殊，僅有中卷前三面碑文，更奇怪的是中卷的起始並沒有承接上卷的結束，而是銜接在《阿彌陀經》之後，多年來並沒注意到這麼一小部分片段竟恰好是《大正藏》中一部年代久遠的經文所缺的部分。這一切確實應驗了當年高僧大德和帝王們不惜花費大量人力物力和漫長的時間營建藏經洞的初衷，那就是當世上經文不存在的時候，藏經洞中還有。古代先賢大德們不可思議的宏深願力和殊勝功德所輻射出的光芒，超越了時空以及一切的障礙，至今依然澤被著我們後人┄┄。
    從房山石經中尋找到的這部分經文的內容主要包括為命終之人三稱三寶名字薦拔超度的方便、一相三寶的開示以及針對菩薩的大量的教誡——菩薩大慈大悲之喻、菩薩所應受持的十善法和十法、於惡世中行菩薩道的殊勝、對菩薩的勉勵和菩薩成就菩提所應修行的四法。這些內容對惡世末法眾生意義極其重要。
    獲此進展後，本人隨即向另一位至尊恩師胡繼歐居士請求幫助補譯此經，胡老師雖已年近八十，仍然非常高興地接受了請求，與藏文本對照通校了全部的《大通方廣經》。前後歷時三個多月，共校譯十三次。當時正值北京酷暑，其間胡老師帶病仍堅持校譯工作，使人深受教育（至尊的胡繼歐老師於本經校勘結束四個月後圓寂）。《大通方廣經》終於以最快的速度、完整地與世人見面了。
    這部經文的緣起本身就極具殊勝加持力，感人淚下。它是我們的本師釋迦世尊去娑羅樹涅槃途中宣講的經文。釋迦世尊臨欲涅槃的時候，心中仍充滿了對我們罪苦眾生的極大悲憫，再賜淨除罪障的方便，教令稱念十方三世佛和菩薩名號以及十二部經名。另外，本經內容十分豐富：不僅宣講了懺悔淨罪的殊勝法門，包括參加修持的人數、天數和占夢的驗相等，還宣講了三乘是一乘、別相三寶、一相三寶、薦拔眾生的方便、無上空義、成就菩薩道的方便、佛的本生故事、對虛空藏菩薩的授記等等。經中講，此經比佛更難值遇。我們的本師釋迦佛曾經歷劫修行，供養無數諸佛，但僅僅得聞一次此經的名字，並未親眼得見此經。而後又經多劫修行，終於定光佛時得聞得見此經，並得授記。經中還講，得見此經的人，就等於見到了本師釋迦佛，並且會得到釋迦佛的授記；若人受持此經，就能滅除一切煩惱重罪，饒益一切眾生，功德無量，十方佛土，隨意往生┄┄。
    這部歷史上曾僅存名字的經典，一百年前終於振落掉了敦煌藏經洞千年的塵封，它先輾轉飄零於異國他鄉，而後又在它的故土上與房山石經洞的藏經完整地會聚一處，最終在大悲上師三寶的覆護之下，漢地眾生從藏傳佛教系統又重新接續上了《大通方廣懺悔滅罪莊嚴成佛經》殊勝的無間斷的傳承加持，使《大通方廣懺悔滅罪莊嚴成佛經》的法門得到了再次的弘揚，無量的眾生將因此而證得解脫┄┄。每當想起所有的這一切，心中就湧起了對大悲上師三寶無限的感恩與思念┄┄。
    在尋找、發掘和整理這部經文過程中，始終貫穿著本人至尊恩師拉西仁勤師父的耐心細緻的指教和關懷，使得一個個的困難最終得以克服。另外，在整理和助印方面，很多善信居士們都付出了辛勤的勞動和最熱情的支持，感人至深。
    此次校勘還僅是一個初級性的工作。在校勘過程中，本人遵從上師的要求，作了一些文字整理工作，由於水平和時間有限，可能會有許多訛誤疏漏之處，敬請批評賜教，祈請上師三寶容恕。
    雖願承辦盡赤誠，然由惡業過失多，今對師佛善信前，至心懺悔祈加持。
    佛說真實解脫經，師賜不共解脫經，虔誠精進求解脫，解脫一切父母眾。

    二000年九月 承辦者謹識