封面

阿格旺波尊者自传
迦造堪布译
中华佛典宝库制作 2005.3.28


目录

序言
奇妙幻化戏论
    第一章
    第二章（一）
          （二）
          （三）
          （四）
    第三章（一）
          （二）
二十五本生传
阿格旺波零星传记
阿格旺波再显化身松吉泽仁仁波切略传
阿松堪布简介
译后语


序言

《阿格旺波尊者自传》

    序一
    两年前，应噶陀佛学院阿松堪布为首的喇嘛、扎巴僧众及汉族诸弟子、护法居士的请求，把《阿格旺波尊者自传》译成汉文以利群生。对挑起翻译、整理、发行《传记》重担的迦造喇嘛深表谢意；向发心校对、出资流通该《传记》的善信致以深切的祝愿。
    同登彼岸 共证佛果

谨此
    老僧松吉泽仁
    2002年3月1日

    序二
    比马米扎真身无垢光，
    是为宏法利众而降生。
    再显化身阿格旺波尊，
    祈请住吾心轮密宫中。
    尊者三密奇妙又殊胜，
    示现优美动听文字相。
    何人眼见耳闻即解脱，
    如此微妙怎不生信心。
    阿格旺波自传此法宝，
    是为后学诸弟子实修。
    由藏译成摩诃震旦文，
    我献随喜功德之鲜花。
    普贤王如来密意宝库，光明金刚心要即身成佛的教诫，三传承持明上师的言教，光明大圆满窍诀部妙法。为教证、讲授密续广行班智达宗写了《七宝藏》，深见古萨里窍诀〈荟萃〉而成《四心髓》。把不同根器的诸有情都接到究竟道而成就虹化。
    大遍知者隆钦绕江巴智美俄色再显三具金刚持，披黄袈裟，显比丘身的大堪布阿格旺波从诞生到圆寂的事迹，闻、思、修以自利，讲、辨、著以利他来宏扬佛法利益有情的传记，朴实无华的文句，真实无误的奥义，让人见即生信心，闻即息妄心，忆即解脱等无量无边的功德。
    阿格旺波的心子大圆满瑜伽士堪布明色的亲弟子迦造喇嘛，精通汉藏文化，广闻显密经论，实修殊胜正法，以讲、闻、译来宏法，翻译经论来利生。他所译的自传词句优美，句义精确，通俗易懂。今翻译事毕，行将付梓，使广大读者成欢喜的供品云。我也随喜功德，并献赞美花与吉洋词。
    老牧人 土登尼玛
    2002年7月27日

    序三
    嗡，梭帝！
    这《自传》的前言，要讲一点圣地五百位班智达的首位班智达比马米札和雪域智者之王遍知者隆钦饶降巴等的再显化身、大善知识、噶陀寺的大堪布阿旺巴桑，本尊赐名为俄萨仁钦宁波白玛愣遮杂。他的名号像日月般闻名于世界，是一位真正的贤哲、转法轮者。他生于藏历圣胜周852阴土兔年(公元187830.年)，在多康四河六冈之一的珠达色莫冈中，有一游牧部落叫瓦宿昌科。富裕清净氏族家里，是与奇妙的瑞相同时诞生的。他从童年时代起，完全超越了一般凡夫的行为而显出神通和智慧，受到所有人的尊重。从青年时代起，就生起了真正的出离心，进入佛道之门，依止了多位具有善知识相的上师，闻思显密经论与文化等，彻底断除了增益。在寂护法师的传承下出家并受具足戒，从未犯过任何戒律，没有点滴微尘之垢，常常散发出持戒的芳香。完全没有自利涅槃的私心，而以伟大的利他菩提心，直接和间接地以四摄、六度来行持如大海般的菩萨行，给所有有缘的有情赐予了大菩萨的果位。特别是在寂静的山上，静静地实修了禅定和本尊，因而在一生中亲见了诸多上师和本尊，证得了光明大圆满二次第道圆满准确无误的证相。在宁玛巴传承系统的法源、东方佛道场——噶陀金刚宝座的佛学院担任了十三年堪布，在这期间，以无边三藏续部的讲、辩、著来弘扬佛法、利益众生，因此对宁玛巴的法脉贡献极大。正因为如此，没有分别的贤哲大德们都纷纷赞美说：“佛教的功德似第二佛祖”。与他有缘的亲弟子无数，其中大部分都作了弘法利生的伟大事业，而且还在不断继续着。他著有心意伏藏净相类、窍诀口耳传承类以及经论注释类十多函法宝，并现证了无碍的神通乃至十地五道的至高境界、无漏的智慧。很早就说寿命六十三换刹土，转世将诞生在贡波地区德吉康萨家族，其真实金刚语无增益地现量了。总的来说，尊者的智慧、持戒、成就三方面和智、悲、力三方面，在整个雪域都无以伦比，这不是为修饰而赞美，而是上师自己所写的具有加持力的《自传》尚有空行母余温的窍决，看后就会明白了，在此不加多说。
    此《自传》传播的地方比较广，会有一些文字上的出入。这一部是由上师自己的母稿所誊抄和用茫康甲色寺的木刻、卫藏拉萨的木刻等版本对勘的。今后凡有传、讲、译的弘扬者不用生疑。
    顶触着黄袈裟的法王金刚总持阿旺巴桑波的莲足，所有弟子中最下等，有个行头陀行的虚名者桑吉多杰，写于十六胜圣周土猴年十二月十八日，在印度的北方邦噶拉境内多吉林山山腰——修行自然解脱光明顶上自己的禅堂中写毕，愿利他的事业遍满虚空。
    奇妙幻化戏论
    顶礼诸佛菩萨！
    何人领悟本性缘起法，如实传授有缘众有情，
    越渡无明苦海至解脱，顶礼本师释迦牟尼佛。
    不同次第之乘诸法门，深广法义结集者菩萨，
    智慧文殊无能胜弥勒，顶礼龙树无著传承师。
    清净无碍智慧之意中，发出本性无尽大悲心，
    自然明智法性普贤王，顶礼祖师金刚大总持。
    自显五方佛主菩萨众，无量无边功德受用物，
    闪耀本净大圆满之光，顶礼遍空佛陀意传承。
    佛陀九十六法之功德，为用表记殊妙证现量，
    成就无漏自净身果位，顶礼持明表记传承师。
    众多空行母云之中央，妙行密乘殊胜瑜伽师，
    清净有情度化雪域众，顶礼海生金刚莲花佛。
    普贤如来直至根本师，口授耳闻语义断戏论，
    登地证道示现应化身，顶礼口耳传承持明者。
    遍知父子传承如意宝，持有无量窍妙之口诀，
    语无缺重意无错谬误，如是证悟白玛愣遮杂。
    犹如瓶瓶相灌无疏漏，大乘密法口诀传记法，
    无有丝毫点滴虚构词，乐为有缘众生造此传。
    这本《自传》是为对我具足信心的后学弟子们写的。从正等觉圆满佛到自己的根本上师及历代传承祖师都曾有写《自传》的传统，在此我想通过《自传》来讲述一下清净的传承和殊胜的窍诀。末法时代持法师名的我，在无边无尽的六道轮回中，由于受不可思议的业力役使，除了无有自主地漂泊外，没有什么登地证道等功德可谈，就连资粮道的功德和微细的证相都没有。正如《人道论》中说：“宣讲自己之功德，帝释天也不恰当。”说自己的功德是不应该的！但是，在众多对我具有信心的圣人、大德多次请求下，为了满足他们的愿望，就从大地尘埃那么多的过失中，把只有黄金那么少的功德，如实地写出以下三方面内容：
    第一，从出生至童年时期；
    第二，生起求法心，依止善知识，在上师那里闻思显密经论；
    第三，虽然自己没有修证，但还是作了利他的模样。


第一章

    《空行心髓》中说：“明皎雪山之东方，铁箱燃烧似上区，野牛横睡背座上……”这授记指出我的多世的出生地，可概述如下：多康四江六冈之内，珠达色莫冈附近，二十五大圣地之一，噶陀香波绒格[日/阿]屙瓦事业之事业圣地的东方，在古今历代圣者贤哲们修持过的道场，林莫白玛扎嘎神山的脚下，有一个紫董氏的后代，其中白林分为大、中、小三种族，属于小种族的拉如强盗七兄弟之一林子阿扎的后裔属辽西这个游牧小部落。在这个部落里，囊杰是我的父亲；母亲名叫白玛措，是金沙江畔扎多久瓦部落的康巴人。我于十五绕迥土兔年十月初十清晨，出生在像一头野牦牛横睡似的措达良夏山背座上。据说，当时看到了彩虹和听到了法螺声，出生后的第三天早上作了盘腿禅定的样子，口中念诵：“嗡，班杂格里格拉雅”等一百多遍咒语。我妈妈说从这以后，我的头就能抬起来了，有不再哭和不再随地大小便等许多特殊功德。我自己用心回忆的话，从出生到现在的事情，大部分都能清楚地想起来。
    在八个月时，我没经历过爬行就能站立走路。当地老牧民有一种说法：“婴儿过早站立走路是不祥的预兆”。
    这年冬天的一个晚上，我睡在妈妈的怀里，子时做了一个梦，梦见妈妈是一位黑色的女人，脸上有很多皱纹，显现忿怒相，露出锋利的獠牙，用朱红色的头发盖着我，我非常害怕，惊恐地叫出：“妈妈……！”妈妈说：“你叫什么？我在这里。”我一看，妈妈确实就在身边。从这以后，我就会说话了。
    同年冬天的又一个晚上，天气异常寒冷，我和妈妈睡在一起，被冻得全身发抖，我持气观修拙火定，很快生起了暖乐，妈妈好像坐在大火旁一样热得难受，于是把我从怀里拉出来说：“你不像人的儿子，是哪个魔的儿子吧？”我唱着回答说：“我是东方拉卜愣寺，自在气脉明点拙火，成就本尊密集金刚，名叫阿拉日扎识否？”妈妈说：“不认识，不认识。”突然又把我用力拉回怀里，说：“从此不准你说‘我是这个，我是那个’这类话，如果哪天有人实实在在说你是某某上师转世，那只有把你送给他们，除此之外，不要随便多说话！”从此，我就没有讲过这类话了。第二天早晨，我奶奶问：“昨天晚上，你们母子俩说什么话？”妈妈回答说：“没有，没有，是他说梦话。”
    我经常做同样的一个梦，梦见在印度一个很美丽又不可思议的地方——巴森尸陀林和它穹尸陀林，我在那里轮番修炼，有时是出家人的样子，有时是瑜伽士的样子。密乘护法一髻佛母和罗睺罗有时现真身相，有时现化身相来护持我。从那时一直到十三岁，每天傍晚天快要黑的时候，都有九只鹫从空中飞来，刹那显出骷髅相，在我周围旋绕着跳起金刚舞。他们来到跟前时，我手里自然就会有甘露丸，当分给他们吃后，这些骷髅便会非常欢喜地跳着舞蹈飞向空中。
    我那非常仁慈的奶奶做我的养母。在一岁左右的时候，我每天都睡在她的怀里。每当快入睡时，耳边会响起如雷般“轰隆隆”的声音，这时候，一切境相就像阳光照射在大雪山上一样，只是白茫茫一片，过了一会就变成比较浓厚的红色光蕴，像霞光笼罩一般，使心住在朦朦胧胧的昏昧中，接着很快又被裹在一个浅蓝色境相中。此时的心沉沉的，什么也想不起来，又过一会，心就会安住在明空无边无相的境界之中。同时，自己的所有境相都遍满了五色光，其中有很多像树枝一样的光团和不可思议的大小明点发出无尽的光芒，特别是很多像刀枪一样锋利的光刺入眼睛，使我害怕而不敢入睡。告诉奶奶后，她用灯光照着说：“什么也没有嘛！”
    三岁时的春天，我看见一头犏牛犊陷进泥潭里，它出不来，又死不了，不断发出悲惨叫声。我心想它以前做了很多恶业，现在正受恶报，实在很痛苦，而且还要继续痛苦下去，又没有一个人能从泥潭里把它救出来，那就让我来解除它的痛苦吧！于是我将牛犊拉出泥潭，放在干净地方，由于不会颇瓦法的观想，就把心识观想为豌豆大小的白光，把这个光送往上空，念了很多遍“供养上师三宝，呸！呸！”后，牛犊断气时顶门冒出了热气，据说还掉了一团毛和拇指般大小的头盖骨。我的伯伯是一位老喇嘛，对我父母说：“这不是一般人能做得到的，不要给别人讲。”由于这个缘故；我只要看到或听到众生受苦，就会自然生起慈悲心，并深信六道轮回的苦与乐、贫与富、贵与贱等等都是无常！我的心境经常很沉重，总想找到一种令众生都能得到解脱的法门，为此常常沉默不语。每次看见穷人来乞讨，我都会想方设法地找些财物公开或暗中送给他们，并跟随乞丐走遍全部落去助讨。父母亲说：“他的这种行为不是好的征兆。”我经常想为穷人办事，生来就有这样的慈悲心，并认为这是大乘根器的人都应具备的，这也是我主要的功德。小时候，我常念诵六字真言，已念满了一千万遍。我出生在一个较富裕的家庭，家里有非常多的牛羊等牲畜，每年家里都要屠杀许多菜羊，每当看到这种情景我都要跑到山上去，油然生起了无法忍受的悲心，我没有救助它们的能力，为此深感愧疚而泪如雨下。
    五岁的冬末，我随母亲去牧场，住在仁莫帝久狭沟的下游。开春季节，上游雪山融化，雪水冲坏了我们的小帐蓬和牛栏，因而每天都要去筑堤坝，又累又烦。有一天，我把一个小木桩削成金刚橛，洪水来的时候，就手持金刚橛对着洪水说：“我是印度贝玛拉，恒河也能使倒流，莫说你这小沟水！妈妈请看奇妙戏！嗡，班杂格里格拉雅呸！”说着便转动着金刚撅，只见山上流下的洪水改道了，像被风吹走一样。妈妈说：“做得好！做得好！”这洪水绕道流走的痕迹至今可见。
    七岁时，叔叔对我说：“现在是该学文字的时候了。”于是就写了三十个字母教我。他教“嘎”字时，我就读到“卡”字去了，没有重复念他教的字母。叔叔说：“嘿！不要跑到前面去，应一个字母一个字母地读，不然学不会！”我这样读了两三遍后，就可以全背下来了。叔叔不高兴地批评我说：“你要一个字母一个字母地认，光会背就像里塔一样。”里塔是一个最不会认字的老人，叔叔用他来比喻我，并交给我一根木棍说：“用棍指着一个字母一个字母地念。”念了几遍后叔叔又说：“哎！哎！现在可以念《普贤行愿品》了！”于是就教了《普贤行愿品》中七支供养部分的拼读，用了二十多天才学完。由于我是小孩，每天都早睡一些。有一天晚上，大人们还在聊天，吃东西，我在梦里把《普贤行愿品》从头到尾背诵了一遍。叔叔听到后高兴地说：“不用学了。”从此他也不再教我学文字了。
    后来他交给我一本噶陀传承的仪轨法本说：“以后就念这个。”读完这法本后又对我说：“如果会读《闻解脱仪轨》的话，就算你读得好。”于是就交给我一个法本，我说：“这是我的法，怎么不会读呢？！”接过法本后便念了起来，除了其中系解脱部分的几个咒语读得不准确外，其它都会念，没有需要更正的。叔叔认为很奇妙。由于那时没有学拼读的原因，所以现在拼读也不太熟练。后来叔叔对我说：“现在应该学《莲花生本生传》。”我念了几遍后就感到莲花生大师对西藏的恩德比三世诸佛还大，因而对莲师生起了不可改变的信心，并常念《七支祈请文》和莲师心咒，在夜晚作恶梦时也能想起莲花生大师，并会叫出：“莲师知！莲师知……”。
    有一次，一位女人来给我当向导，她领着我像鸟一样飞向西南方上空，所过之处看到很多不同的地方，那女人都一一作了介绍。过后，看见一个有铁围墙的大国，一刹那降落在北门口，益喜措嘉空行母手持白银宝瓶为我沐浴。同时来了一位实际是当金·多吉勒巴的白色大丈夫，将我从铁围墙东门带进城，看到了铜色吉祥山光明宫殿，从南门进入后见到宫殿里雄伟庄严，中央美丽的八瓣莲花上有塑像一样的八相莲师，我以猛厉的虔信心念诵《七支金刚祈请文》后，看到塑像的外壳浮云般消失了，里面显出八相莲师真相，莲台的每一瓣上都有三千大千世界，并且有一尊佛陀和一尊莲师，我在莲师前得到了一个灌顶，后来想这个灌顶很像伏藏大师热那林巴的意修仪轨灌顶。莲师还对我说：“你年满二十五岁就会成为大自在眼天子。”廿五岁时，我学完了一切经论，可能就是授记这件事吧！当时，我虽然还是一个没有成熟的学童，对上面那些甚深密义很难理解，但对那些法要还是明了的。
    八岁那年夏天，爸爸带我赶着很多牦牛去远方，牦牛到处乱跑，我赶不了，爸爸就很生气的责骂我，这使我想到：六道轮回的每个角落都充满痛苦！我发誓要为众生解脱而修持佛法，但如果不完全断除亲属的束缚，就会变成轮回的枷锁，我一定要放下名、利、吃、穿，寻求一位好上师，实修佛法！我想如果妈妈同意的话，就马上走。于是向妈妈讲了这些想法和外出修法的打算，妈妈却说：“你这么小的娃娃要逃跑，是不是着魔了？连吃的也找不到，逃出去狗会咬死你的，要不是被狗咬死也得饿死。你暂时不要走，附近也有好上师，等你长大了，再去修法也不迟。”妈妈讲了很多道理，我只有留下来了。这时，感到苦与乐，贫与富，贵与贱都是无常的，就这样自然生起了出离心。
    我每天把古汝曲旺的伏藏经典《千佛名号》作为必修课念诵，看到名称赞妙王和法音海二佛名号的功德时，发愿为度化无量众生要像这二位佛的成就，让众生证得二位佛陀那样的果位。我小时候本来就是一个有正知正念不放逸的人，特别是认为与女人说话交往等，是最忌讳的事，所以老人们都叫我“小喇嘛”。我每天上午背诵五十页短页的经文，后来在竹庆寺，一天之内背下了所有仪轨和《明了三戒》。假如我是一位黄教的格西，可能是最会念诵的人了。协钦寺的绕江仁波切来到我家乡时说：“你是我们寺的仁波切，赐名为丹巴绕泊。”十八岁的竹庆仁波切来此地“夏季化缘”时给我剃度，并赐名为协努白玛勒珠。知普觉吉夏珠大堪布罗珠伽造给我灌了萨迦传承的大日如来顶，赐名阿旺巴桑波并说：“如果你去潘波拉楞扎寺(那烂陀)的话，将来对弘法利生会有很大功献。”还说第二年再来康巴地区时要带我去，但他那一年却圆寂了，我也没有去成。
    有一次，我和很多僧人一起为一俗家作佛事，念诵《般若经》和《度母经》。当时我是给大家斟茶的，没把茶水倒好，有一个叫松吉俄热的老喇嘛生气地说：“你眼睛看好茶碗倒。”我说：“我眼睛怎么看？今天不都在念没有眼睛，没有耳朵吗？”他说：“那你说为什么‘没有’？”我说：“你先说怎么‘有’。”他说：“唉呀！你这小孩，为什么说这样的大话，嘿嘿！”我也不会讲怎么‘没有’，但我心里一直在沉思这个问题。后来，我们家的帐蓬搬到了齐柯，每天早上要把牦牛放出去，下午又要往回赶。在一个叫米协拉卡的地方，我看到很多草蓬里面住着比丘，跑到一位比丘前问：“您是谁？”“我是月称。”我请求加持后问：“我以前到一俗家去念《般若经》，和一位老喇嘛争论有没有眼睛和耳朵的问题时，他不会讲‘有’的道理，我也不会讲‘无’的道理，这是？”月称回答说：“要懂得二谛的安立和生起因缘的关系后才能懂得‘有’与‘无’。”“这又是什么道理？”“眼耳鼻皆非真实，色身心亦非真实，若是诸根为真实，圣道对谁有何用？！”他就诵了这个偈作为回答。我再问：“这又是什么意思？”“你现在还是个小孩，没有开发智慧，如果慢慢思考，这些道理就会明白的。”最后我向这位比丘求了一个法，他把一本《释入中观论》放在我头上，口诵了很多咒语，还赐给我一顶旧的黄色班智达帽和一法本。因为家里的人很忌讳这类旧东西，拿回家他们担心会带来灾难，所以我就把这些东西放在帐蓬附近的岩石上。回家后家人问我为什么这么晚才回来，我就把当天遇到的事讲给他们听，他们都不相信，说小孩子不要撒谎，荒地上哪来寺庙？要有人的话也是非人！你为何不留下来住在寺里？如果捡到那些僧衣和经书的话倒很好。他们满不在乎地说了这些话。第二天早上，叔叔听到这事后，叫我去拿回经书和帽子，我跑到原处，发现那些东西已都不见了。
    以上是童年时代的事迹，能记起的我都简要地记了下来。


第二章

第二章 （一）

    三乘正道的证相要靠三欢喜依止具足功德的上师，二祖师(龙树和无著)为首的历代传承祖师所著的显密经论，通过闻、思、修来开发智慧，才能得到入道的证相等自利；而以讲、辩、著来弘扬佛法，到没有佛法的地方去弘法，到佛法衰退的地方去弘法，让佛法像太阳普照大地一样，利益一切众生，这是神圣大德们的足迹。而我没有他们那样的功德，只有一些细微的功德，按历代祖师们的传记学着写，我认为没有什么过失吧，正如律经仪轨所说：“像释迦佛祖那样，跟着学，跟着修，跟着做。”
    首先是我拜见善知识。
    三域无与伦比的向秋多吉·龙多丹比尼玛坚赞巴桑波，是在巴珠大金刚总持如星星那样多的亲弟子中，像水晶王(月亮)坛城一样开发了智慧、具极大慈悲、威猛加持力以及无人可比的修证经验，是佛教兴旺的大西藏一致公认的成就者。扎多地区有这样的传说：“如果没有辽西龙多，巴格(巴珠)将断子绝孙！”事实上也是如此。这位圣者，列绕林巴授记他是寂护法师的转世，蒋杨钦哲旺波授记他是贡涅贝比朗觉和吉文根卓朗杰的转世等。不管怎样，他依止了邬金吉美曲言旺波(巴珠)上师二十八年，闻思显密经论，特别是精通了不共同的深广究竟法门，以及密乘心髓的窍诀和修道方法，证得了超出心识范围的现量智慧本来面目，并且实修了本空立断(彻却)和直指三身即道相光明顿超(脱噶)。他所闻的这二次第就像一个宝瓶的甘露倒入另一个宝瓶一样，而且不仅停留在闻的阶段，还将词语依哲理和经典来作思维及抉择，并随上师在寂静的山上实修，从而全面消除了增益，与密乘经典印证。他和文波丹增洛布，贡秋俄热堪布，米雅贡索，拉塔珠古等在阿吾(巴珠)仁波切面前发誓，要一辈子在囊青和类乌齐地区修头陀行。阿吾仁波切没有同意，说：“贡秋俄热到竹庆寺当堪布，其它三人返回自己家乡实修，文波丹增洛布还要到我的格芒寺去讲经说法，能讲多少就讲多少。”因此具恩上师龙多仁波切回到辽西圆林，并以此地作为主要的道场，修了《入菩萨行》十年，《三休息》三年，共用了十三年修心。后来他开玩笑似地说：“我在辽西圆林收展了十三年别念，因此不让增长智慧，如果开始就修大圆满的话，必定会成为—个好见修人。”另外他还在宗那，桑阿玛、噶丁日绰、郎贡、俄里玛、嘉都日绰等地各住了几年。在此期间没有收供养，后来到多珠钦寺住了九年，那时所得的供养全部上供下施，前后作了七次净布施并回向功德，就像噶当派的大德那样什么东西都不留。不仅跟仲敦巴的修持和功德完全一样，而且显密经典中所讲的上师功德也都全部具足。事实上，金刚大总持龙多喇嘛住在嘉都日绰时我才五岁，也就是水羊年开春的季节，爸爸领着我去拜见他。从那时起，他对我的恩德很大。这位金刚大总持尊者与现在大多数装模作样，只求名利，贡高我慢，做一个好梦就认为登了很高的地，入了最大的道，以自慢心去寻找供养，贪睡图食等所谓的“成就者”完全不一样。
    我长期依止上师期间，他对我讲：“我在竹庆雪山为祈请敏久囊卡多杰长住世而闭关三年，在此期间没有什么可吃，竹庆寺拉丈也不像现在这么富裕，很少给我吃的，具恩阿吾也没有赐我什么，我很贫苦地过了三年，那时只有一件破旧的内衣和三法衣，垫的是一块大石头。闭关满三年后，我立即去见阿吾，阿吾问：‘你过得很贫苦吗？’我回答说：‘没有多少吃、穿的，但按上师要求去做，为了竹庆敏久囊卡多杰能长久住世，我感到很快乐幸福。’阿吾说：‘行者若是不破戒，鬼神亦会送饮食。这句话就是对你这样的修行人而言’。”鬼神怎么送粮食的事上师从来没有讲过。有一次他对我说：“你们光是求法，却不注重实修，如果注重实修，上等根器的人日日增长，中等月月增长，下等年年增长，绝对不会没有增长的！实修的人要懂得方法，修了没有增长就是没有懂得它的要领。仲敦巴大师说：‘修法需要闻、思、修结合起来，这是修持佛法的窍诀。’巴珠仁波切给我们讲法时，讲了一段后就让我们长时间地去修。那时我们师徒在果阿玛，我的妈妈夏季打酥油时每天都把一小块酥油加在前面的那块酥油上，装在袋子里寄给我，而我剪一块放在糌巴上请阿吾仁波切吃，阿吾看着糌巴愣了一会儿问：‘你的酥油怎么像大黄芽，这是为什么？’我把由来禀告后，阿吾说：‘哦！这样的话，我就不敢吃了。’于是他就不吃了。有一天又问：‘你想妈妈吗？’‘不太想。’‘哦！这是你没有修慈悲心的过失，到那边柳树林中去修知母思恩等七天吧。’于是我按知母思恩等修了七天后，就自然生起了菩提心。在上师前如实汇报后，上师说：‘哦！是这样，就需要这么做，修了就会生起菩提心，这是必然规律。以前我不让你收供养，但这一次你能得到多少就收多少，回家去看妈妈吧。’为阿吾的妈妈去世做四十九天超度法会时，我参加超度得了一匹好马和十两白银。由扎曲卡到尼隆化缘，又得到几包茶叶和几头牛，这些东西全都送给了妈妈。这些坏财物你要追寻时就找不到，不去找它时却又一大堆一大堆的送过来。”上师还讲道：“有一次，我们师徒在多阿惹森林中烧‘三身茶’，用边讲边修的方法，修《大圆满心性休息》等三休息，修《幻化休息》时，倒塌了我的执实义的洞，懂得了一切有为法皆为幻化无实义。”我问：“这是不是证相？”上师说：“不是，只是一种好的境界。”“那‘三身茶’是什么呢？”“当时我们师徒条件很差，早上加些茶叶来烧茶，颜色和味道都比较好，这就叫‘化身茶’；中午加点水在剩茶叶里烧开来喝，就比早上的差一点了，就叫做‘报身茶’；晚上再加水来烧，这茶水就没有一点颜色味道了，就叫它为‘法身茶’。这是阿吾仁波切开玩笑时取的名字。”“那吃得怎么样？”“早上舔一点糌巴，中午有一点糌巴吃，晚上就不吃了，后来有一段时间什么也没有了，有时就吃点牧民丢给狗吃的饿死的牦牛肉。法快要修完时，当地流行瘟疫，阿吾说：‘我们要逃跑。’于是，我们每个人就搬到一棵松树旁住下，只吃白杜鹃花根。夏天五月份时，阿吾派巴青多杰来找我们聚集在一起，大家都是披三衣，托钵持杖的僧人，因此阿吾亲自持香前来迎接说：‘唉，像印度比丘一样。’他身边有一块奶饼，就说：‘用这个来招待大家吧。’中午就分着吃了这块奶饼，全天都没生火烧过什么吃的东西。阿吾接着说：‘你们一点苦也没吃过，就能修好法？现在条件这么好，自己还不好好修，那就太可惜了’。”
    有一次，在益勒嘎寺举行《新伏藏修宝瓶》的法会期间，我去朝拜益勒嘎寺，看到很多僧人因降临智慧本尊而跳起金刚舞来。晚上回寺后，上师把我叫到身边问：“你今天修宝瓶时看到什么了？他们做了什么？”我把所见到的情景汇报后，上师说：“有心识的舞蹈是那样的，没有心识的舞蹈有时也会有。”我问：“那怎么会跳起舞来呀？”“我曾在辽西圆林作了经部十三坛城的近修，其中修若伏藏大师的金刚橛时，坛城中用紫铜制成的小金刚橛也跳起来了。”“这是为什么？”“我不知道是好是坏。”我又问：“那个金刚橛还在吗？”“我送给索甲仁波切了，他用这个金刚橛在岩石里取伏藏，就像挖泥土一样容易。以后他把金刚橛送给贡觉康萨家族了，从此取伏藏时岩石还是岩石那么坚硬了。因为他是大喇嘛，只喜欢昂贵的响铜金刚橛，像这种紫铜的他不喜欢，拿去送人了。具恩的阿吾上师跟我讲：‘你没有年满五十岁前，不要给别人传授大圆满，五十岁后因缘具足就传。’但是在未满五十岁时，应格芒寺文·敦嘎再三请求，我只传了一点点，除此之外，我没有一刹那违背过阿吾上师的话，因此可称得上传承的金丝没有沾染破戒的锈迹。”
   虽然很难说出具恩上师内在的功德，但是上师偶尔不经意中会流出几句象甘露般的修证精要，从中可以看出他的修证，持戒清净的基础、稳固的禅定与慈悲心相连，生圆次第的要门彻底达到了续部经论所印证的境界。仲敦巴大师说：“我的传承就像一条河，源头是雪山，从圆满佛直到我的根本上师阿底峡尊者之间，整个传承的每一位上师都可以一一指出来，实修菩提心这个宝链从未断过，所以这个传承具有殊胜的加持力。甚深的见地，广泛的行持等都具有窍诀，因此一切修道的窍诀都已具足。”正是如此，我的传承也同样具有很大加持力。这位圣者(龙多上师)住在嘉都日绰时，我才两岁，爸爸带着我去拜见他，上师很高兴地赐予我装满红、白葡萄、糖果的木碗和金刚结，还给我戴上哈达，用具有无量福德资粮的双手为我摩顶，诵了吉祥词及愿文并为我加持，还对我爸爸说：“等他长大了，带他到我这里来求法。”现在看来，这就是后来我们能成为师徒的缘起。向秋叔叔住在兰若时，托人捎来口信说：“上师说：‘今天那个小孩很奇特……，应该注意卫生。’在上师那里来的不管是上层人物，还是平民百姓，都不说他们的好坏，要注意保护。”
    火猪年我九岁时，跟着爸爸和很多的人到曲柯扎陀温泉，拜见了来温泉做浴疗的虹化成就者(白玛邓灯)的弟子江底多杰，又名塔耶喇嘛，得到了《遍满虚空众生自然解脱前行仪轨》，前后听了七天。那时我的智慧还未开发，没有听明白，但对这位上师生起了信心，我想他可能就是我的有缘上师，然而过了不久他就去世了。十一岁时，多杰桑珠叔叔教我蒋扬钦哲旺波的注释《文殊智慧殊妙功德赞》，我很快就全部背下来了。那年冬天，辽西还没有上、下二寺，有一家庭召集了达、昌二部落的僧人在宗嘎圣地开了法会，我把《文殊智慧殊妙功德赞》讲了一遍，当时老喇嘛们都十分赞叹。
    十二岁时，有一位叫扎秋的叔叔，也是一位很好的喇嘛，他写噶陀传承依怙主嘛哈嘎拉仪轨，我帮他磨平纸张，多利喇嘛抄写。我念原稿校对时，对“消毒头上惨叫时”这句话念得不顺，就去问叔叔，他骂我说：“叫你不要当喇嘛，你偏要来出家，现在连文字都不会读……”。那天晚上，我向文殊菩萨猛厉祈请，拂晓时胸膛内响起了“阿[日/阿]屙巴扎那帝”的声音，看到很多珠红色的‘阿[日/阿]巴扎’像奶子沸腾般从内腔往外流溢，随后我就昏厥过去。从此我的念诵就很好了，一天能念一遍《般若八千颂》。也是十二岁那年，一位龙女送给我一件宝贝说：“这是如意宝。”十三岁时，在宗嘎圣地找到一部医典，这些都交给了各自伏藏主，当时也没有重视。
    我年满十四岁时，在噶陀智美西雄第四世持明者敏久丹比坚赞的亲弟子宿布巴森的转世，名叫阿旺丹增的大伏藏师，又名吉扎土多林巴前，得到了《龙萨宁波前行》中轨，懂得了不管做任何大、小善事，都不能离开“三妙法”。按这个传承，认真修了发心、曼扎、内外金刚萨埵修诵、上师相应法和名号祈请。为了消除违缘而念诵“长吽”等都修持圆满。十五岁时，我在这位伏藏大师前，得到了《龙萨多杰宁波伏藏经典》十一函的全部灌顶传承。在准备前行灌顶时，上师对我说：“你看看今晚做什么梦，明天告诉我。”天亮前我真的做了一个梦，梦见在一棵大柳树旁，我敲着一面很大的锣，看到从远处来了很多人。第二天向上师禀报了这个梦境，伏藏大师仁波切说：“那棵大柳树是噶陀，敲锣是你以后会到噶陀讲经说法。”看来，他的解释确实是看到了我的未来。正行灌顶时，智慧本尊亲临。自己观想为本尊时，我的凡夫体一刹那具足一切庄严的忿怒本尊相，具足三境力，自己的耳中十分清楚地听到本尊金刚翅扇动的声音，生起了坚固的佛慢。
    那一年，我去了康侧嘎，具恩上师龙多仁波切的亲弟子，博学多闻、持戒清净、证悟高深并智悲力等全具足的大堪布坚赞俄热为授戒和尚，古龙堪布赤诚罗布为羯摩师，噶玛当秋俄热为屏教师，才旺仁增为引礼师，敏珠林寺的金刚上师囊卓迦措为尊证师，在如此僧伽圆满数前，按三次第我接受了沙弥戒。具恩上师龙多仁波切高兴地把我叫到跟前说：“得到出家的戒律缘起非常好，律经中说：‘得此沙弥戒刹那，诸居士众皆应作，恭敬顶礼并发愿。’就应这样摆脱家庭的束缚，得到无上功德的能依。龙树菩萨也说：‘律如有情无情之大地，诸多功德相依之基础’就是这样，有不可思议的功德，一定要守持好每一条戒。《定量论》中说：‘杀生偷盗邪淫与妄语，饮酒观听歌舞涂香饰，坐卧高广大床非时食，触摩金银宝物不应作’我认为你能守持好根本四戒，六支戒，实际上三十条细戒也包含在内了。”并授与我很多教诲，还赐予我五匹红绸。从此，我严格听从上师教诲，戒律中虽然没有讲离三衣的堕罪，但我从未离开过五衣和七衣，并过午不食，不捉持金银，严守十戒，从未当面一套，背后一套，确实以出离心为基础而行持的。光是持戒清净的功德，就可以算是一个很好的喇嘛。因此，跟我的后学者，应当学好律经，好好持戒。这一点非常重要。噶玛恰麦仁波切说：“老僧清净律仪者，即是成就者征像。”我认为这句话说得非常好。
    以后的两年是在散漫中度过的。到十七岁时，由于诵了一遍《大般若经》，所以对空性生起了欢喜心，每念到“幻化不与幻化执着”的词句时，就觉受到一切有为法犹如梦境。那年初冬，我才真正领悟到了二谛不一不异，进一步地认识到“我”和“法”不管在何处、何方、何时都不存在，懂得了以前月称所说的眼、耳、鼻都不是真实等的实义，也彻底领悟到生死因缘中没有本性。按此修持以后，首先平息了执著心，只剩下一个对境相，过了一段时间这个相也消逝了，只有明空之心，一个空空的对境，以后连这也消逝了，心和空二相全消逝，像水中加水一样融为一味，在无别念境界中安住。从这种状态中准备返回大的别念时，一切相都如梦如幻，除了偶尔有一点实相外，没有执著。按此推断登地的诸菩萨也有短暂的执著，并非绝对无别念与对境。现量空性的无别念与我年满廿七岁时圆满证得明智如量相，即以心与对境的本性明智和以智慧力的现量，这二者的区别非常大，这是我亲身的体会。出定后对治烦恼障和智慧分析的力量大小等的区别方面可以写很多。近年有不少人说显密二法的二见道与证得的智慧没有区别，我这是为纠正他们的说法而写的。
    具恩上师龙多仁波切在多珠钦寺住了九年，准备返回家乡时，对俄热喇嘛说：“现在我给那些像鸡蛋一样的禅师们做了眼睛和嘴巴，还做了一个梦，梦见色雄沟下游，有一座大金塔斜倒在那里，我快要把它扶起来了，这样的梦重复了多次，看来我该走了。”
    第二年上师离开多珠钦寺回家乡(辽西园林)，走到温泉时，达、昌二部落的所有僧人骑着马赶来迎接，在曲科扎陀温泉住了几天。离开那天，龙多仁波切骑上马说：“你们骑马列队向前走，阿利(阿格旺波)和松吉焦到我的左右来作护卫。”我们走到莫公玛郎岗山上，甲学部落的人们前来烧茶接待，并一起到阿旺丹巴喇嘛圆寂之处回向和发愿。吃过饭后，安章寺大持明者的转世阿旺也来拜见，供养了有八吉祥图文的白银首饰和已圆寂上师用过的金刚铃杵说：“我很高兴您回到家乡来，我很高兴……非常欢迎，我们达、昌二部落及附近部落的人，祈请您传法度化。目前大圆满的大法最清净的传承惟独您一人拥有，请您转大法轮，长住世，竹庆寺来迎请您也不要去，一定要留在我们这边。如果您到其它地方，我这个老喇嘛就抓住您的披单不放。”经过很多次祈请后具恩上师龙多仁波切就留下来了。
    我们继续走到益勒嘎寺，拉丈派人在草坪上搭起了帐蓬并准备了最好的条件。我们一行人住下后，迎接的人们也都回去了。过了几天，我去拜见上师时，他说：“六月初十要作一次会供，你去通知，凡愿意来的人都可以来，有什么供品也可以拿来。”我到各家各户通知后，家家户户都认为这次会供很重要，表示要踊跃参加，那时部落生活条件不像现在这样艰辛，当时他们送了很多酥油、奶渣、奶饼、酸奶等供品。依阿里班禅的伏藏经典《上师功德藏》仪轨作了一次很隆重的会供。上师跟我说：“秋天要传授前行，你也来。”在那里住了几个月后，于八月十三日又搬到白玛日陀。有一天我去拜见上师时，他说：“这次求法的人多，地方又小，应按人头分配。”于是就把地分给五十多个人。“这块是你搭帐蓬的地方。”也给我分了一块地，各人都在所分的地上钉了桩，上师又说：“我的帐蓬以上谁也不让住，还要来很多喇嘛和仁波切。”
    九月初就开始讲《普贤上师言教》，但由于我家住在昌的下游，因此没有及时得到通知，等得到消息马上跑去时，上师已讲到行菩提心了，我问：“现在可以一起闻法吗？”上师说：“给你捎去了很多信，可能没有带到，你可以来闻法。”第二天，我带着三块银元和满满一盒酥油、奶渣及一腔羊肉等作为曼扎来献供，就这样我和大家一起闻法了。法快要传完时，上师重复念了多遍“发大殊胜心，不如生起来”并说：“啊！巧遇这段法，缘起非常好！”
    “发心”以下的法传了一个月·，我作了笔记。在这期间，具恩上师每天都给我从头补课，传法圆满结束后我去请求教诫时，上师说：“你以前没有得到过前行，要修五加行，冬天就住在这里，虽然不是按次序来修，但可以先修金刚萨，修诵方法我慢慢给你讲。”念百字明期间，他详细地给我讲了四力的观修法，并说：“特别是这个依止力，只有修生起次第很熟练后才能修得好，观修色相方面，对眼睛的黑白、发肤和毛孔都要观得清清楚楚；观空的方面，要没有一丝微尘实体的法，观色、空就像观水中的月亮一样。”我就这样观修，可下座前观“金刚萨埵化光融入自身”时，就遇到困难了。去请示上师，他说：“哦！这是太执著的缘故。所谓金刚萨埵，只是用心集脸、手等假名而为金刚萨埵，但实体是没有的，你一部份一部份的分析，还有金刚萨埵吗！”我这样分析后，就领悟了“有相无性”。用五十天念诵了十多万遍百字明，清净罪障的证相也出现了许多，如梦境中和现实中都有身体轻松、自然进入禅定等等。我去问“现在又念什么？”时，上师说：“《入菩萨行》里面讲到四部，其中有一个放弃部，你也休息一下。”休息十天后，上师说：“现在我们是修金刚萨和供曼扎来代替显宗大乘佛法所讲的一大阿僧祗劫方可圆满的资粮道和加行道，用正行的讲授来代替见道的智慧。现在还要修曼扎，这是菩萨修资粮道的第一步。”于是借给我修曼扎所需的三依，即身依铜佛像一尊；语依《简集经》和《大幻化网》二函；意依噶当舍利塔。“这个塔子具有三次第道的表意，从莲台到塔顶还可以表示三学。”上师讲了一遍后就什么也不说，过了一会又拿起大遍知者的塑像说：“这塑像内有大遍知者的脑髓和无畏洲的头发等，是蒋杨钦哲旺波赐与我的，你拿去吧，他是宁玛巴最重要的一位大上师，只要好好祈请，就有可能亲自面见。这是积累资粮的第一步，因此要准备好五供，你是富裕人家的儿子，应尽量多供酥油灯，我送给你灯芯。”说着就赐给我棉花，一百把红白香和涂香等等。
    当天我就开始打扫清洁修持的地方，将三依圣物摆在一块石头上，设了一个坛城，在一块小木板上供了食子、油灯和五供。从供曼扎的粮食中拣出了鸟粪和残缺次品，四克(十六公斤)粮食洗得干干净净后，用香水浸泡，并每天都换新粮，没有重复用过。按照《隆钦心髓仪轨》修三身曼扎“三千世界百亿刹……”，修到三万多遍时，上师叫我去，问道：“修完多少了”我如实禀报后上师说：“七万遍和补缺都修蒋扬钦哲写的‘大地涂香……’和‘自他……’这两个你选择哪一个都可以。”我说：“钦哲旺波写的不是不好，但我还是想修大法王(赤松德赞)写的。”“修这个可以，阿底峡尊者说，‘现在积累资粮和发愿文等方面，用佛祖亲口说的《普贤行愿品》这样的愿文，或者是十地菩萨弥勒的愿文，或一地菩萨龙树的《二十颂》愿文等真言来发愿的话，功德特别大。一般凡夫用华丽的词语所写的发愿文，没有什么意义。’事实就是如此，但是蒋扬钦哲是大法王无误的化身，因此与法王并没有那么大的区别，不过你可以按自己的愿望来修。‘大地涂香……’是大法王向莲花生供养国家和臣民时所作的，不管做任何事都要先分析清楚，考虑周到才做，那么修显密二道也就不会有错。如果像饿狗见到肺片似的，所有的法都过早地去求，那就会坏了他的一生!”如此等等赐给了我详细的教言。
    从上师那里返回后，我就不管天数，每一座都要修一百多遍皈依、发心和金刚萨埵等，然后才修供曼扎，《普贤行愿品》其中的七支供与行大礼一起做，每一座都念诵十遍七支供，行十个大礼，最后就修供曼扎，下座时也诵了不少。那时我作了一个梦，梦见一位叫玉珍玛的女子要我去拜见大遍知者(无垢光)，她把我带到色雄色帝山东面的一个修行洞。这座山像右旋海螺一样，我们沿着右旋的山路往上走，就到了山顶一块黄色的草坪上，见到大遍知者面朝东方，凝视虚空，口里念着：“啊！啊！”手里拿着像绵羊心形状的水晶石，放在我的头顶上说：“啊！心性自然菩提心啊；啊！广大虚空普贤界啊；啊！直穿明智即法身啊；啊！五大本能显种种啊；啊！超越见修明智性啊；啊！愿今融入你心中啊！”我生起净信心后，就在无别念中昏厥过去了。醒过来时，发现大遍知者的唐卡上有几颗舍利。供完曼扎还三依给上师，在上师身边时，他问：“见着大遍知者了吗？”我回答真正的大遍知者没有见到。见到大遍知者的梦忘记禀告了，舍利子由上师收了起来。后来有一次上师又问：“你在供曼扎时见到大遍知者了吗？”“没有见到过。”他又问：“做梦了吗？”我把梦境详细地向上师讲述后，他说：“这不就是大遍知者赐给你三部大圆满词句灌顶了吗？”我回答不知道后上师就什么也没有说了。后来，上师对几位弟子赞叹说：“阿利亲见了大遍知者。”
    有一次上师说：“‘真谛本来面目之智慧，积累资粮消障二功德，及依具加持力圣上师，寻找它法则是愚人行。’如此说来，顺缘修供曼扎时，仪轨中讲了共同与不共同法门，然而阿吾说：‘显相化身曼扎，实际报身曼扎，遍满法身曼扎。’这句话很有实际意义。”这方面讲了很多很多。还说：“用自己身体来积累资粮的古萨里法门，是一个简单而又能起很大作用的法门，大遍知者写的《心性休息》中说：‘与上师相应法连起来修。’但是遍知者无畏洲又将古萨里合在内外曼扎中来积累资粮同时修，不管怎么样都非常重要。”说着就把四施的观修方法详细地讲了一遍。上师接着说：“早上要作白施，中午作花施，晚上作红施，黑施暂时不作，这个要到很险怖的尸陀林去修。这个法是长时间不得征候量，或得到后，还没有圆满制伏量，那怕圆满了，但仍没有得到驱除量的人才需要修，现在连讲这个法的人也没有了。”
    以后上师把《注释断行空行母的歌声·六度岁月》和阿吾著的《讲解》结合起来给我讲了一遍。我把供曼扎与施身法连起来修了一段时间后。连续作了这样一个梦，梦中到了一个尸陀林，那里有很多新、旧尸体，还有很多鸟类和兽类。我的心识从自己的身体里跳了出来，一刹那就变成了黑忿怒金刚瑜珈母，自己的驱体布施给那些鸟类和兽类。这件事向上师讲后，上师问“你害怕吗？”“一点也不害怕。”上师开玩的笑着说：“那是乌杂那尸陀林，密主金刚手菩萨也怕得差一点把手里的金刚杵掉下来了，你怎么会不怕呢？”我说：“我的心跳入虚空中，现出黑忿怒金刚瑜珈母相，她是一切佛的母亲，一切佛都是她所生，比得上佛的力量的鬼神哪里有？心中是空空的，没有害怕的感觉。”上师说：“不要说这样的大话，难道你比金刚手还要厉害吗？”这些是实修施身法的功德，我不懂得是好是坏。
    开春时上师给所有求法的人讲解了《隆钦心髓前行仪轨》和蒋扬钦哲旺波写的《观修方法》。我这次还得到了阿吾仁波切传承的《入菩萨行》，加上这一次，我已四次得到《入菩萨行》和三次得到《菩萨戒仪轨》的传承。上师对我说：“上师相应法你暂时不修，先从四出离心开始修起，要想成为一个好的修行人，修这个前行很重要，正行才能修入正道，正如寂天菩萨说：‘平息世间八风以自利，自然生起大悲而利他，’如实证得空性的话，空性现出缘起，缘起进入空性，彻底领悟这个关系后，就不得不对真实不虚的因果生起信心来，正如龙树菩萨说：‘领悟诸法之空性，业力因果即生起，最奇妙者还奇妙，最殊胜者还殊胜。’仲敦巴也说：‘证悟空性与生起慈悲心是同时的，生起慈悲心和消除罪障过也是同时的。’”我问：“那么，近代称自己证悟了空性的人们，为什么烦恼没有一点减少？”上师说：“这些人进入的仅是口头‘空’。”接着又说：“末法时代说证得空性，见到心性，见地很高的人们，行恶业的胆量越来越大，烦恼也越来越多，除了说话时有很大的口气外，其它什么也没有。但是一旦到了生、死、中三有的关键时刻，心识的了知却比一个心地善良的老太婆还要差！他们嘴里讲的和做的尽相违背。所以有些人现在视宁玛巴就如笨波教一样，这是法和行没有融为一体、伪装像高见地的人在破坏宁玛巴。因此，宁玛巴应该依《大圆满心性休息次第道》修自己的心，证悟了大圆满本性后，长期实修，见地要宽广，行持要精细，这样做的话，就能像持明者无畏洲那样，受到登上甘丹寺金宝座的赤巴仁波切，和东啧、北啧、萨迦法王等的非常尊重和爱戴，这是因为他的见行符合宁玛巴的经论和次第道。我们俩须要慢慢地、很好地以四出离心来反复修心，阿吾仁波切的传承也是按照《心性休息·实义讲授》，从前行暇满难得至行菩提心六度，用一百四十六天来修心。这样做的话，上等根器的人可以得到四禅定，中等根器的人可得初禅定，下等根器的人最少可得欲界一心不乱定，这样成就后，再传授直指大圆满明智，就称得上实际的止观双运。寂天菩萨说：‘有止诸胜观，能灭诸烦恼，知己先求止，止由离贪成。’心解脱的观修法门，不管显密经论都讲要像无风的灯一样明亮，要有不散漫心，而它的因是修如实的止，那么止也要以不贪六道轮回的出离心为基础，守持清净戒律，并将三学所规定的取舍分清楚。如果不是这样，就成了所谓的“大手印”、“大圆满”，仅取名为有相无相的止，修了数年数月根本不可能有正信的禅定，连起码的欲界一心不乱定境也不会得到，如果这样虚度人生就实在是太可惜了！”我问：“有相无相的止修方法，难道在大手印、大圆满的经典中没有讲吗？”上师说：“大遍知者在大圆满窍诀中没有讲过有相的止，大手印里面可能有，那时候有很多具有功德又精通窍诀的上师，他们依‘舍弃五过失’，‘八行蕴’，‘住心九法’用木棍、石子等物来修合格的止，现在没有这些窍诀，光是把心识强行止在木棍和石子上，是绝对得不到一点止的味道。宗喀巴大师说：‘禅定止的部分，应该是心识，但是说它是眼识，这是很可笑的。’这是事实。讲授的方法有：有缘对境根器者从禅修里找见地，明智自相根器者从见地里寻找禅修。大遍知者说：‘从总纲理论上讲应该是后面的方法，但是从实际修持来讲，还是前面的方法好。’通过前行修心，虽然很难得到如实的止，但不会得不到欲界一心不乱定。首先，从发心开始修知母、思恩，都要以自己的根本母亲来修，不分上座与下座。阿底峡尊者说：‘修因果需要七窍诀，’但是阿吾的传承中讲知母、思恩等在五窍诀中已包含了，可爱的慈悲包括在愿得乐里，清净的心包括在以发心相连里。”上师将每一座修心的方法都给我讲一遍后，让我思维很多天，因此我用了近两年时间才修完。那年，上师为索甲喇嘛师徒、阿旺丹增喇嘛师徒详细讲解了大圆满前行，我也去听了，并作了笔记。
    在前行修心时，那不由自主往外跑的心完全止住了，不管观修还是止修都很顺利。有一次，我心寂然入定，没有观修和止修之分，进入明空的状态中自然放松，所有诸相都变成明点，而后这些明点也在定中消失，没有任何相。我将此事讲给上师听后，他说：“不懂，可能是阿赖耶识吧。”由于上师这么说，我就特别注意把修心的任何一次观想，都观得清清楚楚，观想越紧，就越进入无对境中安住，遇到这种情况再问上师时，他还是说：“不知道这是什么。”直到后来传正行明智与心识辨别时才说：“你以前修心的时候，曾问过有相无相的禅定，就是这个！但当时没有给你指明，是怕你也成了‘快要丢掉所修的对境’”那时候上师不让我看任何心性方面的书。有一天大堪布坚赞俄热来到这里，上师对我说：“你要去他那里学点经论。”于是我就去学了竹庆寺堪布晋美桑丹注释新彭塔耶菩萨的《分析五蕴颂》和《广论窍诀》，稍稍懂得了词义。过后又学了扎瓦格西所写的《噶当十宝教言》和《隆钦心髓修心七要》的实修方法《正念近住》、《修山法教言奇妙海》等，还学了《明了三律仪论》、《入菩萨行》等，经过努力学习后，我懂得了这些论注的一点意义。
    又一次，上师说：“你还要跟阿朵(堪布坚赞俄热)学习《生起次第双运穗》，虽然生起次第和圆满次第方面没有深奥的意义，但是你闭关近修本尊时就需要。”我问：“生起次第、圆满次第讲得比较细微的论有那些呢？”上师说：“《心性休息》本来不是论，而是大根器的次第道，也是显密生起次第、圆满次第等广深二道全部具足而无误的窍决。但是敏珠林寺伏藏大师师徒后期的讲授就越来越少了，具恩的阿吾给我们讲过一遍，这个内容已包含在我所传的前行里了，但以后你应求得更详细的讲解。”我就这样学了《生起次第双运穗》。上师说：“你还要继续修心，皈依和发心修了多少。”我说：“每一座的时间分三分之二修心，三分之一修皈依，皈依已念满三十万，发心念了十万遍。”“发心再念三万就够了，修心很重要，发誓愿的皈依也念够了。平时要实修四皈依，它是在轮回与涅槃当中，消除一切违缘的依怙主、帮助者、接引者和护送者，还有比他们更好的吗？！要想救拔一切苦难者，如果自己没有脱离痛苦的话，就无法救度。佛祖是不住二边的成就者，因此如果向他皈依就能得救拔；法就是成就佛果的灭、道二谛智慧，正如《释量论》中以遍知四谛的取舍来衡量佛祖的标准，此法作为道来修，也能救拔；僧宝是登地以上的菩萨，修持具恩世尊所指明的法而得到道相功德者，要以他们作为修道的助伴和榜样而皈依。不然就像一位很有财富的商人经过险境时，没有很好的护送者便不能通过一样。正如《简集经》中说：‘何人手持《般若经》，魔鬼便来造违缘。’因此，受违缘不受违缘的菩萨都有。既没有智慧又没有精进的人，是已经着了魔的违缘；只有精进而没有智慧的人，也会遭受违缘；智慧精进都具备的人魔也没有办法来制造违缘。《简集经》中又说：‘多子之母患重病，子忧寻除母疾法，十方诸佛与菩萨，护持母亲《般若经》。’你也有不一般的智慧和精进，因此，为消除障道而精进地修皈依具有很重要的意义。实际修道的皈依，就像受戒发誓言一样，所有法都不超出皈依的范围。不要一开始就说正行正行的，不要做好高鹜远的人，要当好修道者，先要打好扎实的前行基础。仲敦巴格西说：‘下糌巴的菜舀得多是好，但舀菜的糌巴勺子做结实点更好！’如此，必须通过修心来改变自己的习气，你修心后增长了这方面的功德吗？”我说：“四出离心如实地生起来是很不容易的，但我从小就是一个不喜欢轮回中的富贵荣华的人，并且在上师的加持下懂得了轮回的道理后，并不需要用心去改变就能生起出离心，对三宝的信心真实地生起来了，做到了心口一如。不仅如此，我还懂得了这个菩提心就是大乘修道的基础，仇敌与亲朋同样都是自己无始劫以来的母亲，为他们离苦得乐从而生起了殊胜的菩提心。只要是为了利他，那怕献出自己的生命也无所畏惧。所以，说我从小就有为众生成就佛的果位而欲求成佛的思想一点也不觉羞愧。”上师说：“哦，就需要这样，通过修心后你生起了一点点善心，但不反复修的话，很快就会发生变化，因此，需要从暇满本性、数目、次第等等一个一个地修，《普贤上师言教》要全部牢记心中。”说完，他给了我一本《普贤上师言教》，按照上师的要求，我很快将这本书背诵下来了。上师很高兴地说：“就需要这样，不要学那些愚蠢的禅师们很执著地止修，并把它看得很重要，这种禅师没有用！‘上等的禅师成就上等的佛，中等的禅师成就中等的佛，下等的禅师成就下等的佛，’这句话也说得对。我所讲的话连一个词句你都不要忘记，要好好记住，用心思维。正如《修心七要》中说的那样：‘记住上师一句话的功德，比讲授三世诸佛经典的功德还要大。’对上师所讲的法，没有用一点思维，就很随便用自己的话来讲是不对的，宁玛巴大部分的口耳传承都快要断了，因此，为弘扬佛法，传承窍诀需长久住世而努力，这很重要！”我将上师的话牢记在心中，一字一句都背了下来并作了笔记。目前，在具恩上师的亲弟子中，不管是前行方面还是正行方面，我的讲解算是最殊胜的。后来，阿朵喇嘛说：“以前具恩上师传法时很少讲阿吾的口耳传承，现在给你讲的这些窍诀极为殊胜，我是一个没有耳福的人，虽然来了很多印证见地的人，各自都讲了很多好像是证悟心性的话给我听，但是真正能辩别心识与明智、见到明智本来面目的人我还没有遇到过一个。我懂得的又无法拿给他们看，想说给他们听吧，也没有正统的口耳传承窍诀，因此，他们也听不明白。”说完，他就在具恩上师那里求了口耳传承。不管怎么样，我想阿吾的口耳传承，生起次第和圆满次第教授等所有窍诀，可能除我一人之外，没有普传。具恩上师前半期收的弟子是索甲和阿朵二位；中期的弟子有多利堪布、林达·洛尔科、萨恩·旺钦、拉卡诸珠、阿洛诸珠、色多诸珠和匹查·圆丹喇嘛等；后期弟子有匹查·白玛多吉、索朗洛布、白玛罗萨、达科·白玛多吉、萨恩·贡秋等大弟子。但是，从给我传一切窍诀的精要以及给我讲弘扬口耳传承的重要性等方面来看，上师实际上已将传承的主脉全交给我了。


第二章（二）

    具恩上师给大弟子坚赞和圆丹说：“阿吾仁波切对我说：‘每隔一百年，为了整顿与弘扬心髓法脉，比玛拉牟扎说要亲临一次，这百年期快要到了，我是见不到了，你会见得到的。’我曾猜想是不是竹庆仁波切呢？但是，竹庆仁波切不但阿吾亲自见过，而且也给他传过《大幻化网》，成了他的弟子，看来就不是了。现在阿利不是的话，那我也见不着了，但从他的智慧和证道各方面来看，好像是他！”然而，我不敢说自己是比玛拉亲来，但是我的顶轮有“嗡”字，眉间有“吽”字，鼻尖有“阿”的相，身体上还有五方佛的法器像等很清晰的现量标记。在第一次传授大圆满时，也有天上下了花雨，出现了一个彩虹的帐篷等诸多瑞相。具有信心的大部分弟子在临终时见到我亲自接引等诸多众所公认的奇妙征相，以这些来看，我也许是一位可以勉强使弟子生起信心的人！
    我在喇嘛大伏藏师那里得到了《新伏藏》的一切灌顶传承，后来开始修《上师相应法》时，在阿朵处得到了隆钦心髓伏藏经典《二函》的所有灌顶传承。具恩上师说：“现在以持咒近修和前行修心同时来修《上师相应法》。隆钦心髓修上师加持的次第有：外修依《上师相应法》共不共前行来修心；内修依《持明总集》来修阿鲁瑜伽《经部意集》中第六十四品的共同生起次第来证得不净七地。这七地以上的各证地要依靠《口耳传承·如意宝卷》来证得不净幻化身和标记光明，依次从生起标记光明直到有学双运，再到无学双运。以《持明意修忿怒大勇士集》的注释《忿怒本尊言教》，它的意释《前往密严刹土的阶梯》，而它的疑难解答是阿吾仁波切所作的《黑汝嘎忿怒本尊心意五次第》来修摩诃瑜伽的生起次第；密修依《大悲自解苦难》；极密修依《上师明点印》、《大乐空行王母根本修持仪轨》等，就称之为‘隆钦心髓’。其中主要依《智慧法界续》、《后续》、《普贤王如来意证》，这几部续的意释是《智慧上师》、《遍知者言教》等。从无畏洲以后就有了灌顶和讲授的传承。因此，现在《上师相应法》说是只需要念一百万遍，但是这次一定要念满三百万遍。”
    我按上师说的那样，以具备五识来修《上师相应法》，并结合七支供养行十万遍大礼。不管是见到上师还是闻到法，我都以视上师为佛陀的信心来祈请，从来没有生起过上师是普通人的坏念头。每一座修持的前一半是修“修成就祈清”，后一半修“求成就祈清”，在念满一百万莲师心咒之前，每念满一百遍心咒念一次祈请，修后二百万心咒时，每念一千遍心咒念一遍祈请。在修心咒期间我去拜见了上师，上师每天午斋后要沿自己的禅堂绕二十五圈，我跟在后面。 他穿着狼皮的短内裙，裙子下方的边沿系有一条鞋带，看起来像一条尾巴，大小香时就说：“快来拉我的‘尾巴’。”我就往外拉，使上师更方便一些。有一天他什么也没说就大小香了，我看他不方便的样子便说：“需要拉您的‘尾巴’吗？”“哦！我忘掉了，拉吧拉吧。”上师边说边看着我说：“儿子，你这是学我说的活，不怪你，但对上师要视为法身佛而不能看成是报身佛，哪里还可以说有尾巴呢？何人看我是色身……”诵了一偈后又说：“不把上师看成是法身佛，而看成是具有色、声、香、味、触的坏念头，它会成为修殊胜成就的很大障碍。‘应视上师为法性。’因此要有法性的证量来把上师视为法身佛。”听了这句话，我从内心自然生起了金刚总持就是自己的上师的净信心。上师无论是在近处还是远处、白天还是晚上，都在用清净的智慧眼，是没有一物看不见的。我不管在何处都像在上师跟前一样，连一个小小的坏念头都不敢生起来，并很注意以正知正念来观照自己。我想“思念上师思念佛”这句话可能就是这样吧。依据把上师看成是佛等五法，使我自然生起了不可改变的信心。从此后，只要是给我有过灌顶和传承的诸上师，除了思其恩德和无限关怀外，从来没有作过违背上师的行为。后来，竹庆寺堪布索曲称赞我说：“很会依止上师，就像圣财贤的事迹一样！”我不仅是对上师，就是对金刚兄弟姐妹们，于记忆中，也从未在当面或背后说过他们一丁点缺点或对他们做过一丁点的错误，故认为自己是一位持戒很清净的人。现在是末法时代，在同一位上师、传承下修法的有些人，对上师金刚兄弟姐妹们看缺点、说坏话，用嫉妒和诽谤经常闹矛盾，还要比学位、比世间财富和受用，并修持邪法来希望得到神通，成了名利地位等的皈依处，而且还认为自己是持戒者。这些破戒人修的只是堕落三恶道的因！对于密乘行者来说，持清净的三昧耶戒是最重要的。《寂静本尊续》中说：“不离上师本尊师兄弟，清净三昧耶戒最重要。”
    《上师相应法》修完的时候，上师对我说：“现在应该学点生起次第。”随后就给我详细地讲了《命根四钉窍诀·游二界梵天之音》、《通向密严刹土阶梯·解疑》，特别是《五次第》内容是指摩诃瑜伽和阿鲁瑜伽的共同要点。“《黑如噶要义》中说：‘金刚诵观想，自加持光明，双运五法者，称之五次第。’这些方面能很好地讲解者只有具恩阿吾一人！”我也作了一点笔记，对这方面的疑难题，也在上师那里前后多次问得清清楚楚，所以对金刚乘的二次第有了正确的认识。拉索喇嘛仁增向上师求《三休息意释》时，我也一同得到了。上师说：“《三休息意释》需要几个月来修心。”我按此去观修时，上师又说：“对治凡夫的实相执著是以观明相、想清净、生佛慢来达到三境威力，其它的传承中只单单讲了生起次第的修法，而没有讲开始时就需要见地，然而在宁玛巴的传承中开始就讲对大清净、大平等的见要有一个无法改变的了义识。这一点，在《根本续大幻化网》第五品中说：‘一因文字相，加持现量者，四非常证量，立诸法即佛。’‘情器诸相续，证得清净相，’‘此二平等者，二殊胜平等。’虽然有三清净、四平等、大圣者等诸因，但四证因基本包含了这些大自性要义，并抉择诸法即现等觉之王，这就是立自宗。其中以一因的哲理来反驳轮回的根本无明实执。‘啊伙！轮回我执所生祸……唉玛伙！如来藏之中，业力幻念生，’这是指什么呢？是指你们念诵《闻解脱》的时候，有一句‘清净分别心障碍’，就是指一点也捉不住的分别念称之为我执，要想反驳这个，在空性中所有的因只有一个树立自宗。但是，用显宗中观应成或自续二派的哲理来认识无我，就好理解，要不然，光说一句都是同一个因，除了上等根器的人以外谁都听不懂，不起作用。”我问：“应成派和自续派二者谁为重要呢？”上师说：“你说什么？证得空性方面没有一点区别！虽然在俗谛安住方面有不同的辩论，但是，密乘最根本的是实际光明和幻化身双运。要依气和明点的圆满次第来修气、心进入中脉的境相，而得到标记和实际的智慧光明。从这里出定后，就会生起诸相如幻的境界，到那时俗谛的安住，不管怎么做都不会有实体的执，著，这样就平等了。麦哲巴法王也是唯识派，金刚铃杵阿矇黎是自续派，寂天菩萨是应成派，然而他们获得的殊胜成就和见地的证觉却没有丝毫区别！”“这是为什么？”“在那个时候，八十种分别心全部需要熄灭的话，俗谛的区分太微小了。”“如果是这样，应成和自续二派，为何因俗谛的不同而有无好坏高低之分呢？”“你说什么？在俗谛的实意上还是有点增益，但它对道起不到违缘的作用。”“如果是这样的话，现在很多人相互争论又是为什么？”“那些人不懂得道的实际意义，而只是在见地上分你我高低的争论。”“那难道佛护和清辨论师他们也不懂得道的实义吗？”“不，这两位是争论圣者的宗旨要怎么消除俗谛的增益，真谛方面有差别和无差别、真谛注重得多与少的区分。但是初学者如首先对差别真谛有了正确的认识后，再以资粮道的认识和实际的止修，加上长时间去实修道的话，就能够进入大资粮道，这样才能对观修有一点经验而进入加行道，现量空性时无差别真谛到一地才能有。但不是说除了第一地所证得的空性以外，每一地都有不同的空性，而是以所证得的心的力量而分十个层次！近来，人们高呼什么应成派的初学者也有无差别真谛，远离一切相的真谛，实修者与三圣入定一样。虽然这么说了，但还是承认与三圣所证得的见有很大的区别，哪里讲得通和三圣入定时没有区别呢？！没有别念的禅定，禅天和五色界里面都有，与这种定没有什么区别，这种定对破我执和实执起不了任何作用。正如：‘慈等不相违迷惑，故此不降伏对治’开始就说‘我没有执着，我是远离一切相的人’等等大话，对二执起不到一点对治作用。譬如说：‘二执也没有，是无相的，’光是会说这一点不起任何作用，不要说大话！我们算是寂护法师的后学者，中观以自续派为主，这样缘起会很好。显宗的最高见地是应成派，但要丝毫无误地领会并证得是很难的！这是因为说自己是应成派的人们，为了自圆其说，用了很多应成派的经论来论证自己的观点，然而这些论证是说不准的，因为论证和獐皮哪边都可以随意拉。今后要通过好好的思维分析来获得正确的了义识，这个是很有福报的人才能证得的。中观的因和哲理不要向外去争论，要向内来对治自己的执著，这样的话，在对境中就能看到无我，就不会不破坏我执。如黄昏时，看到花绳就认为是一条蛇，但只要拿一盏明灯来照，就会知道它只不过是一根绳子，同时也消除了蛇执。因为蛇执的时间不长，只需要消除一次就行了。而实执的时间很长，在自心中不反复地思维和长期修证的话，就不能消除。因此，要依止不偏袒任何宗派的善知识，这样就像没有眼病的人看东西一样，有智慧的人长期思维分析的话就会领悟此理。”
    “初学人的见地有两种：用智慧来分析后，对显密经论各自的见地有不可改变的了义识时就叫作了义识见，当对密乘大清净、大平等见有了这了义识后，再修生起次第的话，就可以叫作生起次第与圆满次第双运；光说那是某某上师的话，某某经典中讲，但自己没有一点了义识，这种叫作信心见。这种见很容易变，是靠不住的，所以说了义识见是很重要的，但是说‘密乘以信心修道，’因此，也不能认为信心是没有用的，自己没有一点什么是正法、什么是邪法的辨别智慧，别人说什么就跟他跑，不要向这种人学！阿吾说：‘要想证得一个准确的证道，就要猛厉地祈请上师和本尊，多方面地积累资粮，经和论结合起来看，如果树立一个正信来分析就会明白。我是首先将佛经读通，过后再精通圣者们的论学，故像一只大鹏金翅鸟翱翔空中再降落在地面一样，你们要像在石头上刻字一样，一个字一个字地去记。看到其它宗派的论后，自己不站在正信立场上而偏颇一边，只想如何去反驳，而不去想有哪些是我不懂的，要如何增长自己的知识等，这样就得不到法益。’这些话说得非常真实。他是大成就者，通读了经和论后所起的作用，从《大乘经的功德》一书中也看得出来，虽然这样做不容易，但是不要别人怎么说就怎么做，要用智慧来分析。阿吾给我们传法时，只讲明智的一点点边，就叫我们去好好分析。就是这样，一因的哲理是抉择一切法的本性空。”
    我问：“除了认识空性的心以外，就不要密乘的智吗？”上师回答说：“你说什么？智慧也要用一和异的哲理来分析，在明智本性中没有什么不是空的。首先从色到遍知间一切有为法都是空性，这是一切有为法的本来面目，也是主要对境的本来面目。此后，自心的本来面目好好地分析时，任运成就七财本性，即法界与智慧双运，这需要续部的哲理来细细分析并抉择，除此之外，很难证得，这也是用资粮道来认识空性。
    第二，文字式的哲理为‘阿、乌、嘛’三字和合而成的‘嗡’字来表示，按显宗来说，空即是不灭的缘起一样，这里也要让智的各种妙用不灭地显现出来，这不净的相也是智的妙用。要有这样一个妙用和本尊相无二无别的了义识，不然不懂这些道理，还说相即是佛。如一位敦巴喇嘛说的‘嘴巴即是鼻子’般没有什么用。
    第三，加持的哲理是智与妙用相互印证，就像显宗所说空与缘起无二无别一样，这妙用也不离智，就像波浪不离大海般，又像冰块显出冰块的同时也是水，显不净相的同时是智本性的妙用，相没有请到空中去，空也没有请到相中来，本来就是智的妙用，本尊与自性无二无别。事实就是这样，在领悟证得后只要修炼就会现量，虽然所有证得的东西不一定要现量，但是证得殊胜二谛无二无别的见，并按此实修就能现量成就。这是一切法的规律，也是二谛无二无别的缘由。
    第四，现量的哲理像用圣者的现量来证得一样，这里也需要明智智慧的现量来证得。初学者没有如实的明智智慧现量，但要懂得这个道理。明智智慧有不同层次的分类，待以后讲正行的时候再说。现在首先要明白二谛无二后才持咒。因此，对治一般凡夫的执著，要靠以上所讲的四哲理中的第一个哲理来了知法界与智慧无二无别，这是最殊胜的真谛。所以要靠分析真谛的智慧来证悟；第二个哲理是相、声、明智，是智慧的化现，不灭的缘起，本尊与心识无二无别，就叫作殊胜的俗谛。其中第一个哲理不但对治相续的执著，而且能证得法界与智慧无二，它能熄灭情器诸法不净的执著和我执；第二哲理主要熄灭一般凡夫的不清净相和俗谛的幻相，这二种哲理主要是讲真谛了义识见；第三个哲理是讲这种见地通过修炼后能否现量？若能证悟后，是否会退失？要断除这种疑惑的坏念头；第四哲理是证得殊胜二谛无二无别的大法身，要依圣者的智慧，有明智智慧现量的同时也会明了俗谛本尊与心识无二无别的证量。虽然对境相没有执著，但对不净的境相还是用不净来看待的话，就是违背了殊胜俗谛的宗旨。因此，认识这本尊与心识无二无别，在金刚乘里面是非常重要的。精通这些道理后，按此修行的人就可以称之为密乘的瑜伽士。”
    上师说：“这内修《持明总集》是依续部阿鲁瑜伽经典的仪轨，但是，以伏藏经典的分类来看，还是属于三根本修‘加持根本上师’仪轨。因此，如‘智慧明空无改变’是说阿鲁瑜伽，法界与智慧无二无别的修持方法。但是，这次要按照摩诃瑜伽的三禅定来禅修为好。因此，本性即空性，妙音是大悲，显相皆‘吽’字，观想从中生起坛城的能依所依，这是一因的哲理。这里还需要记住文字和加持的哲理等来修持，不要将希望寄托在近修的天数上，而近修是与本尊融合，从观想‘吽’字直到圆满的坛城，需要观得清清楚楚、实实在在，这是莲花生说的，这也需要修得像金刚宝石一样具有不破不坏、坚、真、利等七个特点，这是对境显本尊相，自心在空性中清净地修持，再坚固也不需要实有！‘境相佛慢不散漫，观想清楚来修持。’这明相在没有达到三对境合为一体之前需要修持。‘空慢有相而无心，’对境显现出来的同时要认识没有丝毫的实义。但是，近来不懂得这两者分类的人，说有相无心、如幻、如水中月、如彩虹等，需要做一个隐隐约约的本尊，这是错误的！观想一尊隐隐约约的本尊，不是真实的生起次第，修上一层圆满次第的成熟灌顶都不是。不懂得生起次第和圆满次第重要性的人，讲生起次第只是个虚假的道，是大圆满的障碍。又说：‘修得只是赞美彩虹和幻化的生起次第的话，是宁玛巴末法时代的表现。’所以说重要的不是数量的多少以及时间的长短，重要的是观修，这次是你首次的近修，因此要严格地闭关，誓言的时间不要太长，否则没有修满，就是犯了誓言缺的罪，以后生生世世都会遇到誓言缺的过患；因此你先闭关四十九天就够了。”
    就这样，我近修了《上师持明总集》，每天四座，第一座的前半部分主要用三禅定清清楚楚地观修；后半部分诵咒或同时轮流交替地观修坛城的能依所依。在此期间，在对治不净地境相时，所观修的对境无须造作与改变，就能自然现量达到所修法的境相。有一次，上师叫我去问：“你的生起次第修得怎么样？”我讲了修持的情况后又说：“基本上可以，相、声、明智即本尊、咒语和智慧的妙用，这并不是说所有的相都观为本尊。佛刹土和受用、事业要如实地观为道场、宫殿和刹土，自己的身、语、意三业和佛的身、语、意、事业都要懂得用《命根四钉》的窍诀来套用，观修部分按你前面修的就可以了。这是对治不净的方法；下面要修对治执著的方法——清净念和稳固慢，执著可分法执与我执二种。对治前面的执著需要修明晰相，如果对它有实体本尊的执著，那就需要修清净念，三头即三身、六臂即六度等诸法果显现为能依、所依的了义识。在此基础上，用稳固慢对治我执，有时观本尊的如实相，需要的是这个本尊的佛慢；有时为无相法性胜义的本尊、基果无二的智，以莲花生的佛慢来诵持，这些是生起次第最精要的要点。”通过这样修持后，我掌握并稳固了生起次第的修持。
    修满了一百万遍莲师心咒和四十万《持明总集》的时候，上师给我捎口信来说：“到现在没有出现什么违缘就结束吧。”出关后去拜见上师时，上师说：“就是这样修，这生起次第对止修和共同成就的诸多事业都离不开的，它又是为修上一层圆满次第而打下基础，净与不净的幻化身也要靠生起次第的功德显现出来。一般来说，所有生起部分都按生起次第来理解是不起作用的。寂语的前行是要修寂身，它与修生起次第有很大的区别。这《大乐王空行母经》中讲明了阿底瑜伽的修法，一刹那间圆满本尊相，隆钦心髓的传承持明者们就是靠这种法门来成就殊胜果位的，因此对整个西藏的恩德非常之大，她是密法金刚乘的法主母。父经和母经的联系也很大，应该近修一次此法。一般来说，生起次第可以清净生、死、中三有的习气，这些习气归纳起来有四生处。通过生起次第和圆满次第来修清净后，先得到四持明的果位，最终成就双运的果位。首先按摩诃瑜伽来修清净卵生的习气。广仪轨《八大行法·佛总集》中指出：‘自子与他子来观修。’《大幻化网寂静忿怒尊》的修行仪轨中也有全面的修法。《大勇士总集》中只有简轨而没有广轨，这所谓的自子是赞颂明智如来藏的殊胜功德，通过这样修炼后，轮回与涅槃的精华集中起来作自己的儿子；所谓的他子，是为了继承如来族的后代，观想清净现量的佛黑如噶父母后，佛母为生佛子而向佛祈请，自己的蕴、界、处等化光成为明点，由佛的鼻孔进入后与大乐菩提心的明点融为一体，在佛母胎中的庄严、法相和法器悉皆圆满后再请到坛城中去；中轨是依生起五现证或四现证，以及金刚三仪轨等来清净胎生的习气，即五行、五蕴、八识，中阴界的气、心、红白点，六根对境所生环境与受用等的习气，这种习气的对治方法在《通往密严刹土的阶梯》中有讲，一定要认识明白。莲花佛的大部分伏藏经典都是金刚三仪轨的观修，因此必须懂得外修摩诃瑜伽与内修阿鲁瑜伽、密修阿底瑜伽的仪轨，但现在以念诵仪轨词句的多少来取名是错误的。修清净湿生的习气要靠阿鲁瑜伽诵持名号、咒语来观修，或法界与智慧无二无别的境相来观修等两种仪轨如我前面已讲过的那样。修清净化生的习气要依靠阿底瑜伽领悟明智法身的见和智慧法身的妙用，安住在一切有为法的本基是大清净与大平等，用这样的见地来修道是一刹那念即圆满的观修方法。所以说在这四生处中修清净其中的一个生处，就能达到其它生处也能清净的效果。这是因为光明智慧完全是统一的，要对治轮回的习气也是统一的，有殊胜的生起次第和圆满次第的对治力。这生起次第分广轨和简轨应该这样去理解才对。大遍知者在《心性休息》中说：‘这些生起次第修习的方法，是一个众生初次修法，中间修法，殊胜修法、极殊胜修法的不同法门，这个对圆满修道而言是很重要的。至于对以信心修道的人来说，内三乘的修法将不知所措。阿敦说他自己是用诵持后思其义的方法来修的，他是以噶陀系《大幻化网》的讲授仪轨作为功课来诵持的，像他这样的人只可以结一个好缘。这次按阿底瑜伽来修《大乐王空行母经》，是以二刹那念即圆满来观修的。然而，你还没有得到正行的讲授，还做不到如此修法，但自心不着有相，自心五分别地观修，圆满能依所依的明相是很重要的。生圆次第三修持方法，除观修本尊有广轨和简轨的区分之外，观修本尊都需要清晰的观想和稳固的见地这两方面没有区别。你前世有缘，在观想本尊方面没有困难，这次近修的时候，在持咒四法中，群星绕月和国王差使般这两种持咒法是摩诃瑜伽的持咒方法，而轿子持咒法是阿鲁瑜伽的修持法，或者把国王差使般又可以作为三个共同的持咒方法。对治昏沉的法门是：观心轮中的咒轮，通过上升到佛的鼻腔而出再进入佛母的鼻孔，向下到达密处，由密处再融入原来的根本咒轮上；对治散漫的法门是：观想咒通过下降到密处，再到鼻孔像焰轮一般无间断地运转来持咒。它的主要作用是生起乐空智慧，特别是对明点的升降起到很大的作用。如果生起次第修得非常好的话，只需要用轿子式的持咒法来修本尊佛母就能生起大乐智慧。另外有主要的本尊与眷属问答法义，在宫女处实取五欲的供品。另外还有以法金刚橛触而生起大乐智慧等。通过最殊胜的修炼就可以得到生起次第的禅定，因此气心为一，就能做到心具堪能，到那个时候，修圆满次第气、脉、明点就容易了。此外，能修气与拙火定使主要的气和明点自在的同时，也得到殊胜的心具堪能，由于它的功能而获得殊胜的五眼六通。然而目前说什么冬天修个气、脉、明点，其实并没有掌握好它的要点，只是忍受寒苦而已！他们与外道们守狗戒和牛戒，坚持耐寒来作为所谓清净和解脱的究竟法门没有什么两样。你有邪见吗？”“没有。”“你的清净心大，对一切都要修清净心，需要有好好分析什么是正道、什么是邪道的智慧。这次要按照阿底瑜伽坏了蜂窝般的持咒法来观清楚刹土与宫殿等等，注重修一切诸声即咒语之音而诵持。”我不分昼夜地近修了一个月以后，所有的声音都无需用心去改变，就能生起朗朗的咒语声，这时候也懂了本尊与相全是心的化现，是只有名称而没有实义的本性，生起了殊胜的了义识并知道这是修持成就的殊胜法门。
我二十五岁那年的一月上旬，有一天上师说：“在阿朵喇嘛处受个具足戒吧。”“我认为比丘的戒律很多，要全部守持比较困难，我已受的沙弥戒好好行持是否可以？”这样问上师后他说：“不可以，这次你得到了暇满人身，要做有用的人身，完全进入圆满的佛道，必须得到比丘的戒，修密乘的基础也同样以比丘最殊胜，极喜金刚说：‘上等比丘最殊胜，中等受持沙弥戒，在家居士为下等。’比丘戒的戒条多，圆满资粮的力量就大，因而清净罪障的力量也大；积累资粮和消除罪障的力量越大，证得殊胜的道相功德就越大。因为它是不共的近因，正如‘佛法宝灯能明亮，苦行器皿佛弟子，身着袈裟诸比丘。’如三学中最殊胜之身像明亮宝灯一样的慧学，最殊胜的现证还是比丘最好。《时轮金刚》中说：‘唯除登地菩萨外，居士不当国王师。’佛祖对月贤法王说：‘除了登地菩萨和比丘以外，不要依止在家居士为上师。’佛法住世与不住世，取决于比丘的有无。寂天菩萨也说：‘佛根本乃比丘。’受比丘戒非常重要，我给你创造顺缘。”又说：“这里以地域来讲虽然是边地，但授戒比丘数目要像中土一样，应在涂丹坚赞俄热为首的十位比丘前求戒。”于是招集了十位比丘，“祖衣和钵、敷具等如法的资具要准备好，刚好我这里有多出的祖衣、钵、敷具可以借给你。”我就这样很圆满地得到了比丘戒。此后，尽可能清净地守持比丘的五堕罪戒。我把十三资具等自物实事和象征他物都作了加持，界内自煮、自取、生熟、触火、触宝等方面依班禅洛桑曲吉坚赞所作的《时念》来行持。后来财物很多的时候，也做到了不离供养三宝、上师、同修、施主的正念，并没有随便受用一点未经过加持的财物，因此可以说是对所有的财物都无欲贪执，对自己的财物有知足心，对他人的财物没有贪取心，这就叫作以无贪知足的正念来修菩萨道。对这些财物也从来没有想过我生病的时候需要，我死亡的时候需要，看到别人的财富和地位也从来没有羡慕和追求过，这可能是修四出离心的结果吧！
    有一次，具恩上师显出病相。索甲伏藏师授记说需要念诵《无垢忏悔续》十万遍，参加念诵的有一百五十多位弟子，其中有二十多位念得最快，每天能诵十八、九遍，其余的人每天念不了多少遍，所以花了几个月才完成。我自己也发愿念诵此续一千一百遍，其它弟子也发愿，放三千多条生命，这样上师的病就痊愈了。弟子们还商议决定每人闭关一百天修《长寿仪轨》，于是大家都闭关了。我去上师身边问：“为了您长久住世，我还要念诵《忏悔续》吗？”“我现在老了，幻化蕴身像一棵古树般，不知何时就会抛弃，然而，对上师和金刚兄弟姐妹祈请长住世，这是七支供养中的请长住世支，因此它可以消除自己目前暂时寿命的违缘，终究能达到长寿、成就等的殊胜功德。你就依《长寿仪轨精要甘露宝瓶》来闭关修持吧，长寿宝瓶嘎巴拉，长寿彩箭找不到也不要紧，这是蒋杨钦则旺波的长寿甘露丸。”说着就给了我一小纸包后又说：“只依这个和朵玛来修，一般来说，密乘经典中所说的圣物，具备这些是非常重要的。圣物、咒语和禅定这三点各有各的特点和意义，然而这次你已经修过《持明总集》，还需要补阙，与它结合起来修，每座的前半部分持咒，后半部分以观修气和明点来修《长寿仪轨》，这个观想在前行时你已经修过气、脉、明点，就算可以了。但这次为了不缺少阿鲁瑜伽的修法，要修一点点气与拙火定的瑜伽。所谓的寿命就是现热和心识结合的那段时间。但在密乘中，首先进入母胎是身、识、气，三者和合时就叫作寿命，它是在心间中脉内像丝线一样的白种子，它长寿命就长，它短寿命就短，它弯曲身体就多病等，这就是寿命。如果它衰退寿命也衰退，如果它穷尽寿命也就结束了。为了使它不衰退并增长就需要依气和明点来修《长寿仪轨》。众生的死亡有三个因：因寿命结束而死亡、因耗尽业力的增长而死亡和减少现在的福报而死亡。只耗尽一方面还可以改变，但耗尽其中的两样或全耗尽则无法改变。自在了气和明点的瑜伽行者，留住心间神识的能依持命气就是寿自在。一般来讲，摩诃瑜伽的寿自在持明说是从见道开始，但这是对已进入后面诸道而言的，在证得了密乘的加行道后，还没有进入见道之前，就能留住的话，这也是寿自在。证得了见道后就没有了生死的真相，因此怎么做都可以。在加行道的时候，心轮和顶轮的二持命气自在后，便可得粗大的气脉中留住微细的红、白、气三者的自在。在见道寿自在时，已经消除了粗大的气脉，但它有圣者智慧的微细气脉明点藏的自在，这二者有很大的区别。另外，外道的神仙得到的长寿是神赐予的成就或是以圣物辟谷的功能，不能与密乘的长寿成就者相比。长寿持明莲花生就将情器镇压在心轮，他是通过修密乘道，将果报的五大种浊法用智慧火烧清净后，现证了胜义本性自然种殊胜的佛果。所以认为所有长寿者都是同等果位的话那是错误的。”还讲了具有四行的宝瓶气窍诀，拙火定和微细的明点次第等。“没有修满一百天之前不要到我这里来。”
    这样近修的时候，出现了甘露丸发出光芒，朵玛和甘露丸化光，梦见果实累累的宝树，受用各种各样的果品等瑞相，对此我也不持欲望而安住在法界。通过长时间修气，入、住、融的证相都次第圆满了，想持多久的气就能持多久。此后修了拙火定，全身得到了暖乐和融化明点而证得了乐空之境，外面的寒冷与炎热都成了暖乐的助缘，只需要短暂的修炼，即能熄灭微细的心与心所的所有分别念。又不像熟睡那样的昏沉，无分别的外境首先变得空朗朗，然后这也消失了，每一座都安住在不可思议的明空中。我修满百日出关后，把修供圣物献给上师，上师尝了一点后说：“我老了，长期住下去很难伺侯；你还年青，能多住一段时间好。因此给你灌个长寿顶。”说着就给我灌了长寿顶，把剩下的所有成就圣物都给了我并说：“全部吃下，一点也不要剩，也不要送给别人。”坐了一会又说：“吃腐烂的朵玛只有拉肚子的因，嘿嘿……，你修气脉时有什么证相？”汇报后上师又说：“可能是前世你修炼过气脉，种下了这个因，现在又唤醒了，但不要自慢，也不要讲给任何人听，要经常修，你懂得密乘修道的捷径吗？还要继续修四出离心和上师相应法。《益喜措嘉空行母问答》中说：‘如果每座都不修四出离心的话，开始上座时行佛法，但下座前就已经跑到世间法里去了。’要想做一位外内如一的修行者，这修心非常重要。阿吾仁波切每一座都修心，捶着胸膛说：‘哎呀，苦啊！苦啊！’后来有一次说：‘龙吉(龙多丹比尼玛)，我现在根本不敢去想三恶道的痛苦，修六道轮回的痛苦时，仅仅想到三善道的痛苦就受不了。’他住在多阿惹森林时，早晨听到画眉鸟叫‘鸠鸠鸠、鸠鸠鸠……’时就重复学：‘你痛苦，我痛苦……。’阿吾这么做，我们也知道应该怎么做。不要说什么正行讲授的大话，眼光太高的话，‘头靠得太高，脖子低处断。’据说唐巴比丘已自在了心气，但由于一个坏念头没有用到正道上，因此后来还俗，当了统率军队的一位将军。”
    上师给修满五加行的其他弟子传了正行，但很长时间都没有给我传，我也听从上师的安排，没有反复请求传授正行和窍诀。但很多年前我供曼扎求法时曾说：“请按我的根器来传前行和正行。”上师说：“正行很难，大遍知者说：‘现在是末法时代，求这大圆满需要积最上等的资粮，广泛地闻思显密经论者才能行持，除此之外，就没有这个法缘。’大圆满见、修、行的要点，只有圣者才能行持，一般老头子、老太婆等俗人可能听不懂也学不会。”


第二章（三）

     二十一岁的夏天，家乡来人想接我回去，我就准备返回家乡。中午时拿了一些酥油和奶渣作供品去拜见上师并求加持，当时上师正躺在那里，我退出门外顶礼了一段时间。当上师抬起头时，我到他面前供养了供品，上师问：“这么多酥油和奶渣，拿来干什么？”“今天想回家去，妈妈也说需要做个水供，等到了秋天才回来。”具恩上师重复地说了几次：“我做了一个奇妙的梦。”但是我没有敢问做了什么梦。上师接着说：“以我做的梦来看给你传个正行的话，也许你会成为一个能为别人传授正法的人，不要回家去！正行详细地讲授需要一百天左右。”“为母亲做个水供只需十天左右就回来，可以去吗？”“不可以，闻特别殊胜的法不能有惰心和延迟。‘正法难求违缘多，何人法宝未求到，为造违缘魔降临。’因此明天就开始传授，看今晚作什么梦。”听到这些话后，我汗毛耸立，热泪盈眶，生起了不可思议的信心和欢喜心，身体坐不住，心也有些慌，我深信这个传承具有极大的加持力。那天晚上梦见益喜措嘉空行母赐给我一函又细又长，名为《三传承持明上师意藏》的经典，我打开宝卷来看，里面全是满满没有边框的像表记文一样的细小文字。第二天，我拿着供品和曼扎到上师跟前时，他问：“昨晚做了什么梦？”详细地讲了梦境后，他又说：“你看得懂表记文吗？”“看不懂。”“以那函写得满满的文字来看，你将可能成为最上等的修行者，但是以没有边框来看，身语的善业可能会差一点，其余的我不懂。”上师从那天起就开始给我传授正行了。“传授的提纲是持明者无畏洲口传耳闻传承，此传承的弟子如金项链，又多又好。大持明者的亲弟子前往康区的主要有多珠钦吉美赤列俄热等，他的弟子有四大金刚、六布达、十三囊卡、持坛城者上百位。在十三囊卡名号的上首弟子敏久南卡多吉前，我得到了《法界宝藏》。在吉美嘉维纽固的上首亲弟子蒋杨钦哲旺波、具恩的阿吾二位面前，得到了《空行心髓》的义释《深义海云》和《直指胜义藏》、《密行金刚导行》的讲授。持明无畏洲有这样的授记：‘在我的光明心髓的传承中，儿子比父亲强，孙子比儿子强，曾孙比孙子强。’因而我以上的传承都用不着惭愧。现在你是曾孙，具恩的阿吾在很长的时间内只讲一两道题，我在内心中做到了真正的熟练，遇到不懂的地方和疑难处就到阿吾的跟前，用教证二法来断除了词语增益。能令智者欢喜的讲授、清净的词句、能够说出实义有经验的话，都是具有加持力的传承，因此你也不要丢掉一字一句，一定要记在心里。”
    上师先简要地讲两道题后就让我修几天，再将这内容详细地解答疑难后，又让我思维几天，并问我：“这些词句记住了吗？”“现在是记住了，但不知以后是否会忘记，能不能作个笔记？”“说什么，口耳传承不立文字，你没有听说过吗？”过了一段时间后上师又说：“你怕忘掉的话，最主要的词句作个笔记也可以，秘密无文字部分大遍知者记下来后，就成了《上师心髓》口耳传承三部和《深义心髓》秘密无文字的口耳传承，但我俩与他不一样，这口耳传承的讲授既怕传开又怕失传。”因此，后来就成了简要和详细的两种笔记讲义。
    传正行智慧禅定见的考证时，我什么也不会讲，因此很泄气，于是猛烈地祈请了历代传承祖师，并按照上师相应法来领受四灌顶，心意融为一体而安住。以前修前行时，我出现过无分别的心境诸相都消失的状态，上师说是阿赖耶识，但现在来分析的话，三时没有与善念、恶念及无记念相混杂，也不是五无分别心期，而是赤裸裸的明空，我想就是它！这应该不会有错，从内心里面决定了。跑到上师面前去汇报，他笑着说：“实际上这就是明智，但我没有给你指出来。大遍知者说：‘领悟心髓的宗旨，就需要赤裸裸的明智，不懂得这个的话，修立断和顿超都无益。’就是这样。”说着又显出很高兴的样子说：“父亲的儿子能传宗接代，今天我们要做个庆贺。”就赐给了我许多糖和水果。“来喝一喝我的茶。”在说了很多家常话后又说：“你在前行修心的时候，就有无相的禅定，你所讲的无相禅定就是正行，圣者入定的时候，外境和内心二念中首先消失心念，此时外境还没有消失，因此相还是存在于禅定的对境中，此后禅定的境相亦消失。所以前面是有相禅定，后面是无相禅定，现在有一些法师讲般若有相无相的禅定时，认为是空性与幻化二禅定，这是没有经验的人说的露馅的话，你说在出定时先是出现碰铃一样的响声为缘起，然后一切外境之相显现出来，《佛陀一子续》中说：‘相自声如铙钹响，过后现出幻化相。’这是成就虹化身的证量，与内明智圆满相吻合，但不要贡高我慢，你有自满吗？”“没有，出定后，一切诸相无实义而不起作用，只有凄惨的感觉。”“就需要这样，大遍知者说：‘熟练本性功德是证境，明知无常心无远谋略，生起净相无边恭敬心，慈悲心等不断发出来。’就需要有这些功德，萨[日/阿]哈说：‘在前在后和十方，见到何法皆本性，今如怙主我断惑，不向何人问问题。’具恩的阿吾在竹庆那穷玛山上给我讲授了正行。”我问：“怎么讲的？”“是这样的，我原来是一个很喜欢禅修的人，昌成就者给我讲了一刹那的正行，我往前面走，到了义陇喇嘛嘎绕前印证了一下，就成了二刹那。到了格芒寺去拜见蒋贡仁波切，他给我喝酸奶，我说：‘没有碗。’‘拿出自然的嘎巴拉来！’我用双手掌窝着去接，他又说：‘很聪明，有智慧！’那时在他那里也作了印证，就变成了三刹那。再到了阿吾的身边，得到讲授后，我就成了渐门者。”我问：“这二刹那和三刹那是什么？”“这是开玩笑的，如果没有口耳传承的窍诀讲授和要点，光靠诸位上师境界很高的禅话，是达不到任何目的的！因它对间接根器的众生很难指明本性。如今大家都做书本上的游戏，这也不起作用。阿吾和我师徒俩当时住在那穷玛对面一棵松树的旁边，阿吾每天都到寂静的地方去打坐，我则在那棵大松树下烧茶，阿吾回来后就坐在那里。我曾常做一个同样的梦：有一个黑线团需要保护。有一天晚上，梦见阿吾从线团中拉出线头，抽完线后，看见中间有一尊金刚总持的金身佛像，并把此像交给了我。我想，早知线团内有这样一尊佛像，就不用那么辛苦地保管线团了。阿吾每当在天快黑的时候，就躺在一块小草坪上，铺开毡垫，仰卧在上面，伸展四肢修三重三虚空。有一天傍晚，他像往常一样在那里修的时候叫我说：‘龙吉，你不是说不知道心性吗？’‘不知道。’‘没有什么不知道的，快到这里来。’到了他身边后阿吾说：‘你也像我这样来凝望虚空。’我依他说的做了，阿吾又说：‘看到了天上的星星吗？听到了竹庆寺的狗叫声吗？明白我们正在说话吗？’我一一回答后他又说：‘哦，这就是禅！’如此一说，我就从内心完全领悟了，解开了是非的增益，亲见了明空赤裸的智慧，这当然是他加持而证得的。正如萨[日/阿]哈所说：‘上师之语进入谁心中，如观掌上宝物般清楚。’后来，用思维分析，阿吾好像只说了眼识和耳识就是明智，但心髓的实际证量只有靠心意传承的加持力！阿吾在米雅拉乌塘附近凄凉的尸陀林中坐了一夜，出现了很多种试探和考验，通过对上师祈请后，证得了大圆满的见地。‘钦则益喜多吉印证时说，这是你一刹那即断除四魔。可能是从此后我也没有生起过多少烦恼的分别念。’所以说，这个传承只有靠对上师的信心才能证悟！‘依止上师时，需要的是信心而不是尊敬；修持上师时，需要的是信心而不是祈请。’吉美嘉维纽固在喜玛拉雅山珠穆朗玛峰的其恰圣地修了很多年的苦行。有一天，他在阳光下往拉萨方向看，就想起了根本上师和心髓法脉传承的祖师们，以大信心祈请后昏厥过去了。醒来的时候，以前还需要观照的禅修已全部消失于法界之中，成为无见无修而到达了一个无散漫、无昏沉的明智本性中，然而他并没有满足。如果他没有在阳光下的话，还有一种能修可修，但现在什么也没有了。吉美嘉维纽固便想去上师处印证，加上上师年岁已高也需要去拜见一下，同时还可以看看老母亲。于是就启程了，但由于他修苦行的原因，身体很瘦弱，所以一天下来只走到了修行处下方的一条河边。一对山神夫妇显出门巴男女的身相，给他供养了玉米、糌巴和野兽肉。第二天早晨他们还让他带走剩余的供品作为口粮。走了几天后，又遇到一家很富裕的牧民杀了一头绵羊，在受用供养的羊肉时，他生起了如母亲吃儿子肉的强烈悲心，莫说是吃肉了，连看都不敢去看，从此就再也没有吃过肉。”
    “当他来到持明者吉美林巴跟前拜见并请印证时，上师很高兴地说：‘儿啊，就是这个，这是进入了法尽心穷相。’此后，他在上师那里住了一年，将以前所得到的窍诀全部作了断除增益．上师说：‘我不知道你有这么大的智慧，现在你要是长期住在我这里就可以成为大智者。’但是他说：‘如果我的阿妈还没有死的话，就先回去见见，由于上师的恩德，前行和正行的讲授都得到了，如果我能如实修证行持这些法就已不错了。’这样上师同意他回去，回到康区见过妈妈后，就住在扎查玛山上修了二十多年，因此，人们称呼他为查玛喇嘛。所以说光是证悟了不行，还需要实修，修量要达到自然任运的境界，在没有自然进入究竟之前，还需要努力地以坐上坐下来禅修。到什么时候证得大圆满法尽心穷相以自利，抉择通达诸法的智慧由内心中爆发出来，对所持宗派自心具有如菌褶般分科立判互不混淆的能力，自然而然地生起无缘大慈悲的时候，就是到了可以讲、辩、著利他的时候。因此，要按照历代圣者们的事迹，认准自己的修证，用抉择诸法的智慧来衡量和区分道与非道。如果自己实修的话，这么多就够了；如果要给他人讲，就要会归纳窍诀的精要，因此以后应依大遍知者的《七宝藏》、《心髓四母子》等来校正。假如只是依一位老上师的话，而说这《七宝藏》、《四心髓》只是理论的东西而搁置一边，还说什么这是我无上的某某上师的口耳传承赐与我的。对有相和无相的止修，取一个所谓的‘止、变、智三法’的新名称，欺骗所有的上下弟子，这些都是着了魔的邪法！大遍知者指责说：‘观空时空的相如黑暗中投石子般，进入人为的执著见修中，这是不懂道理的愚修！’你的智慧不小，修道的究竟精要按大遍知者的密诀常常作好详细的思维分析，对照自己的修证。我所讲的阿吾这些口诀，那怕是背着一个月的口粮去寻找也听闻不到，是否听得到你以后会知道的。我给米旁喇嘛、踏则奔洛、思奔白玛、单匹喇嘛等供养《智慧上师》法时，大部分口诀也曾供养过。除了踏则奔洛外，他们好像不是很重视，以后看到他们所作的窍诀有什么特点就可以看得出来。”
    后来继续讲授，到直指正行的时候，上师说：“看今天晚上做什么梦。”那天晚上我做了这样一个梦，梦见有一无边无际的像四方形的大围墙，每一方都有大门，里面有满满的不同种类动物，每一扇门的上面都有很多像守门人一样的喇嘛，西方的门上有手持宝剑和经典的红文殊，他的右边有白色的上身赤裸头顶有发髻显比丘相的龙树菩萨，我就在他的身后，而我的后面还有许多喇嘛，都害怕里面的动物往外跑掉而把守着门。第二天如实向上师禀报后，上师并没有解释，只说是个好梦。又开玩笑地说：“那些动物往外跑的话，文殊菩萨的宝剑用力砍会死掉，不用力又挡不住。龙树菩萨的手中有什么？”“没有。”“哦，空手的人多了也没有用，还作了什么梦？”“下半夜梦见阿育王建造的遮耶塔的西面倒塌了，直到西方的大海像洪水般地汹涌流过，海水全变成了红红的颜色，此时空中响起了一个声音：‘在大海里一百万众生得到了正果’。”上师对这梦也没有说好与坏。却说：“这个直指正行别人只作传承祖师的祈请，但这次依《智慧上师》要作智慧妙用二灌顶。”我问：“需要什么准备吗？”“要供黄金的曼扎，但你没有，我的曼扎中有一朵金花，把这个取来和你的几块银元一起供养，恐怕大家听到上师要灌顶都会跑来，所以灌顶时就不用铃鼓了。”上师赐予我《智慧上师》的立断和顿超二灌顶后又说：“这个传承中除了这两个最殊胜的灌顶外，就再没有比这个更好的了！你经常说求我灌顶，现在你已满愿了！我这一辈子给别人没有灌过多少顶，以前曾给多珠钦寺的堪布阿旺和当曲灌过顶，他俩发愿常修《持明总集》，要诵一亿遍莲师心咒，后来色须阿旺写信说已念满三亿遍莲师心咒，要灌顶的话就必须起到这样的作用！在康泽嘎灌了《噶玛经部(十三)修供仪轨》的所有灌顶传承，他们希望做到‘以经部为主，伏藏部作庄严，’但他们现在仍是以伏藏部为主，经部作庄严。后来，除了阿朵只作过几次经部的灌顶讲授传承之外，对于整个道场没有起到多大的作用。去年，为阿旺丹增喇嘛和多利二位传《智慧上师》时，依钦哲旺波所造的仪轨灌了个顶，就再也没有灌过顶。《智慧上师》的妙用二灌顶是《明点印》自己的不共同灌顶，从此后你可以近修《明点印》。
    于是开始为我讲授直指正行。上师说：“这是正式的词句灌顶，只讲一遍，不会重复的，但明后天会详细地讲。”上师每天按提纲将前行、正行、结行的所有内容一一讲授，并让我长时间地思维所闻的内容，我也尽力用最大的智慧来记词和义，遇到疑难问题就去问上师，跟一般所谓的闻法不能相比，自己也很满意。
    第一，前行讲授
    第一天，是共同与不共同的前行修心后进入正行的讲授；第二天，怎样发显密共同与不共同的智慧之心；第三天，要用五圆满来讲闻密乘的法；第四天，大圆满三传承的源流和远近的区别；第五天，大小二乘见、修、行的差异；第六天，其中密乘的特点；第七天，从事部到阿鲁瑜伽部之间各自见、修、行、果等的区分；第八天，如何理解大圆满续其中的数量和结集为心、界、窍诀三部；第九天，窍诀部比心、界二部如何更殊胜；第十天，窍诀部有外、内、密和无上秘密四类，其中无上秘密类有《十七续》，加上《护持密法忿怒母续》为十八，《明法界日光续》为十九，以这十九母子续的分类和意义而有比玛拉著的《秘密心髓》和莲花生的《空行心髓》，它指出了每千个众生修道上的所有顺缘全部圆满无缺；第十一天，《二心髓》的主要意义讲得极为清楚明白的有大遍知者的《上师心髓的心髓》和《空行心髓的心髓》，这二心髓的心髓有《甚深心髓的心髓》，又名《空行心髓的心髓之密义印》，所以这是二心髓的心髓，不要另外数了，所以也就叫作《心髓四母子》；第十二天，《心髓四母子》及它的意义统一起来就是《隆钦 (大法界)心髓》名称的由来。持明者无畏洲在桑耶青蒲寂静的森林中，以看到遍知者的论著为缘起，生起了如见到佛祖一般的信心，通过祈请并近修了三年后，亲见了大遍知者，三次得到了身、语、意的加持并(祈请)说：“愿其意迁入心中！愿其语的传承圆满！”重复了三遍后就得到了心意传承，入定时现量了远离心识分析的大圆满本性，出定后，显密深广道相不学而知，就如新鲜的肉豆蔻放在手掌上一般。如此的见得如此的智而爆发出大智慧，这是由大遍知者的加持所得到的大法，故称作《隆钦心髓》，此法是心中最精华的明点等等；第十三天，以上所讲的要按三根器的次第来引导，并与大遍知者的《心性休息》配合来修并加以思维。
    第二，正行讲授
    基、道、果的区分，修了三天；
    认识道续有成熟道灌顶和解脱道窍诀二次第，要比以下共同的生圆次第灌顶和窍诀更为殊胜，修了一天；
    解脱道窍诀的次第有：懒惰人的无勤解脱——空性立断，精进人的有勤解脱——任运顿超，这二者的教授是方便因生智慧果的关系，也是法身和色身的近因，修了两天；
    立断的讲授以不同根器的众生而有不同的方法，即度化有缘的根器与明智自相的根器，有从见中寻禅和从禅中寻见这两种讲授的区别。有缘外境根器的众生首先要修《心性休息》中所讲的天道与人道的修行方法。《胜乘宝藏》中说：“对有缘外境根器的人讲授有禅修时心定在白色的‘阿’和专注于气、明点上。”指出近来所谓有相止修的观点与这不相符，并破除他宗，完全反驳了那些观点，建立大圆满自己的宗旨和见解，修了三天；
    首先，讲授立断的前行破心房、正行直指明智、结行证相养育，这三者的条目要背诵，修了四天；寻觅心的缺陷，修了六天；它的分类，修了七天；用来、住、去三哲理来认识被驳的执著，领悟无分别境等，修了八天；
    此后，心的来处修了九天，所来者修了十天；住处修了十一天，所住者修了十二天；去处修了十三天，所去者修了十四天；
    接着，还要领悟远离这三者的色空双运心本性，这些是心识分析见和大圆满独有的名称，是法见和法性见二者的前行者，依现量明智见是顿超脉要义的现量。摩诃和阿鲁的方便引出光明，也可以称之为现量等等，在比玛拉的《明灯见的分析》中有详解，修了十五天。
    第四，分析不共同的心性和依此抉择的直接智，这二者第一的见、修、行、果，作了阿赖耶识和法身的分辨、心识与明智的分辨、俗谛与真谛的分辨；要认识所决定的微细分别心，决定自己的本性后，有劳阿鲁以下的见、修、行、果四类，与大圆满自己的见、修、行、果四类的决定见分辨。过后，在修方面，有劳二取念和无劳原始念两者的分辨，修四大自然放下及三具不动摇。在行方面，有自己的本性方便道禁戒行和解脱道谨慎行，又叫如理方便行，这两种行中主要讲了后一种行。果位方面分暂时和究竟二种，暂时的果需要圆满三十七菩提分法，把它们归纳起来就是智慧与大悲，有了这两者就是暂时道的果；究竟果是生、死、中三有的解脱相，按极喜金刚所著的《基本标准证相文》。第二，现量自然解脱，直指明智本来面目的分类。二者共修了五天。
    结行养育证相分七类，这就圆满了上等根器即身成就的讲授。此后还讲了：中等根器的人在中阴界解脱的教授，进入光明壳的窍诀一天；夺舍的颇瓦法二天；光明进入壳颇瓦法三天；见证法汇三重虚空法四天；最终成熟的再生中阴解脱的讲授，心识骑气法等每一天都讲了一种，期间还有多天的思维。大遍知者说：“修我这个传承的人需要长时间地依止上师和长时间地听闻窍诀。”我就是这样来努力的，前后依止了龙多仁波切六年，是按三欢喜来依止的，得到了全部的窍诀后进行了实修，因此以后如有意想做来世的事和想真心修法的人，也要做到长时间地依止上师和长时间地听闻窍诀。
正行立断的讲授圆满后，上师说：“这次要修《上师明点印》，它是密修上师《智慧上师》的修持，因此在一百天里，每天要持咒一万遍，主要是依三不动摇来修持，不用严格地闭关，每隔几天到我这里来一次，正行的要点要作详细的分析。”我遵嘱修到三个七天的时候，相证有大遍知者在虚空中很像现量的相。知证有慈悲菩提心三者与心识同生，连晚上睡觉时也不脱离。到上师处汇报后，上师说：“是一种好的相证和知证，‘若能熟练后，无一物不巧’这些都不是高层次的十地五道证相，证相和证悟不会分辨的话，就如‘慧自力妙用圆满，心识执著外境相，两者相似而误会’，怕你认不准也会这样。”说着就给我传了《三句精要椎击窍诀》、《制伏迷误的狮子吼》。又一次，给我讲授了《空行心髓》的问答《甘露金链》后说：“现在你出关的时间也快到了，安阿喇嘛要传《七宝藏》的传承，你要去听。”于是出关后，我得到了《七宝藏》和《三休息》的传承并立即就去拜见具恩上师，他说：“《七宝藏》与你的证量基本相符吗？”“哪里像，我只知道一点。”听我说完，上师又很高兴地说：“对，是这样，以‘了知’、‘经验’、‘证相’这三者来对应十地五道，这很重要。近来有人只有‘了知’就讲授‘证相’，还说什么无见无修无散漫，是什么见修为一，不要说这样的大话！对十地五道要有一个准确的认识，这也是一件非常重要的事。这《法界宝藏论》说它是大遍知者证相的面具，第九品以上指见、第十品指修，十一品指行，十二品指暂时的道果，十三品指究竟的果位，要懂得这实义去精读。”
    我猛厉地祈请大遍知者而读《法界宝藏》后仍然看不懂。有一次，上师问：“看得懂吗？”我说：“心部、界部、窍决部，特别是心部引用得太多，因为我觉得心部与秘密部的要点不同，所以就生起了许多种疑难。”上师说：“教言词可以随便拉，然而上乘的教言不能往下拉，而下乘的教言可以拉到上乘来，现在，我看能否给你讲一遍《法界宝藏论》。”于是就给我讲了。上师说：“你福报大，可以坐着就能闻法，我闻这个法的时候，阿吾仁波切是利用睡觉的时间，在竹庆雪山上给我讲的。那时候坐下来的话容易睡着，所以就用手捧着打开的《法界宝藏论》法本，往后退着走，阿吾跟着往前走，用了很多个夜晚才讲完。这个《法界宝藏论》是佛法的精要，阿吾将它视为最心爱的法宝，我也是这样子，你现在也要牢记在心中，按照所讲的这些内容准确地理解，就不会与心部相混淆。无上秘密续无文字，佛与持明者遗教以窍诀作了庄严，依与不依西日森哈所作的《大鹏金翅鸟翱翔》的两种讲授都具备了，因此它是口耳传承的窍诀。”于是我按上师所言，再读《法界宝藏论》时，就不像以前那样弄不懂了，终于看懂了一些。向上师汇报时，他说：“就这么做，逐渐地提高理解能力。从前，我叫林达·洛尔科看这法本，有一天，我问他能不能看懂‘三界轮回漂泊不漂泊，佛陀果位得到与不得，普贤法界无轮涅因果。’他回答懂得这个道理。他是有大证悟的人，有可能是懂，但这句话说得太大了一点，不要像他那样！这样对整体的佛法有害，另外也枉费了一个人的心机，也有害，特别是对没有福报的弟子更有害，所以说‘见要勇敢行要胆小’这句话说得非常好，确实就是这样。”
    有一次，我求上师传《智慧上师》，但他却说：“我年龄大了，眼睛也看不见，就讲一次无上秘密的《基、道、果》吧。”极密顿超的口耳传承无文字并有很多分类，上师用民很长时间来讲解，后来我也写了个笔记。在这期间，我还在阿朵喇嘛那里学了《经部》、《伏藏部》和《大幻化网》等坛城的设计和建造。上师要用木板建造一座《大幻化网》的坛城，虽然用了很长时间才建成，但后来还是起到了很大作用，到现在不管是讲还是修，我都有实际的经验与心得。”
    有一天，一个猎人持枪打死了一只獐子，我们僧众都念经，抖搂袈娑。这时我正好去上师那里，上师问：“你们这是干什么？”我将情况禀告后，上师说：“哦，你们颠倒了慈悲心，被杀的獐子是受报前世的果，死亡会一一减轻它的业力，还清业债，而杀生者是在造苦的因，从现在起，将在地狱受五百劫的苦和还五百世的命债，发慈悲心的话应对猎人发而不是对獐子发，我还以为你们有点知识，可连慈悲心都不懂，太蠢了，那高层次的十地五道就更难理解了！”又一天，上师对我说：“你很注重见，但还需要修一尊忿怒相，不然需要的时候没有，就像是遇到狗而没有打狗棒，我也曾有过只靠见的力量的时候，这样不好。”我问：“要近修哪一尊忿怒相？”他说：“一般来说，以前宁玛巴的持明者们以经部的《真实意》为意依，莲花生说：‘《真实意》如商人，而金刚橛像护送者。’因此这两者要结合起来修，就能得到成就，他们是成就的主要本尊，特别是要想发挥旧译密法威力的话，近修空行母、文殊忿怒和金刚橛这三本尊非常重要。”“金刚橛哪一个仪轨好？”“是《三利刀》，但这里不要说灌顶传承，就连法本都找不到。”“文殊忿怒哪一个仪轨最殊胜？”“除了《像铁蟹》和《铁蟹》两个外，其余的不是很起作用，阿朵喇嘛那里有《岗夏空行母》和《铁蟹》的法本，但暂时不用求，以后也许要这些传承，要记在心里。这次主要是注重学上师的窍诀，以后还要去学经论，但如到黄教的寺院去学的话，这一生的时间都会花在度量境界的哲理方面，噶陀寺才是我们的去处，可惜现在没有什么讲修了。竹庆方面据说也只有死了的讲解尸，不像从前格芒和阿吾在世时那样了。”
    后来，上师又说：“现在，你应该到竹庆去学习，因为喇嘛米旁仁波切过年时会到竹庆，以他的著作为主讲经说法几年。这是他的弟子俄萨来信告诉我的，所以你一定要去。”我说：“喇嘛仁波切米旁转法轮，能得到也好，但大智者的讲授，我这初学者不一定听得懂，自己也怕懂得一点经论后，这一生都会用在散漫中。上师年岁已大，在您住世期间，我无论如何也要留在您身边，若还能给我讲一点修持方面的要点是很好，但以前讲过的也已经满足了，我请求能留在这边实修，以后再不定住处地行走，在寂静的地方度过这一生罢了。”“说什么！‘离开家乡者没有修持，修持大法者很会积财’正如这么说的一样，不定居的到处行走，有一天会遇到女人而结合。在这里修，自利方面是可以的，但佛教讲修的太阳都快要靠近水神的怀抱而入睡了，利他不学经论不行！我对你有利他的希望，不要等我死！在没有学到经论以前，我病了不要来，死了也不要来，你必须要走！”上师的话很坚决，我什么也不敢说，心中想：像这样一位具法相的善知识，是如此难以见到，见到的时候，这一生即使能暂时依止也好，利他做不到也就算了。想到这里就流下了眼泪。“不要流泪，善知识没有见到该哭，见到后没有得到教诫该哭，得到教诫后没有断除增益该哭，然而，你已遇到了殊胜光明心髓的传承上师，甚深教授口耳传承的窍诀，已像由一个宝瓶往另一个宝瓶灌甘露般地得到了，自己实修后也能够彻底断除增益，独自实修的证量也达到了。我把心髓的法脉交给你，也是你该做利他事业的时候了，一定要去！”我说：“米旁喇嘛不来怎么办？”“如果不来，在竹庆寺也绝对会有能教你的人，要作好走的准备。”就这样，我不敢不听上师的话，便决定要走。上师又说：“回家去准备衣服和口粮等物品。”我将去竹庆的时候，上师捎口信来叫我，中午我就赶到了上师住地，但上师叫我天黑前不要去见他。天黑后我去拜见，他正在念诵功课，上师就以念诵功课所到的地方来观察缘起，正好诵到《帕当巴桑吉三十颂愿文》的结尾：“愿化身的利他事业圆满”，这句话重复念了几遍后说：“化身事业的利他圆满是佛地，对你来说是否高了一点？”又重复几遍。“能成佛的话高也没办法。”“这是开玩笑的，从遇到的颂词缘起来看，你这一生的利他事业方面没有任何违缘！修菩萨道期间需要圆满利他事业。”如此授记后又说：“现在我已年老多病，不知以后我俩还能否见面。阿吾给我说：‘年满五十岁之前不要讲大圆满，但从今以后，对来求法的人，你不管是求前行还是正行，要会看根器而分详细或简要地来讲，到竹庆寺学到经论后不要留在那里。噶陀寺是宁玛巴传承的源头，新彭塔耶菩萨想去，但却圆寂了，阿吾仁波切也去过，但除了前世斯度仁波切外，没有他人能起到利他的作用。阿吾叫我去，我也在香色山上闭了几年关，但没有人知道我是个喇嘛，今后有人来请你去的话，你要去，在那里你可以起到利他的作用。祖师们真切的发心真实不虚，敏珠林寺和竹庆寺都自以为很好，其实不是这样，他们只有几代上师的传承，还是新建起来的寺院。噶陀寺与他们根本不一样，从噶当巴法王师徒开始就已将宁玛巴的《经部》、《幻化部》、《心部》的法门传到曲波嘎日朗日以下，汉地交界地区以上。他的弟子中贤者、智者和成就虹化者有数千百个，召集过十八万僧众开法会，据说作布萨时，袈裟的光芒仿佛改变了天空的颜色，这句话是有根有据的事实。在那个时候，琼波以下地区除了当巴仁波切传承弟子以外没有任何宗派，萨迦巴、格鲁巴、噶举巴等宗派也只在卫藏有很少的种子，多康地区当时是发展噶陀传承的时候。如果以这些来看，现在有些喇嘛说我做的利他事业大，可比起他们，真是太渺小了！新彭塔耶菩萨和蒋杨钦哲旺波两位以噶陀为中等道场，可惜没有具备上好的缘起，这可能是佛法的一大损失。你到了竹庆后，不要空手去见上师们，无论大小都要供个曼扎。学的时候不要反复地学一个论，能得到多少就求多少，要找到讲授的传承和注释。光是词句的解释不是很难，对意义的要点，以思维智慧来分析，显密二乘的精要，要会归纳才行。要自己修的话懂得这么多就可以了，但要给别人讲，该讲多少才适合，要有一个彻底的认识。阿吾说：‘要学不分教派的论，光学一派是破智慧的因，若不分宗派来学，就能用自己的智慧证悟到对与不对，深奥与肤浅，哪一个与佛法相吻合等方面。’就需要这么做！心髓传承祖师们也是基本上全部不分教派地闻过各派的论和教诫，这些可以在他们各自的传记中看到，大遍知者对西藏所有的传承法门几乎没有不留下论的。生心的上师和生身的父母恩德同样大，时刻不要忘记上师，如果能具足信心地祈请，那就等于没有离开过我，这是因为上师的关心养育，是和弟子的信心连在一起的，这两者都重要。我们师徒不像其他师徒，以后在你父母没有过世之前，要留在家乡的山上修，过后，你自己会知道该怎么做。现在，把缰绳绕在自己的头上，你走吧。”说着，就将我供养的银子返赐给我，另外加了二十块银元和五十多条哈达。我在上师处出来后，向上师顶礼，上师喊：“回来！”我跑回他面前时，他说：“把你的手伸出来，我发个愿。”说着就诵了《上师心髓》的祈请和愿文。“现在走吧。”我再走出去顶礼时，上师又把我叫回跟前说：“以后我们父子见不到了，不要让我的口耳传承失传，尽量去弘扬，虽然具器者难遇，现在不用说得到大圆满灌顶传承的人，就连听过一遍此名称的人，也会在人寿十年期成为妙智空行母的弟子，在生有、死有、中有的任一界中一定能得到解脱，这是《阿底瑜伽大庄严》中真实不虚的授记。讲授正行时，受者最好是得到了《心髓母子》的灌顶，或至少也要得到《上师明点印》的灌顶才能讲，要不然就不能讲。这灌顶你自己能灌就自己灌，灌不了就请别的上师灌。”接着又给了我十三块红糖及囊增吉祥哈达并说：“我封你为第十三金刚持地阿阇黎！”随即作了安慰和赞美，还诵了圆满吉祥文，我念诵了“任何生处一切众有情……”等愿文而发愿。在上师处出来后，我悲痛得昏厥过去了，清醒时已泪流满面。当天晚上住在一位师兄弟那里，哭了一通宵，也很不想走，但又害怕违背上师，这可是最大的过患，因此我还是决定走了。


第二章（四）

    子年九月二日到了竹庆寺的西日森哈佛学院，借多敦家的房子安顿下来。那天晚上来了一位穿戴着缎帽、缎衣、缎鞋的夜叉向我顶礼并献哈达。我问他为什么这么做，他回答说：“这是遵守从前的誓言，您是阿里班禅时，我护奉您作为萨伽法王的帝师；您是洛桑嘉措五世达赖时，我护持您为蒙古王的供养处，您都想不起来了吗？”我说：“我想不起来。”那夜叉说：“嘿嘿，这是胎垢障，从今以后我还要护持您。”我认为这是此道场的土地神也很欢迎我到来的一种征像。住下后，米旁喇嘛还没有到竹庆来，听说要第二年才来。过了几天，我在一位叫阿翁登孜的喇嘛处学了《中观庄严论》的细目和注释，还简要地学了他作的《广论》和简略的《讲程》等。他每天都赞美《中观庄严论》的中观与因明就像双狮奋讯，讲授快要结束的时候，我问：“这双狮奋讯怎么理解？”他答道：“俗谛量所立法用真谛哲理来灭，而真谛所分析承许法用俗谛量灭。”对这点我感觉不是很妥当，就说：“这与‘坐乘两宗马车上，拉着哲理之缰绳’这句话不吻合，如果这样，这二谛不就成了无立无分了吗？”他是一位很温和的人，听后没有半点生气地说：“那你是怎么理解的？讲来听听。”“我认为，众生本来的执著用真谛哲理来灭，而宗派所立的胜性和自在天等用俗谛量来灭。”他考虑了一下说：“就是这样，就是这样。”此后，他凡是遇到难题都来问我。听说他向师兄弟说：“这次新来的一位学员很有智慧，讲课时要谨慎地讲，随便地解释他是不会满足的。”后来，我们这里来了一位米雅喇嘛仁增多吉，他在米旁喇嘛处住过十三年，据说是位很有学问，名气也很大的人物。在他那里我学了《中观庄严论》正文和注释、米旁所造的《释量理宝藏》及多丹拉桑所作的《定义的注释》等，对这些也有了一点认识。但当时我还没有学到《释量论》，所以对米旁作的注释《语分辨》等，还不能完全理解。
    在古色喇嘛白玛旺钦那里学了《八大行法的注疏》、《大幻化网总纲光明藏》、《真实意密释要义》等。过后在洛色堪布处学了《释三戒定量·如意穗》、《三戒简释》及噶玛额勒的注释等。西日森哈佛学院的大殿上有一座大幻化网的殿堂，后来我在那里得了很满意的《大幻化网寂静忿怒》灌顶，还得到了无著的《庄严经论》，荣敦著的《定庄严》、《二分辨》(《辨法性论》、《辨中边论》)，多(布巴)著的《释宝性论》、《释大幻化网除十方迷暗》、《释(大幻化网)三宝》，佣敦著的《释大幻化网庄严花》，荣桑(法贤)作的《入大乘论》、《相即本尊》。阿拉丹达作的《功德藏》的正文和注释，虽然没有它的讲授传承，但它写得非常好，洛色堪布也给我传了。多珠钦著的《一滴海水》，阿吾仁波切著的《疑难题》、《大圆满心性休息》正文注释和讲义，耶玛朗索著的《幻化休息》正文、注释、讲义等他都很慈悲地赐予了我，他是我第一位大具恩上师。
    在现任堪布索朗曲彭，又叫协珠曲吉朗瓦那里学了阿吾的《释般若现观庄严论》、《总纲》，宗喀巴大师著的《格言金链》、《般若禅定的次第》，托(美)所注释的《入菩萨行》、《禅定次第》，米旁喇嘛所作的《智慧品》，根索所著的《智慧品纲义》等。此时，我对应成派的见生起了非常大的信心，然而还没有完全理解，因此祈请了上师和本尊。放假期间的一天，我去山上散闷，找到了一本用黑色丝绸布包着的《智慧品》，从此，对应成派的见就有了新的理解。后来，在西日森哈佛学院大殿内，索朗曲彭堪布以对大众所讲的方式，讲了一遍《根本续大幻化网》，又以学习讲解的方式讲了一遍《大幻化网意庄严》，这是文仁波切丹增洛布的讲授传承，是给少数几个人讲的，我也得到了。此后，索朗曲彭堪布依《八大行法》闭关了六个月，我作了护关。在他下座期间我向他学了龙树菩萨著的《中论》，嘎拉吉美达瓦作的《注释》，月称论师著的《显句论》，玛夏瓦著的《注释》等。开始学的第二天拂晓，出现了这样一个境相，我见到显比丘相的龙树菩萨像如来般庄严，手里拿着一函《中论》放在我的头上诵“生起因缘何人知……”等供养词偈后又重复了三遍说：“愿知道生起因缘。”依此缘起，我就能很容易地树立起生起因缘无本性二谛的宗旨。五哲理全部学完后，他接着又给我讲了月称的《入中观论》注释，邬金丹孜罗布著的《释智慧明灯》，增·西日色吉都谢造的注释以及主要指唯识派护法阿阇黎的注释《中观四百论》。月称的注释等虽然没有讲授的传承，然而《丹珠尔》内有念诵的传承，所以也讲了。此后，还学了《如意藏》正文注释的《讲义》，米旁喇嘛著的《简论宗派》和《第十八品的疑难注解》，阿吾著的《自始自终行善的话》、《看大乘经的功德》、《说寂静山的话·天鼓声》、《十四戒笔记》、《讲授大乘中观见》、《噶当巴祖师们的开示录》等的讲解和部分传承。还得到了《直指心髓气脉》等等传承，因此，堪布索朗曲彭是我第二位大具恩上师。
    在阿拉噶敦嘉措的转世那里学了《诗学明镜》的第二章，还学了博克巴、康巴两位的注解。在弥拉喇嘛处学了历算方面的《五简要五曜星》、声明学的《妙音经典》，阿吾造的《韵律》及协忡写的《词藻》等。在敦萨·巴瓦喇嘛多安那里学了米旁造的《四部医典的注释》、《二分辨的注释》、《修供文殊仪轨》和斯度曲古炯列著的《语法三十颂》、《时态发音注解》。此后，弥[日/阿]屙珠古白玛德钦桑波来到了竹庆，他以竹庆寺的仪轨很隆重灌顶了《根本续寂静忿怒百尊自然解脱》广轨，凡遇者都能自然解脱的《六道有情自然解脱》中轨，《朵玛灌顶》简轨，《触者皆得法益》，并传了《六中阴界的讲授》、《观本来面目》、《二正文函》的念诵传承和《智慧上师》的讲授，额敦丹增桑波作的《空行心髓的讲授·白色的解脱道》。在西日森哈佛学院的大殿里，按照阿吾的讲授传承讲解了共四品的《入菩萨行》，受了深义传承的菩萨戒。在索曲堪布的禅堂内，受了广行传承的菩萨戒，他还给诸闭关者按照广轨，灌了很多天《上师意集》顶。索曲堪布是在任堪布，因而需要传很多戒，每一次传戒时都让我去作羯摩。有一次我就请求说：“我复习功课非常重要，能不能另找羯摩师。”但堪布说：“不行，这也是亲见传承的实际实习，非常重要，要会执行，你以后也会有需要的时候，到那个时候想学会很困难的。”还有一段时间，需要我作佛学院的辅导老师，解答和讲解大家提出的疑难问题，令我感到很劳累。
    在此期间，我还在益喜坚赞堪布那里学了《大幻化网总纲·格言之海》、《曲扎的笔记》。贡秋洛布堪布在阿吾那里听过十三遍《入菩萨行》，一辈子专修菩提心，我请求他按照阿吾仁波切的传承给我讲一遍《入菩萨行》。他说：“我不会讲什么大法，目前的这些学员只会探讨别人的话而已，对他们讲了并没有多大的意义，但是你跟他们不太一样。明天就跟你讲，但不要给任何人说。”《入菩萨行》的正文和细目他都能很流利地背得下来，阿吾于此是这样说的，于彼又是那样讲的，应该怎么去思维，止观二道的修法与窍诀如何结合等等，他都讲得非常好。这样用了一个月的时间讲完后，他幽默地问：“我讲得怎么样？”“很奇妙！”“对，竹庆寺还说我不懂经论，懂是懂，但懂也没有用，，遇不到一个求来世解脱和此生实修的人，因此我一直没有讲解。你学过《戒律根本经》吗？”“没有学过，您能否恩赐？”“这不行，我只专修菩提心，对其它经论没有闻思分析，眼睛也不好，依不了经文，你要向其他人求。戒律是功德的基础，以前这个寺院的戒律行持非常严格，现在开始松散了，只以中观应成、自续的派别争论去对外看，而没有多少向内心作对治的人，这戒律需要有好的基础、比较稳定的心和非同一般的智慧，不诈现威仪，炫耀卖弄，而需要一个真实的出离心，虽然开始做不到，但要慢慢地改变趋入。我听索曲说你也是一位基础不差的人，去索曲那里一定要求到戒律才行。”我把这些话记在心里，就在索曲堪布前求到了《戒律根本经》、文仁波切的《注释》，《释律经宝链》，措那瓦作的《注释》，根敦主编著的《持戒因缘》，宗咯巴大师造的比丘和沙弥学处《飞翔空中》、《别解脱戒注疏》、《律经妙花链》以及夏迦谢尼所著的《释律经》，比玛拉所著《释律经》。索曲堪布又赐给我他自己用的《律经宝链》和《持戒缘起》，嘱我看此二书并说：“现在这里养成了一种迷在小注释中，没有人去看大论的风气，讲因果的方面只有靠律经，没有其它别的哲理来分辨。”
    此后，将格西根桑索朗的亲弟子阿呗被请到竹庆寺来建立《俱舍论》的讲授传承。竹庆珠古仁波切要在本寺和外地来的僧人当中选十位比较聪明的人来学，我的名字也列在其中。阿呗是位大善知识，讲《俱舍论》时大部分的正文和注释都能流利地背下来，他注释的前半部分与《王子》、《岗呗》、《钦释》等大小注释连在一起来讲。开始几天我们连词语都理解不了，大家都很泄气，认为学不会。我去了西日森哈的山上，在具恩的阿吾讲《俱舍论》时(曾坐过的)像宝座一样的大石头那里发愿，我虽不懂《俱舍论》，但想结个善缘，便将正文部分念了几遍并发愿能领悟它的本义，这样发了很多愿后就在那里睡着了，梦见世亲论师穿着一件蓝色的背心和三衣，头戴一顶像山林僧人的短耳帽子，是在印度的某个地方，模模糊糊地忆起了我是安慧。世亲念诵了“何人彻底消除了黑暗……”等供养偈后又说：“钦的大注释如实地讲解了《俱舍论》，以它为主来看，就会懂得《俱舍论》。”听完这句话后，我就醒过来了，于是马上去根桑拉丈处借钦的注释，看完后真的就完全明白了。《俱舍论》讲到一半的时候，果洛和竹庆的人互相闹矛盾，大部分人走了。到最后全部学完《俱舍论》的人只有佣夏堪布、格吉喇嘛、多利和我四位。后来，我将传承供养给了再任堪布拉甲，因此在那里传承还算没有断。我还在堪布阿呗那里闻了《修心格言汇集》、《故事宝垒》，根桑作的《修心发愿开示录》等。
    开春时，米旁喇嘛由邓科来到了竹庆，竹庆寺的僧众列队举行了隆重的迎接仪式，我也在迎接时和他见了面。他住在西日森哈的大殿，我通过他的亲弟子俄萨帮忙又拜见了他，本想求一个法，但他说暂时不行。一个月后，他就搬到山上小森林中开始写《智者入门》的论。直到五月我去拜见时，他说：“今天是鬼宿星木曜结合的吉祥日，《智者入门》的论也写圆满了，这个缘起很好。”就从论的开头来给我传，“这个论叫《智者入门》，就像是三智者进入的门一样，它与萨迦班智达的《智者入门》相比有更显著的特点。这个口诀要背诵，是口诀而不是正文。”前面开始讲解一点后便念诵下去，隔一段念诵一段再翻一段，这样到了晚上才传完。他把《论》放在我头上说：“从头到尾没有全部念完，此法交给你了，我是论的作者，得到我的开许，今后你可以讲授，如果你能够讲授此论的话，将会出现很多智者。龙吉前后来了几封信说要给你俩(阿格和多利)讲授，我有关节炎的毛病折腾着，加上年龄已大了，所以不想讲解，能够写几部论留下来的话，希望能对宁玛巴起到一点利益的作用，但因为现时代的原因，恐怕很难起作用。若新彭塔耶菩萨能够长住世的话，将对宁玛巴的传承利益很大，他正在开创新的局面，然而由于此派福报不够而圆寂了。除了他，在宁玛巴中精通经论最好的算是喇嘛龙多，此后是索甲和多珠钦，他们的知识也不差，其余的就没有什么了。我以前去噶陀寺，为斯度珠古讲授《五部慈氏论》等，那时希望能建一座佛学院，但没能建上，现在斯度珠古想建一座佛学院，他给我来了几封信，捎口信的人也有几个，看来我去不了，如果今后他的愿望实现了，你一定要去帮忙。”说着他就赐给我用布包好的《真实名经》和七颗文殊甘露丸等。俄萨也是具恩上师龙多的弟子，所以经常关心我，帮助我。有一天他对我说要供一万盏油灯，叫我去帮忙。我就在他那里帮忙了几天，同时在米旁那里求了《心义手持佛》等四十多页的传承，通过俄萨的请求，还传了《圣妙真实名经》的授权和《圣妙真实名经九重光明》、《修诵》的灌顶。米旁说：“这是我按文殊续部写的，以前还没有传过，加持力非常大，你要抄的话我可以借给你法本，但不要给别人看！”就这样，我将法本请到西日森哈山上的一个石洞里抄了下来。去还法本并向他请求灌顶时，他说：“灌萨班确美的那个顶就可以，没有其它的了。灌顶灌不了，给你念个传承。”在念了修诵仪轨的《如愿文》、《长寿仪轨》、《供施红白朵玛仪轨》传承后，又传了一点事业方面的仪轨。剩下的事业方面传承也在俄萨那里听完。米旁嘱咐说：“今后你在没有近修完之前，不要传给别人。”后来我是在近修了三次，将事业部全修完后才开始传的。在堪布索曲那里还学了《反驳文光明》，萨桑作的《释大乘阿毗达摩杂集论》、《瑜伽师地论》、《摄大乘论》，世亲的《三十论》，得到了噶玛拉西赖的《修行三次第》等传承。在第五世竹庆仁波切那里得到了《极密皈依总集》的灌顶传承，在珠巴格钦曲英若比多吉那里得到了《上师意集》的灌顶传承。
    通过三年里的二十四个月昼夜地修持，努力地学习，到虎年秋天我准备返回家乡时，有一天，珠巴格钦从他的住地白玛塘捎口信来说：“今天拿一把铜刀来剃头。”当我拿着铜刀去时，他笑着说：“我今天是灌《空行心髓》的顶，怕别人听了跑来，所以说了个假话。现在你和布洛其塔去把房间整理干净，供品和庄严都需要具备圆满，没有准备好之前我到外面去坐一坐。”说着就到外面围廊内坐了下来，到下午看准备好了才进来说：“这《空行心髓》是大成就者竹庆巴把法的名字变作人的名字，是个独传的灌顶，只能传给一个弟子。敏久朗卡多吉传给了我，现在我想传给你。扎达嘎玛给我授记说：‘今年如果能在雪山中闭关三年，就会圆满弘法利生的事业和延长自己的寿命，如果不这样的话，四十四岁这关很难过。’有关我自己的授记中倘若今年不死、能长时间住世的话，就可到莲花光明中去，今年死的话，就要到雅垄地方去再转世一次，然后再到莲花光明中去。”我求住世说：“您一定能住一段时间，需要我为长住世做什么闭关修持的话，多少年月我也一定去做。”“说什么？谁也不愿意死，但我今年有死的征兆，也曾多次有空行母来迎接，所以这个灌顶一定要交给你。”我说：“那么多利喇嘛也可以来求吗？”“别人听不到的话也可以。”于是他修灌顶，我作供司，其塔去叫多利喇嘛。我拿着朵玛到外面时，见到围廊外面有很多不同种族的女人，跑到上师面前解释说：“外面来了很多女人，可我没有给任何人讲过，是不是其塔讲了。”“有你认识的人吗？”我说：“没有。”“哦，这些不是人，可能是空行母的聚会吧，晚上会供时，要在屋顶供许多供品才行。做如愿仪轨的时候，会出现许多跳舞的骷髅，这些是心髓的护法，此时不能散漫，要入定境，看你的境界高不高。”这时，多利他们俩也从西日森哈佛学院赶来了。那天晚上做好了前行准备，第二天正式传正行。上师说：“如果你们没有发愿曼扎的话，我不敢灌顶。”于是，其塔发愿说闭关一百天近修《上师明点印》，多利喇嘛发愿要修一百天顿超。这时，我前后的别念在法界中消失，安住在明空赤裸的智慧中，灭了分别念，口里什么也说不出来。上师问：“你现在发什么愿？”我什么也想不起来，就说：“请您来决定。”“这样的话，你就把《空行心髓》讲授十三遍吧，不能随便讲，要通过实修，得到上师和空行的开许后再讲授与弘扬。”我如是发愿后，就受了灌顶并发了愿。会供施剩余供品时，看见有很多骷髅在坛城边舞蹈，我想将剩余的供品供给他们，上师说：“供品拿到外面去供。”我拿着供品出去时，看见外面有一位金刚玉珍玛，显出很美丽的女人相。灌顶结束后，上师说：“多利和其塔回去吧，阿里留下来为我收拾东西。”那天晚上，他俩回去了，我就住在上师那里。早上收拾灌顶坛城时，上师问：“昨天灌顶时你看到了什么？”我于是禀报了所看见的境相，上师又问“对骷髅们有恐惧，对女人有贪心吗？”“没有，我的心进入了无缘的境界，就像是看到小孩在玩耍一样，进入了一种不会言论的境界。”“哦，就是这样，在法性本来面目中，一切有为法都纳入法性本来面目中，自己就能役使空行母。你以后不会遇到违缘。”他这句话是预见我未来而说的。
    此后我回到了家乡。这时，具恩龙多上师已在前一年的五月二十五日圆寂了，整片大地都变得如茫茫荒漠一般。我来到上师的住处，向灵塔供养顶礼，看见灵塔的顶上显现出一个涟漪般的彩虹明点，中间有一尊金刚萨埵像。我在这里以修上师相应法为主，多次出现上师身、语的相，我了知这是不离上师加持与摄受的征像。此时，从达霍荣和茫康两地来了几位求法人，于是为这两地为首的几位求法者作了《慈氏五部》等经论的讲解。在讲《功德藏》的第一天早晨，整个地方都遍满了彩虹。讲《功德藏》的同时也修了十万遍会供。为了满上师的愿，还简略地讲了一遍《入中观论》。在灵塔前各作了十万遍顶礼和供曼扎，念回向，为弘扬佛法念诵了很多遍米旁写的《教法兴盛发愿文》。听到具恩上师的声音说：“大勇金刚古玛[日/阿]屙，与你结缘十三世，善与恶业之诸缘，莲光会融入大地。”又以《心髓的金刚橛镇压魔军》的仪轨做了三个月闭关。生起次第的本性圆满了四直捷的密意。此时，出现了很多外界所造的违缘，但密乘的护法均予以保护。后又依《四轮修法仪轨》，近修了《新伏藏经典》三忿怒之一的《文殊忿怒》，结行时也作了朵玛，将朵玛交给僧人拉甲送走，他后来说朵玛上生起了自然火。晚上天地空间的瑞相很多，特别是大家都看见天上很多星星象流星似地飞舞。补阙的护摩灰撒入河水中时出现了很大的响声。当时是最寒冷的季节，撒灰的河流周围一百米内的冰全部融化，如此具加持力的证相出现了很多。
    那时因辽绒战乱，住在这道场不安定，只有到上师住过的地方四处云游，近修了心髓的《忿怒大吉祥集》和《空行依怙主兄妹》。密乘佛法母给我看一个松耳石般很明亮的镜子，镜子中显现出普贤王如来佛母。在佛母的心轮中有一“啊”字，她说：“现在是弘扬大圆满的时候了，我给你护持。”说着将头发变成像羽毛一样来遮盖我，于是便出现了无边无际光明无分别的证相。后藏的大护法当今·多吉勒巴拿着装有打铁的锤、钳等工具的盒子给我，打开后看到盒子里面有铁的锤和黄金的锤，当我不知道该拿哪一种锤的时候，他说：“拿黄金的锤子能增长财富，拿铁锤的话能降伏敌人，但只能选择一个，不能两个都拿。”我就拿了黄金的锤子。
    那时候，我经常想到这样一件事，心髓的气脉如果有一个详细的讲授，那么内三乘的根本窍诀就会圆满。一天晚上，持明者无畏洲身穿白袈裟显出普通咒师的模样，在像莲花绽开一样的桑耶青蒲中间，给我传了口耳传承、拙火定和动作等等，连续几天都有这样的征像。由于没有能够真实传授的把握，所以我没有给别人讲。到嘎定日绰后，我近修了《大幻化网寂静与忿怒》和《续部文殊》，也为“种事业”诵了十万遍缘起咒。冬天最冷的时候，供曼扎时作供品的粮食掉在地上发了一卡长的芽，使我认识到这就是缘起没有本性的缘故。在那里为二十多位弟子灌了《大幻化网寂静忿怒百尊》的顶，并讲授了《大幻化网》的注释《密主意庄严》。不久，以严格的闭关，早、晚来修顿超。一次修持时，现出明点虚空灯像面盆那么大，有五层。由于对心髓传承祖师们信心和观想的缘故，寂静忿怒报身佛与刹土的相遍满了整个虚空，明智妙用金刚链细微智慧融入内境，消失了所有证相的执著外壳，到达了明空赤裸的智慧本来面目中，外境与内心的分别全消失，在光明大圆满见中安住了半天。下午俄色喇嘛来说：“我认为您是病了，看来不是病，是睡着了。”说着就开始生火。我以烧火的嚓嚓响声为缘起，根识在外境中苏醒过来，此后生起了直穿智，消除了一切相的执著，无执著的相没有是非专注，极细微尘和极短一刹那的生灭，都成了六根的现量，大小烦恼的别念全部消失，爆发出最殊胜的妙用抉择通达诸法之智慧，证得了高层次十地五道的外内不共证相，如此全部都亲身体会，生起一切相无执著的功德。此时，金刚铃掉在石头上，石头上有铃的印，铃上有石头的印。修供的泉水干涸时，在涸泉处作了供龙的朵玛，用酥油做的鱼和青蛙等变成了活的动物，同时，涸泉也流出水来了。
    嘉果珠古根桑特确丹比坚赞为求《如意藏》和《三休息》的讲授而来，我给他讲授完毕后，他有《心髓母子》“康”的传承，我又从别处得到了这个灌顶传承，并按自己的财力供了较大的曼扎，随后他回去了。我闭关近修《空行心髓》空行修法的外、内、密和《修屠夫之命》等法，写了《伏藏主伴神的供养》，近修了《上师心髓》的三根本·广轨和简轨等。第二年，在一座叫齐科的山上近修《空行心髓》。一天晚上快要入睡时，来了一位身颜红色的可怖妇女，指甲像铁钩一样弯着向我抓来，因此我的心识就像射箭那么快地到达了密严刹土佛主之母金刚亥母所住宫殿的东门，一位身颜白色的女子手持青金石宝瓶为我沐浴。沐浴后；她重复三遍念诵“喏，忿怒威怖之身相……”等《空行心髓》的进门词后，坛城的门“哗”的一声开了，同时出现了像阳光中尘埃那么多的跳动着的食骷髅、鼓骷髅、跑骷髅、供骷髅、屠骷髅、淫骷髅等等相，使我无分别地呆了一会儿后，骷髅们也不跳了，我也根本没有现在的相，而只有白玛萨公主的相，身穿紫红色的绸缎衣，以宝石、花鬘作庄严。前面的女子献给我一朵很大的红花，嘱我抓住她的手把我带了进去，进坛城后，看见以金刚忿怒母为首的寂静五部，有千百万空行母围绕着，我在主尊前面一座往右旋绕虹光太极图的红色莲台上安坐，准备解下头上的花鬘时，领我进坛城的女子说：“不用解下．这是莲花生赐给你的帽子。”这时，主尊母以《空行心髓灌顶宝灯》依次灌顶，我将先前得到的那朵花供养给主尊母，她赐我秘密名为：俄萨仁钦宁波白玛愣遮杂。宝瓶灌顶后的三灌顶连着《灌顶母释》，接着，妙用的上两个灌顶偈词都是由主尊母的主首来念诵的，咒语则是头上的亥首念的，大心髓的讲授也赐予了我后，所有的空行母都诵了灌顶的吉祥文，主尊母说：“这是分给你的财物。”于是便送给我能远照的白银镜，一套紫色缎子的衣服、黄金和松耳石所造的装饰品，还有五十四骨块组成的紫色嘎巴拉，每一骨块都有《空行心髓》的法宝，像魔术般地显现出来，又灌了一宝瓶灌顶后叫我离开。我请求说：“人间很难住，请让我留在这里吧！”“这次不行，这样会对寿命有违缘，你是《空行心髓》的法主，以后还可以来，这次回到人间后，该作利他的事。”于是，嘱北方的主尊母送我回去。我跟她一起到北面的门，走了一会，看见一个很可怕的尸陀林，林中有一座头盖骨的宫殿，里面有五部忿怒母。主尊母手持明镜和嘎巴拉，口诵着“嗡，嗡，嗡，顿超的明智妙用灌顶”，没有全部念完就诵吉祥文，此时下了大花雨，“喜日所帝”的响声周遍十方。主尊母向北方的绿色忿怒母交代说：“把他送到无违缘的地方去。”于是我俩就像鹫寻找食物一样地飞回。那位事业空行母落在我的躯体上时，我躯体的头顶上出现了尸陀林主母，她像麦多哈洛花的颜色一样，非常美丽。她跑到前面时，我从顶轮进入，六根显外境相时，事业空行母嘱咐着尸陀林主母，并任命地为护持《空行心髓》的护法神。此后一段时间，我一直都觉得有这位尸陀林母跟随在身边。我在那座山上修了一次大妙用的朵玛，晚上的境相中，我到了一个刹土，见到具恩上师坐在那里，我顶礼并领受加持后，上师叫我坐在上首位置的垫子上。我要将自己从离开上师后的修持情况作汇报，但上师不听，而像唱道歌一样地唱诵着阿吾所著的《上师祈请颂》。后来又接着作印证，上师说：“证相好！”我说：“大遍知者的秘诀讲授和窍诀直指都很奇妙。”上师说：“遍知者法王没有什么奇妙之处，我的具恩上师巴珠仁波切修头陀行，这个很奇妙。”我问：“比他更奇妙的还有吗？”“你的上师古玛[日/阿]屙杂更奇妙。”上师说此话的同时，出现了一位少女和一位少男，喊我去见古玛[日/阿]屙杂上师，于是我跟在他们后面，到了雅朵香披岗吉[日/阿]瓦一块明镜似的草坪上，大持明者古玛[日/阿]屙杂就住在一座白布帐蓬内。帐蓬的门关闭着，我们在外面顶礼祈请时，里面传来三次“你是谁”的询问声，我不敢回答什么。跟我一起来的那位少男说：“这是有缘亲弟子阿格旺波。”经他这样一说后，我一刹那想起了自己就是大遍知者。待打开帐篷的门进去时，发现这帐篷原来是个宫殿，里面的设施奇妙无比，不可思议，古玛[日/阿]屙杂上师显出修苦行的相，我求了加持后，上师一刹那就现出了大持明者极喜金刚相，上方有大圆满十二佛在传法，宫殿内廊有六十四刹土为首等不可思议刹土和佛的化现，也有无数的众生，很像一座踊跃颤动的幻城。我安住在法性实义上师的本来面目中。我的男伴说：“六十四个十万佛在讲大圆满等量续，要注意听。”我专注地去闻法，这时所有佛的音都融为“啊，啊，伊，伊……”等，还听到极喜金刚说“虚空雷轮续”这句，其它都未听到。我心里想：“如果有这个名字的续，那么何人能持这个续并修行呢，也不知有多少颂？”正想到这里时，带我来的那位少男变成了黑依怙主勒德囊波，手持木棒和嘎巴拉，那位少女变成密法主母，手里拿着人皮棒和誓木，他们说：“心识分类而区分，过去未来与现在，以时得续之名称，可知现在分偈颂，不说不可说法界，所化不同显异相，远离一与异之边，悉皆圆满三界中。”为此，我想刹土、佛和众生的相虽然看上去无边无尽，但这些全部都不是自心世俗体，而是上师的慈悲与智慧的妙用无二无别。因此我想，向外求成就就好像小孩沉迷在游戏中一样没有意思，应该向内求与明智实义上师心心相印。当念了“大持明者古玛[日/阿]杂知！”的祈请后，所有相都像水与水汇合起来一样融入大阿阇黎极喜金刚的身上并变成了浅蓝色的光，在大遍布的明点中消失后，古玛[日/阿]屙杂显出如前的比丘相坐在班羚皮垫上，在我猛厉祈请并恳求摄受后，上师说：“我从前已赐给你全部的《大圆满十七续》母子、口耳传承和窍诀等的灌顶讲授，但现在还是重新给你加持吧。”说着就拿了一枝在上段有孔雀羽毛的藤条，在中间处系着的一块黄色绸布上，用朱砂写了大遍知者隆钦饶降岗夏让卓杂，并把它放在我的头上，眼视虚空加持说；“啊，啊，啊。”此时，大持明者以前的全部灌顶讲授我都想起来了，一切疑难全部自然解除，词语和实义两方面都得到了不依别人决定的了义识，这是大持明者古玛[日/阿]屙杂的恩德。这也是为了我传承的后学者认清和相信传承的来源而写在此。
    我快到二十九岁的马年十二月，具大恩的生身母亲得了胆结石病，接受治疗、吃药和念经都不见效。伏藏大师仁钦林巴打卦说要念诵五大王的修供一千遍。我们师徒几位一起修供，在修供了一千遍的当天晚上，我快要入睡时，听到马蹄声和铃声，感觉来了很多骑士，我一看，原来是来了骑着马的五大王护法，马鞍都以绸缎和宝石作庄严，他们身穿深黄色的绸缎衣服，佩着铁剑，戴着帽子，上前向我顶礼说：“由于您的圣旨太威严，我们由白嘎国库赶来，到这里来一趟是不违背从前的誓言，但您母亲的疾病并不是暂时的违缘，而是业力因果所致，故不可改变。”他们说完就不知去向了。此后，一位应该是则杰白玛吉的女孩也来给我说：“您的妈妈的病是前世的因果，她的寿命快要结束了，我们江扎姐妹也没有办法，请看那边！”我一看，在老母亲的病床有一位身黑色的女人，头发和胡须都是金黄色的，上身赤裸，围着虎裙，垂足而坐在宝座上，周围有很多妇女准备抬宝座。接着这景象就消失了。妈妈也梦见一位僧人拿着一把金扦子(割脉刀)，自称是我派去的医生，从她肋骨间剖开，拉出很多像马尾一样很细的线。这以后的十三天，妈妈没有什么病痛，但过后又犯起病来，前后四个月我不分昼夜地发慈悲心和修苦乐交换，同时也作了服侍。这样，我觉得消除了自己的罪障过。
    羊年三月十日晚上，我睡了一会儿，梦见自己是娘班·定孜桑波，在卫拉日姆石岩北方的一个刚好可容一人的修行洞内修行时，面前来了一位漂亮的妇女，她身穿五层五色衣，外面一层是陈旧的绿色衣裳。我正想这是谁呢？这时女孩说：“女孩我从二十四域来，本性是一显出了异相，金刚亥母甲那班嘎[日/阿]屙、密续主母除我有何人？！”接着赐给我《文殊大幻化网》的灌顶和讲授，又说：“哦，从今以后，整个西藏所埋藏的一切伏藏、灌顶传承你都有权讲授，但伏藏物的用处不大，要讲授以前的伏藏经典。”她像变魔术般地脱下内衣，并把这尚有余温的衣服给我穿上，由此缘故，我安住在乐、空无分别的境界中。从此以后，外相的炎热与寒冷，石头、木棍、刺等的触全都变成了乐的因，这个证相持续了一个多月。后来，在三次灌顶传承《大宝伏藏》期间和作其它灌顶传承时，都没有一点违缘，这与胜圣的生身诸佛之母的加持力分不开。
    四月初十，我的老母亲去世了。当时出现了地震，空中呈现光明等相，从她去世到火化，前后多次出现了奇妙的征像，但由于在末法时代，人们也许不相信，所以就只写这一点。此后，我还到辽西圆林供了万盏灯，诵了三千遍《普贤行愿品》。可能是心清净的缘故吧，反正融化的酥油增多了，在供台上出现了供品云藏，凝固的酥油上也自然显现出八吉祥图和八吉祥物的相，这些现象大家都看见了。
    在伏藏大师阿旺丹增仁波切那里听了《旧译续部》的传承。一天，伏藏大师对我说：“我们俩生生世世有互为师徒的因缘，明天请你给我按《(密主)言教》来简要地讲授《意庄严》，我需要闻此法。”于是我给他作了法供养。求完《旧译续部》的传承后，我去下一次竹庆寺，在拉甲堪布处学了《释量论》，学“他利比量”时比较困难，在祈请特殊本尊(文殊)后也能完全理解了，当时还写了《文殊赞》。在堪布新嘎前学了果让巴注释的《入中观论·消除邪见迷暗》、《妙乘中观总纲》、《现观庄严论·疑难解答》及新嘎堪布写的《入中观论注解·自立宗派》、《隆钦心髓气脉明点》。给拉甲堪布新嘎堪布他俩供养了《三句精要捶击句窍诀》和《制伏迷误的狮子吼》。在堪布索曲那里学了《智者入门》和《反驳绕萨问》，给他传了大圆满的立断口耳传承，简略传了《智慧上师》。在八个月内，为初学者供养了各自所需的法，晚上在油灯下还传了《智慧品》、《戒律根本经》、《三律仪论》等经论。本来想在竹庆多留一段时间，但由于太忙碌而感无法安宁，于是准备返回辽西，竹庆仁波切说：“按本寺的堪布规章，虽然不许外来僧人作堪布，但文波和龙多二位与我们本寺的喇嘛没有区别，所以你在拉甲堪布任期满后担任堪布吧。多日的房子、白渣的房子、洛甲的房子和洛珠的房子，这四套房子中你喜欢哪间就送你哪间。”管家也特别对我说洛甲、洛珠两位的房子，我要是喜欢的话，用具及眷众全部赐给我。然而我想起以前具恩上师龙多给我说过不要长期住在竹庆。便以这句话为由而没有住下来。
    以曲英惹比多吉著的《大修供仪轨》，我学习了伏藏大师嘎玛林巴《寂静忿怒大修诵仪轨》的仪轨。在白洛维那和根桑旦匹供师那里学了《聚集大法会修甘露丸》仪轨等。在达科地区，由噶陀寺出资修了几天《寂静忿怒百尊》大修供，我修改此仪轨后，还首创修十九次大修供。那时，外面的彩虹像柱子一样直射修法堂，甘露丸也不断地增加了很多。虽然是秋末，但是设坛城的地方也开了许多花茎很长的白花。装甘露丸的宫殿中自然出现了很多佛像，黑小的诃子突然出现在药粉中等等，我想这是一个只要尝到此药的有缘众生都能获得解脱的瑞相。后来，按斯度依怙主的指示，将此修供改成《寂静忿怒八大行法修甘露》。《八大行法修甘露药丸》我按敏珠林的传承作了十五次修供。此后我就住在辽西圆林，冬季准备为外来的僧众念《七宝藏》的传承，首先灌了母经“空行母”的顶，灌顶时嘎巴拉里的水变成了色味非常好的酒，明镜上自然凸出五方佛母的种子字。开始念《七宝藏》的那天，来了一位以宝石、珍珠作庄严的妇女参加闻法，后来不知去向。本地僧人以为是外地来送供养的，外地僧人又以为是本地的妇女，实际上那是金刚玉珍玛欢喜的征像。讲授《心性休息》那天，整个山川都遍满了彩虹，虚空中也有很多光团，在这些光团里下了像刺藤树花那么大的花雨，下午大部分彩虹都降落地面，有一部分彩虹升到空中，大家都感到很奇妙。我的心完全没有别念地进入法性，不管出现什么好坏现象，也没有分别心，进入了诸法一味的大圆满境界中安住。一天晚上，梦见一位头和背都戴满琥珀作庄严的妇女，骑着一头骡子来到这里，叫我立刻跟她走。我问：“你是谁？到什么地方去？”她说：“我是旧译经、幻、心三部的主护法母，名叫热玛德，你到噶陀寺去作弘法利生事业的时机到了！走吧。”我说：“我不是什么大喇嘛，不适合到那么大的道场里，在这里培养小小的几位修行人就可以了。”她却说：“哦，我知道你可以做得到，快骑上骡吧！”说着她就下了骡，从口袋里拿了一块缎子敷具垫在骡鞍上，手拉着缰绳。第二天，我正想着这梦有什么意义时，就收到了噶陀寺斯度仁波切要建立佛学院并需要我去的信。但我决定暂且往后推几年才作打算。此后每当收到噶陀的来信，就会看见以前的那位妇女来催促我说：“你一定要去！”有一天我问那位妇女：“我去噶陀的话有利益吗？斯度仁波切的发心如何？”她说：“他是位十地大菩萨，对整个佛教，特别是为宁玛巴的出家僧众建立了道场，护持发展不分宗派的佛法，建立讲闻院和进修院等等，发心非常伟大。你以前是乌俄·益西笨巴和桑日笨巴等的时候，曾经护持过这个道场，因此，你回到自己家里还不高兴吗？”听她这样说后，我就作了要去噶陀的决定。
    有一天晚上，我做了一个梦：以噶当巴师徒为首的很多比丘住在一个大房间里，门口有很多经卷。我也进了房间并念诵“师如虚空无边无尽……”等祈请文，求了加持后问噶当巴：“这些经书是什么？”“这些是经部、幻化部、心部的经典，很长时间投有人管理了，已经损失了一半，斯度珠古管理了一部分，所以这些就留下来了。”“现在还是不少嘛！”“没有儿子的话，父亲的财物再多也没有用，如果有谁能管的话，我就赐给他。”“这样的话，能否赐给我经部、幻化部、心部的经典？”“当时我主要讲的是经部，在那时起了很大作用，从现在往后看，好像利益不大，心部你自己有，依那个就可以了，幻化部可以给你讲授。”就从开头的“密藏本性了义续之王”念到“击大法鼓之声”等时，梦也醒了。
    前往噶陀前，在大持明者拉措让卓前求了《大圆满意直径》、《空行心髓》、《上师心髓》等灌顶，那时也请他作了印证，他非常高兴地说：“我俩相互校证也行，相互印证也行。”他十三岁时去过噶陀，在斯度曲吉罗珠前闻了《金刚心要》前行，修了几年就真正生起了无常心，还在斯度前求到了气脉和大圆满的讲授。二十一岁见到了明智本性，一直到三十四岁时都是专修明智。“那时候我这老头得到了这样的证相，过后就再也没有增长。”他将他证悟的情况给我讲了一遍，我想大圆满瑜伽行者就应该是像他这样的人。我住在他的道场时，他经常叫他的弟子们到我这里来作印证，他的弟子大部分都来印证了，我也尽自己所能来为他们断除增益。后来他讲授了《金刚心要》的前行和正行，为我和他首要的几位弟子按老教程来传了很长时间。将噶陀传承的很多讲授都赐给了我们并对我说：“这些是我在噶陀斯度仁波切那里得到的殊胜传承，你到噶陀寺的话，每年都讲一遍这个传承，不要断。现在还要你讲授一遍《空行心髓》，我要拿出最大的智慧来闻。”我说：“您以前可能闻过，需要传承的话我就给您念一遍，我不敢讲。”他却说：“没事，这是一个好的缘起。”因此，我就再也不敢违背地讲了一遍《空行心髓》。
    还给仁钦林巴伏藏师供养了《七宝藏》的传承和《三休息》的讲授。我也在他那里得到了他的新伏藏经典《亚门达嘎》、《文殊黑寿主》、《花金刚大鹏金翅鸟》的灌顶，并授记说我是他的法主，还写了我是大法王的转世长住世的祈请文，给了我许多财物。以后来了一位叫郭增得敦益喜炯内的伏藏师，我也给他念了一遍《七宝藏》传承，随后就返回了辽西圆林。
    那一年的夏季，噶陀派日多管家等几位前来迎接，当时因雨季昌曲河水上涨，所以他们没法过河就暂时住在安章寺了，斯度仁波切的信是拴在牦牛角上送来的，我回信说猴年一定到噶陀寺。这一年，我近修了《新伏藏经典》文殊忿怒、寂静，修了七天就亲见黑文殊，在‘修行房’周围下了蓝色的花雨，甘露丸变成了甘露水，念了七十万遍忿怒心咒长“哎”字，出现了天龙八部的心一时被吞尽的梦境。后来斯度仁波切说他的伏藏经典是假的，但是我没有生起邪见，我想他是个真伏藏师，有不如理的行为和说一些假话，是伏藏师们的习惯。斯度仁波切的伏藏经典的词义都非常圆满，所有伏藏经典的次序都有等同之处，这说明不了它是假的。从前没有争论的伏藏大师们，大部分伏藏经典与娘伏藏大师和古伏藏大师甚至词都基本一样，我想就这点也说明不了它是假的。
    猴年六月又来人迎接，我立即就去了噶陀。刚好遇上初十的法会，僧众们列队奏乐将我迎接到佛学院，斯度仁波切到门外来迎接，互相献了哈达，大家列队坐下，共用了斋饭。斯度仁波切说：“佛学院刚开始就想请你来，已过两年了，现在你能来非常好。在明天的初十法会上要请你供一个法曼扎。”第二天，仁波切和吉文喇嘛、阿朵、根巴堪布等一起参加了法会，我以八大行法修《上师持明》的仪轨，讲了修法基本具有九次第的要义，成了智者们欢喜的格言。斯度仁波切和吉文喇嘛给我献了哈达。初十晚上，在智美西雄的塑像前，仁波切单独为我作了《敦都金刚橛》的灌顶传承，还要求我第二天就开始作辅导师。第二天，斯度仁波切把我带到佛学院的宝殿，让我坐在法座上举行了坐床仪式，将镏金的铜佛像、金刚铃杵、宝瓶、红白甘露杯、木制朵玛、白法螺一对，手木棍、眼匙、拂布系在铁金刚杵上，祖衣、披单、坎肩，七衣，五衣，敷具，绸缎上衣，《次第总纲》一函、《所知藏》三函和一个小塔全赐给了我，并说：“要讲授的话就需要像昨天那样来讲，光注释词语讲解不了内义也不起作用。对新的学员请您要用实义来讲解。”又赐给我哈达。就这样，我有缘坐在法座上而担任了法太子。结夏安居时，根巴堪布留了下来并详细地给我讲了阿旺曲卓著的《释三律仪论》，果让巴作的《解释疑难题》，释确的《问答集金棍》，这些都是与阿里班禅的论结合在一起讲的。秋天时讲了《释量论》和《量理宝藏》，在学《量理宝藏》时，以其中恰、藏、丹三位的立场为反驳对像，与《释量论》的反驳对象不一样。西藏前期的反驳对象哲理非常细致，所以极难领会，在以《量理宝藏自注》来分析思维时，我梦见自己到了萨迦果任的房间，向萨迦班智达祈请。看见扎巴坚赞发际高，头发全白，是一位比丘相。我求加持说：“请求您能否将萨迦班智达自己的注释讲一遍。”他说：“哦，你是勒萨瓦的时候，你与蔡千两位对《道果》法方面恩德很大，窍诀修学方面也著了很多论，但是，这一世你对这个传承利益不大，不讲《量理宝藏》。”我说：“那么，在法王的法本中，请给我一张梵文的原稿。”他就从一函法本中抽了一张看着说：“这是我的《四无执》，我给你讲讲这个吧。”随后就赐与了。我认为这是得到了扎巴坚赞法王加持的征像。扎巴坚赞还继续讲授了《如意藏》，《窍诀宝藏》和《法界宝藏》。鸡年初，在扎堆地区出现了匪徒的骚扰，所以，堪布根巴仁波切需要回去了。


第三章 （一）

    以下简要地说一下我怎样做利他之事。
    堪布根巴仁波切回家乡后，我就在噶陀担任了堪布，开始主持管理佛学院，每届五年，第一届的后三年，加上后两届的十年，我前后为佛学院服务了十三年。在那期间，光是出家僧人受戒的就有三千四百多人，这是吉文仁波切记下来的。其中能作利他事业的有三十七人，灌顶、传承结缘者无数。这期间，在佛学院图书记录中有二百多个经论的名称，甲容、擦科、果洛和色达等地区来的求法者很多，还有羌地区、卫地区、藏地区、洛巴地区、主巴地区等地来的人也非常多，一天都要传六、七次不同的法，最少也不下三、四次。灌顶传承了《金刚心要》三次，《心髓母子》二十七次，《七宝藏》十三次等，承担了利他样子的重任。虽然先后多次请假，但斯度仁波切的发心非常大，一直不让我走。尽管我很累，但因心中想到这是为弘扬佛法和自己消业障而接此重任，不管谁来求法，不论大小，从来没有拒绝过。
    同时，我也在斯度法王那里求得了三个《八大行法》传承，其中前两个是连在一起的灌顶，后一个是单一的灌顶。《大聚会》的康、卫二传承，《金刚心要》的灌顶两次，《敦都》的五部灌顶传承和《大宝伏藏》、《所知藏》、《窍诀宝藏》、《时轮金刚》等是按阿底峡尊者的传承和夏娄的传承，这两种传承的上乘大灌顶等，依觉、夏二位现有的法本。当巴仁波切的《寂静、忿怒、金刚橛三尊》、《空行母的不共同交命根》，遍知者的《空行母不共同交命根》、《不共同七部交命根》，钦哲法王的《光明心髓》、《成就心髓》灌顶、讲授窍诀等，蒋贡康楚作的《深义》、《宝性论》、《二辨别》等注释，将贡仁波切作的《释金刚橛黑十万》、《释阳光》，米旁喇嘛著的《真实意密释》，荣敦作的《释般若现观庄严论》、《五部慈氏修习次第》、《量修行次第》，雅写的《释现观庄严论》，而《释大幻化网青蒲教言》是法王噶当巴讲，藏敦笔录的《经部密意集合经》注疏，当巴仁波切的《疑难解答》、《释明智汇集经》，章敦著的《禅定眼灯讲义》、《心部明镜教授》，益喜坚赞注释的《次第总纲》，释迦多吉的《疑难解答》，熟雀僧人根秋赤诚注释的《释大幻化网》，持明者囊喀仁钦注释的《释大幻化网》，丝摩根敦贝注释的《释大幻化网》，满龙巴弥觉多吉注释的《释大幻化网》，次第道《广论》和《简论》，《心髓注释》、《释次第道简论》，朗卡贝著的《释三味耶戒细论》和《释细微广泛》等，噶当巴著的《相似意殊胜》、《毒蛇的记录》、《宝剑的记录》、《树枝的记录》，渣国王的《明道次第庄严》、《黑忿怒母》灌顶，玛尔传承《圣妙吉祥真实名经》灌顶，荣波多敦多吉注释的《次第道》，比玛拉注释的《次第道》，古汝则登坚赞的伏藏经典由曲旺以大圆满揭开的《无戏论大明了义续》及《与佛和合的讲授》，多林所作的《法界光明》讲授、《释三宝剑续》、《释八大行法》、《密乘经典宝藏》和《恶劣行为》、《充满教诲的钥匙》、《八大行法密乘圆满续》、《密集有相五次第线子圆满台》、《天口实义讲授》、《龙萨宁波的八大行法实义》等。
    还得到了《噶当父法子法》、《解脱心髓的气脉》，北传伏藏师的《前行五钉子》，龙萨宁波《气脉》讲授，在吉文仁波切处得到了《八大行法》九函、《上师意集》十三函、《敦都》九函的传承及噶当巴师徒所造的《零碎仪轨》一函，措西·旺扎嘉措的《零碎仪轨》，噶玛恰麦著的《住山修行法仪轨》和没有封印类等的传承，在林昌堪布那里得到了《四部医典的注释·蓝宝石》四函、《窍诀封印补遗》，达莫的《封印》，米旁所著的《把脉和察尿的注释》、《释根本续》、《手指草药》，在坚赞俄热堪布处得到了《空行心髓》的讲义《深义云海》、《直指了义藏》、《指密行金刚道》、《上师心髓讲义三类》、《口耳传承三类》、《自然解脱三类》讲授和《经部十三修供》及《文殊忿怒六面》等的灌顶传承。根巴堪布再到噶陀的时候，言传身教了《心髓气脉》。在柱巴赤勒喇嘛那里得到了多珠钦的亲弟子阿拉囊卡嘉措著的有封印的讲义和零碎的法本等。在果洛·索囊巴丹处得到了宗喀巴大师的《菩提道次第广论》和《略论》，《密乘道次第》和它的《口耳传承·五次节》的讲授，另外，还得到了达尔的《注释》、《释心庄严》，宗喀巴大师的《释中论》、《释智慧品》、《大释中论·智海》。在白玉白玛洛布仁波切处得到了《大宝伏藏》有封印的三函，朗曲的《天法》十三函，加上《心意宝箱》等十八函，所有有讲义(传承)的《天法》，热那林巴的《伏藏经典》十三函，《北传伏藏经典》六函，《敏珠林伏藏经典》六函，《嘉村伏藏经典》六函，《解脱心髓》二函，《洛氏原论》一函，曲旺伏藏大师的《极密利刀》一函。《经部总汇》的传承，我和吉文仁波切互相供养来补阙共二十六函。印度和西藏四位大智者注释的《八大行法堡垒》、《上师意集》的灌顶和细小灌顶都得到了。在斯度法王那里得到了《大手印窍诀海》，东恰扎尔造的《瑜伽四次第》，巴棹扎西仁钦造的《讲义》等；在大伏藏师志美那里得到了《寿主像铁》和《铁蟹》共四函，《努的传承灌顶仪轨·珍珠鬘》。《灌顶教宝鬘》既可以是对佛塔的灌顶，也可以是对弟子的灌顶，因此灌了此顶，也灌了《大悲藏论》一函。在仁波切处还得到了娘伏藏大师的伏藏经典《忿怒母》一函，《空行母海》其中的几篇。在藏巴喇嘛处得了萨迦传承《空行母》一函的灌顶、讲授和直指法性的加持等。这里我只概括地说一下多闻之门，详细目录在《闻记》中。
    下面我简要地说一说在这期间所生起的一些境相。
    我经常想去一趟热振寺，一天晚上就梦见到了热振，但那里没有什么寺院。在一块岩石上面，有一个我想是仲敦巴佛子的禅堂，在这个禅堂的东方有一位妇女前来迎接。我想噶当派的道场怎么还会有妇女呢？便问：“你是谁？你是否能带我去见仲敦巴佛子？”她微笑着说：“我是生生世世给你加持的度母，你认不出来了吗？好，现在带你进去吧。”说完就将我引到禅堂内。这个禅堂原来是一个像用石头砌起来的墙，有外、内都能看得清楚的六字真言。禅堂的四方由各方各色组成，上、下方由蓝、白色组成。里面有六字真言的空宝座。那女人指着宝座说：“这是仲敦巴佛子的宝座，他现在住在兜率天刹土，你要顶礼求加持。”我顶礼求加持后，心里想：我真是个福薄缘浅的人，见不到上师了，感觉就像掏出心脏般痛苦不已，口里说：“兜率天上面的佛与佛子请摄受我，加持我与您们无二无别！”就这样痛哭祈请。那位妇女手里拿着一块小石头，石头上有四个小生命，各自爬向四方，在这四条生命的外面还有一条生命，共五条生命，她一一指着五条生命对我说：“为这个发慈心，这个发悲心，这个发喜心，这个发舍心，这个发菩提心。”我如此发愿后，四无量心和菩提心一刹那同时生起来了。她说：“就是这样，即使亲眼见到仲敦巴佛子，他的发心也没有别的，你与佛子一样，阿底峡将他选为法太子时赐给他的帽子就是这个。”说着就从怀里取出帽耳并不长的班智达帽。整顶帽有一肘高，金线像白螺纹一样旋绕，她赐予我后，令我想起了自己作地藏班智达时的习气。这时候来了很多人，那位妇女说：“你现在与仲敦巴没有区别，所以请你为他们传个法。”与此同时，大家都念起“众生根器不一……”等等。我想这顶帽子是一位妇女给的，他们知道的话不好意思，但传法不戴帽子也不行。又想可能是阿底峡的帽子，考虑了一下后，就毫不犹豫地戴上了。此时，在我心中很清晰地想起了《菩萨本生传·宝鬘》，于是我就给大家详细地讲了一遍，那位妇女念了：“愿此功德……”等回向文后，闻法的人就全散了。我知道这妇女是真的度母，所以就向她求噶当四本尊的加持。她说：“前面这些就是四本尊的加持，除此之外，我不知道还有什么四本尊的加持。”我把帽子交还她的时候，她说：“这是你的，你可以拿走。”送帽子给我时，梦也醒了。那时候，我就因此而写了佛与佛子三师徒等的传承祈请愿文。
    又一次，我依“火兔年和水牛年，圆满一切密意愿，虎兔年的密咒师，若是能做到鼓励，火猴铁虎年都活。”的授记，用早晚打座近修了《忿怒马头明王》和《大鹏金翅鸟》。白天虽然要为讲经说法而忙碌，但仍不离本尊相而默念咒语，如此近修了九个月。一天晚上睡得很熟，醒来时听见很多响铃声，我一看，原来是穿着白衣服的四位妇女，手抓四方栓着四根绸带像鼓一样的虹光圈，上面有五部佛的法器像，她们对我说：“上来吧”“到哪里去？”“到门卡列任森仲和达仓森格桑珠，那里住有莲师父母，去一去好。”“那么遥远的地方，我走路是到达不了的，还是不去吧，我与莲花生大师也从未离开过！”“不用行走，坐在这块垫子上就可以了。”说着就把那块垫子变成一肘厚，房屋那么宽，我刚坐在上面，就把我抬到空中往西而去。看到下面有不可思议的地区和山川，我问这些是什么地方？她门说：“这是西藏地区，不用管它，还要走。”又走了很久，在看到下面有一个很大地区的空中休息。她们从一口锅里拿出生肉和酒给我吃，并边吃边说了那是什么地方，这是什么地方，那里有什么国王、大臣，有什么僧人，什么男人、女人，他们由于前世的愿力，对弘法利生作了什么样的事业等的许多议论。而我想那可能是人肉就没有吃，她们知道后说：“这不是肉，是莲花花瓣，不喝酒的话就给你虚空的酒吧。”说着就给我喝了像水银一样的液汁，吃了很像莲花花瓣一样的肉，它也像酒的味道有点酸。她们还说了很多奇妙的话赞美女人和好像是授记类的话，就这样边说边唱边跳。我说：“这就叫‘伏藏师会坏在授记上，’这些我都不懂，快走吧！”“对，对，像您这样一位虚空般的人不需要，但中等根器和下等根器的人还是需要的。”我问：“那么，目前有很多人以授记的名义而做坏的行为，欺骗许多众生，这是为什么？”“不完全是这样，但按时间来行持的人是不多。”“那为什么不按时间来授记和非时间来授记呢？”“嘿嘿，是按时间授记了，但没有人去做，没有办法了。”说着又开始走了。
    我们到了达仓岩，这里的岩石多半由蓝、白石组成，下面是大森林的狭沟，上面由像莲花般的白岩石组成，三面的山很高，而南面稍低，她们把我放在一处很多层楼房那么高的岩石边上后，就像骷髅一样跑进岩石里，我也持虚空气跟在她们后面，天地十方自然响起了像雷声那么响亮的“班杂格拉雅”之声，同时听到虚空中“胜利了！”的很大声音，其中一位伴侣说：“这次战胜了违缘军。”我看见此山背面的一块平地上有一座山，山上面有一个可住一人的达仓修行洞，上面有‘格拉雅’的自然字，每字有一个人那么大，各发出自声并颤抖着。我想这就是莲花生，就立刻诵了《七支祈请文》，当这些文字融为一体的一刹那，就变成了深蓝色的忿怒金刚橛和紫黑色的忿怒金刚橛，这二者就像灯和灯影一样不可分开，我领受了明智力的灌顶，“嗡，吉祥忿怒金刚橛，前世所发大愿力，身语意之大和合，法界本性无二别。”撒了智慧花后，从那尊像上面，深蓝色的忿怒金刚橛如一生二般地溶入了我，我也变成了忿怒金刚橛。前面的那位空行母变成了一只母老虎，另外一位空行母叫我骑在上面，骑上后我吼出“吽”声，变成三界怖畏的相走到了印度的南方。到了一个认为是尸多婆那的大尸陀林，在皮子似的帐篷内住有以莲师父母为首的娘·宁玛俄热等听过名字的和没有听过名字的伏藏大师及很多眷属。坛城上有一个人的尸体，我问这是什么？娘说：“准备灌《八大行法》的顶。”此时，老虎把那尸体粉碎了，腹腔内有遍满虚空的八大行法诸本尊，圣众们击着鼓诵了生起次第偈，几位咒师抬着像酒罐的罐说：“这是灌顶的紫色犀牛盒，领受加持吧！”我看里面有像酒一样的液体，就喝了一口，说：“这酒的味道为什么这么差？”“有这样的味道还算不错了，西藏的喇嘛们搅了又搅后，断了酒的力量。”“还有味道好的吗？”“从前，由龙魔帝巴杂的口中交给你的铁盒，很有味道和力量，但你没有重视而放弃了。”
    随后，老虎又开始跑，我们基本上跑遍了整个印度，也到了许多尸陀林，看到了很多穿着短裤，手持铃鼓、卡杖喀、鸟、鱼和刀枪等武器的瑜伽行者，老虎发出吼声后，大家都现出畏惧的样子。在八大尸陀林中，有印度的八大受教法持明者，每位持明者都有西藏的持明者做护关，听他们说八大行法有总教和支教等很多，所以不能说八大行法绝对是这么多。又走了很长一段路后，看到一座非常大的塔，塔尖高耸入云，我知道这是吉祥无触塔空行母的宫殿，就想到里面去闻几部续。从宝瓶东门进入时，有很多披散着头发，遮盖了前后大部分身体的小女孩前来迎接。到了宝瓶内，见到一位消瘦、眼昏、牙齿全无、耳朵不灵便，还穿着破烂衣服的老奶奶。我想她可能是智慧空行母，就祈请灌胜乐金刚、极喜金刚和密集金刚的顶。她装着听不见的样子说：“啊，啊……”再请求后说：“三个不行，给你灌个密集金刚吧。”说着就从舌头上面取了一块四方形的蓝色石头，上面有‘啊、旺、嘛、亚’四字交到我手中说：“这个很舍不得给你。”说完就消失了。
    我再走到北门时，见到一位男人黑着脸坐在那里，我问：“你怎么啦？”“这间房子从前被盗了很多次，这次又有很多经典被盗了，是不是你拿走的？”我说：“空房子里本来没有什么东西，那还有什么东西可拿？给你留个空法，你好好保管吧，嘿嘿！”“我是这个房子的守护者，你拿了我并没有不高兴，只是没有根器好的弟子可以给，才不高兴。”说着一刹那他就变成了四臂嘛哈嘎拉说：“你要去吉祥山的话，我给你帮忙。”他于是领着我到了印度南方的吉祥山，到了那里后并没有见到龙树师徒，却见到了许多妇女在嬉笑玩牌，走到她们跟前一看，那些看似普通的妇女们在玩很多五色牌，牌上面有字，写着“身寂”、“语寂”、“意寂”、“光明”、“幻化身”、“双运”等，每个人都拿着对词组成的牌，她们叫我也坐下一起玩并给了我写有六组词的六张牌，我说：“如果把‘身寂’归到‘语寂’内，则只有五个数目。”“你说什么？这种牌我们会，快出牌吧。”这样我就出了一张牌遇上“幻化身”，这个她们没有说什么，接着我又出了一张“双运”，她们嘲笑我说：“没有光明的双运没有用，你怎么会胜利呢？”于是给我喝了酒后就叫我走了。我们差不多走遍了全印度，到了印度与尼泊尔交界的卓阿达则山上，见到了大拉尊，作了证量的供曼扎后，他显出了很高兴的样子。我说：“你说‘达波噶举巴承认别念即法身，而我不承认’，但达波仁波切也说：‘心性本来即法身，本来相即法身光，’因此，我想除心性无分别的本来面目外，不是说分别心即法身。”“你曾经是昂宗丹巴，所以对噶举巴有一种感情。然而，岗波巴他并没有说别念即法身，现在，直指时住、变、知这三者，除了心识以外没有别的，所以，明白错与不错的界线非常重要。”此时，境相都消失了。以后，每当我想起卓阿达则圣地的同时，大拉尊的身相也会清清楚楚地显现出来。
    得到《时轮金刚》灌顶的晚上，我到了巴登哲蚌的塔内，用彩色粉绘了时轮金刚身、语的坛城、意坛城和力坛城看不见，全是罗睺蓝色的明点。按夏娄传承来灌顶时，我作了一个意坛城和大乐力坛城很清楚的梦。有一次，我以噶丹百尊来修不共同的上师相应法，是以班禅洛桑坚赞造的《观想》来一一观修了“无缘慈悲……”等祈请文，每一个观修念了十万遍。那时候做了个梦，梦见自己到了兜率天，见到了宗喀巴师徒三尊，上面有弥勒菩萨，左边有阿底峡二师徒，在(宗喀巴)大师前，我问了《菩提道次第广论》观修方面的反驳文《杂亚阿愣达》的疑难问题，他给我解答疑难后说：“这位克主杰借给你二十五年做你的经师，然后要还给我。”我算了一下，二十五年后我就是六十几岁，这可能是指我寿命的劫数，但也说不定。这时，克主杰变成了仙童后就交给了我，我把他装在怀里，走到半路上看时，他已变成了有五十品的又细又长的释律经和俱舍以上、时轮金刚以下的经函。由于这个缘起，我对宗喀巴大师的所有论著都比以前理解多了，我深信这是宗喀巴大师的加持。此时写了《五次第讲授备忘录》、《时轮金刚备忘录》、《了义和不了义蓝色备忘录》、《应成派因明学笔记》、《因明学反体讲解》，另外还写了几篇小论。
    后来，近修了两次龙萨宁波的《智慧火焰》，第二次修的时候，在噶陀寺大殿内作布萨时，殿内的龙萨宁波塑像微笑起来，头巾中的阿弥陀佛念了三遍六字真言。我还近修了《八大行法》、《上师意集》、《时轮金刚》等。在修《时轮金刚》时看到了大乐力坛城中时轮金刚的单身相，并得到了加持的证相。修《上师意集》时，梦到供赞和夏萨卡莫杰二护法前来请求讲授《上师意集》。修唐东杰波《空行口耳传承》时，到了印度的[日/阿]美夏绕尸陀林，得到了大成就者(唐东杰波)的摄受与加持。有一次，我得了一种不知是什么的传染病，眼看就快要死了。为了消除病魔，斯度法王作了《金刚萨埵护摩》十万遍。就因这个加持，一天晚上的境相中见到大成就者亲临的征相，他说：“用慈悲的水来洗，智慧的木棒来敲打。”说着就将我衣服脱光，从净水瓶里倒出奶水为我全身洗了一遍，我身心都得到了安乐，再用木棒从头到脚打了一遍后，乐的执著也消失在空性中，没有任何别念，苏醒过来时，病也基本上好了。刚好那天晚上，斯度仁波切也作了一个梦说：“我梦见蒋扬钦哲旺波来为你灌了个唐东杰波《长寿广轨》的顶，这次的病会好起来。”患病期间，我梦见吉祥天母护法神给了我一个盒子，座骑骡用舌头来舔。因此，这吉祥天母护法神，是噶陀传承持法者应该值得供养的护法神。
    一次，来了很多像打鼓骷髅似的小女孩。她们交给我一个鼓，我们一起骑在鼓上，到了西方一个不认识的地方，那里有很多大如盾牌的红花，发出的光芒映红了天空，十方遍满了彩虹网，在这样一个道场中我见到了大成就者，他的身体有山那么高，前面有一座红色的圆形大坛城，有九个格子，每一个格子中有不同的修持仪轨，都一一传给了我。东北的格子里有诛业类的《金刚橛咒轮》，既很深奥又很简要的灌顶传承也全部赐给了我。当时我还记得清楚，但后来都忘记了。那时，很多地方都出现了战乱等灾难。斯度法王要求做一本《空行母依怙主的轮回灵器》供施，叫我到噶当巴的殿内近修空行母和依怙主来补阙。开始修的那天晚上，出现了这样的境相：一位比丘牵着一匹以尸体作马鞍的黑马给我骑上，还交给我铁的弓箭，把弓箭拿在手中的一刹那我就变成了黑嘛哈嘎拉，佩戴着头盖骨的项链，四个关节都有眼睛作庄严，头发是往上直立的毒蛇，威猛而忿怒。生起了三界的命根主宰就是我这样的一个大慢，过后就跑到一个地方的下游。那儿有很多像野牛一样的牛，我很傲慢地发出雷鸣般的嘘声，那些野牛顿时惊恐万分，但一刹那就变成了温和、恭驯的新旧派护法神，其中当吉曲甲显出很黑的人相持刀冲了过来，我一箭射在他的心脏上，他的心肺被粉碎了并倒了下去，箭羽上还沾染着血迹。在对尸体发大悲心的同时，我变成了一位比丘。如果不发悲心的话，所具的威力整个西藏都没有人比得上，这对我来说并不难。
    在噶陀结夏安居的一天，海螺声把我唤醒了，抬起头来一看，见到在达吉曲弄时，我是桑达赤列愣珠，当时有我的大小四个孩子睡在身旁，连他们的黑发也看得清楚，并看见其中一个小孩起来了。这时我没有想起自己是在噶陀，这个境相持续到第二次响起法螺声的时候。我讲经时坐在大殿宝座上，大殿天窗里旧壁画有很多上师的相，其中有一位身着白衣的咒师发出白色的光射入我的顶轮，这是我的几位弟于看到的。后来看那幅画时，正是桑达赤列愣珠的像。我因此知道这是大持明者加持的证相。从此以后，密乘的仪轨和修诵的方法及灌顶传承次第只要看过就不会忘记。一次，我们几师徒去绕寺院，喝了一点文殊岩的水，那时出现了一条很细的彩虹将圣地和我之间连在一起，里面有很多红色的‘帝’字来来去去。这是跟我一起的几位弟子看到的。听说另外一些人看见在圣岩里，来了一条龙，往天上飞走了。在曲吉朗波仁波切前得到了噶玛恰麦作的《天法》小讲义，热那林巴的《伏藏经典》，龙萨宁波的《伏藏经典》、《隆钦心髓》讲授和《山法无封印》等传承。《无封印》中有詹巴拉古汝古里天丹等灌顶，也都得到了。在近修作明佛母的一天晚上。有这样一个境相，克珠·噶玛恰麦仁波切在西宁青海湖旁，以作明佛母咒等密法来度化蒙古人和鬼神等大部分众生以及在芒康地方降伏龙王米棍胳波等事，还记得很清楚。
    我从小就自然具有以大慈大悲观世音作为本尊的想法，对观世音有特别的信心，慈悲心也能自然生起来。一切佛法的法主斯度仁波切说：“在辽西圆林要建一座小小的寺院，我在噶陀建佛学院之前作了个梦，梦见一朵大莲花被同样的四朵花围绕着，每一朵花的中间都有一把很好的宝剑立在那里，并发出光芒，接着又出现了五朵。按这个征象来看，是这(噶陀)佛学院能再发展到五个五明佛学院的缘起，你自己能建一座寺院的话非常好。”于是开许我建一座寺院，因此我在辽西圆林创建了一座有四十根柱子的宝殿，并没有任何违缘地建成了所有能依所依，这是法王的加持和慈悲力。莫查成就者依金刚亥母的授记说：“蛙蛇二争十字金刚杵，持有阿名自从东方来，若是不贪手掌大光镜，而居圣地噶陀寺道场，弘法利生事业会圆满。”就是这样，最好的道场是不定居的地区，中等的道场是噶陀，下等的道场是现在的这个(辽西)，中等和下等道场的缘起都实现了。此后去了白玉建讲学院，为三十多位弟子讲解了《胜出灭神赞》、《殊胜赞》、米旁仁波切著的《随念三宝经无尽吉祥音》和寂天菩萨的《入菩萨行》。从此，出现了很多智者。邬金桑阿林巴的授记说：“白玉修行院出佛学院，未见过的经论会发展。”指的就是这个时间。在那个道场时，我亲见到了法王巴珠仁波切，他给我传授了四品《入菩萨行》，也授了菩萨戒，说：“你独自一人求涅槃，还不如多建一座佛学院，这样对佛法的利益更大，佛法之宝的基础戒律的有无，决定于《三毗奈耶事仪轨》的行持、持戒的清净和显密经论讲闻的有无，因此戒律行持和讲授非常重要。现在什么都不懂，却说我是觉者的人很多，这是末法时代的征像，在家修密法者也很多，然而多子的狐狸挡不了一个洞的门，宁玛巴有很多小寺院，但能起到作用的寺院不多。”
    持金年(火鸡年的异名)，应噶陀宁敦旺波的第五世夏扎仁波切前后多次请求，前往达科地区扎拉寺，在拉丈室里住了下来。因为从果洛和色达来的求法者很多，所以准备传《大宝伏藏》的灌顶。为了消除违缘修了一次《金刚萨埵》的修供，外彩粉坛城按大修供修了九天。过后，为首先打开加持的门而修《上师密集》四圆形灌顶和朵玛灌顶，而《八大行法如来集》的大纲等七天内灌完。这样才开始依次进行了《大宝伏藏》的传承灌顶，除讲授目前目录中有记号的之外其它的就没有讲授。但是，法王斯度仁波切有的讲授和近修仪轨，大部分都是从蒋贡仁波切、扎西俄热堪布、涂丹坚赞俄热等处得到的，这些讲授传承都讲了。用了六个月的时间完全按持明者的传承来执行，绝对没有作过简单化。摆设法器和经典全部按目录，灌顶按照仪轨，仪轨按实际应用很规范地作灌顶，与目前那些粗糙的灌顶完全不一样。我认为就这一点来说，已为宁玛巴莲花生的传承作了一件大事。灌顶从开始到结束，选了七位修证好的喇嘛，每天早上修供《金刚萨埵》生起次第、五大如愿会供等，也作了供养如愿和众生如愿，轮流来作敏珠林传承的总护法朵玛。每当三根本的灌顶传承圆满后，八大喇嘛轮流来作一次会供，每一次会供都用了四锭白银的供品，这样隆重地灌顶、传承与讲授，在没有一点违缘下圆满地结束，结界也解除了。此后五天内，准备为外来的男女居士举行《曲旺伏藏经典·大悲心集》和《千佛》连在一起的灌顶，热那林巴的《大悲》和《千佛》连在一起的灌顶，西波林巴的《大悲》和《千佛》连起来的灌顶，以及《寂静忿怒结缘者自然解脱》的灌顶。上午修嘉村宁波的《寂静忿怒百尊》的灌顶等，午斋后开始灌顶，因为来参加灌顶的人太多，在下午日落前，寺院中需要按列席依序一一灌顶，所以非常累，但想到自己利他的发心就坚持下来了。那时还简要地讲了六字真言的功德，因而不用动员，就有七百多人誓愿念诵六字真言一亿遍。另外，各个部落来的人也发愿行善积德、不作恶业；发封盗窃、封枪、封山封水，不挖虫草、黄芪等愿的人很多。那时，我以大慈悲心度化了一位因前世作恶业而堕入极为可怕和痛苦的饿鬼道众生。如此直接和间接地做了利益有情的利他事。果洛的头人和几位有心人从各地来邀请，我想前往，但因夏天有骚乱，缘起不好所以没有去。那时，由北方等寺院送来的供养财物非常多，都全部用在弘扬佛法的寺院上及讲、修、辩等利他事业上，绝对没有把信众供养的财物拿来奢侈和作庄严自己的事。我所作的事业这里没有一一写下来，因为这是需要骗取他人财物时才需要这样做。实际上，所有大小财物的供养全都善根回向佛果，并以三轮清净来回向，绝对没有不做回向的，这些财物大部份都用在了三宝的供养上，绝对没有浪费。
    此后，我又到尼科上游住了下来，在那儿传了《四心髓》和《隆钦心髓》的灌顶传承，为很多求法者讲授了《前行》与《智慧上师》。尼科南莫契是金刚亥母加持过的圣地，刚住下时也有一些异常现象，后来尼科南莫契山神现身为一位漂亮的女孩，她送给我酸奶和一腿野马肉说：“需要为您做什么事情，我一概从命。”
    在噶陀寺，斯度仁波切要开一次千僧大法会，所以来信要我回到寺院去。收信的当晚，梦见一座空空的大城市中有一位看起来很苦的老奶奶，流着眼泪坐在那里，我问：“你怎么啦？”“城市空了没人管，因此我悲伤。”“一切有为法都是无常，你将它当成有常来痛苦，这不是自找痛苦吗？”“说什么，是佛法快要没落了，浪费了这么多的经典，太可惜了。”我一望，只见一座大宫殿中的围墙内，有无数质量非常好的经典堆积着，然而上面却没有什么遮盖。她从东方的门上取了一卷交给我，我打开一看，原来是《虚空雷轮续》，正是从前金刚阿阇黎极喜金刚赐给我的那一函，就说：“这个拿来要作什么！”“这是你的，你保管吧，不要对他们太保密，也不要太公开，我该走了。”“到哪里去？”“要到兜率天！”一刹那她就走到别处去了，这时我也从梦中醒了过来。
    到了噶陀后，我立即去拜见斯度仁波切，顶礼问讯并作了供养。
    那时斯度仁波切也显出病相来。千僧法会开始是《大悲心集》的大修供，在“领受成就”时，看见“修宝瓶”正是大悲父母，殊胜内在的灌顶用内心领受，对菩提心起到了增长的作用。此后，以《莲花光要》的仪轨来修莲师心咒的修宝瓶，虽然仁波切的病情较重，但是仁波切仍然连续几天坚持担任法会的金刚上师。后来以《上师密集》的仪轨降临加持时，来了很多像打鼓骷髅一样的空行母，载歌载舞的空行母遍满子大殿的所有空间。我想向空行母问一问仁波切的寿命时，其中一位叫仁钦萨珍的空行母边跳边唱道：“西边阳光落在东山顶，初三之月升在东山顶，佛法增衰众生共业定，诸空行母是来迎接者。”因此，我想法王住世的时间不长了，就像掏出心脏般的非常难过。
    法会结束时，为了仁波切的住世而做了《遣回空行母》、《莲师忿怒送王》、《千返金刚橛》等修供。一天仁波切叫我到他身边说：“这次从我的病情来看，做什么也没有用，我自己并没有犯过根本和支分的三昧耶戒，从小直到现在，金刚乘的殊胜灌顶传承，有缘和无缘者我全都赐予了，同伴的破戒和牵连的破戒罪障对十地五道也许会有障碍，因此要做一次娘伏藏大师的《黑忿怒母》的护摩《持明者接命》，请烧在天窗边我听得到的地方，我也能念多少咒语就念多少，吹打等需要隆重，我俩这一生共同在一个坛城里的修供，以后也不一定再有了。”就这样，在禅堂的屋顶天窗边做了十万遍《黑忿怒母》的护摩，用了几天完成后，我就马上到他身边去，他说：“现在好了，虽然，我没有去念诵仪轨，但诵了十万遍咒语，因此证得了清净罪障的证相，现在再也不用做住世的修供了。”我作了长住世韵祈请后，他又说：“谁也不愿意死，但这次不能留下来。”“走后要做什么？”“我很辛苦地将噶陀寺的仁波切们寻找来，是花了很珍贵的财物请回来的，他们应该会考虑的。”说着就眼视虚空而安住。第二天的早晨，他的色身收回兜率天刹土去了。过了五天后，荼毗法体宝时，僧众供了很多供品。我也供了供品，并祈请领受四灌顶，心心相印，心意融为一体等，做得比较满意。除了我对佛法像一个心地善良的老太婆般外，没有一个人能承办此事。
    第二年，我到林西乡嘎寺灌顶传承《大宝伏藏》。附近寺院的喇嘛、仁波切和扎巴来得非常多，还有从汉地的木里地区走了三个月路程来的宁玛巴、噶举巴、萨迦巴的喇嘛和在家男女居士等，共三、四千人。灌顶和讲授用了五个多月时间，没有出现一点违缘，非常圆满。这些不是为了自己多收点供养，而是因以前法王斯度仁波切说过：“这《大宝伏藏》是二位蒋贡的事业，你也要传三遍。”我就是将这句话牢记在心里，为了弘扬佛法而去传的。由这个缘起，敏觉仁波切和愣珠二兄弟请了《大宝伏藏》的经典，还画了《大宝伏藏》查里坛城佛像，其中敏觉仁波切在自己的家乡灌顶和传授了两次《大宝伏藏》，发愿闭关修三根本的喇嘛和扎巴有一千六百人，发愿以一个根本咒语念一亿遍的有三百人，发愿近修《金刚橛》和《金刚手》的有两百多人，放了三十万零五千条生命。在家居士也各以自己的力量发愿行善积德，不作恶业等，实行封山、封水等等善业，并有人发愿不去抢卡瓦格波神山绕经人的财物，在那个地区的一个坏王也被降伏了。此后，布日和扎康日等地来人邀请，但当时是很炎热的夏天，就推迟了。返回辽西的路上到了雅索寺，为钦哲法王的亲弟子，大成就者喇嘛圆敦仁波切的灵塔作了开光。后来到了次朴寺，雅索寺的罗珠嘉波珠古负责召集了一百五十多人，我用一个月时间传承灌顶了《隆钦心髓》的大部分经典，还作了《如意宝瓶》的全部灌顶传承。这时为了我的长住世，他们诵了一百一十五个十万百字明，并放很多生命。发愿近修《隆钦心髓三根本》的有六十多人，有发愿近修敏珠林的《金刚萨埵》和以此仪轨为常课的，还有六十多人发愿念一亿遍六字真言。在北方寺院和这里发愿念一亿遍六字真言的已超出三百多人。
    进入四十九岁时，法王仁波切曾说我有个关口，为此就住在自己的道场中闭关，不分昼夜地近修了大部分《大宝伏藏》的三根本咒，首先近修了所有上师仪轨之王——《上师意集》，并作了业的仪轨。期间做了一个梦，梦见罗扎拉雅莲师殿的附近有一块平地，我是古汝曲旺，儿子白玛旺钦为侍者，我们去散步时，看见来了一位身披白袈裟的阿扎亚背着一个很大的背包。他从下面的平原上走过来，见到我就非常尊敬地说：“我是莲花生派来为你送这封印经典的，请留步坐一下。”我坐了一会儿，他把背包打开，给了我像汉人法本那样的经典，其中有一本《莲花生的根本次第文》，里面写了一辈子该做什么事的内容，还有一些授记，其中说：“不要走很远的地方，对受用品不能用贪执来供养和布施，对莲花生的信心不能退失，要知道积累资粮的对象是上师，出世的慧根不能断”等五条。另一本有曲旺的《本生传二十五世》，每一世都写有利益众生的事业和度化众生事业的大小功德，而我是第十九世，我所度化的众生不是很多，而其它世的度化事业非常大。后来在噶陀寺以《上师意集》的仪轨《火星》近修了一次。这次，以仪轨《花鬘》来近修，不分昼夜都能见《上师意集》九主本尊的相，贡赞和夏萨卡莫契二护法前来请求弘扬《上师意集》的法。又作了《金刚心要》中《不动佛》的近修，看到东方都是不动佛的刹土，完全如经典中所说的那样，不动佛的身上发出蓝色之光遍满三界，大部分恶趣清净后变成了不动佛的刹土，如来佛说：“不用说按你这个仪轨来念诵不动佛刹土中的经典，就连触到密乘加持的金刚沙和听到咒语念诵声的众生，都能断除恶趣而往生不动佛的刹土。”得到了这样的授记。从此，我身上就再也没有生过外内的虫类，前后多次看见刹土和佛的境相，对作恶的、没有依怙的众生自然生起一种非常大的慈悲心，忍辱度修持圆满。
    此后，近修了《八大行法如来集》、《八大行法自然生起》，曲旺伏藏的经典《(金刚橛)宝剑》和桑吉林巴的伏藏经典《意的精要(金刚橛)》，《白林金刚橛宝剑》，北伏藏大师的伏藏经典《金刚橛宝剑》等三宝剑，热那林巴的伏藏经典《无上极密(金刚橛)》，娘伏藏大师的伏藏经典《黑忿怒金刚橛》，蒋杨钦哲旺波再取伏藏经典《空行母秘密聚集金刚橛》等也全部近修了。在近修[日/阿]夏伏藏经典的《空行母岗夏》时，出现了很多异常现象，真实地来了很多女孩叫喊着名字，还听到各种不同的语言和声音等，大部分都成了大众所感的共同境相。过后近修了以前已近修过多次的《寿主阎王寂静忿怒亚门达嘎》等。以五世达赖所作的仪轨《阎罗王红黑二主骷髅的返回》近修时出现了这样一个境相：到布达拉宫去见五世达赖，他很高兴地说：“做得好！”并钦赐诏书写在水晶宝瓶，宝瓶上刻着司郎吉巴成列珠巴则的印。我想这是消除寿违缘的征像。此后每天晚上的后半夜念诵三金刚字，因此，气都在中脉里，生、进、住三不共的证相都是我亲身的体验。这时，五世达赖赐给我《亲见法王授记金刚·大幻化网次第道》和邬金堪布教授的《大圆满隆钦心髓·口耳传承如意宝经卷》，此二者连在一起，同时也赐予了十九对金刚铃、杵并任我为法主。因此，我将《隆钦心髓》的拙火定注解和动作写成了文字。
    以桑吉林巴的长寿仪轨《日月封印》和热那林巴的《长寿仪轨》近修后，修堂内遍满了香味，朵玛上流出了甘露，在长寿宝瓶上面见到了长寿佛而得到了加持。随后，在近修《上师明点封印》时亲见了大遍知者，他说：“这次要写一部大圆满宗派明讲要义的论，这是因为从前‘遮耶塔尘数量的众生得到法益’等授记的时间到了，因此，要写好大圆满的要义。”这样，我就写了《上师心髓》和《二心髓》注疏《日光》、《大圆满母子的钥匙普贤心的注释》、《顿超的口耳传承空行母的心髓》等，此后就出关了。
    噶陀寺来信要我去主持《上师意集》的大法会，在“接成就”的时候，一般的显相全融入法性而安住在明智无分别的境界中，从中再显出外相莲花生大士在桑耶青蒲为王臣弟子传《上师意集》的灌顶，以及传授续部、经部、窍诀部等全部大法时的境相。，成就供品所供的对象——上师也变成了《上师意集》十三函数目的空行母。除了领受内灌顶外没有其它相，我觉得《上师意集》的加持力实在太大了，当时我就想起了我是桑吉林巴的上师曲吉罗珠。法会结束后，就返回自己的道场，走到吉谢神山脚下住了一夜，晚上出现这样一个境相：亲见经部、幻化部、心部的第二传承祖师努钦(努·桑杰也协)仁波切前来摄受并传授了《释经部渣国王之授记》、《经部密集集合经》和《大圆满禅定眼灯》等。因此我写了努钦的《上师相应法》和简要的讲授，对《续部》的意义有一点理解，这也是与努钦的加持分不开的。
    在四十九岁的关口出现了比较大的违缘，但以白玉贝诺仁波切为首的僧众念了《甘珠尔》三遍，《般若八千颂》三百遍，金刚橛心咒三亿遍，长寿咒三亿遍，狮面佛母咒一亿遍，修了《八大行法供施代替品》、《遣回空行母》的会供十万遍，《空行母和依怙主的退阵投灵品》，《度母的退阵投灵品》，玛帝伏藏大师的《狮面佛母万遍阻挡法》等。各位弟子在贡、查、波、娘、白玉等地放了三万一千条生命，《七支祈请》念了百个十万，发愿近修热那林巴的《长寿仪轨》和《长住世发愿文》的有二十多人。在扎拉寺，夏扎仁波切也为我长住世建造了一亿遍百字明的转经筒，僧众们念了三遍《甘珠尔》，金刚橛的咒语三亿遍，莲师心咒、狮面佛母咒各一亿遍。《如愿成就》和《消除障道》二祈请文各十万遍。《八大行法查令牌》、《三根本的会供》十万遍。弟子们各自发愿修三根本和长寿仪轨来闭关的人很多，达科地区上游的每家每户念长寿咒三亿遍，放生三千。阿色帝那部落念长寿咒三亿遍，放生三百，铸擦擦塔十万个，莲花生像十万尊等来祈求我长住世。夏扎仁波切还在果洛和色达各个地区放了五千条生命，由于这些真实力量，我暂时消除了寿违缘，病情也痊愈康复了。
    在辽西圆林的山上，身依刻了(噶当十六明点》之一的不动忿怒佛像和语依五遍《续》，在近修时见到了阿底峡师徒，尊者说：“不是一个明点一个明点来修，而是四个明点连起来修。”并将以瞻部洲清净明点为基础，中土地方明点，仲敦巴佛子意明点，观想在不动忿怒佛的心轮中不可思议的法身明点等四个连起来修持等的实际讲授赐予了我，我也作了一个近修方法的记录。


第三章（二）

    我五十一岁时，即蛇年，芒康卫达谢林公子和帮达公子为首的人前来迎请，因此前往芒康，一路上都有骑马烧茶来迎接的人，到寺院后休息了几天，公子和小姐们都是多生多劫积有福报的人，他们再三祈求《大宝伏藏》的灌顶，为了满足他们就应允了。当时寺院里有很多国兵，比较拥挤，不方便结界，因而迁到努[日/阿]宝殿内，灌顶和讲授了《隆钦心髓》的传承。他们在领受灌顶的同时也修了前行，此后又开始传《心髓母子》的灌顶传承，大遍知者的《七宝藏》和其它零碎论的传承。《心性休息》等三休息和正行的讲授、《智慧上师》的讲授圆满后，就开始了《大宝伏藏》灌顶的前行，为消除违缘而念了《甘珠尔》一遍，《般若八千颂》多遍和前后加起来一百个十万多的百字明。此后，与各地来求《大宝伏藏》灌顶的人们一起修诵金刚总持大修供。四大金刚的结界、降魔、外内门牌等前行该作的法全做成功后，依彩粉做的坛城，以修供的宝瓶为首，经幢和幡等作庄严，修供七天完成。内修与灌顶连在一起，《上师密集》的灌顶和《金刚萨埵》的灌顶连在一起，主要的《金刚萨埵》坛城作了彩粉，其余的坛城以布画代替来灌顶。灌顶和讲授都按照传承的规范严格地执行。传承是吉美多杰仁波切念的，前后用了五个月全部圆满。在此期间，大修供开始的时候，出现了彩虹的帐篷，大地震动等，前后三次灌《大宝伏藏》都有大地震动的征相。在中间休息时，作了一次很隆重的会供。还作了九部实受用护法眷属的供养，当把供养的供品送到火供中时，所有参加法会的人都见到了虚空中全是像帐篷连在一起的圆形彩虹，彩虹从空中直射到地上就像国王耳环与王后耳环，还显出经幢与经幡等许多供品的形状。据他们说彩虹帐篷中有一朵彩云，像骑士跑来跑去。由于这个缘起，在那个地区的人都觉得很奇妙，所以来参加灌顶的人越来越多。另外，还有在朵玛上生了像头发一样的花，一小杯油灯可以点很多个昼夜，甘露沸腾起来等诸多征像。
    灌顶到十分之三的时候，也就是五月初十的晚上，有这样一个境相：坛城的南方来了一位名叫白玛纽古帝瓦杂的空行母，衣着一般、身体也比较差，我问：“你为什么会这样？”“因为你们师徒《大宝伏藏》会供太简省了，您妈妈说这次要见你，叫我捎个口信来。”她这样一说后，我也想见见老妈妈，便问：“我的妈妈现在在哪里？”她答道：“在很远的地方。”那时我的腿痛，行走不方便，在梦中也有这个习气，因此想到需要走路的话，该怎么办？正想着，她就对我说：“不用走路，只要这样去就可以了。”说着她就变成了一只鹫飞了起来，我也随即变成了鹫飞起来。我们飞了很久，飞过了南方门巴、印度等地后，在印度和西方邬仗那二地的中间一座像直尺一样很光滑的山顶上降落下来，见到了地域极为宽广、望不到边际的西方邬仗那，中间国都的宫殿是一座上面有瓦盖着的很多层的楼房，以经幢、经幡和宝伞盖等作庄严。我问：“下面是哪个国家，哪个国王的宫殿和城市？”“这是西方邬仗那国聚集空行母的宫殿。”“那你不是欺骗我吗？大部分的灌顶和讲授我还没有圆满，还要给几位有缘的弟子讲授大圆满正行，我暂时不能去。”她听到后，显出很担忧的样子说：“那么，这次还不想去的话，不久后一定要到这里来。”说完，又变成鹫直奔大殿的方向飞去，此时境相消失了。
    第二天我作了隆重的会供和如愿，并在灌顶期间都很注意地找供品来供养。我们认为已是很隆重地作了会供，但空行母还是不那么满意。然而有的人还要说什么实际和观想，只是用糌巴做几个小小的供品来念诵千万遍，看来这样做是不行的。“要向至尊诸上师眼前忏悔供品法器小罪过”就是这样，想积累资粮反而起了拉后腿和犯戒的作用。娘仁波切说：“炒一点麦青稞来请很多客人，这是令客人不高兴的因。”就和这个一样，因此我想不要光说以观想来变化供品，要找很多实际的供品来作隆重供养才行。过后在灌顶和传承圆满结束时，非常隆重地做了一次为表示谢意的会供。供品有很多宝石、绸缎、茶叶、水果、骡马等各种千供。
    拉乌的管家来迎请我去他们那里，前来烧茶和献哈达的人很多，我在看得见仓巴大神宫殿红色岩石的地方作了薰香供。当时由于身体麻了一刹那，即进入无心境、无分别的境界中安住了片刻。过后的境相中看到从昌巴大神的宫殿里来了很多身着犀牛盔甲，手拿红色军旗，骑着红色马的鬼神前来迎接。僧众向我供养茶时，由于我正在看那些境相而忘记了喝茶，因此拉乌的头人棍波走到我的身边问：“您是不是病了？”“不是。”“那是不是有什么境相？”“什么也没有。”说着便来到了他的庄园，他们为我身边的一百多位求法者供养了修法期间的资粮。棍波请求要《心髓母子》、《七宝藏》、北传伏藏经典部分的灌顶传承，按照他的请求，灌顶和传承我都一一供养了。
    一天晚上，由于想去邬仗那地方的缘起，就持幻化身前往邬仗那空行母洲。许多种族的空行母前来迎接，她们边吹笛边跳舞的同时唱着持明者的悲歌：“拉伊笑，持明者，拉伊笑；拉伊笑，白玛楞遮杂，拉伊笑；拉伊笑，在桑耶青蒲的隔宫，拉伊笑；拉伊笑，在莲花生大士的足前，拉伊笑；拉伊笑，同一个法源的儿子，拉伊笑；拉伊笑，是否以前的誓言遗忘了，拉伊笑；拉伊笑，空行母的会集中，拉伊笑；拉伊笑，怎么不早来，拉伊笑；拉伊笑，耽搁时间太长了，拉伊笑；拉伊笑，我们很想念，请您来作伴以消除痛苦，拉伊笑。”在邬仗那地方，房屋都像青稞的形状，下面没有挨着地，上面也没有顶盖，齐腰高的五色光的围墙围绕着，各种颜色的五方勇士和空行母非常多。在每一位身着裙裤和飘带的勇士主尊周围都有空行母围绕，而每一位空行母主尊周围又有勇士围绕。四隅坐满了多方的勇士和空行，多得望不到边际，载歌载舞，食肉饮酒，受用各种果实，中间的宫殿外面像塔形，狮子宝座的地方有四门。东方的门前，嘎木西谢(息白)空行母在浴池中沐浴，她对我说：“此门是资粮道的入门，你不需要。”我问：“你在做什么？”她说：“我是资粮道的人，相续的罪过用沐浴来消除。”在南方的门前，色莫杰谢玛(增黄)空行母正用一个大石臼舂很多大米。我问：“这是干什么？”“此门是加行道的入口，你不需要，我是修加行道的人，断除证相的花纹。”西方的门口有一块大的石坪，中间有座一肘半高的莲台，走到那里看见门口有玛莫旺谢白玛纽古德瓦泽(怀红)空行母，以各种各样的珠宝和飘带作庄严，右手拿着二束红花，左手拿着装满酒的水晶瓶前来迎接说：“乘越资、加道莲台，菩提供品花与香，具八支德甘露酒，饮后请来无学道。”说着就让我坐在莲台上，将酒瓶赐与我后，我饮尽了，然后问道：“现在我是否从北门进去？”她说：“不用这样，你已经饮了八支圣道的酒，这个门是大乐怀之门，从这里进入缘起非常好，我们莲花部空行母的主尊也是你，你不知道吗？”她说着就从诸多宝石和绸缎作庄严的西门进去，我也跟着进去了，看到里面的宝殿是四方形的内廊和厅于，以宝物和红莲作庄严，厅中有身、语、意的八瓣莲花，白、红、蓝色依次重叠，莲台上面有各种四瓣莲花，花蕊中央下小上大(三角形)法基的上面，有五方佛和二十四域的诸勇士空行母。一位空行母主尊坐在中间，我坐在她前面铺着虎皮的莲花台上祈请说：
    “嗡，
    原来所发大誓愿，乃与诸佛愿和合，
    命终死亡合法身，中阴生起报身佛，
    再生净相化身佛，大灌顶请赐予我！”
    由此，东方金刚空行母用钺刀从嘎巴拉取出甘露说：
    “嗡！
    明空宝瓶宫殿中，显出空行母坛城，
    无有实体乃空性，具有大乐五智慧，
    圆满空乐本尊相，本来与自无二别，
    乃由大小禅定来，清净失误与邪见，
    下端微细之明点，小如芝麻十分一，
    从中生起大乐智，嘎拉夏。”
    说着就洒甘露并灌顶。此后羯摩空行母说：
    “啊！
    三世诸佛的三间，生起三个种子字，
    红白气心不分离，来去即是金刚音，
    入住融化之次第，任何一法亦难分，
    脉之结有三二六，自从外内近行中，
    取舍是故开下口，即能生起光明境，
    幻化无改自圆满。”
    西方的空行母又说：
    “啥！
    有情身语意三门，远离不清净执着，
    五方五部来分辨．是空行母总坛城，
    智慧方便和合散，五气聚集之缘故，
    息灭无数之别念，增长此本来智慧，
    显现三相之光明，联合心咒五色气，
    生起智慧空行母，不用转世与轮回，
    即身能成正果位。”
    南方的空行母说：
    “章！
    手印持命气心法，分为有缘与无缘，
    生后摧与持整体，入住融在中脉内，
    生起自身智慧相，成为起座行走气，
    内在本性不动摇，若能行经逆时者，
    诸空行母之誓言，能依所依全境相，
    住在顶轮与心轮，空色即会成自相，
    亦成长寿之精华。”
    此后，中央空行母主尊说：
    “嗡！
    前者所说之道相，未能消除二垢尘，
    是故佛意与色身，未能如实地成熟，
    进入无漏之圣道，圆满福慧二资粮，
    是故证得实光明，现量无分别空性，
    二识运行全息灭，开发圣者大智慧，
    消灭二障之力量，能使证得无学道，
    由此前三者行持，仙女龙女劣种女，
    招引和合之行持，外内功德四现证，
    生起大手印成就，证得殊胜大智果，
    能除无明与烦恼，如此实修禅定者，
    无身之身殊胜身，所生之身幻化身，
    此后入光明空性，一次禅定的功德，
    色相与本来空性，无二无别即双运，
    此后不用学何道。”
    随后，空行母作了个弹手指的标志，四方空行母融入中主尊母，中主尊空行母化光变成了浅蓝色的光点，在中央的莲台上，自声响起来说：
    “诸法本来即空性，无生起来也无灭，
    证得解脱智海中，如此成就清净果。”
    说着，蓝明点变成像拇指般大的松耳石明镜，上面有表无生的白“啊”字，自声响道：
    “大圆镜智来表记，诸法证得幻化相，
    有情遍布菩提心，大慈大悲全显现。”
    同时也响起了自声说：“啊，哈，日，呢，萨。”
    “奇妙神奇殊胜法，生起因缘本无灭，
    聚集空行母坛城，生起种种异相来。”
    由此响声的缘故，中间与四方的莲花台上，具各方颜色的各法基中央有：中布达空行父母二十八尊，东金刚空行父母三十尊，南宝生空行父母十六尊，西莲花空行父母六十四尊，羯摩空行父母二十八尊。
    此外还有：“意”的八朵莲花上，布呢阿麻那雅等八处有堪扎嘎巴拉勇士和忿怒瑜伽母二位等“意”的瑜伽父母；“语”的八莲花上，白玛噶麻汝噶玛日等八处，有嗡格日勇士和唉[日/阿]瓦空行母等“语”的瑜伽八父母；“身轮”八辐上，者达布汝等八辐有大势至轮勇士、持势母子二位等诸“身”瑜伽母住于其上，廊中和厅内有果日八空行母，外廊有狮哈八空行母和二十八自在母，另外还有千千万万的深蓝色大空行母，深黄色大空行母等，四门有四方大骷髅等坛城。有诸供养母作行茶者供了色、声等五欲，圆满的供品令众皆得欢喜。触空行母性自在说：“十六胜乐空虚酒，欢喜受用殊胜供，醉后入睡融光明。”依此缘起，外境与我内心以顺时进入了相、增和得三境，以此收回、融入光明界而与法界空性融为一体，心气的运行全部息灭而长时间地安住。重新起气时，以逆时出现了近得境后三相的光明为因，其座骑五光气为缘，我的心轮中有诸空行母大坛城的能依所依，有相而无执，空而无执，清晰而似幻化。此后，慢慢地苏醒在外境实相中，同时在自己的铺垫上醒了。
    有一段时间，我很想去莲花生的刹土，因此，就有到了邬金刹土中一个圆林的境相，树林中有药树，果树，各种花围绕的花园，看见有白玛纽固帝瓦则等莲花部的诸空行母在修行，她们很高兴地给我献上红花环，供养了种种供品后说：“从今直到得佛果，永不分离的誓愿，住在此地行密法，是否如意善男子。”主尊母又说：“这次不能留长久，菩萨行持是利他，是故度化有缘者，未曾得度诸有情。”说着赐给了我很多酒和各种果实，还说那是长住世的药。也说了很多延时的话，还说以后要到门措空行母宫殿中来，有话要跟我谈。说完后，境相就消失了。
    后来离开拉乌，到中印管家的庄园住了几天，为他们做了经忏佛事并按管家的要求传了法。也应大众的要求在屋顶上安立了仓巴尔大神的能依。(大神)附在一位僧人的身上，从那天晚上起，屋顶上有鬼神到来的异象，也听到了很多听不懂的各种语言，每天都有，因此大家觉得很奇妙。那时候，大姜玛莫妹妹来问讯并献了哈达。此后，再到四部落嘎桑头人的房间去住了几天，做了长寿灌顶、经忏等佛事。随后，前往邦达庄园休息了几天，念了巴珠仁波切全集的传承和其中几个讲授，还念了《般若波罗蜜多》、《现观庄严论》的注释等。庄园里主护法殿的多吉扎丹(护法神)，曾在我以前灌顶《大宝伏藏》时现身说：“像这样作很好。”还参加了灌顶，此时他又高高兴兴地来接受了《般若经》的传承灌顶。很可能是这个原因，在《大宝伏藏》从头到尾的传法过程中，我们师徒没有一点违缘，我认为是与这位大护法的事业分不开的。
    随后去拉都朝拜大日如来，在那里供了千供，按照《四曼扎的仪轨·龙王之意》作了诵赞。持咒诵赞的同时也好好思维了大日如来亲口所说的《二十一度母赞》内容，为了弘法利生而念诵了一千遍《二十一度母赞》。那时因供养的人太多，油灯和供品都无法摆设，剩下的酥油是放在石器上和铁锅中供的。据说这大日如来主尊和眷众都是文成公主的伏藏品，又说是显出神通来塑造的，实际上那是一天然出现的大日如来石像，佛像有一层楼高，八大菩萨有人那么高，还有一尊法王像和守门的忿怒像等。其中金刚手的面部是寂静相、头发和眉毛是忿怒相，时而面部又现出各种寂静和忿怒相，头发和眉毛上燃出火焰及进发出火星，眼睛的变化，嘴唇的微笑等等每天都不一样。我知道这是我得到了这尊佛的加持。
    后来到了彭措湖边，这湖形状像金刚亥母的身相，湖的中间有两座小山，表金刚亥母的“乳房”，到“左肩膀”靠近“面部”的地方献了哈达和圣物粉，也献上了三颗宝药丸、黄金和白银等宝物。我们安营住在“身体臀部”左边，作了很丰盛的会供，会供时下了一场倾盆大雨，天晴后，在两座小山上出现了各种颜色的彩虹。在那里，我们连续住了三天来做会供，临走的前一天晚上，听到两座山上传来很多女人优美的歌声，那里的牧民也说我的帐篷和神湖之间有彩虹连接了三天。不管怎么样，这是得到了圣湖的加持。本来我的身体不舒服已经很长时间了，但由于圣湖的加持也痊愈了。’
    随后到了邦达，作了经忏和佛事以及大吉祥母的招财仪轨，信众给我供养了很多供品。我在到达芒康时，为国兵灌了长寿顶，并赐予运气旺盛，赞美战神，武器加持等。闻达谢公子塑造了三依，我按《善如意》的仪轨用了三天对整座宫殿和三依开光。他们给我供养了各种财物，我也给那个地方的萨迦巴、格鲁巴等寺院也供养了白银、茶叶等。此后，公子等亲自送了一天，到了青邦驿站，此地已多年不长庄稼，但是那一年整个地区，尤其是青邦的庄稼长得非常好，连马草都结了穗，大家都说很奇妙。所住的村庄都按自己的能力前来供养，并祈愿年年丰收。后来听说那里连续三年都丰收了。我到珠古多驿站后，前往大持明者敦都多吉和伏藏师达雄挖掘的《益喜措嘉空行母传记》中说的，在整个康区独一无二，是莲花生身、浯、意无二无别加持过的三达仓之一的意的神山——藏谢多吉卓络神山去结缘。在愣果寺住下后，我自己当施主，请整个寺院的僧众共同按《八大行法的仪轨·大乐妙用》修了一次甘露丸的前行、正行和结行。这些都是按照持明者的传承进行，法会开了十三天，最后修供和灌顶连在一起，法和甘露丸连在一起。供养每位参加法会的人四两白银，喇嘛和珠古们也按层次供养了三十两、二十五两、二十两、十五两、十两白银，大法会的全部费用按汉钱来算为三千多元，功德回向圆满后念了《普贤行愿品》。此圣地主供有莲师忿怒自然像，左右供有敦都和达雄两位亲自塑造并各自开了光的泥塑像。另外，在一修行洞内有莲师忿怒塑像等三依，在离开的前一晚上，洞内出现了很亮的光，供桌颤动，圣山里几天前就来了从未见过的神奇鸟，直到第二天才飞走等瑞相，这些是供司们说的。第二天，在洞内准备了会供的糌巴四十袋，面粉八袋，酥油七包，奶渣三包，各种果实五包，三付全牲肉腔等，按敦都伏藏经典为四客欢喜而努力举行了莲师忿怒仪轨的会供、薰香供和火供。那时，多次来人来函邀请我参加甲色仁波切转世灵童的坐床仪式，虽然还没有念满十万遍会供，但供品倒是供了几十万遍，供司很惊奇地说：“供十万遍的会供从来没有见过这么丰盛的供品！”我还留下了供长明灯的油资。开始修供“请降临”时，莲师忿怒的自然佛像动了起来。由火星的响声为缘起，在明智法性本来面目中安住了一天，我想这也是本尊的加持力。此外，还作了圣地维修和大神山降临的加持。后来据说此地区很吉祥圆满。到甲色寺住在山庙里，藏历九月二十二的佛入胎日早晨，以持明者龙萨宁波的伏藏经典《莲花光耀》和《修长寿无上极密》两者连在一起来修。特别是仁波切坐床仪式时，除魔、沐浴、除垢和消除不祥物等前行做好后，诸坛城的主尊观想为莲师，智慧本尊与三昧耶本尊无二无别地融为一体。外内供养，开光，安住，供曼扎之前，念了曼扎的讲解及赞颂。以噶陀寺为首的各个寺院都献上表示庆祝的供养供品，念完供养文后，结行吉祥长寿灌顶等诸行圆满。此后，萨迦来的果那法王的转世及眷众和别处来的僧众们很多，我为他们灌顶传承了《上师意集》、《八大行法如来集》，噶玛林巴伏藏经典《寂静忿怒百尊》，敦都伏藏经典《莲花光耀》，龙萨宁波伏藏经典《红狮面佛母》、《寂静忿怒百尊》、《大悲修供》、《心髓母子》等。应果那寺的邀请，前往住了两天，灌顶传承结了法缘，并为大殿开了光。这个地区来邀请和供养的寺院很多。回到甲色寺，为整个寺院的僧众，和当地的男女信众举行灌顶传承，结了法缘。收到集体和个人的供养也很多。到色德寺，为寺院和村民们灌顶。在色德仁波切的房间里，为转世灵童作了《莲师忿怒》的会供，并认定了灵童。那时虽然是冬季，但当地老百姓看到很多彩虹在寺院的上空，灵童选定为宁西伏藏大师噶玛的儿子巴登嘉措的小儿子，但缘起不好，后来听说也圆寂了。
    玛要官邀请我的人来迎接，离开时，寺院送行的人也很多，到了曼曲卡，这里是文成公主从前洗过头发的地方，在那里有一棵柏树，树上有二十八自在母，我以闻到一种香气为缘起，身心进入遍满乐的定境，在明智无分别中安住。过了一会，外相在前方虚空中显出身着汉女服饰的文成公主，面容白里透红，身材又高又细，像红莲花般的手上捧着《度母行诸种续》经卷，显出神通为我灌顶讲授。这种境相持续到行至白玛神山下，这是得到了公主的加持。我到玛尔管的庄宅，按他的要求作了灌顶传承，结了法缘。之后来到拉拓牧场见到了苍曲弥嘎木，那里还有天然的六字真言，龙王敏棍根噶说：“在扎[日/阿]龙嘎木，有一份分给你的财物。”我觉得没有多大的作用而放弃了。
    到了贡觉地区，那里的各个寺院和头人们都前来邀请我前往，但当时是寒冬季节，而且下着很大的雪，所以我只去了多珠上、下游，去巴拉村化了一百六十多包粮食，将这些粮食全部供到噶陀寺用来新建大佛殿。还顺路到了贡觉的七个头人家和八、九座寺院。扎亚拉帕寺和拉松，可[日/阿]、都日等地也来邀请，但我没有去，只顺着大道到了桑珠头人家休息了几天，在那里为头人和信众作了经忏及佛事。到辽拉向曲多吉的道场，为六十四位僧人传了沙弥戒和比丘戒，这些善业都以三轮清净供养了。由芒康到这里为近三百人授了戒，求大圆满正行的有一千多人，求气脉讲授的有四十来人，求《智慧上师》讲授的有一百来人。我讲授这些法，并没有像大喇嘛那样摆大架子集体化地讲授，也没有像大智者那样语句化的讲授，而按照持明传承的言教，立断的明智，顿超的四灯把大圆满的窍决详尽而细致地讲授，具证相的老人们也不由自主地说：“从来没有听过这么殊胜的大圆满的讲授。”那时候，因为来印证和断除增益的人很多，只有一次为三四十人共同讲授而没有一个一个地讲，所以有的成了比较粗糙的执行者，但人太多，这也没有办法。
    离开芒康后，我总觉得仓巴尔，特别是大姜妹妹一直跟着送行。到桑珠时，我叫他们不要再送了！但他们说：“噶陀的护法神依怙主和空行母还没有来迎接，在它们还没到来之前要护送。”这一定也是从前有誓言的护法。从那里平安地到达了噶陀寺，向所有僧众，特别是给仁波切们作了供养，另外还将财物、黄金、白银折合汉元一万零三百多元，全部用在光明宫殿作金瓦上。随后回到了自己的道场，从别处来求法的人们，也按自己的能力与他们结了法缘。
    猴年开春时，扎拉寺夏扎仁波切建新佛学院要我去那里，我也答应了。过年的时候，到德多志美伏藏师圆寂的地方作了供养和荼毗法体宝。本来决定二月初去扎拉寺，但白玉寺的直旺白玛诺布病重邀我去，所以就先到那里去了。斯度法王圆寂后，宁玛巴传承中能弘法利生的大德就是他了。我在那里做了很多祈请长寿住世的仪轨，但没有起到多大的利益，就请求暂时去扎拉寺，并答应尽快回来。在去扎拉寺路途中的一天晚上，境相中看见宗喀巴大师、法王米旁仁波切和我的具恩上师坐在一起，他们在互相辨论月称的中观应成派方面的疑难，我想我要是听的话会得到一些新的见解。但具恩上师说：“把你所作的大圆满讲授和注释拿来我看看。”我呈献后，上师高兴地说：“做得很好。”依这个梦境来看，在扎拉寺可以建上一座比较好的佛学院。在离扎拉讲修院不远的地方住了一晚上，第二天骑马来迎接的人很多，到寺院后就住在夏扎仁波切的禅室中，为了给四十多位学员开发智慧而作了《文殊赞修供》的灌顶传承和讲授。班智达玛德所著的《白文殊·仪轨》的灌顶和《释随念三宝经·无尽吉祥的妙音》，寂天菩萨的《入菩萨行》注释(托美造)，还讲了《智慧品》注释《格达嘎》。另外为其它几位求法的也讲了《普贤上师言教》、《智慧上师》、《三解脱的讲义》、《心性休息三间三善讲义》等。圆满的时候，梦境中看到白玛诺布仁波切往生别的刹土去了。于是我持幻化身去见他，我问讯时他说：“现在这个病把我的内脏大部分都搞坏了，已不想继续住在这个幻化身里面，故准备走了。”“想去哪个刹土？我也给你帮个忙。”他说：“心识骑气的窍诀我很熟练，想去哪个刹土都可以，特别是念了一亿遍大悲观世音菩萨的心咒，《意修勇士集》的心咒也念了那么多，经常见到莲花生大士，所以到普陀山和莲师刹土，或去哪一个刹土都没有问题。但您的《光明心髓》此法还没有作到更多的事业，我对这方面的希望很大，愿意在您身边。”我说：“请暂时不要这样，噶玛恰麦仁波切说，选刹土的骏马最好是极乐世界，暂且去那里，再可以化现应化身来作想作的事。”“那么，我就暂时去莲花光明刹土，请加持今后能如愿。”过了几天，捎口信的人说白玛诺布仁波切的病情很重，要我赶快去。我尽快赶去时，仁波切已经圆寂五天了，做了放意誓(出定)和祈请速转世的愿文，为法体宝供养了供品。从白玉来的噶玛阳瑟师徒，供了三天供品云，瑟安具仁波切和格桑丹增等也来参加荼毗大典，以《大集合》和《八大行法如来集》为主的四坛城来举行荼毗。此时出现大地震动，听到铃声等法乐声，闻到扑鼻香气，五大妙用的圆形彩虹成为帐篷连在一起遍满虚空等诸多瑞相，故对信众增加了信心。清理灵骨请回白玉寺供了三个七期。接着，为弟子讲经说法，作了《心髓母子》的灌顶传承，用《金刚橛续部仪轨》灌顶，在金刚橛护法灌顶时，朵玛上燃起火焰，进出火花，甘露沸腾，有几位弟子听到了狗、狼、狐狸、豺等叫声。
    有一天，收到噶陀寺要我参加法王斯度仁波切的转世灵童坐床仪式的信，因此前往噶陀。蒋杨钦哲旺波的转世蒋杨罗珠嘉措说让我作坐床仪式的金刚上师，我也答应了。坐床典礼按五世达赖喇嘛的转世苍央嘉措的坐床仪式，以德思桑吉嘉措问敏珠林伏藏大师作答所著的《大集合菩提心的灌顶》仪轨来举行了。
    在我年满四十五岁的秋天作了一个梦，梦见蔡千·络赛嘉措和与我无二无别的勒萨瓦·蒋央钦哲旺须一起行走，我俩赶着一头白色骡，驮着一驮经典到了一个地方，打水拾柴烧茶时，炉灶的右边有三枝黄花，左边有七枝红花，我问蔡千仁波切：“这是什么意思？”他说：“三枝黄花是我还要投身三世为宏扬佛法的比丘相，这些红花是您来世七代要作殊胜的咒师相的标记。”又问：“这是什么地方？”“这里不是贡波布秋庙附近的德吉康萨家族吗？”他回答说。
    我年满五十五岁时，为了消除违缘，闭关近修了热那林巴伏藏大师的伏藏经典《无上极密金刚橛》，这是莲花生大士最心爱的法，既无增加又无减少地传给益喜措嘉空行母，是极为殊胜的。近修此法过了一段时间，梦境中到了门卡列任森格宗，在一个小泉水的上面有一个非常舒适的岩洞内，这里面看见金刚橛盒的坛城上有系着蓝色飘带的天铁金刚橛，火星嚓嚓地进发出声音来，我虔诚祈请后，这金刚橛变成了空行母益喜措嘉的相，前面有莲花生的亲弟子阿札亚萨勒作护关。我生起信心地说：“诸佛陀之智慧身，本来金刚法界中，炽燃忿怒相现身，祈愿生起一佛子”等，如此在益喜措嘉空行母的前面祈请，蓝色发光的金刚橛台上，像涟漪般渐渐地扩展。中间的主尊在三角形蓝色发光的台上，噶巴拉的周围外台子有四辐天铁轮，在此外面的四方四隅中有八大忿怒本尊，其住处有八辐轮，宫殿的天窗上有忿怒日台，主尊的台呈三角形，台内空间中三角形的角尖伸到宫殿的庑廊内，上端是菱形，前方有门，下面有忿怒相台等，益喜措嘉空行母正在这里讲授《金刚橛根本续》，由心轮发出一个又一个的天铁金刚橛，各位本尊处设有金刚橛箱，这也变成了根本坛城而显现出来。阿札亚萨勒作羯摩金刚来作《释十万黑金刚橛》的灌顶，护法灌顶前，在羯摩金刚唱了一首长长嘘歌的同时，一刹那就来了十二空行母护法和四门卫等，教诲并灌了誓命顶，我请求讲授热那林巴伏藏大师的伏藏经典《益喜措嘉空行母的问答》，但益喜措嘉说：“这个《释金刚橛》，是我请求莲花生大土讲的，是三金刚上师共同的心意，讲这个更好。”说着就赐予了我。过后三个根本坛城都融入了益喜措嘉空行母，护法的坛城融入了阿扎亚萨勒，益喜措嘉空行母变成九股天铁金钢橛，有浅蓝色“吽”字作表记，“吽”字发出“呜鸣”之声，也如空中的彩虹一样消失，自己的明智智慧金刚橛融入无生的法性界，在无分别的法界中安住了片刻。
    在又一次境相中，看见蒋贡罗珠塔耶显出很老的相，身着紫色绸缎的衣裳，对我以前三次《大宝伏藏》灌顶传承表示很欢喜的样子说：“这是分给你的一份法，是我的伏藏经典《母经空行母秘密心髓》，现在需要给你灌个道顶。”说着就给我灌了这个顶，还传授了极殊胜的《空行母续》。又说：“目前，弘法利生的事业应该由你来承担，然而你仅作无戏论这一点很可惜。”另外还给我传授了很多法，但我认为没有必要写在这里，所以就不写了。
    如此正值末法时代中，地域时间差故上师差，信心精进智慧亦太差，无有清净功德可写处，
    然由贤哲善知识摄受，深广显密经论闻思修，
    平息相续烦恼圣者恩，并无智者欢喜优美词，
    更无修道成就之现证，但为消除增益之二边，
    毫无保密叙说自证相，随我后学有缘诸弟子，
    清净传承法脉须重视，正统不可增加与减少，
    窍诀不能混淆它传承，是故生起正信心而写，
    自从佛祖正等觉至今，以上无有词语之改变，
    意义传承一一接下来，犹如国王圣旨传接般，
    加持密意传承从未断，词语教授传承也未断，
    心识不证密乘了义法，福大有缘弟子信心得，
    词义著为文字之功德，消除有情众生之迷惑，
    愿能行持大圆满实义，成为圆满自他二利因。
    在这样一个末法时代里，地、世和时间都很差，因此
    度化众生的上师也差，信心、精进和智慧都太差，没有非常多的清净功德可写。但是，既有几个贤哲善知识摄受，闻、思、修深广显密经论，精进学习对治自己的相续并能平息，这与圣者们的恩德分不开，使智者们欢喜的优美词汇也没有，根本谈不上能够成就的修道现证。然而为了消除增益二边，没有保密的讲出了我自己的证相。跟我后学的有缘们，清净的传承不能轻视，也不能作假，更不能有增加和减少，这窍诀不能与传承混淆。因此，为了生起正信心而写，从正等觉佛祖直到现在，没有词语的混淆，而是实义意传承一致地延续下来，就像国王的圣旨一个接一个传下来的。因此，这个传承的加持从未断过，也没有断过词语的传承和教授的传授，此意不可以用自己的兴趣而得到，因为这是密乘最殊胜的传承，也是有福报的有缘弟子才可信奉的法门。词义写为文字的功德，消除有情的全迷惑，愿能行持大圆满而成就圆满自他二利的因。
    这是由于诸持三藏者的请求，特别是吉美多吉仁波切、堪仁波切勒谢觉丹、利丹两位，堪贡觉扎巴仁波切等诸位智者、善知识等前后再三地请求，因而白玛愣遮杂写于自己的道场——辽西圆林。愿将上师看成是成佛的因，而现证明智普贤王如来的果位。善哉！善哉！善哉！


二十五本生传

    维摩诘 又名无垢称，据《维摩诘所说经》记载，维摩诘是释迦佛在世时，中印度毗耶离城中的居士，虽身在尘俗之中，却精通大乘佛法，辅佐佛陀教化众生，是名副其实的法身大士，“以众生病，是故我病”而与前往探病的文殊菩萨一起以种种问答揭示空、无相等大乘深义。佛授记：“佛涅槃后四百年，作比丘持名为具祥(龙树)，弘扬中观大乘。”佛陀涅槃后的二十八年，金刚手菩萨向天、龙、药叉、夜叉、人等五圣贤宣讲普贤佛在法界传授的密法，维摩诘即是当时圣人持明的祖师。金刚手加持密续宝典降落在渣国王的皇宫上，渣国王在维摩诘处求得口耳传承，这是密续在人间传承的开始。
    持佛名比丘 又名积慧，号称一切世间乐见离车童子。据《大法鼓经》记载：过去鸡罗佛时，他是一位持法治国的转轮圣王。此后到灯光如来出世时，生为地自在王的长子，有状如天女的六万姝女弃之如唾，一切有为法了知无常并危脆不坚，舍家学道。灯光如来授记曰：未来释迦佛出世时，名为一切世间乐见离车童子，此佛涅槃后，正法将灭前的八十年，作比丘持佛名(积慧)，宣扬《大法鼓经》，大乘空经，击大法鼓，吹大法螺，设大法会，建大法幢。百年寿终，生极乐国，得大神力，住第八地。此后过千佛六十二劫，成就佛道，佛名号为智积光明如来应供正等觉。
    龙树 《大云经》、《文殊根本续》及《大法鼓经》中授记佛涅槃后四百年出生，弘扬大乘法。八岁时出家，依止婆罗门族的大持明者萨[日/阿]哈学了《密集金刚》等，并在师前求受了具足戒，赐名为妙吉祥比丘。去那烂陀寺求得了《三藏》和《四续》，并得到了文殊菩萨的加持，通达一切显密经论。曾在那烂陀寺生活艰难的情况下，自造了黄金供养。弘扬律经，降伏外道和持邪见者。去龙宫迎请了《大般若经》、《华严经》等大乘经典，并取龙宫的泥土建塔千万座。龙树是大乘佛教中观学派的创始人，其著述极为丰富，造论之多，世所罕见，如《中论颂》、《十二门论》、《空性七十论》等等，有“千部论王”的美称，又被尊崇为一切大小、显密佛法的祖师。
    月称 印度那烂陀寺的住持。拜龙树为师，得到三藏诸法，通达显密经论，外内一切执著全部放下而安住在真谛心性中。曾在自己所画的乳牛中挤出乳汁供养僧众。度汝卡的军队来侵犯那烂陀时，以神通力使石狮身上的鬃毛抖擞三次吓退敌军。又一次，森林四面发生大火，森林中月称安住的茅篷周围却完好无损。与旃陀罗波辩论七年。继承龙树的宗旨著了《入菩萨行》、《入中观论》和《明语》等。他被列入印度八十位持明成就者之中。
    法称 南印度婆罗门族人。少年修习婆罗门及外道，后以比丘模样修持佛法，外道的舅舅因此将他开除。他心想：“我要降伏所有的外道”。就正式入了佛门并受了比丘戒。在自在军前重复学了三遍《集量论》。为了学会外道的窍诀，装扮成外道舅母的佣人，潜入外道群中学到了外道的明论并说：“我已精通了外道的所有秘诀。”降伏了大部份的外道，剩下的也都逃跑了。贤哲们赞美说：“如果没有法称，就会降落辩论的太阳，正法将被粉碎而消亡，邪法就会昌盛。”花增王也护持他宏法。著作有《释量论》、《正理一滴》、《因一滴》等因明七论。
    安慧 世亲论师在邦噶比哈那，坐在装满了植物油的锅里，念诵八十遍《五般若》。当时在旁边一只经常听闻的鸽子死后投生在边地，刚刚出生时就问：“我的上师世亲在哪里？”父亲在知道世亲在中印度后，终于把他送到上师处。上师给他教授了五明。在那烂陀寺向度母佛像供养豆子时，亲见了度母并领受了加持，开发了智慧成就无碍的辩才。将《大宝积经》从头背到第四十九品，并作了注释。著作有《唯识三十颂注释》、《大乘阿毗达磨杂集论》、《大乘五蕴论》等，成为十大论师之一。
    蒋巴些宁 出生在印度西方。幼时学习外道，精通吠陀经典。见到极喜金刚，并得到外、内、密续的殊胜窍诀。又在受金刚处得到了密法，获得共同的成就。在一座桥上遇见骑象的外道国王，双方互不让道。阿阇黎作手印，外道国王和大象顿时被撕成两半掉到桥下。臣民们忏悔后，再将他们合拢复活，从此，外道王皈依佛法。蒋巴些宁得到了与文殊菩萨无二无别的双运大成就。文殊菩萨给他亲传了亚门达嘎的灌顶、讲授和窍诀等，他降伏诸多鬼神成为佛教的护法。婆罗门成就藏也是上师阿阇黎的别名。
    洛布果勒 又名吽噶拉，出生在尼泊尔的婆罗门族，在南那烂陀寺住持佛智处受戒出家，听闻显密经论并实修外内密续。在灌顶黑汝嘎坛城时，供养花落在佛部，了知若修此法则定能成就。以伏藏取来的黄金请了一位具相的持明母，携她到山上修持六月后，证得了大手印殊胜成就。著有《真实成就》、《真实如鲁金链》等诸多论，最后即身成就，似大鹏金翅鸟直飞东方不动佛的刹土。
    比马拉米札 又名无垢友，诞生在印度郎布冈(牛背山)。学了五明学和其它所有分支，以及大小乘全部经论。依止布达格阿阇黎闻、思、修密乘续，成就了大手印。按金刚萨埵的授记，到大唐去见西日森哈阿阇黎，求得了口耳传承外、内、密的窍诀。再次到达渗尸陀林，拜见迦那苏扎大师，圆满求得了大圆满无上秘密的灌顶和窍诀。因此生起了不共殊胜的证相，证悟时，鼻尖上显出白色的“阿”字。迦那苏扎虹化时，四方法门再显语教言，因此在词语和意义方面都得到了印证。殊胜的极密宝典写了三份，一份埋藏在邬仗那金沙洲，一份藏在金洲的悬崖里，一份交给了尸陀林主空行母。西藏法王赤松德赞迎请他来雪域，为法王和娘·定孜桑波等传了所有窍诀后到中国五台山，成就大虹化身，并发愿在佛法完全隐灭前常住世。
    那噶达咱 又名龙宝幢。是堪布、上师和法王师君三尊在西藏开始弘扬佛法时，九大译师中三位年青的译师之一——焦若·努益坚赞。在寂护处学习翻译，与莲花生共同翻译了诸多内密乘续和窍诀。后来奉国王的圣旨前往圣地印度，迎请比马拉米札来西藏弘扬大圆满的窍诀。在桑耶寺译经院，和诸位班智达进行了十三年的翻译工作，将印度的梵文及孟加拉、克什米尔、斯里兰卡、中国等语言的经典译成藏文。后来修持大圆满成就了虹化身。
    定孜桑波 法王赤松德赞的大臣，曾入定一坐七年。肉眼通能一刹那观看四大洲，给国王授记说：“现在印度有一国王供养的寺院，其中五百位班智达的首席上师，是传授密乘光明大圆满殊胜法门者，名叫班智达比马拉米札。应该迎请这位大成就者。”因此，国王派遣三位译师带着黄金前往，比马拉也了知度化机缘成熟而应邀前来西藏，传授了《因果经》，特别是由玉扎宁波为译师，比马拉将后译十三部最殊胜的心髓窍诀单传给国王和定孜桑波。比马拉前往中国后的五十五年，娘·定孜桑波成就了无漏的光身。多吉勒巴(妙金刚)护法神送他在康区降冰雹收来的五百驮骆驼的粮食，以此粮食创建了邬汝夏益拉康(中土帽寺)。把窍诀埋藏在此地修行洞三层门内，口耳传承传给仁青巴，最后在拉萨鲁普修行洞内成就虹化。
    囊卡宁波 在寂护法师前出家并受比丘戒。莲花生大师灌顶《八大行法》时，供养花落在真实意部。通过修持成就，来去时显出骑着阳光行走的神通。学习了梵语，法王派遣他前往印度，拜见了吽噶拉阿阇黎与其他诸班智达，得到了灌顶传承和窍诀。回到西藏后，由于不喜佛法的臣相从中作梗，因此就去了拉扎它曲修持，亲见了本尊，成就了大手印持明，不舍肉身飞往刹土。
    囊巴囊王 又名超日王，印度崛多王朝的国王，佛陀涅槃后的一千年出世。是一位威名远播、诸印臣服并大力护持佛法的大施主法王，护持无著、世亲等大论师振兴瑜伽密法，又奖励各种文艺宗教，赈恤贫穷，照顾臣僚，被臣民们尊称为圣仙大王。根据藏文书籍记载在莲花生大师《五部遗教》中的《译师班智达教言》和《妙音天女传》等书中都说他是龙树菩萨的再显化身，名为威严超日大国王。
    那耶美多 又名赤松德赞，在《文殊根本续》中赞称为地光贤，也就是松赞干布后的第五代法王。十七岁执政，与格法臣商议从印度迎请了寂护法师和莲师，创建了桑耶寺，还建立译经院。召集了一百零八位班智达和译师，培养出贝若杂那、噶瓦·巴则等西藏的一百零八位翻译家，将密经典和续部《甘珠尔》、《丹珠尔》译成藏文。让安置巴·益西旺波等七位首批出家，建立了二部僧众，王臣二十五等成就者遍满了全西藏。现在西藏显密经等宏扬的所有功德完全是此法王的恩德。法王和文殊金刚本性无二无别，在莲花生那里灌顶时，供养花落在中央殊胜甘露功德上，在莲师、班智达比马拉和大译师贝若杂那等处修学了大圆满窍诀的灌顶、讲授和传承，自在了大圆满三摩地证相。在寂护法师处学习显密经论，著有《正量论》、《般若十万颂注释》，最后进入文殊智慧意，后来也不断地显现了应化身。
    登巴泽仁 德格法王登巴泽仁，生来就有慈悲心，敬重三宝，和顺发心。幼年始学了显密经论，尤其是学习了医方明，如法治理国家，因此当时国泰民安。在康区所有大小寺院都曾作过护持，帮助建立三依，特别是创建了藏文大藏经印经院(即德格印经院)。
    隆钦巴 又名无垢光，《声应成续》授记说：“此后大智慧持法。”与普贤王如来无二无别、为弘法利生显现为白玛塞公主的转世——白玛楞遮杂，他在报身刹土游览了一下就显出无垢光，从小就具有圣者的德相，进入桑蒲寺通达了显密经论，在大持明古玛[日/阿]杂那里得到了《大圆满心髓》的灌顶、传承和窍诀。从此以头陀行实修了七年大圆满，得到了上师和本尊的加持，证得了“明智圆满如量相，”亲见了莲师父母，领受加持并得到了《空行心髓》的传授。按心意伏藏结集了心髓二法，著了《三心髓》、 {七宝藏》等诸多论著，创立了光明大圆满密乘心要，培养了无数弟子。最后在桑耶青蒲显现极为殊胜的证相而位证佛果。
    索囊僧格 萨迦派六庄严之一，精通显密经论，又称果噢让蒋巴(果涯地区的大智者)、依证教辩才第一，遍知索囊僧格(福狮)。萨迦派分萨、俄、蔡三传承，他是其中俄传承大智者金刚总持贡噶桑波的亲弟子，俄传承的第五代祖师。萨迦派中分大众讲授和单传两部份，其中大众讲授的历代传承祖师即是他的再传弟子。
    益西苯巴 是噶陀寺的律师、传戒师，是噶当巴德协的上首弟子。二十九岁时继承了噶当巴德协的所有法脉，弘扬了显密经论，特别是内续三乘瑜伽。同时有十八万僧众举行布萨，在他的弟子中有一百多位获得了虹化成就者，住持噶陀寺四十四年，后来将法脉交付昌国王之子向秋巴，色身摄回了法界。
    宁玛俄色 从小就见到释迦佛祖、大悲观世音和莲花生。并得到灌顶加持。取出伏藏经典《八大行法如来集》以及伏藏的佛像、尝解脱等。前后求了莲师和八大持明等圣法；并得到了八大行法传承和窍诀，弘法利生的事业遍如虚空般广大，是伏藏师的开创祖师。最后色身摄回了法界。
    白鸡愣遮杂 白玛萨公主的转世，名为德敦仁钦次多。密名白玛愣遮杂，出家法名赤诚多吉。二十三岁时，得到大伏藏师仁钦林巴的授记，在达波地区掘取了《大圆满空行心髓》等伏藏经典。在桑耶青蒲时，按金刚亥母的授记到拉萨拜见噶玛巴让迥多杰，并将《空行心髓》传授给噶玛巴；还将全部传承灌顶传给了夏迦色勒巴和珠古仁钦林巴。一生中作了不可思议的弘法利生事业，后来圆寂时、舍利上显现出金刚亥母的像，空中连续七天遍布了彩虹。
    噶玛林巴 出生在达波地区，大成就者涅德桑吉的长子。本来具有许多殊胜的功德和神通。十五岁时得到授记并具足上好的缘起，前往岗波吉日雪山掘取了《寂静忿怒百尊·意自然解脱（西藏度亡经）》、《大悲莲花寂静忿怒百尊》，为十四位法主弟子传了《寂静忿怒百尊解脱法》，《寂静忿怒意解脱》单传给自己的儿子涅达曲吉，此法单传了三代后，南卡曲吉嘉措将此法广弘开来。
    仁青罗珠 是卡钦巴吉旺须的转世，出生在下多康，俗称玛帝热那。在协科泉水中取了伏藏经《空行降魔忿怒母》上师相应法，因为他很穷，向莲师祈求赐福，莲师授记说：“在东方夏[日/阿]噶摩有骡驮黄金。”但实际上只挖取了用手捏出来的一骡驮黄金，如果把这些作为供品来修持则可以得到一驮的财物，后来缘起不好，没有完全实现就圆寂了。
    圣格王修 出生在娘若涅家族，从小多闻广思，在罗睺罗沟见到了勒德当玛，得到了所有窍诀。上师圆寂后，将窍诀经典藏起来到山上去修持，梦见一位阿阇黎说：“我是比马拉米札；有缘弟子想得到传承就应该前往桑耶青蒲扎玛隔宫之上，那里有密乘心髓此法”。得此授记后就动身前往，护法神将法亲自交付给他。在俄尤西岗扎瓦修行时，比马拉米札亲自降临，并为他传法灌顶半个月，后来将窍诀全部传给了向敦珠古。实修七年后，成就了虹光身。
    噶玛恰麦 他是达噶那咱的转世，出生在昂地区。从小就精通藏语文和历算，修生起次第很稳固并得到自在。学习了显密经论，在红帽第六世噶玛巴处受了具足戒，并得到了大手印传承。长期住在尼多巴日侧，修了许多本尊，境相中亲见骑着罗刹韵莲师，因此，取出心意伏藏《大悲讲授》，据授记，此法聚集度化十八亿众生，并往生极乐世界等诸功德。还写了实修窍诀五十多函，最后即身成就，往生极乐国。
    多吉塞杰则 阿格旺波的法名之一，又名阿旺巴桑，金刚亥母赐密名为俄萨仁钦宁波白玛愣遮杂，因在噶陀佛学院担任堪布十三年，故又称堪布阿琼(或称堪布阿利)。依止喇嘛龙多·丹比尼玛六年，求得大圆满隆钦心髓所有灌顶、传承和窍诀。前往竹庆寺佛学院学习了三年显密经论及文化知识。在辽西圆林修行洞内闭关实修，现证了十地五道的究竟功德。创建了辽西寺及佛学院，著有《入中观论释》、《普贤心要》等显密经论和窍诀，整顿、弘扬了大圆满隆钦心髓，最后色身摄回法界，亲自授记的化身松吉泽仁诞生在西藏贡波地区，现正在宏法利生。
    此本生传依江央老堪布和阿松堪布提供的资料所编。


阿格旺波零星传记

    生起信心良药
    本来远离常与断见不坏金刚称法身，
    无生无灭始终任运自然净相号报身，
    远离二边不可思议戏论示现应化身，
    顶礼无别遍知阿格旺波上师自性身！
    尊者三密功德深如海，愚昧心识难于辨别开，
    然由鉴析清净摩尼镜，妙音奉献诸具信心人。
    先如此之赞颂供养后，一般来说登地的诸菩萨，本来无生死之相，现量成就无边金刚身，但是为了度化众生而示现应化身的功德。《宝性论》中说：“具有清净见定故，远离生死等诸相，然由生起慈悲心，示现生老病死相。”如此，除事业的变化相之外，无有别的事实。尤其是遍知者阿格旺波上师，实质上与金刚总持无二无别，是在法界早已觉悟后再显的不可思议幻化相的应化身。共有二十五代：释迦佛授记的三尊者(维摩诘、持佛名比丘、龙树)、印度的三圣者(法称、月称、洛珠登巴)、三瑜伽禅师(曼珠密扎、吽嘎拉、比马拉米札)、西藏的三译师(达那嘎达、定增桑波、囊喀宁波)、三大法王(囊巴南王、赤松德赞、登巴国王)、西藏的三位班智达(隆钦饶降巴、索囊圣格、益喜笨巴)、三大伏藏师(宁玛俄色、白玛愣遮杂、噶玛林巴)、三头陀瑜伽行者(仁钦罗珠、圣格王修、噶玛恰美)等等。其中与大班智达比马拉米札和无垢光尊者无二无别的遍知者阿格旺波，号称阿旺巴桑·俄萨仁钦宁波·白玛楞遮杂，他美名天下之功德全在《自传幻化戏论》中记载。以下我要写的，是以他几位亲弟子的零星话而作的没有次序的记述。
    班禅比马拉说：“到了心髓之法与心识辨别混淆的时候，每一百年我的应化身要亲临！”正如他的誓愿，为了清除违缘，弘扬、整顿光明心髓法要，第一个百年就来了当玛楞珠坚赞，其后有一位就是遍知上师(阿格旺波)。
    龙多喇嘛依止了二十八年巴珠·邬金吉美曲吉旺波，后来在扎秋莫康多离开巴珠仁波切回家乡时，阿吾(巴珠)仁波切用双手抚摸着龙多的头说：“龙吉，你不必伤心！大遍知者(无垢光)我是见不到了，但你可以见得到！”龙多忍不住离别的悲伤，哭着走了几步后又返回去，将头置于阿吾仁波切的胸间。如前面一样，阿吾用手抚摸着龙多的头重申他可以见到大遍知者，如此重复了三次，阿吾都作了同样的安慰。
    离开上师后，喇嘛龙多仁波切到噶陀菩提洞住了三年，以后又没有固定地云游了不少山庙，后来到了多珠钦寺，住了一段时间后说：“我要回家乡，辽西圆林的东面附近一个叫色雄沟的下游，有一座倾斜着的金塔，扶了多次，快要扶正了。这样的梦我做了多次，该是收弟子的时候了！”
    于是返回了家乡，在益勒嘎莲花山住下来，在那儿向诸多弟子讲述了阿吾讲的话，又用手指着阿格旺波说：“比马拉每一百年要来的时期已快结束了，现在这位小孩如果不是大遍知者的话，我肯定就见不到了！大遍知者的化身确实来之不易。这小孩刚出生的第三天就能诵《金刚橛》的心咒，超度犏牛犊的亡灵，身上有五方佛的法器像，鼻尖上有自生的“阿”字相，既有智慧又有慈悲心等等，不管从哪方面来看，无疑是大遍知者的再显化身！”就对阿格旺波作了如此赞颂。正因为如此，与大遍知者无垢光的三密无二无别的再显化身、遍知上师阿旺巴桑，是公认的比马拉美名持有者。
    他小时候与妹妹卡尔里一同去放羊，一天中午和妹妹玩耍时，在附近找来很多金身佛像供在石台上，晚上回家时，佛像就放在那儿，第二天又去放羊时，佛像却不见了，只剩下供台。如此之事常有，这是他妹妹说的。又有一天，他与妹妹照常去放羊，有一只母羊在悬崖上下来不了，尊者就用投石绳向母羊投了石头，结果却将母羊的腿打断了，这样一来母羊就更下不来了。于是尊者爬上悬崖，将母羊从三层楼那么高的岩石上推了下去，母羊发出痛苦的哀鸣声，像要断气了。当兄妹俩赶着羊群回家，妹妹正害怕会受到大人责骂时，却发现那只母羊已经在羊群中安然无恙，她赶紧跑到哥哥处说此奇事，他只是笑了笑没答话。又有一次，兄妹俩到辽西园林附近的山上放羊时，妹妹卡尔里不知怎的看见辽西圆林似乎有规模很大的寺院，赶快跑去告诉哥哥阿嘎(阿格旺波的昵称)，阿嘎说：“这是将来此地会有大寺院的预兆！”后来也确实如此。
    他依止了有缘上师喇嘛龙多仁波切六年，求得了隆钦心髓前行、正行等全部法门，并得到实义、心意传承的加持，证得了上师与弟子间心心相印、无二无别的成就。遵上师的旨意，在竹庆寺佛学院学习了三年显密经论及文化知识，开发了智慧，成为博学广闻的大智者，荣誉名号遍布十方。
    土猴年，也就是三十岁的时候，按照龙多喇嘛、阿旺丹孜和米旁仁波切三位大德的授记，吉祥天母的劝请以及大斯度仁波切的再三邀请，前往噶陀续部讲修须弥山佛学院，前后共担任了十三年的客座堪布，利益众生广如虚空，讲、辩、著三智任运无碍。培养了三十多位能作利他事业的智者。
    有一天，袁嘎侍者做好了午斋，等(阿格旺波尊者)了很久都没来，他认为是别人请去用斋了。午后尊者回来，袁嘎侍者把斋饭送到他面前时，尊者说：“我没有饿，只是有点渴，今天辽西大伏藏师阿旺丹孜的母亲去世了，他要求给天鹫布施，我不好拒绝，就变成鹫飞去，吃多了点人肉，现在口里有一种味道，需要喝茶！”这是老喇嘛巴嘉亲口说的。
    有一个叫查楚的老头子疯了，脱光了身上的所有衣裳，朋友给他穿上衣服后带到尊者堪布面前，老人一见到堪布就恢复了正常记忆，马上就说：“我要遮羞！”惹得大家都笑了起来。这是老堪布江泽俄热说的。
    在河坡地方的犏母牛、黄母牛等奶牛无奶可挤时，尊者堪布对着奶牛说道：“你们要不给奶的话，就可能有被杀掉的危险！还不如给奶来挤为好。”这样一说，当即就有奶挤了！大家在惊奇之中都生起了殷重的信心。
    在续部讲修院里有一位叫那呢夏的学生，他患了耳炎，痛得非常厉害。于是就跑到堪布(阿格旺波)前求加持，堪布显出很生气的样子说：“黑嘴巴，你是谁？！”说着，就打了他一记耳光，吓得他只往外跑，到了家中，耳炎却彻底痊愈了。另外有一个叫扎西的人患了肝炎，眼看就要死掉了，堪布赐给他一块吃剩下的糌巴，他吃下后，当天肝病就全好了。
    噶陀寺修行院中有一位从甲绒来的喇嘛，他本是闭关院的首座。有一天，过了中午还没有听到下座的号声，大家跑去看时，这位喇嘛还端坐在禅垫上，有的人认为他走了，就赶紧跑去请示尊者(阿格旺波)，尊者说：“他不是死了，而是堕入了顽空定，你们快去，在他耳边发出‘嘿’的声音来叫醒他！”照此做了后，他就醒过来了，并马上用手去拿他还有剩茶的茶杯，大家都笑了。
    有一次尊者去河坡村里，他望着鄂树村左边的一座高山幽默地说：“从前那里有一座笨波教的寺庙，我前世的前世在那里当寺主。”后来在场的人们跑去山上查看，确实是有寺庙的遗址，大家都因此而生起了信心。
    大斯度仁波切曲吉嘉措作了一个梦，梦见在一片茫茫大海的中央有一朵莲花，莲花台上有宝剑、经函，它的四周也围绕着同样的图景。这些图景复又增长、变化出无数的莲花台、宝剑、经函。其中位于东方的莲台图景即辽西圆林，大斯度授记说在那里一定要建一座寺院。辽西圆林是喇嘛龙多仁波切的修行道场，那有天然的铜色吉祥山，是四大成就者的圣地，那里还有大伏藏持明者龙萨宁波亲手塑造的莲师圣像“见解脱”等圣依。尊者说：“水狗年，大殿外内能依所依圆满建造是大斯度仁波切的加持。”他下半生就常住在这个寺院，为十方来求法的诸弟子传承灌顶，施予正法甘露，特别是讲授《密乘大圆满隆钦心髓前行》和遍知大持明者无畏洲传下来的口耳传承的诀窍，不掺杂心识，直指心性。因此，获得大彻大悟、圆满四相的弟子不可胜数！现在，徒子徒孙们已遍布了整个瞻部洲。
    在寺院铜色吉祥山的一块大岩石上，尊者用手里拿着的新鲜的酥油写了六字法界解脱，后来成了自然显现的字体。还用手指画了大象、没有按顺序的莲花生心咒等，这些字迹至今仍可目睹。
    在寺院的后面很多大石头中，有一块房间那么大的巨石。有一天，尊者指着这块巨石，向比勒·索囊等弟子说：“这石头会破坏寺院的风水，需要打碎它！”于是，弟子们用石头、斧头猛砸，在巨石上面生火等办法碎开了巨石，当时掉下来了一块牦牛般大的石头，发现里面有三只受孤独地狱苦的青蛙！这些青蛙的身体被压得像纸张那么薄，掉到地上后，青蛙的身体才渐渐胀大恢复原状。弟子们将这些青蛙装在口袋中，送到尊者的面前时，其中一只却不见了。尊者说：“这剩下的两只是辽西部落刚刚开始形成的时候，有一对做官的夫妇由于不择手段去榨取贫民钱财，做了不少打骂等坏事，因此，就堕落在孤独地狱，受苦果的报应！那时候他们与我有点缘份，现在我也该超度他们了，另外一只与我无缘，这次未能度化，但受苦的时间也不会很长，就能得到解脱了。”说完，尊者就作了金刚萨埵超度仪轨及颇瓦法，当时两只青蛙的眼睛望着堪布的脸就死去了。
    另外还度化了他佛未曾度化的、野蛮残暴的山神等诸多非人众生，此等众生被降伏后都成了创造顺缘的护法，还发下誓愿要为尊者、尊者的弟子眷众及转世等的事业造顺缘。尊者将他们安置在辽西圆林现名叫罗布玉吉、袁敦日扎、雍忠达则和定增杰母等。他们拜见尊者时，有的供养了铁墩，有的供养了刺藤树的种子。这刺藤树的种子种下后，现在已长成了一棵大树。
    尊者按照大斯度仁波切的规定，每年开一次八大行法忿怒本尊的大修甘露丸法会。有一年法会，坛城中药粉变成了三面六臂的大吉祥身，被送到尊者的面前过目，有弟子问道：“像毒蝎一样的，这是什么？”尊者说：“与药粉合在一起做甘露丸吧”。第二年，药粉变成了金刚跏趺坐的金刚持像。弟子们说：“去年的大吉祥身像合在药粉中了，今年的这个就不用问上师了，可以放在药粉里”。于是就和在药粉里面了。后来把这件事告诉了大堪布仁波切时，他说：“哦，黑嘴巴！你们应该把那尊佛保留下来，错了！错了！”
    又有一次，坛城的彩粉上铺满了自然出现的黑尖诃子，这些诃子与药合在一起后作了尝解脱，得名为“黑圣药物”。金龙年五月，八大行法忿怒大修药法会时，坛城中勇士天灵盖上面着了大火，火舌一直升到大殿的天窗上。大家害怕大殿失火，都用水来扑火，可水却一点都起不了作用。待火自然熄灭后，法台上任金刚大阿阇黎的尊者问：“你们在喧哗什么？”听到汇报后，尊者说：“无缘的智慧之火，能用世间的水灭得掉吗？！这药丸叫‘燃火甘露丸’。”那时候，堪布明色仁波切也在法会中，此情景是明色仁波切很详细地讲述给他的亲弟子迦造喇嘛听的。
    在噶陀寺为德恰江杨罗萨多吉仁波切等弟子传了《隆钦心髓母子》的灌顶，至明智力灌顶，拉开袈裟时，大众都见到了尊者胸间蓝色的“吽”字闪闪发光，大小有手指那么大；鼻尖上看到白色的“阿”字，后来仁波切(江杨罗萨多吉)对我(阿格堪布)说：“确实是比马拉的亲临真身！”仁波切有一次去拜见尊者时问道：“江杨，你去朝拜拉萨的觉沃佛吗？”“我要问过秋珠上师才决定！”“哦，就须要这样！不管任何事，都应该请示上师而决定！现在所谓现代的闻思者只看到一点新派的经论就变成了执著新派的人。索囊秋卓在扎色须寺学了多年的新派论典，然而他还是守持旧派论的人。喇嘛米旁仁波切的无误立宗者，目前只有秋卓仁波切了！你与其住在噶陀寺，还不如去依止秋卓仁波切。”
    阿格旺波的鼻尖上有个“阿”字，有缘弟子都能看见，特别是尊者显出忿怒相的时候就显得更清楚，他身上有五方佛的法器像，而且还是彩色的，还有秘密金刚杵马阴藏像等诸多相好圆满之特征。应甘孜康萨官府的盛情邀请前往温泉沐浴时，到那里去拜见的有亲弟子阿格和阿桑。尊者对他们说：“我是大遍知者的化身，有这些表记。”随即就给他们看了右大腿内侧拇指般大小的黑、白二痣。“这就是《空行精要》中所指的右大腿内侧记有空行眼般痣。”另外他们还看到了大圆满续部中所说的身、语、意的诸多征相。
    夏扎仁波切白玛赤勒嘉措和弟子们一起去拉萨朝拜，伸们到了夏岗山顶上，那里是异常险要的冰雪崖。驮运东西的骡因路滑滚到山沟下面去了，夏扎仁波切束手无策地喊道：“遍知者阿格旺波上师，您知！您知！”随着高声呼叫，阿格旺波微笑的像显现在前上空，夏扎仁波切因而生起了猛烈的信心，哭了又哭。然后看见骡和物品均安然无恙。他深知这是上师的加持。从拉萨回到噶陀去拜见堪布仁波切时，只听见上师对他说：“黑嘴巴，夏岗山顶上一头老骡翻滚时，有一个穷小和尚悲伤地哭了，你听说了吗?？！”夏扎仁波切头碰着上师的膝盖哭着说：“是您慈悲的加持救了！”
    辽绒喇嘛阿达是续部讲学院供护法的喇嘛。有一次，晚上去小便时，于黑茫茫中迷了路，当快从窗子掉下去的时候，后面有一个人拉了他一把，才没有摔下去。第二天去堪布面前时，尊者说：“哦，如果不是我的话，你昨晚就死掉了！”喇嘛阿达这才知道是堪布救了他！
    每年尊者都去一次噶陀寺主持法会，传授《心髓母子》和《寂静忿怒金刚橛三法》的灌顶、传承，如此等等功德说之不尽。
    “水亥年九月，喇嘛约敦和我为辽西圆林寺院供奉了观音菩萨像，而卡萨巴呢佛像是用哈达包起来的。我做了这样一个梦，不知是什么意思？”
    那天，约敦抱着年满四岁的多吉秋雄来求加持，尊者将他认定为喇嘛龙多的转世灵童，并让他坐在自己坐过、还尚有余温的宝座上作了坐床仪式。尊者和堪布多里等向他顶礼并禅位于他。
    木鼠年，在扎拉寺传法、灌顶《大宝伏藏》时，大殿内开了一朵白色百瓣的奇花，一直开到灌顶法会结束也没有凋谢，还显有诸多瑞相。
    那时候，尊者把自己玉碗中剩下的饭交给敦登扎巴，叫他分给夏扎仁波切等僧众，敦登扎巴遵嘱分了，但只够分一部分人，有一位叫罗遮桑波的扎巴说：“啊，德格的喇嘛胆子也太大了，竟敢给我们的夏扎仁波切分剩饭吃！”
    过后不久，那里就流行了瘟疫，然而凡吃过剩饭的人都没有染上病，其余的人都病得很厉害，尤其是有邪见的那个人差一点就死掉了，大家都因此而生起了信心。
    有一个叫拉洛的扎巴得了神经病，尊者虽给他吃了药，还念了经，但都起不了作用。有一次又被带去见尊者时，刚好尊者的案前摆有一盘羊肉，盘子里有一把刀，尊者用手抓起刀一下就刺进拉洛扎巴的脊背中，鲜红的血从伤口喷涌而出。这时尊者说：“不要把我的房间弄脏了，快给我出去！”过了一会儿，又像消了气似的说：“可怜的拉洛！叫他进来吧。”众弟子很害怕地左右扶着来到尊者面前，尊者用手抚摸着伤口，并吐了些唾液抹在伤口处，血即刻就止住，病也从此痊愈了。后来拉洛扎巴还给尊者的再显化身(松吉泽仁仁波切)看了背后的伤痕。
    戈泽霍玛部落有一位叫郭登的扎巴，他家里很穷，只有八头奶牛，十五只绵羊。他的兄弟们决定说：“今天我们应该把佳拉玛母绵羊宰杀了，将最好的奶牛和羊肉来供养堪布尊者。”于是就去请飨。堪布说：“你们不把佳拉玛母绵羊头的肉和骨头分开来煮的话，我就来。”他们暗想：难道堪布已经知道我们杀了绵羊？尊者到了他们家，吃完了绵羊的羊头、肉汤，吃了十分之一的羊肉，喝了六碗酸奶，还吃了五碗人参果酥油汤。扎巴把八头奶牛中的最好一头供养给了尊者。尊者说：“我俩相比起来，我是富裕得多，但为了给你培养福报，你们供养的奶牛我就收下吧，以后你们家也会变成很富裕的家庭！”
    后来再显化身仁波切去扎拉寺时，又被请到他们家去，那时候他们已经有了两百多头牛、两百多只羊和很多的家产，确实已是非常富裕的家庭。他们说这全是堪布的恩德，并给再显化身供养了很多的财物。
    大堪布上师到牧区去化缘时，喇嘛贡布丹孜去帮忙，后来他想：这位上师很威严，不管从哪一方面看，都像是雪域西藏的依怙主、噶举巴的译师玛尔巴一样！我要是他的亲弟子米拉日巴就好了。刚想到这里时，大堪布由马背上转过身来很严肃地说：“我可以像玛尔巴，但是你能像米拉日巴那样修苦行吗？！”
    一次，尊者在传了《大宝伏藏》后传《自传》，念到“转世诞生在贡波……”那段时，夏扎仁波切发愿去认定，因此尊者显出很满意的样子，灌顶结束发愿的时候对夏扎仁波切就说：“你要为我的转世灌顶、传承两遍《大宝伏藏》。”夏扎仁波切领受了上师的这个安排；木牛年参加了噶陀的千僧法会，并于法会中担任首席金刚阿阇黎。为斯度仁波切的圆寂做了圆满的荼毗大典。为僧众们传法灌顶《四心髓》、《二函》、《前行引导文·普贤上师言教》及《笔记》、《智慧上师》、《入中观论·注释》和《无畏洲全集》等。
    应重病中的白玉智旺仁波切之请，到白玉寺作了法会。然而，因众生的福报不够之故，智旺仁波切还是圆寂了。
    在辽西圆林为夏扎仁波切、觉罗仁波切、江泽俄热堪布等详细地讲授了前行、正行、心髓气脉等。木狗年为扎玛堪布、巴登移喜喇嘛、嘎桑堪布、羌·赤诚桑波等灌顶了《大宝伏藏》、《七宝藏·秘密部》、《智慧上师》、《金刚瑜伽母》、《如意宝瓶》，康楚编的《三根本意集》和《大圆满经部总汇》等等。
    伏藏大师的儿子秋美前往拜见尊者时，因夏天雨季长，秋河水位高涨，导致行人无法渡河，但是秋美毫不犹豫地涉水过河，河水淹到脖子时，他很害怕地高喊：“遍知阿格旺波上师，您知！您知！”一刹那间，前方空中顿时非常清楚地显现出尊者的相，他如同由睡梦中醒来般发现已抵达到河的对岸。刚好在同一天，大堪布喇嘛也说：“今天伏藏大师的儿子秋美要来了，应准备迎接。”在将秋美迎至跟前时，对他说：“嘿嘿，今天你为过一条小河就叫唤我，不害羞吗？！”随后给他传授了《口耳传承窍诀部》、《前行》、《正行》等法要，尊者还将自己小时候倒流洪水时用过的木金刚橛赐给了他。
    火鼠年土匪来到康藏区，为此修诵了《莲师忿怒智慧火焰》、《八大行法忿怒本尊·降伏仪轨》等。
    为伏藏大师阿旺丹孜的儿子巴帝和阿贝、阿称、阿嘎等传了诸多密法。掘取了《金刚橛修诵仪轨》，并赐给他们灌顶传承。
    第十绕迥的土兔年修了《金刚橛》的闭关。第二年去噶陀寺传法灌顶了《大圆满经部》、《幻化部》、《心部》、《寂静忿怒金刚橛三法要》、《四心髓》和《二函》等等。
    金龙年，按照大斯度仁波切的授记，在辽西圆林创建了遍知显密讲修法苑·密续部佛学院。挖地基的时候，出土了非常奇妙的宝石。宝石上有天然的文殊菩萨六字心咒“嗡阿[日/阿]巴杂那帝”及种子字“帝”和“舍”，还有法螺的图像等等，现在还可以看到。
    那时候，给堪布明色仁波切等诸弟子传了《前行》、《正行》、《智慧上师》的口耳传承窍诀和自己的著作，及《四心髓》、《二函》、《寂静忿怒生起次第、圆满次第》、《经部灌顶》和《气脉》、《噶当巴的大法》、《铁木板》、《铁蟹》等等法要。
    佛学院的大殿土墙不正，眼看着就要倒下来了，大家眼睁睁地看着没有办法。堪布明色仁波切去禀告尊者说：“密续部的大殿土墙快倒了，怎么办？”尊者说：“哦，这件事要是有一位印度的班智达，那就是一件很容易的事，要不然，就没有办法了。”第二天早晨，大家都以为墙倒了，当明色仁波切跑去看的时候，发现土墙像直尺一般比以前还直得多。后来，堪布明色仁波切常对众弟子说：“我的上师就是大班禅比马拉！”
    有一次，尊者说：“堪布明色将要成为弘法利生的成就者，应该举行座床仪典！”于是他亲自带领诸弟子做了一个泥土的法台宝座，让明色仁波切坐上法台，进行了座床仪式。这是对明色仁波切弘扬佛法，特别是把隆钦心髓传遍全世界的授记。明色仁波切后来还摄受了龙多仁波切的转世协珠丹增仁波切，这些都是对辽西圆林弘法利生等功德的预知缘起。
    为玉惹少爷索甲和科惹仁波切灌顶、传承了《前行》、《正行》、《四心髓》、《七宝藏》、《续部金刚橛》、《口耳传承窍诀》、《寂静忿怒》、《汇集经》、《断行》、《莲师忿怒智慧火焰》等法要。
    寺院山脚下一条沟的中游有一座小山，山上有昌彻本王国的遗址，还有石砌的楼堡。几位弟子问：“这楼堡可以拆下来吗？”“不能拆！鬼神都住进去了，如果要拆的话，你们拆和我拆就不一样了，从前我是格萨尔王的大将军噶德曲雄白那的时候，曾经用过石炮，造石炮的技术现在我还没有忘记！因此用石炮的话这楼堡一瞬间就能被摧毁，但我认为没有必要这么做！”
    有一天，尊者走在辽西圆林寺院的后面，显出极忿怒的相，右手托着一块小房间那么大的巨石，往空中一扔，边上有一棵松树，擦的一下就断了，巨石发出呼啸的声音，飞出大概有三由旬(三十九公里)之远。现在就在阳山那里，犹如一个盘子里装了一颗酥油丸一般。
    有一次去茫康地区，有一段险要狭窄的路程，尊者对比索等弟子眷众说：“我从前在参加霍国与林国的作战期间，当时用的是石炮与弓箭，那时我拇指上戴有象牙的戒指，因感觉不方便，就埋在这地下了。”随即叫弟子们挖，从泥土中果然挖出了像桶那么大的、发着光的象牙戒指来。弟子们准备带回去时，尊者说：“还没到时候，不能带回去，应该埋回原处。”弟子们都感到很可惜。
    住在茫康期间，有一位著了嫉妒魔的人在供养的食物里下了毒药，尊者虽然知道，但是为了满足他的愿望，还是全部吃完了。因此显出病痛的相来，眷众们都非常担心和害怕。尊者因此去了吉祥山光明刹土中见了母亲，母亲问：“你为什么来此地？”尊者回答说：“是吃了毒药导致病痛而来”，“说什么？毒药的病痛在哪里存在？弘法利生的事业还没有圆满，你不应该来这里！应该为了利生弘法而回去！”随这境相的显现，尊者的病便痊愈了。
    有一次，尊者由噶陀寺返回自己的道场时，到达饶恰山上，一棵松树横倒了下来，挡住了去路，大家无法通行。尊者显出忿怒相，用手把那棵大松树扔到沟里去了，到了吃中饭的地方，大家都为此事窃窃私语，后来去问尊者，尊者说：“有可能这是我与林国的将军一同行走时，看见一棵大松树拦住了道路，就扔掉了它。”可见尊者就是嘎德的化身，也密修格萨尔金刚堡。在辽西圆林塑了一尊不动明王泥像。有一次，修诵金刚橛镇压魔魅，尊者显出忿怒之相，用经架子劈打供祀的喇嘛夏桑，喇嘛们看也不敢看尊者的威严。待稍微平静下来偷看时，大堪布喇嘛显现出了遍满虚空的、金刚橛九面十八臂相！熊熊的智慧火焰也正在收回体内。当时，塑佛像的工匠中有我的亲伯伯让觉，这是他亲口给我讲的。如此实现三境相，因而显出本尊相时有多次共同境相。又如在辽绒阿色牧区与扎嘎仁波切见面时，扎嘎仁波切想：这位堪布名气很大，今天我要看看他到底有些什么本事？刚见面时，看到的却是北方金刚多闻天，具无比之威严，一刹那间扎嘎仁波切就断除了分别念而昏倒在地！待他清醒过来时马上生起了极大的信心，遂向尊者礼拜求法，成了尊者的亲传弟子。
    应蒋杨钦哲·曲吉罗珠，噶陀格则·久美丹巴朗杰、根桑林扎仁波切等的请求，传法灌顶了《四心髓》、《智慧上师》等；还传了大堪布亲自著的《口耳传承·密意海云》等。
    堪布邬金仁孜的母亲去世后，请问上师其母的投生转世所在地时，尊者说：“生为汉地一片竹林中的一只鸟。”有一次又说：“你‘母亲’所转生成的鸟已被毒蛇吞吃了！现在将要投生为康区一位持戒清净的比丘，渐渐就能获得解脱！”
    有一次，在噶陀寺正为僧众们讲经说法时，尊者说：“哎呀！央培扎巴因为偷了斯度仁波切的很多供养财物，现在已投生到大海中，成了一条大鱼，就像阳寺左边的光明山那么大！很可怜啊！”
    有一次，快到白玉寺附近的达郭神山光明法苑时，休息了一会儿，说道：“我要做一个朵玛，快去拿一块泥土来！”桑丹和阿久找到了一个已经揉好了的泥块。尊者用手将它扳成两半，泥土中有一尊大小约十寸高的莲花生，遂命名为‘见解脱’并说：“啊，善哉！我这一生是持戒清净的比丘，下一世要作有妻有儿的瑜伽士！到那一世时，这一尊佛像能消除违缘！”就交给管家比索囊嘱咐说：“要保管好！”后来阿多仁波切在转世灵童还未诞生之前，就将这尊佛像送到了转世灵童母亲的手上。
    有一次在茫康地区，一家人请尊者去作“叫魂仪轨”。当魂羊放在尊者的面前时，尊者用手指指向它，它就随着尊者手指的指向自动旋转起来了。尊者给弟子们传法时，一入禅定加持就能令弟子当下亲见明智。在灌顶口耳传承的时候，弟子们也有多次降临智慧尊的征相。包括有身体颤栗、作出舞姿、口说多种语言、心中生起信心、出离心及乐明无念的征相等等。蒋央罗珠多吉和堪布江泽俄热等给我讲过多次。
    那年，将自己常用的莲花帽赐给了龙多丹比尼玛的再显化身阿多仁波切，并让他坐在自己的床上，称他为法太子，同时还将拉丈内外的一切财产、事务都交到了他的手中。
    铁龙年十二月，应德格王之请抵达愣珠登地，作了《空行母依怙主供施灵器》的仪轨，敕令土地神守护。尊者说：“这次要做最隆重的设供和依轨，因为现在是末法时代，这印经院是不分教派的弘法利生的核心，我老衲即使病也要起病的作用，死也要起死的作用。”因而修诵了很多天仪轨。当时朵玛自然燃起了火焰，毒火和烟子直接飘到了山外，并发出一种众所能闻的怪异叫声。
    铁蛇年三月，抵达噶陀寺为斯度、莫扎、文波、阿贝、蒋杨江赞堪布、阿谢堪布等三百多位弟子传法灌顶了《都龙》，那时侯已开始显出病相：流鼻血。后由河坡村的居士们用轿子送尊者回到了辽西圆林。四月份，僧众念诵了十万遍《金刚摧破陀罗尼》、《秽迹金刚》、《遣回阎罗王》、《遣回空行母》、《空行母依怙主供施灵器》、《驱走鬼王》和《甘珠尔》等。诸弟子和居士们以及全部落都实行封山放生等等。
    噶陀寺的堪布、珠古们也举行了《莲师忿怒驱魔王》、《遣回空行母》、十万遍的《会供》、《金刚摧破陀罗尼》、《秽迹金刚》、《百字明》等等不可思议的消灾延寿的佛事活动。在扎拉、茫康、白玉、辽绒等地的各个寺院也举行了类似的法会。
    大概在那时候就开始进入了“法性尽地”，如《根本续》云：“法性遍尽相，证悟相皆空，身尽根境尽，分别心亦尽，已证无言说。”如此三门法性尽地相，真实现量的证悟就如《续部》所说的那样。
    有一次，哈里弟弟从门缝里窥看，只见尊者时而不在法座上，时而又只是一片光明彩虹，晚上灯光下见不到身影等等。如此情景诸弟子们也都目睹了。
    拉丈室尊者的房间黑夜中一片光明，附近众多的人都能看得到。身边的人员请求用斋时，回答也是“请用斋”；问：“今天好一点吗？”回答也是“今天好一点吗”只是重复所问，再也不说其它，就如空谷中的回音一样。
    大堪布喇嘛三十八岁时，在噶陀寺于《修持五格丹百尊上师相应法》显现的境相中听到宗喀巴说：“克珠杰尊者借给你二十年做为善知识，到时还给我就可以了。”这句话是否就是住世期的授记？大家知道这时间刚好即是，所以弟子们知道上师要圆寂了，心中无不悲痛万分！
    六十三岁时，即藏历铁蛇年的五月十七日，将色身摄回法界本来面目中，融入童身宝瓶境相内。七天之内封闭消息，法体的毛孔中发出蜂蜜一样的色香味，溢出一种夏天不坏、冬天不干的甘露两壶之多，后来就和在甘露丸中，谁尝到了谁就能得到解脱。
    法体供放了二十一天，供四众弟子们瞻礼供养。阿惹仁波切等诸堪布、仁波切们举行了供养法体的仪轨。阿多仁波切负责荼毗大典及寺内外的一切事务。夏扎仁波切到法体前时昏死了过去，醒来后诸多弟子都看到了他们师徒之间作了对话！
    在大殿前的石板上以《四业一殊》的护摩仪轨火化了遗体，当时，尊者有一匹叫百瓣宝的马跑到火化炉旁绕了三圈，俯首低头在炉前不肯离去，大家见了心中更觉悲痛。火化后，一切与大圆满续部相符合，如《金刚萨埵心要镜》中说：“涅槃有二：清净圆满佛和成等正觉。
    后者的征相有：出现光生身、大地震动等。”《舍利炽燃续》云：“善者涅槃时，遗留之蕴身，荼毗火化时，出生佛舍利，不同佛部故，具五种舍利。”尊者法体火化后，出现了很多不坏金刚五色舍利，有豌豆那么大，也有芥子那么大，也有诸弟子建造了很多供奉此舍利的舍利塔。辽绒喇嘛嘎桑向阿多仁波切要尊者的灵骨，要来的灵骨中夹有两颗大舍利，这是他亲口对我说的。
    善知识大堪布喇嘛住世时，(素未谋面的)热振仁波切亲眼见到了他的智慧相，并得到了前行的笔记、正行口耳传承的传授。圆寂后，明色仁波切在监狱中也亲眼见到了尊者的智慧相，并赐授记说弘扬口耳传承的时机来临。堪布阿格闭关依《遍知者上师明点印》修持时，亲见了与大遍知者无二无别的尊者智慧相，给他传授了五页前行、正行的法要，并于当场证得了遍满虚空般的智慧。如此等等，诸亲弟子同样都有不同程度的类似境相。
    圆寂后的一切事务皆由阿多仁波切来管理，如佛学院的供养等等，在辽西圆林继续着弘法利生的事业。
    尊者的语生弟子有四方四大心子：珠旺巴钦德巴、夏扎·白玛赤勒嘉措、益新阿惹、龙多·多吉秋雄。
    八大栋梁弟子有：格则仁波切、堪布觉德、堪布江泽俄热、堪布明色、绒塔·蒋央罗萨多吉、恰扎·桑吉多吉、果洛·久美多吉、德色吉美。
    十三大珠绳弟子有：蒋杨钦哲·曲吉罗珠、堪布新噶、堪布波利、多仁钦仁钦林巴、敏觉珠古、洞果珠古、巴登益西喇嘛、羌·吉美多吉、班吉堪布、邬金仁孜堪布、阿其堪布、果吉·德多益喜炯内、根德饶杰堪布。(以上的弟子是阿多仁波切的笔记中记下来的)。另外还有梨丹堪布仁波切、邬金丹培、索囊、嘎桑曲尼、邬金志美、佩登俄美热、安称、江杨嘉措、憨江堪布。
    还有珠古根桑年扎、色德珠古、江达珠古、甲色珠古、阿白珠古、噶玛央瑟珠古、莫查珠古、斯度珠古、文珠古、达陀任嘎珠古、瑟珠古、措朴珠古、扎玛珠古、阿贝珠古、阿德珠古、阿称珠古、阿嘎珠古、扎珠古、巴钦多吉珠古、丹增罗布珠古、夏迦珠古、图桑珠古、文波珠古、科惹珠古、董陀珠古、图汝珠古、贡觉扎巴珠古、勒西·愣珠珠古、邬金千阙珠古、洛珠珠古、甲波珠古、那塔珠古、邬金多吉珠古。
    喇嘛弟子有措卡阿贝、卓玛泽仁、阿帝、贝炯、桑吉贡波、图汝索甲少爷、桑德、澄嘎，阿桑、扎雅·罗珠让佩等等。 ’
    女弟子有土多林巴的女儿索登卓玛、吉增曲英王姆等等。官贵弟子有夏格多登、那嘎本、希嘎波达、德格等地的法王，另外还有萨迦、噶举等其它教派的弟子等数不胜数。
    大堪布喇嘛的授记有：“八大栋梁四支柱，内外弟子如繁星，诸强十三上弦月；外内诸多因缘故，支柱数为历代师，栋梁数为持法者，椽子顶盖般徒众，大风金刚转机器，堡楼佛法之衡量，哈哈！”
    尊者为后世有缘弟子留下的著作有十三金刚持地数，分为四类：《入中观论注释》和《中观四百颂注释》等等显宗的论著，《金刚橛口耳传承》和《忿怒本尊》等修诵仪轨，《生起次第》、《圆满次第》及《方便道》等共同金刚乘；《普贤心要》等不共无上秘密。目前，协珠丹增仁波切在发心、收集、整理并出版。
    奇妙法性广阔虚空中，讲解传记太阳放光芒，
    具信者众心莲齐盛开，供养安住刹土中尊者。
    为此所作功德皆回向，遍知师徒所传法精要，
    遍满净刹诸圣请满愿，无分三密融入为一体。
    遍知喇嘛阿格旺波的零星点滴功德，是按口传汇集记录的。无比恩德仁波切的儿子协珠丹增的圣旨黄金金刚杵落在了我的头上，又由于对光明心髓之法具有清净的正信心、善行善意的迦造喇嘛前后多次请求，故以阿多仁波切的笔记为基础，以诸位年长的高僧大德的口述为补充而成，并以此作为尊者《自传》的拾遗。
    辽绒的游子释迦沙门索囊丹巴，于噶陀金刚宝座续部讲修宝山法苑(佛学院)讲解《释量论》的同时，于百忙中挤时而作。


阿格旺波再显化身松吉泽仁仁波切略传

    大悲加持铁钩
    原始怙主金刚总持示显相好圆满身，
    比马米札遍知法界心要无垢光尊者，
    总集百尊三密功德智慧遍布妙大士，
    文殊格言佛法太阳摄受直至成正果！
    应化示现有情中，无垢功德圆满界，愚童并非贡高心，为积资粮故编写！写一点前言后，再来讲述原始依怙主、比马拉米札及无垢光尊者等的再显化身——蒋巴赖协·曲吉尼玛巴桑波那深广如大海般的功德中，我有信心也仅如一根小草沾来一滴水般写写他的外功德而已。
    遍知上师阿格旺波在《自传幻化戏论》中授记说：“在我年满四十五岁的秋天作了一个梦，梦见蔡千·洛塞嘉措和与我无二无别的勒萨瓦·蒋央钦哲旺须一起行走，我们俩赶着一头白色的骡，驮着一驮经典，到了一个地方。打水拾柴烧茶时，在炉灶的右边有三枝黄花，左边有七枝红花。我问蔡千仁波切：‘这是什么意思？’他说：‘三枝黄花是我还要投生三世为弘扬佛法的比丘，这些红花是您未来七世要显殊胜咒师相的标记。’又问：‘这是什么地方？’‘这里不是贡波布秋庙附近的德吉康萨家族吗？’他回答说。”如此就将(阿格旺波自己转世的)出生地点、种族等都讲得很清楚了。
    昌同都敦泽授记说：“在雪山围绕的国土中，形成卫、藏、康三区。其中‘康’的上游，地名有‘嘎’字，家名中有‘巴’字，家族的名字有‘玛’字；于大鹏年以方便、智慧具有表记的‘安’和‘玛’字组成；东北方和合出生，相好圆满持有拂尘，猴年基字‘亚’加‘乌’，以此分析新名而得此赐名。”
    蒋杨钦哲，曲吉罗珠授记说：“大堪布喇嘛圆寂的那年年底，我于‘迷惑’的境相中看到了如同大堪布喇嘛一样的、聚集了他的三密功德的转世灵童，说要做位于白玛郭(莲师刹土)与波密中间的一家父亲名为白玛、母亲名为泽的夫妇的儿子。”因此就写了一封要如何认定、座床等等的授记信函。
    果洛·达陀任嘎仁波切到白玉寺的时候，也写了授记。他写道：“遍知上师身语意，化身示现事业戏论无障碍，莲师密修圣地贡波地，父名白玛泽仁，母名泽央拉姆，他们的儿子生在猴年，如能准确认定的话，所有的结缘者都将获得法益，他将弘扬佛法利益众生，白玛嘎[日/阿]为本尊。以班杂格拉做消除违缘的法会，不能拖延，莲花没有盛开之前需要保密。”
    这些授记，已将胜圣的仁波切现世应化的地点、父母名称及功德都讲得非常清楚了。
    阿多仁波切(龙多·多吉秋雄)以无碍的慧眼看到：木猴年四月十五日，将是大遍知者喇嘛的转世灵童诞生日。以前大堪布曾授记的那尊在白玉达科那里由伏藏泥土中取出来的莲华生佛像，能消除转世的违缘，因此阿多仁波切就派了桑登和扎安久将佛像准时送到了灵童母亲的手中。又召集了辽西部落与全寺院的人们说：“今天是四月十五日，是转世灵童要诞生的日子……”随后就率众到寺院的后山顶上举行了烟供。那天，人们看到了天空中显出彩虹，还听到了法螺声以及见到了雪花等瑞相，因而都生起了无比的欢喜心。
    转世灵童也刚好那天诞生了。诞生地是莲花生的密行圣地——大法王创建四镇节寺之一的贡波布秋黄金庙附近。父亲是法王的后裔白玛泽旺，母亲是泽央拉姆，一位没有任何垢失的母亲。这夫妻俩于第十六绕迥木猴年四月十五日的上午诞生了一位头直立、脚结金刚跏趺坐的奇特婴儿。伴随着婴儿的诞生，周围自然出现了香气四溢、彩虹缭绕、各种色鹫盘旋上空等诸多奇异的瑞相。生下如此神奇的婴孩，家人无不惊喜，父亲为婴儿献名为松吉泽仁(寿佛)。前世大堪布喇嘛在一次灌顶传授《大宝伏藏》的同时传了自己的《自传)，当念到“转世诞生在贡波……”那一段时，神情非常悲伤地说：“我老衲死后要投生在贡波地区，我要尽身、语、意的全力去投生，但噶陀的大仁波切们不会管我老衲的，小仁波切们又没有能力去管我，那怎么办？”当时夏扎仁波切就请求说：“当您降生在贡波地区的时候，就让我去承担认定、坐床的责任吧！”
    大堪布喇嘛于是就很满意地说：“是个好孩子！是个好孩子！就需要这样做！”随后再传完了《自传》的全部传承。在《大宝伏藏》灌顶结束后分灌顶加持物时，堪布、珠古、喇嘛们都纷纷发各自力所能及的誓愿。夏扎仁波切发了念诵十万遍《七支祈请文》、闭关专修“三根本”、做一亿遍《百字明》转经筒和放生一万等等誓愿后，大堪布喇嘛还是没有将作加持的佛像拿回去，并问：“你发什么愿？！”“现在不知还能发什么愿？”夏扎仁波切回答说。
    “黑嘴巴！你难道不为我的转世传法灌顶吗？”大堪布喇嘛问。因此夏扎仁波切就发了要作法供养的誓愿。
    木鸡年，夏扎仁波切、曲尼堪布、朴泽堪布等僧众前往贡波地区认定转世灵童。为灵童举行了沐浴、穿戴等仪式，并供养了身、语、意的三依。请示热振仁波切后，热振仁波切也非常高兴地供养了身、语、意的三依，并为转世灵童赐名为将巴勒协·曲吉尼玛，还撰写了长寿祈祷文和简要功德记。
    火猪年，依阿多仁波切的旨意，邬金仁孜堪布、索登、巴嘉、多钦、哈里等四十多位僧众骑着马骡前往贡波迎请转世灵童回前世的驻锡地——辽西圆林。热振仁波切说：“在我的道场里要举行一次隆重的座床大典，再派西藏政府的兵马来护送！”然而过了不久，热振仁波切却圆寂了。
    十月初十日，将转世灵童安坐于宝座上，邬金仁孜堪布和全体僧众们以《持明总集》的仪轨做了一次丰盛的会供。当时，转世灵童仁波切显得有一点不高兴的样子，待后来沐浴穿衣后，一切就显得庄严、愉悦多了。然后就把灵童及其母亲、桑杰和仁钦两位舅舅都迎请到了辽西圆林。
    一路上很顺利地到了邦达，地方官多杰和袁佩向灵童供养了衣物、金帽及身、语、意的三依、以种种庄严的座骑骡，并做了极为隆重的迎接和送行仪式。到达西嘎、达苯时人们也供养了座骑骡等供养品。到了巴朗寺，寺院的僧众、当地的居士们都来迎接，也供养了诸多财物。
    到德格时，噶陀寺的斯度仁波切、白玉嘎玛杨瑟、博黎乌玛的管家以及德格王、臣、民等来迎请，到了德格王宫。夏格多登又将灵童请到自己的官邸中，到了夏府，仁波切用从贡波带来的一根木棍打了一下夏格多登的头顶，夏格多登顿时生起了猛烈的信心，流着眼泪祈请说：“愿消除罪障、愿消除违缘！”后来改革时，多登没有受到迫害，故此他常说：“我之所以能保全性命，全是仁波切加持的恩德啊！”
    雅宁等人接送一行人到了曲科刹陀温泉，以阿多仁波切为首的辽西、益勒、安章、多科、昌台等部落都纷纷前往迎接。到了辽西道场，夏扎仁波切、阿惹仁波切、邬金仁孜堪布以及安章寺、噶陀寺、白玉寺等地的大堪布、大仁波切们都来参加了座床典礼。
    五岁的时候，也就是土鼠年(1948)藏历六月，按照宁玛巴的主寺——噶陀金刚宝座上的钦哲·曲吉罗珠仁波切、格则·久美丹巴朗杰仁波切的安排，以斯度仁波切、莫查仁波切、阿贝仁波切、巴德益喜喇嘛、觉德堪布和江泽俄热堪布为首的全寺僧众、居士们，以真诚邀请和最隆重的迎接仪式，于初十法会吉祥日，在三界镇压的大雄宝殿中狮子宝座上，以伏藏大师咕汝秋旺的《上师密集》伏藏仪轨，为灵童举行了沐浴和消除违缘的仪式及座床盛典，并作了丰盛的供养。蒋杨钦哲·曲吉罗珠为灵童赐名为“特确丹比嘉措”，顿珠·杰扎益喜多吉赐名为“阿旺罗珠特确丹比坚赞丹色威宁协”。二位大德还分别供养了长寿住世祈祷文及身、语、意的三依。
    前世的亲弟子阿桑开始为转世灵童教授藏文时，灵童显得舌根有些迟钝而发不出标准的字音，因而祈请了前一世的意依文殊菩萨唐卡佛像，在专修了心咒“阿[日/阿]巴杂纳帝”后，即发出了流畅的读音，读写一切顺利。到八岁的时候，所有的功课、仪轨都背诵下来。“桑吉舅舅和母亲返回贡波去了，仁钦舅舅和我则将家乡抛于脑后，留在了道场，从此就再也没有见到过具深恩德的母亲了！”这是仁波切深情怀念母亲的话。
    在阿多仁波切处领受了《旧译经典总汇》、《隆钦四心髓》、《二函》、《百尊寂静忿怒》等长轨、简轨和略轨的所有灌顶传承。“那时候，在境相之中，见到了很多美丽的空行母，她们的头上戴着五冠帽，身上佩饰各种奇珍异宝而为庄严，手中持有铃鼓，各各显出非常欢喜的神态，以种种优美的舞姿围绕着我，我了知这是金刚瑜伽母加持的征相。”
    九岁的时候，仁波切预知了母亲的去世，因此向噶陀佛学院供养了一块银元并哭着说：“我母亲死了，天也下着雪来哭悼！”僧众们都想是否有什么问题，果然半个月后，有人从家乡捎信来说仁波切的母亲去世了。因此拉丈和僧众眷属们都深信仁波切能清楚地看到未来。
    时局动荡时，为了消除寺院违缘而修诵《金刚橛镇压》仪轨，阿多仁波切亲自带领全寺僧众念诵了很多天仪轨。到寺院的山脚下做镇压法事时，阿多仁波切说：“今天要请转世仁波切来看。”转世仁波切搬动了那里的一块小石板，只见石板下有一个无底洞，洞中散发出深蓝色的气体，被镇压的牛脚扔到洞里去时，牛脚往下翻滚的声音持续了很长时间，大家都听到了。复用石扳盖住了洞口，并在上面建了一座三菱形的泥塔。
    仁波切那里有一幅嘛哈嘎拉与当今多吉勒巴、阿嘎杂帝、罗睺及尸陀林主母的唐卡。平时寺院遇到一些不顺利的事及违缘时，只要请出来简要地作一次供护法，唐卡就会发出“呼呼、嚓嚓”霹雳般响声，显出不可思议的征相。
    十岁的时候，阿多仁波切携转世灵童前往扎拉寺，夏扎仁波切等僧众进行了隆重的迎接，一行人安住在玉钦家中。水蛇年一月至五月，转世灵童在夏扎仁波切处领受了《八大行法》的大灌顶。在大修《金刚萨埵仪轨》的同时领受了《大宝伏藏》的灌顶传承，还得到了《前行引导文·普贤上师言教》及前一世的《笔记》、《寂静忿怒生起次第、圆满次第》长轨、简轨和略轨的所有灌顶传承，另外也得到了《心髓二函》的灌顶传承及《忿怒文殊》、《如铁》、《铁蟹》、前一世的《口耳传承·窍诀部》等所有灌顶传承。
    在堪布志美那里领受了《心髓前行·普贤上师言教》等。把在扎拉地区化缘时得到的所有供养全部都捐给了辽西寺。“从这以后，就再也没有见到过具恩上师夏扎仁波切了。”这也是仁波切深切思念具恩上师的话。
    在自己的道场闭关修持了前一世的《口耳传承·金刚橛》。当时朵玛上发出了火星，火星的爆破声传遍了室内外。天灵盖内甘露的色、香、味变得有点像蜂蜜，也有点像酥油糖，而且夏天不腐、冬天不干。因此，经师阿桑将此甘露供在坛城中多年，他说：“真正的甘露就是这个，没有别的！”
    木马年，应伏藏大师的儿子秋美的邀请，前往贡觉地区。在路过雅索寺、江嘎寺时，为满足那些地方人们的愿望而举行了灌顶法会。到达德色寺后，为了整个地区的太平而修诵了数月《金刚橛镇压魔障》，也闭关一月左右修持了前世的《口耳传承·金刚橛》。那时，修诵的朵玛上显现出彩虹和光芒，天灵盖内的供酒也变成了像蜂蜜一样的甘露，浓浓的如丝线一般可以拉得很长，香味扑鼻。伏藏大师的儿子等人都亲尝了甘露并因此取得了成就。
    仁波切还去了嚓绕寺、色德寺、甲色寺、楞郭寺、多拉寺、满秋卡寺、甲[日/阿]寺、科钦寺、果康寺、坚松寺、曲杰寺、巴拉寺和桑珠寺等寺院传了《心髓二函》、《寂静忿怒百尊》长轨、简轨和略轨的所有灌顶传承。
    另外还去了达摩寺，在龙王人头泉水边做了一个酥油捏成的酥油蛙，在酥油蛙的内腔中装藏了咒语《四业保护轮》，准备埋藏在泉谷中。仁波切搬动了一块石板，石板下露出一个深洞。酥油蛙被放进洞中后，变成了一只真实的活青蛙！第二天，几个人再去看时，见到青蛙还活着。这事乃跟随仁波切的眷众及全达摩寺的僧众都亲眼目睹的。这是当时目睹的当地人以及喇嘛巴嘉亲口讲给我听的。这种现象是已圆满成就了“明智如量相”的证相。
    就这样，仁波切不管去任何一个地区、寺院，都是吉祥如意，加上仁波切的殷殷善意，所到之处，即能消除病魔灾荒，平息战乱，五谷丰登，就连树木花草也出现竟相茂盛等等诸多自然而奇妙的功德。
    一年多后仁波切返回了自己的道场，在路过白玉沟上游登[日/阿]的时候，巴嘉喇嘛背着仁波切坐在路边的一块巨石上休息，在石头上就留下了仁波切的一双就像在湿润的泥土上踩下的脚印。因为现在这个地方已经修了公路，所以就见不到了。
    仁波切将这次所得的供养全都交给了阿多仁波切，用作佛学院的经费。邬金仁孜堪布和阿桑等陪仁波切到了绰巴尔神山依《普贤上师言教》配合《笔记》闭关修持《修心百日》。仁波切在观修《共同前行》中的暇满难得、寿命无常的时候，生起了：“唉！可能今晚就会死去！不会活到明天！”的定解，每晚都将饭碗倒扣起来，彻底断除了对财物的贪执，成为无贪、知足的胜圣菩萨。
    在观修轮回的痛苦时，进一步地对轮回生起了厌离心与出离心，经常痛哭得如心儿破碎了一般。只要一想到轮回苦海中的众生，每晚都无法成眠，并且常常流泪不止，虽身边的僧众再三劝请也不能停止。
    观修到因果业力时，证知到外器内情和一切万法悉皆了无自性，犹如梦幻，继而连这种证悟境相也全消失在无戏论的大空性中，诸念息灭，长时间地安住于遍布光明的本性智慧中。后来在阿惹仁波切那里求得大圆满的正行时，也再没有其它任何新的悟境增长。
    观修金刚萨埵的时候，从身体内往外流出了不同形状的动物、炭汁、烟灰等诸多不净物。“这样的境相，不但定观中见到，在日常也如是地发生。金刚萨埵放光融入自身的时候，自身变成了真实的金刚萨埵，光明莹彻、无执无著就如水晶一般。”
    “在修持上师相应法的时候，亲见到与夏扎仁波切无二的比丘相，身著三衣，以很欢喜的相安住在我头顶的光明彩虹中，由内心中猛厉祈请，刹那间顶轮上的上师就与邬金莲花生大士无二无别了，并赐予长寿灌顶，因此，觉受到了遍满全身的空乐大智慧，这种境相持续了数日之久，这是领受到了上师加持的证相。”
    “在一次境相中，护法神多吉昌巴尔及其眷属七兄弟，骑着棕色的马，右手持金刚杵，左手拿吹风鼓，亲临我面前誓愿说：‘需要办什么事，我们立即去办！’依此缘起，我即时写了个供护法的简轨。”
    十五岁时，在邬金仁孜堪布处求了德格版一百零三函的《甘珠尔》的全部传承。“我随后就开始看经，那是堪布的恩德和自己的精进，能圆满地得到这殊胜的传承”，“那时候，不可思议地就到了印度本师释迦牟尼佛前，本师世尊相好圆满，佛光灿烂，我也不象是现在这样，而是离遮毗(维摩诘)，跟随无量声闻、缘觉和菩萨眷众一起闻深广殊妙之法。”以上这些是仁波切亲口讲给我听的秘密话。
    在阿多仁波切那里求了《八大行法》、《意密直穿》，前世的《度母仪轨》等的灌顶及《全集》的所有传承。“气脉明点、拙火定等单传了我一个人。另外还得到了大遍知者的《七宝藏》、《三休息》等全集的传承。”
    “此后，时代坏得像熊熊燃烧的烈火一般，具恩上师阿多仁波切也被打入了牢房，我和舅舅也被送进了监狱。寺院的三依全部被摧毁。土猪年，阿多仁波切显现出奇特的征像圆寂了。第二年，舅舅也死在牢狱中，只剩下了孤苦伶仃、无依无靠的我。”
    “积极分子们的批斗和揍骂就像暴风雨和雷声一样扑面而来。还没有长大成人的我，竟也给罗列了如山般的罪名！既没有吃的东西，衣服也仅有一块权当遮羞的小破布，也没有其它可想的办法，还要受到众人的欺侮，一副可怜兮兮的模样！虽然承受了这般痛苦，但由于常观轮回中的苦与乐即如梦幻泡影，一切万法都是虚幻而无一点真实可言，因此，在我内心中反而生起了诸法无常的决定见。对那些打我、骂我、害我的人们，我都将自己的乐因与乐果全回向给他们，再发愿将他们所有的苦因与苦果，由我一人来承担！就这样来修取舍苦乐，从未有过报复与害他之心，就这一点而言，我完全可以向诸佛菩萨起誓。”
    “在狱中度过了三年后，我返回辽西圆林。但是，寺院和三依已全被摧毁得无影无踪，惟一的依怙主阿多仁波切圆寂了，惟一的依靠桑吉舅舅也去世了，惟一的道场寺院已荡然无存，人们的思想也变得没有一刹那的善心，未曾作过错事的我被视为敌对者来看待。因而想到：身处轮回，都是痛苦的。于是生起了无可改变的出离心。处在轮回中的众生，由于我执，因此就生起了恶念，乃至进入了歪门邪道。我常常对他们发起猛烈的慈悲心，并清净地进行回向和发愿。
    “过了一个月之后，我又被抓回了监狱，押送的一路上还声声叫嚣着‘打、杀’，尽管如此，我仍认为：一切皆为空性，他们爱怎么做就怎么做，随缘吧！这样一来也就一点也感觉不到痛苦。”这是后来仁波切在佛学院举行开学典礼时，为噶陀和辽西一百多位师生开示说的话，最下等的弟子我也在边座上如是亲耳聆听了。
    “十九岁的水虎年四月，我又从监狱里被放了出来，至来年的十二月十八日，政府将我安排在县政协，从此以后，就没有衣食上的困难。直到三十一岁都在白玉县上。那时候，常常历境修心，因此在修心方面的功德增长了不少。‘情器遍布邪恶时，一切违缘转道用’说的正是如此啊！”
    按照前一世的授记，以金刚亥母的化身扎西卓玛为智慧明智母。木龙年十一月十五日日出时，在种种神奇的瑞相中生下了儿子协珠丹增。昌台的阿惹仁波切认定为龙多喇嘛的转世灵童，并授记说：“将来能够领受上一世的传承。”
    携母子俩及眷众去朝拜了拉萨觉沃佛，并作了丰盛的供养。仁波切的父亲白玛泽旺也由监狱中平反出来了，仁波切和亲戚朋友们一同回到了贡波家乡。“住了几个月，感觉很好。”仁波切说。
    携空行母和儿子去拜见阿惹仁波切时，阿惹仁波切哭着说：“具恩上师(阿格旺波)曾对我说：‘现在你在我面前来求法，来世我们父母儿子三人都来拜见你！’这句话指的就是现在这件事啊！”随后便很欢喜地传了大圆满的口耳传承，并交代了前世(阿格旺波)的传承。仁波切将自己的证悟禀告了，阿惹仁波切非常高兴地说：“就是这样，除此以外，什么都没有！但是，这次指示只需要表示一下……”如此等赞美的话说了很多。又对协珠丹增仁波切说：“你的事业将会象前一世一样。”并为他赐名为赤诚洛珠。白玉直旺贝诺仁波切也认定他为龙多仁波切的转世灵童。
    仁波切前往噶陀为堪布江泽俄热等灌顶传授了《隆钦心髓极密长寿》等法。堪布仁波切供养了有切、贡、确三位大德手印的莲花生唐卡佛像、格则班智达的钵、佛像及班智达帽，并说：“现在弘扬佛法要靠您……”等等很多祈请转法轮的话。
    后在自己的道场辽西圆林里建起了方丈室，随后还建造了大殿等，所建的能依所依在短短几个月内就全部竣工了，使大家都感到实在不可思议，如长长的大柱子仅一两个人也能搬得动，大家幽默地说：“我们搬柱子就象驱使牛马一样。”这实际上是仁波切的加持和请来诸护法神帮忙所致，因此建造大殿的能依、所依比起其它人要顺利得多。也仅用了几十万就建好了。
    堪布明色仁波切发心作了《阿格旺波全集》的木刻制版。木鼠年，应洛嘎仁波切和江泽俄热堪布仁波切的请求，在噶陀阳寺禅堂法苑，为江杨大堪布仁波切、洛嘎仁波切、格则仁波切等堪能弘法利生的大德们传授了《大宝伏藏》的全部灌顶，整个过程中没有一点违缘，灌顶圆满。
    结束时，为当地几千位信众灌顶了《噶当巴无量光佛仪轨》，并赐予了开示。还勉励大家道：“重建大殿时，大家要努力！”因此大众个个都欢欣鼓舞，不少人都发愿要好好修复寺院。仁波切又将喇嘛、珠古们供养给他的很多供养全部赠给了噶陀寺，还把用黄金庄严的白银长号也供养给丁噶陀寺。
    土龙年十二月四日，政府同意让仁波切回辽西圆林常住。当抵达辽西圆林时，大家好像都听到了日扎神山上响起了法螺和唢呐声。子夜时分，日扎神山的山顶上现出了银盆般的白光，此光越来越大，当升至寺院的上空时，就如画师所绘出来的巨大太极图……大家去看时，光明照耀之下的山林、树木及房舍已宛如白昼。从此，辽西园林的山水林木都变得生机盎然，呈现出一片欣欣向荣的景象。同年，根本上师阿惹仁波切智慧心融入了法界，仁波切为此而作了隆重的供养仪轨。
    土蛇年三月七日，在自己的道场辽西圆林开始传授《大宝伏藏》的全部灌顶传承。弟子有夏扎珠古、堪布阿秋、珍珠古、色德珠古、喇嘛敏觉、钦饶、巴珠、喇嘛邬金、嘎·康卫珠古等等，里塘、噶陀等地也来了堪布、珠古、喇嘛和扎巴共四百五十多位。同年，去了扎拉寺，为两千多位堪布、珠古、喇嘛、扎巴们灌顶、传承了《大宝伏藏》。一直到全部圆满结束，没有丝毫违缘，这是三根本的加持。那时，堪布明色仁波切也专程由红科赶到扎拉寺领受《三根本》的灌顶，并献上了七尊金佛像和七万多元人民币等供养，明色仁波切回到无修光明苑时，对众多弟子说道：“我具恩上师的再显化身松吉泽仁仁波切与遍知无垢光尊者无二无别……！”边说边双手合十于头顶，赞美了松吉泽仁的诸多不可思议的功德。仁波切将在扎拉寺灌顶传法得到的所有供养全部转供给扎拉寺，以用来维修建造供奉释迦牟尼佛大雄宝殿。
    辽绒炯空寺堪布觉德的转世洛嘎仁波切在自己的寺院灌顶传承《大宝伏藏》时，请松吉泽仁仁波切为一千多位信众传法灌顶《长寿佛》、《三根本》。仁波切将当时得到的所有供养全部转供给该寺院。返回辽西的路上还去了扎格珠德寺，为当地信众作了“诸恶莫作、众善奉行”之意等的开示，并为寺院的三依加持、开光。回到辽西圆林后，把从德格印经院请来的两套《大藏经》供养给了辽西佛学院。
    水鸡年一月，在寺院的上方——莲花苑内闭了为期一年的关，修持热那林巴的《长寿仪轨》，诵满了一千万遍的长寿佛心咒，另外还诵满了口耳传承《金刚橛》心咒一千万遍、六字真言一千万遍、莲师心咒一千万遍，并修了《金刚橛》仪轨一千遍。因此，消除了所有的违缘，特别是修持了本尊《童身金刚橛》后，得到了本尊殷切劝请：要为利他转大法枪。从此开始摄受弟子。
    为了消除寿命方面的违缘，念诵了整套《甘珠尔》一遍、《会供》十万遍、前一世的《莲师忿怒》一万遍。明色仁波切也为此放十万头牛羊。堪布阿秋、卓格阿色、达科·桑珠雄巴、喇嘛巴嘉、阿孜·赤诚喇嘛、卓雅·曲丹喇嘛等等也做了无数的放生功德，仁波切自己也分别供养了九十九匹马和九十九头牛给噶陀寺、白玉寺、[日/阿]临寺、达摩寺、波江寺、雅庆寺、昌格寺、达科寺、多科寺、安章寺、阿色寺、益勒寺等寺院丛林。
    噶陀西雄赤勒岗波仁波切开千圣法会时，迎请仁波切为法会的首席金刚阿阇黎。在法会期间仁波切作了《长寿住世仪轨》，并供养了三十一尊佛像及许多财物，还放了一万条生命，因而消除了寿命方面的违缘。仁波切为噶陀千圣法会供养了一万元，为七千多位僧众举行了传法灌顶，并加持了甘露丸，与之结缘的所有人都能进入解脱道。仁波切说：“这是噶陀寺的功德。”
    辽西寺院的所有建筑工程一共用了几十万元，召集了所有僧众集体做了回向。请来了白玉直旺贝诺仁波切为寺院的三依举行加持、开光典礼，并作了诸多供养。辽西堪布蒋杨多吉(即纽舒堪布)也从国外来到了辽西圆林，仁波切为他传授了前一世的《口耳传承》。为色德珠古、列果珠古等弟子前后传授了《大圆满隆钦心髓前行》、《普贤上师言教》及《笔记》，并严格要求弟子们修好《修心百日》、《五加行》、《上师相应法·莲师心咒》，全部修习圆满后方可传授前一世的《口耳传承·彻却》。
    传授正行时，有时标记传，有时经验讲授，因此，凡得到正行的所有弟子都能亲见大圆满本性。在传授弟子当中，从来没有对一位只是讲了头、或是中间的正文有所省略，或没有结尾等等。近来有些所谓的“大圆满传承者”，只作了个传法的样子，仁波切就和他们根本不一样，要是冷静观察，单从这一方面，就可以完全断定仁波切是当今密乘大圆满光明心髓法要惟一的堪能弘扬者！衷心祈愿他能长久住世、转大法轮！也只有具大福报、大善根的人，才能依止他，并成为他的弟子。我常常都是这样想的。
    仁波切对已经得到正行并修持比较稳定的弟子，便开始传授《智慧上师》的前行——《云游轮回与涅槃》，然后是正行《彻却》与《脱嘎》，最后是《临终中有》等教导的圆满讲授。
    仁波切幽默地说：“你们光是眼泪汪汪地看看太阳，还是没有用！按传承来说，先修前行，过后是正行；修正行又先‘彻却’、后‘脱噶’，这是历代持明传承祖师的教诲。《共同前行》要按《讲义》先修。修‘脱噶’之前，应该具有坚实而稳固的‘彻却见’。因此，先将‘彻却见’修练好，等修到非常稳定时，再来修‘脱噶’，这是要点。”也是仁波切对弟子的要求。
    “……如此说来，‘脱噶’这法门具有诸多特点，然而，没有先修好稳定的‘彻却’，就急急忙忙去修‘脱噶’，这是没有用的。比如一座楼房的地基是‘彻却’，打好地基后，‘脱噶’就好办了，要不然，只徒然的增加一种执著而毫无利益可言。你们首先将‘彻却’修好，不要将暇满难得的人生都置于散漫中空过！我们谁也不知何时会死掉，死后只有佛法才能有利益，我老衲也只有一只山羊般的寿命，因此，请大家都将这一生的一切俗事全部像对人的尸体一般抛弃吧！应该要实修正法……！”每一次传法时，仁波切都有类似语重心长、针砭时弊的开示。
    应前一世的弟子、贡觉果康寺大伏藏师阿旺丹孜的再显化身、邬金千确仁波切的请求，为该寺堪布、珠古、喇嘛等五百多位僧众传法灌顶了《大宝伏藏》。“前后四次传法灌顶《大宝伏藏》，没有一点违缘，这是三宝的加持。总的来说是弘扬了佛法，特别是生在宁玛巴传承下的我，为此法脉尽了些力。那些灌顶所得的供养全都为了弘法利生而转供给了各个寺院，虽然如此，也从未有过为了自己的名利而沾染上世间八风的恶念。”“四次传法灌顶时，都有堪布江杨坚赞，这是噶陀寺的恩德！”还前往了色德寺、楞郭寺、达摩寺、甲色寺、德色寺、[日/阿]廓寺、[日/阿]彻寺、曲杰寺、桑珠寺、巴寺等地传法灌顶，并将得到的数万元供养作了无缘的回向。同时，还去昌多、甲宿、京敦、卡塔等地区作了封山放生等行善积德的事业，使得这些地区安乐吉祥、幸福如意。“得到的四万元供养用于佛学院的建设，没有浪费一分钱。”扎拉寺释迦牟尼佛像建好时前往开光。木狗年，明色仁波切圆寂时，应邀前往主持荼毗法会，满足了堪布旦巴达吉等诸弟子的心愿。考虑到佛法的核心是讲修，并且又有前一世讲修院的基础，故在辽西园林建造了一座佛学院的大殿和学生们的寮房。在大殿内塑造了“主供”——文殊转法轮的塑像，右边供有莲师印度相及遍知无垢光，左边为大堪布菩提萨埵和法王米旁仁波切等，请来工艺家楞嘉等人精心塑造，内外能依所依一切圆满。此外，还建了第二层的两间佛像殿。
    木猪年，应西雄仁波切等大德们的诚意邀请前往噶陀寺参加万僧法会，并于法会中担任首席金刚阿阇黎。法会结束时，为一万多僧众结了传法灌顶的殊胜法缘。
    应喜饶俄热仁波切的真诚邀请，前往大成就者白玛邓灯的道场嘎绒寺，为“三师君”的大铜佛像主持了开光法会。并为当地的四众弟子进行了传法灌顶，结了殊胜法缘。返回的路上去了西瓦寺，为大殿的落成举行开光典礼。
    土虎年十月四日，在辽西圆林遍知显密讲修法苑举行了佛学院重建开学典礼，为从噶陀佛学院来的堪布、珠古和本佛学院的弟子等一百多人灌顶了大遍知者的《修上师明点印》、秋林的伏藏经典《文殊舍利》、前一世的《文殊续部仪轨》等等，讲解了前一世的法规、内外的行为取舍要点及持戒清净的基础。
    “对显密经论首先要多闻，再以思维来修心，最后以修持来对治烦恼。请常常向诸佛之语金刚自相文殊菩萨祈请，要精进努力地修学经论，要不然，就完全失去了进入佛学院的意义……”如此等等佛法与世间法各方面的教诲，只要能够记住其中的一丁点，都具有诸多深刻的教诲意义。仁波切的几位弟子说仁波切在灌顶的时候，曾多次出现了智慧本尊降临的证相等很多奇妙的境相。由这一点来看，他不愧为一位圣者、登地的菩萨，我常常这样想到。
    那时，详细地讲解了《大圆满前行引导文》和前一世的《笔记》，强调了轮回中的出离心和对涅槃功德的向往等各方面的教诲。因此，培养了诸多有出离心的弟子。当时，虽然是寒冬季节，但是树枝上开出了奇花，天空中出现了美不胜收、令人目不暇给的法身五色彩虹等瑞相。
    土兔年，再次应宁玛巴的源头——噶陀金刚座西雄仁波切等大德们的邀请前往噶陀寺参加十万僧众的大法会，并于法会中担任首席金刚阿阇黎。用了十天时间大修宝瓶，当时也给僧众举行了《金刚心要长寿佛》的灌顶传承。总的来说，胜圣的应化身仁波切，是由圣者的愿力和众生的福德所感现，因此，闭关见本尊、得授记等证境，超越世间规律的奇妙秘密功德数不胜数。但是，因为还没有得到开许，所以这次未能写上。然而，现在众所周知的噶陀堪布江泽俄热的转世灵童及贡波曲杰寺伏藏大师的转世灵章等的认定，仁波切都如亲临其境、亲眼目睹般的说出地点、姓名、房屋等，一切认得准确无误。对于弟子们身、语、意三门的行为等均能无碍了知。骑白马时，马蹄下冒出了火星，并在坚硬的石头上留下子深深的马蹄印，现在仍可见到。
    住在白玉县时，有一个叫张波的干部，在打猎时带着仁波切去作饭，猎人向一头大熊开枪，不料大熊却反而冲了过来，猎人逃跑了。仁波切却拿着柏树枝，在大熊的头上轻轻抚摸着，那只熊就好像是见到了母亲似的坐了下来，现出非常亲切的样子。那猎人见到后，从此对仁波切的信心变得非常具足。
    早在仁波切十五岁被关进监狱，就在坚固封闭的牢房中示现了穿墙过壁、进出无碍的自在神通。金龙年闭关时，闭关房的供灯不点自燃。亲弟子迦造喇嘛也亲眼见他由闭关房后面的石岩中走了出来。莫扎仁波切在噶陀万僧法会时也看到了坐在宝座上的就是前一世阿格旺波！当即就生起了猛烈的信心与悲心，他没有丝毫的怀疑那不是阿格旺波，可等过了一会儿再看时，则是现在的仁波切。这些都是他们亲口讲给我听的。
    弟子们所见到身、语、文字等不同的境相，不管从哪一方面来看，仁波切确是一位真正的大成就者，世间八风的戏论消失于法界，示现为无戏论的自在瑜伽行者。尽可能地控制弟子人数的增长，不分宗派地融合各方寺院的喇嘛、珠古，从未浪费众生的一分钱，所得的供养全部用在弘法利生的事业上。常常以四时瑜伽而精进不懈地修持，不但自己如此，也要求弟子如是修持。
    “一切功德的基础是持戒，因此要持戒清净，要想脱离轮回惟有证悟空性，因此要远离我执；佛法与自心能否融为一体，这还是要靠修四出离心；成就佛的果位要靠正行无缘，因此要修不共同的禅定。不管是大小、粗细的善业，一定要用‘三妙法’来行持”等如此窍诀要点的开示，在每一次传法时都会讲到。因此，我想与其他上师的弟子比较起来，仁波切那些在雪山、岩洞等寂静之地实修的弟子，所得到的证悟都能契合大圆满续部的解脱标准，而事实上也是如此。
    喇嘛龙多丹比尼玛的伏藏品观世音金身像，是由伏藏大师列饶林巴从贡觉龙王白人头泉水中挖掘出来的，喇嘛龙多把这尊佛像作为他一辈子的本尊来修。世道大变期间，被托运佛像的一个人从多康寺的岩石上往下扔掉了，后来仁波切回家乡见父亲时，在贡波那里，有一个人由后面跑过来对他说：“请等一等！”并从怀里抱出这尊观音像，说：“供养给您！”这是再次掘出的伏藏，现在仁波切就供在自己的佛坛中。
    还有诸多授记、表记等，但均不予理睬，有的则不解密。又在自己的道场里不可思议地挖出了两股泉，如此等等说之不尽。现在是金龙年，仁波切闭关实修一年，只收一元钱的供养。
    祝愿原始依怙主显出相好圆满之相，在轮回中众生没有度尽之前，双足金刚不坏常住无量劫中，常转密乘大法轮，以长寿金刚童子相而长住世！
    遍满刹土之微尘，利乐皆依三宝恩，
    慈悲聚集应化身，讲述功德是我福。
    功德回向持法者，消除违缘及魔障，
    进入究竟圆满时，愿得具恩上师果！
    依怙主上师松吉泽仁仁波切的略传，是应仁波切的亲弟子、具智慧、持戒清净的迦造喇嘛再三祈求，上师赐恩的行者，土登移喜俄热(释智光)于噶陀金刚宝座密续讲修佛学院教证法库苑喜文殊禅堂内。
    金蛇年一月十五日写定。


阿松堪布简介

    在收集、整理遍知者阿格旺波尊者的自传过程中，辽绒将觉寺的大喇嘛，宁玛巴六大寺院之一，噶陀金刚宝座的客座大堪布，噶陀须弥宝山佛学院的院长一一阿松丹巴堪布仁波切，法号土登·益西俄热(释智光)，给予了极大的鼓励和帮助，在百忙之中抽出时间，亲自撰写了阿格旺波自传的增补《零星传记》及再显化身仁波切的略传《大悲加持钩》，还参与收集阿格旺波二十五本生传略等。堪布仁波切大发慈悲开许把尊者的自传翻译成中文利益更多的有缘者，故在此衷心地感谢他给予了殊胜加持和无限的关怀！我想趁此机会，简要地介绍一下大堪布仁波切的实际功德：七岁即进入将觉寺剃度出家，依止阿格旺波八大栋梁弟子之一蒋杨·罗萨多杰为根本上师，求得了东方伏藏大师秋吉林巴的所有伏藏经典的灌顶传承，并得到了大圆满隆钦心髓前行、正行和结行的所有灌顶、传承和窍诀。即使在最为艰苦的日子里，也从未断过四时瑜伽的修持。有一次，背着为准备闭关而化缘得来的十公斤糌巴上山时，在一个名叫尼朗宫(太阳轨道)的地方休息，糌巴袋放下的刹那豁然开悟！此后，就在寂静的山上，自建的茅蓬中独自闭关实修了二十八年。其修持证量梦醒一如，昼夜任运安住在大圆满的光明境相中。
    虽然没有在正规的佛学院学过多少经论，但只受噶陀的一位老堪布慈诚塔欣开导后就开发大智慧，自然通达一切经论的要点，特别是对于疑难的解答极为殊胜圆满。加上无论何时都以极其清苦谦卑、随和热情的形象，以满足不同根器者的需求。在噶陀寺老堪布江泽俄热处受圆满具足戒，此后护戒如护己目，即使再微细的一条戒律也从未犯过，因此被大众封称为“持戒王”之名号。前后在将觉寺、噶陀佛学院、辽西佛学院等地讲授了《律经》、《中观庄严论》、《俱舍论》、《释量论》、《慈氏五论》等显宗经典，以及《大幻化网》、《八大行法》、《三戒论》、《功德藏》等密乘续论。著有《释律仪》、《中观疑难解答》、《定解宝灯论笔记》、《文殊功德赞注释》、《医方明窍诀》等。为培养佛教栋梁而呕心沥血，数十位品质兼优并能作利他事业的堪布各自宏化一方，目前仍不辞辛劳地来往噶陀、辽西等寺。


译后语

    比马拉米札亲自发愿应化的遍知者无垢光、持明者吉美林巴以及遍知者阿格旺波等等，他们修持佛法所达到的究竟成就和对宁玛巴法脉的伟大贡献，完全可以向世人声明：如果没有尊者的应化，整顿与弘扬大圆满光明心髓，此大法恐怕早已失传！正如雪域贤哲们赞美他“佛教的功德可称第二佛祖。”我认为这句话一点也不夸张！《自传》虽名为传记，但实际上正如尊者亲口所说：“这是一本实修大圆满心要的口诀法宝，”她包含了许多修持大圆满的极密窍诀和证相！在过去，为保持传承的清净与殊胜加持，不能对没有得到大圆满正行的人泄密，即使是已得正行，但还没有得到此传记的口耳传承前，也不允许阅读和修持。这次译成汉文并出版，是尊者的再显化身——依怙主松吉泽仁仁波切的慈悲开许与加持分不开的。
    在《自传》翻译初期，虽发生了一些违缘而停了下来。但由于有噶陀佛学院阿松大堪布的加持和仁波切对《自传》翻译作的许多开示，并派人送一尊文殊佛像来，因此翻译工作又重新进行，再也没有任何违缘，直至圆满。
    译者劝请有缘获此法宝者，万勿生轻慢心，对《自传》中密乘的窍诀和种种证相不可诽谤！“法殊胜故，果报亦不可思议！”这次汉译《自传》，依尊者八大栋梁弟子之一，近百高龄，恰扎·桑杰多吉仁波切的誊稿本为母稿。为了保留《自传》原著风貌，多用直译。但考虑到藏汉语法差异，完全直译恐怕汉地弟子难以理解，也有意译或注译。由于水平所致，错漏难免，译者在上师三宝、诸护法空行母前诚心忏悔。
    在翻译《自传》的过程中，有诸多给予热情支持的各大德、护法，在此表示衷心感谢，并以此功德，回向无量有情同圆种智，依此传记法宝为指南，实修佛法圣道，遣除内心中一切疑暗，获得大圆满正知正见，实证金刚总持果位！

    译者
    佛历2546年6月10日